Exercise 1: QGIS Overview
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2. QGIS Overview Exercise

2.1. Intro to Quantum GIS
Lab Setup: Get the data files

* Wewill use the following datasets for this lab: a) vector towns boundary for MA, b) vector landuse and roads data
for the Town of Amherst, MA, and c) 2 meter resolution orthophoto(s).

* Please download [the dataset
[http://svn.osgeo.org/osgeo/education/Rel eases UM ass/I ntroductionToGisUsingQgisV 0.8/M 1-Exercise-QGI SOverview/Datal]]
to atemporary folder on your computer.

» This data was made available from the Massachusetts GIS repository (MassGIS) and is in United States State
Plane Coordinate System, Lambert Conformal Conic, NAD83, Massachusetts Mainland.

» Unzip datato your working directory. Y ou should see the following files appear:
* Orthophoto
2_117902.aux
2 _117902.tfw
2 117902.tif
e Landuselayer
¢ |us8.dbf
o lusB.prj
* |usB.sbn
* lus8.sbx
* |us8.shp
* |us8.shp.xml
* lus8.shp
¢ Roadslayer
* rd5k8.dbf
 rd5k8.shp

* rd5k8.shx
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QGIS Overview Exercise

e Townslayer

* TOWNS_POLY .dbf

TOWNS POLY .prj

TOWNS_POLY .sbn

TOWNS _POLY .sbx

TOWNS POLY .shp

TOWNS POLY .shx

TOWNS_POLY_AREACODE.dbf

Getting Started: Let's look at the Menus of QGIS
1. Start up QGIS application.

@ oqgis File View Layer Setting ugins Help

Ireﬂa . [qHamumCIS—n.?.i{‘Sﬁmu!'} _ _
IEIEIFTEETEIE] VNN ENE.] N SN -3 () (o) | i .
IS
=
: 3. Standan Menu
System
1. Table of Contents
(Layers)
5. mﬂhﬂgh
ZHW
Exigsy: 02 05 8]
Figure 1: Ref
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QGIS Overview Exercise

There are 5 major areas of QGIS main screen (Figure 1):
1. Table of Contents (layers) on the left

2. Map Overview Area

3. Standard Menu System

4. Zoom and other toolsin the button row

5. Map area at the center (blank right now)

6. Status bar (area at the bottom of the application screen)
The status bar provides information on:

 gspatial extent

+ scale

* current coordinates of cursor (Figure 2).

Spatial Extent Area Scale Cnordilnams Project Projection Settings
|
i —% = i
v L

Figure 2:

Let's consider menu system and toolbars in detail .

Menu
QGIS has a standard menu system:

» File> New Project, Open Project, Save Project, Save Project As ..., Print, Export As Imae, Export As Mapserver
file, Check QGIS Version

* View > Zoom to full extent, Zoom to selected features, Zoom to previous extent, Zoom to layer, Geospatial
bookmarks, New Geospatial bookmark, Refresh

» Layer > Add a Vector Layer, Add a Raster Layer, Add a PostGIS Layer, Remove Layer, New Vector Layer,
Toggle in Overview, Add All To Overview, Remove All From Overview, Show All Layers, Hide All Layers,
Attribute Table, Properties

» Settings > Project Properties, Custom Projections
» Plugins > Plugin Manager

» Help > Contents, QGIS Home Page, QGI S SourceForge Page

Icons

please define productname in your
docbook file! Exercise 1. QGIS Overview 4



QGIS Overview Exercise

Look at the Icon Menus/Toolbars. The major toolbars buttons are described below (Figures N-N)

\jEL':TIL.'I _'J

Frmt
Eave Project As..
Save Project
1 Open Project
Start a new QGIS Project
Figure 3:

g B 2s |t |

L |_ Add/iRemove All Layers

from Overview Map

Show/Hide All Layers
Add a Raster Layer
—Add a Vector Layer
—Add a PostGIS Layer
Figure 4
[SNENE N EAR I =T P2
I
Refresh Measure
Zoom to Select features
. last extent |dentify a featurs
an
Zoom to selected feature Capture Points/
Zoom to full extent Lines/Polygons Tool
Zoom to layer
Zoom Out
Zoom In
Figure 5:
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J_ka? U “i-:u :‘J

F

Geospatial Bookmarks
What is this?
Open attribute table for selected layer

igure 6:

Using QGIS

Recall that QGIS is atool for viewing, querying, editing, composing and publishing electronic maps. It combines
functionality for electronic mapping and spatial analysis. For those of you who have seen or used the ArcView 3.x

p

1

2.

7

roduct, it's quite similar.
. Start QGIS (if you don't have QGI S open)
The main window will be blank, thisis an empty default project.

. To set project properties click "[Settings > Project Properties]” in the main menu. The "Project Properties’
window will appear.

. Click on the "[General]" tab and set Project Title and Map Units. Call this project Class Demo:QGI S and set the
Map Unitsto Meters.

. To set the projection of the project, click on the projection tab and find Projected Coordinate System, Lambert
Conformal Conic, and NAD83 Massachusetts Mainland.

. Click "[OKk]" button to make changes. (Figure 6)

Progect Propees
Jm I Prajction
Pramer Title

Class Doy 005

Bap Unili

oy Mgy ) Fawt Cher i mal cegrees

Figure 7: Settings project properties

. First we will add a vector file.

8. Click on"[Add a Vector Layer]" button or select "Layer > Add a Vector Layer" in the main menu

9. A dialog window will appear. Please select alanduse layer (lus8.shp) from your working directory.(Figure 7).
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T ey T T |
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Figure 8: Add avector layer
10.Now let's display the raster file.
11.Click on"[Add a Raster Layer]" button or select "L ayer > Add a Raster Layer" in the main menu.
12.Select orthophoto file 2_117902.tif from your working directory and click [Open]

13.Y ou have two overlaying layers now in QGIS (Figure 8):

¢ [Hen-Commaprcial] - (st GE - 0, 74 [Sewmn’)
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QGIS Overview Exercise

Figure 9

14.If you don't have the raster image in your view, then select any layer in the Table of Contents (TOC) and click
the "Zoom to layer" menu button. The view should refresh itself and you will be able to see two data layers
(Figure 9).

Ly

C R
[
M Luss r
Yector Layer

Zoom to extent of selected laver

Togighe In Cverview
Biefidye

Open sttribube tabls
Start edting

Stop editing
Properties

Figure 10: Refresh screen

15.Click on theraster file (2_117902.tif) and drag it downso that it is listed in the table of contents BELOW the land
use vector layer. Y ou should see the raster image covered with the land use layer (Figure 10).

16.If theland use layer does not cover the raster image select "View > Refresh”
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</ [Hon-Commercial] - Ouantun GI5 - 0.7.4 ["Seamus’)
Els View Laver Zsttings Plugins Help

1 EHEEB S @PPLE-L-0O0ANT
| Layess '
e [

Figure 11: Changing order of layersin TOC

17 .Note the coordinates from the map projection being used at the bottom, right hand corner and how they change as
you move the cursor around the map. Notice that the units of this coordinate system is meters.

18.To specify/change display units click Setting > Project Properties and click on [General] tab in the window
(Figure 10).

i [Hon-Comenercial] - Project Propertios

- Change map units

Eigpezt Ttk here
DEMO FOR NRC2T: (LASS

Figure 12: Settings maps units

It'sagood habit to specify these settings when you start working on the project.
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Now let's consider some map toals:

Map Tools

The map tools provide functions that help you navigate around the map.

[o§[oR1s Jlogisyr Me )G

I
| Refresh
Zoom to
last extent
Fan
Zoom to selected featurs
Zoom to full extent
Zoom to layer
Zoom Out
Zoom In

Figure 13

Specific tools:

* Zoom in and out (the magnifying tool + and -). This tool requires you to left-click and draw a rectangle around
the area that you want to zoom in on. Zoom in and notice how the map scale (at status bar) changes. GIS is
"scale-less’ which is why it is important as to what scales input maps were at so you don't try to use the GIS at

inappropriate scales!

» Zoom to layer. Select any layer in TOC and try this tool. Please, notice that map extent is set up to the selected

layer.

» Zoom to full extent. Thistool zooms in such way that all data are viewable in the map area.

Adding New Layers

» We have added one vector layer (land use) and the raster layer (orthophoto image).

» Usethe"Add Vector data' button to add road data layer (Rd5k8.shp) for the Town of Amherst.

@ ==

Add a Raster Layer
d a Vector Layer
Add a PostGIS Layer

Figure 14: Add Layers Tools
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Change TOC information

Let's change the Table of Contents references:

* Right click on landuse layer entry: "'lus8pl.shp

Layers

E - Lus=Bp1

Vector Layer

Toggle In Overview

Remove
Open attribute table

Start editing
Stop editing

Zoom to extent of selected layer

Figure 15
» Choose Propertiesfrom the menu
» Layer Propertieswindow will appear

» Click on the General tab

Layer Properties

- .1

[ Symbology | General | Metadata | Labels | Actions |

Layer source | fUsers /stepanov/Desktop/tmpFossCIS/data/lus8pl.shp

Display nam@

Figure 16
» Changethe Layer nameto Land Use
» Click "ok". The TOC entry should be changed.

 Change the color of this polygon layer to light green.

Display field tile_name B:
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« Double-click on the rectengul (or Right click on the layer and select Properties)

¢ Click on [Symbology] tab

.Laver Probeﬁ_ie-s- -

—
—
‘,-Svmhology—l G&neral lMetadata lLabeIs lActions i
L i

Legend type: [ Single Symbol |—34
Label:
-Point
Symbol O = Size |6
-Outline Style:

g -

T ——
Outline color: - El
QOutline Width: 1 Z
Fill Colar: I:l EI
-Fill Patterns: ——

LIS

Gz

S5 [T

Help

Figure 17

l: Apply ) m l: Cancel )

Change the fill and outline colors of the polygon features.

Click [ok] and notice that color of land use layer was changed.

Whatever layer is at the top of the TOC will be displayed on top

Move the raster image to the top of the table of contents

¢ Click and hold on the 2_117902.tif image

» Drag this up to the top of the TOC

* You should see that some line and polygon features disappear because the raster grid is overlaying on the

vector layer
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View Attribute Data

Tolook at the associated attribute database for the landuse features:
» Select Land Use Layer in TOC (put the layer on the top)

 Click on "Open Attribute Table" tool button.

» Scroll to the rght to view various records of data

 Polygons represent different land use types. Fields [LU37_Code] and [LU21 Code] store codes of different land
use types.

CODE ABBREV CATEGORY DEFINITION

1 AC Cropland Intensive agriculture

2 AP Pasture Extensive agriculture

3 F Forest Forest

4 FW Wetland MNonforested freshwater wetland

5 M Mining Sand; gravel & rock

6 0 Open Land Abandoned agriculture; power lines; areas of no vegetation
7 RP Participation Recreation  Golf; tennis; Playgrounds; skiing

8 RS Spectator Recreation Stadiums; racetracks; Fairgrounds; drive-ins

9 RW Water Based Recreation Beaches; marinas; Swimming pools

10 RO Residential Multi-family

11 R1 Residential Smaller than 1/4 acre lots

12 RZ Residential 1/4 - 1/2 acre lots

13 R3 Residential Larger than 1/2 acre lots

14 Sw Salt Wetland Salt marsh

15 uc Commercial General urban; shopping center

16 U1 Industrial Light & heavy industry

17 uo Urban Open Parks; cemeteries; public & institutional greenspace; also vacant undeveloped land
18 uT Transpartation Airports; docks; divided highway; freight; storage; railroads
19 uw Waste Disposal Landfills; sewage lagoons

20 W Water Fresh water; coastal embayment

21 WP Woody Perennial Orchard; nursery; cranberry bog

22 - Mo Change Code used by MassGIS only during quality checking

Figure 18. Land use types coding scheme
* Scroll down and select any record (Figure 15).

806 J Attribute table - Land Use

:] . . Click to select record I Land use type
_.-“'/L
[id

_’4.3( |perimeter |Iu5_ Ilus_id |ti|e_name
2 2

655568.352 1428521
15868.664 570.973 3 3 a
7264588.500 67545031 4 4 a8

[1u_id

Figure 19

» To seethe selected parcel(s) on the map, switch to the map view and click on the [Refresh] button

© - =

Figure 20

please define productname in your
docbook file! Exercise 1. QGIS Overview 13
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» The selected parcels are shown in yellow color.

» Another way to see attribute information for a specific spatial feature (polygon, in our case), use [Info] tool
(Figure 17).

EEEIAET

ientify a feature on the active layer

Figure 21: Info tool
* Click on Info tool and then click on afeature (in the active layer) you are interested in.

» A window containing information for this feature will apear. Scroll down and note that it has the same fields as
the attribute table.

Measuring distances

L et's measure the distance between objects on the map. We will use M easure Tool for this operaton.

 Click onthe Measuretool (it's a button with picture of ruler on it).

4

Measure

[ ]

Figure 22: Measure tool

» Navigate a cursor over afeature and left click with a mouse to set a starting point. Select another point and click
again. A window showing segments length will appear
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I Measure
Ing rermEnt | Total
304198 md-l.%f
3000.66 6042.64)
1169.36 9212
4210.97 13423
Help M Ew Close

Figure 23: Measure tool output
* Theresults will be in the map units you are working in. In this case, meters.

+ Continue to measure or right-click to stop.

Finishing the work
Saving amap as an image:
» Click File> Export Aslmage

» A dialog window will apper. You will need to specify file name and location, as well as to select image
format.JPEG and PNG are wide supported formats. So we would advise to save your map as jpeg or png files.
Then you can insert them into text document or presentation.

» To save the project, click [File > Save Project (As)]. The next time you can open the project in QGIS and QGIS
will restore your work status on the moment of saving. Note: Be sureto check wherethefile will be saved.

2.2. External Links

» Wikipedia articles on Image Formats: http://en.wikipedia.org/wiki/Image_formats

GDAL (Geospatial Data Abstraction Library): http://www.gdal .org/

FW tools: http://fwtools.maptools.org/

MassGIS: http://www.mass.gov/mgis/= [http://www.mass.gov/mgis/]
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