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Intro to Quantum GIS
Lab Setup

1. Get the data files

We will use the following datasets for this lab: a) vector towns boundary for MA, b) vector land
use and roads data for the Town of Amherst, MA, and c) 2 meter resolution orthophoto(s).
Please download [the dataset] to a temporary folder on your computer.
This data was made available from the Massachusetts GIS repository (MassGIS) and is in
United States State Plane Coordinate System, Lambert Conformal Conic, NADS3,
Massachusetts Mainland.
Unzip data to your working directory. You should see the following files appear:
Orthophoto
2 117902.aux
2 117902.tfw
2 117902.tif
Landuse layer
lus8.dbf


http://creativecommons.org/licenses/by-nd/3.0/
http://linuxlab.sbs.umass.edu/beginning-fossgis-umass/datasets/lab_intro/IntroQGISClassDemo.zip
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lus8.prj
lus8.sbn
lus8.sbx
lus8.shp
lus8.shp.xml
+ lus8.shp

Roads layer
rd5k8.dbf
rd5k8.shp
rd5k8.shx

Towns layer
TOWNS_POLY.dbf
TOWNS_ POLY.prj
TOWNS POLY.sbn
TOWNS POLY.sbx
TOWNS_POLY.shp
TOWNS POLY.shx

TOWNS_POLY_ AREACODE.dbf

Getting Started: Let's look at the Menus of QGIS

1. Start up QGIS application.
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There are 6 major areas of QGIS main screen (Figure 1):

1. Table of Contents (layers) on the left

Map Overview Area

Standard Menu System

Zoom and other tools in the button row

Map area at the center (blank right now)

6. Status bar (area at the bottom of the application screen)

il

The status bar provides information on:

spatial extent
scale
current coordinates of cursor (Figure 2).
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Figure 2:

Let's consider menu system and toolbars in detail.
Menu
QGIS has a standard menu system:

File > New Project, Open Project, Save Project, Save Project As, Save As Image, Print, Exit
View > Zoom to full extent, Zoom to selected features, Zoom to layer, Zoom to previous extent,
Refresh, Show Geospatial bookmarks, New Geospatial bookmark, Show Toolbars, Hide
Toolbars, Available Toolbars, Legend on/off, Overview on/off

Layer > Add a Vector Layer, Add a Raster Layer, Add a PostGIS Layer, Add WMS Layer,
Remove Layer, New Vector Layer, Toggle in Overview, Add All To Overview, Remove All
From Overview, Hide All Layers, Show All Layers

Settings > Project Properties, Custom Projections, Options

Plugins > Plugin Manager, Python Console

Help > Help Contents, QGIS Home Page, Check QGIS Version, About

Icons

Look at the Icon Menus/Toolbars. The major toolbars buttons are described below (Figures 3-6)
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Figure 6:

Using QGIS

Recall that QGIS is a tool for viewing, querying, editing, composing and publishing electronic maps. It
combines functionality for electronic mapping and spatial analysis. For those of you who have seen or
used the ArcView 3.x product, it's quite similar.

1.
2.
3.

Start QGIS (if you don't have QGIS open)

The main window will be blank, this is an empty default project.

To set project properties click "[Settings > Project Properties]" in the main menu. The "Project
Properties" window will appear.

Click on the "[General]" tab and set Project Title and Map Units. Call this project Class
Demo:QGIS and set the Map Units to Meters.

To set the projection of the project, click on the projection tab and find Projected Coordinate
System, Lambert Conformal Conic, and NADS83 Massachusetts Mainland.

Click "[OK]" button to make changes. (Figure 7-9)
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Figure 8: Setting Projected Coordinate System


file:///intro-fossgis-umass/index.php%3Ftitle=Image:IntroLabSetProjectProperties.gif
file:///intro-fossgis-umass/index.php%3Ftitle=Image:IntroLabSetProjectProperties-ProjectedCoordinateSystem.gif

QGIS Overview

‘-JKProject Properties
General Projection

Enable on the fly projection

Projection

Spatial Reference System Id

D

Geographic Coordinate Systems

[l Projected Coordinate Systems

Albers Equal Area

Cassin

Equidistant Cylindrical (Plate Careg)

krovak

Lambert Azimuthal Equal Area

Lambert Conformal Conic
AGD66 / Vicgridee 1073
ATF (Paris) / Nord de Guerre 2313
Ain el Abd / Aramco Lambert 287
American Samoa 1962 / American Samoa Lambert 1065
American Samoa 1962 / American Samoa Lambert (deprecated) 146
American Samoa 1962 / American Samoa Lambert (deprecated) 178

o-&-6-5-m-58

Belge 1950 (Brussels) / Belge Lambert 50 1868

Belge 1972 / Belge Lambert 72 2532

Belge 1972 / Belgian Lambert 72 2533

Carthage / Nord Tunisie 1910

Carthage / Sud Tunisie 1911 E
| | 1D

QGIS SRSID: 3293
PostGIS SRID: 4269
+proj=longlat +ellps=GRS80 +datum=NADS3 +no_defs

Search
& Postgis SRID EPSG ID QGIS 5RSID Name:

Find

oK Apply Cancel

Figure 9: Setting Coordinate System

9. First we will add a vector file.

10.Click on "[Add a Vector Layer]" button or select "Layer > Add a Vector Layer" in the main
menu

11.A dialog window will appear. Please select a landuse layer (lus8.shp) from your working
directory.(Figure 10).

igure 10: Add a vector layer

12.Now let's display the raster file.

13.Click on "[Add a Raster Layer]" button or select "Layer > Add a Raster Layer" in the main
menu.

14.Select orthophoto file 2_117902.tif from your working directory and click [Open]

15.You have two overlaying layers now in QGIS (Figure 11):
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Figure 11

16.If you don't have the raster image in your view, then select any layer in the Table of Contents
(TOC) and click the "Zoom to layer extent" menu button. The view should refresh itself and you
will be able to see two data layers (Figure 12).

o % @ 2 117902

® | Zoom to layer extent
Show in overview
%| Remove
Open attribute table
# Toggle editing

Save as shapefile...

Properties

Rename

Add group
[0 Expand all

[ Collapse all
Show file groups

Figure 12: Refresh screen
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17.Click on the raster file (2_117902.tif) and drag it down so that it is listed in the table of contents
BELOW the land use vector layer. You should see the raster image covered with the land use
layer (Figure 13).

18.1f the land use layer does not cover the raster image select "View > Refresh"

_ [Hon-Commercial] - Ouantum GI5- 0.7.4 [Seamus’)

Bl Yew Layer Settngs Phigns Heb

B S @EPE-- O O

Figure 13: Changing order of layers in TOC

19.Note the coordinates from the map projection being used at the bottom, right hand corner and
how they change as you move the cursor around the map. Notice that the units of this coordinate
system is meters.

20.To specify/change display units click Setting > Project Properties and click on [General] tab

in the window (Figure 14).
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Figure 14: Settings maps units

It's a good habit to specify these settings when you start working on the project.

Now let's consider some map tools:

Map Tools

The map tools provide functions that help you navigate around the map.
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Figure 15
Specific tools:

Zoom in and out (the magnifying tool + and -). This tool requires you to left-click and draw a
rectangle around the area that you want to zoom in on. Zoom in and notice how the map scale
(at status bar) changes. GIS is "scale-less" which is why it is important as to what scales input
maps were at so you don't try to use the GIS at inappropriate scales!

Zoom to layer. Select any layer in TOC and try this tool. Please, notice that map extent is set up
to the selected layer.

Zoom to full extent. This tool zooms in such way that all data are viewable in the map area.

Adding New Layers

We have added one vector layer (land use) and the raster layer (orthophoto image).
Use the "Add Vector data" button to add road data layer (RdSk8.shp) for the Town of Ambherst.
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Figure 16: Add Layers Tools

Change TOC information
Let's change the Table of Contents references:
Right click on landuse layer entry: "'lus8.shp

Legend
O % & 2 117902

@ | Zoom to layer extent
Show in overview
#%| Remove
Open attribute table
# Toggle editing

Save as shapefile...

Fename
Add group

[ Expand all
[ Collapse all

Show file groups

Figure 17
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« Choose Properties from the menu
- Layer Properties window will appear
+ Click on the General tab

Q Layer Properties

Symbology General Metadata Labels Actions
Options
Digplay name |Land Use]
Display field TILE_MAME -
Figure 18

+ Change the Layer name to Land Use

+ Click "ok". The TOC entry should be changed.

+ Change the color of this polygon layer to light green.
+ Double-click on the rectangle (or Right click on the layer and select Properties)
+ Click on [Symbology] tab

Q Layer Properties

Symbology | General = Metadata = Labels | Actions

Legend type Single Symbol + | Transparency: 0% O:
Label
Style Options
Outline style — Solid Line -
Outline width 0.40 =
Fill color [ l

Fill style = Solid = E]

Restare Default Style Save As Default Load Style ... Save Style ...
Help Apply Cancel
Figure 19

+ Change the fill and outline colors of the polygon features.
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Click [ok] and notice that color of land use layer was changed.
Whatever layer is at the top of the TOC will be displayed on top
Move the raster image to the top of the table of contents

View Attribute Data

To look at the associated attribute database for the landuse features:

Click and hold on the 2_117902.tif image

Drag this up to the top of the TOC

You should see that some line and polygon features disappear because the raster grid is
overlaying on the vector layer

Select Land Use Layer in TOC (put the layer on the top)

Click on "Open Attribute Table" tool button.

Scroll to the right to view various records of data

Polygons represent different land use types. Fields [LU37 Code] and [LU21_Code] store

codes of different land use types.
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Cropland

Pasture

Forest

Wetland

Mining

Open Land
Participation Recreation
Spectator Recreation
Water Based Recreation
Residential
Residential
Residential
Residential

Salt Wetland
Commercial
Industrial

Urban Open
Transportation
Waste Disposal
Water

Woody Perennial

Mo Change

DEFINITION

Intensive agriculture

Extensive agriculture

Forest

Monforested freshwater wetland

Sand; gravel B rock

Abandoned agriculture; power lines; areas of no vegetation
Golf; tennis; Playgrounds; skiing

Stadiums; racetracks; Fairgrounds; drive-ins

Beaches; marinas; Swimming poals

Multi-family

Smaller than 1/4 acre lots

1/4 - 1/2 acre lots

Larger than 1/2 acre lots

Salt marsh

General urban; shopping center

Light & heavy industry

Parks; cemeteries; public & institutional greenspace; also vacant undeveloped land
Airports; docks; divided highway; freight; storage; railroads
Landfills; sewage lagoons

Fresh water; coastal embayment

Orchard; nursery; cranberry bog

Code used by MassGIS anly during quality checking

Figure 20. Land use types coding scheme

Scroll down and select any record (Figure 21).
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Q Attribute table - Land Use

. Click to select record Land use type statedinad [
id |TILE_nAME OBJECTID | LU21_1971|LU21_1985|LU37_1985|LU21_1999|LU37_1999 | RELATEID | AREA_ACRES| SHAPE_AREA | swAPE_Len | 2]
| b— 0 8 22| 599717 13 13 13 13| 13/ 800022 2.0861 84421597 374 164990548
2 8 99 0 8000 62894 846 54 98
lls==t" - 8 26| 599721 4 4 4 4 4| 800026 2.58161| 10447.39735 392150343889
4 3 8 69| 599764 | 1 1 1 1 1| 800069 2.39347 9686.0344 446 540053949
5 4 8 2| 599697 2 2 2 2 2| 800002 16.1999 65558 65155 1428 91220496
6 5 8 52 59974?. 3 3_ 3_ 13_ 13_ 800052 1.35293 54751029 296.222823902
7 6 8 65 599?607 137 13 13 13 13 8000657 3.69173 14939.91695 565.705749709
Figure 21
 To see the selected parcel(s) on the map, switch to the map view and click on the [Refresh]
button
@ m—
=
Figure 22

+ The selected parcels are shown in yellow color.
« Another way to see attribute information for a specific spatial feature (polygon, in our case), use
Info] tool (Figure 23).

L EE 2R

Identify a feature on the active layer

Figure 23: Info tool
+ Click on Info tool and then click on a feature (in the active layer) you are interested in.
« A window containing information for this feature will apear. Scroll down and note that it
has the same fields as the attribute table.

Measuring distances

Let's measure the distance between objects on the map. We will use Measure Line Tool for this
operaton.

+ Click on the Measure tool (it's a button with picture of ruler on it).

—~ ™ - |

REFFEEY

Ly '.'\’\ == . h h
Measure Line

Figure 24: Measure line tool
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Navigate a cursor over a feature and left click with a mouse to set a starting point. Select

another point and click again. A window showing segments' length will appear

-

|Segments (in meters)

4,514.27

1,037.77
456.29
5,023.82

Total: 14.90 km

Figure 25: Measure tool output

The results will be in the map units you are working in. In this case, meters.
Continue to measure or right-click to stop.

Finishing the work
Saving a map as an image:

Click File > Export As Image

A dialog window will apper. You will need to specify file name and location, as well as to select
image format.JPEG and PNG are wide supported formats. So we would advise to save your
map as jpeg or png files. Then you can insert them into text document or presentation.

To save the project, click [File > Save Project (As)]. The next time you can open the project in
QGIS and QGIS will restore your work status on the moment of saving. Note: Be sure to check
where the file will be saved.

External Links

Wikipedia articles on Image Formats: http://en.wikipedia.org/wiki/Image formats
GDAL (Geospatial Data Abstraction Library): http://www.gdal.org
FW tools: http://fwtools.maptools.org/

MassGIS: http://www.mass.gov/mgis/
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