OSGeo.MapGuide.MaestroAPI

OSGeo Maestro
OSGeo.MapGuide.MaestroAPI Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | AllowedValueType |
Public class | AllowedValueTypeCollection |
Public class | ApplicationDefinitionContainerInfoSet |
Public class | ApplicationDefinitionContainerInfoType |
Public class | ApplicationDefinitionContainerInfoTypeCollection |
Public class | ApplicationDefinitionPanelType |
Public class | ApplicationDefinitionPanelTypeCollection |
Public class | ApplicationDefinitionTemplateInfoSet |
Public class | ApplicationDefinitionTemplateInfoType |
Public class | ApplicationDefinitionTemplateInfoTypeCollection |
Public class | ApplicationDefinitionWidgetInfoSet |
Public class | ApplicationDefinitionWidgetInfoType |
Public class | ApplicationDefinitionWidgetInfoTypeCollection |
Public class | ApplicationDefinitionWidgetParameterType |
Public class | ApplicationDefinitionWidgetParameterTypeCollection |
Public class | AreaRuleType |
Public class | AreaRuleTypeCollection |
Public class | AreaSymbolizationFillType |
Public class | AreaSymbolizationType |
Public class | AreaTypeStyleType |
Public class | AreaUsage |
Public class | AttributeRelateType |
Public class | AttributeRelateTypeCollection |
Public class | BaseLayerDefinitionType |
Public class | BaseMapLayerGroupCommonType |
Public class | BaseMapLayerGroupCommonTypeCollection |
Public class | BaseMapLayerType |
Public class | BaseMapLayerTypeCollection |
Public class | BasicCommandType |
Public class | BlockSymbolType |
Public class | Box2DType |
Public class | BufferCommandType |
Public class | CalculatedPropertyType |
Public class | CalculatedPropertyTypeCollection |
Public class | Change |
Public class | ChangeList |
Public class | ChannelBandType |
Public class | CommandItemType |
Public class | CommandType |
Public class | CommandTypeCollection |
Public class | CompositeRule |
Public class | CompositeRuleCollection |
Public class | CompositeSymbolization |
Public class | CompositeTypeStyle |
Public class | CompoundSymbolDefinition |
Public class | ContextMenuType |
Public class | CoordinateSystem | Interface to MapGuide coordinate system functions. Only works with server > 1.2, since the coordinate mapping is not avalible through Http on older versions
NestedPublic class | CoordinateSystem.Category |
NestedPublic class | CoordinateSystem.CoordSys |
Public class | CustomCommandType |
Public class | DataStoreItem | Represents a single datastore item
Public class | DataStoreItemCollection | Represents a list of datastore items
Public class | DataStoreList | Represents a list of data in a featuresource
Public class | DoubleCollection |
Public class | DrawingLayerDefinitionType |
Public class | DrawingSection | Represents a single drawing section
Public class | DrawingSectionCollection | Represents a list of drawing sections
Public class | DrawingSectionList | Represents a Drawing Section
Public class | DrawingSectionResource | Represents a single DrawingSectionResource
Public class | DrawingSectionResourceCollection | Represents a list of DrawingSectionResources
Public class | DrawingSectionResourceList | Represents a DrawingSectionResourceList
Public class | DrawingSource |
Public class | DrawingSourceSheet |
Public class | DrawingSourceSheetCollection |
Public class | DrawingSourceSheetExtent |
Public class | DwfLoadProcedureType |
Public class | DwgComponentType |
Public class | DwgComponentTypeCollection |
Public class | DwgDriveAliasType |
Public class | DwgDriveAliasTypeCollection |
Public class | DwgLoadProcedureType |
Public class | ElevationSettingsType |
Public class | Envelope |
Public class | EnvelopeLowerLeftCoordinate |
Public class | EnvelopeUpperRightCoordinate |
Public class | ExtendedDataType |
Public class | FdoLongTransactionList |
Public class | FdoLongTransactionListLongTransaction |
Public class | FdoLongTransactionListLongTransactionCollection |
Public class | FdoProviderCapabilities |
Public class | FdoProviderCapabilitiesCommand |
Public class | FdoProviderCapabilitiesCommandNameCollection |
Public class | FdoProviderCapabilitiesConnection |
Public class | FdoProviderCapabilitiesConnectionTypeCollection |
Public class | FdoProviderCapabilitiesExpression |
Public class | FdoProviderCapabilitiesExpressionFunctionDefinition |
Public class | FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition |
Public class | FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection |
Public class | FdoProviderCapabilitiesExpressionFunctionDefinitionCollection |
Public class | FdoProviderCapabilitiesExpressionNameCollection |
Public class | FdoProviderCapabilitiesFilter |
Public class | FdoProviderCapabilitiesFilterOperation1Collection |
Public class | FdoProviderCapabilitiesFilterOperationCollection |
Public class | FdoProviderCapabilitiesFilterTypeCollection |
Public class | FdoProviderCapabilitiesGeometry |
Public class | FdoProviderCapabilitiesGeometryType1Collection |
Public class | FdoProviderCapabilitiesGeometryTypeCollection |
Public class | FdoProviderCapabilitiesProvider |
Public class | FdoProviderCapabilitiesRaster |
Public class | FdoProviderCapabilitiesSchema |
Public class | FdoProviderCapabilitiesSchemaType1Collection |
Public class | FdoProviderCapabilitiesSchemaTypeCollection |
Public class | FdoProviderCapabilitiesTopology |
Public class | FdoSpatialContextList |
Public class | FdoSpatialContextListSpatialContext |
Public class | FdoSpatialContextListSpatialContextCollection |
Public class | FdoSpatialContextListSpatialContextExtent |
Public class | FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate |
Public class | FdoSpatialContextListSpatialContextExtentUpperRightCoordinate |
Public class | FeatureProviderRegistry |
Public class | FeatureProviderRegistryFeatureProvider |
Public class | FeatureProviderRegistryFeatureProviderCollection |
Public class | FeatureProviderRegistryFeatureProviderConnectionProperty |
Public class | FeatureProviderRegistryFeatureProviderConnectionPropertyCollection |
Public class | FeatureSet | Represents a set of features
Public class | FeatureSetColumn |
Public class | FeatureSetLayer |
Public class | FeatureSetLayerClass |
Public class | FeatureSetLayerClassCollection |
Public class | FeatureSetLayerCollection |
Public class | FeatureSetReader | Represents a set of results from a query
Public class | FeatureSetRow |
Public class | FeatureSource |
Public class | FeatureSourceDescription | Class that represents a the layout of a datasource
NestedPublic class | FeatureSourceDescription.FeatureSourceSchema |
Public class | FeatureSourceTypeExtension |
Public class | FeatureSourceTypeExtensionCollection |
Public class | FileBufferedStreamReader | Represents a buffered reader that relays stream data, using a file buffer, thus exhausting the source fast.
Public class | FillType |
Public class | FlyoutItemType |
Public class | FontSymbolType |
Public class | GeoReferenceOverrideType |
Public class | GeoReferenceOverrideTypeCollection |
Public class | GetPrintablePageCommandType |
Public class | GraphicBase |
Public class | GraphicBaseCollection |
Public class | GridColorBandsType |
Public class | GridColorRuleType |
Public class | GridColorRuleTypeCollection |
Public class | GridColorStyleType |
Public class | GridColorType |
Public class | GridLayerDefinitionType |
Public class | GridScaleRangeType |
Public class | GridScaleRangeTypeCollection |
Public class | GridSurfaceStyleType |
Public class | Group |
Public class | GroupList |
Public class | GroupListGroup |
Public class | GroupListGroupCollection |
Public class | GroupUsers |
Public class | GroupUsersUser |
Public class | GroupUsersUserCollection |
Public class | HelpCommandType |
Public class | HillShadeType |
Public class | HttpServerConnection | Primary http based connection to the MapGuide Server
Public class | Image |
Public class | ImageReference |
Public class | ImageSymbolType |
Public class | ImageSymbolTypeImage |
Public class | InformationPaneType |
Public class | InvokeScriptCommandType |
Public class | InvokeURLCommandType |
Public class | LayerDefinition |
Public class | LayerDefinitionType |
Public class | LengthyOperationCallbackArgs |
NestedPublic class | LengthyOperationCallbackArgs.LengthyOperationItem |
Public class | LengthyOperationProgressArgs |
Public class | LineRuleType |
Public class | LineRuleTypeCollection |
Public class | LineTypeStyleType |
Public class | LineUsage |
Public class | LoadProcedure |
Public class | LoadProcedureType |
Public class | LoadProcedureTypeType |
Public class | LocalNativeConnection | A connection to the server, using the Native API. Only works locally, or with special firewall rules for the server.
Public class | MapDefinition | Defines a Map, in either the library or session repository
Public class | MapDefinitionTypeBaseMapDefinition |
Public class | MapLayerGroupCommonType |
Public class | MapLayerGroupType |
Public class | MapLayerGroupTypeCollection |
Public class | MapLayerType |
Public class | MapLayerTypeCollection |
Public class | MapType |
Public class | MapViewType |
Public class | MarkSymbolType |
Public class | MeasureCommandType |
Public class | NameStringPairType |
Public class | NameStringPairTypeCollection |
Public class | NameValuePairType |
Public class | NameValuePairTypeCollection |
Public class | Override |
Public class | OverrideCollection |
Public class | Parameter |
Public class | ParameterCollection |
Public class | ParameterDefinition |
Public class | ParameterOverrides |
Public class | ParameterPairType |
Public class | ParameterPairTypeCollection |
Public class | Path |
Public class | PointRuleType |
Public class | PointRuleTypeCollection |
Public class | PointSymbolization2DType |
Public class | PointTypeStyleType |
Public class | PointUsage |
Public class | PrintCommandType |
Public class | PrintLayout |
Public class | PrintLayoutLayoutProperties |
Public class | PrintLayoutLogo |
Public class | PrintLayoutLogoCollection |
Public class | PrintLayoutLogoPosition |
Public class | PrintLayoutLogoSize |
Public class | PrintLayoutPageProperties |
Public class | PrintLayoutPagePropertiesBackgroundColor |
Public class | PrintLayoutText |
Public class | PrintLayoutTextCollection |
Public class | PrintLayoutTextFont |
Public class | PrintLayoutTextPosition |
Public class | PropertiesType |
Public class | PropertyCollectionType |
Public class | PropertyDefinitionsType |
Public class | PropertyDefinitionType |
Public class | PropertyDefinitionTypeCollection |
Public class | PropertySetType |
Public class | PropertySetTypeProperties |
Public class | PropertySetTypePropertiesPropertyCollection |
Public class | PropertySetTypePropertiesPropertyCollectionCollection |
Public class | PropertySetTypePropertyDefinitions |
Public class | PropertyType |
Public class | PropertyTypeCollection |
Public class | RasterLoadProcedureType |
Public class | RelatePropertyType |
Public class | RelatePropertyTypeCollection |
Public class | RepositoryContentType |
Public class | ResizeBox |
Public class | ResourceDataList |
Public class | ResourceDataListResourceData |
Public class | ResourceDataListResourceDataCollection |
Public class | ResourceDocumentHeaderType |
Public class | ResourceDocumentHeaderTypeGeneral |
Public class | ResourceDocumentHeaderTypeMetadata |
Public class | ResourceDocumentHeaderTypeMetadataSimple |
Public class | ResourceDocumentHeaderTypeMetadataSimpleProperty |
Public class | ResourceDocumentHeaderTypeMetadataSimplePropertyCollection |
Public class | ResourceFolderHeaderType |
Public class | ResourceIdentifier | This class contains all the required code for maintaining resource identifiers. It has implicit conversions to and from a string, which makes it much easier to use. It has both static methods that operate on strings, as well as a class that can be manipulated.
Public class | ResourceList |
Public class | ResourceListResourceDocument |
Public class | ResourceListResourceFolder |
Public class | ResourcePackageManifest |
Public class | ResourcePackageManifestOperations |
Public class | ResourcePackageManifestOperationsOperation |
Public class | ResourcePackageManifestOperationsOperationCollection |
Public class | ResourcePackageManifestOperationsOperationParameters |
Public class | ResourcePackageManifestOperationsOperationParametersParameter |
Public class | ResourcePackageManifestOperationsOperationParametersParameterCollection |
Public class | ResourceReferenceList |
Public class | ResourceReferenceType |
Public class | ResourceReferenceTypeCollection |
Public class | ResourceSecurityType |
Public class | ResourceSecurityTypeGroups |
Public class | ResourceSecurityTypeGroupsGroup |
Public class | ResourceSecurityTypeGroupsGroupCollection |
Public class | ResourceSecurityTypeUsers |
Public class | ResourceSecurityTypeUsersUser |
Public class | ResourceSecurityTypeUsersUserCollection |
Public class | ResultColumnType |
Public class | ResultColumnTypeCollection |
Public class | Role |
Public class | RoleGroups |
Public class | RoleGroupsGroup |
Public class | RoleGroupsGroupCollection |
Public class | RoleUsers |
Public class | RoleUsersUser |
Public class | RoleUsersUserCollection |
Public class | RowCollectionType |
Public class | RowCollectionTypeColumnDefinitionsColumn |
Public class | RowCollectionTypeColumnDefinitionsColumnCollection |
Public class | RowCollectionTypeRow |
Public class | RowCollectionTypeRowCollection |
Public class | RowCollectionTypeRowColumn |
Public class | RowCollectionTypeRowColumnCollection |
Public class | RowCollectionTypeRowColumnName |
Public class | RowType |
Public class | SdfLoadProcedureType |
Public class | SearchCommandType |
Public class | SelectWithinCommandType |
Public class | SeparatorItemType |
Public class | ServerConnectionBase |
Public class | ServerType |
Public class | ShpLoadProcedureType |
Public class | SimpleSymbol |
Public class | SimpleSymbolCollection |
Public class | SimpleSymbolDefinition |
Public class | SimpleSymbolDefinition1 |
Public class | SiteInformation |
Public class | SiteInformationSiteServer |
Public class | SiteInformationSiteServerOperatingSystem |
Public class | SiteInformationStatistics |
Public class | SiteVersion |
Public class | SiteVersions |
Public class | SpatialContextType |
Public class | SpatialContextTypeCollection |
Public class | StatusBarType |
Public class | StrokeType |
Public class | StrokeTypeCollection |
Public class | SymbolDefinitionBase |
Public class | SymbolInstance |
Public class | SymbolInstanceCollection |
Public class | SymbolLibraryType |
Public class | SymbolType |
Public class | SymbolTypeLibrary |
Public class | SymbolTypeLibraryCollection |
Public class | TargetedCommandType |
Public class | TaskBarType |
Public class | TaskButtonType |
Public class | TaskPaneType |
Public class | Text |
Public class | TextFrame |
Public class | TextSymbolType |
Public class | TextSymbolTypeAdvancedPlacement |
Public class | ThemeLabel |
Public class | ToolBarType |
Public class | UIItemType |
Public class | UIItemTypeCollection |
Public class | UnmanagedDataList |
Public class | UnmanagedDataListUnmanagedDataFile |
Public class | UnmanagedDataListUnmanagedDataFolder |
Public class | User |
Public class | UserList |
Public class | UserListGroup |
Public class | UserListUser |
Public class | Utf8XmlWriter | Overrides the default XmlWriter, to ensure that the Xml is Utf8 and with whitespaces, as the MapGuide server requires Utf8
Public class | Utility | Various helper functions
Public class | VectorLayerDefinitionType |
Public class | VectorScaleRangeType |
Public class | VectorScaleRangeTypeCollection |
Public class | ViewOptionsCommandType |
Public class | W2DSymbolType |
Public class | W2DSymbolTypeW2DSymbol |
Public class | WebLayout |
Public class | WebLayoutControlType |
Public class | WebLayoutResizableControlType |
Public class | XmlElementCollection |
Public class | XMLValidator | Class that makes XSD validation
Public class | ZoomControlType |

Interfaces

 | Interface | Description
Public interface | ServerConnectionI | Primary connection to the MapGuide Server

Delegates

 | Delegate | Description
Public delegate | LengthyOperationCallBack |
Public delegate | LengthyOperationProgressCallBack |
NestedPublic delegate | Utility.StreamCopyProgressDelegate | A delegate used to update a progress bar while copying a stream.

Enumerations

 | Enumeration | Description
Public enumeration | BackgroundStyleType |
Public enumeration | BasicCommandActionType |
NestedPublic enumeration | Change.ChangeType |
Public enumeration | DataType |
Public enumeration | DwgComponentTypeType |
Public enumeration | DwgResourceTypeType |
Public enumeration | ElevationTypeType |
Public enumeration | FdoProviderCapabilitiesCommandName |
Public enumeration | FdoProviderCapabilitiesConnectionThreadCapability |
Public enumeration | FdoProviderCapabilitiesConnectionType |
Public enumeration | FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType |
Public enumeration | FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType |
Public enumeration | FdoProviderCapabilitiesExpressionName |
Public enumeration | FdoProviderCapabilitiesFilterOperation |
Public enumeration | FdoProviderCapabilitiesFilterOperation1 |
Public enumeration | FdoProviderCapabilitiesFilterType |
Public enumeration | FdoProviderCapabilitiesGeometryType |
Public enumeration | FdoProviderCapabilitiesGeometryType1 |
Public enumeration | FdoProviderCapabilitiesSchemaType |
Public enumeration | FdoProviderCapabilitiesSchemaType1 |
Public enumeration | FdoSpatialContextListSpatialContextExtentType |
Public enumeration | FeatureNameType |
Public enumeration | GeometryContextType |
Public enumeration | ItemChoiceType |
Public enumeration | KnownSiteVersions | This file contains the current known versions of the MapGuide server.
Public enumeration | LengthUnitType |
NestedPublic enumeration | LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus |
Public enumeration | Operations |
Public enumeration | OverlapTreatmentType |
Public enumeration | PermissionsType |
Public enumeration | PropertyDefinitionTypeType |
Public enumeration | QueryMapFeaturesLayerAttributes |
Public enumeration | RelateTypeEnum |
Public enumeration | ResourceDataType |
Public enumeration | ResourceTypes |
Public enumeration | RowCollectionTypeColumnDefinitionsColumnType |
Public enumeration | SdfKeyTreatmentType |
Public enumeration | ShapeType |
Public enumeration | SizeContextType |
Public enumeration | TargetType |
Public enumeration | TargetViewerType |
Public enumeration | UIItemFunctionType |
Public enumeration | UnmanagedDataTypes |
Public enumeration | UsageContextType |

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.9.

Send comments on this topic.

GNU Lesser General Public License


AllowedValueType Class

AllowedValueType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AllowedValueType
C#
public class AllowedValueType
C++
ref class AllowedValueType
J#
public class AllowedValueType
JScript
public class AllowedValueType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.AllowedValueType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AllowedValueType Members
OSGeo.MapGuide.MaestroAPI Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.9.

Send comments on this topic.

GNU Lesser General Public License

Generated from assembly OSGeo.MapGuide.MaestroAPI [1.0.9.23420]


AllowedValueType Members

AllowedValueType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AllowedValueType.

Public Constructors

 | Name | Description
Public method | AllowedValueType | Initializes a new instance of the AllowedValueType class.
Top

Public Properties

 | Name | Description
Public property | Label |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AllowedValueType Class
OSGeo.MapGuide.MaestroAPI Namespace


AllowedValueType Constructor

AllowedValueType Constructor
See Also Example
[image]

Initializes a new instance of the AllowedValueType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AllowedValueType()
C++
public:
AllowedValueType() sealed
J#
public AllowedValueType()
JScript
public function AllowedValueType()

See Also

AllowedValueType Class


Properties

AllowedValueType Properties
[image]

Public Properties

 | Name | Description
Public property | Label |
Public property | Name |
Top

See Also

AllowedValueType Class


Label Property

AllowedValueType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label { get; set; }
C++
public property string Label sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Label();

/** property */
public void set_Label(string value);
JScript
public function get Label() : String

public function set Label(value : String);

See Also

AllowedValueType Class


Name Property

AllowedValueType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

AllowedValueType Class


AllowedValueTypeCollection Class

AllowedValueTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class AllowedValueTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class AllowedValueTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class AllowedValueTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class AllowedValueTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class AllowedValueTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.AllowedValueTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AllowedValueTypeCollection Members


AllowedValueTypeCollection Members

AllowedValueTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AllowedValueTypeCollection.

Public Constructors

 | Name | Description
Public method | AllowedValueTypeCollection | Initializes a new instance of the AllowedValueTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AllowedValueTypeCollection Class


AllowedValueTypeCollection Constructor

AllowedValueTypeCollection Constructor
[image]

Initializes a new instance of the AllowedValueTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AllowedValueTypeCollection()
C++
public:
AllowedValueTypeCollection() sealed
J#
public AllowedValueTypeCollection()
JScript
public function AllowedValueTypeCollection()

See Also

AllowedValueTypeCollection Class


Properties

AllowedValueTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

AllowedValueTypeCollection Class


Item Property

AllowedValueTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As AllowedValueType
C#
public AllowedValueType this[
int idx
] { get; set; }
C++
public property AllowedValueType default[int idx] sealed {
AllowedValueType get(int idx);
void set(int idx, AllowedValueType value);
}
J#
/** property */
public AllowedValueType get_Item(int idx);

/** property */
public void set_Item(int idx, AllowedValueType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

AllowedValueTypeCollection Class


Methods

AllowedValueTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AllowedValueTypeCollection Class


Add Method

AllowedValueTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As AllowedValueType _
) As Integer
C#
public int Add(
AllowedValueType value
)
C++
public:
int Add(
AllowedValueType value
) sealed
J#
public int Add(
AllowedValueType value
)
JScript
public function Add(
value : AllowedValueType
) : int

See Also

AllowedValueTypeCollection Class


ApplicationDefinitionContainerInfoSet Class

ApplicationDefinitionContainerInfoSet Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class ApplicationDefinitionContainerInfoSet
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class ApplicationDefinitionContainerInfoSet
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class ApplicationDefinitionContainerInfoSet
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class ApplicationDefinitionContainerInfoSet
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class ApplicationDefinitionContainerInfoSet

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionContainerInfoSet

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionContainerInfoSet Members


ApplicationDefinitionContainerInfoSet Members

ApplicationDefinitionContainerInfoSet Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionContainerInfoSet.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionContainerInfoSet | Initializes a new instance of the ApplicationDefinitionContainerInfoSet class.
Top

Public Properties

 | Name | Description
Public property | ContainerInfo |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionContainerInfoSet Class


ApplicationDefinitionContainerInfoSet Constructor

ApplicationDefinitionContainerInfoSet Constructor
[image]

Initializes a new instance of the ApplicationDefinitionContainerInfoSet class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionContainerInfoSet()
C++
public:
ApplicationDefinitionContainerInfoSet() sealed
J#
public ApplicationDefinitionContainerInfoSet()
JScript
public function ApplicationDefinitionContainerInfoSet()

See Also

ApplicationDefinitionContainerInfoSet Class


Properties

ApplicationDefinitionContainerInfoSet Properties
[image]

Public Properties

 | Name | Description
Public property | ContainerInfo |
Top

See Also

ApplicationDefinitionContainerInfoSet Class


ContainerInfo Property

ApplicationDefinitionContainerInfoSet.ContainerInfo Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("ContainerInfo")>
Public Property ContainerInfo As ApplicationDefinitionContainerInfoTypeCollection
C#
[XmlElementAttribute("ContainerInfo")]
public ApplicationDefinitionContainerInfoTypeCollection ContainerInfo { get; set; }
C++
[XmlElementAttribute(L"ContainerInfo")]
public property ApplicationDefinitionContainerInfoTypeCollection ContainerInfo sealed {
ApplicationDefinitionContainerInfoTypeCollection get();
void set(ApplicationDefinitionContainerInfoTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("ContainerInfo") */
/** property */
public ApplicationDefinitionContainerInfoTypeCollection get_ContainerInfo();

/** property */
public void set_ContainerInfo(ApplicationDefinitionContainerInfoTypeCollection value);
JScript
public function get ContainerInfo() : ApplicationDefinitionContainerInfoTypeCollection

public function set ContainerInfo(value : ApplicationDefinitionContainerInfoTypeCollection);

See Also

ApplicationDefinitionContainerInfoSet Class


ApplicationDefinitionContainerInfoType Class

ApplicationDefinitionContainerInfoType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ApplicationDefinitionContainerInfoType
C#
public class ApplicationDefinitionContainerInfoType
C++
ref class ApplicationDefinitionContainerInfoType
J#
public class ApplicationDefinitionContainerInfoType
JScript
public class ApplicationDefinitionContainerInfoType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionContainerInfoType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionContainerInfoType Members


ApplicationDefinitionContainerInfoType Members

ApplicationDefinitionContainerInfoType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionContainerInfoType.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionContainerInfoType | Initializes a new instance of the ApplicationDefinitionContainerInfoType class.
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | LocalizedType |
Public property | PreviewImageUrl |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionContainerInfoType Class


ApplicationDefinitionContainerInfoType Constructor

ApplicationDefinitionContainerInfoType Constructor
[image]

Initializes a new instance of the ApplicationDefinitionContainerInfoType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionContainerInfoType()
C++
public:
ApplicationDefinitionContainerInfoType() sealed
J#
public ApplicationDefinitionContainerInfoType()
JScript
public function ApplicationDefinitionContainerInfoType()

See Also

ApplicationDefinitionContainerInfoType Class


Properties

ApplicationDefinitionContainerInfoType Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | LocalizedType |
Public property | PreviewImageUrl |
Public property | Type |
Top

See Also

ApplicationDefinitionContainerInfoType Class


Description Property

ApplicationDefinitionContainerInfoType.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

ApplicationDefinitionContainerInfoType Class


LocalizedType Property

ApplicationDefinitionContainerInfoType.LocalizedType Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalizedType As String
C#
public string LocalizedType { get; set; }
C++
public property string LocalizedType sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LocalizedType();

/** property */
public void set_LocalizedType(string value);
JScript
public function get LocalizedType() : String

public function set LocalizedType(value : String);

See Also

ApplicationDefinitionContainerInfoType Class


PreviewImageUrl Property

ApplicationDefinitionContainerInfoType.PreviewImageUrl Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property PreviewImageUrl As String
C#
public string PreviewImageUrl { get; set; }
C++
public property string PreviewImageUrl sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_PreviewImageUrl();

/** property */
public void set_PreviewImageUrl(string value);
JScript
public function get PreviewImageUrl() : String

public function set PreviewImageUrl(value : String);

See Also

ApplicationDefinitionContainerInfoType Class


Type Property

ApplicationDefinitionContainerInfoType.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
C++
public property string Type sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Type();

/** property */
public void set_Type(string value);
JScript
public function get Type() : String

public function set Type(value : String);

See Also

ApplicationDefinitionContainerInfoType Class


ApplicationDefinitionContainerInfoTypeCollection Class

ApplicationDefinitionContainerInfoTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ApplicationDefinitionContainerInfoTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ApplicationDefinitionContainerInfoTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ApplicationDefinitionContainerInfoTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ApplicationDefinitionContainerInfoTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ApplicationDefinitionContainerInfoTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionContainerInfoTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionContainerInfoTypeCollection Members


ApplicationDefinitionContainerInfoTypeCollection Members

ApplicationDefinitionContainerInfoTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionContainerInfoTypeCollection.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionContainerInfoTypeCollection | Initializes a new instance of the ApplicationDefinitionContainerInfoTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionContainerInfoTypeCollection Class


ApplicationDefinitionContainerInfoTypeCollection Constructor

ApplicationDefinitionContainerInfoTypeCollection Constructor
[image]

Initializes a new instance of the ApplicationDefinitionContainerInfoTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionContainerInfoTypeCollection()
C++
public:
ApplicationDefinitionContainerInfoTypeCollection() sealed
J#
public ApplicationDefinitionContainerInfoTypeCollection()
JScript
public function ApplicationDefinitionContainerInfoTypeCollection()

See Also

ApplicationDefinitionContainerInfoTypeCollection Class


Properties

ApplicationDefinitionContainerInfoTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ApplicationDefinitionContainerInfoTypeCollection Class


Item Property

ApplicationDefinitionContainerInfoTypeCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ApplicationDefinitionContainerInfoType
C#
public ApplicationDefinitionContainerInfoType this[
int idx
] { get; set; }
C++
public property ApplicationDefinitionContainerInfoType default[int idx] sealed {
ApplicationDefinitionContainerInfoType get(int idx);
void set(int idx, ApplicationDefinitionContainerInfoType value);
}
J#
/** property */
public ApplicationDefinitionContainerInfoType get_Item(int idx);

/** property */
public void set_Item(int idx, ApplicationDefinitionContainerInfoType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ApplicationDefinitionContainerInfoTypeCollection Class


Methods

ApplicationDefinitionContainerInfoTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionContainerInfoTypeCollection Class


Add Method

ApplicationDefinitionContainerInfoTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ApplicationDefinitionContainerInfoType _
) As Integer
C#
public int Add(
ApplicationDefinitionContainerInfoType value
)
C++
public:
int Add(
ApplicationDefinitionContainerInfoType value
) sealed
J#
public int Add(
ApplicationDefinitionContainerInfoType value
)
JScript
public function Add(
value : ApplicationDefinitionContainerInfoType
) : int

See Also

ApplicationDefinitionContainerInfoTypeCollection Class


ApplicationDefinitionPanelType Class

ApplicationDefinitionPanelType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ApplicationDefinitionPanelType
C#
public class ApplicationDefinitionPanelType
C++
ref class ApplicationDefinitionPanelType
J#
public class ApplicationDefinitionPanelType
JScript
public class ApplicationDefinitionPanelType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionPanelType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionPanelType Members


ApplicationDefinitionPanelType Members

ApplicationDefinitionPanelType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionPanelType.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionPanelType | Initializes a new instance of the ApplicationDefinitionPanelType class.
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | Label |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionPanelType Class


ApplicationDefinitionPanelType Constructor

ApplicationDefinitionPanelType Constructor
[image]

Initializes a new instance of the ApplicationDefinitionPanelType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionPanelType()
C++
public:
ApplicationDefinitionPanelType() sealed
J#
public ApplicationDefinitionPanelType()
JScript
public function ApplicationDefinitionPanelType()

See Also

ApplicationDefinitionPanelType Class


Properties

ApplicationDefinitionPanelType Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | Label |
Public property | Name |
Top

See Also

ApplicationDefinitionPanelType Class


Description Property

ApplicationDefinitionPanelType.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

ApplicationDefinitionPanelType Class


Label Property

ApplicationDefinitionPanelType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label { get; set; }
C++
public property string Label sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Label();

/** property */
public void set_Label(string value);
JScript
public function get Label() : String

public function set Label(value : String);

See Also

ApplicationDefinitionPanelType Class


Name Property

ApplicationDefinitionPanelType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ApplicationDefinitionPanelType Class


ApplicationDefinitionPanelTypeCollection Class

ApplicationDefinitionPanelTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ApplicationDefinitionPanelTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ApplicationDefinitionPanelTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ApplicationDefinitionPanelTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ApplicationDefinitionPanelTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ApplicationDefinitionPanelTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionPanelTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionPanelTypeCollection Members


ApplicationDefinitionPanelTypeCollection Members

ApplicationDefinitionPanelTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionPanelTypeCollection.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionPanelTypeCollection | Initializes a new instance of the ApplicationDefinitionPanelTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionPanelTypeCollection Class


ApplicationDefinitionPanelTypeCollection Constructor

ApplicationDefinitionPanelTypeCollection Constructor
[image]

Initializes a new instance of the ApplicationDefinitionPanelTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionPanelTypeCollection()
C++
public:
ApplicationDefinitionPanelTypeCollection() sealed
J#
public ApplicationDefinitionPanelTypeCollection()
JScript
public function ApplicationDefinitionPanelTypeCollection()

See Also

ApplicationDefinitionPanelTypeCollection Class


Properties

ApplicationDefinitionPanelTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ApplicationDefinitionPanelTypeCollection Class


Item Property

ApplicationDefinitionPanelTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ApplicationDefinitionPanelType
C#
public ApplicationDefinitionPanelType this[
int idx
] { get; set; }
C++
public property ApplicationDefinitionPanelType default[int idx] sealed {
ApplicationDefinitionPanelType get(int idx);
void set(int idx, ApplicationDefinitionPanelType value);
}
J#
/** property */
public ApplicationDefinitionPanelType get_Item(int idx);

/** property */
public void set_Item(int idx, ApplicationDefinitionPanelType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ApplicationDefinitionPanelTypeCollection Class


Methods

ApplicationDefinitionPanelTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionPanelTypeCollection Class


Add Method

ApplicationDefinitionPanelTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ApplicationDefinitionPanelType _
) As Integer
C#
public int Add(
ApplicationDefinitionPanelType value
)
C++
public:
int Add(
ApplicationDefinitionPanelType value
) sealed
J#
public int Add(
ApplicationDefinitionPanelType value
)
JScript
public function Add(
value : ApplicationDefinitionPanelType
) : int

See Also

ApplicationDefinitionPanelTypeCollection Class


ApplicationDefinitionTemplateInfoSet Class

ApplicationDefinitionTemplateInfoSet Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class ApplicationDefinitionTemplateInfoSet
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class ApplicationDefinitionTemplateInfoSet
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class ApplicationDefinitionTemplateInfoSet
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class ApplicationDefinitionTemplateInfoSet
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class ApplicationDefinitionTemplateInfoSet

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionTemplateInfoSet

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionTemplateInfoSet Members


ApplicationDefinitionTemplateInfoSet Members

ApplicationDefinitionTemplateInfoSet Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionTemplateInfoSet.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionTemplateInfoSet | Initializes a new instance of the ApplicationDefinitionTemplateInfoSet class.
Top

Public Properties

 | Name | Description
Public property | TemplateInfo |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionTemplateInfoSet Class


ApplicationDefinitionTemplateInfoSet Constructor

ApplicationDefinitionTemplateInfoSet Constructor
[image]

Initializes a new instance of the ApplicationDefinitionTemplateInfoSet class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionTemplateInfoSet()
C++
public:
ApplicationDefinitionTemplateInfoSet() sealed
J#
public ApplicationDefinitionTemplateInfoSet()
JScript
public function ApplicationDefinitionTemplateInfoSet()

See Also

ApplicationDefinitionTemplateInfoSet Class


Properties

ApplicationDefinitionTemplateInfoSet Properties
[image]

Public Properties

 | Name | Description
Public property | TemplateInfo |
Top

See Also

ApplicationDefinitionTemplateInfoSet Class


TemplateInfo Property

ApplicationDefinitionTemplateInfoSet.TemplateInfo Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("TemplateInfo")>
Public Property TemplateInfo As ApplicationDefinitionTemplateInfoTypeCollection
C#
[XmlElementAttribute("TemplateInfo")]
public ApplicationDefinitionTemplateInfoTypeCollection TemplateInfo { get; set; }
C++
[XmlElementAttribute(L"TemplateInfo")]
public property ApplicationDefinitionTemplateInfoTypeCollection TemplateInfo sealed {
ApplicationDefinitionTemplateInfoTypeCollection get();
void set(ApplicationDefinitionTemplateInfoTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("TemplateInfo") */
/** property */
public ApplicationDefinitionTemplateInfoTypeCollection get_TemplateInfo();

/** property */
public void set_TemplateInfo(ApplicationDefinitionTemplateInfoTypeCollection value);
JScript
public function get TemplateInfo() : ApplicationDefinitionTemplateInfoTypeCollection

public function set TemplateInfo(value : ApplicationDefinitionTemplateInfoTypeCollection);

See Also

ApplicationDefinitionTemplateInfoSet Class


ApplicationDefinitionTemplateInfoType Class

ApplicationDefinitionTemplateInfoType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ApplicationDefinitionTemplateInfoType
C#
public class ApplicationDefinitionTemplateInfoType
C++
ref class ApplicationDefinitionTemplateInfoType
J#
public class ApplicationDefinitionTemplateInfoType
JScript
public class ApplicationDefinitionTemplateInfoType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionTemplateInfoType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionTemplateInfoType Members


ApplicationDefinitionTemplateInfoType Members

ApplicationDefinitionTemplateInfoType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionTemplateInfoType.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionTemplateInfoType | Initializes a new instance of the ApplicationDefinitionTemplateInfoType class.
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | LocationUrl |
Public property | Name |
Public property | Panel |
Public property | PreviewImageUrl |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionTemplateInfoType Class


ApplicationDefinitionTemplateInfoType Constructor

ApplicationDefinitionTemplateInfoType Constructor
[image]

Initializes a new instance of the ApplicationDefinitionTemplateInfoType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionTemplateInfoType()
C++
public:
ApplicationDefinitionTemplateInfoType() sealed
J#
public ApplicationDefinitionTemplateInfoType()
JScript
public function ApplicationDefinitionTemplateInfoType()

See Also

ApplicationDefinitionTemplateInfoType Class


Properties

ApplicationDefinitionTemplateInfoType Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | LocationUrl |
Public property | Name |
Public property | Panel |
Public property | PreviewImageUrl |
Top

See Also

ApplicationDefinitionTemplateInfoType Class


Description Property

ApplicationDefinitionTemplateInfoType.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

ApplicationDefinitionTemplateInfoType Class


LocationUrl Property

ApplicationDefinitionTemplateInfoType.LocationUrl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LocationUrl As String
C#
public string LocationUrl { get; set; }
C++
public property string LocationUrl sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LocationUrl();

/** property */
public void set_LocationUrl(string value);
JScript
public function get LocationUrl() : String

public function set LocationUrl(value : String);

See Also

ApplicationDefinitionTemplateInfoType Class


Name Property

ApplicationDefinitionTemplateInfoType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ApplicationDefinitionTemplateInfoType Class


Panel Property

ApplicationDefinitionTemplateInfoType.Panel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Panel")>
Public Property Panel As ApplicationDefinitionPanelTypeCollection
C#
[XmlElementAttribute("Panel")]
public ApplicationDefinitionPanelTypeCollection Panel { get; set; }
C++
[XmlElementAttribute(L"Panel")]
public property ApplicationDefinitionPanelTypeCollection Panel sealed {
ApplicationDefinitionPanelTypeCollection get();
void set(ApplicationDefinitionPanelTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("Panel") */
/** property */
public ApplicationDefinitionPanelTypeCollection get_Panel();

/** property */
public void set_Panel(ApplicationDefinitionPanelTypeCollection value);
JScript
public function get Panel() : ApplicationDefinitionPanelTypeCollection

public function set Panel(value : ApplicationDefinitionPanelTypeCollection);

See Also

ApplicationDefinitionTemplateInfoType Class


PreviewImageUrl Property

ApplicationDefinitionTemplateInfoType.PreviewImageUrl Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property PreviewImageUrl As String
C#
public string PreviewImageUrl { get; set; }
C++
public property string PreviewImageUrl sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_PreviewImageUrl();

/** property */
public void set_PreviewImageUrl(string value);
JScript
public function get PreviewImageUrl() : String

public function set PreviewImageUrl(value : String);

See Also

ApplicationDefinitionTemplateInfoType Class


ApplicationDefinitionTemplateInfoTypeCollection Class

ApplicationDefinitionTemplateInfoTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ApplicationDefinitionTemplateInfoTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ApplicationDefinitionTemplateInfoTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ApplicationDefinitionTemplateInfoTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ApplicationDefinitionTemplateInfoTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ApplicationDefinitionTemplateInfoTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionTemplateInfoTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionTemplateInfoTypeCollection Members


ApplicationDefinitionTemplateInfoTypeCollection Members

ApplicationDefinitionTemplateInfoTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionTemplateInfoTypeCollection.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionTemplateInfoTypeCollection | Initializes a new instance of the ApplicationDefinitionTemplateInfoTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionTemplateInfoTypeCollection Class


ApplicationDefinitionTemplateInfoTypeCollection Constructor

ApplicationDefinitionTemplateInfoTypeCollection Constructor
[image]

Initializes a new instance of the ApplicationDefinitionTemplateInfoTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionTemplateInfoTypeCollection()
C++
public:
ApplicationDefinitionTemplateInfoTypeCollection() sealed
J#
public ApplicationDefinitionTemplateInfoTypeCollection()
JScript
public function ApplicationDefinitionTemplateInfoTypeCollection()

See Also

ApplicationDefinitionTemplateInfoTypeCollection Class


Properties

ApplicationDefinitionTemplateInfoTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ApplicationDefinitionTemplateInfoTypeCollection Class


Item Property

ApplicationDefinitionTemplateInfoTypeCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ApplicationDefinitionTemplateInfoType
C#
public ApplicationDefinitionTemplateInfoType this[
int idx
] { get; set; }
C++
public property ApplicationDefinitionTemplateInfoType default[int idx] sealed {
ApplicationDefinitionTemplateInfoType get(int idx);
void set(int idx, ApplicationDefinitionTemplateInfoType value);
}
J#
/** property */
public ApplicationDefinitionTemplateInfoType get_Item(int idx);

/** property */
public void set_Item(int idx, ApplicationDefinitionTemplateInfoType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ApplicationDefinitionTemplateInfoTypeCollection Class


Methods

ApplicationDefinitionTemplateInfoTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionTemplateInfoTypeCollection Class


Add Method

ApplicationDefinitionTemplateInfoTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ApplicationDefinitionTemplateInfoType _
) As Integer
C#
public int Add(
ApplicationDefinitionTemplateInfoType value
)
C++
public:
int Add(
ApplicationDefinitionTemplateInfoType value
) sealed
J#
public int Add(
ApplicationDefinitionTemplateInfoType value
)
JScript
public function Add(
value : ApplicationDefinitionTemplateInfoType
) : int

See Also

ApplicationDefinitionTemplateInfoTypeCollection Class


ApplicationDefinitionWidgetInfoSet Class

ApplicationDefinitionWidgetInfoSet Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class ApplicationDefinitionWidgetInfoSet
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class ApplicationDefinitionWidgetInfoSet
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class ApplicationDefinitionWidgetInfoSet
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class ApplicationDefinitionWidgetInfoSet
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class ApplicationDefinitionWidgetInfoSet

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionWidgetInfoSet

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionWidgetInfoSet Members


ApplicationDefinitionWidgetInfoSet Members

ApplicationDefinitionWidgetInfoSet Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionWidgetInfoSet.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionWidgetInfoSet | Initializes a new instance of the ApplicationDefinitionWidgetInfoSet class.
Top

Public Properties

 | Name | Description
Public property | WidgetInfo |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionWidgetInfoSet Class


ApplicationDefinitionWidgetInfoSet Constructor

ApplicationDefinitionWidgetInfoSet Constructor
[image]

Initializes a new instance of the ApplicationDefinitionWidgetInfoSet class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionWidgetInfoSet()
C++
public:
ApplicationDefinitionWidgetInfoSet() sealed
J#
public ApplicationDefinitionWidgetInfoSet()
JScript
public function ApplicationDefinitionWidgetInfoSet()

See Also

ApplicationDefinitionWidgetInfoSet Class


Properties

ApplicationDefinitionWidgetInfoSet Properties
[image]

Public Properties

 | Name | Description
Public property | WidgetInfo |
Top

See Also

ApplicationDefinitionWidgetInfoSet Class


WidgetInfo Property

ApplicationDefinitionWidgetInfoSet.WidgetInfo Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("WidgetInfo")>
Public Property WidgetInfo As ApplicationDefinitionWidgetInfoTypeCollection
C#
[XmlElementAttribute("WidgetInfo")]
public ApplicationDefinitionWidgetInfoTypeCollection WidgetInfo { get; set; }
C++
[XmlElementAttribute(L"WidgetInfo")]
public property ApplicationDefinitionWidgetInfoTypeCollection WidgetInfo sealed {
ApplicationDefinitionWidgetInfoTypeCollection get();
void set(ApplicationDefinitionWidgetInfoTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("WidgetInfo") */
/** property */
public ApplicationDefinitionWidgetInfoTypeCollection get_WidgetInfo();

/** property */
public void set_WidgetInfo(ApplicationDefinitionWidgetInfoTypeCollection value);
JScript
public function get WidgetInfo() : ApplicationDefinitionWidgetInfoTypeCollection

public function set WidgetInfo(value : ApplicationDefinitionWidgetInfoTypeCollection);

See Also

ApplicationDefinitionWidgetInfoSet Class


ApplicationDefinitionWidgetInfoType Class

ApplicationDefinitionWidgetInfoType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ApplicationDefinitionWidgetInfoType
C#
public class ApplicationDefinitionWidgetInfoType
C++
ref class ApplicationDefinitionWidgetInfoType
J#
public class ApplicationDefinitionWidgetInfoType
JScript
public class ApplicationDefinitionWidgetInfoType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionWidgetInfoType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionWidgetInfoType Members


ApplicationDefinitionWidgetInfoType Members

ApplicationDefinitionWidgetInfoType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionWidgetInfoType.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionWidgetInfoType | Initializes a new instance of the ApplicationDefinitionWidgetInfoType class.
Top

Public Properties

 | Name | Description
Public property | ContainableBy |
Public property | Description |
Public property | ImageClass |
Public property | ImageUrl |
Public property | Label |
Public property | LocalizedType |
Public property | Location |
Public property | Parameter |
Public property | StandardUi |
Public property | StandardUiSpecified |
Public property | StatusText |
Public property | Tooltip |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionWidgetInfoType Class


ApplicationDefinitionWidgetInfoType Constructor

ApplicationDefinitionWidgetInfoType Constructor
[image]

Initializes a new instance of the ApplicationDefinitionWidgetInfoType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionWidgetInfoType()
C++
public:
ApplicationDefinitionWidgetInfoType() sealed
J#
public ApplicationDefinitionWidgetInfoType()
JScript
public function ApplicationDefinitionWidgetInfoType()

See Also

ApplicationDefinitionWidgetInfoType Class


Properties

ApplicationDefinitionWidgetInfoType Properties
[image]

Public Properties

 | Name | Description
Public property | ContainableBy |
Public property | Description |
Public property | ImageClass |
Public property | ImageUrl |
Public property | Label |
Public property | LocalizedType |
Public property | Location |
Public property | Parameter |
Public property | StandardUi |
Public property | StandardUiSpecified |
Public property | StatusText |
Public property | Tooltip |
Public property | Type |
Top

See Also

ApplicationDefinitionWidgetInfoType Class


ContainableBy Property

ApplicationDefinitionWidgetInfoType.ContainableBy Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("ContainableBy")>
Public Property ContainableBy As StringCollection
C#
[XmlElementAttribute("ContainableBy")]
public StringCollection ContainableBy { get; set; }
C++
[XmlElementAttribute(L"ContainableBy")]
public property StringCollection ContainableBy sealed {
StringCollection get();
void set(StringCollection value);
}
J#
/** @attribute XmlElementAttribute("ContainableBy") */
/** property */
public StringCollection get_ContainableBy();

/** property */
public void set_ContainableBy(StringCollection value);
JScript
public function get ContainableBy() : StringCollection

public function set ContainableBy(value : StringCollection);

See Also

ApplicationDefinitionWidgetInfoType Class


Description Property

ApplicationDefinitionWidgetInfoType.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

ApplicationDefinitionWidgetInfoType Class


ImageClass Property

ApplicationDefinitionWidgetInfoType.ImageClass Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageClass As String
C#
public string ImageClass { get; set; }
C++
public property string ImageClass sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ImageClass();

/** property */
public void set_ImageClass(string value);
JScript
public function get ImageClass() : String

public function set ImageClass(value : String);

See Also

ApplicationDefinitionWidgetInfoType Class


ImageUrl Property

ApplicationDefinitionWidgetInfoType.ImageUrl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageUrl As String
C#
public string ImageUrl { get; set; }
C++
public property string ImageUrl sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ImageUrl();

/** property */
public void set_ImageUrl(string value);
JScript
public function get ImageUrl() : String

public function set ImageUrl(value : String);

See Also

ApplicationDefinitionWidgetInfoType Class


Label Property

ApplicationDefinitionWidgetInfoType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label { get; set; }
C++
public property string Label sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Label();

/** property */
public void set_Label(string value);
JScript
public function get Label() : String

public function set Label(value : String);

See Also

ApplicationDefinitionWidgetInfoType Class


LocalizedType Property

ApplicationDefinitionWidgetInfoType.LocalizedType Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalizedType As String
C#
public string LocalizedType { get; set; }
C++
public property string LocalizedType sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LocalizedType();

/** property */
public void set_LocalizedType(string value);
JScript
public function get LocalizedType() : String

public function set LocalizedType(value : String);

See Also

ApplicationDefinitionWidgetInfoType Class


Location Property

ApplicationDefinitionWidgetInfoType.Location Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Location As String
C#
public string Location { get; set; }
C++
public property string Location sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Location();

/** property */
public void set_Location(string value);
JScript
public function get Location() : String

public function set Location(value : String);

See Also

ApplicationDefinitionWidgetInfoType Class


Parameter Property

ApplicationDefinitionWidgetInfoType.Parameter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Parameter")>
Public Property Parameter As ApplicationDefinitionWidgetParameterTypeCollection
C#
[XmlElementAttribute("Parameter")]
public ApplicationDefinitionWidgetParameterTypeCollection Parameter { get; set; }
C++
[XmlElementAttribute(L"Parameter")]
public property ApplicationDefinitionWidgetParameterTypeCollection Parameter sealed {
ApplicationDefinitionWidgetParameterTypeCollection get();
void set(ApplicationDefinitionWidgetParameterTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("Parameter") */
/** property */
public ApplicationDefinitionWidgetParameterTypeCollection get_Parameter();

/** property */
public void set_Parameter(ApplicationDefinitionWidgetParameterTypeCollection value);
JScript
public function get Parameter() : ApplicationDefinitionWidgetParameterTypeCollection

public function set Parameter(value : ApplicationDefinitionWidgetParameterTypeCollection);

See Also

ApplicationDefinitionWidgetInfoType Class


StandardUi Property

ApplicationDefinitionWidgetInfoType.StandardUi Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property StandardUi As Boolean
C#
public bool StandardUi { get; set; }
C++
public property bool StandardUi sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_StandardUi();

/** property */
public void set_StandardUi(bool value);
JScript
public function get StandardUi() : bool

public function set StandardUi(value : bool);

See Also

ApplicationDefinitionWidgetInfoType Class


StandardUiSpecified Property

ApplicationDefinitionWidgetInfoType.StandardUiSpecified Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property StandardUiSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool StandardUiSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool StandardUiSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_StandardUiSpecified();

/** property */
public void set_StandardUiSpecified(bool value);
JScript
public function get StandardUiSpecified() : bool

public function set StandardUiSpecified(value : bool);

See Also

ApplicationDefinitionWidgetInfoType Class


StatusText Property

ApplicationDefinitionWidgetInfoType.StatusText Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property StatusText As String
C#
public string StatusText { get; set; }
C++
public property string StatusText sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_StatusText();

/** property */
public void set_StatusText(string value);
JScript
public function get StatusText() : String

public function set StatusText(value : String);

See Also

ApplicationDefinitionWidgetInfoType Class


Tooltip Property

ApplicationDefinitionWidgetInfoType.Tooltip Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Tooltip As String
C#
public string Tooltip { get; set; }
C++
public property string Tooltip sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Tooltip();

/** property */
public void set_Tooltip(string value);
JScript
public function get Tooltip() : String

public function set Tooltip(value : String);

See Also

ApplicationDefinitionWidgetInfoType Class


Type Property

ApplicationDefinitionWidgetInfoType.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
C++
public property string Type sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Type();

/** property */
public void set_Type(string value);
JScript
public function get Type() : String

public function set Type(value : String);

See Also

ApplicationDefinitionWidgetInfoType Class


ApplicationDefinitionWidgetInfoTypeCollection Class

ApplicationDefinitionWidgetInfoTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ApplicationDefinitionWidgetInfoTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ApplicationDefinitionWidgetInfoTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ApplicationDefinitionWidgetInfoTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ApplicationDefinitionWidgetInfoTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ApplicationDefinitionWidgetInfoTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionWidgetInfoTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionWidgetInfoTypeCollection Members


ApplicationDefinitionWidgetInfoTypeCollection Members

ApplicationDefinitionWidgetInfoTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionWidgetInfoTypeCollection.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionWidgetInfoTypeCollection | Initializes a new instance of the ApplicationDefinitionWidgetInfoTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionWidgetInfoTypeCollection Class


ApplicationDefinitionWidgetInfoTypeCollection Constructor

ApplicationDefinitionWidgetInfoTypeCollection Constructor
[image]

Initializes a new instance of the ApplicationDefinitionWidgetInfoTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionWidgetInfoTypeCollection()
C++
public:
ApplicationDefinitionWidgetInfoTypeCollection() sealed
J#
public ApplicationDefinitionWidgetInfoTypeCollection()
JScript
public function ApplicationDefinitionWidgetInfoTypeCollection()

See Also

ApplicationDefinitionWidgetInfoTypeCollection Class


Properties

ApplicationDefinitionWidgetInfoTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ApplicationDefinitionWidgetInfoTypeCollection Class


Item Property

ApplicationDefinitionWidgetInfoTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ApplicationDefinitionWidgetInfoType
C#
public ApplicationDefinitionWidgetInfoType this[
int idx
] { get; set; }
C++
public property ApplicationDefinitionWidgetInfoType default[int idx] sealed {
ApplicationDefinitionWidgetInfoType get(int idx);
void set(int idx, ApplicationDefinitionWidgetInfoType value);
}
J#
/** property */
public ApplicationDefinitionWidgetInfoType get_Item(int idx);

/** property */
public void set_Item(int idx, ApplicationDefinitionWidgetInfoType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ApplicationDefinitionWidgetInfoTypeCollection Class


Methods

ApplicationDefinitionWidgetInfoTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionWidgetInfoTypeCollection Class


Add Method

ApplicationDefinitionWidgetInfoTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ApplicationDefinitionWidgetInfoType _
) As Integer
C#
public int Add(
ApplicationDefinitionWidgetInfoType value
)
C++
public:
int Add(
ApplicationDefinitionWidgetInfoType value
) sealed
J#
public int Add(
ApplicationDefinitionWidgetInfoType value
)
JScript
public function Add(
value : ApplicationDefinitionWidgetInfoType
) : int

See Also

ApplicationDefinitionWidgetInfoTypeCollection Class


ApplicationDefinitionWidgetParameterType Class

ApplicationDefinitionWidgetParameterType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ApplicationDefinitionWidgetParameterType
C#
public class ApplicationDefinitionWidgetParameterType
C++
ref class ApplicationDefinitionWidgetParameterType
J#
public class ApplicationDefinitionWidgetParameterType
JScript
public class ApplicationDefinitionWidgetParameterType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionWidgetParameterType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionWidgetParameterType Members


ApplicationDefinitionWidgetParameterType Members

ApplicationDefinitionWidgetParameterType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionWidgetParameterType.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionWidgetParameterType | Initializes a new instance of the ApplicationDefinitionWidgetParameterType class.
Top

Public Properties

 | Name | Description
Public property | AllowedValue |
Public property | DefaultValue |
Public property | Description |
Public property | IsMandatory |
Public property | IsMandatorySpecified |
Public property | Label |
Public property | Max |
Public property | Min |
Public property | Name |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionWidgetParameterType Class


ApplicationDefinitionWidgetParameterType Constructor

ApplicationDefinitionWidgetParameterType Constructor
[image]

Initializes a new instance of the ApplicationDefinitionWidgetParameterType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionWidgetParameterType()
C++
public:
ApplicationDefinitionWidgetParameterType() sealed
J#
public ApplicationDefinitionWidgetParameterType()
JScript
public function ApplicationDefinitionWidgetParameterType()

See Also

ApplicationDefinitionWidgetParameterType Class


Properties

ApplicationDefinitionWidgetParameterType Properties
[image]

Public Properties

 | Name | Description
Public property | AllowedValue |
Public property | DefaultValue |
Public property | Description |
Public property | IsMandatory |
Public property | IsMandatorySpecified |
Public property | Label |
Public property | Max |
Public property | Min |
Public property | Name |
Public property | Type |
Top

See Also

ApplicationDefinitionWidgetParameterType Class


AllowedValue Property

ApplicationDefinitionWidgetParameterType.AllowedValue Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("AllowedValue")>
Public Property AllowedValue As AllowedValueTypeCollection
C#
[XmlElementAttribute("AllowedValue")]
public AllowedValueTypeCollection AllowedValue { get; set; }
C++
[XmlElementAttribute(L"AllowedValue")]
public property AllowedValueTypeCollection AllowedValue sealed {
AllowedValueTypeCollection get();
void set(AllowedValueTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("AllowedValue") */
/** property */
public AllowedValueTypeCollection get_AllowedValue();

/** property */
public void set_AllowedValue(AllowedValueTypeCollection value);
JScript
public function get AllowedValue() : AllowedValueTypeCollection

public function set AllowedValue(value : AllowedValueTypeCollection);

See Also

ApplicationDefinitionWidgetParameterType Class


DefaultValue Property

ApplicationDefinitionWidgetParameterType.DefaultValue Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
C#
public string DefaultValue { get; set; }
C++
public property string DefaultValue sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DefaultValue();

/** property */
public void set_DefaultValue(string value);
JScript
public function get DefaultValue() : String

public function set DefaultValue(value : String);

See Also

ApplicationDefinitionWidgetParameterType Class


Description Property

ApplicationDefinitionWidgetParameterType.Description Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

ApplicationDefinitionWidgetParameterType Class


IsMandatory Property

ApplicationDefinitionWidgetParameterType.IsMandatory Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property IsMandatory As Boolean
C#
public bool IsMandatory { get; set; }
C++
public property bool IsMandatory sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IsMandatory();

/** property */
public void set_IsMandatory(bool value);
JScript
public function get IsMandatory() : bool

public function set IsMandatory(value : bool);

See Also

ApplicationDefinitionWidgetParameterType Class


IsMandatorySpecified Property

ApplicationDefinitionWidgetParameterType.IsMandatorySpecified Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property IsMandatorySpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool IsMandatorySpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool IsMandatorySpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_IsMandatorySpecified();

/** property */
public void set_IsMandatorySpecified(bool value);
JScript
public function get IsMandatorySpecified() : bool

public function set IsMandatorySpecified(value : bool);

See Also

ApplicationDefinitionWidgetParameterType Class


Label Property

ApplicationDefinitionWidgetParameterType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label { get; set; }
C++
public property string Label sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Label();

/** property */
public void set_Label(string value);
JScript
public function get Label() : String

public function set Label(value : String);

See Also

ApplicationDefinitionWidgetParameterType Class


Max Property

ApplicationDefinitionWidgetParameterType.Max Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Max As String
C#
public string Max { get; set; }
C++
public property string Max sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Max();

/** property */
public void set_Max(string value);
JScript
public function get Max() : String

public function set Max(value : String);

See Also

ApplicationDefinitionWidgetParameterType Class


Min Property

ApplicationDefinitionWidgetParameterType.Min Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Min As String
C#
public string Min { get; set; }
C++
public property string Min sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Min();

/** property */
public void set_Min(string value);
JScript
public function get Min() : String

public function set Min(value : String);

See Also

ApplicationDefinitionWidgetParameterType Class


Name Property

ApplicationDefinitionWidgetParameterType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ApplicationDefinitionWidgetParameterType Class


Type Property

ApplicationDefinitionWidgetParameterType.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
C++
public property string Type sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Type();

/** property */
public void set_Type(string value);
JScript
public function get Type() : String

public function set Type(value : String);

See Also

ApplicationDefinitionWidgetParameterType Class


ApplicationDefinitionWidgetParameterTypeCollection Class

ApplicationDefinitionWidgetParameterTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ApplicationDefinitionWidgetParameterTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ApplicationDefinitionWidgetParameterTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ApplicationDefinitionWidgetParameterTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ApplicationDefinitionWidgetParameterTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ApplicationDefinitionWidgetParameterTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionWidgetParameterTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionWidgetParameterTypeCollection Members


ApplicationDefinitionWidgetParameterTypeCollection Members

ApplicationDefinitionWidgetParameterTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionWidgetParameterTypeCollection.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionWidgetParameterTypeCollection | Initializes a new instance of the ApplicationDefinitionWidgetParameterTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionWidgetParameterTypeCollection Class


ApplicationDefinitionWidgetParameterTypeCollection Constructor

ApplicationDefinitionWidgetParameterTypeCollection Constructor
See Also Example
[image]

Initializes a new instance of the ApplicationDefinitionWidgetParameterTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionWidgetParameterTypeCollection()
C++
public:
ApplicationDefinitionWidgetParameterTypeCollection() sealed
J#
public ApplicationDefinitionWidgetParameterTypeCollection()
JScript
public function ApplicationDefinitionWidgetParameterTypeCollection()

See Also

ApplicationDefinitionWidgetParameterTypeCollection Class


Properties

ApplicationDefinitionWidgetParameterTypeCollection Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ApplicationDefinitionWidgetParameterTypeCollection Class


Item Property

ApplicationDefinitionWidgetParameterTypeCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ApplicationDefinitionWidgetParameterType
C#
public ApplicationDefinitionWidgetParameterType this[
int idx
] { get; set; }
C++
public property ApplicationDefinitionWidgetParameterType default[int idx] sealed {
ApplicationDefinitionWidgetParameterType get(int idx);
void set(int idx, ApplicationDefinitionWidgetParameterType value);
}
J#
/** property */
public ApplicationDefinitionWidgetParameterType get_Item(int idx);

/** property */
public void set_Item(int idx, ApplicationDefinitionWidgetParameterType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ApplicationDefinitionWidgetParameterTypeCollection Class


Methods

ApplicationDefinitionWidgetParameterTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionWidgetParameterTypeCollection Class


Add Method

ApplicationDefinitionWidgetParameterTypeCollection.Add Method
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ApplicationDefinitionWidgetParameterType _
) As Integer
C#
public int Add(
ApplicationDefinitionWidgetParameterType value
)
C++
public:
int Add(
ApplicationDefinitionWidgetParameterType value
) sealed
J#
public int Add(
ApplicationDefinitionWidgetParameterType value
)
JScript
public function Add(
value : ApplicationDefinitionWidgetParameterType
) : int

See Also

ApplicationDefinitionWidgetParameterTypeCollection Class


AreaRuleType Class

AreaRuleType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AreaRuleType
C#
public class AreaRuleType
C++
ref class AreaRuleType
J#
public class AreaRuleType
JScript
public class AreaRuleType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.AreaRuleType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AreaRuleType Members


AreaRuleType Members

AreaRuleType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AreaRuleType.

Public Constructors

 | Name | Description
Public method | AreaRuleType | Initializes a new instance of the AreaRuleType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Filter |
Public property | Item |
Public property | Label |
Public property | LegendLabel |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AreaRuleType Class


AreaRuleType Constructor

AreaRuleType Constructor
[image]

Initializes a new instance of the AreaRuleType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AreaRuleType()
C++
public:
AreaRuleType() sealed
J#
public AreaRuleType()
JScript
public function AreaRuleType()

See Also

AreaRuleType Class


Properties

AreaRuleType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Filter |
Public property | Item |
Public property | Label |
Public property | LegendLabel |
Top

See Also

AreaRuleType Class


ExtendedData1 Property

AreaRuleType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

AreaRuleType Class


Filter Property

AreaRuleType.Filter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; set; }
C++
public property string Filter sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Filter();

/** property */
public void set_Filter(string value);
JScript
public function get Filter() : String

public function set Filter(value : String);

See Also

AreaRuleType Class


Item Property

AreaRuleType.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("AreaSymbolization2D")>
Public Property Item As AreaSymbolizationFillType
C#
[XmlElementAttribute("AreaSymbolization2D")]
public AreaSymbolizationFillType Item { get; set; }
C++
[XmlElementAttribute(L"AreaSymbolization2D")]
public property AreaSymbolizationFillType Item sealed {
AreaSymbolizationFillType get();
void set(AreaSymbolizationFillType value);
}
J#
/** @attribute XmlElementAttribute("AreaSymbolization2D") */
/** property */
public AreaSymbolizationFillType get_Item();

/** property */
public void set_Item(AreaSymbolizationFillType value);
JScript
public function get Item() : AreaSymbolizationFillType

public function set Item(value : AreaSymbolizationFillType);

See Also

AreaRuleType Class


Label Property

AreaRuleType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As TextSymbolType
C#
public TextSymbolType Label { get; set; }
C++
public property TextSymbolType Label sealed {
TextSymbolType get();
void set(TextSymbolType value);
}
J#
/** property */
public TextSymbolType get_Label();

/** property */
public void set_Label(TextSymbolType value);
JScript
public function get Label() : TextSymbolType

public function set Label(value : TextSymbolType);

See Also

AreaRuleType Class


LegendLabel Property

AreaRuleType.LegendLabel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LegendLabel As String
C#
public string LegendLabel { get; set; }
C++
public property string LegendLabel sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LegendLabel();

/** property */
public void set_LegendLabel(string value);
JScript
public function get LegendLabel() : String

public function set LegendLabel(value : String);

See Also

AreaRuleType Class


AreaRuleTypeCollection Class

AreaRuleTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class AreaRuleTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class AreaRuleTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class AreaRuleTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class AreaRuleTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class AreaRuleTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.AreaRuleTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AreaRuleTypeCollection Members


AreaRuleTypeCollection Members

AreaRuleTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AreaRuleTypeCollection.

Public Constructors

 | Name | Description
Public method | AreaRuleTypeCollection | Initializes a new instance of the AreaRuleTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AreaRuleTypeCollection Class


AreaRuleTypeCollection Constructor

AreaRuleTypeCollection Constructor
[image]

Initializes a new instance of the AreaRuleTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AreaRuleTypeCollection()
C++
public:
AreaRuleTypeCollection() sealed
J#
public AreaRuleTypeCollection()
JScript
public function AreaRuleTypeCollection()

See Also

AreaRuleTypeCollection Class


Properties

AreaRuleTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

AreaRuleTypeCollection Class


Item Property

AreaRuleTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As AreaRuleType
C#
public AreaRuleType this[
int idx
] { get; set; }
C++
public property AreaRuleType default[int idx] sealed {
AreaRuleType get(int idx);
void set(int idx, AreaRuleType value);
}
J#
/** property */
public AreaRuleType get_Item(int idx);

/** property */
public void set_Item(int idx, AreaRuleType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

AreaRuleTypeCollection Class


Methods

AreaRuleTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AreaRuleTypeCollection Class


Add Method

AreaRuleTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As AreaRuleType _
) As Integer
C#
public int Add(
AreaRuleType value
)
C++
public:
int Add(
AreaRuleType value
) sealed
J#
public int Add(
AreaRuleType value
)
JScript
public function Add(
value : AreaRuleType
) : int

See Also

AreaRuleTypeCollection Class


AreaSymbolizationFillType Class

AreaSymbolizationFillType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AreaSymbolizationFillType
Inherits AreaSymbolizationType
C#
public class AreaSymbolizationFillType : AreaSymbolizationType
C++
ref class AreaSymbolizationFillType : AreaSymbolizationType
J#
public class AreaSymbolizationFillType extends AreaSymbolizationType
JScript
public class AreaSymbolizationFillType extends AreaSymbolizationType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.AreaSymbolizationType
OSGeo.MapGuide.MaestroAPI.AreaSymbolizationFillType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AreaSymbolizationFillType Members


AreaSymbolizationFillType Members

AreaSymbolizationFillType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AreaSymbolizationFillType.

Public Constructors

 | Name | Description
Public method | AreaSymbolizationFillType | Initializes a new instance of the AreaSymbolizationFillType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Fill |
Public property | Stroke |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AreaSymbolizationFillType Class


AreaSymbolizationFillType Constructor

AreaSymbolizationFillType Constructor
[image]

Initializes a new instance of the AreaSymbolizationFillType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AreaSymbolizationFillType()
C++
public:
AreaSymbolizationFillType() sealed
J#
public AreaSymbolizationFillType()
JScript
public function AreaSymbolizationFillType()

See Also

AreaSymbolizationFillType Class


Properties

AreaSymbolizationFillType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Fill |
Public property | Stroke |
Top

See Also

AreaSymbolizationFillType Class


ExtendedData1 Property

AreaSymbolizationFillType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

AreaSymbolizationFillType Class


Fill Property

AreaSymbolizationFillType.Fill Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Fill As FillType
C#
public FillType Fill { get; set; }
C++
public property FillType Fill sealed {
FillType get();
void set(FillType value);
}
J#
/** property */
public FillType get_Fill();

/** property */
public void set_Fill(FillType value);
JScript
public function get Fill() : FillType

public function set Fill(value : FillType);

See Also

AreaSymbolizationFillType Class


Stroke Property

AreaSymbolizationFillType.Stroke Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Stroke As StrokeType
C#
public StrokeType Stroke { get; set; }
C++
public property StrokeType Stroke sealed {
StrokeType get();
void set(StrokeType value);
}
J#
/** property */
public StrokeType get_Stroke();

/** property */
public void set_Stroke(StrokeType value);
JScript
public function get Stroke() : StrokeType

public function set Stroke(value : StrokeType);

See Also

AreaSymbolizationFillType Class


AreaSymbolizationType Class

AreaSymbolizationType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(AreaSymbolizationFillType))>
Public Class AreaSymbolizationType
C#
[XmlIncludeAttribute(typeof(AreaSymbolizationFillType))]
public class AreaSymbolizationType
C++
[XmlIncludeAttribute(typeof(AreaSymbolizationFillType))]
ref class AreaSymbolizationType
J#
/** @attribute XmlIncludeAttribute(typeof(AreaSymbolizationFillType)) */
public class AreaSymbolizationType
JScript
public
XmlIncludeAttribute(typeof(AreaSymbolizationFillType))
class AreaSymbolizationType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.AreaSymbolizationType
OSGeo.MapGuide.MaestroAPI.AreaSymbolizationFillType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AreaSymbolizationType Members


AreaSymbolizationType Members

AreaSymbolizationType Members
See Also Example Constructors Methods
[image]

The following tables list the members exposed by AreaSymbolizationType.

Public Constructors

 | Name | Description
Public method | AreaSymbolizationType | Initializes a new instance of the AreaSymbolizationType class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AreaSymbolizationType Class


AreaSymbolizationType Constructor

AreaSymbolizationType Constructor
[image]

Initializes a new instance of the AreaSymbolizationType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AreaSymbolizationType()
C++
public:
AreaSymbolizationType() sealed
J#
public AreaSymbolizationType()
JScript
public function AreaSymbolizationType()

See Also

AreaSymbolizationType Class


AreaTypeStyleType Class

AreaTypeStyleType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AreaTypeStyleType
C#
public class AreaTypeStyleType
C++
ref class AreaTypeStyleType
J#
public class AreaTypeStyleType
JScript
public class AreaTypeStyleType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.AreaTypeStyleType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AreaTypeStyleType Members


AreaTypeStyleType Members

AreaTypeStyleType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AreaTypeStyleType.

Public Constructors

 | Name | Description
Public method | AreaTypeStyleType | Initializes a new instance of the AreaTypeStyleType class.
Top

Public Properties

 | Name | Description
Public property | AreaRule |
Public property | ExtendedData1 |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AreaTypeStyleType Class


AreaTypeStyleType Constructor

AreaTypeStyleType Constructor
[image]

Initializes a new instance of the AreaTypeStyleType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AreaTypeStyleType()
C++
public:
AreaTypeStyleType() sealed
J#
public AreaTypeStyleType()
JScript
public function AreaTypeStyleType()

See Also

AreaTypeStyleType Class


Properties

AreaTypeStyleType Properties
[image]

Public Properties

 | Name | Description
Public property | AreaRule |
Public property | ExtendedData1 |
Top

See Also

AreaTypeStyleType Class


AreaRule Property

AreaTypeStyleType.AreaRule Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("AreaRule")>
Public Property AreaRule As AreaRuleTypeCollection
C#
[XmlElementAttribute("AreaRule")]
public AreaRuleTypeCollection AreaRule { get; set; }
C++
[XmlElementAttribute(L"AreaRule")]
public property AreaRuleTypeCollection AreaRule sealed {
AreaRuleTypeCollection get();
void set(AreaRuleTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("AreaRule") */
/** property */
public AreaRuleTypeCollection get_AreaRule();

/** property */
public void set_AreaRule(AreaRuleTypeCollection value);
JScript
public function get AreaRule() : AreaRuleTypeCollection

public function set AreaRule(value : AreaRuleTypeCollection);

See Also

AreaTypeStyleType Class


ExtendedData1 Property

AreaTypeStyleType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

AreaTypeStyleType Class


AreaUsage Class

AreaUsage Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AreaUsage
C#
public class AreaUsage
C++
ref class AreaUsage
J#
public class AreaUsage
JScript
public class AreaUsage

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.AreaUsage

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AreaUsage Members


AreaUsage Members

AreaUsage Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AreaUsage.

Public Constructors

 | Name | Description
Public method | AreaUsage | Initializes a new instance of the AreaUsage class.
Top

Public Properties

 | Name | Description
Public property | Angle |
Public property | AngleControl |
Public property | BufferWidth |
Public property | ClippingControl |
Public property | ExtendedData1 |
Public property | OriginControl |
Public property | OriginX |
Public property | OriginY |
Public property | RepeatX |
Public property | RepeatY |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AreaUsage Class


AreaUsage Constructor

AreaUsage Constructor
[image]

Initializes a new instance of the AreaUsage class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AreaUsage()
C++
public:
AreaUsage() sealed
J#
public AreaUsage()
JScript
public function AreaUsage()

See Also

AreaUsage Class


Properties

AreaUsage Properties
[image]

Public Properties

 | Name | Description
Public property | Angle |
Public property | AngleControl |
Public property | BufferWidth |
Public property | ClippingControl |
Public property | ExtendedData1 |
Public property | OriginControl |
Public property | OriginX |
Public property | OriginY |
Public property | RepeatX |
Public property | RepeatY |
Top

See Also

AreaUsage Class


Angle Property

AreaUsage.Angle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property Angle As String
C#
[DefaultValueAttribute("0.0")]
public string Angle { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string Angle sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_Angle();

/** property */
public void set_Angle(string value);
JScript
public function get Angle() : String

public function set Angle(value : String);

See Also

AreaUsage Class


AngleControl Property

AreaUsage.AngleControl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'FromAngle'")>
Public Property AngleControl As String
C#
[DefaultValueAttribute("'FromAngle'")]
public string AngleControl { get; set; }
C++
[DefaultValueAttribute(L"'FromAngle'")]
public property string AngleControl sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'FromAngle'") */
/** property */
public string get_AngleControl();

/** property */
public void set_AngleControl(string value);
JScript
public function get AngleControl() : String

public function set AngleControl(value : String);

See Also

AreaUsage Class


BufferWidth Property

AreaUsage.BufferWidth Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property BufferWidth As String
C#
[DefaultValueAttribute("0.0")]
public string BufferWidth { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string BufferWidth sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_BufferWidth();

/** property */
public void set_BufferWidth(string value);
JScript
public function get BufferWidth() : String

public function set BufferWidth(value : String);

See Also

AreaUsage Class


ClippingControl Property

AreaUsage.ClippingControl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'Clip'")>
Public Property ClippingControl As String
C#
[DefaultValueAttribute("'Clip'")]
public string ClippingControl { get; set; }
C++
[DefaultValueAttribute(L"'Clip'")]
public property string ClippingControl sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'Clip'") */
/** property */
public string get_ClippingControl();

/** property */
public void set_ClippingControl(string value);
JScript
public function get ClippingControl() : String

public function set ClippingControl(value : String);

See Also

AreaUsage Class


ExtendedData1 Property

AreaUsage.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

AreaUsage Class


OriginControl Property

AreaUsage.OriginControl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'Global'")>
Public Property OriginControl As String
C#
[DefaultValueAttribute("'Global'")]
public string OriginControl { get; set; }
C++
[DefaultValueAttribute(L"'Global'")]
public property string OriginControl sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'Global'") */
/** property */
public string get_OriginControl();

/** property */
public void set_OriginControl(string value);
JScript
public function get OriginControl() : String

public function set OriginControl(value : String);

See Also

AreaUsage Class


OriginX Property

AreaUsage.OriginX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property OriginX As String
C#
[DefaultValueAttribute("0.0")]
public string OriginX { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string OriginX sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_OriginX();

/** property */
public void set_OriginX(string value);
JScript
public function get OriginX() : String

public function set OriginX(value : String);

See Also

AreaUsage Class


OriginY Property

AreaUsage.OriginY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property OriginY As String
C#
[DefaultValueAttribute("0.0")]
public string OriginY { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string OriginY sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_OriginY();

/** property */
public void set_OriginY(string value);
JScript
public function get OriginY() : String

public function set OriginY(value : String);

See Also

AreaUsage Class


RepeatX Property

AreaUsage.RepeatX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property RepeatX As String
C#
[DefaultValueAttribute("0.0")]
public string RepeatX { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string RepeatX sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_RepeatX();

/** property */
public void set_RepeatX(string value);
JScript
public function get RepeatX() : String

public function set RepeatX(value : String);

See Also

AreaUsage Class


RepeatY Property

AreaUsage.RepeatY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property RepeatY As String
C#
[DefaultValueAttribute("0.0")]
public string RepeatY { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string RepeatY sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_RepeatY();

/** property */
public void set_RepeatY(string value);
JScript
public function get RepeatY() : String

public function set RepeatY(value : String);

See Also

AreaUsage Class


AttributeRelateType Class

AttributeRelateType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class AttributeRelateType
C#
public class AttributeRelateType
C++
ref class AttributeRelateType
J#
public class AttributeRelateType
JScript
public class AttributeRelateType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.AttributeRelateType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AttributeRelateType Members


AttributeRelateType Members

AttributeRelateType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AttributeRelateType.

Public Constructors

 | Name | Description
Public method | AttributeRelateType | Initializes a new instance of the AttributeRelateType class.
Top

Public Properties

 | Name | Description
Public property | AttributeClass |
Public property | AttributeNameDelimiter |
Public property | ForceOneToOne |
Public property | ForceOneToOneSpecified |
Public property | Name |
Public property | RelateProperty |
Public property | RelateType |
Public property | RelateTypeSpecified |
Public property | ResourceId |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AttributeRelateType Class


AttributeRelateType Constructor

AttributeRelateType Constructor
[image]

Initializes a new instance of the AttributeRelateType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AttributeRelateType()
C++
public:
AttributeRelateType() sealed
J#
public AttributeRelateType()
JScript
public function AttributeRelateType()

See Also

AttributeRelateType Class


Properties

AttributeRelateType Properties
[image]

Public Properties

 | Name | Description
Public property | AttributeClass |
Public property | AttributeNameDelimiter |
Public property | ForceOneToOne |
Public property | ForceOneToOneSpecified |
Public property | Name |
Public property | RelateProperty |
Public property | RelateType |
Public property | RelateTypeSpecified |
Public property | ResourceId |
Top

See Also

AttributeRelateType Class


AttributeClass Property

AttributeRelateType.AttributeClass Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property AttributeClass As String
C#
public string AttributeClass { get; set; }
C++
public property string AttributeClass sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AttributeClass();

/** property */
public void set_AttributeClass(string value);
JScript
public function get AttributeClass() : String

public function set AttributeClass(value : String);

See Also

AttributeRelateType Class


AttributeNameDelimiter Property

AttributeRelateType.AttributeNameDelimiter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property AttributeNameDelimiter As String
C#
public string AttributeNameDelimiter { get; set; }
C++
public property string AttributeNameDelimiter sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AttributeNameDelimiter();

/** property */
public void set_AttributeNameDelimiter(string value);
JScript
public function get AttributeNameDelimiter() : String

public function set AttributeNameDelimiter(value : String);

See Also

AttributeRelateType Class


ForceOneToOne Property

AttributeRelateType.ForceOneToOne Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ForceOneToOne As Boolean
C#
public bool ForceOneToOne { get; set; }
C++
public property bool ForceOneToOne sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ForceOneToOne();

/** property */
public void set_ForceOneToOne(bool value);
JScript
public function get ForceOneToOne() : bool

public function set ForceOneToOne(value : bool);

See Also

AttributeRelateType Class


ForceOneToOneSpecified Property

AttributeRelateType.ForceOneToOneSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ForceOneToOneSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ForceOneToOneSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ForceOneToOneSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ForceOneToOneSpecified();

/** property */
public void set_ForceOneToOneSpecified(bool value);
JScript
public function get ForceOneToOneSpecified() : bool

public function set ForceOneToOneSpecified(value : bool);

See Also

AttributeRelateType Class


Name Property

AttributeRelateType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

AttributeRelateType Class


RelateProperty Property

AttributeRelateType.RelateProperty Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("RelateProperty")>
Public Property RelateProperty As RelatePropertyTypeCollection
C#
[XmlElementAttribute("RelateProperty")]
public RelatePropertyTypeCollection RelateProperty { get; set; }
C++
[XmlElementAttribute(L"RelateProperty")]
public property RelatePropertyTypeCollection RelateProperty sealed {
RelatePropertyTypeCollection get();
void set(RelatePropertyTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("RelateProperty") */
/** property */
public RelatePropertyTypeCollection get_RelateProperty();

/** property */
public void set_RelateProperty(RelatePropertyTypeCollection value);
JScript
public function get RelateProperty() : RelatePropertyTypeCollection

public function set RelateProperty(value : RelatePropertyTypeCollection);

See Also

AttributeRelateType Class


RelateType Property

AttributeRelateType.RelateType Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property RelateType As RelateTypeEnum
C#
public RelateTypeEnum RelateType { get; set; }
C++
public property RelateTypeEnum RelateType sealed {
RelateTypeEnum get();
void set(RelateTypeEnum value);
}
J#
/** property */
public RelateTypeEnum get_RelateType();

/** property */
public void set_RelateType(RelateTypeEnum value);
JScript
public function get RelateType() : RelateTypeEnum

public function set RelateType(value : RelateTypeEnum);

See Also

AttributeRelateType Class


RelateTypeSpecified Property

AttributeRelateType.RelateTypeSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property RelateTypeSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool RelateTypeSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool RelateTypeSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_RelateTypeSpecified();

/** property */
public void set_RelateTypeSpecified(bool value);
JScript
public function get RelateTypeSpecified() : bool

public function set RelateTypeSpecified(value : bool);

See Also

AttributeRelateType Class


ResourceId Property

AttributeRelateType.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceId As String
C#
public string ResourceId { get; set; }
C++
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

AttributeRelateType Class


AttributeRelateTypeCollection Class

AttributeRelateTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class AttributeRelateTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class AttributeRelateTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class AttributeRelateTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class AttributeRelateTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class AttributeRelateTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.AttributeRelateTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

AttributeRelateTypeCollection Members


AttributeRelateTypeCollection Members

AttributeRelateTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by AttributeRelateTypeCollection.

Public Constructors

 | Name | Description
Public method | AttributeRelateTypeCollection | Initializes a new instance of the AttributeRelateTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AttributeRelateTypeCollection Class


AttributeRelateTypeCollection Constructor

AttributeRelateTypeCollection Constructor
[image]

Initializes a new instance of the AttributeRelateTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public AttributeRelateTypeCollection()
C++
public:
AttributeRelateTypeCollection() sealed
J#
public AttributeRelateTypeCollection()
JScript
public function AttributeRelateTypeCollection()

See Also

AttributeRelateTypeCollection Class


Properties

AttributeRelateTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

AttributeRelateTypeCollection Class


Item Property

AttributeRelateTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As AttributeRelateType
C#
public AttributeRelateType this[
int idx
] { get; set; }
C++
public property AttributeRelateType default[int idx] sealed {
AttributeRelateType get(int idx);
void set(int idx, AttributeRelateType value);
}
J#
/** property */
public AttributeRelateType get_Item(int idx);

/** property */
public void set_Item(int idx, AttributeRelateType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

AttributeRelateTypeCollection Class


Methods

AttributeRelateTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

AttributeRelateTypeCollection Class


Add Method

AttributeRelateTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As AttributeRelateType _
) As Integer
C#
public int Add(
AttributeRelateType value
)
C++
public:
int Add(
AttributeRelateType value
) sealed
J#
public int Add(
AttributeRelateType value
)
JScript
public function Add(
value : AttributeRelateType
) : int

See Also

AttributeRelateTypeCollection Class


BackgroundStyleType Enumeration

BackgroundStyleType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum BackgroundStyleType
C#
public enum BackgroundStyleType
C++
public enum class BackgroundStyleType
J#
public enum BackgroundStyleType
JScript
public enum BackgroundStyleType

Members

Member Name | Description
Transparent |
Opaque |
Ghosted |

See Also


BaseLayerDefinitionType Class

BaseLayerDefinitionType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(DrawingLayerDefinitionType)), _
XmlIncludeAttribute(GetType(GridLayerDefinitionType)), _
XmlIncludeAttribute(GetType(VectorLayerDefinitionType))>
Public Class BaseLayerDefinitionType
C#
[XmlIncludeAttribute(typeof(DrawingLayerDefinitionType))]
[XmlIncludeAttribute(typeof(GridLayerDefinitionType))]
[XmlIncludeAttribute(typeof(VectorLayerDefinitionType))]
public class BaseLayerDefinitionType
C++
[XmlIncludeAttribute(typeof(DrawingLayerDefinitionType))]
[XmlIncludeAttribute(typeof(GridLayerDefinitionType))]
[XmlIncludeAttribute(typeof(VectorLayerDefinitionType))]
ref class BaseLayerDefinitionType
J#
/** @attribute XmlIncludeAttribute(typeof(DrawingLayerDefinitionType)) */
/** @attribute XmlIncludeAttribute(typeof(GridLayerDefinitionType)) */
/** @attribute XmlIncludeAttribute(typeof(VectorLayerDefinitionType)) */
public class BaseLayerDefinitionType
JScript
public
XmlIncludeAttribute(typeof(DrawingLayerDefinitionType))
XmlIncludeAttribute(typeof(GridLayerDefinitionType))
XmlIncludeAttribute(typeof(VectorLayerDefinitionType))
class BaseLayerDefinitionType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.BaseLayerDefinitionType
OSGeo.MapGuide.MaestroAPI.DrawingLayerDefinitionType
OSGeo.MapGuide.MaestroAPI.GridLayerDefinitionType
OSGeo.MapGuide.MaestroAPI.VectorLayerDefinitionType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

BaseLayerDefinitionType Members


BaseLayerDefinitionType Members

BaseLayerDefinitionType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by BaseLayerDefinitionType.

Public Constructors

 | Name | Description
Public method | BaseLayerDefinitionType | Initializes a new instance of the BaseLayerDefinitionType class.
Top

Public Properties

 | Name | Description
Public property | Opacity |
Public property | OpacitySpecified |
Public property | ResourceId |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BaseLayerDefinitionType Class


BaseLayerDefinitionType Constructor

BaseLayerDefinitionType Constructor
[image]

Initializes a new instance of the BaseLayerDefinitionType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BaseLayerDefinitionType()
C++
public:
BaseLayerDefinitionType() sealed
J#
public BaseLayerDefinitionType()
JScript
public function BaseLayerDefinitionType()

See Also

BaseLayerDefinitionType Class


Properties

BaseLayerDefinitionType Properties
[image]

Public Properties

 | Name | Description
Public property | Opacity |
Public property | OpacitySpecified |
Public property | ResourceId |
Top

See Also

BaseLayerDefinitionType Class


Opacity Property

BaseLayerDefinitionType.Opacity Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Opacity As Double
C#
public double Opacity { get; set; }
C++
public property double Opacity sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Opacity();

/** property */
public void set_Opacity(double value);
JScript
public function get Opacity() : double

public function set Opacity(value : double);

See Also

BaseLayerDefinitionType Class


OpacitySpecified Property

BaseLayerDefinitionType.OpacitySpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property OpacitySpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool OpacitySpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool OpacitySpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_OpacitySpecified();

/** property */
public void set_OpacitySpecified(bool value);
JScript
public function get OpacitySpecified() : bool

public function set OpacitySpecified(value : bool);

See Also

BaseLayerDefinitionType Class


ResourceId Property

BaseLayerDefinitionType.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceId As String
C#
public string ResourceId { get; set; }
C++
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

BaseLayerDefinitionType Class


BaseMapLayerGroupCommonType Class

BaseMapLayerGroupCommonType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class BaseMapLayerGroupCommonType
Inherits MapLayerGroupCommonType
C#
public class BaseMapLayerGroupCommonType : MapLayerGroupCommonType
C++
ref class BaseMapLayerGroupCommonType : MapLayerGroupCommonType
J#
public class BaseMapLayerGroupCommonType extends MapLayerGroupCommonType
JScript
public class BaseMapLayerGroupCommonType extends MapLayerGroupCommonType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.MapLayerGroupCommonType
OSGeo.MapGuide.MaestroAPI.BaseMapLayerGroupCommonType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

BaseMapLayerGroupCommonType Members


BaseMapLayerGroupCommonType Members

BaseMapLayerGroupCommonType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by BaseMapLayerGroupCommonType.

Public Constructors

 | Name | Description
Public method | BaseMapLayerGroupCommonType | Initializes a new instance of the BaseMapLayerGroupCommonType class.
Top

Public Properties

 | Name | Description
Public property | BaseMapLayer |
Public property | ExpandInLegend | Gets or sets a value indicating if this groups layers are displayed in the map legend (inherited from MapLayerGroupCommonType)
Public property | LegendLabel | Gets or sets the label to use for this group (inherited from MapLayerGroupCommonType)
Public property | Name | Gets or sets the name of the group (inherited from MapLayerGroupCommonType)
Public property | ShowInLegend | Gets or sets a value indicating if this group is displayed in the map legend (inherited from MapLayerGroupCommonType)
Public property | Visible | Gets or set the group visibility (inherited from MapLayerGroupCommonType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BaseMapLayerGroupCommonType Class


BaseMapLayerGroupCommonType Constructor

BaseMapLayerGroupCommonType Constructor
[image]

Initializes a new instance of the BaseMapLayerGroupCommonType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BaseMapLayerGroupCommonType()
C++
public:
BaseMapLayerGroupCommonType() sealed
J#
public BaseMapLayerGroupCommonType()
JScript
public function BaseMapLayerGroupCommonType()

See Also

BaseMapLayerGroupCommonType Class


Properties

BaseMapLayerGroupCommonType Properties
[image]

Public Properties

 | Name | Description
Public property | BaseMapLayer |
Public property | ExpandInLegend | Gets or sets a value indicating if this groups layers are displayed in the map legend (inherited from MapLayerGroupCommonType)
Public property | LegendLabel | Gets or sets the label to use for this group (inherited from MapLayerGroupCommonType)
Public property | Name | Gets or sets the name of the group (inherited from MapLayerGroupCommonType)
Public property | ShowInLegend | Gets or sets a value indicating if this group is displayed in the map legend (inherited from MapLayerGroupCommonType)
Public property | Visible | Gets or set the group visibility (inherited from MapLayerGroupCommonType)
Top

See Also

BaseMapLayerGroupCommonType Class


BaseMapLayer Property

BaseMapLayerGroupCommonType.BaseMapLayer Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("BaseMapLayer")>
Public Property BaseMapLayer As BaseMapLayerTypeCollection
C#
[XmlElementAttribute("BaseMapLayer")]
public BaseMapLayerTypeCollection BaseMapLayer { get; set; }
C++
[XmlElementAttribute(L"BaseMapLayer")]
public property BaseMapLayerTypeCollection BaseMapLayer sealed {
BaseMapLayerTypeCollection get();
void set(BaseMapLayerTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("BaseMapLayer") */
/** property */
public BaseMapLayerTypeCollection get_BaseMapLayer();

/** property */
public void set_BaseMapLayer(BaseMapLayerTypeCollection value);
JScript
public function get BaseMapLayer() : BaseMapLayerTypeCollection

public function set BaseMapLayer(value : BaseMapLayerTypeCollection);

See Also

BaseMapLayerGroupCommonType Class


BaseMapLayerGroupCommonTypeCollection Class

BaseMapLayerGroupCommonTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class BaseMapLayerGroupCommonTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class BaseMapLayerGroupCommonTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class BaseMapLayerGroupCommonTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class BaseMapLayerGroupCommonTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class BaseMapLayerGroupCommonTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.BaseMapLayerGroupCommonTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

BaseMapLayerGroupCommonTypeCollection Members


BaseMapLayerGroupCommonTypeCollection Members

BaseMapLayerGroupCommonTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by BaseMapLayerGroupCommonTypeCollection.

Public Constructors

 | Name | Description
Public method | BaseMapLayerGroupCommonTypeCollection | Initializes a new instance of the BaseMapLayerGroupCommonTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BaseMapLayerGroupCommonTypeCollection Class


BaseMapLayerGroupCommonTypeCollection Constructor

BaseMapLayerGroupCommonTypeCollection Constructor
[image]

Initializes a new instance of the BaseMapLayerGroupCommonTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BaseMapLayerGroupCommonTypeCollection()
C++
public:
BaseMapLayerGroupCommonTypeCollection() sealed
J#
public BaseMapLayerGroupCommonTypeCollection()
JScript
public function BaseMapLayerGroupCommonTypeCollection()

See Also

BaseMapLayerGroupCommonTypeCollection Class


Properties

BaseMapLayerGroupCommonTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

BaseMapLayerGroupCommonTypeCollection Class


Item Property

BaseMapLayerGroupCommonTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As BaseMapLayerGroupCommonType
C#
public BaseMapLayerGroupCommonType this[
int idx
] { get; set; }
C++
public property BaseMapLayerGroupCommonType default[int idx] sealed {
BaseMapLayerGroupCommonType get(int idx);
void set(int idx, BaseMapLayerGroupCommonType value);
}
J#
/** property */
public BaseMapLayerGroupCommonType get_Item(int idx);

/** property */
public void set_Item(int idx, BaseMapLayerGroupCommonType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

BaseMapLayerGroupCommonTypeCollection Class


Methods

BaseMapLayerGroupCommonTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BaseMapLayerGroupCommonTypeCollection Class


Add Method

BaseMapLayerGroupCommonTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As BaseMapLayerGroupCommonType _
) As Integer
C#
public int Add(
BaseMapLayerGroupCommonType value
)
C++
public:
int Add(
BaseMapLayerGroupCommonType value
) sealed
J#
public int Add(
BaseMapLayerGroupCommonType value
)
JScript
public function Add(
value : BaseMapLayerGroupCommonType
) : int

See Also

BaseMapLayerGroupCommonTypeCollection Class


BaseMapLayerType Class

BaseMapLayerType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(MapLayerType))>
Public Class BaseMapLayerType
C#
[XmlIncludeAttribute(typeof(MapLayerType))]
public class BaseMapLayerType
C++
[XmlIncludeAttribute(typeof(MapLayerType))]
ref class BaseMapLayerType
J#
/** @attribute XmlIncludeAttribute(typeof(MapLayerType)) */
public class BaseMapLayerType
JScript
public
XmlIncludeAttribute(typeof(MapLayerType))
class BaseMapLayerType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.BaseMapLayerType
OSGeo.MapGuide.MaestroAPI.MapLayerType
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMapGroup

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

BaseMapLayerType Members


BaseMapLayerType Members

BaseMapLayerType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by BaseMapLayerType.

Public Constructors

 | Name | Description
Public method | BaseMapLayerType | Initializes a new instance of the BaseMapLayerType class.
Top

Public Properties

 | Name | Description
Public property | ExpandInLegend |
Public property | LegendLabel |
Public property | Name |
Public property | Parent |
Public property | ResourceId |
Public property | Selectable |
Public property | ShowInLegend |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BaseMapLayerType Class


BaseMapLayerType Constructor

BaseMapLayerType Constructor
[image]

Initializes a new instance of the BaseMapLayerType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BaseMapLayerType()
C++
public:
BaseMapLayerType() sealed
J#
public BaseMapLayerType()
JScript
public function BaseMapLayerType()

See Also

BaseMapLayerType Class


Properties

BaseMapLayerType Properties
[image]

Public Properties

 | Name | Description
Public property | ExpandInLegend |
Public property | LegendLabel |
Public property | Name |
Public property | Parent |
Public property | ResourceId |
Public property | Selectable |
Public property | ShowInLegend |
Top

See Also

BaseMapLayerType Class


ExpandInLegend Property

BaseMapLayerType.ExpandInLegend Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpandInLegend As Boolean
C#
public bool ExpandInLegend { get; set; }
C++
public property bool ExpandInLegend sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ExpandInLegend();

/** property */
public void set_ExpandInLegend(bool value);
JScript
public function get ExpandInLegend() : bool

public function set ExpandInLegend(value : bool);

See Also

BaseMapLayerType Class


LegendLabel Property

BaseMapLayerType.LegendLabel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LegendLabel As String
C#
public string LegendLabel { get; set; }
C++
public property string LegendLabel sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LegendLabel();

/** property */
public void set_LegendLabel(string value);
JScript
public function get LegendLabel() : String

public function set LegendLabel(value : String);

See Also

BaseMapLayerType Class


Name Property

BaseMapLayerType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

BaseMapLayerType Class


Parent Property

BaseMapLayerType.Parent Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property Parent As MapDefinition
C#
[XmlIgnoreAttribute]
public MapDefinition Parent { get; set; }
C++
[XmlIgnoreAttribute]
public property MapDefinition Parent sealed {
MapDefinition get();
void set(MapDefinition value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public MapDefinition get_Parent();

/** property */
public void set_Parent(MapDefinition value);
JScript
public function get Parent() : MapDefinition

public function set Parent(value : MapDefinition);

See Also

BaseMapLayerType Class


ResourceId Property

BaseMapLayerType.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceId As String
C#
public string ResourceId { get; set; }
C++
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

BaseMapLayerType Class


Selectable Property

BaseMapLayerType.Selectable Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Selectable As Boolean
C#
public virtual bool Selectable { get; set; }
C++
public virtual property bool Selectable {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Selectable();

/** property */
public void set_Selectable(bool value);
JScript
public function get Selectable() : bool

public function set Selectable(value : bool);

See Also

BaseMapLayerType Class


ShowInLegend Property

BaseMapLayerType.ShowInLegend Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowInLegend As Boolean
C#
public bool ShowInLegend { get; set; }
C++
public property bool ShowInLegend sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowInLegend();

/** property */
public void set_ShowInLegend(bool value);
JScript
public function get ShowInLegend() : bool

public function set ShowInLegend(value : bool);

See Also

BaseMapLayerType Class


BaseMapLayerTypeCollection Class

BaseMapLayerTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class BaseMapLayerTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class BaseMapLayerTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class BaseMapLayerTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class BaseMapLayerTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class BaseMapLayerTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.BaseMapLayerTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

BaseMapLayerTypeCollection Members


BaseMapLayerTypeCollection Members

BaseMapLayerTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by BaseMapLayerTypeCollection.

Public Constructors

 | Name | Description
Public method | BaseMapLayerTypeCollection | Initializes a new instance of the BaseMapLayerTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BaseMapLayerTypeCollection Class


BaseMapLayerTypeCollection Constructor

BaseMapLayerTypeCollection Constructor
[image]

Initializes a new instance of the BaseMapLayerTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BaseMapLayerTypeCollection()
C++
public:
BaseMapLayerTypeCollection() sealed
J#
public BaseMapLayerTypeCollection()
JScript
public function BaseMapLayerTypeCollection()

See Also

BaseMapLayerTypeCollection Class


Properties

BaseMapLayerTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

BaseMapLayerTypeCollection Class


Item Property

BaseMapLayerTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As BaseMapLayerType
C#
public BaseMapLayerType this[
int idx
] { get; set; }
C++
public property BaseMapLayerType default[int idx] sealed {
BaseMapLayerType get(int idx);
void set(int idx, BaseMapLayerType value);
}
J#
/** property */
public BaseMapLayerType get_Item(int idx);

/** property */
public void set_Item(int idx, BaseMapLayerType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

BaseMapLayerTypeCollection Class


Methods

BaseMapLayerTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BaseMapLayerTypeCollection Class


Add Method

BaseMapLayerTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As BaseMapLayerType _
) As Integer
C#
public int Add(
BaseMapLayerType value
)
C++
public:
int Add(
BaseMapLayerType value
) sealed
J#
public int Add(
BaseMapLayerType value
)
JScript
public function Add(
value : BaseMapLayerType
) : int

See Also

BaseMapLayerTypeCollection Class


BasicCommandActionType Enumeration

BasicCommandActionType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum BasicCommandActionType
C#
public enum BasicCommandActionType
C++
public enum class BasicCommandActionType
J#
public enum BasicCommandActionType
JScript
public enum BasicCommandActionType

Members

Member Name | Description
Pan |
PanUp |
PanDown |
PanRight |
PanLeft |
Zoom |
ZoomIn |
ZoomOut |
ZoomRectangle |
ZoomToSelection |
FitToWindow |
PreviousView |
NextView |
RestoreView |
Select |
SelectRadius |
SelectPolygon |
ClearSelection |
Refresh |
CopyMap |
About |

See Also


BasicCommandType Class

BasicCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class BasicCommandType
Inherits CommandType
C#
public class BasicCommandType : CommandType
C++
ref class BasicCommandType : CommandType
J#
public class BasicCommandType extends CommandType
JScript
public class BasicCommandType extends CommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.BasicCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

BasicCommandType Members


BasicCommandType Members

BasicCommandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by BasicCommandType.

Public Constructors

 | Name | Description
Public method | BasicCommandType | Initializes a new instance of the BasicCommandType class.
Top

Public Properties

 | Name | Description
Public property | Action |
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BasicCommandType Class


BasicCommandType Constructor

BasicCommandType Constructor
[image]

Initializes a new instance of the BasicCommandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BasicCommandType()
C++
public:
BasicCommandType() sealed
J#
public BasicCommandType()
JScript
public function BasicCommandType()

See Also

BasicCommandType Class


Properties

BasicCommandType Properties
[image]

Public Properties

 | Name | Description
Public property | Action |
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

See Also

BasicCommandType Class


Action Property

BasicCommandType.Action Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Action As BasicCommandActionType
C#
public BasicCommandActionType Action { get; set; }
C++
public property BasicCommandActionType Action sealed {
BasicCommandActionType get();
void set(BasicCommandActionType value);
}
J#
/** property */
public BasicCommandActionType get_Action();

/** property */
public void set_Action(BasicCommandActionType value);
JScript
public function get Action() : BasicCommandActionType

public function set Action(value : BasicCommandActionType);

See Also

BasicCommandType Class


BlockSymbolType Class

BlockSymbolType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class BlockSymbolType
Inherits SymbolType
C#
public class BlockSymbolType : SymbolType
C++
ref class BlockSymbolType : SymbolType
J#
public class BlockSymbolType extends SymbolType
JScript
public class BlockSymbolType extends SymbolType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolType
OSGeo.MapGuide.MaestroAPI.BlockSymbolType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

BlockSymbolType Members


BlockSymbolType Members

BlockSymbolType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by BlockSymbolType.

Public Constructors

 | Name | Description
Public method | BlockSymbolType | Initializes a new instance of the BlockSymbolType class.
Top

Public Properties

 | Name | Description
Public property | BlockColor |
Public property | BlockName |
Public property | DrawingName |
Public property | ExtendedData1 |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | LayerColor |
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | Unit | (inherited from SymbolType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BlockSymbolType Class


BlockSymbolType Constructor

BlockSymbolType Constructor
[image]

Initializes a new instance of the BlockSymbolType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BlockSymbolType()
C++
public:
BlockSymbolType() sealed
J#
public BlockSymbolType()
JScript
public function BlockSymbolType()

See Also

BlockSymbolType Class


Properties

BlockSymbolType Properties
[image]

Public Properties

 | Name | Description
Public property | BlockColor |
Public property | BlockName |
Public property | DrawingName |
Public property | ExtendedData1 |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | LayerColor |
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | Unit | (inherited from SymbolType)
Top

See Also

BlockSymbolType Class


BlockColor Property

BlockSymbolType.BlockColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property BlockColor As String
C#
public string BlockColor { get; set; }
C++
public property string BlockColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_BlockColor();

/** property */
public void set_BlockColor(string value);
JScript
public function get BlockColor() : String

public function set BlockColor(value : String);

See Also

BlockSymbolType Class


BlockName Property

BlockSymbolType.BlockName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property BlockName As String
C#
public string BlockName { get; set; }
C++
public property string BlockName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_BlockName();

/** property */
public void set_BlockName(string value);
JScript
public function get BlockName() : String

public function set BlockName(value : String);

See Also

BlockSymbolType Class


DrawingName Property

BlockSymbolType.DrawingName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DrawingName As String
C#
public string DrawingName { get; set; }
C++
public property string DrawingName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DrawingName();

/** property */
public void set_DrawingName(string value);
JScript
public function get DrawingName() : String

public function set DrawingName(value : String);

See Also

BlockSymbolType Class


ExtendedData1 Property

BlockSymbolType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

BlockSymbolType Class


LayerColor Property

BlockSymbolType.LayerColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LayerColor As String
C#
public string LayerColor { get; set; }
C++
public property string LayerColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LayerColor();

/** property */
public void set_LayerColor(string value);
JScript
public function get LayerColor() : String

public function set LayerColor(value : String);

See Also

BlockSymbolType Class


Box2DType Class

Box2DType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class Box2DType
C#
public class Box2DType
C++
ref class Box2DType
J#
public class Box2DType
JScript
public class Box2DType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.Box2DType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Box2DType Members


Box2DType Members

Box2DType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by Box2DType.

Public Constructors

 | Name | Description
Public method | Box2DType | Initializes a new instance of the Box2DType class.
Top

Public Properties

 | Name | Description
Public property | MaxX |
Public property | MaxY |
Public property | MinX |
Public property | MinY |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Box2DType Class


Box2DType Constructor

Box2DType Constructor
[image]

Initializes a new instance of the Box2DType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Box2DType()
C++
public:
Box2DType() sealed
J#
public Box2DType()
JScript
public function Box2DType()

See Also

Box2DType Class


Properties

Box2DType Properties
[image]

Public Properties

 | Name | Description
Public property | MaxX |
Public property | MaxY |
Public property | MinX |
Public property | MinY |
Top

See Also

Box2DType Class


MaxX Property

Box2DType.MaxX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxX As Double
C#
public double MaxX { get; set; }
C++
public property double MaxX sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MaxX();

/** property */
public void set_MaxX(double value);
JScript
public function get MaxX() : double

public function set MaxX(value : double);

See Also

Box2DType Class


MaxY Property

Box2DType.MaxY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxY As Double
C#
public double MaxY { get; set; }
C++
public property double MaxY sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MaxY();

/** property */
public void set_MaxY(double value);
JScript
public function get MaxY() : double

public function set MaxY(value : double);

See Also

Box2DType Class


MinX Property

Box2DType.MinX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MinX As Double
C#
public double MinX { get; set; }
C++
public property double MinX sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MinX();

/** property */
public void set_MinX(double value);
JScript
public function get MinX() : double

public function set MinX(value : double);

See Also

Box2DType Class


MinY Property

Box2DType.MinY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MinY As Double
C#
public double MinY { get; set; }
C++
public property double MinY sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MinY();

/** property */
public void set_MinY(double value);
JScript
public function get MinY() : double

public function set MinY(value : double);

See Also

Box2DType Class


BufferCommandType Class

BufferCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class BufferCommandType
Inherits TargetedCommandType
C#
public class BufferCommandType : TargetedCommandType
C++
ref class BufferCommandType : TargetedCommandType
J#
public class BufferCommandType extends TargetedCommandType
JScript
public class BufferCommandType extends TargetedCommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.TargetedCommandType
OSGeo.MapGuide.MaestroAPI.BufferCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

BufferCommandType Members


BufferCommandType Members

BufferCommandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by BufferCommandType.

Public Constructors

 | Name | Description
Public method | BufferCommandType | Initializes a new instance of the BufferCommandType class.
Top

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | Target | (inherited from TargetedCommandType)
Public property | TargetFrame | (inherited from TargetedCommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BufferCommandType Class


BufferCommandType Constructor

BufferCommandType Constructor
[image]

Initializes a new instance of the BufferCommandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public BufferCommandType()
C++
public:
BufferCommandType() sealed
J#
public BufferCommandType()
JScript
public function BufferCommandType()

See Also

BufferCommandType Class


CalculatedPropertyType Class

CalculatedPropertyType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class CalculatedPropertyType
C#
public class CalculatedPropertyType
C++
ref class CalculatedPropertyType
J#
public class CalculatedPropertyType
JScript
public class CalculatedPropertyType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CalculatedPropertyType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CalculatedPropertyType Members


CalculatedPropertyType Members

CalculatedPropertyType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by CalculatedPropertyType.

Public Constructors

 | Name | Description
Public method | CalculatedPropertyType | Initializes a new instance of the CalculatedPropertyType class.
Top

Public Properties

 | Name | Description
Public property | Expression |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CalculatedPropertyType Class


CalculatedPropertyType Constructor

CalculatedPropertyType Constructor
[image]

Initializes a new instance of the CalculatedPropertyType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CalculatedPropertyType()
C++
public:
CalculatedPropertyType() sealed
J#
public CalculatedPropertyType()
JScript
public function CalculatedPropertyType()

See Also

CalculatedPropertyType Class


Properties

CalculatedPropertyType Properties
[image]

Public Properties

 | Name | Description
Public property | Expression |
Public property | Name |
Top

See Also

CalculatedPropertyType Class


Expression Property

CalculatedPropertyType.Expression Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Expression As String
C#
public string Expression { get; set; }
C++
public property string Expression sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Expression();

/** property */
public void set_Expression(string value);
JScript
public function get Expression() : String

public function set Expression(value : String);

See Also

CalculatedPropertyType Class


Name Property

CalculatedPropertyType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

CalculatedPropertyType Class


CalculatedPropertyTypeCollection Class

CalculatedPropertyTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class CalculatedPropertyTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class CalculatedPropertyTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class CalculatedPropertyTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class CalculatedPropertyTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class CalculatedPropertyTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.CalculatedPropertyTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CalculatedPropertyTypeCollection Members


CalculatedPropertyTypeCollection Members

CalculatedPropertyTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by CalculatedPropertyTypeCollection.

Public Constructors

 | Name | Description
Public method | CalculatedPropertyTypeCollection | Initializes a new instance of the CalculatedPropertyTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CalculatedPropertyTypeCollection Class


CalculatedPropertyTypeCollection Constructor

CalculatedPropertyTypeCollection Constructor
[image]

Initializes a new instance of the CalculatedPropertyTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CalculatedPropertyTypeCollection()
C++
public:
CalculatedPropertyTypeCollection() sealed
J#
public CalculatedPropertyTypeCollection()
JScript
public function CalculatedPropertyTypeCollection()

See Also

CalculatedPropertyTypeCollection Class


Properties

CalculatedPropertyTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

CalculatedPropertyTypeCollection Class


Item Property

CalculatedPropertyTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As CalculatedPropertyType
C#
public CalculatedPropertyType this[
int idx
] { get; set; }
C++
public property CalculatedPropertyType default[int idx] sealed {
CalculatedPropertyType get(int idx);
void set(int idx, CalculatedPropertyType value);
}
J#
/** property */
public CalculatedPropertyType get_Item(int idx);

/** property */
public void set_Item(int idx, CalculatedPropertyType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

CalculatedPropertyTypeCollection Class


Methods

CalculatedPropertyTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CalculatedPropertyTypeCollection Class


Add Method

CalculatedPropertyTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As CalculatedPropertyType _
) As Integer
C#
public int Add(
CalculatedPropertyType value
)
C++
public:
int Add(
CalculatedPropertyType value
) sealed
J#
public int Add(
CalculatedPropertyType value
)
JScript
public function Add(
value : CalculatedPropertyType
) : int

See Also

CalculatedPropertyTypeCollection Class


Change Class

Change Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class Change
C#
public class Change
C++
ref class Change
J#
public class Change
JScript
public class Change

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.Change

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Change Members


Change Members

Change Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by Change.

Public Constructors

Name | Description
Change | Overloaded. Initializes a new instance of the Change class.
Top

Public Properties

 | Name | Description
Public property | Params |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Change | Overloaded. Initializes a new instance of the Change class.
Top

See Also

Change Class


Change Constructor

Change Constructor

Initializes a new instance of the Change class.

Overload List

 | Name | Description
Public method | Change | Initializes a new instance of the Change class.
Public method | Change (Change.ChangeType, String) |

See Also

Change Class


Change Constructor ()

Change Constructor ()
See Also Example
[image]

Initializes a new instance of the Change class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Change()
C++
public:
Change() sealed
J#
public Change()
JScript
public function Change()

See Also

Change Class
Change Constructor Overload List


Change Constructor (Change.ChangeType, String)

Change Constructor (Change.ChangeType, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal type As Change.ChangeType, _
ByVal param As String _
)
C#
public Change(
Change.ChangeType type,
string param
)
C++
public:
Change(
Change.ChangeType type,
String param
) sealed
J#
public Change(
Change.ChangeType type,
string param
)
JScript
public function Change(
type : Change.ChangeType,
param : String
)

See Also

Change Class
Change Constructor Overload List


Properties

Change Properties
[image]

Public Properties

 | Name | Description
Public property | Params |
Public property | Type |
Top

See Also

Change Class


Params Property

Change.Params Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Params As String
C#
public string Params { get; }
C++
public property string Params sealed {
String get();
}
J#
/** property */
public string get_Params();
JScript
public function get Params() : String

See Also

Change Class


Type Property

Change.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As Change.ChangeType
C#
public Change.ChangeType Type { get; }
C++
public property Change.ChangeType Type sealed {
Change.ChangeType get();
}
J#
/** property */
public Change.ChangeType get_Type();
JScript
public function get Type() : Change.ChangeType

See Also

Change Class


Change.ChangeType Enumeration

Change.ChangeType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum Change.ChangeType
C#
public enum Change.ChangeType
C++
public enum class Change.ChangeType
J#
public enum Change.ChangeType
JScript
public enum Change.ChangeType

Members

Member Name | Description
removed |
added |
visibilityChanged |
displayInLegendChanged |
legendLabelChanged |
parentChanged |
selectabilityChanged |
definitionChanged |

See Also


ChangeList Class

ChangeList Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ChangeList
C#
public class ChangeList
C++
ref class ChangeList
J#
public class ChangeList
JScript
public class ChangeList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ChangeList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ChangeList Members


ChangeList Members

ChangeList Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by ChangeList.

Public Constructors

Name | Description
ChangeList | Overloaded. Initializes a new instance of the ChangeList class.
Top

Public Properties

 | Name | Description
Public property | Changes |
Public property | IsLayer |
Public property | ObjectId |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ChangeList | Overloaded. Initializes a new instance of the ChangeList class.
Top

See Also

ChangeList Class


ChangeList Constructor

ChangeList Constructor

Initializes a new instance of the ChangeList class.

Overload List

 | Name | Description
Public method | ChangeList | Initializes a new instance of the ChangeList class.
Public method | ChangeList (String, Boolean) |

See Also

ChangeList Class


ChangeList Constructor ()

ChangeList Constructor ()
See Also Example
[image]

Initializes a new instance of the ChangeList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ChangeList()
C++
public:
ChangeList() sealed
J#
public ChangeList()
JScript
public function ChangeList()

See Also

ChangeList Class
ChangeList Constructor Overload List


ChangeList Constructor (String, Boolean)

ChangeList Constructor (String, Boolean)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal objectId As String, _
ByVal isLayer As Boolean _
)
C#
public ChangeList(
string objectId,
bool isLayer
)
C++
public:
ChangeList(
String objectId,
bool isLayer
) sealed
J#
public ChangeList(
string objectId,
bool isLayer
)
JScript
public function ChangeList(
objectId : String,
isLayer : bool
)

See Also

ChangeList Class
ChangeList Constructor Overload List


Properties

ChangeList Properties
[image]

Public Properties

 | Name | Description
Public property | Changes |
Public property | IsLayer |
Public property | ObjectId |
Top

See Also

ChangeList Class


Changes Property

ChangeList.Changes Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Changes As ArrayList
C#
public ArrayList Changes { get; }
C++
public property ArrayList Changes sealed {
ArrayList get();
}
J#
/** property */
public ArrayList get_Changes();
JScript
public function get Changes() : ArrayList

See Also

ChangeList Class


IsLayer Property

ChangeList.IsLayer Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsLayer As Boolean
C#
public bool IsLayer { get; }
C++
public property bool IsLayer sealed {
bool get();
}
J#
/** property */
public bool get_IsLayer();
JScript
public function get IsLayer() : bool

See Also

ChangeList Class


ObjectId Property

ChangeList.ObjectId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectId As String
C#
public string ObjectId { get; }
C++
public property string ObjectId sealed {
String get();
}
J#
/** property */
public string get_ObjectId();
JScript
public function get ObjectId() : String

See Also

ChangeList Class


ChannelBandType Class

ChannelBandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ChannelBandType
C#
public class ChannelBandType
C++
ref class ChannelBandType
J#
public class ChannelBandType
JScript
public class ChannelBandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ChannelBandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ChannelBandType Members


ChannelBandType Members

ChannelBandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ChannelBandType.

Public Constructors

 | Name | Description
Public method | ChannelBandType | Initializes a new instance of the ChannelBandType class.
Top

Public Properties

 | Name | Description
Public property | Band |
Public property | ExtendedData1 |
Public property | HighBand |
Public property | HighBandSpecified |
Public property | HighChannel |
Public property | HighChannelSpecified |
Public property | LowBand |
Public property | LowBandSpecified |
Public property | LowChannel |
Public property | LowChannelSpecified |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ChannelBandType Class


ChannelBandType Constructor

ChannelBandType Constructor
[image]

Initializes a new instance of the ChannelBandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ChannelBandType()
C++
public:
ChannelBandType() sealed
J#
public ChannelBandType()
JScript
public function ChannelBandType()

See Also

ChannelBandType Class


Properties

ChannelBandType Properties
[image]

Public Properties

 | Name | Description
Public property | Band |
Public property | ExtendedData1 |
Public property | HighBand |
Public property | HighBandSpecified |
Public property | HighChannel |
Public property | HighChannelSpecified |
Public property | LowBand |
Public property | LowBandSpecified |
Public property | LowChannel |
Public property | LowChannelSpecified |
Top

See Also

ChannelBandType Class


Band Property

ChannelBandType.Band Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Band As String
C#
public string Band { get; set; }
C++
public property string Band sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Band();

/** property */
public void set_Band(string value);
JScript
public function get Band() : String

public function set Band(value : String);

See Also

ChannelBandType Class


ExtendedData1 Property

ChannelBandType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

ChannelBandType Class


HighBand Property

ChannelBandType.HighBand Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property HighBand As Double
C#
public double HighBand { get; set; }
C++
public property double HighBand sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_HighBand();

/** property */
public void set_HighBand(double value);
JScript
public function get HighBand() : double

public function set HighBand(value : double);

See Also

ChannelBandType Class


HighBandSpecified Property

ChannelBandType.HighBandSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property HighBandSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool HighBandSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool HighBandSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_HighBandSpecified();

/** property */
public void set_HighBandSpecified(bool value);
JScript
public function get HighBandSpecified() : bool

public function set HighBandSpecified(value : bool);

See Also

ChannelBandType Class


HighChannel Property

ChannelBandType.HighChannel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property HighChannel As Byte
C#
public byte HighChannel { get; set; }
C++
public property byte HighChannel sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_HighChannel();

/** property */
public void set_HighChannel(byte value);
JScript
public function get HighChannel() : Byte

public function set HighChannel(value : Byte);

See Also

ChannelBandType Class


HighChannelSpecified Property

ChannelBandType.HighChannelSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property HighChannelSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool HighChannelSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool HighChannelSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_HighChannelSpecified();

/** property */
public void set_HighChannelSpecified(bool value);
JScript
public function get HighChannelSpecified() : bool

public function set HighChannelSpecified(value : bool);

See Also

ChannelBandType Class


LowBand Property

ChannelBandType.LowBand Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LowBand As Double
C#
public double LowBand { get; set; }
C++
public property double LowBand sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_LowBand();

/** property */
public void set_LowBand(double value);
JScript
public function get LowBand() : double

public function set LowBand(value : double);

See Also

ChannelBandType Class


LowBandSpecified Property

ChannelBandType.LowBandSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property LowBandSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool LowBandSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool LowBandSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_LowBandSpecified();

/** property */
public void set_LowBandSpecified(bool value);
JScript
public function get LowBandSpecified() : bool

public function set LowBandSpecified(value : bool);

See Also

ChannelBandType Class


LowChannel Property

ChannelBandType.LowChannel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LowChannel As Byte
C#
public byte LowChannel { get; set; }
C++
public property byte LowChannel sealed {
char get();
void set(char value);
}
J#
/** property */
public byte get_LowChannel();

/** property */
public void set_LowChannel(byte value);
JScript
public function get LowChannel() : Byte

public function set LowChannel(value : Byte);

See Also

ChannelBandType Class


LowChannelSpecified Property

ChannelBandType.LowChannelSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property LowChannelSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool LowChannelSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool LowChannelSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_LowChannelSpecified();

/** property */
public void set_LowChannelSpecified(bool value);
JScript
public function get LowChannelSpecified() : bool

public function set LowChannelSpecified(value : bool);

See Also

ChannelBandType Class


CommandItemType Class

CommandItemType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class CommandItemType
Inherits UIItemType
C#
public class CommandItemType : UIItemType
C++
ref class CommandItemType : UIItemType
J#
public class CommandItemType extends UIItemType
JScript
public class CommandItemType extends UIItemType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.UIItemType
OSGeo.MapGuide.MaestroAPI.CommandItemType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CommandItemType Members


CommandItemType Members

CommandItemType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by CommandItemType.

Public Constructors

 | Name | Description
Public method | CommandItemType | Initializes a new instance of the CommandItemType class.
Top

Public Properties

 | Name | Description
Public property | Command |
Public property | Function | (inherited from UIItemType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CommandItemType Class


CommandItemType Constructor

CommandItemType Constructor
[image]

Initializes a new instance of the CommandItemType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CommandItemType()
C++
public:
CommandItemType() sealed
J#
public CommandItemType()
JScript
public function CommandItemType()

See Also

CommandItemType Class


Properties

CommandItemType Properties
[image]

Public Properties

 | Name | Description
Public property | Command |
Public property | Function | (inherited from UIItemType)
Top

See Also

CommandItemType Class


Command Property

CommandItemType.Command Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Command As String
C#
public string Command { get; set; }
C++
public property string Command sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Command();

/** property */
public void set_Command(string value);
JScript
public function get Command() : String

public function set Command(value : String);

See Also

CommandItemType Class


CommandType Class

CommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(SearchCommandType)), _
XmlIncludeAttribute(GetType(ViewOptionsCommandType)), _
XmlIncludeAttribute(GetType(HelpCommandType)), _
XmlIncludeAttribute(GetType(InvokeScriptCommandType)), _
XmlIncludeAttribute(GetType(BasicCommandType)), _
XmlIncludeAttribute(GetType(MeasureCommandType)), _
XmlIncludeAttribute(GetType(GetPrintablePageCommandType)), _
XmlIncludeAttribute(GetType(InvokeURLCommandType)), _
XmlIncludeAttribute(GetType(SelectWithinCommandType)), _
XmlIncludeAttribute(GetType(CustomCommandType)), _
XmlIncludeAttribute(GetType(PrintCommandType)), _
XmlIncludeAttribute(GetType(TargetedCommandType)), _
XmlIncludeAttribute(GetType(BufferCommandType))>
Public MustInherit Class CommandType
C#
[XmlIncludeAttribute(typeof(SearchCommandType))]
[XmlIncludeAttribute(typeof(ViewOptionsCommandType))]
[XmlIncludeAttribute(typeof(HelpCommandType))]
[XmlIncludeAttribute(typeof(InvokeScriptCommandType))]
[XmlIncludeAttribute(typeof(BasicCommandType))]
[XmlIncludeAttribute(typeof(MeasureCommandType))]
[XmlIncludeAttribute(typeof(GetPrintablePageCommandType))]
[XmlIncludeAttribute(typeof(InvokeURLCommandType))]
[XmlIncludeAttribute(typeof(SelectWithinCommandType))]
[XmlIncludeAttribute(typeof(CustomCommandType))]
[XmlIncludeAttribute(typeof(PrintCommandType))]
[XmlIncludeAttribute(typeof(TargetedCommandType))]
[XmlIncludeAttribute(typeof(BufferCommandType))]
public abstract class CommandType
C++
[XmlIncludeAttribute(typeof(SearchCommandType))]
[XmlIncludeAttribute(typeof(ViewOptionsCommandType))]
[XmlIncludeAttribute(typeof(HelpCommandType))]
[XmlIncludeAttribute(typeof(InvokeScriptCommandType))]
[XmlIncludeAttribute(typeof(BasicCommandType))]
[XmlIncludeAttribute(typeof(MeasureCommandType))]
[XmlIncludeAttribute(typeof(GetPrintablePageCommandType))]
[XmlIncludeAttribute(typeof(InvokeURLCommandType))]
[XmlIncludeAttribute(typeof(SelectWithinCommandType))]
[XmlIncludeAttribute(typeof(CustomCommandType))]
[XmlIncludeAttribute(typeof(PrintCommandType))]
[XmlIncludeAttribute(typeof(TargetedCommandType))]
[XmlIncludeAttribute(typeof(BufferCommandType))]
ref class CommandType abstract
J#
/** @attribute XmlIncludeAttribute(typeof(SearchCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(ViewOptionsCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(HelpCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(InvokeScriptCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(BasicCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(MeasureCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(GetPrintablePageCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(InvokeURLCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(SelectWithinCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(CustomCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(PrintCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(TargetedCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(BufferCommandType)) */
public class CommandType
JScript
public
XmlIncludeAttribute(typeof(SearchCommandType))
XmlIncludeAttribute(typeof(ViewOptionsCommandType))
XmlIncludeAttribute(typeof(HelpCommandType))
XmlIncludeAttribute(typeof(InvokeScriptCommandType))
XmlIncludeAttribute(typeof(BasicCommandType))
XmlIncludeAttribute(typeof(MeasureCommandType))
XmlIncludeAttribute(typeof(GetPrintablePageCommandType))
XmlIncludeAttribute(typeof(InvokeURLCommandType))
XmlIncludeAttribute(typeof(SelectWithinCommandType))
XmlIncludeAttribute(typeof(CustomCommandType))
XmlIncludeAttribute(typeof(PrintCommandType))
XmlIncludeAttribute(typeof(TargetedCommandType))
XmlIncludeAttribute(typeof(BufferCommandType))
class CommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.BasicCommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CommandType Members


CommandType Members

CommandType Members
See Also Example Properties Methods
[image]

The following tables list the members exposed by CommandType.

Public Properties

 | Name | Description
Public property | Description |
Public property | DisabledImageURL |
Public property | ImageURL |
Public property | Label |
Public property | Name |
Public property | TargetViewer |
Public property | Tooltip |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CommandType Class


Properties

CommandType Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | DisabledImageURL |
Public property | ImageURL |
Public property | Label |
Public property | Name |
Public property | TargetViewer |
Public property | Tooltip |
Top

See Also

CommandType Class


Description Property

CommandType.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

CommandType Class


DisabledImageURL Property

CommandType.DisabledImageURL Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisabledImageURL As String
C#
public string DisabledImageURL { get; set; }
C++
public property string DisabledImageURL sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DisabledImageURL();

/** property */
public void set_DisabledImageURL(string value);
JScript
public function get DisabledImageURL() : String

public function set DisabledImageURL(value : String);

See Also

CommandType Class


ImageURL Property

CommandType.ImageURL Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageURL As String
C#
public string ImageURL { get; set; }
C++
public property string ImageURL sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ImageURL();

/** property */
public void set_ImageURL(string value);
JScript
public function get ImageURL() : String

public function set ImageURL(value : String);

See Also

CommandType Class


Label Property

CommandType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label { get; set; }
C++
public property string Label sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Label();

/** property */
public void set_Label(string value);
JScript
public function get Label() : String

public function set Label(value : String);

See Also

CommandType Class


Name Property

CommandType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

CommandType Class


TargetViewer Property

CommandType.TargetViewer Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetViewer As TargetViewerType
C#
public TargetViewerType TargetViewer { get; set; }
C++
public property TargetViewerType TargetViewer sealed {
TargetViewerType get();
void set(TargetViewerType value);
}
J#
/** property */
public TargetViewerType get_TargetViewer();

/** property */
public void set_TargetViewer(TargetViewerType value);
JScript
public function get TargetViewer() : TargetViewerType

public function set TargetViewer(value : TargetViewerType);

See Also

CommandType Class


Tooltip Property

CommandType.Tooltip Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Tooltip As String
C#
public string Tooltip { get; set; }
C++
public property string Tooltip sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Tooltip();

/** property */
public void set_Tooltip(string value);
JScript
public function get Tooltip() : String

public function set Tooltip(value : String);

See Also

CommandType Class


CommandTypeCollection Class

CommandTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class CommandTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class CommandTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class CommandTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class CommandTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class CommandTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.CommandTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CommandTypeCollection Members


CommandTypeCollection Members

CommandTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by CommandTypeCollection.

Public Constructors

 | Name | Description
Public method | CommandTypeCollection | Initializes a new instance of the CommandTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CommandTypeCollection Class


CommandTypeCollection Constructor

CommandTypeCollection Constructor
[image]

Initializes a new instance of the CommandTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CommandTypeCollection()
C++
public:
CommandTypeCollection() sealed
J#
public CommandTypeCollection()
JScript
public function CommandTypeCollection()

See Also

CommandTypeCollection Class


Properties

CommandTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

CommandTypeCollection Class


Item Property

CommandTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As CommandType
C#
public CommandType this[
int idx
] { get; set; }
C++
public property CommandType default[int idx] sealed {
CommandType get(int idx);
void set(int idx, CommandType value);
}
J#
/** property */
public CommandType get_Item(int idx);

/** property */
public void set_Item(int idx, CommandType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

CommandTypeCollection Class


Methods

CommandTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CommandTypeCollection Class


Add Method

CommandTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As CommandType _
) As Integer
C#
public int Add(
CommandType value
)
C++
public:
int Add(
CommandType value
) sealed
J#
public int Add(
CommandType value
)
JScript
public function Add(
value : CommandType
) : int

See Also

CommandTypeCollection Class


CompositeRule Class

CompositeRule Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class CompositeRule
C#
public class CompositeRule
C++
ref class CompositeRule
J#
public class CompositeRule
JScript
public class CompositeRule

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CompositeRule

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CompositeRule Members


CompositeRule Members

CompositeRule Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by CompositeRule.

Public Constructors

 | Name | Description
Public method | CompositeRule | Initializes a new instance of the CompositeRule class.
Top

Public Properties

 | Name | Description
Public property | CompositeSymbolization |
Public property | ExtendedData1 |
Public property | Filter |
Public property | LegendLabel |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CompositeRule Class


CompositeRule Constructor

CompositeRule Constructor
[image]

Initializes a new instance of the CompositeRule class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CompositeRule()
C++
public:
CompositeRule() sealed
J#
public CompositeRule()
JScript
public function CompositeRule()

See Also

CompositeRule Class


Properties

CompositeRule Properties
[image]

Public Properties

 | Name | Description
Public property | CompositeSymbolization |
Public property | ExtendedData1 |
Public property | Filter |
Public property | LegendLabel |
Top

See Also

CompositeRule Class


CompositeSymbolization Property

CompositeRule.CompositeSymbolization Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CompositeSymbolization As CompositeSymbolization
C#
public CompositeSymbolization CompositeSymbolization { get; set; }
C++
public property CompositeSymbolization CompositeSymbolization sealed {
CompositeSymbolization get();
void set(CompositeSymbolization value);
}
J#
/** property */
public CompositeSymbolization get_CompositeSymbolization();

/** property */
public void set_CompositeSymbolization(CompositeSymbolization value);
JScript
public function get CompositeSymbolization() : CompositeSymbolization

public function set CompositeSymbolization(value : CompositeSymbolization);

See Also

CompositeRule Class


ExtendedData1 Property

CompositeRule.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

CompositeRule Class


Filter Property

CompositeRule.Filter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; set; }
C++
public property string Filter sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Filter();

/** property */
public void set_Filter(string value);
JScript
public function get Filter() : String

public function set Filter(value : String);

See Also

CompositeRule Class


LegendLabel Property

CompositeRule.LegendLabel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LegendLabel As String
C#
public string LegendLabel { get; set; }
C++
public property string LegendLabel sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LegendLabel();

/** property */
public void set_LegendLabel(string value);
JScript
public function get LegendLabel() : String

public function set LegendLabel(value : String);

See Also

CompositeRule Class


CompositeRuleCollection Class

CompositeRuleCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class CompositeRuleCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class CompositeRuleCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class CompositeRuleCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class CompositeRuleCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class CompositeRuleCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.CompositeRuleCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CompositeRuleCollection Members


CompositeRuleCollection Members

CompositeRuleCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by CompositeRuleCollection.

Public Constructors

 | Name | Description
Public method | CompositeRuleCollection | Initializes a new instance of the CompositeRuleCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CompositeRuleCollection Class


CompositeRuleCollection Constructor

CompositeRuleCollection Constructor
[image]

Initializes a new instance of the CompositeRuleCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CompositeRuleCollection()
C++
public:
CompositeRuleCollection() sealed
J#
public CompositeRuleCollection()
JScript
public function CompositeRuleCollection()

See Also

CompositeRuleCollection Class


Properties

CompositeRuleCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

CompositeRuleCollection Class


Item Property

CompositeRuleCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As CompositeRule
C#
public CompositeRule this[
int idx
] { get; set; }
C++
public property CompositeRule default[int idx] sealed {
CompositeRule get(int idx);
void set(int idx, CompositeRule value);
}
J#
/** property */
public CompositeRule get_Item(int idx);

/** property */
public void set_Item(int idx, CompositeRule value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

CompositeRuleCollection Class


Methods

CompositeRuleCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CompositeRuleCollection Class


Add Method

CompositeRuleCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As CompositeRule _
) As Integer
C#
public int Add(
CompositeRule value
)
C++
public:
int Add(
CompositeRule value
) sealed
J#
public int Add(
CompositeRule value
)
JScript
public function Add(
value : CompositeRule
) : int

See Also

CompositeRuleCollection Class


CompositeSymbolization Class

CompositeSymbolization Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class CompositeSymbolization
C#
public class CompositeSymbolization
C++
ref class CompositeSymbolization
J#
public class CompositeSymbolization
JScript
public class CompositeSymbolization

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CompositeSymbolization

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CompositeSymbolization Members


CompositeSymbolization Members

CompositeSymbolization Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by CompositeSymbolization.

Public Constructors

 | Name | Description
Public method | CompositeSymbolization | Initializes a new instance of the CompositeSymbolization class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | SymbolInstance |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CompositeSymbolization Class


CompositeSymbolization Constructor

CompositeSymbolization Constructor
[image]

Initializes a new instance of the CompositeSymbolization class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CompositeSymbolization()
C++
public:
CompositeSymbolization() sealed
J#
public CompositeSymbolization()
JScript
public function CompositeSymbolization()

See Also

CompositeSymbolization Class


Properties

CompositeSymbolization Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | SymbolInstance |
Top

See Also

CompositeSymbolization Class


ExtendedData1 Property

CompositeSymbolization.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

CompositeSymbolization Class


SymbolInstance Property

CompositeSymbolization.SymbolInstance Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("SymbolInstance")>
Public Property SymbolInstance As SymbolInstanceCollection
C#
[XmlElementAttribute("SymbolInstance")]
public SymbolInstanceCollection SymbolInstance { get; set; }
C++
[XmlElementAttribute(L"SymbolInstance")]
public property SymbolInstanceCollection SymbolInstance sealed {
SymbolInstanceCollection get();
void set(SymbolInstanceCollection value);
}
J#
/** @attribute XmlElementAttribute("SymbolInstance") */
/** property */
public SymbolInstanceCollection get_SymbolInstance();

/** property */
public void set_SymbolInstance(SymbolInstanceCollection value);
JScript
public function get SymbolInstance() : SymbolInstanceCollection

public function set SymbolInstance(value : SymbolInstanceCollection);

See Also

CompositeSymbolization Class


CompositeTypeStyle Class

CompositeTypeStyle Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class CompositeTypeStyle
C#
public class CompositeTypeStyle
C++
ref class CompositeTypeStyle
J#
public class CompositeTypeStyle
JScript
public class CompositeTypeStyle

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CompositeTypeStyle

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CompositeTypeStyle Members


CompositeTypeStyle Members

CompositeTypeStyle Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by CompositeTypeStyle.

Public Constructors

 | Name | Description
Public method | CompositeTypeStyle | Initializes a new instance of the CompositeTypeStyle class.
Top

Public Properties

 | Name | Description
Public property | CompositeRule |
Public property | ExtendedData1 |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CompositeTypeStyle Class


CompositeTypeStyle Constructor

CompositeTypeStyle Constructor
[image]

Initializes a new instance of the CompositeTypeStyle class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CompositeTypeStyle()
C++
public:
CompositeTypeStyle() sealed
J#
public CompositeTypeStyle()
JScript
public function CompositeTypeStyle()

See Also

CompositeTypeStyle Class


Properties

CompositeTypeStyle Properties
[image]

Public Properties

 | Name | Description
Public property | CompositeRule |
Public property | ExtendedData1 |
Top

See Also

CompositeTypeStyle Class


CompositeRule Property

CompositeTypeStyle.CompositeRule Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("CompositeRule")>
Public Property CompositeRule As CompositeRuleCollection
C#
[XmlElementAttribute("CompositeRule")]
public CompositeRuleCollection CompositeRule { get; set; }
C++
[XmlElementAttribute(L"CompositeRule")]
public property CompositeRuleCollection CompositeRule sealed {
CompositeRuleCollection get();
void set(CompositeRuleCollection value);
}
J#
/** @attribute XmlElementAttribute("CompositeRule") */
/** property */
public CompositeRuleCollection get_CompositeRule();

/** property */
public void set_CompositeRule(CompositeRuleCollection value);
JScript
public function get CompositeRule() : CompositeRuleCollection

public function set CompositeRule(value : CompositeRuleCollection);

See Also

CompositeTypeStyle Class


ExtendedData1 Property

CompositeTypeStyle.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

CompositeTypeStyle Class


CompoundSymbolDefinition Class

CompoundSymbolDefinition Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class CompoundSymbolDefinition
Inherits SymbolDefinitionBase
C#
public class CompoundSymbolDefinition : SymbolDefinitionBase
C++
ref class CompoundSymbolDefinition : SymbolDefinitionBase
J#
public class CompoundSymbolDefinition extends SymbolDefinitionBase
JScript
public class CompoundSymbolDefinition extends SymbolDefinitionBase

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolDefinitionBase
OSGeo.MapGuide.MaestroAPI.CompoundSymbolDefinition

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CompoundSymbolDefinition Members


CompoundSymbolDefinition Members

CompoundSymbolDefinition Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by CompoundSymbolDefinition.

Public Constructors

 | Name | Description
Public method | CompoundSymbolDefinition | Initializes a new instance of the CompoundSymbolDefinition class.
Top

Public Properties

 | Name | Description
Public property | Description | (inherited from SymbolDefinitionBase)
Public property | ExtendedData1 |
Public property | Name | (inherited from SymbolDefinitionBase)
Public property | SimpleSymbol |
Public property | version |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CompoundSymbolDefinition Class


CompoundSymbolDefinition Constructor

CompoundSymbolDefinition Constructor
[image]

Initializes a new instance of the CompoundSymbolDefinition class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CompoundSymbolDefinition()
C++
public:
CompoundSymbolDefinition() sealed
J#
public CompoundSymbolDefinition()
JScript
public function CompoundSymbolDefinition()

See Also

CompoundSymbolDefinition Class


Properties

CompoundSymbolDefinition Properties
[image]

Public Properties

 | Name | Description
Public property | Description | (inherited from SymbolDefinitionBase)
Public property | ExtendedData1 |
Public property | Name | (inherited from SymbolDefinitionBase)
Public property | SimpleSymbol |
Public property | version |
Top

See Also

CompoundSymbolDefinition Class


ExtendedData1 Property

CompoundSymbolDefinition.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

CompoundSymbolDefinition Class


SimpleSymbol Property

CompoundSymbolDefinition.SimpleSymbol Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("SimpleSymbol")>
Public Property SimpleSymbol As SimpleSymbolCollection
C#
[XmlElementAttribute("SimpleSymbol")]
public SimpleSymbolCollection SimpleSymbol { get; set; }
C++
[XmlElementAttribute(L"SimpleSymbol")]
public property SimpleSymbolCollection SimpleSymbol sealed {
SimpleSymbolCollection get();
void set(SimpleSymbolCollection value);
}
J#
/** @attribute XmlElementAttribute("SimpleSymbol") */
/** property */
public SimpleSymbolCollection get_SimpleSymbol();

/** property */
public void set_SimpleSymbol(SimpleSymbolCollection value);
JScript
public function get SimpleSymbol() : SimpleSymbolCollection

public function set SimpleSymbol(value : SimpleSymbolCollection);

See Also

CompoundSymbolDefinition Class


version Property

CompoundSymbolDefinition.version Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("1.1.0"), _
XmlAttributeAttribute>
Public Property version As String
C#
[DefaultValueAttribute("1.1.0")]
[XmlAttributeAttribute]
public string version { get; set; }
C++
[DefaultValueAttribute(L"1.1.0")]
[XmlAttributeAttribute]
public property string version sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("1.1.0") */
/** @attribute XmlAttributeAttribute() */
/** property */
public string get_version();

/** property */
public void set_version(string value);
JScript
public function get version() : String

public function set version(value : String);

See Also

CompoundSymbolDefinition Class


ContextMenuType Class

ContextMenuType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ContextMenuType
Inherits WebLayoutControlType
C#
public class ContextMenuType : WebLayoutControlType
C++
ref class ContextMenuType : WebLayoutControlType
J#
public class ContextMenuType extends WebLayoutControlType
JScript
public class ContextMenuType extends WebLayoutControlType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.WebLayoutControlType
OSGeo.MapGuide.MaestroAPI.ContextMenuType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ContextMenuType Members


ContextMenuType Members

ContextMenuType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ContextMenuType.

Public Constructors

 | Name | Description
Public method | ContextMenuType | Initializes a new instance of the ContextMenuType class.
Top

Public Properties

 | Name | Description
Public property | MenuItem |
Public property | Visible | (inherited from WebLayoutControlType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ContextMenuType Class


ContextMenuType Constructor

ContextMenuType Constructor
[image]

Initializes a new instance of the ContextMenuType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ContextMenuType()
C++
public:
ContextMenuType() sealed
J#
public ContextMenuType()
JScript
public function ContextMenuType()

See Also

ContextMenuType Class


Properties

ContextMenuType Properties
[image]

Public Properties

 | Name | Description
Public property | MenuItem |
Public property | Visible | (inherited from WebLayoutControlType)
Top

See Also

ContextMenuType Class


MenuItem Property

ContextMenuType.MenuItem Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("MenuItem")>
Public Property MenuItem As UIItemTypeCollection
C#
[XmlElementAttribute("MenuItem")]
public UIItemTypeCollection MenuItem { get; set; }
C++
[XmlElementAttribute(L"MenuItem")]
public property UIItemTypeCollection MenuItem sealed {
UIItemTypeCollection get();
void set(UIItemTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("MenuItem") */
/** property */
public UIItemTypeCollection get_MenuItem();

/** property */
public void set_MenuItem(UIItemTypeCollection value);
JScript
public function get MenuItem() : UIItemTypeCollection

public function set MenuItem(value : UIItemTypeCollection);

See Also

ContextMenuType Class


CoordinateSystem Class

CoordinateSystem Class
See Also Example Members
[image]

Interface to MapGuide coordinate system functions. Only works with server > 1.2, since the coordinate mapping is not avalible through Http on older versions

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class CoordinateSystem
C#
public class CoordinateSystem
C++
ref class CoordinateSystem
J#
public class CoordinateSystem
JScript
public class CoordinateSystem

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CoordinateSystem

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CoordinateSystem Members


CoordinateSystem Members

CoordinateSystem Members
See Also Example Properties Methods
[image]

Interface to MapGuide coordinate system functions. Only works with server > 1.2, since the coordinate mapping is not avalible through Http on older versions

The following tables list the members exposed by CoordinateSystem.

Public Properties

 | Name | Description
Public property | Categories |
Public property | Coordsys |
Public property | LibraryName |
Top

Public Methods

 | Name | Description
Public method | ConvertCoordinateSystemCodeToWkt |
Public method | ConvertEpsgCodeToWkt |
Public method | ConvertWktToCoordinateSystemCode |
Public method | ConvertWktToEpsgCode |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindCoordSys |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsValid |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CoordinateSystem Class


Properties

CoordinateSystem Properties
[image]

Public Properties

 | Name | Description
Public property | Categories |
Public property | Coordsys |
Public property | LibraryName |
Top

See Also

CoordinateSystem Class


Categories Property

CoordinateSystem.Categories Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Categories As CoordinateSystem.Category()
C#
public CoordinateSystem.Category[] Categories { get; }
C++
public property CoordinateSystem.Category[] Categories sealed {
array<CoordinateSystem.Category>^ get();
}
J#
/** property */
public CoordinateSystem.Category[] get_Categories();
JScript
public function get Categories() : CoordinateSystem.Category[]

See Also

CoordinateSystem Class


Coordsys Property

CoordinateSystem.Coordsys Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Coordsys As CoordinateSystem.CoordSys()
C#
public CoordinateSystem.CoordSys[] Coordsys { get; }
C++
public property CoordinateSystem.CoordSys[] Coordsys sealed {
array<CoordinateSystem.CoordSys>^ get();
}
J#
/** property */
public CoordinateSystem.CoordSys[] get_Coordsys();
JScript
public function get Coordsys() : CoordinateSystem.CoordSys[]

See Also

CoordinateSystem Class


LibraryName Property

CoordinateSystem.LibraryName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LibraryName As String
C#
public string LibraryName { get; }
C++
public property string LibraryName sealed {
String get();
}
J#
/** property */
public string get_LibraryName();
JScript
public function get LibraryName() : String

See Also

CoordinateSystem Class


Methods

CoordinateSystem Methods
[image]

Public Methods

 | Name | Description
Public method | ConvertCoordinateSystemCodeToWkt |
Public method | ConvertEpsgCodeToWkt |
Public method | ConvertWktToCoordinateSystemCode |
Public method | ConvertWktToEpsgCode |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindCoordSys |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsValid |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CoordinateSystem Class


ConvertCoordinateSystemCodeToWkt Method

CoordinateSystem.ConvertCoordinateSystemCodeToWkt Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ConvertCoordinateSystemCodeToWkt( _
ByVal coordcode As String _
) As String
C#
public string ConvertCoordinateSystemCodeToWkt(
string coordcode
)
C++
public:
String ConvertCoordinateSystemCodeToWkt(
String coordcode
) sealed
J#
public string ConvertCoordinateSystemCodeToWkt(
string coordcode
)
JScript
public function ConvertCoordinateSystemCodeToWkt(
coordcode : String
) : String

See Also

CoordinateSystem Class


ConvertEpsgCodeToWkt Method

CoordinateSystem.ConvertEpsgCodeToWkt Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ConvertEpsgCodeToWkt( _
ByVal epsg As String _
) As String
C#
public string ConvertEpsgCodeToWkt(
string epsg
)
C++
public:
String ConvertEpsgCodeToWkt(
String epsg
) sealed
J#
public string ConvertEpsgCodeToWkt(
string epsg
)
JScript
public function ConvertEpsgCodeToWkt(
epsg : String
) : String

See Also

CoordinateSystem Class


ConvertWktToCoordinateSystemCode Method

CoordinateSystem.ConvertWktToCoordinateSystemCode Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ConvertWktToCoordinateSystemCode( _
ByVal wkt As String _
) As String
C#
public string ConvertWktToCoordinateSystemCode(
string wkt
)
C++
public:
String ConvertWktToCoordinateSystemCode(
String wkt
) sealed
J#
public string ConvertWktToCoordinateSystemCode(
string wkt
)
JScript
public function ConvertWktToCoordinateSystemCode(
wkt : String
) : String

See Also

CoordinateSystem Class


ConvertWktToEpsgCode Method

CoordinateSystem.ConvertWktToEpsgCode Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ConvertWktToEpsgCode( _
ByVal wkt As String _
) As String
C#
public string ConvertWktToEpsgCode(
string wkt
)
C++
public:
String ConvertWktToEpsgCode(
String wkt
) sealed
J#
public string ConvertWktToEpsgCode(
string wkt
)
JScript
public function ConvertWktToEpsgCode(
wkt : String
) : String

See Also

CoordinateSystem Class


FindCoordSys Method

CoordinateSystem.FindCoordSys Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function FindCoordSys( _
ByVal coordcode As String _
) As CoordinateSystem.CoordSys
C#
public CoordinateSystem.CoordSys FindCoordSys(
string coordcode
)
C++
public:
CoordinateSystem.CoordSys FindCoordSys(
String coordcode
) sealed
J#
public CoordinateSystem.CoordSys FindCoordSys(
string coordcode
)
JScript
public function FindCoordSys(
coordcode : String
) : CoordinateSystem.CoordSys

See Also

CoordinateSystem Class


IsValid Method

CoordinateSystem.IsValid Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function IsValid( _
ByVal wkt As String _
) As Boolean
C#
public bool IsValid(
string wkt
)
C++
public:
bool IsValid(
String wkt
) sealed
J#
public bool IsValid(
string wkt
)
JScript
public function IsValid(
wkt : String
) : bool

See Also

CoordinateSystem Class


CoordinateSystem.Category Class

CoordinateSystem.Category Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class CoordinateSystem.Category
C#
public class CoordinateSystem.Category
C++
ref class CoordinateSystem.Category
J#
public class CoordinateSystem.Category
JScript
public class CoordinateSystem.Category

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CoordinateSystem.Category

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CoordinateSystem.Category Members


CoordinateSystem.Category Members

CoordinateSystem.Category Members
See Also Example Properties Methods
[image]

The following tables list the members exposed by CoordinateSystem.Category.

Public Properties

 | Name | Description
Public property | Items |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden.
Top

See Also

CoordinateSystem.Category Class


Properties

CoordinateSystem.Category Properties
[image]

Public Properties

 | Name | Description
Public property | Items |
Public property | Name |
Top

See Also

CoordinateSystem.Category Class


Items Property

CoordinateSystem.Category.Items Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As CoordinateSystem.CoordSys()
C#
public CoordinateSystem.CoordSys[] Items { get; }
C++
public property CoordinateSystem.CoordSys[] Items sealed {
array<CoordinateSystem.CoordSys>^ get();
}
J#
/** property */
public CoordinateSystem.CoordSys[] get_Items();
JScript
public function get Items() : CoordinateSystem.CoordSys[]

See Also

CoordinateSystem.Category Class


Name Property

CoordinateSystem.Category.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

CoordinateSystem.Category Class


Methods

CoordinateSystem.Category Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden.
Top

See Also

CoordinateSystem.Category Class


ToString Method

CoordinateSystem.Category.ToString Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

See Also

CoordinateSystem.Category Class


CoordinateSystem.CoordSys Class

CoordinateSystem.CoordSys Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class CoordinateSystem.CoordSys
C#
public class CoordinateSystem.CoordSys
C++
ref class CoordinateSystem.CoordSys
J#
public class CoordinateSystem.CoordSys
JScript
public class CoordinateSystem.CoordSys

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CoordinateSystem.CoordSys

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CoordinateSystem.CoordSys Members


CoordinateSystem.CoordSys Members

CoordinateSystem.CoordSys Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by CoordinateSystem.CoordSys.

Public Constructors

 | Name | Description
Public method | CoordinateSystem.CoordSys | Initializes a new instance of the CoordinateSystem.CoordSys class.
Top

Public Properties

 | Name | Description
Public property | Code |
Public property | Datum |
Public property | DatumDescription |
Public property | Description |
Public property | Ellipsoid |
Public property | EllipsoidDescription |
Public property | EPSG |
Public property | Projection |
Public property | ProjectionDescription |
Public property | WKT |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden.
Top

See Also

CoordinateSystem.CoordSys Class


CoordinateSystem.CoordSys Constructor

CoordinateSystem.CoordSys Constructor
[image]

Initializes a new instance of the CoordinateSystem.CoordSys class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CoordinateSystem.CoordSys()
C++
public:
CoordinateSystem.CoordSys() sealed
J#
public CoordinateSystem.CoordSys()
JScript
public function CoordinateSystem.CoordSys()

See Also

CoordinateSystem.CoordSys Class


Properties

CoordinateSystem.CoordSys Properties
[image]

Public Properties

 | Name | Description
Public property | Code |
Public property | Datum |
Public property | DatumDescription |
Public property | Description |
Public property | Ellipsoid |
Public property | EllipsoidDescription |
Public property | EPSG |
Public property | Projection |
Public property | ProjectionDescription |
Public property | WKT |
Top

See Also

CoordinateSystem.CoordSys Class


Code Property

CoordinateSystem.CoordSys.Code Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Code As String
C#
public string Code { get; set; }
C++
public property string Code sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Code();

/** property */
public void set_Code(string value);
JScript
public function get Code() : String

public function set Code(value : String);

See Also

CoordinateSystem.CoordSys Class


Datum Property

CoordinateSystem.CoordSys.Datum Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Datum As String
C#
public string Datum { get; }
C++
public property string Datum sealed {
String get();
}
J#
/** property */
public string get_Datum();
JScript
public function get Datum() : String

See Also

CoordinateSystem.CoordSys Class


DatumDescription Property

CoordinateSystem.CoordSys.DatumDescription Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DatumDescription As String
C#
public string DatumDescription { get; }
C++
public property string DatumDescription sealed {
String get();
}
J#
/** property */
public string get_DatumDescription();
JScript
public function get DatumDescription() : String

See Also

CoordinateSystem.CoordSys Class


Description Property

CoordinateSystem.CoordSys.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

CoordinateSystem.CoordSys Class


Ellipsoid Property

CoordinateSystem.CoordSys.Ellipsoid Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Ellipsoid As String
C#
public string Ellipsoid { get; }
C++
public property string Ellipsoid sealed {
String get();
}
J#
/** property */
public string get_Ellipsoid();
JScript
public function get Ellipsoid() : String

See Also

CoordinateSystem.CoordSys Class


EllipsoidDescription Property

CoordinateSystem.CoordSys.EllipsoidDescription Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EllipsoidDescription As String
C#
public string EllipsoidDescription { get; }
C++
public property string EllipsoidDescription sealed {
String get();
}
J#
/** property */
public string get_EllipsoidDescription();
JScript
public function get EllipsoidDescription() : String

See Also

CoordinateSystem.CoordSys Class


EPSG Property

CoordinateSystem.CoordSys.EPSG Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EPSG As String
C#
public string EPSG { get; }
C++
public property string EPSG sealed {
String get();
}
J#
/** property */
public string get_EPSG();
JScript
public function get EPSG() : String

See Also

CoordinateSystem.CoordSys Class


Projection Property

CoordinateSystem.CoordSys.Projection Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Projection As String
C#
public string Projection { get; }
C++
public property string Projection sealed {
String get();
}
J#
/** property */
public string get_Projection();
JScript
public function get Projection() : String

See Also

CoordinateSystem.CoordSys Class


ProjectionDescription Property

CoordinateSystem.CoordSys.ProjectionDescription Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProjectionDescription As String
C#
public string ProjectionDescription { get; }
C++
public property string ProjectionDescription sealed {
String get();
}
J#
/** property */
public string get_ProjectionDescription();
JScript
public function get ProjectionDescription() : String

See Also

CoordinateSystem.CoordSys Class


WKT Property

CoordinateSystem.CoordSys.WKT Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property WKT As String
C#
public string WKT { get; set; }
C++
public property string WKT sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_WKT();

/** property */
public void set_WKT(string value);
JScript
public function get WKT() : String

public function set WKT(value : String);

See Also

CoordinateSystem.CoordSys Class


Methods

CoordinateSystem.CoordSys Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Overridden.
Top

See Also

CoordinateSystem.CoordSys Class


ToString Method

CoordinateSystem.CoordSys.ToString Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

See Also

CoordinateSystem.CoordSys Class


CustomCommandType Class

CustomCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(InvokeURLCommandType)), _
XmlIncludeAttribute(GetType(HelpCommandType)), _
XmlIncludeAttribute(GetType(InvokeScriptCommandType)), _
XmlIncludeAttribute(GetType(TargetedCommandType)), _
XmlIncludeAttribute(GetType(SearchCommandType)), _
XmlIncludeAttribute(GetType(MeasureCommandType)), _
XmlIncludeAttribute(GetType(GetPrintablePageCommandType)), _
XmlIncludeAttribute(GetType(PrintCommandType)), _
XmlIncludeAttribute(GetType(SelectWithinCommandType)), _
XmlIncludeAttribute(GetType(BufferCommandType)), _
XmlIncludeAttribute(GetType(ViewOptionsCommandType))>
Public MustInherit Class CustomCommandType
Inherits CommandType
C#
[XmlIncludeAttribute(typeof(InvokeURLCommandType))]
[XmlIncludeAttribute(typeof(HelpCommandType))]
[XmlIncludeAttribute(typeof(InvokeScriptCommandType))]
[XmlIncludeAttribute(typeof(TargetedCommandType))]
[XmlIncludeAttribute(typeof(SearchCommandType))]
[XmlIncludeAttribute(typeof(MeasureCommandType))]
[XmlIncludeAttribute(typeof(GetPrintablePageCommandType))]
[XmlIncludeAttribute(typeof(PrintCommandType))]
[XmlIncludeAttribute(typeof(SelectWithinCommandType))]
[XmlIncludeAttribute(typeof(BufferCommandType))]
[XmlIncludeAttribute(typeof(ViewOptionsCommandType))]
public abstract class CustomCommandType : CommandType
C++
[XmlIncludeAttribute(typeof(InvokeURLCommandType))]
[XmlIncludeAttribute(typeof(HelpCommandType))]
[XmlIncludeAttribute(typeof(InvokeScriptCommandType))]
[XmlIncludeAttribute(typeof(TargetedCommandType))]
[XmlIncludeAttribute(typeof(SearchCommandType))]
[XmlIncludeAttribute(typeof(MeasureCommandType))]
[XmlIncludeAttribute(typeof(GetPrintablePageCommandType))]
[XmlIncludeAttribute(typeof(PrintCommandType))]
[XmlIncludeAttribute(typeof(SelectWithinCommandType))]
[XmlIncludeAttribute(typeof(BufferCommandType))]
[XmlIncludeAttribute(typeof(ViewOptionsCommandType))]
ref class CustomCommandType abstract : CommandType
J#
/** @attribute XmlIncludeAttribute(typeof(InvokeURLCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(HelpCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(InvokeScriptCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(TargetedCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(SearchCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(MeasureCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(GetPrintablePageCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(PrintCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(SelectWithinCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(BufferCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(ViewOptionsCommandType)) */
public class CustomCommandType extends CommandType
JScript
public
XmlIncludeAttribute(typeof(InvokeURLCommandType))
XmlIncludeAttribute(typeof(HelpCommandType))
XmlIncludeAttribute(typeof(InvokeScriptCommandType))
XmlIncludeAttribute(typeof(TargetedCommandType))
XmlIncludeAttribute(typeof(SearchCommandType))
XmlIncludeAttribute(typeof(MeasureCommandType))
XmlIncludeAttribute(typeof(GetPrintablePageCommandType))
XmlIncludeAttribute(typeof(PrintCommandType))
XmlIncludeAttribute(typeof(SelectWithinCommandType))
XmlIncludeAttribute(typeof(BufferCommandType))
XmlIncludeAttribute(typeof(ViewOptionsCommandType))
class CustomCommandType extends CommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.InvokeScriptCommandType
OSGeo.MapGuide.MaestroAPI.PrintCommandType
OSGeo.MapGuide.MaestroAPI.TargetedCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CustomCommandType Members


CustomCommandType Members

CustomCommandType Members
See Also Example Properties Methods
[image]

The following tables list the members exposed by CustomCommandType.

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

CustomCommandType Class


DataStoreItem Class

DataStoreItem Class
See Also Example Members
[image]

Represents a single datastore item

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DataStoreItem
C#
public class DataStoreItem
C++
ref class DataStoreItem
J#
public class DataStoreItem
JScript
public class DataStoreItem

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.DataStoreItem

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DataStoreItem Members


DataStoreItem Members

DataStoreItem Members
See Also Example Constructors Properties Methods
[image]

Represents a single datastore item

The following tables list the members exposed by DataStoreItem.

Public Constructors

 | Name | Description
Public method | DataStoreItem | Initializes a new instance of the DataStoreItem class.
Top

Public Properties

 | Name | Description
Public property | FdoEnabled | Gets or sets a value indicating if this item is FDO enabled
Public property | Name | Gets or sets name of the data item
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DataStoreItem Class


DataStoreItem Constructor

DataStoreItem Constructor
[image]

Initializes a new instance of the DataStoreItem class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DataStoreItem()
C++
public:
DataStoreItem() sealed
J#
public DataStoreItem()
JScript
public function DataStoreItem()

See Also

DataStoreItem Class


Properties

DataStoreItem Properties
[image]

Public Properties

 | Name | Description
Public property | FdoEnabled | Gets or sets a value indicating if this item is FDO enabled
Public property | Name | Gets or sets name of the data item
Top

See Also

DataStoreItem Class


FdoEnabled Property

DataStoreItem.FdoEnabled Property
[image]

Gets or sets a value indicating if this item is FDO enabled

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FdoEnabled As Boolean
C#
public bool FdoEnabled { get; set; }
C++
public property bool FdoEnabled sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_FdoEnabled();

/** property */
public void set_FdoEnabled(bool value);
JScript
public function get FdoEnabled() : bool

public function set FdoEnabled(value : bool);

See Also

DataStoreItem Class


Name Property

DataStoreItem.Name Property
[image]

Gets or sets name of the data item

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

DataStoreItem Class


DataStoreItemCollection Class

DataStoreItemCollection Class
See Also Example Members
[image]

Represents a list of datastore items

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class DataStoreItemCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class DataStoreItemCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class DataStoreItemCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class DataStoreItemCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class DataStoreItemCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.DataStoreItemCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DataStoreItemCollection Members


DataStoreItemCollection Members

DataStoreItemCollection Members
See Also Example Constructors Properties Methods
[image]

Represents a list of datastore items

The following tables list the members exposed by DataStoreItemCollection.

Public Constructors

 | Name | Description
Public method | DataStoreItemCollection | Initializes a new instance of the DataStoreItemCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Gets or sets a datastore item, using the item index
Top

Public Methods

 | Name | Description
Public method | Add | Adds a datastore item
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DataStoreItemCollection Class


DataStoreItemCollection Constructor

DataStoreItemCollection Constructor
[image]

Initializes a new instance of the DataStoreItemCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DataStoreItemCollection()
C++
public:
DataStoreItemCollection() sealed
J#
public DataStoreItemCollection()
JScript
public function DataStoreItemCollection()

See Also

DataStoreItemCollection Class


Properties

DataStoreItemCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Gets or sets a datastore item, using the item index
Top

See Also

DataStoreItemCollection Class


Item Property

DataStoreItemCollection.Item Property
[image]

Gets or sets a datastore item, using the item index

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As DataStoreItem
C#
public DataStoreItem this[
int idx
] { get; set; }
C++
public property DataStoreItem default[int idx] sealed {
DataStoreItem get(int idx);
void set(int idx, DataStoreItem value);
}
J#
/** property */
public DataStoreItem get_Item(int idx);

/** property */
public void set_Item(int idx, DataStoreItem value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

DataStoreItemCollection Class


Methods

DataStoreItemCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Adds a datastore item
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DataStoreItemCollection Class


Add Method

DataStoreItemCollection.Add Method
[image]

Adds a datastore item

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As DataStoreItem _
) As Integer
C#
public int Add(
DataStoreItem value
)
C++
public:
int Add(
DataStoreItem value
) sealed
J#
public int Add(
DataStoreItem value
)
JScript
public function Add(
value : DataStoreItem
) : int

Parameters

value
The item to add

Return Value

The newly assigned index

See Also

DataStoreItemCollection Class


DataStoreList Class

DataStoreList Class
See Also Example Members
[image]

Represents a list of data in a featuresource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("DataStoreList", Namespace := "", IsNullable := False)>
Public Class DataStoreList
C#
[XmlRootAttribute("DataStoreList", Namespace = "", IsNullable = False)]
public class DataStoreList
C++
[XmlRootAttribute(L"DataStoreList", Namespace = L"", IsNullable = False)]
ref class DataStoreList
J#
/** @attribute XmlRootAttribute("DataStoreList", Namespace = "", IsNullable = False) */
public class DataStoreList
JScript
public
XmlRootAttribute("DataStoreList", Namespace = "", IsNullable = False)
class DataStoreList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.DataStoreList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DataStoreList Members


DataStoreList Members

DataStoreList Members
See Also Example Constructors Fields Properties Methods
[image]

Represents a list of data in a featuresource

The following tables list the members exposed by DataStoreList.

Public Constructors

 | Name | Description
Public method | DataStoreList | Initializes a new instance of the DataStoreList class.
Top

Public Fields

Name | Description
SchemaName | The name of the xsd document that will be used to validate this class before and after serialization This field is read-only.
Top

Public Properties

 | Name | Description
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | DataStore | Gets or sets the datastore elements
Public property | XsdSchema | Gets the name of the xsd document that will be used to validate this class before and after serialization
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DataStoreList Class


DataStoreList Constructor

DataStoreList Constructor
[image]

Initializes a new instance of the DataStoreList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DataStoreList()
C++
public:
DataStoreList() sealed
J#
public DataStoreList()
JScript
public function DataStoreList()

See Also

DataStoreList Class


Fields

DataStoreList Fields
[image]

Public Fields

Name | Description
SchemaName | The name of the xsd document that will be used to validate this class before and after serialization This field is read-only.
Top

See Also

DataStoreList Class


SchemaName Field

DataStoreList.SchemaName Field
[image]

The name of the xsd document that will be used to validate this class before and after serialization This field is read-only.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Shared ReadOnly SchemaName As String
C#
[XmlIgnoreAttribute]
public static readonly string SchemaName;
C++
[XmlIgnoreAttribute]
public:
static const String SchemaName;
J#
/** @attribute XmlIgnoreAttribute() */
public static final string SchemaName
JScript
public
XmlIgnoreAttribute
static const var SchemaName : String;

See Also

DataStoreList Class


Properties

DataStoreList Properties
[image]

Public Properties

 | Name | Description
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | DataStore | Gets or sets the datastore elements
Public property | XsdSchema | Gets the name of the xsd document that will be used to validate this class before and after serialization
Top

See Also

DataStoreList Class


CurrentConnection Property

DataStoreList.CurrentConnection Property
[image]

Gets or sets the connection used in various operations performed on this object

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property CurrentConnection As ServerConnectionI
C#
[XmlIgnoreAttribute]
public ServerConnectionI CurrentConnection { get; set; }
C++
[XmlIgnoreAttribute]
public property ServerConnectionI CurrentConnection sealed {
ServerConnectionI get();
void set(ServerConnectionI value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public ServerConnectionI get_CurrentConnection();

/** property */
public void set_CurrentConnection(ServerConnectionI value);
JScript
public function get CurrentConnection() : ServerConnectionI

public function set CurrentConnection(value : ServerConnectionI);

See Also

DataStoreList Class


DataStore Property

DataStoreList.DataStore Property
[image]

Gets or sets the datastore elements

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("DataStore")>
Public Property DataStore As DataStoreItemCollection
C#
[XmlElementAttribute("DataStore")]
public DataStoreItemCollection DataStore { get; set; }
C++
[XmlElementAttribute(L"DataStore")]
public property DataStoreItemCollection DataStore sealed {
DataStoreItemCollection get();
void set(DataStoreItemCollection value);
}
J#
/** @attribute XmlElementAttribute("DataStore") */
/** property */
public DataStoreItemCollection get_DataStore();

/** property */
public void set_DataStore(DataStoreItemCollection value);
JScript
public function get DataStore() : DataStoreItemCollection

public function set DataStore(value : DataStoreItemCollection);

See Also

DataStoreList Class


XsdSchema Property

DataStoreList.XsdSchema Property
[image]

Gets the name of the xsd document that will be used to validate this class before and after serialization

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

DataStoreList Class


DataType Enumeration

DataType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum DataType
C#
public enum DataType
C++
public enum class DataType
J#
public enum DataType
JScript
public enum DataType

Members

Member Name | Description
String |
Boolean |
Integer |
Real |
Color |
Angle |
FillColor |
LineColor |
LineWeight |
Content |
Markup |
FontName |
Bold |
Italic |
Underlined |
Overlined |
ObliqueAngle |
TrackSpacing |
FontHeight |
HorizontalAlignment |
VerticalAlignment |
Justification |
LineSpacing |
TextColor |
GhostColor |
FrameLineColor |
FrameFillColor |
StartOffset |
EndOffset |
RepeatX |
RepeatY |

See Also


DoubleCollection Class

DoubleCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class DoubleCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class DoubleCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class DoubleCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class DoubleCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class DoubleCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.DoubleCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DoubleCollection Members


DoubleCollection Members

DoubleCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DoubleCollection.

Public Constructors

 | Name | Description
Public method | DoubleCollection | Initializes a new instance of the DoubleCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DoubleCollection Class


DoubleCollection Constructor

DoubleCollection Constructor
[image]

Initializes a new instance of the DoubleCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DoubleCollection()
C++
public:
DoubleCollection() sealed
J#
public DoubleCollection()
JScript
public function DoubleCollection()

See Also

DoubleCollection Class


Properties

DoubleCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

DoubleCollection Class


Item Property

DoubleCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As Double
C#
public double this[
int idx
] { get; set; }
C++
public property double default[int idx] sealed {
double get(int idx);
void set(int idx, double value);
}
J#
/** property */
public double get_Item(int idx);

/** property */
public void set_Item(int idx, double value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

DoubleCollection Class


Methods

DoubleCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DoubleCollection Class


Add Method

DoubleCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As Double _
) As Integer
C#
public int Add(
double value
)
C++
public:
int Add(
double value
) sealed
J#
public int Add(
double value
)
JScript
public function Add(
value : double
) : int

See Also

DoubleCollection Class


DrawingLayerDefinitionType Class

DrawingLayerDefinitionType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DrawingLayerDefinitionType
Inherits BaseLayerDefinitionType
C#
public class DrawingLayerDefinitionType : BaseLayerDefinitionType
C++
ref class DrawingLayerDefinitionType : BaseLayerDefinitionType
J#
public class DrawingLayerDefinitionType extends BaseLayerDefinitionType
JScript
public class DrawingLayerDefinitionType extends BaseLayerDefinitionType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.BaseLayerDefinitionType
OSGeo.MapGuide.MaestroAPI.DrawingLayerDefinitionType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DrawingLayerDefinitionType Members


DrawingLayerDefinitionType Members

DrawingLayerDefinitionType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DrawingLayerDefinitionType.

Public Constructors

 | Name | Description
Public method | DrawingLayerDefinitionType | Initializes a new instance of the DrawingLayerDefinitionType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | LayerFilter |
Public property | MaxScale |
Public property | MaxScaleSpecified |
Public property | MinScale |
Public property | MinScaleSpecified |
Public property | Opacity | (inherited from BaseLayerDefinitionType)
Public property | OpacitySpecified | (inherited from BaseLayerDefinitionType)
Public property | ResourceId | (inherited from BaseLayerDefinitionType)
Public property | Sheet |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingLayerDefinitionType Class


DrawingLayerDefinitionType Constructor

DrawingLayerDefinitionType Constructor
[image]

Initializes a new instance of the DrawingLayerDefinitionType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DrawingLayerDefinitionType()
C++
public:
DrawingLayerDefinitionType() sealed
J#
public DrawingLayerDefinitionType()
JScript
public function DrawingLayerDefinitionType()

See Also

DrawingLayerDefinitionType Class


Properties

DrawingLayerDefinitionType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | LayerFilter |
Public property | MaxScale |
Public property | MaxScaleSpecified |
Public property | MinScale |
Public property | MinScaleSpecified |
Public property | Opacity | (inherited from BaseLayerDefinitionType)
Public property | OpacitySpecified | (inherited from BaseLayerDefinitionType)
Public property | ResourceId | (inherited from BaseLayerDefinitionType)
Public property | Sheet |
Top

See Also

DrawingLayerDefinitionType Class


ExtendedData1 Property

DrawingLayerDefinitionType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

DrawingLayerDefinitionType Class


LayerFilter Property

DrawingLayerDefinitionType.LayerFilter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LayerFilter As String
C#
public string LayerFilter { get; set; }
C++
public property string LayerFilter sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LayerFilter();

/** property */
public void set_LayerFilter(string value);
JScript
public function get LayerFilter() : String

public function set LayerFilter(value : String);

See Also

DrawingLayerDefinitionType Class


MaxScale Property

DrawingLayerDefinitionType.MaxScale Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxScale As Double
C#
public double MaxScale { get; set; }
C++
public property double MaxScale sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MaxScale();

/** property */
public void set_MaxScale(double value);
JScript
public function get MaxScale() : double

public function set MaxScale(value : double);

See Also

DrawingLayerDefinitionType Class


MaxScaleSpecified Property

DrawingLayerDefinitionType.MaxScaleSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property MaxScaleSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool MaxScaleSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool MaxScaleSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_MaxScaleSpecified();

/** property */
public void set_MaxScaleSpecified(bool value);
JScript
public function get MaxScaleSpecified() : bool

public function set MaxScaleSpecified(value : bool);

See Also

DrawingLayerDefinitionType Class


MinScale Property

DrawingLayerDefinitionType.MinScale Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MinScale As Double
C#
public double MinScale { get; set; }
C++
public property double MinScale sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MinScale();

/** property */
public void set_MinScale(double value);
JScript
public function get MinScale() : double

public function set MinScale(value : double);

See Also

DrawingLayerDefinitionType Class


MinScaleSpecified Property

DrawingLayerDefinitionType.MinScaleSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property MinScaleSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool MinScaleSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool MinScaleSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_MinScaleSpecified();

/** property */
public void set_MinScaleSpecified(bool value);
JScript
public function get MinScaleSpecified() : bool

public function set MinScaleSpecified(value : bool);

See Also

DrawingLayerDefinitionType Class


Sheet Property

DrawingLayerDefinitionType.Sheet Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Sheet As String
C#
public string Sheet { get; set; }
C++
public property string Sheet sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Sheet();

/** property */
public void set_Sheet(string value);
JScript
public function get Sheet() : String

public function set Sheet(value : String);

See Also

DrawingLayerDefinitionType Class


DrawingSection Class

DrawingSection Class
See Also Example Members
[image]

Represents a single drawing section

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DrawingSection
C#
public class DrawingSection
C++
ref class DrawingSection
J#
public class DrawingSection
JScript
public class DrawingSection

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.DrawingSection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DrawingSection Members


DrawingSection Members

DrawingSection Members
See Also Example Constructors Properties Methods
[image]

Represents a single drawing section

The following tables list the members exposed by DrawingSection.

Public Constructors

 | Name | Description
Public method | DrawingSection | Initializes a new instance of the DrawingSection class.
Top

Public Properties

 | Name | Description
Public property | Name | Gets or sets the name of this drawing section
Public property | Title | Gets or sets the title of this drawing section
Public property | Type | Gets or sets the type of this drawing section
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSection Class


DrawingSection Constructor

DrawingSection Constructor
[image]

Initializes a new instance of the DrawingSection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DrawingSection()
C++
public:
DrawingSection() sealed
J#
public DrawingSection()
JScript
public function DrawingSection()

See Also

DrawingSection Class


Properties

DrawingSection Properties
[image]

Public Properties

 | Name | Description
Public property | Name | Gets or sets the name of this drawing section
Public property | Title | Gets or sets the title of this drawing section
Public property | Type | Gets or sets the type of this drawing section
Top

See Also

DrawingSection Class


Name Property

DrawingSection.Name Property
[image]

Gets or sets the name of this drawing section

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

DrawingSection Class


Title Property

DrawingSection.Title Property
[image]

Gets or sets the title of this drawing section

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title { get; set; }
C++
public property string Title sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Title();

/** property */
public void set_Title(string value);
JScript
public function get Title() : String

public function set Title(value : String);

See Also

DrawingSection Class


Type Property

DrawingSection.Type Property
[image]

Gets or sets the type of this drawing section

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
C++
public property string Type sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Type();

/** property */
public void set_Type(string value);
JScript
public function get Type() : String

public function set Type(value : String);

See Also

DrawingSection Class


DrawingSectionCollection Class

DrawingSectionCollection Class
See Also Example Members
[image]

Represents a list of drawing sections

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class DrawingSectionCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class DrawingSectionCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class DrawingSectionCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class DrawingSectionCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class DrawingSectionCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.DrawingSectionCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DrawingSectionCollection Members


DrawingSectionCollection Members

DrawingSectionCollection Members
See Also Example Constructors Properties Methods
[image]

Represents a list of drawing sections

The following tables list the members exposed by DrawingSectionCollection.

Public Constructors

 | Name | Description
Public method | DrawingSectionCollection | Initializes a new instance of the DrawingSectionCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Gets or sets a drawing section, based on the item index
Top

Public Methods

 | Name | Description
Public method | Add | Appends a drawing section to the end of the list
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSectionCollection Class


DrawingSectionCollection Constructor

DrawingSectionCollection Constructor
[image]

Initializes a new instance of the DrawingSectionCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DrawingSectionCollection()
C++
public:
DrawingSectionCollection() sealed
J#
public DrawingSectionCollection()
JScript
public function DrawingSectionCollection()

See Also

DrawingSectionCollection Class


Properties

DrawingSectionCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Gets or sets a drawing section, based on the item index
Top

See Also

DrawingSectionCollection Class


Item Property

DrawingSectionCollection.Item Property
[image]

Gets or sets a drawing section, based on the item index

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As DrawingSection
C#
public DrawingSection this[
int idx
] { get; set; }
C++
public property DrawingSection default[int idx] sealed {
DrawingSection get(int idx);
void set(int idx, DrawingSection value);
}
J#
/** property */
public DrawingSection get_Item(int idx);

/** property */
public void set_Item(int idx, DrawingSection value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

DrawingSectionCollection Class


Methods

DrawingSectionCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Appends a drawing section to the end of the list
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSectionCollection Class


Add Method

DrawingSectionCollection.Add Method
[image]

Appends a drawing section to the end of the list

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As DrawingSection _
) As Integer
C#
public int Add(
DrawingSection value
)
C++
public:
int Add(
DrawingSection value
) sealed
J#
public int Add(
DrawingSection value
)
JScript
public function Add(
value : DrawingSection
) : int

Parameters

value
The drawing section to append

Return Value

The newly assigned index

See Also

DrawingSectionCollection Class


DrawingSectionList Class

DrawingSectionList Class
See Also Example Members
[image]

Represents a Drawing Section

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("DrawingSectionList", Namespace := "", IsNullable := False)>
Public Class DrawingSectionList
C#
[XmlRootAttribute("DrawingSectionList", Namespace = "", IsNullable = False)]
public class DrawingSectionList
C++
[XmlRootAttribute(L"DrawingSectionList", Namespace = L"", IsNullable = False)]
ref class DrawingSectionList
J#
/** @attribute XmlRootAttribute("DrawingSectionList", Namespace = "", IsNullable = False) */
public class DrawingSectionList
JScript
public
XmlRootAttribute("DrawingSectionList", Namespace = "", IsNullable = False)
class DrawingSectionList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.DrawingSectionList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DrawingSectionList Members


DrawingSectionList Members

DrawingSectionList Members
See Also Example Constructors Fields Properties Methods
[image]

Represents a Drawing Section

The following tables list the members exposed by DrawingSectionList.

Public Constructors

 | Name | Description
Public method | DrawingSectionList | Initializes a new instance of the DrawingSectionList class.
Top

Public Fields

Name | Description
SchemaName | The name of the xsd document that will be used to validate this class before and after serialization This field is read-only.
Top

Public Properties

 | Name | Description
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | Section | Gets or sets a list of drawing sections
Public property | XsdSchema | Gets the name of the xsd document that will be used to validate this class before and after serialization
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSectionList Class


DrawingSectionList Constructor

DrawingSectionList Constructor
[image]

Initializes a new instance of the DrawingSectionList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DrawingSectionList()
C++
public:
DrawingSectionList() sealed
J#
public DrawingSectionList()
JScript
public function DrawingSectionList()

See Also

DrawingSectionList Class


Fields

DrawingSectionList Fields
[image]

Public Fields

Name | Description
SchemaName | The name of the xsd document that will be used to validate this class before and after serialization This field is read-only.
Top

See Also

DrawingSectionList Class


SchemaName Field

DrawingSectionList.SchemaName Field
[image]

The name of the xsd document that will be used to validate this class before and after serialization This field is read-only.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

DrawingSectionList Class


Properties

DrawingSectionList Properties
[image]

Public Properties

 | Name | Description
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | Section | Gets or sets a list of drawing sections
Public property | XsdSchema | Gets the name of the xsd document that will be used to validate this class before and after serialization
Top

See Also

DrawingSectionList Class


CurrentConnection Property

DrawingSectionList.CurrentConnection Property
[image]

Gets or sets the connection used in various operations performed on this object

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property CurrentConnection As ServerConnectionI
C#
[XmlIgnoreAttribute]
public ServerConnectionI CurrentConnection { get; set; }
C++
[XmlIgnoreAttribute]
public property ServerConnectionI CurrentConnection sealed {
ServerConnectionI get();
void set(ServerConnectionI value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public ServerConnectionI get_CurrentConnection();

/** property */
public void set_CurrentConnection(ServerConnectionI value);
JScript
public function get CurrentConnection() : ServerConnectionI

public function set CurrentConnection(value : ServerConnectionI);

See Also

DrawingSectionList Class


Section Property

DrawingSectionList.Section Property
[image]

Gets or sets a list of drawing sections

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Section")>
Public Property Section As DrawingSectionCollection
C#
[XmlElementAttribute("Section")]
public DrawingSectionCollection Section { get; set; }
C++
[XmlElementAttribute(L"Section")]
public property DrawingSectionCollection Section sealed {
DrawingSectionCollection get();
void set(DrawingSectionCollection value);
}
J#
/** @attribute XmlElementAttribute("Section") */
/** property */
public DrawingSectionCollection get_Section();

/** property */
public void set_Section(DrawingSectionCollection value);
JScript
public function get Section() : DrawingSectionCollection

public function set Section(value : DrawingSectionCollection);

See Also

DrawingSectionList Class


XsdSchema Property

DrawingSectionList.XsdSchema Property
[image]

Gets the name of the xsd document that will be used to validate this class before and after serialization

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

DrawingSectionList Class


DrawingSectionResource Class

DrawingSectionResource Class
See Also Example Members
[image]

Represents a single DrawingSectionResource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DrawingSectionResource
C#
public class DrawingSectionResource
C++
ref class DrawingSectionResource
J#
public class DrawingSectionResource
JScript
public class DrawingSectionResource

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.DrawingSectionResource

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DrawingSectionResource Members


DrawingSectionResource Members

DrawingSectionResource Members
See Also Example Constructors Properties Methods
[image]

Represents a single DrawingSectionResource

The following tables list the members exposed by DrawingSectionResource.

Public Constructors

 | Name | Description
Public method | DrawingSectionResource | Initializes a new instance of the DrawingSectionResource class.
Top

Public Properties

 | Name | Description
Public property | Href | Gets or sets the resource link
Public property | Mime | Gets or sets the resource mime type
Public property | Role | Gets or sets the resource role
Public property | Title | Gets or sets the resource title
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSectionResource Class


DrawingSectionResource Constructor

DrawingSectionResource Constructor
[image]

Initializes a new instance of the DrawingSectionResource class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DrawingSectionResource()
C++
public:
DrawingSectionResource() sealed
J#
public DrawingSectionResource()
JScript
public function DrawingSectionResource()

See Also

DrawingSectionResource Class


Properties

DrawingSectionResource Properties
[image]

Public Properties

 | Name | Description
Public property | Href | Gets or sets the resource link
Public property | Mime | Gets or sets the resource mime type
Public property | Role | Gets or sets the resource role
Public property | Title | Gets or sets the resource title
Top

See Also

DrawingSectionResource Class


Href Property

DrawingSectionResource.Href Property
[image]

Gets or sets the resource link

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Href As String
C#
public string Href { get; set; }
C++
public property string Href sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Href();

/** property */
public void set_Href(string value);
JScript
public function get Href() : String

public function set Href(value : String);

See Also

DrawingSectionResource Class


Mime Property

DrawingSectionResource.Mime Property
[image]

Gets or sets the resource mime type

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Mime As String
C#
public string Mime { get; set; }
C++
public property string Mime sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Mime();

/** property */
public void set_Mime(string value);
JScript
public function get Mime() : String

public function set Mime(value : String);

See Also

DrawingSectionResource Class


Role Property

DrawingSectionResource.Role Property
[image]

Gets or sets the resource role

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Role As String
C#
public string Role { get; set; }
C++
public property string Role sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Role();

/** property */
public void set_Role(string value);
JScript
public function get Role() : String

public function set Role(value : String);

See Also

DrawingSectionResource Class


Title Property

DrawingSectionResource.Title Property
[image]

Gets or sets the resource title

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title { get; set; }
C++
public property string Title sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Title();

/** property */
public void set_Title(string value);
JScript
public function get Title() : String

public function set Title(value : String);

See Also

DrawingSectionResource Class


DrawingSectionResourceCollection Class

DrawingSectionResourceCollection Class
See Also Example Members
[image]

Represents a list of DrawingSectionResources

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class DrawingSectionResourceCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class DrawingSectionResourceCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class DrawingSectionResourceCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class DrawingSectionResourceCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class DrawingSectionResourceCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.DrawingSectionResourceCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DrawingSectionResourceCollection Members


DrawingSectionResourceCollection Members

DrawingSectionResourceCollection Members
See Also Example Constructors Properties Methods
[image]

Represents a list of DrawingSectionResources

The following tables list the members exposed by DrawingSectionResourceCollection.

Public Constructors

 | Name | Description
Public method | DrawingSectionResourceCollection | Initializes a new instance of the DrawingSectionResourceCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Gets or sets an item, using the collection index
Top

Public Methods

 | Name | Description
Public method | Add | Adds a resource to the collection
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSectionResourceCollection Class


DrawingSectionResourceCollection Constructor

DrawingSectionResourceCollection Constructor
[image]

Initializes a new instance of the DrawingSectionResourceCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DrawingSectionResourceCollection()
C++
public:
DrawingSectionResourceCollection() sealed
J#
public DrawingSectionResourceCollection()
JScript
public function DrawingSectionResourceCollection()

See Also

DrawingSectionResourceCollection Class


Properties

DrawingSectionResourceCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Gets or sets an item, using the collection index
Top

See Also

DrawingSectionResourceCollection Class


Item Property

DrawingSectionResourceCollection.Item Property
[image]

Gets or sets an item, using the collection index

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As DrawingSectionResource
C#
public DrawingSectionResource this[
int idx
] { get; set; }
C++
public property DrawingSectionResource default[int idx] sealed {
DrawingSectionResource get(int idx);
void set(int idx, DrawingSectionResource value);
}
J#
/** property */
public DrawingSectionResource get_Item(int idx);

/** property */
public void set_Item(int idx, DrawingSectionResource value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

DrawingSectionResourceCollection Class


Methods

DrawingSectionResourceCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Adds a resource to the collection
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSectionResourceCollection Class


Add Method

DrawingSectionResourceCollection.Add Method
[image]

Adds a resource to the collection

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As DrawingSectionResource _
) As Integer
C#
public int Add(
DrawingSectionResource value
)
C++
public:
int Add(
DrawingSectionResource value
) sealed
J#
public int Add(
DrawingSectionResource value
)
JScript
public function Add(
value : DrawingSectionResource
) : int

Parameters

value

See Also

DrawingSectionResourceCollection Class


DrawingSectionResourceList Class

DrawingSectionResourceList Class
See Also Example Members
[image]

Represents a DrawingSectionResourceList

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("DrawingSectionResourceList", Namespace := "", IsNullable := False)>
Public Class DrawingSectionResourceList
C#
[XmlRootAttribute("DrawingSectionResourceList", Namespace = "", IsNullable = False)]
public class DrawingSectionResourceList
C++
[XmlRootAttribute(L"DrawingSectionResourceList", Namespace = L"", IsNullable = False)]
ref class DrawingSectionResourceList
J#
/** @attribute XmlRootAttribute("DrawingSectionResourceList", Namespace = "", IsNullable = False) */
public class DrawingSectionResourceList
JScript
public
XmlRootAttribute("DrawingSectionResourceList", Namespace = "", IsNullable = False)
class DrawingSectionResourceList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.DrawingSectionResourceList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DrawingSectionResourceList Members


DrawingSectionResourceList Members

DrawingSectionResourceList Members
See Also Example Constructors Fields Properties Methods
[image]

Represents a DrawingSectionResourceList

The following tables list the members exposed by DrawingSectionResourceList.

Public Constructors

 | Name | Description
Public method | DrawingSectionResourceList | Initializes a new instance of the DrawingSectionResourceList class.
Top

Public Fields

Name | Description
SchemaName | The name of the xsd document that will be used to validate this class before and after serialization This field is read-only.
Top

Public Properties

 | Name | Description
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | SectionResources | Gets or sets the Section Resources
Public property | XsdSchema | Gets the name of the xsd document that will be used to validate this class before and after serialization
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSectionResourceList Class


DrawingSectionResourceList Constructor

DrawingSectionResourceList Constructor
[image]

Initializes a new instance of the DrawingSectionResourceList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DrawingSectionResourceList()
C++
public:
DrawingSectionResourceList() sealed
J#
public DrawingSectionResourceList()
JScript
public function DrawingSectionResourceList()

See Also

DrawingSectionResourceList Class


Fields

DrawingSectionResourceList Fields
[image]

Public Fields

Name | Description
SchemaName | The name of the xsd document that will be used to validate this class before and after serialization This field is read-only.
Top

See Also

DrawingSectionResourceList Class


SchemaName Field

DrawingSectionResourceList.SchemaName Field
[image]

The name of the xsd document that will be used to validate this class before and after serialization This field is read-only.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

DrawingSectionResourceList Class


Properties

DrawingSectionResourceList Properties
[image]

Public Properties

 | Name | Description
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | SectionResources | Gets or sets the Section Resources
Public property | XsdSchema | Gets the name of the xsd document that will be used to validate this class before and after serialization
Top

See Also

DrawingSectionResourceList Class


CurrentConnection Property

DrawingSectionResourceList.CurrentConnection Property
[image]

Gets or sets the connection used in various operations performed on this object

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property CurrentConnection As ServerConnectionI
C#
[XmlIgnoreAttribute]
public ServerConnectionI CurrentConnection { get; set; }
C++
[XmlIgnoreAttribute]
public property ServerConnectionI CurrentConnection sealed {
ServerConnectionI get();
void set(ServerConnectionI value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public ServerConnectionI get_CurrentConnection();

/** property */
public void set_CurrentConnection(ServerConnectionI value);
JScript
public function get CurrentConnection() : ServerConnectionI

public function set CurrentConnection(value : ServerConnectionI);

See Also

DrawingSectionResourceList Class


SectionResources Property

DrawingSectionResourceList.SectionResources Property
[image]

Gets or sets the Section Resources

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("SectionResource")>
Public Property SectionResources As DrawingSectionResourceCollection
C#
[XmlElementAttribute("SectionResource")]
public DrawingSectionResourceCollection SectionResources { get; set; }
C++
[XmlElementAttribute(L"SectionResource")]
public property DrawingSectionResourceCollection SectionResources sealed {
DrawingSectionResourceCollection get();
void set(DrawingSectionResourceCollection value);
}
J#
/** @attribute XmlElementAttribute("SectionResource") */
/** property */
public DrawingSectionResourceCollection get_SectionResources();

/** property */
public void set_SectionResources(DrawingSectionResourceCollection value);
JScript
public function get SectionResources() : DrawingSectionResourceCollection

public function set SectionResources(value : DrawingSectionResourceCollection);

See Also

DrawingSectionResourceList Class


XsdSchema Property

DrawingSectionResourceList.XsdSchema Property
[image]

Gets the name of the xsd document that will be used to validate this class before and after serialization

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

DrawingSectionResourceList Class


DrawingSource Class

DrawingSource Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class DrawingSource
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class DrawingSource
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class DrawingSource
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class DrawingSource
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class DrawingSource

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.DrawingSource

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DrawingSource Members


DrawingSource Members

DrawingSource Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by DrawingSource.

Public Constructors

 | Name | Description
Public method | DrawingSource | Initializes a new instance of the DrawingSource class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | CoordinateSpace |
Public property | Sheet |
Public property | SourceName |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSource Class


DrawingSource Constructor

DrawingSource Constructor
[image]

Initializes a new instance of the DrawingSource class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DrawingSource()
C++
public:
DrawingSource() sealed
J#
public DrawingSource()
JScript
public function DrawingSource()

See Also

DrawingSource Class


Fields

DrawingSource Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

DrawingSource Class


SchemaName Field

DrawingSource.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

DrawingSource Class


Properties

DrawingSource Properties
[image]

Public Properties

 | Name | Description
Public property | CoordinateSpace |
Public property | Sheet |
Public property | SourceName |
Public property | XsdSchema |
Top

See Also

DrawingSource Class


CoordinateSpace Property

DrawingSource.CoordinateSpace Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CoordinateSpace As String
C#
public string CoordinateSpace { get; set; }
C++
public property string CoordinateSpace sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CoordinateSpace();

/** property */
public void set_CoordinateSpace(string value);
JScript
public function get CoordinateSpace() : String

public function set CoordinateSpace(value : String);

See Also

DrawingSource Class


Sheet Property

DrawingSource.Sheet Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Sheet")>
Public Property Sheet As DrawingSourceSheetCollection
C#
[XmlElementAttribute("Sheet")]
public DrawingSourceSheetCollection Sheet { get; set; }
C++
[XmlElementAttribute(L"Sheet")]
public property DrawingSourceSheetCollection Sheet sealed {
DrawingSourceSheetCollection get();
void set(DrawingSourceSheetCollection value);
}
J#
/** @attribute XmlElementAttribute("Sheet") */
/** property */
public DrawingSourceSheetCollection get_Sheet();

/** property */
public void set_Sheet(DrawingSourceSheetCollection value);
JScript
public function get Sheet() : DrawingSourceSheetCollection

public function set Sheet(value : DrawingSourceSheetCollection);

See Also

DrawingSource Class


SourceName Property

DrawingSource.SourceName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SourceName As String
C#
public string SourceName { get; set; }
C++
public property string SourceName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SourceName();

/** property */
public void set_SourceName(string value);
JScript
public function get SourceName() : String

public function set SourceName(value : String);

See Also

DrawingSource Class


XsdSchema Property

DrawingSource.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

DrawingSource Class


DrawingSourceSheet Class

DrawingSourceSheet Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DrawingSourceSheet
C#
public class DrawingSourceSheet
C++
ref class DrawingSourceSheet
J#
public class DrawingSourceSheet
JScript
public class DrawingSourceSheet

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.DrawingSourceSheet

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DrawingSourceSheet Members


DrawingSourceSheet Members

DrawingSourceSheet Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DrawingSourceSheet.

Public Constructors

 | Name | Description
Public method | DrawingSourceSheet | Initializes a new instance of the DrawingSourceSheet class.
Top

Public Properties

 | Name | Description
Public property | Extent |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSourceSheet Class


DrawingSourceSheet Constructor

DrawingSourceSheet Constructor
[image]

Initializes a new instance of the DrawingSourceSheet class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DrawingSourceSheet()
C++
public:
DrawingSourceSheet() sealed
J#
public DrawingSourceSheet()
JScript
public function DrawingSourceSheet()

See Also

DrawingSourceSheet Class


Properties

DrawingSourceSheet Properties
[image]

Public Properties

 | Name | Description
Public property | Extent |
Public property | Name |
Top

See Also

DrawingSourceSheet Class


Extent Property

DrawingSourceSheet.Extent Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Extent As DrawingSourceSheetExtent
C#
public DrawingSourceSheetExtent Extent { get; set; }
C++
public property DrawingSourceSheetExtent Extent sealed {
DrawingSourceSheetExtent get();
void set(DrawingSourceSheetExtent value);
}
J#
/** property */
public DrawingSourceSheetExtent get_Extent();

/** property */
public void set_Extent(DrawingSourceSheetExtent value);
JScript
public function get Extent() : DrawingSourceSheetExtent

public function set Extent(value : DrawingSourceSheetExtent);

See Also

DrawingSourceSheet Class


Name Property

DrawingSourceSheet.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

DrawingSourceSheet Class


DrawingSourceSheetCollection Class

DrawingSourceSheetCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class DrawingSourceSheetCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class DrawingSourceSheetCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class DrawingSourceSheetCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class DrawingSourceSheetCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class DrawingSourceSheetCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.DrawingSourceSheetCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DrawingSourceSheetCollection Members


DrawingSourceSheetCollection Members

DrawingSourceSheetCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DrawingSourceSheetCollection.

Public Constructors

 | Name | Description
Public method | DrawingSourceSheetCollection | Initializes a new instance of the DrawingSourceSheetCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSourceSheetCollection Class


DrawingSourceSheetCollection Constructor

DrawingSourceSheetCollection Constructor
[image]

Initializes a new instance of the DrawingSourceSheetCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DrawingSourceSheetCollection()
C++
public:
DrawingSourceSheetCollection() sealed
J#
public DrawingSourceSheetCollection()
JScript
public function DrawingSourceSheetCollection()

See Also

DrawingSourceSheetCollection Class


Properties

DrawingSourceSheetCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

DrawingSourceSheetCollection Class


Item Property

DrawingSourceSheetCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As DrawingSourceSheet
C#
public DrawingSourceSheet this[
int idx
] { get; set; }
C++
public property DrawingSourceSheet default[int idx] sealed {
DrawingSourceSheet get(int idx);
void set(int idx, DrawingSourceSheet value);
}
J#
/** property */
public DrawingSourceSheet get_Item(int idx);

/** property */
public void set_Item(int idx, DrawingSourceSheet value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

DrawingSourceSheetCollection Class


Methods

DrawingSourceSheetCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSourceSheetCollection Class


Add Method

DrawingSourceSheetCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As DrawingSourceSheet _
) As Integer
C#
public int Add(
DrawingSourceSheet value
)
C++
public:
int Add(
DrawingSourceSheet value
) sealed
J#
public int Add(
DrawingSourceSheet value
)
JScript
public function Add(
value : DrawingSourceSheet
) : int

See Also

DrawingSourceSheetCollection Class


DrawingSourceSheetExtent Class

DrawingSourceSheetExtent Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DrawingSourceSheetExtent
C#
public class DrawingSourceSheetExtent
C++
ref class DrawingSourceSheetExtent
J#
public class DrawingSourceSheetExtent
JScript
public class DrawingSourceSheetExtent

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.DrawingSourceSheetExtent

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DrawingSourceSheetExtent Members


DrawingSourceSheetExtent Members

DrawingSourceSheetExtent Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DrawingSourceSheetExtent.

Public Constructors

 | Name | Description
Public method | DrawingSourceSheetExtent | Initializes a new instance of the DrawingSourceSheetExtent class.
Top

Public Properties

 | Name | Description
Public property | MaxX |
Public property | MaxY |
Public property | MinX |
Public property | MinY |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DrawingSourceSheetExtent Class


DrawingSourceSheetExtent Constructor

DrawingSourceSheetExtent Constructor
[image]

Initializes a new instance of the DrawingSourceSheetExtent class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DrawingSourceSheetExtent()
C++
public:
DrawingSourceSheetExtent() sealed
J#
public DrawingSourceSheetExtent()
JScript
public function DrawingSourceSheetExtent()

See Also

DrawingSourceSheetExtent Class


Properties

DrawingSourceSheetExtent Properties
[image]

Public Properties

 | Name | Description
Public property | MaxX |
Public property | MaxY |
Public property | MinX |
Public property | MinY |
Top

See Also

DrawingSourceSheetExtent Class


MaxX Property

DrawingSourceSheetExtent.MaxX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxX As Double
C#
public double MaxX { get; set; }
C++
public property double MaxX sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MaxX();

/** property */
public void set_MaxX(double value);
JScript
public function get MaxX() : double

public function set MaxX(value : double);

See Also

DrawingSourceSheetExtent Class


MaxY Property

DrawingSourceSheetExtent.MaxY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxY As Double
C#
public double MaxY { get; set; }
C++
public property double MaxY sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MaxY();

/** property */
public void set_MaxY(double value);
JScript
public function get MaxY() : double

public function set MaxY(value : double);

See Also

DrawingSourceSheetExtent Class


MinX Property

DrawingSourceSheetExtent.MinX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MinX As Double
C#
public double MinX { get; set; }
C++
public property double MinX sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MinX();

/** property */
public void set_MinX(double value);
JScript
public function get MinX() : double

public function set MinX(value : double);

See Also

DrawingSourceSheetExtent Class


MinY Property

DrawingSourceSheetExtent.MinY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MinY As Double
C#
public double MinY { get; set; }
C++
public property double MinY sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MinY();

/** property */
public void set_MinY(double value);
JScript
public function get MinY() : double

public function set MinY(value : double);

See Also

DrawingSourceSheetExtent Class


DwfLoadProcedureType Class

DwfLoadProcedureType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DwfLoadProcedureType
Inherits LoadProcedureType
C#
public class DwfLoadProcedureType : LoadProcedureType
C++
ref class DwfLoadProcedureType : LoadProcedureType
J#
public class DwfLoadProcedureType extends LoadProcedureType
JScript
public class DwfLoadProcedureType extends LoadProcedureType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LoadProcedureType
OSGeo.MapGuide.MaestroAPI.DwfLoadProcedureType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DwfLoadProcedureType Members


DwfLoadProcedureType Members

DwfLoadProcedureType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DwfLoadProcedureType.

Public Constructors

 | Name | Description
Public method | DwfLoadProcedureType | Initializes a new instance of the DwfLoadProcedureType class.
Top

Public Properties

 | Name | Description
Public property | CoordinateSystem | (inherited from LoadProcedureType)
Public property | GenerateLayers | (inherited from LoadProcedureType)
Public property | GenerateMaps | (inherited from LoadProcedureType)
Public property | GenerateMapsSpecified | (inherited from LoadProcedureType)
Public property | GenerateSpatialDataSources | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibraries | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibrariesSpecified | (inherited from LoadProcedureType)
Public property | LayersFolder | (inherited from LoadProcedureType)
Public property | LayersPath | (inherited from LoadProcedureType)
Public property | MapsFolder | (inherited from LoadProcedureType)
Public property | MapsPath | (inherited from LoadProcedureType)
Public property | ResourceId | (inherited from LoadProcedureType)
Public property | RootPath | (inherited from LoadProcedureType)
Public property | SourceFile | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesFolder | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesPath | (inherited from LoadProcedureType)
Public property | SymbolLibrariesFolder | (inherited from LoadProcedureType)
Public property | SymbolLibrariesPath | (inherited from LoadProcedureType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DwfLoadProcedureType Class


DwfLoadProcedureType Constructor

DwfLoadProcedureType Constructor
[image]

Initializes a new instance of the DwfLoadProcedureType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DwfLoadProcedureType()
C++
public:
DwfLoadProcedureType() sealed
J#
public DwfLoadProcedureType()
JScript
public function DwfLoadProcedureType()

See Also

DwfLoadProcedureType Class


DwgComponentType Class

DwgComponentType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DwgComponentType
C#
public class DwgComponentType
C++
ref class DwgComponentType
J#
public class DwgComponentType
JScript
public class DwgComponentType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.DwgComponentType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DwgComponentType Members


DwgComponentType Members

DwgComponentType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DwgComponentType.

Public Constructors

 | Name | Description
Public method | DwgComponentType | Initializes a new instance of the DwgComponentType class.
Top

Public Properties

 | Name | Description
Public property | Children |
Public property | DwgHandle |
Public property | Name |
Public property | Selected |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DwgComponentType Class


DwgComponentType Constructor

DwgComponentType Constructor
[image]

Initializes a new instance of the DwgComponentType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DwgComponentType()
C++
public:
DwgComponentType() sealed
J#
public DwgComponentType()
JScript
public function DwgComponentType()

See Also

DwgComponentType Class


Properties

DwgComponentType Properties
[image]

Public Properties

 | Name | Description
Public property | Children |
Public property | DwgHandle |
Public property | Name |
Public property | Selected |
Public property | Type |
Top

See Also

DwgComponentType Class


Children Property

DwgComponentType.Children Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Children")>
Public Property Children As DwgComponentTypeCollection
C#
[XmlElementAttribute("Children")]
public DwgComponentTypeCollection Children { get; set; }
C++
[XmlElementAttribute(L"Children")]
public property DwgComponentTypeCollection Children sealed {
DwgComponentTypeCollection get();
void set(DwgComponentTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("Children") */
/** property */
public DwgComponentTypeCollection get_Children();

/** property */
public void set_Children(DwgComponentTypeCollection value);
JScript
public function get Children() : DwgComponentTypeCollection

public function set Children(value : DwgComponentTypeCollection);

See Also

DwgComponentType Class


DwgHandle Property

DwgComponentType.DwgHandle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DwgHandle As String
C#
public string DwgHandle { get; set; }
C++
public property string DwgHandle sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DwgHandle();

/** property */
public void set_DwgHandle(string value);
JScript
public function get DwgHandle() : String

public function set DwgHandle(value : String);

See Also

DwgComponentType Class


Name Property

DwgComponentType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

DwgComponentType Class


Selected Property

DwgComponentType.Selected Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Selected As Boolean
C#
public bool Selected { get; set; }
C++
public property bool Selected sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Selected();

/** property */
public void set_Selected(bool value);
JScript
public function get Selected() : bool

public function set Selected(value : bool);

See Also

DwgComponentType Class


Type Property

DwgComponentType.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As DwgComponentTypeType
C#
public DwgComponentTypeType Type { get; set; }
C++
public property DwgComponentTypeType Type sealed {
DwgComponentTypeType get();
void set(DwgComponentTypeType value);
}
J#
/** property */
public DwgComponentTypeType get_Type();

/** property */
public void set_Type(DwgComponentTypeType value);
JScript
public function get Type() : DwgComponentTypeType

public function set Type(value : DwgComponentTypeType);

See Also

DwgComponentType Class


DwgComponentTypeCollection Class

DwgComponentTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class DwgComponentTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class DwgComponentTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class DwgComponentTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class DwgComponentTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class DwgComponentTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.DwgComponentTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DwgComponentTypeCollection Members


DwgComponentTypeCollection Members

DwgComponentTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DwgComponentTypeCollection.

Public Constructors

 | Name | Description
Public method | DwgComponentTypeCollection | Initializes a new instance of the DwgComponentTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DwgComponentTypeCollection Class


DwgComponentTypeCollection Constructor

DwgComponentTypeCollection Constructor
[image]

Initializes a new instance of the DwgComponentTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DwgComponentTypeCollection()
C++
public:
DwgComponentTypeCollection() sealed
J#
public DwgComponentTypeCollection()
JScript
public function DwgComponentTypeCollection()

See Also

DwgComponentTypeCollection Class


Properties

DwgComponentTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

DwgComponentTypeCollection Class


Item Property

DwgComponentTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As DwgComponentType
C#
public DwgComponentType this[
int idx
] { get; set; }
C++
public property DwgComponentType default[int idx] sealed {
DwgComponentType get(int idx);
void set(int idx, DwgComponentType value);
}
J#
/** property */
public DwgComponentType get_Item(int idx);

/** property */
public void set_Item(int idx, DwgComponentType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

DwgComponentTypeCollection Class


Methods

DwgComponentTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DwgComponentTypeCollection Class


Add Method

DwgComponentTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As DwgComponentType _
) As Integer
C#
public int Add(
DwgComponentType value
)
C++
public:
int Add(
DwgComponentType value
) sealed
J#
public int Add(
DwgComponentType value
)
JScript
public function Add(
value : DwgComponentType
) : int

See Also

DwgComponentTypeCollection Class


DwgComponentTypeType Enumeration

DwgComponentTypeType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum DwgComponentTypeType
C#
public enum DwgComponentTypeType
C++
public enum class DwgComponentTypeType
J#
public enum DwgComponentTypeType
JScript
public enum DwgComponentTypeType

Members

Member Name | Description
Dwg |
Map |
Group |
Element |
Layer |
QueryCategory |
Query |
ThematicMap |
Theme |

See Also


DwgDriveAliasType Class

DwgDriveAliasType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DwgDriveAliasType
C#
public class DwgDriveAliasType
C++
ref class DwgDriveAliasType
J#
public class DwgDriveAliasType
JScript
public class DwgDriveAliasType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.DwgDriveAliasType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DwgDriveAliasType Members


DwgDriveAliasType Members

DwgDriveAliasType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DwgDriveAliasType.

Public Constructors

 | Name | Description
Public method | DwgDriveAliasType | Initializes a new instance of the DwgDriveAliasType class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Path |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DwgDriveAliasType Class


DwgDriveAliasType Constructor

DwgDriveAliasType Constructor
[image]

Initializes a new instance of the DwgDriveAliasType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DwgDriveAliasType()
C++
public:
DwgDriveAliasType() sealed
J#
public DwgDriveAliasType()
JScript
public function DwgDriveAliasType()

See Also

DwgDriveAliasType Class


Properties

DwgDriveAliasType Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Path |
Top

See Also

DwgDriveAliasType Class


Name Property

DwgDriveAliasType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

DwgDriveAliasType Class


Path Property

DwgDriveAliasType.Path Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; set; }
C++
public property string Path sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Path();

/** property */
public void set_Path(string value);
JScript
public function get Path() : String

public function set Path(value : String);

See Also

DwgDriveAliasType Class


DwgDriveAliasTypeCollection Class

DwgDriveAliasTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class DwgDriveAliasTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class DwgDriveAliasTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class DwgDriveAliasTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class DwgDriveAliasTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class DwgDriveAliasTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.DwgDriveAliasTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DwgDriveAliasTypeCollection Members


DwgDriveAliasTypeCollection Members

DwgDriveAliasTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DwgDriveAliasTypeCollection.

Public Constructors

 | Name | Description
Public method | DwgDriveAliasTypeCollection | Initializes a new instance of the DwgDriveAliasTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DwgDriveAliasTypeCollection Class


DwgDriveAliasTypeCollection Constructor

DwgDriveAliasTypeCollection Constructor
[image]

Initializes a new instance of the DwgDriveAliasTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DwgDriveAliasTypeCollection()
C++
public:
DwgDriveAliasTypeCollection() sealed
J#
public DwgDriveAliasTypeCollection()
JScript
public function DwgDriveAliasTypeCollection()

See Also

DwgDriveAliasTypeCollection Class


Properties

DwgDriveAliasTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

DwgDriveAliasTypeCollection Class


Item Property

DwgDriveAliasTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As DwgDriveAliasType
C#
public DwgDriveAliasType this[
int idx
] { get; set; }
C++
public property DwgDriveAliasType default[int idx] sealed {
DwgDriveAliasType get(int idx);
void set(int idx, DwgDriveAliasType value);
}
J#
/** property */
public DwgDriveAliasType get_Item(int idx);

/** property */
public void set_Item(int idx, DwgDriveAliasType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

DwgDriveAliasTypeCollection Class


Methods

DwgDriveAliasTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DwgDriveAliasTypeCollection Class


Add Method

DwgDriveAliasTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As DwgDriveAliasType _
) As Integer
C#
public int Add(
DwgDriveAliasType value
)
C++
public:
int Add(
DwgDriveAliasType value
) sealed
J#
public int Add(
DwgDriveAliasType value
)
JScript
public function Add(
value : DwgDriveAliasType
) : int

See Also

DwgDriveAliasTypeCollection Class


DwgLoadProcedureType Class

DwgLoadProcedureType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class DwgLoadProcedureType
Inherits LoadProcedureType
C#
public class DwgLoadProcedureType : LoadProcedureType
C++
ref class DwgLoadProcedureType : LoadProcedureType
J#
public class DwgLoadProcedureType extends LoadProcedureType
JScript
public class DwgLoadProcedureType extends LoadProcedureType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LoadProcedureType
OSGeo.MapGuide.MaestroAPI.DwgLoadProcedureType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

DwgLoadProcedureType Members


DwgLoadProcedureType Members

DwgLoadProcedureType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by DwgLoadProcedureType.

Public Constructors

 | Name | Description
Public method | DwgLoadProcedureType | Initializes a new instance of the DwgLoadProcedureType class.
Top

Public Properties

 | Name | Description
Public property | ClosedPolylinesToPolygons |
Public property | CombineComponents |
Public property | Components |
Public property | CoordinateSystem | (inherited from LoadProcedureType)
Public property | DwgDriveAlias |
Public property | Generalization |
Public property | GenerateLayers | (inherited from LoadProcedureType)
Public property | GenerateMaps | (inherited from LoadProcedureType)
Public property | GenerateMapsSpecified | (inherited from LoadProcedureType)
Public property | GenerateSpatialDataSources | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibraries | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibrariesSpecified | (inherited from LoadProcedureType)
Public property | LayersFolder | (inherited from LoadProcedureType)
Public property | LayersPath | (inherited from LoadProcedureType)
Public property | MapsFolder | (inherited from LoadProcedureType)
Public property | MapsPath | (inherited from LoadProcedureType)
Public property | ResourceId | (inherited from LoadProcedureType)
Public property | ResourceType |
Public property | RootPath | (inherited from LoadProcedureType)
Public property | SourceFile | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesFolder | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesPath | (inherited from LoadProcedureType)
Public property | SymbolLibrariesFolder | (inherited from LoadProcedureType)
Public property | SymbolLibrariesPath | (inherited from LoadProcedureType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

DwgLoadProcedureType Class


DwgLoadProcedureType Constructor

DwgLoadProcedureType Constructor
[image]

Initializes a new instance of the DwgLoadProcedureType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public DwgLoadProcedureType()
C++
public:
DwgLoadProcedureType() sealed
J#
public DwgLoadProcedureType()
JScript
public function DwgLoadProcedureType()

See Also

DwgLoadProcedureType Class


Properties

DwgLoadProcedureType Properties
[image]

Public Properties

 | Name | Description
Public property | ClosedPolylinesToPolygons |
Public property | CombineComponents |
Public property | Components |
Public property | CoordinateSystem | (inherited from LoadProcedureType)
Public property | DwgDriveAlias |
Public property | Generalization |
Public property | GenerateLayers | (inherited from LoadProcedureType)
Public property | GenerateMaps | (inherited from LoadProcedureType)
Public property | GenerateMapsSpecified | (inherited from LoadProcedureType)
Public property | GenerateSpatialDataSources | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibraries | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibrariesSpecified | (inherited from LoadProcedureType)
Public property | LayersFolder | (inherited from LoadProcedureType)
Public property | LayersPath | (inherited from LoadProcedureType)
Public property | MapsFolder | (inherited from LoadProcedureType)
Public property | MapsPath | (inherited from LoadProcedureType)
Public property | ResourceId | (inherited from LoadProcedureType)
Public property | ResourceType |
Public property | RootPath | (inherited from LoadProcedureType)
Public property | SourceFile | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesFolder | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesPath | (inherited from LoadProcedureType)
Public property | SymbolLibrariesFolder | (inherited from LoadProcedureType)
Public property | SymbolLibrariesPath | (inherited from LoadProcedureType)
Top

See Also

DwgLoadProcedureType Class


ClosedPolylinesToPolygons Property

DwgLoadProcedureType.ClosedPolylinesToPolygons Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ClosedPolylinesToPolygons As Boolean
C#
public bool ClosedPolylinesToPolygons { get; set; }
C++
public property bool ClosedPolylinesToPolygons sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ClosedPolylinesToPolygons();

/** property */
public void set_ClosedPolylinesToPolygons(bool value);
JScript
public function get ClosedPolylinesToPolygons() : bool

public function set ClosedPolylinesToPolygons(value : bool);

See Also

DwgLoadProcedureType Class


CombineComponents Property

DwgLoadProcedureType.CombineComponents Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CombineComponents As Boolean
C#
public bool CombineComponents { get; set; }
C++
public property bool CombineComponents sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CombineComponents();

/** property */
public void set_CombineComponents(bool value);
JScript
public function get CombineComponents() : bool

public function set CombineComponents(value : bool);

See Also

DwgLoadProcedureType Class


Components Property

DwgLoadProcedureType.Components Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Component", IsNullable := False)>
Public Property Components As DwgComponentTypeCollection
C#
[XmlArrayItemAttribute("Component", IsNullable = False)]
public DwgComponentTypeCollection Components { get; set; }
C++
[XmlArrayItemAttribute(L"Component", IsNullable = False)]
public property DwgComponentTypeCollection Components sealed {
DwgComponentTypeCollection get();
void set(DwgComponentTypeCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Component", IsNullable = False) */
/** property */
public DwgComponentTypeCollection get_Components();

/** property */
public void set_Components(DwgComponentTypeCollection value);
JScript
public function get Components() : DwgComponentTypeCollection

public function set Components(value : DwgComponentTypeCollection);

See Also

DwgLoadProcedureType Class


DwgDriveAlias Property

DwgLoadProcedureType.DwgDriveAlias Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("DwgDriveAlias")>
Public Property DwgDriveAlias As DwgDriveAliasTypeCollection
C#
[XmlElementAttribute("DwgDriveAlias")]
public DwgDriveAliasTypeCollection DwgDriveAlias { get; set; }
C++
[XmlElementAttribute(L"DwgDriveAlias")]
public property DwgDriveAliasTypeCollection DwgDriveAlias sealed {
DwgDriveAliasTypeCollection get();
void set(DwgDriveAliasTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("DwgDriveAlias") */
/** property */
public DwgDriveAliasTypeCollection get_DwgDriveAlias();

/** property */
public void set_DwgDriveAlias(DwgDriveAliasTypeCollection value);
JScript
public function get DwgDriveAlias() : DwgDriveAliasTypeCollection

public function set DwgDriveAlias(value : DwgDriveAliasTypeCollection);

See Also

DwgLoadProcedureType Class


Generalization Property

DwgLoadProcedureType.Generalization Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Generalization As Double
C#
public double Generalization { get; set; }
C++
public property double Generalization sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Generalization();

/** property */
public void set_Generalization(double value);
JScript
public function get Generalization() : double

public function set Generalization(value : double);

See Also

DwgLoadProcedureType Class


ResourceType Property

DwgLoadProcedureType.ResourceType Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceType As DwgResourceTypeType
C#
public DwgResourceTypeType ResourceType { get; set; }
C++
public property DwgResourceTypeType ResourceType sealed {
DwgResourceTypeType get();
void set(DwgResourceTypeType value);
}
J#
/** property */
public DwgResourceTypeType get_ResourceType();

/** property */
public void set_ResourceType(DwgResourceTypeType value);
JScript
public function get ResourceType() : DwgResourceTypeType

public function set ResourceType(value : DwgResourceTypeType);

See Also

DwgLoadProcedureType Class


DwgResourceTypeType Enumeration

DwgResourceTypeType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum DwgResourceTypeType
C#
public enum DwgResourceTypeType
C++
public enum class DwgResourceTypeType
J#
public enum DwgResourceTypeType
JScript
public enum DwgResourceTypeType

Members

Member Name | Description
Feature |
Drawing |

See Also


ElevationSettingsType Class

ElevationSettingsType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ElevationSettingsType
C#
public class ElevationSettingsType
C++
ref class ElevationSettingsType
J#
public class ElevationSettingsType
JScript
public class ElevationSettingsType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ElevationSettingsType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ElevationSettingsType Members


ElevationSettingsType Members

ElevationSettingsType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ElevationSettingsType.

Public Constructors

 | Name | Description
Public method | ElevationSettingsType | Initializes a new instance of the ElevationSettingsType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Unit |
Public property | UnitSpecified |
Public property | ZExtrusion |
Public property | ZOffset |
Public property | ZOffsetType |
Public property | ZOffsetTypeSpecified |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ElevationSettingsType Class


ElevationSettingsType Constructor

ElevationSettingsType Constructor
[image]

Initializes a new instance of the ElevationSettingsType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ElevationSettingsType()
C++
public:
ElevationSettingsType() sealed
J#
public ElevationSettingsType()
JScript
public function ElevationSettingsType()

See Also

ElevationSettingsType Class


Properties

ElevationSettingsType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Unit |
Public property | UnitSpecified |
Public property | ZExtrusion |
Public property | ZOffset |
Public property | ZOffsetType |
Public property | ZOffsetTypeSpecified |
Top

See Also

ElevationSettingsType Class


ExtendedData1 Property

ElevationSettingsType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

ElevationSettingsType Class


Unit Property

ElevationSettingsType.Unit Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Unit As LengthUnitType
C#
public LengthUnitType Unit { get; set; }
C++
public property LengthUnitType Unit sealed {
LengthUnitType get();
void set(LengthUnitType value);
}
J#
/** property */
public LengthUnitType get_Unit();

/** property */
public void set_Unit(LengthUnitType value);
JScript
public function get Unit() : LengthUnitType

public function set Unit(value : LengthUnitType);

See Also

ElevationSettingsType Class


UnitSpecified Property

ElevationSettingsType.UnitSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property UnitSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool UnitSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool UnitSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_UnitSpecified();

/** property */
public void set_UnitSpecified(bool value);
JScript
public function get UnitSpecified() : bool

public function set UnitSpecified(value : bool);

See Also

ElevationSettingsType Class


ZExtrusion Property

ElevationSettingsType.ZExtrusion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ZExtrusion As String
C#
public string ZExtrusion { get; set; }
C++
public property string ZExtrusion sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ZExtrusion();

/** property */
public void set_ZExtrusion(string value);
JScript
public function get ZExtrusion() : String

public function set ZExtrusion(value : String);

See Also

ElevationSettingsType Class


ZOffset Property

ElevationSettingsType.ZOffset Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ZOffset As String
C#
public string ZOffset { get; set; }
C++
public property string ZOffset sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ZOffset();

/** property */
public void set_ZOffset(string value);
JScript
public function get ZOffset() : String

public function set ZOffset(value : String);

See Also

ElevationSettingsType Class


ZOffsetType Property

ElevationSettingsType.ZOffsetType Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ZOffsetType As ElevationTypeType
C#
public ElevationTypeType ZOffsetType { get; set; }
C++
public property ElevationTypeType ZOffsetType sealed {
ElevationTypeType get();
void set(ElevationTypeType value);
}
J#
/** property */
public ElevationTypeType get_ZOffsetType();

/** property */
public void set_ZOffsetType(ElevationTypeType value);
JScript
public function get ZOffsetType() : ElevationTypeType

public function set ZOffsetType(value : ElevationTypeType);

See Also

ElevationSettingsType Class


ZOffsetTypeSpecified Property

ElevationSettingsType.ZOffsetTypeSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ZOffsetTypeSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ZOffsetTypeSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ZOffsetTypeSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ZOffsetTypeSpecified();

/** property */
public void set_ZOffsetTypeSpecified(bool value);
JScript
public function get ZOffsetTypeSpecified() : bool

public function set ZOffsetTypeSpecified(value : bool);

See Also

ElevationSettingsType Class


ElevationTypeType Enumeration

ElevationTypeType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ElevationTypeType
C#
public enum ElevationTypeType
C++
public enum class ElevationTypeType
J#
public enum ElevationTypeType
JScript
public enum ElevationTypeType

Members

Member Name | Description
RelativeToGround |
Absolute |

See Also


Envelope Class

Envelope Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class Envelope
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class Envelope
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class Envelope
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class Envelope
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class Envelope

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.Envelope

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Envelope Members


Envelope Members

Envelope Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by Envelope.

Public Constructors

 | Name | Description
Public method | Envelope | Initializes a new instance of the Envelope class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | LowerLeftCoordinate |
Public property | UpperRightCoordinate |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Envelope Class


Envelope Constructor

Envelope Constructor
[image]

Initializes a new instance of the Envelope class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Envelope()
C++
public:
Envelope() sealed
J#
public Envelope()
JScript
public function Envelope()

See Also

Envelope Class


Fields

Envelope Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

Envelope Class


SchemaName Field

Envelope.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

Envelope Class


Properties

Envelope Properties
[image]

Public Properties

 | Name | Description
Public property | LowerLeftCoordinate |
Public property | UpperRightCoordinate |
Public property | XsdSchema |
Top

See Also

Envelope Class


LowerLeftCoordinate Property

Envelope.LowerLeftCoordinate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LowerLeftCoordinate As EnvelopeLowerLeftCoordinate
C#
public EnvelopeLowerLeftCoordinate LowerLeftCoordinate { get; set; }
C++
public property EnvelopeLowerLeftCoordinate LowerLeftCoordinate sealed {
EnvelopeLowerLeftCoordinate get();
void set(EnvelopeLowerLeftCoordinate value);
}
J#
/** property */
public EnvelopeLowerLeftCoordinate get_LowerLeftCoordinate();

/** property */
public void set_LowerLeftCoordinate(EnvelopeLowerLeftCoordinate value);
JScript
public function get LowerLeftCoordinate() : EnvelopeLowerLeftCoordinate

public function set LowerLeftCoordinate(value : EnvelopeLowerLeftCoordinate);

See Also

Envelope Class


UpperRightCoordinate Property

Envelope.UpperRightCoordinate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property UpperRightCoordinate As EnvelopeUpperRightCoordinate
C#
public EnvelopeUpperRightCoordinate UpperRightCoordinate { get; set; }
C++
public property EnvelopeUpperRightCoordinate UpperRightCoordinate sealed {
EnvelopeUpperRightCoordinate get();
void set(EnvelopeUpperRightCoordinate value);
}
J#
/** property */
public EnvelopeUpperRightCoordinate get_UpperRightCoordinate();

/** property */
public void set_UpperRightCoordinate(EnvelopeUpperRightCoordinate value);
JScript
public function get UpperRightCoordinate() : EnvelopeUpperRightCoordinate

public function set UpperRightCoordinate(value : EnvelopeUpperRightCoordinate);

See Also

Envelope Class


XsdSchema Property

Envelope.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

Envelope Class


EnvelopeLowerLeftCoordinate Class

EnvelopeLowerLeftCoordinate Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class EnvelopeLowerLeftCoordinate
C#
public class EnvelopeLowerLeftCoordinate
C++
ref class EnvelopeLowerLeftCoordinate
J#
public class EnvelopeLowerLeftCoordinate
JScript
public class EnvelopeLowerLeftCoordinate

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.EnvelopeLowerLeftCoordinate

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

EnvelopeLowerLeftCoordinate Members


EnvelopeLowerLeftCoordinate Members

EnvelopeLowerLeftCoordinate Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by EnvelopeLowerLeftCoordinate.

Public Constructors

 | Name | Description
Public method | EnvelopeLowerLeftCoordinate | Initializes a new instance of the EnvelopeLowerLeftCoordinate class.
Top

Public Properties

 | Name | Description
Public property | M |
Public property | X |
Public property | Y |
Public property | Z |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

EnvelopeLowerLeftCoordinate Class


EnvelopeLowerLeftCoordinate Constructor

EnvelopeLowerLeftCoordinate Constructor
[image]

Initializes a new instance of the EnvelopeLowerLeftCoordinate class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public EnvelopeLowerLeftCoordinate()
C++
public:
EnvelopeLowerLeftCoordinate() sealed
J#
public EnvelopeLowerLeftCoordinate()
JScript
public function EnvelopeLowerLeftCoordinate()

See Also

EnvelopeLowerLeftCoordinate Class


Properties

EnvelopeLowerLeftCoordinate Properties
[image]

Public Properties

 | Name | Description
Public property | M |
Public property | X |
Public property | Y |
Public property | Z |
Top

See Also

EnvelopeLowerLeftCoordinate Class


M Property

EnvelopeLowerLeftCoordinate.M Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property M As Double
C#
public double M { get; set; }
C++
public property double M sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_M();

/** property */
public void set_M(double value);
JScript
public function get M() : double

public function set M(value : double);

See Also

EnvelopeLowerLeftCoordinate Class


X Property

EnvelopeLowerLeftCoordinate.X Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property X As Double
C#
public double X { get; set; }
C++
public property double X sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_X();

/** property */
public void set_X(double value);
JScript
public function get X() : double

public function set X(value : double);

See Also

EnvelopeLowerLeftCoordinate Class


Y Property

EnvelopeLowerLeftCoordinate.Y Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Y As Double
C#
public double Y { get; set; }
C++
public property double Y sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Y();

/** property */
public void set_Y(double value);
JScript
public function get Y() : double

public function set Y(value : double);

See Also

EnvelopeLowerLeftCoordinate Class


Z Property

EnvelopeLowerLeftCoordinate.Z Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Z As Double
C#
public double Z { get; set; }
C++
public property double Z sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Z();

/** property */
public void set_Z(double value);
JScript
public function get Z() : double

public function set Z(value : double);

See Also

EnvelopeLowerLeftCoordinate Class


EnvelopeUpperRightCoordinate Class

EnvelopeUpperRightCoordinate Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class EnvelopeUpperRightCoordinate
C#
public class EnvelopeUpperRightCoordinate
C++
ref class EnvelopeUpperRightCoordinate
J#
public class EnvelopeUpperRightCoordinate
JScript
public class EnvelopeUpperRightCoordinate

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.EnvelopeUpperRightCoordinate

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

EnvelopeUpperRightCoordinate Members


EnvelopeUpperRightCoordinate Members

EnvelopeUpperRightCoordinate Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by EnvelopeUpperRightCoordinate.

Public Constructors

 | Name | Description
Public method | EnvelopeUpperRightCoordinate | Initializes a new instance of the EnvelopeUpperRightCoordinate class.
Top

Public Properties

 | Name | Description
Public property | M |
Public property | X |
Public property | Y |
Public property | Z |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

EnvelopeUpperRightCoordinate Class


EnvelopeUpperRightCoordinate Constructor

EnvelopeUpperRightCoordinate Constructor
[image]

Initializes a new instance of the EnvelopeUpperRightCoordinate class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public EnvelopeUpperRightCoordinate()
C++
public:
EnvelopeUpperRightCoordinate() sealed
J#
public EnvelopeUpperRightCoordinate()
JScript
public function EnvelopeUpperRightCoordinate()

See Also

EnvelopeUpperRightCoordinate Class


Properties

EnvelopeUpperRightCoordinate Properties
[image]

Public Properties

 | Name | Description
Public property | M |
Public property | X |
Public property | Y |
Public property | Z |
Top

See Also

EnvelopeUpperRightCoordinate Class


M Property

EnvelopeUpperRightCoordinate.M Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property M As String
C#
public string M { get; set; }
C++
public property string M sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_M();

/** property */
public void set_M(string value);
JScript
public function get M() : String

public function set M(value : String);

See Also

EnvelopeUpperRightCoordinate Class


X Property

EnvelopeUpperRightCoordinate.X Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property X As String
C#
public string X { get; set; }
C++
public property string X sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_X();

/** property */
public void set_X(string value);
JScript
public function get X() : String

public function set X(value : String);

See Also

EnvelopeUpperRightCoordinate Class


Y Property

EnvelopeUpperRightCoordinate.Y Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Y As String
C#
public string Y { get; set; }
C++
public property string Y sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Y();

/** property */
public void set_Y(string value);
JScript
public function get Y() : String

public function set Y(value : String);

See Also

EnvelopeUpperRightCoordinate Class


Z Property

EnvelopeUpperRightCoordinate.Z Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Z As String
C#
public string Z { get; set; }
C++
public property string Z sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Z();

/** property */
public void set_Z(string value);
JScript
public function get Z() : String

public function set Z(value : String);

See Also

EnvelopeUpperRightCoordinate Class


ExtendedDataType Class

ExtendedDataType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ExtendedDataType
C#
public class ExtendedDataType
C++
ref class ExtendedDataType
J#
public class ExtendedDataType
JScript
public class ExtendedDataType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ExtendedDataType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ExtendedDataType Members


ExtendedDataType Members

ExtendedDataType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ExtendedDataType.

Public Constructors

 | Name | Description
Public method | ExtendedDataType | Initializes a new instance of the ExtendedDataType class.
Top

Public Properties

 | Name | Description
Public property | Any |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExtendedDataType Class


ExtendedDataType Constructor

ExtendedDataType Constructor
[image]

Initializes a new instance of the ExtendedDataType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ExtendedDataType()
C++
public:
ExtendedDataType() sealed
J#
public ExtendedDataType()
JScript
public function ExtendedDataType()

See Also

ExtendedDataType Class


Properties

ExtendedDataType Properties
[image]

Public Properties

 | Name | Description
Public property | Any |
Top

See Also

ExtendedDataType Class


Any Property

ExtendedDataType.Any Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAnyElementAttribute>
Public Property Any As XmlElement()
C#
[XmlAnyElementAttribute]
public XmlElement[] Any { get; set; }
C++
[XmlAnyElementAttribute]
public property XmlElement[] Any sealed {
array<XmlElement>^ get();
void set(array<XmlElement>^ value);
}
J#
/** @attribute XmlAnyElementAttribute() */
/** property */
public XmlElement[] get_Any();

/** property */
public void set_Any(XmlElement[] value);
JScript
public function get Any() : XmlElement[]

public function set Any(value : XmlElement[]);

See Also

ExtendedDataType Class


FdoLongTransactionList Class

FdoLongTransactionList Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class FdoLongTransactionList
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class FdoLongTransactionList
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class FdoLongTransactionList
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class FdoLongTransactionList
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class FdoLongTransactionList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoLongTransactionList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoLongTransactionList Members


FdoLongTransactionList Members

FdoLongTransactionList Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by FdoLongTransactionList.

Public Constructors

 | Name | Description
Public method | FdoLongTransactionList | Initializes a new instance of the FdoLongTransactionList class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | LongTransaction |
Public property | ProviderName |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoLongTransactionList Class


FdoLongTransactionList Constructor

FdoLongTransactionList Constructor
[image]

Initializes a new instance of the FdoLongTransactionList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoLongTransactionList()
C++
public:
FdoLongTransactionList() sealed
J#
public FdoLongTransactionList()
JScript
public function FdoLongTransactionList()

See Also

FdoLongTransactionList Class


Fields

FdoLongTransactionList Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

FdoLongTransactionList Class


SchemaName Field

FdoLongTransactionList.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

FdoLongTransactionList Class


Properties

FdoLongTransactionList Properties
[image]

Public Properties

 | Name | Description
Public property | LongTransaction |
Public property | ProviderName |
Public property | XsdSchema |
Top

See Also

FdoLongTransactionList Class


LongTransaction Property

FdoLongTransactionList.LongTransaction Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("LongTransaction")>
Public Property LongTransaction As FdoLongTransactionListLongTransactionCollection
C#
[XmlElementAttribute("LongTransaction")]
public FdoLongTransactionListLongTransactionCollection LongTransaction { get; set; }
C++
[XmlElementAttribute(L"LongTransaction")]
public property FdoLongTransactionListLongTransactionCollection LongTransaction sealed {
FdoLongTransactionListLongTransactionCollection get();
void set(FdoLongTransactionListLongTransactionCollection value);
}
J#
/** @attribute XmlElementAttribute("LongTransaction") */
/** property */
public FdoLongTransactionListLongTransactionCollection get_LongTransaction();

/** property */
public void set_LongTransaction(FdoLongTransactionListLongTransactionCollection value);
JScript
public function get LongTransaction() : FdoLongTransactionListLongTransactionCollection

public function set LongTransaction(value : FdoLongTransactionListLongTransactionCollection);

See Also

FdoLongTransactionList Class


ProviderName Property

FdoLongTransactionList.ProviderName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ProviderName As String
C#
public string ProviderName { get; set; }
C++
public property string ProviderName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ProviderName();

/** property */
public void set_ProviderName(string value);
JScript
public function get ProviderName() : String

public function set ProviderName(value : String);

See Also

FdoLongTransactionList Class


XsdSchema Property

FdoLongTransactionList.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

FdoLongTransactionList Class


FdoLongTransactionListLongTransaction Class

FdoLongTransactionListLongTransaction Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoLongTransactionListLongTransaction
C#
public class FdoLongTransactionListLongTransaction
C++
ref class FdoLongTransactionListLongTransaction
J#
public class FdoLongTransactionListLongTransaction
JScript
public class FdoLongTransactionListLongTransaction

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoLongTransactionListLongTransaction

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoLongTransactionListLongTransaction Members


FdoLongTransactionListLongTransaction Members

FdoLongTransactionListLongTransaction Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoLongTransactionListLongTransaction.

Public Constructors

 | Name | Description
Public method | FdoLongTransactionListLongTransaction | Initializes a new instance of the FdoLongTransactionListLongTransaction class.
Top

Public Properties

 | Name | Description
Public property | CreationDate |
Public property | Description |
Public property | IsActive |
Public property | IsFrozen |
Public property | Name |
Public property | Owner |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoLongTransactionListLongTransaction Class


FdoLongTransactionListLongTransaction Constructor

FdoLongTransactionListLongTransaction Constructor
[image]

Initializes a new instance of the FdoLongTransactionListLongTransaction class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoLongTransactionListLongTransaction()
C++
public:
FdoLongTransactionListLongTransaction() sealed
J#
public FdoLongTransactionListLongTransaction()
JScript
public function FdoLongTransactionListLongTransaction()

See Also

FdoLongTransactionListLongTransaction Class


Properties

FdoLongTransactionListLongTransaction Properties
[image]

Public Properties

 | Name | Description
Public property | CreationDate |
Public property | Description |
Public property | IsActive |
Public property | IsFrozen |
Public property | Name |
Public property | Owner |
Top

See Also

FdoLongTransactionListLongTransaction Class


CreationDate Property

FdoLongTransactionListLongTransaction.CreationDate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CreationDate As String
C#
public string CreationDate { get; set; }
C++
public property string CreationDate sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CreationDate();

/** property */
public void set_CreationDate(string value);
JScript
public function get CreationDate() : String

public function set CreationDate(value : String);

See Also

FdoLongTransactionListLongTransaction Class


Description Property

FdoLongTransactionListLongTransaction.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

FdoLongTransactionListLongTransaction Class


IsActive Property

FdoLongTransactionListLongTransaction.IsActive Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute>
Public Property IsActive As Boolean
C#
[XmlAttributeAttribute]
public bool IsActive { get; set; }
C++
[XmlAttributeAttribute]
public property bool IsActive sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** property */
public bool get_IsActive();

/** property */
public void set_IsActive(bool value);
JScript
public function get IsActive() : bool

public function set IsActive(value : bool);

See Also

FdoLongTransactionListLongTransaction Class


IsFrozen Property

FdoLongTransactionListLongTransaction.IsFrozen Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute>
Public Property IsFrozen As Boolean
C#
[XmlAttributeAttribute]
public bool IsFrozen { get; set; }
C++
[XmlAttributeAttribute]
public property bool IsFrozen sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** property */
public bool get_IsFrozen();

/** property */
public void set_IsFrozen(bool value);
JScript
public function get IsFrozen() : bool

public function set IsFrozen(value : bool);

See Also

FdoLongTransactionListLongTransaction Class


Name Property

FdoLongTransactionListLongTransaction.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

FdoLongTransactionListLongTransaction Class


Owner Property

FdoLongTransactionListLongTransaction.Owner Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
C++
public property string Owner sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Owner();

/** property */
public void set_Owner(string value);
JScript
public function get Owner() : String

public function set Owner(value : String);

See Also

FdoLongTransactionListLongTransaction Class


FdoLongTransactionListLongTransactionCollection Class

FdoLongTransactionListLongTransactionCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoLongTransactionListLongTransactionCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoLongTransactionListLongTransactionCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoLongTransactionListLongTransactionCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoLongTransactionListLongTransactionCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoLongTransactionListLongTransactionCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoLongTransactionListLongTransactionCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoLongTransactionListLongTransactionCollection Members


FdoLongTransactionListLongTransactionCollection Members

FdoLongTransactionListLongTransactionCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoLongTransactionListLongTransactionCollection.

Public Constructors

 | Name | Description
Public method | FdoLongTransactionListLongTransactionCollection | Initializes a new instance of the FdoLongTransactionListLongTransactionCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoLongTransactionListLongTransactionCollection Class


FdoLongTransactionListLongTransactionCollection Constructor

FdoLongTransactionListLongTransactionCollection Constructor
[image]

Initializes a new instance of the FdoLongTransactionListLongTransactionCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoLongTransactionListLongTransactionCollection()
C++
public:
FdoLongTransactionListLongTransactionCollection() sealed
J#
public FdoLongTransactionListLongTransactionCollection()
JScript
public function FdoLongTransactionListLongTransactionCollection()

See Also

FdoLongTransactionListLongTransactionCollection Class


Properties

FdoLongTransactionListLongTransactionCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoLongTransactionListLongTransactionCollection Class


Item Property

FdoLongTransactionListLongTransactionCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoLongTransactionListLongTransaction
C#
public FdoLongTransactionListLongTransaction this[
int idx
] { get; set; }
C++
public property FdoLongTransactionListLongTransaction default[int idx] sealed {
FdoLongTransactionListLongTransaction get(int idx);
void set(int idx, FdoLongTransactionListLongTransaction value);
}
J#
/** property */
public FdoLongTransactionListLongTransaction get_Item(int idx);

/** property */
public void set_Item(int idx, FdoLongTransactionListLongTransaction value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoLongTransactionListLongTransactionCollection Class


Methods

FdoLongTransactionListLongTransactionCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoLongTransactionListLongTransactionCollection Class


Add Method

FdoLongTransactionListLongTransactionCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoLongTransactionListLongTransaction _
) As Integer
C#
public int Add(
FdoLongTransactionListLongTransaction value
)
C++
public:
int Add(
FdoLongTransactionListLongTransaction value
) sealed
J#
public int Add(
FdoLongTransactionListLongTransaction value
)
JScript
public function Add(
value : FdoLongTransactionListLongTransaction
) : int

See Also

FdoLongTransactionListLongTransactionCollection Class


FdoProviderCapabilities Class

FdoProviderCapabilities Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("FeatureProviderCapabilities", Namespace := "", IsNullable := False)>
Public Class FdoProviderCapabilities
C#
[XmlRootAttribute("FeatureProviderCapabilities", Namespace = "", IsNullable = False)]
public class FdoProviderCapabilities
C++
[XmlRootAttribute(L"FeatureProviderCapabilities", Namespace = L"", IsNullable = False)]
ref class FdoProviderCapabilities
J#
/** @attribute XmlRootAttribute("FeatureProviderCapabilities", Namespace = "", IsNullable = False) */
public class FdoProviderCapabilities
JScript
public
XmlRootAttribute("FeatureProviderCapabilities", Namespace = "", IsNullable = False)
class FdoProviderCapabilities

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilities

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilities Members


FdoProviderCapabilities Members

FdoProviderCapabilities Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilities.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilities | Initializes a new instance of the FdoProviderCapabilities class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Command |
Public property | Connection |
Public property | Expression |
Public property | Filter |
Public property | Geometry |
Public property | Provider |
Public property | Raster |
Public property | Schema |
Public property | Topology |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilities Class


FdoProviderCapabilities Constructor

FdoProviderCapabilities Constructor
[image]

Initializes a new instance of the FdoProviderCapabilities class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilities()
C++
public:
FdoProviderCapabilities() sealed
J#
public FdoProviderCapabilities()
JScript
public function FdoProviderCapabilities()

See Also

FdoProviderCapabilities Class


Fields

FdoProviderCapabilities Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

FdoProviderCapabilities Class


SchemaName Field

FdoProviderCapabilities.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

FdoProviderCapabilities Class


Properties

FdoProviderCapabilities Properties
[image]

Public Properties

 | Name | Description
Public property | Command |
Public property | Connection |
Public property | Expression |
Public property | Filter |
Public property | Geometry |
Public property | Provider |
Public property | Raster |
Public property | Schema |
Public property | Topology |
Public property | XsdSchema |
Top

See Also

FdoProviderCapabilities Class


Command Property

FdoProviderCapabilities.Command Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Command As FdoProviderCapabilitiesCommand
C#
public FdoProviderCapabilitiesCommand Command { get; set; }
C++
public property FdoProviderCapabilitiesCommand Command sealed {
FdoProviderCapabilitiesCommand get();
void set(FdoProviderCapabilitiesCommand value);
}
J#
/** property */
public FdoProviderCapabilitiesCommand get_Command();

/** property */
public void set_Command(FdoProviderCapabilitiesCommand value);
JScript
public function get Command() : FdoProviderCapabilitiesCommand

public function set Command(value : FdoProviderCapabilitiesCommand);

See Also

FdoProviderCapabilities Class


Connection Property

FdoProviderCapabilities.Connection Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Connection As FdoProviderCapabilitiesConnection
C#
public FdoProviderCapabilitiesConnection Connection { get; set; }
C++
public property FdoProviderCapabilitiesConnection Connection sealed {
FdoProviderCapabilitiesConnection get();
void set(FdoProviderCapabilitiesConnection value);
}
J#
/** property */
public FdoProviderCapabilitiesConnection get_Connection();

/** property */
public void set_Connection(FdoProviderCapabilitiesConnection value);
JScript
public function get Connection() : FdoProviderCapabilitiesConnection

public function set Connection(value : FdoProviderCapabilitiesConnection);

See Also

FdoProviderCapabilities Class


Expression Property

FdoProviderCapabilities.Expression Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Expression As FdoProviderCapabilitiesExpression
C#
public FdoProviderCapabilitiesExpression Expression { get; set; }
C++
public property FdoProviderCapabilitiesExpression Expression sealed {
FdoProviderCapabilitiesExpression get();
void set(FdoProviderCapabilitiesExpression value);
}
J#
/** property */
public FdoProviderCapabilitiesExpression get_Expression();

/** property */
public void set_Expression(FdoProviderCapabilitiesExpression value);
JScript
public function get Expression() : FdoProviderCapabilitiesExpression

public function set Expression(value : FdoProviderCapabilitiesExpression);

See Also

FdoProviderCapabilities Class


Filter Property

FdoProviderCapabilities.Filter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As FdoProviderCapabilitiesFilter
C#
public FdoProviderCapabilitiesFilter Filter { get; set; }
C++
public property FdoProviderCapabilitiesFilter Filter sealed {
FdoProviderCapabilitiesFilter get();
void set(FdoProviderCapabilitiesFilter value);
}
J#
/** property */
public FdoProviderCapabilitiesFilter get_Filter();

/** property */
public void set_Filter(FdoProviderCapabilitiesFilter value);
JScript
public function get Filter() : FdoProviderCapabilitiesFilter

public function set Filter(value : FdoProviderCapabilitiesFilter);

See Also

FdoProviderCapabilities Class


Geometry Property

FdoProviderCapabilities.Geometry Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Geometry As FdoProviderCapabilitiesGeometry
C#
public FdoProviderCapabilitiesGeometry Geometry { get; set; }
C++
public property FdoProviderCapabilitiesGeometry Geometry sealed {
FdoProviderCapabilitiesGeometry get();
void set(FdoProviderCapabilitiesGeometry value);
}
J#
/** property */
public FdoProviderCapabilitiesGeometry get_Geometry();

/** property */
public void set_Geometry(FdoProviderCapabilitiesGeometry value);
JScript
public function get Geometry() : FdoProviderCapabilitiesGeometry

public function set Geometry(value : FdoProviderCapabilitiesGeometry);

See Also

FdoProviderCapabilities Class


Provider Property

FdoProviderCapabilities.Provider Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Provider As FdoProviderCapabilitiesProvider
C#
public FdoProviderCapabilitiesProvider Provider { get; set; }
C++
public property FdoProviderCapabilitiesProvider Provider sealed {
FdoProviderCapabilitiesProvider get();
void set(FdoProviderCapabilitiesProvider value);
}
J#
/** property */
public FdoProviderCapabilitiesProvider get_Provider();

/** property */
public void set_Provider(FdoProviderCapabilitiesProvider value);
JScript
public function get Provider() : FdoProviderCapabilitiesProvider

public function set Provider(value : FdoProviderCapabilitiesProvider);

See Also

FdoProviderCapabilities Class


Raster Property

FdoProviderCapabilities.Raster Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Raster As FdoProviderCapabilitiesRaster
C#
public FdoProviderCapabilitiesRaster Raster { get; set; }
C++
public property FdoProviderCapabilitiesRaster Raster sealed {
FdoProviderCapabilitiesRaster get();
void set(FdoProviderCapabilitiesRaster value);
}
J#
/** property */
public FdoProviderCapabilitiesRaster get_Raster();

/** property */
public void set_Raster(FdoProviderCapabilitiesRaster value);
JScript
public function get Raster() : FdoProviderCapabilitiesRaster

public function set Raster(value : FdoProviderCapabilitiesRaster);

See Also

FdoProviderCapabilities Class


Schema Property

FdoProviderCapabilities.Schema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Schema As FdoProviderCapabilitiesSchema
C#
public FdoProviderCapabilitiesSchema Schema { get; set; }
C++
public property FdoProviderCapabilitiesSchema Schema sealed {
FdoProviderCapabilitiesSchema get();
void set(FdoProviderCapabilitiesSchema value);
}
J#
/** property */
public FdoProviderCapabilitiesSchema get_Schema();

/** property */
public void set_Schema(FdoProviderCapabilitiesSchema value);
JScript
public function get Schema() : FdoProviderCapabilitiesSchema

public function set Schema(value : FdoProviderCapabilitiesSchema);

See Also

FdoProviderCapabilities Class


Topology Property

FdoProviderCapabilities.Topology Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Topology As FdoProviderCapabilitiesTopology
C#
public FdoProviderCapabilitiesTopology Topology { get; set; }
C++
public property FdoProviderCapabilitiesTopology Topology sealed {
FdoProviderCapabilitiesTopology get();
void set(FdoProviderCapabilitiesTopology value);
}
J#
/** property */
public FdoProviderCapabilitiesTopology get_Topology();

/** property */
public void set_Topology(FdoProviderCapabilitiesTopology value);
JScript
public function get Topology() : FdoProviderCapabilitiesTopology

public function set Topology(value : FdoProviderCapabilitiesTopology);

See Also

FdoProviderCapabilities Class


XsdSchema Property

FdoProviderCapabilities.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

FdoProviderCapabilities Class


FdoProviderCapabilitiesCommand Class

FdoProviderCapabilitiesCommand Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoProviderCapabilitiesCommand
C#
public class FdoProviderCapabilitiesCommand
C++
ref class FdoProviderCapabilitiesCommand
J#
public class FdoProviderCapabilitiesCommand
JScript
public class FdoProviderCapabilitiesCommand

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesCommand

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesCommand Members


FdoProviderCapabilitiesCommand Members

FdoProviderCapabilitiesCommand Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesCommand.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesCommand | Initializes a new instance of the FdoProviderCapabilitiesCommand class.
Top

Public Properties

 | Name | Description
Public property | SupportedCommands |
Public property | SupportsParameters |
Public property | SupportsTimeout |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesCommand Class


FdoProviderCapabilitiesCommand Constructor

FdoProviderCapabilitiesCommand Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesCommand class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesCommand()
C++
public:
FdoProviderCapabilitiesCommand() sealed
J#
public FdoProviderCapabilitiesCommand()
JScript
public function FdoProviderCapabilitiesCommand()

See Also

FdoProviderCapabilitiesCommand Class


Properties

FdoProviderCapabilitiesCommand Properties
[image]

Public Properties

 | Name | Description
Public property | SupportedCommands |
Public property | SupportsParameters |
Public property | SupportsTimeout |
Top

See Also

FdoProviderCapabilitiesCommand Class


SupportedCommands Property

FdoProviderCapabilitiesCommand.SupportedCommands Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Name", IsNullable := False)>
Public Property SupportedCommands As FdoProviderCapabilitiesCommandNameCollection
C#
[XmlArrayItemAttribute("Name", IsNullable = False)]
public FdoProviderCapabilitiesCommandNameCollection SupportedCommands { get; set; }
C++
[XmlArrayItemAttribute(L"Name", IsNullable = False)]
public property FdoProviderCapabilitiesCommandNameCollection SupportedCommands sealed {
FdoProviderCapabilitiesCommandNameCollection get();
void set(FdoProviderCapabilitiesCommandNameCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Name", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesCommandNameCollection get_SupportedCommands();

/** property */
public void set_SupportedCommands(FdoProviderCapabilitiesCommandNameCollection value);
JScript
public function get SupportedCommands() : FdoProviderCapabilitiesCommandNameCollection

public function set SupportedCommands(value : FdoProviderCapabilitiesCommandNameCollection);

See Also

FdoProviderCapabilitiesCommand Class


SupportsParameters Property

FdoProviderCapabilitiesCommand.SupportsParameters Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsParameters As Boolean
C#
public bool SupportsParameters { get; set; }
C++
public property bool SupportsParameters sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsParameters();

/** property */
public void set_SupportsParameters(bool value);
JScript
public function get SupportsParameters() : bool

public function set SupportsParameters(value : bool);

See Also

FdoProviderCapabilitiesCommand Class


SupportsTimeout Property

FdoProviderCapabilitiesCommand.SupportsTimeout Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsTimeout As Boolean
C#
public bool SupportsTimeout { get; set; }
C++
public property bool SupportsTimeout sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsTimeout();

/** property */
public void set_SupportsTimeout(bool value);
JScript
public function get SupportsTimeout() : bool

public function set SupportsTimeout(value : bool);

See Also

FdoProviderCapabilitiesCommand Class


FdoProviderCapabilitiesCommandName Enumeration

FdoProviderCapabilitiesCommandName Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FdoProviderCapabilitiesCommandName
C#
public enum FdoProviderCapabilitiesCommandName
C++
public enum class FdoProviderCapabilitiesCommandName
J#
public enum FdoProviderCapabilitiesCommandName
JScript
public enum FdoProviderCapabilitiesCommandName

Members

Member Name | Description
Select |
Insert |
Delete |
Update |
DescribeSchema |
ApplySchema |
DestroySchema |
ActivateSpatialContext |
CreateSpatialContext |
DestroySpatialContext |
GetSpatialContexts |
CreateMeasureUnit |
DestroyMeasureUnit |
GetMeasureUnits |
SQLCommand |
AcquireLock |
GetLockInfo |
GetLockedObjects |
GetLockOwners |
ReleaseLock |
ActivateLongTransaction |
CommitLongTransaction |
CreateLongTransaction |
GetLongTransactions |
FreezeLongTransaction |
RollbackLongTransaction |
ActivateLongTransactionCheckpoint |
CreateLongTransactionCheckpoint |
GetLongTransactionCheckpoints |
RollbackLongTransactionCheckpoint |
ChangeLongTransactionPrivileges |
GetLongTransactionPrivileges |
ChangeLongTransactionSet |
GetLongTransactionsInSet |
FirstProviderCommand |
DeactivateLongTransaction |

See Also


FdoProviderCapabilitiesCommandNameCollection Class

FdoProviderCapabilitiesCommandNameCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesCommandNameCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesCommandNameCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesCommandNameCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesCommandNameCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesCommandNameCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesCommandNameCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesCommandNameCollection Members


FdoProviderCapabilitiesCommandNameCollection Members

FdoProviderCapabilitiesCommandNameCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesCommandNameCollection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesCommandNameCollection | Initializes a new instance of the FdoProviderCapabilitiesCommandNameCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesCommandNameCollection Class


FdoProviderCapabilitiesCommandNameCollection Constructor

FdoProviderCapabilitiesCommandNameCollection Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesCommandNameCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesCommandNameCollection()
C++
public:
FdoProviderCapabilitiesCommandNameCollection() sealed
J#
public FdoProviderCapabilitiesCommandNameCollection()
JScript
public function FdoProviderCapabilitiesCommandNameCollection()

See Also

FdoProviderCapabilitiesCommandNameCollection Class


Properties

FdoProviderCapabilitiesCommandNameCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesCommandNameCollection Class


Item Property

FdoProviderCapabilitiesCommandNameCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesCommandName
C#
public FdoProviderCapabilitiesCommandName this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesCommandName default[int idx] sealed {
FdoProviderCapabilitiesCommandName get(int idx);
void set(int idx, FdoProviderCapabilitiesCommandName value);
}
J#
/** property */
public FdoProviderCapabilitiesCommandName get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesCommandName value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesCommandNameCollection Class


Methods

FdoProviderCapabilitiesCommandNameCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesCommandNameCollection Class


Add Method

FdoProviderCapabilitiesCommandNameCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesCommandName _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesCommandName value
)
C++
public:
int Add(
FdoProviderCapabilitiesCommandName value
) sealed
J#
public int Add(
FdoProviderCapabilitiesCommandName value
)
JScript
public function Add(
value : FdoProviderCapabilitiesCommandName
) : int

See Also

FdoProviderCapabilitiesCommandNameCollection Class


FdoProviderCapabilitiesConnection Class

FdoProviderCapabilitiesConnection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoProviderCapabilitiesConnection
C#
public class FdoProviderCapabilitiesConnection
C++
ref class FdoProviderCapabilitiesConnection
J#
public class FdoProviderCapabilitiesConnection
JScript
public class FdoProviderCapabilitiesConnection

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesConnection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesConnection Members


FdoProviderCapabilitiesConnection Members

FdoProviderCapabilitiesConnection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesConnection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesConnection | Initializes a new instance of the FdoProviderCapabilitiesConnection class.
Top

Public Properties

 | Name | Description
Public property | SpatialContextExtent |
Public property | SupportsConfiguration |
Public property | SupportsLocking |
Public property | SupportsLongTransactions |
Public property | SupportsSQL |
Public property | SupportsTimeout |
Public property | SupportsTransactions |
Public property | ThreadCapability |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesConnection Class


FdoProviderCapabilitiesConnection Constructor

FdoProviderCapabilitiesConnection Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesConnection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesConnection()
C++
public:
FdoProviderCapabilitiesConnection() sealed
J#
public FdoProviderCapabilitiesConnection()
JScript
public function FdoProviderCapabilitiesConnection()

See Also

FdoProviderCapabilitiesConnection Class


Properties

FdoProviderCapabilitiesConnection Properties
[image]

Public Properties

 | Name | Description
Public property | SpatialContextExtent |
Public property | SupportsConfiguration |
Public property | SupportsLocking |
Public property | SupportsLongTransactions |
Public property | SupportsSQL |
Public property | SupportsTimeout |
Public property | SupportsTransactions |
Public property | ThreadCapability |
Top

See Also

FdoProviderCapabilitiesConnection Class


SpatialContextExtent Property

FdoProviderCapabilitiesConnection.SpatialContextExtent Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Type", IsNullable := False)>
Public Property SpatialContextExtent As FdoProviderCapabilitiesConnectionTypeCollection
C#
[XmlArrayItemAttribute("Type", IsNullable = False)]
public FdoProviderCapabilitiesConnectionTypeCollection SpatialContextExtent { get; set; }
C++
[XmlArrayItemAttribute(L"Type", IsNullable = False)]
public property FdoProviderCapabilitiesConnectionTypeCollection SpatialContextExtent sealed {
FdoProviderCapabilitiesConnectionTypeCollection get();
void set(FdoProviderCapabilitiesConnectionTypeCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Type", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesConnectionTypeCollection get_SpatialContextExtent();

/** property */
public void set_SpatialContextExtent(FdoProviderCapabilitiesConnectionTypeCollection value);
JScript
public function get SpatialContextExtent() : FdoProviderCapabilitiesConnectionTypeCollection

public function set SpatialContextExtent(value : FdoProviderCapabilitiesConnectionTypeCollection);

See Also

FdoProviderCapabilitiesConnection Class


SupportsConfiguration Property

FdoProviderCapabilitiesConnection.SupportsConfiguration Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsConfiguration As Boolean
C#
public bool SupportsConfiguration { get; set; }
C++
public property bool SupportsConfiguration sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsConfiguration();

/** property */
public void set_SupportsConfiguration(bool value);
JScript
public function get SupportsConfiguration() : bool

public function set SupportsConfiguration(value : bool);

See Also

FdoProviderCapabilitiesConnection Class


SupportsLocking Property

FdoProviderCapabilitiesConnection.SupportsLocking Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsLocking As Boolean
C#
public bool SupportsLocking { get; set; }
C++
public property bool SupportsLocking sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsLocking();

/** property */
public void set_SupportsLocking(bool value);
JScript
public function get SupportsLocking() : bool

public function set SupportsLocking(value : bool);

See Also

FdoProviderCapabilitiesConnection Class


SupportsLongTransactions Property

FdoProviderCapabilitiesConnection.SupportsLongTransactions Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsLongTransactions As Boolean
C#
public bool SupportsLongTransactions { get; set; }
C++
public property bool SupportsLongTransactions sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsLongTransactions();

/** property */
public void set_SupportsLongTransactions(bool value);
JScript
public function get SupportsLongTransactions() : bool

public function set SupportsLongTransactions(value : bool);

See Also

FdoProviderCapabilitiesConnection Class


SupportsSQL Property

FdoProviderCapabilitiesConnection.SupportsSQL Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsSQL As Boolean
C#
public bool SupportsSQL { get; set; }
C++
public property bool SupportsSQL sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsSQL();

/** property */
public void set_SupportsSQL(bool value);
JScript
public function get SupportsSQL() : bool

public function set SupportsSQL(value : bool);

See Also

FdoProviderCapabilitiesConnection Class


SupportsTimeout Property

FdoProviderCapabilitiesConnection.SupportsTimeout Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsTimeout As Boolean
C#
public bool SupportsTimeout { get; set; }
C++
public property bool SupportsTimeout sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsTimeout();

/** property */
public void set_SupportsTimeout(bool value);
JScript
public function get SupportsTimeout() : bool

public function set SupportsTimeout(value : bool);

See Also

FdoProviderCapabilitiesConnection Class


SupportsTransactions Property

FdoProviderCapabilitiesConnection.SupportsTransactions Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsTransactions As Boolean
C#
public bool SupportsTransactions { get; set; }
C++
public property bool SupportsTransactions sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsTransactions();

/** property */
public void set_SupportsTransactions(bool value);
JScript
public function get SupportsTransactions() : bool

public function set SupportsTransactions(value : bool);

See Also

FdoProviderCapabilitiesConnection Class


ThreadCapability Property

FdoProviderCapabilitiesConnection.ThreadCapability Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ThreadCapability As FdoProviderCapabilitiesConnectionThreadCapability
C#
public FdoProviderCapabilitiesConnectionThreadCapability ThreadCapability { get; set; }
C++
public property FdoProviderCapabilitiesConnectionThreadCapability ThreadCapability sealed {
FdoProviderCapabilitiesConnectionThreadCapability get();
void set(FdoProviderCapabilitiesConnectionThreadCapability value);
}
J#
/** property */
public FdoProviderCapabilitiesConnectionThreadCapability get_ThreadCapability();

/** property */
public void set_ThreadCapability(FdoProviderCapabilitiesConnectionThreadCapability value);
JScript
public function get ThreadCapability() : FdoProviderCapabilitiesConnectionThreadCapability

public function set ThreadCapability(value : FdoProviderCapabilitiesConnectionThreadCapability);

See Also

FdoProviderCapabilitiesConnection Class


FdoProviderCapabilitiesConnectionThreadCapability Enumeration

FdoProviderCapabilitiesConnectionThreadCapability Enumeration
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FdoProviderCapabilitiesConnectionThreadCapability
C#
public enum FdoProviderCapabilitiesConnectionThreadCapability
C++
public enum class FdoProviderCapabilitiesConnectionThreadCapability
J#
public enum FdoProviderCapabilitiesConnectionThreadCapability
JScript
public enum FdoProviderCapabilitiesConnectionThreadCapability

Members

Member Name | Description
SingleThreaded |
PerConnectionThreaded |
PerCommandThreaded |
MultiThreaded |

See Also


FdoProviderCapabilitiesConnectionType Enumeration

FdoProviderCapabilitiesConnectionType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FdoProviderCapabilitiesConnectionType
C#
public enum FdoProviderCapabilitiesConnectionType
C++
public enum class FdoProviderCapabilitiesConnectionType
J#
public enum FdoProviderCapabilitiesConnectionType
JScript
public enum FdoProviderCapabilitiesConnectionType

Members

Member Name | Description
Static |
Dynamic |

See Also


FdoProviderCapabilitiesConnectionTypeCollection Class

FdoProviderCapabilitiesConnectionTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesConnectionTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesConnectionTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesConnectionTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesConnectionTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesConnectionTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesConnectionTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesConnectionTypeCollection Members


FdoProviderCapabilitiesConnectionTypeCollection Members

FdoProviderCapabilitiesConnectionTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesConnectionTypeCollection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesConnectionTypeCollection | Initializes a new instance of the FdoProviderCapabilitiesConnectionTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesConnectionTypeCollection Class


FdoProviderCapabilitiesConnectionTypeCollection Constructor

FdoProviderCapabilitiesConnectionTypeCollection Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesConnectionTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesConnectionTypeCollection()
C++
public:
FdoProviderCapabilitiesConnectionTypeCollection() sealed
J#
public FdoProviderCapabilitiesConnectionTypeCollection()
JScript
public function FdoProviderCapabilitiesConnectionTypeCollection()

See Also

FdoProviderCapabilitiesConnectionTypeCollection Class


Properties

FdoProviderCapabilitiesConnectionTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesConnectionTypeCollection Class


Item Property

FdoProviderCapabilitiesConnectionTypeCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesConnectionType
C#
public FdoProviderCapabilitiesConnectionType this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesConnectionType default[int idx] sealed {
FdoProviderCapabilitiesConnectionType get(int idx);
void set(int idx, FdoProviderCapabilitiesConnectionType value);
}
J#
/** property */
public FdoProviderCapabilitiesConnectionType get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesConnectionType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesConnectionTypeCollection Class


Methods

FdoProviderCapabilitiesConnectionTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesConnectionTypeCollection Class


Add Method

FdoProviderCapabilitiesConnectionTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesConnectionType _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesConnectionType value
)
C++
public:
int Add(
FdoProviderCapabilitiesConnectionType value
) sealed
J#
public int Add(
FdoProviderCapabilitiesConnectionType value
)
JScript
public function Add(
value : FdoProviderCapabilitiesConnectionType
) : int

See Also

FdoProviderCapabilitiesConnectionTypeCollection Class


FdoProviderCapabilitiesExpression Class

FdoProviderCapabilitiesExpression Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoProviderCapabilitiesExpression
C#
public class FdoProviderCapabilitiesExpression
C++
ref class FdoProviderCapabilitiesExpression
J#
public class FdoProviderCapabilitiesExpression
JScript
public class FdoProviderCapabilitiesExpression

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpression

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesExpression Members


FdoProviderCapabilitiesExpression Members

FdoProviderCapabilitiesExpression Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesExpression.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesExpression | Initializes a new instance of the FdoProviderCapabilitiesExpression class.
Top

Public Properties

 | Name | Description
Public property | FunctionDefinitionList |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesExpression Class


FdoProviderCapabilitiesExpression Constructor

FdoProviderCapabilitiesExpression Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesExpression class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesExpression()
C++
public:
FdoProviderCapabilitiesExpression() sealed
J#
public FdoProviderCapabilitiesExpression()
JScript
public function FdoProviderCapabilitiesExpression()

See Also

FdoProviderCapabilitiesExpression Class


Properties

FdoProviderCapabilitiesExpression Properties
[image]

Public Properties

 | Name | Description
Public property | FunctionDefinitionList |
Public property | Type |
Top

See Also

FdoProviderCapabilitiesExpression Class


FunctionDefinitionList Property

FdoProviderCapabilitiesExpression.FunctionDefinitionList Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("FunctionDefinition", IsNullable := False)>
Public Property FunctionDefinitionList As FdoProviderCapabilitiesExpressionFunctionDefinitionCollection
C#
[XmlArrayItemAttribute("FunctionDefinition", IsNullable = False)]
public FdoProviderCapabilitiesExpressionFunctionDefinitionCollection FunctionDefinitionList { get; set; }
C++
[XmlArrayItemAttribute(L"FunctionDefinition", IsNullable = False)]
public property FdoProviderCapabilitiesExpressionFunctionDefinitionCollection FunctionDefinitionList sealed {
FdoProviderCapabilitiesExpressionFunctionDefinitionCollection get();
void set(FdoProviderCapabilitiesExpressionFunctionDefinitionCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("FunctionDefinition", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesExpressionFunctionDefinitionCollection get_FunctionDefinitionList();

/** property */
public void set_FunctionDefinitionList(FdoProviderCapabilitiesExpressionFunctionDefinitionCollection value);
JScript
public function get FunctionDefinitionList() : FdoProviderCapabilitiesExpressionFunctionDefinitionCollection

public function set FunctionDefinitionList(value : FdoProviderCapabilitiesExpressionFunctionDefinitionCollection);

See Also

FdoProviderCapabilitiesExpression Class


Type Property

FdoProviderCapabilitiesExpression.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Name", IsNullable := False)>
Public Property Type As FdoProviderCapabilitiesExpressionNameCollection
C#
[XmlArrayItemAttribute("Name", IsNullable = False)]
public FdoProviderCapabilitiesExpressionNameCollection Type { get; set; }
C++
[XmlArrayItemAttribute(L"Name", IsNullable = False)]
public property FdoProviderCapabilitiesExpressionNameCollection Type sealed {
FdoProviderCapabilitiesExpressionNameCollection get();
void set(FdoProviderCapabilitiesExpressionNameCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Name", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesExpressionNameCollection get_Type();

/** property */
public void set_Type(FdoProviderCapabilitiesExpressionNameCollection value);
JScript
public function get Type() : FdoProviderCapabilitiesExpressionNameCollection

public function set Type(value : FdoProviderCapabilitiesExpressionNameCollection);

See Also

FdoProviderCapabilitiesExpression Class


FdoProviderCapabilitiesExpressionFunctionDefinition Class

FdoProviderCapabilitiesExpressionFunctionDefinition Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoProviderCapabilitiesExpressionFunctionDefinition
C#
public class FdoProviderCapabilitiesExpressionFunctionDefinition
C++
ref class FdoProviderCapabilitiesExpressionFunctionDefinition
J#
public class FdoProviderCapabilitiesExpressionFunctionDefinition
JScript
public class FdoProviderCapabilitiesExpressionFunctionDefinition

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionFunctionDefinition

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesExpressionFunctionDefinition Members


FdoProviderCapabilitiesExpressionFunctionDefinition Members

FdoProviderCapabilitiesExpressionFunctionDefinition Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesExpressionFunctionDefinition.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesExpressionFunctionDefinition | Initializes a new instance of the FdoProviderCapabilitiesExpressionFunctionDefinition class.
Top

Public Properties

 | Name | Description
Public property | ArgumentDefinitionList |
Public property | Description |
Public property | Name |
Public property | ReturnType |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesExpressionFunctionDefinition Class


FdoProviderCapabilitiesExpressionFunctionDefinition Constructor

FdoProviderCapabilitiesExpressionFunctionDefinition Constructor
See Also Example
[image]

Initializes a new instance of the FdoProviderCapabilitiesExpressionFunctionDefinition class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesExpressionFunctionDefinition()
C++
public:
FdoProviderCapabilitiesExpressionFunctionDefinition() sealed
J#
public FdoProviderCapabilitiesExpressionFunctionDefinition()
JScript
public function FdoProviderCapabilitiesExpressionFunctionDefinition()

See Also

FdoProviderCapabilitiesExpressionFunctionDefinition Class


Properties

FdoProviderCapabilitiesExpressionFunctionDefinition Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | ArgumentDefinitionList |
Public property | Description |
Public property | Name |
Public property | ReturnType |
Top

See Also

FdoProviderCapabilitiesExpressionFunctionDefinition Class


ArgumentDefinitionList Property

FdoProviderCapabilitiesExpressionFunctionDefinition.ArgumentDefinitionList Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("ArgumentDefinition", IsNullable := False)>
Public Property ArgumentDefinitionList As FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection
C#
[XmlArrayItemAttribute("ArgumentDefinition", IsNullable = False)]
public FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection ArgumentDefinitionList { get; set; }
C++
[XmlArrayItemAttribute(L"ArgumentDefinition", IsNullable = False)]
public property FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection ArgumentDefinitionList sealed {
FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection get();
void set(FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("ArgumentDefinition", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection get_ArgumentDefinitionList();

/** property */
public void set_ArgumentDefinitionList(FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection value);
JScript
public function get ArgumentDefinitionList() : FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection

public function set ArgumentDefinitionList(value : FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection);

See Also

FdoProviderCapabilitiesExpressionFunctionDefinition Class


Description Property

FdoProviderCapabilitiesExpressionFunctionDefinition.Description Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

FdoProviderCapabilitiesExpressionFunctionDefinition Class


Name Property

FdoProviderCapabilitiesExpressionFunctionDefinition.Name Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

FdoProviderCapabilitiesExpressionFunctionDefinition Class


ReturnType Property

FdoProviderCapabilitiesExpressionFunctionDefinition.ReturnType Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnType As FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType
C#
public FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType ReturnType { get; set; }
C++
public property FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType ReturnType sealed {
FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType get();
void set(FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType value);
}
J#
/** property */
public FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType get_ReturnType();

/** property */
public void set_ReturnType(FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType value);
JScript
public function get ReturnType() : FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType

public function set ReturnType(value : FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType);

See Also

FdoProviderCapabilitiesExpressionFunctionDefinition Class


FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Class

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition
C#
public class FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition
C++
ref class FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition
J#
public class FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition
JScript
public class FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Members


FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Members

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition | Initializes a new instance of the FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition class.
Top

Public Properties

 | Name | Description
Public property | DataType |
Public property | Description |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Class


FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Constructor

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Constructor
See Also Example
[image]

Initializes a new instance of the FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition()
C++
public:
FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition() sealed
J#
public FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition()
JScript
public function FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition()

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Class


Properties

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | DataType |
Public property | Description |
Public property | Name |
Top

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Class


DataType Property

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition.DataType Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DataType As FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType
C#
public FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType DataType { get; set; }
C++
public property FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType DataType sealed {
FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType get();
void set(FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType value);
}
J#
/** property */
public FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType get_DataType();

/** property */
public void set_DataType(FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType value);
JScript
public function get DataType() : FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType

public function set DataType(value : FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType);

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Class


Description Property

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition.Description Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Class


Name Property

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition.Name Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition Class


FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Class

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Members


FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Members

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection | Initializes a new instance of the FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Class


FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Constructor

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Constructor
See Also Example
[image]

Initializes a new instance of the FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection()
C++
public:
FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection() sealed
J#
public FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection()
JScript
public function FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection()

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Class


Properties

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Class


Item Property

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition
C#
public FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition default[int idx] sealed {
FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition get(int idx);
void set(int idx, FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition value);
}
J#
/** property */
public FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Class


Methods

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Class


Add Method

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection.Add Method
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition value
)
C++
public:
int Add(
FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition value
) sealed
J#
public int Add(
FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition value
)
JScript
public function Add(
value : FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition
) : int

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection Class


FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType Enumeration

FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType Enumeration
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType
C#
public enum FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType
C++
public enum class FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType
J#
public enum FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType
JScript
public enum FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType

Members

Member Name | Description
Boolean |
Byte |
DateTime |
Decimal |
Double |
Int16 |
Int32 |
Int64 |
Single |
String |
BLOB |
CLOB |
UniqueID |

See Also


FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Class

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesExpressionFunctionDefinitionCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesExpressionFunctionDefinitionCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesExpressionFunctionDefinitionCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesExpressionFunctionDefinitionCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesExpressionFunctionDefinitionCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionFunctionDefinitionCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Members


FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Members

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesExpressionFunctionDefinitionCollection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesExpressionFunctionDefinitionCollection | Initializes a new instance of the FdoProviderCapabilitiesExpressionFunctionDefinitionCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Class


FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Constructor

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Constructor
See Also Example
[image]

Initializes a new instance of the FdoProviderCapabilitiesExpressionFunctionDefinitionCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesExpressionFunctionDefinitionCollection()
C++
public:
FdoProviderCapabilitiesExpressionFunctionDefinitionCollection() sealed
J#
public FdoProviderCapabilitiesExpressionFunctionDefinitionCollection()
JScript
public function FdoProviderCapabilitiesExpressionFunctionDefinitionCollection()

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Class


Properties

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Class


Item Property

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesExpressionFunctionDefinition
C#
public FdoProviderCapabilitiesExpressionFunctionDefinition this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesExpressionFunctionDefinition default[int idx] sealed {
FdoProviderCapabilitiesExpressionFunctionDefinition get(int idx);
void set(int idx, FdoProviderCapabilitiesExpressionFunctionDefinition value);
}
J#
/** property */
public FdoProviderCapabilitiesExpressionFunctionDefinition get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesExpressionFunctionDefinition value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Class


Methods

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Class


Add Method

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection.Add Method
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesExpressionFunctionDefinition _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesExpressionFunctionDefinition value
)
C++
public:
int Add(
FdoProviderCapabilitiesExpressionFunctionDefinition value
) sealed
J#
public int Add(
FdoProviderCapabilitiesExpressionFunctionDefinition value
)
JScript
public function Add(
value : FdoProviderCapabilitiesExpressionFunctionDefinition
) : int

See Also

FdoProviderCapabilitiesExpressionFunctionDefinitionCollection Class


FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType Enumeration

FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType Enumeration
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType
C#
public enum FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType
C++
public enum class FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType
J#
public enum FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType
JScript
public enum FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType

Members

Member Name | Description
Boolean |
Byte |
DateTime |
Decimal |
Double |
Int16 |
Int32 |
Int64 |
Single |
String |
BLOB |
CLOB |
UniqueID |

See Also


FdoProviderCapabilitiesExpressionName Enumeration

FdoProviderCapabilitiesExpressionName Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FdoProviderCapabilitiesExpressionName
C#
public enum FdoProviderCapabilitiesExpressionName
C++
public enum class FdoProviderCapabilitiesExpressionName
J#
public enum FdoProviderCapabilitiesExpressionName
JScript
public enum FdoProviderCapabilitiesExpressionName

Members

Member Name | Description
Basic |
Function |
Parameter |

See Also


FdoProviderCapabilitiesExpressionNameCollection Class

FdoProviderCapabilitiesExpressionNameCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesExpressionNameCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesExpressionNameCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesExpressionNameCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesExpressionNameCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesExpressionNameCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionNameCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesExpressionNameCollection Members


FdoProviderCapabilitiesExpressionNameCollection Members

FdoProviderCapabilitiesExpressionNameCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesExpressionNameCollection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesExpressionNameCollection | Initializes a new instance of the FdoProviderCapabilitiesExpressionNameCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesExpressionNameCollection Class


FdoProviderCapabilitiesExpressionNameCollection Constructor

FdoProviderCapabilitiesExpressionNameCollection Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesExpressionNameCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesExpressionNameCollection()
C++
public:
FdoProviderCapabilitiesExpressionNameCollection() sealed
J#
public FdoProviderCapabilitiesExpressionNameCollection()
JScript
public function FdoProviderCapabilitiesExpressionNameCollection()

See Also

FdoProviderCapabilitiesExpressionNameCollection Class


Properties

FdoProviderCapabilitiesExpressionNameCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesExpressionNameCollection Class


Item Property

FdoProviderCapabilitiesExpressionNameCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesExpressionName
C#
public FdoProviderCapabilitiesExpressionName this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesExpressionName default[int idx] sealed {
FdoProviderCapabilitiesExpressionName get(int idx);
void set(int idx, FdoProviderCapabilitiesExpressionName value);
}
J#
/** property */
public FdoProviderCapabilitiesExpressionName get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesExpressionName value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesExpressionNameCollection Class


Methods

FdoProviderCapabilitiesExpressionNameCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesExpressionNameCollection Class


Add Method

FdoProviderCapabilitiesExpressionNameCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesExpressionName _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesExpressionName value
)
C++
public:
int Add(
FdoProviderCapabilitiesExpressionName value
) sealed
J#
public int Add(
FdoProviderCapabilitiesExpressionName value
)
JScript
public function Add(
value : FdoProviderCapabilitiesExpressionName
) : int

See Also

FdoProviderCapabilitiesExpressionNameCollection Class


FdoProviderCapabilitiesFilter Class

FdoProviderCapabilitiesFilter Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoProviderCapabilitiesFilter
C#
public class FdoProviderCapabilitiesFilter
C++
ref class FdoProviderCapabilitiesFilter
J#
public class FdoProviderCapabilitiesFilter
JScript
public class FdoProviderCapabilitiesFilter

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesFilter

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesFilter Members


FdoProviderCapabilitiesFilter Members

FdoProviderCapabilitiesFilter Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesFilter.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesFilter | Initializes a new instance of the FdoProviderCapabilitiesFilter class.
Top

Public Properties

 | Name | Description
Public property | Condition |
Public property | Distance |
Public property | Spatial |
Public property | SupportsGeodesicDistance |
Public property | SupportsNonLiteralGeometricOperations |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesFilter Class


FdoProviderCapabilitiesFilter Constructor

FdoProviderCapabilitiesFilter Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesFilter class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesFilter()
C++
public:
FdoProviderCapabilitiesFilter() sealed
J#
public FdoProviderCapabilitiesFilter()
JScript
public function FdoProviderCapabilitiesFilter()

See Also

FdoProviderCapabilitiesFilter Class


Properties

FdoProviderCapabilitiesFilter Properties
[image]

Public Properties

 | Name | Description
Public property | Condition |
Public property | Distance |
Public property | Spatial |
Public property | SupportsGeodesicDistance |
Public property | SupportsNonLiteralGeometricOperations |
Top

See Also

FdoProviderCapabilitiesFilter Class


Condition Property

FdoProviderCapabilitiesFilter.Condition Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Type", IsNullable := False)>
Public Property Condition As FdoProviderCapabilitiesFilterTypeCollection
C#
[XmlArrayItemAttribute("Type", IsNullable = False)]
public FdoProviderCapabilitiesFilterTypeCollection Condition { get; set; }
C++
[XmlArrayItemAttribute(L"Type", IsNullable = False)]
public property FdoProviderCapabilitiesFilterTypeCollection Condition sealed {
FdoProviderCapabilitiesFilterTypeCollection get();
void set(FdoProviderCapabilitiesFilterTypeCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Type", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesFilterTypeCollection get_Condition();

/** property */
public void set_Condition(FdoProviderCapabilitiesFilterTypeCollection value);
JScript
public function get Condition() : FdoProviderCapabilitiesFilterTypeCollection

public function set Condition(value : FdoProviderCapabilitiesFilterTypeCollection);

See Also

FdoProviderCapabilitiesFilter Class


Distance Property

FdoProviderCapabilitiesFilter.Distance Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Operation", IsNullable := False)>
Public Property Distance As FdoProviderCapabilitiesFilterOperation1Collection
C#
[XmlArrayItemAttribute("Operation", IsNullable = False)]
public FdoProviderCapabilitiesFilterOperation1Collection Distance { get; set; }
C++
[XmlArrayItemAttribute(L"Operation", IsNullable = False)]
public property FdoProviderCapabilitiesFilterOperation1Collection Distance sealed {
FdoProviderCapabilitiesFilterOperation1Collection get();
void set(FdoProviderCapabilitiesFilterOperation1Collection value);
}
J#
/** @attribute XmlArrayItemAttribute("Operation", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesFilterOperation1Collection get_Distance();

/** property */
public void set_Distance(FdoProviderCapabilitiesFilterOperation1Collection value);
JScript
public function get Distance() : FdoProviderCapabilitiesFilterOperation1Collection

public function set Distance(value : FdoProviderCapabilitiesFilterOperation1Collection);

See Also

FdoProviderCapabilitiesFilter Class


Spatial Property

FdoProviderCapabilitiesFilter.Spatial Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Operation", IsNullable := False)>
Public Property Spatial As FdoProviderCapabilitiesFilterOperationCollection
C#
[XmlArrayItemAttribute("Operation", IsNullable = False)]
public FdoProviderCapabilitiesFilterOperationCollection Spatial { get; set; }
C++
[XmlArrayItemAttribute(L"Operation", IsNullable = False)]
public property FdoProviderCapabilitiesFilterOperationCollection Spatial sealed {
FdoProviderCapabilitiesFilterOperationCollection get();
void set(FdoProviderCapabilitiesFilterOperationCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Operation", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesFilterOperationCollection get_Spatial();

/** property */
public void set_Spatial(FdoProviderCapabilitiesFilterOperationCollection value);
JScript
public function get Spatial() : FdoProviderCapabilitiesFilterOperationCollection

public function set Spatial(value : FdoProviderCapabilitiesFilterOperationCollection);

See Also

FdoProviderCapabilitiesFilter Class


SupportsGeodesicDistance Property

FdoProviderCapabilitiesFilter.SupportsGeodesicDistance Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsGeodesicDistance As Boolean
C#
public bool SupportsGeodesicDistance { get; set; }
C++
public property bool SupportsGeodesicDistance sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsGeodesicDistance();

/** property */
public void set_SupportsGeodesicDistance(bool value);
JScript
public function get SupportsGeodesicDistance() : bool

public function set SupportsGeodesicDistance(value : bool);

See Also

FdoProviderCapabilitiesFilter Class


SupportsNonLiteralGeometricOperations Property

FdoProviderCapabilitiesFilter.SupportsNonLiteralGeometricOperations Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsNonLiteralGeometricOperations As Boolean
C#
public bool SupportsNonLiteralGeometricOperations { get; set; }
C++
public property bool SupportsNonLiteralGeometricOperations sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsNonLiteralGeometricOperations();

/** property */
public void set_SupportsNonLiteralGeometricOperations(bool value);
JScript
public function get SupportsNonLiteralGeometricOperations() : bool

public function set SupportsNonLiteralGeometricOperations(value : bool);

See Also

FdoProviderCapabilitiesFilter Class


FdoProviderCapabilitiesFilterOperation Enumeration

FdoProviderCapabilitiesFilterOperation Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FdoProviderCapabilitiesFilterOperation
C#
public enum FdoProviderCapabilitiesFilterOperation
C++
public enum class FdoProviderCapabilitiesFilterOperation
J#
public enum FdoProviderCapabilitiesFilterOperation
JScript
public enum FdoProviderCapabilitiesFilterOperation

Members

Member Name | Description
Contains |
Crosses |
Disjoint |
Equals |
Intersects |
Overlaps |
Touches |
Within |
CoveredBy |
Inside |
EnvelopeIntersects |

See Also


FdoProviderCapabilitiesFilterOperation1 Enumeration

FdoProviderCapabilitiesFilterOperation1 Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlTypeAttribute(TypeName := "FdoProviderCapabilitiesFilterGeometryOperation")>
Public Enum FdoProviderCapabilitiesFilterOperation1
C#
[XmlTypeAttribute(TypeName = "FdoProviderCapabilitiesFilterGeometryOperation")]
public enum FdoProviderCapabilitiesFilterOperation1
C++
[XmlTypeAttribute(TypeName = L"FdoProviderCapabilitiesFilterGeometryOperation")]
public enum class FdoProviderCapabilitiesFilterOperation1
J#
/** @attribute XmlTypeAttribute(TypeName = "FdoProviderCapabilitiesFilterGeometryOperation") */
public enum FdoProviderCapabilitiesFilterOperation1
JScript
public enum FdoProviderCapabilitiesFilterOperation1

Members

Member Name | Description
Beyond |
Within |

See Also


FdoProviderCapabilitiesFilterOperation1Collection Class

FdoProviderCapabilitiesFilterOperation1Collection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesFilterOperation1Collection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesFilterOperation1Collection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesFilterOperation1Collection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesFilterOperation1Collection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesFilterOperation1Collection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesFilterOperation1Collection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesFilterOperation1Collection Members


FdoProviderCapabilitiesFilterOperation1Collection Members

FdoProviderCapabilitiesFilterOperation1Collection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesFilterOperation1Collection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesFilterOperation1Collection | Initializes a new instance of the FdoProviderCapabilitiesFilterOperation1Collection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesFilterOperation1Collection Class


FdoProviderCapabilitiesFilterOperation1Collection Constructor

FdoProviderCapabilitiesFilterOperation1Collection Constructor
See Also Example
[image]

Initializes a new instance of the FdoProviderCapabilitiesFilterOperation1Collection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesFilterOperation1Collection()
C++
public:
FdoProviderCapabilitiesFilterOperation1Collection() sealed
J#
public FdoProviderCapabilitiesFilterOperation1Collection()
JScript
public function FdoProviderCapabilitiesFilterOperation1Collection()

See Also

FdoProviderCapabilitiesFilterOperation1Collection Class


Properties

FdoProviderCapabilitiesFilterOperation1Collection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesFilterOperation1Collection Class


Item Property

FdoProviderCapabilitiesFilterOperation1Collection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesFilterOperation1
C#
public FdoProviderCapabilitiesFilterOperation1 this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesFilterOperation1 default[int idx] sealed {
FdoProviderCapabilitiesFilterOperation1 get(int idx);
void set(int idx, FdoProviderCapabilitiesFilterOperation1 value);
}
J#
/** property */
public FdoProviderCapabilitiesFilterOperation1 get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesFilterOperation1 value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesFilterOperation1Collection Class


Methods

FdoProviderCapabilitiesFilterOperation1Collection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesFilterOperation1Collection Class


Add Method

FdoProviderCapabilitiesFilterOperation1Collection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesFilterOperation1 _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesFilterOperation1 value
)
C++
public:
int Add(
FdoProviderCapabilitiesFilterOperation1 value
) sealed
J#
public int Add(
FdoProviderCapabilitiesFilterOperation1 value
)
JScript
public function Add(
value : FdoProviderCapabilitiesFilterOperation1
) : int

See Also

FdoProviderCapabilitiesFilterOperation1Collection Class


FdoProviderCapabilitiesFilterOperationCollection Class

FdoProviderCapabilitiesFilterOperationCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesFilterOperationCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesFilterOperationCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesFilterOperationCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesFilterOperationCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesFilterOperationCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesFilterOperationCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesFilterOperationCollection Members


FdoProviderCapabilitiesFilterOperationCollection Members

FdoProviderCapabilitiesFilterOperationCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesFilterOperationCollection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesFilterOperationCollection | Initializes a new instance of the FdoProviderCapabilitiesFilterOperationCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesFilterOperationCollection Class


FdoProviderCapabilitiesFilterOperationCollection Constructor

FdoProviderCapabilitiesFilterOperationCollection Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesFilterOperationCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesFilterOperationCollection()
C++
public:
FdoProviderCapabilitiesFilterOperationCollection() sealed
J#
public FdoProviderCapabilitiesFilterOperationCollection()
JScript
public function FdoProviderCapabilitiesFilterOperationCollection()

See Also

FdoProviderCapabilitiesFilterOperationCollection Class


Properties

FdoProviderCapabilitiesFilterOperationCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesFilterOperationCollection Class


Item Property

FdoProviderCapabilitiesFilterOperationCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesFilterOperation
C#
public FdoProviderCapabilitiesFilterOperation this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesFilterOperation default[int idx] sealed {
FdoProviderCapabilitiesFilterOperation get(int idx);
void set(int idx, FdoProviderCapabilitiesFilterOperation value);
}
J#
/** property */
public FdoProviderCapabilitiesFilterOperation get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesFilterOperation value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesFilterOperationCollection Class


Methods

FdoProviderCapabilitiesFilterOperationCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesFilterOperationCollection Class


Add Method

FdoProviderCapabilitiesFilterOperationCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesFilterOperation _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesFilterOperation value
)
C++
public:
int Add(
FdoProviderCapabilitiesFilterOperation value
) sealed
J#
public int Add(
FdoProviderCapabilitiesFilterOperation value
)
JScript
public function Add(
value : FdoProviderCapabilitiesFilterOperation
) : int

See Also

FdoProviderCapabilitiesFilterOperationCollection Class


FdoProviderCapabilitiesFilterType Enumeration

FdoProviderCapabilitiesFilterType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FdoProviderCapabilitiesFilterType
C#
public enum FdoProviderCapabilitiesFilterType
C++
public enum class FdoProviderCapabilitiesFilterType
J#
public enum FdoProviderCapabilitiesFilterType
JScript
public enum FdoProviderCapabilitiesFilterType

Members

Member Name | Description
Comparison |
Like |
In |
Null |
Spatial |
Distance |

See Also


FdoProviderCapabilitiesFilterTypeCollection Class

FdoProviderCapabilitiesFilterTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesFilterTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesFilterTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesFilterTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesFilterTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesFilterTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesFilterTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesFilterTypeCollection Members


FdoProviderCapabilitiesFilterTypeCollection Members

FdoProviderCapabilitiesFilterTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesFilterTypeCollection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesFilterTypeCollection | Initializes a new instance of the FdoProviderCapabilitiesFilterTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesFilterTypeCollection Class


FdoProviderCapabilitiesFilterTypeCollection Constructor

FdoProviderCapabilitiesFilterTypeCollection Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesFilterTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesFilterTypeCollection()
C++
public:
FdoProviderCapabilitiesFilterTypeCollection() sealed
J#
public FdoProviderCapabilitiesFilterTypeCollection()
JScript
public function FdoProviderCapabilitiesFilterTypeCollection()

See Also

FdoProviderCapabilitiesFilterTypeCollection Class


Properties

FdoProviderCapabilitiesFilterTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesFilterTypeCollection Class


Item Property

FdoProviderCapabilitiesFilterTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesFilterType
C#
public FdoProviderCapabilitiesFilterType this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesFilterType default[int idx] sealed {
FdoProviderCapabilitiesFilterType get(int idx);
void set(int idx, FdoProviderCapabilitiesFilterType value);
}
J#
/** property */
public FdoProviderCapabilitiesFilterType get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesFilterType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesFilterTypeCollection Class


Methods

FdoProviderCapabilitiesFilterTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesFilterTypeCollection Class


Add Method

FdoProviderCapabilitiesFilterTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesFilterType _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesFilterType value
)
C++
public:
int Add(
FdoProviderCapabilitiesFilterType value
) sealed
J#
public int Add(
FdoProviderCapabilitiesFilterType value
)
JScript
public function Add(
value : FdoProviderCapabilitiesFilterType
) : int

See Also

FdoProviderCapabilitiesFilterTypeCollection Class


FdoProviderCapabilitiesGeometry Class

FdoProviderCapabilitiesGeometry Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoProviderCapabilitiesGeometry
C#
public class FdoProviderCapabilitiesGeometry
C++
ref class FdoProviderCapabilitiesGeometry
J#
public class FdoProviderCapabilitiesGeometry
JScript
public class FdoProviderCapabilitiesGeometry

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesGeometry

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesGeometry Members


FdoProviderCapabilitiesGeometry Members

FdoProviderCapabilitiesGeometry Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesGeometry.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesGeometry | Initializes a new instance of the FdoProviderCapabilitiesGeometry class.
Top

Public Properties

 | Name | Description
Public property | Components |
Public property | Dimensionality |
Public property | Types |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesGeometry Class


FdoProviderCapabilitiesGeometry Constructor

FdoProviderCapabilitiesGeometry Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesGeometry class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesGeometry()
C++
public:
FdoProviderCapabilitiesGeometry() sealed
J#
public FdoProviderCapabilitiesGeometry()
JScript
public function FdoProviderCapabilitiesGeometry()

See Also

FdoProviderCapabilitiesGeometry Class


Properties

FdoProviderCapabilitiesGeometry Properties
[image]

Public Properties

 | Name | Description
Public property | Components |
Public property | Dimensionality |
Public property | Types |
Top

See Also

FdoProviderCapabilitiesGeometry Class


Components Property

FdoProviderCapabilitiesGeometry.Components Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Type", IsNullable := False)>
Public Property Components As FdoProviderCapabilitiesGeometryType1Collection
C#
[XmlArrayItemAttribute("Type", IsNullable = False)]
public FdoProviderCapabilitiesGeometryType1Collection Components { get; set; }
C++
[XmlArrayItemAttribute(L"Type", IsNullable = False)]
public property FdoProviderCapabilitiesGeometryType1Collection Components sealed {
FdoProviderCapabilitiesGeometryType1Collection get();
void set(FdoProviderCapabilitiesGeometryType1Collection value);
}
J#
/** @attribute XmlArrayItemAttribute("Type", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesGeometryType1Collection get_Components();

/** property */
public void set_Components(FdoProviderCapabilitiesGeometryType1Collection value);
JScript
public function get Components() : FdoProviderCapabilitiesGeometryType1Collection

public function set Components(value : FdoProviderCapabilitiesGeometryType1Collection);

See Also

FdoProviderCapabilitiesGeometry Class


Dimensionality Property

FdoProviderCapabilitiesGeometry.Dimensionality Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property Dimensionality As String
C#
[XmlElementAttribute(DataType = "integer")]
public string Dimensionality { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string Dimensionality sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_Dimensionality();

/** property */
public void set_Dimensionality(string value);
JScript
public function get Dimensionality() : String

public function set Dimensionality(value : String);

See Also

FdoProviderCapabilitiesGeometry Class


Types Property

FdoProviderCapabilitiesGeometry.Types Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Type", IsNullable := False)>
Public Property Types As FdoProviderCapabilitiesGeometryTypeCollection
C#
[XmlArrayItemAttribute("Type", IsNullable = False)]
public FdoProviderCapabilitiesGeometryTypeCollection Types { get; set; }
C++
[XmlArrayItemAttribute(L"Type", IsNullable = False)]
public property FdoProviderCapabilitiesGeometryTypeCollection Types sealed {
FdoProviderCapabilitiesGeometryTypeCollection get();
void set(FdoProviderCapabilitiesGeometryTypeCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Type", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesGeometryTypeCollection get_Types();

/** property */
public void set_Types(FdoProviderCapabilitiesGeometryTypeCollection value);
JScript
public function get Types() : FdoProviderCapabilitiesGeometryTypeCollection

public function set Types(value : FdoProviderCapabilitiesGeometryTypeCollection);

See Also

FdoProviderCapabilitiesGeometry Class


FdoProviderCapabilitiesGeometryType Enumeration

FdoProviderCapabilitiesGeometryType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FdoProviderCapabilitiesGeometryType
C#
public enum FdoProviderCapabilitiesGeometryType
C++
public enum class FdoProviderCapabilitiesGeometryType
J#
public enum FdoProviderCapabilitiesGeometryType
JScript
public enum FdoProviderCapabilitiesGeometryType

Members

Member Name | Description
None |
Point |
LineString |
Polygon |
MultiPoint |
MultiLineString |
MultiPolygon |
MultiGeometry |
CurveString |
CurvePolygon |
MultiCurveString |
MultiCurvePolygon |

See Also


FdoProviderCapabilitiesGeometryType1 Enumeration

FdoProviderCapabilitiesGeometryType1 Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlTypeAttribute(TypeName := "FdoProviderCapabilitiesGeometryLineType")>
Public Enum FdoProviderCapabilitiesGeometryType1
C#
[XmlTypeAttribute(TypeName = "FdoProviderCapabilitiesGeometryLineType")]
public enum FdoProviderCapabilitiesGeometryType1
C++
[XmlTypeAttribute(TypeName = L"FdoProviderCapabilitiesGeometryLineType")]
public enum class FdoProviderCapabilitiesGeometryType1
J#
/** @attribute XmlTypeAttribute(TypeName = "FdoProviderCapabilitiesGeometryLineType") */
public enum FdoProviderCapabilitiesGeometryType1
JScript
public enum FdoProviderCapabilitiesGeometryType1

Members

Member Name | Description
LinearRing |
ArcSegment |
LinearSegment |
CurveRing |

See Also


FdoProviderCapabilitiesGeometryType1Collection Class

FdoProviderCapabilitiesGeometryType1Collection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesGeometryType1Collection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesGeometryType1Collection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesGeometryType1Collection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesGeometryType1Collection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesGeometryType1Collection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesGeometryType1Collection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesGeometryType1Collection Members


FdoProviderCapabilitiesGeometryType1Collection Members

FdoProviderCapabilitiesGeometryType1Collection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesGeometryType1Collection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesGeometryType1Collection | Initializes a new instance of the FdoProviderCapabilitiesGeometryType1Collection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesGeometryType1Collection Class


FdoProviderCapabilitiesGeometryType1Collection Constructor

FdoProviderCapabilitiesGeometryType1Collection Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesGeometryType1Collection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesGeometryType1Collection()
C++
public:
FdoProviderCapabilitiesGeometryType1Collection() sealed
J#
public FdoProviderCapabilitiesGeometryType1Collection()
JScript
public function FdoProviderCapabilitiesGeometryType1Collection()

See Also

FdoProviderCapabilitiesGeometryType1Collection Class


Properties

FdoProviderCapabilitiesGeometryType1Collection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesGeometryType1Collection Class


Item Property

FdoProviderCapabilitiesGeometryType1Collection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesGeometryType1
C#
public FdoProviderCapabilitiesGeometryType1 this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesGeometryType1 default[int idx] sealed {
FdoProviderCapabilitiesGeometryType1 get(int idx);
void set(int idx, FdoProviderCapabilitiesGeometryType1 value);
}
J#
/** property */
public FdoProviderCapabilitiesGeometryType1 get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesGeometryType1 value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesGeometryType1Collection Class


Methods

FdoProviderCapabilitiesGeometryType1Collection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesGeometryType1Collection Class


Add Method

FdoProviderCapabilitiesGeometryType1Collection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesGeometryType1 _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesGeometryType1 value
)
C++
public:
int Add(
FdoProviderCapabilitiesGeometryType1 value
) sealed
J#
public int Add(
FdoProviderCapabilitiesGeometryType1 value
)
JScript
public function Add(
value : FdoProviderCapabilitiesGeometryType1
) : int

See Also

FdoProviderCapabilitiesGeometryType1Collection Class


FdoProviderCapabilitiesGeometryTypeCollection Class

FdoProviderCapabilitiesGeometryTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesGeometryTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesGeometryTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesGeometryTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesGeometryTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesGeometryTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesGeometryTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesGeometryTypeCollection Members


FdoProviderCapabilitiesGeometryTypeCollection Members

FdoProviderCapabilitiesGeometryTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesGeometryTypeCollection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesGeometryTypeCollection | Initializes a new instance of the FdoProviderCapabilitiesGeometryTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesGeometryTypeCollection Class


FdoProviderCapabilitiesGeometryTypeCollection Constructor

FdoProviderCapabilitiesGeometryTypeCollection Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesGeometryTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesGeometryTypeCollection()
C++
public:
FdoProviderCapabilitiesGeometryTypeCollection() sealed
J#
public FdoProviderCapabilitiesGeometryTypeCollection()
JScript
public function FdoProviderCapabilitiesGeometryTypeCollection()

See Also

FdoProviderCapabilitiesGeometryTypeCollection Class


Properties

FdoProviderCapabilitiesGeometryTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesGeometryTypeCollection Class


Item Property

FdoProviderCapabilitiesGeometryTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesGeometryType
C#
public FdoProviderCapabilitiesGeometryType this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesGeometryType default[int idx] sealed {
FdoProviderCapabilitiesGeometryType get(int idx);
void set(int idx, FdoProviderCapabilitiesGeometryType value);
}
J#
/** property */
public FdoProviderCapabilitiesGeometryType get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesGeometryType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesGeometryTypeCollection Class


Methods

FdoProviderCapabilitiesGeometryTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesGeometryTypeCollection Class


Add Method

FdoProviderCapabilitiesGeometryTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesGeometryType _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesGeometryType value
)
C++
public:
int Add(
FdoProviderCapabilitiesGeometryType value
) sealed
J#
public int Add(
FdoProviderCapabilitiesGeometryType value
)
JScript
public function Add(
value : FdoProviderCapabilitiesGeometryType
) : int

See Also

FdoProviderCapabilitiesGeometryTypeCollection Class


FdoProviderCapabilitiesProvider Class

FdoProviderCapabilitiesProvider Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoProviderCapabilitiesProvider
C#
public class FdoProviderCapabilitiesProvider
C++
ref class FdoProviderCapabilitiesProvider
J#
public class FdoProviderCapabilitiesProvider
JScript
public class FdoProviderCapabilitiesProvider

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesProvider

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesProvider Members


FdoProviderCapabilitiesProvider Members

FdoProviderCapabilitiesProvider Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesProvider.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesProvider | Initializes a new instance of the FdoProviderCapabilitiesProvider class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Value |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesProvider Class


FdoProviderCapabilitiesProvider Constructor

FdoProviderCapabilitiesProvider Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesProvider class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesProvider()
C++
public:
FdoProviderCapabilitiesProvider() sealed
J#
public FdoProviderCapabilitiesProvider()
JScript
public function FdoProviderCapabilitiesProvider()

See Also

FdoProviderCapabilitiesProvider Class


Properties

FdoProviderCapabilitiesProvider Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Value |
Top

See Also

FdoProviderCapabilitiesProvider Class


Name Property

FdoProviderCapabilitiesProvider.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute>
Public Property Name As String
C#
[XmlAttributeAttribute]
public string Name { get; set; }
C++
[XmlAttributeAttribute]
public property string Name sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

FdoProviderCapabilitiesProvider Class


Value Property

FdoProviderCapabilitiesProvider.Value Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlTextAttribute>
Public Property Value As String
C#
[XmlTextAttribute]
public string Value { get; set; }
C++
[XmlTextAttribute]
public property string Value sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlTextAttribute() */
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

FdoProviderCapabilitiesProvider Class


FdoProviderCapabilitiesRaster Class

FdoProviderCapabilitiesRaster Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoProviderCapabilitiesRaster
C#
public class FdoProviderCapabilitiesRaster
C++
ref class FdoProviderCapabilitiesRaster
J#
public class FdoProviderCapabilitiesRaster
JScript
public class FdoProviderCapabilitiesRaster

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesRaster

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesRaster Members


FdoProviderCapabilitiesRaster Members

FdoProviderCapabilitiesRaster Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesRaster.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesRaster | Initializes a new instance of the FdoProviderCapabilitiesRaster class.
Top

Public Properties

 | Name | Description
Public property | SupportsRaster |
Public property | SupportsStitching |
Public property | SupportsSubsampling |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesRaster Class


FdoProviderCapabilitiesRaster Constructor

FdoProviderCapabilitiesRaster Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesRaster class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesRaster()
C++
public:
FdoProviderCapabilitiesRaster() sealed
J#
public FdoProviderCapabilitiesRaster()
JScript
public function FdoProviderCapabilitiesRaster()

See Also

FdoProviderCapabilitiesRaster Class


Properties

FdoProviderCapabilitiesRaster Properties
[image]

Public Properties

 | Name | Description
Public property | SupportsRaster |
Public property | SupportsStitching |
Public property | SupportsSubsampling |
Top

See Also

FdoProviderCapabilitiesRaster Class


SupportsRaster Property

FdoProviderCapabilitiesRaster.SupportsRaster Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsRaster As Boolean
C#
public bool SupportsRaster { get; set; }
C++
public property bool SupportsRaster sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsRaster();

/** property */
public void set_SupportsRaster(bool value);
JScript
public function get SupportsRaster() : bool

public function set SupportsRaster(value : bool);

See Also

FdoProviderCapabilitiesRaster Class


SupportsStitching Property

FdoProviderCapabilitiesRaster.SupportsStitching Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsStitching As Boolean
C#
public bool SupportsStitching { get; set; }
C++
public property bool SupportsStitching sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsStitching();

/** property */
public void set_SupportsStitching(bool value);
JScript
public function get SupportsStitching() : bool

public function set SupportsStitching(value : bool);

See Also

FdoProviderCapabilitiesRaster Class


SupportsSubsampling Property

FdoProviderCapabilitiesRaster.SupportsSubsampling Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsSubsampling As Boolean
C#
public bool SupportsSubsampling { get; set; }
C++
public property bool SupportsSubsampling sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsSubsampling();

/** property */
public void set_SupportsSubsampling(bool value);
JScript
public function get SupportsSubsampling() : bool

public function set SupportsSubsampling(value : bool);

See Also

FdoProviderCapabilitiesRaster Class


FdoProviderCapabilitiesSchema Class

FdoProviderCapabilitiesSchema Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoProviderCapabilitiesSchema
C#
public class FdoProviderCapabilitiesSchema
C++
ref class FdoProviderCapabilitiesSchema
J#
public class FdoProviderCapabilitiesSchema
JScript
public class FdoProviderCapabilitiesSchema

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesSchema

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesSchema Members


FdoProviderCapabilitiesSchema Members

FdoProviderCapabilitiesSchema Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesSchema.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesSchema | Initializes a new instance of the FdoProviderCapabilitiesSchema class.
Top

Public Properties

 | Name | Description
Public property | Class |
Public property | Data |
Public property | SupportsAssociationProperties |
Public property | SupportsInheritance |
Public property | SupportsMultipleSchemas |
Public property | SupportsNetworkModel |
Public property | SupportsObjectProperties |
Public property | SupportsSchemaOverrides |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesSchema Class


FdoProviderCapabilitiesSchema Constructor

FdoProviderCapabilitiesSchema Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesSchema class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesSchema()
C++
public:
FdoProviderCapabilitiesSchema() sealed
J#
public FdoProviderCapabilitiesSchema()
JScript
public function FdoProviderCapabilitiesSchema()

See Also

FdoProviderCapabilitiesSchema Class


Properties

FdoProviderCapabilitiesSchema Properties
[image]

Public Properties

 | Name | Description
Public property | Class |
Public property | Data |
Public property | SupportsAssociationProperties |
Public property | SupportsInheritance |
Public property | SupportsMultipleSchemas |
Public property | SupportsNetworkModel |
Public property | SupportsObjectProperties |
Public property | SupportsSchemaOverrides |
Top

See Also

FdoProviderCapabilitiesSchema Class


Class Property

FdoProviderCapabilitiesSchema.Class Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Type", IsNullable := False)>
Public Property Class As FdoProviderCapabilitiesSchemaTypeCollection
C#
[XmlArrayItemAttribute("Type", IsNullable = False)]
public FdoProviderCapabilitiesSchemaTypeCollection Class { get; set; }
C++
[XmlArrayItemAttribute(L"Type", IsNullable = False)]
public property FdoProviderCapabilitiesSchemaTypeCollection Class sealed {
FdoProviderCapabilitiesSchemaTypeCollection get();
void set(FdoProviderCapabilitiesSchemaTypeCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Type", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesSchemaTypeCollection get_Class();

/** property */
public void set_Class(FdoProviderCapabilitiesSchemaTypeCollection value);
JScript
public function get Class() : FdoProviderCapabilitiesSchemaTypeCollection

public function set Class(value : FdoProviderCapabilitiesSchemaTypeCollection);

See Also

FdoProviderCapabilitiesSchema Class


Data Property

FdoProviderCapabilitiesSchema.Data Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Type", IsNullable := False)>
Public Property Data As FdoProviderCapabilitiesSchemaType1Collection
C#
[XmlArrayItemAttribute("Type", IsNullable = False)]
public FdoProviderCapabilitiesSchemaType1Collection Data { get; set; }
C++
[XmlArrayItemAttribute(L"Type", IsNullable = False)]
public property FdoProviderCapabilitiesSchemaType1Collection Data sealed {
FdoProviderCapabilitiesSchemaType1Collection get();
void set(FdoProviderCapabilitiesSchemaType1Collection value);
}
J#
/** @attribute XmlArrayItemAttribute("Type", IsNullable = False) */
/** property */
public FdoProviderCapabilitiesSchemaType1Collection get_Data();

/** property */
public void set_Data(FdoProviderCapabilitiesSchemaType1Collection value);
JScript
public function get Data() : FdoProviderCapabilitiesSchemaType1Collection

public function set Data(value : FdoProviderCapabilitiesSchemaType1Collection);

See Also

FdoProviderCapabilitiesSchema Class


SupportsAssociationProperties Property

FdoProviderCapabilitiesSchema.SupportsAssociationProperties Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsAssociationProperties As Boolean
C#
public bool SupportsAssociationProperties { get; set; }
C++
public property bool SupportsAssociationProperties sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsAssociationProperties();

/** property */
public void set_SupportsAssociationProperties(bool value);
JScript
public function get SupportsAssociationProperties() : bool

public function set SupportsAssociationProperties(value : bool);

See Also

FdoProviderCapabilitiesSchema Class


SupportsInheritance Property

FdoProviderCapabilitiesSchema.SupportsInheritance Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsInheritance As Boolean
C#
public bool SupportsInheritance { get; set; }
C++
public property bool SupportsInheritance sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsInheritance();

/** property */
public void set_SupportsInheritance(bool value);
JScript
public function get SupportsInheritance() : bool

public function set SupportsInheritance(value : bool);

See Also

FdoProviderCapabilitiesSchema Class


SupportsMultipleSchemas Property

FdoProviderCapabilitiesSchema.SupportsMultipleSchemas Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsMultipleSchemas As Boolean
C#
public bool SupportsMultipleSchemas { get; set; }
C++
public property bool SupportsMultipleSchemas sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsMultipleSchemas();

/** property */
public void set_SupportsMultipleSchemas(bool value);
JScript
public function get SupportsMultipleSchemas() : bool

public function set SupportsMultipleSchemas(value : bool);

See Also

FdoProviderCapabilitiesSchema Class


SupportsNetworkModel Property

FdoProviderCapabilitiesSchema.SupportsNetworkModel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsNetworkModel As Boolean
C#
public bool SupportsNetworkModel { get; set; }
C++
public property bool SupportsNetworkModel sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsNetworkModel();

/** property */
public void set_SupportsNetworkModel(bool value);
JScript
public function get SupportsNetworkModel() : bool

public function set SupportsNetworkModel(value : bool);

See Also

FdoProviderCapabilitiesSchema Class


SupportsObjectProperties Property

FdoProviderCapabilitiesSchema.SupportsObjectProperties Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsObjectProperties As Boolean
C#
public bool SupportsObjectProperties { get; set; }
C++
public property bool SupportsObjectProperties sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsObjectProperties();

/** property */
public void set_SupportsObjectProperties(bool value);
JScript
public function get SupportsObjectProperties() : bool

public function set SupportsObjectProperties(value : bool);

See Also

FdoProviderCapabilitiesSchema Class


SupportsSchemaOverrides Property

FdoProviderCapabilitiesSchema.SupportsSchemaOverrides Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsSchemaOverrides As Boolean
C#
public bool SupportsSchemaOverrides { get; set; }
C++
public property bool SupportsSchemaOverrides sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsSchemaOverrides();

/** property */
public void set_SupportsSchemaOverrides(bool value);
JScript
public function get SupportsSchemaOverrides() : bool

public function set SupportsSchemaOverrides(value : bool);

See Also

FdoProviderCapabilitiesSchema Class


FdoProviderCapabilitiesSchemaType Enumeration

FdoProviderCapabilitiesSchemaType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FdoProviderCapabilitiesSchemaType
C#
public enum FdoProviderCapabilitiesSchemaType
C++
public enum class FdoProviderCapabilitiesSchemaType
J#
public enum FdoProviderCapabilitiesSchemaType
JScript
public enum FdoProviderCapabilitiesSchemaType

Members

Member Name | Description
Class |
FeatureClass |

See Also


FdoProviderCapabilitiesSchemaType1 Enumeration

FdoProviderCapabilitiesSchemaType1 Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlTypeAttribute(TypeName := "FdoProviderCapabilitiesSchemaDataType")>
Public Enum FdoProviderCapabilitiesSchemaType1
C#
[XmlTypeAttribute(TypeName = "FdoProviderCapabilitiesSchemaDataType")]
public enum FdoProviderCapabilitiesSchemaType1
C++
[XmlTypeAttribute(TypeName = L"FdoProviderCapabilitiesSchemaDataType")]
public enum class FdoProviderCapabilitiesSchemaType1
J#
/** @attribute XmlTypeAttribute(TypeName = "FdoProviderCapabilitiesSchemaDataType") */
public enum FdoProviderCapabilitiesSchemaType1
JScript
public enum FdoProviderCapabilitiesSchemaType1

Members

Member Name | Description
Boolean |
Byte |
DateTime |
Decimal |
Double |
Int16 |
Int32 |
Int64 |
Single |
String |
BLOB |
CLOB |
UniqueID |

See Also


FdoProviderCapabilitiesSchemaType1Collection Class

FdoProviderCapabilitiesSchemaType1Collection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesSchemaType1Collection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesSchemaType1Collection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesSchemaType1Collection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesSchemaType1Collection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesSchemaType1Collection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesSchemaType1Collection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesSchemaType1Collection Members


FdoProviderCapabilitiesSchemaType1Collection Members

FdoProviderCapabilitiesSchemaType1Collection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesSchemaType1Collection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesSchemaType1Collection | Initializes a new instance of the FdoProviderCapabilitiesSchemaType1Collection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesSchemaType1Collection Class


FdoProviderCapabilitiesSchemaType1Collection Constructor

FdoProviderCapabilitiesSchemaType1Collection Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesSchemaType1Collection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesSchemaType1Collection()
C++
public:
FdoProviderCapabilitiesSchemaType1Collection() sealed
J#
public FdoProviderCapabilitiesSchemaType1Collection()
JScript
public function FdoProviderCapabilitiesSchemaType1Collection()

See Also

FdoProviderCapabilitiesSchemaType1Collection Class


Properties

FdoProviderCapabilitiesSchemaType1Collection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesSchemaType1Collection Class


Item Property

FdoProviderCapabilitiesSchemaType1Collection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesSchemaType1
C#
public FdoProviderCapabilitiesSchemaType1 this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesSchemaType1 default[int idx] sealed {
FdoProviderCapabilitiesSchemaType1 get(int idx);
void set(int idx, FdoProviderCapabilitiesSchemaType1 value);
}
J#
/** property */
public FdoProviderCapabilitiesSchemaType1 get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesSchemaType1 value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesSchemaType1Collection Class


Methods

FdoProviderCapabilitiesSchemaType1Collection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesSchemaType1Collection Class


Add Method

FdoProviderCapabilitiesSchemaType1Collection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesSchemaType1 _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesSchemaType1 value
)
C++
public:
int Add(
FdoProviderCapabilitiesSchemaType1 value
) sealed
J#
public int Add(
FdoProviderCapabilitiesSchemaType1 value
)
JScript
public function Add(
value : FdoProviderCapabilitiesSchemaType1
) : int

See Also

FdoProviderCapabilitiesSchemaType1Collection Class


FdoProviderCapabilitiesSchemaTypeCollection Class

FdoProviderCapabilitiesSchemaTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoProviderCapabilitiesSchemaTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoProviderCapabilitiesSchemaTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoProviderCapabilitiesSchemaTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoProviderCapabilitiesSchemaTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoProviderCapabilitiesSchemaTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesSchemaTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesSchemaTypeCollection Members


FdoProviderCapabilitiesSchemaTypeCollection Members

FdoProviderCapabilitiesSchemaTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesSchemaTypeCollection.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesSchemaTypeCollection | Initializes a new instance of the FdoProviderCapabilitiesSchemaTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesSchemaTypeCollection Class


FdoProviderCapabilitiesSchemaTypeCollection Constructor

FdoProviderCapabilitiesSchemaTypeCollection Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesSchemaTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesSchemaTypeCollection()
C++
public:
FdoProviderCapabilitiesSchemaTypeCollection() sealed
J#
public FdoProviderCapabilitiesSchemaTypeCollection()
JScript
public function FdoProviderCapabilitiesSchemaTypeCollection()

See Also

FdoProviderCapabilitiesSchemaTypeCollection Class


Properties

FdoProviderCapabilitiesSchemaTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoProviderCapabilitiesSchemaTypeCollection Class


Item Property

FdoProviderCapabilitiesSchemaTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoProviderCapabilitiesSchemaType
C#
public FdoProviderCapabilitiesSchemaType this[
int idx
] { get; set; }
C++
public property FdoProviderCapabilitiesSchemaType default[int idx] sealed {
FdoProviderCapabilitiesSchemaType get(int idx);
void set(int idx, FdoProviderCapabilitiesSchemaType value);
}
J#
/** property */
public FdoProviderCapabilitiesSchemaType get_Item(int idx);

/** property */
public void set_Item(int idx, FdoProviderCapabilitiesSchemaType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoProviderCapabilitiesSchemaTypeCollection Class


Methods

FdoProviderCapabilitiesSchemaTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesSchemaTypeCollection Class


Add Method

FdoProviderCapabilitiesSchemaTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoProviderCapabilitiesSchemaType _
) As Integer
C#
public int Add(
FdoProviderCapabilitiesSchemaType value
)
C++
public:
int Add(
FdoProviderCapabilitiesSchemaType value
) sealed
J#
public int Add(
FdoProviderCapabilitiesSchemaType value
)
JScript
public function Add(
value : FdoProviderCapabilitiesSchemaType
) : int

See Also

FdoProviderCapabilitiesSchemaTypeCollection Class


FdoProviderCapabilitiesTopology Class

FdoProviderCapabilitiesTopology Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoProviderCapabilitiesTopology
C#
public class FdoProviderCapabilitiesTopology
C++
ref class FdoProviderCapabilitiesTopology
J#
public class FdoProviderCapabilitiesTopology
JScript
public class FdoProviderCapabilitiesTopology

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesTopology

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoProviderCapabilitiesTopology Members


FdoProviderCapabilitiesTopology Members

FdoProviderCapabilitiesTopology Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoProviderCapabilitiesTopology.

Public Constructors

 | Name | Description
Public method | FdoProviderCapabilitiesTopology | Initializes a new instance of the FdoProviderCapabilitiesTopology class.
Top

Public Properties

 | Name | Description
Public property | ActivatesTopologyByArea |
Public property | BreaksCurveCrossingsAutomatically |
Public property | ConstrainsFeatureMovements |
Public property | SupportsTopologicalHierarchy |
Public property | SupportsTopology |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoProviderCapabilitiesTopology Class


FdoProviderCapabilitiesTopology Constructor

FdoProviderCapabilitiesTopology Constructor
[image]

Initializes a new instance of the FdoProviderCapabilitiesTopology class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoProviderCapabilitiesTopology()
C++
public:
FdoProviderCapabilitiesTopology() sealed
J#
public FdoProviderCapabilitiesTopology()
JScript
public function FdoProviderCapabilitiesTopology()

See Also

FdoProviderCapabilitiesTopology Class


Properties

FdoProviderCapabilitiesTopology Properties
[image]

Public Properties

 | Name | Description
Public property | ActivatesTopologyByArea |
Public property | BreaksCurveCrossingsAutomatically |
Public property | ConstrainsFeatureMovements |
Public property | SupportsTopologicalHierarchy |
Public property | SupportsTopology |
Top

See Also

FdoProviderCapabilitiesTopology Class


ActivatesTopologyByArea Property

FdoProviderCapabilitiesTopology.ActivatesTopologyByArea Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ActivatesTopologyByArea As Boolean
C#
public bool ActivatesTopologyByArea { get; set; }
C++
public property bool ActivatesTopologyByArea sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ActivatesTopologyByArea();

/** property */
public void set_ActivatesTopologyByArea(bool value);
JScript
public function get ActivatesTopologyByArea() : bool

public function set ActivatesTopologyByArea(value : bool);

See Also

FdoProviderCapabilitiesTopology Class


BreaksCurveCrossingsAutomatically Property

FdoProviderCapabilitiesTopology.BreaksCurveCrossingsAutomatically Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property BreaksCurveCrossingsAutomatically As Boolean
C#
public bool BreaksCurveCrossingsAutomatically { get; set; }
C++
public property bool BreaksCurveCrossingsAutomatically sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_BreaksCurveCrossingsAutomatically();

/** property */
public void set_BreaksCurveCrossingsAutomatically(bool value);
JScript
public function get BreaksCurveCrossingsAutomatically() : bool

public function set BreaksCurveCrossingsAutomatically(value : bool);

See Also

FdoProviderCapabilitiesTopology Class


ConstrainsFeatureMovements Property

FdoProviderCapabilitiesTopology.ConstrainsFeatureMovements Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ConstrainsFeatureMovements As Boolean
C#
public bool ConstrainsFeatureMovements { get; set; }
C++
public property bool ConstrainsFeatureMovements sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ConstrainsFeatureMovements();

/** property */
public void set_ConstrainsFeatureMovements(bool value);
JScript
public function get ConstrainsFeatureMovements() : bool

public function set ConstrainsFeatureMovements(value : bool);

See Also

FdoProviderCapabilitiesTopology Class


SupportsTopologicalHierarchy Property

FdoProviderCapabilitiesTopology.SupportsTopologicalHierarchy Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsTopologicalHierarchy As Boolean
C#
public bool SupportsTopologicalHierarchy { get; set; }
C++
public property bool SupportsTopologicalHierarchy sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsTopologicalHierarchy();

/** property */
public void set_SupportsTopologicalHierarchy(bool value);
JScript
public function get SupportsTopologicalHierarchy() : bool

public function set SupportsTopologicalHierarchy(value : bool);

See Also

FdoProviderCapabilitiesTopology Class


SupportsTopology Property

FdoProviderCapabilitiesTopology.SupportsTopology Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SupportsTopology As Boolean
C#
public bool SupportsTopology { get; set; }
C++
public property bool SupportsTopology sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_SupportsTopology();

/** property */
public void set_SupportsTopology(bool value);
JScript
public function get SupportsTopology() : bool

public function set SupportsTopology(value : bool);

See Also

FdoProviderCapabilitiesTopology Class


FdoSpatialContextList Class

FdoSpatialContextList Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class FdoSpatialContextList
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class FdoSpatialContextList
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class FdoSpatialContextList
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class FdoSpatialContextList
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class FdoSpatialContextList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoSpatialContextList Members


FdoSpatialContextList Members

FdoSpatialContextList Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by FdoSpatialContextList.

Public Constructors

 | Name | Description
Public method | FdoSpatialContextList | Initializes a new instance of the FdoSpatialContextList class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | ProviderName |
Public property | SpatialContext |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoSpatialContextList Class


FdoSpatialContextList Constructor

FdoSpatialContextList Constructor
[image]

Initializes a new instance of the FdoSpatialContextList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoSpatialContextList()
C++
public:
FdoSpatialContextList() sealed
J#
public FdoSpatialContextList()
JScript
public function FdoSpatialContextList()

See Also

FdoSpatialContextList Class


Fields

FdoSpatialContextList Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

FdoSpatialContextList Class


SchemaName Field

FdoSpatialContextList.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

FdoSpatialContextList Class


Properties

FdoSpatialContextList Properties
[image]

Public Properties

 | Name | Description
Public property | ProviderName |
Public property | SpatialContext |
Public property | XsdSchema |
Top

See Also

FdoSpatialContextList Class


ProviderName Property

FdoSpatialContextList.ProviderName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ProviderName As String
C#
public string ProviderName { get; set; }
C++
public property string ProviderName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ProviderName();

/** property */
public void set_ProviderName(string value);
JScript
public function get ProviderName() : String

public function set ProviderName(value : String);

See Also

FdoSpatialContextList Class


SpatialContext Property

FdoSpatialContextList.SpatialContext Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("SpatialContext")>
Public Property SpatialContext As FdoSpatialContextListSpatialContextCollection
C#
[XmlElementAttribute("SpatialContext")]
public FdoSpatialContextListSpatialContextCollection SpatialContext { get; set; }
C++
[XmlElementAttribute(L"SpatialContext")]
public property FdoSpatialContextListSpatialContextCollection SpatialContext sealed {
FdoSpatialContextListSpatialContextCollection get();
void set(FdoSpatialContextListSpatialContextCollection value);
}
J#
/** @attribute XmlElementAttribute("SpatialContext") */
/** property */
public FdoSpatialContextListSpatialContextCollection get_SpatialContext();

/** property */
public void set_SpatialContext(FdoSpatialContextListSpatialContextCollection value);
JScript
public function get SpatialContext() : FdoSpatialContextListSpatialContextCollection

public function set SpatialContext(value : FdoSpatialContextListSpatialContextCollection);

See Also

FdoSpatialContextList Class


XsdSchema Property

FdoSpatialContextList.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

FdoSpatialContextList Class


FdoSpatialContextListSpatialContext Class

FdoSpatialContextListSpatialContext Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoSpatialContextListSpatialContext
C#
public class FdoSpatialContextListSpatialContext
C++
ref class FdoSpatialContextListSpatialContext
J#
public class FdoSpatialContextListSpatialContext
JScript
public class FdoSpatialContextListSpatialContext

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextListSpatialContext

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoSpatialContextListSpatialContext Members


FdoSpatialContextListSpatialContext Members

FdoSpatialContextListSpatialContext Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoSpatialContextListSpatialContext.

Public Constructors

 | Name | Description
Public method | FdoSpatialContextListSpatialContext | Initializes a new instance of the FdoSpatialContextListSpatialContext class.
Top

Public Properties

 | Name | Description
Public property | CoordinateSystemName |
Public property | CoordinateSystemWkt |
Public property | Description |
Public property | Extent |
Public property | ExtentType |
Public property | IsActive |
Public property | Name |
Public property | XYTolerance |
Public property | ZTolerance |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoSpatialContextListSpatialContext Class


FdoSpatialContextListSpatialContext Constructor

FdoSpatialContextListSpatialContext Constructor
[image]

Initializes a new instance of the FdoSpatialContextListSpatialContext class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoSpatialContextListSpatialContext()
C++
public:
FdoSpatialContextListSpatialContext() sealed
J#
public FdoSpatialContextListSpatialContext()
JScript
public function FdoSpatialContextListSpatialContext()

See Also

FdoSpatialContextListSpatialContext Class


Properties

FdoSpatialContextListSpatialContext Properties
[image]

Public Properties

 | Name | Description
Public property | CoordinateSystemName |
Public property | CoordinateSystemWkt |
Public property | Description |
Public property | Extent |
Public property | ExtentType |
Public property | IsActive |
Public property | Name |
Public property | XYTolerance |
Public property | ZTolerance |
Top

See Also

FdoSpatialContextListSpatialContext Class


CoordinateSystemName Property

FdoSpatialContextListSpatialContext.CoordinateSystemName Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CoordinateSystemName As String
C#
public string CoordinateSystemName { get; set; }
C++
public property string CoordinateSystemName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CoordinateSystemName();

/** property */
public void set_CoordinateSystemName(string value);
JScript
public function get CoordinateSystemName() : String

public function set CoordinateSystemName(value : String);

See Also

FdoSpatialContextListSpatialContext Class


CoordinateSystemWkt Property

FdoSpatialContextListSpatialContext.CoordinateSystemWkt Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CoordinateSystemWkt As String
C#
public string CoordinateSystemWkt { get; set; }
C++
public property string CoordinateSystemWkt sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CoordinateSystemWkt();

/** property */
public void set_CoordinateSystemWkt(string value);
JScript
public function get CoordinateSystemWkt() : String

public function set CoordinateSystemWkt(value : String);

See Also

FdoSpatialContextListSpatialContext Class


Description Property

FdoSpatialContextListSpatialContext.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

FdoSpatialContextListSpatialContext Class


Extent Property

FdoSpatialContextListSpatialContext.Extent Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Extent As FdoSpatialContextListSpatialContextExtent
C#
public FdoSpatialContextListSpatialContextExtent Extent { get; set; }
C++
public property FdoSpatialContextListSpatialContextExtent Extent sealed {
FdoSpatialContextListSpatialContextExtent get();
void set(FdoSpatialContextListSpatialContextExtent value);
}
J#
/** property */
public FdoSpatialContextListSpatialContextExtent get_Extent();

/** property */
public void set_Extent(FdoSpatialContextListSpatialContextExtent value);
JScript
public function get Extent() : FdoSpatialContextListSpatialContextExtent

public function set Extent(value : FdoSpatialContextListSpatialContextExtent);

See Also

FdoSpatialContextListSpatialContext Class


ExtentType Property

FdoSpatialContextListSpatialContext.ExtentType Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtentType As FdoSpatialContextListSpatialContextExtentType
C#
public FdoSpatialContextListSpatialContextExtentType ExtentType { get; set; }
C++
public property FdoSpatialContextListSpatialContextExtentType ExtentType sealed {
FdoSpatialContextListSpatialContextExtentType get();
void set(FdoSpatialContextListSpatialContextExtentType value);
}
J#
/** property */
public FdoSpatialContextListSpatialContextExtentType get_ExtentType();

/** property */
public void set_ExtentType(FdoSpatialContextListSpatialContextExtentType value);
JScript
public function get ExtentType() : FdoSpatialContextListSpatialContextExtentType

public function set ExtentType(value : FdoSpatialContextListSpatialContextExtentType);

See Also

FdoSpatialContextListSpatialContext Class


IsActive Property

FdoSpatialContextListSpatialContext.IsActive Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(False), _
XmlAttributeAttribute>
Public Property IsActive As Boolean
C#
[DefaultValueAttribute(False)]
[XmlAttributeAttribute]
public bool IsActive { get; set; }
C++
[DefaultValueAttribute(False)]
[XmlAttributeAttribute]
public property bool IsActive sealed {
bool get();
void set(bool value);
}
J#
/** @attribute DefaultValueAttribute(False) */
/** @attribute XmlAttributeAttribute() */
/** property */
public bool get_IsActive();

/** property */
public void set_IsActive(bool value);
JScript
public function get IsActive() : bool

public function set IsActive(value : bool);

See Also

FdoSpatialContextListSpatialContext Class


Name Property

FdoSpatialContextListSpatialContext.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

FdoSpatialContextListSpatialContext Class


XYTolerance Property

FdoSpatialContextListSpatialContext.XYTolerance Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property XYTolerance As Double
C#
public double XYTolerance { get; set; }
C++
public property double XYTolerance sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_XYTolerance();

/** property */
public void set_XYTolerance(double value);
JScript
public function get XYTolerance() : double

public function set XYTolerance(value : double);

See Also

FdoSpatialContextListSpatialContext Class


ZTolerance Property

FdoSpatialContextListSpatialContext.ZTolerance Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ZTolerance As Double
C#
public double ZTolerance { get; set; }
C++
public property double ZTolerance sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_ZTolerance();

/** property */
public void set_ZTolerance(double value);
JScript
public function get ZTolerance() : double

public function set ZTolerance(value : double);

See Also

FdoSpatialContextListSpatialContext Class


FdoSpatialContextListSpatialContextCollection Class

FdoSpatialContextListSpatialContextCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FdoSpatialContextListSpatialContextCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FdoSpatialContextListSpatialContextCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FdoSpatialContextListSpatialContextCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FdoSpatialContextListSpatialContextCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FdoSpatialContextListSpatialContextCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextListSpatialContextCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoSpatialContextListSpatialContextCollection Members


FdoSpatialContextListSpatialContextCollection Members

FdoSpatialContextListSpatialContextCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoSpatialContextListSpatialContextCollection.

Public Constructors

 | Name | Description
Public method | FdoSpatialContextListSpatialContextCollection | Initializes a new instance of the FdoSpatialContextListSpatialContextCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoSpatialContextListSpatialContextCollection Class


FdoSpatialContextListSpatialContextCollection Constructor

FdoSpatialContextListSpatialContextCollection Constructor
[image]

Initializes a new instance of the FdoSpatialContextListSpatialContextCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoSpatialContextListSpatialContextCollection()
C++
public:
FdoSpatialContextListSpatialContextCollection() sealed
J#
public FdoSpatialContextListSpatialContextCollection()
JScript
public function FdoSpatialContextListSpatialContextCollection()

See Also

FdoSpatialContextListSpatialContextCollection Class


Properties

FdoSpatialContextListSpatialContextCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FdoSpatialContextListSpatialContextCollection Class


Item Property

FdoSpatialContextListSpatialContextCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FdoSpatialContextListSpatialContext
C#
public FdoSpatialContextListSpatialContext this[
int idx
] { get; set; }
C++
public property FdoSpatialContextListSpatialContext default[int idx] sealed {
FdoSpatialContextListSpatialContext get(int idx);
void set(int idx, FdoSpatialContextListSpatialContext value);
}
J#
/** property */
public FdoSpatialContextListSpatialContext get_Item(int idx);

/** property */
public void set_Item(int idx, FdoSpatialContextListSpatialContext value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FdoSpatialContextListSpatialContextCollection Class


Methods

FdoSpatialContextListSpatialContextCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoSpatialContextListSpatialContextCollection Class


Add Method

FdoSpatialContextListSpatialContextCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FdoSpatialContextListSpatialContext _
) As Integer
C#
public int Add(
FdoSpatialContextListSpatialContext value
)
C++
public:
int Add(
FdoSpatialContextListSpatialContext value
) sealed
J#
public int Add(
FdoSpatialContextListSpatialContext value
)
JScript
public function Add(
value : FdoSpatialContextListSpatialContext
) : int

See Also

FdoSpatialContextListSpatialContextCollection Class


FdoSpatialContextListSpatialContextExtent Class

FdoSpatialContextListSpatialContextExtent Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoSpatialContextListSpatialContextExtent
C#
public class FdoSpatialContextListSpatialContextExtent
C++
ref class FdoSpatialContextListSpatialContextExtent
J#
public class FdoSpatialContextListSpatialContextExtent
JScript
public class FdoSpatialContextListSpatialContextExtent

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextListSpatialContextExtent

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoSpatialContextListSpatialContextExtent Members


FdoSpatialContextListSpatialContextExtent Members

FdoSpatialContextListSpatialContextExtent Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoSpatialContextListSpatialContextExtent.

Public Constructors

 | Name | Description
Public method | FdoSpatialContextListSpatialContextExtent | Initializes a new instance of the FdoSpatialContextListSpatialContextExtent class.
Top

Public Properties

 | Name | Description
Public property | LowerLeftCoordinate |
Public property | UpperRightCoordinate |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoSpatialContextListSpatialContextExtent Class


FdoSpatialContextListSpatialContextExtent Constructor

FdoSpatialContextListSpatialContextExtent Constructor
[image]

Initializes a new instance of the FdoSpatialContextListSpatialContextExtent class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoSpatialContextListSpatialContextExtent()
C++
public:
FdoSpatialContextListSpatialContextExtent() sealed
J#
public FdoSpatialContextListSpatialContextExtent()
JScript
public function FdoSpatialContextListSpatialContextExtent()

See Also

FdoSpatialContextListSpatialContextExtent Class


Properties

FdoSpatialContextListSpatialContextExtent Properties
[image]

Public Properties

 | Name | Description
Public property | LowerLeftCoordinate |
Public property | UpperRightCoordinate |
Top

See Also

FdoSpatialContextListSpatialContextExtent Class


LowerLeftCoordinate Property

FdoSpatialContextListSpatialContextExtent.LowerLeftCoordinate Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LowerLeftCoordinate As FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate
C#
public FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate LowerLeftCoordinate { get; set; }
C++
public property FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate LowerLeftCoordinate sealed {
FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate get();
void set(FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate value);
}
J#
/** property */
public FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate get_LowerLeftCoordinate();

/** property */
public void set_LowerLeftCoordinate(FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate value);
JScript
public function get LowerLeftCoordinate() : FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate

public function set LowerLeftCoordinate(value : FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate);

See Also

FdoSpatialContextListSpatialContextExtent Class


UpperRightCoordinate Property

FdoSpatialContextListSpatialContextExtent.UpperRightCoordinate Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property UpperRightCoordinate As FdoSpatialContextListSpatialContextExtentUpperRightCoordinate
C#
public FdoSpatialContextListSpatialContextExtentUpperRightCoordinate UpperRightCoordinate { get; set; }
C++
public property FdoSpatialContextListSpatialContextExtentUpperRightCoordinate UpperRightCoordinate sealed {
FdoSpatialContextListSpatialContextExtentUpperRightCoordinate get();
void set(FdoSpatialContextListSpatialContextExtentUpperRightCoordinate value);
}
J#
/** property */
public FdoSpatialContextListSpatialContextExtentUpperRightCoordinate get_UpperRightCoordinate();

/** property */
public void set_UpperRightCoordinate(FdoSpatialContextListSpatialContextExtentUpperRightCoordinate value);
JScript
public function get UpperRightCoordinate() : FdoSpatialContextListSpatialContextExtentUpperRightCoordinate

public function set UpperRightCoordinate(value : FdoSpatialContextListSpatialContextExtentUpperRightCoordinate);

See Also

FdoSpatialContextListSpatialContextExtent Class


FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Class

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate
C#
public class FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate
C++
ref class FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate
J#
public class FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate
JScript
public class FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Members


FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Members

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate.

Public Constructors

 | Name | Description
Public method | FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate | Initializes a new instance of the FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate class.
Top

Public Properties

 | Name | Description
Public property | M |
Public property | X |
Public property | Y |
Public property | Z |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Class


FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Constructor

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Constructor
See Also Example
[image]

Initializes a new instance of the FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate()
C++
public:
FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate() sealed
J#
public FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate()
JScript
public function FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate()

See Also

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Class


Properties

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | M |
Public property | X |
Public property | Y |
Public property | Z |
Top

See Also

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Class


M Property

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate.M Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property M As String
C#
public string M { get; set; }
C++
public property string M sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_M();

/** property */
public void set_M(string value);
JScript
public function get M() : String

public function set M(value : String);

See Also

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Class


X Property

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate.X Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property X As String
C#
public string X { get; set; }
C++
public property string X sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_X();

/** property */
public void set_X(string value);
JScript
public function get X() : String

public function set X(value : String);

See Also

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Class


Y Property

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate.Y Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Y As String
C#
public string Y { get; set; }
C++
public property string Y sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Y();

/** property */
public void set_Y(string value);
JScript
public function get Y() : String

public function set Y(value : String);

See Also

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Class


Z Property

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate.Z Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Z As String
C#
public string Z { get; set; }
C++
public property string Z sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Z();

/** property */
public void set_Z(string value);
JScript
public function get Z() : String

public function set Z(value : String);

See Also

FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate Class


FdoSpatialContextListSpatialContextExtentType Enumeration

FdoSpatialContextListSpatialContextExtentType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FdoSpatialContextListSpatialContextExtentType
C#
public enum FdoSpatialContextListSpatialContextExtentType
C++
public enum class FdoSpatialContextListSpatialContextExtentType
J#
public enum FdoSpatialContextListSpatialContextExtentType
JScript
public enum FdoSpatialContextListSpatialContextExtentType

Members

Member Name | Description
Static |
Dynamic |

See Also


FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Class

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FdoSpatialContextListSpatialContextExtentUpperRightCoordinate
C#
public class FdoSpatialContextListSpatialContextExtentUpperRightCoordinate
C++
ref class FdoSpatialContextListSpatialContextExtentUpperRightCoordinate
J#
public class FdoSpatialContextListSpatialContextExtentUpperRightCoordinate
JScript
public class FdoSpatialContextListSpatialContextExtentUpperRightCoordinate

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextListSpatialContextExtentUpperRightCoordinate

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Members


FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Members

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FdoSpatialContextListSpatialContextExtentUpperRightCoordinate.

Public Constructors

 | Name | Description
Public method | FdoSpatialContextListSpatialContextExtentUpperRightCoordinate | Initializes a new instance of the FdoSpatialContextListSpatialContextExtentUpperRightCoordinate class.
Top

Public Properties

 | Name | Description
Public property | M |
Public property | X |
Public property | Y |
Public property | Z |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Class


FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Constructor

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Constructor
See Also Example
[image]

Initializes a new instance of the FdoSpatialContextListSpatialContextExtentUpperRightCoordinate class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FdoSpatialContextListSpatialContextExtentUpperRightCoordinate()
C++
public:
FdoSpatialContextListSpatialContextExtentUpperRightCoordinate() sealed
J#
public FdoSpatialContextListSpatialContextExtentUpperRightCoordinate()
JScript
public function FdoSpatialContextListSpatialContextExtentUpperRightCoordinate()

See Also

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Class


Properties

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | M |
Public property | X |
Public property | Y |
Public property | Z |
Top

See Also

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Class


M Property

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate.M Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property M As String
C#
public string M { get; set; }
C++
public property string M sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_M();

/** property */
public void set_M(string value);
JScript
public function get M() : String

public function set M(value : String);

See Also

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Class


X Property

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate.X Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property X As String
C#
public string X { get; set; }
C++
public property string X sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_X();

/** property */
public void set_X(string value);
JScript
public function get X() : String

public function set X(value : String);

See Also

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Class


Y Property

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate.Y Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Y As String
C#
public string Y { get; set; }
C++
public property string Y sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Y();

/** property */
public void set_Y(string value);
JScript
public function get Y() : String

public function set Y(value : String);

See Also

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Class


Z Property

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate.Z Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Z As String
C#
public string Z { get; set; }
C++
public property string Z sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Z();

/** property */
public void set_Z(string value);
JScript
public function get Z() : String

public function set Z(value : String);

See Also

FdoSpatialContextListSpatialContextExtentUpperRightCoordinate Class


FeatureNameType Enumeration

FeatureNameType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum FeatureNameType
C#
public enum FeatureNameType
C++
public enum class FeatureNameType
J#
public enum FeatureNameType
JScript
public enum FeatureNameType

Members

Member Name | Description
FeatureClass |
NamedExtension |

See Also


FeatureProviderRegistry Class

FeatureProviderRegistry Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class FeatureProviderRegistry
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class FeatureProviderRegistry
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class FeatureProviderRegistry
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class FeatureProviderRegistry
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class FeatureProviderRegistry

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureProviderRegistry

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureProviderRegistry Members


FeatureProviderRegistry Members

FeatureProviderRegistry Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by FeatureProviderRegistry.

Public Constructors

 | Name | Description
Public method | FeatureProviderRegistry | Initializes a new instance of the FeatureProviderRegistry class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | FeatureProvider |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureProviderRegistry Class


FeatureProviderRegistry Constructor

FeatureProviderRegistry Constructor
[image]

Initializes a new instance of the FeatureProviderRegistry class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureProviderRegistry()
C++
public:
FeatureProviderRegistry() sealed
J#
public FeatureProviderRegistry()
JScript
public function FeatureProviderRegistry()

See Also

FeatureProviderRegistry Class


Fields

FeatureProviderRegistry Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

FeatureProviderRegistry Class


SchemaName Field

FeatureProviderRegistry.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

FeatureProviderRegistry Class


Properties

FeatureProviderRegistry Properties
[image]

Public Properties

 | Name | Description
Public property | FeatureProvider |
Public property | XsdSchema |
Top

See Also

FeatureProviderRegistry Class


FeatureProvider Property

FeatureProviderRegistry.FeatureProvider Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("FeatureProvider")>
Public Property FeatureProvider As FeatureProviderRegistryFeatureProviderCollection
C#
[XmlElementAttribute("FeatureProvider")]
public FeatureProviderRegistryFeatureProviderCollection FeatureProvider { get; set; }
C++
[XmlElementAttribute(L"FeatureProvider")]
public property FeatureProviderRegistryFeatureProviderCollection FeatureProvider sealed {
FeatureProviderRegistryFeatureProviderCollection get();
void set(FeatureProviderRegistryFeatureProviderCollection value);
}
J#
/** @attribute XmlElementAttribute("FeatureProvider") */
/** property */
public FeatureProviderRegistryFeatureProviderCollection get_FeatureProvider();

/** property */
public void set_FeatureProvider(FeatureProviderRegistryFeatureProviderCollection value);
JScript
public function get FeatureProvider() : FeatureProviderRegistryFeatureProviderCollection

public function set FeatureProvider(value : FeatureProviderRegistryFeatureProviderCollection);

See Also

FeatureProviderRegistry Class


XsdSchema Property

FeatureProviderRegistry.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

FeatureProviderRegistry Class


FeatureProviderRegistryFeatureProvider Class

FeatureProviderRegistryFeatureProvider Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FeatureProviderRegistryFeatureProvider
C#
public class FeatureProviderRegistryFeatureProvider
C++
ref class FeatureProviderRegistryFeatureProvider
J#
public class FeatureProviderRegistryFeatureProvider
JScript
public class FeatureProviderRegistryFeatureProvider

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureProviderRegistryFeatureProvider

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureProviderRegistryFeatureProvider Members


FeatureProviderRegistryFeatureProvider Members

FeatureProviderRegistryFeatureProvider Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FeatureProviderRegistryFeatureProvider.

Public Constructors

 | Name | Description
Public method | FeatureProviderRegistryFeatureProvider | Initializes a new instance of the FeatureProviderRegistryFeatureProvider class.
Top

Public Properties

 | Name | Description
Public property | ConnectionProperties |
Public property | Description |
Public property | DisplayName |
Public property | FeatureDataObjectsVersion |
Public property | Name |
Public property | Version |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureProviderRegistryFeatureProvider Class


FeatureProviderRegistryFeatureProvider Constructor

FeatureProviderRegistryFeatureProvider Constructor
[image]

Initializes a new instance of the FeatureProviderRegistryFeatureProvider class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureProviderRegistryFeatureProvider()
C++
public:
FeatureProviderRegistryFeatureProvider() sealed
J#
public FeatureProviderRegistryFeatureProvider()
JScript
public function FeatureProviderRegistryFeatureProvider()

See Also

FeatureProviderRegistryFeatureProvider Class


Properties

FeatureProviderRegistryFeatureProvider Properties
[image]

Public Properties

 | Name | Description
Public property | ConnectionProperties |
Public property | Description |
Public property | DisplayName |
Public property | FeatureDataObjectsVersion |
Public property | Name |
Public property | Version |
Top

See Also

FeatureProviderRegistryFeatureProvider Class


ConnectionProperties Property

FeatureProviderRegistryFeatureProvider.ConnectionProperties Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("ConnectionProperty", IsNullable := False)>
Public Property ConnectionProperties As FeatureProviderRegistryFeatureProviderConnectionPropertyCollection
C#
[XmlArrayItemAttribute("ConnectionProperty", IsNullable = False)]
public FeatureProviderRegistryFeatureProviderConnectionPropertyCollection ConnectionProperties { get; set; }
C++
[XmlArrayItemAttribute(L"ConnectionProperty", IsNullable = False)]
public property FeatureProviderRegistryFeatureProviderConnectionPropertyCollection ConnectionProperties sealed {
FeatureProviderRegistryFeatureProviderConnectionPropertyCollection get();
void set(FeatureProviderRegistryFeatureProviderConnectionPropertyCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("ConnectionProperty", IsNullable = False) */
/** property */
public FeatureProviderRegistryFeatureProviderConnectionPropertyCollection get_ConnectionProperties();

/** property */
public void set_ConnectionProperties(FeatureProviderRegistryFeatureProviderConnectionPropertyCollection value);
JScript
public function get ConnectionProperties() : FeatureProviderRegistryFeatureProviderConnectionPropertyCollection

public function set ConnectionProperties(value : FeatureProviderRegistryFeatureProviderConnectionPropertyCollection);

See Also

FeatureProviderRegistryFeatureProvider Class


Description Property

FeatureProviderRegistryFeatureProvider.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

FeatureProviderRegistryFeatureProvider Class


DisplayName Property

FeatureProviderRegistryFeatureProvider.DisplayName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisplayName As String
C#
public string DisplayName { get; set; }
C++
public property string DisplayName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DisplayName();

/** property */
public void set_DisplayName(string value);
JScript
public function get DisplayName() : String

public function set DisplayName(value : String);

See Also

FeatureProviderRegistryFeatureProvider Class


FeatureDataObjectsVersion Property

FeatureProviderRegistryFeatureProvider.FeatureDataObjectsVersion Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FeatureDataObjectsVersion As String
C#
public string FeatureDataObjectsVersion { get; set; }
C++
public property string FeatureDataObjectsVersion sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FeatureDataObjectsVersion();

/** property */
public void set_FeatureDataObjectsVersion(string value);
JScript
public function get FeatureDataObjectsVersion() : String

public function set FeatureDataObjectsVersion(value : String);

See Also

FeatureProviderRegistryFeatureProvider Class


Name Property

FeatureProviderRegistryFeatureProvider.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

FeatureProviderRegistryFeatureProvider Class


Version Property

FeatureProviderRegistryFeatureProvider.Version Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
C++
public property string Version sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Version();

/** property */
public void set_Version(string value);
JScript
public function get Version() : String

public function set Version(value : String);

See Also

FeatureProviderRegistryFeatureProvider Class


FeatureProviderRegistryFeatureProviderCollection Class

FeatureProviderRegistryFeatureProviderCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FeatureProviderRegistryFeatureProviderCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FeatureProviderRegistryFeatureProviderCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FeatureProviderRegistryFeatureProviderCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FeatureProviderRegistryFeatureProviderCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FeatureProviderRegistryFeatureProviderCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FeatureProviderRegistryFeatureProviderCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureProviderRegistryFeatureProviderCollection Members


FeatureProviderRegistryFeatureProviderCollection Members

FeatureProviderRegistryFeatureProviderCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FeatureProviderRegistryFeatureProviderCollection.

Public Constructors

 | Name | Description
Public method | FeatureProviderRegistryFeatureProviderCollection | Initializes a new instance of the FeatureProviderRegistryFeatureProviderCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureProviderRegistryFeatureProviderCollection Class


FeatureProviderRegistryFeatureProviderCollection Constructor

FeatureProviderRegistryFeatureProviderCollection Constructor
[image]

Initializes a new instance of the FeatureProviderRegistryFeatureProviderCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureProviderRegistryFeatureProviderCollection()
C++
public:
FeatureProviderRegistryFeatureProviderCollection() sealed
J#
public FeatureProviderRegistryFeatureProviderCollection()
JScript
public function FeatureProviderRegistryFeatureProviderCollection()

See Also

FeatureProviderRegistryFeatureProviderCollection Class


Properties

FeatureProviderRegistryFeatureProviderCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FeatureProviderRegistryFeatureProviderCollection Class


Item Property

FeatureProviderRegistryFeatureProviderCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FeatureProviderRegistryFeatureProvider
C#
public FeatureProviderRegistryFeatureProvider this[
int idx
] { get; set; }
C++
public property FeatureProviderRegistryFeatureProvider default[int idx] sealed {
FeatureProviderRegistryFeatureProvider get(int idx);
void set(int idx, FeatureProviderRegistryFeatureProvider value);
}
J#
/** property */
public FeatureProviderRegistryFeatureProvider get_Item(int idx);

/** property */
public void set_Item(int idx, FeatureProviderRegistryFeatureProvider value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FeatureProviderRegistryFeatureProviderCollection Class


Methods

FeatureProviderRegistryFeatureProviderCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureProviderRegistryFeatureProviderCollection Class


Add Method

FeatureProviderRegistryFeatureProviderCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FeatureProviderRegistryFeatureProvider _
) As Integer
C#
public int Add(
FeatureProviderRegistryFeatureProvider value
)
C++
public:
int Add(
FeatureProviderRegistryFeatureProvider value
) sealed
J#
public int Add(
FeatureProviderRegistryFeatureProvider value
)
JScript
public function Add(
value : FeatureProviderRegistryFeatureProvider
) : int

See Also

FeatureProviderRegistryFeatureProviderCollection Class


FeatureProviderRegistryFeatureProviderConnectionProperty Class

FeatureProviderRegistryFeatureProviderConnectionProperty Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FeatureProviderRegistryFeatureProviderConnectionProperty
C#
public class FeatureProviderRegistryFeatureProviderConnectionProperty
C++
ref class FeatureProviderRegistryFeatureProviderConnectionProperty
J#
public class FeatureProviderRegistryFeatureProviderConnectionProperty
JScript
public class FeatureProviderRegistryFeatureProviderConnectionProperty

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureProviderRegistryFeatureProviderConnectionProperty

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureProviderRegistryFeatureProviderConnectionProperty Members


FeatureProviderRegistryFeatureProviderConnectionProperty Members

FeatureProviderRegistryFeatureProviderConnectionProperty Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FeatureProviderRegistryFeatureProviderConnectionProperty.

Public Constructors

 | Name | Description
Public method | FeatureProviderRegistryFeatureProviderConnectionProperty | Initializes a new instance of the FeatureProviderRegistryFeatureProviderConnectionProperty class.
Top

Public Properties

 | Name | Description
Public property | DefaultValue |
Public property | Enumerable |
Public property | LocalizedName |
Public property | Name |
Public property | Protected |
Public property | Required |
Public property | Value |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureProviderRegistryFeatureProviderConnectionProperty Class


FeatureProviderRegistryFeatureProviderConnectionProperty Constructor

FeatureProviderRegistryFeatureProviderConnectionProperty Constructor
See Also Example
[image]

Initializes a new instance of the FeatureProviderRegistryFeatureProviderConnectionProperty class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureProviderRegistryFeatureProviderConnectionProperty()
C++
public:
FeatureProviderRegistryFeatureProviderConnectionProperty() sealed
J#
public FeatureProviderRegistryFeatureProviderConnectionProperty()
JScript
public function FeatureProviderRegistryFeatureProviderConnectionProperty()

See Also

FeatureProviderRegistryFeatureProviderConnectionProperty Class


Properties

FeatureProviderRegistryFeatureProviderConnectionProperty Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | DefaultValue |
Public property | Enumerable |
Public property | LocalizedName |
Public property | Name |
Public property | Protected |
Public property | Required |
Public property | Value |
Top

See Also

FeatureProviderRegistryFeatureProviderConnectionProperty Class


DefaultValue Property

FeatureProviderRegistryFeatureProviderConnectionProperty.DefaultValue Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
C#
public string DefaultValue { get; set; }
C++
public property string DefaultValue sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DefaultValue();

/** property */
public void set_DefaultValue(string value);
JScript
public function get DefaultValue() : String

public function set DefaultValue(value : String);

See Also

FeatureProviderRegistryFeatureProviderConnectionProperty Class


Enumerable Property

FeatureProviderRegistryFeatureProviderConnectionProperty.Enumerable Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute>
Public Property Enumerable As Boolean
C#
[XmlAttributeAttribute]
public bool Enumerable { get; set; }
C++
[XmlAttributeAttribute]
public property bool Enumerable sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** property */
public bool get_Enumerable();

/** property */
public void set_Enumerable(bool value);
JScript
public function get Enumerable() : bool

public function set Enumerable(value : bool);

See Also

FeatureProviderRegistryFeatureProviderConnectionProperty Class


LocalizedName Property

FeatureProviderRegistryFeatureProviderConnectionProperty.LocalizedName Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalizedName As String
C#
public string LocalizedName { get; set; }
C++
public property string LocalizedName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LocalizedName();

/** property */
public void set_LocalizedName(string value);
JScript
public function get LocalizedName() : String

public function set LocalizedName(value : String);

See Also

FeatureProviderRegistryFeatureProviderConnectionProperty Class


Name Property

FeatureProviderRegistryFeatureProviderConnectionProperty.Name Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

FeatureProviderRegistryFeatureProviderConnectionProperty Class


Protected Property

FeatureProviderRegistryFeatureProviderConnectionProperty.Protected Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute>
Public Property Protected As Boolean
C#
[XmlAttributeAttribute]
public bool Protected { get; set; }
C++
[XmlAttributeAttribute]
public property bool Protected sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** property */
public bool get_Protected();

/** property */
public void set_Protected(bool value);
JScript
public function get Protected() : bool

public function set Protected(value : bool);

See Also

FeatureProviderRegistryFeatureProviderConnectionProperty Class


Required Property

FeatureProviderRegistryFeatureProviderConnectionProperty.Required Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute>
Public Property Required As Boolean
C#
[XmlAttributeAttribute]
public bool Required { get; set; }
C++
[XmlAttributeAttribute]
public property bool Required sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** property */
public bool get_Required();

/** property */
public void set_Required(bool value);
JScript
public function get Required() : bool

public function set Required(value : bool);

See Also

FeatureProviderRegistryFeatureProviderConnectionProperty Class


Value Property

FeatureProviderRegistryFeatureProviderConnectionProperty.Value Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Value")>
Public Property Value As StringCollection
C#
[XmlElementAttribute("Value")]
public StringCollection Value { get; set; }
C++
[XmlElementAttribute(L"Value")]
public property StringCollection Value sealed {
StringCollection get();
void set(StringCollection value);
}
J#
/** @attribute XmlElementAttribute("Value") */
/** property */
public StringCollection get_Value();

/** property */
public void set_Value(StringCollection value);
JScript
public function get Value() : StringCollection

public function set Value(value : StringCollection);

See Also

FeatureProviderRegistryFeatureProviderConnectionProperty Class


FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Class

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FeatureProviderRegistryFeatureProviderConnectionPropertyCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FeatureProviderRegistryFeatureProviderConnectionPropertyCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FeatureProviderRegistryFeatureProviderConnectionPropertyCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FeatureProviderRegistryFeatureProviderConnectionPropertyCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FeatureProviderRegistryFeatureProviderConnectionPropertyCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FeatureProviderRegistryFeatureProviderConnectionPropertyCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Members


FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Members

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FeatureProviderRegistryFeatureProviderConnectionPropertyCollection.

Public Constructors

 | Name | Description
Public method | FeatureProviderRegistryFeatureProviderConnectionPropertyCollection | Initializes a new instance of the FeatureProviderRegistryFeatureProviderConnectionPropertyCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Class


FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Constructor

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Constructor
See Also Example
[image]

Initializes a new instance of the FeatureProviderRegistryFeatureProviderConnectionPropertyCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureProviderRegistryFeatureProviderConnectionPropertyCollection()
C++
public:
FeatureProviderRegistryFeatureProviderConnectionPropertyCollection() sealed
J#
public FeatureProviderRegistryFeatureProviderConnectionPropertyCollection()
JScript
public function FeatureProviderRegistryFeatureProviderConnectionPropertyCollection()

See Also

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Class


Properties

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Class


Item Property

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FeatureProviderRegistryFeatureProviderConnectionProperty
C#
public FeatureProviderRegistryFeatureProviderConnectionProperty this[
int idx
] { get; set; }
C++
public property FeatureProviderRegistryFeatureProviderConnectionProperty default[int idx] sealed {
FeatureProviderRegistryFeatureProviderConnectionProperty get(int idx);
void set(int idx, FeatureProviderRegistryFeatureProviderConnectionProperty value);
}
J#
/** property */
public FeatureProviderRegistryFeatureProviderConnectionProperty get_Item(int idx);

/** property */
public void set_Item(int idx, FeatureProviderRegistryFeatureProviderConnectionProperty value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Class


Methods

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Class


Add Method

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection.Add Method
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FeatureProviderRegistryFeatureProviderConnectionProperty _
) As Integer
C#
public int Add(
FeatureProviderRegistryFeatureProviderConnectionProperty value
)
C++
public:
int Add(
FeatureProviderRegistryFeatureProviderConnectionProperty value
) sealed
J#
public int Add(
FeatureProviderRegistryFeatureProviderConnectionProperty value
)
JScript
public function Add(
value : FeatureProviderRegistryFeatureProviderConnectionProperty
) : int

See Also

FeatureProviderRegistryFeatureProviderConnectionPropertyCollection Class


FeatureSet Class

FeatureSet Class
See Also Example Members
[image]

Represents a set of features

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("FeatureSet", Namespace := "", IsNullable := False)>
Public Class FeatureSet
C#
[XmlRootAttribute("FeatureSet", Namespace = "", IsNullable = False)]
public class FeatureSet
C++
[XmlRootAttribute(L"FeatureSet", Namespace = L"", IsNullable = False)]
ref class FeatureSet
J#
/** @attribute XmlRootAttribute("FeatureSet", Namespace = "", IsNullable = False) */
public class FeatureSet
JScript
public
XmlRootAttribute("FeatureSet", Namespace = "", IsNullable = False)
class FeatureSet

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureSet

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSet Members


FeatureSet Members

FeatureSet Members
See Also Example Constructors Fields Properties Methods
[image]

Represents a set of features

The following tables list the members exposed by FeatureSet.

Public Constructors

 | Name | Description
Public method | FeatureSet | Initializes a new instance of the FeatureSet class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Layer |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSet Class


FeatureSet Constructor

FeatureSet Constructor
[image]

Initializes a new instance of the FeatureSet class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureSet()
C++
public:
FeatureSet() sealed
J#
public FeatureSet()
JScript
public function FeatureSet()

See Also

FeatureSet Class


Fields

FeatureSet Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

FeatureSet Class


SchemaName Field

FeatureSet.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

FeatureSet Class


Properties

FeatureSet Properties
[image]

Public Properties

 | Name | Description
Public property | Layer |
Public property | XsdSchema |
Top

See Also

FeatureSet Class


Layer Property

FeatureSet.Layer Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Layer")>
Public Property Layer As FeatureSetLayerCollection
C#
[XmlElementAttribute("Layer")]
public FeatureSetLayerCollection Layer { get; set; }
C++
[XmlElementAttribute(L"Layer")]
public property FeatureSetLayerCollection Layer sealed {
FeatureSetLayerCollection get();
void set(FeatureSetLayerCollection value);
}
J#
/** @attribute XmlElementAttribute("Layer") */
/** property */
public FeatureSetLayerCollection get_Layer();

/** property */
public void set_Layer(FeatureSetLayerCollection value);
JScript
public function get Layer() : FeatureSetLayerCollection

public function set Layer(value : FeatureSetLayerCollection);

See Also

FeatureSet Class


XsdSchema Property

FeatureSet.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

FeatureSet Class


FeatureSetColumn Class

FeatureSetColumn Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FeatureSetColumn
C#
public class FeatureSetColumn
C++
ref class FeatureSetColumn
J#
public class FeatureSetColumn
JScript
public class FeatureSetColumn

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureSetColumn

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSetColumn Members


FeatureSetColumn Members

FeatureSetColumn Members
See Also Example Properties Methods
[image]

The following tables list the members exposed by FeatureSetColumn.

Public Properties

 | Name | Description
Public property | Name |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSetColumn Class


Properties

FeatureSetColumn Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Type |
Top

See Also

FeatureSetColumn Class


Name Property

FeatureSetColumn.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

FeatureSetColumn Class


Type Property

FeatureSetColumn.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As Type
C#
public Type Type { get; }
C++
public property Type Type sealed {
Type get();
}
J#
/** property */
public Type get_Type();
JScript
public function get Type() : Type

See Also

FeatureSetColumn Class


FeatureSetLayer Class

FeatureSetLayer Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FeatureSetLayer
C#
public class FeatureSetLayer
C++
ref class FeatureSetLayer
J#
public class FeatureSetLayer
JScript
public class FeatureSetLayer

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureSetLayer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSetLayer Members


FeatureSetLayer Members

FeatureSetLayer Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FeatureSetLayer.

Public Constructors

 | Name | Description
Public method | FeatureSetLayer | Initializes a new instance of the FeatureSetLayer class.
Top

Public Properties

 | Name | Description
Public property | Class |
Public property | id |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSetLayer Class


FeatureSetLayer Constructor

FeatureSetLayer Constructor
[image]

Initializes a new instance of the FeatureSetLayer class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureSetLayer()
C++
public:
FeatureSetLayer() sealed
J#
public FeatureSetLayer()
JScript
public function FeatureSetLayer()

See Also

FeatureSetLayer Class


Properties

FeatureSetLayer Properties
[image]

Public Properties

 | Name | Description
Public property | Class |
Public property | id |
Top

See Also

FeatureSetLayer Class


Class Property

FeatureSetLayer.Class Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Class")>
Public Property Class As FeatureSetLayerClassCollection
C#
[XmlElementAttribute("Class")]
public FeatureSetLayerClassCollection Class { get; set; }
C++
[XmlElementAttribute(L"Class")]
public property FeatureSetLayerClassCollection Class sealed {
FeatureSetLayerClassCollection get();
void set(FeatureSetLayerClassCollection value);
}
J#
/** @attribute XmlElementAttribute("Class") */
/** property */
public FeatureSetLayerClassCollection get_Class();

/** property */
public void set_Class(FeatureSetLayerClassCollection value);
JScript
public function get Class() : FeatureSetLayerClassCollection

public function set Class(value : FeatureSetLayerClassCollection);

See Also

FeatureSetLayer Class


id Property

FeatureSetLayer.id Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute>
Public Property id As String
C#
[XmlAttributeAttribute]
public string id { get; set; }
C++
[XmlAttributeAttribute]
public property string id sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** property */
public string get_id();

/** property */
public void set_id(string value);
JScript
public function get id() : String

public function set id(value : String);

See Also

FeatureSetLayer Class


FeatureSetLayerClass Class

FeatureSetLayerClass Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FeatureSetLayerClass
C#
public class FeatureSetLayerClass
C++
ref class FeatureSetLayerClass
J#
public class FeatureSetLayerClass
JScript
public class FeatureSetLayerClass

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureSetLayerClass

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSetLayerClass Members


FeatureSetLayerClass Members

FeatureSetLayerClass Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FeatureSetLayerClass.

Public Constructors

 | Name | Description
Public method | FeatureSetLayerClass | Initializes a new instance of the FeatureSetLayerClass class.
Top

Public Properties

 | Name | Description
Public property | id |
Public property | ID |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSetLayerClass Class


FeatureSetLayerClass Constructor

FeatureSetLayerClass Constructor
[image]

Initializes a new instance of the FeatureSetLayerClass class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureSetLayerClass()
C++
public:
FeatureSetLayerClass() sealed
J#
public FeatureSetLayerClass()
JScript
public function FeatureSetLayerClass()

See Also

FeatureSetLayerClass Class


Properties

FeatureSetLayerClass Properties
[image]

Public Properties

 | Name | Description
Public property | id |
Public property | ID |
Top

See Also

FeatureSetLayerClass Class


id Property

FeatureSetLayerClass.id Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute>
Public Property id As String
C#
[XmlAttributeAttribute]
public string id { get; set; }
C++
[XmlAttributeAttribute]
public property string id sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** property */
public string get_id();

/** property */
public void set_id(string value);
JScript
public function get id() : String

public function set id(value : String);

See Also

FeatureSetLayerClass Class


FeatureSetLayerClassCollection Class

FeatureSetLayerClassCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FeatureSetLayerClassCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FeatureSetLayerClassCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FeatureSetLayerClassCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FeatureSetLayerClassCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FeatureSetLayerClassCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FeatureSetLayerClassCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSetLayerClassCollection Members


FeatureSetLayerClassCollection Members

FeatureSetLayerClassCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FeatureSetLayerClassCollection.

Public Constructors

 | Name | Description
Public method | FeatureSetLayerClassCollection | Initializes a new instance of the FeatureSetLayerClassCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSetLayerClassCollection Class


FeatureSetLayerClassCollection Constructor

FeatureSetLayerClassCollection Constructor
[image]

Initializes a new instance of the FeatureSetLayerClassCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureSetLayerClassCollection()
C++
public:
FeatureSetLayerClassCollection() sealed
J#
public FeatureSetLayerClassCollection()
JScript
public function FeatureSetLayerClassCollection()

See Also

FeatureSetLayerClassCollection Class


Properties

FeatureSetLayerClassCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FeatureSetLayerClassCollection Class


Item Property

FeatureSetLayerClassCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FeatureSetLayerClass
C#
public FeatureSetLayerClass this[
int idx
] { get; set; }
C++
public property FeatureSetLayerClass default[int idx] sealed {
FeatureSetLayerClass get(int idx);
void set(int idx, FeatureSetLayerClass value);
}
J#
/** property */
public FeatureSetLayerClass get_Item(int idx);

/** property */
public void set_Item(int idx, FeatureSetLayerClass value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FeatureSetLayerClassCollection Class


Methods

FeatureSetLayerClassCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSetLayerClassCollection Class


Add Method

FeatureSetLayerClassCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FeatureSetLayerClass _
) As Integer
C#
public int Add(
FeatureSetLayerClass value
)
C++
public:
int Add(
FeatureSetLayerClass value
) sealed
J#
public int Add(
FeatureSetLayerClass value
)
JScript
public function Add(
value : FeatureSetLayerClass
) : int

See Also

FeatureSetLayerClassCollection Class


FeatureSetLayerCollection Class

FeatureSetLayerCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FeatureSetLayerCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FeatureSetLayerCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FeatureSetLayerCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FeatureSetLayerCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FeatureSetLayerCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FeatureSetLayerCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSetLayerCollection Members


FeatureSetLayerCollection Members

FeatureSetLayerCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FeatureSetLayerCollection.

Public Constructors

 | Name | Description
Public method | FeatureSetLayerCollection | Initializes a new instance of the FeatureSetLayerCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSetLayerCollection Class


FeatureSetLayerCollection Constructor

FeatureSetLayerCollection Constructor
[image]

Initializes a new instance of the FeatureSetLayerCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureSetLayerCollection()
C++
public:
FeatureSetLayerCollection() sealed
J#
public FeatureSetLayerCollection()
JScript
public function FeatureSetLayerCollection()

See Also

FeatureSetLayerCollection Class


Properties

FeatureSetLayerCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FeatureSetLayerCollection Class


Item Property

FeatureSetLayerCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FeatureSetLayer
C#
public FeatureSetLayer this[
int idx
] { get; set; }
C++
public property FeatureSetLayer default[int idx] sealed {
FeatureSetLayer get(int idx);
void set(int idx, FeatureSetLayer value);
}
J#
/** property */
public FeatureSetLayer get_Item(int idx);

/** property */
public void set_Item(int idx, FeatureSetLayer value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FeatureSetLayerCollection Class


Methods

FeatureSetLayerCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSetLayerCollection Class


Add Method

FeatureSetLayerCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FeatureSetLayer _
) As Integer
C#
public int Add(
FeatureSetLayer value
)
C++
public:
int Add(
FeatureSetLayer value
) sealed
J#
public int Add(
FeatureSetLayer value
)
JScript
public function Add(
value : FeatureSetLayer
) : int

See Also

FeatureSetLayerCollection Class


FeatureSetReader Class

FeatureSetReader Class
See Also Example Members
[image]

Represents a set of results from a query

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FeatureSetReader
Implements IDisposable
C#
public class FeatureSetReader : IDisposable
C++
ref class FeatureSetReader : IDisposable
J#
public class FeatureSetReader implements IDisposable
JScript
public class FeatureSetReader extends IDisposable

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureSetReader

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSetReader Members


FeatureSetReader Members

FeatureSetReader Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Represents a set of results from a query

The following tables list the members exposed by FeatureSetReader.

Public Constructors

Name | Description
FeatureSetReader | Overloaded.
Top

Public Properties

 | Name | Description
Public property | Columns |
Public property | Row |
Top

Public Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Read |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
FeatureSetReader | Overloaded.
Top

See Also

FeatureSetReader Class


FeatureSetReader Constructor

FeatureSetReader Constructor

Overload List

 | Name | Description
Public method | FeatureSetReader (MgFeatureReader) |
Public method | FeatureSetReader (Stream) |

See Also

FeatureSetReader Class


FeatureSetReader Constructor (MgFeatureReader)

FeatureSetReader Constructor (MgFeatureReader)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal rd As MgFeatureReader _
)
C#
public FeatureSetReader(
MgFeatureReader rd
)
C++
public:
FeatureSetReader(
MgFeatureReader rd
) sealed
J#
public FeatureSetReader(
MgFeatureReader rd
)
JScript
public function FeatureSetReader(
rd : MgFeatureReader
)

See Also

FeatureSetReader Class
FeatureSetReader Constructor Overload List


FeatureSetReader Constructor (Stream)

FeatureSetReader Constructor (Stream)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal m_source As Stream _
)
C#
public FeatureSetReader(
Stream m_source
)
C++
public:
FeatureSetReader(
Stream m_source
) sealed
J#
public FeatureSetReader(
Stream m_source
)
JScript
public function FeatureSetReader(
m_source : Stream
)

See Also

FeatureSetReader Class
FeatureSetReader Constructor Overload List


Properties

FeatureSetReader Properties
[image]

Public Properties

 | Name | Description
Public property | Columns |
Public property | Row |
Top

See Also

FeatureSetReader Class


Columns Property

FeatureSetReader.Columns Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As FeatureSetColumn()
C#
public FeatureSetColumn[] Columns { get; }
C++
public property FeatureSetColumn[] Columns sealed {
array<FeatureSetColumn>^ get();
}
J#
/** property */
public FeatureSetColumn[] get_Columns();
JScript
public function get Columns() : FeatureSetColumn[]

See Also

FeatureSetReader Class


Row Property

FeatureSetReader.Row Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Row As FeatureSetRow
C#
public FeatureSetRow Row { get; }
C++
public property FeatureSetRow Row sealed {
FeatureSetRow get();
}
J#
/** property */
public FeatureSetRow get_Row();
JScript
public function get Row() : FeatureSetRow

See Also

FeatureSetReader Class


Methods

FeatureSetReader Methods
[image]

Public Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Read |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSetReader Class


Dispose Method

FeatureSetReader.Dispose Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose() _
Implements IDisposable.Dispose
C#
public void Dispose()
C++
public:
void Dispose() sealed
J#
public void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

FeatureSetReader Class


Read Method

FeatureSetReader.Read Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Read() As Boolean
C#
public bool Read()
C++
public:
bool Read() sealed
J#
public bool Read()
JScript
public function Read() : bool

See Also

FeatureSetReader Class


FeatureSetRow Class

FeatureSetRow Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FeatureSetRow
C#
[DefaultMemberAttribute("Item")]
public class FeatureSetRow
C++
[DefaultMemberAttribute(L"Item")]
ref class FeatureSetRow
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FeatureSetRow
JScript
public
DefaultMemberAttribute("Item")
class FeatureSetRow

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureSetRow

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSetRow Members


FeatureSetRow Members

FeatureSetRow Members
See Also Example Methods
[image]

The following tables list the members exposed by FeatureSetRow.

Public Properties

 | Name | Description
Public property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetOrdinal |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsValueNull | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSetRow Class


Properties

FeatureSetRow Properties
[image]

Public Properties

 | Name | Description
Public property | Item | Overloaded.
Top

See Also

FeatureSetRow Class


Item Property

FeatureSetRow.Item Property

Overload List

 | Name | Description
Public property | Item (Int32) |
Public property | Item (String) |

See Also

FeatureSetRow Class


Item Property (Int32)

FeatureSetRow.Item Property (Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As Object
C#
public object this[
int index
] { get; }
C++
public property object default[int index] sealed {
Object get(int index);
}
J#
/** property */
public object get_Item(int index);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FeatureSetRow Class
FeatureSetRow.Item Overload List


Item Property (String)

FeatureSetRow.Item Property (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default ReadOnly Property Item( _
ByVal name As String _
) As Object
C#
public object this[
string name
] { get; }
C++
public property object default[String name] sealed {
Object get(String name);
}
J#
/** property */
public object get_Item(string name);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FeatureSetRow Class
FeatureSetRow.Item Overload List


Methods

FeatureSetRow Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetOrdinal |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsValueNull | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSetRow Class


GetOrdinal Method

FeatureSetRow.GetOrdinal Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetOrdinal( _
ByVal name As String _
) As Integer
C#
public int GetOrdinal(
string name
)
C++
public:
int GetOrdinal(
String name
) sealed
J#
public int GetOrdinal(
string name
)
JScript
public function GetOrdinal(
name : String
) : int

See Also

FeatureSetRow Class


IsValueNull Method

FeatureSetRow.IsValueNull Method

Overload List

 | Name | Description
Public method | IsValueNull (Int32) |
Public method | IsValueNull (String) |

See Also

FeatureSetRow Class


IsValueNull Method (Int32)

FeatureSetRow.IsValueNull Method (Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function IsValueNull( _
ByVal index As Integer _
) As Boolean
C#
public bool IsValueNull(
int index
)
C++
public:
bool IsValueNull(
int index
) sealed
J#
public bool IsValueNull(
int index
)
JScript
public function IsValueNull(
index : int
) : bool

See Also

FeatureSetRow Class
FeatureSetRow.IsValueNull Overload List


IsValueNull Method (String)

FeatureSetRow.IsValueNull Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function IsValueNull( _
ByVal name As String _
) As Boolean
C#
public bool IsValueNull(
string name
)
C++
public:
bool IsValueNull(
String name
) sealed
J#
public bool IsValueNull(
string name
)
JScript
public function IsValueNull(
name : String
) : bool

See Also

FeatureSetRow Class
FeatureSetRow.IsValueNull Overload List


FeatureSource Class

FeatureSource Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("FeatureSource", Namespace := "", IsNullable := False)>
Public Class FeatureSource
C#
[XmlRootAttribute("FeatureSource", Namespace = "", IsNullable = False)]
public class FeatureSource
C++
[XmlRootAttribute(L"FeatureSource", Namespace = L"", IsNullable = False)]
ref class FeatureSource
J#
/** @attribute XmlRootAttribute("FeatureSource", Namespace = "", IsNullable = False) */
public class FeatureSource
JScript
public
XmlRootAttribute("FeatureSource", Namespace = "", IsNullable = False)
class FeatureSource

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureSource

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSource Members


FeatureSource Members

FeatureSource Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by FeatureSource.

Public Constructors

 | Name | Description
Public method | FeatureSource | Initializes a new instance of the FeatureSource class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | ConfigurationDocument |
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | Extension |
Public property | LongTransaction |
Public property | Parameter |
Public property | Provider |
Public property | ResourceId |
Public property | SupplementalSpatialContextInfo |
Public property | version |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | DescribeSource | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetIdentityProperties |
Public method | GetSpatialInfo |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SelectFeatures | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSource Class


FeatureSource Constructor

FeatureSource Constructor
[image]

Initializes a new instance of the FeatureSource class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureSource()
C++
public:
FeatureSource() sealed
J#
public FeatureSource()
JScript
public function FeatureSource()

See Also

FeatureSource Class


Fields

FeatureSource Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

FeatureSource Class


SchemaName Field

FeatureSource.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

FeatureSource Class


Properties

FeatureSource Properties
[image]

Public Properties

 | Name | Description
Public property | ConfigurationDocument |
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | Extension |
Public property | LongTransaction |
Public property | Parameter |
Public property | Provider |
Public property | ResourceId |
Public property | SupplementalSpatialContextInfo |
Public property | version |
Public property | XsdSchema |
Top

See Also

FeatureSource Class


ConfigurationDocument Property

FeatureSource.ConfigurationDocument Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ConfigurationDocument As String
C#
public string ConfigurationDocument { get; set; }
C++
public property string ConfigurationDocument sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ConfigurationDocument();

/** property */
public void set_ConfigurationDocument(string value);
JScript
public function get ConfigurationDocument() : String

public function set ConfigurationDocument(value : String);

See Also

FeatureSource Class


CurrentConnection Property

FeatureSource.CurrentConnection Property
[image]

Gets or sets the connection used in various operations performed on this object

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property CurrentConnection As ServerConnectionI
C#
[XmlIgnoreAttribute]
public ServerConnectionI CurrentConnection { get; set; }
C++
[XmlIgnoreAttribute]
public property ServerConnectionI CurrentConnection sealed {
ServerConnectionI get();
void set(ServerConnectionI value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public ServerConnectionI get_CurrentConnection();

/** property */
public void set_CurrentConnection(ServerConnectionI value);
JScript
public function get CurrentConnection() : ServerConnectionI

public function set CurrentConnection(value : ServerConnectionI);

See Also

FeatureSource Class


Extension Property

FeatureSource.Extension Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Extension")>
Public Property Extension As FeatureSourceTypeExtensionCollection
C#
[XmlElementAttribute("Extension")]
public FeatureSourceTypeExtensionCollection Extension { get; set; }
C++
[XmlElementAttribute(L"Extension")]
public property FeatureSourceTypeExtensionCollection Extension sealed {
FeatureSourceTypeExtensionCollection get();
void set(FeatureSourceTypeExtensionCollection value);
}
J#
/** @attribute XmlElementAttribute("Extension") */
/** property */
public FeatureSourceTypeExtensionCollection get_Extension();

/** property */
public void set_Extension(FeatureSourceTypeExtensionCollection value);
JScript
public function get Extension() : FeatureSourceTypeExtensionCollection

public function set Extension(value : FeatureSourceTypeExtensionCollection);

See Also

FeatureSource Class


LongTransaction Property

FeatureSource.LongTransaction Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LongTransaction As String
C#
public string LongTransaction { get; set; }
C++
public property string LongTransaction sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LongTransaction();

/** property */
public void set_LongTransaction(string value);
JScript
public function get LongTransaction() : String

public function set LongTransaction(value : String);

See Also

FeatureSource Class


Parameter Property

FeatureSource.Parameter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Parameter")>
Public Property Parameter As NameValuePairTypeCollection
C#
[XmlElementAttribute("Parameter")]
public NameValuePairTypeCollection Parameter { get; set; }
C++
[XmlElementAttribute(L"Parameter")]
public property NameValuePairTypeCollection Parameter sealed {
NameValuePairTypeCollection get();
void set(NameValuePairTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("Parameter") */
/** property */
public NameValuePairTypeCollection get_Parameter();

/** property */
public void set_Parameter(NameValuePairTypeCollection value);
JScript
public function get Parameter() : NameValuePairTypeCollection

public function set Parameter(value : NameValuePairTypeCollection);

See Also

FeatureSource Class


Provider Property

FeatureSource.Provider Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Provider As String
C#
public string Provider { get; set; }
C++
public property string Provider sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Provider();

/** property */
public void set_Provider(string value);
JScript
public function get Provider() : String

public function set Provider(value : String);

See Also

FeatureSource Class


ResourceId Property

FeatureSource.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ResourceId As String
C#
[XmlIgnoreAttribute]
public string ResourceId { get; set; }
C++
[XmlIgnoreAttribute]
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

FeatureSource Class


SupplementalSpatialContextInfo Property

FeatureSource.SupplementalSpatialContextInfo Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("SupplementalSpatialContextInfo")>
Public Property SupplementalSpatialContextInfo As SpatialContextTypeCollection
C#
[XmlElementAttribute("SupplementalSpatialContextInfo")]
public SpatialContextTypeCollection SupplementalSpatialContextInfo { get; set; }
C++
[XmlElementAttribute(L"SupplementalSpatialContextInfo")]
public property SpatialContextTypeCollection SupplementalSpatialContextInfo sealed {
SpatialContextTypeCollection get();
void set(SpatialContextTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("SupplementalSpatialContextInfo") */
/** property */
public SpatialContextTypeCollection get_SupplementalSpatialContextInfo();

/** property */
public void set_SupplementalSpatialContextInfo(SpatialContextTypeCollection value);
JScript
public function get SupplementalSpatialContextInfo() : SpatialContextTypeCollection

public function set SupplementalSpatialContextInfo(value : SpatialContextTypeCollection);

See Also

FeatureSource Class


version Property

FeatureSource.version Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute>
Public Property version As String
C#
[XmlAttributeAttribute]
public string version { get; set; }
C++
[XmlAttributeAttribute]
public property string version sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** property */
public string get_version();

/** property */
public void set_version(string value);
JScript
public function get version() : String

public function set version(value : String);

See Also

FeatureSource Class


XsdSchema Property

FeatureSource.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

FeatureSource Class


Methods

FeatureSource Methods
[image]

Public Methods

 | Name | Description
Public method | DescribeSource | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetIdentityProperties |
Public method | GetSpatialInfo |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SelectFeatures | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSource Class


DescribeSource Method

FeatureSource.DescribeSource Method

Overload List

 | Name | Description
Public method | DescribeSource |
Public method | DescribeSource (String) |

See Also

FeatureSource Class


DescribeSource Method ()

FeatureSource.DescribeSource Method ()
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function DescribeSource() As FeatureSourceDescription
C#
public FeatureSourceDescription DescribeSource()
C++
public:
FeatureSourceDescription DescribeSource() sealed
J#
public FeatureSourceDescription DescribeSource()
JScript
public function DescribeSource() : FeatureSourceDescription

See Also

FeatureSource Class
FeatureSource.DescribeSource Overload List


DescribeSource Method (String)

FeatureSource.DescribeSource Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function DescribeSource( _
ByVal schema As String _
) As FeatureSourceDescription
C#
public FeatureSourceDescription DescribeSource(
string schema
)
C++
public:
FeatureSourceDescription DescribeSource(
String schema
) sealed
J#
public FeatureSourceDescription DescribeSource(
string schema
)
JScript
public function DescribeSource(
schema : String
) : FeatureSourceDescription

See Also

FeatureSource Class
FeatureSource.DescribeSource Overload List


GetIdentityProperties Method

FeatureSource.GetIdentityProperties Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIdentityProperties( _
ByVal classname As String _
) As String()
C#
public string[] GetIdentityProperties(
string classname
)
C++
public:
array<String>^ GetIdentityProperties(
String classname
) sealed
J#
public string[] GetIdentityProperties(
string classname
)
JScript
public function GetIdentityProperties(
classname : String
) : String[]

See Also

FeatureSource Class


GetSpatialInfo Method

FeatureSource.GetSpatialInfo Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSpatialInfo() As FdoSpatialContextList
C#
public FdoSpatialContextList GetSpatialInfo()
C++
public:
FdoSpatialContextList GetSpatialInfo() sealed
J#
public FdoSpatialContextList GetSpatialInfo()
JScript
public function GetSpatialInfo() : FdoSpatialContextList

See Also

FeatureSource Class


SelectFeatures Method

FeatureSource.SelectFeatures Method

Overload List

 | Name | Description
Public method | SelectFeatures (String) |
Public method | SelectFeatures (String, String) |
Public method | SelectFeatures (String, String, String) |

See Also

FeatureSource Class


SelectFeatures Method (String)

FeatureSource.SelectFeatures Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectFeatures( _
ByVal query As String _
) As FeatureSetReader
C#
public FeatureSetReader SelectFeatures(
string query
)
C++
public:
FeatureSetReader SelectFeatures(
String query
) sealed
J#
public FeatureSetReader SelectFeatures(
string query
)
JScript
public function SelectFeatures(
query : String
) : FeatureSetReader

See Also

FeatureSource Class
FeatureSource.SelectFeatures Overload List


SelectFeatures Method (String, String)

FeatureSource.SelectFeatures Method (String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectFeatures( _
ByVal query As String, _
ByVal classname As String _
) As FeatureSetReader
C#
public FeatureSetReader SelectFeatures(
string query,
string classname
)
C++
public:
FeatureSetReader SelectFeatures(
String query,
String classname
) sealed
J#
public FeatureSetReader SelectFeatures(
string query,
string classname
)
JScript
public function SelectFeatures(
query : String,
classname : String
) : FeatureSetReader

See Also

FeatureSource Class
FeatureSource.SelectFeatures Overload List


SelectFeatures Method (String, String, String[])

FeatureSource.SelectFeatures Method (String, String, String[])
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectFeatures( _
ByVal query As String, _
ByVal classname As String, _
ByVal columns As String() _
) As FeatureSetReader
C#
public FeatureSetReader SelectFeatures(
string query,
string classname,
string[] columns
)
C++
public:
FeatureSetReader SelectFeatures(
String query,
String classname,
array<String>^ columns
) sealed
J#
public FeatureSetReader SelectFeatures(
string query,
string classname,
string[] columns
)
JScript
public function SelectFeatures(
query : String,
classname : String,
columns : String[]
) : FeatureSetReader

See Also

FeatureSource Class
FeatureSource.SelectFeatures Overload List


FeatureSourceDescription Class

FeatureSourceDescription Class
See Also Example Members
[image]

Class that represents a the layout of a datasource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FeatureSourceDescription
C#
[DefaultMemberAttribute("Item")]
public class FeatureSourceDescription
C++
[DefaultMemberAttribute(L"Item")]
ref class FeatureSourceDescription
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FeatureSourceDescription
JScript
public
DefaultMemberAttribute("Item")
class FeatureSourceDescription

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureSourceDescription

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSourceDescription Members


FeatureSourceDescription Members

FeatureSourceDescription Members
See Also Example Constructors Properties Methods
[image]

Class that represents a the layout of a datasource

The following tables list the members exposed by FeatureSourceDescription.

Public Constructors

 | Name | Description
Public method | FeatureSourceDescription |
Top

Public Properties

 | Name | Description
Public property | Item | Overloaded.
Public property | Schemas |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSourceDescription Class


FeatureSourceDescription Constructor

FeatureSourceDescription Constructor
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal stream As Stream _
)
C#
public FeatureSourceDescription(
Stream stream
)
C++
public:
FeatureSourceDescription(
Stream stream
) sealed
J#
public FeatureSourceDescription(
Stream stream
)
JScript
public function FeatureSourceDescription(
stream : Stream
)

See Also

FeatureSourceDescription Class


Properties

FeatureSourceDescription Properties
[image]

Public Properties

 | Name | Description
Public property | Item | Overloaded.
Public property | Schemas |
Top

See Also

FeatureSourceDescription Class


Item Property

FeatureSourceDescription.Item Property

Overload List

 | Name | Description
Public property | Item (Int32) |
Public property | Item (String) |

See Also

FeatureSourceDescription Class


Item Property (Int32)

FeatureSourceDescription.Item Property (Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As FeatureSourceDescription.FeatureSourceSchema
C#
public FeatureSourceDescription.FeatureSourceSchema this[
int index
] { get; }
C++
public property FeatureSourceDescription.FeatureSourceSchema default[int index] sealed {
FeatureSourceDescription.FeatureSourceSchema get(int index);
}
J#
/** property */
public FeatureSourceDescription.FeatureSourceSchema get_Item(int index);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FeatureSourceDescription Class
FeatureSourceDescription.Item Overload List


Item Property (String)

FeatureSourceDescription.Item Property (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default ReadOnly Property Item( _
ByVal index As String _
) As FeatureSourceDescription.FeatureSourceSchema
C#
public FeatureSourceDescription.FeatureSourceSchema this[
string index
] { get; }
C++
public property FeatureSourceDescription.FeatureSourceSchema default[String index] sealed {
FeatureSourceDescription.FeatureSourceSchema get(String index);
}
J#
/** property */
public FeatureSourceDescription.FeatureSourceSchema get_Item(string index);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FeatureSourceDescription Class
FeatureSourceDescription.Item Overload List


Schemas Property

FeatureSourceDescription.Schemas Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Schemas As FeatureSourceDescription.FeatureSourceSchema()
C#
public FeatureSourceDescription.FeatureSourceSchema[] Schemas { get; }
C++
public property FeatureSourceDescription.FeatureSourceSchema[] Schemas sealed {
array<FeatureSourceDescription.FeatureSourceSchema>^ get();
}
J#
/** property */
public FeatureSourceDescription.FeatureSourceSchema[] get_Schemas();
JScript
public function get Schemas() : FeatureSourceDescription.FeatureSourceSchema[]

See Also

FeatureSourceDescription Class


FeatureSourceDescription.FeatureSourceSchema Class

FeatureSourceDescription.FeatureSourceSchema Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FeatureSourceDescription.FeatureSourceSchema
C#
public class FeatureSourceDescription.FeatureSourceSchema
C++
ref class FeatureSourceDescription.FeatureSourceSchema
J#
public class FeatureSourceDescription.FeatureSourceSchema
JScript
public class FeatureSourceDescription.FeatureSourceSchema

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureSourceDescription.FeatureSourceSchema

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSourceDescription.FeatureSourceSchema Members


FeatureSourceDescription.FeatureSourceSchema Members

FeatureSourceDescription.FeatureSourceSchema Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FeatureSourceDescription.FeatureSourceSchema.

Public Constructors

 | Name | Description
Public method | FeatureSourceDescription.FeatureSourceSchema |
Top

Public Properties

 | Name | Description
Public property | Columns |
Public property | Fullname |
Public property | FullnameDecoded |
Public property | Name |
Public property | Schema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSourceDescription.FeatureSourceSchema Class


FeatureSourceDescription.FeatureSourceSchema Constructor

FeatureSourceDescription.FeatureSourceSchema Constructor
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal node As XmlNode, _
ByVal doc As XmlDocument, _
ByVal mgr As XmlNamespaceManager _
)
C#
public FeatureSourceDescription.FeatureSourceSchema(
XmlNode node,
XmlDocument doc,
XmlNamespaceManager mgr
)
C++
public:
FeatureSourceDescription.FeatureSourceSchema(
XmlNode node,
XmlDocument doc,
XmlNamespaceManager mgr
) sealed
J#
public FeatureSourceDescription.FeatureSourceSchema(
XmlNode node,
XmlDocument doc,
XmlNamespaceManager mgr
)
JScript
public function FeatureSourceDescription.FeatureSourceSchema(
node : XmlNode,
doc : XmlDocument,
mgr : XmlNamespaceManager
)

See Also

FeatureSourceDescription.FeatureSourceSchema Class


Properties

FeatureSourceDescription.FeatureSourceSchema Properties
[image]

Public Properties

 | Name | Description
Public property | Columns |
Public property | Fullname |
Public property | FullnameDecoded |
Public property | Name |
Public property | Schema |
Top

See Also

FeatureSourceDescription.FeatureSourceSchema Class


Columns Property

FeatureSourceDescription.FeatureSourceSchema.Columns Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As FeatureSetColumn()
C#
public FeatureSetColumn[] Columns { get; }
C++
public property FeatureSetColumn[] Columns sealed {
array<FeatureSetColumn>^ get();
}
J#
/** property */
public FeatureSetColumn[] get_Columns();
JScript
public function get Columns() : FeatureSetColumn[]

See Also

FeatureSourceDescription.FeatureSourceSchema Class


Fullname Property

FeatureSourceDescription.FeatureSourceSchema.Fullname Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fullname As String
C#
public string Fullname { get; }
C++
public property string Fullname sealed {
String get();
}
J#
/** property */
public string get_Fullname();
JScript
public function get Fullname() : String

See Also

FeatureSourceDescription.FeatureSourceSchema Class


FullnameDecoded Property

FeatureSourceDescription.FeatureSourceSchema.FullnameDecoded Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullnameDecoded As String
C#
public string FullnameDecoded { get; }
C++
public property string FullnameDecoded sealed {
String get();
}
J#
/** property */
public string get_FullnameDecoded();
JScript
public function get FullnameDecoded() : String

See Also

FeatureSourceDescription.FeatureSourceSchema Class


Name Property

FeatureSourceDescription.FeatureSourceSchema.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

FeatureSourceDescription.FeatureSourceSchema Class


Schema Property

FeatureSourceDescription.FeatureSourceSchema.Schema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Schema As String
C#
public string Schema { get; }
C++
public property string Schema sealed {
String get();
}
J#
/** property */
public string get_Schema();
JScript
public function get Schema() : String

See Also

FeatureSourceDescription.FeatureSourceSchema Class


FeatureSourceTypeExtension Class

FeatureSourceTypeExtension Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FeatureSourceTypeExtension
C#
public class FeatureSourceTypeExtension
C++
ref class FeatureSourceTypeExtension
J#
public class FeatureSourceTypeExtension
JScript
public class FeatureSourceTypeExtension

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FeatureSourceTypeExtension

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSourceTypeExtension Members


FeatureSourceTypeExtension Members

FeatureSourceTypeExtension Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FeatureSourceTypeExtension.

Public Constructors

 | Name | Description
Public method | FeatureSourceTypeExtension | Initializes a new instance of the FeatureSourceTypeExtension class.
Top

Public Properties

 | Name | Description
Public property | AttributeRelate |
Public property | CalculatedProperty |
Public property | FeatureClass |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SelectFeatures | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSourceTypeExtension Class


FeatureSourceTypeExtension Constructor

FeatureSourceTypeExtension Constructor
[image]

Initializes a new instance of the FeatureSourceTypeExtension class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureSourceTypeExtension()
C++
public:
FeatureSourceTypeExtension() sealed
J#
public FeatureSourceTypeExtension()
JScript
public function FeatureSourceTypeExtension()

See Also

FeatureSourceTypeExtension Class


Properties

FeatureSourceTypeExtension Properties
[image]

Public Properties

 | Name | Description
Public property | AttributeRelate |
Public property | CalculatedProperty |
Public property | FeatureClass |
Public property | Name |
Top

See Also

FeatureSourceTypeExtension Class


AttributeRelate Property

FeatureSourceTypeExtension.AttributeRelate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("AttributeRelate")>
Public Property AttributeRelate As AttributeRelateTypeCollection
C#
[XmlElementAttribute("AttributeRelate")]
public AttributeRelateTypeCollection AttributeRelate { get; set; }
C++
[XmlElementAttribute(L"AttributeRelate")]
public property AttributeRelateTypeCollection AttributeRelate sealed {
AttributeRelateTypeCollection get();
void set(AttributeRelateTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("AttributeRelate") */
/** property */
public AttributeRelateTypeCollection get_AttributeRelate();

/** property */
public void set_AttributeRelate(AttributeRelateTypeCollection value);
JScript
public function get AttributeRelate() : AttributeRelateTypeCollection

public function set AttributeRelate(value : AttributeRelateTypeCollection);

See Also

FeatureSourceTypeExtension Class


CalculatedProperty Property

FeatureSourceTypeExtension.CalculatedProperty Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("CalculatedProperty")>
Public Property CalculatedProperty As CalculatedPropertyTypeCollection
C#
[XmlElementAttribute("CalculatedProperty")]
public CalculatedPropertyTypeCollection CalculatedProperty { get; set; }
C++
[XmlElementAttribute(L"CalculatedProperty")]
public property CalculatedPropertyTypeCollection CalculatedProperty sealed {
CalculatedPropertyTypeCollection get();
void set(CalculatedPropertyTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("CalculatedProperty") */
/** property */
public CalculatedPropertyTypeCollection get_CalculatedProperty();

/** property */
public void set_CalculatedProperty(CalculatedPropertyTypeCollection value);
JScript
public function get CalculatedProperty() : CalculatedPropertyTypeCollection

public function set CalculatedProperty(value : CalculatedPropertyTypeCollection);

See Also

FeatureSourceTypeExtension Class


FeatureClass Property

FeatureSourceTypeExtension.FeatureClass Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FeatureClass As String
C#
public string FeatureClass { get; set; }
C++
public property string FeatureClass sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FeatureClass();

/** property */
public void set_FeatureClass(string value);
JScript
public function get FeatureClass() : String

public function set FeatureClass(value : String);

See Also

FeatureSourceTypeExtension Class


Name Property

FeatureSourceTypeExtension.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

FeatureSourceTypeExtension Class


Methods

FeatureSourceTypeExtension Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | SelectFeatures | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSourceTypeExtension Class


SelectFeatures Method

FeatureSourceTypeExtension.SelectFeatures Method

Overload List

 | Name | Description
Public method | SelectFeatures |
Public method | SelectFeatures (String) |
Public method | SelectFeatures (String, String) |

See Also

FeatureSourceTypeExtension Class


SelectFeatures Method ()

FeatureSourceTypeExtension.SelectFeatures Method ()
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectFeatures() As FeatureSetReader
C#
public FeatureSetReader SelectFeatures()
C++
public:
FeatureSetReader SelectFeatures() sealed
J#
public FeatureSetReader SelectFeatures()
JScript
public function SelectFeatures() : FeatureSetReader

See Also

FeatureSourceTypeExtension Class
FeatureSourceTypeExtension.SelectFeatures Overload List


SelectFeatures Method (String)

FeatureSourceTypeExtension.SelectFeatures Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectFeatures( _
ByVal query As String _
) As FeatureSetReader
C#
public FeatureSetReader SelectFeatures(
string query
)
C++
public:
FeatureSetReader SelectFeatures(
String query
) sealed
J#
public FeatureSetReader SelectFeatures(
string query
)
JScript
public function SelectFeatures(
query : String
) : FeatureSetReader

See Also

FeatureSourceTypeExtension Class
FeatureSourceTypeExtension.SelectFeatures Overload List


SelectFeatures Method (String, String[])

FeatureSourceTypeExtension.SelectFeatures Method (String, String[])
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function SelectFeatures( _
ByVal query As String, _
ByVal columns As String() _
) As FeatureSetReader
C#
public FeatureSetReader SelectFeatures(
string query,
string[] columns
)
C++
public:
FeatureSetReader SelectFeatures(
String query,
array<String>^ columns
) sealed
J#
public FeatureSetReader SelectFeatures(
string query,
string[] columns
)
JScript
public function SelectFeatures(
query : String,
columns : String[]
) : FeatureSetReader

See Also

FeatureSourceTypeExtension Class
FeatureSourceTypeExtension.SelectFeatures Overload List


FeatureSourceTypeExtensionCollection Class

FeatureSourceTypeExtensionCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FeatureSourceTypeExtensionCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class FeatureSourceTypeExtensionCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class FeatureSourceTypeExtensionCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class FeatureSourceTypeExtensionCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class FeatureSourceTypeExtensionCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.FeatureSourceTypeExtensionCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FeatureSourceTypeExtensionCollection Members


FeatureSourceTypeExtensionCollection Members

FeatureSourceTypeExtensionCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FeatureSourceTypeExtensionCollection.

Public Constructors

 | Name | Description
Public method | FeatureSourceTypeExtensionCollection | Initializes a new instance of the FeatureSourceTypeExtensionCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSourceTypeExtensionCollection Class


FeatureSourceTypeExtensionCollection Constructor

FeatureSourceTypeExtensionCollection Constructor
[image]

Initializes a new instance of the FeatureSourceTypeExtensionCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FeatureSourceTypeExtensionCollection()
C++
public:
FeatureSourceTypeExtensionCollection() sealed
J#
public FeatureSourceTypeExtensionCollection()
JScript
public function FeatureSourceTypeExtensionCollection()

See Also

FeatureSourceTypeExtensionCollection Class


Properties

FeatureSourceTypeExtensionCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

FeatureSourceTypeExtensionCollection Class


Item Property

FeatureSourceTypeExtensionCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As FeatureSourceTypeExtension
C#
public FeatureSourceTypeExtension this[
int idx
] { get; set; }
C++
public property FeatureSourceTypeExtension default[int idx] sealed {
FeatureSourceTypeExtension get(int idx);
void set(int idx, FeatureSourceTypeExtension value);
}
J#
/** property */
public FeatureSourceTypeExtension get_Item(int idx);

/** property */
public void set_Item(int idx, FeatureSourceTypeExtension value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

FeatureSourceTypeExtensionCollection Class


Methods

FeatureSourceTypeExtensionCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FeatureSourceTypeExtensionCollection Class


Add Method

FeatureSourceTypeExtensionCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As FeatureSourceTypeExtension _
) As Integer
C#
public int Add(
FeatureSourceTypeExtension value
)
C++
public:
int Add(
FeatureSourceTypeExtension value
) sealed
J#
public int Add(
FeatureSourceTypeExtension value
)
JScript
public function Add(
value : FeatureSourceTypeExtension
) : int

See Also

FeatureSourceTypeExtensionCollection Class


FileBufferedStreamReader Class

FileBufferedStreamReader Class
See Also Example Members
[image]

Represents a buffered reader that relays stream data, using a file buffer, thus exhausting the source fast.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FileBufferedStreamReader
Inherits Stream
C#
public class FileBufferedStreamReader : Stream
C++
ref class FileBufferedStreamReader : Stream
J#
public class FileBufferedStreamReader extends Stream
JScript
public class FileBufferedStreamReader extends Stream

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
OSGeo.MapGuide.MaestroAPI.FileBufferedStreamReader

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FileBufferedStreamReader Members


FileBufferedStreamReader Members

FileBufferedStreamReader Members
See Also Example Constructors Properties Methods
[image]

Represents a buffered reader that relays stream data, using a file buffer, thus exhausting the source fast.

The following tables list the members exposed by FileBufferedStreamReader.

Public Constructors

 | Name | Description
Public method | FileBufferedStreamReader |
Top

Public Properties

 | Name | Description
Public property | CanRead | Overridden.
Public property | CanSeek | Overridden.
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (inherited from Stream)
Public property | CanWrite | Overridden.
Public property | Length | Overridden.
Public property | Position | Overridden.
Public property | ReadTimeout | Gets or sets a value that determines how long the stream will attempt to read before timing out. (inherited from Stream)
Public property | WriteTimeout | Gets or sets a value that determines how long the stream will attempt to write before timing out. (inherited from Stream)
Top

Public Methods

 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (inherited from Stream)
Public method | BeginWrite | Begins an asynchronous write operation. (inherited from Stream)
Public method | Close | Overridden.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose |
Public method | EndRead | Waits for the pending asynchronous read to complete. (inherited from Stream)
Public method | EndWrite | Ends an asynchronous write operation. (inherited from Stream)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Overridden.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | Read | Overridden.
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (inherited from Stream)
Public method | Seek | Overridden.
Public method | SetLength | Overridden.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overridden.
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (inherited from Stream)
Top

See Also

FileBufferedStreamReader Class


FileBufferedStreamReader Constructor

FileBufferedStreamReader Constructor
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal source As Stream, _
ByVal length As Integer _
)
C#
public FileBufferedStreamReader(
Stream source,
int length
)
C++
public:
FileBufferedStreamReader(
Stream source,
int length
) sealed
J#
public FileBufferedStreamReader(
Stream source,
int length
)
JScript
public function FileBufferedStreamReader(
source : Stream,
length : int
)

See Also

FileBufferedStreamReader Class


Properties

FileBufferedStreamReader Properties
[image]

Public Properties

 | Name | Description
Public property | CanRead | Overridden.
Public property | CanSeek | Overridden.
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (inherited from Stream)
Public property | CanWrite | Overridden.
Public property | Length | Overridden.
Public property | Position | Overridden.
Public property | ReadTimeout | Gets or sets a value that determines how long the stream will attempt to read before timing out. (inherited from Stream)
Public property | WriteTimeout | Gets or sets a value that determines how long the stream will attempt to write before timing out. (inherited from Stream)
Top

See Also

FileBufferedStreamReader Class


CanRead Property

FileBufferedStreamReader.CanRead Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
C#
public override bool CanRead { get; }
C++
public override property bool CanRead override {
bool get();
}
J#
/** property */
public bool get_CanRead();
JScript
public function get CanRead() : bool

See Also

FileBufferedStreamReader Class


CanSeek Property

FileBufferedStreamReader.CanSeek Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
C#
public override bool CanSeek { get; }
C++
public override property bool CanSeek override {
bool get();
}
J#
/** property */
public bool get_CanSeek();
JScript
public function get CanSeek() : bool

See Also

FileBufferedStreamReader Class


CanWrite Property

FileBufferedStreamReader.CanWrite Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
C#
public override bool CanWrite { get; }
C++
public override property bool CanWrite override {
bool get();
}
J#
/** property */
public bool get_CanWrite();
JScript
public function get CanWrite() : bool

See Also

FileBufferedStreamReader Class


Length Property

FileBufferedStreamReader.Length Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
C#
public override long Length { get; }
C++
public override property long Length override {
__int64 get();
}
J#
/** property */
public long get_Length();
JScript
public function get Length() : long

See Also

FileBufferedStreamReader Class


Position Property

FileBufferedStreamReader.Position Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
C#
public override long Position { get; set; }
C++
public override property long Position override {
__int64 get();
void set(__int64 value);
}
J#
/** property */
public long get_Position();

/** property */
public void set_Position(long value);
JScript
public function get Position() : long

public function set Position(value : long);

See Also

FileBufferedStreamReader Class


Methods

FileBufferedStreamReader Methods
[image]

Public Methods

 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (inherited from Stream)
Public method | BeginWrite | Begins an asynchronous write operation. (inherited from Stream)
Public method | Close | Overridden.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (inherited from MarshalByRefObject)
Public method | Dispose |
Public method | EndRead | Waits for the pending asynchronous read to complete. (inherited from Stream)
Public method | EndWrite | Ends an asynchronous write operation. (inherited from Stream)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Overridden.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (inherited from MarshalByRefObject)
Public method | Read | Overridden.
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (inherited from Stream)
Public method | Seek | Overridden.
Public method | SetLength | Overridden.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overridden.
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (inherited from Stream)
Top

See Also

FileBufferedStreamReader Class


Close Method

FileBufferedStreamReader.Close Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
C#
public override void Close()
C++
public:
virtual void Close() override
J#
public override void Close()
JScript
public override function Close()

See Also

FileBufferedStreamReader Class


Dispose Method

FileBufferedStreamReader.Dispose Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shadows Sub Dispose() _
Implements IDisposable.Dispose
C#
public new void Dispose()
C++
public:
void Dispose() sealed
J#
public new void Dispose()
JScript
public function Dispose()

Implements

IDisposable.Dispose

See Also

FileBufferedStreamReader Class


Flush Method

FileBufferedStreamReader.Flush Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
C#
public override void Flush()
C++
public:
virtual void Flush() override
J#
public override void Flush()
JScript
public override function Flush()

See Also

FileBufferedStreamReader Class


Read Method

FileBufferedStreamReader.Read Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
ByVal buffer As Byte(), _
ByVal offset As Integer, _
ByVal count As Integer _
) As Integer
C#
public override int Read(
byte[] buffer,
int offset,
int count
)
C++
public:
virtual int Read(
array<char>^ buffer,
int offset,
int count
) override
J#
public override int Read(
byte[] buffer,
int offset,
int count
)
JScript
public override function Read(
buffer : Byte[],
offset : int,
count : int
) : int

See Also

FileBufferedStreamReader Class


Seek Method

FileBufferedStreamReader.Seek Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
ByVal offset As Long, _
ByVal origin As SeekOrigin _
) As Long
C#
public override long Seek(
long offset,
SeekOrigin origin
)
C++
public:
virtual __int64 Seek(
__int64 offset,
SeekOrigin origin
) override
J#
public override long Seek(
long offset,
SeekOrigin origin
)
JScript
public override function Seek(
offset : long,
origin : SeekOrigin
) : long

See Also

FileBufferedStreamReader Class


SetLength Method

FileBufferedStreamReader.SetLength Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
ByVal value As Long _
)
C#
public override void SetLength(
long value
)
C++
public:
virtual void SetLength(
__int64 value
) override
J#
public override void SetLength(
long value
)
JScript
public override function SetLength(
value : long
)

See Also

FileBufferedStreamReader Class


Write Method

FileBufferedStreamReader.Write Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
ByVal buffer As Byte(), _
ByVal offset As Integer, _
ByVal count As Integer _
)
C#
public override void Write(
byte[] buffer,
int offset,
int count
)
C++
public:
virtual void Write(
array<char>^ buffer,
int offset,
int count
) override
J#
public override void Write(
byte[] buffer,
int offset,
int count
)
JScript
public override function Write(
buffer : Byte[],
offset : int,
count : int
)

See Also

FileBufferedStreamReader Class


FillType Class

FillType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FillType
C#
public class FillType
C++
ref class FillType
J#
public class FillType
JScript
public class FillType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.FillType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FillType Members


FillType Members

FillType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FillType.

Public Constructors

 | Name | Description
Public method | FillType | Initializes a new instance of the FillType class.
Top

Public Properties

 | Name | Description
Public property | BackgroundColor |
Public property | BackgroundColorAsHTML |
Public property | ExtendedData1 |
Public property | FillPattern |
Public property | ForegroundColor |
Public property | ForegroundColorAsHTML |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FillType Class


FillType Constructor

FillType Constructor
[image]

Initializes a new instance of the FillType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FillType()
C++
public:
FillType() sealed
J#
public FillType()
JScript
public function FillType()

See Also

FillType Class


Properties

FillType Properties
[image]

Public Properties

 | Name | Description
Public property | BackgroundColor |
Public property | BackgroundColorAsHTML |
Public property | ExtendedData1 |
Public property | FillPattern |
Public property | ForegroundColor |
Public property | ForegroundColorAsHTML |
Top

See Also

FillType Class


BackgroundColor Property

FillType.BackgroundColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property BackgroundColor As Color
C#
[XmlIgnoreAttribute]
public Color BackgroundColor { get; set; }
C++
[XmlIgnoreAttribute]
public property Color BackgroundColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public Color get_BackgroundColor();

/** property */
public void set_BackgroundColor(Color value);
JScript
public function get BackgroundColor() : Color

public function set BackgroundColor(value : Color);

See Also

FillType Class


BackgroundColorAsHTML Property

FillType.BackgroundColorAsHTML Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("BackgroundColor")>
Public Property BackgroundColorAsHTML As String
C#
[XmlElementAttribute("BackgroundColor")]
public string BackgroundColorAsHTML { get; set; }
C++
[XmlElementAttribute(L"BackgroundColor")]
public property string BackgroundColorAsHTML sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute("BackgroundColor") */
/** property */
public string get_BackgroundColorAsHTML();

/** property */
public void set_BackgroundColorAsHTML(string value);
JScript
public function get BackgroundColorAsHTML() : String

public function set BackgroundColorAsHTML(value : String);

See Also

FillType Class


ExtendedData1 Property

FillType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

FillType Class


FillPattern Property

FillType.FillPattern Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FillPattern As String
C#
public string FillPattern { get; set; }
C++
public property string FillPattern sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FillPattern();

/** property */
public void set_FillPattern(string value);
JScript
public function get FillPattern() : String

public function set FillPattern(value : String);

See Also

FillType Class


ForegroundColor Property

FillType.ForegroundColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ForegroundColor As Color
C#
[XmlIgnoreAttribute]
public Color ForegroundColor { get; set; }
C++
[XmlIgnoreAttribute]
public property Color ForegroundColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public Color get_ForegroundColor();

/** property */
public void set_ForegroundColor(Color value);
JScript
public function get ForegroundColor() : Color

public function set ForegroundColor(value : Color);

See Also

FillType Class


ForegroundColorAsHTML Property

FillType.ForegroundColorAsHTML Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("ForegroundColor")>
Public Property ForegroundColorAsHTML As String
C#
[XmlElementAttribute("ForegroundColor")]
public string ForegroundColorAsHTML { get; set; }
C++
[XmlElementAttribute(L"ForegroundColor")]
public property string ForegroundColorAsHTML sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute("ForegroundColor") */
/** property */
public string get_ForegroundColorAsHTML();

/** property */
public void set_ForegroundColorAsHTML(string value);
JScript
public function get ForegroundColorAsHTML() : String

public function set ForegroundColorAsHTML(value : String);

See Also

FillType Class


FlyoutItemType Class

FlyoutItemType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FlyoutItemType
Inherits UIItemType
C#
public class FlyoutItemType : UIItemType
C++
ref class FlyoutItemType : UIItemType
J#
public class FlyoutItemType extends UIItemType
JScript
public class FlyoutItemType extends UIItemType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.UIItemType
OSGeo.MapGuide.MaestroAPI.FlyoutItemType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FlyoutItemType Members


FlyoutItemType Members

FlyoutItemType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FlyoutItemType.

Public Constructors

 | Name | Description
Public method | FlyoutItemType | Initializes a new instance of the FlyoutItemType class.
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | DisabledImageURL |
Public property | Function | (inherited from UIItemType)
Public property | ImageURL |
Public property | Label |
Public property | SubItem |
Public property | Tooltip |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FlyoutItemType Class


FlyoutItemType Constructor

FlyoutItemType Constructor
[image]

Initializes a new instance of the FlyoutItemType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FlyoutItemType()
C++
public:
FlyoutItemType() sealed
J#
public FlyoutItemType()
JScript
public function FlyoutItemType()

See Also

FlyoutItemType Class


Properties

FlyoutItemType Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | DisabledImageURL |
Public property | Function | (inherited from UIItemType)
Public property | ImageURL |
Public property | Label |
Public property | SubItem |
Public property | Tooltip |
Top

See Also

FlyoutItemType Class


Description Property

FlyoutItemType.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

FlyoutItemType Class


DisabledImageURL Property

FlyoutItemType.DisabledImageURL Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisabledImageURL As String
C#
public string DisabledImageURL { get; set; }
C++
public property string DisabledImageURL sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DisabledImageURL();

/** property */
public void set_DisabledImageURL(string value);
JScript
public function get DisabledImageURL() : String

public function set DisabledImageURL(value : String);

See Also

FlyoutItemType Class


ImageURL Property

FlyoutItemType.ImageURL Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageURL As String
C#
public string ImageURL { get; set; }
C++
public property string ImageURL sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ImageURL();

/** property */
public void set_ImageURL(string value);
JScript
public function get ImageURL() : String

public function set ImageURL(value : String);

See Also

FlyoutItemType Class


Label Property

FlyoutItemType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label { get; set; }
C++
public property string Label sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Label();

/** property */
public void set_Label(string value);
JScript
public function get Label() : String

public function set Label(value : String);

See Also

FlyoutItemType Class


SubItem Property

FlyoutItemType.SubItem Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("SubItem")>
Public Property SubItem As UIItemTypeCollection
C#
[XmlElementAttribute("SubItem")]
public UIItemTypeCollection SubItem { get; set; }
C++
[XmlElementAttribute(L"SubItem")]
public property UIItemTypeCollection SubItem sealed {
UIItemTypeCollection get();
void set(UIItemTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("SubItem") */
/** property */
public UIItemTypeCollection get_SubItem();

/** property */
public void set_SubItem(UIItemTypeCollection value);
JScript
public function get SubItem() : UIItemTypeCollection

public function set SubItem(value : UIItemTypeCollection);

See Also

FlyoutItemType Class


Tooltip Property

FlyoutItemType.Tooltip Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Tooltip As String
C#
public string Tooltip { get; set; }
C++
public property string Tooltip sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Tooltip();

/** property */
public void set_Tooltip(string value);
JScript
public function get Tooltip() : String

public function set Tooltip(value : String);

See Also

FlyoutItemType Class


FontSymbolType Class

FontSymbolType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FontSymbolType
Inherits SymbolType
C#
public class FontSymbolType : SymbolType
C++
ref class FontSymbolType : SymbolType
J#
public class FontSymbolType extends SymbolType
JScript
public class FontSymbolType extends SymbolType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolType
OSGeo.MapGuide.MaestroAPI.FontSymbolType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FontSymbolType Members


FontSymbolType Members

FontSymbolType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FontSymbolType.

Public Constructors

 | Name | Description
Public method | FontSymbolType | Initializes a new instance of the FontSymbolType class.
Top

Public Properties

 | Name | Description
Public property | Bold |
Public property | BoldSpecified |
Public property | Character |
Public property | ExtendedData1 |
Public property | FontName |
Public property | ForegroundColor |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | Italic |
Public property | ItalicSpecified |
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | Underlined |
Public property | UnderlinedSpecified |
Public property | Unit | (inherited from SymbolType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FontSymbolType Class


FontSymbolType Constructor

FontSymbolType Constructor
[image]

Initializes a new instance of the FontSymbolType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FontSymbolType()
C++
public:
FontSymbolType() sealed
J#
public FontSymbolType()
JScript
public function FontSymbolType()

See Also

FontSymbolType Class


Properties

FontSymbolType Properties
[image]

Public Properties

 | Name | Description
Public property | Bold |
Public property | BoldSpecified |
Public property | Character |
Public property | ExtendedData1 |
Public property | FontName |
Public property | ForegroundColor |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | Italic |
Public property | ItalicSpecified |
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | Underlined |
Public property | UnderlinedSpecified |
Public property | Unit | (inherited from SymbolType)
Top

See Also

FontSymbolType Class


Bold Property

FontSymbolType.Bold Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Bold As Boolean
C#
public bool Bold { get; set; }
C++
public property bool Bold sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Bold();

/** property */
public void set_Bold(bool value);
JScript
public function get Bold() : bool

public function set Bold(value : bool);

See Also

FontSymbolType Class


BoldSpecified Property

FontSymbolType.BoldSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property BoldSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool BoldSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool BoldSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_BoldSpecified();

/** property */
public void set_BoldSpecified(bool value);
JScript
public function get BoldSpecified() : bool

public function set BoldSpecified(value : bool);

See Also

FontSymbolType Class


Character Property

FontSymbolType.Character Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Character As String
C#
public string Character { get; set; }
C++
public property string Character sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Character();

/** property */
public void set_Character(string value);
JScript
public function get Character() : String

public function set Character(value : String);

See Also

FontSymbolType Class


ExtendedData1 Property

FontSymbolType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

FontSymbolType Class


FontName Property

FontSymbolType.FontName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FontName As String
C#
public string FontName { get; set; }
C++
public property string FontName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FontName();

/** property */
public void set_FontName(string value);
JScript
public function get FontName() : String

public function set FontName(value : String);

See Also

FontSymbolType Class


ForegroundColor Property

FontSymbolType.ForegroundColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ForegroundColor As String
C#
public string ForegroundColor { get; set; }
C++
public property string ForegroundColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ForegroundColor();

/** property */
public void set_ForegroundColor(string value);
JScript
public function get ForegroundColor() : String

public function set ForegroundColor(value : String);

See Also

FontSymbolType Class


Italic Property

FontSymbolType.Italic Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Italic As Boolean
C#
public bool Italic { get; set; }
C++
public property bool Italic sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Italic();

/** property */
public void set_Italic(bool value);
JScript
public function get Italic() : bool

public function set Italic(value : bool);

See Also

FontSymbolType Class


ItalicSpecified Property

FontSymbolType.ItalicSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ItalicSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ItalicSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ItalicSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ItalicSpecified();

/** property */
public void set_ItalicSpecified(bool value);
JScript
public function get ItalicSpecified() : bool

public function set ItalicSpecified(value : bool);

See Also

FontSymbolType Class


Underlined Property

FontSymbolType.Underlined Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Underlined As Boolean
C#
public bool Underlined { get; set; }
C++
public property bool Underlined sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Underlined();

/** property */
public void set_Underlined(bool value);
JScript
public function get Underlined() : bool

public function set Underlined(value : bool);

See Also

FontSymbolType Class


UnderlinedSpecified Property

FontSymbolType.UnderlinedSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property UnderlinedSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool UnderlinedSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool UnderlinedSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_UnderlinedSpecified();

/** property */
public void set_UnderlinedSpecified(bool value);
JScript
public function get UnderlinedSpecified() : bool

public function set UnderlinedSpecified(value : bool);

See Also

FontSymbolType Class


GeometryContextType Enumeration

GeometryContextType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum GeometryContextType
C#
public enum GeometryContextType
C++
public enum class GeometryContextType
J#
public enum GeometryContextType
JScript
public enum GeometryContextType

Members

Member Name | Description
Unspecified |
Point |
LineString |
Polygon |

See Also


GeoReferenceOverrideType Class

GeoReferenceOverrideType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GeoReferenceOverrideType
C#
public class GeoReferenceOverrideType
C++
ref class GeoReferenceOverrideType
J#
public class GeoReferenceOverrideType
JScript
public class GeoReferenceOverrideType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GeoReferenceOverrideType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GeoReferenceOverrideType Members


GeoReferenceOverrideType Members

GeoReferenceOverrideType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GeoReferenceOverrideType.

Public Constructors

 | Name | Description
Public method | GeoReferenceOverrideType | Initializes a new instance of the GeoReferenceOverrideType class.
Top

Public Properties

 | Name | Description
Public property | LocationX |
Public property | LocationY |
Public property | ScaleX |
Public property | ScaleY |
Public property | SourceFile |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GeoReferenceOverrideType Class


GeoReferenceOverrideType Constructor

GeoReferenceOverrideType Constructor
[image]

Initializes a new instance of the GeoReferenceOverrideType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GeoReferenceOverrideType()
C++
public:
GeoReferenceOverrideType() sealed
J#
public GeoReferenceOverrideType()
JScript
public function GeoReferenceOverrideType()

See Also

GeoReferenceOverrideType Class


Properties

GeoReferenceOverrideType Properties
[image]

Public Properties

 | Name | Description
Public property | LocationX |
Public property | LocationY |
Public property | ScaleX |
Public property | ScaleY |
Public property | SourceFile |
Top

See Also

GeoReferenceOverrideType Class


LocationX Property

GeoReferenceOverrideType.LocationX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LocationX As Double
C#
public double LocationX { get; set; }
C++
public property double LocationX sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_LocationX();

/** property */
public void set_LocationX(double value);
JScript
public function get LocationX() : double

public function set LocationX(value : double);

See Also

GeoReferenceOverrideType Class


LocationY Property

GeoReferenceOverrideType.LocationY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LocationY As Double
C#
public double LocationY { get; set; }
C++
public property double LocationY sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_LocationY();

/** property */
public void set_LocationY(double value);
JScript
public function get LocationY() : double

public function set LocationY(value : double);

See Also

GeoReferenceOverrideType Class


ScaleX Property

GeoReferenceOverrideType.ScaleX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ScaleX As Double
C#
public double ScaleX { get; set; }
C++
public property double ScaleX sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_ScaleX();

/** property */
public void set_ScaleX(double value);
JScript
public function get ScaleX() : double

public function set ScaleX(value : double);

See Also

GeoReferenceOverrideType Class


ScaleY Property

GeoReferenceOverrideType.ScaleY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ScaleY As Double
C#
public double ScaleY { get; set; }
C++
public property double ScaleY sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_ScaleY();

/** property */
public void set_ScaleY(double value);
JScript
public function get ScaleY() : double

public function set ScaleY(value : double);

See Also

GeoReferenceOverrideType Class


SourceFile Property

GeoReferenceOverrideType.SourceFile Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SourceFile As String
C#
public string SourceFile { get; set; }
C++
public property string SourceFile sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SourceFile();

/** property */
public void set_SourceFile(string value);
JScript
public function get SourceFile() : String

public function set SourceFile(value : String);

See Also

GeoReferenceOverrideType Class


GeoReferenceOverrideTypeCollection Class

GeoReferenceOverrideTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class GeoReferenceOverrideTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class GeoReferenceOverrideTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class GeoReferenceOverrideTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class GeoReferenceOverrideTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class GeoReferenceOverrideTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.GeoReferenceOverrideTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GeoReferenceOverrideTypeCollection Members


GeoReferenceOverrideTypeCollection Members

GeoReferenceOverrideTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GeoReferenceOverrideTypeCollection.

Public Constructors

 | Name | Description
Public method | GeoReferenceOverrideTypeCollection | Initializes a new instance of the GeoReferenceOverrideTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GeoReferenceOverrideTypeCollection Class


GeoReferenceOverrideTypeCollection Constructor

GeoReferenceOverrideTypeCollection Constructor
[image]

Initializes a new instance of the GeoReferenceOverrideTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GeoReferenceOverrideTypeCollection()
C++
public:
GeoReferenceOverrideTypeCollection() sealed
J#
public GeoReferenceOverrideTypeCollection()
JScript
public function GeoReferenceOverrideTypeCollection()

See Also

GeoReferenceOverrideTypeCollection Class


Properties

GeoReferenceOverrideTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

GeoReferenceOverrideTypeCollection Class


Item Property

GeoReferenceOverrideTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As GeoReferenceOverrideType
C#
public GeoReferenceOverrideType this[
int idx
] { get; set; }
C++
public property GeoReferenceOverrideType default[int idx] sealed {
GeoReferenceOverrideType get(int idx);
void set(int idx, GeoReferenceOverrideType value);
}
J#
/** property */
public GeoReferenceOverrideType get_Item(int idx);

/** property */
public void set_Item(int idx, GeoReferenceOverrideType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

GeoReferenceOverrideTypeCollection Class


Methods

GeoReferenceOverrideTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GeoReferenceOverrideTypeCollection Class


Add Method

GeoReferenceOverrideTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As GeoReferenceOverrideType _
) As Integer
C#
public int Add(
GeoReferenceOverrideType value
)
C++
public:
int Add(
GeoReferenceOverrideType value
) sealed
J#
public int Add(
GeoReferenceOverrideType value
)
JScript
public function Add(
value : GeoReferenceOverrideType
) : int

See Also

GeoReferenceOverrideTypeCollection Class


GetPrintablePageCommandType Class

GetPrintablePageCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GetPrintablePageCommandType
Inherits TargetedCommandType
C#
public class GetPrintablePageCommandType : TargetedCommandType
C++
ref class GetPrintablePageCommandType : TargetedCommandType
J#
public class GetPrintablePageCommandType extends TargetedCommandType
JScript
public class GetPrintablePageCommandType extends TargetedCommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.TargetedCommandType
OSGeo.MapGuide.MaestroAPI.GetPrintablePageCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GetPrintablePageCommandType Members


GetPrintablePageCommandType Members

GetPrintablePageCommandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GetPrintablePageCommandType.

Public Constructors

 | Name | Description
Public method | GetPrintablePageCommandType | Initializes a new instance of the GetPrintablePageCommandType class.
Top

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | Target | (inherited from TargetedCommandType)
Public property | TargetFrame | (inherited from TargetedCommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GetPrintablePageCommandType Class


GetPrintablePageCommandType Constructor

GetPrintablePageCommandType Constructor
[image]

Initializes a new instance of the GetPrintablePageCommandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GetPrintablePageCommandType()
C++
public:
GetPrintablePageCommandType() sealed
J#
public GetPrintablePageCommandType()
JScript
public function GetPrintablePageCommandType()

See Also

GetPrintablePageCommandType Class


GraphicBase Class

GraphicBase Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(Text)), _
XmlIncludeAttribute(GetType(Path)), _
XmlIncludeAttribute(GetType(Image))>
Public Class GraphicBase
C#
[XmlIncludeAttribute(typeof(Text))]
[XmlIncludeAttribute(typeof(Path))]
[XmlIncludeAttribute(typeof(Image))]
public class GraphicBase
C++
[XmlIncludeAttribute(typeof(Text))]
[XmlIncludeAttribute(typeof(Path))]
[XmlIncludeAttribute(typeof(Image))]
ref class GraphicBase
J#
/** @attribute XmlIncludeAttribute(typeof(Text)) */
/** @attribute XmlIncludeAttribute(typeof(Path)) */
/** @attribute XmlIncludeAttribute(typeof(Image)) */
public class GraphicBase
JScript
public
XmlIncludeAttribute(typeof(Text))
XmlIncludeAttribute(typeof(Path))
XmlIncludeAttribute(typeof(Image))
class GraphicBase

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GraphicBase
OSGeo.MapGuide.MaestroAPI.Image
OSGeo.MapGuide.MaestroAPI.Path
OSGeo.MapGuide.MaestroAPI.Text

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GraphicBase Members


GraphicBase Members

GraphicBase Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GraphicBase.

Public Constructors

 | Name | Description
Public method | GraphicBase | Initializes a new instance of the GraphicBase class.
Top

Public Properties

 | Name | Description
Public property | ResizeControl |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GraphicBase Class


GraphicBase Constructor

GraphicBase Constructor
[image]

Initializes a new instance of the GraphicBase class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GraphicBase()
C++
public:
GraphicBase() sealed
J#
public GraphicBase()
JScript
public function GraphicBase()

See Also

GraphicBase Class


Properties

GraphicBase Properties
[image]

Public Properties

 | Name | Description
Public property | ResizeControl |
Top

See Also

GraphicBase Class


ResizeControl Property

GraphicBase.ResizeControl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'ResizeNone'")>
Public Property ResizeControl As String
C#
[DefaultValueAttribute("'ResizeNone'")]
public string ResizeControl { get; set; }
C++
[DefaultValueAttribute(L"'ResizeNone'")]
public property string ResizeControl sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'ResizeNone'") */
/** property */
public string get_ResizeControl();

/** property */
public void set_ResizeControl(string value);
JScript
public function get ResizeControl() : String

public function set ResizeControl(value : String);

See Also

GraphicBase Class


GraphicBaseCollection Class

GraphicBaseCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class GraphicBaseCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class GraphicBaseCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class GraphicBaseCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class GraphicBaseCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class GraphicBaseCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.GraphicBaseCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GraphicBaseCollection Members


GraphicBaseCollection Members

GraphicBaseCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GraphicBaseCollection.

Public Constructors

 | Name | Description
Public method | GraphicBaseCollection | Initializes a new instance of the GraphicBaseCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GraphicBaseCollection Class


GraphicBaseCollection Constructor

GraphicBaseCollection Constructor
[image]

Initializes a new instance of the GraphicBaseCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GraphicBaseCollection()
C++
public:
GraphicBaseCollection() sealed
J#
public GraphicBaseCollection()
JScript
public function GraphicBaseCollection()

See Also

GraphicBaseCollection Class


Properties

GraphicBaseCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

GraphicBaseCollection Class


Item Property

GraphicBaseCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As GraphicBase
C#
public GraphicBase this[
int idx
] { get; set; }
C++
public property GraphicBase default[int idx] sealed {
GraphicBase get(int idx);
void set(int idx, GraphicBase value);
}
J#
/** property */
public GraphicBase get_Item(int idx);

/** property */
public void set_Item(int idx, GraphicBase value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

GraphicBaseCollection Class


Methods

GraphicBaseCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GraphicBaseCollection Class


Add Method

GraphicBaseCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As GraphicBase _
) As Integer
C#
public int Add(
GraphicBase value
)
C++
public:
int Add(
GraphicBase value
) sealed
J#
public int Add(
GraphicBase value
)
JScript
public function Add(
value : GraphicBase
) : int

See Also

GraphicBaseCollection Class


GridColorBandsType Class

GridColorBandsType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GridColorBandsType
C#
public class GridColorBandsType
C++
ref class GridColorBandsType
J#
public class GridColorBandsType
JScript
public class GridColorBandsType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GridColorBandsType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GridColorBandsType Members


GridColorBandsType Members

GridColorBandsType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GridColorBandsType.

Public Constructors

 | Name | Description
Public method | GridColorBandsType | Initializes a new instance of the GridColorBandsType class.
Top

Public Properties

 | Name | Description
Public property | BlueBand |
Public property | GreenBand |
Public property | RedBand |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GridColorBandsType Class


GridColorBandsType Constructor

GridColorBandsType Constructor
[image]

Initializes a new instance of the GridColorBandsType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GridColorBandsType()
C++
public:
GridColorBandsType() sealed
J#
public GridColorBandsType()
JScript
public function GridColorBandsType()

See Also

GridColorBandsType Class


Properties

GridColorBandsType Properties
[image]

Public Properties

 | Name | Description
Public property | BlueBand |
Public property | GreenBand |
Public property | RedBand |
Top

See Also

GridColorBandsType Class


BlueBand Property

GridColorBandsType.BlueBand Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property BlueBand As ChannelBandType
C#
public ChannelBandType BlueBand { get; set; }
C++
public property ChannelBandType BlueBand sealed {
ChannelBandType get();
void set(ChannelBandType value);
}
J#
/** property */
public ChannelBandType get_BlueBand();

/** property */
public void set_BlueBand(ChannelBandType value);
JScript
public function get BlueBand() : ChannelBandType

public function set BlueBand(value : ChannelBandType);

See Also

GridColorBandsType Class


GreenBand Property

GridColorBandsType.GreenBand Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property GreenBand As ChannelBandType
C#
public ChannelBandType GreenBand { get; set; }
C++
public property ChannelBandType GreenBand sealed {
ChannelBandType get();
void set(ChannelBandType value);
}
J#
/** property */
public ChannelBandType get_GreenBand();

/** property */
public void set_GreenBand(ChannelBandType value);
JScript
public function get GreenBand() : ChannelBandType

public function set GreenBand(value : ChannelBandType);

See Also

GridColorBandsType Class


RedBand Property

GridColorBandsType.RedBand Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property RedBand As ChannelBandType
C#
public ChannelBandType RedBand { get; set; }
C++
public property ChannelBandType RedBand sealed {
ChannelBandType get();
void set(ChannelBandType value);
}
J#
/** property */
public ChannelBandType get_RedBand();

/** property */
public void set_RedBand(ChannelBandType value);
JScript
public function get RedBand() : ChannelBandType

public function set RedBand(value : ChannelBandType);

See Also

GridColorBandsType Class


GridColorRuleType Class

GridColorRuleType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GridColorRuleType
C#
public class GridColorRuleType
C++
ref class GridColorRuleType
J#
public class GridColorRuleType
JScript
public class GridColorRuleType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GridColorRuleType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GridColorRuleType Members


GridColorRuleType Members

GridColorRuleType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GridColorRuleType.

Public Constructors

 | Name | Description
Public method | GridColorRuleType | Initializes a new instance of the GridColorRuleType class.
Top

Public Properties

 | Name | Description
Public property | Color |
Public property | ExtendedData1 |
Public property | Filter |
Public property | Label |
Public property | LegendLabel |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GridColorRuleType Class


GridColorRuleType Constructor

GridColorRuleType Constructor
[image]

Initializes a new instance of the GridColorRuleType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GridColorRuleType()
C++
public:
GridColorRuleType() sealed
J#
public GridColorRuleType()
JScript
public function GridColorRuleType()

See Also

GridColorRuleType Class


Properties

GridColorRuleType Properties
[image]

Public Properties

 | Name | Description
Public property | Color |
Public property | ExtendedData1 |
Public property | Filter |
Public property | Label |
Public property | LegendLabel |
Top

See Also

GridColorRuleType Class


Color Property

GridColorRuleType.Color Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Color As GridColorType
C#
public GridColorType Color { get; set; }
C++
public property GridColorType Color sealed {
GridColorType get();
void set(GridColorType value);
}
J#
/** property */
public GridColorType get_Color();

/** property */
public void set_Color(GridColorType value);
JScript
public function get Color() : GridColorType

public function set Color(value : GridColorType);

See Also

GridColorRuleType Class


ExtendedData1 Property

GridColorRuleType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

GridColorRuleType Class


Filter Property

GridColorRuleType.Filter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; set; }
C++
public property string Filter sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Filter();

/** property */
public void set_Filter(string value);
JScript
public function get Filter() : String

public function set Filter(value : String);

See Also

GridColorRuleType Class


Label Property

GridColorRuleType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As TextSymbolType
C#
public TextSymbolType Label { get; set; }
C++
public property TextSymbolType Label sealed {
TextSymbolType get();
void set(TextSymbolType value);
}
J#
/** property */
public TextSymbolType get_Label();

/** property */
public void set_Label(TextSymbolType value);
JScript
public function get Label() : TextSymbolType

public function set Label(value : TextSymbolType);

See Also

GridColorRuleType Class


LegendLabel Property

GridColorRuleType.LegendLabel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LegendLabel As String
C#
public string LegendLabel { get; set; }
C++
public property string LegendLabel sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LegendLabel();

/** property */
public void set_LegendLabel(string value);
JScript
public function get LegendLabel() : String

public function set LegendLabel(value : String);

See Also

GridColorRuleType Class


GridColorRuleTypeCollection Class

GridColorRuleTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class GridColorRuleTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class GridColorRuleTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class GridColorRuleTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class GridColorRuleTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class GridColorRuleTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.GridColorRuleTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GridColorRuleTypeCollection Members


GridColorRuleTypeCollection Members

GridColorRuleTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GridColorRuleTypeCollection.

Public Constructors

 | Name | Description
Public method | GridColorRuleTypeCollection | Initializes a new instance of the GridColorRuleTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GridColorRuleTypeCollection Class


GridColorRuleTypeCollection Constructor

GridColorRuleTypeCollection Constructor
[image]

Initializes a new instance of the GridColorRuleTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GridColorRuleTypeCollection()
C++
public:
GridColorRuleTypeCollection() sealed
J#
public GridColorRuleTypeCollection()
JScript
public function GridColorRuleTypeCollection()

See Also

GridColorRuleTypeCollection Class


Properties

GridColorRuleTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

GridColorRuleTypeCollection Class


Item Property

GridColorRuleTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As GridColorRuleType
C#
public GridColorRuleType this[
int idx
] { get; set; }
C++
public property GridColorRuleType default[int idx] sealed {
GridColorRuleType get(int idx);
void set(int idx, GridColorRuleType value);
}
J#
/** property */
public GridColorRuleType get_Item(int idx);

/** property */
public void set_Item(int idx, GridColorRuleType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

GridColorRuleTypeCollection Class


Methods

GridColorRuleTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GridColorRuleTypeCollection Class


Add Method

GridColorRuleTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As GridColorRuleType _
) As Integer
C#
public int Add(
GridColorRuleType value
)
C++
public:
int Add(
GridColorRuleType value
) sealed
J#
public int Add(
GridColorRuleType value
)
JScript
public function Add(
value : GridColorRuleType
) : int

See Also

GridColorRuleTypeCollection Class


GridColorStyleType Class

GridColorStyleType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GridColorStyleType
C#
public class GridColorStyleType
C++
ref class GridColorStyleType
J#
public class GridColorStyleType
JScript
public class GridColorStyleType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GridColorStyleType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GridColorStyleType Members


GridColorStyleType Members

GridColorStyleType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GridColorStyleType.

Public Constructors

 | Name | Description
Public method | GridColorStyleType | Initializes a new instance of the GridColorStyleType class.
Top

Public Properties

 | Name | Description
Public property | BrightnessFactor |
Public property | BrightnessFactorSpecified |
Public property | ColorRule |
Public property | ContrastFactor |
Public property | ContrastFactorSpecified |
Public property | ExtendedData1 |
Public property | HillShade |
Public property | TransparencyColor |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GridColorStyleType Class


GridColorStyleType Constructor

GridColorStyleType Constructor
[image]

Initializes a new instance of the GridColorStyleType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GridColorStyleType()
C++
public:
GridColorStyleType() sealed
J#
public GridColorStyleType()
JScript
public function GridColorStyleType()

See Also

GridColorStyleType Class


Properties

GridColorStyleType Properties
[image]

Public Properties

 | Name | Description
Public property | BrightnessFactor |
Public property | BrightnessFactorSpecified |
Public property | ColorRule |
Public property | ContrastFactor |
Public property | ContrastFactorSpecified |
Public property | ExtendedData1 |
Public property | HillShade |
Public property | TransparencyColor |
Top

See Also

GridColorStyleType Class


BrightnessFactor Property

GridColorStyleType.BrightnessFactor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property BrightnessFactor As Double
C#
public double BrightnessFactor { get; set; }
C++
public property double BrightnessFactor sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_BrightnessFactor();

/** property */
public void set_BrightnessFactor(double value);
JScript
public function get BrightnessFactor() : double

public function set BrightnessFactor(value : double);

See Also

GridColorStyleType Class


BrightnessFactorSpecified Property

GridColorStyleType.BrightnessFactorSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property BrightnessFactorSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool BrightnessFactorSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool BrightnessFactorSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_BrightnessFactorSpecified();

/** property */
public void set_BrightnessFactorSpecified(bool value);
JScript
public function get BrightnessFactorSpecified() : bool

public function set BrightnessFactorSpecified(value : bool);

See Also

GridColorStyleType Class


ColorRule Property

GridColorStyleType.ColorRule Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("ColorRule")>
Public Property ColorRule As GridColorRuleTypeCollection
C#
[XmlElementAttribute("ColorRule")]
public GridColorRuleTypeCollection ColorRule { get; set; }
C++
[XmlElementAttribute(L"ColorRule")]
public property GridColorRuleTypeCollection ColorRule sealed {
GridColorRuleTypeCollection get();
void set(GridColorRuleTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("ColorRule") */
/** property */
public GridColorRuleTypeCollection get_ColorRule();

/** property */
public void set_ColorRule(GridColorRuleTypeCollection value);
JScript
public function get ColorRule() : GridColorRuleTypeCollection

public function set ColorRule(value : GridColorRuleTypeCollection);

See Also

GridColorStyleType Class


ContrastFactor Property

GridColorStyleType.ContrastFactor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ContrastFactor As Double
C#
public double ContrastFactor { get; set; }
C++
public property double ContrastFactor sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_ContrastFactor();

/** property */
public void set_ContrastFactor(double value);
JScript
public function get ContrastFactor() : double

public function set ContrastFactor(value : double);

See Also

GridColorStyleType Class


ContrastFactorSpecified Property

GridColorStyleType.ContrastFactorSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ContrastFactorSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ContrastFactorSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ContrastFactorSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ContrastFactorSpecified();

/** property */
public void set_ContrastFactorSpecified(bool value);
JScript
public function get ContrastFactorSpecified() : bool

public function set ContrastFactorSpecified(value : bool);

See Also

GridColorStyleType Class


ExtendedData1 Property

GridColorStyleType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

GridColorStyleType Class


HillShade Property

GridColorStyleType.HillShade Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property HillShade As HillShadeType
C#
public HillShadeType HillShade { get; set; }
C++
public property HillShadeType HillShade sealed {
HillShadeType get();
void set(HillShadeType value);
}
J#
/** property */
public HillShadeType get_HillShade();

/** property */
public void set_HillShade(HillShadeType value);
JScript
public function get HillShade() : HillShadeType

public function set HillShade(value : HillShadeType);

See Also

GridColorStyleType Class


TransparencyColor Property

GridColorStyleType.TransparencyColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property TransparencyColor As Object
C#
public object TransparencyColor { get; set; }
C++
public property object TransparencyColor sealed {
Object get();
void set(Object value);
}
J#
/** property */
public object get_TransparencyColor();

/** property */
public void set_TransparencyColor(object value);
JScript
public function get TransparencyColor() : Object

public function set TransparencyColor(value : Object);

See Also

GridColorStyleType Class


GridColorType Class

GridColorType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GridColorType
C#
public class GridColorType
C++
ref class GridColorType
J#
public class GridColorType
JScript
public class GridColorType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GridColorType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GridColorType Members


GridColorType Members

GridColorType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GridColorType.

Public Constructors

 | Name | Description
Public method | GridColorType | Initializes a new instance of the GridColorType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Item |
Public property | ItemElementName |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GridColorType Class


GridColorType Constructor

GridColorType Constructor
[image]

Initializes a new instance of the GridColorType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GridColorType()
C++
public:
GridColorType() sealed
J#
public GridColorType()
JScript
public function GridColorType()

See Also

GridColorType Class


Properties

GridColorType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Item |
Public property | ItemElementName |
Top

See Also

GridColorType Class


ExtendedData1 Property

GridColorType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

GridColorType Class


Item Property

GridColorType.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlChoiceIdentifierAttribute("ItemElementName"), _
XmlElementAttribute("ExplicitColor", GetType(String)), _
XmlElementAttribute("Band", GetType(String)), _
XmlElementAttribute("Bands", GetType(GridColorBandsType))>
Public Property Item As Object
C#
[XmlChoiceIdentifierAttribute("ItemElementName")]
[XmlElementAttribute("ExplicitColor", typeof(String))]
[XmlElementAttribute("Band", typeof(String))]
[XmlElementAttribute("Bands", typeof(GridColorBandsType))]
public object Item { get; set; }
C++
[XmlChoiceIdentifierAttribute(L"ItemElementName")]
[XmlElementAttribute(L"ExplicitColor", typeof(String))]
[XmlElementAttribute(L"Band", typeof(String))]
[XmlElementAttribute(L"Bands", typeof(GridColorBandsType))]
public property object Item sealed {
Object get();
void set(Object value);
}
J#
/** @attribute XmlChoiceIdentifierAttribute("ItemElementName") */
/** @attribute XmlElementAttribute("ExplicitColor", typeof(String)) */
/** @attribute XmlElementAttribute("Band", typeof(String)) */
/** @attribute XmlElementAttribute("Bands", typeof(GridColorBandsType)) */
/** property */
public object get_Item();

/** property */
public void set_Item(object value);
JScript
public function get Item() : Object

public function set Item(value : Object);

See Also

GridColorType Class


ItemElementName Property

GridColorType.ItemElementName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ItemElementName As ItemChoiceType
C#
[XmlIgnoreAttribute]
public ItemChoiceType ItemElementName { get; set; }
C++
[XmlIgnoreAttribute]
public property ItemChoiceType ItemElementName sealed {
ItemChoiceType get();
void set(ItemChoiceType value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public ItemChoiceType get_ItemElementName();

/** property */
public void set_ItemElementName(ItemChoiceType value);
JScript
public function get ItemElementName() : ItemChoiceType

public function set ItemElementName(value : ItemChoiceType);

See Also

GridColorType Class


GridLayerDefinitionType Class

GridLayerDefinitionType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GridLayerDefinitionType
Inherits BaseLayerDefinitionType
C#
public class GridLayerDefinitionType : BaseLayerDefinitionType
C++
ref class GridLayerDefinitionType : BaseLayerDefinitionType
J#
public class GridLayerDefinitionType extends BaseLayerDefinitionType
JScript
public class GridLayerDefinitionType extends BaseLayerDefinitionType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.BaseLayerDefinitionType
OSGeo.MapGuide.MaestroAPI.GridLayerDefinitionType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GridLayerDefinitionType Members


GridLayerDefinitionType Members

GridLayerDefinitionType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GridLayerDefinitionType.

Public Constructors

 | Name | Description
Public method | GridLayerDefinitionType | Initializes a new instance of the GridLayerDefinitionType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | FeatureName |
Public property | Filter |
Public property | Geometry |
Public property | GridScaleRange |
Public property | Opacity | (inherited from BaseLayerDefinitionType)
Public property | OpacitySpecified | (inherited from BaseLayerDefinitionType)
Public property | ResourceId | (inherited from BaseLayerDefinitionType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GridLayerDefinitionType Class


GridLayerDefinitionType Constructor

GridLayerDefinitionType Constructor
[image]

Initializes a new instance of the GridLayerDefinitionType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GridLayerDefinitionType()
C++
public:
GridLayerDefinitionType() sealed
J#
public GridLayerDefinitionType()
JScript
public function GridLayerDefinitionType()

See Also

GridLayerDefinitionType Class


Properties

GridLayerDefinitionType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | FeatureName |
Public property | Filter |
Public property | Geometry |
Public property | GridScaleRange |
Public property | Opacity | (inherited from BaseLayerDefinitionType)
Public property | OpacitySpecified | (inherited from BaseLayerDefinitionType)
Public property | ResourceId | (inherited from BaseLayerDefinitionType)
Top

See Also

GridLayerDefinitionType Class


ExtendedData1 Property

GridLayerDefinitionType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

GridLayerDefinitionType Class


FeatureName Property

GridLayerDefinitionType.FeatureName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FeatureName As String
C#
public string FeatureName { get; set; }
C++
public property string FeatureName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FeatureName();

/** property */
public void set_FeatureName(string value);
JScript
public function get FeatureName() : String

public function set FeatureName(value : String);

See Also

GridLayerDefinitionType Class


Filter Property

GridLayerDefinitionType.Filter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; set; }
C++
public property string Filter sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Filter();

/** property */
public void set_Filter(string value);
JScript
public function get Filter() : String

public function set Filter(value : String);

See Also

GridLayerDefinitionType Class


Geometry Property

GridLayerDefinitionType.Geometry Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Geometry As String
C#
public string Geometry { get; set; }
C++
public property string Geometry sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Geometry();

/** property */
public void set_Geometry(string value);
JScript
public function get Geometry() : String

public function set Geometry(value : String);

See Also

GridLayerDefinitionType Class


GridScaleRange Property

GridLayerDefinitionType.GridScaleRange Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("GridScaleRange")>
Public Property GridScaleRange As GridScaleRangeTypeCollection
C#
[XmlElementAttribute("GridScaleRange")]
public GridScaleRangeTypeCollection GridScaleRange { get; set; }
C++
[XmlElementAttribute(L"GridScaleRange")]
public property GridScaleRangeTypeCollection GridScaleRange sealed {
GridScaleRangeTypeCollection get();
void set(GridScaleRangeTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("GridScaleRange") */
/** property */
public GridScaleRangeTypeCollection get_GridScaleRange();

/** property */
public void set_GridScaleRange(GridScaleRangeTypeCollection value);
JScript
public function get GridScaleRange() : GridScaleRangeTypeCollection

public function set GridScaleRange(value : GridScaleRangeTypeCollection);

See Also

GridLayerDefinitionType Class


GridScaleRangeType Class

GridScaleRangeType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GridScaleRangeType
C#
public class GridScaleRangeType
C++
ref class GridScaleRangeType
J#
public class GridScaleRangeType
JScript
public class GridScaleRangeType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GridScaleRangeType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GridScaleRangeType Members


GridScaleRangeType Members

GridScaleRangeType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GridScaleRangeType.

Public Constructors

 | Name | Description
Public method | GridScaleRangeType | Initializes a new instance of the GridScaleRangeType class.
Top

Public Properties

 | Name | Description
Public property | ColorStyle |
Public property | ExtendedData1 |
Public property | MaxScale |
Public property | MaxScaleSpecified |
Public property | MinScale |
Public property | MinScaleSpecified |
Public property | RebuildFactor |
Public property | SurfaceStyle |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GridScaleRangeType Class


GridScaleRangeType Constructor

GridScaleRangeType Constructor
[image]

Initializes a new instance of the GridScaleRangeType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GridScaleRangeType()
C++
public:
GridScaleRangeType() sealed
J#
public GridScaleRangeType()
JScript
public function GridScaleRangeType()

See Also

GridScaleRangeType Class


Properties

GridScaleRangeType Properties
[image]

Public Properties

 | Name | Description
Public property | ColorStyle |
Public property | ExtendedData1 |
Public property | MaxScale |
Public property | MaxScaleSpecified |
Public property | MinScale |
Public property | MinScaleSpecified |
Public property | RebuildFactor |
Public property | SurfaceStyle |
Top

See Also

GridScaleRangeType Class


ColorStyle Property

GridScaleRangeType.ColorStyle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ColorStyle As GridColorStyleType
C#
public GridColorStyleType ColorStyle { get; set; }
C++
public property GridColorStyleType ColorStyle sealed {
GridColorStyleType get();
void set(GridColorStyleType value);
}
J#
/** property */
public GridColorStyleType get_ColorStyle();

/** property */
public void set_ColorStyle(GridColorStyleType value);
JScript
public function get ColorStyle() : GridColorStyleType

public function set ColorStyle(value : GridColorStyleType);

See Also

GridScaleRangeType Class


ExtendedData1 Property

GridScaleRangeType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

GridScaleRangeType Class


MaxScale Property

GridScaleRangeType.MaxScale Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxScale As Double
C#
public double MaxScale { get; set; }
C++
public property double MaxScale sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MaxScale();

/** property */
public void set_MaxScale(double value);
JScript
public function get MaxScale() : double

public function set MaxScale(value : double);

See Also

GridScaleRangeType Class


MaxScaleSpecified Property

GridScaleRangeType.MaxScaleSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property MaxScaleSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool MaxScaleSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool MaxScaleSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_MaxScaleSpecified();

/** property */
public void set_MaxScaleSpecified(bool value);
JScript
public function get MaxScaleSpecified() : bool

public function set MaxScaleSpecified(value : bool);

See Also

GridScaleRangeType Class


MinScale Property

GridScaleRangeType.MinScale Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MinScale As Double
C#
public double MinScale { get; set; }
C++
public property double MinScale sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MinScale();

/** property */
public void set_MinScale(double value);
JScript
public function get MinScale() : double

public function set MinScale(value : double);

See Also

GridScaleRangeType Class


MinScaleSpecified Property

GridScaleRangeType.MinScaleSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property MinScaleSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool MinScaleSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool MinScaleSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_MinScaleSpecified();

/** property */
public void set_MinScaleSpecified(bool value);
JScript
public function get MinScaleSpecified() : bool

public function set MinScaleSpecified(value : bool);

See Also

GridScaleRangeType Class


RebuildFactor Property

GridScaleRangeType.RebuildFactor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property RebuildFactor As Double
C#
public double RebuildFactor { get; set; }
C++
public property double RebuildFactor sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_RebuildFactor();

/** property */
public void set_RebuildFactor(double value);
JScript
public function get RebuildFactor() : double

public function set RebuildFactor(value : double);

See Also

GridScaleRangeType Class


SurfaceStyle Property

GridScaleRangeType.SurfaceStyle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SurfaceStyle As GridSurfaceStyleType
C#
public GridSurfaceStyleType SurfaceStyle { get; set; }
C++
public property GridSurfaceStyleType SurfaceStyle sealed {
GridSurfaceStyleType get();
void set(GridSurfaceStyleType value);
}
J#
/** property */
public GridSurfaceStyleType get_SurfaceStyle();

/** property */
public void set_SurfaceStyle(GridSurfaceStyleType value);
JScript
public function get SurfaceStyle() : GridSurfaceStyleType

public function set SurfaceStyle(value : GridSurfaceStyleType);

See Also

GridScaleRangeType Class


GridScaleRangeTypeCollection Class

GridScaleRangeTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class GridScaleRangeTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class GridScaleRangeTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class GridScaleRangeTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class GridScaleRangeTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class GridScaleRangeTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.GridScaleRangeTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GridScaleRangeTypeCollection Members


GridScaleRangeTypeCollection Members

GridScaleRangeTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GridScaleRangeTypeCollection.

Public Constructors

 | Name | Description
Public method | GridScaleRangeTypeCollection | Initializes a new instance of the GridScaleRangeTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GridScaleRangeTypeCollection Class


GridScaleRangeTypeCollection Constructor

GridScaleRangeTypeCollection Constructor
[image]

Initializes a new instance of the GridScaleRangeTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GridScaleRangeTypeCollection()
C++
public:
GridScaleRangeTypeCollection() sealed
J#
public GridScaleRangeTypeCollection()
JScript
public function GridScaleRangeTypeCollection()

See Also

GridScaleRangeTypeCollection Class


Properties

GridScaleRangeTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

GridScaleRangeTypeCollection Class


Item Property

GridScaleRangeTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As GridScaleRangeType
C#
public GridScaleRangeType this[
int idx
] { get; set; }
C++
public property GridScaleRangeType default[int idx] sealed {
GridScaleRangeType get(int idx);
void set(int idx, GridScaleRangeType value);
}
J#
/** property */
public GridScaleRangeType get_Item(int idx);

/** property */
public void set_Item(int idx, GridScaleRangeType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

GridScaleRangeTypeCollection Class


Methods

GridScaleRangeTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GridScaleRangeTypeCollection Class


Add Method

GridScaleRangeTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As GridScaleRangeType _
) As Integer
C#
public int Add(
GridScaleRangeType value
)
C++
public:
int Add(
GridScaleRangeType value
) sealed
J#
public int Add(
GridScaleRangeType value
)
JScript
public function Add(
value : GridScaleRangeType
) : int

See Also

GridScaleRangeTypeCollection Class


GridSurfaceStyleType Class

GridSurfaceStyleType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GridSurfaceStyleType
C#
public class GridSurfaceStyleType
C++
ref class GridSurfaceStyleType
J#
public class GridSurfaceStyleType
JScript
public class GridSurfaceStyleType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GridSurfaceStyleType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GridSurfaceStyleType Members


GridSurfaceStyleType Members

GridSurfaceStyleType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GridSurfaceStyleType.

Public Constructors

 | Name | Description
Public method | GridSurfaceStyleType | Initializes a new instance of the GridSurfaceStyleType class.
Top

Public Properties

 | Name | Description
Public property | Band |
Public property | DefaultColor |
Public property | ExtendedData1 |
Public property | ScaleFactor |
Public property | ScaleFactorSpecified |
Public property | ZeroValue |
Public property | ZeroValueSpecified |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GridSurfaceStyleType Class


GridSurfaceStyleType Constructor

GridSurfaceStyleType Constructor
[image]

Initializes a new instance of the GridSurfaceStyleType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GridSurfaceStyleType()
C++
public:
GridSurfaceStyleType() sealed
J#
public GridSurfaceStyleType()
JScript
public function GridSurfaceStyleType()

See Also

GridSurfaceStyleType Class


Properties

GridSurfaceStyleType Properties
[image]

Public Properties

 | Name | Description
Public property | Band |
Public property | DefaultColor |
Public property | ExtendedData1 |
Public property | ScaleFactor |
Public property | ScaleFactorSpecified |
Public property | ZeroValue |
Public property | ZeroValueSpecified |
Top

See Also

GridSurfaceStyleType Class


Band Property

GridSurfaceStyleType.Band Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Band As String
C#
public string Band { get; set; }
C++
public property string Band sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Band();

/** property */
public void set_Band(string value);
JScript
public function get Band() : String

public function set Band(value : String);

See Also

GridSurfaceStyleType Class


DefaultColor Property

GridSurfaceStyleType.DefaultColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultColor As String
C#
public string DefaultColor { get; set; }
C++
public property string DefaultColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DefaultColor();

/** property */
public void set_DefaultColor(string value);
JScript
public function get DefaultColor() : String

public function set DefaultColor(value : String);

See Also

GridSurfaceStyleType Class


ExtendedData1 Property

GridSurfaceStyleType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

GridSurfaceStyleType Class


ScaleFactor Property

GridSurfaceStyleType.ScaleFactor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ScaleFactor As Double
C#
public double ScaleFactor { get; set; }
C++
public property double ScaleFactor sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_ScaleFactor();

/** property */
public void set_ScaleFactor(double value);
JScript
public function get ScaleFactor() : double

public function set ScaleFactor(value : double);

See Also

GridSurfaceStyleType Class


ScaleFactorSpecified Property

GridSurfaceStyleType.ScaleFactorSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ScaleFactorSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ScaleFactorSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ScaleFactorSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ScaleFactorSpecified();

/** property */
public void set_ScaleFactorSpecified(bool value);
JScript
public function get ScaleFactorSpecified() : bool

public function set ScaleFactorSpecified(value : bool);

See Also

GridSurfaceStyleType Class


ZeroValue Property

GridSurfaceStyleType.ZeroValue Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ZeroValue As Double
C#
public double ZeroValue { get; set; }
C++
public property double ZeroValue sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_ZeroValue();

/** property */
public void set_ZeroValue(double value);
JScript
public function get ZeroValue() : double

public function set ZeroValue(value : double);

See Also

GridSurfaceStyleType Class


ZeroValueSpecified Property

GridSurfaceStyleType.ZeroValueSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ZeroValueSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ZeroValueSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ZeroValueSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ZeroValueSpecified();

/** property */
public void set_ZeroValueSpecified(bool value);
JScript
public function get ZeroValueSpecified() : bool

public function set ZeroValueSpecified(value : bool);

See Also

GridSurfaceStyleType Class


Group Class

Group Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class Group
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class Group
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class Group
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class Group
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class Group

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.Group

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Group Members


Group Members

Group Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by Group.

Public Constructors

 | Name | Description
Public method | Group | Initializes a new instance of the Group class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | Users |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Group Class


Group Constructor

Group Constructor
[image]

Initializes a new instance of the Group class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Group()
C++
public:
Group() sealed
J#
public Group()
JScript
public function Group()

See Also

Group Class


Fields

Group Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

Group Class


SchemaName Field

Group.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

Group Class


Properties

Group Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | Users |
Public property | XsdSchema |
Top

See Also

Group Class


Description Property

Group.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

Group Class


Users Property

Group.Users Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Users As GroupUsers
C#
public GroupUsers Users { get; set; }
C++
public property GroupUsers Users sealed {
GroupUsers get();
void set(GroupUsers value);
}
J#
/** property */
public GroupUsers get_Users();

/** property */
public void set_Users(GroupUsers value);
JScript
public function get Users() : GroupUsers

public function set Users(value : GroupUsers);

See Also

Group Class


XsdSchema Property

Group.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

Group Class


GroupList Class

GroupList Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class GroupList
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class GroupList
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class GroupList
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class GroupList
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class GroupList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GroupList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GroupList Members


GroupList Members

GroupList Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by GroupList.

Public Constructors

 | Name | Description
Public method | GroupList | Initializes a new instance of the GroupList class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Group |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GroupList Class


GroupList Constructor

GroupList Constructor
[image]

Initializes a new instance of the GroupList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GroupList()
C++
public:
GroupList() sealed
J#
public GroupList()
JScript
public function GroupList()

See Also

GroupList Class


Fields

GroupList Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

GroupList Class


SchemaName Field

GroupList.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

GroupList Class


Properties

GroupList Properties
[image]

Public Properties

 | Name | Description
Public property | Group |
Public property | XsdSchema |
Top

See Also

GroupList Class


Group Property

GroupList.Group Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Group")>
Public Property Group As GroupListGroupCollection
C#
[XmlElementAttribute("Group")]
public GroupListGroupCollection Group { get; set; }
C++
[XmlElementAttribute(L"Group")]
public property GroupListGroupCollection Group sealed {
GroupListGroupCollection get();
void set(GroupListGroupCollection value);
}
J#
/** @attribute XmlElementAttribute("Group") */
/** property */
public GroupListGroupCollection get_Group();

/** property */
public void set_Group(GroupListGroupCollection value);
JScript
public function get Group() : GroupListGroupCollection

public function set Group(value : GroupListGroupCollection);

See Also

GroupList Class


XsdSchema Property

GroupList.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

GroupList Class


GroupListGroup Class

GroupListGroup Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GroupListGroup
C#
public class GroupListGroup
C++
ref class GroupListGroup
J#
public class GroupListGroup
JScript
public class GroupListGroup

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GroupListGroup

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GroupListGroup Members


GroupListGroup Members

GroupListGroup Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GroupListGroup.

Public Constructors

 | Name | Description
Public method | GroupListGroup | Initializes a new instance of the GroupListGroup class.
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GroupListGroup Class


GroupListGroup Constructor

GroupListGroup Constructor
[image]

Initializes a new instance of the GroupListGroup class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GroupListGroup()
C++
public:
GroupListGroup() sealed
J#
public GroupListGroup()
JScript
public function GroupListGroup()

See Also

GroupListGroup Class


Properties

GroupListGroup Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | Name |
Top

See Also

GroupListGroup Class


Description Property

GroupListGroup.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

GroupListGroup Class


Name Property

GroupListGroup.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

GroupListGroup Class


GroupListGroupCollection Class

GroupListGroupCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class GroupListGroupCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class GroupListGroupCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class GroupListGroupCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class GroupListGroupCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class GroupListGroupCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.GroupListGroupCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GroupListGroupCollection Members


GroupListGroupCollection Members

GroupListGroupCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GroupListGroupCollection.

Public Constructors

 | Name | Description
Public method | GroupListGroupCollection | Initializes a new instance of the GroupListGroupCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GroupListGroupCollection Class


GroupListGroupCollection Constructor

GroupListGroupCollection Constructor
[image]

Initializes a new instance of the GroupListGroupCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GroupListGroupCollection()
C++
public:
GroupListGroupCollection() sealed
J#
public GroupListGroupCollection()
JScript
public function GroupListGroupCollection()

See Also

GroupListGroupCollection Class


Properties

GroupListGroupCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

GroupListGroupCollection Class


Item Property

GroupListGroupCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As GroupListGroup
C#
public GroupListGroup this[
int idx
] { get; set; }
C++
public property GroupListGroup default[int idx] sealed {
GroupListGroup get(int idx);
void set(int idx, GroupListGroup value);
}
J#
/** property */
public GroupListGroup get_Item(int idx);

/** property */
public void set_Item(int idx, GroupListGroup value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

GroupListGroupCollection Class


Methods

GroupListGroupCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GroupListGroupCollection Class


Add Method

GroupListGroupCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As GroupListGroup _
) As Integer
C#
public int Add(
GroupListGroup value
)
C++
public:
int Add(
GroupListGroup value
) sealed
J#
public int Add(
GroupListGroup value
)
JScript
public function Add(
value : GroupListGroup
) : int

See Also

GroupListGroupCollection Class


GroupUsers Class

GroupUsers Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GroupUsers
C#
public class GroupUsers
C++
ref class GroupUsers
J#
public class GroupUsers
JScript
public class GroupUsers

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GroupUsers

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GroupUsers Members


GroupUsers Members

GroupUsers Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GroupUsers.

Public Constructors

 | Name | Description
Public method | GroupUsers | Initializes a new instance of the GroupUsers class.
Top

Public Properties

 | Name | Description
Public property | User |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GroupUsers Class


GroupUsers Constructor

GroupUsers Constructor
[image]

Initializes a new instance of the GroupUsers class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GroupUsers()
C++
public:
GroupUsers() sealed
J#
public GroupUsers()
JScript
public function GroupUsers()

See Also

GroupUsers Class


Properties

GroupUsers Properties
[image]

Public Properties

 | Name | Description
Public property | User |
Top

See Also

GroupUsers Class


User Property

GroupUsers.User Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("User")>
Public Property User As GroupUsersUserCollection
C#
[XmlElementAttribute("User")]
public GroupUsersUserCollection User { get; set; }
C++
[XmlElementAttribute(L"User")]
public property GroupUsersUserCollection User sealed {
GroupUsersUserCollection get();
void set(GroupUsersUserCollection value);
}
J#
/** @attribute XmlElementAttribute("User") */
/** property */
public GroupUsersUserCollection get_User();

/** property */
public void set_User(GroupUsersUserCollection value);
JScript
public function get User() : GroupUsersUserCollection

public function set User(value : GroupUsersUserCollection);

See Also

GroupUsers Class


GroupUsersUser Class

GroupUsersUser Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class GroupUsersUser
C#
public class GroupUsersUser
C++
ref class GroupUsersUser
J#
public class GroupUsersUser
JScript
public class GroupUsersUser

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GroupUsersUser

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GroupUsersUser Members


GroupUsersUser Members

GroupUsersUser Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GroupUsersUser.

Public Constructors

 | Name | Description
Public method | GroupUsersUser | Initializes a new instance of the GroupUsersUser class.
Top

Public Properties

 | Name | Description
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GroupUsersUser Class


GroupUsersUser Constructor

GroupUsersUser Constructor
[image]

Initializes a new instance of the GroupUsersUser class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GroupUsersUser()
C++
public:
GroupUsersUser() sealed
J#
public GroupUsersUser()
JScript
public function GroupUsersUser()

See Also

GroupUsersUser Class


Properties

GroupUsersUser Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Top

See Also

GroupUsersUser Class


Name Property

GroupUsersUser.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

GroupUsersUser Class


GroupUsersUserCollection Class

GroupUsersUserCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class GroupUsersUserCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class GroupUsersUserCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class GroupUsersUserCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class GroupUsersUserCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class GroupUsersUserCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.GroupUsersUserCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

GroupUsersUserCollection Members


GroupUsersUserCollection Members

GroupUsersUserCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by GroupUsersUserCollection.

Public Constructors

 | Name | Description
Public method | GroupUsersUserCollection | Initializes a new instance of the GroupUsersUserCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GroupUsersUserCollection Class


GroupUsersUserCollection Constructor

GroupUsersUserCollection Constructor
[image]

Initializes a new instance of the GroupUsersUserCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public GroupUsersUserCollection()
C++
public:
GroupUsersUserCollection() sealed
J#
public GroupUsersUserCollection()
JScript
public function GroupUsersUserCollection()

See Also

GroupUsersUserCollection Class


Properties

GroupUsersUserCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

GroupUsersUserCollection Class


Item Property

GroupUsersUserCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As GroupUsersUser
C#
public GroupUsersUser this[
int idx
] { get; set; }
C++
public property GroupUsersUser default[int idx] sealed {
GroupUsersUser get(int idx);
void set(int idx, GroupUsersUser value);
}
J#
/** property */
public GroupUsersUser get_Item(int idx);

/** property */
public void set_Item(int idx, GroupUsersUser value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

GroupUsersUserCollection Class


Methods

GroupUsersUserCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

GroupUsersUserCollection Class


Add Method

GroupUsersUserCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As GroupUsersUser _
) As Integer
C#
public int Add(
GroupUsersUser value
)
C++
public:
int Add(
GroupUsersUser value
) sealed
J#
public int Add(
GroupUsersUser value
)
JScript
public function Add(
value : GroupUsersUser
) : int

See Also

GroupUsersUserCollection Class


HelpCommandType Class

HelpCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class HelpCommandType
Inherits TargetedCommandType
C#
public class HelpCommandType : TargetedCommandType
C++
ref class HelpCommandType : TargetedCommandType
J#
public class HelpCommandType extends TargetedCommandType
JScript
public class HelpCommandType extends TargetedCommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.TargetedCommandType
OSGeo.MapGuide.MaestroAPI.HelpCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

HelpCommandType Members


HelpCommandType Members

HelpCommandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by HelpCommandType.

Public Constructors

 | Name | Description
Public method | HelpCommandType | Initializes a new instance of the HelpCommandType class.
Top

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | Target | (inherited from TargetedCommandType)
Public property | TargetFrame | (inherited from TargetedCommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Public property | URL |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

HelpCommandType Class


HelpCommandType Constructor

HelpCommandType Constructor
[image]

Initializes a new instance of the HelpCommandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public HelpCommandType()
C++
public:
HelpCommandType() sealed
J#
public HelpCommandType()
JScript
public function HelpCommandType()

See Also

HelpCommandType Class


Properties

HelpCommandType Properties
[image]

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | Target | (inherited from TargetedCommandType)
Public property | TargetFrame | (inherited from TargetedCommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Public property | URL |
Top

See Also

HelpCommandType Class


URL Property

HelpCommandType.URL Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property URL As String
C#
public string URL { get; set; }
C++
public property string URL sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_URL();

/** property */
public void set_URL(string value);
JScript
public function get URL() : String

public function set URL(value : String);

See Also

HelpCommandType Class


HillShadeType Class

HillShadeType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class HillShadeType
C#
public class HillShadeType
C++
ref class HillShadeType
J#
public class HillShadeType
JScript
public class HillShadeType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.HillShadeType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

HillShadeType Members


HillShadeType Members

HillShadeType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by HillShadeType.

Public Constructors

 | Name | Description
Public method | HillShadeType | Initializes a new instance of the HillShadeType class.
Top

Public Properties

 | Name | Description
Public property | Altitude |
Public property | Azimuth |
Public property | Band |
Public property | ExtendedData1 |
Public property | ScaleFactor |
Public property | ScaleFactorSpecified |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

HillShadeType Class


HillShadeType Constructor

HillShadeType Constructor
[image]

Initializes a new instance of the HillShadeType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public HillShadeType()
C++
public:
HillShadeType() sealed
J#
public HillShadeType()
JScript
public function HillShadeType()

See Also

HillShadeType Class


Properties

HillShadeType Properties
[image]

Public Properties

 | Name | Description
Public property | Altitude |
Public property | Azimuth |
Public property | Band |
Public property | ExtendedData1 |
Public property | ScaleFactor |
Public property | ScaleFactorSpecified |
Top

See Also

HillShadeType Class


Altitude Property

HillShadeType.Altitude Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Altitude As Double
C#
public double Altitude { get; set; }
C++
public property double Altitude sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Altitude();

/** property */
public void set_Altitude(double value);
JScript
public function get Altitude() : double

public function set Altitude(value : double);

See Also

HillShadeType Class


Azimuth Property

HillShadeType.Azimuth Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Azimuth As Double
C#
public double Azimuth { get; set; }
C++
public property double Azimuth sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Azimuth();

/** property */
public void set_Azimuth(double value);
JScript
public function get Azimuth() : double

public function set Azimuth(value : double);

See Also

HillShadeType Class


Band Property

HillShadeType.Band Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Band As String
C#
public string Band { get; set; }
C++
public property string Band sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Band();

/** property */
public void set_Band(string value);
JScript
public function get Band() : String

public function set Band(value : String);

See Also

HillShadeType Class


ExtendedData1 Property

HillShadeType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

HillShadeType Class


ScaleFactor Property

HillShadeType.ScaleFactor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ScaleFactor As Double
C#
public double ScaleFactor { get; set; }
C++
public property double ScaleFactor sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_ScaleFactor();

/** property */
public void set_ScaleFactor(double value);
JScript
public function get ScaleFactor() : double

public function set ScaleFactor(value : double);

See Also

HillShadeType Class


ScaleFactorSpecified Property

HillShadeType.ScaleFactorSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ScaleFactorSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ScaleFactorSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ScaleFactorSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ScaleFactorSpecified();

/** property */
public void set_ScaleFactorSpecified(bool value);
JScript
public function get ScaleFactorSpecified() : bool

public function set ScaleFactorSpecified(value : bool);

See Also

HillShadeType Class


HttpServerConnection Class

HttpServerConnection Class
See Also Example Members
[image]

Primary http based connection to the MapGuide Server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class HttpServerConnection
Inherits ServerConnectionBase
Implements ServerConnectionI, IDisposable
C#
public class HttpServerConnection : ServerConnectionBase, ServerConnectionI, IDisposable
C++
ref class HttpServerConnection : ServerConnectionBase, ServerConnectionI, IDisposable
J#
public class HttpServerConnection extends ServerConnectionBase implements ServerConnectionI, IDisposable
JScript
public class HttpServerConnection extends ServerConnectionBase, ServerConnectionI, IDisposable

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ServerConnectionBase
OSGeo.MapGuide.MaestroAPI.HttpServerConnection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

HttpServerConnection Members


HttpServerConnection Members

HttpServerConnection Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Primary http based connection to the MapGuide Server

The following tables list the members exposed by HttpServerConnection.

Public Constructors

Name | Description
HttpServerConnection | Overloaded.
Top

Public Properties

 | Name | Description
Public property | AutoRestartSession | Gets or sets a value indicating if the session should automatically be restarted if it expires (inherited from ServerConnectionBase)
Public property | BaseURL | Gets the base url, ea.: http://localhost/mapguide/
Public property | CachedSchemas | Gets or sets the collection of cached schemas. Use the object type for key, and an XmlSchema instance for value. (inherited from ServerConnectionBase)
Public property | CoordinateSystem |
Public property | DisableValidation | Gets or sets a flag that indicates if the Xml resources are validated before leaving and entering the server. (inherited from ServerConnectionBase)
Public property | DisplayName | Gets a string that can be used to identify the server by a user
Public property | FeatureProviders | Overridden.
Public property | LastResponseHeaders |
Public property | MaxTestedVersion | Gets the highest version the API is currently tested againts (inherited from ServerConnectionBase)
Public property | RepositoryResources |
Public property | ResourceTypeLookup | Gets or sets a hashtable where the key is resourceID extensions, and values are System.Type values. (inherited from ServerConnectionBase)
Public property | ServerURI | Returns the Uri for the mapagent
Public property | SessionID | Overridden.
Public property | SiteVersion | Overridden.
Top

Public Methods

 | Name | Description
Public method | CopyFolder | Overridden.
Public method | CopyFolderWithReferences | Copies folder, and subsequently updates all resources within the folder to use the new folder path instead of the originating one. (inherited from ServerConnectionBase)
Public method | CopyResource | Overridden.
Public method | CreateFolder | Creates a folder on the server (inherited from ServerConnectionBase)
Public method | CreateRuntimeMap | Overloaded. Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.
Public method | DeleteFolder |
Public method | DeleteResource | Overridden.
Public method | DeleteResourceData |
Public method | DescribeFeatureSource | Overloaded.
Public method | DescribeSchema | Placeholder for actual method call
Public method | DeserializeObject | Overloaded. Deserializes an object from a stream. (inherited from ServerConnectionBase)
Public method | Dispose | Overridden.
Public method | EnumerateGroups | Overridden. Gets a list of all groups on the server
Public method | EnumerateResourceData |
Public method | EnumerateResourceReferences | Overridden.
Public method | EnumerateUnmanagedData | Overridden. Enumerates all unmanaged folders, meaning alias'ed folders
Public method | EnumerateUsers | Overloaded. Gets a list of all users on the server
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | ExecuteOperation |
Public method | GetApplicationContainers | Overridden. Returns the avalible widget containers on the server
Public method | GetApplicationDefinition | Returns a ApplicationDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetApplicationTemplates | Overridden. Returns the avalible application templates on the server
Public method | GetApplicationWidgets | Overridden. Returns the avalible application widgets on the server
Public method | GetFeatureProvider | Returns an installed provider, given the name of the provider (inherited from ServerConnectionBase)
Public method | GetFeatureSource | Returns a FeatureSource from the server. (inherited from ServerConnectionBase)
Public method | GetFeatureSourceDescription | (inherited from ServerConnectionBase)
Public method | GetFeatureSourceSchema | (inherited from ServerConnectionBase)
Public method | GetFolderHeader | (inherited from ServerConnectionBase)
Public method | GetFolderOrResourceHeader | Overridden.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetIdentityProperties | Overridden. Gets the names of the identity properties from a feature
Public method | GetLayerDefinition | Returns a LayerDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetLegendImage | Overridden. Renders a minature bitmap of the layers style
Public method | GetMapDefinition | Returns a MapDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetMapDWF |
Public method | GetProviderCapabilities |
Public method | GetRepositoryResources | Overloaded. Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly.
Public method | GetResource | Returns an object deserialized from server data. Uses the ResourceID to infer the object type. (inherited from ServerConnectionBase)
Public method | GetResourceData | Overridden.
Public method | GetResourceHeader | (inherited from ServerConnectionBase)
Public method | GetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types. (inherited from ServerConnectionBase)
Public method | GetResourceXmlData | Overridden.
Public method | GetRuntimeMap |
Public method | GetSelectionXml | Overridden. Gets the selection from a map
Public method | GetSpatialContextInfo | Overridden. Returns the spatial info for a given featuresource
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetWebLayout | Returns a WebLayout from the server. (inherited from ServerConnectionBase)
Public method | HasFolder | Returns a value indicating if a given folder exists (inherited from ServerConnectionBase)
Public method | IsSessionExpiredException | Overridden.
Public method | MoveFolder | Overridden.
Public method | MoveFolderWithReferences | Moves a folder, and subsequently updates all resources pointing to the old resource path (inherited from ServerConnectionBase)
Public method | MoveResource | Overridden.
Public method | MoveResourceWithReferences | Moves a resource, and subsequently updates all resources pointing to the old resource path (inherited from ServerConnectionBase)
Public method | QueryFeatureSource | Overloaded.
Public method | QueryMapFeatures | Overloaded. Selects features from a runtime map, returning a selection Xml.
Public method | RemoveVersionFromProviderName | Removes the version numbers from a providername (inherited from ServerConnectionBase)
Public method | RenderRuntimeMap |
Public method | ResetFeatureSourceSchemaCache | (inherited from ServerConnectionBase)
Public method | ResourceExists | Returns a boolean indicating if a given resource exists (inherited from ServerConnectionBase)
Public method | RestartSession | Overloaded. Restarts the server session, and creates a new session ID
Public method | SaveResource | Overloaded. Saves a FeatureSource, using its originating resourceId (inherited from ServerConnectionBase)
Public method | SaveResourceAs | Overloaded. Saves a FeatureSource under a different resourceID (inherited from ServerConnectionBase)
Public method | SaveRuntimeMap | Updates an existing runtime map
Public method | SerializeObject | Overloaded. Serialize an object into a new memory stream. (inherited from ServerConnectionBase)
Public method | SetFolderHeader | (inherited from ServerConnectionBase)
Public method | SetFolderOrResourceHeader | (inherited from ServerConnectionBase)
Public method | SetResourceData | Overloaded. Uploads data to a resource
Public method | SetResourceHeader | (inherited from ServerConnectionBase)
Public method | SetResourceXmlData | Overloaded. Writes raw data into a resource.
Public method | SetSelectionXml | Overridden. Sets the selection of a map
Public method | TestConnection | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types. (inherited from ServerConnectionBase)
Public method | UpdateResourceReferences | Updates all resource references inside an object. (inherited from ServerConnectionBase)
Public method | UploadPackage | Overridden. Upload a MapGuide Package file to the server
Public method | WriteResource | Writes an object into a resourceID (inherited from ServerConnectionBase)
Top

Explicit Interface Implementations

Name | Description
HttpServerConnection | Overloaded.
Top

See Also

HttpServerConnection Class


HttpServerConnection Constructor

HttpServerConnection Constructor

Overload List

 | Name | Description
Public method | HttpServerConnection (Uri, String, String, Boolean) |
Public method | HttpServerConnection (Uri, String, String, String, Boolean) |

See Also

HttpServerConnection Class


HttpServerConnection Constructor (Uri, String, String, Boolean)

HttpServerConnection Constructor (Uri, String, String, Boolean)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal hosturl As Uri, _
ByVal sessionid As String, _
ByVal locale As String, _
ByVal allowUntestedVersion As Boolean _
)
C#
public HttpServerConnection(
Uri hosturl,
string sessionid,
string locale,
bool allowUntestedVersion
)
C++
public:
HttpServerConnection(
Uri hosturl,
String sessionid,
String locale,
bool allowUntestedVersion
) sealed
J#
public HttpServerConnection(
Uri hosturl,
string sessionid,
string locale,
bool allowUntestedVersion
)
JScript
public function HttpServerConnection(
hosturl : Uri,
sessionid : String,
locale : String,
allowUntestedVersion : bool
)

See Also

HttpServerConnection Class
HttpServerConnection Constructor Overload List


HttpServerConnection Constructor (Uri, String, String, String, Boolean)

HttpServerConnection Constructor (Uri, String, String, String, Boolean)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal hosturl As Uri, _
ByVal username As String, _
ByVal password As String, _
ByVal locale As String, _
ByVal allowUntestedVersion As Boolean _
)
C#
public HttpServerConnection(
Uri hosturl,
string username,
string password,
string locale,
bool allowUntestedVersion
)
C++
public:
HttpServerConnection(
Uri hosturl,
String username,
String password,
String locale,
bool allowUntestedVersion
) sealed
J#
public HttpServerConnection(
Uri hosturl,
string username,
string password,
string locale,
bool allowUntestedVersion
)
JScript
public function HttpServerConnection(
hosturl : Uri,
username : String,
password : String,
locale : String,
allowUntestedVersion : bool
)

See Also

HttpServerConnection Class
HttpServerConnection Constructor Overload List


Properties

HttpServerConnection Properties
[image]

Public Properties

 | Name | Description
Public property | AutoRestartSession | Gets or sets a value indicating if the session should automatically be restarted if it expires (inherited from ServerConnectionBase)
Public property | BaseURL | Gets the base url, ea.: http://localhost/mapguide/
Public property | CachedSchemas | Gets or sets the collection of cached schemas. Use the object type for key, and an XmlSchema instance for value. (inherited from ServerConnectionBase)
Public property | CoordinateSystem |
Public property | DisableValidation | Gets or sets a flag that indicates if the Xml resources are validated before leaving and entering the server. (inherited from ServerConnectionBase)
Public property | DisplayName | Gets a string that can be used to identify the server by a user
Public property | FeatureProviders | Overridden.
Public property | LastResponseHeaders |
Public property | MaxTestedVersion | Gets the highest version the API is currently tested againts (inherited from ServerConnectionBase)
Public property | RepositoryResources |
Public property | ResourceTypeLookup | Gets or sets a hashtable where the key is resourceID extensions, and values are System.Type values. (inherited from ServerConnectionBase)
Public property | ServerURI | Returns the Uri for the mapagent
Public property | SessionID | Overridden.
Public property | SiteVersion | Overridden.
Top

See Also

HttpServerConnection Class


BaseURL Property

HttpServerConnection.BaseURL Property
[image]

Gets the base url, ea.: http://localhost/mapguide/

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BaseURL As String
C#
public string BaseURL { get; }
C++
public property string BaseURL sealed {
String get();
}
J#
/** property */
public string get_BaseURL();
JScript
public function get BaseURL() : String

See Also

HttpServerConnection Class


CoordinateSystem Property

HttpServerConnection.CoordinateSystem Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CoordinateSystem As CoordinateSystem _
Implements ServerConnectionI.CoordinateSystem
C#
public CoordinateSystem CoordinateSystem { get; }
C++
public property CoordinateSystem CoordinateSystem sealed {
CoordinateSystem get();
}
J#
/** property */
public CoordinateSystem get_CoordinateSystem();
JScript
public function get CoordinateSystem() : CoordinateSystem

Implements

ServerConnectionI.CoordinateSystem

See Also

HttpServerConnection Class


DisplayName Property

HttpServerConnection.DisplayName Property
[image]

Gets a string that can be used to identify the server by a user

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayName As String _
Implements ServerConnectionI.DisplayName
C#
public string DisplayName { get; }
C++
public property string DisplayName sealed {
String get();
}
J#
/** property */
public string get_DisplayName();
JScript
public function get DisplayName() : String

Implements

ServerConnectionI.DisplayName

See Also

HttpServerConnection Class


FeatureProviders Property

HttpServerConnection.FeatureProviders Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FeatureProviders As FeatureProviderRegistryFeatureProviderCollection _
Implements ServerConnectionI.FeatureProviders
C#
public override FeatureProviderRegistryFeatureProviderCollection FeatureProviders { get; }
C++
public override property FeatureProviderRegistryFeatureProviderCollection FeatureProviders override {
FeatureProviderRegistryFeatureProviderCollection get();
}
J#
/** property */
public FeatureProviderRegistryFeatureProviderCollection get_FeatureProviders();
JScript
public function get FeatureProviders() : FeatureProviderRegistryFeatureProviderCollection

Implements

ServerConnectionI.FeatureProviders

See Also

HttpServerConnection Class


LastResponseHeaders Property

HttpServerConnection.LastResponseHeaders Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastResponseHeaders As WebHeaderCollection
C#
public WebHeaderCollection LastResponseHeaders { get; }
C++
public property WebHeaderCollection LastResponseHeaders sealed {
WebHeaderCollection get();
}
J#
/** property */
public WebHeaderCollection get_LastResponseHeaders();
JScript
public function get LastResponseHeaders() : WebHeaderCollection

See Also

HttpServerConnection Class


RepositoryResources Property

HttpServerConnection.RepositoryResources Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RepositoryResources As ResourceList _
Implements ServerConnectionI.RepositoryResources
C#
public ResourceList RepositoryResources { get; }
C++
public property ResourceList RepositoryResources sealed {
ResourceList get();
}
J#
/** property */
public ResourceList get_RepositoryResources();
JScript
public function get RepositoryResources() : ResourceList

Implements

ServerConnectionI.RepositoryResources

See Also

HttpServerConnection Class


ServerURI Property

HttpServerConnection.ServerURI Property
[image]

Returns the Uri for the mapagent

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ServerURI As String
C#
public string ServerURI { get; }
C++
public property string ServerURI sealed {
String get();
}
J#
/** property */
public string get_ServerURI();
JScript
public function get ServerURI() : String

See Also

HttpServerConnection Class


SessionID Property

HttpServerConnection.SessionID Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property SessionID As String _
Implements ServerConnectionI.SessionID
C#
public override string SessionID { get; }
C++
public override property string SessionID override {
String get();
}
J#
/** property */
public string get_SessionID();
JScript
public function get SessionID() : String

Implements

ServerConnectionI.SessionID

See Also

HttpServerConnection Class


SiteVersion Property

HttpServerConnection.SiteVersion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property SiteVersion As Version _
Implements ServerConnectionI.SiteVersion
C#
public override Version SiteVersion { get; }
C++
public override property Version SiteVersion override {
Version get();
}
J#
/** property */
public Version get_SiteVersion();
JScript
public function get SiteVersion() : Version

Implements

ServerConnectionI.SiteVersion

See Also

HttpServerConnection Class


Methods

HttpServerConnection Methods
[image]

Public Methods

 | Name | Description
Public method | CopyFolder | Overridden.
Public method | CopyFolderWithReferences | Copies folder, and subsequently updates all resources within the folder to use the new folder path instead of the originating one. (inherited from ServerConnectionBase)
Public method | CopyResource | Overridden.
Public method | CreateFolder | Creates a folder on the server (inherited from ServerConnectionBase)
Public method | CreateRuntimeMap | Overloaded. Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.
Public method | DeleteFolder |
Public method | DeleteResource | Overridden.
Public method | DeleteResourceData |
Public method | DescribeFeatureSource | Overloaded.
Public method | DescribeSchema | Placeholder for actual method call
Public method | DeserializeObject | Overloaded. Deserializes an object from a stream. (inherited from ServerConnectionBase)
Public method | Dispose | Overridden.
Public method | EnumerateGroups | Overridden. Gets a list of all groups on the server
Public method | EnumerateResourceData |
Public method | EnumerateResourceReferences | Overridden.
Public method | EnumerateUnmanagedData | Overridden. Enumerates all unmanaged folders, meaning alias'ed folders
Public method | EnumerateUsers | Overloaded. Gets a list of all users on the server
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | ExecuteOperation |
Public method | GetApplicationContainers | Overridden. Returns the avalible widget containers on the server
Public method | GetApplicationDefinition | Returns a ApplicationDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetApplicationTemplates | Overridden. Returns the avalible application templates on the server
Public method | GetApplicationWidgets | Overridden. Returns the avalible application widgets on the server
Public method | GetFeatureProvider | Returns an installed provider, given the name of the provider (inherited from ServerConnectionBase)
Public method | GetFeatureSource | Returns a FeatureSource from the server. (inherited from ServerConnectionBase)
Public method | GetFeatureSourceDescription | (inherited from ServerConnectionBase)
Public method | GetFeatureSourceSchema | (inherited from ServerConnectionBase)
Public method | GetFolderHeader | (inherited from ServerConnectionBase)
Public method | GetFolderOrResourceHeader | Overridden.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetIdentityProperties | Overridden. Gets the names of the identity properties from a feature
Public method | GetLayerDefinition | Returns a LayerDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetLegendImage | Overridden. Renders a minature bitmap of the layers style
Public method | GetMapDefinition | Returns a MapDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetMapDWF |
Public method | GetProviderCapabilities |
Public method | GetRepositoryResources | Overloaded. Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly.
Public method | GetResource | Returns an object deserialized from server data. Uses the ResourceID to infer the object type. (inherited from ServerConnectionBase)
Public method | GetResourceData | Overridden.
Public method | GetResourceHeader | (inherited from ServerConnectionBase)
Public method | GetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types. (inherited from ServerConnectionBase)
Public method | GetResourceXmlData | Overridden.
Public method | GetRuntimeMap |
Public method | GetSelectionXml | Overridden. Gets the selection from a map
Public method | GetSpatialContextInfo | Overridden. Returns the spatial info for a given featuresource
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetWebLayout | Returns a WebLayout from the server. (inherited from ServerConnectionBase)
Public method | HasFolder | Returns a value indicating if a given folder exists (inherited from ServerConnectionBase)
Public method | IsSessionExpiredException | Overridden.
Public method | MoveFolder | Overridden.
Public method | MoveFolderWithReferences | Moves a folder, and subsequently updates all resources pointing to the old resource path (inherited from ServerConnectionBase)
Public method | MoveResource | Overridden.
Public method | MoveResourceWithReferences | Moves a resource, and subsequently updates all resources pointing to the old resource path (inherited from ServerConnectionBase)
Public method | QueryFeatureSource | Overloaded.
Public method | QueryMapFeatures | Overloaded. Selects features from a runtime map, returning a selection Xml.
Public method | RemoveVersionFromProviderName | Removes the version numbers from a providername (inherited from ServerConnectionBase)
Public method | RenderRuntimeMap |
Public method | ResetFeatureSourceSchemaCache | (inherited from ServerConnectionBase)
Public method | ResourceExists | Returns a boolean indicating if a given resource exists (inherited from ServerConnectionBase)
Public method | RestartSession | Overloaded. Restarts the server session, and creates a new session ID
Public method | SaveResource | Overloaded. Saves a FeatureSource, using its originating resourceId (inherited from ServerConnectionBase)
Public method | SaveResourceAs | Overloaded. Saves a FeatureSource under a different resourceID (inherited from ServerConnectionBase)
Public method | SaveRuntimeMap | Updates an existing runtime map
Public method | SerializeObject | Overloaded. Serialize an object into a new memory stream. (inherited from ServerConnectionBase)
Public method | SetFolderHeader | (inherited from ServerConnectionBase)
Public method | SetFolderOrResourceHeader | (inherited from ServerConnectionBase)
Public method | SetResourceData | Overloaded. Uploads data to a resource
Public method | SetResourceHeader | (inherited from ServerConnectionBase)
Public method | SetResourceXmlData | Overloaded. Writes raw data into a resource.
Public method | SetSelectionXml | Overridden. Sets the selection of a map
Public method | TestConnection | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types. (inherited from ServerConnectionBase)
Public method | UpdateResourceReferences | Updates all resource references inside an object. (inherited from ServerConnectionBase)
Public method | UploadPackage | Overridden. Upload a MapGuide Package file to the server
Public method | WriteResource | Writes an object into a resourceID (inherited from ServerConnectionBase)
Top

See Also

HttpServerConnection Class


CopyFolder Method

HttpServerConnection.CopyFolder Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub CopyFolder( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
) _
Implements ServerConnectionI.CopyFolder
C#
public override void CopyFolder(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
virtual void CopyFolder(
String oldpath,
String newpath,
bool overwrite
) override
J#
public override void CopyFolder(
string oldpath,
string newpath,
bool overwrite
)
JScript
public override function CopyFolder(
oldpath : String,
newpath : String,
overwrite : bool
)

Implements

ServerConnectionI.CopyFolder

See Also

HttpServerConnection Class


CopyResource Method

HttpServerConnection.CopyResource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub CopyResource( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
) _
Implements ServerConnectionI.CopyResource
C#
public override void CopyResource(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
virtual void CopyResource(
String oldpath,
String newpath,
bool overwrite
) override
J#
public override void CopyResource(
string oldpath,
string newpath,
bool overwrite
)
JScript
public override function CopyResource(
oldpath : String,
newpath : String,
overwrite : bool
)

Implements

ServerConnectionI.CopyResource

See Also

HttpServerConnection Class


CreateRuntimeMap Method

HttpServerConnection.CreateRuntimeMap Method

Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.

Overload List

 | Name | Description
Public method | CreateRuntimeMap (String, MapDefinition) | Creates a runtime map on the server
Public method | CreateRuntimeMap (String, RuntimeMap) | Creates a runtime map on the server
Public method | CreateRuntimeMap (String, String) | Overridden. Creates a runtime map on the server
Public method | CreateRuntimeMap (String) | Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map. (inherited from ServerConnectionBase)

See Also

HttpServerConnection Class


CreateRuntimeMap Method (String, MapDefinition)

HttpServerConnection.CreateRuntimeMap Method (String, MapDefinition)
See Also Example
[image]

Creates a runtime map on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateRuntimeMap( _
ByVal resourceID As String, _
ByVal map As MapDefinition _
) _
Implements ServerConnectionI.CreateRuntimeMap
C#
public void CreateRuntimeMap(
string resourceID,
MapDefinition map
)
C++
public:
void CreateRuntimeMap(
String resourceID,
MapDefinition map
) sealed
J#
public void CreateRuntimeMap(
string resourceID,
MapDefinition map
)
JScript
public function CreateRuntimeMap(
resourceID : String,
map : MapDefinition
)

Parameters

resourceID
The target resource id for the runtime map
map
The mapdefinition to base the map on

Implements

ServerConnectionI.CreateRuntimeMap

See Also

HttpServerConnection Class
HttpServerConnection.CreateRuntimeMap Overload List


CreateRuntimeMap Method (String, RuntimeMap)

HttpServerConnection.CreateRuntimeMap Method (String, RuntimeMap)
See Also Example
[image]

Creates a runtime map on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateRuntimeMap( _
ByVal resourceID As String, _
ByVal map As RuntimeMap _
) _
Implements ServerConnectionI.CreateRuntimeMap
C#
public void CreateRuntimeMap(
string resourceID,
RuntimeMap map
)
C++
public:
void CreateRuntimeMap(
String resourceID,
RuntimeMap map
) sealed
J#
public void CreateRuntimeMap(
string resourceID,
RuntimeMap map
)
JScript
public function CreateRuntimeMap(
resourceID : String,
map : RuntimeMap
)

Parameters

resourceID
The target resource id for the runtime map
map
The mapdefinition to base the map on

Implements

ServerConnectionI.CreateRuntimeMap

See Also

HttpServerConnection Class
HttpServerConnection.CreateRuntimeMap Overload List


CreateRuntimeMap Method (String, String)

HttpServerConnection.CreateRuntimeMap Method (String, String)
See Also Example
[image]

Creates a runtime map on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub CreateRuntimeMap( _
ByVal resourceID As String, _
ByVal mapdefinition As String _
) _
Implements ServerConnectionI.CreateRuntimeMap
C#
public override void CreateRuntimeMap(
string resourceID,
string mapdefinition
)
C++
public:
virtual void CreateRuntimeMap(
String resourceID,
String mapdefinition
) override
J#
public override void CreateRuntimeMap(
string resourceID,
string mapdefinition
)
JScript
public override function CreateRuntimeMap(
resourceID : String,
mapdefinition : String
)

Parameters

resourceID
The target resource id for the runtime map
mapdefinition
The mapdefinition to base the map on

Implements

ServerConnectionI.CreateRuntimeMap

See Also

HttpServerConnection Class
HttpServerConnection.CreateRuntimeMap Overload List


DeleteFolder Method

HttpServerConnection.DeleteFolder Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteFolder( _
ByVal folderPath As String _
) _
Implements ServerConnectionI.DeleteFolder
C#
public void DeleteFolder(
string folderPath
)
C++
public:
void DeleteFolder(
String folderPath
) sealed
J#
public void DeleteFolder(
string folderPath
)
JScript
public function DeleteFolder(
folderPath : String
)

Implements

ServerConnectionI.DeleteFolder

See Also

HttpServerConnection Class


DeleteResource Method

HttpServerConnection.DeleteResource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub DeleteResource( _
ByVal resourceID As String _
) _
Implements ServerConnectionI.DeleteResource
C#
public override void DeleteResource(
string resourceID
)
C++
public:
virtual void DeleteResource(
String resourceID
) override
J#
public override void DeleteResource(
string resourceID
)
JScript
public override function DeleteResource(
resourceID : String
)

Implements

ServerConnectionI.DeleteResource

See Also

HttpServerConnection Class


DeleteResourceData Method

HttpServerConnection.DeleteResourceData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteResourceData( _
ByVal resourceID As String, _
ByVal dataname As String _
) _
Implements ServerConnectionI.DeleteResourceData
C#
public void DeleteResourceData(
string resourceID,
string dataname
)
C++
public:
void DeleteResourceData(
String resourceID,
String dataname
) sealed
J#
public void DeleteResourceData(
string resourceID,
string dataname
)
JScript
public function DeleteResourceData(
resourceID : String,
dataname : String
)

Implements

ServerConnectionI.DeleteResourceData

See Also

HttpServerConnection Class


DescribeFeatureSource Method

HttpServerConnection.DescribeFeatureSource Method

Overload List

 | Name | Description
Public method | DescribeFeatureSource (String) | Overridden.
Public method | DescribeFeatureSource (String, String) | Overridden.

See Also

HttpServerConnection Class


DescribeFeatureSource Method (String)

HttpServerConnection.DescribeFeatureSource Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function DescribeFeatureSource( _
ByVal resourceID As String _
) As FeatureSourceDescription _
Implements ServerConnectionI.DescribeFeatureSource
C#
public override FeatureSourceDescription DescribeFeatureSource(
string resourceID
)
C++
public:
virtual FeatureSourceDescription DescribeFeatureSource(
String resourceID
) override
J#
public override FeatureSourceDescription DescribeFeatureSource(
string resourceID
)
JScript
public override function DescribeFeatureSource(
resourceID : String
) : FeatureSourceDescription

Implements

ServerConnectionI.DescribeFeatureSource

See Also

HttpServerConnection Class
HttpServerConnection.DescribeFeatureSource Overload List


DescribeFeatureSource Method (String, String)

HttpServerConnection.DescribeFeatureSource Method (String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function DescribeFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String _
) As FeatureSourceDescription _
Implements ServerConnectionI.DescribeFeatureSource
C#
public override FeatureSourceDescription DescribeFeatureSource(
string resourceID,
string schema
)
C++
public:
virtual FeatureSourceDescription DescribeFeatureSource(
String resourceID,
String schema
) override
J#
public override FeatureSourceDescription DescribeFeatureSource(
string resourceID,
string schema
)
JScript
public override function DescribeFeatureSource(
resourceID : String,
schema : String
) : FeatureSourceDescription

Implements

ServerConnectionI.DescribeFeatureSource

See Also

HttpServerConnection Class
HttpServerConnection.DescribeFeatureSource Overload List


DescribeSchema Method

HttpServerConnection.DescribeSchema Method
[image]

Placeholder for actual method call

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub DescribeSchema() _
Implements ServerConnectionI.DescribeSchema
C#
public void DescribeSchema()
C++
public:
void DescribeSchema() sealed
J#
public void DescribeSchema()
JScript
public function DescribeSchema()

Implements

ServerConnectionI.DescribeSchema

See Also

HttpServerConnection Class


Dispose Method

HttpServerConnection.Dispose Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Dispose() _
Implements IDisposable.Dispose
C#
public override void Dispose()
C++
public:
virtual void Dispose() override
J#
public override void Dispose()
JScript
public override function Dispose()

Implements

IDisposable.Dispose

See Also

HttpServerConnection Class


EnumerateGroups Method

HttpServerConnection.EnumerateGroups Method
[image]

Gets a list of all groups on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function EnumerateGroups() As GroupList _
Implements ServerConnectionI.EnumerateGroups
C#
public override GroupList EnumerateGroups()
C++
public:
virtual GroupList EnumerateGroups() override
J#
public override GroupList EnumerateGroups()
JScript
public override function EnumerateGroups() : GroupList

Return Value

The list of groups

Implements

ServerConnectionI.EnumerateGroups

See Also

HttpServerConnection Class


EnumerateResourceData Method

HttpServerConnection.EnumerateResourceData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function EnumerateResourceData( _
ByVal resourceID As String _
) As ResourceDataList _
Implements ServerConnectionI.EnumerateResourceData
C#
public ResourceDataList EnumerateResourceData(
string resourceID
)
C++
public:
ResourceDataList EnumerateResourceData(
String resourceID
) sealed
J#
public ResourceDataList EnumerateResourceData(
string resourceID
)
JScript
public function EnumerateResourceData(
resourceID : String
) : ResourceDataList

Implements

ServerConnectionI.EnumerateResourceData

See Also

HttpServerConnection Class


EnumerateResourceReferences Method

HttpServerConnection.EnumerateResourceReferences Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function EnumerateResourceReferences( _
ByVal resourceid As String _
) As ResourceReferenceList _
Implements ServerConnectionI.EnumerateResourceReferences
C#
public override ResourceReferenceList EnumerateResourceReferences(
string resourceid
)
C++
public:
virtual ResourceReferenceList EnumerateResourceReferences(
String resourceid
) override
J#
public override ResourceReferenceList EnumerateResourceReferences(
string resourceid
)
JScript
public override function EnumerateResourceReferences(
resourceid : String
) : ResourceReferenceList

Implements

ServerConnectionI.EnumerateResourceReferences

See Also

HttpServerConnection Class


EnumerateUnmanagedData Method

HttpServerConnection.EnumerateUnmanagedData Method
[image]

Enumerates all unmanaged folders, meaning alias'ed folders

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function EnumerateUnmanagedData( _
ByVal startpath As String, _
ByVal filter As String, _
ByVal recursive As Boolean, _
ByVal type As UnmanagedDataTypes _
) As UnmanagedDataList _
Implements ServerConnectionI.EnumerateUnmanagedData
C#
public override UnmanagedDataList EnumerateUnmanagedData(
string startpath,
string filter,
bool recursive,
UnmanagedDataTypes type
)
C++
public:
virtual UnmanagedDataList EnumerateUnmanagedData(
String startpath,
String filter,
bool recursive,
UnmanagedDataTypes type
) override
J#
public override UnmanagedDataList EnumerateUnmanagedData(
string startpath,
string filter,
bool recursive,
UnmanagedDataTypes type
)
JScript
public override function EnumerateUnmanagedData(
startpath : String,
filter : String,
recursive : bool,
type : UnmanagedDataTypes
) : UnmanagedDataList

Parameters

startpath
The path to retrieve the data from
filter
A filter applied to the items
recursive
True if the list should contains recursive results
type
The type of data to return

Return Value

A list of unmanaged data

Implements

ServerConnectionI.EnumerateUnmanagedData

See Also

HttpServerConnection Class


EnumerateUsers Method

HttpServerConnection.EnumerateUsers Method

Gets a list of all users on the server

Overload List

 | Name | Description
Public method | EnumerateUsers (String) | Overridden. Gets a list of users in a group
Public method | EnumerateUsers | Gets a list of all users on the server (inherited from ServerConnectionBase)

See Also

HttpServerConnection Class


EnumerateUsers Method (String)

HttpServerConnection.EnumerateUsers Method (String)
See Also Example
[image]

Gets a list of users in a group

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function EnumerateUsers( _
ByVal group As String _
) As UserList _
Implements ServerConnectionI.EnumerateUsers
C#
public override UserList EnumerateUsers(
string group
)
C++
public:
virtual UserList EnumerateUsers(
String group
) override
J#
public override UserList EnumerateUsers(
string group
)
JScript
public override function EnumerateUsers(
group : String
) : UserList

Parameters

group
The group to retrieve the users from

Return Value

The list of users

Implements

ServerConnectionI.EnumerateUsers

See Also

HttpServerConnection Class
HttpServerConnection.EnumerateUsers Overload List


ExecuteOperation Method

HttpServerConnection.ExecuteOperation Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ExecuteOperation( _
ByVal param As NameValueCollection _
) As Stream
C#
public Stream ExecuteOperation(
NameValueCollection param
)
C++
public:
Stream ExecuteOperation(
NameValueCollection param
) sealed
J#
public Stream ExecuteOperation(
NameValueCollection param
)
JScript
public function ExecuteOperation(
param : NameValueCollection
) : Stream

See Also

HttpServerConnection Class


GetApplicationContainers Method

HttpServerConnection.GetApplicationContainers Method
[image]

Returns the avalible widget containers on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetApplicationContainers() As ApplicationDefinitionContainerInfoSet _
Implements ServerConnectionI.GetApplicationContainers
C#
public override ApplicationDefinitionContainerInfoSet GetApplicationContainers()
C++
public:
virtual ApplicationDefinitionContainerInfoSet GetApplicationContainers() override
J#
public override ApplicationDefinitionContainerInfoSet GetApplicationContainers()
JScript
public override function GetApplicationContainers() : ApplicationDefinitionContainerInfoSet

Return Value

The avalible widget containers on the server

Implements

ServerConnectionI.GetApplicationContainers

See Also

HttpServerConnection Class


GetApplicationTemplates Method

HttpServerConnection.GetApplicationTemplates Method
[image]

Returns the avalible application templates on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetApplicationTemplates() As ApplicationDefinitionTemplateInfoSet _
Implements ServerConnectionI.GetApplicationTemplates
C#
public override ApplicationDefinitionTemplateInfoSet GetApplicationTemplates()
C++
public:
virtual ApplicationDefinitionTemplateInfoSet GetApplicationTemplates() override
J#
public override ApplicationDefinitionTemplateInfoSet GetApplicationTemplates()
JScript
public override function GetApplicationTemplates() : ApplicationDefinitionTemplateInfoSet

Return Value

The avalible application templates on the server

Implements

ServerConnectionI.GetApplicationTemplates

See Also

HttpServerConnection Class


GetApplicationWidgets Method

HttpServerConnection.GetApplicationWidgets Method
[image]

Returns the avalible application widgets on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetApplicationWidgets() As ApplicationDefinitionWidgetInfoSet _
Implements ServerConnectionI.GetApplicationWidgets
C#
public override ApplicationDefinitionWidgetInfoSet GetApplicationWidgets()
C++
public:
virtual ApplicationDefinitionWidgetInfoSet GetApplicationWidgets() override
J#
public override ApplicationDefinitionWidgetInfoSet GetApplicationWidgets()
JScript
public override function GetApplicationWidgets() : ApplicationDefinitionWidgetInfoSet

Return Value

The avalible application widgets on the server

Implements

ServerConnectionI.GetApplicationWidgets

See Also

HttpServerConnection Class


GetFolderOrResourceHeader Method

HttpServerConnection.GetFolderOrResourceHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetFolderOrResourceHeader( _
ByVal resourceID As String _
) As Object
C#
public override object GetFolderOrResourceHeader(
string resourceID
)
C++
public:
virtual Object GetFolderOrResourceHeader(
String resourceID
) override
J#
public override object GetFolderOrResourceHeader(
string resourceID
)
JScript
public override function GetFolderOrResourceHeader(
resourceID : String
) : Object

See Also

HttpServerConnection Class


GetIdentityProperties Method

HttpServerConnection.GetIdentityProperties Method
[image]

Gets the names of the identity properties from a feature

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetIdentityProperties( _
ByVal resourceID As String, _
ByVal classname As String _
) As String() _
Implements ServerConnectionI.GetIdentityProperties
C#
public override string[] GetIdentityProperties(
string resourceID,
string classname
)
C++
public:
virtual array<String>^ GetIdentityProperties(
String resourceID,
String classname
) override
J#
public override string[] GetIdentityProperties(
string resourceID,
string classname
)
JScript
public override function GetIdentityProperties(
resourceID : String,
classname : String
) : String[]

Parameters

resourceID
The resourceID for the FeatureSource
classname
The classname of the feature, including schema

Return Value

A string array with the found identities

Implements

ServerConnectionI.GetIdentityProperties

See Also

HttpServerConnection Class


GetLegendImage Method

HttpServerConnection.GetLegendImage Method
[image]

Renders a minature bitmap of the layers style

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetLegendImage( _
ByVal scale As Double, _
ByVal layerdefinition As String, _
ByVal themeIndex As Integer, _
ByVal type As Integer _
) As Image _
Implements ServerConnectionI.GetLegendImage
C#
public override Image GetLegendImage(
double scale,
string layerdefinition,
int themeIndex,
int type
)
C++
public:
virtual Image GetLegendImage(
double scale,
String layerdefinition,
int themeIndex,
int type
) override
J#
public override Image GetLegendImage(
double scale,
string layerdefinition,
int themeIndex,
int type
)
JScript
public override function GetLegendImage(
scale : double,
layerdefinition : String,
themeIndex : int,
type : int
) : Image

Parameters

scale
The scale for the bitmap to match
layerdefinition
The layer the image should represent
themeIndex
If the layer is themed, this gives the theme index, otherwise set to 0
type
The geometry type, 1 for point, 2 for line, 3 for area, 4 for composite

Return Value

The minature bitmap

Implements

ServerConnectionI.GetLegendImage

See Also

HttpServerConnection Class


GetMapDWF Method

HttpServerConnection.GetMapDWF Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMapDWF( _
ByVal resourceID As String _
) As Stream _
Implements ServerConnectionI.GetMapDWF
C#
public Stream GetMapDWF(
string resourceID
)
C++
public:
Stream GetMapDWF(
String resourceID
) sealed
J#
public Stream GetMapDWF(
string resourceID
)
JScript
public function GetMapDWF(
resourceID : String
) : Stream

Implements

ServerConnectionI.GetMapDWF

See Also

HttpServerConnection Class


GetProviderCapabilities Method

HttpServerConnection.GetProviderCapabilities Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetProviderCapabilities( _
ByVal provider As String _
) As FdoProviderCapabilities _
Implements ServerConnectionI.GetProviderCapabilities
C#
public FdoProviderCapabilities GetProviderCapabilities(
string provider
)
C++
public:
FdoProviderCapabilities GetProviderCapabilities(
String provider
) sealed
J#
public FdoProviderCapabilities GetProviderCapabilities(
string provider
)
JScript
public function GetProviderCapabilities(
provider : String
) : FdoProviderCapabilities

Implements

ServerConnectionI.GetProviderCapabilities

See Also

HttpServerConnection Class


GetRepositoryResources Method

HttpServerConnection.GetRepositoryResources Method

Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly.

Overload List

 | Name | Description
Public method | GetRepositoryResources (String, String, Int32) | Overridden.
Public method | GetRepositoryResources | Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly. (inherited from ServerConnectionBase)
Public method | GetRepositoryResources (Int32) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth. (inherited from ServerConnectionBase)
Public method | GetRepositoryResources (String) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth. (inherited from ServerConnectionBase)
Public method | GetRepositoryResources (String, Int32) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth. (inherited from ServerConnectionBase)
Public method | GetRepositoryResources (String, String) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth. (inherited from ServerConnectionBase)

See Also

HttpServerConnection Class


GetRepositoryResources Method (String, String, Int32)

HttpServerConnection.GetRepositoryResources Method (String, String, Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetRepositoryResources( _
ByVal startingpoint As String, _
ByVal type As String, _
ByVal depth As Integer _
) As ResourceList _
Implements ServerConnectionI.GetRepositoryResources
C#
public override ResourceList GetRepositoryResources(
string startingpoint,
string type,
int depth
)
C++
public:
virtual ResourceList GetRepositoryResources(
String startingpoint,
String type,
int depth
) override
J#
public override ResourceList GetRepositoryResources(
string startingpoint,
string type,
int depth
)
JScript
public override function GetRepositoryResources(
startingpoint : String,
type : String,
depth : int
) : ResourceList

Implements

ServerConnectionI.GetRepositoryResources

See Also

HttpServerConnection Class
HttpServerConnection.GetRepositoryResources Overload List


GetResourceData Method

HttpServerConnection.GetResourceData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetResourceData( _
ByVal resourceID As String, _
ByVal dataname As String _
) As MemoryStream _
Implements ServerConnectionI.GetResourceData
C#
public override MemoryStream GetResourceData(
string resourceID,
string dataname
)
C++
public:
virtual MemoryStream GetResourceData(
String resourceID,
String dataname
) override
J#
public override MemoryStream GetResourceData(
string resourceID,
string dataname
)
JScript
public override function GetResourceData(
resourceID : String,
dataname : String
) : MemoryStream

Implements

ServerConnectionI.GetResourceData

See Also

HttpServerConnection Class


GetResourceXmlData Method

HttpServerConnection.GetResourceXmlData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetResourceXmlData( _
ByVal resourceID As String _
) As Byte() _
Implements ServerConnectionI.GetResourceXmlData
C#
public override byte[] GetResourceXmlData(
string resourceID
)
C++
public:
virtual array<char>^ GetResourceXmlData(
String resourceID
) override
J#
public override byte[] GetResourceXmlData(
string resourceID
)
JScript
public override function GetResourceXmlData(
resourceID : String
) : Byte[]

Implements

ServerConnectionI.GetResourceXmlData

See Also

HttpServerConnection Class


GetRuntimeMap Method

HttpServerConnection.GetRuntimeMap Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRuntimeMap( _
ByVal resourceID As String _
) As RuntimeMap _
Implements ServerConnectionI.GetRuntimeMap
C#
public RuntimeMap GetRuntimeMap(
string resourceID
)
C++
public:
RuntimeMap GetRuntimeMap(
String resourceID
) sealed
J#
public RuntimeMap GetRuntimeMap(
string resourceID
)
JScript
public function GetRuntimeMap(
resourceID : String
) : RuntimeMap

Implements

ServerConnectionI.GetRuntimeMap

See Also

HttpServerConnection Class


GetSelectionXml Method

HttpServerConnection.GetSelectionXml Method
[image]

Gets the selection from a map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetSelectionXml( _
ByVal runtimeMap As String _
) As String _
Implements ServerConnectionI.GetSelectionXml
C#
public override string GetSelectionXml(
string runtimeMap
)
C++
public:
virtual String GetSelectionXml(
String runtimeMap
) override
J#
public override string GetSelectionXml(
string runtimeMap
)
JScript
public override function GetSelectionXml(
runtimeMap : String
) : String

Parameters

runtimeMap
The resourceID of the runtime map

Return Value

The selection xml

Implements

ServerConnectionI.GetSelectionXml

See Also

HttpServerConnection Class


GetSpatialContextInfo Method

HttpServerConnection.GetSpatialContextInfo Method
[image]

Returns the spatial info for a given featuresource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetSpatialContextInfo( _
ByVal resourceID As String, _
ByVal activeOnly As Boolean _
) As FdoSpatialContextList _
Implements ServerConnectionI.GetSpatialContextInfo
C#
public override FdoSpatialContextList GetSpatialContextInfo(
string resourceID,
bool activeOnly
)
C++
public:
virtual FdoSpatialContextList GetSpatialContextInfo(
String resourceID,
bool activeOnly
) override
J#
public override FdoSpatialContextList GetSpatialContextInfo(
string resourceID,
bool activeOnly
)
JScript
public override function GetSpatialContextInfo(
resourceID : String,
activeOnly : bool
) : FdoSpatialContextList

Parameters

resourceID
The ID of the resource to query
activeOnly
Query only active items

Return Value

A list of spatial contexts

Implements

ServerConnectionI.GetSpatialContextInfo

See Also

HttpServerConnection Class


IsSessionExpiredException Method

HttpServerConnection.IsSessionExpiredException Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsSessionExpiredException( _
ByVal ex As Exception _
) As Boolean
C#
public override bool IsSessionExpiredException(
Exception ex
)
C++
public:
virtual bool IsSessionExpiredException(
Exception ex
) override
J#
public override bool IsSessionExpiredException(
Exception ex
)
JScript
public override function IsSessionExpiredException(
ex : Exception
) : bool

See Also

HttpServerConnection Class


MoveFolder Method

HttpServerConnection.MoveFolder Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub MoveFolder( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
) _
Implements ServerConnectionI.MoveFolder
C#
public override void MoveFolder(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
virtual void MoveFolder(
String oldpath,
String newpath,
bool overwrite
) override
J#
public override void MoveFolder(
string oldpath,
string newpath,
bool overwrite
)
JScript
public override function MoveFolder(
oldpath : String,
newpath : String,
overwrite : bool
)

Implements

ServerConnectionI.MoveFolder

See Also

HttpServerConnection Class


MoveResource Method

HttpServerConnection.MoveResource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub MoveResource( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
) _
Implements ServerConnectionI.MoveResource
C#
public override void MoveResource(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
virtual void MoveResource(
String oldpath,
String newpath,
bool overwrite
) override
J#
public override void MoveResource(
string oldpath,
string newpath,
bool overwrite
)
JScript
public override function MoveResource(
oldpath : String,
newpath : String,
overwrite : bool
)

Implements

ServerConnectionI.MoveResource

See Also

HttpServerConnection Class


QueryFeatureSource Method

HttpServerConnection.QueryFeatureSource Method

Overload List

 | Name | Description
Public method | QueryFeatureSource (String, String) |
Public method | QueryFeatureSource (String, String, String) |
Public method | QueryFeatureSource (String, String, String, String) |

See Also

HttpServerConnection Class


QueryFeatureSource Method (String, String)

HttpServerConnection.QueryFeatureSource Method (String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function QueryFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String _
) As FeatureSetReader _
Implements ServerConnectionI.QueryFeatureSource
C#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema
)
C++
public:
FeatureSetReader QueryFeatureSource(
String resourceID,
String schema
) sealed
J#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema
)
JScript
public function QueryFeatureSource(
resourceID : String,
schema : String
) : FeatureSetReader

Implements

ServerConnectionI.QueryFeatureSource

See Also

HttpServerConnection Class
HttpServerConnection.QueryFeatureSource Overload List


QueryFeatureSource Method (String, String, String)

HttpServerConnection.QueryFeatureSource Method (String, String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function QueryFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String, _
ByVal query As String _
) As FeatureSetReader _
Implements ServerConnectionI.QueryFeatureSource
C#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query
)
C++
public:
FeatureSetReader QueryFeatureSource(
String resourceID,
String schema,
String query
) sealed
J#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query
)
JScript
public function QueryFeatureSource(
resourceID : String,
schema : String,
query : String
) : FeatureSetReader

Implements

ServerConnectionI.QueryFeatureSource

See Also

HttpServerConnection Class
HttpServerConnection.QueryFeatureSource Overload List


QueryFeatureSource Method (String, String, String, String[])

HttpServerConnection.QueryFeatureSource Method (String, String, String, String[])
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function QueryFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String, _
ByVal query As String, _
ByVal columns As String() _
) As FeatureSetReader _
Implements ServerConnectionI.QueryFeatureSource
C#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query,
string[] columns
)
C++
public:
FeatureSetReader QueryFeatureSource(
String resourceID,
String schema,
String query,
array<String>^ columns
) sealed
J#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query,
string[] columns
)
JScript
public function QueryFeatureSource(
resourceID : String,
schema : String,
query : String,
columns : String[]
) : FeatureSetReader

Implements

ServerConnectionI.QueryFeatureSource

See Also

HttpServerConnection Class
HttpServerConnection.QueryFeatureSource Overload List


QueryMapFeatures Method

HttpServerConnection.QueryMapFeatures Method

Selects features from a runtime map, returning a selection Xml.

Overload List

 | Name | Description
Public method | QueryMapFeatures (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean) | Overridden. Selects features from a runtime map, returning a selection Xml.
Public method | QueryMapFeatures (String, String, Boolean) | Selects features from a runtime map, returning a selection Xml. (inherited from ServerConnectionBase)

See Also

HttpServerConnection Class


QueryMapFeatures Method (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean)

HttpServerConnection.QueryMapFeatures Method (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean)
See Also Example
[image]

Selects features from a runtime map, returning a selection Xml.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function QueryMapFeatures( _
ByVal runtimemap As String, _
ByVal wkt As String, _
ByVal persist As Boolean, _
ByVal attributes As QueryMapFeaturesLayerAttributes, _
ByVal raw As Boolean _
) As String _
Implements ServerConnectionI.QueryMapFeatures
C#
public override string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
)
C++
public:
virtual String QueryMapFeatures(
String runtimemap,
String wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
) override
J#
public override string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
)
JScript
public override function QueryMapFeatures(
runtimemap : String,
wkt : String,
persist : bool,
attributes : QueryMapFeaturesLayerAttributes,
raw : bool
) : String

Parameters

runtimemap
The map to query. NOT a resourceID, only the map name!
wkt
The WKT of the geometry to query with (always uses intersection)
persist
True if the selection should be saved in the runtime map, false otherwise.
attributes
The type of layer to include in the query
raw
True if the result should contain the tooltip and link info

Return Value

The selection Xml, or an empty string if there were no data.

Implements

ServerConnectionI.QueryMapFeatures

See Also

HttpServerConnection Class
HttpServerConnection.QueryMapFeatures Overload List


RenderRuntimeMap Method

HttpServerConnection.RenderRuntimeMap Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function RenderRuntimeMap( _
ByVal resourceId As String, _
ByVal x As Double, _
ByVal y As Double, _
ByVal scale As Double, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal dpi As Integer _
) As Stream _
Implements ServerConnectionI.RenderRuntimeMap
C#
public Stream RenderRuntimeMap(
string resourceId,
double x,
double y,
double scale,
int width,
int height,
int dpi
)
C++
public:
Stream RenderRuntimeMap(
String resourceId,
double x,
double y,
double scale,
int width,
int height,
int dpi
) sealed
J#
public Stream RenderRuntimeMap(
string resourceId,
double x,
double y,
double scale,
int width,
int height,
int dpi
)
JScript
public function RenderRuntimeMap(
resourceId : String,
x : double,
y : double,
scale : double,
width : int,
height : int,
dpi : int
) : Stream

Implements

ServerConnectionI.RenderRuntimeMap

See Also

HttpServerConnection Class


RestartSession Method

HttpServerConnection.RestartSession Method

Restarts the server session, and creates a new session ID

Overload List

 | Name | Description
Public method | RestartSession (Boolean) | Overridden. Restarts the server session, and creates a new session ID
Public method | RestartSession | Restarts the server session, and creates a new session ID (inherited from ServerConnectionBase)

See Also

HttpServerConnection Class


RestartSession Method (Boolean)

HttpServerConnection.RestartSession Method (Boolean)
See Also Example
[image]

Restarts the server session, and creates a new session ID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function RestartSession( _
ByVal throwException As Boolean _
) As Boolean _
Implements ServerConnectionI.RestartSession
C#
public override bool RestartSession(
bool throwException
)
C++
public:
virtual bool RestartSession(
bool throwException
) override
J#
public override bool RestartSession(
bool throwException
)
JScript
public override function RestartSession(
throwException : bool
) : bool

Parameters

throwException
If set to true, the call throws an exception if the call failed

Return Value

True if the creation succeed, false otherwise

Implements

ServerConnectionI.RestartSession

See Also

HttpServerConnection Class
HttpServerConnection.RestartSession Overload List


SaveRuntimeMap Method

HttpServerConnection.SaveRuntimeMap Method
[image]

Updates an existing runtime map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveRuntimeMap( _
ByVal resourceID As String, _
ByVal map As RuntimeMap _
) _
Implements ServerConnectionI.SaveRuntimeMap
C#
public void SaveRuntimeMap(
string resourceID,
RuntimeMap map
)
C++
public:
void SaveRuntimeMap(
String resourceID,
RuntimeMap map
) sealed
J#
public void SaveRuntimeMap(
string resourceID,
RuntimeMap map
)
JScript
public function SaveRuntimeMap(
resourceID : String,
map : RuntimeMap
)

Parameters

resourceID
The target resource id for the runtime map
map
The runtime map to update with

Implements

ServerConnectionI.SaveRuntimeMap

See Also

HttpServerConnection Class


SetResourceData Method

HttpServerConnection.SetResourceData Method

Uploads data to a resource

Overload List

 | Name | Description
Public method | SetResourceData (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate) | Overridden.
Public method | SetResourceData (String, String, ResourceDataType, Stream) | Uploads data to a resource (inherited from ServerConnectionBase)

See Also

HttpServerConnection Class


SetResourceData Method (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate)

HttpServerConnection.SetResourceData Method (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetResourceData( _
ByVal resourceid As String, _
ByVal dataname As String, _
ByVal datatype As ResourceDataType, _
ByVal stream As Stream, _
ByVal callback As Utility.StreamCopyProgressDelegate _
) _
Implements ServerConnectionI.SetResourceData
C#
public override void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
)
C++
public:
virtual void SetResourceData(
String resourceid,
String dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
) override
J#
public override void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
)
JScript
public override function SetResourceData(
resourceid : String,
dataname : String,
datatype : ResourceDataType,
stream : Stream,
callback : Utility.StreamCopyProgressDelegate
)

Implements

ServerConnectionI.SetResourceData

See Also

HttpServerConnection Class
HttpServerConnection.SetResourceData Overload List


SetResourceXmlData Method

HttpServerConnection.SetResourceXmlData Method

Writes raw data into a resource.

Overload List

 | Name | Description
Public method | SetResourceXmlData (String, Stream, Stream) | Overridden.
Public method | SetResourceXmlData (String, Stream) | Writes raw data into a resource. (inherited from ServerConnectionBase)

See Also

HttpServerConnection Class


SetResourceXmlData Method (String, Stream, Stream)

HttpServerConnection.SetResourceXmlData Method (String, Stream, Stream)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetResourceXmlData( _
ByVal resourceid As String, _
ByVal content As Stream, _
ByVal header As Stream _
)
C#
public override void SetResourceXmlData(
string resourceid,
Stream content,
Stream header
)
C++
public:
virtual void SetResourceXmlData(
String resourceid,
Stream content,
Stream header
) override
J#
public override void SetResourceXmlData(
string resourceid,
Stream content,
Stream header
)
JScript
public override function SetResourceXmlData(
resourceid : String,
content : Stream,
header : Stream
)

See Also

HttpServerConnection Class
HttpServerConnection.SetResourceXmlData Overload List


SetSelectionXml Method

HttpServerConnection.SetSelectionXml Method
[image]

Sets the selection of a map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetSelectionXml( _
ByVal runtimeMap As String, _
ByVal selectionXml As String _
) _
Implements ServerConnectionI.SetSelectionXml
C#
public override void SetSelectionXml(
string runtimeMap,
string selectionXml
)
C++
public:
virtual void SetSelectionXml(
String runtimeMap,
String selectionXml
) override
J#
public override void SetSelectionXml(
string runtimeMap,
string selectionXml
)
JScript
public override function SetSelectionXml(
runtimeMap : String,
selectionXml : String
)

Parameters

runtimeMap
The resourceID of the runtime map
selectionXml
The selection xml

Implements

ServerConnectionI.SetSelectionXml

See Also

HttpServerConnection Class


TestConnection Method

HttpServerConnection.TestConnection Method

Overload List

 | Name | Description
Public method | TestConnection (String) | Overridden.
Public method | TestConnection (String, NameValueCollection) |
Public method | TestConnection (FeatureSource) | (inherited from ServerConnectionBase)

See Also

HttpServerConnection Class


TestConnection Method (String)

HttpServerConnection.TestConnection Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function TestConnection( _
ByVal featuresource As String _
) As String _
Implements ServerConnectionI.TestConnection
C#
public override string TestConnection(
string featuresource
)
C++
public:
virtual String TestConnection(
String featuresource
) override
J#
public override string TestConnection(
string featuresource
)
JScript
public override function TestConnection(
featuresource : String
) : String

Implements

ServerConnectionI.TestConnection

See Also

HttpServerConnection Class
HttpServerConnection.TestConnection Overload List


TestConnection Method (String, NameValueCollection)

HttpServerConnection.TestConnection Method (String, NameValueCollection)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function TestConnection( _
ByVal providername As String, _
ByVal parameters As NameValueCollection _
) As String _
Implements ServerConnectionI.TestConnection
C#
public string TestConnection(
string providername,
NameValueCollection parameters
)
C++
public:
String TestConnection(
String providername,
NameValueCollection parameters
) sealed
J#
public string TestConnection(
string providername,
NameValueCollection parameters
)
JScript
public function TestConnection(
providername : String,
parameters : NameValueCollection
) : String

Implements

ServerConnectionI.TestConnection

See Also

HttpServerConnection Class
HttpServerConnection.TestConnection Overload List


UploadPackage Method

HttpServerConnection.UploadPackage Method
[image]

Upload a MapGuide Package file to the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub UploadPackage( _
ByVal filename As String, _
ByVal callback As Utility.StreamCopyProgressDelegate _
) _
Implements ServerConnectionI.UploadPackage
C#
public override void UploadPackage(
string filename,
Utility.StreamCopyProgressDelegate callback
)
C++
public:
virtual void UploadPackage(
String filename,
Utility.StreamCopyProgressDelegate callback
) override
J#
public override void UploadPackage(
string filename,
Utility.StreamCopyProgressDelegate callback
)
JScript
public override function UploadPackage(
filename : String,
callback : Utility.StreamCopyProgressDelegate
)

Parameters

filename
Name of the file to upload
callback
A callback argument used to display progress. May be null.

Implements

ServerConnectionI.UploadPackage

See Also

HttpServerConnection Class


Image Class

Image Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class Image
Inherits GraphicBase
C#
public class Image : GraphicBase
C++
ref class Image : GraphicBase
J#
public class Image extends GraphicBase
JScript
public class Image extends GraphicBase

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GraphicBase
OSGeo.MapGuide.MaestroAPI.Image

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Image Members


Image Members

Image Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by Image.

Public Constructors

 | Name | Description
Public method | Image | Initializes a new instance of the Image class.
Top

Public Properties

 | Name | Description
Public property | Angle |
Public property | ExtendedData1 |
Public property | Item |
Public property | PositionX |
Public property | PositionY |
Public property | ResizeControl | (inherited from GraphicBase)
Public property | SizeScalable |
Public property | SizeX |
Public property | SizeY |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Image Class


Image Constructor

Image Constructor
[image]

Initializes a new instance of the Image class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Image()
C++
public:
Image() sealed
J#
public Image()
JScript
public function Image()

See Also

Image Class


Properties

Image Properties
[image]

Public Properties

 | Name | Description
Public property | Angle |
Public property | ExtendedData1 |
Public property | Item |
Public property | PositionX |
Public property | PositionY |
Public property | ResizeControl | (inherited from GraphicBase)
Public property | SizeScalable |
Public property | SizeX |
Public property | SizeY |
Top

See Also

Image Class


Angle Property

Image.Angle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property Angle As String
C#
[DefaultValueAttribute("0.0")]
public string Angle { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string Angle sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_Angle();

/** property */
public void set_Angle(string value);
JScript
public function get Angle() : String

public function set Angle(value : String);

See Also

Image Class


ExtendedData1 Property

Image.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

Image Class


Item Property

Image.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Content", GetType(Byte_x005B__x005D_), DataType := "base64Binary"), _
XmlElementAttribute("Reference", GetType(ImageReference))>
Public Property Item As Object
C#
[XmlElementAttribute("Content", typeof(Byte_x005B__x005D_), DataType = "base64Binary")]
[XmlElementAttribute("Reference", typeof(ImageReference))]
public object Item { get; set; }
C++
[XmlElementAttribute(L"Content", typeof(Byte_x005B__x005D_), DataType = L"base64Binary")]
[XmlElementAttribute(L"Reference", typeof(ImageReference))]
public property object Item sealed {
Object get();
void set(Object value);
}
J#
/** @attribute XmlElementAttribute("Content", typeof(Byte_x005B__x005D_), DataType = "base64Binary") */
/** @attribute XmlElementAttribute("Reference", typeof(ImageReference)) */
/** property */
public object get_Item();

/** property */
public void set_Item(object value);
JScript
public function get Item() : Object

public function set Item(value : Object);

See Also

Image Class


PositionX Property

Image.PositionX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property PositionX As String
C#
[DefaultValueAttribute("0.0")]
public string PositionX { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string PositionX sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_PositionX();

/** property */
public void set_PositionX(string value);
JScript
public function get PositionX() : String

public function set PositionX(value : String);

See Also

Image Class


PositionY Property

Image.PositionY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property PositionY As String
C#
[DefaultValueAttribute("0.0")]
public string PositionY { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string PositionY sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_PositionY();

/** property */
public void set_PositionY(string value);
JScript
public function get PositionY() : String

public function set PositionY(value : String);

See Also

Image Class


SizeScalable Property

Image.SizeScalable Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("true")>
Public Property SizeScalable As String
C#
[DefaultValueAttribute("true")]
public string SizeScalable { get; set; }
C++
[DefaultValueAttribute(L"true")]
public property string SizeScalable sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("true") */
/** property */
public string get_SizeScalable();

/** property */
public void set_SizeScalable(string value);
JScript
public function get SizeScalable() : String

public function set SizeScalable(value : String);

See Also

Image Class


SizeX Property

Image.SizeX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("1.0")>
Public Property SizeX As String
C#
[DefaultValueAttribute("1.0")]
public string SizeX { get; set; }
C++
[DefaultValueAttribute(L"1.0")]
public property string SizeX sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("1.0") */
/** property */
public string get_SizeX();

/** property */
public void set_SizeX(string value);
JScript
public function get SizeX() : String

public function set SizeX(value : String);

See Also

Image Class


SizeY Property

Image.SizeY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("1.0")>
Public Property SizeY As String
C#
[DefaultValueAttribute("1.0")]
public string SizeY { get; set; }
C++
[DefaultValueAttribute(L"1.0")]
public property string SizeY sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("1.0") */
/** property */
public string get_SizeY();

/** property */
public void set_SizeY(string value);
JScript
public function get SizeY() : String

public function set SizeY(value : String);

See Also

Image Class


ImageReference Class

ImageReference Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ImageReference
C#
public class ImageReference
C++
ref class ImageReference
J#
public class ImageReference
JScript
public class ImageReference

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ImageReference

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ImageReference Members


ImageReference Members

ImageReference Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ImageReference.

Public Constructors

 | Name | Description
Public method | ImageReference | Initializes a new instance of the ImageReference class.
Top

Public Properties

 | Name | Description
Public property | LibraryItemName |
Public property | ResourceId |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ImageReference Class


ImageReference Constructor

ImageReference Constructor
[image]

Initializes a new instance of the ImageReference class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ImageReference()
C++
public:
ImageReference() sealed
J#
public ImageReference()
JScript
public function ImageReference()

See Also

ImageReference Class


Properties

ImageReference Properties
[image]

Public Properties

 | Name | Description
Public property | LibraryItemName |
Public property | ResourceId |
Top

See Also

ImageReference Class


LibraryItemName Property

ImageReference.LibraryItemName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LibraryItemName As String
C#
public string LibraryItemName { get; set; }
C++
public property string LibraryItemName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LibraryItemName();

/** property */
public void set_LibraryItemName(string value);
JScript
public function get LibraryItemName() : String

public function set LibraryItemName(value : String);

See Also

ImageReference Class


ResourceId Property

ImageReference.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceId As String
C#
public string ResourceId { get; set; }
C++
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

ImageReference Class


ImageSymbolType Class

ImageSymbolType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ImageSymbolType
Inherits SymbolType
C#
public class ImageSymbolType : SymbolType
C++
ref class ImageSymbolType : SymbolType
J#
public class ImageSymbolType extends SymbolType
JScript
public class ImageSymbolType extends SymbolType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolType
OSGeo.MapGuide.MaestroAPI.ImageSymbolType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ImageSymbolType Members


ImageSymbolType Members

ImageSymbolType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ImageSymbolType.

Public Constructors

 | Name | Description
Public method | ImageSymbolType | Initializes a new instance of the ImageSymbolType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | Item |
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | Unit | (inherited from SymbolType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ImageSymbolType Class


ImageSymbolType Constructor

ImageSymbolType Constructor
[image]

Initializes a new instance of the ImageSymbolType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ImageSymbolType()
C++
public:
ImageSymbolType() sealed
J#
public ImageSymbolType()
JScript
public function ImageSymbolType()

See Also

ImageSymbolType Class


Properties

ImageSymbolType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | Item |
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | Unit | (inherited from SymbolType)
Top

See Also

ImageSymbolType Class


ExtendedData1 Property

ImageSymbolType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

ImageSymbolType Class


Item Property

ImageSymbolType.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Image", GetType(ImageSymbolTypeImage)), _
XmlElementAttribute("Content", GetType(Byte_x005B__x005D_), DataType := "hexBinary")>
Public Property Item As Object
C#
[XmlElementAttribute("Image", typeof(ImageSymbolTypeImage))]
[XmlElementAttribute("Content", typeof(Byte_x005B__x005D_), DataType = "hexBinary")]
public object Item { get; set; }
C++
[XmlElementAttribute(L"Image", typeof(ImageSymbolTypeImage))]
[XmlElementAttribute(L"Content", typeof(Byte_x005B__x005D_), DataType = L"hexBinary")]
public property object Item sealed {
Object get();
void set(Object value);
}
J#
/** @attribute XmlElementAttribute("Image", typeof(ImageSymbolTypeImage)) */
/** @attribute XmlElementAttribute("Content", typeof(Byte_x005B__x005D_), DataType = "hexBinary") */
/** property */
public object get_Item();

/** property */
public void set_Item(object value);
JScript
public function get Item() : Object

public function set Item(value : Object);

See Also

ImageSymbolType Class


ImageSymbolTypeImage Class

ImageSymbolTypeImage Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ImageSymbolTypeImage
C#
public class ImageSymbolTypeImage
C++
ref class ImageSymbolTypeImage
J#
public class ImageSymbolTypeImage
JScript
public class ImageSymbolTypeImage

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ImageSymbolTypeImage

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ImageSymbolTypeImage Members


ImageSymbolTypeImage Members

ImageSymbolTypeImage Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ImageSymbolTypeImage.

Public Constructors

 | Name | Description
Public method | ImageSymbolTypeImage | Initializes a new instance of the ImageSymbolTypeImage class.
Top

Public Properties

 | Name | Description
Public property | LibraryItemName |
Public property | ResourceId |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ImageSymbolTypeImage Class


ImageSymbolTypeImage Constructor

ImageSymbolTypeImage Constructor
[image]

Initializes a new instance of the ImageSymbolTypeImage class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ImageSymbolTypeImage()
C++
public:
ImageSymbolTypeImage() sealed
J#
public ImageSymbolTypeImage()
JScript
public function ImageSymbolTypeImage()

See Also

ImageSymbolTypeImage Class


Properties

ImageSymbolTypeImage Properties
[image]

Public Properties

 | Name | Description
Public property | LibraryItemName |
Public property | ResourceId |
Top

See Also

ImageSymbolTypeImage Class


LibraryItemName Property

ImageSymbolTypeImage.LibraryItemName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LibraryItemName As Object
C#
public object LibraryItemName { get; set; }
C++
public property object LibraryItemName sealed {
Object get();
void set(Object value);
}
J#
/** property */
public object get_LibraryItemName();

/** property */
public void set_LibraryItemName(object value);
JScript
public function get LibraryItemName() : Object

public function set LibraryItemName(value : Object);

See Also

ImageSymbolTypeImage Class


ResourceId Property

ImageSymbolTypeImage.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceId As Object
C#
public object ResourceId { get; set; }
C++
public property object ResourceId sealed {
Object get();
void set(Object value);
}
J#
/** property */
public object get_ResourceId();

/** property */
public void set_ResourceId(object value);
JScript
public function get ResourceId() : Object

public function set ResourceId(value : Object);

See Also

ImageSymbolTypeImage Class


InformationPaneType Class

InformationPaneType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class InformationPaneType
Inherits WebLayoutResizableControlType
C#
public class InformationPaneType : WebLayoutResizableControlType
C++
ref class InformationPaneType : WebLayoutResizableControlType
J#
public class InformationPaneType extends WebLayoutResizableControlType
JScript
public class InformationPaneType extends WebLayoutResizableControlType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.WebLayoutControlType
OSGeo.MapGuide.MaestroAPI.WebLayoutResizableControlType
OSGeo.MapGuide.MaestroAPI.InformationPaneType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

InformationPaneType Members


InformationPaneType Members

InformationPaneType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by InformationPaneType.

Public Constructors

 | Name | Description
Public method | InformationPaneType | Initializes a new instance of the InformationPaneType class.
Top

Public Properties

 | Name | Description
Public property | LegendVisible |
Public property | PropertiesVisible |
Public property | Visible | (inherited from WebLayoutControlType)
Public property | Width | (inherited from WebLayoutResizableControlType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

InformationPaneType Class


InformationPaneType Constructor

InformationPaneType Constructor
[image]

Initializes a new instance of the InformationPaneType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public InformationPaneType()
C++
public:
InformationPaneType() sealed
J#
public InformationPaneType()
JScript
public function InformationPaneType()

See Also

InformationPaneType Class


Properties

InformationPaneType Properties
[image]

Public Properties

 | Name | Description
Public property | LegendVisible |
Public property | PropertiesVisible |
Public property | Visible | (inherited from WebLayoutControlType)
Public property | Width | (inherited from WebLayoutResizableControlType)
Top

See Also

InformationPaneType Class


LegendVisible Property

InformationPaneType.LegendVisible Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LegendVisible As Boolean
C#
public bool LegendVisible { get; set; }
C++
public property bool LegendVisible sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_LegendVisible();

/** property */
public void set_LegendVisible(bool value);
JScript
public function get LegendVisible() : bool

public function set LegendVisible(value : bool);

See Also

InformationPaneType Class


PropertiesVisible Property

InformationPaneType.PropertiesVisible Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertiesVisible As Boolean
C#
public bool PropertiesVisible { get; set; }
C++
public property bool PropertiesVisible sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_PropertiesVisible();

/** property */
public void set_PropertiesVisible(bool value);
JScript
public function get PropertiesVisible() : bool

public function set PropertiesVisible(value : bool);

See Also

InformationPaneType Class


InvokeScriptCommandType Class

InvokeScriptCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class InvokeScriptCommandType
Inherits CustomCommandType
C#
public class InvokeScriptCommandType : CustomCommandType
C++
ref class InvokeScriptCommandType : CustomCommandType
J#
public class InvokeScriptCommandType extends CustomCommandType
JScript
public class InvokeScriptCommandType extends CustomCommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.InvokeScriptCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

InvokeScriptCommandType Members


InvokeScriptCommandType Members

InvokeScriptCommandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by InvokeScriptCommandType.

Public Constructors

 | Name | Description
Public method | InvokeScriptCommandType | Initializes a new instance of the InvokeScriptCommandType class.
Top

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | Script |
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

InvokeScriptCommandType Class


InvokeScriptCommandType Constructor

InvokeScriptCommandType Constructor
[image]

Initializes a new instance of the InvokeScriptCommandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public InvokeScriptCommandType()
C++
public:
InvokeScriptCommandType() sealed
J#
public InvokeScriptCommandType()
JScript
public function InvokeScriptCommandType()

See Also

InvokeScriptCommandType Class


Properties

InvokeScriptCommandType Properties
[image]

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | Script |
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

See Also

InvokeScriptCommandType Class


Script Property

InvokeScriptCommandType.Script Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Script As String
C#
public string Script { get; set; }
C++
public property string Script sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Script();

/** property */
public void set_Script(string value);
JScript
public function get Script() : String

public function set Script(value : String);

See Also

InvokeScriptCommandType Class


InvokeURLCommandType Class

InvokeURLCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class InvokeURLCommandType
Inherits TargetedCommandType
C#
public class InvokeURLCommandType : TargetedCommandType
C++
ref class InvokeURLCommandType : TargetedCommandType
J#
public class InvokeURLCommandType extends TargetedCommandType
JScript
public class InvokeURLCommandType extends TargetedCommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.TargetedCommandType
OSGeo.MapGuide.MaestroAPI.InvokeURLCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

InvokeURLCommandType Members


InvokeURLCommandType Members

InvokeURLCommandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by InvokeURLCommandType.

Public Constructors

 | Name | Description
Public method | InvokeURLCommandType | Initializes a new instance of the InvokeURLCommandType class.
Top

Public Properties

 | Name | Description
Public property | AdditionalParameter |
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | DisableIfSelectionEmpty |
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | LayerSet |
Public property | Name | (inherited from CommandType)
Public property | Target | (inherited from TargetedCommandType)
Public property | TargetFrame | (inherited from TargetedCommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Public property | URL |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

InvokeURLCommandType Class


InvokeURLCommandType Constructor

InvokeURLCommandType Constructor
[image]

Initializes a new instance of the InvokeURLCommandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public InvokeURLCommandType()
C++
public:
InvokeURLCommandType() sealed
J#
public InvokeURLCommandType()
JScript
public function InvokeURLCommandType()

See Also

InvokeURLCommandType Class


Properties

InvokeURLCommandType Properties
[image]

Public Properties

 | Name | Description
Public property | AdditionalParameter |
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | DisableIfSelectionEmpty |
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | LayerSet |
Public property | Name | (inherited from CommandType)
Public property | Target | (inherited from TargetedCommandType)
Public property | TargetFrame | (inherited from TargetedCommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Public property | URL |
Top

See Also

InvokeURLCommandType Class


AdditionalParameter Property

InvokeURLCommandType.AdditionalParameter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("AdditionalParameter")>
Public Property AdditionalParameter As ParameterPairTypeCollection
C#
[XmlElementAttribute("AdditionalParameter")]
public ParameterPairTypeCollection AdditionalParameter { get; set; }
C++
[XmlElementAttribute(L"AdditionalParameter")]
public property ParameterPairTypeCollection AdditionalParameter sealed {
ParameterPairTypeCollection get();
void set(ParameterPairTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("AdditionalParameter") */
/** property */
public ParameterPairTypeCollection get_AdditionalParameter();

/** property */
public void set_AdditionalParameter(ParameterPairTypeCollection value);
JScript
public function get AdditionalParameter() : ParameterPairTypeCollection

public function set AdditionalParameter(value : ParameterPairTypeCollection);

See Also

InvokeURLCommandType Class


DisableIfSelectionEmpty Property

InvokeURLCommandType.DisableIfSelectionEmpty Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisableIfSelectionEmpty As Boolean
C#
public bool DisableIfSelectionEmpty { get; set; }
C++
public property bool DisableIfSelectionEmpty sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DisableIfSelectionEmpty();

/** property */
public void set_DisableIfSelectionEmpty(bool value);
JScript
public function get DisableIfSelectionEmpty() : bool

public function set DisableIfSelectionEmpty(value : bool);

See Also

InvokeURLCommandType Class


LayerSet Property

InvokeURLCommandType.LayerSet Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Layer", IsNullable := False)>
Public Property LayerSet As StringCollection
C#
[XmlArrayItemAttribute("Layer", IsNullable = False)]
public StringCollection LayerSet { get; set; }
C++
[XmlArrayItemAttribute(L"Layer", IsNullable = False)]
public property StringCollection LayerSet sealed {
StringCollection get();
void set(StringCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Layer", IsNullable = False) */
/** property */
public StringCollection get_LayerSet();

/** property */
public void set_LayerSet(StringCollection value);
JScript
public function get LayerSet() : StringCollection

public function set LayerSet(value : StringCollection);

See Also

InvokeURLCommandType Class


URL Property

InvokeURLCommandType.URL Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property URL As String
C#
public string URL { get; set; }
C++
public property string URL sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_URL();

/** property */
public void set_URL(string value);
JScript
public function get URL() : String

public function set URL(value : String);

See Also

InvokeURLCommandType Class


ItemChoiceType Enumeration

ItemChoiceType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlTypeAttribute(IncludeInSchema := False)>
Public Enum ItemChoiceType
C#
[XmlTypeAttribute(IncludeInSchema = False)]
public enum ItemChoiceType
C++
[XmlTypeAttribute(IncludeInSchema = False)]
public enum class ItemChoiceType
J#
/** @attribute XmlTypeAttribute(IncludeInSchema = False) */
public enum ItemChoiceType
JScript
public enum ItemChoiceType

Members

Member Name | Description
Bands |
Band |
ExplicitColor |

See Also


KnownSiteVersions Enumeration

KnownSiteVersions Enumeration
[image]

This file contains the current known versions of the MapGuide server.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum KnownSiteVersions
C#
public enum KnownSiteVersions
C++
public enum class KnownSiteVersions
J#
public enum KnownSiteVersions
JScript
public enum KnownSiteVersions

Members

Member Name | Description
MapGuideEP1_1 |
MapGuideOS1_1 |
MapGuideOS1_2 |
MapGuideEP1_2 |
MapGuideOS2_0B1 |
MapGuideOS2_0 |
MapGuideEP2009 |

See Also


LayerDefinition Class

LayerDefinition Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class LayerDefinition
Inherits LayerDefinitionType
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class LayerDefinition : LayerDefinitionType
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class LayerDefinition : LayerDefinitionType
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class LayerDefinition extends LayerDefinitionType
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class LayerDefinition extends LayerDefinitionType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LayerDefinitionType
OSGeo.MapGuide.MaestroAPI.LayerDefinition

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LayerDefinition Members


LayerDefinition Members

LayerDefinition Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by LayerDefinition.

Public Constructors

 | Name | Description
Public method | LayerDefinition | Initializes a new instance of the LayerDefinition class.
Top

Public Fields

Name | Description
SchemaName |
SchemaName1_0 |
SchemaName1_1 |
Top

Public Properties

 | Name | Description
Public property | Item | (inherited from LayerDefinitionType)
Public property | ResourceId |
Public property | version |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LayerDefinition Class


LayerDefinition Constructor

LayerDefinition Constructor
[image]

Initializes a new instance of the LayerDefinition class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LayerDefinition()
C++
public:
LayerDefinition() sealed
J#
public LayerDefinition()
JScript
public function LayerDefinition()

See Also

LayerDefinition Class


Fields

LayerDefinition Fields
[image]

Public Fields

Name | Description
SchemaName |
SchemaName1_0 |
SchemaName1_1 |
Top

See Also

LayerDefinition Class


SchemaName Field

LayerDefinition.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

LayerDefinition Class


SchemaName1_0 Field

LayerDefinition.SchemaName1_0 Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName1_0 As String
C#
public static readonly string SchemaName1_0;
C++
public:
static const String SchemaName1_0;
J#
public static final string SchemaName1_0
JScript
public static const var SchemaName1_0 : String;

See Also

LayerDefinition Class


SchemaName1_1 Field

LayerDefinition.SchemaName1_1 Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName1_1 As String
C#
public static readonly string SchemaName1_1;
C++
public:
static const String SchemaName1_1;
J#
public static final string SchemaName1_1
JScript
public static const var SchemaName1_1 : String;

See Also

LayerDefinition Class


Properties

LayerDefinition Properties
[image]

Public Properties

 | Name | Description
Public property | Item | (inherited from LayerDefinitionType)
Public property | ResourceId |
Public property | version |
Public property | XsdSchema |
Top

See Also

LayerDefinition Class


ResourceId Property

LayerDefinition.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ResourceId As String
C#
[XmlIgnoreAttribute]
public string ResourceId { get; set; }
C++
[XmlIgnoreAttribute]
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

LayerDefinition Class


version Property

LayerDefinition.version Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute>
Public Property version As String
C#
[XmlAttributeAttribute]
public string version { get; set; }
C++
[XmlAttributeAttribute]
public property string version sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** property */
public string get_version();

/** property */
public void set_version(string value);
JScript
public function get version() : String

public function set version(value : String);

See Also

LayerDefinition Class


XsdSchema Property

LayerDefinition.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

LayerDefinition Class


LayerDefinitionType Class

LayerDefinitionType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(LayerDefinition))>
Public Class LayerDefinitionType
C#
[XmlIncludeAttribute(typeof(LayerDefinition))]
public class LayerDefinitionType
C++
[XmlIncludeAttribute(typeof(LayerDefinition))]
ref class LayerDefinitionType
J#
/** @attribute XmlIncludeAttribute(typeof(LayerDefinition)) */
public class LayerDefinitionType
JScript
public
XmlIncludeAttribute(typeof(LayerDefinition))
class LayerDefinitionType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LayerDefinitionType
OSGeo.MapGuide.MaestroAPI.LayerDefinition

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LayerDefinitionType Members


LayerDefinitionType Members

LayerDefinitionType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by LayerDefinitionType.

Public Constructors

 | Name | Description
Public method | LayerDefinitionType | Initializes a new instance of the LayerDefinitionType class.
Top

Public Properties

 | Name | Description
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LayerDefinitionType Class


LayerDefinitionType Constructor

LayerDefinitionType Constructor
[image]

Initializes a new instance of the LayerDefinitionType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LayerDefinitionType()
C++
public:
LayerDefinitionType() sealed
J#
public LayerDefinitionType()
JScript
public function LayerDefinitionType()

See Also

LayerDefinitionType Class


Properties

LayerDefinitionType Properties
[image]

Public Properties

 | Name | Description
Public property | Item |
Top

See Also

LayerDefinitionType Class


Item Property

LayerDefinitionType.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("GridLayerDefinition", GetType(GridLayerDefinitionType)), _
XmlElementAttribute("DrawingLayerDefinition", GetType(DrawingLayerDefinitionType)), _
XmlElementAttribute("VectorLayerDefinition", GetType(VectorLayerDefinitionType))>
Public Property Item As BaseLayerDefinitionType
C#
[XmlElementAttribute("GridLayerDefinition", typeof(GridLayerDefinitionType))]
[XmlElementAttribute("DrawingLayerDefinition", typeof(DrawingLayerDefinitionType))]
[XmlElementAttribute("VectorLayerDefinition", typeof(VectorLayerDefinitionType))]
public BaseLayerDefinitionType Item { get; set; }
C++
[XmlElementAttribute(L"GridLayerDefinition", typeof(GridLayerDefinitionType))]
[XmlElementAttribute(L"DrawingLayerDefinition", typeof(DrawingLayerDefinitionType))]
[XmlElementAttribute(L"VectorLayerDefinition", typeof(VectorLayerDefinitionType))]
public property BaseLayerDefinitionType Item sealed {
BaseLayerDefinitionType get();
void set(BaseLayerDefinitionType value);
}
J#
/** @attribute XmlElementAttribute("GridLayerDefinition", typeof(GridLayerDefinitionType)) */
/** @attribute XmlElementAttribute("DrawingLayerDefinition", typeof(DrawingLayerDefinitionType)) */
/** @attribute XmlElementAttribute("VectorLayerDefinition", typeof(VectorLayerDefinitionType)) */
/** property */
public BaseLayerDefinitionType get_Item();

/** property */
public void set_Item(BaseLayerDefinitionType value);
JScript
public function get Item() : BaseLayerDefinitionType

public function set Item(value : BaseLayerDefinitionType);

See Also

LayerDefinitionType Class


LengthUnitType Enumeration

LengthUnitType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum LengthUnitType
C#
public enum LengthUnitType
C++
public enum class LengthUnitType
J#
public enum LengthUnitType
JScript
public enum LengthUnitType

Members

Member Name | Description
Millimeters |
Centimeters |
Meters |
Kilometers |
Inches |
Feet |
Yards |
Miles |
Points |

See Also


LengthyOperationCallBack Delegate

LengthyOperationCallBack Delegate
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub LengthyOperationCallBack( _
ByVal sender As Object, _
ByVal items As LengthyOperationCallbackArgs _
)
C#
public delegate void LengthyOperationCallBack(
object sender,
LengthyOperationCallbackArgs items
)
C++
public delegate void LengthyOperationCallBack(
Object sender,
LengthyOperationCallbackArgs items
)
J#
/** delegate */
public delegate void LengthyOperationCallBack(
object sender,
LengthyOperationCallbackArgs items
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also


LengthyOperationCallbackArgs Class

LengthyOperationCallbackArgs Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class LengthyOperationCallbackArgs
C#
public class LengthyOperationCallbackArgs
C++
ref class LengthyOperationCallbackArgs
J#
public class LengthyOperationCallbackArgs
JScript
public class LengthyOperationCallbackArgs

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LengthyOperationCallbackArgs

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LengthyOperationCallbackArgs Members


LengthyOperationCallbackArgs Members

LengthyOperationCallbackArgs Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by LengthyOperationCallbackArgs.

Public Constructors

 | Name | Description
Public method | LengthyOperationCallbackArgs |
Top

Public Properties

 | Name | Description
Public property | Cancel |
Public property | Index |
Public property | Items |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LengthyOperationCallbackArgs Class


LengthyOperationCallbackArgs Constructor

LengthyOperationCallbackArgs Constructor
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal items As LengthyOperationCallbackArgs.LengthyOperationItem() _
)
C#
public LengthyOperationCallbackArgs(
LengthyOperationCallbackArgs.LengthyOperationItem[] items
)
C++
public:
LengthyOperationCallbackArgs(
array<LengthyOperationCallbackArgs.LengthyOperationItem>^ items
) sealed
J#
public LengthyOperationCallbackArgs(
LengthyOperationCallbackArgs.LengthyOperationItem[] items
)
JScript
public function LengthyOperationCallbackArgs(
items : LengthyOperationCallbackArgs.LengthyOperationItem[]
)

See Also

LengthyOperationCallbackArgs Class


Properties

LengthyOperationCallbackArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Cancel |
Public property | Index |
Public property | Items |
Top

See Also

LengthyOperationCallbackArgs Class


Cancel Property

LengthyOperationCallbackArgs.Cancel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel { get; set; }
C++
public property bool Cancel sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Cancel();

/** property */
public void set_Cancel(bool value);
JScript
public function get Cancel() : bool

public function set Cancel(value : bool);

See Also

LengthyOperationCallbackArgs Class


Index Property

LengthyOperationCallbackArgs.Index Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Index As Integer
C#
public int Index { get; set; }
C++
public property int Index sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Index();

/** property */
public void set_Index(int value);
JScript
public function get Index() : int

public function set Index(value : int);

See Also

LengthyOperationCallbackArgs Class


Items Property

LengthyOperationCallbackArgs.Items Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Items As LengthyOperationCallbackArgs.LengthyOperationItem()
C#
public LengthyOperationCallbackArgs.LengthyOperationItem[] Items { get; }
C++
public property LengthyOperationCallbackArgs.LengthyOperationItem[] Items sealed {
array<LengthyOperationCallbackArgs.LengthyOperationItem>^ get();
}
J#
/** property */
public LengthyOperationCallbackArgs.LengthyOperationItem[] get_Items();
JScript
public function get Items() : LengthyOperationCallbackArgs.LengthyOperationItem[]

See Also

LengthyOperationCallbackArgs Class


LengthyOperationCallbackArgs.LengthyOperationItem Class

LengthyOperationCallbackArgs.LengthyOperationItem Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class LengthyOperationCallbackArgs.LengthyOperationItem
C#
public class LengthyOperationCallbackArgs.LengthyOperationItem
C++
ref class LengthyOperationCallbackArgs.LengthyOperationItem
J#
public class LengthyOperationCallbackArgs.LengthyOperationItem
JScript
public class LengthyOperationCallbackArgs.LengthyOperationItem

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LengthyOperationCallbackArgs.LengthyOperationItem

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LengthyOperationCallbackArgs.LengthyOperationItem Members


LengthyOperationCallbackArgs.LengthyOperationItem Members

LengthyOperationCallbackArgs.LengthyOperationItem Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by LengthyOperationCallbackArgs.LengthyOperationItem.

Public Constructors

 | Name | Description
Public method | LengthyOperationCallbackArgs.LengthyOperationItem |
Top

Public Properties

 | Name | Description
Public property | Itempath |
Public property | Status |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LengthyOperationCallbackArgs.LengthyOperationItem Class


LengthyOperationCallbackArgs.LengthyOperationItem Constructor

LengthyOperationCallbackArgs.LengthyOperationItem Constructor
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal path As String _
)
C#
public LengthyOperationCallbackArgs.LengthyOperationItem(
string path
)
C++
public:
LengthyOperationCallbackArgs.LengthyOperationItem(
String path
) sealed
J#
public LengthyOperationCallbackArgs.LengthyOperationItem(
string path
)
JScript
public function LengthyOperationCallbackArgs.LengthyOperationItem(
path : String
)

See Also

LengthyOperationCallbackArgs.LengthyOperationItem Class


Properties

LengthyOperationCallbackArgs.LengthyOperationItem Properties
[image]

Public Properties

 | Name | Description
Public property | Itempath |
Public property | Status |
Top

See Also

LengthyOperationCallbackArgs.LengthyOperationItem Class


Itempath Property

LengthyOperationCallbackArgs.LengthyOperationItem.Itempath Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Itempath As String
C#
public string Itempath { get; }
C++
public property string Itempath sealed {
String get();
}
J#
/** property */
public string get_Itempath();
JScript
public function get Itempath() : String

See Also

LengthyOperationCallbackArgs.LengthyOperationItem Class


Status Property

LengthyOperationCallbackArgs.LengthyOperationItem.Status Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus
C#
public LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus Status { get; set; }
C++
public property LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus Status sealed {
LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus get();
void set(LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus value);
}
J#
/** property */
public LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus get_Status();

/** property */
public void set_Status(LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus value);
JScript
public function get Status() : LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus

public function set Status(value : LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus);

See Also

LengthyOperationCallbackArgs.LengthyOperationItem Class


LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus Enumeration

LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus Enumeration
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus
C#
public enum LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus
C++
public enum class LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus
J#
public enum LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus
JScript
public enum LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus

Members

Member Name | Description
None |
Pending |
Success |
Failure |

See Also


LengthyOperationProgressArgs Class

LengthyOperationProgressArgs Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class LengthyOperationProgressArgs
C#
public class LengthyOperationProgressArgs
C++
ref class LengthyOperationProgressArgs
J#
public class LengthyOperationProgressArgs
JScript
public class LengthyOperationProgressArgs

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LengthyOperationProgressArgs

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LengthyOperationProgressArgs Members


LengthyOperationProgressArgs Members

LengthyOperationProgressArgs Members
See Also Example Constructors Fields Methods
[image]

The following tables list the members exposed by LengthyOperationProgressArgs.

Public Constructors

 | Name | Description
Public method | LengthyOperationProgressArgs |
Top

Public Fields

 | Name | Description
Public field | Cancel |
Public field | Progress |
Public field | StatusMessage |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LengthyOperationProgressArgs Class


LengthyOperationProgressArgs Constructor

LengthyOperationProgressArgs Constructor
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal message As String, _
ByVal progress As Integer _
)
C#
public LengthyOperationProgressArgs(
string message,
int progress
)
C++
public:
LengthyOperationProgressArgs(
String message,
int progress
) sealed
J#
public LengthyOperationProgressArgs(
string message,
int progress
)
JScript
public function LengthyOperationProgressArgs(
message : String,
progress : int
)

See Also

LengthyOperationProgressArgs Class


Fields

LengthyOperationProgressArgs Fields
[image]

Public Fields

 | Name | Description
Public field | Cancel |
Public field | Progress |
Public field | StatusMessage |
Top

See Also

LengthyOperationProgressArgs Class


Cancel Field

LengthyOperationProgressArgs.Cancel Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Cancel As Boolean
C#
public bool Cancel;
C++
public:
bool Cancel sealed ;
J#
public bool Cancel
JScript
public Cancel : bool;

See Also

LengthyOperationProgressArgs Class


Progress Field

LengthyOperationProgressArgs.Progress Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Progress As Integer
C#
public int Progress;
C++
public:
int Progress sealed ;
J#
public int Progress
JScript
public Progress : int;

See Also

LengthyOperationProgressArgs Class


StatusMessage Field

LengthyOperationProgressArgs.StatusMessage Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public StatusMessage As String
C#
public string StatusMessage;
C++
public:
String StatusMessage sealed ;
J#
public string StatusMessage
JScript
public StatusMessage : String;

See Also

LengthyOperationProgressArgs Class


LengthyOperationProgressCallBack Delegate

LengthyOperationProgressCallBack Delegate
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub LengthyOperationProgressCallBack( _
ByVal sender As Object, _
ByVal e As LengthyOperationProgressArgs _
)
C#
public delegate void LengthyOperationProgressCallBack(
object sender,
LengthyOperationProgressArgs e
)
C++
public delegate void LengthyOperationProgressCallBack(
Object sender,
LengthyOperationProgressArgs e
)
J#
/** delegate */
public delegate void LengthyOperationProgressCallBack(
object sender,
LengthyOperationProgressArgs e
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also


LineRuleType Class

LineRuleType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class LineRuleType
C#
public class LineRuleType
C++
ref class LineRuleType
J#
public class LineRuleType
JScript
public class LineRuleType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LineRuleType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LineRuleType Members


LineRuleType Members

LineRuleType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by LineRuleType.

Public Constructors

 | Name | Description
Public method | LineRuleType | Initializes a new instance of the LineRuleType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Filter |
Public property | Items |
Public property | Label |
Public property | LegendLabel |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LineRuleType Class


LineRuleType Constructor

LineRuleType Constructor
[image]

Initializes a new instance of the LineRuleType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LineRuleType()
C++
public:
LineRuleType() sealed
J#
public LineRuleType()
JScript
public function LineRuleType()

See Also

LineRuleType Class


Properties

LineRuleType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Filter |
Public property | Items |
Public property | Label |
Public property | LegendLabel |
Top

See Also

LineRuleType Class


ExtendedData1 Property

LineRuleType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

LineRuleType Class


Filter Property

LineRuleType.Filter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; set; }
C++
public property string Filter sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Filter();

/** property */
public void set_Filter(string value);
JScript
public function get Filter() : String

public function set Filter(value : String);

See Also

LineRuleType Class


Items Property

LineRuleType.Items Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("LineSymbolization2D")>
Public Property Items As StrokeTypeCollection
C#
[XmlElementAttribute("LineSymbolization2D")]
public StrokeTypeCollection Items { get; set; }
C++
[XmlElementAttribute(L"LineSymbolization2D")]
public property StrokeTypeCollection Items sealed {
StrokeTypeCollection get();
void set(StrokeTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("LineSymbolization2D") */
/** property */
public StrokeTypeCollection get_Items();

/** property */
public void set_Items(StrokeTypeCollection value);
JScript
public function get Items() : StrokeTypeCollection

public function set Items(value : StrokeTypeCollection);

See Also

LineRuleType Class


Label Property

LineRuleType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As TextSymbolType
C#
public TextSymbolType Label { get; set; }
C++
public property TextSymbolType Label sealed {
TextSymbolType get();
void set(TextSymbolType value);
}
J#
/** property */
public TextSymbolType get_Label();

/** property */
public void set_Label(TextSymbolType value);
JScript
public function get Label() : TextSymbolType

public function set Label(value : TextSymbolType);

See Also

LineRuleType Class


LegendLabel Property

LineRuleType.LegendLabel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LegendLabel As String
C#
public string LegendLabel { get; set; }
C++
public property string LegendLabel sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LegendLabel();

/** property */
public void set_LegendLabel(string value);
JScript
public function get LegendLabel() : String

public function set LegendLabel(value : String);

See Also

LineRuleType Class


LineRuleTypeCollection Class

LineRuleTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class LineRuleTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class LineRuleTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class LineRuleTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class LineRuleTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class LineRuleTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.LineRuleTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LineRuleTypeCollection Members


LineRuleTypeCollection Members

LineRuleTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by LineRuleTypeCollection.

Public Constructors

 | Name | Description
Public method | LineRuleTypeCollection | Initializes a new instance of the LineRuleTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LineRuleTypeCollection Class


LineRuleTypeCollection Constructor

LineRuleTypeCollection Constructor
[image]

Initializes a new instance of the LineRuleTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LineRuleTypeCollection()
C++
public:
LineRuleTypeCollection() sealed
J#
public LineRuleTypeCollection()
JScript
public function LineRuleTypeCollection()

See Also

LineRuleTypeCollection Class


Properties

LineRuleTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

LineRuleTypeCollection Class


Item Property

LineRuleTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As LineRuleType
C#
public LineRuleType this[
int idx
] { get; set; }
C++
public property LineRuleType default[int idx] sealed {
LineRuleType get(int idx);
void set(int idx, LineRuleType value);
}
J#
/** property */
public LineRuleType get_Item(int idx);

/** property */
public void set_Item(int idx, LineRuleType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

LineRuleTypeCollection Class


Methods

LineRuleTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LineRuleTypeCollection Class


Add Method

LineRuleTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As LineRuleType _
) As Integer
C#
public int Add(
LineRuleType value
)
C++
public:
int Add(
LineRuleType value
) sealed
J#
public int Add(
LineRuleType value
)
JScript
public function Add(
value : LineRuleType
) : int

See Also

LineRuleTypeCollection Class


LineTypeStyleType Class

LineTypeStyleType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class LineTypeStyleType
C#
public class LineTypeStyleType
C++
ref class LineTypeStyleType
J#
public class LineTypeStyleType
JScript
public class LineTypeStyleType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LineTypeStyleType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LineTypeStyleType Members


LineTypeStyleType Members

LineTypeStyleType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by LineTypeStyleType.

Public Constructors

 | Name | Description
Public method | LineTypeStyleType | Initializes a new instance of the LineTypeStyleType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | LineRule |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LineTypeStyleType Class


LineTypeStyleType Constructor

LineTypeStyleType Constructor
[image]

Initializes a new instance of the LineTypeStyleType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LineTypeStyleType()
C++
public:
LineTypeStyleType() sealed
J#
public LineTypeStyleType()
JScript
public function LineTypeStyleType()

See Also

LineTypeStyleType Class


Properties

LineTypeStyleType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | LineRule |
Top

See Also

LineTypeStyleType Class


ExtendedData1 Property

LineTypeStyleType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

LineTypeStyleType Class


LineRule Property

LineTypeStyleType.LineRule Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("LineRule")>
Public Property LineRule As LineRuleTypeCollection
C#
[XmlElementAttribute("LineRule")]
public LineRuleTypeCollection LineRule { get; set; }
C++
[XmlElementAttribute(L"LineRule")]
public property LineRuleTypeCollection LineRule sealed {
LineRuleTypeCollection get();
void set(LineRuleTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("LineRule") */
/** property */
public LineRuleTypeCollection get_LineRule();

/** property */
public void set_LineRule(LineRuleTypeCollection value);
JScript
public function get LineRule() : LineRuleTypeCollection

public function set LineRule(value : LineRuleTypeCollection);

See Also

LineTypeStyleType Class


LineUsage Class

LineUsage Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class LineUsage
C#
public class LineUsage
C++
ref class LineUsage
J#
public class LineUsage
JScript
public class LineUsage

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LineUsage

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LineUsage Members


LineUsage Members

LineUsage Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by LineUsage.

Public Constructors

 | Name | Description
Public method | LineUsage | Initializes a new instance of the LineUsage class.
Top

Public Properties

 | Name | Description
Public property | Angle |
Public property | AngleControl |
Public property | DefaultPath |
Public property | EndOffset |
Public property | ExtendedData1 |
Public property | Repeat |
Public property | StartOffset |
Public property | UnitsControl |
Public property | VertexAngleLimit |
Public property | VertexControl |
Public property | VertexJoin |
Public property | VertexMiterLimit |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LineUsage Class


LineUsage Constructor

LineUsage Constructor
[image]

Initializes a new instance of the LineUsage class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LineUsage()
C++
public:
LineUsage() sealed
J#
public LineUsage()
JScript
public function LineUsage()

See Also

LineUsage Class


Properties

LineUsage Properties
[image]

Public Properties

 | Name | Description
Public property | Angle |
Public property | AngleControl |
Public property | DefaultPath |
Public property | EndOffset |
Public property | ExtendedData1 |
Public property | Repeat |
Public property | StartOffset |
Public property | UnitsControl |
Public property | VertexAngleLimit |
Public property | VertexControl |
Public property | VertexJoin |
Public property | VertexMiterLimit |
Top

See Also

LineUsage Class


Angle Property

LineUsage.Angle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property Angle As String
C#
[DefaultValueAttribute("0.0")]
public string Angle { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string Angle sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_Angle();

/** property */
public void set_Angle(string value);
JScript
public function get Angle() : String

public function set Angle(value : String);

See Also

LineUsage Class


AngleControl Property

LineUsage.AngleControl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'FromGeometry'")>
Public Property AngleControl As String
C#
[DefaultValueAttribute("'FromGeometry'")]
public string AngleControl { get; set; }
C++
[DefaultValueAttribute(L"'FromGeometry'")]
public property string AngleControl sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'FromGeometry'") */
/** property */
public string get_AngleControl();

/** property */
public void set_AngleControl(string value);
JScript
public function get AngleControl() : String

public function set AngleControl(value : String);

See Also

LineUsage Class


DefaultPath Property

LineUsage.DefaultPath Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultPath As Path
C#
public Path DefaultPath { get; set; }
C++
public property Path DefaultPath sealed {
Path get();
void set(Path value);
}
J#
/** property */
public Path get_DefaultPath();

/** property */
public void set_DefaultPath(Path value);
JScript
public function get DefaultPath() : Path

public function set DefaultPath(value : Path);

See Also

LineUsage Class


EndOffset Property

LineUsage.EndOffset Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property EndOffset As String
C#
public string EndOffset { get; set; }
C++
public property string EndOffset sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_EndOffset();

/** property */
public void set_EndOffset(string value);
JScript
public function get EndOffset() : String

public function set EndOffset(value : String);

See Also

LineUsage Class


ExtendedData1 Property

LineUsage.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

LineUsage Class


Repeat Property

LineUsage.Repeat Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property Repeat As String
C#
[DefaultValueAttribute("0.0")]
public string Repeat { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string Repeat sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_Repeat();

/** property */
public void set_Repeat(string value);
JScript
public function get Repeat() : String

public function set Repeat(value : String);

See Also

LineUsage Class


StartOffset Property

LineUsage.StartOffset Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property StartOffset As String
C#
public string StartOffset { get; set; }
C++
public property string StartOffset sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_StartOffset();

/** property */
public void set_StartOffset(string value);
JScript
public function get StartOffset() : String

public function set StartOffset(value : String);

See Also

LineUsage Class


UnitsControl Property

LineUsage.UnitsControl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'Absolute'")>
Public Property UnitsControl As String
C#
[DefaultValueAttribute("'Absolute'")]
public string UnitsControl { get; set; }
C++
[DefaultValueAttribute(L"'Absolute'")]
public property string UnitsControl sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'Absolute'") */
/** property */
public string get_UnitsControl();

/** property */
public void set_UnitsControl(string value);
JScript
public function get UnitsControl() : String

public function set UnitsControl(value : String);

See Also

LineUsage Class


VertexAngleLimit Property

LineUsage.VertexAngleLimit Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property VertexAngleLimit As String
C#
[DefaultValueAttribute("0.0")]
public string VertexAngleLimit { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string VertexAngleLimit sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_VertexAngleLimit();

/** property */
public void set_VertexAngleLimit(string value);
JScript
public function get VertexAngleLimit() : String

public function set VertexAngleLimit(value : String);

See Also

LineUsage Class


VertexControl Property

LineUsage.VertexControl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'OverlapNone'")>
Public Property VertexControl As String
C#
[DefaultValueAttribute("'OverlapNone'")]
public string VertexControl { get; set; }
C++
[DefaultValueAttribute(L"'OverlapNone'")]
public property string VertexControl sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'OverlapNone'") */
/** property */
public string get_VertexControl();

/** property */
public void set_VertexControl(string value);
JScript
public function get VertexControl() : String

public function set VertexControl(value : String);

See Also

LineUsage Class


VertexJoin Property

LineUsage.VertexJoin Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'Round'")>
Public Property VertexJoin As String
C#
[DefaultValueAttribute("'Round'")]
public string VertexJoin { get; set; }
C++
[DefaultValueAttribute(L"'Round'")]
public property string VertexJoin sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'Round'") */
/** property */
public string get_VertexJoin();

/** property */
public void set_VertexJoin(string value);
JScript
public function get VertexJoin() : String

public function set VertexJoin(value : String);

See Also

LineUsage Class


VertexMiterLimit Property

LineUsage.VertexMiterLimit Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("5.0")>
Public Property VertexMiterLimit As String
C#
[DefaultValueAttribute("5.0")]
public string VertexMiterLimit { get; set; }
C++
[DefaultValueAttribute(L"5.0")]
public property string VertexMiterLimit sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("5.0") */
/** property */
public string get_VertexMiterLimit();

/** property */
public void set_VertexMiterLimit(string value);
JScript
public function get VertexMiterLimit() : String

public function set VertexMiterLimit(value : String);

See Also

LineUsage Class


LoadProcedure Class

LoadProcedure Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class LoadProcedure
Inherits LoadProcedureTypeType
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class LoadProcedure : LoadProcedureTypeType
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class LoadProcedure : LoadProcedureTypeType
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class LoadProcedure extends LoadProcedureTypeType
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class LoadProcedure extends LoadProcedureTypeType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LoadProcedureTypeType
OSGeo.MapGuide.MaestroAPI.LoadProcedure

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LoadProcedure Members


LoadProcedure Members

LoadProcedure Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by LoadProcedure.

Public Constructors

 | Name | Description
Public method | LoadProcedure | Initializes a new instance of the LoadProcedure class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Item | (inherited from LoadProcedureTypeType)
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LoadProcedure Class


LoadProcedure Constructor

LoadProcedure Constructor
[image]

Initializes a new instance of the LoadProcedure class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LoadProcedure()
C++
public:
LoadProcedure() sealed
J#
public LoadProcedure()
JScript
public function LoadProcedure()

See Also

LoadProcedure Class


Fields

LoadProcedure Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

LoadProcedure Class


SchemaName Field

LoadProcedure.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

LoadProcedure Class


Properties

LoadProcedure Properties
[image]

Public Properties

 | Name | Description
Public property | Item | (inherited from LoadProcedureTypeType)
Public property | XsdSchema |
Top

See Also

LoadProcedure Class


XsdSchema Property

LoadProcedure.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

LoadProcedure Class


LoadProcedureType Class

LoadProcedureType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(DwfLoadProcedureType)), _
XmlIncludeAttribute(GetType(RasterLoadProcedureType)), _
XmlIncludeAttribute(GetType(DwgLoadProcedureType)), _
XmlIncludeAttribute(GetType(SdfLoadProcedureType)), _
XmlIncludeAttribute(GetType(ShpLoadProcedureType))>
Public Class LoadProcedureType
C#
[XmlIncludeAttribute(typeof(DwfLoadProcedureType))]
[XmlIncludeAttribute(typeof(RasterLoadProcedureType))]
[XmlIncludeAttribute(typeof(DwgLoadProcedureType))]
[XmlIncludeAttribute(typeof(SdfLoadProcedureType))]
[XmlIncludeAttribute(typeof(ShpLoadProcedureType))]
public class LoadProcedureType
C++
[XmlIncludeAttribute(typeof(DwfLoadProcedureType))]
[XmlIncludeAttribute(typeof(RasterLoadProcedureType))]
[XmlIncludeAttribute(typeof(DwgLoadProcedureType))]
[XmlIncludeAttribute(typeof(SdfLoadProcedureType))]
[XmlIncludeAttribute(typeof(ShpLoadProcedureType))]
ref class LoadProcedureType
J#
/** @attribute XmlIncludeAttribute(typeof(DwfLoadProcedureType)) */
/** @attribute XmlIncludeAttribute(typeof(RasterLoadProcedureType)) */
/** @attribute XmlIncludeAttribute(typeof(DwgLoadProcedureType)) */
/** @attribute XmlIncludeAttribute(typeof(SdfLoadProcedureType)) */
/** @attribute XmlIncludeAttribute(typeof(ShpLoadProcedureType)) */
public class LoadProcedureType
JScript
public
XmlIncludeAttribute(typeof(DwfLoadProcedureType))
XmlIncludeAttribute(typeof(RasterLoadProcedureType))
XmlIncludeAttribute(typeof(DwgLoadProcedureType))
XmlIncludeAttribute(typeof(SdfLoadProcedureType))
XmlIncludeAttribute(typeof(ShpLoadProcedureType))
class LoadProcedureType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LoadProcedureType
OSGeo.MapGuide.MaestroAPI.DwfLoadProcedureType
OSGeo.MapGuide.MaestroAPI.DwgLoadProcedureType
OSGeo.MapGuide.MaestroAPI.RasterLoadProcedureType
OSGeo.MapGuide.MaestroAPI.SdfLoadProcedureType
OSGeo.MapGuide.MaestroAPI.ShpLoadProcedureType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LoadProcedureType Members


LoadProcedureType Members

LoadProcedureType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by LoadProcedureType.

Public Constructors

 | Name | Description
Public method | LoadProcedureType | Initializes a new instance of the LoadProcedureType class.
Top

Public Properties

 | Name | Description
Public property | CoordinateSystem |
Public property | GenerateLayers |
Public property | GenerateMaps |
Public property | GenerateMapsSpecified |
Public property | GenerateSpatialDataSources |
Public property | GenerateSymbolLibraries |
Public property | GenerateSymbolLibrariesSpecified |
Public property | LayersFolder |
Public property | LayersPath |
Public property | MapsFolder |
Public property | MapsPath |
Public property | ResourceId |
Public property | RootPath |
Public property | SourceFile |
Public property | SpatialDataSourcesFolder |
Public property | SpatialDataSourcesPath |
Public property | SymbolLibrariesFolder |
Public property | SymbolLibrariesPath |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LoadProcedureType Class


LoadProcedureType Constructor

LoadProcedureType Constructor
[image]

Initializes a new instance of the LoadProcedureType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LoadProcedureType()
C++
public:
LoadProcedureType() sealed
J#
public LoadProcedureType()
JScript
public function LoadProcedureType()

See Also

LoadProcedureType Class


Properties

LoadProcedureType Properties
[image]

Public Properties

 | Name | Description
Public property | CoordinateSystem |
Public property | GenerateLayers |
Public property | GenerateMaps |
Public property | GenerateMapsSpecified |
Public property | GenerateSpatialDataSources |
Public property | GenerateSymbolLibraries |
Public property | GenerateSymbolLibrariesSpecified |
Public property | LayersFolder |
Public property | LayersPath |
Public property | MapsFolder |
Public property | MapsPath |
Public property | ResourceId |
Public property | RootPath |
Public property | SourceFile |
Public property | SpatialDataSourcesFolder |
Public property | SpatialDataSourcesPath |
Public property | SymbolLibrariesFolder |
Public property | SymbolLibrariesPath |
Top

See Also

LoadProcedureType Class


CoordinateSystem Property

LoadProcedureType.CoordinateSystem Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CoordinateSystem As String
C#
public string CoordinateSystem { get; set; }
C++
public property string CoordinateSystem sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CoordinateSystem();

/** property */
public void set_CoordinateSystem(string value);
JScript
public function get CoordinateSystem() : String

public function set CoordinateSystem(value : String);

See Also

LoadProcedureType Class


GenerateLayers Property

LoadProcedureType.GenerateLayers Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property GenerateLayers As Boolean
C#
public bool GenerateLayers { get; set; }
C++
public property bool GenerateLayers sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_GenerateLayers();

/** property */
public void set_GenerateLayers(bool value);
JScript
public function get GenerateLayers() : bool

public function set GenerateLayers(value : bool);

See Also

LoadProcedureType Class


GenerateMaps Property

LoadProcedureType.GenerateMaps Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property GenerateMaps As Boolean
C#
public bool GenerateMaps { get; set; }
C++
public property bool GenerateMaps sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_GenerateMaps();

/** property */
public void set_GenerateMaps(bool value);
JScript
public function get GenerateMaps() : bool

public function set GenerateMaps(value : bool);

See Also

LoadProcedureType Class


GenerateMapsSpecified Property

LoadProcedureType.GenerateMapsSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property GenerateMapsSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool GenerateMapsSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool GenerateMapsSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_GenerateMapsSpecified();

/** property */
public void set_GenerateMapsSpecified(bool value);
JScript
public function get GenerateMapsSpecified() : bool

public function set GenerateMapsSpecified(value : bool);

See Also

LoadProcedureType Class


GenerateSpatialDataSources Property

LoadProcedureType.GenerateSpatialDataSources Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property GenerateSpatialDataSources As Boolean
C#
public bool GenerateSpatialDataSources { get; set; }
C++
public property bool GenerateSpatialDataSources sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_GenerateSpatialDataSources();

/** property */
public void set_GenerateSpatialDataSources(bool value);
JScript
public function get GenerateSpatialDataSources() : bool

public function set GenerateSpatialDataSources(value : bool);

See Also

LoadProcedureType Class


GenerateSymbolLibraries Property

LoadProcedureType.GenerateSymbolLibraries Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property GenerateSymbolLibraries As Boolean
C#
public bool GenerateSymbolLibraries { get; set; }
C++
public property bool GenerateSymbolLibraries sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_GenerateSymbolLibraries();

/** property */
public void set_GenerateSymbolLibraries(bool value);
JScript
public function get GenerateSymbolLibraries() : bool

public function set GenerateSymbolLibraries(value : bool);

See Also

LoadProcedureType Class


GenerateSymbolLibrariesSpecified Property

LoadProcedureType.GenerateSymbolLibrariesSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property GenerateSymbolLibrariesSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool GenerateSymbolLibrariesSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool GenerateSymbolLibrariesSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_GenerateSymbolLibrariesSpecified();

/** property */
public void set_GenerateSymbolLibrariesSpecified(bool value);
JScript
public function get GenerateSymbolLibrariesSpecified() : bool

public function set GenerateSymbolLibrariesSpecified(value : bool);

See Also

LoadProcedureType Class


LayersFolder Property

LoadProcedureType.LayersFolder Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LayersFolder As String
C#
public string LayersFolder { get; set; }
C++
public property string LayersFolder sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LayersFolder();

/** property */
public void set_LayersFolder(string value);
JScript
public function get LayersFolder() : String

public function set LayersFolder(value : String);

See Also

LoadProcedureType Class


LayersPath Property

LoadProcedureType.LayersPath Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LayersPath As String
C#
public string LayersPath { get; set; }
C++
public property string LayersPath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LayersPath();

/** property */
public void set_LayersPath(string value);
JScript
public function get LayersPath() : String

public function set LayersPath(value : String);

See Also

LoadProcedureType Class


MapsFolder Property

LoadProcedureType.MapsFolder Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MapsFolder As String
C#
public string MapsFolder { get; set; }
C++
public property string MapsFolder sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_MapsFolder();

/** property */
public void set_MapsFolder(string value);
JScript
public function get MapsFolder() : String

public function set MapsFolder(value : String);

See Also

LoadProcedureType Class


MapsPath Property

LoadProcedureType.MapsPath Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MapsPath As String
C#
public string MapsPath { get; set; }
C++
public property string MapsPath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_MapsPath();

/** property */
public void set_MapsPath(string value);
JScript
public function get MapsPath() : String

public function set MapsPath(value : String);

See Also

LoadProcedureType Class


ResourceId Property

LoadProcedureType.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("ResourceId")>
Public Property ResourceId As StringCollection
C#
[XmlElementAttribute("ResourceId")]
public StringCollection ResourceId { get; set; }
C++
[XmlElementAttribute(L"ResourceId")]
public property StringCollection ResourceId sealed {
StringCollection get();
void set(StringCollection value);
}
J#
/** @attribute XmlElementAttribute("ResourceId") */
/** property */
public StringCollection get_ResourceId();

/** property */
public void set_ResourceId(StringCollection value);
JScript
public function get ResourceId() : StringCollection

public function set ResourceId(value : StringCollection);

See Also

LoadProcedureType Class


RootPath Property

LoadProcedureType.RootPath Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property RootPath As String
C#
public string RootPath { get; set; }
C++
public property string RootPath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_RootPath();

/** property */
public void set_RootPath(string value);
JScript
public function get RootPath() : String

public function set RootPath(value : String);

See Also

LoadProcedureType Class


SourceFile Property

LoadProcedureType.SourceFile Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("SourceFile")>
Public Property SourceFile As StringCollection
C#
[XmlElementAttribute("SourceFile")]
public StringCollection SourceFile { get; set; }
C++
[XmlElementAttribute(L"SourceFile")]
public property StringCollection SourceFile sealed {
StringCollection get();
void set(StringCollection value);
}
J#
/** @attribute XmlElementAttribute("SourceFile") */
/** property */
public StringCollection get_SourceFile();

/** property */
public void set_SourceFile(StringCollection value);
JScript
public function get SourceFile() : StringCollection

public function set SourceFile(value : StringCollection);

See Also

LoadProcedureType Class


SpatialDataSourcesFolder Property

LoadProcedureType.SpatialDataSourcesFolder Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SpatialDataSourcesFolder As String
C#
public string SpatialDataSourcesFolder { get; set; }
C++
public property string SpatialDataSourcesFolder sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SpatialDataSourcesFolder();

/** property */
public void set_SpatialDataSourcesFolder(string value);
JScript
public function get SpatialDataSourcesFolder() : String

public function set SpatialDataSourcesFolder(value : String);

See Also

LoadProcedureType Class


SpatialDataSourcesPath Property

LoadProcedureType.SpatialDataSourcesPath Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SpatialDataSourcesPath As String
C#
public string SpatialDataSourcesPath { get; set; }
C++
public property string SpatialDataSourcesPath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SpatialDataSourcesPath();

/** property */
public void set_SpatialDataSourcesPath(string value);
JScript
public function get SpatialDataSourcesPath() : String

public function set SpatialDataSourcesPath(value : String);

See Also

LoadProcedureType Class


SymbolLibrariesFolder Property

LoadProcedureType.SymbolLibrariesFolder Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SymbolLibrariesFolder As String
C#
public string SymbolLibrariesFolder { get; set; }
C++
public property string SymbolLibrariesFolder sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SymbolLibrariesFolder();

/** property */
public void set_SymbolLibrariesFolder(string value);
JScript
public function get SymbolLibrariesFolder() : String

public function set SymbolLibrariesFolder(value : String);

See Also

LoadProcedureType Class


SymbolLibrariesPath Property

LoadProcedureType.SymbolLibrariesPath Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SymbolLibrariesPath As String
C#
public string SymbolLibrariesPath { get; set; }
C++
public property string SymbolLibrariesPath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SymbolLibrariesPath();

/** property */
public void set_SymbolLibrariesPath(string value);
JScript
public function get SymbolLibrariesPath() : String

public function set SymbolLibrariesPath(value : String);

See Also

LoadProcedureType Class


LoadProcedureTypeType Class

LoadProcedureTypeType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(LoadProcedure))>
Public Class LoadProcedureTypeType
C#
[XmlIncludeAttribute(typeof(LoadProcedure))]
public class LoadProcedureTypeType
C++
[XmlIncludeAttribute(typeof(LoadProcedure))]
ref class LoadProcedureTypeType
J#
/** @attribute XmlIncludeAttribute(typeof(LoadProcedure)) */
public class LoadProcedureTypeType
JScript
public
XmlIncludeAttribute(typeof(LoadProcedure))
class LoadProcedureTypeType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LoadProcedureTypeType
OSGeo.MapGuide.MaestroAPI.LoadProcedure

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LoadProcedureTypeType Members


LoadProcedureTypeType Members

LoadProcedureTypeType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by LoadProcedureTypeType.

Public Constructors

 | Name | Description
Public method | LoadProcedureTypeType | Initializes a new instance of the LoadProcedureTypeType class.
Top

Public Properties

 | Name | Description
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

LoadProcedureTypeType Class


LoadProcedureTypeType Constructor

LoadProcedureTypeType Constructor
[image]

Initializes a new instance of the LoadProcedureTypeType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public LoadProcedureTypeType()
C++
public:
LoadProcedureTypeType() sealed
J#
public LoadProcedureTypeType()
JScript
public function LoadProcedureTypeType()

See Also

LoadProcedureTypeType Class


Properties

LoadProcedureTypeType Properties
[image]

Public Properties

 | Name | Description
Public property | Item |
Top

See Also

LoadProcedureTypeType Class


Item Property

LoadProcedureTypeType.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("RasterLoadProcedure", GetType(RasterLoadProcedureType)), _
XmlElementAttribute("SdfLoadProcedure", GetType(SdfLoadProcedureType)), _
XmlElementAttribute("DwgLoadProcedure", GetType(DwgLoadProcedureType)), _
XmlElementAttribute("DwfLoadProcedure", GetType(DwfLoadProcedureType)), _
XmlElementAttribute("ShpLoadProcedure", GetType(ShpLoadProcedureType))>
Public Property Item As LoadProcedureType
C#
[XmlElementAttribute("RasterLoadProcedure", typeof(RasterLoadProcedureType))]
[XmlElementAttribute("SdfLoadProcedure", typeof(SdfLoadProcedureType))]
[XmlElementAttribute("DwgLoadProcedure", typeof(DwgLoadProcedureType))]
[XmlElementAttribute("DwfLoadProcedure", typeof(DwfLoadProcedureType))]
[XmlElementAttribute("ShpLoadProcedure", typeof(ShpLoadProcedureType))]
public LoadProcedureType Item { get; set; }
C++
[XmlElementAttribute(L"RasterLoadProcedure", typeof(RasterLoadProcedureType))]
[XmlElementAttribute(L"SdfLoadProcedure", typeof(SdfLoadProcedureType))]
[XmlElementAttribute(L"DwgLoadProcedure", typeof(DwgLoadProcedureType))]
[XmlElementAttribute(L"DwfLoadProcedure", typeof(DwfLoadProcedureType))]
[XmlElementAttribute(L"ShpLoadProcedure", typeof(ShpLoadProcedureType))]
public property LoadProcedureType Item sealed {
LoadProcedureType get();
void set(LoadProcedureType value);
}
J#
/** @attribute XmlElementAttribute("RasterLoadProcedure", typeof(RasterLoadProcedureType)) */
/** @attribute XmlElementAttribute("SdfLoadProcedure", typeof(SdfLoadProcedureType)) */
/** @attribute XmlElementAttribute("DwgLoadProcedure", typeof(DwgLoadProcedureType)) */
/** @attribute XmlElementAttribute("DwfLoadProcedure", typeof(DwfLoadProcedureType)) */
/** @attribute XmlElementAttribute("ShpLoadProcedure", typeof(ShpLoadProcedureType)) */
/** property */
public LoadProcedureType get_Item();

/** property */
public void set_Item(LoadProcedureType value);
JScript
public function get Item() : LoadProcedureType

public function set Item(value : LoadProcedureType);

See Also

LoadProcedureTypeType Class


LocalNativeConnection Class

LocalNativeConnection Class
See Also Example Members
[image]

A connection to the server, using the Native API. Only works locally, or with special firewall rules for the server.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class LocalNativeConnection
Inherits ServerConnectionBase
Implements ServerConnectionI, IDisposable
C#
public class LocalNativeConnection : ServerConnectionBase, ServerConnectionI, IDisposable
C++
ref class LocalNativeConnection : ServerConnectionBase, ServerConnectionI, IDisposable
J#
public class LocalNativeConnection extends ServerConnectionBase implements ServerConnectionI, IDisposable
JScript
public class LocalNativeConnection extends ServerConnectionBase, ServerConnectionI, IDisposable

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ServerConnectionBase
OSGeo.MapGuide.MaestroAPI.LocalNativeConnection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

LocalNativeConnection Members


LocalNativeConnection Members

LocalNativeConnection Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

A connection to the server, using the Native API. Only works locally, or with special firewall rules for the server.

The following tables list the members exposed by LocalNativeConnection.

Public Constructors

Name | Description
LocalNativeConnection | Overloaded.
Top

Public Properties

 | Name | Description
Public property | AutoRestartSession | Gets or sets a value indicating if the session should automatically be restarted if it expires (inherited from ServerConnectionBase)
Public property | CachedSchemas | Gets or sets the collection of cached schemas. Use the object type for key, and an XmlSchema instance for value. (inherited from ServerConnectionBase)
Public property | CoordinateSystem |
Public property | DisableValidation | Gets or sets a flag that indicates if the Xml resources are validated before leaving and entering the server. (inherited from ServerConnectionBase)
Public property | DisplayName |
Public property | FeatureProviders | Overridden.
Public property | MaxTestedVersion | Gets the highest version the API is currently tested againts (inherited from ServerConnectionBase)
Public property | RepositoryResources |
Public property | ResourceTypeLookup | Gets or sets a hashtable where the key is resourceID extensions, and values are System.Type values. (inherited from ServerConnectionBase)
Public property | SessionID | Overridden.
Public property | SiteVersion | Overridden.
Top

Public Methods

 | Name | Description
Public method | CopyFolder | Overridden.
Public method | CopyFolderWithReferences | Copies folder, and subsequently updates all resources within the folder to use the new folder path instead of the originating one. (inherited from ServerConnectionBase)
Public method | CopyResource | Overridden.
Public method | CreateFolder | Creates a folder on the server (inherited from ServerConnectionBase)
Public method | CreateRuntimeMap | Overloaded. Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.
Public method | DeleteFolder |
Public method | DeleteResource | Overridden.
Public method | DeleteResourceData |
Public method | DescribeFeatureSource | Overloaded.
Public method | DescribeSchema |
Public method | DeserializeObject | Overloaded. Deserializes an object from a stream. (inherited from ServerConnectionBase)
Public method | Dispose | Overridden.
Public method | EnumerateGroups | Overridden. Gets a list of all groups on the server
Public method | EnumerateResourceData |
Public method | EnumerateResourceReferences | Overridden.
Public method | EnumerateUnmanagedData | Overridden. Enumerates all unmanaged folders, meaning alias'ed folders
Public method | EnumerateUsers | Overloaded. Gets a list of all users on the server
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetApplicationContainers | Overridden. Returns the avalible widget containers on the server
Public method | GetApplicationDefinition | Returns a ApplicationDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetApplicationTemplates | Overridden. Returns the avalible application templates on the server
Public method | GetApplicationWidgets | Overridden. Returns the avalible application widgets on the server
Public method | GetFeatureProvider | Overridden.
Public method | GetFeatureSource | Returns a FeatureSource from the server. (inherited from ServerConnectionBase)
Public method | GetFeatureSourceDescription | (inherited from ServerConnectionBase)
Public method | GetFeatureSourceSchema | (inherited from ServerConnectionBase)
Public method | GetFolderHeader | (inherited from ServerConnectionBase)
Public method | GetFolderOrResourceHeader | Overridden.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetIdentityProperties | Overridden. Gets the names of the identity properties from a feature
Public method | GetLayerDefinition | Returns a LayerDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetLegendImage | Overridden. Renders a minature bitmap of the layers style
Public method | GetMapDefinition | Returns a MapDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetMapDWF |
Public method | GetProviderCapabilities |
Public method | GetRepositoryResources | Overloaded. Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly.
Public method | GetResource | Returns an object deserialized from server data. Uses the ResourceID to infer the object type. (inherited from ServerConnectionBase)
Public method | GetResourceData | Overridden.
Public method | GetResourceHeader | (inherited from ServerConnectionBase)
Public method | GetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types. (inherited from ServerConnectionBase)
Public method | GetResourceXmlData | Overridden.
Public method | GetRuntimeMap |
Public method | GetSelectionXml | Overridden. Gets the selection from a map
Public method | GetSpatialContextInfo | Overridden. Returns the spatial info for a given featuresource
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetWebLayout | Returns a WebLayout from the server. (inherited from ServerConnectionBase)
Public method | HasFolder | Returns a value indicating if a given folder exists (inherited from ServerConnectionBase)
Public method | IsSessionExpiredException | Overridden.
Public method | MoveFolder | Overridden.
Public method | MoveFolderWithReferences | Moves a folder, and subsequently updates all resources pointing to the old resource path (inherited from ServerConnectionBase)
Public method | MoveResource | Overridden.
Public method | MoveResourceWithReferences | Moves a resource, and subsequently updates all resources pointing to the old resource path (inherited from ServerConnectionBase)
Public method | QueryFeatureSource | Overloaded.
Public method | QueryMapFeatures | Overloaded. Selects features from a runtime map, returning a selection Xml.
Public method | RemoveVersionFromProviderName | Removes the version numbers from a providername (inherited from ServerConnectionBase)
Public method | RenderRuntimeMap |
Public method | ResetFeatureSourceSchemaCache | (inherited from ServerConnectionBase)
Public method | ResourceExists | Returns a boolean indicating if a given resource exists (inherited from ServerConnectionBase)
Public method | RestartSession | Overloaded. Restarts the server session, and creates a new session ID
Public method | SaveResource | Overloaded. Saves a FeatureSource, using its originating resourceId (inherited from ServerConnectionBase)
Public method | SaveResourceAs | Overloaded. Saves a FeatureSource under a different resourceID (inherited from ServerConnectionBase)
Public method | SaveRuntimeMap |
Public method | SerializeObject | Overloaded. Serialize an object into a new memory stream. (inherited from ServerConnectionBase)
Public method | SetFolderHeader | (inherited from ServerConnectionBase)
Public method | SetFolderOrResourceHeader | (inherited from ServerConnectionBase)
Public method | SetResourceData | Overloaded. Uploads data to a resource
Public method | SetResourceHeader | (inherited from ServerConnectionBase)
Public method | SetResourceXmlData | Overloaded. Writes raw data into a resource.
Public method | SetSelectionXml | Overridden. Sets the selection of a map
Public method | TestConnection | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types. (inherited from ServerConnectionBase)
Public method | UpdateResourceReferences | Updates all resource references inside an object. (inherited from ServerConnectionBase)
Public method | UploadPackage | Overridden. Upload a MapGuide Package file to the server
Public method | WriteResource | Writes an object into a resourceID (inherited from ServerConnectionBase)
Top

Explicit Interface Implementations

Name | Description
LocalNativeConnection | Overloaded.
Top

See Also

LocalNativeConnection Class


LocalNativeConnection Constructor

LocalNativeConnection Constructor

Overload List

 | Name | Description
Public method | LocalNativeConnection (String) |
Public method | LocalNativeConnection (String, String, String, String) |

See Also

LocalNativeConnection Class


LocalNativeConnection Constructor (String)

LocalNativeConnection Constructor (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal sessionid As String _
)
C#
public LocalNativeConnection(
string sessionid
)
C++
public:
LocalNativeConnection(
String sessionid
) sealed
J#
public LocalNativeConnection(
string sessionid
)
JScript
public function LocalNativeConnection(
sessionid : String
)

See Also

LocalNativeConnection Class
LocalNativeConnection Constructor Overload List


LocalNativeConnection Constructor (String, String, String, String)

LocalNativeConnection Constructor (String, String, String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal configFile As String, _
ByVal username As String, _
ByVal password As String, _
ByVal locale As String _
)
C#
public LocalNativeConnection(
string configFile,
string username,
string password,
string locale
)
C++
public:
LocalNativeConnection(
String configFile,
String username,
String password,
String locale
) sealed
J#
public LocalNativeConnection(
string configFile,
string username,
string password,
string locale
)
JScript
public function LocalNativeConnection(
configFile : String,
username : String,
password : String,
locale : String
)

See Also

LocalNativeConnection Class
LocalNativeConnection Constructor Overload List


Properties

LocalNativeConnection Properties
[image]

Public Properties

 | Name | Description
Public property | AutoRestartSession | Gets or sets a value indicating if the session should automatically be restarted if it expires (inherited from ServerConnectionBase)
Public property | CachedSchemas | Gets or sets the collection of cached schemas. Use the object type for key, and an XmlSchema instance for value. (inherited from ServerConnectionBase)
Public property | CoordinateSystem |
Public property | DisableValidation | Gets or sets a flag that indicates if the Xml resources are validated before leaving and entering the server. (inherited from ServerConnectionBase)
Public property | DisplayName |
Public property | FeatureProviders | Overridden.
Public property | MaxTestedVersion | Gets the highest version the API is currently tested againts (inherited from ServerConnectionBase)
Public property | RepositoryResources |
Public property | ResourceTypeLookup | Gets or sets a hashtable where the key is resourceID extensions, and values are System.Type values. (inherited from ServerConnectionBase)
Public property | SessionID | Overridden.
Public property | SiteVersion | Overridden.
Top

See Also

LocalNativeConnection Class


CoordinateSystem Property

LocalNativeConnection.CoordinateSystem Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CoordinateSystem As CoordinateSystem _
Implements ServerConnectionI.CoordinateSystem
C#
public CoordinateSystem CoordinateSystem { get; }
C++
public property CoordinateSystem CoordinateSystem sealed {
CoordinateSystem get();
}
J#
/** property */
public CoordinateSystem get_CoordinateSystem();
JScript
public function get CoordinateSystem() : CoordinateSystem

Implements

ServerConnectionI.CoordinateSystem

See Also

LocalNativeConnection Class


DisplayName Property

LocalNativeConnection.DisplayName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DisplayName As String _
Implements ServerConnectionI.DisplayName
C#
public string DisplayName { get; }
C++
public property string DisplayName sealed {
String get();
}
J#
/** property */
public string get_DisplayName();
JScript
public function get DisplayName() : String

Implements

ServerConnectionI.DisplayName

See Also

LocalNativeConnection Class


FeatureProviders Property

LocalNativeConnection.FeatureProviders Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FeatureProviders As FeatureProviderRegistryFeatureProviderCollection _
Implements ServerConnectionI.FeatureProviders
C#
public override FeatureProviderRegistryFeatureProviderCollection FeatureProviders { get; }
C++
public override property FeatureProviderRegistryFeatureProviderCollection FeatureProviders override {
FeatureProviderRegistryFeatureProviderCollection get();
}
J#
/** property */
public FeatureProviderRegistryFeatureProviderCollection get_FeatureProviders();
JScript
public function get FeatureProviders() : FeatureProviderRegistryFeatureProviderCollection

Implements

ServerConnectionI.FeatureProviders

See Also

LocalNativeConnection Class


RepositoryResources Property

LocalNativeConnection.RepositoryResources Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RepositoryResources As ResourceList _
Implements ServerConnectionI.RepositoryResources
C#
public ResourceList RepositoryResources { get; }
C++
public property ResourceList RepositoryResources sealed {
ResourceList get();
}
J#
/** property */
public ResourceList get_RepositoryResources();
JScript
public function get RepositoryResources() : ResourceList

Implements

ServerConnectionI.RepositoryResources

See Also

LocalNativeConnection Class


SessionID Property

LocalNativeConnection.SessionID Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property SessionID As String _
Implements ServerConnectionI.SessionID
C#
public override string SessionID { get; }
C++
public override property string SessionID override {
String get();
}
J#
/** property */
public string get_SessionID();
JScript
public function get SessionID() : String

Implements

ServerConnectionI.SessionID

See Also

LocalNativeConnection Class


SiteVersion Property

LocalNativeConnection.SiteVersion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property SiteVersion As Version _
Implements ServerConnectionI.SiteVersion
C#
public override Version SiteVersion { get; }
C++
public override property Version SiteVersion override {
Version get();
}
J#
/** property */
public Version get_SiteVersion();
JScript
public function get SiteVersion() : Version

Implements

ServerConnectionI.SiteVersion

See Also

LocalNativeConnection Class


Methods

LocalNativeConnection Methods
[image]

Public Methods

 | Name | Description
Public method | CopyFolder | Overridden.
Public method | CopyFolderWithReferences | Copies folder, and subsequently updates all resources within the folder to use the new folder path instead of the originating one. (inherited from ServerConnectionBase)
Public method | CopyResource | Overridden.
Public method | CreateFolder | Creates a folder on the server (inherited from ServerConnectionBase)
Public method | CreateRuntimeMap | Overloaded. Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.
Public method | DeleteFolder |
Public method | DeleteResource | Overridden.
Public method | DeleteResourceData |
Public method | DescribeFeatureSource | Overloaded.
Public method | DescribeSchema |
Public method | DeserializeObject | Overloaded. Deserializes an object from a stream. (inherited from ServerConnectionBase)
Public method | Dispose | Overridden.
Public method | EnumerateGroups | Overridden. Gets a list of all groups on the server
Public method | EnumerateResourceData |
Public method | EnumerateResourceReferences | Overridden.
Public method | EnumerateUnmanagedData | Overridden. Enumerates all unmanaged folders, meaning alias'ed folders
Public method | EnumerateUsers | Overloaded. Gets a list of all users on the server
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetApplicationContainers | Overridden. Returns the avalible widget containers on the server
Public method | GetApplicationDefinition | Returns a ApplicationDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetApplicationTemplates | Overridden. Returns the avalible application templates on the server
Public method | GetApplicationWidgets | Overridden. Returns the avalible application widgets on the server
Public method | GetFeatureProvider | Overridden.
Public method | GetFeatureSource | Returns a FeatureSource from the server. (inherited from ServerConnectionBase)
Public method | GetFeatureSourceDescription | (inherited from ServerConnectionBase)
Public method | GetFeatureSourceSchema | (inherited from ServerConnectionBase)
Public method | GetFolderHeader | (inherited from ServerConnectionBase)
Public method | GetFolderOrResourceHeader | Overridden.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetIdentityProperties | Overridden. Gets the names of the identity properties from a feature
Public method | GetLayerDefinition | Returns a LayerDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetLegendImage | Overridden. Renders a minature bitmap of the layers style
Public method | GetMapDefinition | Returns a MapDefinition from the server. (inherited from ServerConnectionBase)
Public method | GetMapDWF |
Public method | GetProviderCapabilities |
Public method | GetRepositoryResources | Overloaded. Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly.
Public method | GetResource | Returns an object deserialized from server data. Uses the ResourceID to infer the object type. (inherited from ServerConnectionBase)
Public method | GetResourceData | Overridden.
Public method | GetResourceHeader | (inherited from ServerConnectionBase)
Public method | GetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types. (inherited from ServerConnectionBase)
Public method | GetResourceXmlData | Overridden.
Public method | GetRuntimeMap |
Public method | GetSelectionXml | Overridden. Gets the selection from a map
Public method | GetSpatialContextInfo | Overridden. Returns the spatial info for a given featuresource
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetWebLayout | Returns a WebLayout from the server. (inherited from ServerConnectionBase)
Public method | HasFolder | Returns a value indicating if a given folder exists (inherited from ServerConnectionBase)
Public method | IsSessionExpiredException | Overridden.
Public method | MoveFolder | Overridden.
Public method | MoveFolderWithReferences | Moves a folder, and subsequently updates all resources pointing to the old resource path (inherited from ServerConnectionBase)
Public method | MoveResource | Overridden.
Public method | MoveResourceWithReferences | Moves a resource, and subsequently updates all resources pointing to the old resource path (inherited from ServerConnectionBase)
Public method | QueryFeatureSource | Overloaded.
Public method | QueryMapFeatures | Overloaded. Selects features from a runtime map, returning a selection Xml.
Public method | RemoveVersionFromProviderName | Removes the version numbers from a providername (inherited from ServerConnectionBase)
Public method | RenderRuntimeMap |
Public method | ResetFeatureSourceSchemaCache | (inherited from ServerConnectionBase)
Public method | ResourceExists | Returns a boolean indicating if a given resource exists (inherited from ServerConnectionBase)
Public method | RestartSession | Overloaded. Restarts the server session, and creates a new session ID
Public method | SaveResource | Overloaded. Saves a FeatureSource, using its originating resourceId (inherited from ServerConnectionBase)
Public method | SaveResourceAs | Overloaded. Saves a FeatureSource under a different resourceID (inherited from ServerConnectionBase)
Public method | SaveRuntimeMap |
Public method | SerializeObject | Overloaded. Serialize an object into a new memory stream. (inherited from ServerConnectionBase)
Public method | SetFolderHeader | (inherited from ServerConnectionBase)
Public method | SetFolderOrResourceHeader | (inherited from ServerConnectionBase)
Public method | SetResourceData | Overloaded. Uploads data to a resource
Public method | SetResourceHeader | (inherited from ServerConnectionBase)
Public method | SetResourceXmlData | Overloaded. Writes raw data into a resource.
Public method | SetSelectionXml | Overridden. Sets the selection of a map
Public method | TestConnection | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types. (inherited from ServerConnectionBase)
Public method | UpdateResourceReferences | Updates all resource references inside an object. (inherited from ServerConnectionBase)
Public method | UploadPackage | Overridden. Upload a MapGuide Package file to the server
Public method | WriteResource | Writes an object into a resourceID (inherited from ServerConnectionBase)
Top

See Also

LocalNativeConnection Class


CopyFolder Method

LocalNativeConnection.CopyFolder Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub CopyFolder( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
) _
Implements ServerConnectionI.CopyFolder
C#
public override void CopyFolder(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
virtual void CopyFolder(
String oldpath,
String newpath,
bool overwrite
) override
J#
public override void CopyFolder(
string oldpath,
string newpath,
bool overwrite
)
JScript
public override function CopyFolder(
oldpath : String,
newpath : String,
overwrite : bool
)

Implements

ServerConnectionI.CopyFolder

See Also

LocalNativeConnection Class


CopyResource Method

LocalNativeConnection.CopyResource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub CopyResource( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
) _
Implements ServerConnectionI.CopyResource
C#
public override void CopyResource(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
virtual void CopyResource(
String oldpath,
String newpath,
bool overwrite
) override
J#
public override void CopyResource(
string oldpath,
string newpath,
bool overwrite
)
JScript
public override function CopyResource(
oldpath : String,
newpath : String,
overwrite : bool
)

Implements

ServerConnectionI.CopyResource

See Also

LocalNativeConnection Class


CreateRuntimeMap Method

LocalNativeConnection.CreateRuntimeMap Method

Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.

Overload List

 | Name | Description
Public method | CreateRuntimeMap (String, String) | Overridden.
Public method | CreateRuntimeMap (String) | Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map. (inherited from ServerConnectionBase)

See Also

LocalNativeConnection Class


CreateRuntimeMap Method (String, String)

LocalNativeConnection.CreateRuntimeMap Method (String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub CreateRuntimeMap( _
ByVal resourceID As String, _
ByVal mapdefinition As String _
) _
Implements ServerConnectionI.CreateRuntimeMap
C#
public override void CreateRuntimeMap(
string resourceID,
string mapdefinition
)
C++
public:
virtual void CreateRuntimeMap(
String resourceID,
String mapdefinition
) override
J#
public override void CreateRuntimeMap(
string resourceID,
string mapdefinition
)
JScript
public override function CreateRuntimeMap(
resourceID : String,
mapdefinition : String
)

Implements

ServerConnectionI.CreateRuntimeMap

See Also

LocalNativeConnection Class
LocalNativeConnection.CreateRuntimeMap Overload List


DeleteFolder Method

LocalNativeConnection.DeleteFolder Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteFolder( _
ByVal folderPath As String _
) _
Implements ServerConnectionI.DeleteFolder
C#
public void DeleteFolder(
string folderPath
)
C++
public:
void DeleteFolder(
String folderPath
) sealed
J#
public void DeleteFolder(
string folderPath
)
JScript
public function DeleteFolder(
folderPath : String
)

Implements

ServerConnectionI.DeleteFolder

See Also

LocalNativeConnection Class


DeleteResource Method

LocalNativeConnection.DeleteResource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub DeleteResource( _
ByVal resourceID As String _
) _
Implements ServerConnectionI.DeleteResource
C#
public override void DeleteResource(
string resourceID
)
C++
public:
virtual void DeleteResource(
String resourceID
) override
J#
public override void DeleteResource(
string resourceID
)
JScript
public override function DeleteResource(
resourceID : String
)

Implements

ServerConnectionI.DeleteResource

See Also

LocalNativeConnection Class


DeleteResourceData Method

LocalNativeConnection.DeleteResourceData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteResourceData( _
ByVal resourceID As String, _
ByVal dataname As String _
) _
Implements ServerConnectionI.DeleteResourceData
C#
public void DeleteResourceData(
string resourceID,
string dataname
)
C++
public:
void DeleteResourceData(
String resourceID,
String dataname
) sealed
J#
public void DeleteResourceData(
string resourceID,
string dataname
)
JScript
public function DeleteResourceData(
resourceID : String,
dataname : String
)

Implements

ServerConnectionI.DeleteResourceData

See Also

LocalNativeConnection Class


DescribeFeatureSource Method

LocalNativeConnection.DescribeFeatureSource Method

Overload List

 | Name | Description
Public method | DescribeFeatureSource (String) | Overridden.
Public method | DescribeFeatureSource (String, String) | Overridden.

See Also

LocalNativeConnection Class


DescribeFeatureSource Method (String)

LocalNativeConnection.DescribeFeatureSource Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function DescribeFeatureSource( _
ByVal resourceID As String _
) As FeatureSourceDescription _
Implements ServerConnectionI.DescribeFeatureSource
C#
public override FeatureSourceDescription DescribeFeatureSource(
string resourceID
)
C++
public:
virtual FeatureSourceDescription DescribeFeatureSource(
String resourceID
) override
J#
public override FeatureSourceDescription DescribeFeatureSource(
string resourceID
)
JScript
public override function DescribeFeatureSource(
resourceID : String
) : FeatureSourceDescription

Implements

ServerConnectionI.DescribeFeatureSource

See Also

LocalNativeConnection Class
LocalNativeConnection.DescribeFeatureSource Overload List


DescribeFeatureSource Method (String, String)

LocalNativeConnection.DescribeFeatureSource Method (String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function DescribeFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String _
) As FeatureSourceDescription _
Implements ServerConnectionI.DescribeFeatureSource
C#
public override FeatureSourceDescription DescribeFeatureSource(
string resourceID,
string schema
)
C++
public:
virtual FeatureSourceDescription DescribeFeatureSource(
String resourceID,
String schema
) override
J#
public override FeatureSourceDescription DescribeFeatureSource(
string resourceID,
string schema
)
JScript
public override function DescribeFeatureSource(
resourceID : String,
schema : String
) : FeatureSourceDescription

Implements

ServerConnectionI.DescribeFeatureSource

See Also

LocalNativeConnection Class
LocalNativeConnection.DescribeFeatureSource Overload List


DescribeSchema Method

LocalNativeConnection.DescribeSchema Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub DescribeSchema() _
Implements ServerConnectionI.DescribeSchema
C#
public void DescribeSchema()
C++
public:
void DescribeSchema() sealed
J#
public void DescribeSchema()
JScript
public function DescribeSchema()

Implements

ServerConnectionI.DescribeSchema

See Also

LocalNativeConnection Class


Dispose Method

LocalNativeConnection.Dispose Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Dispose() _
Implements IDisposable.Dispose
C#
public override void Dispose()
C++
public:
virtual void Dispose() override
J#
public override void Dispose()
JScript
public override function Dispose()

Implements

IDisposable.Dispose

See Also

LocalNativeConnection Class


EnumerateGroups Method

LocalNativeConnection.EnumerateGroups Method
[image]

Gets a list of all groups on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function EnumerateGroups() As GroupList _
Implements ServerConnectionI.EnumerateGroups
C#
public override GroupList EnumerateGroups()
C++
public:
virtual GroupList EnumerateGroups() override
J#
public override GroupList EnumerateGroups()
JScript
public override function EnumerateGroups() : GroupList

Return Value

The list of groups

Implements

ServerConnectionI.EnumerateGroups

See Also

LocalNativeConnection Class


EnumerateResourceData Method

LocalNativeConnection.EnumerateResourceData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function EnumerateResourceData( _
ByVal resourceID As String _
) As ResourceDataList _
Implements ServerConnectionI.EnumerateResourceData
C#
public ResourceDataList EnumerateResourceData(
string resourceID
)
C++
public:
ResourceDataList EnumerateResourceData(
String resourceID
) sealed
J#
public ResourceDataList EnumerateResourceData(
string resourceID
)
JScript
public function EnumerateResourceData(
resourceID : String
) : ResourceDataList

Implements

ServerConnectionI.EnumerateResourceData

See Also

LocalNativeConnection Class


EnumerateResourceReferences Method

LocalNativeConnection.EnumerateResourceReferences Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function EnumerateResourceReferences( _
ByVal resourceid As String _
) As ResourceReferenceList _
Implements ServerConnectionI.EnumerateResourceReferences
C#
public override ResourceReferenceList EnumerateResourceReferences(
string resourceid
)
C++
public:
virtual ResourceReferenceList EnumerateResourceReferences(
String resourceid
) override
J#
public override ResourceReferenceList EnumerateResourceReferences(
string resourceid
)
JScript
public override function EnumerateResourceReferences(
resourceid : String
) : ResourceReferenceList

Implements

ServerConnectionI.EnumerateResourceReferences

See Also

LocalNativeConnection Class


EnumerateUnmanagedData Method

LocalNativeConnection.EnumerateUnmanagedData Method
[image]

Enumerates all unmanaged folders, meaning alias'ed folders

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function EnumerateUnmanagedData( _
ByVal startpath As String, _
ByVal filter As String, _
ByVal recursive As Boolean, _
ByVal type As UnmanagedDataTypes _
) As UnmanagedDataList _
Implements ServerConnectionI.EnumerateUnmanagedData
C#
public override UnmanagedDataList EnumerateUnmanagedData(
string startpath,
string filter,
bool recursive,
UnmanagedDataTypes type
)
C++
public:
virtual UnmanagedDataList EnumerateUnmanagedData(
String startpath,
String filter,
bool recursive,
UnmanagedDataTypes type
) override
J#
public override UnmanagedDataList EnumerateUnmanagedData(
string startpath,
string filter,
bool recursive,
UnmanagedDataTypes type
)
JScript
public override function EnumerateUnmanagedData(
startpath : String,
filter : String,
recursive : bool,
type : UnmanagedDataTypes
) : UnmanagedDataList

Parameters

startpath
The path to retrieve the data from
filter
A filter applied to the items
recursive
True if the list should contains recursive results
type
The type of data to return

Return Value

A list of unmanaged data

Implements

ServerConnectionI.EnumerateUnmanagedData

See Also

LocalNativeConnection Class


EnumerateUsers Method

LocalNativeConnection.EnumerateUsers Method

Gets a list of all users on the server

Overload List

 | Name | Description
Public method | EnumerateUsers (String) | Overridden. Gets a list of users in a group
Public method | EnumerateUsers | Gets a list of all users on the server (inherited from ServerConnectionBase)

See Also

LocalNativeConnection Class


EnumerateUsers Method (String)

LocalNativeConnection.EnumerateUsers Method (String)
See Also Example
[image]

Gets a list of users in a group

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function EnumerateUsers( _
ByVal group As String _
) As UserList _
Implements ServerConnectionI.EnumerateUsers
C#
public override UserList EnumerateUsers(
string group
)
C++
public:
virtual UserList EnumerateUsers(
String group
) override
J#
public override UserList EnumerateUsers(
string group
)
JScript
public override function EnumerateUsers(
group : String
) : UserList

Parameters

group
The group to retrieve the users from

Return Value

The list of users

Implements

ServerConnectionI.EnumerateUsers

See Also

LocalNativeConnection Class
LocalNativeConnection.EnumerateUsers Overload List


GetApplicationContainers Method

LocalNativeConnection.GetApplicationContainers Method
[image]

Returns the avalible widget containers on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetApplicationContainers() As ApplicationDefinitionContainerInfoSet _
Implements ServerConnectionI.GetApplicationContainers
C#
public override ApplicationDefinitionContainerInfoSet GetApplicationContainers()
C++
public:
virtual ApplicationDefinitionContainerInfoSet GetApplicationContainers() override
J#
public override ApplicationDefinitionContainerInfoSet GetApplicationContainers()
JScript
public override function GetApplicationContainers() : ApplicationDefinitionContainerInfoSet

Return Value

The avalible widget containers on the server

Implements

ServerConnectionI.GetApplicationContainers

See Also

LocalNativeConnection Class


GetApplicationTemplates Method

LocalNativeConnection.GetApplicationTemplates Method
[image]

Returns the avalible application templates on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetApplicationTemplates() As ApplicationDefinitionTemplateInfoSet _
Implements ServerConnectionI.GetApplicationTemplates
C#
public override ApplicationDefinitionTemplateInfoSet GetApplicationTemplates()
C++
public:
virtual ApplicationDefinitionTemplateInfoSet GetApplicationTemplates() override
J#
public override ApplicationDefinitionTemplateInfoSet GetApplicationTemplates()
JScript
public override function GetApplicationTemplates() : ApplicationDefinitionTemplateInfoSet

Return Value

The avalible application templates on the server

Implements

ServerConnectionI.GetApplicationTemplates

See Also

LocalNativeConnection Class


GetApplicationWidgets Method

LocalNativeConnection.GetApplicationWidgets Method
[image]

Returns the avalible application widgets on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetApplicationWidgets() As ApplicationDefinitionWidgetInfoSet _
Implements ServerConnectionI.GetApplicationWidgets
C#
public override ApplicationDefinitionWidgetInfoSet GetApplicationWidgets()
C++
public:
virtual ApplicationDefinitionWidgetInfoSet GetApplicationWidgets() override
J#
public override ApplicationDefinitionWidgetInfoSet GetApplicationWidgets()
JScript
public override function GetApplicationWidgets() : ApplicationDefinitionWidgetInfoSet

Return Value

The avalible application widgets on the server

Implements

ServerConnectionI.GetApplicationWidgets

See Also

LocalNativeConnection Class


GetFeatureProvider Method

LocalNativeConnection.GetFeatureProvider Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetFeatureProvider( _
ByVal providername As String _
) As FeatureProviderRegistryFeatureProvider _
Implements ServerConnectionI.GetFeatureProvider
C#
public override FeatureProviderRegistryFeatureProvider GetFeatureProvider(
string providername
)
C++
public:
virtual FeatureProviderRegistryFeatureProvider GetFeatureProvider(
String providername
) override
J#
public override FeatureProviderRegistryFeatureProvider GetFeatureProvider(
string providername
)
JScript
public override function GetFeatureProvider(
providername : String
) : FeatureProviderRegistryFeatureProvider

Implements

ServerConnectionI.GetFeatureProvider

See Also

LocalNativeConnection Class


GetFolderOrResourceHeader Method

LocalNativeConnection.GetFolderOrResourceHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetFolderOrResourceHeader( _
ByVal resourceID As String _
) As Object
C#
public override object GetFolderOrResourceHeader(
string resourceID
)
C++
public:
virtual Object GetFolderOrResourceHeader(
String resourceID
) override
J#
public override object GetFolderOrResourceHeader(
string resourceID
)
JScript
public override function GetFolderOrResourceHeader(
resourceID : String
) : Object

See Also

LocalNativeConnection Class


GetIdentityProperties Method

LocalNativeConnection.GetIdentityProperties Method
[image]

Gets the names of the identity properties from a feature

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetIdentityProperties( _
ByVal resourceID As String, _
ByVal classname As String _
) As String() _
Implements ServerConnectionI.GetIdentityProperties
C#
public override string[] GetIdentityProperties(
string resourceID,
string classname
)
C++
public:
virtual array<String>^ GetIdentityProperties(
String resourceID,
String classname
) override
J#
public override string[] GetIdentityProperties(
string resourceID,
string classname
)
JScript
public override function GetIdentityProperties(
resourceID : String,
classname : String
) : String[]

Parameters

resourceID
The resourceID for the FeatureSource
classname
The classname of the feature, including schema

Return Value

A string array with the found identities

Implements

ServerConnectionI.GetIdentityProperties

See Also

LocalNativeConnection Class


GetLegendImage Method

LocalNativeConnection.GetLegendImage Method
[image]

Renders a minature bitmap of the layers style

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetLegendImage( _
ByVal scale As Double, _
ByVal layerdefinition As String, _
ByVal themeIndex As Integer, _
ByVal type As Integer _
) As Image _
Implements ServerConnectionI.GetLegendImage
C#
public override Image GetLegendImage(
double scale,
string layerdefinition,
int themeIndex,
int type
)
C++
public:
virtual Image GetLegendImage(
double scale,
String layerdefinition,
int themeIndex,
int type
) override
J#
public override Image GetLegendImage(
double scale,
string layerdefinition,
int themeIndex,
int type
)
JScript
public override function GetLegendImage(
scale : double,
layerdefinition : String,
themeIndex : int,
type : int
) : Image

Parameters

scale
The scale for the bitmap to match
layerdefinition
The layer the image should represent
themeIndex
If the layer is themed, this gives the theme index, otherwise set to 0
type
The geometry type, 1 for point, 2 for line, 3 for area, 4 for composite

Return Value

The minature bitmap

Implements

ServerConnectionI.GetLegendImage

See Also

LocalNativeConnection Class


GetMapDWF Method

LocalNativeConnection.GetMapDWF Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMapDWF( _
ByVal resourceID As String _
) As Stream _
Implements ServerConnectionI.GetMapDWF
C#
public Stream GetMapDWF(
string resourceID
)
C++
public:
Stream GetMapDWF(
String resourceID
) sealed
J#
public Stream GetMapDWF(
string resourceID
)
JScript
public function GetMapDWF(
resourceID : String
) : Stream

Implements

ServerConnectionI.GetMapDWF

See Also

LocalNativeConnection Class


GetProviderCapabilities Method

LocalNativeConnection.GetProviderCapabilities Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetProviderCapabilities( _
ByVal provider As String _
) As FdoProviderCapabilities _
Implements ServerConnectionI.GetProviderCapabilities
C#
public FdoProviderCapabilities GetProviderCapabilities(
string provider
)
C++
public:
FdoProviderCapabilities GetProviderCapabilities(
String provider
) sealed
J#
public FdoProviderCapabilities GetProviderCapabilities(
string provider
)
JScript
public function GetProviderCapabilities(
provider : String
) : FdoProviderCapabilities

Implements

ServerConnectionI.GetProviderCapabilities

See Also

LocalNativeConnection Class


GetRepositoryResources Method

LocalNativeConnection.GetRepositoryResources Method

Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly.

Overload List

 | Name | Description
Public method | GetRepositoryResources (String, String, Int32) | Overridden.
Public method | GetRepositoryResources | Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly. (inherited from ServerConnectionBase)
Public method | GetRepositoryResources (Int32) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth. (inherited from ServerConnectionBase)
Public method | GetRepositoryResources (String) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth. (inherited from ServerConnectionBase)
Public method | GetRepositoryResources (String, Int32) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth. (inherited from ServerConnectionBase)
Public method | GetRepositoryResources (String, String) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth. (inherited from ServerConnectionBase)

See Also

LocalNativeConnection Class


GetRepositoryResources Method (String, String, Int32)

LocalNativeConnection.GetRepositoryResources Method (String, String, Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetRepositoryResources( _
ByVal startingpoint As String, _
ByVal type As String, _
ByVal depth As Integer _
) As ResourceList _
Implements ServerConnectionI.GetRepositoryResources
C#
public override ResourceList GetRepositoryResources(
string startingpoint,
string type,
int depth
)
C++
public:
virtual ResourceList GetRepositoryResources(
String startingpoint,
String type,
int depth
) override
J#
public override ResourceList GetRepositoryResources(
string startingpoint,
string type,
int depth
)
JScript
public override function GetRepositoryResources(
startingpoint : String,
type : String,
depth : int
) : ResourceList

Implements

ServerConnectionI.GetRepositoryResources

See Also

LocalNativeConnection Class
LocalNativeConnection.GetRepositoryResources Overload List


GetResourceData Method

LocalNativeConnection.GetResourceData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetResourceData( _
ByVal resourceID As String, _
ByVal dataname As String _
) As MemoryStream _
Implements ServerConnectionI.GetResourceData
C#
public override MemoryStream GetResourceData(
string resourceID,
string dataname
)
C++
public:
virtual MemoryStream GetResourceData(
String resourceID,
String dataname
) override
J#
public override MemoryStream GetResourceData(
string resourceID,
string dataname
)
JScript
public override function GetResourceData(
resourceID : String,
dataname : String
) : MemoryStream

Implements

ServerConnectionI.GetResourceData

See Also

LocalNativeConnection Class


GetResourceXmlData Method

LocalNativeConnection.GetResourceXmlData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetResourceXmlData( _
ByVal resourceID As String _
) As Byte() _
Implements ServerConnectionI.GetResourceXmlData
C#
public override byte[] GetResourceXmlData(
string resourceID
)
C++
public:
virtual array<char>^ GetResourceXmlData(
String resourceID
) override
J#
public override byte[] GetResourceXmlData(
string resourceID
)
JScript
public override function GetResourceXmlData(
resourceID : String
) : Byte[]

Implements

ServerConnectionI.GetResourceXmlData

See Also

LocalNativeConnection Class


GetRuntimeMap Method

LocalNativeConnection.GetRuntimeMap Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRuntimeMap( _
ByVal resourceID As String _
) As RuntimeMap _
Implements ServerConnectionI.GetRuntimeMap
C#
public RuntimeMap GetRuntimeMap(
string resourceID
)
C++
public:
RuntimeMap GetRuntimeMap(
String resourceID
) sealed
J#
public RuntimeMap GetRuntimeMap(
string resourceID
)
JScript
public function GetRuntimeMap(
resourceID : String
) : RuntimeMap

Implements

ServerConnectionI.GetRuntimeMap

See Also

LocalNativeConnection Class


GetSelectionXml Method

LocalNativeConnection.GetSelectionXml Method
[image]

Gets the selection from a map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetSelectionXml( _
ByVal runtimeMap As String _
) As String _
Implements ServerConnectionI.GetSelectionXml
C#
public override string GetSelectionXml(
string runtimeMap
)
C++
public:
virtual String GetSelectionXml(
String runtimeMap
) override
J#
public override string GetSelectionXml(
string runtimeMap
)
JScript
public override function GetSelectionXml(
runtimeMap : String
) : String

Parameters

runtimeMap
The resourceID of the runtime map

Return Value

The selection xml

Implements

ServerConnectionI.GetSelectionXml

See Also

LocalNativeConnection Class


GetSpatialContextInfo Method

LocalNativeConnection.GetSpatialContextInfo Method
[image]

Returns the spatial info for a given featuresource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetSpatialContextInfo( _
ByVal resourceID As String, _
ByVal activeOnly As Boolean _
) As FdoSpatialContextList _
Implements ServerConnectionI.GetSpatialContextInfo
C#
public override FdoSpatialContextList GetSpatialContextInfo(
string resourceID,
bool activeOnly
)
C++
public:
virtual FdoSpatialContextList GetSpatialContextInfo(
String resourceID,
bool activeOnly
) override
J#
public override FdoSpatialContextList GetSpatialContextInfo(
string resourceID,
bool activeOnly
)
JScript
public override function GetSpatialContextInfo(
resourceID : String,
activeOnly : bool
) : FdoSpatialContextList

Parameters

resourceID
The ID of the resource to query
activeOnly
Query only active items

Return Value

A list of spatial contexts

Implements

ServerConnectionI.GetSpatialContextInfo

See Also

LocalNativeConnection Class


IsSessionExpiredException Method

LocalNativeConnection.IsSessionExpiredException Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsSessionExpiredException( _
ByVal ex As Exception _
) As Boolean
C#
public override bool IsSessionExpiredException(
Exception ex
)
C++
public:
virtual bool IsSessionExpiredException(
Exception ex
) override
J#
public override bool IsSessionExpiredException(
Exception ex
)
JScript
public override function IsSessionExpiredException(
ex : Exception
) : bool

See Also

LocalNativeConnection Class


MoveFolder Method

LocalNativeConnection.MoveFolder Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub MoveFolder( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
) _
Implements ServerConnectionI.MoveFolder
C#
public override void MoveFolder(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
virtual void MoveFolder(
String oldpath,
String newpath,
bool overwrite
) override
J#
public override void MoveFolder(
string oldpath,
string newpath,
bool overwrite
)
JScript
public override function MoveFolder(
oldpath : String,
newpath : String,
overwrite : bool
)

Implements

ServerConnectionI.MoveFolder

See Also

LocalNativeConnection Class


MoveResource Method

LocalNativeConnection.MoveResource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub MoveResource( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
) _
Implements ServerConnectionI.MoveResource
C#
public override void MoveResource(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
virtual void MoveResource(
String oldpath,
String newpath,
bool overwrite
) override
J#
public override void MoveResource(
string oldpath,
string newpath,
bool overwrite
)
JScript
public override function MoveResource(
oldpath : String,
newpath : String,
overwrite : bool
)

Implements

ServerConnectionI.MoveResource

See Also

LocalNativeConnection Class


QueryFeatureSource Method

LocalNativeConnection.QueryFeatureSource Method

Overload List

 | Name | Description
Public method | QueryFeatureSource (String, String) |
Public method | QueryFeatureSource (String, String, String) |
Public method | QueryFeatureSource (String, String, String, String) |

See Also

LocalNativeConnection Class


QueryFeatureSource Method (String, String)

LocalNativeConnection.QueryFeatureSource Method (String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function QueryFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String _
) As FeatureSetReader _
Implements ServerConnectionI.QueryFeatureSource
C#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema
)
C++
public:
FeatureSetReader QueryFeatureSource(
String resourceID,
String schema
) sealed
J#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema
)
JScript
public function QueryFeatureSource(
resourceID : String,
schema : String
) : FeatureSetReader

Implements

ServerConnectionI.QueryFeatureSource

See Also

LocalNativeConnection Class
LocalNativeConnection.QueryFeatureSource Overload List


QueryFeatureSource Method (String, String, String)

LocalNativeConnection.QueryFeatureSource Method (String, String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function QueryFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String, _
ByVal query As String _
) As FeatureSetReader _
Implements ServerConnectionI.QueryFeatureSource
C#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query
)
C++
public:
FeatureSetReader QueryFeatureSource(
String resourceID,
String schema,
String query
) sealed
J#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query
)
JScript
public function QueryFeatureSource(
resourceID : String,
schema : String,
query : String
) : FeatureSetReader

Implements

ServerConnectionI.QueryFeatureSource

See Also

LocalNativeConnection Class
LocalNativeConnection.QueryFeatureSource Overload List


QueryFeatureSource Method (String, String, String, String[])

LocalNativeConnection.QueryFeatureSource Method (String, String, String, String[])
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function QueryFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String, _
ByVal query As String, _
ByVal columns As String() _
) As FeatureSetReader _
Implements ServerConnectionI.QueryFeatureSource
C#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query,
string[] columns
)
C++
public:
FeatureSetReader QueryFeatureSource(
String resourceID,
String schema,
String query,
array<String>^ columns
) sealed
J#
public FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query,
string[] columns
)
JScript
public function QueryFeatureSource(
resourceID : String,
schema : String,
query : String,
columns : String[]
) : FeatureSetReader

Implements

ServerConnectionI.QueryFeatureSource

See Also

LocalNativeConnection Class
LocalNativeConnection.QueryFeatureSource Overload List


QueryMapFeatures Method

LocalNativeConnection.QueryMapFeatures Method

Selects features from a runtime map, returning a selection Xml.

Overload List

 | Name | Description
Public method | QueryMapFeatures (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean) | Overridden.
Public method | QueryMapFeatures (String, String, Boolean) | Selects features from a runtime map, returning a selection Xml. (inherited from ServerConnectionBase)

See Also

LocalNativeConnection Class


QueryMapFeatures Method (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean)

LocalNativeConnection.QueryMapFeatures Method (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function QueryMapFeatures( _
ByVal runtimemap As String, _
ByVal wkt As String, _
ByVal persist As Boolean, _
ByVal attributes As QueryMapFeaturesLayerAttributes, _
ByVal raw As Boolean _
) As String _
Implements ServerConnectionI.QueryMapFeatures
C#
public override string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
)
C++
public:
virtual String QueryMapFeatures(
String runtimemap,
String wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
) override
J#
public override string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
)
JScript
public override function QueryMapFeatures(
runtimemap : String,
wkt : String,
persist : bool,
attributes : QueryMapFeaturesLayerAttributes,
raw : bool
) : String

Implements

ServerConnectionI.QueryMapFeatures

See Also

LocalNativeConnection Class
LocalNativeConnection.QueryMapFeatures Overload List


RenderRuntimeMap Method

LocalNativeConnection.RenderRuntimeMap Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function RenderRuntimeMap( _
ByVal resourceId As String, _
ByVal x As Double, _
ByVal y As Double, _
ByVal scale As Double, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal dpi As Integer _
) As Stream _
Implements ServerConnectionI.RenderRuntimeMap
C#
public Stream RenderRuntimeMap(
string resourceId,
double x,
double y,
double scale,
int width,
int height,
int dpi
)
C++
public:
Stream RenderRuntimeMap(
String resourceId,
double x,
double y,
double scale,
int width,
int height,
int dpi
) sealed
J#
public Stream RenderRuntimeMap(
string resourceId,
double x,
double y,
double scale,
int width,
int height,
int dpi
)
JScript
public function RenderRuntimeMap(
resourceId : String,
x : double,
y : double,
scale : double,
width : int,
height : int,
dpi : int
) : Stream

Implements

ServerConnectionI.RenderRuntimeMap

See Also

LocalNativeConnection Class


RestartSession Method

LocalNativeConnection.RestartSession Method

Restarts the server session, and creates a new session ID

Overload List

 | Name | Description
Public method | RestartSession (Boolean) | Overridden. Restarts the server session, and creates a new session ID
Public method | RestartSession | Restarts the server session, and creates a new session ID (inherited from ServerConnectionBase)

See Also

LocalNativeConnection Class


RestartSession Method (Boolean)

LocalNativeConnection.RestartSession Method (Boolean)
See Also Example
[image]

Restarts the server session, and creates a new session ID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function RestartSession( _
ByVal throwException As Boolean _
) As Boolean _
Implements ServerConnectionI.RestartSession
C#
public override bool RestartSession(
bool throwException
)
C++
public:
virtual bool RestartSession(
bool throwException
) override
J#
public override bool RestartSession(
bool throwException
)
JScript
public override function RestartSession(
throwException : bool
) : bool

Parameters

throwException
If set to true, the call throws an exception if the call failed

Return Value

True if the creation succeed, false otherwise

Implements

ServerConnectionI.RestartSession

See Also

LocalNativeConnection Class
LocalNativeConnection.RestartSession Overload List


SaveRuntimeMap Method

LocalNativeConnection.SaveRuntimeMap Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveRuntimeMap( _
ByVal resourceID As String, _
ByVal map As RuntimeMap _
) _
Implements ServerConnectionI.SaveRuntimeMap
C#
public void SaveRuntimeMap(
string resourceID,
RuntimeMap map
)
C++
public:
void SaveRuntimeMap(
String resourceID,
RuntimeMap map
) sealed
J#
public void SaveRuntimeMap(
string resourceID,
RuntimeMap map
)
JScript
public function SaveRuntimeMap(
resourceID : String,
map : RuntimeMap
)

Implements

ServerConnectionI.SaveRuntimeMap

See Also

LocalNativeConnection Class


SetResourceData Method

LocalNativeConnection.SetResourceData Method

Uploads data to a resource

Overload List

 | Name | Description
Public method | SetResourceData (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate) | Overridden.
Public method | SetResourceData (String, String, ResourceDataType, Stream) | Uploads data to a resource (inherited from ServerConnectionBase)

See Also

LocalNativeConnection Class


SetResourceData Method (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate)

LocalNativeConnection.SetResourceData Method (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetResourceData( _
ByVal resourceid As String, _
ByVal dataname As String, _
ByVal datatype As ResourceDataType, _
ByVal stream As Stream, _
ByVal callback As Utility.StreamCopyProgressDelegate _
) _
Implements ServerConnectionI.SetResourceData
C#
public override void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
)
C++
public:
virtual void SetResourceData(
String resourceid,
String dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
) override
J#
public override void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
)
JScript
public override function SetResourceData(
resourceid : String,
dataname : String,
datatype : ResourceDataType,
stream : Stream,
callback : Utility.StreamCopyProgressDelegate
)

Implements

ServerConnectionI.SetResourceData

See Also

LocalNativeConnection Class
LocalNativeConnection.SetResourceData Overload List


SetResourceXmlData Method

LocalNativeConnection.SetResourceXmlData Method

Writes raw data into a resource.

Overload List

 | Name | Description
Public method | SetResourceXmlData (String, Stream, Stream) | Overridden.
Public method | SetResourceXmlData (String, Stream) | Writes raw data into a resource. (inherited from ServerConnectionBase)

See Also

LocalNativeConnection Class


SetResourceXmlData Method (String, Stream, Stream)

LocalNativeConnection.SetResourceXmlData Method (String, Stream, Stream)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetResourceXmlData( _
ByVal resourceid As String, _
ByVal content As Stream, _
ByVal header As Stream _
)
C#
public override void SetResourceXmlData(
string resourceid,
Stream content,
Stream header
)
C++
public:
virtual void SetResourceXmlData(
String resourceid,
Stream content,
Stream header
) override
J#
public override void SetResourceXmlData(
string resourceid,
Stream content,
Stream header
)
JScript
public override function SetResourceXmlData(
resourceid : String,
content : Stream,
header : Stream
)

See Also

LocalNativeConnection Class
LocalNativeConnection.SetResourceXmlData Overload List


SetSelectionXml Method

LocalNativeConnection.SetSelectionXml Method
[image]

Sets the selection of a map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetSelectionXml( _
ByVal runtimeMap As String, _
ByVal selectionXml As String _
) _
Implements ServerConnectionI.SetSelectionXml
C#
public override void SetSelectionXml(
string runtimeMap,
string selectionXml
)
C++
public:
virtual void SetSelectionXml(
String runtimeMap,
String selectionXml
) override
J#
public override void SetSelectionXml(
string runtimeMap,
string selectionXml
)
JScript
public override function SetSelectionXml(
runtimeMap : String,
selectionXml : String
)

Parameters

runtimeMap
The resourceID of the runtime map
selectionXml
The selection xml

Implements

ServerConnectionI.SetSelectionXml

See Also

LocalNativeConnection Class


TestConnection Method

LocalNativeConnection.TestConnection Method

Overload List

 | Name | Description
Public method | TestConnection (String) | Overridden.
Public method | TestConnection (String, NameValueCollection) |
Public method | TestConnection (FeatureSource) | (inherited from ServerConnectionBase)

See Also

LocalNativeConnection Class


TestConnection Method (String)

LocalNativeConnection.TestConnection Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function TestConnection( _
ByVal featuresource As String _
) As String _
Implements ServerConnectionI.TestConnection
C#
public override string TestConnection(
string featuresource
)
C++
public:
virtual String TestConnection(
String featuresource
) override
J#
public override string TestConnection(
string featuresource
)
JScript
public override function TestConnection(
featuresource : String
) : String

Implements

ServerConnectionI.TestConnection

See Also

LocalNativeConnection Class
LocalNativeConnection.TestConnection Overload List


TestConnection Method (String, NameValueCollection)

LocalNativeConnection.TestConnection Method (String, NameValueCollection)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function TestConnection( _
ByVal providername As String, _
ByVal parameters As NameValueCollection _
) As String _
Implements ServerConnectionI.TestConnection
C#
public string TestConnection(
string providername,
NameValueCollection parameters
)
C++
public:
String TestConnection(
String providername,
NameValueCollection parameters
) sealed
J#
public string TestConnection(
string providername,
NameValueCollection parameters
)
JScript
public function TestConnection(
providername : String,
parameters : NameValueCollection
) : String

Implements

ServerConnectionI.TestConnection

See Also

LocalNativeConnection Class
LocalNativeConnection.TestConnection Overload List


UploadPackage Method

LocalNativeConnection.UploadPackage Method
[image]

Upload a MapGuide Package file to the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub UploadPackage( _
ByVal filename As String, _
ByVal callback As Utility.StreamCopyProgressDelegate _
) _
Implements ServerConnectionI.UploadPackage
C#
public override void UploadPackage(
string filename,
Utility.StreamCopyProgressDelegate callback
)
C++
public:
virtual void UploadPackage(
String filename,
Utility.StreamCopyProgressDelegate callback
) override
J#
public override void UploadPackage(
string filename,
Utility.StreamCopyProgressDelegate callback
)
JScript
public override function UploadPackage(
filename : String,
callback : Utility.StreamCopyProgressDelegate
)

Parameters

filename
Name of the file to upload
callback
A callback argument used to display progress. May be null.

Implements

ServerConnectionI.UploadPackage

See Also

LocalNativeConnection Class


MapDefinition Class

MapDefinition Class
See Also Example Members
[image]

Defines a Map, in either the library or session repository

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("MapDefinition", Namespace := "", IsNullable := False)>
Public Class MapDefinition
C#
[XmlRootAttribute("MapDefinition", Namespace = "", IsNullable = False)]
public class MapDefinition
C++
[XmlRootAttribute(L"MapDefinition", Namespace = L"", IsNullable = False)]
ref class MapDefinition
J#
/** @attribute XmlRootAttribute("MapDefinition", Namespace = "", IsNullable = False) */
public class MapDefinition
JScript
public
XmlRootAttribute("MapDefinition", Namespace = "", IsNullable = False)
class MapDefinition

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.MapDefinition
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMap

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapDefinition Members


MapDefinition Members

MapDefinition Members
See Also Example Constructors Fields Properties Methods
[image]

Defines a Map, in either the library or session repository

The following tables list the members exposed by MapDefinition.

Public Constructors

 | Name | Description
Public method | MapDefinition | Initializes a new instance of the MapDefinition class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | BackgroundColor |
Public property | BackGroundColorAsHTML |
Public property | BaseMapDefinition |
Public property | CoordinateSystem |
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | Extents |
Public property | LayerGroups | Gets or sets the groups defined in this map
Public property | Layers | Gets or sets the layers associated with this map
Public property | Metadata | Gets or sets the Metadata for the map
Public property | Name |
Public property | ResourceId |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapDefinition Class


MapDefinition Constructor

MapDefinition Constructor
[image]

Initializes a new instance of the MapDefinition class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapDefinition()
C++
public:
MapDefinition() sealed
J#
public MapDefinition()
JScript
public function MapDefinition()

See Also

MapDefinition Class


Fields

MapDefinition Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

MapDefinition Class


SchemaName Field

MapDefinition.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

MapDefinition Class


Properties

MapDefinition Properties
[image]

Public Properties

 | Name | Description
Public property | BackgroundColor |
Public property | BackGroundColorAsHTML |
Public property | BaseMapDefinition |
Public property | CoordinateSystem |
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | Extents |
Public property | LayerGroups | Gets or sets the groups defined in this map
Public property | Layers | Gets or sets the layers associated with this map
Public property | Metadata | Gets or sets the Metadata for the map
Public property | Name |
Public property | ResourceId |
Public property | XsdSchema |
Top

See Also

MapDefinition Class


BackgroundColor Property

MapDefinition.BackgroundColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property BackgroundColor As Color
C#
[XmlIgnoreAttribute]
public Color BackgroundColor { get; set; }
C++
[XmlIgnoreAttribute]
public property Color BackgroundColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public Color get_BackgroundColor();

/** property */
public void set_BackgroundColor(Color value);
JScript
public function get BackgroundColor() : Color

public function set BackgroundColor(value : Color);

See Also

MapDefinition Class


BackGroundColorAsHTML Property

MapDefinition.BackGroundColorAsHTML Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("BackgroundColor")>
Public Property BackGroundColorAsHTML As String
C#
[XmlElementAttribute("BackgroundColor")]
public string BackGroundColorAsHTML { get; set; }
C++
[XmlElementAttribute(L"BackgroundColor")]
public property string BackGroundColorAsHTML sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute("BackgroundColor") */
/** property */
public string get_BackGroundColorAsHTML();

/** property */
public void set_BackGroundColorAsHTML(string value);
JScript
public function get BackGroundColorAsHTML() : String

public function set BackGroundColorAsHTML(value : String);

See Also

MapDefinition Class


BaseMapDefinition Property

MapDefinition.BaseMapDefinition Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseMapDefinition As MapDefinitionTypeBaseMapDefinition
C#
public MapDefinitionTypeBaseMapDefinition BaseMapDefinition { get; set; }
C++
public property MapDefinitionTypeBaseMapDefinition BaseMapDefinition sealed {
MapDefinitionTypeBaseMapDefinition get();
void set(MapDefinitionTypeBaseMapDefinition value);
}
J#
/** property */
public MapDefinitionTypeBaseMapDefinition get_BaseMapDefinition();

/** property */
public void set_BaseMapDefinition(MapDefinitionTypeBaseMapDefinition value);
JScript
public function get BaseMapDefinition() : MapDefinitionTypeBaseMapDefinition

public function set BaseMapDefinition(value : MapDefinitionTypeBaseMapDefinition);

See Also

MapDefinition Class


CoordinateSystem Property

MapDefinition.CoordinateSystem Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CoordinateSystem As String
C#
public string CoordinateSystem { get; set; }
C++
public property string CoordinateSystem sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CoordinateSystem();

/** property */
public void set_CoordinateSystem(string value);
JScript
public function get CoordinateSystem() : String

public function set CoordinateSystem(value : String);

See Also

MapDefinition Class


CurrentConnection Property

MapDefinition.CurrentConnection Property
[image]

Gets or sets the connection used in various operations performed on this object

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property CurrentConnection As ServerConnectionI
C#
[XmlIgnoreAttribute]
public ServerConnectionI CurrentConnection { get; set; }
C++
[XmlIgnoreAttribute]
public property ServerConnectionI CurrentConnection sealed {
ServerConnectionI get();
void set(ServerConnectionI value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public ServerConnectionI get_CurrentConnection();

/** property */
public void set_CurrentConnection(ServerConnectionI value);
JScript
public function get CurrentConnection() : ServerConnectionI

public function set CurrentConnection(value : ServerConnectionI);

See Also

MapDefinition Class


Extents Property

MapDefinition.Extents Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Extents As Box2DType
C#
public Box2DType Extents { get; set; }
C++
public property Box2DType Extents sealed {
Box2DType get();
void set(Box2DType value);
}
J#
/** property */
public Box2DType get_Extents();

/** property */
public void set_Extents(Box2DType value);
JScript
public function get Extents() : Box2DType

public function set Extents(value : Box2DType);

See Also

MapDefinition Class


LayerGroups Property

MapDefinition.LayerGroups Property
[image]

Gets or sets the groups defined in this map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("MapLayerGroup")>
Public Property LayerGroups As MapLayerGroupTypeCollection
C#
[XmlElementAttribute("MapLayerGroup")]
public MapLayerGroupTypeCollection LayerGroups { get; set; }
C++
[XmlElementAttribute(L"MapLayerGroup")]
public property MapLayerGroupTypeCollection LayerGroups sealed {
MapLayerGroupTypeCollection get();
void set(MapLayerGroupTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("MapLayerGroup") */
/** property */
public MapLayerGroupTypeCollection get_LayerGroups();

/** property */
public void set_LayerGroups(MapLayerGroupTypeCollection value);
JScript
public function get LayerGroups() : MapLayerGroupTypeCollection

public function set LayerGroups(value : MapLayerGroupTypeCollection);

See Also

MapDefinition Class


Layers Property

MapDefinition.Layers Property
[image]

Gets or sets the layers associated with this map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("MapLayer")>
Public Property Layers As MapLayerTypeCollection
C#
[XmlElementAttribute("MapLayer")]
public MapLayerTypeCollection Layers { get; set; }
C++
[XmlElementAttribute(L"MapLayer")]
public property MapLayerTypeCollection Layers sealed {
MapLayerTypeCollection get();
void set(MapLayerTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("MapLayer") */
/** property */
public MapLayerTypeCollection get_Layers();

/** property */
public void set_Layers(MapLayerTypeCollection value);
JScript
public function get Layers() : MapLayerTypeCollection

public function set Layers(value : MapLayerTypeCollection);

See Also

MapDefinition Class


Metadata Property

MapDefinition.Metadata Property
[image]

Gets or sets the Metadata for the map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Metadata As String
C#
public string Metadata { get; set; }
C++
public property string Metadata sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Metadata();

/** property */
public void set_Metadata(string value);
JScript
public function get Metadata() : String

public function set Metadata(value : String);

See Also

MapDefinition Class


Name Property

MapDefinition.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

MapDefinition Class


ResourceId Property

MapDefinition.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ResourceId As String
C#
[XmlIgnoreAttribute]
public string ResourceId { get; set; }
C++
[XmlIgnoreAttribute]
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

MapDefinition Class


XsdSchema Property

MapDefinition.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

MapDefinition Class


MapDefinitionTypeBaseMapDefinition Class

MapDefinitionTypeBaseMapDefinition Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MapDefinitionTypeBaseMapDefinition
C#
public class MapDefinitionTypeBaseMapDefinition
C++
ref class MapDefinitionTypeBaseMapDefinition
J#
public class MapDefinitionTypeBaseMapDefinition
JScript
public class MapDefinitionTypeBaseMapDefinition

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.MapDefinitionTypeBaseMapDefinition

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapDefinitionTypeBaseMapDefinition Members


MapDefinitionTypeBaseMapDefinition Members

MapDefinitionTypeBaseMapDefinition Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapDefinitionTypeBaseMapDefinition.

Public Constructors

 | Name | Description
Public method | MapDefinitionTypeBaseMapDefinition | Initializes a new instance of the MapDefinitionTypeBaseMapDefinition class.
Top

Public Properties

 | Name | Description
Public property | BaseMapLayerGroup |
Public property | FiniteDisplayScale |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapDefinitionTypeBaseMapDefinition Class


MapDefinitionTypeBaseMapDefinition Constructor

MapDefinitionTypeBaseMapDefinition Constructor
[image]

Initializes a new instance of the MapDefinitionTypeBaseMapDefinition class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapDefinitionTypeBaseMapDefinition()
C++
public:
MapDefinitionTypeBaseMapDefinition() sealed
J#
public MapDefinitionTypeBaseMapDefinition()
JScript
public function MapDefinitionTypeBaseMapDefinition()

See Also

MapDefinitionTypeBaseMapDefinition Class


Properties

MapDefinitionTypeBaseMapDefinition Properties
[image]

Public Properties

 | Name | Description
Public property | BaseMapLayerGroup |
Public property | FiniteDisplayScale |
Top

See Also

MapDefinitionTypeBaseMapDefinition Class


BaseMapLayerGroup Property

MapDefinitionTypeBaseMapDefinition.BaseMapLayerGroup Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("BaseMapLayerGroup")>
Public Property BaseMapLayerGroup As BaseMapLayerGroupCommonTypeCollection
C#
[XmlElementAttribute("BaseMapLayerGroup")]
public BaseMapLayerGroupCommonTypeCollection BaseMapLayerGroup { get; set; }
C++
[XmlElementAttribute(L"BaseMapLayerGroup")]
public property BaseMapLayerGroupCommonTypeCollection BaseMapLayerGroup sealed {
BaseMapLayerGroupCommonTypeCollection get();
void set(BaseMapLayerGroupCommonTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("BaseMapLayerGroup") */
/** property */
public BaseMapLayerGroupCommonTypeCollection get_BaseMapLayerGroup();

/** property */
public void set_BaseMapLayerGroup(BaseMapLayerGroupCommonTypeCollection value);
JScript
public function get BaseMapLayerGroup() : BaseMapLayerGroupCommonTypeCollection

public function set BaseMapLayerGroup(value : BaseMapLayerGroupCommonTypeCollection);

See Also

MapDefinitionTypeBaseMapDefinition Class


FiniteDisplayScale Property

MapDefinitionTypeBaseMapDefinition.FiniteDisplayScale Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("FiniteDisplayScale")>
Public Property FiniteDisplayScale As DoubleCollection
C#
[XmlElementAttribute("FiniteDisplayScale")]
public DoubleCollection FiniteDisplayScale { get; set; }
C++
[XmlElementAttribute(L"FiniteDisplayScale")]
public property DoubleCollection FiniteDisplayScale sealed {
DoubleCollection get();
void set(DoubleCollection value);
}
J#
/** @attribute XmlElementAttribute("FiniteDisplayScale") */
/** property */
public DoubleCollection get_FiniteDisplayScale();

/** property */
public void set_FiniteDisplayScale(DoubleCollection value);
JScript
public function get FiniteDisplayScale() : DoubleCollection

public function set FiniteDisplayScale(value : DoubleCollection);

See Also

MapDefinitionTypeBaseMapDefinition Class


MapLayerGroupCommonType Class

MapLayerGroupCommonType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(MapLayerGroupType)), _
XmlIncludeAttribute(GetType(BaseMapLayerGroupCommonType))>
Public Class MapLayerGroupCommonType
C#
[XmlIncludeAttribute(typeof(MapLayerGroupType))]
[XmlIncludeAttribute(typeof(BaseMapLayerGroupCommonType))]
public class MapLayerGroupCommonType
C++
[XmlIncludeAttribute(typeof(MapLayerGroupType))]
[XmlIncludeAttribute(typeof(BaseMapLayerGroupCommonType))]
ref class MapLayerGroupCommonType
J#
/** @attribute XmlIncludeAttribute(typeof(MapLayerGroupType)) */
/** @attribute XmlIncludeAttribute(typeof(BaseMapLayerGroupCommonType)) */
public class MapLayerGroupCommonType
JScript
public
XmlIncludeAttribute(typeof(MapLayerGroupType))
XmlIncludeAttribute(typeof(BaseMapLayerGroupCommonType))
class MapLayerGroupCommonType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.MapLayerGroupCommonType
OSGeo.MapGuide.MaestroAPI.BaseMapLayerGroupCommonType
OSGeo.MapGuide.MaestroAPI.MapLayerGroupType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapLayerGroupCommonType Members


MapLayerGroupCommonType Members

MapLayerGroupCommonType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapLayerGroupCommonType.

Public Constructors

 | Name | Description
Public method | MapLayerGroupCommonType | Initializes a new instance of the MapLayerGroupCommonType class.
Top

Public Properties

 | Name | Description
Public property | ExpandInLegend | Gets or sets a value indicating if this groups layers are displayed in the map legend
Public property | LegendLabel | Gets or sets the label to use for this group
Public property | Name | Gets or sets the name of the group
Public property | ShowInLegend | Gets or sets a value indicating if this group is displayed in the map legend
Public property | Visible | Gets or set the group visibility
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapLayerGroupCommonType Class


MapLayerGroupCommonType Constructor

MapLayerGroupCommonType Constructor
[image]

Initializes a new instance of the MapLayerGroupCommonType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapLayerGroupCommonType()
C++
public:
MapLayerGroupCommonType() sealed
J#
public MapLayerGroupCommonType()
JScript
public function MapLayerGroupCommonType()

See Also

MapLayerGroupCommonType Class


Properties

MapLayerGroupCommonType Properties
[image]

Public Properties

 | Name | Description
Public property | ExpandInLegend | Gets or sets a value indicating if this groups layers are displayed in the map legend
Public property | LegendLabel | Gets or sets the label to use for this group
Public property | Name | Gets or sets the name of the group
Public property | ShowInLegend | Gets or sets a value indicating if this group is displayed in the map legend
Public property | Visible | Gets or set the group visibility
Top

See Also

MapLayerGroupCommonType Class


ExpandInLegend Property

MapLayerGroupCommonType.ExpandInLegend Property
[image]

Gets or sets a value indicating if this groups layers are displayed in the map legend

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpandInLegend As Boolean
C#
public bool ExpandInLegend { get; set; }
C++
public property bool ExpandInLegend sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ExpandInLegend();

/** property */
public void set_ExpandInLegend(bool value);
JScript
public function get ExpandInLegend() : bool

public function set ExpandInLegend(value : bool);

See Also

MapLayerGroupCommonType Class


LegendLabel Property

MapLayerGroupCommonType.LegendLabel Property
[image]

Gets or sets the label to use for this group

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LegendLabel As String
C#
public string LegendLabel { get; set; }
C++
public property string LegendLabel sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LegendLabel();

/** property */
public void set_LegendLabel(string value);
JScript
public function get LegendLabel() : String

public function set LegendLabel(value : String);

See Also

MapLayerGroupCommonType Class


Name Property

MapLayerGroupCommonType.Name Property
[image]

Gets or sets the name of the group

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

MapLayerGroupCommonType Class


ShowInLegend Property

MapLayerGroupCommonType.ShowInLegend Property
[image]

Gets or sets a value indicating if this group is displayed in the map legend

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowInLegend As Boolean
C#
public bool ShowInLegend { get; set; }
C++
public property bool ShowInLegend sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowInLegend();

/** property */
public void set_ShowInLegend(bool value);
JScript
public function get ShowInLegend() : bool

public function set ShowInLegend(value : bool);

See Also

MapLayerGroupCommonType Class


Visible Property

MapLayerGroupCommonType.Visible Property
[image]

Gets or set the group visibility

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible { get; set; }
C++
public property bool Visible sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Visible();

/** property */
public void set_Visible(bool value);
JScript
public function get Visible() : bool

public function set Visible(value : bool);

See Also

MapLayerGroupCommonType Class


MapLayerGroupType Class

MapLayerGroupType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MapLayerGroupType
Inherits MapLayerGroupCommonType
C#
public class MapLayerGroupType : MapLayerGroupCommonType
C++
ref class MapLayerGroupType : MapLayerGroupCommonType
J#
public class MapLayerGroupType extends MapLayerGroupCommonType
JScript
public class MapLayerGroupType extends MapLayerGroupCommonType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.MapLayerGroupCommonType
OSGeo.MapGuide.MaestroAPI.MapLayerGroupType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapLayerGroupType Members


MapLayerGroupType Members

MapLayerGroupType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapLayerGroupType.

Public Constructors

 | Name | Description
Public method | MapLayerGroupType | Initializes a new instance of the MapLayerGroupType class.
Top

Public Properties

 | Name | Description
Public property | ExpandInLegend | Gets or sets a value indicating if this groups layers are displayed in the map legend (inherited from MapLayerGroupCommonType)
Public property | Group |
Public property | LegendLabel | Gets or sets the label to use for this group (inherited from MapLayerGroupCommonType)
Public property | Name | Gets or sets the name of the group (inherited from MapLayerGroupCommonType)
Public property | ShowInLegend | Gets or sets a value indicating if this group is displayed in the map legend (inherited from MapLayerGroupCommonType)
Public property | Visible | Gets or set the group visibility (inherited from MapLayerGroupCommonType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFullPath | Gets the full path of the group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapLayerGroupType Class


MapLayerGroupType Constructor

MapLayerGroupType Constructor
[image]

Initializes a new instance of the MapLayerGroupType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapLayerGroupType()
C++
public:
MapLayerGroupType() sealed
J#
public MapLayerGroupType()
JScript
public function MapLayerGroupType()

See Also

MapLayerGroupType Class


Properties

MapLayerGroupType Properties
[image]

Public Properties

 | Name | Description
Public property | ExpandInLegend | Gets or sets a value indicating if this groups layers are displayed in the map legend (inherited from MapLayerGroupCommonType)
Public property | Group |
Public property | LegendLabel | Gets or sets the label to use for this group (inherited from MapLayerGroupCommonType)
Public property | Name | Gets or sets the name of the group (inherited from MapLayerGroupCommonType)
Public property | ShowInLegend | Gets or sets a value indicating if this group is displayed in the map legend (inherited from MapLayerGroupCommonType)
Public property | Visible | Gets or set the group visibility (inherited from MapLayerGroupCommonType)
Top

See Also

MapLayerGroupType Class


Group Property

MapLayerGroupType.Group Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Group As String
C#
public string Group { get; set; }
C++
public property string Group sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Group();

/** property */
public void set_Group(string value);
JScript
public function get Group() : String

public function set Group(value : String);

See Also

MapLayerGroupType Class


Methods

MapLayerGroupType Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFullPath | Gets the full path of the group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapLayerGroupType Class


GetFullPath Method

MapLayerGroupType.GetFullPath Method
[image]

Gets the full path of the group

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFullPath( _
ByVal separator As String, _
ByVal parent As MapDefinition _
) As String
C#
public string GetFullPath(
string separator,
MapDefinition parent
)
C++
public:
String GetFullPath(
String separator,
MapDefinition parent
) sealed
J#
public string GetFullPath(
string separator,
MapDefinition parent
)
JScript
public function GetFullPath(
separator : String,
parent : MapDefinition
) : String

Parameters

separator
The string used to separate the individual levels
parent
The parent mapdefinition, use null for the current parent

See Also

MapLayerGroupType Class


MapLayerGroupTypeCollection Class

MapLayerGroupTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class MapLayerGroupTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class MapLayerGroupTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class MapLayerGroupTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class MapLayerGroupTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class MapLayerGroupTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.MapLayerGroupTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapLayerGroupTypeCollection Members


MapLayerGroupTypeCollection Members

MapLayerGroupTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapLayerGroupTypeCollection.

Public Constructors

 | Name | Description
Public method | MapLayerGroupTypeCollection | Initializes a new instance of the MapLayerGroupTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapLayerGroupTypeCollection Class


MapLayerGroupTypeCollection Constructor

MapLayerGroupTypeCollection Constructor
[image]

Initializes a new instance of the MapLayerGroupTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapLayerGroupTypeCollection()
C++
public:
MapLayerGroupTypeCollection() sealed
J#
public MapLayerGroupTypeCollection()
JScript
public function MapLayerGroupTypeCollection()

See Also

MapLayerGroupTypeCollection Class


Properties

MapLayerGroupTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

MapLayerGroupTypeCollection Class


Item Property

MapLayerGroupTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As MapLayerGroupType
C#
public MapLayerGroupType this[
int idx
] { get; set; }
C++
public property MapLayerGroupType default[int idx] sealed {
MapLayerGroupType get(int idx);
void set(int idx, MapLayerGroupType value);
}
J#
/** property */
public MapLayerGroupType get_Item(int idx);

/** property */
public void set_Item(int idx, MapLayerGroupType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

MapLayerGroupTypeCollection Class


Methods

MapLayerGroupTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapLayerGroupTypeCollection Class


Add Method

MapLayerGroupTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As MapLayerGroupType _
) As Integer
C#
public int Add(
MapLayerGroupType value
)
C++
public:
int Add(
MapLayerGroupType value
) sealed
J#
public int Add(
MapLayerGroupType value
)
JScript
public function Add(
value : MapLayerGroupType
) : int

See Also

MapLayerGroupTypeCollection Class


IndexOf Method

MapLayerGroupTypeCollection.IndexOf Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
ByVal value As MapLayerGroupType _
) As Integer
C#
public int IndexOf(
MapLayerGroupType value
)
C++
public:
int IndexOf(
MapLayerGroupType value
) sealed
J#
public int IndexOf(
MapLayerGroupType value
)
JScript
public function IndexOf(
value : MapLayerGroupType
) : int

See Also

MapLayerGroupTypeCollection Class


MapLayerType Class

MapLayerType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MapLayerType
Inherits BaseMapLayerType
C#
public class MapLayerType : BaseMapLayerType
C++
ref class MapLayerType : BaseMapLayerType
J#
public class MapLayerType extends BaseMapLayerType
JScript
public class MapLayerType extends BaseMapLayerType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.BaseMapLayerType
OSGeo.MapGuide.MaestroAPI.MapLayerType
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMapLayer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapLayerType Members


MapLayerType Members

MapLayerType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapLayerType.

Public Constructors

 | Name | Description
Public method | MapLayerType | Initializes a new instance of the MapLayerType class.
Top

Public Properties

 | Name | Description
Public property | ExpandInLegend | (inherited from BaseMapLayerType)
Public property | Group | Gets or sets the Group that this layer belongs to
Public property | Layers | Returns a list of layers present in the current group. This method does NOT run in O(n).
Public property | LegendLabel | (inherited from BaseMapLayerType)
Public property | Name | (inherited from BaseMapLayerType)
Public property | Parent | (inherited from BaseMapLayerType)
Public property | ResourceId | (inherited from BaseMapLayerType)
Public property | Selectable | (inherited from BaseMapLayerType)
Public property | ShowInLegend | (inherited from BaseMapLayerType)
Public property | Visible | Gets or sets the layer visibility, this attribute is combined with the layers DisplayScale, to determine actual visibility.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFullPath | Gets the full path of the group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapLayerType Class


MapLayerType Constructor

MapLayerType Constructor
[image]

Initializes a new instance of the MapLayerType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapLayerType()
C++
public:
MapLayerType() sealed
J#
public MapLayerType()
JScript
public function MapLayerType()

See Also

MapLayerType Class


Properties

MapLayerType Properties
[image]

Public Properties

 | Name | Description
Public property | ExpandInLegend | (inherited from BaseMapLayerType)
Public property | Group | Gets or sets the Group that this layer belongs to
Public property | Layers | Returns a list of layers present in the current group. This method does NOT run in O(n).
Public property | LegendLabel | (inherited from BaseMapLayerType)
Public property | Name | (inherited from BaseMapLayerType)
Public property | Parent | (inherited from BaseMapLayerType)
Public property | ResourceId | (inherited from BaseMapLayerType)
Public property | Selectable | (inherited from BaseMapLayerType)
Public property | ShowInLegend | (inherited from BaseMapLayerType)
Public property | Visible | Gets or sets the layer visibility, this attribute is combined with the layers DisplayScale, to determine actual visibility.
Top

See Also

MapLayerType Class


Group Property

MapLayerType.Group Property
[image]

Gets or sets the Group that this layer belongs to

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Group As String
C#
public string Group { get; set; }
C++
public property string Group sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Group();

/** property */
public void set_Group(string value);
JScript
public function get Group() : String

public function set Group(value : String);

See Also

MapLayerType Class


Layers Property

MapLayerType.Layers Property
[image]

Returns a list of layers present in the current group. This method does NOT run in O(n).

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public ReadOnly Property Layers As MapLayerTypeCollection
C#
[XmlIgnoreAttribute]
public MapLayerTypeCollection Layers { get; }
C++
[XmlIgnoreAttribute]
public property MapLayerTypeCollection Layers sealed {
MapLayerTypeCollection get();
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public MapLayerTypeCollection get_Layers();
JScript
public function get Layers() : MapLayerTypeCollection

See Also

MapLayerType Class


Visible Property

MapLayerType.Visible Property
[image]

Gets or sets the layer visibility, this attribute is combined with the layers DisplayScale, to determine actual visibility.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Visible As Boolean
C#
public virtual bool Visible { get; set; }
C++
public virtual property bool Visible {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Visible();

/** property */
public void set_Visible(bool value);
JScript
public function get Visible() : bool

public function set Visible(value : bool);

See Also

MapLayerType Class


Methods

MapLayerType Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFullPath | Gets the full path of the group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapLayerType Class


GetFullPath Method

MapLayerType.GetFullPath Method
[image]

Gets the full path of the group

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFullPath( _
ByVal separator As String, _
ByVal parent As MapDefinition _
) As String
C#
public string GetFullPath(
string separator,
MapDefinition parent
)
C++
public:
String GetFullPath(
String separator,
MapDefinition parent
) sealed
J#
public string GetFullPath(
string separator,
MapDefinition parent
)
JScript
public function GetFullPath(
separator : String,
parent : MapDefinition
) : String

Parameters

separator
The string used to separate the individual levels
parent
The parent mapdefinition, use null for the current parent

See Also

MapLayerType Class


MapLayerTypeCollection Class

MapLayerTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class MapLayerTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class MapLayerTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class MapLayerTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class MapLayerTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class MapLayerTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.MapLayerTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapLayerTypeCollection Members


MapLayerTypeCollection Members

MapLayerTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapLayerTypeCollection.

Public Constructors

 | Name | Description
Public method | MapLayerTypeCollection | Initializes a new instance of the MapLayerTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapLayerTypeCollection Class


MapLayerTypeCollection Constructor

MapLayerTypeCollection Constructor
[image]

Initializes a new instance of the MapLayerTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapLayerTypeCollection()
C++
public:
MapLayerTypeCollection() sealed
J#
public MapLayerTypeCollection()
JScript
public function MapLayerTypeCollection()

See Also

MapLayerTypeCollection Class


Properties

MapLayerTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

MapLayerTypeCollection Class


Item Property

MapLayerTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As MapLayerType
C#
public MapLayerType this[
int idx
] { get; set; }
C++
public property MapLayerType default[int idx] sealed {
MapLayerType get(int idx);
void set(int idx, MapLayerType value);
}
J#
/** property */
public MapLayerType get_Item(int idx);

/** property */
public void set_Item(int idx, MapLayerType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

MapLayerTypeCollection Class


Methods

MapLayerTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapLayerTypeCollection Class


Add Method

MapLayerTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As MapLayerType _
) As Integer
C#
public int Add(
MapLayerType value
)
C++
public:
int Add(
MapLayerType value
) sealed
J#
public int Add(
MapLayerType value
)
JScript
public function Add(
value : MapLayerType
) : int

See Also

MapLayerTypeCollection Class


IndexOf Method

MapLayerTypeCollection.IndexOf Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
ByVal value As MapLayerType _
) As Integer
C#
public int IndexOf(
MapLayerType value
)
C++
public:
int IndexOf(
MapLayerType value
) sealed
J#
public int IndexOf(
MapLayerType value
)
JScript
public function IndexOf(
value : MapLayerType
) : int

See Also

MapLayerTypeCollection Class


MapType Class

MapType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MapType
Inherits ResourceReferenceType
C#
public class MapType : ResourceReferenceType
C++
ref class MapType : ResourceReferenceType
J#
public class MapType extends ResourceReferenceType
JScript
public class MapType extends ResourceReferenceType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceReferenceType
OSGeo.MapGuide.MaestroAPI.MapType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapType Members


MapType Members

MapType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapType.

Public Constructors

 | Name | Description
Public method | MapType | Initializes a new instance of the MapType class.
Top

Public Properties

 | Name | Description
Public property | HyperlinkTarget |
Public property | HyperlinkTargetFrame |
Public property | InitialView |
Public property | ResourceId | (inherited from ResourceReferenceType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapType Class


MapType Constructor

MapType Constructor
[image]

Initializes a new instance of the MapType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapType()
C++
public:
MapType() sealed
J#
public MapType()
JScript
public function MapType()

See Also

MapType Class


Properties

MapType Properties
[image]

Public Properties

 | Name | Description
Public property | HyperlinkTarget |
Public property | HyperlinkTargetFrame |
Public property | InitialView |
Public property | ResourceId | (inherited from ResourceReferenceType)
Top

See Also

MapType Class


HyperlinkTarget Property

MapType.HyperlinkTarget Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property HyperlinkTarget As TargetType
C#
public TargetType HyperlinkTarget { get; set; }
C++
public property TargetType HyperlinkTarget sealed {
TargetType get();
void set(TargetType value);
}
J#
/** property */
public TargetType get_HyperlinkTarget();

/** property */
public void set_HyperlinkTarget(TargetType value);
JScript
public function get HyperlinkTarget() : TargetType

public function set HyperlinkTarget(value : TargetType);

See Also

MapType Class


HyperlinkTargetFrame Property

MapType.HyperlinkTargetFrame Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property HyperlinkTargetFrame As String
C#
public string HyperlinkTargetFrame { get; set; }
C++
public property string HyperlinkTargetFrame sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_HyperlinkTargetFrame();

/** property */
public void set_HyperlinkTargetFrame(string value);
JScript
public function get HyperlinkTargetFrame() : String

public function set HyperlinkTargetFrame(value : String);

See Also

MapType Class


InitialView Property

MapType.InitialView Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property InitialView As MapViewType
C#
public MapViewType InitialView { get; set; }
C++
public property MapViewType InitialView sealed {
MapViewType get();
void set(MapViewType value);
}
J#
/** property */
public MapViewType get_InitialView();

/** property */
public void set_InitialView(MapViewType value);
JScript
public function get InitialView() : MapViewType

public function set InitialView(value : MapViewType);

See Also

MapType Class


MapViewType Class

MapViewType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MapViewType
C#
public class MapViewType
C++
ref class MapViewType
J#
public class MapViewType
JScript
public class MapViewType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.MapViewType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapViewType Members


MapViewType Members

MapViewType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapViewType.

Public Constructors

 | Name | Description
Public method | MapViewType | Initializes a new instance of the MapViewType class.
Top

Public Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | Scale |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapViewType Class


MapViewType Constructor

MapViewType Constructor
[image]

Initializes a new instance of the MapViewType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapViewType()
C++
public:
MapViewType() sealed
J#
public MapViewType()
JScript
public function MapViewType()

See Also

MapViewType Class


Properties

MapViewType Properties
[image]

Public Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | Scale |
Top

See Also

MapViewType Class


CenterX Property

MapViewType.CenterX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CenterX As Double
C#
public double CenterX { get; set; }
C++
public property double CenterX sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_CenterX();

/** property */
public void set_CenterX(double value);
JScript
public function get CenterX() : double

public function set CenterX(value : double);

See Also

MapViewType Class


CenterY Property

MapViewType.CenterY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CenterY As Double
C#
public double CenterY { get; set; }
C++
public property double CenterY sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_CenterY();

/** property */
public void set_CenterY(double value);
JScript
public function get CenterY() : double

public function set CenterY(value : double);

See Also

MapViewType Class


Scale Property

MapViewType.Scale Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Double
C#
public double Scale { get; set; }
C++
public property double Scale sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Scale();

/** property */
public void set_Scale(double value);
JScript
public function get Scale() : double

public function set Scale(value : double);

See Also

MapViewType Class


MarkSymbolType Class

MarkSymbolType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MarkSymbolType
Inherits SymbolType
C#
public class MarkSymbolType : SymbolType
C++
ref class MarkSymbolType : SymbolType
J#
public class MarkSymbolType extends SymbolType
JScript
public class MarkSymbolType extends SymbolType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolType
OSGeo.MapGuide.MaestroAPI.MarkSymbolType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MarkSymbolType Members


MarkSymbolType Members

MarkSymbolType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MarkSymbolType.

Public Constructors

 | Name | Description
Public method | MarkSymbolType | Initializes a new instance of the MarkSymbolType class.
Top

Public Properties

 | Name | Description
Public property | Edge |
Public property | ExtendedData1 |
Public property | Fill |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | Shape |
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | Unit | (inherited from SymbolType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MarkSymbolType Class


MarkSymbolType Constructor

MarkSymbolType Constructor
[image]

Initializes a new instance of the MarkSymbolType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MarkSymbolType()
C++
public:
MarkSymbolType() sealed
J#
public MarkSymbolType()
JScript
public function MarkSymbolType()

See Also

MarkSymbolType Class


Properties

MarkSymbolType Properties
[image]

Public Properties

 | Name | Description
Public property | Edge |
Public property | ExtendedData1 |
Public property | Fill |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | Shape |
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | Unit | (inherited from SymbolType)
Top

See Also

MarkSymbolType Class


Edge Property

MarkSymbolType.Edge Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Edge As StrokeType
C#
public StrokeType Edge { get; set; }
C++
public property StrokeType Edge sealed {
StrokeType get();
void set(StrokeType value);
}
J#
/** property */
public StrokeType get_Edge();

/** property */
public void set_Edge(StrokeType value);
JScript
public function get Edge() : StrokeType

public function set Edge(value : StrokeType);

See Also

MarkSymbolType Class


ExtendedData1 Property

MarkSymbolType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

MarkSymbolType Class


Fill Property

MarkSymbolType.Fill Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Fill As FillType
C#
public FillType Fill { get; set; }
C++
public property FillType Fill sealed {
FillType get();
void set(FillType value);
}
J#
/** property */
public FillType get_Fill();

/** property */
public void set_Fill(FillType value);
JScript
public function get Fill() : FillType

public function set Fill(value : FillType);

See Also

MarkSymbolType Class


Shape Property

MarkSymbolType.Shape Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Shape As ShapeType
C#
public ShapeType Shape { get; set; }
C++
public property ShapeType Shape sealed {
ShapeType get();
void set(ShapeType value);
}
J#
/** property */
public ShapeType get_Shape();

/** property */
public void set_Shape(ShapeType value);
JScript
public function get Shape() : ShapeType

public function set Shape(value : ShapeType);

See Also

MarkSymbolType Class


MeasureCommandType Class

MeasureCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MeasureCommandType
Inherits TargetedCommandType
C#
public class MeasureCommandType : TargetedCommandType
C++
ref class MeasureCommandType : TargetedCommandType
J#
public class MeasureCommandType extends TargetedCommandType
JScript
public class MeasureCommandType extends TargetedCommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.TargetedCommandType
OSGeo.MapGuide.MaestroAPI.MeasureCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MeasureCommandType Members


MeasureCommandType Members

MeasureCommandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MeasureCommandType.

Public Constructors

 | Name | Description
Public method | MeasureCommandType | Initializes a new instance of the MeasureCommandType class.
Top

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | Target | (inherited from TargetedCommandType)
Public property | TargetFrame | (inherited from TargetedCommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MeasureCommandType Class


MeasureCommandType Constructor

MeasureCommandType Constructor
[image]

Initializes a new instance of the MeasureCommandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MeasureCommandType()
C++
public:
MeasureCommandType() sealed
J#
public MeasureCommandType()
JScript
public function MeasureCommandType()

See Also

MeasureCommandType Class


NameStringPairType Class

NameStringPairType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NameStringPairType
C#
public class NameStringPairType
C++
ref class NameStringPairType
J#
public class NameStringPairType
JScript
public class NameStringPairType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.NameStringPairType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NameStringPairType Members


NameStringPairType Members

NameStringPairType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by NameStringPairType.

Public Constructors

 | Name | Description
Public method | NameStringPairType | Initializes a new instance of the NameStringPairType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Name |
Public property | Value |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NameStringPairType Class


NameStringPairType Constructor

NameStringPairType Constructor
[image]

Initializes a new instance of the NameStringPairType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NameStringPairType()
C++
public:
NameStringPairType() sealed
J#
public NameStringPairType()
JScript
public function NameStringPairType()

See Also

NameStringPairType Class


Properties

NameStringPairType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Name |
Public property | Value |
Top

See Also

NameStringPairType Class


ExtendedData1 Property

NameStringPairType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

NameStringPairType Class


Name Property

NameStringPairType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

NameStringPairType Class


Value Property

NameStringPairType.Value Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
C++
public property string Value sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

NameStringPairType Class


NameStringPairTypeCollection Class

NameStringPairTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class NameStringPairTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class NameStringPairTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class NameStringPairTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class NameStringPairTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class NameStringPairTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.NameStringPairTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NameStringPairTypeCollection Members


NameStringPairTypeCollection Members

NameStringPairTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by NameStringPairTypeCollection.

Public Constructors

 | Name | Description
Public method | NameStringPairTypeCollection | Initializes a new instance of the NameStringPairTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NameStringPairTypeCollection Class


NameStringPairTypeCollection Constructor

NameStringPairTypeCollection Constructor
[image]

Initializes a new instance of the NameStringPairTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NameStringPairTypeCollection()
C++
public:
NameStringPairTypeCollection() sealed
J#
public NameStringPairTypeCollection()
JScript
public function NameStringPairTypeCollection()

See Also

NameStringPairTypeCollection Class


Properties

NameStringPairTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

NameStringPairTypeCollection Class


Item Property

NameStringPairTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As NameStringPairType
C#
public NameStringPairType this[
int idx
] { get; set; }
C++
public property NameStringPairType default[int idx] sealed {
NameStringPairType get(int idx);
void set(int idx, NameStringPairType value);
}
J#
/** property */
public NameStringPairType get_Item(int idx);

/** property */
public void set_Item(int idx, NameStringPairType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

NameStringPairTypeCollection Class


Methods

NameStringPairTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NameStringPairTypeCollection Class


Add Method

NameStringPairTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As NameStringPairType _
) As Integer
C#
public int Add(
NameStringPairType value
)
C++
public:
int Add(
NameStringPairType value
) sealed
J#
public int Add(
NameStringPairType value
)
JScript
public function Add(
value : NameStringPairType
) : int

See Also

NameStringPairTypeCollection Class


NameValuePairType Class

NameValuePairType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class NameValuePairType
C#
public class NameValuePairType
C++
ref class NameValuePairType
J#
public class NameValuePairType
JScript
public class NameValuePairType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.NameValuePairType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NameValuePairType Members


NameValuePairType Members

NameValuePairType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by NameValuePairType.

Public Constructors

 | Name | Description
Public method | NameValuePairType | Initializes a new instance of the NameValuePairType class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Value |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NameValuePairType Class


NameValuePairType Constructor

NameValuePairType Constructor
[image]

Initializes a new instance of the NameValuePairType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NameValuePairType()
C++
public:
NameValuePairType() sealed
J#
public NameValuePairType()
JScript
public function NameValuePairType()

See Also

NameValuePairType Class


Properties

NameValuePairType Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Value |
Top

See Also

NameValuePairType Class


Name Property

NameValuePairType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

NameValuePairType Class


Value Property

NameValuePairType.Value Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
C++
public property string Value sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

NameValuePairType Class


NameValuePairTypeCollection Class

NameValuePairTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class NameValuePairTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class NameValuePairTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class NameValuePairTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class NameValuePairTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class NameValuePairTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.NameValuePairTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NameValuePairTypeCollection Members


NameValuePairTypeCollection Members

NameValuePairTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by NameValuePairTypeCollection.

Public Constructors

 | Name | Description
Public method | NameValuePairTypeCollection | Initializes a new instance of the NameValuePairTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NameValuePairTypeCollection Class


NameValuePairTypeCollection Constructor

NameValuePairTypeCollection Constructor
[image]

Initializes a new instance of the NameValuePairTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public NameValuePairTypeCollection()
C++
public:
NameValuePairTypeCollection() sealed
J#
public NameValuePairTypeCollection()
JScript
public function NameValuePairTypeCollection()

See Also

NameValuePairTypeCollection Class


Properties

NameValuePairTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Overloaded.
Top

See Also

NameValuePairTypeCollection Class


Item Property

NameValuePairTypeCollection.Item Property

Overload List

 | Name | Description
Public property | Item (Int32) |
Public property | Item (String) |

See Also

NameValuePairTypeCollection Class


Item Property (Int32)

NameValuePairTypeCollection.Item Property (Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As NameValuePairType
C#
public NameValuePairType this[
int idx
] { get; set; }
C++
public property NameValuePairType default[int idx] sealed {
NameValuePairType get(int idx);
void set(int idx, NameValuePairType value);
}
J#
/** property */
public NameValuePairType get_Item(int idx);

/** property */
public void set_Item(int idx, NameValuePairType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

NameValuePairTypeCollection Class
NameValuePairTypeCollection.Item Overload List


Item Property (String)

NameValuePairTypeCollection.Item Property (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Default Property Item( _
ByVal elementname As String _
) As String
C#
[XmlIgnoreAttribute]
public string this[
string elementname
] { get; set; }
C++
[XmlIgnoreAttribute]
public property string default[String elementname] sealed {
String get(String elementname);
void set(String elementname, String value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public string get_Item(string elementname);

/** property */
public void set_Item(string elementname, string value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

NameValuePairTypeCollection Class
NameValuePairTypeCollection.Item Overload List


Methods

NameValuePairTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NameValuePairTypeCollection Class


Add Method

NameValuePairTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As NameValuePairType _
) As Integer
C#
public int Add(
NameValuePairType value
)
C++
public:
int Add(
NameValuePairType value
) sealed
J#
public int Add(
NameValuePairType value
)
JScript
public function Add(
value : NameValuePairType
) : int

See Also

NameValuePairTypeCollection Class


Operations Enumeration

Operations Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum Operations
C#
public enum Operations
C++
public enum class Operations
J#
public enum Operations
JScript
public enum Operations

Members

Member Name | Description
CreateSession |
DescribeDrawing |
GetDrawing |
EnumerateDrawingLayers |
GetDrawingLayer |
GetDrawingSection |
GetDrawingSectionResource |
EnumerateDrawingSections |
EnumerateDrawingSectionResources |
GetDrawingCoordinateSpace |
GetFeatureProviders |
GetProviderCapabilities |
GetConnectionPropertyValues |
DescribeFeatureSchema |
SelectFeatures |
SelectAggregates |
ExecuteSqlQuery |
GetSpatialContexts |
GetLongTransactions |
EnumerateDataStores |
GetSchemaMapping |
GetSchemas |
GetClasses |
GetClassDefinition |
GetIdentityProperties |
TestConnection |

See Also


OverlapTreatmentType Enumeration

OverlapTreatmentType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum OverlapTreatmentType
C#
public enum OverlapTreatmentType
C++
public enum class OverlapTreatmentType
J#
public enum OverlapTreatmentType
JScript
public enum OverlapTreatmentType

Members

Member Name | Description
None |
ForegroundOn |
ForegroundOff |

See Also


Override Class

Override Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class Override
C#
public class Override
C++
ref class Override
J#
public class Override
JScript
public class Override

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.Override

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Override Members


Override Members

Override Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by Override.

Public Constructors

 | Name | Description
Public method | Override | Initializes a new instance of the Override class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | ParameterIdentifier |
Public property | ParameterValue |
Public property | SymbolName |
Public property | ThemeLabel |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Override Class


Override Constructor

Override Constructor
[image]

Initializes a new instance of the Override class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Override()
C++
public:
Override() sealed
J#
public Override()
JScript
public function Override()

See Also

Override Class


Properties

Override Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | ParameterIdentifier |
Public property | ParameterValue |
Public property | SymbolName |
Public property | ThemeLabel |
Top

See Also

Override Class


ExtendedData1 Property

Override.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

Override Class


ParameterIdentifier Property

Override.ParameterIdentifier Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterIdentifier As String
C#
public string ParameterIdentifier { get; set; }
C++
public property string ParameterIdentifier sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ParameterIdentifier();

/** property */
public void set_ParameterIdentifier(string value);
JScript
public function get ParameterIdentifier() : String

public function set ParameterIdentifier(value : String);

See Also

Override Class


ParameterValue Property

Override.ParameterValue Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterValue As String
C#
public string ParameterValue { get; set; }
C++
public property string ParameterValue sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ParameterValue();

/** property */
public void set_ParameterValue(string value);
JScript
public function get ParameterValue() : String

public function set ParameterValue(value : String);

See Also

Override Class


SymbolName Property

Override.SymbolName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SymbolName As String
C#
public string SymbolName { get; set; }
C++
public property string SymbolName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SymbolName();

/** property */
public void set_SymbolName(string value);
JScript
public function get SymbolName() : String

public function set SymbolName(value : String);

See Also

Override Class


ThemeLabel Property

Override.ThemeLabel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ThemeLabel As ThemeLabel
C#
public ThemeLabel ThemeLabel { get; set; }
C++
public property ThemeLabel ThemeLabel sealed {
ThemeLabel get();
void set(ThemeLabel value);
}
J#
/** property */
public ThemeLabel get_ThemeLabel();

/** property */
public void set_ThemeLabel(ThemeLabel value);
JScript
public function get ThemeLabel() : ThemeLabel

public function set ThemeLabel(value : ThemeLabel);

See Also

Override Class


OverrideCollection Class

OverrideCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class OverrideCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class OverrideCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class OverrideCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class OverrideCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class OverrideCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.OverrideCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

OverrideCollection Members


OverrideCollection Members

OverrideCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by OverrideCollection.

Public Constructors

 | Name | Description
Public method | OverrideCollection | Initializes a new instance of the OverrideCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

OverrideCollection Class


OverrideCollection Constructor

OverrideCollection Constructor
[image]

Initializes a new instance of the OverrideCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public OverrideCollection()
C++
public:
OverrideCollection() sealed
J#
public OverrideCollection()
JScript
public function OverrideCollection()

See Also

OverrideCollection Class


Properties

OverrideCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

OverrideCollection Class


Item Property

OverrideCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As Override
C#
public Override this[
int idx
] { get; set; }
C++
public property Override default[int idx] sealed {
Override get(int idx);
void set(int idx, Override value);
}
J#
/** property */
public Override get_Item(int idx);

/** property */
public void set_Item(int idx, Override value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

OverrideCollection Class


Methods

OverrideCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

OverrideCollection Class


Add Method

OverrideCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As Override _
) As Integer
C#
public int Add(
Override value
)
C++
public:
int Add(
Override value
) sealed
J#
public int Add(
Override value
)
JScript
public function Add(
value : Override
) : int

See Also

OverrideCollection Class


Parameter Class

Parameter Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class Parameter
C#
public class Parameter
C++
ref class Parameter
J#
public class Parameter
JScript
public class Parameter

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.Parameter

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Parameter Members


Parameter Members

Parameter Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by Parameter.

Public Constructors

 | Name | Description
Public method | Parameter | Initializes a new instance of the Parameter class.
Top

Public Properties

 | Name | Description
Public property | DataType |
Public property | DefaultValue |
Public property | Description |
Public property | DisplayName |
Public property | ExtendedData1 |
Public property | Identifier |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Parameter Class


Parameter Constructor

Parameter Constructor
[image]

Initializes a new instance of the Parameter class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Parameter()
C++
public:
Parameter() sealed
J#
public Parameter()
JScript
public function Parameter()

See Also

Parameter Class


Properties

Parameter Properties
[image]

Public Properties

 | Name | Description
Public property | DataType |
Public property | DefaultValue |
Public property | Description |
Public property | DisplayName |
Public property | ExtendedData1 |
Public property | Identifier |
Top

See Also

Parameter Class


DataType Property

Parameter.DataType Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(DataType.String)>
Public Property DataType As DataType
C#
[DefaultValueAttribute(DataType.String)]
public DataType DataType { get; set; }
C++
[DefaultValueAttribute(DataType::String)]
public property DataType DataType sealed {
DataType get();
void set(DataType value);
}
J#
/** @attribute DefaultValueAttribute(DataType.String) */
/** property */
public DataType get_DataType();

/** property */
public void set_DataType(DataType value);
JScript
public function get DataType() : DataType

public function set DataType(value : DataType);

See Also

Parameter Class


DefaultValue Property

Parameter.DefaultValue Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultValue As String
C#
public string DefaultValue { get; set; }
C++
public property string DefaultValue sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DefaultValue();

/** property */
public void set_DefaultValue(string value);
JScript
public function get DefaultValue() : String

public function set DefaultValue(value : String);

See Also

Parameter Class


Description Property

Parameter.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

Parameter Class


DisplayName Property

Parameter.DisplayName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisplayName As String
C#
public string DisplayName { get; set; }
C++
public property string DisplayName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DisplayName();

/** property */
public void set_DisplayName(string value);
JScript
public function get DisplayName() : String

public function set DisplayName(value : String);

See Also

Parameter Class


ExtendedData1 Property

Parameter.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

Parameter Class


Identifier Property

Parameter.Identifier Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Identifier As String
C#
public string Identifier { get; set; }
C++
public property string Identifier sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Identifier();

/** property */
public void set_Identifier(string value);
JScript
public function get Identifier() : String

public function set Identifier(value : String);

See Also

Parameter Class


ParameterCollection Class

ParameterCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ParameterCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ParameterCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ParameterCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ParameterCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ParameterCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ParameterCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ParameterCollection Members


ParameterCollection Members

ParameterCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ParameterCollection.

Public Constructors

 | Name | Description
Public method | ParameterCollection | Initializes a new instance of the ParameterCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ParameterCollection Class


ParameterCollection Constructor

ParameterCollection Constructor
[image]

Initializes a new instance of the ParameterCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ParameterCollection()
C++
public:
ParameterCollection() sealed
J#
public ParameterCollection()
JScript
public function ParameterCollection()

See Also

ParameterCollection Class


Properties

ParameterCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ParameterCollection Class


Item Property

ParameterCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As Parameter
C#
public Parameter this[
int idx
] { get; set; }
C++
public property Parameter default[int idx] sealed {
Parameter get(int idx);
void set(int idx, Parameter value);
}
J#
/** property */
public Parameter get_Item(int idx);

/** property */
public void set_Item(int idx, Parameter value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ParameterCollection Class


Methods

ParameterCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ParameterCollection Class


Add Method

ParameterCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As Parameter _
) As Integer
C#
public int Add(
Parameter value
)
C++
public:
int Add(
Parameter value
) sealed
J#
public int Add(
Parameter value
)
JScript
public function Add(
value : Parameter
) : int

See Also

ParameterCollection Class


ParameterDefinition Class

ParameterDefinition Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ParameterDefinition
C#
public class ParameterDefinition
C++
ref class ParameterDefinition
J#
public class ParameterDefinition
JScript
public class ParameterDefinition

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ParameterDefinition

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ParameterDefinition Members


ParameterDefinition Members

ParameterDefinition Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ParameterDefinition.

Public Constructors

 | Name | Description
Public method | ParameterDefinition | Initializes a new instance of the ParameterDefinition class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Parameter |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ParameterDefinition Class


ParameterDefinition Constructor

ParameterDefinition Constructor
[image]

Initializes a new instance of the ParameterDefinition class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ParameterDefinition()
C++
public:
ParameterDefinition() sealed
J#
public ParameterDefinition()
JScript
public function ParameterDefinition()

See Also

ParameterDefinition Class


Properties

ParameterDefinition Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Parameter |
Top

See Also

ParameterDefinition Class


ExtendedData1 Property

ParameterDefinition.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

ParameterDefinition Class


Parameter Property

ParameterDefinition.Parameter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Parameter")>
Public Property Parameter As ParameterCollection
C#
[XmlElementAttribute("Parameter")]
public ParameterCollection Parameter { get; set; }
C++
[XmlElementAttribute(L"Parameter")]
public property ParameterCollection Parameter sealed {
ParameterCollection get();
void set(ParameterCollection value);
}
J#
/** @attribute XmlElementAttribute("Parameter") */
/** property */
public ParameterCollection get_Parameter();

/** property */
public void set_Parameter(ParameterCollection value);
JScript
public function get Parameter() : ParameterCollection

public function set Parameter(value : ParameterCollection);

See Also

ParameterDefinition Class


ParameterOverrides Class

ParameterOverrides Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ParameterOverrides
C#
public class ParameterOverrides
C++
ref class ParameterOverrides
J#
public class ParameterOverrides
JScript
public class ParameterOverrides

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ParameterOverrides

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ParameterOverrides Members


ParameterOverrides Members

ParameterOverrides Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ParameterOverrides.

Public Constructors

 | Name | Description
Public method | ParameterOverrides | Initializes a new instance of the ParameterOverrides class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Override |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ParameterOverrides Class


ParameterOverrides Constructor

ParameterOverrides Constructor
[image]

Initializes a new instance of the ParameterOverrides class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ParameterOverrides()
C++
public:
ParameterOverrides() sealed
J#
public ParameterOverrides()
JScript
public function ParameterOverrides()

See Also

ParameterOverrides Class


Properties

ParameterOverrides Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Override |
Top

See Also

ParameterOverrides Class


ExtendedData1 Property

ParameterOverrides.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

ParameterOverrides Class


Override Property

ParameterOverrides.Override Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Override")>
Public Property Override As OverrideCollection
C#
[XmlElementAttribute("Override")]
public OverrideCollection Override { get; set; }
C++
[XmlElementAttribute(L"Override")]
public property OverrideCollection Override sealed {
OverrideCollection get();
void set(OverrideCollection value);
}
J#
/** @attribute XmlElementAttribute("Override") */
/** property */
public OverrideCollection get_Override();

/** property */
public void set_Override(OverrideCollection value);
JScript
public function get Override() : OverrideCollection

public function set Override(value : OverrideCollection);

See Also

ParameterOverrides Class


ParameterPairType Class

ParameterPairType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ParameterPairType
C#
public class ParameterPairType
C++
ref class ParameterPairType
J#
public class ParameterPairType
JScript
public class ParameterPairType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ParameterPairType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ParameterPairType Members


ParameterPairType Members

ParameterPairType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ParameterPairType.

Public Constructors

 | Name | Description
Public method | ParameterPairType | Initializes a new instance of the ParameterPairType class.
Top

Public Properties

 | Name | Description
Public property | Key |
Public property | Value |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ParameterPairType Class


ParameterPairType Constructor

ParameterPairType Constructor
[image]

Initializes a new instance of the ParameterPairType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ParameterPairType()
C++
public:
ParameterPairType() sealed
J#
public ParameterPairType()
JScript
public function ParameterPairType()

See Also

ParameterPairType Class


Properties

ParameterPairType Properties
[image]

Public Properties

 | Name | Description
Public property | Key |
Public property | Value |
Top

See Also

ParameterPairType Class


Key Property

ParameterPairType.Key Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Key As String
C#
public string Key { get; set; }
C++
public property string Key sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Key();

/** property */
public void set_Key(string value);
JScript
public function get Key() : String

public function set Key(value : String);

See Also

ParameterPairType Class


Value Property

ParameterPairType.Value Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
C++
public property string Value sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

ParameterPairType Class


ParameterPairTypeCollection Class

ParameterPairTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ParameterPairTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ParameterPairTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ParameterPairTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ParameterPairTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ParameterPairTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ParameterPairTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ParameterPairTypeCollection Members


ParameterPairTypeCollection Members

ParameterPairTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ParameterPairTypeCollection.

Public Constructors

 | Name | Description
Public method | ParameterPairTypeCollection | Initializes a new instance of the ParameterPairTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ParameterPairTypeCollection Class


ParameterPairTypeCollection Constructor

ParameterPairTypeCollection Constructor
[image]

Initializes a new instance of the ParameterPairTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ParameterPairTypeCollection()
C++
public:
ParameterPairTypeCollection() sealed
J#
public ParameterPairTypeCollection()
JScript
public function ParameterPairTypeCollection()

See Also

ParameterPairTypeCollection Class


Properties

ParameterPairTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ParameterPairTypeCollection Class


Item Property

ParameterPairTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ParameterPairType
C#
public ParameterPairType this[
int idx
] { get; set; }
C++
public property ParameterPairType default[int idx] sealed {
ParameterPairType get(int idx);
void set(int idx, ParameterPairType value);
}
J#
/** property */
public ParameterPairType get_Item(int idx);

/** property */
public void set_Item(int idx, ParameterPairType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ParameterPairTypeCollection Class


Methods

ParameterPairTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ParameterPairTypeCollection Class


Add Method

ParameterPairTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ParameterPairType _
) As Integer
C#
public int Add(
ParameterPairType value
)
C++
public:
int Add(
ParameterPairType value
) sealed
J#
public int Add(
ParameterPairType value
)
JScript
public function Add(
value : ParameterPairType
) : int

See Also

ParameterPairTypeCollection Class


Path Class

Path Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class Path
Inherits GraphicBase
C#
public class Path : GraphicBase
C++
ref class Path : GraphicBase
J#
public class Path extends GraphicBase
JScript
public class Path extends GraphicBase

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GraphicBase
OSGeo.MapGuide.MaestroAPI.Path

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Path Members


Path Members

Path Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by Path.

Public Constructors

 | Name | Description
Public method | Path | Initializes a new instance of the Path class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | FillColor |
Public property | Geometry |
Public property | LineCap |
Public property | LineColor |
Public property | LineJoin |
Public property | LineMiterLimit |
Public property | LineWeight |
Public property | LineWeightScalable |
Public property | ResizeControl | (inherited from GraphicBase)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Path Class


Path Constructor

Path Constructor
[image]

Initializes a new instance of the Path class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Path()
C++
public:
Path() sealed
J#
public Path()
JScript
public function Path()

See Also

Path Class


Properties

Path Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | FillColor |
Public property | Geometry |
Public property | LineCap |
Public property | LineColor |
Public property | LineJoin |
Public property | LineMiterLimit |
Public property | LineWeight |
Public property | LineWeightScalable |
Public property | ResizeControl | (inherited from GraphicBase)
Top

See Also

Path Class


ExtendedData1 Property

Path.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

Path Class


FillColor Property

Path.FillColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FillColor As String
C#
public string FillColor { get; set; }
C++
public property string FillColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FillColor();

/** property */
public void set_FillColor(string value);
JScript
public function get FillColor() : String

public function set FillColor(value : String);

See Also

Path Class


Geometry Property

Path.Geometry Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Geometry As String
C#
public string Geometry { get; set; }
C++
public property string Geometry sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Geometry();

/** property */
public void set_Geometry(string value);
JScript
public function get Geometry() : String

public function set Geometry(value : String);

See Also

Path Class


LineCap Property

Path.LineCap Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'Round'")>
Public Property LineCap As String
C#
[DefaultValueAttribute("'Round'")]
public string LineCap { get; set; }
C++
[DefaultValueAttribute(L"'Round'")]
public property string LineCap sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'Round'") */
/** property */
public string get_LineCap();

/** property */
public void set_LineCap(string value);
JScript
public function get LineCap() : String

public function set LineCap(value : String);

See Also

Path Class


LineColor Property

Path.LineColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LineColor As String
C#
public string LineColor { get; set; }
C++
public property string LineColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LineColor();

/** property */
public void set_LineColor(string value);
JScript
public function get LineColor() : String

public function set LineColor(value : String);

See Also

Path Class


LineJoin Property

Path.LineJoin Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'Round'")>
Public Property LineJoin As String
C#
[DefaultValueAttribute("'Round'")]
public string LineJoin { get; set; }
C++
[DefaultValueAttribute(L"'Round'")]
public property string LineJoin sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'Round'") */
/** property */
public string get_LineJoin();

/** property */
public void set_LineJoin(string value);
JScript
public function get LineJoin() : String

public function set LineJoin(value : String);

See Also

Path Class


LineMiterLimit Property

Path.LineMiterLimit Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("5.0")>
Public Property LineMiterLimit As String
C#
[DefaultValueAttribute("5.0")]
public string LineMiterLimit { get; set; }
C++
[DefaultValueAttribute(L"5.0")]
public property string LineMiterLimit sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("5.0") */
/** property */
public string get_LineMiterLimit();

/** property */
public void set_LineMiterLimit(string value);
JScript
public function get LineMiterLimit() : String

public function set LineMiterLimit(value : String);

See Also

Path Class


LineWeight Property

Path.LineWeight Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property LineWeight As String
C#
[DefaultValueAttribute("0.0")]
public string LineWeight { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string LineWeight sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_LineWeight();

/** property */
public void set_LineWeight(string value);
JScript
public function get LineWeight() : String

public function set LineWeight(value : String);

See Also

Path Class


LineWeightScalable Property

Path.LineWeightScalable Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("true")>
Public Property LineWeightScalable As String
C#
[DefaultValueAttribute("true")]
public string LineWeightScalable { get; set; }
C++
[DefaultValueAttribute(L"true")]
public property string LineWeightScalable sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("true") */
/** property */
public string get_LineWeightScalable();

/** property */
public void set_LineWeightScalable(string value);
JScript
public function get LineWeightScalable() : String

public function set LineWeightScalable(value : String);

See Also

Path Class


PermissionsType Enumeration

PermissionsType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum PermissionsType
C#
public enum PermissionsType
C++
public enum class PermissionsType
J#
public enum PermissionsType
JScript
public enum PermissionsType

Members

Member Name | Description
n |
r |
rw |

See Also


PointRuleType Class

PointRuleType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PointRuleType
C#
public class PointRuleType
C++
ref class PointRuleType
J#
public class PointRuleType
JScript
public class PointRuleType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PointRuleType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PointRuleType Members


PointRuleType Members

PointRuleType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PointRuleType.

Public Constructors

 | Name | Description
Public method | PointRuleType | Initializes a new instance of the PointRuleType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Filter |
Public property | Item |
Public property | Label |
Public property | LegendLabel |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PointRuleType Class


PointRuleType Constructor

PointRuleType Constructor
[image]

Initializes a new instance of the PointRuleType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PointRuleType()
C++
public:
PointRuleType() sealed
J#
public PointRuleType()
JScript
public function PointRuleType()

See Also

PointRuleType Class


Properties

PointRuleType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Filter |
Public property | Item |
Public property | Label |
Public property | LegendLabel |
Top

See Also

PointRuleType Class


ExtendedData1 Property

PointRuleType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

PointRuleType Class


Filter Property

PointRuleType.Filter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; set; }
C++
public property string Filter sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Filter();

/** property */
public void set_Filter(string value);
JScript
public function get Filter() : String

public function set Filter(value : String);

See Also

PointRuleType Class


Item Property

PointRuleType.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("PointSymbolization2D")>
Public Property Item As PointSymbolization2DType
C#
[XmlElementAttribute("PointSymbolization2D")]
public PointSymbolization2DType Item { get; set; }
C++
[XmlElementAttribute(L"PointSymbolization2D")]
public property PointSymbolization2DType Item sealed {
PointSymbolization2DType get();
void set(PointSymbolization2DType value);
}
J#
/** @attribute XmlElementAttribute("PointSymbolization2D") */
/** property */
public PointSymbolization2DType get_Item();

/** property */
public void set_Item(PointSymbolization2DType value);
JScript
public function get Item() : PointSymbolization2DType

public function set Item(value : PointSymbolization2DType);

See Also

PointRuleType Class


Label Property

PointRuleType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As TextSymbolType
C#
public TextSymbolType Label { get; set; }
C++
public property TextSymbolType Label sealed {
TextSymbolType get();
void set(TextSymbolType value);
}
J#
/** property */
public TextSymbolType get_Label();

/** property */
public void set_Label(TextSymbolType value);
JScript
public function get Label() : TextSymbolType

public function set Label(value : TextSymbolType);

See Also

PointRuleType Class


LegendLabel Property

PointRuleType.LegendLabel Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LegendLabel As String
C#
public string LegendLabel { get; set; }
C++
public property string LegendLabel sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LegendLabel();

/** property */
public void set_LegendLabel(string value);
JScript
public function get LegendLabel() : String

public function set LegendLabel(value : String);

See Also

PointRuleType Class


PointRuleTypeCollection Class

PointRuleTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PointRuleTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class PointRuleTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class PointRuleTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class PointRuleTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class PointRuleTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.PointRuleTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PointRuleTypeCollection Members


PointRuleTypeCollection Members

PointRuleTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PointRuleTypeCollection.

Public Constructors

 | Name | Description
Public method | PointRuleTypeCollection | Initializes a new instance of the PointRuleTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PointRuleTypeCollection Class


PointRuleTypeCollection Constructor

PointRuleTypeCollection Constructor
[image]

Initializes a new instance of the PointRuleTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PointRuleTypeCollection()
C++
public:
PointRuleTypeCollection() sealed
J#
public PointRuleTypeCollection()
JScript
public function PointRuleTypeCollection()

See Also

PointRuleTypeCollection Class


Properties

PointRuleTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

PointRuleTypeCollection Class


Item Property

PointRuleTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As PointRuleType
C#
public PointRuleType this[
int idx
] { get; set; }
C++
public property PointRuleType default[int idx] sealed {
PointRuleType get(int idx);
void set(int idx, PointRuleType value);
}
J#
/** property */
public PointRuleType get_Item(int idx);

/** property */
public void set_Item(int idx, PointRuleType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

PointRuleTypeCollection Class


Methods

PointRuleTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PointRuleTypeCollection Class


Add Method

PointRuleTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As PointRuleType _
) As Integer
C#
public int Add(
PointRuleType value
)
C++
public:
int Add(
PointRuleType value
) sealed
J#
public int Add(
PointRuleType value
)
JScript
public function Add(
value : PointRuleType
) : int

See Also

PointRuleTypeCollection Class


PointSymbolization2DType Class

PointSymbolization2DType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PointSymbolization2DType
C#
public class PointSymbolization2DType
C++
ref class PointSymbolization2DType
J#
public class PointSymbolization2DType
JScript
public class PointSymbolization2DType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PointSymbolization2DType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PointSymbolization2DType Members


PointSymbolization2DType Members

PointSymbolization2DType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PointSymbolization2DType.

Public Constructors

 | Name | Description
Public method | PointSymbolization2DType | Initializes a new instance of the PointSymbolization2DType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PointSymbolization2DType Class


PointSymbolization2DType Constructor

PointSymbolization2DType Constructor
[image]

Initializes a new instance of the PointSymbolization2DType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PointSymbolization2DType()
C++
public:
PointSymbolization2DType() sealed
J#
public PointSymbolization2DType()
JScript
public function PointSymbolization2DType()

See Also

PointSymbolization2DType Class


Properties

PointSymbolization2DType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Item |
Top

See Also

PointSymbolization2DType Class


ExtendedData1 Property

PointSymbolization2DType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

PointSymbolization2DType Class


Item Property

PointSymbolization2DType.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Mark", GetType(MarkSymbolType)), _
XmlElementAttribute("Image", GetType(ImageSymbolType)), _
XmlElementAttribute("W2D", GetType(W2DSymbolType)), _
XmlElementAttribute("Font", GetType(FontSymbolType)), _
XmlElementAttribute("Block", GetType(BlockSymbolType))>
Public Property Item As SymbolType
C#
[XmlElementAttribute("Mark", typeof(MarkSymbolType))]
[XmlElementAttribute("Image", typeof(ImageSymbolType))]
[XmlElementAttribute("W2D", typeof(W2DSymbolType))]
[XmlElementAttribute("Font", typeof(FontSymbolType))]
[XmlElementAttribute("Block", typeof(BlockSymbolType))]
public SymbolType Item { get; set; }
C++
[XmlElementAttribute(L"Mark", typeof(MarkSymbolType))]
[XmlElementAttribute(L"Image", typeof(ImageSymbolType))]
[XmlElementAttribute(L"W2D", typeof(W2DSymbolType))]
[XmlElementAttribute(L"Font", typeof(FontSymbolType))]
[XmlElementAttribute(L"Block", typeof(BlockSymbolType))]
public property SymbolType Item sealed {
SymbolType get();
void set(SymbolType value);
}
J#
/** @attribute XmlElementAttribute("Mark", typeof(MarkSymbolType)) */
/** @attribute XmlElementAttribute("Image", typeof(ImageSymbolType)) */
/** @attribute XmlElementAttribute("W2D", typeof(W2DSymbolType)) */
/** @attribute XmlElementAttribute("Font", typeof(FontSymbolType)) */
/** @attribute XmlElementAttribute("Block", typeof(BlockSymbolType)) */
/** property */
public SymbolType get_Item();

/** property */
public void set_Item(SymbolType value);
JScript
public function get Item() : SymbolType

public function set Item(value : SymbolType);

See Also

PointSymbolization2DType Class


PointTypeStyleType Class

PointTypeStyleType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PointTypeStyleType
C#
public class PointTypeStyleType
C++
ref class PointTypeStyleType
J#
public class PointTypeStyleType
JScript
public class PointTypeStyleType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PointTypeStyleType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PointTypeStyleType Members


PointTypeStyleType Members

PointTypeStyleType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PointTypeStyleType.

Public Constructors

 | Name | Description
Public method | PointTypeStyleType | Initializes a new instance of the PointTypeStyleType class.
Top

Public Properties

 | Name | Description
Public property | AllowOverpost |
Public property | DisplayAsText |
Public property | ExtendedData1 |
Public property | PointRule |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PointTypeStyleType Class


PointTypeStyleType Constructor

PointTypeStyleType Constructor
[image]

Initializes a new instance of the PointTypeStyleType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PointTypeStyleType()
C++
public:
PointTypeStyleType() sealed
J#
public PointTypeStyleType()
JScript
public function PointTypeStyleType()

See Also

PointTypeStyleType Class


Properties

PointTypeStyleType Properties
[image]

Public Properties

 | Name | Description
Public property | AllowOverpost |
Public property | DisplayAsText |
Public property | ExtendedData1 |
Public property | PointRule |
Top

See Also

PointTypeStyleType Class


AllowOverpost Property

PointTypeStyleType.AllowOverpost Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowOverpost As Boolean
C#
public bool AllowOverpost { get; set; }
C++
public property bool AllowOverpost sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AllowOverpost();

/** property */
public void set_AllowOverpost(bool value);
JScript
public function get AllowOverpost() : bool

public function set AllowOverpost(value : bool);

See Also

PointTypeStyleType Class


DisplayAsText Property

PointTypeStyleType.DisplayAsText Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisplayAsText As Boolean
C#
public bool DisplayAsText { get; set; }
C++
public property bool DisplayAsText sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DisplayAsText();

/** property */
public void set_DisplayAsText(bool value);
JScript
public function get DisplayAsText() : bool

public function set DisplayAsText(value : bool);

See Also

PointTypeStyleType Class


ExtendedData1 Property

PointTypeStyleType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

PointTypeStyleType Class


PointRule Property

PointTypeStyleType.PointRule Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("PointRule")>
Public Property PointRule As PointRuleTypeCollection
C#
[XmlElementAttribute("PointRule")]
public PointRuleTypeCollection PointRule { get; set; }
C++
[XmlElementAttribute(L"PointRule")]
public property PointRuleTypeCollection PointRule sealed {
PointRuleTypeCollection get();
void set(PointRuleTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("PointRule") */
/** property */
public PointRuleTypeCollection get_PointRule();

/** property */
public void set_PointRule(PointRuleTypeCollection value);
JScript
public function get PointRule() : PointRuleTypeCollection

public function set PointRule(value : PointRuleTypeCollection);

See Also

PointTypeStyleType Class


PointUsage Class

PointUsage Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PointUsage
C#
public class PointUsage
C++
ref class PointUsage
J#
public class PointUsage
JScript
public class PointUsage

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PointUsage

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PointUsage Members


PointUsage Members

PointUsage Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PointUsage.

Public Constructors

 | Name | Description
Public method | PointUsage | Initializes a new instance of the PointUsage class.
Top

Public Properties

 | Name | Description
Public property | Angle |
Public property | AngleControl |
Public property | ExtendedData1 |
Public property | OriginOffsetX |
Public property | OriginOffsetY |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PointUsage Class


PointUsage Constructor

PointUsage Constructor
[image]

Initializes a new instance of the PointUsage class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PointUsage()
C++
public:
PointUsage() sealed
J#
public PointUsage()
JScript
public function PointUsage()

See Also

PointUsage Class


Properties

PointUsage Properties
[image]

Public Properties

 | Name | Description
Public property | Angle |
Public property | AngleControl |
Public property | ExtendedData1 |
Public property | OriginOffsetX |
Public property | OriginOffsetY |
Top

See Also

PointUsage Class


Angle Property

PointUsage.Angle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property Angle As String
C#
[DefaultValueAttribute("0.0")]
public string Angle { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string Angle sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_Angle();

/** property */
public void set_Angle(string value);
JScript
public function get Angle() : String

public function set Angle(value : String);

See Also

PointUsage Class


AngleControl Property

PointUsage.AngleControl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'FromAngle'")>
Public Property AngleControl As String
C#
[DefaultValueAttribute("'FromAngle'")]
public string AngleControl { get; set; }
C++
[DefaultValueAttribute(L"'FromAngle'")]
public property string AngleControl sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'FromAngle'") */
/** property */
public string get_AngleControl();

/** property */
public void set_AngleControl(string value);
JScript
public function get AngleControl() : String

public function set AngleControl(value : String);

See Also

PointUsage Class


ExtendedData1 Property

PointUsage.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

PointUsage Class


OriginOffsetX Property

PointUsage.OriginOffsetX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property OriginOffsetX As String
C#
[DefaultValueAttribute("0.0")]
public string OriginOffsetX { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string OriginOffsetX sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_OriginOffsetX();

/** property */
public void set_OriginOffsetX(string value);
JScript
public function get OriginOffsetX() : String

public function set OriginOffsetX(value : String);

See Also

PointUsage Class


OriginOffsetY Property

PointUsage.OriginOffsetY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property OriginOffsetY As String
C#
[DefaultValueAttribute("0.0")]
public string OriginOffsetY { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string OriginOffsetY sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_OriginOffsetY();

/** property */
public void set_OriginOffsetY(string value);
JScript
public function get OriginOffsetY() : String

public function set OriginOffsetY(value : String);

See Also

PointUsage Class


PrintCommandType Class

PrintCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PrintCommandType
Inherits CustomCommandType
C#
public class PrintCommandType : CustomCommandType
C++
ref class PrintCommandType : CustomCommandType
J#
public class PrintCommandType extends CustomCommandType
JScript
public class PrintCommandType extends CustomCommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.PrintCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintCommandType Members


PrintCommandType Members

PrintCommandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintCommandType.

Public Constructors

 | Name | Description
Public method | PrintCommandType | Initializes a new instance of the PrintCommandType class.
Top

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | PrintLayout |
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintCommandType Class


PrintCommandType Constructor

PrintCommandType Constructor
[image]

Initializes a new instance of the PrintCommandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintCommandType()
C++
public:
PrintCommandType() sealed
J#
public PrintCommandType()
JScript
public function PrintCommandType()

See Also

PrintCommandType Class


Properties

PrintCommandType Properties
[image]

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | PrintLayout |
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

See Also

PrintCommandType Class


PrintLayout Property

PrintCommandType.PrintLayout Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("PrintLayout")>
Public Property PrintLayout As ResourceReferenceTypeCollection
C#
[XmlElementAttribute("PrintLayout")]
public ResourceReferenceTypeCollection PrintLayout { get; set; }
C++
[XmlElementAttribute(L"PrintLayout")]
public property ResourceReferenceTypeCollection PrintLayout sealed {
ResourceReferenceTypeCollection get();
void set(ResourceReferenceTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("PrintLayout") */
/** property */
public ResourceReferenceTypeCollection get_PrintLayout();

/** property */
public void set_PrintLayout(ResourceReferenceTypeCollection value);
JScript
public function get PrintLayout() : ResourceReferenceTypeCollection

public function set PrintLayout(value : ResourceReferenceTypeCollection);

See Also

PrintCommandType Class


PrintLayout Class

PrintLayout Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class PrintLayout
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class PrintLayout
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class PrintLayout
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class PrintLayout
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class PrintLayout

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PrintLayout

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayout Members


PrintLayout Members

PrintLayout Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by PrintLayout.

Public Constructors

 | Name | Description
Public method | PrintLayout | Initializes a new instance of the PrintLayout class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | CustomLogos |
Public property | CustomText |
Public property | LayoutProperties |
Public property | PageProperties |
Public property | ResourceId |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayout Class


PrintLayout Constructor

PrintLayout Constructor
[image]

Initializes a new instance of the PrintLayout class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayout()
C++
public:
PrintLayout() sealed
J#
public PrintLayout()
JScript
public function PrintLayout()

See Also

PrintLayout Class


Fields

PrintLayout Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

PrintLayout Class


SchemaName Field

PrintLayout.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

PrintLayout Class


Properties

PrintLayout Properties
[image]

Public Properties

 | Name | Description
Public property | CustomLogos |
Public property | CustomText |
Public property | LayoutProperties |
Public property | PageProperties |
Public property | ResourceId |
Public property | XsdSchema |
Top

See Also

PrintLayout Class


CustomLogos Property

PrintLayout.CustomLogos Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Logo", IsNullable := False)>
Public Property CustomLogos As PrintLayoutLogoCollection
C#
[XmlArrayItemAttribute("Logo", IsNullable = False)]
public PrintLayoutLogoCollection CustomLogos { get; set; }
C++
[XmlArrayItemAttribute(L"Logo", IsNullable = False)]
public property PrintLayoutLogoCollection CustomLogos sealed {
PrintLayoutLogoCollection get();
void set(PrintLayoutLogoCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Logo", IsNullable = False) */
/** property */
public PrintLayoutLogoCollection get_CustomLogos();

/** property */
public void set_CustomLogos(PrintLayoutLogoCollection value);
JScript
public function get CustomLogos() : PrintLayoutLogoCollection

public function set CustomLogos(value : PrintLayoutLogoCollection);

See Also

PrintLayout Class


CustomText Property

PrintLayout.CustomText Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Text", IsNullable := False)>
Public Property CustomText As PrintLayoutTextCollection
C#
[XmlArrayItemAttribute("Text", IsNullable = False)]
public PrintLayoutTextCollection CustomText { get; set; }
C++
[XmlArrayItemAttribute(L"Text", IsNullable = False)]
public property PrintLayoutTextCollection CustomText sealed {
PrintLayoutTextCollection get();
void set(PrintLayoutTextCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Text", IsNullable = False) */
/** property */
public PrintLayoutTextCollection get_CustomText();

/** property */
public void set_CustomText(PrintLayoutTextCollection value);
JScript
public function get CustomText() : PrintLayoutTextCollection

public function set CustomText(value : PrintLayoutTextCollection);

See Also

PrintLayout Class


LayoutProperties Property

PrintLayout.LayoutProperties Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LayoutProperties As PrintLayoutLayoutProperties
C#
public PrintLayoutLayoutProperties LayoutProperties { get; set; }
C++
public property PrintLayoutLayoutProperties LayoutProperties sealed {
PrintLayoutLayoutProperties get();
void set(PrintLayoutLayoutProperties value);
}
J#
/** property */
public PrintLayoutLayoutProperties get_LayoutProperties();

/** property */
public void set_LayoutProperties(PrintLayoutLayoutProperties value);
JScript
public function get LayoutProperties() : PrintLayoutLayoutProperties

public function set LayoutProperties(value : PrintLayoutLayoutProperties);

See Also

PrintLayout Class


PageProperties Property

PrintLayout.PageProperties Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property PageProperties As PrintLayoutPageProperties
C#
public PrintLayoutPageProperties PageProperties { get; set; }
C++
public property PrintLayoutPageProperties PageProperties sealed {
PrintLayoutPageProperties get();
void set(PrintLayoutPageProperties value);
}
J#
/** property */
public PrintLayoutPageProperties get_PageProperties();

/** property */
public void set_PageProperties(PrintLayoutPageProperties value);
JScript
public function get PageProperties() : PrintLayoutPageProperties

public function set PageProperties(value : PrintLayoutPageProperties);

See Also

PrintLayout Class


ResourceId Property

PrintLayout.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ResourceId As String
C#
[XmlIgnoreAttribute]
public string ResourceId { get; set; }
C++
[XmlIgnoreAttribute]
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

PrintLayout Class


XsdSchema Property

PrintLayout.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

PrintLayout Class


PrintLayoutLayoutProperties Class

PrintLayoutLayoutProperties Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PrintLayoutLayoutProperties
C#
public class PrintLayoutLayoutProperties
C++
ref class PrintLayoutLayoutProperties
J#
public class PrintLayoutLayoutProperties
JScript
public class PrintLayoutLayoutProperties

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PrintLayoutLayoutProperties

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayoutLayoutProperties Members


PrintLayoutLayoutProperties Members

PrintLayoutLayoutProperties Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintLayoutLayoutProperties.

Public Constructors

 | Name | Description
Public method | PrintLayoutLayoutProperties | Initializes a new instance of the PrintLayoutLayoutProperties class.
Top

Public Properties

 | Name | Description
Public property | ShowCustomLogos |
Public property | ShowCustomLogosSpecified |
Public property | ShowCustomText |
Public property | ShowCustomTextSpecified |
Public property | ShowDateTime |
Public property | ShowDateTimeSpecified |
Public property | ShowLegend |
Public property | ShowLegendSpecified |
Public property | ShowNorthArrow |
Public property | ShowNorthArrowSpecified |
Public property | ShowScaleBar |
Public property | ShowScaleBarSpecified |
Public property | ShowTitle |
Public property | ShowTitleSpecified |
Public property | ShowURL |
Public property | ShowURLSpecified |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutLayoutProperties Class


PrintLayoutLayoutProperties Constructor

PrintLayoutLayoutProperties Constructor
[image]

Initializes a new instance of the PrintLayoutLayoutProperties class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayoutLayoutProperties()
C++
public:
PrintLayoutLayoutProperties() sealed
J#
public PrintLayoutLayoutProperties()
JScript
public function PrintLayoutLayoutProperties()

See Also

PrintLayoutLayoutProperties Class


Properties

PrintLayoutLayoutProperties Properties
[image]

Public Properties

 | Name | Description
Public property | ShowCustomLogos |
Public property | ShowCustomLogosSpecified |
Public property | ShowCustomText |
Public property | ShowCustomTextSpecified |
Public property | ShowDateTime |
Public property | ShowDateTimeSpecified |
Public property | ShowLegend |
Public property | ShowLegendSpecified |
Public property | ShowNorthArrow |
Public property | ShowNorthArrowSpecified |
Public property | ShowScaleBar |
Public property | ShowScaleBarSpecified |
Public property | ShowTitle |
Public property | ShowTitleSpecified |
Public property | ShowURL |
Public property | ShowURLSpecified |
Top

See Also

PrintLayoutLayoutProperties Class


ShowCustomLogos Property

PrintLayoutLayoutProperties.ShowCustomLogos Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowCustomLogos As Boolean
C#
public bool ShowCustomLogos { get; set; }
C++
public property bool ShowCustomLogos sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowCustomLogos();

/** property */
public void set_ShowCustomLogos(bool value);
JScript
public function get ShowCustomLogos() : bool

public function set ShowCustomLogos(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowCustomLogosSpecified Property

PrintLayoutLayoutProperties.ShowCustomLogosSpecified Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ShowCustomLogosSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ShowCustomLogosSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ShowCustomLogosSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ShowCustomLogosSpecified();

/** property */
public void set_ShowCustomLogosSpecified(bool value);
JScript
public function get ShowCustomLogosSpecified() : bool

public function set ShowCustomLogosSpecified(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowCustomText Property

PrintLayoutLayoutProperties.ShowCustomText Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowCustomText As Boolean
C#
public bool ShowCustomText { get; set; }
C++
public property bool ShowCustomText sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowCustomText();

/** property */
public void set_ShowCustomText(bool value);
JScript
public function get ShowCustomText() : bool

public function set ShowCustomText(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowCustomTextSpecified Property

PrintLayoutLayoutProperties.ShowCustomTextSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ShowCustomTextSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ShowCustomTextSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ShowCustomTextSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ShowCustomTextSpecified();

/** property */
public void set_ShowCustomTextSpecified(bool value);
JScript
public function get ShowCustomTextSpecified() : bool

public function set ShowCustomTextSpecified(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowDateTime Property

PrintLayoutLayoutProperties.ShowDateTime Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowDateTime As Boolean
C#
public bool ShowDateTime { get; set; }
C++
public property bool ShowDateTime sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowDateTime();

/** property */
public void set_ShowDateTime(bool value);
JScript
public function get ShowDateTime() : bool

public function set ShowDateTime(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowDateTimeSpecified Property

PrintLayoutLayoutProperties.ShowDateTimeSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ShowDateTimeSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ShowDateTimeSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ShowDateTimeSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ShowDateTimeSpecified();

/** property */
public void set_ShowDateTimeSpecified(bool value);
JScript
public function get ShowDateTimeSpecified() : bool

public function set ShowDateTimeSpecified(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowLegend Property

PrintLayoutLayoutProperties.ShowLegend Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowLegend As Boolean
C#
public bool ShowLegend { get; set; }
C++
public property bool ShowLegend sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowLegend();

/** property */
public void set_ShowLegend(bool value);
JScript
public function get ShowLegend() : bool

public function set ShowLegend(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowLegendSpecified Property

PrintLayoutLayoutProperties.ShowLegendSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ShowLegendSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ShowLegendSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ShowLegendSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ShowLegendSpecified();

/** property */
public void set_ShowLegendSpecified(bool value);
JScript
public function get ShowLegendSpecified() : bool

public function set ShowLegendSpecified(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowNorthArrow Property

PrintLayoutLayoutProperties.ShowNorthArrow Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowNorthArrow As Boolean
C#
public bool ShowNorthArrow { get; set; }
C++
public property bool ShowNorthArrow sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowNorthArrow();

/** property */
public void set_ShowNorthArrow(bool value);
JScript
public function get ShowNorthArrow() : bool

public function set ShowNorthArrow(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowNorthArrowSpecified Property

PrintLayoutLayoutProperties.ShowNorthArrowSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ShowNorthArrowSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ShowNorthArrowSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ShowNorthArrowSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ShowNorthArrowSpecified();

/** property */
public void set_ShowNorthArrowSpecified(bool value);
JScript
public function get ShowNorthArrowSpecified() : bool

public function set ShowNorthArrowSpecified(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowScaleBar Property

PrintLayoutLayoutProperties.ShowScaleBar Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowScaleBar As Boolean
C#
public bool ShowScaleBar { get; set; }
C++
public property bool ShowScaleBar sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowScaleBar();

/** property */
public void set_ShowScaleBar(bool value);
JScript
public function get ShowScaleBar() : bool

public function set ShowScaleBar(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowScaleBarSpecified Property

PrintLayoutLayoutProperties.ShowScaleBarSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ShowScaleBarSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ShowScaleBarSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ShowScaleBarSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ShowScaleBarSpecified();

/** property */
public void set_ShowScaleBarSpecified(bool value);
JScript
public function get ShowScaleBarSpecified() : bool

public function set ShowScaleBarSpecified(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowTitle Property

PrintLayoutLayoutProperties.ShowTitle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowTitle As Boolean
C#
public bool ShowTitle { get; set; }
C++
public property bool ShowTitle sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowTitle();

/** property */
public void set_ShowTitle(bool value);
JScript
public function get ShowTitle() : bool

public function set ShowTitle(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowTitleSpecified Property

PrintLayoutLayoutProperties.ShowTitleSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ShowTitleSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ShowTitleSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ShowTitleSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ShowTitleSpecified();

/** property */
public void set_ShowTitleSpecified(bool value);
JScript
public function get ShowTitleSpecified() : bool

public function set ShowTitleSpecified(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowURL Property

PrintLayoutLayoutProperties.ShowURL Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ShowURL As Boolean
C#
public bool ShowURL { get; set; }
C++
public property bool ShowURL sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ShowURL();

/** property */
public void set_ShowURL(bool value);
JScript
public function get ShowURL() : bool

public function set ShowURL(value : bool);

See Also

PrintLayoutLayoutProperties Class


ShowURLSpecified Property

PrintLayoutLayoutProperties.ShowURLSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ShowURLSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ShowURLSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ShowURLSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ShowURLSpecified();

/** property */
public void set_ShowURLSpecified(bool value);
JScript
public function get ShowURLSpecified() : bool

public function set ShowURLSpecified(value : bool);

See Also

PrintLayoutLayoutProperties Class


PrintLayoutLogo Class

PrintLayoutLogo Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PrintLayoutLogo
C#
public class PrintLayoutLogo
C++
ref class PrintLayoutLogo
J#
public class PrintLayoutLogo
JScript
public class PrintLayoutLogo

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PrintLayoutLogo

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayoutLogo Members


PrintLayoutLogo Members

PrintLayoutLogo Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintLayoutLogo.

Public Constructors

 | Name | Description
Public method | PrintLayoutLogo | Initializes a new instance of the PrintLayoutLogo class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Position |
Public property | ResourceId |
Public property | Rotation |
Public property | RotationSpecified |
Public property | Size |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutLogo Class


PrintLayoutLogo Constructor

PrintLayoutLogo Constructor
[image]

Initializes a new instance of the PrintLayoutLogo class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayoutLogo()
C++
public:
PrintLayoutLogo() sealed
J#
public PrintLayoutLogo()
JScript
public function PrintLayoutLogo()

See Also

PrintLayoutLogo Class


Properties

PrintLayoutLogo Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Position |
Public property | ResourceId |
Public property | Rotation |
Public property | RotationSpecified |
Public property | Size |
Top

See Also

PrintLayoutLogo Class


Name Property

PrintLayoutLogo.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

PrintLayoutLogo Class


Position Property

PrintLayoutLogo.Position Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Position As PrintLayoutLogoPosition
C#
public PrintLayoutLogoPosition Position { get; set; }
C++
public property PrintLayoutLogoPosition Position sealed {
PrintLayoutLogoPosition get();
void set(PrintLayoutLogoPosition value);
}
J#
/** property */
public PrintLayoutLogoPosition get_Position();

/** property */
public void set_Position(PrintLayoutLogoPosition value);
JScript
public function get Position() : PrintLayoutLogoPosition

public function set Position(value : PrintLayoutLogoPosition);

See Also

PrintLayoutLogo Class


ResourceId Property

PrintLayoutLogo.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceId As String
C#
public string ResourceId { get; set; }
C++
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

PrintLayoutLogo Class


Rotation Property

PrintLayoutLogo.Rotation Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Rotation As Single
C#
public float Rotation { get; set; }
C++
public property float Rotation sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_Rotation();

/** property */
public void set_Rotation(float value);
JScript
public function get Rotation() : float

public function set Rotation(value : float);

See Also

PrintLayoutLogo Class


RotationSpecified Property

PrintLayoutLogo.RotationSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property RotationSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool RotationSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool RotationSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_RotationSpecified();

/** property */
public void set_RotationSpecified(bool value);
JScript
public function get RotationSpecified() : bool

public function set RotationSpecified(value : bool);

See Also

PrintLayoutLogo Class


Size Property

PrintLayoutLogo.Size Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Size As PrintLayoutLogoSize
C#
public PrintLayoutLogoSize Size { get; set; }
C++
public property PrintLayoutLogoSize Size sealed {
PrintLayoutLogoSize get();
void set(PrintLayoutLogoSize value);
}
J#
/** property */
public PrintLayoutLogoSize get_Size();

/** property */
public void set_Size(PrintLayoutLogoSize value);
JScript
public function get Size() : PrintLayoutLogoSize

public function set Size(value : PrintLayoutLogoSize);

See Also

PrintLayoutLogo Class


PrintLayoutLogoCollection Class

PrintLayoutLogoCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PrintLayoutLogoCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class PrintLayoutLogoCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class PrintLayoutLogoCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class PrintLayoutLogoCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class PrintLayoutLogoCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.PrintLayoutLogoCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayoutLogoCollection Members


PrintLayoutLogoCollection Members

PrintLayoutLogoCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintLayoutLogoCollection.

Public Constructors

 | Name | Description
Public method | PrintLayoutLogoCollection | Initializes a new instance of the PrintLayoutLogoCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutLogoCollection Class


PrintLayoutLogoCollection Constructor

PrintLayoutLogoCollection Constructor
[image]

Initializes a new instance of the PrintLayoutLogoCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayoutLogoCollection()
C++
public:
PrintLayoutLogoCollection() sealed
J#
public PrintLayoutLogoCollection()
JScript
public function PrintLayoutLogoCollection()

See Also

PrintLayoutLogoCollection Class


Properties

PrintLayoutLogoCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

PrintLayoutLogoCollection Class


Item Property

PrintLayoutLogoCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As PrintLayoutLogo
C#
public PrintLayoutLogo this[
int idx
] { get; set; }
C++
public property PrintLayoutLogo default[int idx] sealed {
PrintLayoutLogo get(int idx);
void set(int idx, PrintLayoutLogo value);
}
J#
/** property */
public PrintLayoutLogo get_Item(int idx);

/** property */
public void set_Item(int idx, PrintLayoutLogo value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

PrintLayoutLogoCollection Class


Methods

PrintLayoutLogoCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutLogoCollection Class


Add Method

PrintLayoutLogoCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As PrintLayoutLogo _
) As Integer
C#
public int Add(
PrintLayoutLogo value
)
C++
public:
int Add(
PrintLayoutLogo value
) sealed
J#
public int Add(
PrintLayoutLogo value
)
JScript
public function Add(
value : PrintLayoutLogo
) : int

See Also

PrintLayoutLogoCollection Class


PrintLayoutLogoPosition Class

PrintLayoutLogoPosition Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PrintLayoutLogoPosition
C#
public class PrintLayoutLogoPosition
C++
ref class PrintLayoutLogoPosition
J#
public class PrintLayoutLogoPosition
JScript
public class PrintLayoutLogoPosition

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PrintLayoutLogoPosition

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayoutLogoPosition Members


PrintLayoutLogoPosition Members

PrintLayoutLogoPosition Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintLayoutLogoPosition.

Public Constructors

 | Name | Description
Public method | PrintLayoutLogoPosition | Initializes a new instance of the PrintLayoutLogoPosition class.
Top

Public Properties

 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | Units |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutLogoPosition Class


PrintLayoutLogoPosition Constructor

PrintLayoutLogoPosition Constructor
[image]

Initializes a new instance of the PrintLayoutLogoPosition class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayoutLogoPosition()
C++
public:
PrintLayoutLogoPosition() sealed
J#
public PrintLayoutLogoPosition()
JScript
public function PrintLayoutLogoPosition()

See Also

PrintLayoutLogoPosition Class


Properties

PrintLayoutLogoPosition Properties
[image]

Public Properties

 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | Units |
Top

See Also

PrintLayoutLogoPosition Class


Bottom Property

PrintLayoutLogoPosition.Bottom Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Bottom As Single
C#
public float Bottom { get; set; }
C++
public property float Bottom sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_Bottom();

/** property */
public void set_Bottom(float value);
JScript
public function get Bottom() : float

public function set Bottom(value : float);

See Also

PrintLayoutLogoPosition Class


Left Property

PrintLayoutLogoPosition.Left Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As Single
C#
public float Left { get; set; }
C++
public property float Left sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_Left();

/** property */
public void set_Left(float value);
JScript
public function get Left() : float

public function set Left(value : float);

See Also

PrintLayoutLogoPosition Class


Units Property

PrintLayoutLogoPosition.Units Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Units As String
C#
public string Units { get; set; }
C++
public property string Units sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Units();

/** property */
public void set_Units(string value);
JScript
public function get Units() : String

public function set Units(value : String);

See Also

PrintLayoutLogoPosition Class


PrintLayoutLogoSize Class

PrintLayoutLogoSize Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PrintLayoutLogoSize
C#
public class PrintLayoutLogoSize
C++
ref class PrintLayoutLogoSize
J#
public class PrintLayoutLogoSize
JScript
public class PrintLayoutLogoSize

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PrintLayoutLogoSize

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayoutLogoSize Members


PrintLayoutLogoSize Members

PrintLayoutLogoSize Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintLayoutLogoSize.

Public Constructors

 | Name | Description
Public method | PrintLayoutLogoSize | Initializes a new instance of the PrintLayoutLogoSize class.
Top

Public Properties

 | Name | Description
Public property | Height |
Public property | Units |
Public property | Width |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutLogoSize Class


PrintLayoutLogoSize Constructor

PrintLayoutLogoSize Constructor
[image]

Initializes a new instance of the PrintLayoutLogoSize class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayoutLogoSize()
C++
public:
PrintLayoutLogoSize() sealed
J#
public PrintLayoutLogoSize()
JScript
public function PrintLayoutLogoSize()

See Also

PrintLayoutLogoSize Class


Properties

PrintLayoutLogoSize Properties
[image]

Public Properties

 | Name | Description
Public property | Height |
Public property | Units |
Public property | Width |
Top

See Also

PrintLayoutLogoSize Class


Height Property

PrintLayoutLogoSize.Height Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height { get; set; }
C++
public property float Height sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_Height();

/** property */
public void set_Height(float value);
JScript
public function get Height() : float

public function set Height(value : float);

See Also

PrintLayoutLogoSize Class


Units Property

PrintLayoutLogoSize.Units Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Units As String
C#
public string Units { get; set; }
C++
public property string Units sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Units();

/** property */
public void set_Units(string value);
JScript
public function get Units() : String

public function set Units(value : String);

See Also

PrintLayoutLogoSize Class


Width Property

PrintLayoutLogoSize.Width Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Single
C#
public float Width { get; set; }
C++
public property float Width sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_Width();

/** property */
public void set_Width(float value);
JScript
public function get Width() : float

public function set Width(value : float);

See Also

PrintLayoutLogoSize Class


PrintLayoutPageProperties Class

PrintLayoutPageProperties Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PrintLayoutPageProperties
C#
public class PrintLayoutPageProperties
C++
ref class PrintLayoutPageProperties
J#
public class PrintLayoutPageProperties
JScript
public class PrintLayoutPageProperties

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PrintLayoutPageProperties

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayoutPageProperties Members


PrintLayoutPageProperties Members

PrintLayoutPageProperties Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintLayoutPageProperties.

Public Constructors

 | Name | Description
Public method | PrintLayoutPageProperties | Initializes a new instance of the PrintLayoutPageProperties class.
Top

Public Properties

 | Name | Description
Public property | BackgroundColor |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutPageProperties Class


PrintLayoutPageProperties Constructor

PrintLayoutPageProperties Constructor
[image]

Initializes a new instance of the PrintLayoutPageProperties class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayoutPageProperties()
C++
public:
PrintLayoutPageProperties() sealed
J#
public PrintLayoutPageProperties()
JScript
public function PrintLayoutPageProperties()

See Also

PrintLayoutPageProperties Class


Properties

PrintLayoutPageProperties Properties
[image]

Public Properties

 | Name | Description
Public property | BackgroundColor |
Top

See Also

PrintLayoutPageProperties Class


BackgroundColor Property

PrintLayoutPageProperties.BackgroundColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property BackgroundColor As PrintLayoutPagePropertiesBackgroundColor
C#
public PrintLayoutPagePropertiesBackgroundColor BackgroundColor { get; set; }
C++
public property PrintLayoutPagePropertiesBackgroundColor BackgroundColor sealed {
PrintLayoutPagePropertiesBackgroundColor get();
void set(PrintLayoutPagePropertiesBackgroundColor value);
}
J#
/** property */
public PrintLayoutPagePropertiesBackgroundColor get_BackgroundColor();

/** property */
public void set_BackgroundColor(PrintLayoutPagePropertiesBackgroundColor value);
JScript
public function get BackgroundColor() : PrintLayoutPagePropertiesBackgroundColor

public function set BackgroundColor(value : PrintLayoutPagePropertiesBackgroundColor);

See Also

PrintLayoutPageProperties Class


PrintLayoutPagePropertiesBackgroundColor Class

PrintLayoutPagePropertiesBackgroundColor Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PrintLayoutPagePropertiesBackgroundColor
C#
public class PrintLayoutPagePropertiesBackgroundColor
C++
ref class PrintLayoutPagePropertiesBackgroundColor
J#
public class PrintLayoutPagePropertiesBackgroundColor
JScript
public class PrintLayoutPagePropertiesBackgroundColor

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PrintLayoutPagePropertiesBackgroundColor

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayoutPagePropertiesBackgroundColor Members


PrintLayoutPagePropertiesBackgroundColor Members

PrintLayoutPagePropertiesBackgroundColor Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintLayoutPagePropertiesBackgroundColor.

Public Constructors

 | Name | Description
Public method | PrintLayoutPagePropertiesBackgroundColor | Initializes a new instance of the PrintLayoutPagePropertiesBackgroundColor class.
Top

Public Properties

 | Name | Description
Public property | Blue |
Public property | Green |
Public property | Red |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutPagePropertiesBackgroundColor Class


PrintLayoutPagePropertiesBackgroundColor Constructor

PrintLayoutPagePropertiesBackgroundColor Constructor
[image]

Initializes a new instance of the PrintLayoutPagePropertiesBackgroundColor class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayoutPagePropertiesBackgroundColor()
C++
public:
PrintLayoutPagePropertiesBackgroundColor() sealed
J#
public PrintLayoutPagePropertiesBackgroundColor()
JScript
public function PrintLayoutPagePropertiesBackgroundColor()

See Also

PrintLayoutPagePropertiesBackgroundColor Class


Properties

PrintLayoutPagePropertiesBackgroundColor Properties
[image]

Public Properties

 | Name | Description
Public property | Blue |
Public property | Green |
Public property | Red |
Top

See Also

PrintLayoutPagePropertiesBackgroundColor Class


Blue Property

PrintLayoutPagePropertiesBackgroundColor.Blue Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property Blue As String
C#
[XmlElementAttribute(DataType = "integer")]
public string Blue { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string Blue sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_Blue();

/** property */
public void set_Blue(string value);
JScript
public function get Blue() : String

public function set Blue(value : String);

See Also

PrintLayoutPagePropertiesBackgroundColor Class


Green Property

PrintLayoutPagePropertiesBackgroundColor.Green Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property Green As String
C#
[XmlElementAttribute(DataType = "integer")]
public string Green { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string Green sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_Green();

/** property */
public void set_Green(string value);
JScript
public function get Green() : String

public function set Green(value : String);

See Also

PrintLayoutPagePropertiesBackgroundColor Class


Red Property

PrintLayoutPagePropertiesBackgroundColor.Red Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property Red As String
C#
[XmlElementAttribute(DataType = "integer")]
public string Red { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string Red sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_Red();

/** property */
public void set_Red(string value);
JScript
public function get Red() : String

public function set Red(value : String);

See Also

PrintLayoutPagePropertiesBackgroundColor Class


PrintLayoutText Class

PrintLayoutText Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PrintLayoutText
C#
public class PrintLayoutText
C++
ref class PrintLayoutText
J#
public class PrintLayoutText
JScript
public class PrintLayoutText

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PrintLayoutText

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayoutText Members


PrintLayoutText Members

PrintLayoutText Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintLayoutText.

Public Constructors

 | Name | Description
Public method | PrintLayoutText | Initializes a new instance of the PrintLayoutText class.
Top

Public Properties

 | Name | Description
Public property | Font |
Public property | Position |
Public property | Value |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutText Class


PrintLayoutText Constructor

PrintLayoutText Constructor
[image]

Initializes a new instance of the PrintLayoutText class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayoutText()
C++
public:
PrintLayoutText() sealed
J#
public PrintLayoutText()
JScript
public function PrintLayoutText()

See Also

PrintLayoutText Class


Properties

PrintLayoutText Properties
[image]

Public Properties

 | Name | Description
Public property | Font |
Public property | Position |
Public property | Value |
Top

See Also

PrintLayoutText Class


Font Property

PrintLayoutText.Font Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Font As PrintLayoutTextFont
C#
public PrintLayoutTextFont Font { get; set; }
C++
public property PrintLayoutTextFont Font sealed {
PrintLayoutTextFont get();
void set(PrintLayoutTextFont value);
}
J#
/** property */
public PrintLayoutTextFont get_Font();

/** property */
public void set_Font(PrintLayoutTextFont value);
JScript
public function get Font() : PrintLayoutTextFont

public function set Font(value : PrintLayoutTextFont);

See Also

PrintLayoutText Class


Position Property

PrintLayoutText.Position Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Position As PrintLayoutTextPosition
C#
public PrintLayoutTextPosition Position { get; set; }
C++
public property PrintLayoutTextPosition Position sealed {
PrintLayoutTextPosition get();
void set(PrintLayoutTextPosition value);
}
J#
/** property */
public PrintLayoutTextPosition get_Position();

/** property */
public void set_Position(PrintLayoutTextPosition value);
JScript
public function get Position() : PrintLayoutTextPosition

public function set Position(value : PrintLayoutTextPosition);

See Also

PrintLayoutText Class


Value Property

PrintLayoutText.Value Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
C++
public property string Value sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

PrintLayoutText Class


PrintLayoutTextCollection Class

PrintLayoutTextCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PrintLayoutTextCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class PrintLayoutTextCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class PrintLayoutTextCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class PrintLayoutTextCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class PrintLayoutTextCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.PrintLayoutTextCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayoutTextCollection Members


PrintLayoutTextCollection Members

PrintLayoutTextCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintLayoutTextCollection.

Public Constructors

 | Name | Description
Public method | PrintLayoutTextCollection | Initializes a new instance of the PrintLayoutTextCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutTextCollection Class


PrintLayoutTextCollection Constructor

PrintLayoutTextCollection Constructor
[image]

Initializes a new instance of the PrintLayoutTextCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayoutTextCollection()
C++
public:
PrintLayoutTextCollection() sealed
J#
public PrintLayoutTextCollection()
JScript
public function PrintLayoutTextCollection()

See Also

PrintLayoutTextCollection Class


Properties

PrintLayoutTextCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

PrintLayoutTextCollection Class


Item Property

PrintLayoutTextCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As PrintLayoutText
C#
public PrintLayoutText this[
int idx
] { get; set; }
C++
public property PrintLayoutText default[int idx] sealed {
PrintLayoutText get(int idx);
void set(int idx, PrintLayoutText value);
}
J#
/** property */
public PrintLayoutText get_Item(int idx);

/** property */
public void set_Item(int idx, PrintLayoutText value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

PrintLayoutTextCollection Class


Methods

PrintLayoutTextCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutTextCollection Class


Add Method

PrintLayoutTextCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As PrintLayoutText _
) As Integer
C#
public int Add(
PrintLayoutText value
)
C++
public:
int Add(
PrintLayoutText value
) sealed
J#
public int Add(
PrintLayoutText value
)
JScript
public function Add(
value : PrintLayoutText
) : int

See Also

PrintLayoutTextCollection Class


PrintLayoutTextFont Class

PrintLayoutTextFont Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PrintLayoutTextFont
C#
public class PrintLayoutTextFont
C++
ref class PrintLayoutTextFont
J#
public class PrintLayoutTextFont
JScript
public class PrintLayoutTextFont

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PrintLayoutTextFont

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayoutTextFont Members


PrintLayoutTextFont Members

PrintLayoutTextFont Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintLayoutTextFont.

Public Constructors

 | Name | Description
Public method | PrintLayoutTextFont | Initializes a new instance of the PrintLayoutTextFont class.
Top

Public Properties

 | Name | Description
Public property | Height |
Public property | Name |
Public property | Units |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutTextFont Class


PrintLayoutTextFont Constructor

PrintLayoutTextFont Constructor
[image]

Initializes a new instance of the PrintLayoutTextFont class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayoutTextFont()
C++
public:
PrintLayoutTextFont() sealed
J#
public PrintLayoutTextFont()
JScript
public function PrintLayoutTextFont()

See Also

PrintLayoutTextFont Class


Properties

PrintLayoutTextFont Properties
[image]

Public Properties

 | Name | Description
Public property | Height |
Public property | Name |
Public property | Units |
Top

See Also

PrintLayoutTextFont Class


Height Property

PrintLayoutTextFont.Height Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height { get; set; }
C++
public property float Height sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_Height();

/** property */
public void set_Height(float value);
JScript
public function get Height() : float

public function set Height(value : float);

See Also

PrintLayoutTextFont Class


Name Property

PrintLayoutTextFont.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

PrintLayoutTextFont Class


Units Property

PrintLayoutTextFont.Units Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Units As String
C#
public string Units { get; set; }
C++
public property string Units sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Units();

/** property */
public void set_Units(string value);
JScript
public function get Units() : String

public function set Units(value : String);

See Also

PrintLayoutTextFont Class


PrintLayoutTextPosition Class

PrintLayoutTextPosition Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PrintLayoutTextPosition
C#
public class PrintLayoutTextPosition
C++
ref class PrintLayoutTextPosition
J#
public class PrintLayoutTextPosition
JScript
public class PrintLayoutTextPosition

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PrintLayoutTextPosition

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PrintLayoutTextPosition Members


PrintLayoutTextPosition Members

PrintLayoutTextPosition Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PrintLayoutTextPosition.

Public Constructors

 | Name | Description
Public method | PrintLayoutTextPosition | Initializes a new instance of the PrintLayoutTextPosition class.
Top

Public Properties

 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | Units |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PrintLayoutTextPosition Class


PrintLayoutTextPosition Constructor

PrintLayoutTextPosition Constructor
[image]

Initializes a new instance of the PrintLayoutTextPosition class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PrintLayoutTextPosition()
C++
public:
PrintLayoutTextPosition() sealed
J#
public PrintLayoutTextPosition()
JScript
public function PrintLayoutTextPosition()

See Also

PrintLayoutTextPosition Class


Properties

PrintLayoutTextPosition Properties
[image]

Public Properties

 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | Units |
Top

See Also

PrintLayoutTextPosition Class


Bottom Property

PrintLayoutTextPosition.Bottom Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Bottom As Single
C#
public float Bottom { get; set; }
C++
public property float Bottom sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_Bottom();

/** property */
public void set_Bottom(float value);
JScript
public function get Bottom() : float

public function set Bottom(value : float);

See Also

PrintLayoutTextPosition Class


Left Property

PrintLayoutTextPosition.Left Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Left As Single
C#
public float Left { get; set; }
C++
public property float Left sealed {
float get();
void set(float value);
}
J#
/** property */
public float get_Left();

/** property */
public void set_Left(float value);
JScript
public function get Left() : float

public function set Left(value : float);

See Also

PrintLayoutTextPosition Class


Units Property

PrintLayoutTextPosition.Units Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Units As String
C#
public string Units { get; set; }
C++
public property string Units sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Units();

/** property */
public void set_Units(string value);
JScript
public function get Units() : String

public function set Units(value : String);

See Also

PrintLayoutTextPosition Class


PropertiesType Class

PropertiesType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(PropertySetTypeProperties))>
Public Class PropertiesType
C#
[XmlIncludeAttribute(typeof(PropertySetTypeProperties))]
public class PropertiesType
C++
[XmlIncludeAttribute(typeof(PropertySetTypeProperties))]
ref class PropertiesType
J#
/** @attribute XmlIncludeAttribute(typeof(PropertySetTypeProperties)) */
public class PropertiesType
JScript
public
XmlIncludeAttribute(typeof(PropertySetTypeProperties))
class PropertiesType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PropertiesType
OSGeo.MapGuide.MaestroAPI.PropertySetTypeProperties

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertiesType Members


PropertiesType Members

PropertiesType Members
See Also Example Constructors Methods
[image]

The following tables list the members exposed by PropertiesType.

Public Constructors

 | Name | Description
Public method | PropertiesType | Initializes a new instance of the PropertiesType class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertiesType Class


PropertiesType Constructor

PropertiesType Constructor
[image]

Initializes a new instance of the PropertiesType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertiesType()
C++
public:
PropertiesType() sealed
J#
public PropertiesType()
JScript
public function PropertiesType()

See Also

PropertiesType Class


PropertyCollectionType Class

PropertyCollectionType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(PropertySetTypePropertiesPropertyCollection))>
Public Class PropertyCollectionType
C#
[XmlIncludeAttribute(typeof(PropertySetTypePropertiesPropertyCollection))]
public class PropertyCollectionType
C++
[XmlIncludeAttribute(typeof(PropertySetTypePropertiesPropertyCollection))]
ref class PropertyCollectionType
J#
/** @attribute XmlIncludeAttribute(typeof(PropertySetTypePropertiesPropertyCollection)) */
public class PropertyCollectionType
JScript
public
XmlIncludeAttribute(typeof(PropertySetTypePropertiesPropertyCollection))
class PropertyCollectionType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PropertyCollectionType
OSGeo.MapGuide.MaestroAPI.PropertySetTypePropertiesPropertyCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertyCollectionType Members


PropertyCollectionType Members

PropertyCollectionType Members
See Also Example Constructors Methods
[image]

The following tables list the members exposed by PropertyCollectionType.

Public Constructors

 | Name | Description
Public method | PropertyCollectionType | Initializes a new instance of the PropertyCollectionType class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertyCollectionType Class


PropertyCollectionType Constructor

PropertyCollectionType Constructor
[image]

Initializes a new instance of the PropertyCollectionType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertyCollectionType()
C++
public:
PropertyCollectionType() sealed
J#
public PropertyCollectionType()
JScript
public function PropertyCollectionType()

See Also

PropertyCollectionType Class


PropertyDefinitionsType Class

PropertyDefinitionsType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(PropertySetTypePropertyDefinitions))>
Public Class PropertyDefinitionsType
C#
[XmlIncludeAttribute(typeof(PropertySetTypePropertyDefinitions))]
public class PropertyDefinitionsType
C++
[XmlIncludeAttribute(typeof(PropertySetTypePropertyDefinitions))]
ref class PropertyDefinitionsType
J#
/** @attribute XmlIncludeAttribute(typeof(PropertySetTypePropertyDefinitions)) */
public class PropertyDefinitionsType
JScript
public
XmlIncludeAttribute(typeof(PropertySetTypePropertyDefinitions))
class PropertyDefinitionsType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PropertyDefinitionsType
OSGeo.MapGuide.MaestroAPI.PropertySetTypePropertyDefinitions

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertyDefinitionsType Members


PropertyDefinitionsType Members

PropertyDefinitionsType Members
See Also Example Constructors Methods
[image]

The following tables list the members exposed by PropertyDefinitionsType.

Public Constructors

 | Name | Description
Public method | PropertyDefinitionsType | Initializes a new instance of the PropertyDefinitionsType class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertyDefinitionsType Class


PropertyDefinitionsType Constructor

PropertyDefinitionsType Constructor
[image]

Initializes a new instance of the PropertyDefinitionsType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertyDefinitionsType()
C++
public:
PropertyDefinitionsType() sealed
J#
public PropertyDefinitionsType()
JScript
public function PropertyDefinitionsType()

See Also

PropertyDefinitionsType Class


PropertyDefinitionType Class

PropertyDefinitionType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PropertyDefinitionType
C#
public class PropertyDefinitionType
C++
ref class PropertyDefinitionType
J#
public class PropertyDefinitionType
JScript
public class PropertyDefinitionType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PropertyDefinitionType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertyDefinitionType Members


PropertyDefinitionType Members

PropertyDefinitionType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PropertyDefinitionType.

Public Constructors

 | Name | Description
Public method | PropertyDefinitionType | Initializes a new instance of the PropertyDefinitionType class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertyDefinitionType Class


PropertyDefinitionType Constructor

PropertyDefinitionType Constructor
[image]

Initializes a new instance of the PropertyDefinitionType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertyDefinitionType()
C++
public:
PropertyDefinitionType() sealed
J#
public PropertyDefinitionType()
JScript
public function PropertyDefinitionType()

See Also

PropertyDefinitionType Class


Properties

PropertyDefinitionType Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Type |
Top

See Also

PropertyDefinitionType Class


Name Property

PropertyDefinitionType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

PropertyDefinitionType Class


Type Property

PropertyDefinitionType.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As PropertyDefinitionTypeType
C#
public PropertyDefinitionTypeType Type { get; set; }
C++
public property PropertyDefinitionTypeType Type sealed {
PropertyDefinitionTypeType get();
void set(PropertyDefinitionTypeType value);
}
J#
/** property */
public PropertyDefinitionTypeType get_Type();

/** property */
public void set_Type(PropertyDefinitionTypeType value);
JScript
public function get Type() : PropertyDefinitionTypeType

public function set Type(value : PropertyDefinitionTypeType);

See Also

PropertyDefinitionType Class


PropertyDefinitionTypeCollection Class

PropertyDefinitionTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PropertyDefinitionTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class PropertyDefinitionTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class PropertyDefinitionTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class PropertyDefinitionTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class PropertyDefinitionTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.PropertyDefinitionTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertyDefinitionTypeCollection Members


PropertyDefinitionTypeCollection Members

PropertyDefinitionTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PropertyDefinitionTypeCollection.

Public Constructors

 | Name | Description
Public method | PropertyDefinitionTypeCollection | Initializes a new instance of the PropertyDefinitionTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertyDefinitionTypeCollection Class


PropertyDefinitionTypeCollection Constructor

PropertyDefinitionTypeCollection Constructor
[image]

Initializes a new instance of the PropertyDefinitionTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertyDefinitionTypeCollection()
C++
public:
PropertyDefinitionTypeCollection() sealed
J#
public PropertyDefinitionTypeCollection()
JScript
public function PropertyDefinitionTypeCollection()

See Also

PropertyDefinitionTypeCollection Class


Properties

PropertyDefinitionTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

PropertyDefinitionTypeCollection Class


Item Property

PropertyDefinitionTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As PropertyDefinitionType
C#
public PropertyDefinitionType this[
int idx
] { get; set; }
C++
public property PropertyDefinitionType default[int idx] sealed {
PropertyDefinitionType get(int idx);
void set(int idx, PropertyDefinitionType value);
}
J#
/** property */
public PropertyDefinitionType get_Item(int idx);

/** property */
public void set_Item(int idx, PropertyDefinitionType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

PropertyDefinitionTypeCollection Class


Methods

PropertyDefinitionTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertyDefinitionTypeCollection Class


Add Method

PropertyDefinitionTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As PropertyDefinitionType _
) As Integer
C#
public int Add(
PropertyDefinitionType value
)
C++
public:
int Add(
PropertyDefinitionType value
) sealed
J#
public int Add(
PropertyDefinitionType value
)
JScript
public function Add(
value : PropertyDefinitionType
) : int

See Also

PropertyDefinitionTypeCollection Class


PropertyDefinitionTypeType Enumeration

PropertyDefinitionTypeType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum PropertyDefinitionTypeType
C#
public enum PropertyDefinitionTypeType
C++
public enum class PropertyDefinitionTypeType
J#
public enum PropertyDefinitionTypeType
JScript
public enum PropertyDefinitionTypeType

Members

Member Name | Description
boolean |
byte |
datetime |
decimal |
double |
int16 |
int32 |
int64 |
single |
string |
blob |
clob |

See Also


PropertySetType Class

PropertySetType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("PropertySet", Namespace := "", IsNullable := False)>
Public Class PropertySetType
C#
[XmlRootAttribute("PropertySet", Namespace = "", IsNullable = False)]
public class PropertySetType
C++
[XmlRootAttribute(L"PropertySet", Namespace = L"", IsNullable = False)]
ref class PropertySetType
J#
/** @attribute XmlRootAttribute("PropertySet", Namespace = "", IsNullable = False) */
public class PropertySetType
JScript
public
XmlRootAttribute("PropertySet", Namespace = "", IsNullable = False)
class PropertySetType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PropertySetType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertySetType Members


PropertySetType Members

PropertySetType Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by PropertySetType.

Public Constructors

 | Name | Description
Public method | PropertySetType | Initializes a new instance of the PropertySetType class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Properties |
Public property | PropertyDefinitions |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertySetType Class


PropertySetType Constructor

PropertySetType Constructor
[image]

Initializes a new instance of the PropertySetType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertySetType()
C++
public:
PropertySetType() sealed
J#
public PropertySetType()
JScript
public function PropertySetType()

See Also

PropertySetType Class


Fields

PropertySetType Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

PropertySetType Class


SchemaName Field

PropertySetType.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

PropertySetType Class


Properties

PropertySetType Properties
[image]

Public Properties

 | Name | Description
Public property | Properties |
Public property | PropertyDefinitions |
Public property | XsdSchema |
Top

See Also

PropertySetType Class


Properties Property

PropertySetType.Properties Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Properties As PropertySetTypeProperties
C#
public PropertySetTypeProperties Properties { get; set; }
C++
public property PropertySetTypeProperties Properties sealed {
PropertySetTypeProperties get();
void set(PropertySetTypeProperties value);
}
J#
/** property */
public PropertySetTypeProperties get_Properties();

/** property */
public void set_Properties(PropertySetTypeProperties value);
JScript
public function get Properties() : PropertySetTypeProperties

public function set Properties(value : PropertySetTypeProperties);

See Also

PropertySetType Class


PropertyDefinitions Property

PropertySetType.PropertyDefinitions Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property PropertyDefinitions As PropertySetTypePropertyDefinitions
C#
public PropertySetTypePropertyDefinitions PropertyDefinitions { get; set; }
C++
public property PropertySetTypePropertyDefinitions PropertyDefinitions sealed {
PropertySetTypePropertyDefinitions get();
void set(PropertySetTypePropertyDefinitions value);
}
J#
/** property */
public PropertySetTypePropertyDefinitions get_PropertyDefinitions();

/** property */
public void set_PropertyDefinitions(PropertySetTypePropertyDefinitions value);
JScript
public function get PropertyDefinitions() : PropertySetTypePropertyDefinitions

public function set PropertyDefinitions(value : PropertySetTypePropertyDefinitions);

See Also

PropertySetType Class


XsdSchema Property

PropertySetType.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

PropertySetType Class


PropertySetTypeProperties Class

PropertySetTypeProperties Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PropertySetTypeProperties
Inherits PropertiesType
C#
public class PropertySetTypeProperties : PropertiesType
C++
ref class PropertySetTypeProperties : PropertiesType
J#
public class PropertySetTypeProperties extends PropertiesType
JScript
public class PropertySetTypeProperties extends PropertiesType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PropertiesType
OSGeo.MapGuide.MaestroAPI.PropertySetTypeProperties

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertySetTypeProperties Members


PropertySetTypeProperties Members

PropertySetTypeProperties Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PropertySetTypeProperties.

Public Constructors

 | Name | Description
Public method | PropertySetTypeProperties | Initializes a new instance of the PropertySetTypeProperties class.
Top

Public Properties

 | Name | Description
Public property | PropertyCollection |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertySetTypeProperties Class


PropertySetTypeProperties Constructor

PropertySetTypeProperties Constructor
[image]

Initializes a new instance of the PropertySetTypeProperties class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertySetTypeProperties()
C++
public:
PropertySetTypeProperties() sealed
J#
public PropertySetTypeProperties()
JScript
public function PropertySetTypeProperties()

See Also

PropertySetTypeProperties Class


Properties

PropertySetTypeProperties Properties
[image]

Public Properties

 | Name | Description
Public property | PropertyCollection |
Top

See Also

PropertySetTypeProperties Class


PropertyCollection Property

PropertySetTypeProperties.PropertyCollection Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("PropertyCollection")>
Public Property PropertyCollection As PropertySetTypePropertiesPropertyCollectionCollection
C#
[XmlElementAttribute("PropertyCollection")]
public PropertySetTypePropertiesPropertyCollectionCollection PropertyCollection { get; set; }
C++
[XmlElementAttribute(L"PropertyCollection")]
public property PropertySetTypePropertiesPropertyCollectionCollection PropertyCollection sealed {
PropertySetTypePropertiesPropertyCollectionCollection get();
void set(PropertySetTypePropertiesPropertyCollectionCollection value);
}
J#
/** @attribute XmlElementAttribute("PropertyCollection") */
/** property */
public PropertySetTypePropertiesPropertyCollectionCollection get_PropertyCollection();

/** property */
public void set_PropertyCollection(PropertySetTypePropertiesPropertyCollectionCollection value);
JScript
public function get PropertyCollection() : PropertySetTypePropertiesPropertyCollectionCollection

public function set PropertyCollection(value : PropertySetTypePropertiesPropertyCollectionCollection);

See Also

PropertySetTypeProperties Class


PropertySetTypePropertiesPropertyCollection Class

PropertySetTypePropertiesPropertyCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PropertySetTypePropertiesPropertyCollection
Inherits PropertyCollectionType
C#
public class PropertySetTypePropertiesPropertyCollection : PropertyCollectionType
C++
ref class PropertySetTypePropertiesPropertyCollection : PropertyCollectionType
J#
public class PropertySetTypePropertiesPropertyCollection extends PropertyCollectionType
JScript
public class PropertySetTypePropertiesPropertyCollection extends PropertyCollectionType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PropertyCollectionType
OSGeo.MapGuide.MaestroAPI.PropertySetTypePropertiesPropertyCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertySetTypePropertiesPropertyCollection Members


PropertySetTypePropertiesPropertyCollection Members

PropertySetTypePropertiesPropertyCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PropertySetTypePropertiesPropertyCollection.

Public Constructors

 | Name | Description
Public method | PropertySetTypePropertiesPropertyCollection | Initializes a new instance of the PropertySetTypePropertiesPropertyCollection class.
Top

Public Properties

 | Name | Description
Public property | Property |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertySetTypePropertiesPropertyCollection Class


PropertySetTypePropertiesPropertyCollection Constructor

PropertySetTypePropertiesPropertyCollection Constructor
[image]

Initializes a new instance of the PropertySetTypePropertiesPropertyCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertySetTypePropertiesPropertyCollection()
C++
public:
PropertySetTypePropertiesPropertyCollection() sealed
J#
public PropertySetTypePropertiesPropertyCollection()
JScript
public function PropertySetTypePropertiesPropertyCollection()

See Also

PropertySetTypePropertiesPropertyCollection Class


Properties

PropertySetTypePropertiesPropertyCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Property |
Top

See Also

PropertySetTypePropertiesPropertyCollection Class


Property Property

PropertySetTypePropertiesPropertyCollection.Property Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Property")>
Public Property Property As PropertyTypeCollection
C#
[XmlElementAttribute("Property")]
public PropertyTypeCollection Property { get; set; }
C++
[XmlElementAttribute(L"Property")]
public property PropertyTypeCollection Property sealed {
PropertyTypeCollection get();
void set(PropertyTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("Property") */
/** property */
public PropertyTypeCollection get_Property();

/** property */
public void set_Property(PropertyTypeCollection value);
JScript
public function get Property() : PropertyTypeCollection

public function set Property(value : PropertyTypeCollection);

See Also

PropertySetTypePropertiesPropertyCollection Class


PropertySetTypePropertiesPropertyCollectionCollection Class

PropertySetTypePropertiesPropertyCollectionCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PropertySetTypePropertiesPropertyCollectionCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class PropertySetTypePropertiesPropertyCollectionCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class PropertySetTypePropertiesPropertyCollectionCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class PropertySetTypePropertiesPropertyCollectionCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class PropertySetTypePropertiesPropertyCollectionCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.PropertySetTypePropertiesPropertyCollectionCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertySetTypePropertiesPropertyCollectionCollection Members


PropertySetTypePropertiesPropertyCollectionCollection Members

PropertySetTypePropertiesPropertyCollectionCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PropertySetTypePropertiesPropertyCollectionCollection.

Public Constructors

 | Name | Description
Public method | PropertySetTypePropertiesPropertyCollectionCollection | Initializes a new instance of the PropertySetTypePropertiesPropertyCollectionCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertySetTypePropertiesPropertyCollectionCollection Class


PropertySetTypePropertiesPropertyCollectionCollection Constructor

PropertySetTypePropertiesPropertyCollectionCollection Constructor
See Also Example
[image]

Initializes a new instance of the PropertySetTypePropertiesPropertyCollectionCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertySetTypePropertiesPropertyCollectionCollection()
C++
public:
PropertySetTypePropertiesPropertyCollectionCollection() sealed
J#
public PropertySetTypePropertiesPropertyCollectionCollection()
JScript
public function PropertySetTypePropertiesPropertyCollectionCollection()

See Also

PropertySetTypePropertiesPropertyCollectionCollection Class


Properties

PropertySetTypePropertiesPropertyCollectionCollection Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

PropertySetTypePropertiesPropertyCollectionCollection Class


Item Property

PropertySetTypePropertiesPropertyCollectionCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As PropertySetTypePropertiesPropertyCollection
C#
public PropertySetTypePropertiesPropertyCollection this[
int idx
] { get; set; }
C++
public property PropertySetTypePropertiesPropertyCollection default[int idx] sealed {
PropertySetTypePropertiesPropertyCollection get(int idx);
void set(int idx, PropertySetTypePropertiesPropertyCollection value);
}
J#
/** property */
public PropertySetTypePropertiesPropertyCollection get_Item(int idx);

/** property */
public void set_Item(int idx, PropertySetTypePropertiesPropertyCollection value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

PropertySetTypePropertiesPropertyCollectionCollection Class


Methods

PropertySetTypePropertiesPropertyCollectionCollection Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertySetTypePropertiesPropertyCollectionCollection Class


Add Method

PropertySetTypePropertiesPropertyCollectionCollection.Add Method
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As PropertySetTypePropertiesPropertyCollection _
) As Integer
C#
public int Add(
PropertySetTypePropertiesPropertyCollection value
)
C++
public:
int Add(
PropertySetTypePropertiesPropertyCollection value
) sealed
J#
public int Add(
PropertySetTypePropertiesPropertyCollection value
)
JScript
public function Add(
value : PropertySetTypePropertiesPropertyCollection
) : int

See Also

PropertySetTypePropertiesPropertyCollectionCollection Class


PropertySetTypePropertyDefinitions Class

PropertySetTypePropertyDefinitions Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PropertySetTypePropertyDefinitions
Inherits PropertyDefinitionsType
C#
public class PropertySetTypePropertyDefinitions : PropertyDefinitionsType
C++
ref class PropertySetTypePropertyDefinitions : PropertyDefinitionsType
J#
public class PropertySetTypePropertyDefinitions extends PropertyDefinitionsType
JScript
public class PropertySetTypePropertyDefinitions extends PropertyDefinitionsType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PropertyDefinitionsType
OSGeo.MapGuide.MaestroAPI.PropertySetTypePropertyDefinitions

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertySetTypePropertyDefinitions Members


PropertySetTypePropertyDefinitions Members

PropertySetTypePropertyDefinitions Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PropertySetTypePropertyDefinitions.

Public Constructors

 | Name | Description
Public method | PropertySetTypePropertyDefinitions | Initializes a new instance of the PropertySetTypePropertyDefinitions class.
Top

Public Properties

 | Name | Description
Public property | PropertyDefinition |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertySetTypePropertyDefinitions Class


PropertySetTypePropertyDefinitions Constructor

PropertySetTypePropertyDefinitions Constructor
[image]

Initializes a new instance of the PropertySetTypePropertyDefinitions class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertySetTypePropertyDefinitions()
C++
public:
PropertySetTypePropertyDefinitions() sealed
J#
public PropertySetTypePropertyDefinitions()
JScript
public function PropertySetTypePropertyDefinitions()

See Also

PropertySetTypePropertyDefinitions Class


Properties

PropertySetTypePropertyDefinitions Properties
[image]

Public Properties

 | Name | Description
Public property | PropertyDefinition |
Top

See Also

PropertySetTypePropertyDefinitions Class


PropertyDefinition Property

PropertySetTypePropertyDefinitions.PropertyDefinition Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("PropertyDefinition")>
Public Property PropertyDefinition As PropertyDefinitionTypeCollection
C#
[XmlElementAttribute("PropertyDefinition")]
public PropertyDefinitionTypeCollection PropertyDefinition { get; set; }
C++
[XmlElementAttribute(L"PropertyDefinition")]
public property PropertyDefinitionTypeCollection PropertyDefinition sealed {
PropertyDefinitionTypeCollection get();
void set(PropertyDefinitionTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("PropertyDefinition") */
/** property */
public PropertyDefinitionTypeCollection get_PropertyDefinition();

/** property */
public void set_PropertyDefinition(PropertyDefinitionTypeCollection value);
JScript
public function get PropertyDefinition() : PropertyDefinitionTypeCollection

public function set PropertyDefinition(value : PropertyDefinitionTypeCollection);

See Also

PropertySetTypePropertyDefinitions Class


PropertyType Class

PropertyType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class PropertyType
C#
public class PropertyType
C++
ref class PropertyType
J#
public class PropertyType
JScript
public class PropertyType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.PropertyType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertyType Members


PropertyType Members

PropertyType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PropertyType.

Public Constructors

 | Name | Description
Public method | PropertyType | Initializes a new instance of the PropertyType class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Value |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertyType Class


PropertyType Constructor

PropertyType Constructor
[image]

Initializes a new instance of the PropertyType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertyType()
C++
public:
PropertyType() sealed
J#
public PropertyType()
JScript
public function PropertyType()

See Also

PropertyType Class


Properties

PropertyType Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Value |
Top

See Also

PropertyType Class


Name Property

PropertyType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

PropertyType Class


Value Property

PropertyType.Value Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
C++
public property string Value sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

PropertyType Class


PropertyTypeCollection Class

PropertyTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PropertyTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class PropertyTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class PropertyTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class PropertyTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class PropertyTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.PropertyTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

PropertyTypeCollection Members


PropertyTypeCollection Members

PropertyTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by PropertyTypeCollection.

Public Constructors

 | Name | Description
Public method | PropertyTypeCollection | Initializes a new instance of the PropertyTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertyTypeCollection Class


PropertyTypeCollection Constructor

PropertyTypeCollection Constructor
[image]

Initializes a new instance of the PropertyTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public PropertyTypeCollection()
C++
public:
PropertyTypeCollection() sealed
J#
public PropertyTypeCollection()
JScript
public function PropertyTypeCollection()

See Also

PropertyTypeCollection Class


Properties

PropertyTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

PropertyTypeCollection Class


Item Property

PropertyTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As PropertyType
C#
public PropertyType this[
int idx
] { get; set; }
C++
public property PropertyType default[int idx] sealed {
PropertyType get(int idx);
void set(int idx, PropertyType value);
}
J#
/** property */
public PropertyType get_Item(int idx);

/** property */
public void set_Item(int idx, PropertyType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

PropertyTypeCollection Class


Methods

PropertyTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

PropertyTypeCollection Class


Add Method

PropertyTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As PropertyType _
) As Integer
C#
public int Add(
PropertyType value
)
C++
public:
int Add(
PropertyType value
) sealed
J#
public int Add(
PropertyType value
)
JScript
public function Add(
value : PropertyType
) : int

See Also

PropertyTypeCollection Class


QueryMapFeaturesLayerAttributes Enumeration

QueryMapFeaturesLayerAttributes Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum QueryMapFeaturesLayerAttributes
C#
public enum QueryMapFeaturesLayerAttributes
C++
public enum class QueryMapFeaturesLayerAttributes
J#
public enum QueryMapFeaturesLayerAttributes
JScript
public enum QueryMapFeaturesLayerAttributes

Members

Member Name | Description
AllLayers |
OnlyVisible |
OnlySelectable |
Default |
OnlyWithToolTips |
VisibleWithToolTips |

See Also


RasterLoadProcedureType Class

RasterLoadProcedureType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RasterLoadProcedureType
Inherits LoadProcedureType
C#
public class RasterLoadProcedureType : LoadProcedureType
C++
ref class RasterLoadProcedureType : LoadProcedureType
J#
public class RasterLoadProcedureType extends LoadProcedureType
JScript
public class RasterLoadProcedureType extends LoadProcedureType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LoadProcedureType
OSGeo.MapGuide.MaestroAPI.RasterLoadProcedureType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RasterLoadProcedureType Members


RasterLoadProcedureType Members

RasterLoadProcedureType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RasterLoadProcedureType.

Public Constructors

 | Name | Description
Public method | RasterLoadProcedureType | Initializes a new instance of the RasterLoadProcedureType class.
Top

Public Properties

 | Name | Description
Public property | CoordinateSystem | (inherited from LoadProcedureType)
Public property | FeatureSourceName |
Public property | GenerateLayers | (inherited from LoadProcedureType)
Public property | GenerateMaps | (inherited from LoadProcedureType)
Public property | GenerateMapsSpecified | (inherited from LoadProcedureType)
Public property | GenerateSpatialDataSources | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibraries | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibrariesSpecified | (inherited from LoadProcedureType)
Public property | GeoReferenceOverride |
Public property | LayersFolder | (inherited from LoadProcedureType)
Public property | LayersPath | (inherited from LoadProcedureType)
Public property | MapsFolder | (inherited from LoadProcedureType)
Public property | MapsPath | (inherited from LoadProcedureType)
Public property | OverlapTreatmentType |
Public property | ResourceId | (inherited from LoadProcedureType)
Public property | RootPath | (inherited from LoadProcedureType)
Public property | SourceFile | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesFolder | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesPath | (inherited from LoadProcedureType)
Public property | SubsampleFactor |
Public property | SymbolLibrariesFolder | (inherited from LoadProcedureType)
Public property | SymbolLibrariesPath | (inherited from LoadProcedureType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RasterLoadProcedureType Class


RasterLoadProcedureType Constructor

RasterLoadProcedureType Constructor
[image]

Initializes a new instance of the RasterLoadProcedureType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RasterLoadProcedureType()
C++
public:
RasterLoadProcedureType() sealed
J#
public RasterLoadProcedureType()
JScript
public function RasterLoadProcedureType()

See Also

RasterLoadProcedureType Class


Properties

RasterLoadProcedureType Properties
[image]

Public Properties

 | Name | Description
Public property | CoordinateSystem | (inherited from LoadProcedureType)
Public property | FeatureSourceName |
Public property | GenerateLayers | (inherited from LoadProcedureType)
Public property | GenerateMaps | (inherited from LoadProcedureType)
Public property | GenerateMapsSpecified | (inherited from LoadProcedureType)
Public property | GenerateSpatialDataSources | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibraries | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibrariesSpecified | (inherited from LoadProcedureType)
Public property | GeoReferenceOverride |
Public property | LayersFolder | (inherited from LoadProcedureType)
Public property | LayersPath | (inherited from LoadProcedureType)
Public property | MapsFolder | (inherited from LoadProcedureType)
Public property | MapsPath | (inherited from LoadProcedureType)
Public property | OverlapTreatmentType |
Public property | ResourceId | (inherited from LoadProcedureType)
Public property | RootPath | (inherited from LoadProcedureType)
Public property | SourceFile | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesFolder | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesPath | (inherited from LoadProcedureType)
Public property | SubsampleFactor |
Public property | SymbolLibrariesFolder | (inherited from LoadProcedureType)
Public property | SymbolLibrariesPath | (inherited from LoadProcedureType)
Top

See Also

RasterLoadProcedureType Class


FeatureSourceName Property

RasterLoadProcedureType.FeatureSourceName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FeatureSourceName As String
C#
public string FeatureSourceName { get; set; }
C++
public property string FeatureSourceName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FeatureSourceName();

/** property */
public void set_FeatureSourceName(string value);
JScript
public function get FeatureSourceName() : String

public function set FeatureSourceName(value : String);

See Also

RasterLoadProcedureType Class


GeoReferenceOverride Property

RasterLoadProcedureType.GeoReferenceOverride Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("GeoReferenceOverride")>
Public Property GeoReferenceOverride As GeoReferenceOverrideTypeCollection
C#
[XmlElementAttribute("GeoReferenceOverride")]
public GeoReferenceOverrideTypeCollection GeoReferenceOverride { get; set; }
C++
[XmlElementAttribute(L"GeoReferenceOverride")]
public property GeoReferenceOverrideTypeCollection GeoReferenceOverride sealed {
GeoReferenceOverrideTypeCollection get();
void set(GeoReferenceOverrideTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("GeoReferenceOverride") */
/** property */
public GeoReferenceOverrideTypeCollection get_GeoReferenceOverride();

/** property */
public void set_GeoReferenceOverride(GeoReferenceOverrideTypeCollection value);
JScript
public function get GeoReferenceOverride() : GeoReferenceOverrideTypeCollection

public function set GeoReferenceOverride(value : GeoReferenceOverrideTypeCollection);

See Also

RasterLoadProcedureType Class


OverlapTreatmentType Property

RasterLoadProcedureType.OverlapTreatmentType Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property OverlapTreatmentType As OverlapTreatmentType
C#
public OverlapTreatmentType OverlapTreatmentType { get; set; }
C++
public property OverlapTreatmentType OverlapTreatmentType sealed {
OverlapTreatmentType get();
void set(OverlapTreatmentType value);
}
J#
/** property */
public OverlapTreatmentType get_OverlapTreatmentType();

/** property */
public void set_OverlapTreatmentType(OverlapTreatmentType value);
JScript
public function get OverlapTreatmentType() : OverlapTreatmentType

public function set OverlapTreatmentType(value : OverlapTreatmentType);

See Also

RasterLoadProcedureType Class


SubsampleFactor Property

RasterLoadProcedureType.SubsampleFactor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SubsampleFactor As Double
C#
public double SubsampleFactor { get; set; }
C++
public property double SubsampleFactor sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_SubsampleFactor();

/** property */
public void set_SubsampleFactor(double value);
JScript
public function get SubsampleFactor() : double

public function set SubsampleFactor(value : double);

See Also

RasterLoadProcedureType Class


RelatePropertyType Class

RelatePropertyType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RelatePropertyType
C#
public class RelatePropertyType
C++
ref class RelatePropertyType
J#
public class RelatePropertyType
JScript
public class RelatePropertyType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RelatePropertyType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RelatePropertyType Members


RelatePropertyType Members

RelatePropertyType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RelatePropertyType.

Public Constructors

 | Name | Description
Public method | RelatePropertyType | Initializes a new instance of the RelatePropertyType class.
Top

Public Properties

 | Name | Description
Public property | AttributeClassProperty |
Public property | FeatureClassProperty |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RelatePropertyType Class


RelatePropertyType Constructor

RelatePropertyType Constructor
[image]

Initializes a new instance of the RelatePropertyType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RelatePropertyType()
C++
public:
RelatePropertyType() sealed
J#
public RelatePropertyType()
JScript
public function RelatePropertyType()

See Also

RelatePropertyType Class


Properties

RelatePropertyType Properties
[image]

Public Properties

 | Name | Description
Public property | AttributeClassProperty |
Public property | FeatureClassProperty |
Top

See Also

RelatePropertyType Class


AttributeClassProperty Property

RelatePropertyType.AttributeClassProperty Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property AttributeClassProperty As String
C#
public string AttributeClassProperty { get; set; }
C++
public property string AttributeClassProperty sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_AttributeClassProperty();

/** property */
public void set_AttributeClassProperty(string value);
JScript
public function get AttributeClassProperty() : String

public function set AttributeClassProperty(value : String);

See Also

RelatePropertyType Class


FeatureClassProperty Property

RelatePropertyType.FeatureClassProperty Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FeatureClassProperty As String
C#
public string FeatureClassProperty { get; set; }
C++
public property string FeatureClassProperty sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FeatureClassProperty();

/** property */
public void set_FeatureClassProperty(string value);
JScript
public function get FeatureClassProperty() : String

public function set FeatureClassProperty(value : String);

See Also

RelatePropertyType Class


RelatePropertyTypeCollection Class

RelatePropertyTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class RelatePropertyTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class RelatePropertyTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class RelatePropertyTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class RelatePropertyTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class RelatePropertyTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.RelatePropertyTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RelatePropertyTypeCollection Members


RelatePropertyTypeCollection Members

RelatePropertyTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RelatePropertyTypeCollection.

Public Constructors

 | Name | Description
Public method | RelatePropertyTypeCollection | Initializes a new instance of the RelatePropertyTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RelatePropertyTypeCollection Class


RelatePropertyTypeCollection Constructor

RelatePropertyTypeCollection Constructor
[image]

Initializes a new instance of the RelatePropertyTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RelatePropertyTypeCollection()
C++
public:
RelatePropertyTypeCollection() sealed
J#
public RelatePropertyTypeCollection()
JScript
public function RelatePropertyTypeCollection()

See Also

RelatePropertyTypeCollection Class


Properties

RelatePropertyTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

RelatePropertyTypeCollection Class


Item Property

RelatePropertyTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As RelatePropertyType
C#
public RelatePropertyType this[
int idx
] { get; set; }
C++
public property RelatePropertyType default[int idx] sealed {
RelatePropertyType get(int idx);
void set(int idx, RelatePropertyType value);
}
J#
/** property */
public RelatePropertyType get_Item(int idx);

/** property */
public void set_Item(int idx, RelatePropertyType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

RelatePropertyTypeCollection Class


Methods

RelatePropertyTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RelatePropertyTypeCollection Class


Add Method

RelatePropertyTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As RelatePropertyType _
) As Integer
C#
public int Add(
RelatePropertyType value
)
C++
public:
int Add(
RelatePropertyType value
) sealed
J#
public int Add(
RelatePropertyType value
)
JScript
public function Add(
value : RelatePropertyType
) : int

See Also

RelatePropertyTypeCollection Class


RelateTypeEnum Enumeration

RelateTypeEnum Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum RelateTypeEnum
C#
public enum RelateTypeEnum
C++
public enum class RelateTypeEnum
J#
public enum RelateTypeEnum
JScript
public enum RelateTypeEnum

Members

Member Name | Description
LeftOuter |
RightOuter |
Inner |
Association |

See Also


RepositoryContentType Class

RepositoryContentType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("RepositoryContent", Namespace := "", IsNullable := False)>
Public Class RepositoryContentType
C#
[XmlRootAttribute("RepositoryContent", Namespace = "", IsNullable = False)]
public class RepositoryContentType
C++
[XmlRootAttribute(L"RepositoryContent", Namespace = L"", IsNullable = False)]
ref class RepositoryContentType
J#
/** @attribute XmlRootAttribute("RepositoryContent", Namespace = "", IsNullable = False) */
public class RepositoryContentType
JScript
public
XmlRootAttribute("RepositoryContent", Namespace = "", IsNullable = False)
class RepositoryContentType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RepositoryContentType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RepositoryContentType Members


RepositoryContentType Members

RepositoryContentType Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by RepositoryContentType.

Public Constructors

 | Name | Description
Public method | RepositoryContentType | Initializes a new instance of the RepositoryContentType class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RepositoryContentType Class


RepositoryContentType Constructor

RepositoryContentType Constructor
[image]

Initializes a new instance of the RepositoryContentType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RepositoryContentType()
C++
public:
RepositoryContentType() sealed
J#
public RepositoryContentType()
JScript
public function RepositoryContentType()

See Also

RepositoryContentType Class


Fields

RepositoryContentType Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

RepositoryContentType Class


SchemaName Field

RepositoryContentType.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

RepositoryContentType Class


Properties

RepositoryContentType Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | XsdSchema |
Top

See Also

RepositoryContentType Class


Description Property

RepositoryContentType.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

RepositoryContentType Class


XsdSchema Property

RepositoryContentType.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

RepositoryContentType Class


ResizeBox Class

ResizeBox Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResizeBox
C#
public class ResizeBox
C++
ref class ResizeBox
J#
public class ResizeBox
JScript
public class ResizeBox

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResizeBox

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResizeBox Members


ResizeBox Members

ResizeBox Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResizeBox.

Public Constructors

 | Name | Description
Public method | ResizeBox | Initializes a new instance of the ResizeBox class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | GrowControl |
Public property | PositionX |
Public property | PositionY |
Public property | SizeX |
Public property | SizeY |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResizeBox Class


ResizeBox Constructor

ResizeBox Constructor
[image]

Initializes a new instance of the ResizeBox class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResizeBox()
C++
public:
ResizeBox() sealed
J#
public ResizeBox()
JScript
public function ResizeBox()

See Also

ResizeBox Class


Properties

ResizeBox Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | GrowControl |
Public property | PositionX |
Public property | PositionY |
Public property | SizeX |
Public property | SizeY |
Top

See Also

ResizeBox Class


ExtendedData1 Property

ResizeBox.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

ResizeBox Class


GrowControl Property

ResizeBox.GrowControl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'GrowInXYMaintainAspect'")>
Public Property GrowControl As String
C#
[DefaultValueAttribute("'GrowInXYMaintainAspect'")]
public string GrowControl { get; set; }
C++
[DefaultValueAttribute(L"'GrowInXYMaintainAspect'")]
public property string GrowControl sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'GrowInXYMaintainAspect'") */
/** property */
public string get_GrowControl();

/** property */
public void set_GrowControl(string value);
JScript
public function get GrowControl() : String

public function set GrowControl(value : String);

See Also

ResizeBox Class


PositionX Property

ResizeBox.PositionX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property PositionX As String
C#
[DefaultValueAttribute("0.0")]
public string PositionX { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string PositionX sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_PositionX();

/** property */
public void set_PositionX(string value);
JScript
public function get PositionX() : String

public function set PositionX(value : String);

See Also

ResizeBox Class


PositionY Property

ResizeBox.PositionY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property PositionY As String
C#
[DefaultValueAttribute("0.0")]
public string PositionY { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string PositionY sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_PositionY();

/** property */
public void set_PositionY(string value);
JScript
public function get PositionY() : String

public function set PositionY(value : String);

See Also

ResizeBox Class


SizeX Property

ResizeBox.SizeX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("1.0")>
Public Property SizeX As String
C#
[DefaultValueAttribute("1.0")]
public string SizeX { get; set; }
C++
[DefaultValueAttribute(L"1.0")]
public property string SizeX sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("1.0") */
/** property */
public string get_SizeX();

/** property */
public void set_SizeX(string value);
JScript
public function get SizeX() : String

public function set SizeX(value : String);

See Also

ResizeBox Class


SizeY Property

ResizeBox.SizeY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("1.0")>
Public Property SizeY As String
C#
[DefaultValueAttribute("1.0")]
public string SizeY { get; set; }
C++
[DefaultValueAttribute(L"1.0")]
public property string SizeY sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("1.0") */
/** property */
public string get_SizeY();

/** property */
public void set_SizeY(string value);
JScript
public function get SizeY() : String

public function set SizeY(value : String);

See Also

ResizeBox Class


ResourceDataList Class

ResourceDataList Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class ResourceDataList
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class ResourceDataList
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class ResourceDataList
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class ResourceDataList
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class ResourceDataList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceDataList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceDataList Members


ResourceDataList Members

ResourceDataList Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by ResourceDataList.

Public Constructors

 | Name | Description
Public method | ResourceDataList | Initializes a new instance of the ResourceDataList class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | ResourceData |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceDataList Class


ResourceDataList Constructor

ResourceDataList Constructor
[image]

Initializes a new instance of the ResourceDataList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceDataList()
C++
public:
ResourceDataList() sealed
J#
public ResourceDataList()
JScript
public function ResourceDataList()

See Also

ResourceDataList Class


Fields

ResourceDataList Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

ResourceDataList Class


SchemaName Field

ResourceDataList.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

ResourceDataList Class


Properties

ResourceDataList Properties
[image]

Public Properties

 | Name | Description
Public property | ResourceData |
Public property | XsdSchema |
Top

See Also

ResourceDataList Class


ResourceData Property

ResourceDataList.ResourceData Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("ResourceData")>
Public Property ResourceData As ResourceDataListResourceDataCollection
C#
[XmlElementAttribute("ResourceData")]
public ResourceDataListResourceDataCollection ResourceData { get; set; }
C++
[XmlElementAttribute(L"ResourceData")]
public property ResourceDataListResourceDataCollection ResourceData sealed {
ResourceDataListResourceDataCollection get();
void set(ResourceDataListResourceDataCollection value);
}
J#
/** @attribute XmlElementAttribute("ResourceData") */
/** property */
public ResourceDataListResourceDataCollection get_ResourceData();

/** property */
public void set_ResourceData(ResourceDataListResourceDataCollection value);
JScript
public function get ResourceData() : ResourceDataListResourceDataCollection

public function set ResourceData(value : ResourceDataListResourceDataCollection);

See Also

ResourceDataList Class


XsdSchema Property

ResourceDataList.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

ResourceDataList Class


ResourceDataListResourceData Class

ResourceDataListResourceData Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceDataListResourceData
C#
public class ResourceDataListResourceData
C++
ref class ResourceDataListResourceData
J#
public class ResourceDataListResourceData
JScript
public class ResourceDataListResourceData

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceDataListResourceData

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceDataListResourceData Members


ResourceDataListResourceData Members

ResourceDataListResourceData Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceDataListResourceData.

Public Constructors

 | Name | Description
Public method | ResourceDataListResourceData | Initializes a new instance of the ResourceDataListResourceData class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceDataListResourceData Class


ResourceDataListResourceData Constructor

ResourceDataListResourceData Constructor
[image]

Initializes a new instance of the ResourceDataListResourceData class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceDataListResourceData()
C++
public:
ResourceDataListResourceData() sealed
J#
public ResourceDataListResourceData()
JScript
public function ResourceDataListResourceData()

See Also

ResourceDataListResourceData Class


Properties

ResourceDataListResourceData Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Type |
Top

See Also

ResourceDataListResourceData Class


Name Property

ResourceDataListResourceData.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ResourceDataListResourceData Class


Type Property

ResourceDataListResourceData.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As ResourceDataType
C#
public ResourceDataType Type { get; set; }
C++
public property ResourceDataType Type sealed {
ResourceDataType get();
void set(ResourceDataType value);
}
J#
/** property */
public ResourceDataType get_Type();

/** property */
public void set_Type(ResourceDataType value);
JScript
public function get Type() : ResourceDataType

public function set Type(value : ResourceDataType);

See Also

ResourceDataListResourceData Class


ResourceDataListResourceDataCollection Class

ResourceDataListResourceDataCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ResourceDataListResourceDataCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ResourceDataListResourceDataCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ResourceDataListResourceDataCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ResourceDataListResourceDataCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ResourceDataListResourceDataCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ResourceDataListResourceDataCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceDataListResourceDataCollection Members


ResourceDataListResourceDataCollection Members

ResourceDataListResourceDataCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceDataListResourceDataCollection.

Public Constructors

 | Name | Description
Public method | ResourceDataListResourceDataCollection | Initializes a new instance of the ResourceDataListResourceDataCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceDataListResourceDataCollection Class


ResourceDataListResourceDataCollection Constructor

ResourceDataListResourceDataCollection Constructor
[image]

Initializes a new instance of the ResourceDataListResourceDataCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceDataListResourceDataCollection()
C++
public:
ResourceDataListResourceDataCollection() sealed
J#
public ResourceDataListResourceDataCollection()
JScript
public function ResourceDataListResourceDataCollection()

See Also

ResourceDataListResourceDataCollection Class


Properties

ResourceDataListResourceDataCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ResourceDataListResourceDataCollection Class


Item Property

ResourceDataListResourceDataCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ResourceDataListResourceData
C#
public ResourceDataListResourceData this[
int idx
] { get; set; }
C++
public property ResourceDataListResourceData default[int idx] sealed {
ResourceDataListResourceData get(int idx);
void set(int idx, ResourceDataListResourceData value);
}
J#
/** property */
public ResourceDataListResourceData get_Item(int idx);

/** property */
public void set_Item(int idx, ResourceDataListResourceData value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ResourceDataListResourceDataCollection Class


Methods

ResourceDataListResourceDataCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceDataListResourceDataCollection Class


Add Method

ResourceDataListResourceDataCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ResourceDataListResourceData _
) As Integer
C#
public int Add(
ResourceDataListResourceData value
)
C++
public:
int Add(
ResourceDataListResourceData value
) sealed
J#
public int Add(
ResourceDataListResourceData value
)
JScript
public function Add(
value : ResourceDataListResourceData
) : int

See Also

ResourceDataListResourceDataCollection Class


ResourceDataType Enumeration

ResourceDataType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ResourceDataType
C#
public enum ResourceDataType
C++
public enum class ResourceDataType
J#
public enum ResourceDataType
JScript
public enum ResourceDataType

Members

Member Name | Description
File |
Stream |
String |

See Also


ResourceDocumentHeaderType Class

ResourceDocumentHeaderType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("ResourceDocumentHeader", Namespace := "", IsNullable := False)>
Public Class ResourceDocumentHeaderType
C#
[XmlRootAttribute("ResourceDocumentHeader", Namespace = "", IsNullable = False)]
public class ResourceDocumentHeaderType
C++
[XmlRootAttribute(L"ResourceDocumentHeader", Namespace = L"", IsNullable = False)]
ref class ResourceDocumentHeaderType
J#
/** @attribute XmlRootAttribute("ResourceDocumentHeader", Namespace = "", IsNullable = False) */
public class ResourceDocumentHeaderType
JScript
public
XmlRootAttribute("ResourceDocumentHeader", Namespace = "", IsNullable = False)
class ResourceDocumentHeaderType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceDocumentHeaderType Members


ResourceDocumentHeaderType Members

ResourceDocumentHeaderType Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by ResourceDocumentHeaderType.

Public Constructors

 | Name | Description
Public method | ResourceDocumentHeaderType | Initializes a new instance of the ResourceDocumentHeaderType class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | General |
Public property | Metadata |
Public property | Security |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceDocumentHeaderType Class


ResourceDocumentHeaderType Constructor

ResourceDocumentHeaderType Constructor
[image]

Initializes a new instance of the ResourceDocumentHeaderType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceDocumentHeaderType()
C++
public:
ResourceDocumentHeaderType() sealed
J#
public ResourceDocumentHeaderType()
JScript
public function ResourceDocumentHeaderType()

See Also

ResourceDocumentHeaderType Class


Fields

ResourceDocumentHeaderType Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

ResourceDocumentHeaderType Class


SchemaName Field

ResourceDocumentHeaderType.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

ResourceDocumentHeaderType Class


Properties

ResourceDocumentHeaderType Properties
[image]

Public Properties

 | Name | Description
Public property | General |
Public property | Metadata |
Public property | Security |
Public property | XsdSchema |
Top

See Also

ResourceDocumentHeaderType Class


General Property

ResourceDocumentHeaderType.General Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property General As ResourceDocumentHeaderTypeGeneral
C#
public ResourceDocumentHeaderTypeGeneral General { get; set; }
C++
public property ResourceDocumentHeaderTypeGeneral General sealed {
ResourceDocumentHeaderTypeGeneral get();
void set(ResourceDocumentHeaderTypeGeneral value);
}
J#
/** property */
public ResourceDocumentHeaderTypeGeneral get_General();

/** property */
public void set_General(ResourceDocumentHeaderTypeGeneral value);
JScript
public function get General() : ResourceDocumentHeaderTypeGeneral

public function set General(value : ResourceDocumentHeaderTypeGeneral);

See Also

ResourceDocumentHeaderType Class


Metadata Property

ResourceDocumentHeaderType.Metadata Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Metadata As ResourceDocumentHeaderTypeMetadata
C#
public ResourceDocumentHeaderTypeMetadata Metadata { get; set; }
C++
public property ResourceDocumentHeaderTypeMetadata Metadata sealed {
ResourceDocumentHeaderTypeMetadata get();
void set(ResourceDocumentHeaderTypeMetadata value);
}
J#
/** property */
public ResourceDocumentHeaderTypeMetadata get_Metadata();

/** property */
public void set_Metadata(ResourceDocumentHeaderTypeMetadata value);
JScript
public function get Metadata() : ResourceDocumentHeaderTypeMetadata

public function set Metadata(value : ResourceDocumentHeaderTypeMetadata);

See Also

ResourceDocumentHeaderType Class


Security Property

ResourceDocumentHeaderType.Security Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Security As ResourceSecurityType
C#
public ResourceSecurityType Security { get; set; }
C++
public property ResourceSecurityType Security sealed {
ResourceSecurityType get();
void set(ResourceSecurityType value);
}
J#
/** property */
public ResourceSecurityType get_Security();

/** property */
public void set_Security(ResourceSecurityType value);
JScript
public function get Security() : ResourceSecurityType

public function set Security(value : ResourceSecurityType);

See Also

ResourceDocumentHeaderType Class


XsdSchema Property

ResourceDocumentHeaderType.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

ResourceDocumentHeaderType Class


ResourceDocumentHeaderTypeGeneral Class

ResourceDocumentHeaderTypeGeneral Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceDocumentHeaderTypeGeneral
C#
public class ResourceDocumentHeaderTypeGeneral
C++
ref class ResourceDocumentHeaderTypeGeneral
J#
public class ResourceDocumentHeaderTypeGeneral
JScript
public class ResourceDocumentHeaderTypeGeneral

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderTypeGeneral

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceDocumentHeaderTypeGeneral Members


ResourceDocumentHeaderTypeGeneral Members

ResourceDocumentHeaderTypeGeneral Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceDocumentHeaderTypeGeneral.

Public Constructors

 | Name | Description
Public method | ResourceDocumentHeaderTypeGeneral | Initializes a new instance of the ResourceDocumentHeaderTypeGeneral class.
Top

Public Properties

 | Name | Description
Public property | IconName |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceDocumentHeaderTypeGeneral Class


ResourceDocumentHeaderTypeGeneral Constructor

ResourceDocumentHeaderTypeGeneral Constructor
[image]

Initializes a new instance of the ResourceDocumentHeaderTypeGeneral class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceDocumentHeaderTypeGeneral()
C++
public:
ResourceDocumentHeaderTypeGeneral() sealed
J#
public ResourceDocumentHeaderTypeGeneral()
JScript
public function ResourceDocumentHeaderTypeGeneral()

See Also

ResourceDocumentHeaderTypeGeneral Class


Properties

ResourceDocumentHeaderTypeGeneral Properties
[image]

Public Properties

 | Name | Description
Public property | IconName |
Top

See Also

ResourceDocumentHeaderTypeGeneral Class


IconName Property

ResourceDocumentHeaderTypeGeneral.IconName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property IconName As String
C#
public string IconName { get; set; }
C++
public property string IconName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_IconName();

/** property */
public void set_IconName(string value);
JScript
public function get IconName() : String

public function set IconName(value : String);

See Also

ResourceDocumentHeaderTypeGeneral Class


ResourceDocumentHeaderTypeMetadata Class

ResourceDocumentHeaderTypeMetadata Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceDocumentHeaderTypeMetadata
C#
public class ResourceDocumentHeaderTypeMetadata
C++
ref class ResourceDocumentHeaderTypeMetadata
J#
public class ResourceDocumentHeaderTypeMetadata
JScript
public class ResourceDocumentHeaderTypeMetadata

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderTypeMetadata

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceDocumentHeaderTypeMetadata Members


ResourceDocumentHeaderTypeMetadata Members

ResourceDocumentHeaderTypeMetadata Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceDocumentHeaderTypeMetadata.

Public Constructors

 | Name | Description
Public method | ResourceDocumentHeaderTypeMetadata | Initializes a new instance of the ResourceDocumentHeaderTypeMetadata class.
Top

Public Properties

 | Name | Description
Public property | Simple |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceDocumentHeaderTypeMetadata Class


ResourceDocumentHeaderTypeMetadata Constructor

ResourceDocumentHeaderTypeMetadata Constructor
[image]

Initializes a new instance of the ResourceDocumentHeaderTypeMetadata class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceDocumentHeaderTypeMetadata()
C++
public:
ResourceDocumentHeaderTypeMetadata() sealed
J#
public ResourceDocumentHeaderTypeMetadata()
JScript
public function ResourceDocumentHeaderTypeMetadata()

See Also

ResourceDocumentHeaderTypeMetadata Class


Properties

ResourceDocumentHeaderTypeMetadata Properties
[image]

Public Properties

 | Name | Description
Public property | Simple |
Top

See Also

ResourceDocumentHeaderTypeMetadata Class


Simple Property

ResourceDocumentHeaderTypeMetadata.Simple Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Simple As ResourceDocumentHeaderTypeMetadataSimple
C#
public ResourceDocumentHeaderTypeMetadataSimple Simple { get; set; }
C++
public property ResourceDocumentHeaderTypeMetadataSimple Simple sealed {
ResourceDocumentHeaderTypeMetadataSimple get();
void set(ResourceDocumentHeaderTypeMetadataSimple value);
}
J#
/** property */
public ResourceDocumentHeaderTypeMetadataSimple get_Simple();

/** property */
public void set_Simple(ResourceDocumentHeaderTypeMetadataSimple value);
JScript
public function get Simple() : ResourceDocumentHeaderTypeMetadataSimple

public function set Simple(value : ResourceDocumentHeaderTypeMetadataSimple);

See Also

ResourceDocumentHeaderTypeMetadata Class


ResourceDocumentHeaderTypeMetadataSimple Class

ResourceDocumentHeaderTypeMetadataSimple Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceDocumentHeaderTypeMetadataSimple
C#
public class ResourceDocumentHeaderTypeMetadataSimple
C++
ref class ResourceDocumentHeaderTypeMetadataSimple
J#
public class ResourceDocumentHeaderTypeMetadataSimple
JScript
public class ResourceDocumentHeaderTypeMetadataSimple

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderTypeMetadataSimple

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceDocumentHeaderTypeMetadataSimple Members


ResourceDocumentHeaderTypeMetadataSimple Members

ResourceDocumentHeaderTypeMetadataSimple Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceDocumentHeaderTypeMetadataSimple.

Public Constructors

 | Name | Description
Public method | ResourceDocumentHeaderTypeMetadataSimple | Initializes a new instance of the ResourceDocumentHeaderTypeMetadataSimple class.
Top

Public Properties

 | Name | Description
Public property | Property |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceDocumentHeaderTypeMetadataSimple Class


ResourceDocumentHeaderTypeMetadataSimple Constructor

ResourceDocumentHeaderTypeMetadataSimple Constructor
[image]

Initializes a new instance of the ResourceDocumentHeaderTypeMetadataSimple class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceDocumentHeaderTypeMetadataSimple()
C++
public:
ResourceDocumentHeaderTypeMetadataSimple() sealed
J#
public ResourceDocumentHeaderTypeMetadataSimple()
JScript
public function ResourceDocumentHeaderTypeMetadataSimple()

See Also

ResourceDocumentHeaderTypeMetadataSimple Class


Properties

ResourceDocumentHeaderTypeMetadataSimple Properties
[image]

Public Properties

 | Name | Description
Public property | Property |
Top

See Also

ResourceDocumentHeaderTypeMetadataSimple Class


Property Property

ResourceDocumentHeaderTypeMetadataSimple.Property Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Property")>
Public Property Property As ResourceDocumentHeaderTypeMetadataSimplePropertyCollection
C#
[XmlElementAttribute("Property")]
public ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Property { get; set; }
C++
[XmlElementAttribute(L"Property")]
public property ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Property sealed {
ResourceDocumentHeaderTypeMetadataSimplePropertyCollection get();
void set(ResourceDocumentHeaderTypeMetadataSimplePropertyCollection value);
}
J#
/** @attribute XmlElementAttribute("Property") */
/** property */
public ResourceDocumentHeaderTypeMetadataSimplePropertyCollection get_Property();

/** property */
public void set_Property(ResourceDocumentHeaderTypeMetadataSimplePropertyCollection value);
JScript
public function get Property() : ResourceDocumentHeaderTypeMetadataSimplePropertyCollection

public function set Property(value : ResourceDocumentHeaderTypeMetadataSimplePropertyCollection);

See Also

ResourceDocumentHeaderTypeMetadataSimple Class


ResourceDocumentHeaderTypeMetadataSimpleProperty Class

ResourceDocumentHeaderTypeMetadataSimpleProperty Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceDocumentHeaderTypeMetadataSimpleProperty
C#
public class ResourceDocumentHeaderTypeMetadataSimpleProperty
C++
ref class ResourceDocumentHeaderTypeMetadataSimpleProperty
J#
public class ResourceDocumentHeaderTypeMetadataSimpleProperty
JScript
public class ResourceDocumentHeaderTypeMetadataSimpleProperty

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderTypeMetadataSimpleProperty

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceDocumentHeaderTypeMetadataSimpleProperty Members


ResourceDocumentHeaderTypeMetadataSimpleProperty Members

ResourceDocumentHeaderTypeMetadataSimpleProperty Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceDocumentHeaderTypeMetadataSimpleProperty.

Public Constructors

 | Name | Description
Public method | ResourceDocumentHeaderTypeMetadataSimpleProperty | Initializes a new instance of the ResourceDocumentHeaderTypeMetadataSimpleProperty class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Value |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceDocumentHeaderTypeMetadataSimpleProperty Class


ResourceDocumentHeaderTypeMetadataSimpleProperty Constructor

ResourceDocumentHeaderTypeMetadataSimpleProperty Constructor
[image]

Initializes a new instance of the ResourceDocumentHeaderTypeMetadataSimpleProperty class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceDocumentHeaderTypeMetadataSimpleProperty()
C++
public:
ResourceDocumentHeaderTypeMetadataSimpleProperty() sealed
J#
public ResourceDocumentHeaderTypeMetadataSimpleProperty()
JScript
public function ResourceDocumentHeaderTypeMetadataSimpleProperty()

See Also

ResourceDocumentHeaderTypeMetadataSimpleProperty Class


Properties

ResourceDocumentHeaderTypeMetadataSimpleProperty Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Value |
Top

See Also

ResourceDocumentHeaderTypeMetadataSimpleProperty Class


Name Property

ResourceDocumentHeaderTypeMetadataSimpleProperty.Name Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ResourceDocumentHeaderTypeMetadataSimpleProperty Class


Value Property

ResourceDocumentHeaderTypeMetadataSimpleProperty.Value Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
C++
public property string Value sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

ResourceDocumentHeaderTypeMetadataSimpleProperty Class


ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Class

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ResourceDocumentHeaderTypeMetadataSimplePropertyCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ResourceDocumentHeaderTypeMetadataSimplePropertyCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ResourceDocumentHeaderTypeMetadataSimplePropertyCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ResourceDocumentHeaderTypeMetadataSimplePropertyCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ResourceDocumentHeaderTypeMetadataSimplePropertyCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderTypeMetadataSimplePropertyCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Members


ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Members

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceDocumentHeaderTypeMetadataSimplePropertyCollection.

Public Constructors

 | Name | Description
Public method | ResourceDocumentHeaderTypeMetadataSimplePropertyCollection | Initializes a new instance of the ResourceDocumentHeaderTypeMetadataSimplePropertyCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Find |
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Class


ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Constructor

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Constructor
See Also Example
[image]

Initializes a new instance of the ResourceDocumentHeaderTypeMetadataSimplePropertyCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceDocumentHeaderTypeMetadataSimplePropertyCollection()
C++
public:
ResourceDocumentHeaderTypeMetadataSimplePropertyCollection() sealed
J#
public ResourceDocumentHeaderTypeMetadataSimplePropertyCollection()
JScript
public function ResourceDocumentHeaderTypeMetadataSimplePropertyCollection()

See Also

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Class


Properties

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Overloaded.
Top

See Also

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Class


Item Property

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection.Item Property
See Also Example

Overload List

 | Name | Description
Public property | Item (Int32) |
Public property | Item (String) |

See Also

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Class


Item Property (Int32)

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection.Item Property (Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ResourceDocumentHeaderTypeMetadataSimpleProperty
C#
public ResourceDocumentHeaderTypeMetadataSimpleProperty this[
int idx
] { get; set; }
C++
public property ResourceDocumentHeaderTypeMetadataSimpleProperty default[int idx] sealed {
ResourceDocumentHeaderTypeMetadataSimpleProperty get(int idx);
void set(int idx, ResourceDocumentHeaderTypeMetadataSimpleProperty value);
}
J#
/** property */
public ResourceDocumentHeaderTypeMetadataSimpleProperty get_Item(int idx);

/** property */
public void set_Item(int idx, ResourceDocumentHeaderTypeMetadataSimpleProperty value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Class
OSGeo.MapGuide.MaestroAPI Namespace
ResourceDocumentHeaderTypeMetadataSimplePropertyCollection.Item Overload List


Item Property (String)

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection.Item Property (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As String _
) As String
C#
public string this[
string idx
] { get; set; }
C++
public property string default[String idx] sealed {
String get(String idx);
void set(String idx, String value);
}
J#
/** property */
public string get_Item(string idx);

/** property */
public void set_Item(string idx, string value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Class
OSGeo.MapGuide.MaestroAPI Namespace
ResourceDocumentHeaderTypeMetadataSimplePropertyCollection.Item Overload List


Methods

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Find |
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Class


Add Method

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection.Add Method
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ResourceDocumentHeaderTypeMetadataSimpleProperty _
) As Integer
C#
public int Add(
ResourceDocumentHeaderTypeMetadataSimpleProperty value
)
C++
public:
int Add(
ResourceDocumentHeaderTypeMetadataSimpleProperty value
) sealed
J#
public int Add(
ResourceDocumentHeaderTypeMetadataSimpleProperty value
)
JScript
public function Add(
value : ResourceDocumentHeaderTypeMetadataSimpleProperty
) : int

See Also

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Class


Find Method

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection.Find Method
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Find( _
ByVal x As String _
) As Integer
C#
public int Find(
string x
)
C++
public:
int Find(
String x
) sealed
J#
public int Find(
string x
)
JScript
public function Find(
x : String
) : int

See Also

ResourceDocumentHeaderTypeMetadataSimplePropertyCollection Class


ResourceFolderHeaderType Class

ResourceFolderHeaderType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("ResourceFolderHeader", Namespace := "", IsNullable := False)>
Public Class ResourceFolderHeaderType
C#
[XmlRootAttribute("ResourceFolderHeader", Namespace = "", IsNullable = False)]
public class ResourceFolderHeaderType
C++
[XmlRootAttribute(L"ResourceFolderHeader", Namespace = L"", IsNullable = False)]
ref class ResourceFolderHeaderType
J#
/** @attribute XmlRootAttribute("ResourceFolderHeader", Namespace = "", IsNullable = False) */
public class ResourceFolderHeaderType
JScript
public
XmlRootAttribute("ResourceFolderHeader", Namespace = "", IsNullable = False)
class ResourceFolderHeaderType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceFolderHeaderType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceFolderHeaderType Members


ResourceFolderHeaderType Members

ResourceFolderHeaderType Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by ResourceFolderHeaderType.

Public Constructors

 | Name | Description
Public method | ResourceFolderHeaderType | Initializes a new instance of the ResourceFolderHeaderType class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Security |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceFolderHeaderType Class


ResourceFolderHeaderType Constructor

ResourceFolderHeaderType Constructor
[image]

Initializes a new instance of the ResourceFolderHeaderType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceFolderHeaderType()
C++
public:
ResourceFolderHeaderType() sealed
J#
public ResourceFolderHeaderType()
JScript
public function ResourceFolderHeaderType()

See Also

ResourceFolderHeaderType Class


Fields

ResourceFolderHeaderType Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

ResourceFolderHeaderType Class


SchemaName Field

ResourceFolderHeaderType.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

ResourceFolderHeaderType Class


Properties

ResourceFolderHeaderType Properties
[image]

Public Properties

 | Name | Description
Public property | Security |
Public property | XsdSchema |
Top

See Also

ResourceFolderHeaderType Class


Security Property

ResourceFolderHeaderType.Security Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Security As ResourceSecurityType
C#
public ResourceSecurityType Security { get; set; }
C++
public property ResourceSecurityType Security sealed {
ResourceSecurityType get();
void set(ResourceSecurityType value);
}
J#
/** property */
public ResourceSecurityType get_Security();

/** property */
public void set_Security(ResourceSecurityType value);
JScript
public function get Security() : ResourceSecurityType

public function set Security(value : ResourceSecurityType);

See Also

ResourceFolderHeaderType Class


XsdSchema Property

ResourceFolderHeaderType.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

ResourceFolderHeaderType Class


ResourceIdentifier Class

ResourceIdentifier Class
See Also Example Members
[image]

This class contains all the required code for maintaining resource identifiers. It has implicit conversions to and from a string, which makes it much easier to use. It has both static methods that operate on strings, as well as a class that can be manipulated.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceIdentifier
C#
public class ResourceIdentifier
C++
ref class ResourceIdentifier
J#
public class ResourceIdentifier
JScript
public class ResourceIdentifier

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceIdentifier

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceIdentifier Members


ResourceIdentifier Members

ResourceIdentifier Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

This class contains all the required code for maintaining resource identifiers. It has implicit conversions to and from a string, which makes it much easier to use. It has both static methods that operate on strings, as well as a class that can be manipulated.

The following tables list the members exposed by ResourceIdentifier.

Public Constructors

Name | Description
ResourceIdentifier | Overloaded.
Top

Public Properties

 | Name | Description
Public property | Extension | Gets or sets the extension of the resourceId
Public property | Fullname | Gets or sets the name and extension of the resource
Public property | Fullpath | Gets the full path of the resource, that is the path without repository information
Public property | IsEmpty | Gets a value indicating if the resource is blank
Public property | IsFolder | Gets a value indicating if the resource identifier points to a folder
Public property | IsInLibrary | Gets a value indicating if the resource is in the library repository
Public property | IsInSessionRepository | Gets a value indicating if the resource is in the session repository
Public property | IsValid | Gets a value indicating if the resource identifier is valid
Public property | Length | Gets the length of the resource identifier as a string
Public property | Name | Gets or sets the name of the resource
Public property | Path | Gets the path of the resource, that is the path without repository information and no extension
Public property | ResourceId | Gets or sets the full resource identifier
Top

Public Methods

 | Name | Description
 | ConvertToLibrary | Converts a resource id to be placed in the library
Public method | ConvertToLibrary | Converts this instance to be in the library repository
 | ConvertToSession | Converts a resource id to be placed in the library
Public method | ConvertToSession | Converts this instance to be in the session repository
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | GetExtension | Returns the extension of a resource identifier
 | GetFullname | Gets the name and extension of the identifier
 | GetFullpath | Returns the full path of the resource, that is the resourceId without the repository information
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
 | GetName | Gets the name of a resource, given its identifier
 | GetPath | Returns the path of the resource, that is the resourceId without the repository information and extension
 | GetRepository | Gets the repository part of a resource identifier, eg.: "Library://" or "Session:xxxx//"
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | IsFolderResource | Returns a value indicating if the resource points to a folder
 | Normalize | Normalizes a identifier, that is prepends a slash if it is a folder resource
Public method | Normalize | Normalizes the identifier, that is prepends a slash if the identifier points to a folder
 | op_Implicit | Overloaded. Helper operator that makes using the resource identifiers easier
 | SetExtension | Changes the extension of the given resource
 | SetName | Sets the name of the resource, with or without the extension
 | SetPath | Sets the path of the identifier, with or without the extension
Public method | ToString | Overridden. Returns the full resource id as a string
 | Validate | Overloaded. Determines if a resource identifier is valid
Top

Explicit Interface Implementations

Name | Description
ResourceIdentifier | Overloaded.
Top

See Also

ResourceIdentifier Class


ResourceIdentifier Constructor

ResourceIdentifier Constructor

Overload List

 | Name | Description
Public method | ResourceIdentifier (ResourceIdentifier) | Constructs a new ResourceIdentifier, based on an existing one.
Public method | ResourceIdentifier (String) | Constructs a new ResourceIdentifier with the given full path
Public method | ResourceIdentifier (String, ResourceTypes) | Constructs a new library based resource identifier
Public method | ResourceIdentifier (String, ResourceTypes, String) | Constructs a new session based resource identifier

See Also

ResourceIdentifier Class


ResourceIdentifier Constructor (ResourceIdentifier)

ResourceIdentifier Constructor (ResourceIdentifier)
See Also Example
[image]

Constructs a new ResourceIdentifier, based on an existing one.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal id As ResourceIdentifier _
)
C#
public ResourceIdentifier(
ResourceIdentifier id
)
C++
public:
ResourceIdentifier(
ResourceIdentifier id
) sealed
J#
public ResourceIdentifier(
ResourceIdentifier id
)
JScript
public function ResourceIdentifier(
id : ResourceIdentifier
)

Parameters

id
The resource identifier to copy

See Also

ResourceIdentifier Class
ResourceIdentifier Constructor Overload List


ResourceIdentifier Constructor (String)

ResourceIdentifier Constructor (String)
See Also Example
[image]

Constructs a new ResourceIdentifier with the given full path

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal resourceId As String _
)
C#
public ResourceIdentifier(
string resourceId
)
C++
public:
ResourceIdentifier(
String resourceId
) sealed
J#
public ResourceIdentifier(
string resourceId
)
JScript
public function ResourceIdentifier(
resourceId : String
)

Parameters

resourceId
The path of the resource to refence

See Also

ResourceIdentifier Class
ResourceIdentifier Constructor Overload List


ResourceIdentifier Constructor (String, ResourceTypes)

ResourceIdentifier Constructor (String, ResourceTypes)
See Also Example
[image]

Constructs a new library based resource identifier

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal type As ResourceTypes _
)
C#
public ResourceIdentifier(
string name,
ResourceTypes type
)
C++
public:
ResourceIdentifier(
String name,
ResourceTypes type
) sealed
J#
public ResourceIdentifier(
string name,
ResourceTypes type
)
JScript
public function ResourceIdentifier(
name : String,
type : ResourceTypes
)

Parameters

name
The name of the resource, may include path information with the \"/\" character
type
The type of resource the identifier names

See Also

ResourceIdentifier Class
ResourceIdentifier Constructor Overload List


ResourceIdentifier Constructor (String, ResourceTypes, String)

ResourceIdentifier Constructor (String, ResourceTypes, String)
See Also Example
[image]

Constructs a new session based resource identifier

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal name As String, _
ByVal type As ResourceTypes, _
ByVal sessionId As String _
)
C#
public ResourceIdentifier(
string name,
ResourceTypes type,
string sessionId
)
C++
public:
ResourceIdentifier(
String name,
ResourceTypes type,
String sessionId
) sealed
J#
public ResourceIdentifier(
string name,
ResourceTypes type,
string sessionId
)
JScript
public function ResourceIdentifier(
name : String,
type : ResourceTypes,
sessionId : String
)

Parameters

name
The name of the resource, may include path information with the \"/\" character
type
The type of resource the identifier names
sessionId
The session id to use

See Also

ResourceIdentifier Class
ResourceIdentifier Constructor Overload List


Properties

ResourceIdentifier Properties
[image]

Public Properties

 | Name | Description
Public property | Extension | Gets or sets the extension of the resourceId
Public property | Fullname | Gets or sets the name and extension of the resource
Public property | Fullpath | Gets the full path of the resource, that is the path without repository information
Public property | IsEmpty | Gets a value indicating if the resource is blank
Public property | IsFolder | Gets a value indicating if the resource identifier points to a folder
Public property | IsInLibrary | Gets a value indicating if the resource is in the library repository
Public property | IsInSessionRepository | Gets a value indicating if the resource is in the session repository
Public property | IsValid | Gets a value indicating if the resource identifier is valid
Public property | Length | Gets the length of the resource identifier as a string
Public property | Name | Gets or sets the name of the resource
Public property | Path | Gets the path of the resource, that is the path without repository information and no extension
Public property | ResourceId | Gets or sets the full resource identifier
Top

See Also

ResourceIdentifier Class


Extension Property

ResourceIdentifier.Extension Property
[image]

Gets or sets the extension of the resourceId

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Extension As String
C#
public string Extension { get; set; }
C++
public property string Extension sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Extension();

/** property */
public void set_Extension(string value);
JScript
public function get Extension() : String

public function set Extension(value : String);

See Also

ResourceIdentifier Class


Fullname Property

ResourceIdentifier.Fullname Property
[image]

Gets or sets the name and extension of the resource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Fullname As String
C#
public string Fullname { get; set; }
C++
public property string Fullname sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Fullname();

/** property */
public void set_Fullname(string value);
JScript
public function get Fullname() : String

public function set Fullname(value : String);

See Also

ResourceIdentifier Class


Fullpath Property

ResourceIdentifier.Fullpath Property
[image]

Gets the full path of the resource, that is the path without repository information

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Fullpath As String
C#
public string Fullpath { get; set; }
C++
public property string Fullpath sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Fullpath();

/** property */
public void set_Fullpath(string value);
JScript
public function get Fullpath() : String

public function set Fullpath(value : String);

See Also

ResourceIdentifier Class


IsEmpty Property

ResourceIdentifier.IsEmpty Property
[image]

Gets a value indicating if the resource is blank

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
C#
public bool IsEmpty { get; }
C++
public property bool IsEmpty sealed {
bool get();
}
J#
/** property */
public bool get_IsEmpty();
JScript
public function get IsEmpty() : bool

See Also

ResourceIdentifier Class


IsFolder Property

ResourceIdentifier.IsFolder Property
[image]

Gets a value indicating if the resource identifier points to a folder

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFolder As Boolean
C#
public bool IsFolder { get; }
C++
public property bool IsFolder sealed {
bool get();
}
J#
/** property */
public bool get_IsFolder();
JScript
public function get IsFolder() : bool

See Also

ResourceIdentifier Class


IsInLibrary Property

ResourceIdentifier.IsInLibrary Property
[image]

Gets a value indicating if the resource is in the library repository

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsInLibrary As Boolean
C#
public bool IsInLibrary { get; }
C++
public property bool IsInLibrary sealed {
bool get();
}
J#
/** property */
public bool get_IsInLibrary();
JScript
public function get IsInLibrary() : bool

See Also

ResourceIdentifier Class


IsInSessionRepository Property

ResourceIdentifier.IsInSessionRepository Property
[image]

Gets a value indicating if the resource is in the session repository

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsInSessionRepository As Boolean
C#
public bool IsInSessionRepository { get; }
C++
public property bool IsInSessionRepository sealed {
bool get();
}
J#
/** property */
public bool get_IsInSessionRepository();
JScript
public function get IsInSessionRepository() : bool

See Also

ResourceIdentifier Class


IsValid Property

ResourceIdentifier.IsValid Property
[image]

Gets a value indicating if the resource identifier is valid

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
C#
public bool IsValid { get; }
C++
public property bool IsValid sealed {
bool get();
}
J#
/** property */
public bool get_IsValid();
JScript
public function get IsValid() : bool

See Also

ResourceIdentifier Class


Length Property

ResourceIdentifier.Length Property
[image]

Gets the length of the resource identifier as a string

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
C#
public int Length { get; }
C++
public property int Length sealed {
int get();
}
J#
/** property */
public int get_Length();
JScript
public function get Length() : int

See Also

ResourceIdentifier Class


Name Property

ResourceIdentifier.Name Property
[image]

Gets or sets the name of the resource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ResourceIdentifier Class


Path Property

ResourceIdentifier.Path Property
[image]

Gets the path of the resource, that is the path without repository information and no extension

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Path As String
C#
public string Path { get; set; }
C++
public property string Path sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Path();

/** property */
public void set_Path(string value);
JScript
public function get Path() : String

public function set Path(value : String);

See Also

ResourceIdentifier Class


ResourceId Property

ResourceIdentifier.ResourceId Property
[image]

Gets or sets the full resource identifier

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceId As String
C#
public string ResourceId { get; set; }
C++
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

ResourceIdentifier Class


Methods

ResourceIdentifier Methods
[image]

Public Methods

 | Name | Description
 | ConvertToLibrary | Converts a resource id to be placed in the library
Public method | ConvertToLibrary | Converts this instance to be in the library repository
 | ConvertToSession | Converts a resource id to be placed in the library
Public method | ConvertToSession | Converts this instance to be in the session repository
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | GetExtension | Returns the extension of a resource identifier
 | GetFullname | Gets the name and extension of the identifier
 | GetFullpath | Returns the full path of the resource, that is the resourceId without the repository information
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
 | GetName | Gets the name of a resource, given its identifier
 | GetPath | Returns the path of the resource, that is the resourceId without the repository information and extension
 | GetRepository | Gets the repository part of a resource identifier, eg.: "Library://" or "Session:xxxx//"
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | IsFolderResource | Returns a value indicating if the resource points to a folder
 | Normalize | Normalizes a identifier, that is prepends a slash if it is a folder resource
Public method | Normalize | Normalizes the identifier, that is prepends a slash if the identifier points to a folder
 | op_Implicit | Overloaded. Helper operator that makes using the resource identifiers easier
 | SetExtension | Changes the extension of the given resource
 | SetName | Sets the name of the resource, with or without the extension
 | SetPath | Sets the path of the identifier, with or without the extension
Public method | ToString | Overridden. Returns the full resource id as a string
 | Validate | Overloaded. Determines if a resource identifier is valid
Top

See Also

ResourceIdentifier Class


ConvertToLibrary Method

ResourceIdentifier.ConvertToLibrary Method
[image]

Converts a resource id to be placed in the library

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertToLibrary( _
ByVal identifier As String _
) As String
C#
public static string ConvertToLibrary(
string identifier
)
C++
public:
static String ConvertToLibrary(
String identifier
)
J#
public static string ConvertToLibrary(
string identifier
)
JScript
public static function ConvertToLibrary(
identifier : String
) : String

Parameters

identifier
The identifier to convert

Return Value

The converted identifier

See Also

ResourceIdentifier Class


ConvertToLibrary Method

ResourceIdentifier.ConvertToLibrary Method
[image]

Converts this instance to be in the library repository

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub ConvertToLibrary()
C#
public void ConvertToLibrary()
C++
public:
void ConvertToLibrary() sealed
J#
public void ConvertToLibrary()
JScript
public function ConvertToLibrary()

See Also

ResourceIdentifier Class


ConvertToSession Method

ResourceIdentifier.ConvertToSession Method
[image]

Converts a resource id to be placed in the library

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertToSession( _
ByVal identifier As String, _
ByVal sessionId As String _
) As String
C#
public static string ConvertToSession(
string identifier,
string sessionId
)
C++
public:
static String ConvertToSession(
String identifier,
String sessionId
)
J#
public static string ConvertToSession(
string identifier,
string sessionId
)
JScript
public static function ConvertToSession(
identifier : String,
sessionId : String
) : String

Parameters

identifier
The identifier to convert
sessionId
The session id of the repository it should be placed in

Return Value

The converted identifier

See Also

ResourceIdentifier Class


ConvertToSession Method

ResourceIdentifier.ConvertToSession Method
[image]

Converts this instance to be in the session repository

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub ConvertToSession( _
ByVal sessionId As String _
)
C#
public void ConvertToSession(
string sessionId
)
C++
public:
void ConvertToSession(
String sessionId
) sealed
J#
public void ConvertToSession(
string sessionId
)
JScript
public function ConvertToSession(
sessionId : String
)

Parameters

sessionId
The sessionid

See Also

ResourceIdentifier Class


GetExtension Method

ResourceIdentifier.GetExtension Method
[image]

Returns the extension of a resource identifier

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetExtension( _
ByVal identifier As String _
) As String
C#
public static string GetExtension(
string identifier
)
C++
public:
static String GetExtension(
String identifier
)
J#
public static string GetExtension(
string identifier
)
JScript
public static function GetExtension(
identifier : String
) : String

Parameters

identifier
The identifier to get the extension from

Return Value

The extension of the identifier

See Also

ResourceIdentifier Class


GetFullname Method

ResourceIdentifier.GetFullname Method
[image]

Gets the name and extension of the identifier

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFullname( _
ByVal identifier As String _
) As String
C#
public static string GetFullname(
string identifier
)
C++
public:
static String GetFullname(
String identifier
)
J#
public static string GetFullname(
string identifier
)
JScript
public static function GetFullname(
identifier : String
) : String

Parameters

identifier
The identifier to extract the information from

Return Value

The full name of the identifier

See Also

ResourceIdentifier Class


GetFullpath Method

ResourceIdentifier.GetFullpath Method
[image]

Returns the full path of the resource, that is the resourceId without the repository information

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFullpath( _
ByVal identifier As String _
) As String
C#
public static string GetFullpath(
string identifier
)
C++
public:
static String GetFullpath(
String identifier
)
J#
public static string GetFullpath(
string identifier
)
JScript
public static function GetFullpath(
identifier : String
) : String

Parameters

identifier
The identifier to get the path from

Return Value

The path of the identifier

See Also

ResourceIdentifier Class


GetName Method

ResourceIdentifier.GetName Method
[image]

Gets the name of a resource, given its identifier

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetName( _
ByVal identifier As String _
) As String
C#
public static string GetName(
string identifier
)
C++
public:
static String GetName(
String identifier
)
J#
public static string GetName(
string identifier
)
JScript
public static function GetName(
identifier : String
) : String

Parameters

identifier
The identifier to look for

Return Value

The name of the resource

See Also

ResourceIdentifier Class


GetPath Method

ResourceIdentifier.GetPath Method
[image]

Returns the path of the resource, that is the resourceId without the repository information and extension

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetPath( _
ByVal identifier As String _
) As String
C#
public static string GetPath(
string identifier
)
C++
public:
static String GetPath(
String identifier
)
J#
public static string GetPath(
string identifier
)
JScript
public static function GetPath(
identifier : String
) : String

Parameters

identifier
The identifier to get the path from

Return Value

The path of the identifier

See Also

ResourceIdentifier Class


GetRepository Method

ResourceIdentifier.GetRepository Method
[image]

Gets the repository part of a resource identifier, eg.: "Library://" or "Session:xxxx//"

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRepository( _
ByVal identifier As String _
) As String
C#
public static string GetRepository(
string identifier
)
C++
public:
static String GetRepository(
String identifier
)
J#
public static string GetRepository(
string identifier
)
JScript
public static function GetRepository(
identifier : String
) : String

Parameters

identifier

See Also

ResourceIdentifier Class


IsFolderResource Method

ResourceIdentifier.IsFolderResource Method
[image]

Returns a value indicating if the resource points to a folder

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsFolderResource( _
ByVal identifier As String _
) As Boolean
C#
public static bool IsFolderResource(
string identifier
)
C++
public:
static bool IsFolderResource(
String identifier
)
J#
public static bool IsFolderResource(
string identifier
)
JScript
public static function IsFolderResource(
identifier : String
) : bool

Parameters

identifier
The identifier to evaluate

Return Value

A value indicating if the resource points to a folder

See Also

ResourceIdentifier Class


Normalize Method

ResourceIdentifier.Normalize Method
[image]

Normalizes a identifier, that is prepends a slash if it is a folder resource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Normalize( _
ByVal identifier As String _
) As String
C#
public static string Normalize(
string identifier
)
C++
public:
static String Normalize(
String identifier
)
J#
public static string Normalize(
string identifier
)
JScript
public static function Normalize(
identifier : String
) : String

Parameters

identifier
The identifier to normalize

Return Value

The normalized identifier

See Also

ResourceIdentifier Class


Normalize Method

ResourceIdentifier.Normalize Method
[image]

Normalizes the identifier, that is prepends a slash if the identifier points to a folder

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Normalize()
C#
public void Normalize()
C++
public:
void Normalize() sealed
J#
public void Normalize()
JScript
public function Normalize()

See Also

ResourceIdentifier Class


op_Implicit Operator

ResourceIdentifier.op_Implicit Operator

Helper operator that makes using the resource identifiers easier

Overload List

Name | Description
String op_Implicit (ResourceIdentifier) | Helper operator that makes using the resource identifiers easier
ResourceIdentifier op_Implicit (String) | Helper operator that makes using the resource identifiers easier

See Also

ResourceIdentifier Class


op_Implicit Operator (ResourceIdentifier)

ResourceIdentifier.op_Implicit Operator (ResourceIdentifier)
See Also Example
[image]

Helper operator that makes using the resource identifiers easier

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Widening Operator CType( _
ByVal id As ResourceIdentifier _
) As String
C#
public static string op_Implicit(
ResourceIdentifier id
)
C++
public:
static String op_Implicit(
ResourceIdentifier id
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Parameters

id
The id to convert to a string

Return Value

The converted string

See Also

ResourceIdentifier Class
ResourceIdentifier to Conversion Overload List


op_Implicit Operator (String)

ResourceIdentifier.op_Implicit Operator (String)
See Also Example
[image]

Helper operator that makes using the resource identifiers easier

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Widening Operator CType( _
ByVal id As String _
) As ResourceIdentifier
C#
public static ResourceIdentifier op_Implicit(
string id
)
C++
public:
static ResourceIdentifier op_Implicit(
String id
)
J#
JSharp does not support overloaded operators.
JScript
JScript supports the use of overloaded operators, but not the declaration of new ones.

Parameters

id
The id to convert into a resource indetifier class

Return Value

The resource identifier

See Also

ResourceIdentifier Class
ResourceIdentifier to Conversion Overload List


SetExtension Method

ResourceIdentifier.SetExtension Method
[image]

Changes the extension of the given resource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SetExtension( _
ByVal identifier As String, _
ByVal newextension As String _
) As String
C#
public static string SetExtension(
string identifier,
string newextension
)
C++
public:
static String SetExtension(
String identifier,
String newextension
)
J#
public static string SetExtension(
string identifier,
string newextension
)
JScript
public static function SetExtension(
identifier : String,
newextension : String
) : String

Parameters

identifier
The identifier to change the extension for
newextension
The new extension to use

Return Value

The renmaed identifier

See Also

ResourceIdentifier Class


SetName Method

ResourceIdentifier.SetName Method
[image]

Sets the name of the resource, with or without the extension

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SetName( _
ByVal identifier As String, _
ByVal newname As String _
) As String
C#
public static string SetName(
string identifier,
string newname
)
C++
public:
static String SetName(
String identifier,
String newname
)
J#
public static string SetName(
string identifier,
string newname
)
JScript
public static function SetName(
identifier : String,
newname : String
) : String

Parameters

identifier
The identifier to give a new name
newname
The new name to assign

Return Value

The renamed identifier

See Also

ResourceIdentifier Class


SetPath Method

ResourceIdentifier.SetPath Method
[image]

Sets the path of the identifier, with or without the extension

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SetPath( _
ByVal identifier As String, _
ByVal newpath As String _
) As String
C#
public static string SetPath(
string identifier,
string newpath
)
C++
public:
static String SetPath(
String identifier,
String newpath
)
J#
public static string SetPath(
string identifier,
string newpath
)
JScript
public static function SetPath(
identifier : String,
newpath : String
) : String

Parameters

identifier
The identifier to update
newpath
The new path to user, with or without the extension

Return Value

The new identifier

See Also

ResourceIdentifier Class


ToString Method

ResourceIdentifier.ToString Method
[image]

Returns the full resource id as a string

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
C#
public override string ToString()
C++
public:
virtual String ToString() override
J#
public override string ToString()
JScript
public override function ToString() : String

Return Value

The full resource id as a string

See Also

ResourceIdentifier Class


Validate Method

ResourceIdentifier.Validate Method

Determines if a resource identifier is valid

Overload List

Name | Description
Validate (String) | Determines if a resource identifier is valid
Validate (String, ResourceTypes) | Determines if a resource identifier is valid and of the desired type

See Also

ResourceIdentifier Class


Validate Method (String)

ResourceIdentifier.Validate Method (String)
See Also Example
[image]

Determines if a resource identifier is valid

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Validate( _
ByVal identifier As String _
) As Boolean
C#
public static bool Validate(
string identifier
)
C++
public:
static bool Validate(
String identifier
)
J#
public static bool Validate(
string identifier
)
JScript
public static function Validate(
identifier : String
) : bool

Parameters

identifier
The identifier to validate

Return Value

A value indicating if the identifier is valid

See Also

ResourceIdentifier Class
ResourceIdentifier.Validate Overload List


Validate Method (String, ResourceTypes)

ResourceIdentifier.Validate Method (String, ResourceTypes)
See Also Example
[image]

Determines if a resource identifier is valid and of the desired type

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Validate( _
ByVal identifier As String, _
ByVal type As ResourceTypes _
) As Boolean
C#
public static bool Validate(
string identifier,
ResourceTypes type
)
C++
public:
static bool Validate(
String identifier,
ResourceTypes type
)
J#
public static bool Validate(
string identifier,
ResourceTypes type
)
JScript
public static function Validate(
identifier : String,
type : ResourceTypes
) : bool

Parameters

identifier
The identifier to validate
type
The type the resource identifer must be

Return Value

A value indicating if the identifier is valid

See Also

ResourceIdentifier Class
ResourceIdentifier.Validate Overload List


ResourceList Class

ResourceList Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class ResourceList
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class ResourceList
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class ResourceList
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class ResourceList
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class ResourceList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceList Members


ResourceList Members

ResourceList Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by ResourceList.

Public Constructors

 | Name | Description
Public method | ResourceList | Initializes a new instance of the ResourceList class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Items |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceList Class


ResourceList Constructor

ResourceList Constructor
[image]

Initializes a new instance of the ResourceList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceList()
C++
public:
ResourceList() sealed
J#
public ResourceList()
JScript
public function ResourceList()

See Also

ResourceList Class


Fields

ResourceList Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

ResourceList Class


SchemaName Field

ResourceList.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

ResourceList Class


Properties

ResourceList Properties
[image]

Public Properties

 | Name | Description
Public property | Items |
Public property | XsdSchema |
Top

See Also

ResourceList Class


Items Property

ResourceList.Items Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("ResourceDocument", GetType(ResourceListResourceDocument)), _
XmlElementAttribute("ResourceFolder", GetType(ResourceListResourceFolder))>
Public Property Items As ArrayList
C#
[XmlElementAttribute("ResourceDocument", typeof(ResourceListResourceDocument))]
[XmlElementAttribute("ResourceFolder", typeof(ResourceListResourceFolder))]
public ArrayList Items { get; set; }
C++
[XmlElementAttribute(L"ResourceDocument", typeof(ResourceListResourceDocument))]
[XmlElementAttribute(L"ResourceFolder", typeof(ResourceListResourceFolder))]
public property ArrayList Items sealed {
ArrayList get();
void set(ArrayList value);
}
J#
/** @attribute XmlElementAttribute("ResourceDocument", typeof(ResourceListResourceDocument)) */
/** @attribute XmlElementAttribute("ResourceFolder", typeof(ResourceListResourceFolder)) */
/** property */
public ArrayList get_Items();

/** property */
public void set_Items(ArrayList value);
JScript
public function get Items() : ArrayList

public function set Items(value : ArrayList);

See Also

ResourceList Class


XsdSchema Property

ResourceList.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

ResourceList Class


ResourceListResourceDocument Class

ResourceListResourceDocument Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceListResourceDocument
C#
public class ResourceListResourceDocument
C++
ref class ResourceListResourceDocument
J#
public class ResourceListResourceDocument
JScript
public class ResourceListResourceDocument

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceListResourceDocument

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceListResourceDocument Members


ResourceListResourceDocument Members

ResourceListResourceDocument Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceListResourceDocument.

Public Constructors

 | Name | Description
Public method | ResourceListResourceDocument | Initializes a new instance of the ResourceListResourceDocument class.
Top

Public Properties

 | Name | Description
Public property | CreatedDate |
Public property | Depth |
Public property | ModifiedDate |
Public property | Owner |
Public property | ResourceDocumentHeader |
Public property | ResourceId |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceListResourceDocument Class


ResourceListResourceDocument Constructor

ResourceListResourceDocument Constructor
[image]

Initializes a new instance of the ResourceListResourceDocument class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceListResourceDocument()
C++
public:
ResourceListResourceDocument() sealed
J#
public ResourceListResourceDocument()
JScript
public function ResourceListResourceDocument()

See Also

ResourceListResourceDocument Class


Properties

ResourceListResourceDocument Properties
[image]

Public Properties

 | Name | Description
Public property | CreatedDate |
Public property | Depth |
Public property | ModifiedDate |
Public property | Owner |
Public property | ResourceDocumentHeader |
Public property | ResourceId |
Top

See Also

ResourceListResourceDocument Class


CreatedDate Property

ResourceListResourceDocument.CreatedDate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CreatedDate As Date
C#
public DateTime CreatedDate { get; set; }
C++
public property DateTime CreatedDate sealed {
DateTime get();
void set(DateTime value);
}
J#
/** property */
public DateTime get_CreatedDate();

/** property */
public void set_CreatedDate(DateTime value);
JScript
public function get CreatedDate() : DateTime

public function set CreatedDate(value : DateTime);

See Also

ResourceListResourceDocument Class


Depth Property

ResourceListResourceDocument.Depth Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property Depth As String
C#
[XmlElementAttribute(DataType = "integer")]
public string Depth { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string Depth sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_Depth();

/** property */
public void set_Depth(string value);
JScript
public function get Depth() : String

public function set Depth(value : String);

See Also

ResourceListResourceDocument Class


ModifiedDate Property

ResourceListResourceDocument.ModifiedDate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ModifiedDate As Date
C#
public DateTime ModifiedDate { get; set; }
C++
public property DateTime ModifiedDate sealed {
DateTime get();
void set(DateTime value);
}
J#
/** property */
public DateTime get_ModifiedDate();

/** property */
public void set_ModifiedDate(DateTime value);
JScript
public function get ModifiedDate() : DateTime

public function set ModifiedDate(value : DateTime);

See Also

ResourceListResourceDocument Class


Owner Property

ResourceListResourceDocument.Owner Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
C++
public property string Owner sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Owner();

/** property */
public void set_Owner(string value);
JScript
public function get Owner() : String

public function set Owner(value : String);

See Also

ResourceListResourceDocument Class


ResourceDocumentHeader Property

ResourceListResourceDocument.ResourceDocumentHeader Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceDocumentHeader As ResourceDocumentHeaderType
C#
public ResourceDocumentHeaderType ResourceDocumentHeader { get; set; }
C++
public property ResourceDocumentHeaderType ResourceDocumentHeader sealed {
ResourceDocumentHeaderType get();
void set(ResourceDocumentHeaderType value);
}
J#
/** property */
public ResourceDocumentHeaderType get_ResourceDocumentHeader();

/** property */
public void set_ResourceDocumentHeader(ResourceDocumentHeaderType value);
JScript
public function get ResourceDocumentHeader() : ResourceDocumentHeaderType

public function set ResourceDocumentHeader(value : ResourceDocumentHeaderType);

See Also

ResourceListResourceDocument Class


ResourceId Property

ResourceListResourceDocument.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceId As String
C#
public string ResourceId { get; set; }
C++
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

ResourceListResourceDocument Class


ResourceListResourceFolder Class

ResourceListResourceFolder Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceListResourceFolder
C#
public class ResourceListResourceFolder
C++
ref class ResourceListResourceFolder
J#
public class ResourceListResourceFolder
JScript
public class ResourceListResourceFolder

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceListResourceFolder

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceListResourceFolder Members


ResourceListResourceFolder Members

ResourceListResourceFolder Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceListResourceFolder.

Public Constructors

 | Name | Description
Public method | ResourceListResourceFolder | Initializes a new instance of the ResourceListResourceFolder class.
Top

Public Properties

 | Name | Description
Public property | CreatedDate |
Public property | Depth |
Public property | ModifiedDate |
Public property | NumberOfDocuments |
Public property | NumberOfFolders |
Public property | Owner |
Public property | ResourceFolderHeader |
Public property | ResourceId |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceListResourceFolder Class


ResourceListResourceFolder Constructor

ResourceListResourceFolder Constructor
[image]

Initializes a new instance of the ResourceListResourceFolder class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceListResourceFolder()
C++
public:
ResourceListResourceFolder() sealed
J#
public ResourceListResourceFolder()
JScript
public function ResourceListResourceFolder()

See Also

ResourceListResourceFolder Class


Properties

ResourceListResourceFolder Properties
[image]

Public Properties

 | Name | Description
Public property | CreatedDate |
Public property | Depth |
Public property | ModifiedDate |
Public property | NumberOfDocuments |
Public property | NumberOfFolders |
Public property | Owner |
Public property | ResourceFolderHeader |
Public property | ResourceId |
Top

See Also

ResourceListResourceFolder Class


CreatedDate Property

ResourceListResourceFolder.CreatedDate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CreatedDate As Date
C#
public DateTime CreatedDate { get; set; }
C++
public property DateTime CreatedDate sealed {
DateTime get();
void set(DateTime value);
}
J#
/** property */
public DateTime get_CreatedDate();

/** property */
public void set_CreatedDate(DateTime value);
JScript
public function get CreatedDate() : DateTime

public function set CreatedDate(value : DateTime);

See Also

ResourceListResourceFolder Class


Depth Property

ResourceListResourceFolder.Depth Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property Depth As String
C#
[XmlElementAttribute(DataType = "integer")]
public string Depth { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string Depth sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_Depth();

/** property */
public void set_Depth(string value);
JScript
public function get Depth() : String

public function set Depth(value : String);

See Also

ResourceListResourceFolder Class


ModifiedDate Property

ResourceListResourceFolder.ModifiedDate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ModifiedDate As Date
C#
public DateTime ModifiedDate { get; set; }
C++
public property DateTime ModifiedDate sealed {
DateTime get();
void set(DateTime value);
}
J#
/** property */
public DateTime get_ModifiedDate();

/** property */
public void set_ModifiedDate(DateTime value);
JScript
public function get ModifiedDate() : DateTime

public function set ModifiedDate(value : DateTime);

See Also

ResourceListResourceFolder Class


NumberOfDocuments Property

ResourceListResourceFolder.NumberOfDocuments Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property NumberOfDocuments As String
C#
[XmlElementAttribute(DataType = "integer")]
public string NumberOfDocuments { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string NumberOfDocuments sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_NumberOfDocuments();

/** property */
public void set_NumberOfDocuments(string value);
JScript
public function get NumberOfDocuments() : String

public function set NumberOfDocuments(value : String);

See Also

ResourceListResourceFolder Class


NumberOfFolders Property

ResourceListResourceFolder.NumberOfFolders Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property NumberOfFolders As String
C#
[XmlElementAttribute(DataType = "integer")]
public string NumberOfFolders { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string NumberOfFolders sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_NumberOfFolders();

/** property */
public void set_NumberOfFolders(string value);
JScript
public function get NumberOfFolders() : String

public function set NumberOfFolders(value : String);

See Also

ResourceListResourceFolder Class


Owner Property

ResourceListResourceFolder.Owner Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Owner As String
C#
public string Owner { get; set; }
C++
public property string Owner sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Owner();

/** property */
public void set_Owner(string value);
JScript
public function get Owner() : String

public function set Owner(value : String);

See Also

ResourceListResourceFolder Class


ResourceFolderHeader Property

ResourceListResourceFolder.ResourceFolderHeader Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceFolderHeader As ResourceFolderHeaderType
C#
public ResourceFolderHeaderType ResourceFolderHeader { get; set; }
C++
public property ResourceFolderHeaderType ResourceFolderHeader sealed {
ResourceFolderHeaderType get();
void set(ResourceFolderHeaderType value);
}
J#
/** property */
public ResourceFolderHeaderType get_ResourceFolderHeader();

/** property */
public void set_ResourceFolderHeader(ResourceFolderHeaderType value);
JScript
public function get ResourceFolderHeader() : ResourceFolderHeaderType

public function set ResourceFolderHeader(value : ResourceFolderHeaderType);

See Also

ResourceListResourceFolder Class


ResourceId Property

ResourceListResourceFolder.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceId As String
C#
public string ResourceId { get; set; }
C++
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

ResourceListResourceFolder Class


ResourcePackageManifest Class

ResourcePackageManifest Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class ResourcePackageManifest
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class ResourcePackageManifest
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class ResourcePackageManifest
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class ResourcePackageManifest
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class ResourcePackageManifest

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifest

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourcePackageManifest Members


ResourcePackageManifest Members

ResourcePackageManifest Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by ResourcePackageManifest.

Public Constructors

 | Name | Description
Public method | ResourcePackageManifest | Initializes a new instance of the ResourcePackageManifest class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | Operations |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourcePackageManifest Class


ResourcePackageManifest Constructor

ResourcePackageManifest Constructor
[image]

Initializes a new instance of the ResourcePackageManifest class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourcePackageManifest()
C++
public:
ResourcePackageManifest() sealed
J#
public ResourcePackageManifest()
JScript
public function ResourcePackageManifest()

See Also

ResourcePackageManifest Class


Fields

ResourcePackageManifest Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

ResourcePackageManifest Class


SchemaName Field

ResourcePackageManifest.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

ResourcePackageManifest Class


Properties

ResourcePackageManifest Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | Operations |
Public property | XsdSchema |
Top

See Also

ResourcePackageManifest Class


Description Property

ResourcePackageManifest.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

ResourcePackageManifest Class


Operations Property

ResourcePackageManifest.Operations Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Operations As ResourcePackageManifestOperations
C#
public ResourcePackageManifestOperations Operations { get; set; }
C++
public property ResourcePackageManifestOperations Operations sealed {
ResourcePackageManifestOperations get();
void set(ResourcePackageManifestOperations value);
}
J#
/** property */
public ResourcePackageManifestOperations get_Operations();

/** property */
public void set_Operations(ResourcePackageManifestOperations value);
JScript
public function get Operations() : ResourcePackageManifestOperations

public function set Operations(value : ResourcePackageManifestOperations);

See Also

ResourcePackageManifest Class


XsdSchema Property

ResourcePackageManifest.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

ResourcePackageManifest Class


ResourcePackageManifestOperations Class

ResourcePackageManifestOperations Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourcePackageManifestOperations
C#
public class ResourcePackageManifestOperations
C++
ref class ResourcePackageManifestOperations
J#
public class ResourcePackageManifestOperations
JScript
public class ResourcePackageManifestOperations

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperations

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourcePackageManifestOperations Members


ResourcePackageManifestOperations Members

ResourcePackageManifestOperations Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourcePackageManifestOperations.

Public Constructors

 | Name | Description
Public method | ResourcePackageManifestOperations | Initializes a new instance of the ResourcePackageManifestOperations class.
Top

Public Properties

 | Name | Description
Public property | Operation |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourcePackageManifestOperations Class


ResourcePackageManifestOperations Constructor

ResourcePackageManifestOperations Constructor
[image]

Initializes a new instance of the ResourcePackageManifestOperations class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourcePackageManifestOperations()
C++
public:
ResourcePackageManifestOperations() sealed
J#
public ResourcePackageManifestOperations()
JScript
public function ResourcePackageManifestOperations()

See Also

ResourcePackageManifestOperations Class


Properties

ResourcePackageManifestOperations Properties
[image]

Public Properties

 | Name | Description
Public property | Operation |
Top

See Also

ResourcePackageManifestOperations Class


Operation Property

ResourcePackageManifestOperations.Operation Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Operation")>
Public Property Operation As ResourcePackageManifestOperationsOperationCollection
C#
[XmlElementAttribute("Operation")]
public ResourcePackageManifestOperationsOperationCollection Operation { get; set; }
C++
[XmlElementAttribute(L"Operation")]
public property ResourcePackageManifestOperationsOperationCollection Operation sealed {
ResourcePackageManifestOperationsOperationCollection get();
void set(ResourcePackageManifestOperationsOperationCollection value);
}
J#
/** @attribute XmlElementAttribute("Operation") */
/** property */
public ResourcePackageManifestOperationsOperationCollection get_Operation();

/** property */
public void set_Operation(ResourcePackageManifestOperationsOperationCollection value);
JScript
public function get Operation() : ResourcePackageManifestOperationsOperationCollection

public function set Operation(value : ResourcePackageManifestOperationsOperationCollection);

See Also

ResourcePackageManifestOperations Class


ResourcePackageManifestOperationsOperation Class

ResourcePackageManifestOperationsOperation Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourcePackageManifestOperationsOperation
C#
public class ResourcePackageManifestOperationsOperation
C++
ref class ResourcePackageManifestOperationsOperation
J#
public class ResourcePackageManifestOperationsOperation
JScript
public class ResourcePackageManifestOperationsOperation

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperationsOperation

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourcePackageManifestOperationsOperation Members


ResourcePackageManifestOperationsOperation Members

ResourcePackageManifestOperationsOperation Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourcePackageManifestOperationsOperation.

Public Constructors

 | Name | Description
Public method | ResourcePackageManifestOperationsOperation | Initializes a new instance of the ResourcePackageManifestOperationsOperation class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Parameters |
Public property | Version |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourcePackageManifestOperationsOperation Class


ResourcePackageManifestOperationsOperation Constructor

ResourcePackageManifestOperationsOperation Constructor
[image]

Initializes a new instance of the ResourcePackageManifestOperationsOperation class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourcePackageManifestOperationsOperation()
C++
public:
ResourcePackageManifestOperationsOperation() sealed
J#
public ResourcePackageManifestOperationsOperation()
JScript
public function ResourcePackageManifestOperationsOperation()

See Also

ResourcePackageManifestOperationsOperation Class


Properties

ResourcePackageManifestOperationsOperation Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Parameters |
Public property | Version |
Top

See Also

ResourcePackageManifestOperationsOperation Class


Name Property

ResourcePackageManifestOperationsOperation.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ResourcePackageManifestOperationsOperation Class


Parameters Property

ResourcePackageManifestOperationsOperation.Parameters Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameters As ResourcePackageManifestOperationsOperationParameters
C#
public ResourcePackageManifestOperationsOperationParameters Parameters { get; set; }
C++
public property ResourcePackageManifestOperationsOperationParameters Parameters sealed {
ResourcePackageManifestOperationsOperationParameters get();
void set(ResourcePackageManifestOperationsOperationParameters value);
}
J#
/** property */
public ResourcePackageManifestOperationsOperationParameters get_Parameters();

/** property */
public void set_Parameters(ResourcePackageManifestOperationsOperationParameters value);
JScript
public function get Parameters() : ResourcePackageManifestOperationsOperationParameters

public function set Parameters(value : ResourcePackageManifestOperationsOperationParameters);

See Also

ResourcePackageManifestOperationsOperation Class


Version Property

ResourcePackageManifestOperationsOperation.Version Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
C++
public property string Version sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Version();

/** property */
public void set_Version(string value);
JScript
public function get Version() : String

public function set Version(value : String);

See Also

ResourcePackageManifestOperationsOperation Class


ResourcePackageManifestOperationsOperationCollection Class

ResourcePackageManifestOperationsOperationCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ResourcePackageManifestOperationsOperationCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ResourcePackageManifestOperationsOperationCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ResourcePackageManifestOperationsOperationCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ResourcePackageManifestOperationsOperationCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ResourcePackageManifestOperationsOperationCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperationsOperationCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourcePackageManifestOperationsOperationCollection Members


ResourcePackageManifestOperationsOperationCollection Members

ResourcePackageManifestOperationsOperationCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourcePackageManifestOperationsOperationCollection.

Public Constructors

 | Name | Description
Public method | ResourcePackageManifestOperationsOperationCollection | Initializes a new instance of the ResourcePackageManifestOperationsOperationCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourcePackageManifestOperationsOperationCollection Class


ResourcePackageManifestOperationsOperationCollection Constructor

ResourcePackageManifestOperationsOperationCollection Constructor
See Also Example
[image]

Initializes a new instance of the ResourcePackageManifestOperationsOperationCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourcePackageManifestOperationsOperationCollection()
C++
public:
ResourcePackageManifestOperationsOperationCollection() sealed
J#
public ResourcePackageManifestOperationsOperationCollection()
JScript
public function ResourcePackageManifestOperationsOperationCollection()

See Also

ResourcePackageManifestOperationsOperationCollection Class


Properties

ResourcePackageManifestOperationsOperationCollection Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ResourcePackageManifestOperationsOperationCollection Class


Item Property

ResourcePackageManifestOperationsOperationCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ResourcePackageManifestOperationsOperation
C#
public ResourcePackageManifestOperationsOperation this[
int idx
] { get; set; }
C++
public property ResourcePackageManifestOperationsOperation default[int idx] sealed {
ResourcePackageManifestOperationsOperation get(int idx);
void set(int idx, ResourcePackageManifestOperationsOperation value);
}
J#
/** property */
public ResourcePackageManifestOperationsOperation get_Item(int idx);

/** property */
public void set_Item(int idx, ResourcePackageManifestOperationsOperation value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ResourcePackageManifestOperationsOperationCollection Class


Methods

ResourcePackageManifestOperationsOperationCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourcePackageManifestOperationsOperationCollection Class


Add Method

ResourcePackageManifestOperationsOperationCollection.Add Method
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ResourcePackageManifestOperationsOperation _
) As Integer
C#
public int Add(
ResourcePackageManifestOperationsOperation value
)
C++
public:
int Add(
ResourcePackageManifestOperationsOperation value
) sealed
J#
public int Add(
ResourcePackageManifestOperationsOperation value
)
JScript
public function Add(
value : ResourcePackageManifestOperationsOperation
) : int

See Also

ResourcePackageManifestOperationsOperationCollection Class


ResourcePackageManifestOperationsOperationParameters Class

ResourcePackageManifestOperationsOperationParameters Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourcePackageManifestOperationsOperationParameters
C#
public class ResourcePackageManifestOperationsOperationParameters
C++
ref class ResourcePackageManifestOperationsOperationParameters
J#
public class ResourcePackageManifestOperationsOperationParameters
JScript
public class ResourcePackageManifestOperationsOperationParameters

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperationsOperationParameters

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourcePackageManifestOperationsOperationParameters Members


ResourcePackageManifestOperationsOperationParameters Members

ResourcePackageManifestOperationsOperationParameters Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourcePackageManifestOperationsOperationParameters.

Public Constructors

 | Name | Description
Public method | ResourcePackageManifestOperationsOperationParameters | Initializes a new instance of the ResourcePackageManifestOperationsOperationParameters class.
Top

Public Properties

 | Name | Description
Public property | Parameter |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourcePackageManifestOperationsOperationParameters Class


ResourcePackageManifestOperationsOperationParameters Constructor

ResourcePackageManifestOperationsOperationParameters Constructor
See Also Example
[image]

Initializes a new instance of the ResourcePackageManifestOperationsOperationParameters class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourcePackageManifestOperationsOperationParameters()
C++
public:
ResourcePackageManifestOperationsOperationParameters() sealed
J#
public ResourcePackageManifestOperationsOperationParameters()
JScript
public function ResourcePackageManifestOperationsOperationParameters()

See Also

ResourcePackageManifestOperationsOperationParameters Class


Properties

ResourcePackageManifestOperationsOperationParameters Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Parameter |
Top

See Also

ResourcePackageManifestOperationsOperationParameters Class


Parameter Property

ResourcePackageManifestOperationsOperationParameters.Parameter Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Parameter")>
Public Property Parameter As ResourcePackageManifestOperationsOperationParametersParameterCollection
C#
[XmlElementAttribute("Parameter")]
public ResourcePackageManifestOperationsOperationParametersParameterCollection Parameter { get; set; }
C++
[XmlElementAttribute(L"Parameter")]
public property ResourcePackageManifestOperationsOperationParametersParameterCollection Parameter sealed {
ResourcePackageManifestOperationsOperationParametersParameterCollection get();
void set(ResourcePackageManifestOperationsOperationParametersParameterCollection value);
}
J#
/** @attribute XmlElementAttribute("Parameter") */
/** property */
public ResourcePackageManifestOperationsOperationParametersParameterCollection get_Parameter();

/** property */
public void set_Parameter(ResourcePackageManifestOperationsOperationParametersParameterCollection value);
JScript
public function get Parameter() : ResourcePackageManifestOperationsOperationParametersParameterCollection

public function set Parameter(value : ResourcePackageManifestOperationsOperationParametersParameterCollection);

See Also

ResourcePackageManifestOperationsOperationParameters Class


ResourcePackageManifestOperationsOperationParametersParameter Class

ResourcePackageManifestOperationsOperationParametersParameter Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourcePackageManifestOperationsOperationParametersParameter
C#
public class ResourcePackageManifestOperationsOperationParametersParameter
C++
ref class ResourcePackageManifestOperationsOperationParametersParameter
J#
public class ResourcePackageManifestOperationsOperationParametersParameter
JScript
public class ResourcePackageManifestOperationsOperationParametersParameter

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperationsOperationParametersParameter

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourcePackageManifestOperationsOperationParametersParameter Members


ResourcePackageManifestOperationsOperationParametersParameter Members

ResourcePackageManifestOperationsOperationParametersParameter Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourcePackageManifestOperationsOperationParametersParameter.

Public Constructors

 | Name | Description
Public method | ResourcePackageManifestOperationsOperationParametersParameter | Initializes a new instance of the ResourcePackageManifestOperationsOperationParametersParameter class.
Top

Public Properties

 | Name | Description
Public property | ContentType |
Public property | Name |
Public property | Value |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourcePackageManifestOperationsOperationParametersParameter Class


ResourcePackageManifestOperationsOperationParametersParameter Constructor

ResourcePackageManifestOperationsOperationParametersParameter Constructor
See Also Example
[image]

Initializes a new instance of the ResourcePackageManifestOperationsOperationParametersParameter class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourcePackageManifestOperationsOperationParametersParameter()
C++
public:
ResourcePackageManifestOperationsOperationParametersParameter() sealed
J#
public ResourcePackageManifestOperationsOperationParametersParameter()
JScript
public function ResourcePackageManifestOperationsOperationParametersParameter()

See Also

ResourcePackageManifestOperationsOperationParametersParameter Class


Properties

ResourcePackageManifestOperationsOperationParametersParameter Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | ContentType |
Public property | Name |
Public property | Value |
Top

See Also

ResourcePackageManifestOperationsOperationParametersParameter Class


ContentType Property

ResourcePackageManifestOperationsOperationParametersParameter.ContentType Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ContentType As String
C#
public string ContentType { get; set; }
C++
public property string ContentType sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ContentType();

/** property */
public void set_ContentType(string value);
JScript
public function get ContentType() : String

public function set ContentType(value : String);

See Also

ResourcePackageManifestOperationsOperationParametersParameter Class


Name Property

ResourcePackageManifestOperationsOperationParametersParameter.Name Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ResourcePackageManifestOperationsOperationParametersParameter Class


Value Property

ResourcePackageManifestOperationsOperationParametersParameter.Value Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
C++
public property string Value sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

ResourcePackageManifestOperationsOperationParametersParameter Class


ResourcePackageManifestOperationsOperationParametersParameterCollection Class

ResourcePackageManifestOperationsOperationParametersParameterCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ResourcePackageManifestOperationsOperationParametersParameterCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ResourcePackageManifestOperationsOperationParametersParameterCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ResourcePackageManifestOperationsOperationParametersParameterCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ResourcePackageManifestOperationsOperationParametersParameterCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ResourcePackageManifestOperationsOperationParametersParameterCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperationsOperationParametersParameterCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourcePackageManifestOperationsOperationParametersParameterCollection Members


ResourcePackageManifestOperationsOperationParametersParameterCollection Members

ResourcePackageManifestOperationsOperationParametersParameterCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourcePackageManifestOperationsOperationParametersParameterCollection.

Public Constructors

 | Name | Description
Public method | ResourcePackageManifestOperationsOperationParametersParameterCollection | Initializes a new instance of the ResourcePackageManifestOperationsOperationParametersParameterCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourcePackageManifestOperationsOperationParametersParameterCollection Class


ResourcePackageManifestOperationsOperationParametersParameterCollection Constructor

ResourcePackageManifestOperationsOperationParametersParameterCollection Constructor
See Also Example
[image]

Initializes a new instance of the ResourcePackageManifestOperationsOperationParametersParameterCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourcePackageManifestOperationsOperationParametersParameterCollection()
C++
public:
ResourcePackageManifestOperationsOperationParametersParameterCollection() sealed
J#
public ResourcePackageManifestOperationsOperationParametersParameterCollection()
JScript
public function ResourcePackageManifestOperationsOperationParametersParameterCollection()

See Also

ResourcePackageManifestOperationsOperationParametersParameterCollection Class


Properties

ResourcePackageManifestOperationsOperationParametersParameterCollection Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Overloaded.
Top

See Also

ResourcePackageManifestOperationsOperationParametersParameterCollection Class


Item Property

ResourcePackageManifestOperationsOperationParametersParameterCollection.Item Property
See Also Example

Overload List

 | Name | Description
Public property | Item (Int32) |
Public property | Item (String) |

See Also

ResourcePackageManifestOperationsOperationParametersParameterCollection Class


Item Property (Int32)

ResourcePackageManifestOperationsOperationParametersParameterCollection.Item Property (Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ResourcePackageManifestOperationsOperationParametersParameter
C#
public ResourcePackageManifestOperationsOperationParametersParameter this[
int idx
] { get; set; }
C++
public property ResourcePackageManifestOperationsOperationParametersParameter default[int idx] sealed {
ResourcePackageManifestOperationsOperationParametersParameter get(int idx);
void set(int idx, ResourcePackageManifestOperationsOperationParametersParameter value);
}
J#
/** property */
public ResourcePackageManifestOperationsOperationParametersParameter get_Item(int idx);

/** property */
public void set_Item(int idx, ResourcePackageManifestOperationsOperationParametersParameter value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ResourcePackageManifestOperationsOperationParametersParameterCollection Class
OSGeo.MapGuide.MaestroAPI Namespace
ResourcePackageManifestOperationsOperationParametersParameterCollection.Item Overload List


Item Property (String)

ResourcePackageManifestOperationsOperationParametersParameterCollection.Item Property (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As String _
) As ResourcePackageManifestOperationsOperationParametersParameter
C#
public ResourcePackageManifestOperationsOperationParametersParameter this[
string idx
] { get; set; }
C++
public property ResourcePackageManifestOperationsOperationParametersParameter default[String idx] sealed {
ResourcePackageManifestOperationsOperationParametersParameter get(String idx);
void set(String idx, ResourcePackageManifestOperationsOperationParametersParameter value);
}
J#
/** property */
public ResourcePackageManifestOperationsOperationParametersParameter get_Item(string idx);

/** property */
public void set_Item(string idx, ResourcePackageManifestOperationsOperationParametersParameter value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ResourcePackageManifestOperationsOperationParametersParameterCollection Class
OSGeo.MapGuide.MaestroAPI Namespace
ResourcePackageManifestOperationsOperationParametersParameterCollection.Item Overload List


Methods

ResourcePackageManifestOperationsOperationParametersParameterCollection Methods
See Also Example
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourcePackageManifestOperationsOperationParametersParameterCollection Class


Add Method

ResourcePackageManifestOperationsOperationParametersParameterCollection.Add Method
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ResourcePackageManifestOperationsOperationParametersParameter _
) As Integer
C#
public int Add(
ResourcePackageManifestOperationsOperationParametersParameter value
)
C++
public:
int Add(
ResourcePackageManifestOperationsOperationParametersParameter value
) sealed
J#
public int Add(
ResourcePackageManifestOperationsOperationParametersParameter value
)
JScript
public function Add(
value : ResourcePackageManifestOperationsOperationParametersParameter
) : int

See Also

ResourcePackageManifestOperationsOperationParametersParameterCollection Class


ResourceReferenceList Class

ResourceReferenceList Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class ResourceReferenceList
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class ResourceReferenceList
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class ResourceReferenceList
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class ResourceReferenceList
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class ResourceReferenceList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceReferenceList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceReferenceList Members


ResourceReferenceList Members

ResourceReferenceList Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by ResourceReferenceList.

Public Constructors

 | Name | Description
Public method | ResourceReferenceList | Initializes a new instance of the ResourceReferenceList class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | ResourceId |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceReferenceList Class


ResourceReferenceList Constructor

ResourceReferenceList Constructor
[image]

Initializes a new instance of the ResourceReferenceList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceReferenceList()
C++
public:
ResourceReferenceList() sealed
J#
public ResourceReferenceList()
JScript
public function ResourceReferenceList()

See Also

ResourceReferenceList Class


Fields

ResourceReferenceList Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

ResourceReferenceList Class


SchemaName Field

ResourceReferenceList.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

ResourceReferenceList Class


Properties

ResourceReferenceList Properties
[image]

Public Properties

 | Name | Description
Public property | ResourceId |
Public property | XsdSchema |
Top

See Also

ResourceReferenceList Class


ResourceId Property

ResourceReferenceList.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("ResourceId")>
Public Property ResourceId As StringCollection
C#
[XmlElementAttribute("ResourceId")]
public StringCollection ResourceId { get; set; }
C++
[XmlElementAttribute(L"ResourceId")]
public property StringCollection ResourceId sealed {
StringCollection get();
void set(StringCollection value);
}
J#
/** @attribute XmlElementAttribute("ResourceId") */
/** property */
public StringCollection get_ResourceId();

/** property */
public void set_ResourceId(StringCollection value);
JScript
public function get ResourceId() : StringCollection

public function set ResourceId(value : StringCollection);

See Also

ResourceReferenceList Class


XsdSchema Property

ResourceReferenceList.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

ResourceReferenceList Class


ResourceReferenceType Class

ResourceReferenceType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(MapType))>
Public Class ResourceReferenceType
C#
[XmlIncludeAttribute(typeof(MapType))]
public class ResourceReferenceType
C++
[XmlIncludeAttribute(typeof(MapType))]
ref class ResourceReferenceType
J#
/** @attribute XmlIncludeAttribute(typeof(MapType)) */
public class ResourceReferenceType
JScript
public
XmlIncludeAttribute(typeof(MapType))
class ResourceReferenceType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceReferenceType
OSGeo.MapGuide.MaestroAPI.MapType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceReferenceType Members


ResourceReferenceType Members

ResourceReferenceType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceReferenceType.

Public Constructors

 | Name | Description
Public method | ResourceReferenceType | Initializes a new instance of the ResourceReferenceType class.
Top

Public Properties

 | Name | Description
Public property | ResourceId |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceReferenceType Class


ResourceReferenceType Constructor

ResourceReferenceType Constructor
[image]

Initializes a new instance of the ResourceReferenceType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceReferenceType()
C++
public:
ResourceReferenceType() sealed
J#
public ResourceReferenceType()
JScript
public function ResourceReferenceType()

See Also

ResourceReferenceType Class


Properties

ResourceReferenceType Properties
[image]

Public Properties

 | Name | Description
Public property | ResourceId |
Top

See Also

ResourceReferenceType Class


ResourceId Property

ResourceReferenceType.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceId As String
C#
public string ResourceId { get; set; }
C++
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

ResourceReferenceType Class


ResourceReferenceTypeCollection Class

ResourceReferenceTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ResourceReferenceTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ResourceReferenceTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ResourceReferenceTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ResourceReferenceTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ResourceReferenceTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ResourceReferenceTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceReferenceTypeCollection Members


ResourceReferenceTypeCollection Members

ResourceReferenceTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceReferenceTypeCollection.

Public Constructors

 | Name | Description
Public method | ResourceReferenceTypeCollection | Initializes a new instance of the ResourceReferenceTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceReferenceTypeCollection Class


ResourceReferenceTypeCollection Constructor

ResourceReferenceTypeCollection Constructor
[image]

Initializes a new instance of the ResourceReferenceTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceReferenceTypeCollection()
C++
public:
ResourceReferenceTypeCollection() sealed
J#
public ResourceReferenceTypeCollection()
JScript
public function ResourceReferenceTypeCollection()

See Also

ResourceReferenceTypeCollection Class


Properties

ResourceReferenceTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ResourceReferenceTypeCollection Class


Item Property

ResourceReferenceTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ResourceReferenceType
C#
public ResourceReferenceType this[
int idx
] { get; set; }
C++
public property ResourceReferenceType default[int idx] sealed {
ResourceReferenceType get(int idx);
void set(int idx, ResourceReferenceType value);
}
J#
/** property */
public ResourceReferenceType get_Item(int idx);

/** property */
public void set_Item(int idx, ResourceReferenceType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ResourceReferenceTypeCollection Class


Methods

ResourceReferenceTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceReferenceTypeCollection Class


Add Method

ResourceReferenceTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ResourceReferenceType _
) As Integer
C#
public int Add(
ResourceReferenceType value
)
C++
public:
int Add(
ResourceReferenceType value
) sealed
J#
public int Add(
ResourceReferenceType value
)
JScript
public function Add(
value : ResourceReferenceType
) : int

See Also

ResourceReferenceTypeCollection Class


ResourceSecurityType Class

ResourceSecurityType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("ResourceSecurity", Namespace := "", IsNullable := True)>
Public Class ResourceSecurityType
C#
[XmlRootAttribute("ResourceSecurity", Namespace = "", IsNullable = True)]
public class ResourceSecurityType
C++
[XmlRootAttribute(L"ResourceSecurity", Namespace = L"", IsNullable = True)]
ref class ResourceSecurityType
J#
/** @attribute XmlRootAttribute("ResourceSecurity", Namespace = "", IsNullable = True) */
public class ResourceSecurityType
JScript
public
XmlRootAttribute("ResourceSecurity", Namespace = "", IsNullable = True)
class ResourceSecurityType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceSecurityType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceSecurityType Members


ResourceSecurityType Members

ResourceSecurityType Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by ResourceSecurityType.

Public Constructors

 | Name | Description
Public method | ResourceSecurityType | Initializes a new instance of the ResourceSecurityType class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Groups |
Public property | Inherited |
Public property | Users |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceSecurityType Class


ResourceSecurityType Constructor

ResourceSecurityType Constructor
[image]

Initializes a new instance of the ResourceSecurityType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceSecurityType()
C++
public:
ResourceSecurityType() sealed
J#
public ResourceSecurityType()
JScript
public function ResourceSecurityType()

See Also

ResourceSecurityType Class


Fields

ResourceSecurityType Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

ResourceSecurityType Class


SchemaName Field

ResourceSecurityType.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

ResourceSecurityType Class


Properties

ResourceSecurityType Properties
[image]

Public Properties

 | Name | Description
Public property | Groups |
Public property | Inherited |
Public property | Users |
Public property | XsdSchema |
Top

See Also

ResourceSecurityType Class


Groups Property

ResourceSecurityType.Groups Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Groups As ResourceSecurityTypeGroups
C#
public ResourceSecurityTypeGroups Groups { get; set; }
C++
public property ResourceSecurityTypeGroups Groups sealed {
ResourceSecurityTypeGroups get();
void set(ResourceSecurityTypeGroups value);
}
J#
/** property */
public ResourceSecurityTypeGroups get_Groups();

/** property */
public void set_Groups(ResourceSecurityTypeGroups value);
JScript
public function get Groups() : ResourceSecurityTypeGroups

public function set Groups(value : ResourceSecurityTypeGroups);

See Also

ResourceSecurityType Class


Inherited Property

ResourceSecurityType.Inherited Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Inherited As Boolean
C#
public bool Inherited { get; set; }
C++
public property bool Inherited sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Inherited();

/** property */
public void set_Inherited(bool value);
JScript
public function get Inherited() : bool

public function set Inherited(value : bool);

See Also

ResourceSecurityType Class


Users Property

ResourceSecurityType.Users Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Users As ResourceSecurityTypeUsers
C#
public ResourceSecurityTypeUsers Users { get; set; }
C++
public property ResourceSecurityTypeUsers Users sealed {
ResourceSecurityTypeUsers get();
void set(ResourceSecurityTypeUsers value);
}
J#
/** property */
public ResourceSecurityTypeUsers get_Users();

/** property */
public void set_Users(ResourceSecurityTypeUsers value);
JScript
public function get Users() : ResourceSecurityTypeUsers

public function set Users(value : ResourceSecurityTypeUsers);

See Also

ResourceSecurityType Class


XsdSchema Property

ResourceSecurityType.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

ResourceSecurityType Class


ResourceSecurityTypeGroups Class

ResourceSecurityTypeGroups Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceSecurityTypeGroups
C#
public class ResourceSecurityTypeGroups
C++
ref class ResourceSecurityTypeGroups
J#
public class ResourceSecurityTypeGroups
JScript
public class ResourceSecurityTypeGroups

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeGroups

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceSecurityTypeGroups Members


ResourceSecurityTypeGroups Members

ResourceSecurityTypeGroups Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceSecurityTypeGroups.

Public Constructors

 | Name | Description
Public method | ResourceSecurityTypeGroups | Initializes a new instance of the ResourceSecurityTypeGroups class.
Top

Public Properties

 | Name | Description
Public property | Group |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceSecurityTypeGroups Class


ResourceSecurityTypeGroups Constructor

ResourceSecurityTypeGroups Constructor
[image]

Initializes a new instance of the ResourceSecurityTypeGroups class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceSecurityTypeGroups()
C++
public:
ResourceSecurityTypeGroups() sealed
J#
public ResourceSecurityTypeGroups()
JScript
public function ResourceSecurityTypeGroups()

See Also

ResourceSecurityTypeGroups Class


Properties

ResourceSecurityTypeGroups Properties
[image]

Public Properties

 | Name | Description
Public property | Group |
Top

See Also

ResourceSecurityTypeGroups Class


Group Property

ResourceSecurityTypeGroups.Group Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Group")>
Public Property Group As ResourceSecurityTypeGroupsGroupCollection
C#
[XmlElementAttribute("Group")]
public ResourceSecurityTypeGroupsGroupCollection Group { get; set; }
C++
[XmlElementAttribute(L"Group")]
public property ResourceSecurityTypeGroupsGroupCollection Group sealed {
ResourceSecurityTypeGroupsGroupCollection get();
void set(ResourceSecurityTypeGroupsGroupCollection value);
}
J#
/** @attribute XmlElementAttribute("Group") */
/** property */
public ResourceSecurityTypeGroupsGroupCollection get_Group();

/** property */
public void set_Group(ResourceSecurityTypeGroupsGroupCollection value);
JScript
public function get Group() : ResourceSecurityTypeGroupsGroupCollection

public function set Group(value : ResourceSecurityTypeGroupsGroupCollection);

See Also

ResourceSecurityTypeGroups Class


ResourceSecurityTypeGroupsGroup Class

ResourceSecurityTypeGroupsGroup Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceSecurityTypeGroupsGroup
C#
public class ResourceSecurityTypeGroupsGroup
C++
ref class ResourceSecurityTypeGroupsGroup
J#
public class ResourceSecurityTypeGroupsGroup
JScript
public class ResourceSecurityTypeGroupsGroup

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeGroupsGroup

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceSecurityTypeGroupsGroup Members


ResourceSecurityTypeGroupsGroup Members

ResourceSecurityTypeGroupsGroup Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceSecurityTypeGroupsGroup.

Public Constructors

 | Name | Description
Public method | ResourceSecurityTypeGroupsGroup | Initializes a new instance of the ResourceSecurityTypeGroupsGroup class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Permissions |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceSecurityTypeGroupsGroup Class


ResourceSecurityTypeGroupsGroup Constructor

ResourceSecurityTypeGroupsGroup Constructor
[image]

Initializes a new instance of the ResourceSecurityTypeGroupsGroup class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceSecurityTypeGroupsGroup()
C++
public:
ResourceSecurityTypeGroupsGroup() sealed
J#
public ResourceSecurityTypeGroupsGroup()
JScript
public function ResourceSecurityTypeGroupsGroup()

See Also

ResourceSecurityTypeGroupsGroup Class


Properties

ResourceSecurityTypeGroupsGroup Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Permissions |
Top

See Also

ResourceSecurityTypeGroupsGroup Class


Name Property

ResourceSecurityTypeGroupsGroup.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ResourceSecurityTypeGroupsGroup Class


Permissions Property

ResourceSecurityTypeGroupsGroup.Permissions Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As PermissionsType
C#
public PermissionsType Permissions { get; set; }
C++
public property PermissionsType Permissions sealed {
PermissionsType get();
void set(PermissionsType value);
}
J#
/** property */
public PermissionsType get_Permissions();

/** property */
public void set_Permissions(PermissionsType value);
JScript
public function get Permissions() : PermissionsType

public function set Permissions(value : PermissionsType);

See Also

ResourceSecurityTypeGroupsGroup Class


ResourceSecurityTypeGroupsGroupCollection Class

ResourceSecurityTypeGroupsGroupCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ResourceSecurityTypeGroupsGroupCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ResourceSecurityTypeGroupsGroupCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ResourceSecurityTypeGroupsGroupCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ResourceSecurityTypeGroupsGroupCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ResourceSecurityTypeGroupsGroupCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeGroupsGroupCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceSecurityTypeGroupsGroupCollection Members


ResourceSecurityTypeGroupsGroupCollection Members

ResourceSecurityTypeGroupsGroupCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceSecurityTypeGroupsGroupCollection.

Public Constructors

 | Name | Description
Public method | ResourceSecurityTypeGroupsGroupCollection | Initializes a new instance of the ResourceSecurityTypeGroupsGroupCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceSecurityTypeGroupsGroupCollection Class


ResourceSecurityTypeGroupsGroupCollection Constructor

ResourceSecurityTypeGroupsGroupCollection Constructor
[image]

Initializes a new instance of the ResourceSecurityTypeGroupsGroupCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceSecurityTypeGroupsGroupCollection()
C++
public:
ResourceSecurityTypeGroupsGroupCollection() sealed
J#
public ResourceSecurityTypeGroupsGroupCollection()
JScript
public function ResourceSecurityTypeGroupsGroupCollection()

See Also

ResourceSecurityTypeGroupsGroupCollection Class


Properties

ResourceSecurityTypeGroupsGroupCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ResourceSecurityTypeGroupsGroupCollection Class


Item Property

ResourceSecurityTypeGroupsGroupCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ResourceSecurityTypeGroupsGroup
C#
public ResourceSecurityTypeGroupsGroup this[
int idx
] { get; set; }
C++
public property ResourceSecurityTypeGroupsGroup default[int idx] sealed {
ResourceSecurityTypeGroupsGroup get(int idx);
void set(int idx, ResourceSecurityTypeGroupsGroup value);
}
J#
/** property */
public ResourceSecurityTypeGroupsGroup get_Item(int idx);

/** property */
public void set_Item(int idx, ResourceSecurityTypeGroupsGroup value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ResourceSecurityTypeGroupsGroupCollection Class


Methods

ResourceSecurityTypeGroupsGroupCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceSecurityTypeGroupsGroupCollection Class


Add Method

ResourceSecurityTypeGroupsGroupCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ResourceSecurityTypeGroupsGroup _
) As Integer
C#
public int Add(
ResourceSecurityTypeGroupsGroup value
)
C++
public:
int Add(
ResourceSecurityTypeGroupsGroup value
) sealed
J#
public int Add(
ResourceSecurityTypeGroupsGroup value
)
JScript
public function Add(
value : ResourceSecurityTypeGroupsGroup
) : int

See Also

ResourceSecurityTypeGroupsGroupCollection Class


ResourceSecurityTypeUsers Class

ResourceSecurityTypeUsers Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceSecurityTypeUsers
C#
public class ResourceSecurityTypeUsers
C++
ref class ResourceSecurityTypeUsers
J#
public class ResourceSecurityTypeUsers
JScript
public class ResourceSecurityTypeUsers

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeUsers

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceSecurityTypeUsers Members


ResourceSecurityTypeUsers Members

ResourceSecurityTypeUsers Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceSecurityTypeUsers.

Public Constructors

 | Name | Description
Public method | ResourceSecurityTypeUsers | Initializes a new instance of the ResourceSecurityTypeUsers class.
Top

Public Properties

 | Name | Description
Public property | User |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceSecurityTypeUsers Class


ResourceSecurityTypeUsers Constructor

ResourceSecurityTypeUsers Constructor
[image]

Initializes a new instance of the ResourceSecurityTypeUsers class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceSecurityTypeUsers()
C++
public:
ResourceSecurityTypeUsers() sealed
J#
public ResourceSecurityTypeUsers()
JScript
public function ResourceSecurityTypeUsers()

See Also

ResourceSecurityTypeUsers Class


Properties

ResourceSecurityTypeUsers Properties
[image]

Public Properties

 | Name | Description
Public property | User |
Top

See Also

ResourceSecurityTypeUsers Class


User Property

ResourceSecurityTypeUsers.User Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("User")>
Public Property User As ResourceSecurityTypeUsersUserCollection
C#
[XmlElementAttribute("User")]
public ResourceSecurityTypeUsersUserCollection User { get; set; }
C++
[XmlElementAttribute(L"User")]
public property ResourceSecurityTypeUsersUserCollection User sealed {
ResourceSecurityTypeUsersUserCollection get();
void set(ResourceSecurityTypeUsersUserCollection value);
}
J#
/** @attribute XmlElementAttribute("User") */
/** property */
public ResourceSecurityTypeUsersUserCollection get_User();

/** property */
public void set_User(ResourceSecurityTypeUsersUserCollection value);
JScript
public function get User() : ResourceSecurityTypeUsersUserCollection

public function set User(value : ResourceSecurityTypeUsersUserCollection);

See Also

ResourceSecurityTypeUsers Class


ResourceSecurityTypeUsersUser Class

ResourceSecurityTypeUsersUser Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResourceSecurityTypeUsersUser
C#
public class ResourceSecurityTypeUsersUser
C++
ref class ResourceSecurityTypeUsersUser
J#
public class ResourceSecurityTypeUsersUser
JScript
public class ResourceSecurityTypeUsersUser

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeUsersUser

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceSecurityTypeUsersUser Members


ResourceSecurityTypeUsersUser Members

ResourceSecurityTypeUsersUser Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceSecurityTypeUsersUser.

Public Constructors

 | Name | Description
Public method | ResourceSecurityTypeUsersUser | Initializes a new instance of the ResourceSecurityTypeUsersUser class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Permissions |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceSecurityTypeUsersUser Class


ResourceSecurityTypeUsersUser Constructor

ResourceSecurityTypeUsersUser Constructor
[image]

Initializes a new instance of the ResourceSecurityTypeUsersUser class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceSecurityTypeUsersUser()
C++
public:
ResourceSecurityTypeUsersUser() sealed
J#
public ResourceSecurityTypeUsersUser()
JScript
public function ResourceSecurityTypeUsersUser()

See Also

ResourceSecurityTypeUsersUser Class


Properties

ResourceSecurityTypeUsersUser Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Permissions |
Top

See Also

ResourceSecurityTypeUsersUser Class


Name Property

ResourceSecurityTypeUsersUser.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ResourceSecurityTypeUsersUser Class


Permissions Property

ResourceSecurityTypeUsersUser.Permissions Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Permissions As PermissionsType
C#
public PermissionsType Permissions { get; set; }
C++
public property PermissionsType Permissions sealed {
PermissionsType get();
void set(PermissionsType value);
}
J#
/** property */
public PermissionsType get_Permissions();

/** property */
public void set_Permissions(PermissionsType value);
JScript
public function get Permissions() : PermissionsType

public function set Permissions(value : PermissionsType);

See Also

ResourceSecurityTypeUsersUser Class


ResourceSecurityTypeUsersUserCollection Class

ResourceSecurityTypeUsersUserCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ResourceSecurityTypeUsersUserCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ResourceSecurityTypeUsersUserCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ResourceSecurityTypeUsersUserCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ResourceSecurityTypeUsersUserCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ResourceSecurityTypeUsersUserCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeUsersUserCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResourceSecurityTypeUsersUserCollection Members


ResourceSecurityTypeUsersUserCollection Members

ResourceSecurityTypeUsersUserCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResourceSecurityTypeUsersUserCollection.

Public Constructors

 | Name | Description
Public method | ResourceSecurityTypeUsersUserCollection | Initializes a new instance of the ResourceSecurityTypeUsersUserCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceSecurityTypeUsersUserCollection Class


ResourceSecurityTypeUsersUserCollection Constructor

ResourceSecurityTypeUsersUserCollection Constructor
[image]

Initializes a new instance of the ResourceSecurityTypeUsersUserCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResourceSecurityTypeUsersUserCollection()
C++
public:
ResourceSecurityTypeUsersUserCollection() sealed
J#
public ResourceSecurityTypeUsersUserCollection()
JScript
public function ResourceSecurityTypeUsersUserCollection()

See Also

ResourceSecurityTypeUsersUserCollection Class


Properties

ResourceSecurityTypeUsersUserCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ResourceSecurityTypeUsersUserCollection Class


Item Property

ResourceSecurityTypeUsersUserCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ResourceSecurityTypeUsersUser
C#
public ResourceSecurityTypeUsersUser this[
int idx
] { get; set; }
C++
public property ResourceSecurityTypeUsersUser default[int idx] sealed {
ResourceSecurityTypeUsersUser get(int idx);
void set(int idx, ResourceSecurityTypeUsersUser value);
}
J#
/** property */
public ResourceSecurityTypeUsersUser get_Item(int idx);

/** property */
public void set_Item(int idx, ResourceSecurityTypeUsersUser value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ResourceSecurityTypeUsersUserCollection Class


Methods

ResourceSecurityTypeUsersUserCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResourceSecurityTypeUsersUserCollection Class


Add Method

ResourceSecurityTypeUsersUserCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ResourceSecurityTypeUsersUser _
) As Integer
C#
public int Add(
ResourceSecurityTypeUsersUser value
)
C++
public:
int Add(
ResourceSecurityTypeUsersUser value
) sealed
J#
public int Add(
ResourceSecurityTypeUsersUser value
)
JScript
public function Add(
value : ResourceSecurityTypeUsersUser
) : int

See Also

ResourceSecurityTypeUsersUserCollection Class


ResourceTypes Enumeration

ResourceTypes Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ResourceTypes
C#
public enum ResourceTypes
C++
public enum class ResourceTypes
J#
public enum ResourceTypes
JScript
public enum ResourceTypes

Members

Member Name | Description
MapDefinition |
LayerDefiniton |
FeatureSource |
WebLayout |
RuntimeMap |
Folder |
ApplicationDefinition |

See Also


ResultColumnType Class

ResultColumnType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ResultColumnType
C#
public class ResultColumnType
C++
ref class ResultColumnType
J#
public class ResultColumnType
JScript
public class ResultColumnType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ResultColumnType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResultColumnType Members


ResultColumnType Members

ResultColumnType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResultColumnType.

Public Constructors

 | Name | Description
Public method | ResultColumnType | Initializes a new instance of the ResultColumnType class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Property |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResultColumnType Class


ResultColumnType Constructor

ResultColumnType Constructor
[image]

Initializes a new instance of the ResultColumnType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResultColumnType()
C++
public:
ResultColumnType() sealed
J#
public ResultColumnType()
JScript
public function ResultColumnType()

See Also

ResultColumnType Class


Properties

ResultColumnType Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Property |
Top

See Also

ResultColumnType Class


Name Property

ResultColumnType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ResultColumnType Class


Property Property

ResultColumnType.Property Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Property As String
C#
public string Property { get; set; }
C++
public property string Property sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Property();

/** property */
public void set_Property(string value);
JScript
public function get Property() : String

public function set Property(value : String);

See Also

ResultColumnType Class


ResultColumnTypeCollection Class

ResultColumnTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ResultColumnTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ResultColumnTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ResultColumnTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ResultColumnTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ResultColumnTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ResultColumnTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResultColumnTypeCollection Members


ResultColumnTypeCollection Members

ResultColumnTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ResultColumnTypeCollection.

Public Constructors

 | Name | Description
Public method | ResultColumnTypeCollection | Initializes a new instance of the ResultColumnTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResultColumnTypeCollection Class


ResultColumnTypeCollection Constructor

ResultColumnTypeCollection Constructor
[image]

Initializes a new instance of the ResultColumnTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ResultColumnTypeCollection()
C++
public:
ResultColumnTypeCollection() sealed
J#
public ResultColumnTypeCollection()
JScript
public function ResultColumnTypeCollection()

See Also

ResultColumnTypeCollection Class


Properties

ResultColumnTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ResultColumnTypeCollection Class


Item Property

ResultColumnTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ResultColumnType
C#
public ResultColumnType this[
int idx
] { get; set; }
C++
public property ResultColumnType default[int idx] sealed {
ResultColumnType get(int idx);
void set(int idx, ResultColumnType value);
}
J#
/** property */
public ResultColumnType get_Item(int idx);

/** property */
public void set_Item(int idx, ResultColumnType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ResultColumnTypeCollection Class


Methods

ResultColumnTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ResultColumnTypeCollection Class


Add Method

ResultColumnTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ResultColumnType _
) As Integer
C#
public int Add(
ResultColumnType value
)
C++
public:
int Add(
ResultColumnType value
) sealed
J#
public int Add(
ResultColumnType value
)
JScript
public function Add(
value : ResultColumnType
) : int

See Also

ResultColumnTypeCollection Class


Role Class

Role Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class Role
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class Role
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class Role
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class Role
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class Role

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.Role

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Role Members


Role Members

Role Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by Role.

Public Constructors

 | Name | Description
Public method | Role | Initializes a new instance of the Role class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | Groups |
Public property | Users |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Role Class


Role Constructor

Role Constructor
[image]

Initializes a new instance of the Role class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Role()
C++
public:
Role() sealed
J#
public Role()
JScript
public function Role()

See Also

Role Class


Fields

Role Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

Role Class


SchemaName Field

Role.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

Role Class


Properties

Role Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | Groups |
Public property | Users |
Public property | XsdSchema |
Top

See Also

Role Class


Description Property

Role.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

Role Class


Groups Property

Role.Groups Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Groups As RoleGroups
C#
public RoleGroups Groups { get; set; }
C++
public property RoleGroups Groups sealed {
RoleGroups get();
void set(RoleGroups value);
}
J#
/** property */
public RoleGroups get_Groups();

/** property */
public void set_Groups(RoleGroups value);
JScript
public function get Groups() : RoleGroups

public function set Groups(value : RoleGroups);

See Also

Role Class


Users Property

Role.Users Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Users As RoleUsers
C#
public RoleUsers Users { get; set; }
C++
public property RoleUsers Users sealed {
RoleUsers get();
void set(RoleUsers value);
}
J#
/** property */
public RoleUsers get_Users();

/** property */
public void set_Users(RoleUsers value);
JScript
public function get Users() : RoleUsers

public function set Users(value : RoleUsers);

See Also

Role Class


XsdSchema Property

Role.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

Role Class


RoleGroups Class

RoleGroups Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RoleGroups
C#
public class RoleGroups
C++
ref class RoleGroups
J#
public class RoleGroups
JScript
public class RoleGroups

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RoleGroups

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RoleGroups Members


RoleGroups Members

RoleGroups Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RoleGroups.

Public Constructors

 | Name | Description
Public method | RoleGroups | Initializes a new instance of the RoleGroups class.
Top

Public Properties

 | Name | Description
Public property | Group |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RoleGroups Class


RoleGroups Constructor

RoleGroups Constructor
[image]

Initializes a new instance of the RoleGroups class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RoleGroups()
C++
public:
RoleGroups() sealed
J#
public RoleGroups()
JScript
public function RoleGroups()

See Also

RoleGroups Class


Properties

RoleGroups Properties
[image]

Public Properties

 | Name | Description
Public property | Group |
Top

See Also

RoleGroups Class


Group Property

RoleGroups.Group Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Group")>
Public Property Group As RoleGroupsGroupCollection
C#
[XmlElementAttribute("Group")]
public RoleGroupsGroupCollection Group { get; set; }
C++
[XmlElementAttribute(L"Group")]
public property RoleGroupsGroupCollection Group sealed {
RoleGroupsGroupCollection get();
void set(RoleGroupsGroupCollection value);
}
J#
/** @attribute XmlElementAttribute("Group") */
/** property */
public RoleGroupsGroupCollection get_Group();

/** property */
public void set_Group(RoleGroupsGroupCollection value);
JScript
public function get Group() : RoleGroupsGroupCollection

public function set Group(value : RoleGroupsGroupCollection);

See Also

RoleGroups Class


RoleGroupsGroup Class

RoleGroupsGroup Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RoleGroupsGroup
C#
public class RoleGroupsGroup
C++
ref class RoleGroupsGroup
J#
public class RoleGroupsGroup
JScript
public class RoleGroupsGroup

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RoleGroupsGroup

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RoleGroupsGroup Members


RoleGroupsGroup Members

RoleGroupsGroup Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RoleGroupsGroup.

Public Constructors

 | Name | Description
Public method | RoleGroupsGroup | Initializes a new instance of the RoleGroupsGroup class.
Top

Public Properties

 | Name | Description
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RoleGroupsGroup Class


RoleGroupsGroup Constructor

RoleGroupsGroup Constructor
[image]

Initializes a new instance of the RoleGroupsGroup class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RoleGroupsGroup()
C++
public:
RoleGroupsGroup() sealed
J#
public RoleGroupsGroup()
JScript
public function RoleGroupsGroup()

See Also

RoleGroupsGroup Class


Properties

RoleGroupsGroup Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Top

See Also

RoleGroupsGroup Class


Name Property

RoleGroupsGroup.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

RoleGroupsGroup Class


RoleGroupsGroupCollection Class

RoleGroupsGroupCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class RoleGroupsGroupCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class RoleGroupsGroupCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class RoleGroupsGroupCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class RoleGroupsGroupCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class RoleGroupsGroupCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.RoleGroupsGroupCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RoleGroupsGroupCollection Members


RoleGroupsGroupCollection Members

RoleGroupsGroupCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RoleGroupsGroupCollection.

Public Constructors

 | Name | Description
Public method | RoleGroupsGroupCollection | Initializes a new instance of the RoleGroupsGroupCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RoleGroupsGroupCollection Class


RoleGroupsGroupCollection Constructor

RoleGroupsGroupCollection Constructor
[image]

Initializes a new instance of the RoleGroupsGroupCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RoleGroupsGroupCollection()
C++
public:
RoleGroupsGroupCollection() sealed
J#
public RoleGroupsGroupCollection()
JScript
public function RoleGroupsGroupCollection()

See Also

RoleGroupsGroupCollection Class


Properties

RoleGroupsGroupCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

RoleGroupsGroupCollection Class


Item Property

RoleGroupsGroupCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As RoleGroupsGroup
C#
public RoleGroupsGroup this[
int idx
] { get; set; }
C++
public property RoleGroupsGroup default[int idx] sealed {
RoleGroupsGroup get(int idx);
void set(int idx, RoleGroupsGroup value);
}
J#
/** property */
public RoleGroupsGroup get_Item(int idx);

/** property */
public void set_Item(int idx, RoleGroupsGroup value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

RoleGroupsGroupCollection Class


Methods

RoleGroupsGroupCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RoleGroupsGroupCollection Class


Add Method

RoleGroupsGroupCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As RoleGroupsGroup _
) As Integer
C#
public int Add(
RoleGroupsGroup value
)
C++
public:
int Add(
RoleGroupsGroup value
) sealed
J#
public int Add(
RoleGroupsGroup value
)
JScript
public function Add(
value : RoleGroupsGroup
) : int

See Also

RoleGroupsGroupCollection Class


RoleUsers Class

RoleUsers Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RoleUsers
C#
public class RoleUsers
C++
ref class RoleUsers
J#
public class RoleUsers
JScript
public class RoleUsers

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RoleUsers

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RoleUsers Members


RoleUsers Members

RoleUsers Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RoleUsers.

Public Constructors

 | Name | Description
Public method | RoleUsers | Initializes a new instance of the RoleUsers class.
Top

Public Properties

 | Name | Description
Public property | User |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RoleUsers Class


RoleUsers Constructor

RoleUsers Constructor
[image]

Initializes a new instance of the RoleUsers class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RoleUsers()
C++
public:
RoleUsers() sealed
J#
public RoleUsers()
JScript
public function RoleUsers()

See Also

RoleUsers Class


Properties

RoleUsers Properties
[image]

Public Properties

 | Name | Description
Public property | User |
Top

See Also

RoleUsers Class


User Property

RoleUsers.User Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("User")>
Public Property User As RoleUsersUserCollection
C#
[XmlElementAttribute("User")]
public RoleUsersUserCollection User { get; set; }
C++
[XmlElementAttribute(L"User")]
public property RoleUsersUserCollection User sealed {
RoleUsersUserCollection get();
void set(RoleUsersUserCollection value);
}
J#
/** @attribute XmlElementAttribute("User") */
/** property */
public RoleUsersUserCollection get_User();

/** property */
public void set_User(RoleUsersUserCollection value);
JScript
public function get User() : RoleUsersUserCollection

public function set User(value : RoleUsersUserCollection);

See Also

RoleUsers Class


RoleUsersUser Class

RoleUsersUser Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RoleUsersUser
C#
public class RoleUsersUser
C++
ref class RoleUsersUser
J#
public class RoleUsersUser
JScript
public class RoleUsersUser

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RoleUsersUser

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RoleUsersUser Members


RoleUsersUser Members

RoleUsersUser Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RoleUsersUser.

Public Constructors

 | Name | Description
Public method | RoleUsersUser | Initializes a new instance of the RoleUsersUser class.
Top

Public Properties

 | Name | Description
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RoleUsersUser Class


RoleUsersUser Constructor

RoleUsersUser Constructor
[image]

Initializes a new instance of the RoleUsersUser class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RoleUsersUser()
C++
public:
RoleUsersUser() sealed
J#
public RoleUsersUser()
JScript
public function RoleUsersUser()

See Also

RoleUsersUser Class


Properties

RoleUsersUser Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Top

See Also

RoleUsersUser Class


Name Property

RoleUsersUser.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

RoleUsersUser Class


RoleUsersUserCollection Class

RoleUsersUserCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class RoleUsersUserCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class RoleUsersUserCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class RoleUsersUserCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class RoleUsersUserCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class RoleUsersUserCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.RoleUsersUserCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RoleUsersUserCollection Members


RoleUsersUserCollection Members

RoleUsersUserCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RoleUsersUserCollection.

Public Constructors

 | Name | Description
Public method | RoleUsersUserCollection | Initializes a new instance of the RoleUsersUserCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RoleUsersUserCollection Class


RoleUsersUserCollection Constructor

RoleUsersUserCollection Constructor
[image]

Initializes a new instance of the RoleUsersUserCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RoleUsersUserCollection()
C++
public:
RoleUsersUserCollection() sealed
J#
public RoleUsersUserCollection()
JScript
public function RoleUsersUserCollection()

See Also

RoleUsersUserCollection Class


Properties

RoleUsersUserCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

RoleUsersUserCollection Class


Item Property

RoleUsersUserCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As RoleUsersUser
C#
public RoleUsersUser this[
int idx
] { get; set; }
C++
public property RoleUsersUser default[int idx] sealed {
RoleUsersUser get(int idx);
void set(int idx, RoleUsersUser value);
}
J#
/** property */
public RoleUsersUser get_Item(int idx);

/** property */
public void set_Item(int idx, RoleUsersUser value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

RoleUsersUserCollection Class


Methods

RoleUsersUserCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RoleUsersUserCollection Class


Add Method

RoleUsersUserCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As RoleUsersUser _
) As Integer
C#
public int Add(
RoleUsersUser value
)
C++
public:
int Add(
RoleUsersUser value
) sealed
J#
public int Add(
RoleUsersUser value
)
JScript
public function Add(
value : RoleUsersUser
) : int

See Also

RoleUsersUserCollection Class


RowCollectionType Class

RowCollectionType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("RowSet", Namespace := "", IsNullable := False)>
Public Class RowCollectionType
C#
[XmlRootAttribute("RowSet", Namespace = "", IsNullable = False)]
public class RowCollectionType
C++
[XmlRootAttribute(L"RowSet", Namespace = L"", IsNullable = False)]
ref class RowCollectionType
J#
/** @attribute XmlRootAttribute("RowSet", Namespace = "", IsNullable = False) */
public class RowCollectionType
JScript
public
XmlRootAttribute("RowSet", Namespace = "", IsNullable = False)
class RowCollectionType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RowCollectionType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RowCollectionType Members


RowCollectionType Members

RowCollectionType Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by RowCollectionType.

Public Constructors

 | Name | Description
Public method | RowCollectionType | Initializes a new instance of the RowCollectionType class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | ColumnDefinitions |
Public property | Rows |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowCollectionType Class


RowCollectionType Constructor

RowCollectionType Constructor
[image]

Initializes a new instance of the RowCollectionType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RowCollectionType()
C++
public:
RowCollectionType() sealed
J#
public RowCollectionType()
JScript
public function RowCollectionType()

See Also

RowCollectionType Class


Fields

RowCollectionType Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

RowCollectionType Class


SchemaName Field

RowCollectionType.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

RowCollectionType Class


Properties

RowCollectionType Properties
[image]

Public Properties

 | Name | Description
Public property | ColumnDefinitions |
Public property | Rows |
Public property | XsdSchema |
Top

See Also

RowCollectionType Class


ColumnDefinitions Property

RowCollectionType.ColumnDefinitions Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Column", GetType(RowCollectionTypeColumnDefinitionsColumn), IsNullable := False)>
Public Property ColumnDefinitions As RowCollectionTypeColumnDefinitionsColumnCollection
C#
[XmlArrayItemAttribute("Column", typeof(RowCollectionTypeColumnDefinitionsColumn), IsNullable = False)]
public RowCollectionTypeColumnDefinitionsColumnCollection ColumnDefinitions { get; set; }
C++
[XmlArrayItemAttribute(L"Column", typeof(RowCollectionTypeColumnDefinitionsColumn), IsNullable = False)]
public property RowCollectionTypeColumnDefinitionsColumnCollection ColumnDefinitions sealed {
RowCollectionTypeColumnDefinitionsColumnCollection get();
void set(RowCollectionTypeColumnDefinitionsColumnCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Column", typeof(RowCollectionTypeColumnDefinitionsColumn), IsNullable = False) */
/** property */
public RowCollectionTypeColumnDefinitionsColumnCollection get_ColumnDefinitions();

/** property */
public void set_ColumnDefinitions(RowCollectionTypeColumnDefinitionsColumnCollection value);
JScript
public function get ColumnDefinitions() : RowCollectionTypeColumnDefinitionsColumnCollection

public function set ColumnDefinitions(value : RowCollectionTypeColumnDefinitionsColumnCollection);

See Also

RowCollectionType Class


Rows Property

RowCollectionType.Rows Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Row", IsNullable := False)>
Public Property Rows As RowCollectionTypeRowCollection
C#
[XmlArrayItemAttribute("Row", IsNullable = False)]
public RowCollectionTypeRowCollection Rows { get; set; }
C++
[XmlArrayItemAttribute(L"Row", IsNullable = False)]
public property RowCollectionTypeRowCollection Rows sealed {
RowCollectionTypeRowCollection get();
void set(RowCollectionTypeRowCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Row", IsNullable = False) */
/** property */
public RowCollectionTypeRowCollection get_Rows();

/** property */
public void set_Rows(RowCollectionTypeRowCollection value);
JScript
public function get Rows() : RowCollectionTypeRowCollection

public function set Rows(value : RowCollectionTypeRowCollection);

See Also

RowCollectionType Class


XsdSchema Property

RowCollectionType.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

RowCollectionType Class


RowCollectionTypeColumnDefinitionsColumn Class

RowCollectionTypeColumnDefinitionsColumn Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RowCollectionTypeColumnDefinitionsColumn
C#
public class RowCollectionTypeColumnDefinitionsColumn
C++
ref class RowCollectionTypeColumnDefinitionsColumn
J#
public class RowCollectionTypeColumnDefinitionsColumn
JScript
public class RowCollectionTypeColumnDefinitionsColumn

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeColumnDefinitionsColumn

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RowCollectionTypeColumnDefinitionsColumn Members


RowCollectionTypeColumnDefinitionsColumn Members

RowCollectionTypeColumnDefinitionsColumn Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RowCollectionTypeColumnDefinitionsColumn.

Public Constructors

 | Name | Description
Public method | RowCollectionTypeColumnDefinitionsColumn | Initializes a new instance of the RowCollectionTypeColumnDefinitionsColumn class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowCollectionTypeColumnDefinitionsColumn Class


RowCollectionTypeColumnDefinitionsColumn Constructor

RowCollectionTypeColumnDefinitionsColumn Constructor
[image]

Initializes a new instance of the RowCollectionTypeColumnDefinitionsColumn class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RowCollectionTypeColumnDefinitionsColumn()
C++
public:
RowCollectionTypeColumnDefinitionsColumn() sealed
J#
public RowCollectionTypeColumnDefinitionsColumn()
JScript
public function RowCollectionTypeColumnDefinitionsColumn()

See Also

RowCollectionTypeColumnDefinitionsColumn Class


Properties

RowCollectionTypeColumnDefinitionsColumn Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Type |
Top

See Also

RowCollectionTypeColumnDefinitionsColumn Class


Name Property

RowCollectionTypeColumnDefinitionsColumn.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

RowCollectionTypeColumnDefinitionsColumn Class


Type Property

RowCollectionTypeColumnDefinitionsColumn.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As RowCollectionTypeColumnDefinitionsColumnType
C#
public RowCollectionTypeColumnDefinitionsColumnType Type { get; set; }
C++
public property RowCollectionTypeColumnDefinitionsColumnType Type sealed {
RowCollectionTypeColumnDefinitionsColumnType get();
void set(RowCollectionTypeColumnDefinitionsColumnType value);
}
J#
/** property */
public RowCollectionTypeColumnDefinitionsColumnType get_Type();

/** property */
public void set_Type(RowCollectionTypeColumnDefinitionsColumnType value);
JScript
public function get Type() : RowCollectionTypeColumnDefinitionsColumnType

public function set Type(value : RowCollectionTypeColumnDefinitionsColumnType);

See Also

RowCollectionTypeColumnDefinitionsColumn Class


RowCollectionTypeColumnDefinitionsColumnCollection Class

RowCollectionTypeColumnDefinitionsColumnCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class RowCollectionTypeColumnDefinitionsColumnCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class RowCollectionTypeColumnDefinitionsColumnCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class RowCollectionTypeColumnDefinitionsColumnCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class RowCollectionTypeColumnDefinitionsColumnCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class RowCollectionTypeColumnDefinitionsColumnCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeColumnDefinitionsColumnCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RowCollectionTypeColumnDefinitionsColumnCollection Members


RowCollectionTypeColumnDefinitionsColumnCollection Members

RowCollectionTypeColumnDefinitionsColumnCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RowCollectionTypeColumnDefinitionsColumnCollection.

Public Constructors

 | Name | Description
Public method | RowCollectionTypeColumnDefinitionsColumnCollection | Initializes a new instance of the RowCollectionTypeColumnDefinitionsColumnCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowCollectionTypeColumnDefinitionsColumnCollection Class


RowCollectionTypeColumnDefinitionsColumnCollection Constructor

RowCollectionTypeColumnDefinitionsColumnCollection Constructor
See Also Example
[image]

Initializes a new instance of the RowCollectionTypeColumnDefinitionsColumnCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RowCollectionTypeColumnDefinitionsColumnCollection()
C++
public:
RowCollectionTypeColumnDefinitionsColumnCollection() sealed
J#
public RowCollectionTypeColumnDefinitionsColumnCollection()
JScript
public function RowCollectionTypeColumnDefinitionsColumnCollection()

See Also

RowCollectionTypeColumnDefinitionsColumnCollection Class


Properties

RowCollectionTypeColumnDefinitionsColumnCollection Properties
See Also Example
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

RowCollectionTypeColumnDefinitionsColumnCollection Class


Item Property

RowCollectionTypeColumnDefinitionsColumnCollection.Item Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As RowCollectionTypeColumnDefinitionsColumnCollection
C#
public RowCollectionTypeColumnDefinitionsColumnCollection this[
int idx
] { get; set; }
C++
public property RowCollectionTypeColumnDefinitionsColumnCollection default[int idx] sealed {
RowCollectionTypeColumnDefinitionsColumnCollection get(int idx);
void set(int idx, RowCollectionTypeColumnDefinitionsColumnCollection value);
}
J#
/** property */
public RowCollectionTypeColumnDefinitionsColumnCollection get_Item(int idx);

/** property */
public void set_Item(int idx, RowCollectionTypeColumnDefinitionsColumnCollection value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

RowCollectionTypeColumnDefinitionsColumnCollection Class


Methods

RowCollectionTypeColumnDefinitionsColumnCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowCollectionTypeColumnDefinitionsColumnCollection Class


Add Method

RowCollectionTypeColumnDefinitionsColumnCollection.Add Method
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As RowCollectionTypeColumnDefinitionsColumnCollection _
) As Integer
C#
public int Add(
RowCollectionTypeColumnDefinitionsColumnCollection value
)
C++
public:
int Add(
RowCollectionTypeColumnDefinitionsColumnCollection value
) sealed
J#
public int Add(
RowCollectionTypeColumnDefinitionsColumnCollection value
)
JScript
public function Add(
value : RowCollectionTypeColumnDefinitionsColumnCollection
) : int

See Also

RowCollectionTypeColumnDefinitionsColumnCollection Class


RowCollectionTypeColumnDefinitionsColumnType Enumeration

RowCollectionTypeColumnDefinitionsColumnType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum RowCollectionTypeColumnDefinitionsColumnType
C#
public enum RowCollectionTypeColumnDefinitionsColumnType
C++
public enum class RowCollectionTypeColumnDefinitionsColumnType
J#
public enum RowCollectionTypeColumnDefinitionsColumnType
JScript
public enum RowCollectionTypeColumnDefinitionsColumnType

Members

Member Name | Description
boolean |
byte |
datetime |
decimal |
double |
int16 |
int32 |
int64 |
single |
string |
blob |
clob |
uniqueId |

See Also


RowCollectionTypeRow Class

RowCollectionTypeRow Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RowCollectionTypeRow
Inherits RowType
C#
public class RowCollectionTypeRow : RowType
C++
ref class RowCollectionTypeRow : RowType
J#
public class RowCollectionTypeRow extends RowType
JScript
public class RowCollectionTypeRow extends RowType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RowType
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeRow

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RowCollectionTypeRow Members


RowCollectionTypeRow Members

RowCollectionTypeRow Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RowCollectionTypeRow.

Public Constructors

 | Name | Description
Public method | RowCollectionTypeRow | Initializes a new instance of the RowCollectionTypeRow class.
Top

Public Properties

 | Name | Description
Public property | Column |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowCollectionTypeRow Class


RowCollectionTypeRow Constructor

RowCollectionTypeRow Constructor
[image]

Initializes a new instance of the RowCollectionTypeRow class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RowCollectionTypeRow()
C++
public:
RowCollectionTypeRow() sealed
J#
public RowCollectionTypeRow()
JScript
public function RowCollectionTypeRow()

See Also

RowCollectionTypeRow Class


Properties

RowCollectionTypeRow Properties
[image]

Public Properties

 | Name | Description
Public property | Column |
Top

See Also

RowCollectionTypeRow Class


Column Property

RowCollectionTypeRow.Column Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Column")>
Public Property Column As RowCollectionTypeRowColumnCollection
C#
[XmlElementAttribute("Column")]
public RowCollectionTypeRowColumnCollection Column { get; set; }
C++
[XmlElementAttribute(L"Column")]
public property RowCollectionTypeRowColumnCollection Column sealed {
RowCollectionTypeRowColumnCollection get();
void set(RowCollectionTypeRowColumnCollection value);
}
J#
/** @attribute XmlElementAttribute("Column") */
/** property */
public RowCollectionTypeRowColumnCollection get_Column();

/** property */
public void set_Column(RowCollectionTypeRowColumnCollection value);
JScript
public function get Column() : RowCollectionTypeRowColumnCollection

public function set Column(value : RowCollectionTypeRowColumnCollection);

See Also

RowCollectionTypeRow Class


RowCollectionTypeRowCollection Class

RowCollectionTypeRowCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class RowCollectionTypeRowCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class RowCollectionTypeRowCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class RowCollectionTypeRowCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class RowCollectionTypeRowCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class RowCollectionTypeRowCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeRowCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RowCollectionTypeRowCollection Members


RowCollectionTypeRowCollection Members

RowCollectionTypeRowCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RowCollectionTypeRowCollection.

Public Constructors

 | Name | Description
Public method | RowCollectionTypeRowCollection | Initializes a new instance of the RowCollectionTypeRowCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowCollectionTypeRowCollection Class


RowCollectionTypeRowCollection Constructor

RowCollectionTypeRowCollection Constructor
[image]

Initializes a new instance of the RowCollectionTypeRowCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RowCollectionTypeRowCollection()
C++
public:
RowCollectionTypeRowCollection() sealed
J#
public RowCollectionTypeRowCollection()
JScript
public function RowCollectionTypeRowCollection()

See Also

RowCollectionTypeRowCollection Class


Properties

RowCollectionTypeRowCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

RowCollectionTypeRowCollection Class


Item Property

RowCollectionTypeRowCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As RowCollectionTypeRow
C#
public RowCollectionTypeRow this[
int idx
] { get; set; }
C++
public property RowCollectionTypeRow default[int idx] sealed {
RowCollectionTypeRow get(int idx);
void set(int idx, RowCollectionTypeRow value);
}
J#
/** property */
public RowCollectionTypeRow get_Item(int idx);

/** property */
public void set_Item(int idx, RowCollectionTypeRow value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

RowCollectionTypeRowCollection Class


Methods

RowCollectionTypeRowCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowCollectionTypeRowCollection Class


Add Method

RowCollectionTypeRowCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As RowCollectionTypeRow _
) As Integer
C#
public int Add(
RowCollectionTypeRow value
)
C++
public:
int Add(
RowCollectionTypeRow value
) sealed
J#
public int Add(
RowCollectionTypeRow value
)
JScript
public function Add(
value : RowCollectionTypeRow
) : int

See Also

RowCollectionTypeRowCollection Class


RowCollectionTypeRowColumn Class

RowCollectionTypeRowColumn Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RowCollectionTypeRowColumn
C#
public class RowCollectionTypeRowColumn
C++
ref class RowCollectionTypeRowColumn
J#
public class RowCollectionTypeRowColumn
JScript
public class RowCollectionTypeRowColumn

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeRowColumn

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RowCollectionTypeRowColumn Members


RowCollectionTypeRowColumn Members

RowCollectionTypeRowColumn Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RowCollectionTypeRowColumn.

Public Constructors

 | Name | Description
Public method | RowCollectionTypeRowColumn | Initializes a new instance of the RowCollectionTypeRowColumn class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Value |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowCollectionTypeRowColumn Class


RowCollectionTypeRowColumn Constructor

RowCollectionTypeRowColumn Constructor
[image]

Initializes a new instance of the RowCollectionTypeRowColumn class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RowCollectionTypeRowColumn()
C++
public:
RowCollectionTypeRowColumn() sealed
J#
public RowCollectionTypeRowColumn()
JScript
public function RowCollectionTypeRowColumn()

See Also

RowCollectionTypeRowColumn Class


Properties

RowCollectionTypeRowColumn Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Value |
Top

See Also

RowCollectionTypeRowColumn Class


Name Property

RowCollectionTypeRowColumn.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As RowCollectionTypeRowColumnName
C#
public RowCollectionTypeRowColumnName Name { get; set; }
C++
public property RowCollectionTypeRowColumnName Name sealed {
RowCollectionTypeRowColumnName get();
void set(RowCollectionTypeRowColumnName value);
}
J#
/** property */
public RowCollectionTypeRowColumnName get_Name();

/** property */
public void set_Name(RowCollectionTypeRowColumnName value);
JScript
public function get Name() : RowCollectionTypeRowColumnName

public function set Name(value : RowCollectionTypeRowColumnName);

See Also

RowCollectionTypeRowColumn Class


Value Property

RowCollectionTypeRowColumn.Value Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
C++
public property string Value sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

RowCollectionTypeRowColumn Class


RowCollectionTypeRowColumnCollection Class

RowCollectionTypeRowColumnCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class RowCollectionTypeRowColumnCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class RowCollectionTypeRowColumnCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class RowCollectionTypeRowColumnCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class RowCollectionTypeRowColumnCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class RowCollectionTypeRowColumnCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeRowColumnCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RowCollectionTypeRowColumnCollection Members


RowCollectionTypeRowColumnCollection Members

RowCollectionTypeRowColumnCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RowCollectionTypeRowColumnCollection.

Public Constructors

 | Name | Description
Public method | RowCollectionTypeRowColumnCollection | Initializes a new instance of the RowCollectionTypeRowColumnCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowCollectionTypeRowColumnCollection Class


RowCollectionTypeRowColumnCollection Constructor

RowCollectionTypeRowColumnCollection Constructor
[image]

Initializes a new instance of the RowCollectionTypeRowColumnCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RowCollectionTypeRowColumnCollection()
C++
public:
RowCollectionTypeRowColumnCollection() sealed
J#
public RowCollectionTypeRowColumnCollection()
JScript
public function RowCollectionTypeRowColumnCollection()

See Also

RowCollectionTypeRowColumnCollection Class


Properties

RowCollectionTypeRowColumnCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

RowCollectionTypeRowColumnCollection Class


Item Property

RowCollectionTypeRowColumnCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As RowCollectionTypeRowColumn
C#
public RowCollectionTypeRowColumn this[
int idx
] { get; set; }
C++
public property RowCollectionTypeRowColumn default[int idx] sealed {
RowCollectionTypeRowColumn get(int idx);
void set(int idx, RowCollectionTypeRowColumn value);
}
J#
/** property */
public RowCollectionTypeRowColumn get_Item(int idx);

/** property */
public void set_Item(int idx, RowCollectionTypeRowColumn value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

RowCollectionTypeRowColumnCollection Class


Methods

RowCollectionTypeRowColumnCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowCollectionTypeRowColumnCollection Class


Add Method

RowCollectionTypeRowColumnCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As RowCollectionTypeRowColumn _
) As Integer
C#
public int Add(
RowCollectionTypeRowColumn value
)
C++
public:
int Add(
RowCollectionTypeRowColumn value
) sealed
J#
public int Add(
RowCollectionTypeRowColumn value
)
JScript
public function Add(
value : RowCollectionTypeRowColumn
) : int

See Also

RowCollectionTypeRowColumnCollection Class


RowCollectionTypeRowColumnName Class

RowCollectionTypeRowColumnName Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RowCollectionTypeRowColumnName
C#
public class RowCollectionTypeRowColumnName
C++
ref class RowCollectionTypeRowColumnName
J#
public class RowCollectionTypeRowColumnName
JScript
public class RowCollectionTypeRowColumnName

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeRowColumnName

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RowCollectionTypeRowColumnName Members


RowCollectionTypeRowColumnName Members

RowCollectionTypeRowColumnName Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RowCollectionTypeRowColumnName.

Public Constructors

 | Name | Description
Public method | RowCollectionTypeRowColumnName | Initializes a new instance of the RowCollectionTypeRowColumnName class.
Top

Public Properties

 | Name | Description
Public property | Value |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowCollectionTypeRowColumnName Class


RowCollectionTypeRowColumnName Constructor

RowCollectionTypeRowColumnName Constructor
[image]

Initializes a new instance of the RowCollectionTypeRowColumnName class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RowCollectionTypeRowColumnName()
C++
public:
RowCollectionTypeRowColumnName() sealed
J#
public RowCollectionTypeRowColumnName()
JScript
public function RowCollectionTypeRowColumnName()

See Also

RowCollectionTypeRowColumnName Class


Properties

RowCollectionTypeRowColumnName Properties
[image]

Public Properties

 | Name | Description
Public property | Value |
Top

See Also

RowCollectionTypeRowColumnName Class


Value Property

RowCollectionTypeRowColumnName.Value Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlTextAttribute>
Public Property Value As String
C#
[XmlTextAttribute]
public string Value { get; set; }
C++
[XmlTextAttribute]
public property string Value sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlTextAttribute() */
/** property */
public string get_Value();

/** property */
public void set_Value(string value);
JScript
public function get Value() : String

public function set Value(value : String);

See Also

RowCollectionTypeRowColumnName Class


RowType Class

RowType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(RowCollectionTypeRow))>
Public Class RowType
C#
[XmlIncludeAttribute(typeof(RowCollectionTypeRow))]
public class RowType
C++
[XmlIncludeAttribute(typeof(RowCollectionTypeRow))]
ref class RowType
J#
/** @attribute XmlIncludeAttribute(typeof(RowCollectionTypeRow)) */
public class RowType
JScript
public
XmlIncludeAttribute(typeof(RowCollectionTypeRow))
class RowType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RowType
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeRow

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RowType Members


RowType Members

RowType Members
See Also Example Constructors Methods
[image]

The following tables list the members exposed by RowType.

Public Constructors

 | Name | Description
Public method | RowType | Initializes a new instance of the RowType class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RowType Class


RowType Constructor

RowType Constructor
[image]

Initializes a new instance of the RowType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RowType()
C++
public:
RowType() sealed
J#
public RowType()
JScript
public function RowType()

See Also

RowType Class


SdfKeyTreatmentType Enumeration

SdfKeyTreatmentType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SdfKeyTreatmentType
C#
public enum SdfKeyTreatmentType
C++
public enum class SdfKeyTreatmentType
J#
public enum SdfKeyTreatmentType
JScript
public enum SdfKeyTreatmentType

Members

Member Name | Description
AutogenerateAll |
DiscardDuplicates |
MergeDuplicates |

See Also


SdfLoadProcedureType Class

SdfLoadProcedureType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SdfLoadProcedureType
Inherits LoadProcedureType
C#
public class SdfLoadProcedureType : LoadProcedureType
C++
ref class SdfLoadProcedureType : LoadProcedureType
J#
public class SdfLoadProcedureType extends LoadProcedureType
JScript
public class SdfLoadProcedureType extends LoadProcedureType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LoadProcedureType
OSGeo.MapGuide.MaestroAPI.SdfLoadProcedureType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SdfLoadProcedureType Members


SdfLoadProcedureType Members

SdfLoadProcedureType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SdfLoadProcedureType.

Public Constructors

 | Name | Description
Public method | SdfLoadProcedureType | Initializes a new instance of the SdfLoadProcedureType class.
Top

Public Properties

 | Name | Description
Public property | CoordinateSystem | (inherited from LoadProcedureType)
Public property | Generalization |
Public property | GenerateLayers | (inherited from LoadProcedureType)
Public property | GenerateMaps | (inherited from LoadProcedureType)
Public property | GenerateMapsSpecified | (inherited from LoadProcedureType)
Public property | GenerateSpatialDataSources | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibraries | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibrariesSpecified | (inherited from LoadProcedureType)
Public property | LayersFolder | (inherited from LoadProcedureType)
Public property | LayersPath | (inherited from LoadProcedureType)
Public property | MapsFolder | (inherited from LoadProcedureType)
Public property | MapsPath | (inherited from LoadProcedureType)
Public property | ResourceId | (inherited from LoadProcedureType)
Public property | RootPath | (inherited from LoadProcedureType)
Public property | SdfKeyTreatment |
Public property | SourceFile | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesFolder | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesPath | (inherited from LoadProcedureType)
Public property | SymbolLibrariesFolder | (inherited from LoadProcedureType)
Public property | SymbolLibrariesPath | (inherited from LoadProcedureType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SdfLoadProcedureType Class


SdfLoadProcedureType Constructor

SdfLoadProcedureType Constructor
[image]

Initializes a new instance of the SdfLoadProcedureType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SdfLoadProcedureType()
C++
public:
SdfLoadProcedureType() sealed
J#
public SdfLoadProcedureType()
JScript
public function SdfLoadProcedureType()

See Also

SdfLoadProcedureType Class


Properties

SdfLoadProcedureType Properties
[image]

Public Properties

 | Name | Description
Public property | CoordinateSystem | (inherited from LoadProcedureType)
Public property | Generalization |
Public property | GenerateLayers | (inherited from LoadProcedureType)
Public property | GenerateMaps | (inherited from LoadProcedureType)
Public property | GenerateMapsSpecified | (inherited from LoadProcedureType)
Public property | GenerateSpatialDataSources | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibraries | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibrariesSpecified | (inherited from LoadProcedureType)
Public property | LayersFolder | (inherited from LoadProcedureType)
Public property | LayersPath | (inherited from LoadProcedureType)
Public property | MapsFolder | (inherited from LoadProcedureType)
Public property | MapsPath | (inherited from LoadProcedureType)
Public property | ResourceId | (inherited from LoadProcedureType)
Public property | RootPath | (inherited from LoadProcedureType)
Public property | SdfKeyTreatment |
Public property | SourceFile | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesFolder | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesPath | (inherited from LoadProcedureType)
Public property | SymbolLibrariesFolder | (inherited from LoadProcedureType)
Public property | SymbolLibrariesPath | (inherited from LoadProcedureType)
Top

See Also

SdfLoadProcedureType Class


Generalization Property

SdfLoadProcedureType.Generalization Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Generalization As Double
C#
public double Generalization { get; set; }
C++
public property double Generalization sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Generalization();

/** property */
public void set_Generalization(double value);
JScript
public function get Generalization() : double

public function set Generalization(value : double);

See Also

SdfLoadProcedureType Class


SdfKeyTreatment Property

SdfLoadProcedureType.SdfKeyTreatment Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SdfKeyTreatment As SdfKeyTreatmentType
C#
public SdfKeyTreatmentType SdfKeyTreatment { get; set; }
C++
public property SdfKeyTreatmentType SdfKeyTreatment sealed {
SdfKeyTreatmentType get();
void set(SdfKeyTreatmentType value);
}
J#
/** property */
public SdfKeyTreatmentType get_SdfKeyTreatment();

/** property */
public void set_SdfKeyTreatment(SdfKeyTreatmentType value);
JScript
public function get SdfKeyTreatment() : SdfKeyTreatmentType

public function set SdfKeyTreatment(value : SdfKeyTreatmentType);

See Also

SdfLoadProcedureType Class


SearchCommandType Class

SearchCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SearchCommandType
Inherits TargetedCommandType
C#
public class SearchCommandType : TargetedCommandType
C++
ref class SearchCommandType : TargetedCommandType
J#
public class SearchCommandType extends TargetedCommandType
JScript
public class SearchCommandType extends TargetedCommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.TargetedCommandType
OSGeo.MapGuide.MaestroAPI.SearchCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SearchCommandType Members


SearchCommandType Members

SearchCommandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SearchCommandType.

Public Constructors

 | Name | Description
Public method | SearchCommandType | Initializes a new instance of the SearchCommandType class.
Top

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | Filter |
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Layer |
Public property | MatchLimit |
Public property | Name | (inherited from CommandType)
Public property | Prompt |
Public property | ResultColumns |
Public property | Target | (inherited from TargetedCommandType)
Public property | TargetFrame | (inherited from TargetedCommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SearchCommandType Class


SearchCommandType Constructor

SearchCommandType Constructor
[image]

Initializes a new instance of the SearchCommandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SearchCommandType()
C++
public:
SearchCommandType() sealed
J#
public SearchCommandType()
JScript
public function SearchCommandType()

See Also

SearchCommandType Class


Properties

SearchCommandType Properties
[image]

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | Filter |
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Layer |
Public property | MatchLimit |
Public property | Name | (inherited from CommandType)
Public property | Prompt |
Public property | ResultColumns |
Public property | Target | (inherited from TargetedCommandType)
Public property | TargetFrame | (inherited from TargetedCommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

See Also

SearchCommandType Class


Filter Property

SearchCommandType.Filter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; set; }
C++
public property string Filter sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Filter();

/** property */
public void set_Filter(string value);
JScript
public function get Filter() : String

public function set Filter(value : String);

See Also

SearchCommandType Class


Layer Property

SearchCommandType.Layer Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Layer As String
C#
public string Layer { get; set; }
C++
public property string Layer sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Layer();

/** property */
public void set_Layer(string value);
JScript
public function get Layer() : String

public function set Layer(value : String);

See Also

SearchCommandType Class


MatchLimit Property

SearchCommandType.MatchLimit Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property MatchLimit As String
C#
[XmlElementAttribute(DataType = "integer")]
public string MatchLimit { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string MatchLimit sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_MatchLimit();

/** property */
public void set_MatchLimit(string value);
JScript
public function get MatchLimit() : String

public function set MatchLimit(value : String);

See Also

SearchCommandType Class


Prompt Property

SearchCommandType.Prompt Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Prompt As String
C#
public string Prompt { get; set; }
C++
public property string Prompt sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Prompt();

/** property */
public void set_Prompt(string value);
JScript
public function get Prompt() : String

public function set Prompt(value : String);

See Also

SearchCommandType Class


ResultColumns Property

SearchCommandType.ResultColumns Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Column", IsNullable := False)>
Public Property ResultColumns As ResultColumnTypeCollection
C#
[XmlArrayItemAttribute("Column", IsNullable = False)]
public ResultColumnTypeCollection ResultColumns { get; set; }
C++
[XmlArrayItemAttribute(L"Column", IsNullable = False)]
public property ResultColumnTypeCollection ResultColumns sealed {
ResultColumnTypeCollection get();
void set(ResultColumnTypeCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Column", IsNullable = False) */
/** property */
public ResultColumnTypeCollection get_ResultColumns();

/** property */
public void set_ResultColumns(ResultColumnTypeCollection value);
JScript
public function get ResultColumns() : ResultColumnTypeCollection

public function set ResultColumns(value : ResultColumnTypeCollection);

See Also

SearchCommandType Class


SelectWithinCommandType Class

SelectWithinCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SelectWithinCommandType
Inherits TargetedCommandType
C#
public class SelectWithinCommandType : TargetedCommandType
C++
ref class SelectWithinCommandType : TargetedCommandType
J#
public class SelectWithinCommandType extends TargetedCommandType
JScript
public class SelectWithinCommandType extends TargetedCommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.TargetedCommandType
OSGeo.MapGuide.MaestroAPI.SelectWithinCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SelectWithinCommandType Members


SelectWithinCommandType Members

SelectWithinCommandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SelectWithinCommandType.

Public Constructors

 | Name | Description
Public method | SelectWithinCommandType | Initializes a new instance of the SelectWithinCommandType class.
Top

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | Target | (inherited from TargetedCommandType)
Public property | TargetFrame | (inherited from TargetedCommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SelectWithinCommandType Class


SelectWithinCommandType Constructor

SelectWithinCommandType Constructor
[image]

Initializes a new instance of the SelectWithinCommandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SelectWithinCommandType()
C++
public:
SelectWithinCommandType() sealed
J#
public SelectWithinCommandType()
JScript
public function SelectWithinCommandType()

See Also

SelectWithinCommandType Class


SeparatorItemType Class

SeparatorItemType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SeparatorItemType
Inherits UIItemType
C#
public class SeparatorItemType : UIItemType
C++
ref class SeparatorItemType : UIItemType
J#
public class SeparatorItemType extends UIItemType
JScript
public class SeparatorItemType extends UIItemType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.UIItemType
OSGeo.MapGuide.MaestroAPI.SeparatorItemType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SeparatorItemType Members


SeparatorItemType Members

SeparatorItemType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SeparatorItemType.

Public Constructors

 | Name | Description
Public method | SeparatorItemType | Initializes a new instance of the SeparatorItemType class.
Top

Public Properties

 | Name | Description
Public property | Function | (inherited from UIItemType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SeparatorItemType Class


SeparatorItemType Constructor

SeparatorItemType Constructor
[image]

Initializes a new instance of the SeparatorItemType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SeparatorItemType()
C++
public:
SeparatorItemType() sealed
J#
public SeparatorItemType()
JScript
public function SeparatorItemType()

See Also

SeparatorItemType Class


ServerConnectionBase Class

ServerConnectionBase Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ServerConnectionBase
C#
public abstract class ServerConnectionBase
C++
ref class ServerConnectionBase abstract
J#
public class ServerConnectionBase
JScript
public class ServerConnectionBase

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ServerConnectionBase
OSGeo.MapGuide.MaestroAPI.HttpServerConnection
OSGeo.MapGuide.MaestroAPI.LocalNativeConnection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ServerConnectionBase Members


ServerConnectionBase Members

ServerConnectionBase Members
See Also Example Properties Methods
[image]

The following tables list the members exposed by ServerConnectionBase.

Public Properties

 | Name | Description
Public property | AutoRestartSession | Gets or sets a value indicating if the session should automatically be restarted if it expires
Public property | CachedSchemas | Gets or sets the collection of cached schemas. Use the object type for key, and an XmlSchema instance for value.
Public property | DisableValidation | Gets or sets a flag that indicates if the Xml resources are validated before leaving and entering the server.
Public property | FeatureProviders | Gets a list of installed feature providers
Public property | MaxTestedVersion | Gets the highest version the API is currently tested againts
Public property | ResourceTypeLookup | Gets or sets a hashtable where the key is resourceID extensions, and values are System.Type values.
Public property | SessionID | Gets the current SessionID.
Public property | SiteVersion |
Top

Public Methods

 | Name | Description
Public method | CopyFolder | Copies a folder and all its content. This does not update any references.
Public method | CopyFolderWithReferences | Copies folder, and subsequently updates all resources within the folder to use the new folder path instead of the originating one.
Public method | CopyResource | Copies a resource from one location to another. This does not update any references.
Public method | CreateFolder | Creates a folder on the server
Public method | CreateRuntimeMap | Overloaded. Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.
Public method | DeleteResource |
Public method | DescribeFeatureSource | Overloaded.
Public method | DeserializeObject | Overloaded. Deserializes an object from a stream.
Public method | Dispose |
Public method | EnumerateGroups | Gets a list of all groups on the server
Public method | EnumerateResourceReferences | Enumereates all references to a given resource
Public method | EnumerateUnmanagedData | Enumerates all unmanaged folders, meaning alias'ed folders
Public method | EnumerateUsers | Overloaded. Gets a list of all users on the server
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetApplicationContainers | Returns the avalible widget containers on the server
Public method | GetApplicationDefinition | Returns a ApplicationDefinition from the server.
Public method | GetApplicationTemplates | Returns the avalible application templates on the server
Public method | GetApplicationWidgets | Returns the avalible application widgets on the server
Public method | GetFeatureProvider | Returns an installed provider, given the name of the provider
Public method | GetFeatureSource | Returns a FeatureSource from the server.
Public method | GetFeatureSourceDescription |
Public method | GetFeatureSourceSchema |
Public method | GetFolderHeader |
Public method | GetFolderOrResourceHeader |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetIdentityProperties | Gets the names of the identity properties from a feature
Public method | GetLayerDefinition | Returns a LayerDefinition from the server.
Public method | GetLegendImage | Renders a minature bitmap of the layers style
Public method | GetMapDefinition | Returns a MapDefinition from the server.
Public method | GetRepositoryResources | Overloaded. Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly.
Public method | GetResource | Returns an object deserialized from server data. Uses the ResourceID to infer the object type.
Public method | GetResourceData | Returns data from a resource as a memorystream
Public method | GetResourceHeader |
Public method | GetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types.
Public method | GetResourceXmlData | Returns raw data from the server a byte array
Public method | GetSelectionXml | Gets the selection from a map
Public method | GetSpatialContextInfo | Returns the spatial info for a given featuresource
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetWebLayout | Returns a WebLayout from the server.
Public method | HasFolder | Returns a value indicating if a given folder exists
Public method | IsSessionExpiredException | Determines if an exception is a "Session Expired" exception.
Public method | MoveFolder | Moves a folder and its content from one location to another. This does not update any references.
Public method | MoveFolderWithReferences | Moves a folder, and subsequently updates all resources pointing to the old resource path
Public method | MoveResource | Moves a resource from one location to another. This does not update any references.
Public method | MoveResourceWithReferences | Moves a resource, and subsequently updates all resources pointing to the old resource path
Public method | QueryMapFeatures | Overloaded. Selects features from a runtime map, returning a selection Xml.
Public method | RemoveVersionFromProviderName | Removes the version numbers from a providername
Public method | ResetFeatureSourceSchemaCache |
Public method | ResourceExists | Returns a boolean indicating if a given resource exists
Public method | RestartSession | Overloaded. Restarts the server session, and creates a new session ID
Public method | SaveResource | Overloaded. Saves a FeatureSource, using its originating resourceId
Public method | SaveResourceAs | Overloaded. Saves a FeatureSource under a different resourceID
Public method | SerializeObject | Overloaded. Serialize an object into a new memory stream.
Public method | SetFolderHeader |
Public method | SetFolderOrResourceHeader |
Public method | SetResourceData | Overloaded. Uploads data to a resource
Public method | SetResourceHeader |
Public method | SetResourceXmlData | Overloaded. Writes raw data into a resource.
Public method | SetSelectionXml | Sets the selection of a map
Public method | TestConnection | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types.
Public method | UpdateResourceReferences | Updates all resource references inside an object.
Public method | UploadPackage | Upload a MapGuide Package file to the server
Public method | WriteResource | Writes an object into a resourceID
Top

See Also

ServerConnectionBase Class


Properties

ServerConnectionBase Properties
[image]

Public Properties

 | Name | Description
Public property | AutoRestartSession | Gets or sets a value indicating if the session should automatically be restarted if it expires
Public property | CachedSchemas | Gets or sets the collection of cached schemas. Use the object type for key, and an XmlSchema instance for value.
Public property | DisableValidation | Gets or sets a flag that indicates if the Xml resources are validated before leaving and entering the server.
Public property | FeatureProviders | Gets a list of installed feature providers
Public property | MaxTestedVersion | Gets the highest version the API is currently tested againts
Public property | ResourceTypeLookup | Gets or sets a hashtable where the key is resourceID extensions, and values are System.Type values.
Public property | SessionID | Gets the current SessionID.
Public property | SiteVersion |
Top

See Also

ServerConnectionBase Class


AutoRestartSession Property

ServerConnectionBase.AutoRestartSession Property
[image]

Gets or sets a value indicating if the session should automatically be restarted if it expires

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property AutoRestartSession As Boolean
C#
public virtual bool AutoRestartSession { get; set; }
C++
public virtual property bool AutoRestartSession {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AutoRestartSession();

/** property */
public void set_AutoRestartSession(bool value);
JScript
public function get AutoRestartSession() : bool

public function set AutoRestartSession(value : bool);

See Also

ServerConnectionBase Class


CachedSchemas Property

ServerConnectionBase.CachedSchemas Property
[image]

Gets or sets the collection of cached schemas. Use the object type for key, and an XmlSchema instance for value.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CachedSchemas As Hashtable
C#
public virtual Hashtable CachedSchemas { get; set; }
C++
public virtual property Hashtable CachedSchemas {
Hashtable get();
void set(Hashtable value);
}
J#
/** property */
public Hashtable get_CachedSchemas();

/** property */
public void set_CachedSchemas(Hashtable value);
JScript
public function get CachedSchemas() : Hashtable

public function set CachedSchemas(value : Hashtable);

See Also

ServerConnectionBase Class


DisableValidation Property

ServerConnectionBase.DisableValidation Property
[image]

Gets or sets a flag that indicates if the Xml resources are validated before leaving and entering the server.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisableValidation As Boolean
C#
public bool DisableValidation { get; set; }
C++
public property bool DisableValidation sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DisableValidation();

/** property */
public void set_DisableValidation(bool value);
JScript
public function get DisableValidation() : bool

public function set DisableValidation(value : bool);

See Also

ServerConnectionBase Class


FeatureProviders Property

ServerConnectionBase.FeatureProviders Property
[image]

Gets a list of installed feature providers

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property FeatureProviders As FeatureProviderRegistryFeatureProviderCollection
C#
public abstract FeatureProviderRegistryFeatureProviderCollection FeatureProviders { get; }
C++
public abstract property FeatureProviderRegistryFeatureProviderCollection FeatureProviders abstract {
FeatureProviderRegistryFeatureProviderCollection get();
}
J#
/** property */
public FeatureProviderRegistryFeatureProviderCollection get_FeatureProviders();
JScript
public function get FeatureProviders() : FeatureProviderRegistryFeatureProviderCollection

See Also

ServerConnectionBase Class


MaxTestedVersion Property

ServerConnectionBase.MaxTestedVersion Property
[image]

Gets the highest version the API is currently tested againts

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property MaxTestedVersion As Version
C#
public virtual Version MaxTestedVersion { get; }
C++
public virtual property Version MaxTestedVersion {
Version get();
}
J#
/** property */
public Version get_MaxTestedVersion();
JScript
public function get MaxTestedVersion() : Version

See Also

ServerConnectionBase Class


ResourceTypeLookup Property

ServerConnectionBase.ResourceTypeLookup Property
[image]

Gets or sets a hashtable where the key is resourceID extensions, and values are System.Type values.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ResourceTypeLookup As Hashtable
C#
public virtual Hashtable ResourceTypeLookup { get; set; }
C++
public virtual property Hashtable ResourceTypeLookup {
Hashtable get();
void set(Hashtable value);
}
J#
/** property */
public Hashtable get_ResourceTypeLookup();

/** property */
public void set_ResourceTypeLookup(Hashtable value);
JScript
public function get ResourceTypeLookup() : Hashtable

public function set ResourceTypeLookup(value : Hashtable);

See Also

ServerConnectionBase Class


SessionID Property

ServerConnectionBase.SessionID Property
[image]

Gets the current SessionID.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property SessionID As String
C#
public abstract string SessionID { get; }
C++
public abstract property string SessionID abstract {
String get();
}
J#
/** property */
public string get_SessionID();
JScript
public function get SessionID() : String

See Also

ServerConnectionBase Class


SiteVersion Property

ServerConnectionBase.SiteVersion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property SiteVersion As Version
C#
public abstract Version SiteVersion { get; }
C++
public abstract property Version SiteVersion abstract {
Version get();
}
J#
/** property */
public Version get_SiteVersion();
JScript
public function get SiteVersion() : Version

See Also

ServerConnectionBase Class


Methods

ServerConnectionBase Methods
[image]

Public Methods

 | Name | Description
Public method | CopyFolder | Copies a folder and all its content. This does not update any references.
Public method | CopyFolderWithReferences | Copies folder, and subsequently updates all resources within the folder to use the new folder path instead of the originating one.
Public method | CopyResource | Copies a resource from one location to another. This does not update any references.
Public method | CreateFolder | Creates a folder on the server
Public method | CreateRuntimeMap | Overloaded. Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.
Public method | DeleteResource |
Public method | DescribeFeatureSource | Overloaded.
Public method | DeserializeObject | Overloaded. Deserializes an object from a stream.
Public method | Dispose |
Public method | EnumerateGroups | Gets a list of all groups on the server
Public method | EnumerateResourceReferences | Enumereates all references to a given resource
Public method | EnumerateUnmanagedData | Enumerates all unmanaged folders, meaning alias'ed folders
Public method | EnumerateUsers | Overloaded. Gets a list of all users on the server
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetApplicationContainers | Returns the avalible widget containers on the server
Public method | GetApplicationDefinition | Returns a ApplicationDefinition from the server.
Public method | GetApplicationTemplates | Returns the avalible application templates on the server
Public method | GetApplicationWidgets | Returns the avalible application widgets on the server
Public method | GetFeatureProvider | Returns an installed provider, given the name of the provider
Public method | GetFeatureSource | Returns a FeatureSource from the server.
Public method | GetFeatureSourceDescription |
Public method | GetFeatureSourceSchema |
Public method | GetFolderHeader |
Public method | GetFolderOrResourceHeader |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetIdentityProperties | Gets the names of the identity properties from a feature
Public method | GetLayerDefinition | Returns a LayerDefinition from the server.
Public method | GetLegendImage | Renders a minature bitmap of the layers style
Public method | GetMapDefinition | Returns a MapDefinition from the server.
Public method | GetRepositoryResources | Overloaded. Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly.
Public method | GetResource | Returns an object deserialized from server data. Uses the ResourceID to infer the object type.
Public method | GetResourceData | Returns data from a resource as a memorystream
Public method | GetResourceHeader |
Public method | GetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types.
Public method | GetResourceXmlData | Returns raw data from the server a byte array
Public method | GetSelectionXml | Gets the selection from a map
Public method | GetSpatialContextInfo | Returns the spatial info for a given featuresource
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetWebLayout | Returns a WebLayout from the server.
Public method | HasFolder | Returns a value indicating if a given folder exists
Public method | IsSessionExpiredException | Determines if an exception is a "Session Expired" exception.
Public method | MoveFolder | Moves a folder and its content from one location to another. This does not update any references.
Public method | MoveFolderWithReferences | Moves a folder, and subsequently updates all resources pointing to the old resource path
Public method | MoveResource | Moves a resource from one location to another. This does not update any references.
Public method | MoveResourceWithReferences | Moves a resource, and subsequently updates all resources pointing to the old resource path
Public method | QueryMapFeatures | Overloaded. Selects features from a runtime map, returning a selection Xml.
Public method | RemoveVersionFromProviderName | Removes the version numbers from a providername
Public method | ResetFeatureSourceSchemaCache |
Public method | ResourceExists | Returns a boolean indicating if a given resource exists
Public method | RestartSession | Overloaded. Restarts the server session, and creates a new session ID
Public method | SaveResource | Overloaded. Saves a FeatureSource, using its originating resourceId
Public method | SaveResourceAs | Overloaded. Saves a FeatureSource under a different resourceID
Public method | SerializeObject | Overloaded. Serialize an object into a new memory stream.
Public method | SetFolderHeader |
Public method | SetFolderOrResourceHeader |
Public method | SetResourceData | Overloaded. Uploads data to a resource
Public method | SetResourceHeader |
Public method | SetResourceXmlData | Overloaded. Writes raw data into a resource.
Public method | SetSelectionXml | Sets the selection of a map
Public method | TestConnection | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetResourceType | Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types.
Public method | UpdateResourceReferences | Updates all resource references inside an object.
Public method | UploadPackage | Upload a MapGuide Package file to the server
Public method | WriteResource | Writes an object into a resourceID
Top

See Also

ServerConnectionBase Class


CopyFolder Method

ServerConnectionBase.CopyFolder Method
[image]

Copies a folder and all its content. This does not update any references.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub CopyFolder( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
)
C#
public abstract void CopyFolder(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
void CopyFolder(
String oldpath,
String newpath,
bool overwrite
) abstract
J#
public abstract void CopyFolder(
string oldpath,
string newpath,
bool overwrite
)
JScript
public abstract function CopyFolder(
oldpath : String,
newpath : String,
overwrite : bool
)

Parameters

oldpath
The current folder path, the one copying from
newpath
The new folder path, the one copying to
overwrite
True if the copy can overwrite an existing folder, false otherwise

See Also

ServerConnectionBase Class


CopyFolderWithReferences Method

ServerConnectionBase.CopyFolderWithReferences Method
[image]

Copies folder, and subsequently updates all resources within the folder to use the new folder path instead of the originating one.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function CopyFolderWithReferences( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal callback As LengthyOperationCallBack, _
ByVal progress As LengthyOperationProgressCallBack _
) As Boolean
C#
public bool CopyFolderWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
C++
public:
bool CopyFolderWithReferences(
String oldpath,
String newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
) sealed
J#
public bool CopyFolderWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
JScript
public function CopyFolderWithReferences(
oldpath : String,
newpath : String,
callback : LengthyOperationCallBack,
progress : LengthyOperationProgressCallBack
) : bool

Parameters

oldpath
The current folder path, the one copying from
newpath
The new folder path, the one copying to
callback
A callback delegate, being called for non progress reporting events.
progress
A callback delegate, being called for progress reporting events.

See Also

ServerConnectionBase Class


CopyResource Method

ServerConnectionBase.CopyResource Method
[image]

Copies a resource from one location to another. This does not update any references.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub CopyResource( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
)
C#
public abstract void CopyResource(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
void CopyResource(
String oldpath,
String newpath,
bool overwrite
) abstract
J#
public abstract void CopyResource(
string oldpath,
string newpath,
bool overwrite
)
JScript
public abstract function CopyResource(
oldpath : String,
newpath : String,
overwrite : bool
)

Parameters

oldpath
The current resource path, the one copying from
newpath
The new resource path, the one copying to
overwrite
True if the copy can overwrite an existing resource, false otherwise

See Also

ServerConnectionBase Class


CreateFolder Method

ServerConnectionBase.CreateFolder Method
[image]

Creates a folder on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub CreateFolder( _
ByVal resourceID As String _
)
C#
public virtual void CreateFolder(
string resourceID
)
C++
public:
virtual void CreateFolder(
String resourceID
)
J#
public virtual void CreateFolder(
string resourceID
)
JScript
public virtual function CreateFolder(
resourceID : String
)

Parameters

resourceID
The path of the folder to create

See Also

ServerConnectionBase Class


CreateRuntimeMap Method

ServerConnectionBase.CreateRuntimeMap Method

Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.

Overload List

 | Name | Description
Public method | CreateRuntimeMap (String) | Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.
Public method | CreateRuntimeMap (String, String) | Creates a runtime map on the server

See Also

ServerConnectionBase Class


CreateRuntimeMap Method (String)

ServerConnectionBase.CreateRuntimeMap Method (String)
See Also Example
[image]

Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub CreateRuntimeMap( _
ByVal resourceID As String _
)
C#
public virtual void CreateRuntimeMap(
string resourceID
)
C++
public:
virtual void CreateRuntimeMap(
String resourceID
)
J#
public virtual void CreateRuntimeMap(
string resourceID
)
JScript
public virtual function CreateRuntimeMap(
resourceID : String
)

Parameters

resourceID
The mapDefinition resource id

See Also

ServerConnectionBase Class
ServerConnectionBase.CreateRuntimeMap Overload List


CreateRuntimeMap Method (String, String)

ServerConnectionBase.CreateRuntimeMap Method (String, String)
See Also Example
[image]

Creates a runtime map on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub CreateRuntimeMap( _
ByVal resourceID As String, _
ByVal mapdefinition As String _
)
C#
public abstract void CreateRuntimeMap(
string resourceID,
string mapdefinition
)
C++
public:
void CreateRuntimeMap(
String resourceID,
String mapdefinition
) abstract
J#
public abstract void CreateRuntimeMap(
string resourceID,
string mapdefinition
)
JScript
public abstract function CreateRuntimeMap(
resourceID : String,
mapdefinition : String
)

Parameters

resourceID
The target resource id for the runtime map
mapdefinition
The mapdefinition to base the map on

See Also

ServerConnectionBase Class
ServerConnectionBase.CreateRuntimeMap Overload List


DeleteResource Method

ServerConnectionBase.DeleteResource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub DeleteResource( _
ByVal resourceid As String _
)
C#
public abstract void DeleteResource(
string resourceid
)
C++
public:
void DeleteResource(
String resourceid
) abstract
J#
public abstract void DeleteResource(
string resourceid
)
JScript
public abstract function DeleteResource(
resourceid : String
)

See Also

ServerConnectionBase Class


DescribeFeatureSource Method

ServerConnectionBase.DescribeFeatureSource Method

Overload List

 | Name | Description
Public method | DescribeFeatureSource (String) |
Public method | DescribeFeatureSource (String, String) |

See Also

ServerConnectionBase Class


DescribeFeatureSource Method (String)

ServerConnectionBase.DescribeFeatureSource Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function DescribeFeatureSource( _
ByVal resourceID As String _
) As FeatureSourceDescription
C#
public abstract FeatureSourceDescription DescribeFeatureSource(
string resourceID
)
C++
public:
FeatureSourceDescription DescribeFeatureSource(
String resourceID
) abstract
J#
public abstract FeatureSourceDescription DescribeFeatureSource(
string resourceID
)
JScript
public abstract function DescribeFeatureSource(
resourceID : String
) : FeatureSourceDescription

See Also

ServerConnectionBase Class
ServerConnectionBase.DescribeFeatureSource Overload List


DescribeFeatureSource Method (String, String)

ServerConnectionBase.DescribeFeatureSource Method (String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function DescribeFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String _
) As FeatureSourceDescription
C#
public abstract FeatureSourceDescription DescribeFeatureSource(
string resourceID,
string schema
)
C++
public:
FeatureSourceDescription DescribeFeatureSource(
String resourceID,
String schema
) abstract
J#
public abstract FeatureSourceDescription DescribeFeatureSource(
string resourceID,
string schema
)
JScript
public abstract function DescribeFeatureSource(
resourceID : String,
schema : String
) : FeatureSourceDescription

See Also

ServerConnectionBase Class
ServerConnectionBase.DescribeFeatureSource Overload List


DeserializeObject Generic Method

ServerConnectionBase.DeserializeObject Generic Method

Deserializes an object from a stream.

Overload List

 | Name | Description
Public method | DeserializeObject (Type, Stream) | Deserializes an object from a stream.
Public method | DeserializeObject (Stream) | Deserializes an object from a stream.

See Also

ServerConnectionBase Class


DeserializeObject Method (Type, Stream)

ServerConnectionBase.DeserializeObject Method (Type, Stream)
See Also Example
[image]

Deserializes an object from a stream.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function DeserializeObject( _
ByVal type As Type, _
ByVal data As Stream _
) As Object
C#
public virtual object DeserializeObject(
Type type,
Stream data
)
C++
public:
virtual Object DeserializeObject(
Type type,
Stream data
)
J#
public virtual object DeserializeObject(
Type type,
Stream data
)
JScript
public virtual function DeserializeObject(
type : Type,
data : Stream
) : Object

Parameters

type
The expected object type
data
The stream containing the object

Return Value

The deserialized object

See Also

ServerConnectionBase Class
ServerConnectionBase.DeserializeObject Overload List


DeserializeObject Generic Method (Stream)

ServerConnectionBase.DeserializeObject Generic Method (Stream)
See Also Example
[image]

Deserializes an object from a stream.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function DeserializeObject(Of T)( _
ByVal data As Stream _
)
C#
public virtual T DeserializeObject<T>(
Stream data
)
C++
public:
virtual T DeserializeObject<T>(
Stream data
)
J#
public virtual T DeserializeObject<T>(
Stream data
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The expected object type

Parameters

data
The stream containing the object

Return Value

The deserialized object

See Also

ServerConnectionBase Class
ServerConnectionBase.DeserializeObject Overload List


Dispose Method

ServerConnectionBase.Dispose Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Dispose()
C#
public abstract void Dispose()
C++
public:
void Dispose() abstract
J#
public abstract void Dispose()
JScript
public abstract function Dispose()

See Also

ServerConnectionBase Class


EnumerateGroups Method

ServerConnectionBase.EnumerateGroups Method
[image]

Gets a list of all groups on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function EnumerateGroups() As GroupList
C#
public abstract GroupList EnumerateGroups()
C++
public:
GroupList EnumerateGroups() abstract
J#
public abstract GroupList EnumerateGroups()
JScript
public abstract function EnumerateGroups() : GroupList

Return Value

The list of groups

See Also

ServerConnectionBase Class


EnumerateResourceReferences Method

ServerConnectionBase.EnumerateResourceReferences Method
[image]

Enumereates all references to a given resource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function EnumerateResourceReferences( _
ByVal resourceid As String _
) As ResourceReferenceList
C#
public abstract ResourceReferenceList EnumerateResourceReferences(
string resourceid
)
C++
public:
ResourceReferenceList EnumerateResourceReferences(
String resourceid
) abstract
J#
public abstract ResourceReferenceList EnumerateResourceReferences(
string resourceid
)
JScript
public abstract function EnumerateResourceReferences(
resourceid : String
) : ResourceReferenceList

Parameters

resourceid
The resource to enumerate references for

Return Value

A list of resources that reference the given resourceID

See Also

ServerConnectionBase Class


EnumerateUnmanagedData Method

ServerConnectionBase.EnumerateUnmanagedData Method
[image]

Enumerates all unmanaged folders, meaning alias'ed folders

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function EnumerateUnmanagedData( _
ByVal startpath As String, _
ByVal filter As String, _
ByVal recursive As Boolean, _
ByVal type As UnmanagedDataTypes _
) As UnmanagedDataList
C#
public abstract UnmanagedDataList EnumerateUnmanagedData(
string startpath,
string filter,
bool recursive,
UnmanagedDataTypes type
)
C++
public:
UnmanagedDataList EnumerateUnmanagedData(
String startpath,
String filter,
bool recursive,
UnmanagedDataTypes type
) abstract
J#
public abstract UnmanagedDataList EnumerateUnmanagedData(
string startpath,
string filter,
bool recursive,
UnmanagedDataTypes type
)
JScript
public abstract function EnumerateUnmanagedData(
startpath : String,
filter : String,
recursive : bool,
type : UnmanagedDataTypes
) : UnmanagedDataList

Parameters

startpath
The path to retrieve the data from
filter
A filter applied to the items
recursive
True if the list should contains recursive results
type
The type of data to return

Return Value

A list of unmanaged data

See Also

ServerConnectionBase Class


EnumerateUsers Method

ServerConnectionBase.EnumerateUsers Method

Gets a list of all users on the server

Overload List

 | Name | Description
Public method | EnumerateUsers | Gets a list of all users on the server
Public method | EnumerateUsers (String) | Gets a list of users in a group

See Also

ServerConnectionBase Class


EnumerateUsers Method ()

ServerConnectionBase.EnumerateUsers Method ()
See Also Example
[image]

Gets a list of all users on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function EnumerateUsers() As UserList
C#
public virtual UserList EnumerateUsers()
C++
public:
virtual UserList EnumerateUsers()
J#
public virtual UserList EnumerateUsers()
JScript
public virtual function EnumerateUsers() : UserList

Return Value

The list of users

See Also

ServerConnectionBase Class
ServerConnectionBase.EnumerateUsers Overload List


EnumerateUsers Method (String)

ServerConnectionBase.EnumerateUsers Method (String)
See Also Example
[image]

Gets a list of users in a group

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function EnumerateUsers( _
ByVal group As String _
) As UserList
C#
public abstract UserList EnumerateUsers(
string group
)
C++
public:
UserList EnumerateUsers(
String group
) abstract
J#
public abstract UserList EnumerateUsers(
string group
)
JScript
public abstract function EnumerateUsers(
group : String
) : UserList

Parameters

group
The group to retrieve the users from

Return Value

The list of users

See Also

ServerConnectionBase Class
ServerConnectionBase.EnumerateUsers Overload List


GetApplicationContainers Method

ServerConnectionBase.GetApplicationContainers Method
[image]

Returns the avalible widget containers on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetApplicationContainers() As ApplicationDefinitionContainerInfoSet
C#
public abstract ApplicationDefinitionContainerInfoSet GetApplicationContainers()
C++
public:
ApplicationDefinitionContainerInfoSet GetApplicationContainers() abstract
J#
public abstract ApplicationDefinitionContainerInfoSet GetApplicationContainers()
JScript
public abstract function GetApplicationContainers() : ApplicationDefinitionContainerInfoSet

Return Value

The avalible widget containers on the server

See Also

ServerConnectionBase Class


GetApplicationDefinition Method

ServerConnectionBase.GetApplicationDefinition Method
[image]

Returns a ApplicationDefinition from the server.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetApplicationDefinition( _
ByVal resourceID As String _
) As ApplicationDefinitionType
C#
public virtual ApplicationDefinitionType GetApplicationDefinition(
string resourceID
)
C++
public:
virtual ApplicationDefinitionType GetApplicationDefinition(
String resourceID
)
J#
public virtual ApplicationDefinitionType GetApplicationDefinition(
string resourceID
)
JScript
public virtual function GetApplicationDefinition(
resourceID : String
) : ApplicationDefinitionType

Parameters

resourceID
The full resourceID of the ApplicationDefinition.

Return Value

The ApplicationDefinition with the given ResourceID

See Also

ServerConnectionBase Class


GetApplicationTemplates Method

ServerConnectionBase.GetApplicationTemplates Method
[image]

Returns the avalible application templates on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetApplicationTemplates() As ApplicationDefinitionTemplateInfoSet
C#
public abstract ApplicationDefinitionTemplateInfoSet GetApplicationTemplates()
C++
public:
ApplicationDefinitionTemplateInfoSet GetApplicationTemplates() abstract
J#
public abstract ApplicationDefinitionTemplateInfoSet GetApplicationTemplates()
JScript
public abstract function GetApplicationTemplates() : ApplicationDefinitionTemplateInfoSet

Return Value

The avalible application templates on the server

See Also

ServerConnectionBase Class


GetApplicationWidgets Method

ServerConnectionBase.GetApplicationWidgets Method
[image]

Returns the avalible application widgets on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetApplicationWidgets() As ApplicationDefinitionWidgetInfoSet
C#
public abstract ApplicationDefinitionWidgetInfoSet GetApplicationWidgets()
C++
public:
ApplicationDefinitionWidgetInfoSet GetApplicationWidgets() abstract
J#
public abstract ApplicationDefinitionWidgetInfoSet GetApplicationWidgets()
JScript
public abstract function GetApplicationWidgets() : ApplicationDefinitionWidgetInfoSet

Return Value

The avalible application widgets on the server

See Also

ServerConnectionBase Class


GetFeatureProvider Method

ServerConnectionBase.GetFeatureProvider Method
[image]

Returns an installed provider, given the name of the provider

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetFeatureProvider( _
ByVal providername As String _
) As FeatureProviderRegistryFeatureProvider
C#
public virtual FeatureProviderRegistryFeatureProvider GetFeatureProvider(
string providername
)
C++
public:
virtual FeatureProviderRegistryFeatureProvider GetFeatureProvider(
String providername
)
J#
public virtual FeatureProviderRegistryFeatureProvider GetFeatureProvider(
string providername
)
JScript
public virtual function GetFeatureProvider(
providername : String
) : FeatureProviderRegistryFeatureProvider

Parameters

providername
The name of the provider

Return Value

The first matching provider or null

See Also

ServerConnectionBase Class


GetFeatureSource Method

ServerConnectionBase.GetFeatureSource Method
[image]

Returns a FeatureSource from the server.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetFeatureSource( _
ByVal resourceID As String _
) As FeatureSource
C#
public virtual FeatureSource GetFeatureSource(
string resourceID
)
C++
public:
virtual FeatureSource GetFeatureSource(
String resourceID
)
J#
public virtual FeatureSource GetFeatureSource(
string resourceID
)
JScript
public virtual function GetFeatureSource(
resourceID : String
) : FeatureSource

Parameters

resourceID
The full resourceID of the FeatureSource.

Return Value

The FeatureSource with the given ResourceID

See Also

ServerConnectionBase Class


GetFeatureSourceDescription Method

ServerConnectionBase.GetFeatureSourceDescription Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetFeatureSourceDescription( _
ByVal resourceID As String _
) As FeatureSourceDescription
C#
public virtual FeatureSourceDescription GetFeatureSourceDescription(
string resourceID
)
C++
public:
virtual FeatureSourceDescription GetFeatureSourceDescription(
String resourceID
)
J#
public virtual FeatureSourceDescription GetFeatureSourceDescription(
string resourceID
)
JScript
public virtual function GetFeatureSourceDescription(
resourceID : String
) : FeatureSourceDescription

See Also

ServerConnectionBase Class


GetFeatureSourceSchema Method

ServerConnectionBase.GetFeatureSourceSchema Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetFeatureSourceSchema( _
ByVal resourceID As String, _
ByVal schema As String _
) As FeatureSourceDescription.FeatureSourceSchema
C#
public virtual FeatureSourceDescription.FeatureSourceSchema GetFeatureSourceSchema(
string resourceID,
string schema
)
C++
public:
virtual FeatureSourceDescription.FeatureSourceSchema GetFeatureSourceSchema(
String resourceID,
String schema
)
J#
public virtual FeatureSourceDescription.FeatureSourceSchema GetFeatureSourceSchema(
string resourceID,
string schema
)
JScript
public virtual function GetFeatureSourceSchema(
resourceID : String,
schema : String
) : FeatureSourceDescription.FeatureSourceSchema

See Also

ServerConnectionBase Class


GetFolderHeader Method

ServerConnectionBase.GetFolderHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetFolderHeader( _
ByVal resourceID As String _
) As ResourceFolderHeaderType
C#
public virtual ResourceFolderHeaderType GetFolderHeader(
string resourceID
)
C++
public:
virtual ResourceFolderHeaderType GetFolderHeader(
String resourceID
)
J#
public virtual ResourceFolderHeaderType GetFolderHeader(
string resourceID
)
JScript
public virtual function GetFolderHeader(
resourceID : String
) : ResourceFolderHeaderType

See Also

ServerConnectionBase Class


GetFolderOrResourceHeader Method

ServerConnectionBase.GetFolderOrResourceHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetFolderOrResourceHeader( _
ByVal resourceId As String _
) As Object
C#
public abstract object GetFolderOrResourceHeader(
string resourceId
)
C++
public:
Object GetFolderOrResourceHeader(
String resourceId
) abstract
J#
public abstract object GetFolderOrResourceHeader(
string resourceId
)
JScript
public abstract function GetFolderOrResourceHeader(
resourceId : String
) : Object

See Also

ServerConnectionBase Class


GetIdentityProperties Method

ServerConnectionBase.GetIdentityProperties Method
[image]

Gets the names of the identity properties from a feature

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetIdentityProperties( _
ByVal resourceID As String, _
ByVal classname As String _
) As String()
C#
public abstract string[] GetIdentityProperties(
string resourceID,
string classname
)
C++
public:
array<String>^ GetIdentityProperties(
String resourceID,
String classname
) abstract
J#
public abstract string[] GetIdentityProperties(
string resourceID,
string classname
)
JScript
public abstract function GetIdentityProperties(
resourceID : String,
classname : String
) : String[]

Parameters

resourceID
The resourceID for the FeatureSource
classname
The classname of the feature, including schema

Return Value

A string array with the found identities

See Also

ServerConnectionBase Class


GetLayerDefinition Method

ServerConnectionBase.GetLayerDefinition Method
[image]

Returns a LayerDefinition from the server.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetLayerDefinition( _
ByVal resourceID As String _
) As LayerDefinition
C#
public virtual LayerDefinition GetLayerDefinition(
string resourceID
)
C++
public:
virtual LayerDefinition GetLayerDefinition(
String resourceID
)
J#
public virtual LayerDefinition GetLayerDefinition(
string resourceID
)
JScript
public virtual function GetLayerDefinition(
resourceID : String
) : LayerDefinition

Parameters

resourceID
The full resourceID of the LayerDefinition.

Return Value

The LayerDefinition with the given ResourceID

See Also

ServerConnectionBase Class


GetLegendImage Method

ServerConnectionBase.GetLegendImage Method
[image]

Renders a minature bitmap of the layers style

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetLegendImage( _
ByVal scale As Double, _
ByVal layerdefinition As String, _
ByVal themeIndex As Integer, _
ByVal type As Integer _
) As Image
C#
public abstract Image GetLegendImage(
double scale,
string layerdefinition,
int themeIndex,
int type
)
C++
public:
Image GetLegendImage(
double scale,
String layerdefinition,
int themeIndex,
int type
) abstract
J#
public abstract Image GetLegendImage(
double scale,
string layerdefinition,
int themeIndex,
int type
)
JScript
public abstract function GetLegendImage(
scale : double,
layerdefinition : String,
themeIndex : int,
type : int
) : Image

Parameters

scale
The scale for the bitmap to match
layerdefinition
The layer the image should represent
themeIndex
If the layer is themed, this gives the theme index, otherwise set to 0
type
The geometry type, 1 for point, 2 for line, 3 for area, 4 for composite

Return Value

The minature bitmap

See Also

ServerConnectionBase Class


GetMapDefinition Method

ServerConnectionBase.GetMapDefinition Method
[image]

Returns a MapDefinition from the server.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetMapDefinition( _
ByVal resourceID As String _
) As MapDefinition
C#
public virtual MapDefinition GetMapDefinition(
string resourceID
)
C++
public:
virtual MapDefinition GetMapDefinition(
String resourceID
)
J#
public virtual MapDefinition GetMapDefinition(
string resourceID
)
JScript
public virtual function GetMapDefinition(
resourceID : String
) : MapDefinition

Parameters

resourceID
The full resourceID of the MapDefinition.

Return Value

The MapDefinition with the given ResourceID

See Also

ServerConnectionBase Class


GetRepositoryResources Method

ServerConnectionBase.GetRepositoryResources Method

Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly.

Overload List

 | Name | Description
Public method | GetRepositoryResources | Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly.
Public method | GetRepositoryResources (Int32) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth.
Public method | GetRepositoryResources (String) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth.
Public method | GetRepositoryResources (String, Int32) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth.
Public method | GetRepositoryResources (String, String) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth.
Public method | GetRepositoryResources (String, String, Int32) | Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth.

See Also

ServerConnectionBase Class


GetRepositoryResources Method ()

ServerConnectionBase.GetRepositoryResources Method ()
See Also Example
[image]

Gets a full list of resources in the permanent server repository (Library). This method returns the full catalog and should be used sparringly.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetRepositoryResources() As ResourceList
C#
public virtual ResourceList GetRepositoryResources()
C++
public:
virtual ResourceList GetRepositoryResources()
J#
public virtual ResourceList GetRepositoryResources()
JScript
public virtual function GetRepositoryResources() : ResourceList

Return Value

A list of contained resources

See Also

ServerConnectionBase Class
ServerConnectionBase.GetRepositoryResources Overload List


GetRepositoryResources Method (Int32)

ServerConnectionBase.GetRepositoryResources Method (Int32)
See Also Example
[image]

Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetRepositoryResources( _
ByVal depth As Integer _
) As ResourceList
C#
public virtual ResourceList GetRepositoryResources(
int depth
)
C++
public:
virtual ResourceList GetRepositoryResources(
int depth
)
J#
public virtual ResourceList GetRepositoryResources(
int depth
)
JScript
public virtual function GetRepositoryResources(
depth : int
) : ResourceList

Parameters

depth
The max depth to recurse. Use -1 for no limit.

Return Value

A list of contained resources

See Also

ServerConnectionBase Class
ServerConnectionBase.GetRepositoryResources Overload List


GetRepositoryResources Method (String)

ServerConnectionBase.GetRepositoryResources Method (String)
See Also Example
[image]

Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetRepositoryResources( _
ByVal startingpoint As String _
) As ResourceList
C#
public virtual ResourceList GetRepositoryResources(
string startingpoint
)
C++
public:
virtual ResourceList GetRepositoryResources(
String startingpoint
)
J#
public virtual ResourceList GetRepositoryResources(
string startingpoint
)
JScript
public virtual function GetRepositoryResources(
startingpoint : String
) : ResourceList

Parameters

startingpoint
The folder from which to return items. Use null for "Library://"

Return Value

A list of contained resources

See Also

ServerConnectionBase Class
ServerConnectionBase.GetRepositoryResources Overload List


GetRepositoryResources Method (String, Int32)

ServerConnectionBase.GetRepositoryResources Method (String, Int32)
See Also Example
[image]

Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetRepositoryResources( _
ByVal startingpoint As String, _
ByVal depth As Integer _
) As ResourceList
C#
public virtual ResourceList GetRepositoryResources(
string startingpoint,
int depth
)
C++
public:
virtual ResourceList GetRepositoryResources(
String startingpoint,
int depth
)
J#
public virtual ResourceList GetRepositoryResources(
string startingpoint,
int depth
)
JScript
public virtual function GetRepositoryResources(
startingpoint : String,
depth : int
) : ResourceList

Parameters

startingpoint
The folder from which to return items. Use null for "Library://"
depth
The max depth to recurse. Use -1 for no limit.

Return Value

A list of contained resources

See Also

ServerConnectionBase Class
ServerConnectionBase.GetRepositoryResources Overload List


GetRepositoryResources Method (String, String)

ServerConnectionBase.GetRepositoryResources Method (String, String)
See Also Example
[image]

Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetRepositoryResources( _
ByVal startingpoint As String, _
ByVal type As String _
) As ResourceList
C#
public virtual ResourceList GetRepositoryResources(
string startingpoint,
string type
)
C++
public:
virtual ResourceList GetRepositoryResources(
String startingpoint,
String type
)
J#
public virtual ResourceList GetRepositoryResources(
string startingpoint,
string type
)
JScript
public virtual function GetRepositoryResources(
startingpoint : String,
type : String
) : ResourceList

Parameters

startingpoint
The folder from which to return items. Use null for "Library://"
type
The type of resource to look for. Basically this is the resource extension, like ".MapDefinition". Use null for all resources.

Return Value

A list of contained resources

See Also

ServerConnectionBase Class
ServerConnectionBase.GetRepositoryResources Overload List


GetRepositoryResources Method (String, String, Int32)

ServerConnectionBase.GetRepositoryResources Method (String, String, Int32)
See Also Example
[image]

Gets a list of resources in the permanent server repository (Library). This method limits folder recursion to the specified depth.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetRepositoryResources( _
ByVal startingpoint As String, _
ByVal type As String, _
ByVal depth As Integer _
) As ResourceList
C#
public abstract ResourceList GetRepositoryResources(
string startingpoint,
string type,
int depth
)
C++
public:
ResourceList GetRepositoryResources(
String startingpoint,
String type,
int depth
) abstract
J#
public abstract ResourceList GetRepositoryResources(
string startingpoint,
string type,
int depth
)
JScript
public abstract function GetRepositoryResources(
startingpoint : String,
type : String,
depth : int
) : ResourceList

Parameters

startingpoint
The folder from which to return items. Use null for "Library://"
type
The type of resource to look for. Basically this is the resource extension, like ".MapDefinition". Use null for all resources.
depth
The max depth to recurse. Use -1 for no limit.

Return Value

A list of contained resources

See Also

ServerConnectionBase Class
ServerConnectionBase.GetRepositoryResources Overload List


GetResource Method

ServerConnectionBase.GetResource Method
[image]

Returns an object deserialized from server data. Uses the ResourceID to infer the object type.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetResource( _
ByVal resourceID As String _
) As Object
C#
public virtual object GetResource(
string resourceID
)
C++
public:
virtual Object GetResource(
String resourceID
)
J#
public virtual object GetResource(
string resourceID
)
JScript
public virtual function GetResource(
resourceID : String
) : Object

Parameters

resourceID
The full resourceID of the item to retrieve.

Return Value

A deserialized object.

See Also

ServerConnectionBase Class


GetResourceData Method

ServerConnectionBase.GetResourceData Method
[image]

Returns data from a resource as a memorystream

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetResourceData( _
ByVal resourceID As String, _
ByVal dataname As String _
) As MemoryStream
C#
public abstract MemoryStream GetResourceData(
string resourceID,
string dataname
)
C++
public:
MemoryStream GetResourceData(
String resourceID,
String dataname
) abstract
J#
public abstract MemoryStream GetResourceData(
string resourceID,
string dataname
)
JScript
public abstract function GetResourceData(
resourceID : String,
dataname : String
) : MemoryStream

Parameters

resourceID
The id of the resource to fetch data from
dataname
The name of the associated data item

Return Value

A stream containing the references resource data

See Also

ServerConnectionBase Class


GetResourceHeader Method

ServerConnectionBase.GetResourceHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetResourceHeader( _
ByVal resourceID As String _
) As ResourceDocumentHeaderType
C#
public virtual ResourceDocumentHeaderType GetResourceHeader(
string resourceID
)
C++
public:
virtual ResourceDocumentHeaderType GetResourceHeader(
String resourceID
)
J#
public virtual ResourceDocumentHeaderType GetResourceHeader(
string resourceID
)
JScript
public virtual function GetResourceHeader(
resourceID : String
) : ResourceDocumentHeaderType

See Also

ServerConnectionBase Class


GetResourceType Method

ServerConnectionBase.GetResourceType Method
[image]

Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetResourceType( _
ByVal resourceID As String _
) As Type
C#
public virtual Type GetResourceType(
string resourceID
)
C++
public:
virtual Type GetResourceType(
String resourceID
)
J#
public virtual Type GetResourceType(
string resourceID
)
JScript
public virtual function GetResourceType(
resourceID : String
) : Type

Parameters

resourceID
The resourceID for the resource

Return Value

The type of the given item, throws an exception if the type does not exist

See Also

ServerConnectionBase Class


GetResourceXmlData Method

ServerConnectionBase.GetResourceXmlData Method
[image]

Returns raw data from the server a byte array

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetResourceXmlData( _
ByVal resourceID As String _
) As Byte()
C#
public abstract byte[] GetResourceXmlData(
string resourceID
)
C++
public:
array<char>^ GetResourceXmlData(
String resourceID
) abstract
J#
public abstract byte[] GetResourceXmlData(
string resourceID
)
JScript
public abstract function GetResourceXmlData(
resourceID : String
) : Byte[]

Parameters

resourceID
The full resourceID to get data from

Return Value

Raw data from the given resource

See Also

ServerConnectionBase Class


GetSelectionXml Method

ServerConnectionBase.GetSelectionXml Method
[image]

Gets the selection from a map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetSelectionXml( _
ByVal runtimeMap As String _
) As String
C#
public abstract string GetSelectionXml(
string runtimeMap
)
C++
public:
String GetSelectionXml(
String runtimeMap
) abstract
J#
public abstract string GetSelectionXml(
string runtimeMap
)
JScript
public abstract function GetSelectionXml(
runtimeMap : String
) : String

Parameters

runtimeMap
The resourceID of the runtime map

Return Value

The selection xml

See Also

ServerConnectionBase Class


GetSpatialContextInfo Method

ServerConnectionBase.GetSpatialContextInfo Method
[image]

Returns the spatial info for a given featuresource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetSpatialContextInfo( _
ByVal resourceID As String, _
ByVal activeOnly As Boolean _
) As FdoSpatialContextList
C#
public abstract FdoSpatialContextList GetSpatialContextInfo(
string resourceID,
bool activeOnly
)
C++
public:
FdoSpatialContextList GetSpatialContextInfo(
String resourceID,
bool activeOnly
) abstract
J#
public abstract FdoSpatialContextList GetSpatialContextInfo(
string resourceID,
bool activeOnly
)
JScript
public abstract function GetSpatialContextInfo(
resourceID : String,
activeOnly : bool
) : FdoSpatialContextList

Parameters

resourceID
The ID of the resource to query
activeOnly
Query only active items

Return Value

A list of spatial contexts

See Also

ServerConnectionBase Class


GetWebLayout Method

ServerConnectionBase.GetWebLayout Method
[image]

Returns a WebLayout from the server.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetWebLayout( _
ByVal resourceID As String _
) As WebLayout
C#
public virtual WebLayout GetWebLayout(
string resourceID
)
C++
public:
virtual WebLayout GetWebLayout(
String resourceID
)
J#
public virtual WebLayout GetWebLayout(
string resourceID
)
JScript
public virtual function GetWebLayout(
resourceID : String
) : WebLayout

Parameters

resourceID
The full resourceID of the WebLayout.

Return Value

The WebLayout with the given ResourceID

See Also

ServerConnectionBase Class


HasFolder Method

ServerConnectionBase.HasFolder Method
[image]

Returns a value indicating if a given folder exists

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function HasFolder( _
ByVal folderpath As String _
) As Boolean
C#
public virtual bool HasFolder(
string folderpath
)
C++
public:
virtual bool HasFolder(
String folderpath
)
J#
public virtual bool HasFolder(
string folderpath
)
JScript
public virtual function HasFolder(
folderpath : String
) : bool

Parameters

folderpath
The path of the folder

Return Value

True if the folder exists, false otherwise. Also returns false on error.

See Also

ServerConnectionBase Class


IsSessionExpiredException Method

ServerConnectionBase.IsSessionExpiredException Method
[image]

Determines if an exception is a "Session Expired" exception.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function IsSessionExpiredException( _
ByVal ex As Exception _
) As Boolean
C#
public abstract bool IsSessionExpiredException(
Exception ex
)
C++
public:
bool IsSessionExpiredException(
Exception ex
) abstract
J#
public abstract bool IsSessionExpiredException(
Exception ex
)
JScript
public abstract function IsSessionExpiredException(
ex : Exception
) : bool

Parameters

ex
The exception to evaluate

Return Value

True if the exception is a session expired exception

See Also

ServerConnectionBase Class


MoveFolder Method

ServerConnectionBase.MoveFolder Method
[image]

Moves a folder and its content from one location to another. This does not update any references.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub MoveFolder( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
)
C#
public abstract void MoveFolder(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
void MoveFolder(
String oldpath,
String newpath,
bool overwrite
) abstract
J#
public abstract void MoveFolder(
string oldpath,
string newpath,
bool overwrite
)
JScript
public abstract function MoveFolder(
oldpath : String,
newpath : String,
overwrite : bool
)

Parameters

oldpath
The current folder path, the one moving from
newpath
The new folder path, the one moving to
overwrite
True if the move can overwrite an existing folder, false otherwise

See Also

ServerConnectionBase Class


MoveFolderWithReferences Method

ServerConnectionBase.MoveFolderWithReferences Method
[image]

Moves a folder, and subsequently updates all resources pointing to the old resource path

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function MoveFolderWithReferences( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal callback As LengthyOperationCallBack, _
ByVal progress As LengthyOperationProgressCallBack _
) As Boolean
C#
public bool MoveFolderWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
C++
public:
bool MoveFolderWithReferences(
String oldpath,
String newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
) sealed
J#
public bool MoveFolderWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
JScript
public function MoveFolderWithReferences(
oldpath : String,
newpath : String,
callback : LengthyOperationCallBack,
progress : LengthyOperationProgressCallBack
) : bool

Parameters

oldpath
The current folder path, the one moving from
newpath
The new folder path, the one moving to
callback
A callback delegate, being called for non progress reporting events.
progress
A callback delegate, being called for progress reporting events.

See Also

ServerConnectionBase Class


MoveResource Method

ServerConnectionBase.MoveResource Method
[image]

Moves a resource from one location to another. This does not update any references.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub MoveResource( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
)
C#
public abstract void MoveResource(
string oldpath,
string newpath,
bool overwrite
)
C++
public:
void MoveResource(
String oldpath,
String newpath,
bool overwrite
) abstract
J#
public abstract void MoveResource(
string oldpath,
string newpath,
bool overwrite
)
JScript
public abstract function MoveResource(
oldpath : String,
newpath : String,
overwrite : bool
)

Parameters

oldpath
The current resource path, the one moving from
newpath
The new resource path, the one moving to
overwrite
True if the move can overwrite an existing resource, false otherwise

See Also

ServerConnectionBase Class


MoveResourceWithReferences Method

ServerConnectionBase.MoveResourceWithReferences Method
[image]

Moves a resource, and subsequently updates all resources pointing to the old resource path

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function MoveResourceWithReferences( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal callback As LengthyOperationCallBack, _
ByVal progress As LengthyOperationProgressCallBack _
) As Boolean
C#
public bool MoveResourceWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
C++
public:
bool MoveResourceWithReferences(
String oldpath,
String newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
) sealed
J#
public bool MoveResourceWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
JScript
public function MoveResourceWithReferences(
oldpath : String,
newpath : String,
callback : LengthyOperationCallBack,
progress : LengthyOperationProgressCallBack
) : bool

Parameters

oldpath
The current resource path, the one moving from
newpath
The new resource path, the one moving to
callback
A callback delegate, being called for non progress reporting events.
progress
A callback delegate, being called for progress reporting events.

See Also

ServerConnectionBase Class


QueryMapFeatures Method

ServerConnectionBase.QueryMapFeatures Method

Selects features from a runtime map, returning a selection Xml.

Overload List

 | Name | Description
Public method | QueryMapFeatures (String, String, Boolean) | Selects features from a runtime map, returning a selection Xml.
Public method | QueryMapFeatures (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean) | Selects features from a runtime map, returning a selection Xml.

See Also

ServerConnectionBase Class


QueryMapFeatures Method (String, String, Boolean)

ServerConnectionBase.QueryMapFeatures Method (String, String, Boolean)
See Also Example
[image]

Selects features from a runtime map, returning a selection Xml.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function QueryMapFeatures( _
ByVal runtimemap As String, _
ByVal wkt As String, _
ByVal persist As Boolean _
) As String
C#
public string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist
)
C++
public:
String QueryMapFeatures(
String runtimemap,
String wkt,
bool persist
) sealed
J#
public string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist
)
JScript
public function QueryMapFeatures(
runtimemap : String,
wkt : String,
persist : bool
) : String

Parameters

runtimemap
The map to query. NOT a resourceID, only the map name!
wkt
The WKT of the geometry to query with (always uses intersection)
persist
True if the selection should be saved in the runtime map, false otherwise.

Return Value

The selection Xml, or an empty string if there were no data.

See Also

ServerConnectionBase Class
ServerConnectionBase.QueryMapFeatures Overload List


QueryMapFeatures Method (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean)

ServerConnectionBase.QueryMapFeatures Method (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean)
See Also Example
[image]

Selects features from a runtime map, returning a selection Xml.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function QueryMapFeatures( _
ByVal runtimemap As String, _
ByVal wkt As String, _
ByVal persist As Boolean, _
ByVal attributes As QueryMapFeaturesLayerAttributes, _
ByVal raw As Boolean _
) As String
C#
public abstract string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
)
C++
public:
String QueryMapFeatures(
String runtimemap,
String wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
) abstract
J#
public abstract string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
)
JScript
public abstract function QueryMapFeatures(
runtimemap : String,
wkt : String,
persist : bool,
attributes : QueryMapFeaturesLayerAttributes,
raw : bool
) : String

Parameters

runtimemap
The map to query. NOT a resourceID, only the map name!
wkt
The WKT of the geometry to query with (always uses intersection)
persist
True if the selection should be saved in the runtime map, false otherwise.
attributes
The type of layer to include in the query
raw
True if the result should contain the tooltip and link info

Return Value

The selection Xml, or an empty string if there were no data.

See Also

ServerConnectionBase Class
ServerConnectionBase.QueryMapFeatures Overload List


RemoveVersionFromProviderName Method

ServerConnectionBase.RemoveVersionFromProviderName Method
[image]

Removes the version numbers from a providername

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function RemoveVersionFromProviderName( _
ByVal providername As String _
) As String
C#
public virtual string RemoveVersionFromProviderName(
string providername
)
C++
public:
virtual String RemoveVersionFromProviderName(
String providername
)
J#
public virtual string RemoveVersionFromProviderName(
string providername
)
JScript
public virtual function RemoveVersionFromProviderName(
providername : String
) : String

Parameters

providername
The name of the provider, with or without version numbers

Return Value

The provider name without version numbers

See Also

ServerConnectionBase Class


ResetFeatureSourceSchemaCache Method

ServerConnectionBase.ResetFeatureSourceSchemaCache Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetFeatureSourceSchemaCache()
C#
public virtual void ResetFeatureSourceSchemaCache()
C++
public:
virtual void ResetFeatureSourceSchemaCache()
J#
public virtual void ResetFeatureSourceSchemaCache()
JScript
public virtual function ResetFeatureSourceSchemaCache()

See Also

ServerConnectionBase Class


ResourceExists Method

ServerConnectionBase.ResourceExists Method
[image]

Returns a boolean indicating if a given resource exists

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ResourceExists( _
ByVal resourceid As String _
) As Boolean
C#
public bool ResourceExists(
string resourceid
)
C++
public:
bool ResourceExists(
String resourceid
) sealed
J#
public bool ResourceExists(
string resourceid
)
JScript
public function ResourceExists(
resourceid : String
) : bool

Parameters

resourceid
The resource to look for

Return Value

True if the resource exists false otherwise. Also returns false on error.

See Also

ServerConnectionBase Class


RestartSession Method

ServerConnectionBase.RestartSession Method

Restarts the server session, and creates a new session ID

Overload List

 | Name | Description
Public method | RestartSession | Restarts the server session, and creates a new session ID
Public method | RestartSession (Boolean) | Restarts the server session, and creates a new session ID

See Also

ServerConnectionBase Class


RestartSession Method ()

ServerConnectionBase.RestartSession Method ()
See Also Example
[image]

Restarts the server session, and creates a new session ID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub RestartSession()
C#
public void RestartSession()
C++
public:
void RestartSession() sealed
J#
public void RestartSession()
JScript
public function RestartSession()

See Also

ServerConnectionBase Class
ServerConnectionBase.RestartSession Overload List


RestartSession Method (Boolean)

ServerConnectionBase.RestartSession Method (Boolean)
See Also Example
[image]

Restarts the server session, and creates a new session ID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function RestartSession( _
ByVal throwException As Boolean _
) As Boolean
C#
public abstract bool RestartSession(
bool throwException
)
C++
public:
bool RestartSession(
bool throwException
) abstract
J#
public abstract bool RestartSession(
bool throwException
)
JScript
public abstract function RestartSession(
throwException : bool
) : bool

Parameters

throwException
If set to true, the call throws an exception if the call failed

Return Value

True if the creation succeed, false otherwise

See Also

ServerConnectionBase Class
ServerConnectionBase.RestartSession Overload List


SaveResource Method

ServerConnectionBase.SaveResource Method

Saves a FeatureSource, using its originating resourceId

Overload List

 | Name | Description
Public method | SaveResource (FeatureSource) | Saves a FeatureSource, using its originating resourceId
Public method | SaveResource (LayerDefinition) | Saves a LayerDefinition, using its originating resourceId
Public method | SaveResource (MapDefinition) | Saves a MapDefinition, using its originating resourceId
Public method | SaveResource (WebLayout) | Saves a WebLayout, using its originating resourceId

See Also

ServerConnectionBase Class


SaveResource Method (FeatureSource)

ServerConnectionBase.SaveResource Method (FeatureSource)
See Also Example
[image]

Saves a FeatureSource, using its originating resourceId

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveResource( _
ByVal resource As FeatureSource _
)
C#
public void SaveResource(
FeatureSource resource
)
C++
public:
void SaveResource(
FeatureSource resource
) sealed
J#
public void SaveResource(
FeatureSource resource
)
JScript
public function SaveResource(
resource : FeatureSource
)

Parameters

resource
The FeatureSource to save

See Also

ServerConnectionBase Class
ServerConnectionBase.SaveResource Overload List


SaveResource Method (LayerDefinition)

ServerConnectionBase.SaveResource Method (LayerDefinition)
See Also Example
[image]

Saves a LayerDefinition, using its originating resourceId

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveResource( _
ByVal resource As LayerDefinition _
)
C#
public void SaveResource(
LayerDefinition resource
)
C++
public:
void SaveResource(
LayerDefinition resource
) sealed
J#
public void SaveResource(
LayerDefinition resource
)
JScript
public function SaveResource(
resource : LayerDefinition
)

Parameters

resource
The LayerDefinition to save

See Also

ServerConnectionBase Class
ServerConnectionBase.SaveResource Overload List


SaveResource Method (MapDefinition)

ServerConnectionBase.SaveResource Method (MapDefinition)
See Also Example
[image]

Saves a MapDefinition, using its originating resourceId

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveResource( _
ByVal resource As MapDefinition _
)
C#
public void SaveResource(
MapDefinition resource
)
C++
public:
void SaveResource(
MapDefinition resource
) sealed
J#
public void SaveResource(
MapDefinition resource
)
JScript
public function SaveResource(
resource : MapDefinition
)

Parameters

resource
The MapDefintion to save

See Also

ServerConnectionBase Class
ServerConnectionBase.SaveResource Overload List


SaveResource Method (WebLayout)

ServerConnectionBase.SaveResource Method (WebLayout)
See Also Example
[image]

Saves a WebLayout, using its originating resourceId

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveResource( _
ByVal resource As WebLayout _
)
C#
public void SaveResource(
WebLayout resource
)
C++
public:
void SaveResource(
WebLayout resource
) sealed
J#
public void SaveResource(
WebLayout resource
)
JScript
public function SaveResource(
resource : WebLayout
)

Parameters

resource
The WebLayout to save

See Also

ServerConnectionBase Class
ServerConnectionBase.SaveResource Overload List


SaveResourceAs Method

ServerConnectionBase.SaveResourceAs Method

Saves a FeatureSource under a different resourceID

Overload List

 | Name | Description
Public method | SaveResourceAs (FeatureSource, String) | Saves a FeatureSource under a different resourceID
Public method | SaveResourceAs (LayerDefinition, String) | Saves a LayerDefinition under a different resourceID
Public method | SaveResourceAs (MapDefinition, String) | Saves a MapDefinition under a different resourceID
Public method | SaveResourceAs (WebLayout, String) | Saves a WebLayout under a different resourceID
Public method | SaveResourceAs (Object, String) | Saves an object into the repository

See Also

ServerConnectionBase Class


SaveResourceAs Method (FeatureSource, String)

ServerConnectionBase.SaveResourceAs Method (FeatureSource, String)
See Also Example
[image]

Saves a FeatureSource under a different resourceID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveResourceAs( _
ByVal resource As FeatureSource, _
ByVal resourceid As String _
)
C#
public virtual void SaveResourceAs(
FeatureSource resource,
string resourceid
)
C++
public:
virtual void SaveResourceAs(
FeatureSource resource,
String resourceid
)
J#
public virtual void SaveResourceAs(
FeatureSource resource,
string resourceid
)
JScript
public virtual function SaveResourceAs(
resource : FeatureSource,
resourceid : String
)

Parameters

resource
The FeatureSource to save
resourceid
The new path of the FeatureSource

See Also

ServerConnectionBase Class
ServerConnectionBase.SaveResourceAs Overload List


SaveResourceAs Method (LayerDefinition, String)

ServerConnectionBase.SaveResourceAs Method (LayerDefinition, String)
See Also Example
[image]

Saves a LayerDefinition under a different resourceID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveResourceAs( _
ByVal resource As LayerDefinition, _
ByVal resourceid As String _
)
C#
public virtual void SaveResourceAs(
LayerDefinition resource,
string resourceid
)
C++
public:
virtual void SaveResourceAs(
LayerDefinition resource,
String resourceid
)
J#
public virtual void SaveResourceAs(
LayerDefinition resource,
string resourceid
)
JScript
public virtual function SaveResourceAs(
resource : LayerDefinition,
resourceid : String
)

Parameters

resource
The LayerDefinition to save
resourceid
The new path of the LayerDefinition

See Also

ServerConnectionBase Class
ServerConnectionBase.SaveResourceAs Overload List


SaveResourceAs Method (MapDefinition, String)

ServerConnectionBase.SaveResourceAs Method (MapDefinition, String)
See Also Example
[image]

Saves a MapDefinition under a different resourceID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveResourceAs( _
ByVal resource As MapDefinition, _
ByVal resourceid As String _
)
C#
public virtual void SaveResourceAs(
MapDefinition resource,
string resourceid
)
C++
public:
virtual void SaveResourceAs(
MapDefinition resource,
String resourceid
)
J#
public virtual void SaveResourceAs(
MapDefinition resource,
string resourceid
)
JScript
public virtual function SaveResourceAs(
resource : MapDefinition,
resourceid : String
)

Parameters

resource
The MapDefinition to save
resourceid
The new path of the MapDefinition

See Also

ServerConnectionBase Class
ServerConnectionBase.SaveResourceAs Overload List


SaveResourceAs Method (WebLayout, String)

ServerConnectionBase.SaveResourceAs Method (WebLayout, String)
See Also Example
[image]

Saves a WebLayout under a different resourceID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveResourceAs( _
ByVal resource As WebLayout, _
ByVal resourceid As String _
)
C#
public virtual void SaveResourceAs(
WebLayout resource,
string resourceid
)
C++
public:
virtual void SaveResourceAs(
WebLayout resource,
String resourceid
)
J#
public virtual void SaveResourceAs(
WebLayout resource,
string resourceid
)
JScript
public virtual function SaveResourceAs(
resource : WebLayout,
resourceid : String
)

Parameters

resource
The WebLayout to save
resourceid
The new path of the WebLayout

See Also

ServerConnectionBase Class
ServerConnectionBase.SaveResourceAs Overload List


SaveResourceAs Method (Object, String)

ServerConnectionBase.SaveResourceAs Method (Object, String)
See Also Example
[image]

Saves an object into the repository

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveResourceAs( _
ByVal resource As Object, _
ByVal resourceid As String _
)
C#
public void SaveResourceAs(
object resource,
string resourceid
)
C++
public:
void SaveResourceAs(
Object resource,
String resourceid
) sealed
J#
public void SaveResourceAs(
object resource,
string resourceid
)
JScript
public function SaveResourceAs(
resource : Object,
resourceid : String
)

Parameters

resource
The object to save
resourceid
The resourceId to save the object as

See Also

ServerConnectionBase Class
ServerConnectionBase.SaveResourceAs Overload List


SerializeObject Method

ServerConnectionBase.SerializeObject Method

Serialize an object into a new memory stream.

Overload List

 | Name | Description
Public method | SerializeObject (Object) | Serialize an object into a new memory stream.
Public method | SerializeObject (Object, Stream) | Serializes an object into a stream

See Also

ServerConnectionBase Class


SerializeObject Method (Object)

ServerConnectionBase.SerializeObject Method (Object)
See Also Example
[image]

Serialize an object into a new memory stream.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function SerializeObject( _
ByVal o As Object _
) As MemoryStream
C#
public virtual MemoryStream SerializeObject(
object o
)
C++
public:
virtual MemoryStream SerializeObject(
Object o
)
J#
public virtual MemoryStream SerializeObject(
object o
)
JScript
public virtual function SerializeObject(
o : Object
) : MemoryStream

Parameters

o
The object to serialize

Return Value

A memorystream with the serialized object

See Also

ServerConnectionBase Class
ServerConnectionBase.SerializeObject Overload List


SerializeObject Method (Object, Stream)

ServerConnectionBase.SerializeObject Method (Object, Stream)
See Also Example
[image]

Serializes an object into a stream

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SerializeObject( _
ByVal o As Object, _
ByVal stream As Stream _
)
C#
public virtual void SerializeObject(
object o,
Stream stream
)
C++
public:
virtual void SerializeObject(
Object o,
Stream stream
)
J#
public virtual void SerializeObject(
object o,
Stream stream
)
JScript
public virtual function SerializeObject(
o : Object,
stream : Stream
)

Parameters

o
The object to serialize
stream
The stream to serialize into

See Also

ServerConnectionBase Class
ServerConnectionBase.SerializeObject Overload List


SetFolderHeader Method

ServerConnectionBase.SetFolderHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetFolderHeader( _
ByVal resourceID As String, _
ByVal header As ResourceFolderHeaderType _
)
C#
public virtual void SetFolderHeader(
string resourceID,
ResourceFolderHeaderType header
)
C++
public:
virtual void SetFolderHeader(
String resourceID,
ResourceFolderHeaderType header
)
J#
public virtual void SetFolderHeader(
string resourceID,
ResourceFolderHeaderType header
)
JScript
public virtual function SetFolderHeader(
resourceID : String,
header : ResourceFolderHeaderType
)

See Also

ServerConnectionBase Class


SetFolderOrResourceHeader Method

ServerConnectionBase.SetFolderOrResourceHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetFolderOrResourceHeader( _
ByVal resourceID As String, _
ByVal header As Object _
)
C#
public virtual void SetFolderOrResourceHeader(
string resourceID,
object header
)
C++
public:
virtual void SetFolderOrResourceHeader(
String resourceID,
Object header
)
J#
public virtual void SetFolderOrResourceHeader(
string resourceID,
object header
)
JScript
public virtual function SetFolderOrResourceHeader(
resourceID : String,
header : Object
)

See Also

ServerConnectionBase Class


SetResourceData Method

ServerConnectionBase.SetResourceData Method

Uploads data to a resource

Overload List

 | Name | Description
Public method | SetResourceData (String, String, ResourceDataType, Stream) | Uploads data to a resource
Public method | SetResourceData (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate) | Uploads data to a resource

See Also

ServerConnectionBase Class


SetResourceData Method (String, String, ResourceDataType, Stream)

ServerConnectionBase.SetResourceData Method (String, String, ResourceDataType, Stream)
See Also Example
[image]

Uploads data to a resource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetResourceData( _
ByVal resourceid As String, _
ByVal dataname As String, _
ByVal datatype As ResourceDataType, _
ByVal stream As Stream _
)
C#
public virtual void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream
)
C++
public:
virtual void SetResourceData(
String resourceid,
String dataname,
ResourceDataType datatype,
Stream stream
)
J#
public virtual void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream
)
JScript
public virtual function SetResourceData(
resourceid : String,
dataname : String,
datatype : ResourceDataType,
stream : Stream
)

Parameters

resourceid
The id of the resource to update
dataname
The name of the data to update or create
datatype
The type of data
stream
A stream containing the new content of the resource data

See Also

ServerConnectionBase Class
ServerConnectionBase.SetResourceData Overload List


SetResourceData Method (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate)

ServerConnectionBase.SetResourceData Method (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate)
See Also Example
[image]

Uploads data to a resource

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SetResourceData( _
ByVal resourceid As String, _
ByVal dataname As String, _
ByVal datatype As ResourceDataType, _
ByVal stream As Stream, _
ByVal callback As Utility.StreamCopyProgressDelegate _
)
C#
public abstract void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
)
C++
public:
void SetResourceData(
String resourceid,
String dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
) abstract
J#
public abstract void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
)
JScript
public abstract function SetResourceData(
resourceid : String,
dataname : String,
datatype : ResourceDataType,
stream : Stream,
callback : Utility.StreamCopyProgressDelegate
)

Parameters

resourceid
The id of the resource to update
dataname
The name of the data to update or create
datatype
The type of data
stream
A stream containing the new content of the resource data
callback

See Also

ServerConnectionBase Class
ServerConnectionBase.SetResourceData Overload List


SetResourceHeader Method

ServerConnectionBase.SetResourceHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetResourceHeader( _
ByVal resourceID As String, _
ByVal header As ResourceDocumentHeaderType _
)
C#
public virtual void SetResourceHeader(
string resourceID,
ResourceDocumentHeaderType header
)
C++
public:
virtual void SetResourceHeader(
String resourceID,
ResourceDocumentHeaderType header
)
J#
public virtual void SetResourceHeader(
string resourceID,
ResourceDocumentHeaderType header
)
JScript
public virtual function SetResourceHeader(
resourceID : String,
header : ResourceDocumentHeaderType
)

See Also

ServerConnectionBase Class


SetResourceXmlData Method

ServerConnectionBase.SetResourceXmlData Method

Writes raw data into a resource.

Overload List

 | Name | Description
Public method | SetResourceXmlData (String, Stream) | Writes raw data into a resource.
Public method | SetResourceXmlData (String, Stream, Stream) |

See Also

ServerConnectionBase Class


SetResourceXmlData Method (String, Stream)

ServerConnectionBase.SetResourceXmlData Method (String, Stream)
See Also Example
[image]

Writes raw data into a resource.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetResourceXmlData( _
ByVal resourceid As String, _
ByVal stream As Stream _
)
C#
public virtual void SetResourceXmlData(
string resourceid,
Stream stream
)
C++
public:
virtual void SetResourceXmlData(
String resourceid,
Stream stream
)
J#
public virtual void SetResourceXmlData(
string resourceid,
Stream stream
)
JScript
public virtual function SetResourceXmlData(
resourceid : String,
stream : Stream
)

Parameters

resourceid
The resourceID to write into
stream
The stream containing the data to write.

See Also

ServerConnectionBase Class
ServerConnectionBase.SetResourceXmlData Overload List


SetResourceXmlData Method (String, Stream, Stream)

ServerConnectionBase.SetResourceXmlData Method (String, Stream, Stream)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SetResourceXmlData( _
ByVal resourceId As String, _
ByVal content As Stream, _
ByVal header As Stream _
)
C#
public abstract void SetResourceXmlData(
string resourceId,
Stream content,
Stream header
)
C++
public:
void SetResourceXmlData(
String resourceId,
Stream content,
Stream header
) abstract
J#
public abstract void SetResourceXmlData(
string resourceId,
Stream content,
Stream header
)
JScript
public abstract function SetResourceXmlData(
resourceId : String,
content : Stream,
header : Stream
)

See Also

ServerConnectionBase Class
ServerConnectionBase.SetResourceXmlData Overload List


SetSelectionXml Method

ServerConnectionBase.SetSelectionXml Method
[image]

Sets the selection of a map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SetSelectionXml( _
ByVal runtimeMap As String, _
ByVal selectionXml As String _
)
C#
public abstract void SetSelectionXml(
string runtimeMap,
string selectionXml
)
C++
public:
void SetSelectionXml(
String runtimeMap,
String selectionXml
) abstract
J#
public abstract void SetSelectionXml(
string runtimeMap,
string selectionXml
)
JScript
public abstract function SetSelectionXml(
runtimeMap : String,
selectionXml : String
)

Parameters

runtimeMap
The resourceID of the runtime map
selectionXml
The selection xml

See Also

ServerConnectionBase Class


TestConnection Method

ServerConnectionBase.TestConnection Method

Overload List

 | Name | Description
Public method | TestConnection (FeatureSource) |
Public method | TestConnection (String) |

See Also

ServerConnectionBase Class


TestConnection Method (FeatureSource)

ServerConnectionBase.TestConnection Method (FeatureSource)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function TestConnection( _
ByVal feature As FeatureSource _
) As String
C#
public virtual string TestConnection(
FeatureSource feature
)
C++
public:
virtual String TestConnection(
FeatureSource feature
)
J#
public virtual string TestConnection(
FeatureSource feature
)
JScript
public virtual function TestConnection(
feature : FeatureSource
) : String

See Also

ServerConnectionBase Class
ServerConnectionBase.TestConnection Overload List


TestConnection Method (String)

ServerConnectionBase.TestConnection Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function TestConnection( _
ByVal featuresource As String _
) As String
C#
public abstract string TestConnection(
string featuresource
)
C++
public:
String TestConnection(
String featuresource
) abstract
J#
public abstract string TestConnection(
string featuresource
)
JScript
public abstract function TestConnection(
featuresource : String
) : String

See Also

ServerConnectionBase Class
ServerConnectionBase.TestConnection Overload List


TryGetResourceType Method

ServerConnectionBase.TryGetResourceType Method
[image]

Gets an object type from the resourceID. Use the ResourceTypeLookup to add or remove types.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function TryGetResourceType( _
ByVal resourceID As String _
) As Type
C#
public virtual Type TryGetResourceType(
string resourceID
)
C++
public:
virtual Type TryGetResourceType(
String resourceID
)
J#
public virtual Type TryGetResourceType(
string resourceID
)
JScript
public virtual function TryGetResourceType(
resourceID : String
) : Type

Parameters

resourceID
The resourceID for the resource

Return Value

The type of the given item, returns null if no such type exists

See Also

ServerConnectionBase Class


UpdateResourceReferences Method

ServerConnectionBase.UpdateResourceReferences Method
[image]

Updates all resource references inside an object.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub UpdateResourceReferences( _
ByVal o As Object, _
ByVal oldresourcepath As String, _
ByVal newresourcepath As String, _
ByVal folderupdates As Boolean _
)
C#
public virtual void UpdateResourceReferences(
object o,
string oldresourcepath,
string newresourcepath,
bool folderupdates
)
C++
public:
virtual void UpdateResourceReferences(
Object o,
String oldresourcepath,
String newresourcepath,
bool folderupdates
)
J#
public virtual void UpdateResourceReferences(
object o,
string oldresourcepath,
string newresourcepath,
bool folderupdates
)
JScript
public virtual function UpdateResourceReferences(
o : Object,
oldresourcepath : String,
newresourcepath : String,
folderupdates : bool
)

Parameters

o
The object in which the resource references are to be updated
oldresourcepath
The current resource path, the one updating from
newresourcepath
The new resource path, the one updating to
folderupdates
True if the old and new resource path identifiers are folders, false otherwise

See Also

ServerConnectionBase Class


UploadPackage Method

ServerConnectionBase.UploadPackage Method
[image]

Upload a MapGuide Package file to the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub UploadPackage( _
ByVal filename As String, _
ByVal callback As Utility.StreamCopyProgressDelegate _
)
C#
public abstract void UploadPackage(
string filename,
Utility.StreamCopyProgressDelegate callback
)
C++
public:
void UploadPackage(
String filename,
Utility.StreamCopyProgressDelegate callback
) abstract
J#
public abstract void UploadPackage(
string filename,
Utility.StreamCopyProgressDelegate callback
)
JScript
public abstract function UploadPackage(
filename : String,
callback : Utility.StreamCopyProgressDelegate
)

Parameters

filename
Name of the file to upload
callback
A callback argument used to display progress. May be null.

See Also

ServerConnectionBase Class


WriteResource Method

ServerConnectionBase.WriteResource Method
[image]

Writes an object into a resourceID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteResource( _
ByVal resourceid As String, _
ByVal resource As Object _
)
C#
public virtual void WriteResource(
string resourceid,
object resource
)
C++
public:
virtual void WriteResource(
String resourceid,
Object resource
)
J#
public virtual void WriteResource(
string resourceid,
object resource
)
JScript
public virtual function WriteResource(
resourceid : String,
resource : Object
)

Parameters

resourceid
The resource to write into
resource
The resourcec to write

See Also

ServerConnectionBase Class


ServerConnectionI Interface

ServerConnectionI Interface
See Also Example Members
[image]

Primary connection to the MapGuide Server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface ServerConnectionI
Implements IDisposable
C#
public interface ServerConnectionI : IDisposable
C++
interface class ServerConnectionI : IDisposable
J#
public interface ServerConnectionI implements IDisposable
JScript
public interface ServerConnectionI extends IDisposable

Types that implement ServerConnectionI

Type | Description
OSGeo.MapGuide.MaestroAPI.HttpServerConnection | Primary http based connection to the MapGuide Server
OSGeo.MapGuide.MaestroAPI.LocalNativeConnection | A connection to the server, using the Native API. Only works locally, or with special firewall rules for the server.

See Also

ServerConnectionI Members


ServerConnectionI Members

ServerConnectionI Members
See Also Example Properties Methods
[image]

Primary connection to the MapGuide Server

The following tables list the members exposed by ServerConnectionI.

Public Properties

 | Name | Description
Public property | AutoRestartSession | Gets or sets a value indicating if the session should automatically be restarted if it expires
Public property | CoordinateSystem |
Public property | DisableValidation |
Public property | DisplayName | Gets a string that can be used to identify the server by a user
Public property | FeatureProviders |
Public property | MaxTestedVersion |
Public property | RepositoryResources |
Public property | SessionID |
Public property | SiteVersion |
Top

Public Methods

 | Name | Description
Public method | CopyFolder |
Public method | CopyFolderWithReferences |
Public method | CopyResource |
Public method | CreateFolder |
Public method | CreateRuntimeMap | Overloaded. Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.
Public method | DeleteFolder |
Public method | DeleteResource |
Public method | DeleteResourceData |
Public method | DescribeFeatureSource | Overloaded.
Public method | DescribeSchema | Placeholder for actual method call
Public method | DeserializeObject | Overloaded.
Public method | EnumerateGroups | Gets a list of all groups on the server
Public method | EnumerateResourceData |
Public method | EnumerateResourceReferences |
Public method | EnumerateUnmanagedData | Enumerates all unmanaged folders, meaning alias'ed folders
Public method | EnumerateUsers | Overloaded. Gets a list of all users on the server
Public method | GetApplicationContainers | Returns the avalible widget containers on the server
Public method | GetApplicationDefinition |
Public method | GetApplicationTemplates |
Public method | GetApplicationWidgets | Returns the avalible application widgets on the server
Public method | GetFeatureProvider | Returns an installed provider, given the name of the provider
Public method | GetFeatureSource |
Public method | GetFeatureSourceDescription |
Public method | GetFeatureSourceSchema |
Public method | GetFolderHeader |
Public method | GetIdentityProperties | Gets the names of the identity properties from a feature
Public method | GetLayerDefinition |
Public method | GetLegendImage | Renders a minature bitmap of the layers style
Public method | GetMapDefinition |
Public method | GetMapDWF |
Public method | GetProviderCapabilities |
Public method | GetRepositoryResources | Overloaded.
Public method | GetResource |
Public method | GetResourceData |
Public method | GetResourceHeader |
Public method | GetResourceType | Gets the resource type from a resourceID
Public method | GetResourceXmlData |
Public method | GetRuntimeMap |
Public method | GetSelectionXml | Gets the selection from a map
Public method | GetSpatialContextInfo |
Public method | GetWebLayout |
Public method | HasFolder |
Public method | MoveFolder |
Public method | MoveFolderWithReferences |
Public method | MoveResource |
Public method | MoveResourceWithReferences |
Public method | QueryFeatureSource | Overloaded.
Public method | QueryMapFeatures | Overloaded. Selects features from a runtime map, returning a selection Xml.
Public method | RemoveVersionFromProviderName | Removes the version numbers from a providername
Public method | RenderRuntimeMap |
Public method | ResetFeatureSourceSchemaCache |
Public method | ResourceExists |
Public method | RestartSession | Overloaded. Restarts the server session, and creates a new session ID
Public method | SaveResource | Overloaded. Saves a FeatureSource, using its originating resourceId
Public method | SaveResourceAs | Overloaded. Saves a FeatureSource under a different resourceID
Public method | SaveRuntimeMap | Updates an existing runtime map
Public method | SerializeObject | Overloaded.
Public method | SetFolderHeader |
Public method | SetResourceData | Overloaded.
Public method | SetResourceHeader |
Public method | SetResourceXmlData |
Public method | SetSelectionXml | Sets the selection of a map
Public method | TestConnection | Overloaded.
Public method | TryGetResourceType | Gets the resource type from a resourceID
Public method | UploadPackage | Upload a MapGuide Package file to the server
Top

See Also

ServerConnectionI Interface


Properties

ServerConnectionI Properties
[image]

Public Properties

 | Name | Description
Public property | AutoRestartSession | Gets or sets a value indicating if the session should automatically be restarted if it expires
Public property | CoordinateSystem |
Public property | DisableValidation |
Public property | DisplayName | Gets a string that can be used to identify the server by a user
Public property | FeatureProviders |
Public property | MaxTestedVersion |
Public property | RepositoryResources |
Public property | SessionID |
Public property | SiteVersion |
Top

See Also

ServerConnectionI Interface


AutoRestartSession Property

ServerConnectionI.AutoRestartSession Property
[image]

Gets or sets a value indicating if the session should automatically be restarted if it expires

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Property AutoRestartSession As Boolean
C#
bool AutoRestartSession { get; set; }
C++
property bool AutoRestartSession abstract {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_AutoRestartSession();

/** property */
public void set_AutoRestartSession(bool value);
JScript
public function get AutoRestartSession() : bool

public function set AutoRestartSession(value : bool);

See Also

ServerConnectionI Interface


CoordinateSystem Property

ServerConnectionI.CoordinateSystem Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property CoordinateSystem As CoordinateSystem
C#
CoordinateSystem CoordinateSystem { get; }
C++
property CoordinateSystem CoordinateSystem abstract {
CoordinateSystem get();
}
J#
/** property */
public CoordinateSystem get_CoordinateSystem();
JScript
public function get CoordinateSystem() : CoordinateSystem

See Also

ServerConnectionI Interface


DisableValidation Property

ServerConnectionI.DisableValidation Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Property DisableValidation As Boolean
C#
bool DisableValidation { get; set; }
C++
property bool DisableValidation abstract {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_DisableValidation();

/** property */
public void set_DisableValidation(bool value);
JScript
public function get DisableValidation() : bool

public function set DisableValidation(value : bool);

See Also

ServerConnectionI Interface


DisplayName Property

ServerConnectionI.DisplayName Property
[image]

Gets a string that can be used to identify the server by a user

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DisplayName As String
C#
string DisplayName { get; }
C++
property string DisplayName abstract {
String get();
}
J#
/** property */
public string get_DisplayName();
JScript
public function get DisplayName() : String

See Also

ServerConnectionI Interface


FeatureProviders Property

ServerConnectionI.FeatureProviders Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property FeatureProviders As FeatureProviderRegistryFeatureProviderCollection
C#
FeatureProviderRegistryFeatureProviderCollection FeatureProviders { get; }
C++
property FeatureProviderRegistryFeatureProviderCollection FeatureProviders abstract {
FeatureProviderRegistryFeatureProviderCollection get();
}
J#
/** property */
public FeatureProviderRegistryFeatureProviderCollection get_FeatureProviders();
JScript
public function get FeatureProviders() : FeatureProviderRegistryFeatureProviderCollection

See Also

ServerConnectionI Interface


MaxTestedVersion Property

ServerConnectionI.MaxTestedVersion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property MaxTestedVersion As Version
C#
Version MaxTestedVersion { get; }
C++
property Version MaxTestedVersion abstract {
Version get();
}
J#
/** property */
public Version get_MaxTestedVersion();
JScript
public function get MaxTestedVersion() : Version

See Also

ServerConnectionI Interface


RepositoryResources Property

ServerConnectionI.RepositoryResources Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property RepositoryResources As ResourceList
C#
ResourceList RepositoryResources { get; }
C++
property ResourceList RepositoryResources abstract {
ResourceList get();
}
J#
/** property */
public ResourceList get_RepositoryResources();
JScript
public function get RepositoryResources() : ResourceList

See Also

ServerConnectionI Interface


SessionID Property

ServerConnectionI.SessionID Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SessionID As String
C#
string SessionID { get; }
C++
property string SessionID abstract {
String get();
}
J#
/** property */
public string get_SessionID();
JScript
public function get SessionID() : String

See Also

ServerConnectionI Interface


SiteVersion Property

ServerConnectionI.SiteVersion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property SiteVersion As Version
C#
Version SiteVersion { get; }
C++
property Version SiteVersion abstract {
Version get();
}
J#
/** property */
public Version get_SiteVersion();
JScript
public function get SiteVersion() : Version

See Also

ServerConnectionI Interface


Methods

ServerConnectionI Methods
[image]

Public Methods

 | Name | Description
Public method | CopyFolder |
Public method | CopyFolderWithReferences |
Public method | CopyResource |
Public method | CreateFolder |
Public method | CreateRuntimeMap | Overloaded. Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.
Public method | DeleteFolder |
Public method | DeleteResource |
Public method | DeleteResourceData |
Public method | DescribeFeatureSource | Overloaded.
Public method | DescribeSchema | Placeholder for actual method call
Public method | DeserializeObject | Overloaded.
Public method | EnumerateGroups | Gets a list of all groups on the server
Public method | EnumerateResourceData |
Public method | EnumerateResourceReferences |
Public method | EnumerateUnmanagedData | Enumerates all unmanaged folders, meaning alias'ed folders
Public method | EnumerateUsers | Overloaded. Gets a list of all users on the server
Public method | GetApplicationContainers | Returns the avalible widget containers on the server
Public method | GetApplicationDefinition |
Public method | GetApplicationTemplates |
Public method | GetApplicationWidgets | Returns the avalible application widgets on the server
Public method | GetFeatureProvider | Returns an installed provider, given the name of the provider
Public method | GetFeatureSource |
Public method | GetFeatureSourceDescription |
Public method | GetFeatureSourceSchema |
Public method | GetFolderHeader |
Public method | GetIdentityProperties | Gets the names of the identity properties from a feature
Public method | GetLayerDefinition |
Public method | GetLegendImage | Renders a minature bitmap of the layers style
Public method | GetMapDefinition |
Public method | GetMapDWF |
Public method | GetProviderCapabilities |
Public method | GetRepositoryResources | Overloaded.
Public method | GetResource |
Public method | GetResourceData |
Public method | GetResourceHeader |
Public method | GetResourceType | Gets the resource type from a resourceID
Public method | GetResourceXmlData |
Public method | GetRuntimeMap |
Public method | GetSelectionXml | Gets the selection from a map
Public method | GetSpatialContextInfo |
Public method | GetWebLayout |
Public method | HasFolder |
Public method | MoveFolder |
Public method | MoveFolderWithReferences |
Public method | MoveResource |
Public method | MoveResourceWithReferences |
Public method | QueryFeatureSource | Overloaded.
Public method | QueryMapFeatures | Overloaded. Selects features from a runtime map, returning a selection Xml.
Public method | RemoveVersionFromProviderName | Removes the version numbers from a providername
Public method | RenderRuntimeMap |
Public method | ResetFeatureSourceSchemaCache |
Public method | ResourceExists |
Public method | RestartSession | Overloaded. Restarts the server session, and creates a new session ID
Public method | SaveResource | Overloaded. Saves a FeatureSource, using its originating resourceId
Public method | SaveResourceAs | Overloaded. Saves a FeatureSource under a different resourceID
Public method | SaveRuntimeMap | Updates an existing runtime map
Public method | SerializeObject | Overloaded.
Public method | SetFolderHeader |
Public method | SetResourceData | Overloaded.
Public method | SetResourceHeader |
Public method | SetResourceXmlData |
Public method | SetSelectionXml | Sets the selection of a map
Public method | TestConnection | Overloaded.
Public method | TryGetResourceType | Gets the resource type from a resourceID
Public method | UploadPackage | Upload a MapGuide Package file to the server
Top

See Also

ServerConnectionI Interface


CopyFolder Method

ServerConnectionI.CopyFolder Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub CopyFolder( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
)
C#
void CopyFolder(
string oldpath,
string newpath,
bool overwrite
)
C++
void CopyFolder(
String oldpath,
String newpath,
bool overwrite
) abstract
J#
void CopyFolder(
string oldpath,
string newpath,
bool overwrite
)
JScript
function CopyFolder(
oldpath : String,
newpath : String,
overwrite : bool
)

See Also

ServerConnectionI Interface


CopyFolderWithReferences Method

ServerConnectionI.CopyFolderWithReferences Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function CopyFolderWithReferences( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal callback As LengthyOperationCallBack, _
ByVal progress As LengthyOperationProgressCallBack _
) As Boolean
C#
bool CopyFolderWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
C++
bool CopyFolderWithReferences(
String oldpath,
String newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
) abstract
J#
bool CopyFolderWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
JScript
function CopyFolderWithReferences(
oldpath : String,
newpath : String,
callback : LengthyOperationCallBack,
progress : LengthyOperationProgressCallBack
) : bool

See Also

ServerConnectionI Interface


CopyResource Method

ServerConnectionI.CopyResource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub CopyResource( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
)
C#
void CopyResource(
string oldpath,
string newpath,
bool overwrite
)
C++
void CopyResource(
String oldpath,
String newpath,
bool overwrite
) abstract
J#
void CopyResource(
string oldpath,
string newpath,
bool overwrite
)
JScript
function CopyResource(
oldpath : String,
newpath : String,
overwrite : bool
)

See Also

ServerConnectionI Interface


CreateFolder Method

ServerConnectionI.CreateFolder Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub CreateFolder( _
ByVal folderpath As String _
)
C#
void CreateFolder(
string folderpath
)
C++
void CreateFolder(
String folderpath
) abstract
J#
void CreateFolder(
string folderpath
)
JScript
function CreateFolder(
folderpath : String
)

See Also

ServerConnectionI Interface


CreateRuntimeMap Method

ServerConnectionI.CreateRuntimeMap Method

Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.

Overload List

 | Name | Description
Public method | CreateRuntimeMap (String) | Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.
Public method | CreateRuntimeMap (String, MapDefinition) | Creates a runtime map on the server
Public method | CreateRuntimeMap (String, RuntimeMap) | Creates a runtime map on the server
Public method | CreateRuntimeMap (String, String) | Creates a runtime map on the server

See Also

ServerConnectionI Interface


CreateRuntimeMap Method (String)

ServerConnectionI.CreateRuntimeMap Method (String)
See Also Example
[image]

Creates a runtime map on the server. The map name will be the name of the resource, without path information. This is equivalent to the way the AJAX viewer creates the runtime map.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub CreateRuntimeMap( _
ByVal resourceID As String _
)
C#
public abstract void CreateRuntimeMap(
string resourceID
)
C++
public:
void CreateRuntimeMap(
String resourceID
) abstract
J#
public abstract void CreateRuntimeMap(
string resourceID
)
JScript
public abstract function CreateRuntimeMap(
resourceID : String
)

Parameters

resourceID
The mapDefinition resource id

See Also

ServerConnectionI Interface
ServerConnectionI.CreateRuntimeMap Overload List


CreateRuntimeMap Method (String, MapDefinition)

ServerConnectionI.CreateRuntimeMap Method (String, MapDefinition)
See Also Example
[image]

Creates a runtime map on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub CreateRuntimeMap( _
ByVal resourceID As String, _
ByVal map As MapDefinition _
)
C#
public abstract void CreateRuntimeMap(
string resourceID,
MapDefinition map
)
C++
public:
void CreateRuntimeMap(
String resourceID,
MapDefinition map
) abstract
J#
public abstract void CreateRuntimeMap(
string resourceID,
MapDefinition map
)
JScript
public abstract function CreateRuntimeMap(
resourceID : String,
map : MapDefinition
)

Parameters

resourceID
The target resource id for the runtime map
map
The mapdefinition to base the map on

See Also

ServerConnectionI Interface
ServerConnectionI.CreateRuntimeMap Overload List


CreateRuntimeMap Method (String, RuntimeMap)

ServerConnectionI.CreateRuntimeMap Method (String, RuntimeMap)
See Also Example
[image]

Creates a runtime map on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub CreateRuntimeMap( _
ByVal resourceID As String, _
ByVal map As RuntimeMap _
)
C#
public abstract void CreateRuntimeMap(
string resourceID,
RuntimeMap map
)
C++
public:
void CreateRuntimeMap(
String resourceID,
RuntimeMap map
) abstract
J#
public abstract void CreateRuntimeMap(
string resourceID,
RuntimeMap map
)
JScript
public abstract function CreateRuntimeMap(
resourceID : String,
map : RuntimeMap
)

Parameters

resourceID
The target resource id for the runtime map
map
The mapdefinition to base the map on

See Also

ServerConnectionI Interface
ServerConnectionI.CreateRuntimeMap Overload List


CreateRuntimeMap Method (String, String)

ServerConnectionI.CreateRuntimeMap Method (String, String)
See Also Example
[image]

Creates a runtime map on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub CreateRuntimeMap( _
ByVal resourceID As String, _
ByVal mapdefinition As String _
)
C#
public abstract void CreateRuntimeMap(
string resourceID,
string mapdefinition
)
C++
public:
void CreateRuntimeMap(
String resourceID,
String mapdefinition
) abstract
J#
public abstract void CreateRuntimeMap(
string resourceID,
string mapdefinition
)
JScript
public abstract function CreateRuntimeMap(
resourceID : String,
mapdefinition : String
)

Parameters

resourceID
The target resource id for the runtime map
mapdefinition
The mapdefinition to base the map on

See Also

ServerConnectionI Interface
ServerConnectionI.CreateRuntimeMap Overload List


DeleteFolder Method

ServerConnectionI.DeleteFolder Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub DeleteFolder( _
ByVal folderPath As String _
)
C#
void DeleteFolder(
string folderPath
)
C++
void DeleteFolder(
String folderPath
) abstract
J#
void DeleteFolder(
string folderPath
)
JScript
function DeleteFolder(
folderPath : String
)

See Also

ServerConnectionI Interface


DeleteResource Method

ServerConnectionI.DeleteResource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub DeleteResource( _
ByVal resourceID As String _
)
C#
void DeleteResource(
string resourceID
)
C++
void DeleteResource(
String resourceID
) abstract
J#
void DeleteResource(
string resourceID
)
JScript
function DeleteResource(
resourceID : String
)

See Also

ServerConnectionI Interface


DeleteResourceData Method

ServerConnectionI.DeleteResourceData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub DeleteResourceData( _
ByVal resourceID As String, _
ByVal dataname As String _
)
C#
void DeleteResourceData(
string resourceID,
string dataname
)
C++
void DeleteResourceData(
String resourceID,
String dataname
) abstract
J#
void DeleteResourceData(
string resourceID,
string dataname
)
JScript
function DeleteResourceData(
resourceID : String,
dataname : String
)

See Also

ServerConnectionI Interface


DescribeFeatureSource Method

ServerConnectionI.DescribeFeatureSource Method

Overload List

 | Name | Description
Public method | DescribeFeatureSource (String) |
Public method | DescribeFeatureSource (String, String) |

See Also

ServerConnectionI Interface


DescribeFeatureSource Method (String)

ServerConnectionI.DescribeFeatureSource Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function DescribeFeatureSource( _
ByVal resourceID As String _
) As FeatureSourceDescription
C#
public abstract FeatureSourceDescription DescribeFeatureSource(
string resourceID
)
C++
public:
FeatureSourceDescription DescribeFeatureSource(
String resourceID
) abstract
J#
public abstract FeatureSourceDescription DescribeFeatureSource(
string resourceID
)
JScript
public abstract function DescribeFeatureSource(
resourceID : String
) : FeatureSourceDescription

See Also

ServerConnectionI Interface
ServerConnectionI.DescribeFeatureSource Overload List


DescribeFeatureSource Method (String, String)

ServerConnectionI.DescribeFeatureSource Method (String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function DescribeFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String _
) As FeatureSourceDescription
C#
public abstract FeatureSourceDescription DescribeFeatureSource(
string resourceID,
string schema
)
C++
public:
FeatureSourceDescription DescribeFeatureSource(
String resourceID,
String schema
) abstract
J#
public abstract FeatureSourceDescription DescribeFeatureSource(
string resourceID,
string schema
)
JScript
public abstract function DescribeFeatureSource(
resourceID : String,
schema : String
) : FeatureSourceDescription

See Also

ServerConnectionI Interface
ServerConnectionI.DescribeFeatureSource Overload List


DescribeSchema Method

ServerConnectionI.DescribeSchema Method
[image]

Placeholder for actual method call

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub DescribeSchema()
C#
void DescribeSchema()
C++
void DescribeSchema() abstract
J#
void DescribeSchema()
JScript
function DescribeSchema()

See Also

ServerConnectionI Interface


DeserializeObject Generic Method

ServerConnectionI.DeserializeObject Generic Method

Overload List

 | Name | Description
Public method | DeserializeObject (Type, Stream) |
Public method | DeserializeObject (Stream) |

See Also

ServerConnectionI Interface


DeserializeObject Method (Type, Stream)

ServerConnectionI.DeserializeObject Method (Type, Stream)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function DeserializeObject( _
ByVal type As Type, _
ByVal data As Stream _
) As Object
C#
public abstract object DeserializeObject(
Type type,
Stream data
)
C++
public:
Object DeserializeObject(
Type type,
Stream data
) abstract
J#
public abstract object DeserializeObject(
Type type,
Stream data
)
JScript
public abstract function DeserializeObject(
type : Type,
data : Stream
) : Object

See Also

ServerConnectionI Interface
ServerConnectionI.DeserializeObject Overload List


DeserializeObject Generic Method (Stream)

ServerConnectionI.DeserializeObject Generic Method (Stream)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function DeserializeObject(Of T)( _
ByVal data As Stream _
)
C#
public abstract T DeserializeObject<T>(
Stream data
)
C++
public:
T DeserializeObject<T>(
Stream data
) abstract
J#
public abstract T DeserializeObject<T>(
Stream data
)
JScript
JScript does not support generic types and methods.

See Also

ServerConnectionI Interface
ServerConnectionI.DeserializeObject Overload List


EnumerateGroups Method

ServerConnectionI.EnumerateGroups Method
[image]

Gets a list of all groups on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function EnumerateGroups() As GroupList
C#
GroupList EnumerateGroups()
C++
GroupList EnumerateGroups() abstract
J#
GroupList EnumerateGroups()
JScript
function EnumerateGroups() : GroupList

Return Value

The list of groups

See Also

ServerConnectionI Interface


EnumerateResourceData Method

ServerConnectionI.EnumerateResourceData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function EnumerateResourceData( _
ByVal resourceID As String _
) As ResourceDataList
C#
ResourceDataList EnumerateResourceData(
string resourceID
)
C++
ResourceDataList EnumerateResourceData(
String resourceID
) abstract
J#
ResourceDataList EnumerateResourceData(
string resourceID
)
JScript
function EnumerateResourceData(
resourceID : String
) : ResourceDataList

See Also

ServerConnectionI Interface


EnumerateResourceReferences Method

ServerConnectionI.EnumerateResourceReferences Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function EnumerateResourceReferences( _
ByVal resourceid As String _
) As ResourceReferenceList
C#
ResourceReferenceList EnumerateResourceReferences(
string resourceid
)
C++
ResourceReferenceList EnumerateResourceReferences(
String resourceid
) abstract
J#
ResourceReferenceList EnumerateResourceReferences(
string resourceid
)
JScript
function EnumerateResourceReferences(
resourceid : String
) : ResourceReferenceList

See Also

ServerConnectionI Interface


EnumerateUnmanagedData Method

ServerConnectionI.EnumerateUnmanagedData Method
[image]

Enumerates all unmanaged folders, meaning alias'ed folders

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function EnumerateUnmanagedData( _
ByVal startpath As String, _
ByVal filter As String, _
ByVal recursive As Boolean, _
ByVal type As UnmanagedDataTypes _
) As UnmanagedDataList
C#
UnmanagedDataList EnumerateUnmanagedData(
string startpath,
string filter,
bool recursive,
UnmanagedDataTypes type
)
C++
UnmanagedDataList EnumerateUnmanagedData(
String startpath,
String filter,
bool recursive,
UnmanagedDataTypes type
) abstract
J#
UnmanagedDataList EnumerateUnmanagedData(
string startpath,
string filter,
bool recursive,
UnmanagedDataTypes type
)
JScript
function EnumerateUnmanagedData(
startpath : String,
filter : String,
recursive : bool,
type : UnmanagedDataTypes
) : UnmanagedDataList

Parameters

startpath
The path to retrieve the data from
filter
A filter applied to the items
recursive
True if the list should contains recursive results
type
The type of data to return

Return Value

A list of unmanaged data

See Also

ServerConnectionI Interface


EnumerateUsers Method

ServerConnectionI.EnumerateUsers Method

Gets a list of all users on the server

Overload List

 | Name | Description
Public method | EnumerateUsers | Gets a list of all users on the server
Public method | EnumerateUsers (String) | Gets a list of users in a group

See Also

ServerConnectionI Interface


EnumerateUsers Method ()

ServerConnectionI.EnumerateUsers Method ()
See Also Example
[image]

Gets a list of all users on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function EnumerateUsers() As UserList
C#
public abstract UserList EnumerateUsers()
C++
public:
UserList EnumerateUsers() abstract
J#
public abstract UserList EnumerateUsers()
JScript
public abstract function EnumerateUsers() : UserList

Return Value

The list of users

See Also

ServerConnectionI Interface
ServerConnectionI.EnumerateUsers Overload List


EnumerateUsers Method (String)

ServerConnectionI.EnumerateUsers Method (String)
See Also Example
[image]

Gets a list of users in a group

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function EnumerateUsers( _
ByVal group As String _
) As UserList
C#
public abstract UserList EnumerateUsers(
string group
)
C++
public:
UserList EnumerateUsers(
String group
) abstract
J#
public abstract UserList EnumerateUsers(
string group
)
JScript
public abstract function EnumerateUsers(
group : String
) : UserList

Parameters

group
The group to retrieve the users from

Return Value

The list of users

See Also

ServerConnectionI Interface
ServerConnectionI.EnumerateUsers Overload List


GetApplicationContainers Method

ServerConnectionI.GetApplicationContainers Method
[image]

Returns the avalible widget containers on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetApplicationContainers() As ApplicationDefinitionContainerInfoSet
C#
ApplicationDefinitionContainerInfoSet GetApplicationContainers()
C++
ApplicationDefinitionContainerInfoSet GetApplicationContainers() abstract
J#
ApplicationDefinitionContainerInfoSet GetApplicationContainers()
JScript
function GetApplicationContainers() : ApplicationDefinitionContainerInfoSet

Return Value

The avalible widget containers on the server

See Also

ServerConnectionI Interface


GetApplicationDefinition Method

ServerConnectionI.GetApplicationDefinition Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetApplicationDefinition( _
ByVal resourceID As String _
) As ApplicationDefinitionType
C#
ApplicationDefinitionType GetApplicationDefinition(
string resourceID
)
C++
ApplicationDefinitionType GetApplicationDefinition(
String resourceID
) abstract
J#
ApplicationDefinitionType GetApplicationDefinition(
string resourceID
)
JScript
function GetApplicationDefinition(
resourceID : String
) : ApplicationDefinitionType

See Also

ServerConnectionI Interface


GetApplicationTemplates Method

ServerConnectionI.GetApplicationTemplates Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetApplicationTemplates() As ApplicationDefinitionTemplateInfoSet
C#
ApplicationDefinitionTemplateInfoSet GetApplicationTemplates()
C++
ApplicationDefinitionTemplateInfoSet GetApplicationTemplates() abstract
J#
ApplicationDefinitionTemplateInfoSet GetApplicationTemplates()
JScript
function GetApplicationTemplates() : ApplicationDefinitionTemplateInfoSet

See Also

ServerConnectionI Interface


GetApplicationWidgets Method

ServerConnectionI.GetApplicationWidgets Method
[image]

Returns the avalible application widgets on the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetApplicationWidgets() As ApplicationDefinitionWidgetInfoSet
C#
ApplicationDefinitionWidgetInfoSet GetApplicationWidgets()
C++
ApplicationDefinitionWidgetInfoSet GetApplicationWidgets() abstract
J#
ApplicationDefinitionWidgetInfoSet GetApplicationWidgets()
JScript
function GetApplicationWidgets() : ApplicationDefinitionWidgetInfoSet

Return Value

The avalible application widgets on the server

See Also

ServerConnectionI Interface


GetFeatureProvider Method

ServerConnectionI.GetFeatureProvider Method
[image]

Returns an installed provider, given the name of the provider

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetFeatureProvider( _
ByVal providername As String _
) As FeatureProviderRegistryFeatureProvider
C#
FeatureProviderRegistryFeatureProvider GetFeatureProvider(
string providername
)
C++
FeatureProviderRegistryFeatureProvider GetFeatureProvider(
String providername
) abstract
J#
FeatureProviderRegistryFeatureProvider GetFeatureProvider(
string providername
)
JScript
function GetFeatureProvider(
providername : String
) : FeatureProviderRegistryFeatureProvider

Parameters

providername
The name of the provider

Return Value

The first matching provider or null

See Also

ServerConnectionI Interface


GetFeatureSource Method

ServerConnectionI.GetFeatureSource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetFeatureSource( _
ByVal resourceID As String _
) As FeatureSource
C#
FeatureSource GetFeatureSource(
string resourceID
)
C++
FeatureSource GetFeatureSource(
String resourceID
) abstract
J#
FeatureSource GetFeatureSource(
string resourceID
)
JScript
function GetFeatureSource(
resourceID : String
) : FeatureSource

See Also

ServerConnectionI Interface


GetFeatureSourceDescription Method

ServerConnectionI.GetFeatureSourceDescription Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetFeatureSourceDescription( _
ByVal resourceID As String _
) As FeatureSourceDescription
C#
FeatureSourceDescription GetFeatureSourceDescription(
string resourceID
)
C++
FeatureSourceDescription GetFeatureSourceDescription(
String resourceID
) abstract
J#
FeatureSourceDescription GetFeatureSourceDescription(
string resourceID
)
JScript
function GetFeatureSourceDescription(
resourceID : String
) : FeatureSourceDescription

See Also

ServerConnectionI Interface


GetFeatureSourceSchema Method

ServerConnectionI.GetFeatureSourceSchema Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetFeatureSourceSchema( _
ByVal resourceID As String, _
ByVal schema As String _
) As FeatureSourceDescription.FeatureSourceSchema
C#
FeatureSourceDescription.FeatureSourceSchema GetFeatureSourceSchema(
string resourceID,
string schema
)
C++
FeatureSourceDescription.FeatureSourceSchema GetFeatureSourceSchema(
String resourceID,
String schema
) abstract
J#
FeatureSourceDescription.FeatureSourceSchema GetFeatureSourceSchema(
string resourceID,
string schema
)
JScript
function GetFeatureSourceSchema(
resourceID : String,
schema : String
) : FeatureSourceDescription.FeatureSourceSchema

See Also

ServerConnectionI Interface


GetFolderHeader Method

ServerConnectionI.GetFolderHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetFolderHeader( _
ByVal resourceID As String _
) As ResourceFolderHeaderType
C#
ResourceFolderHeaderType GetFolderHeader(
string resourceID
)
C++
ResourceFolderHeaderType GetFolderHeader(
String resourceID
) abstract
J#
ResourceFolderHeaderType GetFolderHeader(
string resourceID
)
JScript
function GetFolderHeader(
resourceID : String
) : ResourceFolderHeaderType

See Also

ServerConnectionI Interface


GetIdentityProperties Method

ServerConnectionI.GetIdentityProperties Method
[image]

Gets the names of the identity properties from a feature

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetIdentityProperties( _
ByVal resourceID As String, _
ByVal classname As String _
) As String()
C#
string[] GetIdentityProperties(
string resourceID,
string classname
)
C++
array<String>^ GetIdentityProperties(
String resourceID,
String classname
) abstract
J#
string[] GetIdentityProperties(
string resourceID,
string classname
)
JScript
function GetIdentityProperties(
resourceID : String,
classname : String
) : String[]

Parameters

resourceID
The resourceID for the FeatureSource
classname
The classname of the feature, including schema

Return Value

A string array with the found identities

See Also

ServerConnectionI Interface


GetLayerDefinition Method

ServerConnectionI.GetLayerDefinition Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetLayerDefinition( _
ByVal resourceID As String _
) As LayerDefinition
C#
LayerDefinition GetLayerDefinition(
string resourceID
)
C++
LayerDefinition GetLayerDefinition(
String resourceID
) abstract
J#
LayerDefinition GetLayerDefinition(
string resourceID
)
JScript
function GetLayerDefinition(
resourceID : String
) : LayerDefinition

See Also

ServerConnectionI Interface


GetLegendImage Method

ServerConnectionI.GetLegendImage Method
[image]

Renders a minature bitmap of the layers style

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetLegendImage( _
ByVal scale As Double, _
ByVal layerdefinition As String, _
ByVal themeIndex As Integer, _
ByVal type As Integer _
) As Image
C#
Image GetLegendImage(
double scale,
string layerdefinition,
int themeIndex,
int type
)
C++
Image GetLegendImage(
double scale,
String layerdefinition,
int themeIndex,
int type
) abstract
J#
Image GetLegendImage(
double scale,
string layerdefinition,
int themeIndex,
int type
)
JScript
function GetLegendImage(
scale : double,
layerdefinition : String,
themeIndex : int,
type : int
) : Image

Parameters

scale
The scale for the bitmap to match
layerdefinition
The layer the image should represent
themeIndex
If the layer is themed, this gives the theme index, otherwise set to 0
type
The geometry type, 1 for point, 2 for line, 3 for area, 4 for composite

Return Value

The minature bitmap

See Also

ServerConnectionI Interface


GetMapDefinition Method

ServerConnectionI.GetMapDefinition Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetMapDefinition( _
ByVal resourceID As String _
) As MapDefinition
C#
MapDefinition GetMapDefinition(
string resourceID
)
C++
MapDefinition GetMapDefinition(
String resourceID
) abstract
J#
MapDefinition GetMapDefinition(
string resourceID
)
JScript
function GetMapDefinition(
resourceID : String
) : MapDefinition

See Also

ServerConnectionI Interface


GetMapDWF Method

ServerConnectionI.GetMapDWF Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetMapDWF( _
ByVal resourceID As String _
) As Stream
C#
Stream GetMapDWF(
string resourceID
)
C++
Stream GetMapDWF(
String resourceID
) abstract
J#
Stream GetMapDWF(
string resourceID
)
JScript
function GetMapDWF(
resourceID : String
) : Stream

See Also

ServerConnectionI Interface


GetProviderCapabilities Method

ServerConnectionI.GetProviderCapabilities Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetProviderCapabilities( _
ByVal provider As String _
) As FdoProviderCapabilities
C#
FdoProviderCapabilities GetProviderCapabilities(
string provider
)
C++
FdoProviderCapabilities GetProviderCapabilities(
String provider
) abstract
J#
FdoProviderCapabilities GetProviderCapabilities(
string provider
)
JScript
function GetProviderCapabilities(
provider : String
) : FdoProviderCapabilities

See Also

ServerConnectionI Interface


GetRepositoryResources Method

ServerConnectionI.GetRepositoryResources Method

Overload List

 | Name | Description
Public method | GetRepositoryResources |
Public method | GetRepositoryResources (Int32) |
Public method | GetRepositoryResources (String) |
Public method | GetRepositoryResources (String, Int32) |
Public method | GetRepositoryResources (String, String) |
Public method | GetRepositoryResources (String, String, Int32) |

See Also

ServerConnectionI Interface


GetRepositoryResources Method ()

ServerConnectionI.GetRepositoryResources Method ()
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetRepositoryResources() As ResourceList
C#
public abstract ResourceList GetRepositoryResources()
C++
public:
ResourceList GetRepositoryResources() abstract
J#
public abstract ResourceList GetRepositoryResources()
JScript
public abstract function GetRepositoryResources() : ResourceList

See Also

ServerConnectionI Interface
ServerConnectionI.GetRepositoryResources Overload List


GetRepositoryResources Method (Int32)

ServerConnectionI.GetRepositoryResources Method (Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetRepositoryResources( _
ByVal depth As Integer _
) As ResourceList
C#
public abstract ResourceList GetRepositoryResources(
int depth
)
C++
public:
ResourceList GetRepositoryResources(
int depth
) abstract
J#
public abstract ResourceList GetRepositoryResources(
int depth
)
JScript
public abstract function GetRepositoryResources(
depth : int
) : ResourceList

See Also

ServerConnectionI Interface
ServerConnectionI.GetRepositoryResources Overload List


GetRepositoryResources Method (String)

ServerConnectionI.GetRepositoryResources Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetRepositoryResources( _
ByVal startingpoint As String _
) As ResourceList
C#
public abstract ResourceList GetRepositoryResources(
string startingpoint
)
C++
public:
ResourceList GetRepositoryResources(
String startingpoint
) abstract
J#
public abstract ResourceList GetRepositoryResources(
string startingpoint
)
JScript
public abstract function GetRepositoryResources(
startingpoint : String
) : ResourceList

See Also

ServerConnectionI Interface
ServerConnectionI.GetRepositoryResources Overload List


GetRepositoryResources Method (String, Int32)

ServerConnectionI.GetRepositoryResources Method (String, Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetRepositoryResources( _
ByVal startingpoint As String, _
ByVal depth As Integer _
) As ResourceList
C#
public abstract ResourceList GetRepositoryResources(
string startingpoint,
int depth
)
C++
public:
ResourceList GetRepositoryResources(
String startingpoint,
int depth
) abstract
J#
public abstract ResourceList GetRepositoryResources(
string startingpoint,
int depth
)
JScript
public abstract function GetRepositoryResources(
startingpoint : String,
depth : int
) : ResourceList

See Also

ServerConnectionI Interface
ServerConnectionI.GetRepositoryResources Overload List


GetRepositoryResources Method (String, String)

ServerConnectionI.GetRepositoryResources Method (String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetRepositoryResources( _
ByVal startingpoint As String, _
ByVal type As String _
) As ResourceList
C#
public abstract ResourceList GetRepositoryResources(
string startingpoint,
string type
)
C++
public:
ResourceList GetRepositoryResources(
String startingpoint,
String type
) abstract
J#
public abstract ResourceList GetRepositoryResources(
string startingpoint,
string type
)
JScript
public abstract function GetRepositoryResources(
startingpoint : String,
type : String
) : ResourceList

See Also

ServerConnectionI Interface
ServerConnectionI.GetRepositoryResources Overload List


GetRepositoryResources Method (String, String, Int32)

ServerConnectionI.GetRepositoryResources Method (String, String, Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetRepositoryResources( _
ByVal startingpoint As String, _
ByVal type As String, _
ByVal depth As Integer _
) As ResourceList
C#
public abstract ResourceList GetRepositoryResources(
string startingpoint,
string type,
int depth
)
C++
public:
ResourceList GetRepositoryResources(
String startingpoint,
String type,
int depth
) abstract
J#
public abstract ResourceList GetRepositoryResources(
string startingpoint,
string type,
int depth
)
JScript
public abstract function GetRepositoryResources(
startingpoint : String,
type : String,
depth : int
) : ResourceList

See Also

ServerConnectionI Interface
ServerConnectionI.GetRepositoryResources Overload List


GetResource Method

ServerConnectionI.GetResource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetResource( _
ByVal resourceID As String _
) As Object
C#
object GetResource(
string resourceID
)
C++
Object GetResource(
String resourceID
) abstract
J#
object GetResource(
string resourceID
)
JScript
function GetResource(
resourceID : String
) : Object

See Also

ServerConnectionI Interface


GetResourceData Method

ServerConnectionI.GetResourceData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetResourceData( _
ByVal resourceID As String, _
ByVal dataname As String _
) As MemoryStream
C#
MemoryStream GetResourceData(
string resourceID,
string dataname
)
C++
MemoryStream GetResourceData(
String resourceID,
String dataname
) abstract
J#
MemoryStream GetResourceData(
string resourceID,
string dataname
)
JScript
function GetResourceData(
resourceID : String,
dataname : String
) : MemoryStream

See Also

ServerConnectionI Interface


GetResourceHeader Method

ServerConnectionI.GetResourceHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetResourceHeader( _
ByVal resourceID As String _
) As ResourceDocumentHeaderType
C#
ResourceDocumentHeaderType GetResourceHeader(
string resourceID
)
C++
ResourceDocumentHeaderType GetResourceHeader(
String resourceID
) abstract
J#
ResourceDocumentHeaderType GetResourceHeader(
string resourceID
)
JScript
function GetResourceHeader(
resourceID : String
) : ResourceDocumentHeaderType

See Also

ServerConnectionI Interface


GetResourceType Method

ServerConnectionI.GetResourceType Method
[image]

Gets the resource type from a resourceID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetResourceType( _
ByVal resourceID As String _
) As Type
C#
Type GetResourceType(
string resourceID
)
C++
Type GetResourceType(
String resourceID
) abstract
J#
Type GetResourceType(
string resourceID
)
JScript
function GetResourceType(
resourceID : String
) : Type

Parameters

resourceID
The resourceID for the resource

Return Value

The type of the given item, throws an exception if the type does not exist

See Also

ServerConnectionI Interface


GetResourceXmlData Method

ServerConnectionI.GetResourceXmlData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetResourceXmlData( _
ByVal resourceID As String _
) As Byte()
C#
byte[] GetResourceXmlData(
string resourceID
)
C++
array<char>^ GetResourceXmlData(
String resourceID
) abstract
J#
byte[] GetResourceXmlData(
string resourceID
)
JScript
function GetResourceXmlData(
resourceID : String
) : Byte[]

See Also

ServerConnectionI Interface


GetRuntimeMap Method

ServerConnectionI.GetRuntimeMap Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetRuntimeMap( _
ByVal resourceID As String _
) As RuntimeMap
C#
RuntimeMap GetRuntimeMap(
string resourceID
)
C++
RuntimeMap GetRuntimeMap(
String resourceID
) abstract
J#
RuntimeMap GetRuntimeMap(
string resourceID
)
JScript
function GetRuntimeMap(
resourceID : String
) : RuntimeMap

See Also

ServerConnectionI Interface


GetSelectionXml Method

ServerConnectionI.GetSelectionXml Method
[image]

Gets the selection from a map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetSelectionXml( _
ByVal runtimeMap As String _
) As String
C#
string GetSelectionXml(
string runtimeMap
)
C++
String GetSelectionXml(
String runtimeMap
) abstract
J#
string GetSelectionXml(
string runtimeMap
)
JScript
function GetSelectionXml(
runtimeMap : String
) : String

Parameters

runtimeMap
The resourceID of the runtime map

Return Value

The selection xml

See Also

ServerConnectionI Interface


GetSpatialContextInfo Method

ServerConnectionI.GetSpatialContextInfo Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetSpatialContextInfo( _
ByVal resourceID As String, _
ByVal activeOnly As Boolean _
) As FdoSpatialContextList
C#
FdoSpatialContextList GetSpatialContextInfo(
string resourceID,
bool activeOnly
)
C++
FdoSpatialContextList GetSpatialContextInfo(
String resourceID,
bool activeOnly
) abstract
J#
FdoSpatialContextList GetSpatialContextInfo(
string resourceID,
bool activeOnly
)
JScript
function GetSpatialContextInfo(
resourceID : String,
activeOnly : bool
) : FdoSpatialContextList

See Also

ServerConnectionI Interface


GetWebLayout Method

ServerConnectionI.GetWebLayout Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function GetWebLayout( _
ByVal resourceID As String _
) As WebLayout
C#
WebLayout GetWebLayout(
string resourceID
)
C++
WebLayout GetWebLayout(
String resourceID
) abstract
J#
WebLayout GetWebLayout(
string resourceID
)
JScript
function GetWebLayout(
resourceID : String
) : WebLayout

See Also

ServerConnectionI Interface


HasFolder Method

ServerConnectionI.HasFolder Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function HasFolder( _
ByVal folderpath As String _
) As Boolean
C#
bool HasFolder(
string folderpath
)
C++
bool HasFolder(
String folderpath
) abstract
J#
bool HasFolder(
string folderpath
)
JScript
function HasFolder(
folderpath : String
) : bool

See Also

ServerConnectionI Interface


MoveFolder Method

ServerConnectionI.MoveFolder Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub MoveFolder( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
)
C#
void MoveFolder(
string oldpath,
string newpath,
bool overwrite
)
C++
void MoveFolder(
String oldpath,
String newpath,
bool overwrite
) abstract
J#
void MoveFolder(
string oldpath,
string newpath,
bool overwrite
)
JScript
function MoveFolder(
oldpath : String,
newpath : String,
overwrite : bool
)

See Also

ServerConnectionI Interface


MoveFolderWithReferences Method

ServerConnectionI.MoveFolderWithReferences Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function MoveFolderWithReferences( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal callback As LengthyOperationCallBack, _
ByVal progress As LengthyOperationProgressCallBack _
) As Boolean
C#
bool MoveFolderWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
C++
bool MoveFolderWithReferences(
String oldpath,
String newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
) abstract
J#
bool MoveFolderWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
JScript
function MoveFolderWithReferences(
oldpath : String,
newpath : String,
callback : LengthyOperationCallBack,
progress : LengthyOperationProgressCallBack
) : bool

See Also

ServerConnectionI Interface


MoveResource Method

ServerConnectionI.MoveResource Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub MoveResource( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal overwrite As Boolean _
)
C#
void MoveResource(
string oldpath,
string newpath,
bool overwrite
)
C++
void MoveResource(
String oldpath,
String newpath,
bool overwrite
) abstract
J#
void MoveResource(
string oldpath,
string newpath,
bool overwrite
)
JScript
function MoveResource(
oldpath : String,
newpath : String,
overwrite : bool
)

See Also

ServerConnectionI Interface


MoveResourceWithReferences Method

ServerConnectionI.MoveResourceWithReferences Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function MoveResourceWithReferences( _
ByVal oldpath As String, _
ByVal newpath As String, _
ByVal callback As LengthyOperationCallBack, _
ByVal progress As LengthyOperationProgressCallBack _
) As Boolean
C#
bool MoveResourceWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
C++
bool MoveResourceWithReferences(
String oldpath,
String newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
) abstract
J#
bool MoveResourceWithReferences(
string oldpath,
string newpath,
LengthyOperationCallBack callback,
LengthyOperationProgressCallBack progress
)
JScript
function MoveResourceWithReferences(
oldpath : String,
newpath : String,
callback : LengthyOperationCallBack,
progress : LengthyOperationProgressCallBack
) : bool

See Also

ServerConnectionI Interface


QueryFeatureSource Method

ServerConnectionI.QueryFeatureSource Method

Overload List

 | Name | Description
Public method | QueryFeatureSource (String, String) |
Public method | QueryFeatureSource (String, String, String) |
Public method | QueryFeatureSource (String, String, String, String) |

See Also

ServerConnectionI Interface


QueryFeatureSource Method (String, String)

ServerConnectionI.QueryFeatureSource Method (String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function QueryFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String _
) As FeatureSetReader
C#
public abstract FeatureSetReader QueryFeatureSource(
string resourceID,
string schema
)
C++
public:
FeatureSetReader QueryFeatureSource(
String resourceID,
String schema
) abstract
J#
public abstract FeatureSetReader QueryFeatureSource(
string resourceID,
string schema
)
JScript
public abstract function QueryFeatureSource(
resourceID : String,
schema : String
) : FeatureSetReader

See Also

ServerConnectionI Interface
ServerConnectionI.QueryFeatureSource Overload List


QueryFeatureSource Method (String, String, String)

ServerConnectionI.QueryFeatureSource Method (String, String, String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function QueryFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String, _
ByVal query As String _
) As FeatureSetReader
C#
public abstract FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query
)
C++
public:
FeatureSetReader QueryFeatureSource(
String resourceID,
String schema,
String query
) abstract
J#
public abstract FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query
)
JScript
public abstract function QueryFeatureSource(
resourceID : String,
schema : String,
query : String
) : FeatureSetReader

See Also

ServerConnectionI Interface
ServerConnectionI.QueryFeatureSource Overload List


QueryFeatureSource Method (String, String, String, String[])

ServerConnectionI.QueryFeatureSource Method (String, String, String, String[])
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function QueryFeatureSource( _
ByVal resourceID As String, _
ByVal schema As String, _
ByVal query As String, _
ByVal columns As String() _
) As FeatureSetReader
C#
public abstract FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query,
string[] columns
)
C++
public:
FeatureSetReader QueryFeatureSource(
String resourceID,
String schema,
String query,
array<String>^ columns
) abstract
J#
public abstract FeatureSetReader QueryFeatureSource(
string resourceID,
string schema,
string query,
string[] columns
)
JScript
public abstract function QueryFeatureSource(
resourceID : String,
schema : String,
query : String,
columns : String[]
) : FeatureSetReader

See Also

ServerConnectionI Interface
ServerConnectionI.QueryFeatureSource Overload List


QueryMapFeatures Method

ServerConnectionI.QueryMapFeatures Method

Selects features from a runtime map, returning a selection Xml.

Overload List

 | Name | Description
Public method | QueryMapFeatures (String, String, Boolean) | Selects features from a runtime map, returning a selection Xml.
Public method | QueryMapFeatures (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean) | Selects features from a runtime map, returning a selection Xml.

See Also

ServerConnectionI Interface


QueryMapFeatures Method (String, String, Boolean)

ServerConnectionI.QueryMapFeatures Method (String, String, Boolean)
See Also Example
[image]

Selects features from a runtime map, returning a selection Xml.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function QueryMapFeatures( _
ByVal runtimemap As String, _
ByVal wkt As String, _
ByVal persist As Boolean _
) As String
C#
public abstract string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist
)
C++
public:
String QueryMapFeatures(
String runtimemap,
String wkt,
bool persist
) abstract
J#
public abstract string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist
)
JScript
public abstract function QueryMapFeatures(
runtimemap : String,
wkt : String,
persist : bool
) : String

Parameters

runtimemap
The map to query. NOT a resourceID, only the map name!
wkt
The WKT of the geometry to query with (always uses intersection)
persist
True if the selection should be saved in the runtime map, false otherwise.

Return Value

The selection Xml, or an empty string if there were no data.

See Also

ServerConnectionI Interface
ServerConnectionI.QueryMapFeatures Overload List


QueryMapFeatures Method (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean)

ServerConnectionI.QueryMapFeatures Method (String, String, Boolean, QueryMapFeaturesLayerAttributes, Boolean)
See Also Example
[image]

Selects features from a runtime map, returning a selection Xml.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function QueryMapFeatures( _
ByVal runtimemap As String, _
ByVal wkt As String, _
ByVal persist As Boolean, _
ByVal attributes As QueryMapFeaturesLayerAttributes, _
ByVal raw As Boolean _
) As String
C#
public abstract string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
)
C++
public:
String QueryMapFeatures(
String runtimemap,
String wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
) abstract
J#
public abstract string QueryMapFeatures(
string runtimemap,
string wkt,
bool persist,
QueryMapFeaturesLayerAttributes attributes,
bool raw
)
JScript
public abstract function QueryMapFeatures(
runtimemap : String,
wkt : String,
persist : bool,
attributes : QueryMapFeaturesLayerAttributes,
raw : bool
) : String

Parameters

runtimemap
The map to query. NOT a resourceID, only the map name!
wkt
The WKT of the geometry to query with (always uses intersection)
persist
True if the selection should be saved in the runtime map, false otherwise.
attributes
The type of layer to include in the query
raw
True if the result should contain the tooltip and link info

Return Value

The selection Xml, or an empty string if there were no data.

See Also

ServerConnectionI Interface
ServerConnectionI.QueryMapFeatures Overload List


RemoveVersionFromProviderName Method

ServerConnectionI.RemoveVersionFromProviderName Method
[image]

Removes the version numbers from a providername

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function RemoveVersionFromProviderName( _
ByVal providername As String _
) As String
C#
string RemoveVersionFromProviderName(
string providername
)
C++
String RemoveVersionFromProviderName(
String providername
) abstract
J#
string RemoveVersionFromProviderName(
string providername
)
JScript
function RemoveVersionFromProviderName(
providername : String
) : String

Parameters

providername
The name of the provider, with or without version numbers

Return Value

The provider name without version numbers

See Also

ServerConnectionI Interface


RenderRuntimeMap Method

ServerConnectionI.RenderRuntimeMap Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function RenderRuntimeMap( _
ByVal resourceId As String, _
ByVal x As Double, _
ByVal y As Double, _
ByVal scale As Double, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal dpi As Integer _
) As Stream
C#
Stream RenderRuntimeMap(
string resourceId,
double x,
double y,
double scale,
int width,
int height,
int dpi
)
C++
Stream RenderRuntimeMap(
String resourceId,
double x,
double y,
double scale,
int width,
int height,
int dpi
) abstract
J#
Stream RenderRuntimeMap(
string resourceId,
double x,
double y,
double scale,
int width,
int height,
int dpi
)
JScript
function RenderRuntimeMap(
resourceId : String,
x : double,
y : double,
scale : double,
width : int,
height : int,
dpi : int
) : Stream

See Also

ServerConnectionI Interface


ResetFeatureSourceSchemaCache Method

ServerConnectionI.ResetFeatureSourceSchemaCache Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub ResetFeatureSourceSchemaCache()
C#
void ResetFeatureSourceSchemaCache()
C++
void ResetFeatureSourceSchemaCache() abstract
J#
void ResetFeatureSourceSchemaCache()
JScript
function ResetFeatureSourceSchemaCache()

See Also

ServerConnectionI Interface


ResourceExists Method

ServerConnectionI.ResourceExists Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function ResourceExists( _
ByVal resourceid As String _
) As Boolean
C#
bool ResourceExists(
string resourceid
)
C++
bool ResourceExists(
String resourceid
) abstract
J#
bool ResourceExists(
string resourceid
)
JScript
function ResourceExists(
resourceid : String
) : bool

See Also

ServerConnectionI Interface


RestartSession Method

ServerConnectionI.RestartSession Method

Restarts the server session, and creates a new session ID

Overload List

 | Name | Description
Public method | RestartSession | Restarts the server session, and creates a new session ID
Public method | RestartSession (Boolean) | Restarts the server session, and creates a new session ID

See Also

ServerConnectionI Interface


RestartSession Method ()

ServerConnectionI.RestartSession Method ()
See Also Example
[image]

Restarts the server session, and creates a new session ID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub RestartSession()
C#
public abstract void RestartSession()
C++
public:
void RestartSession() abstract
J#
public abstract void RestartSession()
JScript
public abstract function RestartSession()

See Also

ServerConnectionI Interface
ServerConnectionI.RestartSession Overload List


RestartSession Method (Boolean)

ServerConnectionI.RestartSession Method (Boolean)
See Also Example
[image]

Restarts the server session, and creates a new session ID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function RestartSession( _
ByVal throwException As Boolean _
) As Boolean
C#
public abstract bool RestartSession(
bool throwException
)
C++
public:
bool RestartSession(
bool throwException
) abstract
J#
public abstract bool RestartSession(
bool throwException
)
JScript
public abstract function RestartSession(
throwException : bool
) : bool

Parameters

throwException
If set to true, the call throws an exception if the call failed

Return Value

True if the creation succeed, false otherwise

See Also

ServerConnectionI Interface
ServerConnectionI.RestartSession Overload List


SaveResource Method

ServerConnectionI.SaveResource Method

Saves a FeatureSource, using its originating resourceId

Overload List

 | Name | Description
Public method | SaveResource (FeatureSource) | Saves a FeatureSource, using its originating resourceId
Public method | SaveResource (LayerDefinition) | Saves a LayerDefinition, using its originating resourceId
Public method | SaveResource (MapDefinition) | Saves a MapDefinition, using its originating resourceId
Public method | SaveResource (WebLayout) | Saves a WebLayout, using its originating resourceId

See Also

ServerConnectionI Interface


SaveResource Method (FeatureSource)

ServerConnectionI.SaveResource Method (FeatureSource)
See Also Example
[image]

Saves a FeatureSource, using its originating resourceId

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SaveResource( _
ByVal resource As FeatureSource _
)
C#
public abstract void SaveResource(
FeatureSource resource
)
C++
public:
void SaveResource(
FeatureSource resource
) abstract
J#
public abstract void SaveResource(
FeatureSource resource
)
JScript
public abstract function SaveResource(
resource : FeatureSource
)

Parameters

resource
The FeatureSource to save

See Also

ServerConnectionI Interface
ServerConnectionI.SaveResource Overload List


SaveResource Method (LayerDefinition)

ServerConnectionI.SaveResource Method (LayerDefinition)
See Also Example
[image]

Saves a LayerDefinition, using its originating resourceId

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SaveResource( _
ByVal resource As LayerDefinition _
)
C#
public abstract void SaveResource(
LayerDefinition resource
)
C++
public:
void SaveResource(
LayerDefinition resource
) abstract
J#
public abstract void SaveResource(
LayerDefinition resource
)
JScript
public abstract function SaveResource(
resource : LayerDefinition
)

Parameters

resource
The LayerDefinition to save

See Also

ServerConnectionI Interface
ServerConnectionI.SaveResource Overload List


SaveResource Method (MapDefinition)

ServerConnectionI.SaveResource Method (MapDefinition)
See Also Example
[image]

Saves a MapDefinition, using its originating resourceId

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SaveResource( _
ByVal resource As MapDefinition _
)
C#
public abstract void SaveResource(
MapDefinition resource
)
C++
public:
void SaveResource(
MapDefinition resource
) abstract
J#
public abstract void SaveResource(
MapDefinition resource
)
JScript
public abstract function SaveResource(
resource : MapDefinition
)

Parameters

resource
The MapDefintion to save

See Also

ServerConnectionI Interface
ServerConnectionI.SaveResource Overload List


SaveResource Method (WebLayout)

ServerConnectionI.SaveResource Method (WebLayout)
See Also Example
[image]

Saves a WebLayout, using its originating resourceId

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SaveResource( _
ByVal resource As WebLayout _
)
C#
public abstract void SaveResource(
WebLayout resource
)
C++
public:
void SaveResource(
WebLayout resource
) abstract
J#
public abstract void SaveResource(
WebLayout resource
)
JScript
public abstract function SaveResource(
resource : WebLayout
)

Parameters

resource
The WebLayout to save

See Also

ServerConnectionI Interface
ServerConnectionI.SaveResource Overload List


SaveResourceAs Method

ServerConnectionI.SaveResourceAs Method

Saves a FeatureSource under a different resourceID

Overload List

 | Name | Description
Public method | SaveResourceAs (FeatureSource, String) | Saves a FeatureSource under a different resourceID
Public method | SaveResourceAs (LayerDefinition, String) | Saves a LayerDefinition under a different resourceID
Public method | SaveResourceAs (MapDefinition, String) | Saves a MapDefinition under a different resourceID
Public method | SaveResourceAs (WebLayout, String) | Saves a WebLayout under a different resourceID
Public method | SaveResourceAs (Object, String) | Saves an object into the repository

See Also

ServerConnectionI Interface


SaveResourceAs Method (FeatureSource, String)

ServerConnectionI.SaveResourceAs Method (FeatureSource, String)
See Also Example
[image]

Saves a FeatureSource under a different resourceID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SaveResourceAs( _
ByVal resource As FeatureSource, _
ByVal resourceid As String _
)
C#
public abstract void SaveResourceAs(
FeatureSource resource,
string resourceid
)
C++
public:
void SaveResourceAs(
FeatureSource resource,
String resourceid
) abstract
J#
public abstract void SaveResourceAs(
FeatureSource resource,
string resourceid
)
JScript
public abstract function SaveResourceAs(
resource : FeatureSource,
resourceid : String
)

Parameters

resource
The FeatureSource to save
resourceid
The new path of the FeatureSource

See Also

ServerConnectionI Interface
ServerConnectionI.SaveResourceAs Overload List


SaveResourceAs Method (LayerDefinition, String)

ServerConnectionI.SaveResourceAs Method (LayerDefinition, String)
See Also Example
[image]

Saves a LayerDefinition under a different resourceID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SaveResourceAs( _
ByVal resource As LayerDefinition, _
ByVal resourceid As String _
)
C#
public abstract void SaveResourceAs(
LayerDefinition resource,
string resourceid
)
C++
public:
void SaveResourceAs(
LayerDefinition resource,
String resourceid
) abstract
J#
public abstract void SaveResourceAs(
LayerDefinition resource,
string resourceid
)
JScript
public abstract function SaveResourceAs(
resource : LayerDefinition,
resourceid : String
)

Parameters

resource
The LayerDefinition to save
resourceid
The new path of the LayerDefinition

See Also

ServerConnectionI Interface
ServerConnectionI.SaveResourceAs Overload List


SaveResourceAs Method (MapDefinition, String)

ServerConnectionI.SaveResourceAs Method (MapDefinition, String)
See Also Example
[image]

Saves a MapDefinition under a different resourceID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SaveResourceAs( _
ByVal resource As MapDefinition, _
ByVal resourceid As String _
)
C#
public abstract void SaveResourceAs(
MapDefinition resource,
string resourceid
)
C++
public:
void SaveResourceAs(
MapDefinition resource,
String resourceid
) abstract
J#
public abstract void SaveResourceAs(
MapDefinition resource,
string resourceid
)
JScript
public abstract function SaveResourceAs(
resource : MapDefinition,
resourceid : String
)

Parameters

resource
The MapDefinition to save
resourceid
The new path of the MapDefinition

See Also

ServerConnectionI Interface
ServerConnectionI.SaveResourceAs Overload List


SaveResourceAs Method (WebLayout, String)

ServerConnectionI.SaveResourceAs Method (WebLayout, String)
See Also Example
[image]

Saves a WebLayout under a different resourceID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SaveResourceAs( _
ByVal resource As WebLayout, _
ByVal resourceid As String _
)
C#
public abstract void SaveResourceAs(
WebLayout resource,
string resourceid
)
C++
public:
void SaveResourceAs(
WebLayout resource,
String resourceid
) abstract
J#
public abstract void SaveResourceAs(
WebLayout resource,
string resourceid
)
JScript
public abstract function SaveResourceAs(
resource : WebLayout,
resourceid : String
)

Parameters

resource
The WebLayout to save
resourceid
The new path of the WebLayout

See Also

ServerConnectionI Interface
ServerConnectionI.SaveResourceAs Overload List


SaveResourceAs Method (Object, String)

ServerConnectionI.SaveResourceAs Method (Object, String)
See Also Example
[image]

Saves an object into the repository

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SaveResourceAs( _
ByVal resource As Object, _
ByVal resourceid As String _
)
C#
public abstract void SaveResourceAs(
object resource,
string resourceid
)
C++
public:
void SaveResourceAs(
Object resource,
String resourceid
) abstract
J#
public abstract void SaveResourceAs(
object resource,
string resourceid
)
JScript
public abstract function SaveResourceAs(
resource : Object,
resourceid : String
)

Parameters

resource
The object to save
resourceid
The resourceId to save the object as

See Also

ServerConnectionI Interface
ServerConnectionI.SaveResourceAs Overload List


SaveRuntimeMap Method

ServerConnectionI.SaveRuntimeMap Method
[image]

Updates an existing runtime map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub SaveRuntimeMap( _
ByVal resourceID As String, _
ByVal map As RuntimeMap _
)
C#
void SaveRuntimeMap(
string resourceID,
RuntimeMap map
)
C++
void SaveRuntimeMap(
String resourceID,
RuntimeMap map
) abstract
J#
void SaveRuntimeMap(
string resourceID,
RuntimeMap map
)
JScript
function SaveRuntimeMap(
resourceID : String,
map : RuntimeMap
)

Parameters

resourceID
The target resource id for the runtime map
map
The runtime map to update with

See Also

ServerConnectionI Interface


SerializeObject Method

ServerConnectionI.SerializeObject Method

Overload List

 | Name | Description
Public method | SerializeObject (Object) |
Public method | SerializeObject (Object, Stream) |

See Also

ServerConnectionI Interface


SerializeObject Method (Object)

ServerConnectionI.SerializeObject Method (Object)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function SerializeObject( _
ByVal o As Object _
) As MemoryStream
C#
public abstract MemoryStream SerializeObject(
object o
)
C++
public:
MemoryStream SerializeObject(
Object o
) abstract
J#
public abstract MemoryStream SerializeObject(
object o
)
JScript
public abstract function SerializeObject(
o : Object
) : MemoryStream

See Also

ServerConnectionI Interface
ServerConnectionI.SerializeObject Overload List


SerializeObject Method (Object, Stream)

ServerConnectionI.SerializeObject Method (Object, Stream)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SerializeObject( _
ByVal o As Object, _
ByVal stream As Stream _
)
C#
public abstract void SerializeObject(
object o,
Stream stream
)
C++
public:
void SerializeObject(
Object o,
Stream stream
) abstract
J#
public abstract void SerializeObject(
object o,
Stream stream
)
JScript
public abstract function SerializeObject(
o : Object,
stream : Stream
)

See Also

ServerConnectionI Interface
ServerConnectionI.SerializeObject Overload List


SetFolderHeader Method

ServerConnectionI.SetFolderHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub SetFolderHeader( _
ByVal resourceID As String, _
ByVal header As ResourceFolderHeaderType _
)
C#
void SetFolderHeader(
string resourceID,
ResourceFolderHeaderType header
)
C++
void SetFolderHeader(
String resourceID,
ResourceFolderHeaderType header
) abstract
J#
void SetFolderHeader(
string resourceID,
ResourceFolderHeaderType header
)
JScript
function SetFolderHeader(
resourceID : String,
header : ResourceFolderHeaderType
)

See Also

ServerConnectionI Interface


SetResourceData Method

ServerConnectionI.SetResourceData Method

Overload List

 | Name | Description
Public method | SetResourceData (String, String, ResourceDataType, Stream) |
Public method | SetResourceData (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate) |

See Also

ServerConnectionI Interface


SetResourceData Method (String, String, ResourceDataType, Stream)

ServerConnectionI.SetResourceData Method (String, String, ResourceDataType, Stream)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SetResourceData( _
ByVal resourceid As String, _
ByVal dataname As String, _
ByVal datatype As ResourceDataType, _
ByVal stream As Stream _
)
C#
public abstract void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream
)
C++
public:
void SetResourceData(
String resourceid,
String dataname,
ResourceDataType datatype,
Stream stream
) abstract
J#
public abstract void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream
)
JScript
public abstract function SetResourceData(
resourceid : String,
dataname : String,
datatype : ResourceDataType,
stream : Stream
)

See Also

ServerConnectionI Interface
ServerConnectionI.SetResourceData Overload List


SetResourceData Method (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate)

ServerConnectionI.SetResourceData Method (String, String, ResourceDataType, Stream, Utility.StreamCopyProgressDelegate)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SetResourceData( _
ByVal resourceid As String, _
ByVal dataname As String, _
ByVal datatype As ResourceDataType, _
ByVal stream As Stream, _
ByVal callback As Utility.StreamCopyProgressDelegate _
)
C#
public abstract void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
)
C++
public:
void SetResourceData(
String resourceid,
String dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
) abstract
J#
public abstract void SetResourceData(
string resourceid,
string dataname,
ResourceDataType datatype,
Stream stream,
Utility.StreamCopyProgressDelegate callback
)
JScript
public abstract function SetResourceData(
resourceid : String,
dataname : String,
datatype : ResourceDataType,
stream : Stream,
callback : Utility.StreamCopyProgressDelegate
)

See Also

ServerConnectionI Interface
ServerConnectionI.SetResourceData Overload List


SetResourceHeader Method

ServerConnectionI.SetResourceHeader Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub SetResourceHeader( _
ByVal resourceID As String, _
ByVal header As ResourceDocumentHeaderType _
)
C#
void SetResourceHeader(
string resourceID,
ResourceDocumentHeaderType header
)
C++
void SetResourceHeader(
String resourceID,
ResourceDocumentHeaderType header
) abstract
J#
void SetResourceHeader(
string resourceID,
ResourceDocumentHeaderType header
)
JScript
function SetResourceHeader(
resourceID : String,
header : ResourceDocumentHeaderType
)

See Also

ServerConnectionI Interface


SetResourceXmlData Method

ServerConnectionI.SetResourceXmlData Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub SetResourceXmlData( _
ByVal resourceid As String, _
ByVal stream As Stream _
)
C#
void SetResourceXmlData(
string resourceid,
Stream stream
)
C++
void SetResourceXmlData(
String resourceid,
Stream stream
) abstract
J#
void SetResourceXmlData(
string resourceid,
Stream stream
)
JScript
function SetResourceXmlData(
resourceid : String,
stream : Stream
)

See Also

ServerConnectionI Interface


SetSelectionXml Method

ServerConnectionI.SetSelectionXml Method
[image]

Sets the selection of a map

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub SetSelectionXml( _
ByVal runtimeMap As String, _
ByVal selectionXml As String _
)
C#
void SetSelectionXml(
string runtimeMap,
string selectionXml
)
C++
void SetSelectionXml(
String runtimeMap,
String selectionXml
) abstract
J#
void SetSelectionXml(
string runtimeMap,
string selectionXml
)
JScript
function SetSelectionXml(
runtimeMap : String,
selectionXml : String
)

Parameters

runtimeMap
The resourceID of the runtime map
selectionXml
The selection xml

See Also

ServerConnectionI Interface


TestConnection Method

ServerConnectionI.TestConnection Method

Overload List

 | Name | Description
Public method | TestConnection (FeatureSource) |
Public method | TestConnection (String) |
Public method | TestConnection (String, NameValueCollection) |

See Also

ServerConnectionI Interface


TestConnection Method (FeatureSource)

ServerConnectionI.TestConnection Method (FeatureSource)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function TestConnection( _
ByVal feature As FeatureSource _
) As String
C#
public abstract string TestConnection(
FeatureSource feature
)
C++
public:
String TestConnection(
FeatureSource feature
) abstract
J#
public abstract string TestConnection(
FeatureSource feature
)
JScript
public abstract function TestConnection(
feature : FeatureSource
) : String

See Also

ServerConnectionI Interface
ServerConnectionI.TestConnection Overload List


TestConnection Method (String)

ServerConnectionI.TestConnection Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function TestConnection( _
ByVal featuresource As String _
) As String
C#
public abstract string TestConnection(
string featuresource
)
C++
public:
String TestConnection(
String featuresource
) abstract
J#
public abstract string TestConnection(
string featuresource
)
JScript
public abstract function TestConnection(
featuresource : String
) : String

See Also

ServerConnectionI Interface
ServerConnectionI.TestConnection Overload List


TestConnection Method (String, NameValueCollection)

ServerConnectionI.TestConnection Method (String, NameValueCollection)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function TestConnection( _
ByVal providername As String, _
ByVal parameters As NameValueCollection _
) As String
C#
public abstract string TestConnection(
string providername,
NameValueCollection parameters
)
C++
public:
String TestConnection(
String providername,
NameValueCollection parameters
) abstract
J#
public abstract string TestConnection(
string providername,
NameValueCollection parameters
)
JScript
public abstract function TestConnection(
providername : String,
parameters : NameValueCollection
) : String

See Also

ServerConnectionI Interface
ServerConnectionI.TestConnection Overload List


TryGetResourceType Method

ServerConnectionI.TryGetResourceType Method
[image]

Gets the resource type from a resourceID

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Function TryGetResourceType( _
ByVal resourceID As String _
) As Type
C#
Type TryGetResourceType(
string resourceID
)
C++
Type TryGetResourceType(
String resourceID
) abstract
J#
Type TryGetResourceType(
string resourceID
)
JScript
function TryGetResourceType(
resourceID : String
) : Type

Parameters

resourceID
The resourceID for the resource

Return Value

The type of the given item, returns null if no such type exists

See Also

ServerConnectionI Interface


UploadPackage Method

ServerConnectionI.UploadPackage Method
[image]

Upload a MapGuide Package file to the server

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub UploadPackage( _
ByVal filename As String, _
ByVal callback As Utility.StreamCopyProgressDelegate _
)
C#
void UploadPackage(
string filename,
Utility.StreamCopyProgressDelegate callback
)
C++
void UploadPackage(
String filename,
Utility.StreamCopyProgressDelegate callback
) abstract
J#
void UploadPackage(
string filename,
Utility.StreamCopyProgressDelegate callback
)
JScript
function UploadPackage(
filename : String,
callback : Utility.StreamCopyProgressDelegate
)

Parameters

filename
Name of the file to upload
callback
A callback argument used to display progress. May be null.

See Also

ServerConnectionI Interface


ServerType Class

ServerType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("Server", Namespace := "", IsNullable := False)>
Public Class ServerType
C#
[XmlRootAttribute("Server", Namespace = "", IsNullable = False)]
public class ServerType
C++
[XmlRootAttribute(L"Server", Namespace = L"", IsNullable = False)]
ref class ServerType
J#
/** @attribute XmlRootAttribute("Server", Namespace = "", IsNullable = False) */
public class ServerType
JScript
public
XmlRootAttribute("Server", Namespace = "", IsNullable = False)
class ServerType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ServerType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ServerType Members


ServerType Members

ServerType Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by ServerType.

Public Constructors

 | Name | Description
Public method | ServerType | Initializes a new instance of the ServerType class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | IpAddress |
Public property | Name |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ServerType Class


ServerType Constructor

ServerType Constructor
[image]

Initializes a new instance of the ServerType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ServerType()
C++
public:
ServerType() sealed
J#
public ServerType()
JScript
public function ServerType()

See Also

ServerType Class


Fields

ServerType Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

ServerType Class


SchemaName Field

ServerType.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

ServerType Class


Properties

ServerType Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | IpAddress |
Public property | Name |
Public property | XsdSchema |
Top

See Also

ServerType Class


Description Property

ServerType.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

ServerType Class


IpAddress Property

ServerType.IpAddress Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property IpAddress As String
C#
public string IpAddress { get; set; }
C++
public property string IpAddress sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_IpAddress();

/** property */
public void set_IpAddress(string value);
JScript
public function get IpAddress() : String

public function set IpAddress(value : String);

See Also

ServerType Class


Name Property

ServerType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ServerType Class


XsdSchema Property

ServerType.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

ServerType Class


ShapeType Enumeration

ShapeType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum ShapeType
C#
public enum ShapeType
C++
public enum class ShapeType
J#
public enum ShapeType
JScript
public enum ShapeType

Members

Member Name | Description
Square |
Circle |
Triangle |
Star |
Cross |
X |

See Also


ShpLoadProcedureType Class

ShpLoadProcedureType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ShpLoadProcedureType
Inherits LoadProcedureType
C#
public class ShpLoadProcedureType : LoadProcedureType
C++
ref class ShpLoadProcedureType : LoadProcedureType
J#
public class ShpLoadProcedureType extends LoadProcedureType
JScript
public class ShpLoadProcedureType extends LoadProcedureType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.LoadProcedureType
OSGeo.MapGuide.MaestroAPI.ShpLoadProcedureType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ShpLoadProcedureType Members


ShpLoadProcedureType Members

ShpLoadProcedureType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ShpLoadProcedureType.

Public Constructors

 | Name | Description
Public method | ShpLoadProcedureType | Initializes a new instance of the ShpLoadProcedureType class.
Top

Public Properties

 | Name | Description
Public property | ConvertToSdf |
Public property | CoordinateSystem | (inherited from LoadProcedureType)
Public property | Generalization |
Public property | GenerateLayers | (inherited from LoadProcedureType)
Public property | GenerateMaps | (inherited from LoadProcedureType)
Public property | GenerateMapsSpecified | (inherited from LoadProcedureType)
Public property | GenerateSpatialDataSources | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibraries | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibrariesSpecified | (inherited from LoadProcedureType)
Public property | LayersFolder | (inherited from LoadProcedureType)
Public property | LayersPath | (inherited from LoadProcedureType)
Public property | MapsFolder | (inherited from LoadProcedureType)
Public property | MapsPath | (inherited from LoadProcedureType)
Public property | ResourceId | (inherited from LoadProcedureType)
Public property | RootPath | (inherited from LoadProcedureType)
Public property | SourceFile | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesFolder | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesPath | (inherited from LoadProcedureType)
Public property | SymbolLibrariesFolder | (inherited from LoadProcedureType)
Public property | SymbolLibrariesPath | (inherited from LoadProcedureType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ShpLoadProcedureType Class


ShpLoadProcedureType Constructor

ShpLoadProcedureType Constructor
[image]

Initializes a new instance of the ShpLoadProcedureType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ShpLoadProcedureType()
C++
public:
ShpLoadProcedureType() sealed
J#
public ShpLoadProcedureType()
JScript
public function ShpLoadProcedureType()

See Also

ShpLoadProcedureType Class


Properties

ShpLoadProcedureType Properties
[image]

Public Properties

 | Name | Description
Public property | ConvertToSdf |
Public property | CoordinateSystem | (inherited from LoadProcedureType)
Public property | Generalization |
Public property | GenerateLayers | (inherited from LoadProcedureType)
Public property | GenerateMaps | (inherited from LoadProcedureType)
Public property | GenerateMapsSpecified | (inherited from LoadProcedureType)
Public property | GenerateSpatialDataSources | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibraries | (inherited from LoadProcedureType)
Public property | GenerateSymbolLibrariesSpecified | (inherited from LoadProcedureType)
Public property | LayersFolder | (inherited from LoadProcedureType)
Public property | LayersPath | (inherited from LoadProcedureType)
Public property | MapsFolder | (inherited from LoadProcedureType)
Public property | MapsPath | (inherited from LoadProcedureType)
Public property | ResourceId | (inherited from LoadProcedureType)
Public property | RootPath | (inherited from LoadProcedureType)
Public property | SourceFile | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesFolder | (inherited from LoadProcedureType)
Public property | SpatialDataSourcesPath | (inherited from LoadProcedureType)
Public property | SymbolLibrariesFolder | (inherited from LoadProcedureType)
Public property | SymbolLibrariesPath | (inherited from LoadProcedureType)
Top

See Also

ShpLoadProcedureType Class


ConvertToSdf Property

ShpLoadProcedureType.ConvertToSdf Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ConvertToSdf As Boolean
C#
public bool ConvertToSdf { get; set; }
C++
public property bool ConvertToSdf sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_ConvertToSdf();

/** property */
public void set_ConvertToSdf(bool value);
JScript
public function get ConvertToSdf() : bool

public function set ConvertToSdf(value : bool);

See Also

ShpLoadProcedureType Class


Generalization Property

ShpLoadProcedureType.Generalization Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Generalization As Double
C#
public double Generalization { get; set; }
C++
public property double Generalization sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Generalization();

/** property */
public void set_Generalization(double value);
JScript
public function get Generalization() : double

public function set Generalization(value : double);

See Also

ShpLoadProcedureType Class


SimpleSymbol Class

SimpleSymbol Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SimpleSymbol
C#
public class SimpleSymbol
C++
ref class SimpleSymbol
J#
public class SimpleSymbol
JScript
public class SimpleSymbol

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SimpleSymbol

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SimpleSymbol Members


SimpleSymbol Members

SimpleSymbol Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SimpleSymbol.

Public Constructors

 | Name | Description
Public method | SimpleSymbol | Initializes a new instance of the SimpleSymbol class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Item |
Public property | RenderingPass |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SimpleSymbol Class


SimpleSymbol Constructor

SimpleSymbol Constructor
[image]

Initializes a new instance of the SimpleSymbol class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SimpleSymbol()
C++
public:
SimpleSymbol() sealed
J#
public SimpleSymbol()
JScript
public function SimpleSymbol()

See Also

SimpleSymbol Class


Properties

SimpleSymbol Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | Item |
Public property | RenderingPass |
Top

See Also

SimpleSymbol Class


ExtendedData1 Property

SimpleSymbol.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

SimpleSymbol Class


Item Property

SimpleSymbol.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("SimpleSymbolDefinition", GetType(SimpleSymbolDefinition)), _
XmlElementAttribute("ResourceId", GetType(String))>
Public Property Item As Object
C#
[XmlElementAttribute("SimpleSymbolDefinition", typeof(SimpleSymbolDefinition))]
[XmlElementAttribute("ResourceId", typeof(String))]
public object Item { get; set; }
C++
[XmlElementAttribute(L"SimpleSymbolDefinition", typeof(SimpleSymbolDefinition))]
[XmlElementAttribute(L"ResourceId", typeof(String))]
public property object Item sealed {
Object get();
void set(Object value);
}
J#
/** @attribute XmlElementAttribute("SimpleSymbolDefinition", typeof(SimpleSymbolDefinition)) */
/** @attribute XmlElementAttribute("ResourceId", typeof(String)) */
/** property */
public object get_Item();

/** property */
public void set_Item(object value);
JScript
public function get Item() : Object

public function set Item(value : Object);

See Also

SimpleSymbol Class


RenderingPass Property

SimpleSymbol.RenderingPass Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0")>
Public Property RenderingPass As String
C#
[DefaultValueAttribute("0")]
public string RenderingPass { get; set; }
C++
[DefaultValueAttribute(L"0")]
public property string RenderingPass sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0") */
/** property */
public string get_RenderingPass();

/** property */
public void set_RenderingPass(string value);
JScript
public function get RenderingPass() : String

public function set RenderingPass(value : String);

See Also

SimpleSymbol Class


SimpleSymbolCollection Class

SimpleSymbolCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class SimpleSymbolCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class SimpleSymbolCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class SimpleSymbolCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class SimpleSymbolCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class SimpleSymbolCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.SimpleSymbolCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SimpleSymbolCollection Members


SimpleSymbolCollection Members

SimpleSymbolCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SimpleSymbolCollection.

Public Constructors

 | Name | Description
Public method | SimpleSymbolCollection | Initializes a new instance of the SimpleSymbolCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SimpleSymbolCollection Class


SimpleSymbolCollection Constructor

SimpleSymbolCollection Constructor
[image]

Initializes a new instance of the SimpleSymbolCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SimpleSymbolCollection()
C++
public:
SimpleSymbolCollection() sealed
J#
public SimpleSymbolCollection()
JScript
public function SimpleSymbolCollection()

See Also

SimpleSymbolCollection Class


Properties

SimpleSymbolCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

SimpleSymbolCollection Class


Item Property

SimpleSymbolCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As SimpleSymbol
C#
public SimpleSymbol this[
int idx
] { get; set; }
C++
public property SimpleSymbol default[int idx] sealed {
SimpleSymbol get(int idx);
void set(int idx, SimpleSymbol value);
}
J#
/** property */
public SimpleSymbol get_Item(int idx);

/** property */
public void set_Item(int idx, SimpleSymbol value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

SimpleSymbolCollection Class


Methods

SimpleSymbolCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SimpleSymbolCollection Class


Add Method

SimpleSymbolCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As SimpleSymbol _
) As Integer
C#
public int Add(
SimpleSymbol value
)
C++
public:
int Add(
SimpleSymbol value
) sealed
J#
public int Add(
SimpleSymbol value
)
JScript
public function Add(
value : SimpleSymbol
) : int

See Also

SimpleSymbolCollection Class


SimpleSymbolDefinition Class

SimpleSymbolDefinition Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SimpleSymbolDefinition
Inherits SymbolDefinitionBase
C#
public class SimpleSymbolDefinition : SymbolDefinitionBase
C++
ref class SimpleSymbolDefinition : SymbolDefinitionBase
J#
public class SimpleSymbolDefinition extends SymbolDefinitionBase
JScript
public class SimpleSymbolDefinition extends SymbolDefinitionBase

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolDefinitionBase
OSGeo.MapGuide.MaestroAPI.SimpleSymbolDefinition
OSGeo.MapGuide.MaestroAPI.SimpleSymbolDefinition1

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SimpleSymbolDefinition Members


SimpleSymbolDefinition Members

SimpleSymbolDefinition Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SimpleSymbolDefinition.

Public Constructors

 | Name | Description
Public method | SimpleSymbolDefinition | Initializes a new instance of the SimpleSymbolDefinition class.
Top

Public Properties

 | Name | Description
Public property | AreaUsage |
Public property | Description | (inherited from SymbolDefinitionBase)
Public property | ExtendedData1 |
Public property | Graphics |
Public property | LineUsage |
Public property | Name | (inherited from SymbolDefinitionBase)
Public property | ParameterDefinition |
Public property | PointUsage |
Public property | ResizeBox |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SimpleSymbolDefinition Class


SimpleSymbolDefinition Constructor

SimpleSymbolDefinition Constructor
[image]

Initializes a new instance of the SimpleSymbolDefinition class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SimpleSymbolDefinition()
C++
public:
SimpleSymbolDefinition() sealed
J#
public SimpleSymbolDefinition()
JScript
public function SimpleSymbolDefinition()

See Also

SimpleSymbolDefinition Class


Properties

SimpleSymbolDefinition Properties
[image]

Public Properties

 | Name | Description
Public property | AreaUsage |
Public property | Description | (inherited from SymbolDefinitionBase)
Public property | ExtendedData1 |
Public property | Graphics |
Public property | LineUsage |
Public property | Name | (inherited from SymbolDefinitionBase)
Public property | ParameterDefinition |
Public property | PointUsage |
Public property | ResizeBox |
Top

See Also

SimpleSymbolDefinition Class


AreaUsage Property

SimpleSymbolDefinition.AreaUsage Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property AreaUsage As AreaUsage
C#
public AreaUsage AreaUsage { get; set; }
C++
public property AreaUsage AreaUsage sealed {
AreaUsage get();
void set(AreaUsage value);
}
J#
/** property */
public AreaUsage get_AreaUsage();

/** property */
public void set_AreaUsage(AreaUsage value);
JScript
public function get AreaUsage() : AreaUsage

public function set AreaUsage(value : AreaUsage);

See Also

SimpleSymbolDefinition Class


ExtendedData1 Property

SimpleSymbolDefinition.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

SimpleSymbolDefinition Class


Graphics Property

SimpleSymbolDefinition.Graphics Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute(GetType(Text), IsNullable := False), _
XmlArrayItemAttribute(GetType(Image), IsNullable := False), _
XmlArrayItemAttribute(GetType(Path), IsNullable := False)>
Public Property Graphics As GraphicBaseCollection
C#
[XmlArrayItemAttribute(typeof(Text), IsNullable = False)]
[XmlArrayItemAttribute(typeof(Image), IsNullable = False)]
[XmlArrayItemAttribute(typeof(Path), IsNullable = False)]
public GraphicBaseCollection Graphics { get; set; }
C++
[XmlArrayItemAttribute(typeof(Text), IsNullable = False)]
[XmlArrayItemAttribute(typeof(Image), IsNullable = False)]
[XmlArrayItemAttribute(typeof(Path), IsNullable = False)]
public property GraphicBaseCollection Graphics sealed {
GraphicBaseCollection get();
void set(GraphicBaseCollection value);
}
J#
/** @attribute XmlArrayItemAttribute(typeof(Text), IsNullable = False) */
/** @attribute XmlArrayItemAttribute(typeof(Image), IsNullable = False) */
/** @attribute XmlArrayItemAttribute(typeof(Path), IsNullable = False) */
/** property */
public GraphicBaseCollection get_Graphics();

/** property */
public void set_Graphics(GraphicBaseCollection value);
JScript
public function get Graphics() : GraphicBaseCollection

public function set Graphics(value : GraphicBaseCollection);

See Also

SimpleSymbolDefinition Class


LineUsage Property

SimpleSymbolDefinition.LineUsage Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LineUsage As LineUsage
C#
public LineUsage LineUsage { get; set; }
C++
public property LineUsage LineUsage sealed {
LineUsage get();
void set(LineUsage value);
}
J#
/** property */
public LineUsage get_LineUsage();

/** property */
public void set_LineUsage(LineUsage value);
JScript
public function get LineUsage() : LineUsage

public function set LineUsage(value : LineUsage);

See Also

SimpleSymbolDefinition Class


ParameterDefinition Property

SimpleSymbolDefinition.ParameterDefinition Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterDefinition As ParameterDefinition
C#
public ParameterDefinition ParameterDefinition { get; set; }
C++
public property ParameterDefinition ParameterDefinition sealed {
ParameterDefinition get();
void set(ParameterDefinition value);
}
J#
/** property */
public ParameterDefinition get_ParameterDefinition();

/** property */
public void set_ParameterDefinition(ParameterDefinition value);
JScript
public function get ParameterDefinition() : ParameterDefinition

public function set ParameterDefinition(value : ParameterDefinition);

See Also

SimpleSymbolDefinition Class


PointUsage Property

SimpleSymbolDefinition.PointUsage Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property PointUsage As PointUsage
C#
public PointUsage PointUsage { get; set; }
C++
public property PointUsage PointUsage sealed {
PointUsage get();
void set(PointUsage value);
}
J#
/** property */
public PointUsage get_PointUsage();

/** property */
public void set_PointUsage(PointUsage value);
JScript
public function get PointUsage() : PointUsage

public function set PointUsage(value : PointUsage);

See Also

SimpleSymbolDefinition Class


ResizeBox Property

SimpleSymbolDefinition.ResizeBox Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResizeBox As ResizeBox
C#
public ResizeBox ResizeBox { get; set; }
C++
public property ResizeBox ResizeBox sealed {
ResizeBox get();
void set(ResizeBox value);
}
J#
/** property */
public ResizeBox get_ResizeBox();

/** property */
public void set_ResizeBox(ResizeBox value);
JScript
public function get ResizeBox() : ResizeBox

public function set ResizeBox(value : ResizeBox);

See Also

SimpleSymbolDefinition Class


SimpleSymbolDefinition1 Class

SimpleSymbolDefinition1 Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("SimpleSymbolDefinition", Namespace := "", IsNullable := False), _
XmlTypeAttribute(TypeName := "SimpleSymbolDefinition")>
Public Class SimpleSymbolDefinition1
Inherits SimpleSymbolDefinition
C#
[XmlRootAttribute("SimpleSymbolDefinition", Namespace = "", IsNullable = False)]
[XmlTypeAttribute(TypeName = "SimpleSymbolDefinition")]
public class SimpleSymbolDefinition1 : SimpleSymbolDefinition
C++
[XmlRootAttribute(L"SimpleSymbolDefinition", Namespace = L"", IsNullable = False)]
[XmlTypeAttribute(TypeName = L"SimpleSymbolDefinition")]
ref class SimpleSymbolDefinition1 : SimpleSymbolDefinition
J#
/** @attribute XmlRootAttribute("SimpleSymbolDefinition", Namespace = "", IsNullable = False) */
/** @attribute XmlTypeAttribute(TypeName = "SimpleSymbolDefinition") */
public class SimpleSymbolDefinition1 extends SimpleSymbolDefinition
JScript
public
XmlRootAttribute("SimpleSymbolDefinition", Namespace = "", IsNullable = False)
XmlTypeAttribute(TypeName = "SimpleSymbolDefinition")
class SimpleSymbolDefinition1 extends SimpleSymbolDefinition

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolDefinitionBase
OSGeo.MapGuide.MaestroAPI.SimpleSymbolDefinition
OSGeo.MapGuide.MaestroAPI.SimpleSymbolDefinition1

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SimpleSymbolDefinition1 Members


SimpleSymbolDefinition1 Members

SimpleSymbolDefinition1 Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SimpleSymbolDefinition1.

Public Constructors

 | Name | Description
Public method | SimpleSymbolDefinition1 | Initializes a new instance of the SimpleSymbolDefinition1 class.
Top

Public Properties

 | Name | Description
Public property | AreaUsage | (inherited from SimpleSymbolDefinition)
Public property | Description | (inherited from SymbolDefinitionBase)
Public property | ExtendedData1 | (inherited from SimpleSymbolDefinition)
Public property | Graphics | (inherited from SimpleSymbolDefinition)
Public property | LineUsage | (inherited from SimpleSymbolDefinition)
Public property | Name | (inherited from SymbolDefinitionBase)
Public property | ParameterDefinition | (inherited from SimpleSymbolDefinition)
Public property | PointUsage | (inherited from SimpleSymbolDefinition)
Public property | ResizeBox | (inherited from SimpleSymbolDefinition)
Public property | version |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SimpleSymbolDefinition1 Class


SimpleSymbolDefinition1 Constructor

SimpleSymbolDefinition1 Constructor
[image]

Initializes a new instance of the SimpleSymbolDefinition1 class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SimpleSymbolDefinition1()
C++
public:
SimpleSymbolDefinition1() sealed
J#
public SimpleSymbolDefinition1()
JScript
public function SimpleSymbolDefinition1()

See Also

SimpleSymbolDefinition1 Class


Properties

SimpleSymbolDefinition1 Properties
[image]

Public Properties

 | Name | Description
Public property | AreaUsage | (inherited from SimpleSymbolDefinition)
Public property | Description | (inherited from SymbolDefinitionBase)
Public property | ExtendedData1 | (inherited from SimpleSymbolDefinition)
Public property | Graphics | (inherited from SimpleSymbolDefinition)
Public property | LineUsage | (inherited from SimpleSymbolDefinition)
Public property | Name | (inherited from SymbolDefinitionBase)
Public property | ParameterDefinition | (inherited from SimpleSymbolDefinition)
Public property | PointUsage | (inherited from SimpleSymbolDefinition)
Public property | ResizeBox | (inherited from SimpleSymbolDefinition)
Public property | version |
Top

See Also

SimpleSymbolDefinition1 Class


version Property

SimpleSymbolDefinition1.version Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute, _
DefaultValueAttribute("1.1.0")>
Public Property version As String
C#
[XmlAttributeAttribute]
[DefaultValueAttribute("1.1.0")]
public string version { get; set; }
C++
[XmlAttributeAttribute]
[DefaultValueAttribute(L"1.1.0")]
public property string version sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** @attribute DefaultValueAttribute("1.1.0") */
/** property */
public string get_version();

/** property */
public void set_version(string value);
JScript
public function get version() : String

public function set version(value : String);

See Also

SimpleSymbolDefinition1 Class


SiteInformation Class

SiteInformation Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class SiteInformation
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class SiteInformation
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class SiteInformation
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class SiteInformation
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class SiteInformation

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SiteInformation

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SiteInformation Members


SiteInformation Members

SiteInformation Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by SiteInformation.

Public Constructors

 | Name | Description
Public method | SiteInformation | Initializes a new instance of the SiteInformation class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | SiteServer |
Public property | Statistics |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SiteInformation Class


SiteInformation Constructor

SiteInformation Constructor
[image]

Initializes a new instance of the SiteInformation class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SiteInformation()
C++
public:
SiteInformation() sealed
J#
public SiteInformation()
JScript
public function SiteInformation()

See Also

SiteInformation Class


Fields

SiteInformation Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

SiteInformation Class


SchemaName Field

SiteInformation.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

SiteInformation Class


Properties

SiteInformation Properties
[image]

Public Properties

 | Name | Description
Public property | SiteServer |
Public property | Statistics |
Public property | XsdSchema |
Top

See Also

SiteInformation Class


SiteServer Property

SiteInformation.SiteServer Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SiteServer As SiteInformationSiteServer
C#
public SiteInformationSiteServer SiteServer { get; set; }
C++
public property SiteInformationSiteServer SiteServer sealed {
SiteInformationSiteServer get();
void set(SiteInformationSiteServer value);
}
J#
/** property */
public SiteInformationSiteServer get_SiteServer();

/** property */
public void set_SiteServer(SiteInformationSiteServer value);
JScript
public function get SiteServer() : SiteInformationSiteServer

public function set SiteServer(value : SiteInformationSiteServer);

See Also

SiteInformation Class


Statistics Property

SiteInformation.Statistics Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Statistics As SiteInformationStatistics
C#
public SiteInformationStatistics Statistics { get; set; }
C++
public property SiteInformationStatistics Statistics sealed {
SiteInformationStatistics get();
void set(SiteInformationStatistics value);
}
J#
/** property */
public SiteInformationStatistics get_Statistics();

/** property */
public void set_Statistics(SiteInformationStatistics value);
JScript
public function get Statistics() : SiteInformationStatistics

public function set Statistics(value : SiteInformationStatistics);

See Also

SiteInformation Class


XsdSchema Property

SiteInformation.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

SiteInformation Class


SiteInformationSiteServer Class

SiteInformationSiteServer Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SiteInformationSiteServer
C#
public class SiteInformationSiteServer
C++
ref class SiteInformationSiteServer
J#
public class SiteInformationSiteServer
JScript
public class SiteInformationSiteServer

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SiteInformationSiteServer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SiteInformationSiteServer Members


SiteInformationSiteServer Members

SiteInformationSiteServer Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SiteInformationSiteServer.

Public Constructors

 | Name | Description
Public method | SiteInformationSiteServer | Initializes a new instance of the SiteInformationSiteServer class.
Top

Public Properties

 | Name | Description
Public property | DisplayName |
Public property | OperatingSystem |
Public property | Status |
Public property | Version |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SiteInformationSiteServer Class


SiteInformationSiteServer Constructor

SiteInformationSiteServer Constructor
[image]

Initializes a new instance of the SiteInformationSiteServer class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SiteInformationSiteServer()
C++
public:
SiteInformationSiteServer() sealed
J#
public SiteInformationSiteServer()
JScript
public function SiteInformationSiteServer()

See Also

SiteInformationSiteServer Class


Properties

SiteInformationSiteServer Properties
[image]

Public Properties

 | Name | Description
Public property | DisplayName |
Public property | OperatingSystem |
Public property | Status |
Public property | Version |
Top

See Also

SiteInformationSiteServer Class


DisplayName Property

SiteInformationSiteServer.DisplayName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisplayName As String
C#
public string DisplayName { get; set; }
C++
public property string DisplayName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DisplayName();

/** property */
public void set_DisplayName(string value);
JScript
public function get DisplayName() : String

public function set DisplayName(value : String);

See Also

SiteInformationSiteServer Class


OperatingSystem Property

SiteInformationSiteServer.OperatingSystem Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property OperatingSystem As SiteInformationSiteServerOperatingSystem
C#
public SiteInformationSiteServerOperatingSystem OperatingSystem { get; set; }
C++
public property SiteInformationSiteServerOperatingSystem OperatingSystem sealed {
SiteInformationSiteServerOperatingSystem get();
void set(SiteInformationSiteServerOperatingSystem value);
}
J#
/** property */
public SiteInformationSiteServerOperatingSystem get_OperatingSystem();

/** property */
public void set_OperatingSystem(SiteInformationSiteServerOperatingSystem value);
JScript
public function get OperatingSystem() : SiteInformationSiteServerOperatingSystem

public function set OperatingSystem(value : SiteInformationSiteServerOperatingSystem);

See Also

SiteInformationSiteServer Class


Status Property

SiteInformationSiteServer.Status Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As String
C#
public string Status { get; set; }
C++
public property string Status sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Status();

/** property */
public void set_Status(string value);
JScript
public function get Status() : String

public function set Status(value : String);

See Also

SiteInformationSiteServer Class


Version Property

SiteInformationSiteServer.Version Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
C++
public property string Version sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Version();

/** property */
public void set_Version(string value);
JScript
public function get Version() : String

public function set Version(value : String);

See Also

SiteInformationSiteServer Class


SiteInformationSiteServerOperatingSystem Class

SiteInformationSiteServerOperatingSystem Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SiteInformationSiteServerOperatingSystem
C#
public class SiteInformationSiteServerOperatingSystem
C++
ref class SiteInformationSiteServerOperatingSystem
J#
public class SiteInformationSiteServerOperatingSystem
JScript
public class SiteInformationSiteServerOperatingSystem

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SiteInformationSiteServerOperatingSystem

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SiteInformationSiteServerOperatingSystem Members


SiteInformationSiteServerOperatingSystem Members

SiteInformationSiteServerOperatingSystem Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SiteInformationSiteServerOperatingSystem.

Public Constructors

 | Name | Description
Public method | SiteInformationSiteServerOperatingSystem | Initializes a new instance of the SiteInformationSiteServerOperatingSystem class.
Top

Public Properties

 | Name | Description
Public property | AvailablePhysicalMemory |
Public property | AvailableVirtualMemory |
Public property | TotalPhysicalMemory |
Public property | TotalVirtualMemory |
Public property | Version |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SiteInformationSiteServerOperatingSystem Class


SiteInformationSiteServerOperatingSystem Constructor

SiteInformationSiteServerOperatingSystem Constructor
[image]

Initializes a new instance of the SiteInformationSiteServerOperatingSystem class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SiteInformationSiteServerOperatingSystem()
C++
public:
SiteInformationSiteServerOperatingSystem() sealed
J#
public SiteInformationSiteServerOperatingSystem()
JScript
public function SiteInformationSiteServerOperatingSystem()

See Also

SiteInformationSiteServerOperatingSystem Class


Properties

SiteInformationSiteServerOperatingSystem Properties
[image]

Public Properties

 | Name | Description
Public property | AvailablePhysicalMemory |
Public property | AvailableVirtualMemory |
Public property | TotalPhysicalMemory |
Public property | TotalVirtualMemory |
Public property | Version |
Top

See Also

SiteInformationSiteServerOperatingSystem Class


AvailablePhysicalMemory Property

SiteInformationSiteServerOperatingSystem.AvailablePhysicalMemory Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property AvailablePhysicalMemory As String
C#
[XmlElementAttribute(DataType = "integer")]
public string AvailablePhysicalMemory { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string AvailablePhysicalMemory sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_AvailablePhysicalMemory();

/** property */
public void set_AvailablePhysicalMemory(string value);
JScript
public function get AvailablePhysicalMemory() : String

public function set AvailablePhysicalMemory(value : String);

See Also

SiteInformationSiteServerOperatingSystem Class


AvailableVirtualMemory Property

SiteInformationSiteServerOperatingSystem.AvailableVirtualMemory Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property AvailableVirtualMemory As String
C#
[XmlElementAttribute(DataType = "integer")]
public string AvailableVirtualMemory { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string AvailableVirtualMemory sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_AvailableVirtualMemory();

/** property */
public void set_AvailableVirtualMemory(string value);
JScript
public function get AvailableVirtualMemory() : String

public function set AvailableVirtualMemory(value : String);

See Also

SiteInformationSiteServerOperatingSystem Class


TotalPhysicalMemory Property

SiteInformationSiteServerOperatingSystem.TotalPhysicalMemory Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property TotalPhysicalMemory As String
C#
[XmlElementAttribute(DataType = "integer")]
public string TotalPhysicalMemory { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string TotalPhysicalMemory sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_TotalPhysicalMemory();

/** property */
public void set_TotalPhysicalMemory(string value);
JScript
public function get TotalPhysicalMemory() : String

public function set TotalPhysicalMemory(value : String);

See Also

SiteInformationSiteServerOperatingSystem Class


TotalVirtualMemory Property

SiteInformationSiteServerOperatingSystem.TotalVirtualMemory Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property TotalVirtualMemory As String
C#
[XmlElementAttribute(DataType = "integer")]
public string TotalVirtualMemory { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string TotalVirtualMemory sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_TotalVirtualMemory();

/** property */
public void set_TotalVirtualMemory(string value);
JScript
public function get TotalVirtualMemory() : String

public function set TotalVirtualMemory(value : String);

See Also

SiteInformationSiteServerOperatingSystem Class


Version Property

SiteInformationSiteServerOperatingSystem.Version Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
C++
public property string Version sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Version();

/** property */
public void set_Version(string value);
JScript
public function get Version() : String

public function set Version(value : String);

See Also

SiteInformationSiteServerOperatingSystem Class


SiteInformationStatistics Class

SiteInformationStatistics Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SiteInformationStatistics
C#
public class SiteInformationStatistics
C++
ref class SiteInformationStatistics
J#
public class SiteInformationStatistics
JScript
public class SiteInformationStatistics

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SiteInformationStatistics

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SiteInformationStatistics Members


SiteInformationStatistics Members

SiteInformationStatistics Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SiteInformationStatistics.

Public Constructors

 | Name | Description
Public method | SiteInformationStatistics | Initializes a new instance of the SiteInformationStatistics class.
Top

Public Properties

 | Name | Description
Public property | ActiveConnections |
Public property | AdminOperationsQueueCount |
Public property | AverageOperationTime |
Public property | ClientOperationsQueueCount |
Public property | CpuUtilization |
Public property | SiteOperationsQueueCount |
Public property | TotalConnections |
Public property | TotalOperationsProcessed |
Public property | TotalOperationsReceived |
Public property | TotalOperationTime |
Public property | Uptime |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SiteInformationStatistics Class


SiteInformationStatistics Constructor

SiteInformationStatistics Constructor
[image]

Initializes a new instance of the SiteInformationStatistics class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SiteInformationStatistics()
C++
public:
SiteInformationStatistics() sealed
J#
public SiteInformationStatistics()
JScript
public function SiteInformationStatistics()

See Also

SiteInformationStatistics Class


Properties

SiteInformationStatistics Properties
[image]

Public Properties

 | Name | Description
Public property | ActiveConnections |
Public property | AdminOperationsQueueCount |
Public property | AverageOperationTime |
Public property | ClientOperationsQueueCount |
Public property | CpuUtilization |
Public property | SiteOperationsQueueCount |
Public property | TotalConnections |
Public property | TotalOperationsProcessed |
Public property | TotalOperationsReceived |
Public property | TotalOperationTime |
Public property | Uptime |
Top

See Also

SiteInformationStatistics Class


ActiveConnections Property

SiteInformationStatistics.ActiveConnections Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property ActiveConnections As String
C#
[XmlElementAttribute(DataType = "integer")]
public string ActiveConnections { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string ActiveConnections sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_ActiveConnections();

/** property */
public void set_ActiveConnections(string value);
JScript
public function get ActiveConnections() : String

public function set ActiveConnections(value : String);

See Also

SiteInformationStatistics Class


AdminOperationsQueueCount Property

SiteInformationStatistics.AdminOperationsQueueCount Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property AdminOperationsQueueCount As String
C#
[XmlElementAttribute(DataType = "integer")]
public string AdminOperationsQueueCount { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string AdminOperationsQueueCount sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_AdminOperationsQueueCount();

/** property */
public void set_AdminOperationsQueueCount(string value);
JScript
public function get AdminOperationsQueueCount() : String

public function set AdminOperationsQueueCount(value : String);

See Also

SiteInformationStatistics Class


AverageOperationTime Property

SiteInformationStatistics.AverageOperationTime Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property AverageOperationTime As String
C#
[XmlElementAttribute(DataType = "integer")]
public string AverageOperationTime { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string AverageOperationTime sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_AverageOperationTime();

/** property */
public void set_AverageOperationTime(string value);
JScript
public function get AverageOperationTime() : String

public function set AverageOperationTime(value : String);

See Also

SiteInformationStatistics Class


ClientOperationsQueueCount Property

SiteInformationStatistics.ClientOperationsQueueCount Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property ClientOperationsQueueCount As String
C#
[XmlElementAttribute(DataType = "integer")]
public string ClientOperationsQueueCount { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string ClientOperationsQueueCount sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_ClientOperationsQueueCount();

/** property */
public void set_ClientOperationsQueueCount(string value);
JScript
public function get ClientOperationsQueueCount() : String

public function set ClientOperationsQueueCount(value : String);

See Also

SiteInformationStatistics Class


CpuUtilization Property

SiteInformationStatistics.CpuUtilization Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property CpuUtilization As String
C#
[XmlElementAttribute(DataType = "integer")]
public string CpuUtilization { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string CpuUtilization sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_CpuUtilization();

/** property */
public void set_CpuUtilization(string value);
JScript
public function get CpuUtilization() : String

public function set CpuUtilization(value : String);

See Also

SiteInformationStatistics Class


SiteOperationsQueueCount Property

SiteInformationStatistics.SiteOperationsQueueCount Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property SiteOperationsQueueCount As String
C#
[XmlElementAttribute(DataType = "integer")]
public string SiteOperationsQueueCount { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string SiteOperationsQueueCount sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_SiteOperationsQueueCount();

/** property */
public void set_SiteOperationsQueueCount(string value);
JScript
public function get SiteOperationsQueueCount() : String

public function set SiteOperationsQueueCount(value : String);

See Also

SiteInformationStatistics Class


TotalConnections Property

SiteInformationStatistics.TotalConnections Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property TotalConnections As String
C#
[XmlElementAttribute(DataType = "integer")]
public string TotalConnections { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string TotalConnections sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_TotalConnections();

/** property */
public void set_TotalConnections(string value);
JScript
public function get TotalConnections() : String

public function set TotalConnections(value : String);

See Also

SiteInformationStatistics Class


TotalOperationsProcessed Property

SiteInformationStatistics.TotalOperationsProcessed Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property TotalOperationsProcessed As String
C#
[XmlElementAttribute(DataType = "integer")]
public string TotalOperationsProcessed { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string TotalOperationsProcessed sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_TotalOperationsProcessed();

/** property */
public void set_TotalOperationsProcessed(string value);
JScript
public function get TotalOperationsProcessed() : String

public function set TotalOperationsProcessed(value : String);

See Also

SiteInformationStatistics Class


TotalOperationsReceived Property

SiteInformationStatistics.TotalOperationsReceived Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property TotalOperationsReceived As String
C#
[XmlElementAttribute(DataType = "integer")]
public string TotalOperationsReceived { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string TotalOperationsReceived sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_TotalOperationsReceived();

/** property */
public void set_TotalOperationsReceived(string value);
JScript
public function get TotalOperationsReceived() : String

public function set TotalOperationsReceived(value : String);

See Also

SiteInformationStatistics Class


TotalOperationTime Property

SiteInformationStatistics.TotalOperationTime Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property TotalOperationTime As String
C#
[XmlElementAttribute(DataType = "integer")]
public string TotalOperationTime { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string TotalOperationTime sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_TotalOperationTime();

/** property */
public void set_TotalOperationTime(string value);
JScript
public function get TotalOperationTime() : String

public function set TotalOperationTime(value : String);

See Also

SiteInformationStatistics Class


Uptime Property

SiteInformationStatistics.Uptime Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property Uptime As String
C#
[XmlElementAttribute(DataType = "integer")]
public string Uptime { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string Uptime sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_Uptime();

/** property */
public void set_Uptime(string value);
JScript
public function get Uptime() : String

public function set Uptime(value : String);

See Also

SiteInformationStatistics Class


SiteVersion Class

SiteVersion Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class SiteVersion
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class SiteVersion
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class SiteVersion
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class SiteVersion
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class SiteVersion

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SiteVersion

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SiteVersion Members


SiteVersion Members

SiteVersion Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by SiteVersion.

Public Constructors

 | Name | Description
Public method | SiteVersion | Initializes a new instance of the SiteVersion class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Version |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SiteVersion Class


SiteVersion Constructor

SiteVersion Constructor
[image]

Initializes a new instance of the SiteVersion class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SiteVersion()
C++
public:
SiteVersion() sealed
J#
public SiteVersion()
JScript
public function SiteVersion()

See Also

SiteVersion Class


Fields

SiteVersion Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

SiteVersion Class


SchemaName Field

SiteVersion.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

SiteVersion Class


Properties

SiteVersion Properties
[image]

Public Properties

 | Name | Description
Public property | Version |
Public property | XsdSchema |
Top

See Also

SiteVersion Class


Version Property

SiteVersion.Version Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As String
C#
public string Version { get; set; }
C++
public property string Version sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Version();

/** property */
public void set_Version(string value);
JScript
public function get Version() : String

public function set Version(value : String);

See Also

SiteVersion Class


XsdSchema Property

SiteVersion.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

SiteVersion Class


SiteVersions Class

SiteVersions Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SiteVersions
C#
public class SiteVersions
C++
ref class SiteVersions
J#
public class SiteVersions
JScript
public class SiteVersions

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SiteVersions

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SiteVersions Members


SiteVersions Members

SiteVersions Members
See Also Example Constructors Fields Methods
[image]

The following tables list the members exposed by SiteVersions.

Public Constructors

 | Name | Description
Public method | SiteVersions | Initializes a new instance of the SiteVersions class.
Top

Public Fields

Name | Description
SiteVersionNumbers |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | GetVersion |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SiteVersions Class


SiteVersions Constructor

SiteVersions Constructor
[image]

Initializes a new instance of the SiteVersions class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SiteVersions()
C++
public:
SiteVersions() sealed
J#
public SiteVersions()
JScript
public function SiteVersions()

See Also

SiteVersions Class


Fields

SiteVersions Fields
[image]

Public Fields

Name | Description
SiteVersionNumbers |
Top

See Also

SiteVersions Class


SiteVersionNumbers Field

SiteVersions.SiteVersionNumbers Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SiteVersionNumbers As Version()
C#
public static readonly Version[] SiteVersionNumbers;
C++
public:
static const array<Version>^ SiteVersionNumbers;
J#
public static final Version[] SiteVersionNumbers
JScript
public static const var SiteVersionNumbers : Version[];

See Also

SiteVersions Class


Methods

SiteVersions Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | GetVersion |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SiteVersions Class


GetVersion Method

SiteVersions.GetVersion Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetVersion( _
ByVal index As KnownSiteVersions _
) As Version
C#
public static Version GetVersion(
KnownSiteVersions index
)
C++
public:
static Version GetVersion(
KnownSiteVersions index
)
J#
public static Version GetVersion(
KnownSiteVersions index
)
JScript
public static function GetVersion(
index : KnownSiteVersions
) : Version

See Also

SiteVersions Class


SizeContextType Enumeration

SizeContextType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum SizeContextType
C#
public enum SizeContextType
C++
public enum class SizeContextType
J#
public enum SizeContextType
JScript
public enum SizeContextType

Members

Member Name | Description
Default |
MappingUnits |
DeviceUnits |

See Also


SpatialContextType Class

SpatialContextType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SpatialContextType
C#
public class SpatialContextType
C++
ref class SpatialContextType
J#
public class SpatialContextType
JScript
public class SpatialContextType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SpatialContextType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SpatialContextType Members


SpatialContextType Members

SpatialContextType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SpatialContextType.

Public Constructors

 | Name | Description
Public method | SpatialContextType | Initializes a new instance of the SpatialContextType class.
Top

Public Properties

 | Name | Description
Public property | CoordinateSystem |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SpatialContextType Class


SpatialContextType Constructor

SpatialContextType Constructor
[image]

Initializes a new instance of the SpatialContextType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SpatialContextType()
C++
public:
SpatialContextType() sealed
J#
public SpatialContextType()
JScript
public function SpatialContextType()

See Also

SpatialContextType Class


Properties

SpatialContextType Properties
[image]

Public Properties

 | Name | Description
Public property | CoordinateSystem |
Public property | Name |
Top

See Also

SpatialContextType Class


CoordinateSystem Property

SpatialContextType.CoordinateSystem Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CoordinateSystem As String
C#
public string CoordinateSystem { get; set; }
C++
public property string CoordinateSystem sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CoordinateSystem();

/** property */
public void set_CoordinateSystem(string value);
JScript
public function get CoordinateSystem() : String

public function set CoordinateSystem(value : String);

See Also

SpatialContextType Class


Name Property

SpatialContextType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

SpatialContextType Class


SpatialContextTypeCollection Class

SpatialContextTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class SpatialContextTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class SpatialContextTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class SpatialContextTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class SpatialContextTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class SpatialContextTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.SpatialContextTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SpatialContextTypeCollection Members


SpatialContextTypeCollection Members

SpatialContextTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SpatialContextTypeCollection.

Public Constructors

 | Name | Description
Public method | SpatialContextTypeCollection | Initializes a new instance of the SpatialContextTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SpatialContextTypeCollection Class


SpatialContextTypeCollection Constructor

SpatialContextTypeCollection Constructor
[image]

Initializes a new instance of the SpatialContextTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SpatialContextTypeCollection()
C++
public:
SpatialContextTypeCollection() sealed
J#
public SpatialContextTypeCollection()
JScript
public function SpatialContextTypeCollection()

See Also

SpatialContextTypeCollection Class


Properties

SpatialContextTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

SpatialContextTypeCollection Class


Item Property

SpatialContextTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As SpatialContextType
C#
public SpatialContextType this[
int idx
] { get; set; }
C++
public property SpatialContextType default[int idx] sealed {
SpatialContextType get(int idx);
void set(int idx, SpatialContextType value);
}
J#
/** property */
public SpatialContextType get_Item(int idx);

/** property */
public void set_Item(int idx, SpatialContextType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

SpatialContextTypeCollection Class


Methods

SpatialContextTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SpatialContextTypeCollection Class


Add Method

SpatialContextTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As SpatialContextType _
) As Integer
C#
public int Add(
SpatialContextType value
)
C++
public:
int Add(
SpatialContextType value
) sealed
J#
public int Add(
SpatialContextType value
)
JScript
public function Add(
value : SpatialContextType
) : int

See Also

SpatialContextTypeCollection Class


StatusBarType Class

StatusBarType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class StatusBarType
Inherits WebLayoutControlType
C#
public class StatusBarType : WebLayoutControlType
C++
ref class StatusBarType : WebLayoutControlType
J#
public class StatusBarType extends WebLayoutControlType
JScript
public class StatusBarType extends WebLayoutControlType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.WebLayoutControlType
OSGeo.MapGuide.MaestroAPI.StatusBarType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

StatusBarType Members


StatusBarType Members

StatusBarType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by StatusBarType.

Public Constructors

 | Name | Description
Public method | StatusBarType | Initializes a new instance of the StatusBarType class.
Top

Public Properties

 | Name | Description
Public property | Visible | (inherited from WebLayoutControlType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

StatusBarType Class


StatusBarType Constructor

StatusBarType Constructor
[image]

Initializes a new instance of the StatusBarType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StatusBarType()
C++
public:
StatusBarType() sealed
J#
public StatusBarType()
JScript
public function StatusBarType()

See Also

StatusBarType Class


StrokeType Class

StrokeType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class StrokeType
C#
public class StrokeType
C++
ref class StrokeType
J#
public class StrokeType
JScript
public class StrokeType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.StrokeType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

StrokeType Members


StrokeType Members

StrokeType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by StrokeType.

Public Constructors

 | Name | Description
Public method | StrokeType | Initializes a new instance of the StrokeType class.
Top

Public Properties

 | Name | Description
Public property | Color |
Public property | ColorAsHTML |
Public property | ExtendedData1 |
Public property | LineStyle |
Public property | SizeContext |
Public property | Thickness |
Public property | Unit |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

StrokeType Class


StrokeType Constructor

StrokeType Constructor
[image]

Initializes a new instance of the StrokeType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StrokeType()
C++
public:
StrokeType() sealed
J#
public StrokeType()
JScript
public function StrokeType()

See Also

StrokeType Class


Properties

StrokeType Properties
[image]

Public Properties

 | Name | Description
Public property | Color |
Public property | ColorAsHTML |
Public property | ExtendedData1 |
Public property | LineStyle |
Public property | SizeContext |
Public property | Thickness |
Public property | Unit |
Top

See Also

StrokeType Class


Color Property

StrokeType.Color Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property Color As Color
C#
[XmlIgnoreAttribute]
public Color Color { get; set; }
C++
[XmlIgnoreAttribute]
public property Color Color sealed {
Color get();
void set(Color value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public Color get_Color();

/** property */
public void set_Color(Color value);
JScript
public function get Color() : Color

public function set Color(value : Color);

See Also

StrokeType Class


ColorAsHTML Property

StrokeType.ColorAsHTML Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Color")>
Public Property ColorAsHTML As String
C#
[XmlElementAttribute("Color")]
public string ColorAsHTML { get; set; }
C++
[XmlElementAttribute(L"Color")]
public property string ColorAsHTML sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute("Color") */
/** property */
public string get_ColorAsHTML();

/** property */
public void set_ColorAsHTML(string value);
JScript
public function get ColorAsHTML() : String

public function set ColorAsHTML(value : String);

See Also

StrokeType Class


ExtendedData1 Property

StrokeType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

StrokeType Class


LineStyle Property

StrokeType.LineStyle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LineStyle As String
C#
public string LineStyle { get; set; }
C++
public property string LineStyle sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LineStyle();

/** property */
public void set_LineStyle(string value);
JScript
public function get LineStyle() : String

public function set LineStyle(value : String);

See Also

StrokeType Class


SizeContext Property

StrokeType.SizeContext Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(SizeContextType.Default)>
Public Property SizeContext As SizeContextType
C#
[DefaultValueAttribute(SizeContextType.Default)]
public SizeContextType SizeContext { get; set; }
C++
[DefaultValueAttribute(SizeContextType::Default)]
public property SizeContextType SizeContext sealed {
SizeContextType get();
void set(SizeContextType value);
}
J#
/** @attribute DefaultValueAttribute(SizeContextType.Default) */
/** property */
public SizeContextType get_SizeContext();

/** property */
public void set_SizeContext(SizeContextType value);
JScript
public function get SizeContext() : SizeContextType

public function set SizeContext(value : SizeContextType);

See Also

StrokeType Class


Thickness Property

StrokeType.Thickness Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Thickness As String
C#
public string Thickness { get; set; }
C++
public property string Thickness sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Thickness();

/** property */
public void set_Thickness(string value);
JScript
public function get Thickness() : String

public function set Thickness(value : String);

See Also

StrokeType Class


Unit Property

StrokeType.Unit Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Unit As LengthUnitType
C#
public LengthUnitType Unit { get; set; }
C++
public property LengthUnitType Unit sealed {
LengthUnitType get();
void set(LengthUnitType value);
}
J#
/** property */
public LengthUnitType get_Unit();

/** property */
public void set_Unit(LengthUnitType value);
JScript
public function get Unit() : LengthUnitType

public function set Unit(value : LengthUnitType);

See Also

StrokeType Class


StrokeTypeCollection Class

StrokeTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class StrokeTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class StrokeTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class StrokeTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class StrokeTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class StrokeTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.StrokeTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

StrokeTypeCollection Members


StrokeTypeCollection Members

StrokeTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by StrokeTypeCollection.

Public Constructors

 | Name | Description
Public method | StrokeTypeCollection | Initializes a new instance of the StrokeTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

StrokeTypeCollection Class


StrokeTypeCollection Constructor

StrokeTypeCollection Constructor
[image]

Initializes a new instance of the StrokeTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public StrokeTypeCollection()
C++
public:
StrokeTypeCollection() sealed
J#
public StrokeTypeCollection()
JScript
public function StrokeTypeCollection()

See Also

StrokeTypeCollection Class


Properties

StrokeTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

StrokeTypeCollection Class


Item Property

StrokeTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As StrokeType
C#
public StrokeType this[
int idx
] { get; set; }
C++
public property StrokeType default[int idx] sealed {
StrokeType get(int idx);
void set(int idx, StrokeType value);
}
J#
/** property */
public StrokeType get_Item(int idx);

/** property */
public void set_Item(int idx, StrokeType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

StrokeTypeCollection Class


Methods

StrokeTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

StrokeTypeCollection Class


Add Method

StrokeTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As StrokeType _
) As Integer
C#
public int Add(
StrokeType value
)
C++
public:
int Add(
StrokeType value
) sealed
J#
public int Add(
StrokeType value
)
JScript
public function Add(
value : StrokeType
) : int

See Also

StrokeTypeCollection Class


SymbolDefinitionBase Class

SymbolDefinitionBase Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(CompoundSymbolDefinition)), _
XmlIncludeAttribute(GetType(SimpleSymbolDefinition))>
Public Class SymbolDefinitionBase
C#
[XmlIncludeAttribute(typeof(CompoundSymbolDefinition))]
[XmlIncludeAttribute(typeof(SimpleSymbolDefinition))]
public class SymbolDefinitionBase
C++
[XmlIncludeAttribute(typeof(CompoundSymbolDefinition))]
[XmlIncludeAttribute(typeof(SimpleSymbolDefinition))]
ref class SymbolDefinitionBase
J#
/** @attribute XmlIncludeAttribute(typeof(CompoundSymbolDefinition)) */
/** @attribute XmlIncludeAttribute(typeof(SimpleSymbolDefinition)) */
public class SymbolDefinitionBase
JScript
public
XmlIncludeAttribute(typeof(CompoundSymbolDefinition))
XmlIncludeAttribute(typeof(SimpleSymbolDefinition))
class SymbolDefinitionBase

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolDefinitionBase
OSGeo.MapGuide.MaestroAPI.CompoundSymbolDefinition
OSGeo.MapGuide.MaestroAPI.SimpleSymbolDefinition

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SymbolDefinitionBase Members


SymbolDefinitionBase Members

SymbolDefinitionBase Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SymbolDefinitionBase.

Public Constructors

 | Name | Description
Public method | SymbolDefinitionBase | Initializes a new instance of the SymbolDefinitionBase class.
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SymbolDefinitionBase Class


SymbolDefinitionBase Constructor

SymbolDefinitionBase Constructor
[image]

Initializes a new instance of the SymbolDefinitionBase class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SymbolDefinitionBase()
C++
public:
SymbolDefinitionBase() sealed
J#
public SymbolDefinitionBase()
JScript
public function SymbolDefinitionBase()

See Also

SymbolDefinitionBase Class


Properties

SymbolDefinitionBase Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | Name |
Top

See Also

SymbolDefinitionBase Class


Description Property

SymbolDefinitionBase.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

SymbolDefinitionBase Class


Name Property

SymbolDefinitionBase.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

SymbolDefinitionBase Class


SymbolInstance Class

SymbolInstance Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SymbolInstance
C#
public class SymbolInstance
C++
ref class SymbolInstance
J#
public class SymbolInstance
JScript
public class SymbolInstance

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolInstance

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SymbolInstance Members


SymbolInstance Members

SymbolInstance Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SymbolInstance.

Public Constructors

 | Name | Description
Public method | SymbolInstance | Initializes a new instance of the SymbolInstance class.
Top

Public Properties

 | Name | Description
Public property | AddToExclusionRegion |
Public property | CheckExclusionRegion |
Public property | DrawLast |
Public property | ExtendedData1 |
Public property | GeometryContext |
Public property | InsertionOffsetX |
Public property | InsertionOffsetY |
Public property | Item |
Public property | ParameterOverrides |
Public property | PositioningAlgorithm |
Public property | RenderingPass |
Public property | ScaleX |
Public property | ScaleY |
Public property | SizeContext |
Public property | UsageContext |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SymbolInstance Class


SymbolInstance Constructor

SymbolInstance Constructor
[image]

Initializes a new instance of the SymbolInstance class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SymbolInstance()
C++
public:
SymbolInstance() sealed
J#
public SymbolInstance()
JScript
public function SymbolInstance()

See Also

SymbolInstance Class


Properties

SymbolInstance Properties
[image]

Public Properties

 | Name | Description
Public property | AddToExclusionRegion |
Public property | CheckExclusionRegion |
Public property | DrawLast |
Public property | ExtendedData1 |
Public property | GeometryContext |
Public property | InsertionOffsetX |
Public property | InsertionOffsetY |
Public property | Item |
Public property | ParameterOverrides |
Public property | PositioningAlgorithm |
Public property | RenderingPass |
Public property | ScaleX |
Public property | ScaleY |
Public property | SizeContext |
Public property | UsageContext |
Top

See Also

SymbolInstance Class


AddToExclusionRegion Property

SymbolInstance.AddToExclusionRegion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("false")>
Public Property AddToExclusionRegion As String
C#
[DefaultValueAttribute("false")]
public string AddToExclusionRegion { get; set; }
C++
[DefaultValueAttribute(L"false")]
public property string AddToExclusionRegion sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("false") */
/** property */
public string get_AddToExclusionRegion();

/** property */
public void set_AddToExclusionRegion(string value);
JScript
public function get AddToExclusionRegion() : String

public function set AddToExclusionRegion(value : String);

See Also

SymbolInstance Class


CheckExclusionRegion Property

SymbolInstance.CheckExclusionRegion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("false")>
Public Property CheckExclusionRegion As String
C#
[DefaultValueAttribute("false")]
public string CheckExclusionRegion { get; set; }
C++
[DefaultValueAttribute(L"false")]
public property string CheckExclusionRegion sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("false") */
/** property */
public string get_CheckExclusionRegion();

/** property */
public void set_CheckExclusionRegion(string value);
JScript
public function get CheckExclusionRegion() : String

public function set CheckExclusionRegion(value : String);

See Also

SymbolInstance Class


DrawLast Property

SymbolInstance.DrawLast Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("false")>
Public Property DrawLast As String
C#
[DefaultValueAttribute("false")]
public string DrawLast { get; set; }
C++
[DefaultValueAttribute(L"false")]
public property string DrawLast sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("false") */
/** property */
public string get_DrawLast();

/** property */
public void set_DrawLast(string value);
JScript
public function get DrawLast() : String

public function set DrawLast(value : String);

See Also

SymbolInstance Class


ExtendedData1 Property

SymbolInstance.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

SymbolInstance Class


GeometryContext Property

SymbolInstance.GeometryContext Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(GeometryContextType.Unspecified)>
Public Property GeometryContext As GeometryContextType
C#
[DefaultValueAttribute(GeometryContextType.Unspecified)]
public GeometryContextType GeometryContext { get; set; }
C++
[DefaultValueAttribute(GeometryContextType::Unspecified)]
public property GeometryContextType GeometryContext sealed {
GeometryContextType get();
void set(GeometryContextType value);
}
J#
/** @attribute DefaultValueAttribute(GeometryContextType.Unspecified) */
/** property */
public GeometryContextType get_GeometryContext();

/** property */
public void set_GeometryContext(GeometryContextType value);
JScript
public function get GeometryContext() : GeometryContextType

public function set GeometryContext(value : GeometryContextType);

See Also

SymbolInstance Class


InsertionOffsetX Property

SymbolInstance.InsertionOffsetX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property InsertionOffsetX As String
C#
[DefaultValueAttribute("0.0")]
public string InsertionOffsetX { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string InsertionOffsetX sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_InsertionOffsetX();

/** property */
public void set_InsertionOffsetX(string value);
JScript
public function get InsertionOffsetX() : String

public function set InsertionOffsetX(value : String);

See Also

SymbolInstance Class


InsertionOffsetY Property

SymbolInstance.InsertionOffsetY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property InsertionOffsetY As String
C#
[DefaultValueAttribute("0.0")]
public string InsertionOffsetY { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string InsertionOffsetY sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_InsertionOffsetY();

/** property */
public void set_InsertionOffsetY(string value);
JScript
public function get InsertionOffsetY() : String

public function set InsertionOffsetY(value : String);

See Also

SymbolInstance Class


Item Property

SymbolInstance.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("ResourceId", GetType(String)), _
XmlElementAttribute("CompoundSymbolDefinition", GetType(CompoundSymbolDefinition)), _
XmlElementAttribute("SimpleSymbolDefinition", GetType(SimpleSymbolDefinition))>
Public Property Item As Object
C#
[XmlElementAttribute("ResourceId", typeof(String))]
[XmlElementAttribute("CompoundSymbolDefinition", typeof(CompoundSymbolDefinition))]
[XmlElementAttribute("SimpleSymbolDefinition", typeof(SimpleSymbolDefinition))]
public object Item { get; set; }
C++
[XmlElementAttribute(L"ResourceId", typeof(String))]
[XmlElementAttribute(L"CompoundSymbolDefinition", typeof(CompoundSymbolDefinition))]
[XmlElementAttribute(L"SimpleSymbolDefinition", typeof(SimpleSymbolDefinition))]
public property object Item sealed {
Object get();
void set(Object value);
}
J#
/** @attribute XmlElementAttribute("ResourceId", typeof(String)) */
/** @attribute XmlElementAttribute("CompoundSymbolDefinition", typeof(CompoundSymbolDefinition)) */
/** @attribute XmlElementAttribute("SimpleSymbolDefinition", typeof(SimpleSymbolDefinition)) */
/** property */
public object get_Item();

/** property */
public void set_Item(object value);
JScript
public function get Item() : Object

public function set Item(value : Object);

See Also

SymbolInstance Class


ParameterOverrides Property

SymbolInstance.ParameterOverrides Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ParameterOverrides As ParameterOverrides
C#
public ParameterOverrides ParameterOverrides { get; set; }
C++
public property ParameterOverrides ParameterOverrides sealed {
ParameterOverrides get();
void set(ParameterOverrides value);
}
J#
/** property */
public ParameterOverrides get_ParameterOverrides();

/** property */
public void set_ParameterOverrides(ParameterOverrides value);
JScript
public function get ParameterOverrides() : ParameterOverrides

public function set ParameterOverrides(value : ParameterOverrides);

See Also

SymbolInstance Class


PositioningAlgorithm Property

SymbolInstance.PositioningAlgorithm Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property PositioningAlgorithm As String
C#
public string PositioningAlgorithm { get; set; }
C++
public property string PositioningAlgorithm sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_PositioningAlgorithm();

/** property */
public void set_PositioningAlgorithm(string value);
JScript
public function get PositioningAlgorithm() : String

public function set PositioningAlgorithm(value : String);

See Also

SymbolInstance Class


RenderingPass Property

SymbolInstance.RenderingPass Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0")>
Public Property RenderingPass As String
C#
[DefaultValueAttribute("0")]
public string RenderingPass { get; set; }
C++
[DefaultValueAttribute(L"0")]
public property string RenderingPass sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0") */
/** property */
public string get_RenderingPass();

/** property */
public void set_RenderingPass(string value);
JScript
public function get RenderingPass() : String

public function set RenderingPass(value : String);

See Also

SymbolInstance Class


ScaleX Property

SymbolInstance.ScaleX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("1.0")>
Public Property ScaleX As String
C#
[DefaultValueAttribute("1.0")]
public string ScaleX { get; set; }
C++
[DefaultValueAttribute(L"1.0")]
public property string ScaleX sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("1.0") */
/** property */
public string get_ScaleX();

/** property */
public void set_ScaleX(string value);
JScript
public function get ScaleX() : String

public function set ScaleX(value : String);

See Also

SymbolInstance Class


ScaleY Property

SymbolInstance.ScaleY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("1.0")>
Public Property ScaleY As String
C#
[DefaultValueAttribute("1.0")]
public string ScaleY { get; set; }
C++
[DefaultValueAttribute(L"1.0")]
public property string ScaleY sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("1.0") */
/** property */
public string get_ScaleY();

/** property */
public void set_ScaleY(string value);
JScript
public function get ScaleY() : String

public function set ScaleY(value : String);

See Also

SymbolInstance Class


SizeContext Property

SymbolInstance.SizeContext Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(SizeContextType.DeviceUnits)>
Public Property SizeContext As SizeContextType
C#
[DefaultValueAttribute(SizeContextType.DeviceUnits)]
public SizeContextType SizeContext { get; set; }
C++
[DefaultValueAttribute(SizeContextType::DeviceUnits)]
public property SizeContextType SizeContext sealed {
SizeContextType get();
void set(SizeContextType value);
}
J#
/** @attribute DefaultValueAttribute(SizeContextType.DeviceUnits) */
/** property */
public SizeContextType get_SizeContext();

/** property */
public void set_SizeContext(SizeContextType value);
JScript
public function get SizeContext() : SizeContextType

public function set SizeContext(value : SizeContextType);

See Also

SymbolInstance Class


UsageContext Property

SymbolInstance.UsageContext Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(UsageContextType.Unspecified)>
Public Property UsageContext As UsageContextType
C#
[DefaultValueAttribute(UsageContextType.Unspecified)]
public UsageContextType UsageContext { get; set; }
C++
[DefaultValueAttribute(UsageContextType::Unspecified)]
public property UsageContextType UsageContext sealed {
UsageContextType get();
void set(UsageContextType value);
}
J#
/** @attribute DefaultValueAttribute(UsageContextType.Unspecified) */
/** property */
public UsageContextType get_UsageContext();

/** property */
public void set_UsageContext(UsageContextType value);
JScript
public function get UsageContext() : UsageContextType

public function set UsageContext(value : UsageContextType);

See Also

SymbolInstance Class


SymbolInstanceCollection Class

SymbolInstanceCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class SymbolInstanceCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class SymbolInstanceCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class SymbolInstanceCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class SymbolInstanceCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class SymbolInstanceCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.SymbolInstanceCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SymbolInstanceCollection Members


SymbolInstanceCollection Members

SymbolInstanceCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SymbolInstanceCollection.

Public Constructors

 | Name | Description
Public method | SymbolInstanceCollection | Initializes a new instance of the SymbolInstanceCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SymbolInstanceCollection Class


SymbolInstanceCollection Constructor

SymbolInstanceCollection Constructor
[image]

Initializes a new instance of the SymbolInstanceCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SymbolInstanceCollection()
C++
public:
SymbolInstanceCollection() sealed
J#
public SymbolInstanceCollection()
JScript
public function SymbolInstanceCollection()

See Also

SymbolInstanceCollection Class


Properties

SymbolInstanceCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

SymbolInstanceCollection Class


Item Property

SymbolInstanceCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As SymbolInstance
C#
public SymbolInstance this[
int idx
] { get; set; }
C++
public property SymbolInstance default[int idx] sealed {
SymbolInstance get(int idx);
void set(int idx, SymbolInstance value);
}
J#
/** property */
public SymbolInstance get_Item(int idx);

/** property */
public void set_Item(int idx, SymbolInstance value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

SymbolInstanceCollection Class


Methods

SymbolInstanceCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SymbolInstanceCollection Class


Add Method

SymbolInstanceCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As SymbolInstance _
) As Integer
C#
public int Add(
SymbolInstance value
)
C++
public:
int Add(
SymbolInstance value
) sealed
J#
public int Add(
SymbolInstance value
)
JScript
public function Add(
value : SymbolInstance
) : int

See Also

SymbolInstanceCollection Class


SymbolLibraryType Class

SymbolLibraryType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("SymbolLibrary", Namespace := "", IsNullable := False)>
Public Class SymbolLibraryType
C#
[XmlRootAttribute("SymbolLibrary", Namespace = "", IsNullable = False)]
public class SymbolLibraryType
C++
[XmlRootAttribute(L"SymbolLibrary", Namespace = L"", IsNullable = False)]
ref class SymbolLibraryType
J#
/** @attribute XmlRootAttribute("SymbolLibrary", Namespace = "", IsNullable = False) */
public class SymbolLibraryType
JScript
public
XmlRootAttribute("SymbolLibrary", Namespace = "", IsNullable = False)
class SymbolLibraryType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolLibraryType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SymbolLibraryType Members


SymbolLibraryType Members

SymbolLibraryType Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by SymbolLibraryType.

Public Constructors

 | Name | Description
Public method | SymbolLibraryType | Initializes a new instance of the SymbolLibraryType class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | ResourceId |
Public property | Symbol |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SymbolLibraryType Class


SymbolLibraryType Constructor

SymbolLibraryType Constructor
[image]

Initializes a new instance of the SymbolLibraryType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SymbolLibraryType()
C++
public:
SymbolLibraryType() sealed
J#
public SymbolLibraryType()
JScript
public function SymbolLibraryType()

See Also

SymbolLibraryType Class


Fields

SymbolLibraryType Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

SymbolLibraryType Class


SchemaName Field

SymbolLibraryType.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

SymbolLibraryType Class


Properties

SymbolLibraryType Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | ResourceId |
Public property | Symbol |
Public property | XsdSchema |
Top

See Also

SymbolLibraryType Class


Description Property

SymbolLibraryType.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

SymbolLibraryType Class


ResourceId Property

SymbolLibraryType.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ResourceId As String
C#
[XmlIgnoreAttribute]
public string ResourceId { get; set; }
C++
[XmlIgnoreAttribute]
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

SymbolLibraryType Class


Symbol Property

SymbolLibraryType.Symbol Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Symbol")>
Public Property Symbol As SymbolTypeLibraryCollection
C#
[XmlElementAttribute("Symbol")]
public SymbolTypeLibraryCollection Symbol { get; set; }
C++
[XmlElementAttribute(L"Symbol")]
public property SymbolTypeLibraryCollection Symbol sealed {
SymbolTypeLibraryCollection get();
void set(SymbolTypeLibraryCollection value);
}
J#
/** @attribute XmlElementAttribute("Symbol") */
/** property */
public SymbolTypeLibraryCollection get_Symbol();

/** property */
public void set_Symbol(SymbolTypeLibraryCollection value);
JScript
public function get Symbol() : SymbolTypeLibraryCollection

public function set Symbol(value : SymbolTypeLibraryCollection);

See Also

SymbolLibraryType Class


XsdSchema Property

SymbolLibraryType.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

SymbolLibraryType Class


SymbolType Class

SymbolType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(BlockSymbolType)), _
XmlIncludeAttribute(GetType(FontSymbolType)), _
XmlIncludeAttribute(GetType(TextSymbolType)), _
XmlIncludeAttribute(GetType(ImageSymbolType)), _
XmlIncludeAttribute(GetType(MarkSymbolType)), _
XmlIncludeAttribute(GetType(W2DSymbolType))>
Public Class SymbolType
C#
[XmlIncludeAttribute(typeof(BlockSymbolType))]
[XmlIncludeAttribute(typeof(FontSymbolType))]
[XmlIncludeAttribute(typeof(TextSymbolType))]
[XmlIncludeAttribute(typeof(ImageSymbolType))]
[XmlIncludeAttribute(typeof(MarkSymbolType))]
[XmlIncludeAttribute(typeof(W2DSymbolType))]
public class SymbolType
C++
[XmlIncludeAttribute(typeof(BlockSymbolType))]
[XmlIncludeAttribute(typeof(FontSymbolType))]
[XmlIncludeAttribute(typeof(TextSymbolType))]
[XmlIncludeAttribute(typeof(ImageSymbolType))]
[XmlIncludeAttribute(typeof(MarkSymbolType))]
[XmlIncludeAttribute(typeof(W2DSymbolType))]
ref class SymbolType
J#
/** @attribute XmlIncludeAttribute(typeof(BlockSymbolType)) */
/** @attribute XmlIncludeAttribute(typeof(FontSymbolType)) */
/** @attribute XmlIncludeAttribute(typeof(TextSymbolType)) */
/** @attribute XmlIncludeAttribute(typeof(ImageSymbolType)) */
/** @attribute XmlIncludeAttribute(typeof(MarkSymbolType)) */
/** @attribute XmlIncludeAttribute(typeof(W2DSymbolType)) */
public class SymbolType
JScript
public
XmlIncludeAttribute(typeof(BlockSymbolType))
XmlIncludeAttribute(typeof(FontSymbolType))
XmlIncludeAttribute(typeof(TextSymbolType))
XmlIncludeAttribute(typeof(ImageSymbolType))
XmlIncludeAttribute(typeof(MarkSymbolType))
XmlIncludeAttribute(typeof(W2DSymbolType))
class SymbolType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolType
Derived types

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SymbolType Members


SymbolType Class Hierarchy

SymbolType Hierarchy

The following table lists the types derived from SymbolType .

Derived Types

Type | Description
BlockSymbolType |
FontSymbolType |
ImageSymbolType |
MarkSymbolType |
TextSymbolType |
W2DSymbolType |

See Also

SymbolType Class


SymbolType Members

SymbolType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SymbolType.

Public Constructors

 | Name | Description
Public method | SymbolType | Initializes a new instance of the SymbolType class.
Top

Public Properties

 | Name | Description
Public property | InsertionPointX |
Public property | InsertionPointXSpecified |
Public property | InsertionPointY |
Public property | InsertionPointYSpecified |
Public property | MaintainAspect |
Public property | MaintainAspectSpecified |
Public property | Rotation |
Public property | SizeContext |
Public property | SizeX |
Public property | SizeY |
Public property | Unit |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SymbolType Class


SymbolType Constructor

SymbolType Constructor
[image]

Initializes a new instance of the SymbolType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SymbolType()
C++
public:
SymbolType() sealed
J#
public SymbolType()
JScript
public function SymbolType()

See Also

SymbolType Class


Properties

SymbolType Properties
[image]

Public Properties

 | Name | Description
Public property | InsertionPointX |
Public property | InsertionPointXSpecified |
Public property | InsertionPointY |
Public property | InsertionPointYSpecified |
Public property | MaintainAspect |
Public property | MaintainAspectSpecified |
Public property | Rotation |
Public property | SizeContext |
Public property | SizeX |
Public property | SizeY |
Public property | Unit |
Top

See Also

SymbolType Class


InsertionPointX Property

SymbolType.InsertionPointX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property InsertionPointX As Double
C#
public double InsertionPointX { get; set; }
C++
public property double InsertionPointX sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_InsertionPointX();

/** property */
public void set_InsertionPointX(double value);
JScript
public function get InsertionPointX() : double

public function set InsertionPointX(value : double);

See Also

SymbolType Class


InsertionPointXSpecified Property

SymbolType.InsertionPointXSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property InsertionPointXSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool InsertionPointXSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool InsertionPointXSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_InsertionPointXSpecified();

/** property */
public void set_InsertionPointXSpecified(bool value);
JScript
public function get InsertionPointXSpecified() : bool

public function set InsertionPointXSpecified(value : bool);

See Also

SymbolType Class


InsertionPointY Property

SymbolType.InsertionPointY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property InsertionPointY As Double
C#
public double InsertionPointY { get; set; }
C++
public property double InsertionPointY sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_InsertionPointY();

/** property */
public void set_InsertionPointY(double value);
JScript
public function get InsertionPointY() : double

public function set InsertionPointY(value : double);

See Also

SymbolType Class


InsertionPointYSpecified Property

SymbolType.InsertionPointYSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property InsertionPointYSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool InsertionPointYSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool InsertionPointYSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_InsertionPointYSpecified();

/** property */
public void set_InsertionPointYSpecified(bool value);
JScript
public function get InsertionPointYSpecified() : bool

public function set InsertionPointYSpecified(value : bool);

See Also

SymbolType Class


MaintainAspect Property

SymbolType.MaintainAspect Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MaintainAspect As Boolean
C#
public bool MaintainAspect { get; set; }
C++
public property bool MaintainAspect sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_MaintainAspect();

/** property */
public void set_MaintainAspect(bool value);
JScript
public function get MaintainAspect() : bool

public function set MaintainAspect(value : bool);

See Also

SymbolType Class


MaintainAspectSpecified Property

SymbolType.MaintainAspectSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property MaintainAspectSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool MaintainAspectSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool MaintainAspectSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_MaintainAspectSpecified();

/** property */
public void set_MaintainAspectSpecified(bool value);
JScript
public function get MaintainAspectSpecified() : bool

public function set MaintainAspectSpecified(value : bool);

See Also

SymbolType Class


Rotation Property

SymbolType.Rotation Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Rotation As String
C#
public string Rotation { get; set; }
C++
public property string Rotation sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Rotation();

/** property */
public void set_Rotation(string value);
JScript
public function get Rotation() : String

public function set Rotation(value : String);

See Also

SymbolType Class


SizeContext Property

SymbolType.SizeContext Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute(SizeContextType.Default)>
Public Property SizeContext As SizeContextType
C#
[DefaultValueAttribute(SizeContextType.Default)]
public SizeContextType SizeContext { get; set; }
C++
[DefaultValueAttribute(SizeContextType::Default)]
public property SizeContextType SizeContext sealed {
SizeContextType get();
void set(SizeContextType value);
}
J#
/** @attribute DefaultValueAttribute(SizeContextType.Default) */
/** property */
public SizeContextType get_SizeContext();

/** property */
public void set_SizeContext(SizeContextType value);
JScript
public function get SizeContext() : SizeContextType

public function set SizeContext(value : SizeContextType);

See Also

SymbolType Class


SizeX Property

SymbolType.SizeX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SizeX As String
C#
public string SizeX { get; set; }
C++
public property string SizeX sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SizeX();

/** property */
public void set_SizeX(string value);
JScript
public function get SizeX() : String

public function set SizeX(value : String);

See Also

SymbolType Class


SizeY Property

SymbolType.SizeY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SizeY As String
C#
public string SizeY { get; set; }
C++
public property string SizeY sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SizeY();

/** property */
public void set_SizeY(string value);
JScript
public function get SizeY() : String

public function set SizeY(value : String);

See Also

SymbolType Class


Unit Property

SymbolType.Unit Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Unit As LengthUnitType
C#
public LengthUnitType Unit { get; set; }
C++
public property LengthUnitType Unit sealed {
LengthUnitType get();
void set(LengthUnitType value);
}
J#
/** property */
public LengthUnitType get_Unit();

/** property */
public void set_Unit(LengthUnitType value);
JScript
public function get Unit() : LengthUnitType

public function set Unit(value : LengthUnitType);

See Also

SymbolType Class


SymbolTypeLibrary Class

SymbolTypeLibrary Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SymbolTypeLibrary
C#
public class SymbolTypeLibrary
C++
ref class SymbolTypeLibrary
J#
public class SymbolTypeLibrary
JScript
public class SymbolTypeLibrary

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolTypeLibrary

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SymbolTypeLibrary Members


SymbolTypeLibrary Members

SymbolTypeLibrary Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SymbolTypeLibrary.

Public Constructors

 | Name | Description
Public method | SymbolTypeLibrary | Initializes a new instance of the SymbolTypeLibrary class.
Top

Public Properties

 | Name | Description
Public property | Name |
Public property | Resource |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SymbolTypeLibrary Class


SymbolTypeLibrary Constructor

SymbolTypeLibrary Constructor
[image]

Initializes a new instance of the SymbolTypeLibrary class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SymbolTypeLibrary()
C++
public:
SymbolTypeLibrary() sealed
J#
public SymbolTypeLibrary()
JScript
public function SymbolTypeLibrary()

See Also

SymbolTypeLibrary Class


Properties

SymbolTypeLibrary Properties
[image]

Public Properties

 | Name | Description
Public property | Name |
Public property | Resource |
Top

See Also

SymbolTypeLibrary Class


Name Property

SymbolTypeLibrary.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

SymbolTypeLibrary Class


Resource Property

SymbolTypeLibrary.Resource Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Resource As String
C#
public string Resource { get; set; }
C++
public property string Resource sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Resource();

/** property */
public void set_Resource(string value);
JScript
public function get Resource() : String

public function set Resource(value : String);

See Also

SymbolTypeLibrary Class


SymbolTypeLibraryCollection Class

SymbolTypeLibraryCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class SymbolTypeLibraryCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class SymbolTypeLibraryCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class SymbolTypeLibraryCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class SymbolTypeLibraryCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class SymbolTypeLibraryCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.SymbolTypeLibraryCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SymbolTypeLibraryCollection Members


SymbolTypeLibraryCollection Members

SymbolTypeLibraryCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SymbolTypeLibraryCollection.

Public Constructors

 | Name | Description
Public method | SymbolTypeLibraryCollection | Initializes a new instance of the SymbolTypeLibraryCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SymbolTypeLibraryCollection Class


SymbolTypeLibraryCollection Constructor

SymbolTypeLibraryCollection Constructor
[image]

Initializes a new instance of the SymbolTypeLibraryCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SymbolTypeLibraryCollection()
C++
public:
SymbolTypeLibraryCollection() sealed
J#
public SymbolTypeLibraryCollection()
JScript
public function SymbolTypeLibraryCollection()

See Also

SymbolTypeLibraryCollection Class


Properties

SymbolTypeLibraryCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

SymbolTypeLibraryCollection Class


Item Property

SymbolTypeLibraryCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As SymbolTypeLibrary
C#
public SymbolTypeLibrary this[
int idx
] { get; set; }
C++
public property SymbolTypeLibrary default[int idx] sealed {
SymbolTypeLibrary get(int idx);
void set(int idx, SymbolTypeLibrary value);
}
J#
/** property */
public SymbolTypeLibrary get_Item(int idx);

/** property */
public void set_Item(int idx, SymbolTypeLibrary value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

SymbolTypeLibraryCollection Class


Methods

SymbolTypeLibraryCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SymbolTypeLibraryCollection Class


Add Method

SymbolTypeLibraryCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As SymbolTypeLibrary _
) As Integer
C#
public int Add(
SymbolTypeLibrary value
)
C++
public:
int Add(
SymbolTypeLibrary value
) sealed
J#
public int Add(
SymbolTypeLibrary value
)
JScript
public function Add(
value : SymbolTypeLibrary
) : int

See Also

SymbolTypeLibraryCollection Class


TargetedCommandType Class

TargetedCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(GetPrintablePageCommandType)), _
XmlIncludeAttribute(GetType(ViewOptionsCommandType)), _
XmlIncludeAttribute(GetType(HelpCommandType)), _
XmlIncludeAttribute(GetType(MeasureCommandType)), _
XmlIncludeAttribute(GetType(SearchCommandType)), _
XmlIncludeAttribute(GetType(InvokeURLCommandType)), _
XmlIncludeAttribute(GetType(SelectWithinCommandType)), _
XmlIncludeAttribute(GetType(BufferCommandType))>
Public MustInherit Class TargetedCommandType
Inherits CustomCommandType
C#
[XmlIncludeAttribute(typeof(GetPrintablePageCommandType))]
[XmlIncludeAttribute(typeof(ViewOptionsCommandType))]
[XmlIncludeAttribute(typeof(HelpCommandType))]
[XmlIncludeAttribute(typeof(MeasureCommandType))]
[XmlIncludeAttribute(typeof(SearchCommandType))]
[XmlIncludeAttribute(typeof(InvokeURLCommandType))]
[XmlIncludeAttribute(typeof(SelectWithinCommandType))]
[XmlIncludeAttribute(typeof(BufferCommandType))]
public abstract class TargetedCommandType : CustomCommandType
C++
[XmlIncludeAttribute(typeof(GetPrintablePageCommandType))]
[XmlIncludeAttribute(typeof(ViewOptionsCommandType))]
[XmlIncludeAttribute(typeof(HelpCommandType))]
[XmlIncludeAttribute(typeof(MeasureCommandType))]
[XmlIncludeAttribute(typeof(SearchCommandType))]
[XmlIncludeAttribute(typeof(InvokeURLCommandType))]
[XmlIncludeAttribute(typeof(SelectWithinCommandType))]
[XmlIncludeAttribute(typeof(BufferCommandType))]
ref class TargetedCommandType abstract : CustomCommandType
J#
/** @attribute XmlIncludeAttribute(typeof(GetPrintablePageCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(ViewOptionsCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(HelpCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(MeasureCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(SearchCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(InvokeURLCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(SelectWithinCommandType)) */
/** @attribute XmlIncludeAttribute(typeof(BufferCommandType)) */
public class TargetedCommandType extends CustomCommandType
JScript
public
XmlIncludeAttribute(typeof(GetPrintablePageCommandType))
XmlIncludeAttribute(typeof(ViewOptionsCommandType))
XmlIncludeAttribute(typeof(HelpCommandType))
XmlIncludeAttribute(typeof(MeasureCommandType))
XmlIncludeAttribute(typeof(SearchCommandType))
XmlIncludeAttribute(typeof(InvokeURLCommandType))
XmlIncludeAttribute(typeof(SelectWithinCommandType))
XmlIncludeAttribute(typeof(BufferCommandType))
class TargetedCommandType extends CustomCommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.TargetedCommandType
Derived types

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TargetedCommandType Members


TargetedCommandType Class Hierarchy

TargetedCommandType Hierarchy

The following table lists the types derived from TargetedCommandType .

Derived Types

Type | Description
BufferCommandType |
GetPrintablePageCommandType |
HelpCommandType |
InvokeURLCommandType |
MeasureCommandType |
SearchCommandType |
SelectWithinCommandType |
ViewOptionsCommandType |

See Also

TargetedCommandType Class


TargetedCommandType Members

TargetedCommandType Members
See Also Example Properties Methods
[image]

The following tables list the members exposed by TargetedCommandType.

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | Target |
Public property | TargetFrame |
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TargetedCommandType Class


Properties

TargetedCommandType Properties
[image]

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | Target |
Public property | TargetFrame |
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

See Also

TargetedCommandType Class


Target Property

TargetedCommandType.Target Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Target As TargetType
C#
public TargetType Target { get; set; }
C++
public property TargetType Target sealed {
TargetType get();
void set(TargetType value);
}
J#
/** property */
public TargetType get_Target();

/** property */
public void set_Target(TargetType value);
JScript
public function get Target() : TargetType

public function set Target(value : TargetType);

See Also

TargetedCommandType Class


TargetFrame Property

TargetedCommandType.TargetFrame Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property TargetFrame As String
C#
public string TargetFrame { get; set; }
C++
public property string TargetFrame sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_TargetFrame();

/** property */
public void set_TargetFrame(string value);
JScript
public function get TargetFrame() : String

public function set TargetFrame(value : String);

See Also

TargetedCommandType Class


TargetType Enumeration

TargetType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum TargetType
C#
public enum TargetType
C++
public enum class TargetType
J#
public enum TargetType
JScript
public enum TargetType

Members

Member Name | Description
TaskPane |
NewWindow |
SpecifiedFrame |

See Also


TargetViewerType Enumeration

TargetViewerType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum TargetViewerType
C#
public enum TargetViewerType
C++
public enum class TargetViewerType
J#
public enum TargetViewerType
JScript
public enum TargetViewerType

Members

Member Name | Description
Dwf |
Ajax |
All |

See Also


TaskBarType Class

TaskBarType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskBarType
Inherits WebLayoutControlType
C#
public class TaskBarType : WebLayoutControlType
C++
ref class TaskBarType : WebLayoutControlType
J#
public class TaskBarType extends WebLayoutControlType
JScript
public class TaskBarType extends WebLayoutControlType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.WebLayoutControlType
OSGeo.MapGuide.MaestroAPI.TaskBarType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TaskBarType Members


TaskBarType Members

TaskBarType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by TaskBarType.

Public Constructors

 | Name | Description
Public method | TaskBarType | Initializes a new instance of the TaskBarType class.
Top

Public Properties

 | Name | Description
Public property | Back |
Public property | Forward |
Public property | Home |
Public property | MenuButton |
Public property | Tasks |
Public property | Visible | (inherited from WebLayoutControlType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TaskBarType Class


TaskBarType Constructor

TaskBarType Constructor
[image]

Initializes a new instance of the TaskBarType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TaskBarType()
C++
public:
TaskBarType() sealed
J#
public TaskBarType()
JScript
public function TaskBarType()

See Also

TaskBarType Class


Properties

TaskBarType Properties
[image]

Public Properties

 | Name | Description
Public property | Back |
Public property | Forward |
Public property | Home |
Public property | MenuButton |
Public property | Tasks |
Public property | Visible | (inherited from WebLayoutControlType)
Top

See Also

TaskBarType Class


Back Property

TaskBarType.Back Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Back As TaskButtonType
C#
public TaskButtonType Back { get; set; }
C++
public property TaskButtonType Back sealed {
TaskButtonType get();
void set(TaskButtonType value);
}
J#
/** property */
public TaskButtonType get_Back();

/** property */
public void set_Back(TaskButtonType value);
JScript
public function get Back() : TaskButtonType

public function set Back(value : TaskButtonType);

See Also

TaskBarType Class


Forward Property

TaskBarType.Forward Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Forward As TaskButtonType
C#
public TaskButtonType Forward { get; set; }
C++
public property TaskButtonType Forward sealed {
TaskButtonType get();
void set(TaskButtonType value);
}
J#
/** property */
public TaskButtonType get_Forward();

/** property */
public void set_Forward(TaskButtonType value);
JScript
public function get Forward() : TaskButtonType

public function set Forward(value : TaskButtonType);

See Also

TaskBarType Class


Home Property

TaskBarType.Home Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Home As TaskButtonType
C#
public TaskButtonType Home { get; set; }
C++
public property TaskButtonType Home sealed {
TaskButtonType get();
void set(TaskButtonType value);
}
J#
/** property */
public TaskButtonType get_Home();

/** property */
public void set_Home(TaskButtonType value);
JScript
public function get Home() : TaskButtonType

public function set Home(value : TaskButtonType);

See Also

TaskBarType Class


MenuButton Property

TaskBarType.MenuButton Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("MenuButton")>
Public Property MenuButton As UIItemTypeCollection
C#
[XmlElementAttribute("MenuButton")]
public UIItemTypeCollection MenuButton { get; set; }
C++
[XmlElementAttribute(L"MenuButton")]
public property UIItemTypeCollection MenuButton sealed {
UIItemTypeCollection get();
void set(UIItemTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("MenuButton") */
/** property */
public UIItemTypeCollection get_MenuButton();

/** property */
public void set_MenuButton(UIItemTypeCollection value);
JScript
public function get MenuButton() : UIItemTypeCollection

public function set MenuButton(value : UIItemTypeCollection);

See Also

TaskBarType Class


Tasks Property

TaskBarType.Tasks Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Tasks As TaskButtonType
C#
public TaskButtonType Tasks { get; set; }
C++
public property TaskButtonType Tasks sealed {
TaskButtonType get();
void set(TaskButtonType value);
}
J#
/** property */
public TaskButtonType get_Tasks();

/** property */
public void set_Tasks(TaskButtonType value);
JScript
public function get Tasks() : TaskButtonType

public function set Tasks(value : TaskButtonType);

See Also

TaskBarType Class


TaskButtonType Class

TaskButtonType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskButtonType
C#
public class TaskButtonType
C++
ref class TaskButtonType
J#
public class TaskButtonType
JScript
public class TaskButtonType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.TaskButtonType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TaskButtonType Members


TaskButtonType Members

TaskButtonType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by TaskButtonType.

Public Constructors

 | Name | Description
Public method | TaskButtonType | Initializes a new instance of the TaskButtonType class.
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | DisabledImageURL |
Public property | ImageURL |
Public property | Name |
Public property | Tooltip |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TaskButtonType Class


TaskButtonType Constructor

TaskButtonType Constructor
[image]

Initializes a new instance of the TaskButtonType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TaskButtonType()
C++
public:
TaskButtonType() sealed
J#
public TaskButtonType()
JScript
public function TaskButtonType()

See Also

TaskButtonType Class


Properties

TaskButtonType Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | DisabledImageURL |
Public property | ImageURL |
Public property | Name |
Public property | Tooltip |
Top

See Also

TaskButtonType Class


Description Property

TaskButtonType.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

TaskButtonType Class


DisabledImageURL Property

TaskButtonType.DisabledImageURL Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisabledImageURL As String
C#
public string DisabledImageURL { get; set; }
C++
public property string DisabledImageURL sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DisabledImageURL();

/** property */
public void set_DisabledImageURL(string value);
JScript
public function get DisabledImageURL() : String

public function set DisabledImageURL(value : String);

See Also

TaskButtonType Class


ImageURL Property

TaskButtonType.ImageURL Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageURL As String
C#
public string ImageURL { get; set; }
C++
public property string ImageURL sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ImageURL();

/** property */
public void set_ImageURL(string value);
JScript
public function get ImageURL() : String

public function set ImageURL(value : String);

See Also

TaskButtonType Class


Name Property

TaskButtonType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

TaskButtonType Class


Tooltip Property

TaskButtonType.Tooltip Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Tooltip As String
C#
public string Tooltip { get; set; }
C++
public property string Tooltip sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Tooltip();

/** property */
public void set_Tooltip(string value);
JScript
public function get Tooltip() : String

public function set Tooltip(value : String);

See Also

TaskButtonType Class


TaskPaneType Class

TaskPaneType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskPaneType
Inherits WebLayoutResizableControlType
C#
public class TaskPaneType : WebLayoutResizableControlType
C++
ref class TaskPaneType : WebLayoutResizableControlType
J#
public class TaskPaneType extends WebLayoutResizableControlType
JScript
public class TaskPaneType extends WebLayoutResizableControlType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.WebLayoutControlType
OSGeo.MapGuide.MaestroAPI.WebLayoutResizableControlType
OSGeo.MapGuide.MaestroAPI.TaskPaneType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TaskPaneType Members


TaskPaneType Members

TaskPaneType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by TaskPaneType.

Public Constructors

 | Name | Description
Public method | TaskPaneType | Initializes a new instance of the TaskPaneType class.
Top

Public Properties

 | Name | Description
Public property | InitialTask |
Public property | TaskBar |
Public property | Visible | (inherited from WebLayoutControlType)
Public property | Width | (inherited from WebLayoutResizableControlType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TaskPaneType Class


TaskPaneType Constructor

TaskPaneType Constructor
[image]

Initializes a new instance of the TaskPaneType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TaskPaneType()
C++
public:
TaskPaneType() sealed
J#
public TaskPaneType()
JScript
public function TaskPaneType()

See Also

TaskPaneType Class


Properties

TaskPaneType Properties
[image]

Public Properties

 | Name | Description
Public property | InitialTask |
Public property | TaskBar |
Public property | Visible | (inherited from WebLayoutControlType)
Public property | Width | (inherited from WebLayoutResizableControlType)
Top

See Also

TaskPaneType Class


InitialTask Property

TaskPaneType.InitialTask Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property InitialTask As String
C#
public string InitialTask { get; set; }
C++
public property string InitialTask sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_InitialTask();

/** property */
public void set_InitialTask(string value);
JScript
public function get InitialTask() : String

public function set InitialTask(value : String);

See Also

TaskPaneType Class


TaskBar Property

TaskPaneType.TaskBar Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property TaskBar As TaskBarType
C#
public TaskBarType TaskBar { get; set; }
C++
public property TaskBarType TaskBar sealed {
TaskBarType get();
void set(TaskBarType value);
}
J#
/** property */
public TaskBarType get_TaskBar();

/** property */
public void set_TaskBar(TaskBarType value);
JScript
public function get TaskBar() : TaskBarType

public function set TaskBar(value : TaskBarType);

See Also

TaskPaneType Class


Text Class

Text Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class Text
Inherits GraphicBase
C#
public class Text : GraphicBase
C++
ref class Text : GraphicBase
J#
public class Text extends GraphicBase
JScript
public class Text extends GraphicBase

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.GraphicBase
OSGeo.MapGuide.MaestroAPI.Text

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Text Members


Text Members

Text Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by Text.

Public Constructors

 | Name | Description
Public method | Text | Initializes a new instance of the Text class.
Top

Public Properties

 | Name | Description
Public property | Angle |
Public property | Bold |
Public property | Content |
Public property | ExtendedData1 |
Public property | FontName |
Public property | Frame |
Public property | GhostColor |
Public property | Height |
Public property | HeightScalable |
Public property | HorizontalAlignment |
Public property | Italic |
Public property | Justification |
Public property | LineSpacing |
Public property | Markup |
Public property | ObliqueAngle |
Public property | Overlined |
Public property | PositionX |
Public property | PositionY |
Public property | ResizeControl | (inherited from GraphicBase)
Public property | TextColor |
Public property | TrackSpacing |
Public property | Underlined |
Public property | VerticalAlignment |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

Text Class


Text Constructor

Text Constructor
[image]

Initializes a new instance of the Text class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Text()
C++
public:
Text() sealed
J#
public Text()
JScript
public function Text()

See Also

Text Class


Properties

Text Properties
[image]

Public Properties

 | Name | Description
Public property | Angle |
Public property | Bold |
Public property | Content |
Public property | ExtendedData1 |
Public property | FontName |
Public property | Frame |
Public property | GhostColor |
Public property | Height |
Public property | HeightScalable |
Public property | HorizontalAlignment |
Public property | Italic |
Public property | Justification |
Public property | LineSpacing |
Public property | Markup |
Public property | ObliqueAngle |
Public property | Overlined |
Public property | PositionX |
Public property | PositionY |
Public property | ResizeControl | (inherited from GraphicBase)
Public property | TextColor |
Public property | TrackSpacing |
Public property | Underlined |
Public property | VerticalAlignment |
Top

See Also

Text Class


Angle Property

Text.Angle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property Angle As String
C#
[DefaultValueAttribute("0.0")]
public string Angle { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string Angle sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_Angle();

/** property */
public void set_Angle(string value);
JScript
public function get Angle() : String

public function set Angle(value : String);

See Also

Text Class


Bold Property

Text.Bold Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("false")>
Public Property Bold As String
C#
[DefaultValueAttribute("false")]
public string Bold { get; set; }
C++
[DefaultValueAttribute(L"false")]
public property string Bold sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("false") */
/** property */
public string get_Bold();

/** property */
public void set_Bold(string value);
JScript
public function get Bold() : String

public function set Bold(value : String);

See Also

Text Class


Content Property

Text.Content Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Content As String
C#
public string Content { get; set; }
C++
public property string Content sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Content();

/** property */
public void set_Content(string value);
JScript
public function get Content() : String

public function set Content(value : String);

See Also

Text Class


ExtendedData1 Property

Text.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

Text Class


FontName Property

Text.FontName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'Arial'")>
Public Property FontName As String
C#
[DefaultValueAttribute("'Arial'")]
public string FontName { get; set; }
C++
[DefaultValueAttribute(L"'Arial'")]
public property string FontName sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'Arial'") */
/** property */
public string get_FontName();

/** property */
public void set_FontName(string value);
JScript
public function get FontName() : String

public function set FontName(value : String);

See Also

Text Class


Frame Property

Text.Frame Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Frame As TextFrame
C#
public TextFrame Frame { get; set; }
C++
public property TextFrame Frame sealed {
TextFrame get();
void set(TextFrame value);
}
J#
/** property */
public TextFrame get_Frame();

/** property */
public void set_Frame(TextFrame value);
JScript
public function get Frame() : TextFrame

public function set Frame(value : TextFrame);

See Also

Text Class


GhostColor Property

Text.GhostColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property GhostColor As String
C#
public string GhostColor { get; set; }
C++
public property string GhostColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_GhostColor();

/** property */
public void set_GhostColor(string value);
JScript
public function get GhostColor() : String

public function set GhostColor(value : String);

See Also

Text Class


Height Property

Text.Height Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("4.0")>
Public Property Height As String
C#
[DefaultValueAttribute("4.0")]
public string Height { get; set; }
C++
[DefaultValueAttribute(L"4.0")]
public property string Height sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("4.0") */
/** property */
public string get_Height();

/** property */
public void set_Height(string value);
JScript
public function get Height() : String

public function set Height(value : String);

See Also

Text Class


HeightScalable Property

Text.HeightScalable Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("true")>
Public Property HeightScalable As String
C#
[DefaultValueAttribute("true")]
public string HeightScalable { get; set; }
C++
[DefaultValueAttribute(L"true")]
public property string HeightScalable sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("true") */
/** property */
public string get_HeightScalable();

/** property */
public void set_HeightScalable(string value);
JScript
public function get HeightScalable() : String

public function set HeightScalable(value : String);

See Also

Text Class


HorizontalAlignment Property

Text.HorizontalAlignment Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'Center'")>
Public Property HorizontalAlignment As String
C#
[DefaultValueAttribute("'Center'")]
public string HorizontalAlignment { get; set; }
C++
[DefaultValueAttribute(L"'Center'")]
public property string HorizontalAlignment sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'Center'") */
/** property */
public string get_HorizontalAlignment();

/** property */
public void set_HorizontalAlignment(string value);
JScript
public function get HorizontalAlignment() : String

public function set HorizontalAlignment(value : String);

See Also

Text Class


Italic Property

Text.Italic Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("false")>
Public Property Italic As String
C#
[DefaultValueAttribute("false")]
public string Italic { get; set; }
C++
[DefaultValueAttribute(L"false")]
public property string Italic sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("false") */
/** property */
public string get_Italic();

/** property */
public void set_Italic(string value);
JScript
public function get Italic() : String

public function set Italic(value : String);

See Also

Text Class


Justification Property

Text.Justification Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'FromAlignment'")>
Public Property Justification As String
C#
[DefaultValueAttribute("'FromAlignment'")]
public string Justification { get; set; }
C++
[DefaultValueAttribute(L"'FromAlignment'")]
public property string Justification sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'FromAlignment'") */
/** property */
public string get_Justification();

/** property */
public void set_Justification(string value);
JScript
public function get Justification() : String

public function set Justification(value : String);

See Also

Text Class


LineSpacing Property

Text.LineSpacing Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("1.05")>
Public Property LineSpacing As String
C#
[DefaultValueAttribute("1.05")]
public string LineSpacing { get; set; }
C++
[DefaultValueAttribute(L"1.05")]
public property string LineSpacing sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("1.05") */
/** property */
public string get_LineSpacing();

/** property */
public void set_LineSpacing(string value);
JScript
public function get LineSpacing() : String

public function set LineSpacing(value : String);

See Also

Text Class


Markup Property

Text.Markup Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'Plain'")>
Public Property Markup As String
C#
[DefaultValueAttribute("'Plain'")]
public string Markup { get; set; }
C++
[DefaultValueAttribute(L"'Plain'")]
public property string Markup sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'Plain'") */
/** property */
public string get_Markup();

/** property */
public void set_Markup(string value);
JScript
public function get Markup() : String

public function set Markup(value : String);

See Also

Text Class


ObliqueAngle Property

Text.ObliqueAngle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property ObliqueAngle As String
C#
[DefaultValueAttribute("0.0")]
public string ObliqueAngle { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string ObliqueAngle sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_ObliqueAngle();

/** property */
public void set_ObliqueAngle(string value);
JScript
public function get ObliqueAngle() : String

public function set ObliqueAngle(value : String);

See Also

Text Class


Overlined Property

Text.Overlined Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("false")>
Public Property Overlined As String
C#
[DefaultValueAttribute("false")]
public string Overlined { get; set; }
C++
[DefaultValueAttribute(L"false")]
public property string Overlined sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("false") */
/** property */
public string get_Overlined();

/** property */
public void set_Overlined(string value);
JScript
public function get Overlined() : String

public function set Overlined(value : String);

See Also

Text Class


PositionX Property

Text.PositionX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property PositionX As String
C#
[DefaultValueAttribute("0.0")]
public string PositionX { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string PositionX sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_PositionX();

/** property */
public void set_PositionX(string value);
JScript
public function get PositionX() : String

public function set PositionX(value : String);

See Also

Text Class


PositionY Property

Text.PositionY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property PositionY As String
C#
[DefaultValueAttribute("0.0")]
public string PositionY { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string PositionY sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_PositionY();

/** property */
public void set_PositionY(string value);
JScript
public function get PositionY() : String

public function set PositionY(value : String);

See Also

Text Class


TextColor Property

Text.TextColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("ff000000")>
Public Property TextColor As String
C#
[DefaultValueAttribute("ff000000")]
public string TextColor { get; set; }
C++
[DefaultValueAttribute(L"ff000000")]
public property string TextColor sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("ff000000") */
/** property */
public string get_TextColor();

/** property */
public void set_TextColor(string value);
JScript
public function get TextColor() : String

public function set TextColor(value : String);

See Also

Text Class


TrackSpacing Property

Text.TrackSpacing Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("1.0")>
Public Property TrackSpacing As String
C#
[DefaultValueAttribute("1.0")]
public string TrackSpacing { get; set; }
C++
[DefaultValueAttribute(L"1.0")]
public property string TrackSpacing sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("1.0") */
/** property */
public string get_TrackSpacing();

/** property */
public void set_TrackSpacing(string value);
JScript
public function get TrackSpacing() : String

public function set TrackSpacing(value : String);

See Also

Text Class


Underlined Property

Text.Underlined Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("false")>
Public Property Underlined As String
C#
[DefaultValueAttribute("false")]
public string Underlined { get; set; }
C++
[DefaultValueAttribute(L"false")]
public property string Underlined sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("false") */
/** property */
public string get_Underlined();

/** property */
public void set_Underlined(string value);
JScript
public function get Underlined() : String

public function set Underlined(value : String);

See Also

Text Class


VerticalAlignment Property

Text.VerticalAlignment Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("'Halfline'")>
Public Property VerticalAlignment As String
C#
[DefaultValueAttribute("'Halfline'")]
public string VerticalAlignment { get; set; }
C++
[DefaultValueAttribute(L"'Halfline'")]
public property string VerticalAlignment sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("'Halfline'") */
/** property */
public string get_VerticalAlignment();

/** property */
public void set_VerticalAlignment(string value);
JScript
public function get VerticalAlignment() : String

public function set VerticalAlignment(value : String);

See Also

Text Class


TextFrame Class

TextFrame Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class TextFrame
C#
public class TextFrame
C++
ref class TextFrame
J#
public class TextFrame
JScript
public class TextFrame

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.TextFrame

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TextFrame Members


TextFrame Members

TextFrame Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by TextFrame.

Public Constructors

 | Name | Description
Public method | TextFrame | Initializes a new instance of the TextFrame class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | FillColor |
Public property | LineColor |
Public property | OffsetX |
Public property | OffsetY |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TextFrame Class


TextFrame Constructor

TextFrame Constructor
[image]

Initializes a new instance of the TextFrame class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TextFrame()
C++
public:
TextFrame() sealed
J#
public TextFrame()
JScript
public function TextFrame()

See Also

TextFrame Class


Properties

TextFrame Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | FillColor |
Public property | LineColor |
Public property | OffsetX |
Public property | OffsetY |
Top

See Also

TextFrame Class


ExtendedData1 Property

TextFrame.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

TextFrame Class


FillColor Property

TextFrame.FillColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FillColor As String
C#
public string FillColor { get; set; }
C++
public property string FillColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FillColor();

/** property */
public void set_FillColor(string value);
JScript
public function get FillColor() : String

public function set FillColor(value : String);

See Also

TextFrame Class


LineColor Property

TextFrame.LineColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LineColor As String
C#
public string LineColor { get; set; }
C++
public property string LineColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LineColor();

/** property */
public void set_LineColor(string value);
JScript
public function get LineColor() : String

public function set LineColor(value : String);

See Also

TextFrame Class


OffsetX Property

TextFrame.OffsetX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property OffsetX As String
C#
[DefaultValueAttribute("0.0")]
public string OffsetX { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string OffsetX sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_OffsetX();

/** property */
public void set_OffsetX(string value);
JScript
public function get OffsetX() : String

public function set OffsetX(value : String);

See Also

TextFrame Class


OffsetY Property

TextFrame.OffsetY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute("0.0")>
Public Property OffsetY As String
C#
[DefaultValueAttribute("0.0")]
public string OffsetY { get; set; }
C++
[DefaultValueAttribute(L"0.0")]
public property string OffsetY sealed {
String get();
void set(String value);
}
J#
/** @attribute DefaultValueAttribute("0.0") */
/** property */
public string get_OffsetY();

/** property */
public void set_OffsetY(string value);
JScript
public function get OffsetY() : String

public function set OffsetY(value : String);

See Also

TextFrame Class


TextSymbolType Class

TextSymbolType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class TextSymbolType
Inherits SymbolType
C#
public class TextSymbolType : SymbolType
C++
ref class TextSymbolType : SymbolType
J#
public class TextSymbolType extends SymbolType
JScript
public class TextSymbolType extends SymbolType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolType
OSGeo.MapGuide.MaestroAPI.TextSymbolType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TextSymbolType Members


TextSymbolType Members

TextSymbolType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by TextSymbolType.

Public Constructors

 | Name | Description
Public method | TextSymbolType | Initializes a new instance of the TextSymbolType class.
Top

Public Properties

 | Name | Description
Public property | AdvancedPlacement |
Public property | BackgroundColor |
Public property | BackgroundColorAsHTML |
Public property | BackgroundStyle |
Public property | Bold |
Public property | ExtendedData1 |
Public property | FontName |
Public property | ForegroundColor |
Public property | ForegroundColorAsHTML |
Public property | HorizontalAlignment |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | Italic |
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | Text |
Public property | Underlined |
Public property | Unit | (inherited from SymbolType)
Public property | VerticalAlignment |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TextSymbolType Class


TextSymbolType Constructor

TextSymbolType Constructor
[image]

Initializes a new instance of the TextSymbolType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TextSymbolType()
C++
public:
TextSymbolType() sealed
J#
public TextSymbolType()
JScript
public function TextSymbolType()

See Also

TextSymbolType Class


Properties

TextSymbolType Properties
[image]

Public Properties

 | Name | Description
Public property | AdvancedPlacement |
Public property | BackgroundColor |
Public property | BackgroundColorAsHTML |
Public property | BackgroundStyle |
Public property | Bold |
Public property | ExtendedData1 |
Public property | FontName |
Public property | ForegroundColor |
Public property | ForegroundColorAsHTML |
Public property | HorizontalAlignment |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | Italic |
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | Text |
Public property | Underlined |
Public property | Unit | (inherited from SymbolType)
Public property | VerticalAlignment |
Top

See Also

TextSymbolType Class


AdvancedPlacement Property

TextSymbolType.AdvancedPlacement Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property AdvancedPlacement As TextSymbolTypeAdvancedPlacement
C#
public TextSymbolTypeAdvancedPlacement AdvancedPlacement { get; set; }
C++
public property TextSymbolTypeAdvancedPlacement AdvancedPlacement sealed {
TextSymbolTypeAdvancedPlacement get();
void set(TextSymbolTypeAdvancedPlacement value);
}
J#
/** property */
public TextSymbolTypeAdvancedPlacement get_AdvancedPlacement();

/** property */
public void set_AdvancedPlacement(TextSymbolTypeAdvancedPlacement value);
JScript
public function get AdvancedPlacement() : TextSymbolTypeAdvancedPlacement

public function set AdvancedPlacement(value : TextSymbolTypeAdvancedPlacement);

See Also

TextSymbolType Class


BackgroundColor Property

TextSymbolType.BackgroundColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property BackgroundColor As Color
C#
[XmlIgnoreAttribute]
public Color BackgroundColor { get; set; }
C++
[XmlIgnoreAttribute]
public property Color BackgroundColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public Color get_BackgroundColor();

/** property */
public void set_BackgroundColor(Color value);
JScript
public function get BackgroundColor() : Color

public function set BackgroundColor(value : Color);

See Also

TextSymbolType Class


BackgroundColorAsHTML Property

TextSymbolType.BackgroundColorAsHTML Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("BackgroundColor")>
Public Property BackgroundColorAsHTML As String
C#
[XmlElementAttribute("BackgroundColor")]
public string BackgroundColorAsHTML { get; set; }
C++
[XmlElementAttribute(L"BackgroundColor")]
public property string BackgroundColorAsHTML sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute("BackgroundColor") */
/** property */
public string get_BackgroundColorAsHTML();

/** property */
public void set_BackgroundColorAsHTML(string value);
JScript
public function get BackgroundColorAsHTML() : String

public function set BackgroundColorAsHTML(value : String);

See Also

TextSymbolType Class


BackgroundStyle Property

TextSymbolType.BackgroundStyle Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property BackgroundStyle As BackgroundStyleType
C#
public BackgroundStyleType BackgroundStyle { get; set; }
C++
public property BackgroundStyleType BackgroundStyle sealed {
BackgroundStyleType get();
void set(BackgroundStyleType value);
}
J#
/** property */
public BackgroundStyleType get_BackgroundStyle();

/** property */
public void set_BackgroundStyle(BackgroundStyleType value);
JScript
public function get BackgroundStyle() : BackgroundStyleType

public function set BackgroundStyle(value : BackgroundStyleType);

See Also

TextSymbolType Class


Bold Property

TextSymbolType.Bold Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Bold As String
C#
public string Bold { get; set; }
C++
public property string Bold sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Bold();

/** property */
public void set_Bold(string value);
JScript
public function get Bold() : String

public function set Bold(value : String);

See Also

TextSymbolType Class


ExtendedData1 Property

TextSymbolType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

TextSymbolType Class


FontName Property

TextSymbolType.FontName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FontName As String
C#
public string FontName { get; set; }
C++
public property string FontName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FontName();

/** property */
public void set_FontName(string value);
JScript
public function get FontName() : String

public function set FontName(value : String);

See Also

TextSymbolType Class


ForegroundColor Property

TextSymbolType.ForegroundColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ForegroundColor As Color
C#
[XmlIgnoreAttribute]
public Color ForegroundColor { get; set; }
C++
[XmlIgnoreAttribute]
public property Color ForegroundColor sealed {
Color get();
void set(Color value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public Color get_ForegroundColor();

/** property */
public void set_ForegroundColor(Color value);
JScript
public function get ForegroundColor() : Color

public function set ForegroundColor(value : Color);

See Also

TextSymbolType Class


ForegroundColorAsHTML Property

TextSymbolType.ForegroundColorAsHTML Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("ForegroundColor")>
Public Property ForegroundColorAsHTML As String
C#
[XmlElementAttribute("ForegroundColor")]
public string ForegroundColorAsHTML { get; set; }
C++
[XmlElementAttribute(L"ForegroundColor")]
public property string ForegroundColorAsHTML sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute("ForegroundColor") */
/** property */
public string get_ForegroundColorAsHTML();

/** property */
public void set_ForegroundColorAsHTML(string value);
JScript
public function get ForegroundColorAsHTML() : String

public function set ForegroundColorAsHTML(value : String);

See Also

TextSymbolType Class


HorizontalAlignment Property

TextSymbolType.HorizontalAlignment Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property HorizontalAlignment As String
C#
public string HorizontalAlignment { get; set; }
C++
public property string HorizontalAlignment sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_HorizontalAlignment();

/** property */
public void set_HorizontalAlignment(string value);
JScript
public function get HorizontalAlignment() : String

public function set HorizontalAlignment(value : String);

See Also

TextSymbolType Class


Italic Property

TextSymbolType.Italic Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Italic As String
C#
public string Italic { get; set; }
C++
public property string Italic sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Italic();

/** property */
public void set_Italic(string value);
JScript
public function get Italic() : String

public function set Italic(value : String);

See Also

TextSymbolType Class


Text Property

TextSymbolType.Text Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As String
C#
public string Text { get; set; }
C++
public property string Text sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Text();

/** property */
public void set_Text(string value);
JScript
public function get Text() : String

public function set Text(value : String);

See Also

TextSymbolType Class


Underlined Property

TextSymbolType.Underlined Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Underlined As String
C#
public string Underlined { get; set; }
C++
public property string Underlined sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Underlined();

/** property */
public void set_Underlined(string value);
JScript
public function get Underlined() : String

public function set Underlined(value : String);

See Also

TextSymbolType Class


VerticalAlignment Property

TextSymbolType.VerticalAlignment Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property VerticalAlignment As String
C#
public string VerticalAlignment { get; set; }
C++
public property string VerticalAlignment sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_VerticalAlignment();

/** property */
public void set_VerticalAlignment(string value);
JScript
public function get VerticalAlignment() : String

public function set VerticalAlignment(value : String);

See Also

TextSymbolType Class


TextSymbolTypeAdvancedPlacement Class

TextSymbolTypeAdvancedPlacement Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class TextSymbolTypeAdvancedPlacement
C#
public class TextSymbolTypeAdvancedPlacement
C++
ref class TextSymbolTypeAdvancedPlacement
J#
public class TextSymbolTypeAdvancedPlacement
JScript
public class TextSymbolTypeAdvancedPlacement

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.TextSymbolTypeAdvancedPlacement

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TextSymbolTypeAdvancedPlacement Members


TextSymbolTypeAdvancedPlacement Members

TextSymbolTypeAdvancedPlacement Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by TextSymbolTypeAdvancedPlacement.

Public Constructors

 | Name | Description
Public method | TextSymbolTypeAdvancedPlacement | Initializes a new instance of the TextSymbolTypeAdvancedPlacement class.
Top

Public Properties

 | Name | Description
Public property | ScaleLimit |
Public property | ScaleLimitSpecified |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TextSymbolTypeAdvancedPlacement Class


TextSymbolTypeAdvancedPlacement Constructor

TextSymbolTypeAdvancedPlacement Constructor
[image]

Initializes a new instance of the TextSymbolTypeAdvancedPlacement class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public TextSymbolTypeAdvancedPlacement()
C++
public:
TextSymbolTypeAdvancedPlacement() sealed
J#
public TextSymbolTypeAdvancedPlacement()
JScript
public function TextSymbolTypeAdvancedPlacement()

See Also

TextSymbolTypeAdvancedPlacement Class


Properties

TextSymbolTypeAdvancedPlacement Properties
[image]

Public Properties

 | Name | Description
Public property | ScaleLimit |
Public property | ScaleLimitSpecified |
Top

See Also

TextSymbolTypeAdvancedPlacement Class


ScaleLimit Property

TextSymbolTypeAdvancedPlacement.ScaleLimit Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ScaleLimit As Double
C#
public double ScaleLimit { get; set; }
C++
public property double ScaleLimit sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_ScaleLimit();

/** property */
public void set_ScaleLimit(double value);
JScript
public function get ScaleLimit() : double

public function set ScaleLimit(value : double);

See Also

TextSymbolTypeAdvancedPlacement Class


ScaleLimitSpecified Property

TextSymbolTypeAdvancedPlacement.ScaleLimitSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ScaleLimitSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool ScaleLimitSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool ScaleLimitSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_ScaleLimitSpecified();

/** property */
public void set_ScaleLimitSpecified(bool value);
JScript
public function get ScaleLimitSpecified() : bool

public function set ScaleLimitSpecified(value : bool);

See Also

TextSymbolTypeAdvancedPlacement Class


ThemeLabel Class

ThemeLabel Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ThemeLabel
C#
public class ThemeLabel
C++
ref class ThemeLabel
J#
public class ThemeLabel
JScript
public class ThemeLabel

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ThemeLabel

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ThemeLabel Members


ThemeLabel Members

ThemeLabel Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ThemeLabel.

Public Constructors

 | Name | Description
Public method | ThemeLabel | Initializes a new instance of the ThemeLabel class.
Top

Public Properties

 | Name | Description
Public property | CategoryFormat |
Public property | Description |
Public property | ExtendedData1 |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ThemeLabel Class


ThemeLabel Constructor

ThemeLabel Constructor
[image]

Initializes a new instance of the ThemeLabel class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ThemeLabel()
C++
public:
ThemeLabel() sealed
J#
public ThemeLabel()
JScript
public function ThemeLabel()

See Also

ThemeLabel Class


Properties

ThemeLabel Properties
[image]

Public Properties

 | Name | Description
Public property | CategoryFormat |
Public property | Description |
Public property | ExtendedData1 |
Top

See Also

ThemeLabel Class


CategoryFormat Property

ThemeLabel.CategoryFormat Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CategoryFormat As String
C#
public string CategoryFormat { get; set; }
C++
public property string CategoryFormat sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_CategoryFormat();

/** property */
public void set_CategoryFormat(string value);
JScript
public function get CategoryFormat() : String

public function set CategoryFormat(value : String);

See Also

ThemeLabel Class


Description Property

ThemeLabel.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

ThemeLabel Class


ExtendedData1 Property

ThemeLabel.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

ThemeLabel Class


ToolBarType Class

ToolBarType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ToolBarType
Inherits WebLayoutControlType
C#
public class ToolBarType : WebLayoutControlType
C++
ref class ToolBarType : WebLayoutControlType
J#
public class ToolBarType extends WebLayoutControlType
JScript
public class ToolBarType extends WebLayoutControlType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.WebLayoutControlType
OSGeo.MapGuide.MaestroAPI.ToolBarType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ToolBarType Members


ToolBarType Members

ToolBarType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ToolBarType.

Public Constructors

 | Name | Description
Public method | ToolBarType | Initializes a new instance of the ToolBarType class.
Top

Public Properties

 | Name | Description
Public property | Button |
Public property | Visible | (inherited from WebLayoutControlType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ToolBarType Class


ToolBarType Constructor

ToolBarType Constructor
[image]

Initializes a new instance of the ToolBarType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ToolBarType()
C++
public:
ToolBarType() sealed
J#
public ToolBarType()
JScript
public function ToolBarType()

See Also

ToolBarType Class


Properties

ToolBarType Properties
[image]

Public Properties

 | Name | Description
Public property | Button |
Public property | Visible | (inherited from WebLayoutControlType)
Top

See Also

ToolBarType Class


Button Property

ToolBarType.Button Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Button")>
Public Property Button As UIItemTypeCollection
C#
[XmlElementAttribute("Button")]
public UIItemTypeCollection Button { get; set; }
C++
[XmlElementAttribute(L"Button")]
public property UIItemTypeCollection Button sealed {
UIItemTypeCollection get();
void set(UIItemTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("Button") */
/** property */
public UIItemTypeCollection get_Button();

/** property */
public void set_Button(UIItemTypeCollection value);
JScript
public function get Button() : UIItemTypeCollection

public function set Button(value : UIItemTypeCollection);

See Also

ToolBarType Class


UIItemFunctionType Enumeration

UIItemFunctionType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UIItemFunctionType
C#
public enum UIItemFunctionType
C++
public enum class UIItemFunctionType
J#
public enum UIItemFunctionType
JScript
public enum UIItemFunctionType

Members

Member Name | Description
Separator |
Command |
Flyout |

See Also


UIItemType Class

UIItemType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(FlyoutItemType)), _
XmlIncludeAttribute(GetType(SeparatorItemType)), _
XmlIncludeAttribute(GetType(CommandItemType))>
Public Class UIItemType
C#
[XmlIncludeAttribute(typeof(FlyoutItemType))]
[XmlIncludeAttribute(typeof(SeparatorItemType))]
[XmlIncludeAttribute(typeof(CommandItemType))]
public class UIItemType
C++
[XmlIncludeAttribute(typeof(FlyoutItemType))]
[XmlIncludeAttribute(typeof(SeparatorItemType))]
[XmlIncludeAttribute(typeof(CommandItemType))]
ref class UIItemType
J#
/** @attribute XmlIncludeAttribute(typeof(FlyoutItemType)) */
/** @attribute XmlIncludeAttribute(typeof(SeparatorItemType)) */
/** @attribute XmlIncludeAttribute(typeof(CommandItemType)) */
public class UIItemType
JScript
public
XmlIncludeAttribute(typeof(FlyoutItemType))
XmlIncludeAttribute(typeof(SeparatorItemType))
XmlIncludeAttribute(typeof(CommandItemType))
class UIItemType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.UIItemType
OSGeo.MapGuide.MaestroAPI.CommandItemType
OSGeo.MapGuide.MaestroAPI.FlyoutItemType
OSGeo.MapGuide.MaestroAPI.SeparatorItemType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UIItemType Members


UIItemType Members

UIItemType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UIItemType.

Public Constructors

 | Name | Description
Public method | UIItemType | Initializes a new instance of the UIItemType class.
Top

Public Properties

 | Name | Description
Public property | Function |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UIItemType Class


UIItemType Constructor

UIItemType Constructor
[image]

Initializes a new instance of the UIItemType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UIItemType()
C++
public:
UIItemType() sealed
J#
public UIItemType()
JScript
public function UIItemType()

See Also

UIItemType Class


Properties

UIItemType Properties
[image]

Public Properties

 | Name | Description
Public property | Function |
Top

See Also

UIItemType Class


Function Property

UIItemType.Function Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Function As UIItemFunctionType
C#
public UIItemFunctionType Function { get; set; }
C++
public property UIItemFunctionType Function sealed {
UIItemFunctionType get();
void set(UIItemFunctionType value);
}
J#
/** property */
public UIItemFunctionType get_Function();

/** property */
public void set_Function(UIItemFunctionType value);
JScript
public function get Function() : UIItemFunctionType

public function set Function(value : UIItemFunctionType);

See Also

UIItemType Class


UIItemTypeCollection Class

UIItemTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class UIItemTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class UIItemTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class UIItemTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class UIItemTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class UIItemTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.UIItemTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UIItemTypeCollection Members


UIItemTypeCollection Members

UIItemTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UIItemTypeCollection.

Public Constructors

 | Name | Description
Public method | UIItemTypeCollection | Initializes a new instance of the UIItemTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | Insert |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UIItemTypeCollection Class


UIItemTypeCollection Constructor

UIItemTypeCollection Constructor
[image]

Initializes a new instance of the UIItemTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UIItemTypeCollection()
C++
public:
UIItemTypeCollection() sealed
J#
public UIItemTypeCollection()
JScript
public function UIItemTypeCollection()

See Also

UIItemTypeCollection Class


Properties

UIItemTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

UIItemTypeCollection Class


Item Property

UIItemTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As UIItemType
C#
public UIItemType this[
int idx
] { get; set; }
C++
public property UIItemType default[int idx] sealed {
UIItemType get(int idx);
void set(int idx, UIItemType value);
}
J#
/** property */
public UIItemType get_Item(int idx);

/** property */
public void set_Item(int idx, UIItemType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

UIItemTypeCollection Class


Methods

UIItemTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | Insert |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UIItemTypeCollection Class


Add Method

UIItemTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As UIItemType _
) As Integer
C#
public int Add(
UIItemType value
)
C++
public:
int Add(
UIItemType value
) sealed
J#
public int Add(
UIItemType value
)
JScript
public function Add(
value : UIItemType
) : int

See Also

UIItemTypeCollection Class


IndexOf Method

UIItemTypeCollection.IndexOf Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
ByVal value As UIItemType _
) As Integer
C#
public int IndexOf(
UIItemType value
)
C++
public:
int IndexOf(
UIItemType value
) sealed
J#
public int IndexOf(
UIItemType value
)
JScript
public function IndexOf(
value : UIItemType
) : int

See Also

UIItemTypeCollection Class


Insert Method

UIItemTypeCollection.Insert Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As UIItemType _
)
C#
public void Insert(
int index,
UIItemType value
)
C++
public:
void Insert(
int index,
UIItemType value
) sealed
J#
public void Insert(
int index,
UIItemType value
)
JScript
public function Insert(
index : int,
value : UIItemType
)

See Also

UIItemTypeCollection Class


UnmanagedDataList Class

UnmanagedDataList Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class UnmanagedDataList
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class UnmanagedDataList
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class UnmanagedDataList
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class UnmanagedDataList
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class UnmanagedDataList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.UnmanagedDataList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UnmanagedDataList Members


UnmanagedDataList Members

UnmanagedDataList Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UnmanagedDataList.

Public Constructors

 | Name | Description
Public method | UnmanagedDataList | Initializes a new instance of the UnmanagedDataList class.
Top

Public Properties

 | Name | Description
Public property | Items |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UnmanagedDataList Class


UnmanagedDataList Constructor

UnmanagedDataList Constructor
[image]

Initializes a new instance of the UnmanagedDataList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UnmanagedDataList()
C++
public:
UnmanagedDataList() sealed
J#
public UnmanagedDataList()
JScript
public function UnmanagedDataList()

See Also

UnmanagedDataList Class


Properties

UnmanagedDataList Properties
[image]

Public Properties

 | Name | Description
Public property | Items |
Top

See Also

UnmanagedDataList Class


Items Property

UnmanagedDataList.Items Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("UnmanagedDataFile", GetType(UnmanagedDataListUnmanagedDataFile)), _
XmlElementAttribute("UnmanagedDataFolder", GetType(UnmanagedDataListUnmanagedDataFolder))>
Public Property Items As ArrayList
C#
[XmlElementAttribute("UnmanagedDataFile", typeof(UnmanagedDataListUnmanagedDataFile))]
[XmlElementAttribute("UnmanagedDataFolder", typeof(UnmanagedDataListUnmanagedDataFolder))]
public ArrayList Items { get; set; }
C++
[XmlElementAttribute(L"UnmanagedDataFile", typeof(UnmanagedDataListUnmanagedDataFile))]
[XmlElementAttribute(L"UnmanagedDataFolder", typeof(UnmanagedDataListUnmanagedDataFolder))]
public property ArrayList Items sealed {
ArrayList get();
void set(ArrayList value);
}
J#
/** @attribute XmlElementAttribute("UnmanagedDataFile", typeof(UnmanagedDataListUnmanagedDataFile)) */
/** @attribute XmlElementAttribute("UnmanagedDataFolder", typeof(UnmanagedDataListUnmanagedDataFolder)) */
/** property */
public ArrayList get_Items();

/** property */
public void set_Items(ArrayList value);
JScript
public function get Items() : ArrayList

public function set Items(value : ArrayList);

See Also

UnmanagedDataList Class


UnmanagedDataListUnmanagedDataFile Class

UnmanagedDataListUnmanagedDataFile Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UnmanagedDataListUnmanagedDataFile
C#
public class UnmanagedDataListUnmanagedDataFile
C++
ref class UnmanagedDataListUnmanagedDataFile
J#
public class UnmanagedDataListUnmanagedDataFile
JScript
public class UnmanagedDataListUnmanagedDataFile

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.UnmanagedDataListUnmanagedDataFile

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UnmanagedDataListUnmanagedDataFile Members


UnmanagedDataListUnmanagedDataFile Members

UnmanagedDataListUnmanagedDataFile Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UnmanagedDataListUnmanagedDataFile.

Public Constructors

 | Name | Description
Public method | UnmanagedDataListUnmanagedDataFile | Initializes a new instance of the UnmanagedDataListUnmanagedDataFile class.
Top

Public Properties

 | Name | Description
Public property | CreatedDate |
Public property | ModifiedDate |
Public property | Size |
Public property | UnmanagedDataId |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UnmanagedDataListUnmanagedDataFile Class


UnmanagedDataListUnmanagedDataFile Constructor

UnmanagedDataListUnmanagedDataFile Constructor
[image]

Initializes a new instance of the UnmanagedDataListUnmanagedDataFile class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UnmanagedDataListUnmanagedDataFile()
C++
public:
UnmanagedDataListUnmanagedDataFile() sealed
J#
public UnmanagedDataListUnmanagedDataFile()
JScript
public function UnmanagedDataListUnmanagedDataFile()

See Also

UnmanagedDataListUnmanagedDataFile Class


Properties

UnmanagedDataListUnmanagedDataFile Properties
[image]

Public Properties

 | Name | Description
Public property | CreatedDate |
Public property | ModifiedDate |
Public property | Size |
Public property | UnmanagedDataId |
Top

See Also

UnmanagedDataListUnmanagedDataFile Class


CreatedDate Property

UnmanagedDataListUnmanagedDataFile.CreatedDate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CreatedDate As Date
C#
public DateTime CreatedDate { get; set; }
C++
public property DateTime CreatedDate sealed {
DateTime get();
void set(DateTime value);
}
J#
/** property */
public DateTime get_CreatedDate();

/** property */
public void set_CreatedDate(DateTime value);
JScript
public function get CreatedDate() : DateTime

public function set CreatedDate(value : DateTime);

See Also

UnmanagedDataListUnmanagedDataFile Class


ModifiedDate Property

UnmanagedDataListUnmanagedDataFile.ModifiedDate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ModifiedDate As Date
C#
public DateTime ModifiedDate { get; set; }
C++
public property DateTime ModifiedDate sealed {
DateTime get();
void set(DateTime value);
}
J#
/** property */
public DateTime get_ModifiedDate();

/** property */
public void set_ModifiedDate(DateTime value);
JScript
public function get ModifiedDate() : DateTime

public function set ModifiedDate(value : DateTime);

See Also

UnmanagedDataListUnmanagedDataFile Class


Size Property

UnmanagedDataListUnmanagedDataFile.Size Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property Size As String
C#
[XmlElementAttribute(DataType = "integer")]
public string Size { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string Size sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_Size();

/** property */
public void set_Size(string value);
JScript
public function get Size() : String

public function set Size(value : String);

See Also

UnmanagedDataListUnmanagedDataFile Class


UnmanagedDataId Property

UnmanagedDataListUnmanagedDataFile.UnmanagedDataId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property UnmanagedDataId As String
C#
public string UnmanagedDataId { get; set; }
C++
public property string UnmanagedDataId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_UnmanagedDataId();

/** property */
public void set_UnmanagedDataId(string value);
JScript
public function get UnmanagedDataId() : String

public function set UnmanagedDataId(value : String);

See Also

UnmanagedDataListUnmanagedDataFile Class


UnmanagedDataListUnmanagedDataFolder Class

UnmanagedDataListUnmanagedDataFolder Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UnmanagedDataListUnmanagedDataFolder
C#
public class UnmanagedDataListUnmanagedDataFolder
C++
ref class UnmanagedDataListUnmanagedDataFolder
J#
public class UnmanagedDataListUnmanagedDataFolder
JScript
public class UnmanagedDataListUnmanagedDataFolder

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.UnmanagedDataListUnmanagedDataFolder

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UnmanagedDataListUnmanagedDataFolder Members


UnmanagedDataListUnmanagedDataFolder Members

UnmanagedDataListUnmanagedDataFolder Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UnmanagedDataListUnmanagedDataFolder.

Public Constructors

 | Name | Description
Public method | UnmanagedDataListUnmanagedDataFolder | Initializes a new instance of the UnmanagedDataListUnmanagedDataFolder class.
Top

Public Properties

 | Name | Description
Public property | CreatedDate |
Public property | ModifiedDate |
Public property | NumberOfFiles |
Public property | NumberOfFolders |
Public property | UnmanagedDataId |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UnmanagedDataListUnmanagedDataFolder Class


UnmanagedDataListUnmanagedDataFolder Constructor

UnmanagedDataListUnmanagedDataFolder Constructor
[image]

Initializes a new instance of the UnmanagedDataListUnmanagedDataFolder class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UnmanagedDataListUnmanagedDataFolder()
C++
public:
UnmanagedDataListUnmanagedDataFolder() sealed
J#
public UnmanagedDataListUnmanagedDataFolder()
JScript
public function UnmanagedDataListUnmanagedDataFolder()

See Also

UnmanagedDataListUnmanagedDataFolder Class


Properties

UnmanagedDataListUnmanagedDataFolder Properties
[image]

Public Properties

 | Name | Description
Public property | CreatedDate |
Public property | ModifiedDate |
Public property | NumberOfFiles |
Public property | NumberOfFolders |
Public property | UnmanagedDataId |
Top

See Also

UnmanagedDataListUnmanagedDataFolder Class


CreatedDate Property

UnmanagedDataListUnmanagedDataFolder.CreatedDate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CreatedDate As Date
C#
public DateTime CreatedDate { get; set; }
C++
public property DateTime CreatedDate sealed {
DateTime get();
void set(DateTime value);
}
J#
/** property */
public DateTime get_CreatedDate();

/** property */
public void set_CreatedDate(DateTime value);
JScript
public function get CreatedDate() : DateTime

public function set CreatedDate(value : DateTime);

See Also

UnmanagedDataListUnmanagedDataFolder Class


ModifiedDate Property

UnmanagedDataListUnmanagedDataFolder.ModifiedDate Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ModifiedDate As Date
C#
public DateTime ModifiedDate { get; set; }
C++
public property DateTime ModifiedDate sealed {
DateTime get();
void set(DateTime value);
}
J#
/** property */
public DateTime get_ModifiedDate();

/** property */
public void set_ModifiedDate(DateTime value);
JScript
public function get ModifiedDate() : DateTime

public function set ModifiedDate(value : DateTime);

See Also

UnmanagedDataListUnmanagedDataFolder Class


NumberOfFiles Property

UnmanagedDataListUnmanagedDataFolder.NumberOfFiles Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property NumberOfFiles As String
C#
[XmlElementAttribute(DataType = "integer")]
public string NumberOfFiles { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string NumberOfFiles sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_NumberOfFiles();

/** property */
public void set_NumberOfFiles(string value);
JScript
public function get NumberOfFiles() : String

public function set NumberOfFiles(value : String);

See Also

UnmanagedDataListUnmanagedDataFolder Class


NumberOfFolders Property

UnmanagedDataListUnmanagedDataFolder.NumberOfFolders Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute(DataType := "integer")>
Public Property NumberOfFolders As String
C#
[XmlElementAttribute(DataType = "integer")]
public string NumberOfFolders { get; set; }
C++
[XmlElementAttribute(DataType = L"integer")]
public property string NumberOfFolders sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlElementAttribute(DataType = "integer") */
/** property */
public string get_NumberOfFolders();

/** property */
public void set_NumberOfFolders(string value);
JScript
public function get NumberOfFolders() : String

public function set NumberOfFolders(value : String);

See Also

UnmanagedDataListUnmanagedDataFolder Class


UnmanagedDataId Property

UnmanagedDataListUnmanagedDataFolder.UnmanagedDataId Property
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property UnmanagedDataId As String
C#
public string UnmanagedDataId { get; set; }
C++
public property string UnmanagedDataId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_UnmanagedDataId();

/** property */
public void set_UnmanagedDataId(string value);
JScript
public function get UnmanagedDataId() : String

public function set UnmanagedDataId(value : String);

See Also

UnmanagedDataListUnmanagedDataFolder Class


UnmanagedDataTypes Enumeration

UnmanagedDataTypes Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UnmanagedDataTypes
C#
public enum UnmanagedDataTypes
C++
public enum class UnmanagedDataTypes
J#
public enum UnmanagedDataTypes
JScript
public enum UnmanagedDataTypes

Members

Member Name | Description
Files |
Folders |
Both |

See Also


UsageContextType Enumeration

UsageContextType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UsageContextType
C#
public enum UsageContextType
C++
public enum class UsageContextType
J#
public enum UsageContextType
JScript
public enum UsageContextType

Members

Member Name | Description
Unspecified |
Point |
Line |
Area |

See Also


User Class

User Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class User
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class User
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class User
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class User
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class User

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.User

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

User Members


User Members

User Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by User.

Public Constructors

 | Name | Description
Public method | User | Initializes a new instance of the User class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | FullName |
Public property | Password |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

User Class


User Constructor

User Constructor
[image]

Initializes a new instance of the User class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public User()
C++
public:
User() sealed
J#
public User()
JScript
public function User()

See Also

User Class


Fields

User Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

User Class


SchemaName Field

User.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

User Class


Properties

User Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | FullName |
Public property | Password |
Public property | XsdSchema |
Top

See Also

User Class


Description Property

User.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

User Class


FullName Property

User.FullName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FullName As String
C#
public string FullName { get; set; }
C++
public property string FullName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FullName();

/** property */
public void set_FullName(string value);
JScript
public function get FullName() : String

public function set FullName(value : String);

See Also

User Class


Password Property

User.Password Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
C++
public property string Password sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Password();

/** property */
public void set_Password(string value);
JScript
public function get Password() : String

public function set Password(value : String);

See Also

User Class


XsdSchema Property

User.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

User Class


UserList Class

UserList Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute(Namespace := "", IsNullable := False)>
Public Class UserList
C#
[XmlRootAttribute(Namespace = "", IsNullable = False)]
public class UserList
C++
[XmlRootAttribute(Namespace = L"", IsNullable = False)]
ref class UserList
J#
/** @attribute XmlRootAttribute(Namespace = "", IsNullable = False) */
public class UserList
JScript
public
XmlRootAttribute(Namespace = "", IsNullable = False)
class UserList

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.UserList

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UserList Members


UserList Members

UserList Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by UserList.

Public Constructors

 | Name | Description
Public method | UserList | Initializes a new instance of the UserList class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | Items |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UserList Class


UserList Constructor

UserList Constructor
[image]

Initializes a new instance of the UserList class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UserList()
C++
public:
UserList() sealed
J#
public UserList()
JScript
public function UserList()

See Also

UserList Class


Fields

UserList Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

UserList Class


SchemaName Field

UserList.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

UserList Class


Properties

UserList Properties
[image]

Public Properties

 | Name | Description
Public property | Items |
Public property | XsdSchema |
Top

See Also

UserList Class


Items Property

UserList.Items Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("User", GetType(UserListUser)), _
XmlElementAttribute("Group", GetType(UserListGroup))>
Public Property Items As ArrayList
C#
[XmlElementAttribute("User", typeof(UserListUser))]
[XmlElementAttribute("Group", typeof(UserListGroup))]
public ArrayList Items { get; set; }
C++
[XmlElementAttribute(L"User", typeof(UserListUser))]
[XmlElementAttribute(L"Group", typeof(UserListGroup))]
public property ArrayList Items sealed {
ArrayList get();
void set(ArrayList value);
}
J#
/** @attribute XmlElementAttribute("User", typeof(UserListUser)) */
/** @attribute XmlElementAttribute("Group", typeof(UserListGroup)) */
/** property */
public ArrayList get_Items();

/** property */
public void set_Items(ArrayList value);
JScript
public function get Items() : ArrayList

public function set Items(value : ArrayList);

See Also

UserList Class


XsdSchema Property

UserList.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

UserList Class


UserListGroup Class

UserListGroup Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UserListGroup
C#
public class UserListGroup
C++
ref class UserListGroup
J#
public class UserListGroup
JScript
public class UserListGroup

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.UserListGroup

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UserListGroup Members


UserListGroup Members

UserListGroup Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UserListGroup.

Public Constructors

 | Name | Description
Public method | UserListGroup | Initializes a new instance of the UserListGroup class.
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | Name |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UserListGroup Class


UserListGroup Constructor

UserListGroup Constructor
[image]

Initializes a new instance of the UserListGroup class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UserListGroup()
C++
public:
UserListGroup() sealed
J#
public UserListGroup()
JScript
public function UserListGroup()

See Also

UserListGroup Class


Properties

UserListGroup Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | Name |
Top

See Also

UserListGroup Class


Description Property

UserListGroup.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

UserListGroup Class


Name Property

UserListGroup.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

UserListGroup Class


UserListUser Class

UserListUser Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UserListUser
C#
public class UserListUser
C++
ref class UserListUser
J#
public class UserListUser
JScript
public class UserListUser

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.UserListUser

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UserListUser Members


UserListUser Members

UserListUser Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UserListUser.

Public Constructors

 | Name | Description
Public method | UserListUser | Initializes a new instance of the UserListUser class.
Top

Public Properties

 | Name | Description
Public property | Description |
Public property | FullName |
Public property | Name |
Public property | Password |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UserListUser Class


UserListUser Constructor

UserListUser Constructor
[image]

Initializes a new instance of the UserListUser class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UserListUser()
C++
public:
UserListUser() sealed
J#
public UserListUser()
JScript
public function UserListUser()

See Also

UserListUser Class


Properties

UserListUser Properties
[image]

Public Properties

 | Name | Description
Public property | Description |
Public property | FullName |
Public property | Name |
Public property | Password |
Top

See Also

UserListUser Class


Description Property

UserListUser.Description Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
C++
public property string Description sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Description();

/** property */
public void set_Description(string value);
JScript
public function get Description() : String

public function set Description(value : String);

See Also

UserListUser Class


FullName Property

UserListUser.FullName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FullName As String
C#
public string FullName { get; set; }
C++
public property string FullName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FullName();

/** property */
public void set_FullName(string value);
JScript
public function get FullName() : String

public function set FullName(value : String);

See Also

UserListUser Class


Name Property

UserListUser.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

UserListUser Class


Password Property

UserListUser.Password Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
C++
public property string Password sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Password();

/** property */
public void set_Password(string value);
JScript
public function get Password() : String

public function set Password(value : String);

See Also

UserListUser Class


Utf8XmlWriter Class

Utf8XmlWriter Class
See Also Example Members
[image]

Overrides the default XmlWriter, to ensure that the Xml is Utf8 and with whitespaces, as the MapGuide server requires Utf8

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class Utf8XmlWriter
Inherits XmlTextWriter
C#
public class Utf8XmlWriter : XmlTextWriter
C++
ref class Utf8XmlWriter : XmlTextWriter
J#
public class Utf8XmlWriter extends XmlTextWriter
JScript
public class Utf8XmlWriter extends XmlTextWriter

Inheritance Hierarchy

System.Object
System.Xml.XmlWriter
System.Xml.XmlTextWriter
OSGeo.MapGuide.MaestroAPI.Utf8XmlWriter

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Utf8XmlWriter Members


Utf8XmlWriter Members

Utf8XmlWriter Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Overrides the default XmlWriter, to ensure that the Xml is Utf8 and with whitespaces, as the MapGuide server requires Utf8

The following tables list the members exposed by Utf8XmlWriter.

Public Constructors

Name | Description
Utf8XmlWriter | Overloaded.
Top

Public Properties

 | Name | Description
Public property | BaseStream | Gets the underlying stream object. (inherited from XmlTextWriter)
Public property | Formatting | Indicates how the output is formatted. (inherited from XmlTextWriter)
Public property | Indentation | Gets or sets how many IndentChars to write for each level in the hierarchy when Formatting is set to Formatting.Indented. (inherited from XmlTextWriter)
Public property | IndentChar | Gets or sets which character to use for indenting when Formatting is set to Formatting.Indented. (inherited from XmlTextWriter)
Public property | Namespaces | Gets or sets a value indicating whether to do namespace support. (inherited from XmlTextWriter)
Public property | QuoteChar | Gets or sets which character to use to quote attribute values. (inherited from XmlTextWriter)
Public property | Settings | Gets the XmlWriterSettings object used to create this XmlWriter instance. (inherited from XmlWriter)
Public property | WriteState | Gets the state of the writer. (inherited from XmlTextWriter)
Public property | XmlLang | Gets the current xml:lang scope. (inherited from XmlTextWriter)
Public property | XmlSpace | Gets an XmlSpace representing the current xml:space scope. (inherited from XmlTextWriter)
Top

Public Methods

 | Name | Description
Public method | Close | Closes this stream and the underlying stream. (inherited from XmlTextWriter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream. (inherited from XmlTextWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LookupPrefix | Returns the closest prefix defined in the current namespace scope for the namespace URI. (inherited from XmlTextWriter)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | WriteAttributes | When overridden in a derived class, writes out all the attributes found at the current position in the XmlReader. (inherited from XmlWriter)
Public method | WriteAttributeString | Overloaded. When overridden in a derived class, writes an attribute with the specified value. (inherited from XmlWriter)
Public method | WriteBase64 | Encodes the specified binary bytes as base64 and writes out the resulting text. (inherited from XmlTextWriter)
Public method | WriteBinHex | Encodes the specified binary bytes as binhex and writes out the resulting text. (inherited from XmlTextWriter)
Public method | WriteCData | Writes out a <![CDATA[...]]> block containing the specified text. (inherited from XmlTextWriter)
Public method | WriteCharEntity | Forces the generation of a character entity for the specified Unicode character value. (inherited from XmlTextWriter)
Public method | WriteChars | Writes text one buffer at a time. (inherited from XmlTextWriter)
Public method | WriteComment | Writes out a comment <!--...--> containing the specified text. (inherited from XmlTextWriter)
Public method | WriteDocType | Writes the DOCTYPE declaration with the specified name and optional attributes. (inherited from XmlTextWriter)
Public method | WriteElementString | Overloaded. When overridden in a derived class, writes an element containing a string value. (inherited from XmlWriter)
Public method | WriteEndAttribute | Closes the previous WriteStartAttribute call. (inherited from XmlTextWriter)
Public method | WriteEndDocument | Closes any open elements or attributes and puts the writer back in the Start state. (inherited from XmlTextWriter)
Public method | WriteEndElement | Closes one element and pops the corresponding namespace scope. (inherited from XmlTextWriter)
Public method | WriteEntityRef | Writes out an entity reference as &name;. (inherited from XmlTextWriter)
Public method | WriteFullEndElement | Closes one element and pops the corresponding namespace scope. (inherited from XmlTextWriter)
Public method | WriteName | Writes out the specified name, ensuring it is a valid name according to the W3C XML 1.0 recommendation (http://www.w3.org/TR/1998/REC-xml-19980210#NT-Name). (inherited from XmlTextWriter)
Public method | WriteNmToken | Writes out the specified name, ensuring it is a valid NmToken according to the W3C XML 1.0 recommendation (http://www.w3.org/TR/1998/REC-xml-19980210#NT-Name). (inherited from XmlTextWriter)
Public method | WriteNode | Overloaded. Copies everything from the source object to the current writer instance. (inherited from XmlWriter)
Public method | WriteProcessingInstruction | Writes out a processing instruction with a space between the name and text as follows: <?name text?>. (inherited from XmlTextWriter)
Public method | WriteQualifiedName | Writes out the namespace-qualified name. This method looks up the prefix that is in scope for the given namespace. (inherited from XmlTextWriter)
Public method | WriteRaw | Overloaded. Writes raw markup manually. (inherited from XmlTextWriter)
Public method | WriteStartAttribute | Overloaded. Writes the start of an attribute. (inherited from XmlTextWriter)
Public method | WriteStartDocument | Overloaded. Writes the XML declaration with the version "1.0".
Public method | WriteStartElement | Overloaded. Writes the specified start tag. (inherited from XmlTextWriter)
Public method | WriteString | Writes the given text content. (inherited from XmlTextWriter)
Public method | WriteSurrogateCharEntity | Generates and writes the surrogate character entity for the surrogate character pair. (inherited from XmlTextWriter)
Public method | WriteValue | Overloaded. Writes a single simple-typed value. (inherited from XmlWriter)
Public method | WriteWhitespace | Writes out the given white space. (inherited from XmlTextWriter)
Top

Explicit Interface Implementations

Name | Description
Utf8XmlWriter | Overloaded.
Top

See Also

Utf8XmlWriter Class


Utf8XmlWriter Constructor

Utf8XmlWriter Constructor

Overload List

 | Name | Description
Public method | Utf8XmlWriter (Stream) |
Public method | Utf8XmlWriter (TextWriter) |

See Also

Utf8XmlWriter Class


Utf8XmlWriter Constructor (Stream)

Utf8XmlWriter Constructor (Stream)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal s As Stream _
)
C#
public Utf8XmlWriter(
Stream s
)
C++
public:
Utf8XmlWriter(
Stream s
) sealed
J#
public Utf8XmlWriter(
Stream s
)
JScript
public function Utf8XmlWriter(
s : Stream
)

See Also

Utf8XmlWriter Class
Utf8XmlWriter Constructor Overload List


Utf8XmlWriter Constructor (TextWriter)

Utf8XmlWriter Constructor (TextWriter)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal w As TextWriter _
)
C#
public Utf8XmlWriter(
TextWriter w
)
C++
public:
Utf8XmlWriter(
TextWriter w
) sealed
J#
public Utf8XmlWriter(
TextWriter w
)
JScript
public function Utf8XmlWriter(
w : TextWriter
)

See Also

Utf8XmlWriter Class
Utf8XmlWriter Constructor Overload List


Methods

Utf8XmlWriter Methods
[image]

Public Methods

 | Name | Description
Public method | Close | Closes this stream and the underlying stream. (inherited from XmlTextWriter)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | Flush | Flushes whatever is in the buffer to the underlying streams and also flushes the underlying stream. (inherited from XmlTextWriter)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | LookupPrefix | Returns the closest prefix defined in the current namespace scope for the namespace URI. (inherited from XmlTextWriter)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | WriteAttributes | When overridden in a derived class, writes out all the attributes found at the current position in the XmlReader. (inherited from XmlWriter)
Public method | WriteAttributeString | Overloaded. When overridden in a derived class, writes an attribute with the specified value. (inherited from XmlWriter)
Public method | WriteBase64 | Encodes the specified binary bytes as base64 and writes out the resulting text. (inherited from XmlTextWriter)
Public method | WriteBinHex | Encodes the specified binary bytes as binhex and writes out the resulting text. (inherited from XmlTextWriter)
Public method | WriteCData | Writes out a <![CDATA[...]]> block containing the specified text. (inherited from XmlTextWriter)
Public method | WriteCharEntity | Forces the generation of a character entity for the specified Unicode character value. (inherited from XmlTextWriter)
Public method | WriteChars | Writes text one buffer at a time. (inherited from XmlTextWriter)
Public method | WriteComment | Writes out a comment <!--...--> containing the specified text. (inherited from XmlTextWriter)
Public method | WriteDocType | Writes the DOCTYPE declaration with the specified name and optional attributes. (inherited from XmlTextWriter)
Public method | WriteElementString | Overloaded. When overridden in a derived class, writes an element containing a string value. (inherited from XmlWriter)
Public method | WriteEndAttribute | Closes the previous WriteStartAttribute call. (inherited from XmlTextWriter)
Public method | WriteEndDocument | Closes any open elements or attributes and puts the writer back in the Start state. (inherited from XmlTextWriter)
Public method | WriteEndElement | Closes one element and pops the corresponding namespace scope. (inherited from XmlTextWriter)
Public method | WriteEntityRef | Writes out an entity reference as &name;. (inherited from XmlTextWriter)
Public method | WriteFullEndElement | Closes one element and pops the corresponding namespace scope. (inherited from XmlTextWriter)
Public method | WriteName | Writes out the specified name, ensuring it is a valid name according to the W3C XML 1.0 recommendation (http://www.w3.org/TR/1998/REC-xml-19980210#NT-Name). (inherited from XmlTextWriter)
Public method | WriteNmToken | Writes out the specified name, ensuring it is a valid NmToken according to the W3C XML 1.0 recommendation (http://www.w3.org/TR/1998/REC-xml-19980210#NT-Name). (inherited from XmlTextWriter)
Public method | WriteNode | Overloaded. Copies everything from the source object to the current writer instance. (inherited from XmlWriter)
Public method | WriteProcessingInstruction | Writes out a processing instruction with a space between the name and text as follows: <?name text?>. (inherited from XmlTextWriter)
Public method | WriteQualifiedName | Writes out the namespace-qualified name. This method looks up the prefix that is in scope for the given namespace. (inherited from XmlTextWriter)
Public method | WriteRaw | Overloaded. Writes raw markup manually. (inherited from XmlTextWriter)
Public method | WriteStartAttribute | Overloaded. Writes the start of an attribute. (inherited from XmlTextWriter)
Public method | WriteStartDocument | Overloaded. Writes the XML declaration with the version "1.0".
Public method | WriteStartElement | Overloaded. Writes the specified start tag. (inherited from XmlTextWriter)
Public method | WriteString | Writes the given text content. (inherited from XmlTextWriter)
Public method | WriteSurrogateCharEntity | Generates and writes the surrogate character entity for the surrogate character pair. (inherited from XmlTextWriter)
Public method | WriteValue | Overloaded. Writes a single simple-typed value. (inherited from XmlWriter)
Public method | WriteWhitespace | Writes out the given white space. (inherited from XmlTextWriter)
Top

See Also

Utf8XmlWriter Class


WriteStartDocument Method

Utf8XmlWriter.WriteStartDocument Method

Writes the XML declaration with the version "1.0".

Overload List

 | Name | Description
Public method | WriteStartDocument | Overridden.
Public method | WriteStartDocument (Boolean) | Overridden.

See Also

Utf8XmlWriter Class


WriteStartDocument Method ()

Utf8XmlWriter.WriteStartDocument Method ()
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteStartDocument()
C#
public override void WriteStartDocument()
C++
public:
virtual void WriteStartDocument() override
J#
public override void WriteStartDocument()
JScript
public override function WriteStartDocument()

See Also

Utf8XmlWriter Class
Utf8XmlWriter.WriteStartDocument Overload List


WriteStartDocument Method (Boolean)

Utf8XmlWriter.WriteStartDocument Method (Boolean)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub WriteStartDocument( _
ByVal standalone As Boolean _
)
C#
public override void WriteStartDocument(
bool standalone
)
C++
public:
virtual void WriteStartDocument(
bool standalone
) override
J#
public override void WriteStartDocument(
bool standalone
)
JScript
public override function WriteStartDocument(
standalone : bool
)

See Also

Utf8XmlWriter Class
Utf8XmlWriter.WriteStartDocument Overload List


Utility Class

Utility Class
See Also Example Members
[image]

Various helper functions

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class Utility
C#
public class Utility
C++
ref class Utility
J#
public class Utility
JScript
public class Utility

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.Utility

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Utility Members


Utility Members

Utility Members
See Also Example Constructors Properties Methods
[image]

Various helper functions

The following tables list the members exposed by Utility.

Public Constructors

 | Name | Description
Public method | Utility | Initializes a new instance of the Utility class.
Top

Public Properties

Name | Description
GeometryType | Returns the type used to define a geometry column in a feature reader
RasterType | Returns a type used to define a raster column in a feature reader
Top

Public Methods

 | Name | Description
 | CleanUpFeatureSet |
 | ConvertMgTypeToNetType | Gets the type of an item, givne the MapGuide type id
 | ConvertNetTypeToMgType | Gets the MapGuide id for a given type
 | CopyStream | Overloaded. Copies the content of a stream into another stream. Automatically attempts to rewind the source stream.
 | DecodeFDOName | Converts FDO encoded characters into their original character. Encoded characters have the form -x00-.
 | DeepCopy | Overloaded. Makes a deep copy of an object, by copying all the public properties
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | FormatSizeString | Formats a number of bytes to a human readable format, ea.: 2.56 Kb
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | MgStreamToNetStream | Converts a MgStream to a .Net Stream object. Due to some swig issues, it is not possible to pass on an MgStream to a function, so this function calls a method to retrieve the stream locally.
 | ParseDigit | Parses a string with a decimal value in EN-US format
 | ParseHTMLColor | Parses a color in HTML notation (ea. #ffaabbff)
 | RemoveUTF8BOM | Creates a copy of the stream, with removed Utf8 BOM, if any
 | SerializeDigit | Overloaded. Turns a decimal value into a string representation in EN-US format
 | SerializeHTMLColor | Returns the HTML representation of an .Net color structure
 | StreamAsArray | Reads all data from a stream, and returns it as a single array. Note that this is very inefficient if the stream is several megabytes long.
 | ThrowAsWebException | This method tries to extract the html content of a WebException. If succesfull, it will return an exception with an error message corresponding to the html text. If not, it will return the original exception object.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
 | XmlDeepCopy | Builds a copy of the object by serializing it to xml, and then deserializing it. Please note that this function is has a large overhead.
Top

See Also

Utility Class


Utility Constructor

Utility Constructor
[image]

Initializes a new instance of the Utility class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Utility()
C++
public:
Utility() sealed
J#
public Utility()
JScript
public function Utility()

See Also

Utility Class


Properties

Utility Properties
[image]

Public Properties

Name | Description
GeometryType | Returns the type used to define a geometry column in a feature reader
RasterType | Returns a type used to define a raster column in a feature reader
Top

See Also

Utility Class


GeometryType Property

Utility.GeometryType Property
[image]

Returns the type used to define a geometry column in a feature reader

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property GeometryType As Type
C#
public static Type GeometryType { get; }
C++
public static property Type GeometryType {
Type get();
}
J#
/** property */
public Type get_GeometryType();
JScript
public function get GeometryType() : Type

See Also

Utility Class


RasterType Property

Utility.RasterType Property
[image]

Returns a type used to define a raster column in a feature reader

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property RasterType As Type
C#
public static Type RasterType { get; }
C++
public static property Type RasterType {
Type get();
}
J#
/** property */
public Type get_RasterType();
JScript
public function get RasterType() : Type

See Also

Utility Class


Methods

Utility Methods
[image]

Public Methods

 | Name | Description
 | CleanUpFeatureSet |
 | ConvertMgTypeToNetType | Gets the type of an item, givne the MapGuide type id
 | ConvertNetTypeToMgType | Gets the MapGuide id for a given type
 | CopyStream | Overloaded. Copies the content of a stream into another stream. Automatically attempts to rewind the source stream.
 | DecodeFDOName | Converts FDO encoded characters into their original character. Encoded characters have the form -x00-.
 | DeepCopy | Overloaded. Makes a deep copy of an object, by copying all the public properties
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
 | FormatSizeString | Formats a number of bytes to a human readable format, ea.: 2.56 Kb
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
 | MgStreamToNetStream | Converts a MgStream to a .Net Stream object. Due to some swig issues, it is not possible to pass on an MgStream to a function, so this function calls a method to retrieve the stream locally.
 | ParseDigit | Parses a string with a decimal value in EN-US format
 | ParseHTMLColor | Parses a color in HTML notation (ea. #ffaabbff)
 | RemoveUTF8BOM | Creates a copy of the stream, with removed Utf8 BOM, if any
 | SerializeDigit | Overloaded. Turns a decimal value into a string representation in EN-US format
 | SerializeHTMLColor | Returns the HTML representation of an .Net color structure
 | StreamAsArray | Reads all data from a stream, and returns it as a single array. Note that this is very inefficient if the stream is several megabytes long.
 | ThrowAsWebException | This method tries to extract the html content of a WebException. If succesfull, it will return an exception with an error message corresponding to the html text. If not, it will return the original exception object.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
 | XmlDeepCopy | Builds a copy of the object by serializing it to xml, and then deserializing it. Please note that this function is has a large overhead.
Top

See Also

Utility Class


CleanUpFeatureSet Method

Utility.CleanUpFeatureSet Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CleanUpFeatureSet( _
ByVal input As String _
) As String
C#
public static string CleanUpFeatureSet(
string input
)
C++
public:
static String CleanUpFeatureSet(
String input
)
J#
public static string CleanUpFeatureSet(
string input
)
JScript
public static function CleanUpFeatureSet(
input : String
) : String

See Also

Utility Class


ConvertMgTypeToNetType Method

Utility.ConvertMgTypeToNetType Method
[image]

Gets the type of an item, givne the MapGuide type id

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertMgTypeToNetType( _
ByVal MgType As Integer _
) As Type
C#
public static Type ConvertMgTypeToNetType(
int MgType
)
C++
public:
static Type ConvertMgTypeToNetType(
int MgType
)
J#
public static Type ConvertMgTypeToNetType(
int MgType
)
JScript
public static function ConvertMgTypeToNetType(
MgType : int
) : Type

Parameters

MgType
The MapGuide type id

Return Value

The corresponding .Net type

See Also

Utility Class


ConvertNetTypeToMgType Method

Utility.ConvertNetTypeToMgType Method
[image]

Gets the MapGuide id for a given type

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertNetTypeToMgType( _
ByVal type As Type _
) As Integer
C#
public static int ConvertNetTypeToMgType(
Type type
)
C++
public:
static int ConvertNetTypeToMgType(
Type type
)
J#
public static int ConvertNetTypeToMgType(
Type type
)
JScript
public static function ConvertNetTypeToMgType(
type : Type
) : int

Parameters

type
The .Net type

Return Value

The corresponding MapGuide type id

See Also

Utility Class


CopyStream Method

Utility.CopyStream Method

Copies the content of a stream into another stream. Automatically attempts to rewind the source stream.

Overload List

Name | Description
CopyStream (Stream, Stream) | Copies the content of a stream into another stream. Automatically attempts to rewind the source stream.
CopyStream (Stream, Stream, Utility.StreamCopyProgressDelegate, Int64) | Copies the content of a stream into another stream, with callbacks.
CopyStream (Stream, Stream, Boolean) | Copies the content of a stream into another stream.

See Also

Utility Class


CopyStream Method (Stream, Stream)

Utility.CopyStream Method (Stream, Stream)
See Also Example
[image]

Copies the content of a stream into another stream. Automatically attempts to rewind the source stream.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CopyStream( _
ByVal source As Stream, _
ByVal target As Stream _
)
C#
public static void CopyStream(
Stream source,
Stream target
)
C++
public:
static void CopyStream(
Stream source,
Stream target
)
J#
public static void CopyStream(
Stream source,
Stream target
)
JScript
public static function CopyStream(
source : Stream,
target : Stream
)

Parameters

source
The source stream
target
The target stream

See Also

Utility Class
Utility.CopyStream Overload List


CopyStream Method (Stream, Stream, Utility.StreamCopyProgressDelegate, Int64)

Utility.CopyStream Method (Stream, Stream, Utility.StreamCopyProgressDelegate, Int64)
See Also Example
[image]

Copies the content of a stream into another stream, with callbacks.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CopyStream( _
ByVal source As Stream, _
ByVal target As Stream, _
ByVal callback As Utility.StreamCopyProgressDelegate, _
ByVal updateFrequence As Long _
)
C#
public static void CopyStream(
Stream source,
Stream target,
Utility.StreamCopyProgressDelegate callback,
long updateFrequence
)
C++
public:
static void CopyStream(
Stream source,
Stream target,
Utility.StreamCopyProgressDelegate callback,
__int64 updateFrequence
)
J#
public static void CopyStream(
Stream source,
Stream target,
Utility.StreamCopyProgressDelegate callback,
long updateFrequence
)
JScript
public static function CopyStream(
source : Stream,
target : Stream,
callback : Utility.StreamCopyProgressDelegate,
updateFrequence : long
)

Parameters

source
The source stream
target
The target stream
callback
An optional callback delegate, may be null.
updateFrequence
The number of bytes to copy before calling the callback delegate, set to 0 to get every update

See Also

Utility Class
Utility.CopyStream Overload List


CopyStream Method (Stream, Stream, Boolean)

Utility.CopyStream Method (Stream, Stream, Boolean)
See Also Example
[image]

Copies the content of a stream into another stream.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CopyStream( _
ByVal source As Stream, _
ByVal target As Stream, _
ByVal rewind As Boolean _
)
C#
public static void CopyStream(
Stream source,
Stream target,
bool rewind
)
C++
public:
static void CopyStream(
Stream source,
Stream target,
bool rewind
)
J#
public static void CopyStream(
Stream source,
Stream target,
bool rewind
)
JScript
public static function CopyStream(
source : Stream,
target : Stream,
rewind : bool
)

Parameters

source
The source stream
target
The target stream
rewind
True if the source stream should be rewound before being copied

See Also

Utility Class
Utility.CopyStream Overload List


DecodeFDOName Method

Utility.DecodeFDOName Method
[image]

Converts FDO encoded characters into their original character. Encoded characters have the form -x00-.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function DecodeFDOName( _
ByVal name As String _
) As String
C#
public static string DecodeFDOName(
string name
)
C++
public:
static String DecodeFDOName(
String name
)
J#
public static string DecodeFDOName(
string name
)
JScript
public static function DecodeFDOName(
name : String
) : String

Parameters

name
The FDO encoded string

Return Value

The unencoded version of the string

See Also

Utility Class


DeepCopy Method

Utility.DeepCopy Method

Makes a deep copy of an object, by copying all the public properties

Overload List

Name | Description
DeepCopy (Object) | Makes a deep copy of an object, by copying all the public properties
DeepCopy (Object, Object) | Makes a deep copy of an object, by copying all the public properties. This overload tries to maintain object references by assigning properties

See Also

Utility Class


DeepCopy Method (Object)

Utility.DeepCopy Method (Object)
See Also Example
[image]

Makes a deep copy of an object, by copying all the public properties

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function DeepCopy( _
ByVal source As Object _
) As Object
C#
public static object DeepCopy(
object source
)
C++
public:
static Object DeepCopy(
Object source
)
J#
public static object DeepCopy(
object source
)
JScript
public static function DeepCopy(
source : Object
) : Object

Parameters

source
The object to copy

Return Value

A copied object

See Also

Utility Class
Utility.DeepCopy Overload List


DeepCopy Method (Object, Object)

Utility.DeepCopy Method (Object, Object)
See Also Example
[image]

Makes a deep copy of an object, by copying all the public properties. This overload tries to maintain object references by assigning properties

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function DeepCopy( _
ByVal source As Object, _
ByVal target As Object _
) As Object
C#
public static object DeepCopy(
object source,
object target
)
C++
public:
static Object DeepCopy(
Object source,
Object target
)
J#
public static object DeepCopy(
object source,
object target
)
JScript
public static function DeepCopy(
source : Object,
target : Object
) : Object

Parameters

source
The object to copy
target
The object to assign to

Return Value

A copied object

See Also

Utility Class
Utility.DeepCopy Overload List


FormatSizeString Method

Utility.FormatSizeString Method
[image]

Formats a number of bytes to a human readable format, ea.: 2.56 Kb

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FormatSizeString( _
ByVal size As Long _
) As String
C#
public static string FormatSizeString(
long size
)
C++
public:
static String FormatSizeString(
__int64 size
)
J#
public static string FormatSizeString(
long size
)
JScript
public static function FormatSizeString(
size : long
) : String

Parameters

size
The size in bytes

Return Value

The human readable string

See Also

Utility Class


MgStreamToNetStream Method

Utility.MgStreamToNetStream Method
[image]

Converts a MgStream to a .Net Stream object. Due to some swig issues, it is not possible to pass on an MgStream to a function, so this function calls a method to retrieve the stream locally.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function MgStreamToNetStream( _
ByVal source As Object, _
ByVal mi As MethodInfo, _
ByVal args As Object() _
) As MemoryStream
C#
public static MemoryStream MgStreamToNetStream(
object source,
MethodInfo mi,
object[] args
)
C++
public:
static MemoryStream MgStreamToNetStream(
Object source,
MethodInfo mi,
array<Object>^ args
)
J#
public static MemoryStream MgStreamToNetStream(
object source,
MethodInfo mi,
object[] args
)
JScript
public static function MgStreamToNetStream(
source : Object,
mi : MethodInfo,
args : Object[]
) : MemoryStream

Parameters

source
The object which has a stream
mi
The method to call
args
Arguments to the method

Return Value

A memorystream with the MgStream's content

See Also

Utility Class


ParseDigit Method

Utility.ParseDigit Method
[image]

Parses a string with a decimal value in EN-US format

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ParseDigit( _
ByVal digit As String _
) As Single
C#
public static float ParseDigit(
string digit
)
C++
public:
static float ParseDigit(
String digit
)
J#
public static float ParseDigit(
string digit
)
JScript
public static function ParseDigit(
digit : String
) : float

Parameters

digit
The string value

Return Value

The parsed value

See Also

Utility Class


ParseHTMLColor Method

Utility.ParseHTMLColor Method
[image]

Parses a color in HTML notation (ea. #ffaabbff)

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ParseHTMLColor( _
ByVal color As String _
) As Color
C#
public static Color ParseHTMLColor(
string color
)
C++
public:
static Color ParseHTMLColor(
String color
)
J#
public static Color ParseHTMLColor(
string color
)
JScript
public static function ParseHTMLColor(
color : String
) : Color

Parameters

color
The HTML representation of the color

Return Value

The .Net color structure that matches the color

See Also

Utility Class


RemoveUTF8BOM Method

Utility.RemoveUTF8BOM Method
[image]

Creates a copy of the stream, with removed Utf8 BOM, if any

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function RemoveUTF8BOM( _
ByVal ms As MemoryStream _
) As MemoryStream
C#
public static MemoryStream RemoveUTF8BOM(
MemoryStream ms
)
C++
public:
static MemoryStream RemoveUTF8BOM(
MemoryStream ms
)
J#
public static MemoryStream RemoveUTF8BOM(
MemoryStream ms
)
JScript
public static function RemoveUTF8BOM(
ms : MemoryStream
) : MemoryStream

Parameters

ms
The stream to fix

Return Value

A stream with no Utf8 BOM

See Also

Utility Class


SerializeDigit Method

Utility.SerializeDigit Method

Turns a decimal value into a string representation in EN-US format

Overload List

Name | Description
SerializeDigit (Double) | Turns a decimal value into a string representation in EN-US format
SerializeDigit (Single) | Turns a decimal value into a string representation in EN-US format

See Also

Utility Class


SerializeDigit Method (Double)

Utility.SerializeDigit Method (Double)
See Also Example
[image]

Turns a decimal value into a string representation in EN-US format

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SerializeDigit( _
ByVal digit As Double _
) As String
C#
public static string SerializeDigit(
double digit
)
C++
public:
static String SerializeDigit(
double digit
)
J#
public static string SerializeDigit(
double digit
)
JScript
public static function SerializeDigit(
digit : double
) : String

Parameters

digit
The value to encode

Return Value

The encoded value

See Also

Utility Class
Utility.SerializeDigit Overload List


SerializeDigit Method (Single)

Utility.SerializeDigit Method (Single)
See Also Example
[image]

Turns a decimal value into a string representation in EN-US format

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SerializeDigit( _
ByVal digit As Single _
) As String
C#
public static string SerializeDigit(
float digit
)
C++
public:
static String SerializeDigit(
float digit
)
J#
public static string SerializeDigit(
float digit
)
JScript
public static function SerializeDigit(
digit : float
) : String

Parameters

digit
The value to encode

Return Value

The encoded value

See Also

Utility Class
Utility.SerializeDigit Overload List


SerializeHTMLColor Method

Utility.SerializeHTMLColor Method
[image]

Returns the HTML representation of an .Net color structure

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SerializeHTMLColor( _
ByVal color As Color, _
ByVal includeAlpha As Boolean _
) As String
C#
public static string SerializeHTMLColor(
Color color,
bool includeAlpha
)
C++
public:
static String SerializeHTMLColor(
Color color,
bool includeAlpha
)
J#
public static string SerializeHTMLColor(
Color color,
bool includeAlpha
)
JScript
public static function SerializeHTMLColor(
color : Color,
includeAlpha : bool
) : String

Parameters

color
The color to encode
includeAlpha
A flag indicating if the color structures alpha value should be included

Return Value

The HTML representation of the color structure

See Also

Utility Class


StreamAsArray Method

Utility.StreamAsArray Method
[image]

Reads all data from a stream, and returns it as a single array. Note that this is very inefficient if the stream is several megabytes long.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function StreamAsArray( _
ByVal s As Stream _
) As Byte()
C#
public static byte[] StreamAsArray(
Stream s
)
C++
public:
static array<char>^ StreamAsArray(
Stream s
)
J#
public static byte[] StreamAsArray(
Stream s
)
JScript
public static function StreamAsArray(
s : Stream
) : Byte[]

Parameters

s
The stream to exhaust

Return Value

The streams content as an array

See Also

Utility Class


ThrowAsWebException Method

Utility.ThrowAsWebException Method
[image]

This method tries to extract the html content of a WebException. If succesfull, it will return an exception with an error message corresponding to the html text. If not, it will return the original exception object.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ThrowAsWebException( _
ByVal ex As Exception _
) As Exception
C#
public static Exception ThrowAsWebException(
Exception ex
)
C++
public:
static Exception ThrowAsWebException(
Exception ex
)
J#
public static Exception ThrowAsWebException(
Exception ex
)
JScript
public static function ThrowAsWebException(
ex : Exception
) : Exception

Parameters

ex
The exception object to extract from

Return Value

A potentially better exeception

See Also

Utility Class


XmlDeepCopy Method

Utility.XmlDeepCopy Method
[image]

Builds a copy of the object by serializing it to xml, and then deserializing it. Please note that this function is has a large overhead.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function XmlDeepCopy( _
ByVal source As Object _
) As Object
C#
public static object XmlDeepCopy(
object source
)
C++
public:
static Object XmlDeepCopy(
Object source
)
J#
public static object XmlDeepCopy(
object source
)
JScript
public static function XmlDeepCopy(
source : Object
) : Object

Parameters

source
The object to copy

Return Value

A copy of the object

See Also

Utility Class


Utility.StreamCopyProgressDelegate Delegate

Utility.StreamCopyProgressDelegate Delegate
[image]

A delegate used to update a progress bar while copying a stream.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub Utility.StreamCopyProgressDelegate( _
ByVal copied As Long, _
ByVal remaining As Long, _
ByVal total As Long _
)
C#
public delegate void Utility.StreamCopyProgressDelegate(
long copied,
long remaining,
long total
)
C++
public delegate void Utility.StreamCopyProgressDelegate(
__int64 copied,
__int64 remaining,
__int64 total
)
J#
/** delegate */
public delegate void Utility.StreamCopyProgressDelegate(
long copied,
long remaining,
long total
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

Parameters

copied
The number of bytes copied so far
remaining
The number of bytes left in the stream. -1 if the stream length is not known
total
The total number of bytes in the source stream. -1 if the stream length is unknown

See Also


VectorLayerDefinitionType Class

VectorLayerDefinitionType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class VectorLayerDefinitionType
Inherits BaseLayerDefinitionType
C#
public class VectorLayerDefinitionType : BaseLayerDefinitionType
C++
ref class VectorLayerDefinitionType : BaseLayerDefinitionType
J#
public class VectorLayerDefinitionType extends BaseLayerDefinitionType
JScript
public class VectorLayerDefinitionType extends BaseLayerDefinitionType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.BaseLayerDefinitionType
OSGeo.MapGuide.MaestroAPI.VectorLayerDefinitionType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VectorLayerDefinitionType Members


VectorLayerDefinitionType Members

VectorLayerDefinitionType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by VectorLayerDefinitionType.

Public Constructors

 | Name | Description
Public method | VectorLayerDefinitionType | Initializes a new instance of the VectorLayerDefinitionType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | FeatureName |
Public property | FeatureNameType |
Public property | Filter |
Public property | Geometry |
Public property | Opacity | (inherited from BaseLayerDefinitionType)
Public property | OpacitySpecified | (inherited from BaseLayerDefinitionType)
Public property | PropertyMapping |
Public property | ResourceId | (inherited from BaseLayerDefinitionType)
Public property | ToolTip |
Public property | Url |
Public property | VectorScaleRange |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

VectorLayerDefinitionType Class


VectorLayerDefinitionType Constructor

VectorLayerDefinitionType Constructor
[image]

Initializes a new instance of the VectorLayerDefinitionType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VectorLayerDefinitionType()
C++
public:
VectorLayerDefinitionType() sealed
J#
public VectorLayerDefinitionType()
JScript
public function VectorLayerDefinitionType()

See Also

VectorLayerDefinitionType Class


Properties

VectorLayerDefinitionType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | FeatureName |
Public property | FeatureNameType |
Public property | Filter |
Public property | Geometry |
Public property | Opacity | (inherited from BaseLayerDefinitionType)
Public property | OpacitySpecified | (inherited from BaseLayerDefinitionType)
Public property | PropertyMapping |
Public property | ResourceId | (inherited from BaseLayerDefinitionType)
Public property | ToolTip |
Public property | Url |
Public property | VectorScaleRange |
Top

See Also

VectorLayerDefinitionType Class


ExtendedData1 Property

VectorLayerDefinitionType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

VectorLayerDefinitionType Class


FeatureName Property

VectorLayerDefinitionType.FeatureName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FeatureName As String
C#
public string FeatureName { get; set; }
C++
public property string FeatureName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FeatureName();

/** property */
public void set_FeatureName(string value);
JScript
public function get FeatureName() : String

public function set FeatureName(value : String);

See Also

VectorLayerDefinitionType Class


FeatureNameType Property

VectorLayerDefinitionType.FeatureNameType Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FeatureNameType As FeatureNameType
C#
public FeatureNameType FeatureNameType { get; set; }
C++
public property FeatureNameType FeatureNameType sealed {
FeatureNameType get();
void set(FeatureNameType value);
}
J#
/** property */
public FeatureNameType get_FeatureNameType();

/** property */
public void set_FeatureNameType(FeatureNameType value);
JScript
public function get FeatureNameType() : FeatureNameType

public function set FeatureNameType(value : FeatureNameType);

See Also

VectorLayerDefinitionType Class


Filter Property

VectorLayerDefinitionType.Filter Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Filter As String
C#
public string Filter { get; set; }
C++
public property string Filter sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Filter();

/** property */
public void set_Filter(string value);
JScript
public function get Filter() : String

public function set Filter(value : String);

See Also

VectorLayerDefinitionType Class


Geometry Property

VectorLayerDefinitionType.Geometry Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Geometry As String
C#
public string Geometry { get; set; }
C++
public property string Geometry sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Geometry();

/** property */
public void set_Geometry(string value);
JScript
public function get Geometry() : String

public function set Geometry(value : String);

See Also

VectorLayerDefinitionType Class


PropertyMapping Property

VectorLayerDefinitionType.PropertyMapping Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("PropertyMapping")>
Public Property PropertyMapping As NameStringPairTypeCollection
C#
[XmlElementAttribute("PropertyMapping")]
public NameStringPairTypeCollection PropertyMapping { get; set; }
C++
[XmlElementAttribute(L"PropertyMapping")]
public property NameStringPairTypeCollection PropertyMapping sealed {
NameStringPairTypeCollection get();
void set(NameStringPairTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("PropertyMapping") */
/** property */
public NameStringPairTypeCollection get_PropertyMapping();

/** property */
public void set_PropertyMapping(NameStringPairTypeCollection value);
JScript
public function get PropertyMapping() : NameStringPairTypeCollection

public function set PropertyMapping(value : NameStringPairTypeCollection);

See Also

VectorLayerDefinitionType Class


ToolTip Property

VectorLayerDefinitionType.ToolTip Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ToolTip As String
C#
public string ToolTip { get; set; }
C++
public property string ToolTip sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ToolTip();

/** property */
public void set_ToolTip(string value);
JScript
public function get ToolTip() : String

public function set ToolTip(value : String);

See Also

VectorLayerDefinitionType Class


Url Property

VectorLayerDefinitionType.Url Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Url As String
C#
public string Url { get; set; }
C++
public property string Url sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Url();

/** property */
public void set_Url(string value);
JScript
public function get Url() : String

public function set Url(value : String);

See Also

VectorLayerDefinitionType Class


VectorScaleRange Property

VectorLayerDefinitionType.VectorScaleRange Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("VectorScaleRange")>
Public Property VectorScaleRange As VectorScaleRangeTypeCollection
C#
[XmlElementAttribute("VectorScaleRange")]
public VectorScaleRangeTypeCollection VectorScaleRange { get; set; }
C++
[XmlElementAttribute(L"VectorScaleRange")]
public property VectorScaleRangeTypeCollection VectorScaleRange sealed {
VectorScaleRangeTypeCollection get();
void set(VectorScaleRangeTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("VectorScaleRange") */
/** property */
public VectorScaleRangeTypeCollection get_VectorScaleRange();

/** property */
public void set_VectorScaleRange(VectorScaleRangeTypeCollection value);
JScript
public function get VectorScaleRange() : VectorScaleRangeTypeCollection

public function set VectorScaleRange(value : VectorScaleRangeTypeCollection);

See Also

VectorLayerDefinitionType Class


VectorScaleRangeType Class

VectorScaleRangeType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class VectorScaleRangeType
C#
public class VectorScaleRangeType
C++
ref class VectorScaleRangeType
J#
public class VectorScaleRangeType
JScript
public class VectorScaleRangeType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.VectorScaleRangeType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VectorScaleRangeType Members


VectorScaleRangeType Members

VectorScaleRangeType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by VectorScaleRangeType.

Public Constructors

 | Name | Description
Public method | VectorScaleRangeType | Initializes a new instance of the VectorScaleRangeType class.
Top

Public Properties

 | Name | Description
Public property | ElevationSettings |
Public property | ExtendedData1 |
Public property | Items |
Public property | MaxScale |
Public property | MaxScaleSpecified |
Public property | MinScale |
Public property | MinScaleSpecified |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

VectorScaleRangeType Class


VectorScaleRangeType Constructor

VectorScaleRangeType Constructor
[image]

Initializes a new instance of the VectorScaleRangeType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VectorScaleRangeType()
C++
public:
VectorScaleRangeType() sealed
J#
public VectorScaleRangeType()
JScript
public function VectorScaleRangeType()

See Also

VectorScaleRangeType Class


Properties

VectorScaleRangeType Properties
[image]

Public Properties

 | Name | Description
Public property | ElevationSettings |
Public property | ExtendedData1 |
Public property | Items |
Public property | MaxScale |
Public property | MaxScaleSpecified |
Public property | MinScale |
Public property | MinScaleSpecified |
Top

See Also

VectorScaleRangeType Class


ElevationSettings Property

VectorScaleRangeType.ElevationSettings Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ElevationSettings As ElevationSettingsType
C#
public ElevationSettingsType ElevationSettings { get; set; }
C++
public property ElevationSettingsType ElevationSettings sealed {
ElevationSettingsType get();
void set(ElevationSettingsType value);
}
J#
/** property */
public ElevationSettingsType get_ElevationSettings();

/** property */
public void set_ElevationSettings(ElevationSettingsType value);
JScript
public function get ElevationSettings() : ElevationSettingsType

public function set ElevationSettings(value : ElevationSettingsType);

See Also

VectorScaleRangeType Class


ExtendedData1 Property

VectorScaleRangeType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

VectorScaleRangeType Class


Items Property

VectorScaleRangeType.Items Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("AreaTypeStyle", GetType(AreaTypeStyleType)), _
XmlElementAttribute("PointTypeStyle", GetType(PointTypeStyleType)), _
XmlElementAttribute("CompositeTypeStyle", GetType(CompositeTypeStyle)), _
XmlElementAttribute("LineTypeStyle", GetType(LineTypeStyleType))>
Public Property Items As ArrayList
C#
[XmlElementAttribute("AreaTypeStyle", typeof(AreaTypeStyleType))]
[XmlElementAttribute("PointTypeStyle", typeof(PointTypeStyleType))]
[XmlElementAttribute("CompositeTypeStyle", typeof(CompositeTypeStyle))]
[XmlElementAttribute("LineTypeStyle", typeof(LineTypeStyleType))]
public ArrayList Items { get; set; }
C++
[XmlElementAttribute(L"AreaTypeStyle", typeof(AreaTypeStyleType))]
[XmlElementAttribute(L"PointTypeStyle", typeof(PointTypeStyleType))]
[XmlElementAttribute(L"CompositeTypeStyle", typeof(CompositeTypeStyle))]
[XmlElementAttribute(L"LineTypeStyle", typeof(LineTypeStyleType))]
public property ArrayList Items sealed {
ArrayList get();
void set(ArrayList value);
}
J#
/** @attribute XmlElementAttribute("AreaTypeStyle", typeof(AreaTypeStyleType)) */
/** @attribute XmlElementAttribute("PointTypeStyle", typeof(PointTypeStyleType)) */
/** @attribute XmlElementAttribute("CompositeTypeStyle", typeof(CompositeTypeStyle)) */
/** @attribute XmlElementAttribute("LineTypeStyle", typeof(LineTypeStyleType)) */
/** property */
public ArrayList get_Items();

/** property */
public void set_Items(ArrayList value);
JScript
public function get Items() : ArrayList

public function set Items(value : ArrayList);

See Also

VectorScaleRangeType Class


MaxScale Property

VectorScaleRangeType.MaxScale Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxScale As Double
C#
public double MaxScale { get; set; }
C++
public property double MaxScale sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MaxScale();

/** property */
public void set_MaxScale(double value);
JScript
public function get MaxScale() : double

public function set MaxScale(value : double);

See Also

VectorScaleRangeType Class


MaxScaleSpecified Property

VectorScaleRangeType.MaxScaleSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property MaxScaleSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool MaxScaleSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool MaxScaleSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_MaxScaleSpecified();

/** property */
public void set_MaxScaleSpecified(bool value);
JScript
public function get MaxScaleSpecified() : bool

public function set MaxScaleSpecified(value : bool);

See Also

VectorScaleRangeType Class


MinScale Property

VectorScaleRangeType.MinScale Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MinScale As Double
C#
public double MinScale { get; set; }
C++
public property double MinScale sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MinScale();

/** property */
public void set_MinScale(double value);
JScript
public function get MinScale() : double

public function set MinScale(value : double);

See Also

VectorScaleRangeType Class


MinScaleSpecified Property

VectorScaleRangeType.MinScaleSpecified Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property MinScaleSpecified As Boolean
C#
[XmlIgnoreAttribute]
public bool MinScaleSpecified { get; set; }
C++
[XmlIgnoreAttribute]
public property bool MinScaleSpecified sealed {
bool get();
void set(bool value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public bool get_MinScaleSpecified();

/** property */
public void set_MinScaleSpecified(bool value);
JScript
public function get MinScaleSpecified() : bool

public function set MinScaleSpecified(value : bool);

See Also

VectorScaleRangeType Class


VectorScaleRangeTypeCollection Class

VectorScaleRangeTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class VectorScaleRangeTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class VectorScaleRangeTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class VectorScaleRangeTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class VectorScaleRangeTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class VectorScaleRangeTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.VectorScaleRangeTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VectorScaleRangeTypeCollection Members


VectorScaleRangeTypeCollection Members

VectorScaleRangeTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by VectorScaleRangeTypeCollection.

Public Constructors

 | Name | Description
Public method | VectorScaleRangeTypeCollection | Initializes a new instance of the VectorScaleRangeTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

VectorScaleRangeTypeCollection Class


VectorScaleRangeTypeCollection Constructor

VectorScaleRangeTypeCollection Constructor
[image]

Initializes a new instance of the VectorScaleRangeTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public VectorScaleRangeTypeCollection()
C++
public:
VectorScaleRangeTypeCollection() sealed
J#
public VectorScaleRangeTypeCollection()
JScript
public function VectorScaleRangeTypeCollection()

See Also

VectorScaleRangeTypeCollection Class


Properties

VectorScaleRangeTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

VectorScaleRangeTypeCollection Class


Item Property

VectorScaleRangeTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As VectorScaleRangeType
C#
public VectorScaleRangeType this[
int idx
] { get; set; }
C++
public property VectorScaleRangeType default[int idx] sealed {
VectorScaleRangeType get(int idx);
void set(int idx, VectorScaleRangeType value);
}
J#
/** property */
public VectorScaleRangeType get_Item(int idx);

/** property */
public void set_Item(int idx, VectorScaleRangeType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

VectorScaleRangeTypeCollection Class


Methods

VectorScaleRangeTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

VectorScaleRangeTypeCollection Class


Add Method

VectorScaleRangeTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As VectorScaleRangeType _
) As Integer
C#
public int Add(
VectorScaleRangeType value
)
C++
public:
int Add(
VectorScaleRangeType value
) sealed
J#
public int Add(
VectorScaleRangeType value
)
JScript
public function Add(
value : VectorScaleRangeType
) : int

See Also

VectorScaleRangeTypeCollection Class


ViewOptionsCommandType Class

ViewOptionsCommandType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ViewOptionsCommandType
Inherits TargetedCommandType
C#
public class ViewOptionsCommandType : TargetedCommandType
C++
ref class ViewOptionsCommandType : TargetedCommandType
J#
public class ViewOptionsCommandType extends TargetedCommandType
JScript
public class ViewOptionsCommandType extends TargetedCommandType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.TargetedCommandType
OSGeo.MapGuide.MaestroAPI.ViewOptionsCommandType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ViewOptionsCommandType Members


ViewOptionsCommandType Members

ViewOptionsCommandType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ViewOptionsCommandType.

Public Constructors

 | Name | Description
Public method | ViewOptionsCommandType | Initializes a new instance of the ViewOptionsCommandType class.
Top

Public Properties

 | Name | Description
Public property | Description | (inherited from CommandType)
Public property | DisabledImageURL | (inherited from CommandType)
Public property | ImageURL | (inherited from CommandType)
Public property | Label | (inherited from CommandType)
Public property | Name | (inherited from CommandType)
Public property | Target | (inherited from TargetedCommandType)
Public property | TargetFrame | (inherited from TargetedCommandType)
Public property | TargetViewer | (inherited from CommandType)
Public property | Tooltip | (inherited from CommandType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ViewOptionsCommandType Class


ViewOptionsCommandType Constructor

ViewOptionsCommandType Constructor
[image]

Initializes a new instance of the ViewOptionsCommandType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ViewOptionsCommandType()
C++
public:
ViewOptionsCommandType() sealed
J#
public ViewOptionsCommandType()
JScript
public function ViewOptionsCommandType()

See Also

ViewOptionsCommandType Class


W2DSymbolType Class

W2DSymbolType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class W2DSymbolType
Inherits SymbolType
C#
public class W2DSymbolType : SymbolType
C++
ref class W2DSymbolType : SymbolType
J#
public class W2DSymbolType extends SymbolType
JScript
public class W2DSymbolType extends SymbolType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.SymbolType
OSGeo.MapGuide.MaestroAPI.W2DSymbolType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

W2DSymbolType Members


W2DSymbolType Members

W2DSymbolType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by W2DSymbolType.

Public Constructors

 | Name | Description
Public method | W2DSymbolType | Initializes a new instance of the W2DSymbolType class.
Top

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | FillColor |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | LineColor |
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | TextColor |
Public property | Unit | (inherited from SymbolType)
Public property | W2DSymbol |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

W2DSymbolType Class


W2DSymbolType Constructor

W2DSymbolType Constructor
[image]

Initializes a new instance of the W2DSymbolType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public W2DSymbolType()
C++
public:
W2DSymbolType() sealed
J#
public W2DSymbolType()
JScript
public function W2DSymbolType()

See Also

W2DSymbolType Class


Properties

W2DSymbolType Properties
[image]

Public Properties

 | Name | Description
Public property | ExtendedData1 |
Public property | FillColor |
Public property | InsertionPointX | (inherited from SymbolType)
Public property | InsertionPointXSpecified | (inherited from SymbolType)
Public property | InsertionPointY | (inherited from SymbolType)
Public property | InsertionPointYSpecified | (inherited from SymbolType)
Public property | LineColor |
Public property | MaintainAspect | (inherited from SymbolType)
Public property | MaintainAspectSpecified | (inherited from SymbolType)
Public property | Rotation | (inherited from SymbolType)
Public property | SizeContext | (inherited from SymbolType)
Public property | SizeX | (inherited from SymbolType)
Public property | SizeY | (inherited from SymbolType)
Public property | TextColor |
Public property | Unit | (inherited from SymbolType)
Public property | W2DSymbol |
Top

See Also

W2DSymbolType Class


ExtendedData1 Property

W2DSymbolType.ExtendedData1 Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedData1 As ExtendedDataType
C#
public ExtendedDataType ExtendedData1 { get; set; }
C++
public property ExtendedDataType ExtendedData1 sealed {
ExtendedDataType get();
void set(ExtendedDataType value);
}
J#
/** property */
public ExtendedDataType get_ExtendedData1();

/** property */
public void set_ExtendedData1(ExtendedDataType value);
JScript
public function get ExtendedData1() : ExtendedDataType

public function set ExtendedData1(value : ExtendedDataType);

See Also

W2DSymbolType Class


FillColor Property

W2DSymbolType.FillColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FillColor As String
C#
public string FillColor { get; set; }
C++
public property string FillColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FillColor();

/** property */
public void set_FillColor(string value);
JScript
public function get FillColor() : String

public function set FillColor(value : String);

See Also

W2DSymbolType Class


LineColor Property

W2DSymbolType.LineColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LineColor As String
C#
public string LineColor { get; set; }
C++
public property string LineColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_LineColor();

/** property */
public void set_LineColor(string value);
JScript
public function get LineColor() : String

public function set LineColor(value : String);

See Also

W2DSymbolType Class


TextColor Property

W2DSymbolType.TextColor Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property TextColor As String
C#
public string TextColor { get; set; }
C++
public property string TextColor sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_TextColor();

/** property */
public void set_TextColor(string value);
JScript
public function get TextColor() : String

public function set TextColor(value : String);

See Also

W2DSymbolType Class


W2DSymbol Property

W2DSymbolType.W2DSymbol Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property W2DSymbol As W2DSymbolTypeW2DSymbol
C#
public W2DSymbolTypeW2DSymbol W2DSymbol { get; set; }
C++
public property W2DSymbolTypeW2DSymbol W2DSymbol sealed {
W2DSymbolTypeW2DSymbol get();
void set(W2DSymbolTypeW2DSymbol value);
}
J#
/** property */
public W2DSymbolTypeW2DSymbol get_W2DSymbol();

/** property */
public void set_W2DSymbol(W2DSymbolTypeW2DSymbol value);
JScript
public function get W2DSymbol() : W2DSymbolTypeW2DSymbol

public function set W2DSymbol(value : W2DSymbolTypeW2DSymbol);

See Also

W2DSymbolType Class


W2DSymbolTypeW2DSymbol Class

W2DSymbolTypeW2DSymbol Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class W2DSymbolTypeW2DSymbol
C#
public class W2DSymbolTypeW2DSymbol
C++
ref class W2DSymbolTypeW2DSymbol
J#
public class W2DSymbolTypeW2DSymbol
JScript
public class W2DSymbolTypeW2DSymbol

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.W2DSymbolTypeW2DSymbol

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

W2DSymbolTypeW2DSymbol Members


W2DSymbolTypeW2DSymbol Members

W2DSymbolTypeW2DSymbol Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by W2DSymbolTypeW2DSymbol.

Public Constructors

 | Name | Description
Public method | W2DSymbolTypeW2DSymbol | Initializes a new instance of the W2DSymbolTypeW2DSymbol class.
Top

Public Properties

 | Name | Description
Public property | LibraryItemName |
Public property | ResourceId |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

W2DSymbolTypeW2DSymbol Class


W2DSymbolTypeW2DSymbol Constructor

W2DSymbolTypeW2DSymbol Constructor
[image]

Initializes a new instance of the W2DSymbolTypeW2DSymbol class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public W2DSymbolTypeW2DSymbol()
C++
public:
W2DSymbolTypeW2DSymbol() sealed
J#
public W2DSymbolTypeW2DSymbol()
JScript
public function W2DSymbolTypeW2DSymbol()

See Also

W2DSymbolTypeW2DSymbol Class


Properties

W2DSymbolTypeW2DSymbol Properties
[image]

Public Properties

 | Name | Description
Public property | LibraryItemName |
Public property | ResourceId |
Top

See Also

W2DSymbolTypeW2DSymbol Class


LibraryItemName Property

W2DSymbolTypeW2DSymbol.LibraryItemName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LibraryItemName As Object
C#
public object LibraryItemName { get; set; }
C++
public property object LibraryItemName sealed {
Object get();
void set(Object value);
}
J#
/** property */
public object get_LibraryItemName();

/** property */
public void set_LibraryItemName(object value);
JScript
public function get LibraryItemName() : Object

public function set LibraryItemName(value : Object);

See Also

W2DSymbolTypeW2DSymbol Class


ResourceId Property

W2DSymbolTypeW2DSymbol.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceId As Object
C#
public object ResourceId { get; set; }
C++
public property object ResourceId sealed {
Object get();
void set(Object value);
}
J#
/** property */
public object get_ResourceId();

/** property */
public void set_ResourceId(object value);
JScript
public function get ResourceId() : Object

public function set ResourceId(value : Object);

See Also

W2DSymbolTypeW2DSymbol Class


WebLayout Class

WebLayout Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("WebLayout", Namespace := "", IsNullable := False)>
Public Class WebLayout
C#
[XmlRootAttribute("WebLayout", Namespace = "", IsNullable = False)]
public class WebLayout
C++
[XmlRootAttribute(L"WebLayout", Namespace = L"", IsNullable = False)]
ref class WebLayout
J#
/** @attribute XmlRootAttribute("WebLayout", Namespace = "", IsNullable = False) */
public class WebLayout
JScript
public
XmlRootAttribute("WebLayout", Namespace = "", IsNullable = False)
class WebLayout

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.WebLayout

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WebLayout Members


WebLayout Members

WebLayout Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by WebLayout.

Public Constructors

 | Name | Description
Public method | WebLayout | Initializes a new instance of the WebLayout class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | CommandSet |
Public property | ContextMenu |
Public property | InformationPane |
Public property | Map |
Public property | ResourceId |
Public property | StatusBar |
Public property | TaskPane |
Public property | Title |
Public property | ToolBar |
Public property | XsdSchema |
Public property | ZoomControl |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

WebLayout Class


WebLayout Constructor

WebLayout Constructor
[image]

Initializes a new instance of the WebLayout class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WebLayout()
C++
public:
WebLayout() sealed
J#
public WebLayout()
JScript
public function WebLayout()

See Also

WebLayout Class


Fields

WebLayout Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

WebLayout Class


SchemaName Field

WebLayout.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

WebLayout Class


Properties

WebLayout Properties
[image]

Public Properties

 | Name | Description
Public property | CommandSet |
Public property | ContextMenu |
Public property | InformationPane |
Public property | Map |
Public property | ResourceId |
Public property | StatusBar |
Public property | TaskPane |
Public property | Title |
Public property | ToolBar |
Public property | XsdSchema |
Public property | ZoomControl |
Top

See Also

WebLayout Class


CommandSet Property

WebLayout.CommandSet Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("Command", IsNullable := False)>
Public Property CommandSet As CommandTypeCollection
C#
[XmlArrayItemAttribute("Command", IsNullable = False)]
public CommandTypeCollection CommandSet { get; set; }
C++
[XmlArrayItemAttribute(L"Command", IsNullable = False)]
public property CommandTypeCollection CommandSet sealed {
CommandTypeCollection get();
void set(CommandTypeCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("Command", IsNullable = False) */
/** property */
public CommandTypeCollection get_CommandSet();

/** property */
public void set_CommandSet(CommandTypeCollection value);
JScript
public function get CommandSet() : CommandTypeCollection

public function set CommandSet(value : CommandTypeCollection);

See Also

WebLayout Class


ContextMenu Property

WebLayout.ContextMenu Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ContextMenu As ContextMenuType
C#
public ContextMenuType ContextMenu { get; set; }
C++
public property ContextMenuType ContextMenu sealed {
ContextMenuType get();
void set(ContextMenuType value);
}
J#
/** property */
public ContextMenuType get_ContextMenu();

/** property */
public void set_ContextMenu(ContextMenuType value);
JScript
public function get ContextMenu() : ContextMenuType

public function set ContextMenu(value : ContextMenuType);

See Also

WebLayout Class


InformationPane Property

WebLayout.InformationPane Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property InformationPane As InformationPaneType
C#
public InformationPaneType InformationPane { get; set; }
C++
public property InformationPaneType InformationPane sealed {
InformationPaneType get();
void set(InformationPaneType value);
}
J#
/** property */
public InformationPaneType get_InformationPane();

/** property */
public void set_InformationPane(InformationPaneType value);
JScript
public function get InformationPane() : InformationPaneType

public function set InformationPane(value : InformationPaneType);

See Also

WebLayout Class


Map Property

WebLayout.Map Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Map As MapType
C#
public MapType Map { get; set; }
C++
public property MapType Map sealed {
MapType get();
void set(MapType value);
}
J#
/** property */
public MapType get_Map();

/** property */
public void set_Map(MapType value);
JScript
public function get Map() : MapType

public function set Map(value : MapType);

See Also

WebLayout Class


ResourceId Property

WebLayout.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ResourceId As String
C#
[XmlIgnoreAttribute]
public string ResourceId { get; set; }
C++
[XmlIgnoreAttribute]
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

WebLayout Class


StatusBar Property

WebLayout.StatusBar Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property StatusBar As StatusBarType
C#
public StatusBarType StatusBar { get; set; }
C++
public property StatusBarType StatusBar sealed {
StatusBarType get();
void set(StatusBarType value);
}
J#
/** property */
public StatusBarType get_StatusBar();

/** property */
public void set_StatusBar(StatusBarType value);
JScript
public function get StatusBar() : StatusBarType

public function set StatusBar(value : StatusBarType);

See Also

WebLayout Class


TaskPane Property

WebLayout.TaskPane Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property TaskPane As TaskPaneType
C#
public TaskPaneType TaskPane { get; set; }
C++
public property TaskPaneType TaskPane sealed {
TaskPaneType get();
void set(TaskPaneType value);
}
J#
/** property */
public TaskPaneType get_TaskPane();

/** property */
public void set_TaskPane(TaskPaneType value);
JScript
public function get TaskPane() : TaskPaneType

public function set TaskPane(value : TaskPaneType);

See Also

WebLayout Class


Title Property

WebLayout.Title Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title { get; set; }
C++
public property string Title sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Title();

/** property */
public void set_Title(string value);
JScript
public function get Title() : String

public function set Title(value : String);

See Also

WebLayout Class


ToolBar Property

WebLayout.ToolBar Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ToolBar As ToolBarType
C#
public ToolBarType ToolBar { get; set; }
C++
public property ToolBarType ToolBar sealed {
ToolBarType get();
void set(ToolBarType value);
}
J#
/** property */
public ToolBarType get_ToolBar();

/** property */
public void set_ToolBar(ToolBarType value);
JScript
public function get ToolBar() : ToolBarType

public function set ToolBar(value : ToolBarType);

See Also

WebLayout Class


XsdSchema Property

WebLayout.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

WebLayout Class


ZoomControl Property

WebLayout.ZoomControl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoomControl As ZoomControlType
C#
public ZoomControlType ZoomControl { get; set; }
C++
public property ZoomControlType ZoomControl sealed {
ZoomControlType get();
void set(ZoomControlType value);
}
J#
/** property */
public ZoomControlType get_ZoomControl();

/** property */
public void set_ZoomControl(ZoomControlType value);
JScript
public function get ZoomControl() : ZoomControlType

public function set ZoomControl(value : ZoomControlType);

See Also

WebLayout Class


WebLayoutControlType Class

WebLayoutControlType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(TaskPaneType)), _
XmlIncludeAttribute(GetType(InformationPaneType)), _
XmlIncludeAttribute(GetType(ContextMenuType)), _
XmlIncludeAttribute(GetType(StatusBarType)), _
XmlIncludeAttribute(GetType(TaskBarType)), _
XmlIncludeAttribute(GetType(WebLayoutResizableControlType)), _
XmlIncludeAttribute(GetType(ZoomControlType)), _
XmlIncludeAttribute(GetType(ToolBarType))>
Public Class WebLayoutControlType
C#
[XmlIncludeAttribute(typeof(TaskPaneType))]
[XmlIncludeAttribute(typeof(InformationPaneType))]
[XmlIncludeAttribute(typeof(ContextMenuType))]
[XmlIncludeAttribute(typeof(StatusBarType))]
[XmlIncludeAttribute(typeof(TaskBarType))]
[XmlIncludeAttribute(typeof(WebLayoutResizableControlType))]
[XmlIncludeAttribute(typeof(ZoomControlType))]
[XmlIncludeAttribute(typeof(ToolBarType))]
public class WebLayoutControlType
C++
[XmlIncludeAttribute(typeof(TaskPaneType))]
[XmlIncludeAttribute(typeof(InformationPaneType))]
[XmlIncludeAttribute(typeof(ContextMenuType))]
[XmlIncludeAttribute(typeof(StatusBarType))]
[XmlIncludeAttribute(typeof(TaskBarType))]
[XmlIncludeAttribute(typeof(WebLayoutResizableControlType))]
[XmlIncludeAttribute(typeof(ZoomControlType))]
[XmlIncludeAttribute(typeof(ToolBarType))]
ref class WebLayoutControlType
J#
/** @attribute XmlIncludeAttribute(typeof(TaskPaneType)) */
/** @attribute XmlIncludeAttribute(typeof(InformationPaneType)) */
/** @attribute XmlIncludeAttribute(typeof(ContextMenuType)) */
/** @attribute XmlIncludeAttribute(typeof(StatusBarType)) */
/** @attribute XmlIncludeAttribute(typeof(TaskBarType)) */
/** @attribute XmlIncludeAttribute(typeof(WebLayoutResizableControlType)) */
/** @attribute XmlIncludeAttribute(typeof(ZoomControlType)) */
/** @attribute XmlIncludeAttribute(typeof(ToolBarType)) */
public class WebLayoutControlType
JScript
public
XmlIncludeAttribute(typeof(TaskPaneType))
XmlIncludeAttribute(typeof(InformationPaneType))
XmlIncludeAttribute(typeof(ContextMenuType))
XmlIncludeAttribute(typeof(StatusBarType))
XmlIncludeAttribute(typeof(TaskBarType))
XmlIncludeAttribute(typeof(WebLayoutResizableControlType))
XmlIncludeAttribute(typeof(ZoomControlType))
XmlIncludeAttribute(typeof(ToolBarType))
class WebLayoutControlType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.WebLayoutControlType
Derived types

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WebLayoutControlType Members


WebLayoutControlType Class Hierarchy

WebLayoutControlType Hierarchy

The following table lists the types derived from WebLayoutControlType .

Derived Types

Type | Description
ContextMenuType |
StatusBarType |
TaskBarType |
ToolBarType |
WebLayoutResizableControlType |
ZoomControlType |

See Also

WebLayoutControlType Class


WebLayoutControlType Members

WebLayoutControlType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by WebLayoutControlType.

Public Constructors

 | Name | Description
Public method | WebLayoutControlType | Initializes a new instance of the WebLayoutControlType class.
Top

Public Properties

 | Name | Description
Public property | Visible |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

WebLayoutControlType Class


WebLayoutControlType Constructor

WebLayoutControlType Constructor
[image]

Initializes a new instance of the WebLayoutControlType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WebLayoutControlType()
C++
public:
WebLayoutControlType() sealed
J#
public WebLayoutControlType()
JScript
public function WebLayoutControlType()

See Also

WebLayoutControlType Class


Properties

WebLayoutControlType Properties
[image]

Public Properties

 | Name | Description
Public property | Visible |
Top

See Also

WebLayoutControlType Class


Visible Property

WebLayoutControlType.Visible Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible { get; set; }
C++
public property bool Visible sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Visible();

/** property */
public void set_Visible(bool value);
JScript
public function get Visible() : bool

public function set Visible(value : bool);

See Also

WebLayoutControlType Class


WebLayoutResizableControlType Class

WebLayoutResizableControlType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(InformationPaneType)), _
XmlIncludeAttribute(GetType(TaskPaneType))>
Public Class WebLayoutResizableControlType
Inherits WebLayoutControlType
C#
[XmlIncludeAttribute(typeof(InformationPaneType))]
[XmlIncludeAttribute(typeof(TaskPaneType))]
public class WebLayoutResizableControlType : WebLayoutControlType
C++
[XmlIncludeAttribute(typeof(InformationPaneType))]
[XmlIncludeAttribute(typeof(TaskPaneType))]
ref class WebLayoutResizableControlType : WebLayoutControlType
J#
/** @attribute XmlIncludeAttribute(typeof(InformationPaneType)) */
/** @attribute XmlIncludeAttribute(typeof(TaskPaneType)) */
public class WebLayoutResizableControlType extends WebLayoutControlType
JScript
public
XmlIncludeAttribute(typeof(InformationPaneType))
XmlIncludeAttribute(typeof(TaskPaneType))
class WebLayoutResizableControlType extends WebLayoutControlType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.WebLayoutControlType
OSGeo.MapGuide.MaestroAPI.WebLayoutResizableControlType
OSGeo.MapGuide.MaestroAPI.InformationPaneType
OSGeo.MapGuide.MaestroAPI.TaskPaneType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WebLayoutResizableControlType Members


WebLayoutResizableControlType Members

WebLayoutResizableControlType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by WebLayoutResizableControlType.

Public Constructors

 | Name | Description
Public method | WebLayoutResizableControlType | Initializes a new instance of the WebLayoutResizableControlType class.
Top

Public Properties

 | Name | Description
Public property | Visible | (inherited from WebLayoutControlType)
Public property | Width |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

WebLayoutResizableControlType Class


WebLayoutResizableControlType Constructor

WebLayoutResizableControlType Constructor
[image]

Initializes a new instance of the WebLayoutResizableControlType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WebLayoutResizableControlType()
C++
public:
WebLayoutResizableControlType() sealed
J#
public WebLayoutResizableControlType()
JScript
public function WebLayoutResizableControlType()

See Also

WebLayoutResizableControlType Class


Properties

WebLayoutResizableControlType Properties
[image]

Public Properties

 | Name | Description
Public property | Visible | (inherited from WebLayoutControlType)
Public property | Width |
Top

See Also

WebLayoutResizableControlType Class


Width Property

WebLayoutResizableControlType.Width Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
C#
public int Width { get; set; }
C++
public property int Width sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Width();

/** property */
public void set_Width(int value);
JScript
public function get Width() : int

public function set Width(value : int);

See Also

WebLayoutResizableControlType Class


XmlElementCollection Class

XmlElementCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XmlElementCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class XmlElementCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class XmlElementCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class XmlElementCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class XmlElementCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.XmlElementCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XmlElementCollection Members


XmlElementCollection Members

XmlElementCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by XmlElementCollection.

Public Constructors

 | Name | Description
Public method | XmlElementCollection | Initializes a new instance of the XmlElementCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XmlElementCollection Class


XmlElementCollection Constructor

XmlElementCollection Constructor
[image]

Initializes a new instance of the XmlElementCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XmlElementCollection()
C++
public:
XmlElementCollection() sealed
J#
public XmlElementCollection()
JScript
public function XmlElementCollection()

See Also

XmlElementCollection Class


Properties

XmlElementCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

XmlElementCollection Class


Item Property

XmlElementCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As XmlElement
C#
public XmlElement this[
int idx
] { get; set; }
C++
public property XmlElement default[int idx] sealed {
XmlElement get(int idx);
void set(int idx, XmlElement value);
}
J#
/** property */
public XmlElement get_Item(int idx);

/** property */
public void set_Item(int idx, XmlElement value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

XmlElementCollection Class


Methods

XmlElementCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XmlElementCollection Class


Add Method

XmlElementCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As XmlElement _
) As Integer
C#
public int Add(
XmlElement value
)
C++
public:
int Add(
XmlElement value
) sealed
J#
public int Add(
XmlElement value
)
JScript
public function Add(
value : XmlElement
) : int

See Also

XmlElementCollection Class


XMLValidator Class

XMLValidator Class
See Also Example Members
[image]

Class that makes XSD validation

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class XMLValidator
C#
public class XMLValidator
C++
ref class XMLValidator
J#
public class XMLValidator
JScript
public class XMLValidator

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.XMLValidator

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XMLValidator Members


XMLValidator Members

XMLValidator Members
See Also Example Constructors Methods
[image]

Class that makes XSD validation

The following tables list the members exposed by XMLValidator.

Public Constructors

 | Name | Description
Public method | XMLValidator | Initializes a new instance of the XMLValidator class.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Validate |
Public method | ValidationHandler |
Top

See Also

XMLValidator Class


XMLValidator Constructor

XMLValidator Constructor
[image]

Initializes a new instance of the XMLValidator class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XMLValidator()
C++
public:
XMLValidator() sealed
J#
public XMLValidator()
JScript
public function XMLValidator()

See Also

XMLValidator Class


Methods

XMLValidator Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Validate |
Public method | ValidationHandler |
Top

See Also

XMLValidator Class


Validate Method

XMLValidator.Validate Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Validate( _
ByVal xml As Stream, _
ByVal xsd As XmlSchema _
)
C#
public void Validate(
Stream xml,
XmlSchema xsd
)
C++
public:
void Validate(
Stream xml,
XmlSchema xsd
) sealed
J#
public void Validate(
Stream xml,
XmlSchema xsd
)
JScript
public function Validate(
xml : Stream,
xsd : XmlSchema
)

See Also

XMLValidator Class


ValidationHandler Method

XMLValidator.ValidationHandler Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub ValidationHandler( _
ByVal sender As Object, _
ByVal args As ValidationEventArgs _
)
C#
public void ValidationHandler(
object sender,
ValidationEventArgs args
)
C++
public:
void ValidationHandler(
Object sender,
ValidationEventArgs args
) sealed
J#
public void ValidationHandler(
object sender,
ValidationEventArgs args
)
JScript
public function ValidationHandler(
sender : Object,
args : ValidationEventArgs
)

See Also

XMLValidator Class


ZoomControlType Class

ZoomControlType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class ZoomControlType
Inherits WebLayoutControlType
C#
public class ZoomControlType : WebLayoutControlType
C++
ref class ZoomControlType : WebLayoutControlType
J#
public class ZoomControlType extends WebLayoutControlType
JScript
public class ZoomControlType extends WebLayoutControlType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.WebLayoutControlType
OSGeo.MapGuide.MaestroAPI.ZoomControlType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ZoomControlType Members


ZoomControlType Members

ZoomControlType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ZoomControlType.

Public Constructors

 | Name | Description
Public method | ZoomControlType | Initializes a new instance of the ZoomControlType class.
Top

Public Properties

 | Name | Description
Public property | Visible | (inherited from WebLayoutControlType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ZoomControlType Class


ZoomControlType Constructor

ZoomControlType Constructor
[image]

Initializes a new instance of the ZoomControlType class.

Namespace: OSGeo.MapGuide.MaestroAPI
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ZoomControlType()
C++
public:
ZoomControlType() sealed
J#
public ZoomControlType()
JScript
public function ZoomControlType()

See Also

ZoomControlType Class


OSGeo.MapGuide.MaestroAPI.ApplicationDefinition

OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | ApplicationDefinitionType |
Public class | ContainerType |
Public class | ContainerTypeCollection |
Public class | CustomContentType |
Public class | FlyoutItemType |
Public class | MapGroupType |
Public class | MapGroupTypeCollection |
Public class | MapType |
Public class | MapTypeCollection |
Public class | MapViewType |
Public class | MapWidgetType |
Public class | SeparatorItemType |
Public class | UiItemContainerType |
Public class | UiItemType |
Public class | UiItemTypeCollection |
Public class | UiWidgetType |
Public class | WidgetItemType |
Public class | WidgetSetType |
Public class | WidgetSetTypeCollection |
Public class | WidgetType |
Public class | WidgetTypeCollection |
Public class | XmlElementCollection |

Enumerations

 | Enumeration | Description
Public enumeration | UiItemFunctionType |


ApplicationDefinitionType Class

ApplicationDefinitionType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlRootAttribute("ApplicationDefinition", Namespace := "", IsNullable := False)>
Public Class ApplicationDefinitionType
C#
[XmlRootAttribute("ApplicationDefinition", Namespace = "", IsNullable = False)]
public class ApplicationDefinitionType
C++
[XmlRootAttribute(L"ApplicationDefinition", Namespace = L"", IsNullable = False)]
ref class ApplicationDefinitionType
J#
/** @attribute XmlRootAttribute("ApplicationDefinition", Namespace = "", IsNullable = False) */
public class ApplicationDefinitionType
JScript
public
XmlRootAttribute("ApplicationDefinition", Namespace = "", IsNullable = False)
class ApplicationDefinitionType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.ApplicationDefinitionType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ApplicationDefinitionType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ApplicationDefinitionType Members

ApplicationDefinitionType Members
See Also Example Constructors Fields Properties Methods
[image]

The following tables list the members exposed by ApplicationDefinitionType.

Public Constructors

 | Name | Description
Public method | ApplicationDefinitionType | Initializes a new instance of the ApplicationDefinitionType class.
Top

Public Fields

Name | Description
SchemaName |
Top

Public Properties

 | Name | Description
Public property | ApplicationDocument | Gets the Application Document, used to create new extension elements
Public property | Extension |
Public property | MapSet |
Public property | ResourceId |
Public property | TemplateUrl |
Public property | Title |
Public property | WidgetSet |
Public property | XsdSchema |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ApplicationDefinitionType Constructor

ApplicationDefinitionType Constructor
[image]

Initializes a new instance of the ApplicationDefinitionType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ApplicationDefinitionType()
C++
public:
ApplicationDefinitionType() sealed
J#
public ApplicationDefinitionType()
JScript
public function ApplicationDefinitionType()

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Fields

ApplicationDefinitionType Fields
[image]

Public Fields

Name | Description
SchemaName |
Top

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


SchemaName Field

ApplicationDefinitionType.SchemaName Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SchemaName As String
C#
public static readonly string SchemaName;
C++
public:
static const String SchemaName;
J#
public static final string SchemaName
JScript
public static const var SchemaName : String;

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

ApplicationDefinitionType Properties
[image]

Public Properties

 | Name | Description
Public property | ApplicationDocument | Gets the Application Document, used to create new extension elements
Public property | Extension |
Public property | MapSet |
Public property | ResourceId |
Public property | TemplateUrl |
Public property | Title |
Public property | WidgetSet |
Public property | XsdSchema |
Top

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ApplicationDocument Property

ApplicationDefinitionType.ApplicationDocument Property
[image]

Gets the Application Document, used to create new extension elements

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public ReadOnly Property ApplicationDocument As XmlDocument
C#
[XmlIgnoreAttribute]
public XmlDocument ApplicationDocument { get; }
C++
[XmlIgnoreAttribute]
public property XmlDocument ApplicationDocument sealed {
XmlDocument get();
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public XmlDocument get_ApplicationDocument();
JScript
public function get ApplicationDocument() : XmlDocument

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Extension Property

ApplicationDefinitionType.Extension Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Extension As CustomContentType
C#
public CustomContentType Extension { get; set; }
C++
public property CustomContentType Extension sealed {
CustomContentType get();
void set(CustomContentType value);
}
J#
/** property */
public CustomContentType get_Extension();

/** property */
public void set_Extension(CustomContentType value);
JScript
public function get Extension() : CustomContentType

public function set Extension(value : CustomContentType);

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapSet Property

ApplicationDefinitionType.MapSet Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlArrayItemAttribute("MapGroup", IsNullable := False)>
Public Property MapSet As MapGroupTypeCollection
C#
[XmlArrayItemAttribute("MapGroup", IsNullable = False)]
public MapGroupTypeCollection MapSet { get; set; }
C++
[XmlArrayItemAttribute(L"MapGroup", IsNullable = False)]
public property MapGroupTypeCollection MapSet sealed {
MapGroupTypeCollection get();
void set(MapGroupTypeCollection value);
}
J#
/** @attribute XmlArrayItemAttribute("MapGroup", IsNullable = False) */
/** property */
public MapGroupTypeCollection get_MapSet();

/** property */
public void set_MapSet(MapGroupTypeCollection value);
JScript
public function get MapSet() : MapGroupTypeCollection

public function set MapSet(value : MapGroupTypeCollection);

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ResourceId Property

ApplicationDefinitionType.ResourceId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property ResourceId As String
C#
[XmlIgnoreAttribute]
public string ResourceId { get; set; }
C++
[XmlIgnoreAttribute]
public property string ResourceId sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public string get_ResourceId();

/** property */
public void set_ResourceId(string value);
JScript
public function get ResourceId() : String

public function set ResourceId(value : String);

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


TemplateUrl Property

ApplicationDefinitionType.TemplateUrl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property TemplateUrl As String
C#
public string TemplateUrl { get; set; }
C++
public property string TemplateUrl sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_TemplateUrl();

/** property */
public void set_TemplateUrl(string value);
JScript
public function get TemplateUrl() : String

public function set TemplateUrl(value : String);

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Title Property

ApplicationDefinitionType.Title Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title { get; set; }
C++
public property string Title sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Title();

/** property */
public void set_Title(string value);
JScript
public function get Title() : String

public function set Title(value : String);

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetSet Property

ApplicationDefinitionType.WidgetSet Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("WidgetSet")>
Public Property WidgetSet As WidgetSetTypeCollection
C#
[XmlElementAttribute("WidgetSet")]
public WidgetSetTypeCollection WidgetSet { get; set; }
C++
[XmlElementAttribute(L"WidgetSet")]
public property WidgetSetTypeCollection WidgetSet sealed {
WidgetSetTypeCollection get();
void set(WidgetSetTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("WidgetSet") */
/** property */
public WidgetSetTypeCollection get_WidgetSet();

/** property */
public void set_WidgetSet(WidgetSetTypeCollection value);
JScript
public function get WidgetSet() : WidgetSetTypeCollection

public function set WidgetSet(value : WidgetSetTypeCollection);

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


XsdSchema Property

ApplicationDefinitionType.XsdSchema Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace := "http://www.w3.org/2001/XMLSchema-instance")>
Public Property XsdSchema As String
C#
[XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance")]
public string XsdSchema { get; set; }
C++
[XmlAttributeAttribute(L"noNamespaceSchemaLocation", Namespace = L"http://www.w3.org/2001/XMLSchema-instance")]
public property string XsdSchema sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute("noNamespaceSchemaLocation", Namespace = "http://www.w3.org/2001/XMLSchema-instance") */
/** property */
public string get_XsdSchema();

/** property */
public void set_XsdSchema(string value);
JScript
public function get XsdSchema() : String

public function set XsdSchema(value : String);

See Also

ApplicationDefinitionType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ContainerType Class

ContainerType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(UiItemContainerType))>
Public Class ContainerType
C#
[XmlIncludeAttribute(typeof(UiItemContainerType))]
public class ContainerType
C++
[XmlIncludeAttribute(typeof(UiItemContainerType))]
ref class ContainerType
J#
/** @attribute XmlIncludeAttribute(typeof(UiItemContainerType)) */
public class ContainerType
JScript
public
XmlIncludeAttribute(typeof(UiItemContainerType))
class ContainerType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.ContainerType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiItemContainerType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ContainerType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ContainerType Members

ContainerType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ContainerType.

Public Constructors

 | Name | Description
Public method | ContainerType | Initializes a new instance of the ContainerType class.
Top

Public Properties

 | Name | Description
Public property | Extension |
Public property | Name |
Public property | Position |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ContainerType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ContainerType Constructor

ContainerType Constructor
[image]

Initializes a new instance of the ContainerType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ContainerType()
C++
public:
ContainerType() sealed
J#
public ContainerType()
JScript
public function ContainerType()

See Also

ContainerType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

ContainerType Properties
[image]

Public Properties

 | Name | Description
Public property | Extension |
Public property | Name |
Public property | Position |
Public property | Type |
Top

See Also

ContainerType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Extension Property

ContainerType.Extension Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Extension As CustomContentType
C#
public CustomContentType Extension { get; set; }
C++
public property CustomContentType Extension sealed {
CustomContentType get();
void set(CustomContentType value);
}
J#
/** property */
public CustomContentType get_Extension();

/** property */
public void set_Extension(CustomContentType value);
JScript
public function get Extension() : CustomContentType

public function set Extension(value : CustomContentType);

See Also

ContainerType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Name Property

ContainerType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

ContainerType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Position Property

ContainerType.Position Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Position As String
C#
public string Position { get; set; }
C++
public property string Position sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Position();

/** property */
public void set_Position(string value);
JScript
public function get Position() : String

public function set Position(value : String);

See Also

ContainerType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Type Property

ContainerType.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
C++
public property string Type sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Type();

/** property */
public void set_Type(string value);
JScript
public function get Type() : String

public function set Type(value : String);

See Also

ContainerType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ContainerTypeCollection Class

ContainerTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ContainerTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class ContainerTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class ContainerTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class ContainerTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class ContainerTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.ContainerTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ContainerTypeCollection Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ContainerTypeCollection Members

ContainerTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by ContainerTypeCollection.

Public Constructors

 | Name | Description
Public method | ContainerTypeCollection | Initializes a new instance of the ContainerTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | Insert |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ContainerTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ContainerTypeCollection Constructor

ContainerTypeCollection Constructor
[image]

Initializes a new instance of the ContainerTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ContainerTypeCollection()
C++
public:
ContainerTypeCollection() sealed
J#
public ContainerTypeCollection()
JScript
public function ContainerTypeCollection()

See Also

ContainerTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

ContainerTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

ContainerTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Item Property

ContainerTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As ContainerType
C#
public ContainerType this[
int idx
] { get; set; }
C++
public property ContainerType default[int idx] sealed {
ContainerType get(int idx);
void set(int idx, ContainerType value);
}
J#
/** property */
public ContainerType get_Item(int idx);

/** property */
public void set_Item(int idx, ContainerType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

ContainerTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Methods

ContainerTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Contains |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | Insert |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ContainerTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Add Method

ContainerTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As ContainerType _
) As Integer
C#
public int Add(
ContainerType value
)
C++
public:
int Add(
ContainerType value
) sealed
J#
public int Add(
ContainerType value
)
JScript
public function Add(
value : ContainerType
) : int

See Also

ContainerTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Contains Method

ContainerTypeCollection.Contains Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal value As ContainerType _
) As Boolean
C#
public bool Contains(
ContainerType value
)
C++
public:
bool Contains(
ContainerType value
) sealed
J#
public bool Contains(
ContainerType value
)
JScript
public function Contains(
value : ContainerType
) : bool

See Also

ContainerTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


IndexOf Method

ContainerTypeCollection.IndexOf Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
ByVal value As ContainerType _
) As Integer
C#
public int IndexOf(
ContainerType value
)
C++
public:
int IndexOf(
ContainerType value
) sealed
J#
public int IndexOf(
ContainerType value
)
JScript
public function IndexOf(
value : ContainerType
) : int

See Also

ContainerTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Insert Method

ContainerTypeCollection.Insert Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As ContainerType _
)
C#
public void Insert(
int index,
ContainerType value
)
C++
public:
void Insert(
int index,
ContainerType value
) sealed
J#
public void Insert(
int index,
ContainerType value
)
JScript
public function Insert(
index : int,
value : ContainerType
)

See Also

ContainerTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


CustomContentType Class

CustomContentType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class CustomContentType
C#
[DefaultMemberAttribute("Item")]
public class CustomContentType
C++
[DefaultMemberAttribute(L"Item")]
ref class CustomContentType
J#
/** @attribute DefaultMemberAttribute("Item") */
public class CustomContentType
JScript
public
DefaultMemberAttribute("Item")
class CustomContentType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.CustomContentType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CustomContentType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


CustomContentType Members

CustomContentType Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by CustomContentType.

Public Constructors

Name | Description
CustomContentType | Overloaded. Initializes a new instance of the CustomContentType class.
Top

Public Properties

 | Name | Description
Public property | Any |
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
CustomContentType | Overloaded. Initializes a new instance of the CustomContentType class.
Top

See Also

CustomContentType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


CustomContentType Constructor

CustomContentType Constructor

Initializes a new instance of the CustomContentType class.

Overload List

 | Name | Description
Public method | CustomContentType | Initializes a new instance of the CustomContentType class.
Public method | CustomContentType (XmlElementCollection) |

See Also

CustomContentType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


CustomContentType Constructor ()

CustomContentType Constructor ()
See Also Example
[image]

Initializes a new instance of the CustomContentType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CustomContentType()
C++
public:
CustomContentType() sealed
J#
public CustomContentType()
JScript
public function CustomContentType()

See Also

CustomContentType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace
CustomContentType Constructor Overload List


CustomContentType Constructor (XmlElementCollection)

CustomContentType Constructor (XmlElementCollection)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal col As XmlElementCollection _
)
C#
public CustomContentType(
XmlElementCollection col
)
C++
public:
CustomContentType(
XmlElementCollection col
) sealed
J#
public CustomContentType(
XmlElementCollection col
)
JScript
public function CustomContentType(
col : XmlElementCollection
)

See Also

CustomContentType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace
CustomContentType Constructor Overload List


Properties

CustomContentType Properties
[image]

Public Properties

 | Name | Description
Public property | Any |
Public property | Item |
Top

See Also

CustomContentType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Any Property

CustomContentType.Any Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAnyElementAttribute>
Public Property Any As XmlElement()
C#
[XmlAnyElementAttribute]
public XmlElement[] Any { get; set; }
C++
[XmlAnyElementAttribute]
public property XmlElement[] Any sealed {
array<XmlElement>^ get();
void set(array<XmlElement>^ value);
}
J#
/** @attribute XmlAnyElementAttribute() */
/** property */
public XmlElement[] get_Any();

/** property */
public void set_Any(XmlElement[] value);
JScript
public function get Any() : XmlElement[]

public function set Any(value : XmlElement[]);

See Also

CustomContentType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Item Property

CustomContentType.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Default Property Item( _
ByVal elementname As String _
) As String
C#
[XmlIgnoreAttribute]
public string this[
string elementname
] { get; set; }
C++
[XmlIgnoreAttribute]
public property string default[String elementname] sealed {
String get(String elementname);
void set(String elementname, String value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public string get_Item(string elementname);

/** property */
public void set_Item(string elementname, string value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

CustomContentType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


FlyoutItemType Class

FlyoutItemType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class FlyoutItemType
Inherits UiItemType
C#
public class FlyoutItemType : UiItemType
C++
ref class FlyoutItemType : UiItemType
J#
public class FlyoutItemType extends UiItemType
JScript
public class FlyoutItemType extends UiItemType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiItemType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.FlyoutItemType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

FlyoutItemType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


FlyoutItemType Members

FlyoutItemType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by FlyoutItemType.

Public Constructors

 | Name | Description
Public method | FlyoutItemType | Initializes a new instance of the FlyoutItemType class.
Top

Public Properties

 | Name | Description
Public property | Function | (inherited from UiItemType)
Public property | ImageClass |
Public property | ImageUrl |
Public property | Item |
Public property | Label |
Public property | Tooltip |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

FlyoutItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


FlyoutItemType Constructor

FlyoutItemType Constructor
[image]

Initializes a new instance of the FlyoutItemType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public FlyoutItemType()
C++
public:
FlyoutItemType() sealed
J#
public FlyoutItemType()
JScript
public function FlyoutItemType()

See Also

FlyoutItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

FlyoutItemType Properties
[image]

Public Properties

 | Name | Description
Public property | Function | (inherited from UiItemType)
Public property | ImageClass |
Public property | ImageUrl |
Public property | Item |
Public property | Label |
Public property | Tooltip |
Top

See Also

FlyoutItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ImageClass Property

FlyoutItemType.ImageClass Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageClass As String
C#
public string ImageClass { get; set; }
C++
public property string ImageClass sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ImageClass();

/** property */
public void set_ImageClass(string value);
JScript
public function get ImageClass() : String

public function set ImageClass(value : String);

See Also

FlyoutItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ImageUrl Property

FlyoutItemType.ImageUrl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageUrl As String
C#
public string ImageUrl { get; set; }
C++
public property string ImageUrl sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ImageUrl();

/** property */
public void set_ImageUrl(string value);
JScript
public function get ImageUrl() : String

public function set ImageUrl(value : String);

See Also

FlyoutItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Item Property

FlyoutItemType.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Item")>
Public Property Item As UiItemTypeCollection
C#
[XmlElementAttribute("Item")]
public UiItemTypeCollection Item { get; set; }
C++
[XmlElementAttribute(L"Item")]
public property UiItemTypeCollection Item sealed {
UiItemTypeCollection get();
void set(UiItemTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("Item") */
/** property */
public UiItemTypeCollection get_Item();

/** property */
public void set_Item(UiItemTypeCollection value);
JScript
public function get Item() : UiItemTypeCollection

public function set Item(value : UiItemTypeCollection);

See Also

FlyoutItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Label Property

FlyoutItemType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label { get; set; }
C++
public property string Label sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Label();

/** property */
public void set_Label(string value);
JScript
public function get Label() : String

public function set Label(value : String);

See Also

FlyoutItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Tooltip Property

FlyoutItemType.Tooltip Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Tooltip As String
C#
public string Tooltip { get; set; }
C++
public property string Tooltip sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Tooltip();

/** property */
public void set_Tooltip(string value);
JScript
public function get Tooltip() : String

public function set Tooltip(value : String);

See Also

FlyoutItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapGroupType Class

MapGroupType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MapGroupType
C#
public class MapGroupType
C++
ref class MapGroupType
J#
public class MapGroupType
JScript
public class MapGroupType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapGroupType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapGroupType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapGroupType Members

MapGroupType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapGroupType.

Public Constructors

 | Name | Description
Public method | MapGroupType | Initializes a new instance of the MapGroupType class.
Top

Public Properties

 | Name | Description
Public property | Extension |
Public property | id |
Public property | InitialView |
Public property | Map |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapGroupType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapGroupType Constructor

MapGroupType Constructor
[image]

Initializes a new instance of the MapGroupType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapGroupType()
C++
public:
MapGroupType() sealed
J#
public MapGroupType()
JScript
public function MapGroupType()

See Also

MapGroupType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

MapGroupType Properties
[image]

Public Properties

 | Name | Description
Public property | Extension |
Public property | id |
Public property | InitialView |
Public property | Map |
Top

See Also

MapGroupType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Extension Property

MapGroupType.Extension Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Extension As CustomContentType
C#
public CustomContentType Extension { get; set; }
C++
public property CustomContentType Extension sealed {
CustomContentType get();
void set(CustomContentType value);
}
J#
/** property */
public CustomContentType get_Extension();

/** property */
public void set_Extension(CustomContentType value);
JScript
public function get Extension() : CustomContentType

public function set Extension(value : CustomContentType);

See Also

MapGroupType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


id Property

MapGroupType.id Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlAttributeAttribute>
Public Property id As String
C#
[XmlAttributeAttribute]
public string id { get; set; }
C++
[XmlAttributeAttribute]
public property string id sealed {
String get();
void set(String value);
}
J#
/** @attribute XmlAttributeAttribute() */
/** property */
public string get_id();

/** property */
public void set_id(string value);
JScript
public function get id() : String

public function set id(value : String);

See Also

MapGroupType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


InitialView Property

MapGroupType.InitialView Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property InitialView As MapViewType
C#
public MapViewType InitialView { get; set; }
C++
public property MapViewType InitialView sealed {
MapViewType get();
void set(MapViewType value);
}
J#
/** property */
public MapViewType get_InitialView();

/** property */
public void set_InitialView(MapViewType value);
JScript
public function get InitialView() : MapViewType

public function set InitialView(value : MapViewType);

See Also

MapGroupType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Map Property

MapGroupType.Map Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Map")>
Public Property Map As MapTypeCollection
C#
[XmlElementAttribute("Map")]
public MapTypeCollection Map { get; set; }
C++
[XmlElementAttribute(L"Map")]
public property MapTypeCollection Map sealed {
MapTypeCollection get();
void set(MapTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("Map") */
/** property */
public MapTypeCollection get_Map();

/** property */
public void set_Map(MapTypeCollection value);
JScript
public function get Map() : MapTypeCollection

public function set Map(value : MapTypeCollection);

See Also

MapGroupType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapGroupTypeCollection Class

MapGroupTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class MapGroupTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class MapGroupTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class MapGroupTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class MapGroupTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class MapGroupTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapGroupTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapGroupTypeCollection Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapGroupTypeCollection Members

MapGroupTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapGroupTypeCollection.

Public Constructors

 | Name | Description
Public method | MapGroupTypeCollection | Initializes a new instance of the MapGroupTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapGroupTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapGroupTypeCollection Constructor

MapGroupTypeCollection Constructor
[image]

Initializes a new instance of the MapGroupTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapGroupTypeCollection()
C++
public:
MapGroupTypeCollection() sealed
J#
public MapGroupTypeCollection()
JScript
public function MapGroupTypeCollection()

See Also

MapGroupTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

MapGroupTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

MapGroupTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Item Property

MapGroupTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As MapGroupType
C#
public MapGroupType this[
int idx
] { get; set; }
C++
public property MapGroupType default[int idx] sealed {
MapGroupType get(int idx);
void set(int idx, MapGroupType value);
}
J#
/** property */
public MapGroupType get_Item(int idx);

/** property */
public void set_Item(int idx, MapGroupType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

MapGroupTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Methods

MapGroupTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapGroupTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Add Method

MapGroupTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As MapGroupType _
) As Integer
C#
public int Add(
MapGroupType value
)
C++
public:
int Add(
MapGroupType value
) sealed
J#
public int Add(
MapGroupType value
)
JScript
public function Add(
value : MapGroupType
) : int

See Also

MapGroupTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapType Class

MapType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MapType
C#
public class MapType
C++
ref class MapType
J#
public class MapType
JScript
public class MapType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapType Members

MapType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapType.

Public Constructors

 | Name | Description
Public method | MapType | Initializes a new instance of the MapType class.
Top

Public Properties

 | Name | Description
Public property | Extension |
Public property | SingleTile |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapType Constructor

MapType Constructor
[image]

Initializes a new instance of the MapType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapType()
C++
public:
MapType() sealed
J#
public MapType()
JScript
public function MapType()

See Also

MapType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

MapType Properties
[image]

Public Properties

 | Name | Description
Public property | Extension |
Public property | SingleTile |
Public property | Type |
Top

See Also

MapType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Extension Property

MapType.Extension Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Extension As CustomContentType
C#
public CustomContentType Extension { get; set; }
C++
public property CustomContentType Extension sealed {
CustomContentType get();
void set(CustomContentType value);
}
J#
/** property */
public CustomContentType get_Extension();

/** property */
public void set_Extension(CustomContentType value);
JScript
public function get Extension() : CustomContentType

public function set Extension(value : CustomContentType);

See Also

MapType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


SingleTile Property

MapType.SingleTile Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SingleTile As String
C#
public string SingleTile { get; set; }
C++
public property string SingleTile sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SingleTile();

/** property */
public void set_SingleTile(string value);
JScript
public function get SingleTile() : String

public function set SingleTile(value : String);

See Also

MapType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Type Property

MapType.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
C++
public property string Type sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Type();

/** property */
public void set_Type(string value);
JScript
public function get Type() : String

public function set Type(value : String);

See Also

MapType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapTypeCollection Class

MapTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class MapTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class MapTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class MapTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class MapTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class MapTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapTypeCollection Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapTypeCollection Members

MapTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapTypeCollection.

Public Constructors

 | Name | Description
Public method | MapTypeCollection | Initializes a new instance of the MapTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapTypeCollection Constructor

MapTypeCollection Constructor
[image]

Initializes a new instance of the MapTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapTypeCollection()
C++
public:
MapTypeCollection() sealed
J#
public MapTypeCollection()
JScript
public function MapTypeCollection()

See Also

MapTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

MapTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

MapTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Item Property

MapTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As MapType
C#
public MapType this[
int idx
] { get; set; }
C++
public property MapType default[int idx] sealed {
MapType get(int idx);
void set(int idx, MapType value);
}
J#
/** property */
public MapType get_Item(int idx);

/** property */
public void set_Item(int idx, MapType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

MapTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Methods

MapTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Add Method

MapTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As MapType _
) As Integer
C#
public int Add(
MapType value
)
C++
public:
int Add(
MapType value
) sealed
J#
public int Add(
MapType value
)
JScript
public function Add(
value : MapType
) : int

See Also

MapTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapViewType Class

MapViewType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MapViewType
C#
public class MapViewType
C++
ref class MapViewType
J#
public class MapViewType
JScript
public class MapViewType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapViewType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapViewType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapViewType Members

MapViewType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapViewType.

Public Constructors

 | Name | Description
Public method | MapViewType | Initializes a new instance of the MapViewType class.
Top

Public Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | Scale |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapViewType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapViewType Constructor

MapViewType Constructor
[image]

Initializes a new instance of the MapViewType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapViewType()
C++
public:
MapViewType() sealed
J#
public MapViewType()
JScript
public function MapViewType()

See Also

MapViewType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

MapViewType Properties
[image]

Public Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | Scale |
Top

See Also

MapViewType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


CenterX Property

MapViewType.CenterX Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CenterX As Double
C#
public double CenterX { get; set; }
C++
public property double CenterX sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_CenterX();

/** property */
public void set_CenterX(double value);
JScript
public function get CenterX() : double

public function set CenterX(value : double);

See Also

MapViewType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


CenterY Property

MapViewType.CenterY Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property CenterY As Double
C#
public double CenterY { get; set; }
C++
public property double CenterY sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_CenterY();

/** property */
public void set_CenterY(double value);
JScript
public function get CenterY() : double

public function set CenterY(value : double);

See Also

MapViewType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Scale Property

MapViewType.Scale Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Double
C#
public double Scale { get; set; }
C++
public property double Scale sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Scale();

/** property */
public void set_Scale(double value);
JScript
public function get Scale() : double

public function set Scale(value : double);

See Also

MapViewType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapWidgetType Class

MapWidgetType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MapWidgetType
Inherits WidgetType
C#
public class MapWidgetType : WidgetType
C++
ref class MapWidgetType : WidgetType
J#
public class MapWidgetType extends WidgetType
JScript
public class MapWidgetType extends WidgetType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapWidgetType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MapWidgetType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapWidgetType Members

MapWidgetType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by MapWidgetType.

Public Constructors

 | Name | Description
Public method | MapWidgetType | Initializes a new instance of the MapWidgetType class.
Top

Public Properties

 | Name | Description
Public property | Extension | (inherited from WidgetType)
Public property | Location | (inherited from WidgetType)
Public property | MapId |
Public property | Name | (inherited from WidgetType)
Public property | Type | (inherited from WidgetType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MapWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapWidgetType Constructor

MapWidgetType Constructor
[image]

Initializes a new instance of the MapWidgetType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public MapWidgetType()
C++
public:
MapWidgetType() sealed
J#
public MapWidgetType()
JScript
public function MapWidgetType()

See Also

MapWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

MapWidgetType Properties
[image]

Public Properties

 | Name | Description
Public property | Extension | (inherited from WidgetType)
Public property | Location | (inherited from WidgetType)
Public property | MapId |
Public property | Name | (inherited from WidgetType)
Public property | Type | (inherited from WidgetType)
Top

See Also

MapWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapId Property

MapWidgetType.MapId Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MapId As String
C#
public string MapId { get; set; }
C++
public property string MapId sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_MapId();

/** property */
public void set_MapId(string value);
JScript
public function get MapId() : String

public function set MapId(value : String);

See Also

MapWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


SeparatorItemType Class

SeparatorItemType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class SeparatorItemType
Inherits UiItemType
C#
public class SeparatorItemType : UiItemType
C++
ref class SeparatorItemType : UiItemType
J#
public class SeparatorItemType extends UiItemType
JScript
public class SeparatorItemType extends UiItemType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiItemType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.SeparatorItemType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SeparatorItemType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


SeparatorItemType Members

SeparatorItemType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SeparatorItemType.

Public Constructors

 | Name | Description
Public method | SeparatorItemType | Initializes a new instance of the SeparatorItemType class.
Top

Public Properties

 | Name | Description
Public property | Function | (inherited from UiItemType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

SeparatorItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


SeparatorItemType Constructor

SeparatorItemType Constructor
[image]

Initializes a new instance of the SeparatorItemType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SeparatorItemType()
C++
public:
SeparatorItemType() sealed
J#
public SeparatorItemType()
JScript
public function SeparatorItemType()

See Also

SeparatorItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiItemContainerType Class

UiItemContainerType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UiItemContainerType
Inherits ContainerType
C#
public class UiItemContainerType : ContainerType
C++
ref class UiItemContainerType : ContainerType
J#
public class UiItemContainerType extends ContainerType
JScript
public class UiItemContainerType extends ContainerType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.ContainerType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiItemContainerType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UiItemContainerType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiItemContainerType Members

UiItemContainerType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UiItemContainerType.

Public Constructors

 | Name | Description
Public method | UiItemContainerType | Initializes a new instance of the UiItemContainerType class.
Top

Public Properties

 | Name | Description
Public property | Extension | (inherited from ContainerType)
Public property | Item |
Public property | Name | (inherited from ContainerType)
Public property | Position | (inherited from ContainerType)
Public property | Type | (inherited from ContainerType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UiItemContainerType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiItemContainerType Constructor

UiItemContainerType Constructor
[image]

Initializes a new instance of the UiItemContainerType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UiItemContainerType()
C++
public:
UiItemContainerType() sealed
J#
public UiItemContainerType()
JScript
public function UiItemContainerType()

See Also

UiItemContainerType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

UiItemContainerType Properties
[image]

Public Properties

 | Name | Description
Public property | Extension | (inherited from ContainerType)
Public property | Item |
Public property | Name | (inherited from ContainerType)
Public property | Position | (inherited from ContainerType)
Public property | Type | (inherited from ContainerType)
Top

See Also

UiItemContainerType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Item Property

UiItemContainerType.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Item")>
Public Property Item As UiItemTypeCollection
C#
[XmlElementAttribute("Item")]
public UiItemTypeCollection Item { get; set; }
C++
[XmlElementAttribute(L"Item")]
public property UiItemTypeCollection Item sealed {
UiItemTypeCollection get();
void set(UiItemTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("Item") */
/** property */
public UiItemTypeCollection get_Item();

/** property */
public void set_Item(UiItemTypeCollection value);
JScript
public function get Item() : UiItemTypeCollection

public function set Item(value : UiItemTypeCollection);

See Also

UiItemContainerType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiItemFunctionType Enumeration

UiItemFunctionType Enumeration
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Enum UiItemFunctionType
C#
public enum UiItemFunctionType
C++
public enum class UiItemFunctionType
J#
public enum UiItemFunctionType
JScript
public enum UiItemFunctionType

Members

Member Name | Description
Separator |
Widget |
Flyout |

See Also

OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiItemType Class

UiItemType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(WidgetItemType)), _
XmlIncludeAttribute(GetType(FlyoutItemType)), _
XmlIncludeAttribute(GetType(SeparatorItemType))>
Public MustInherit Class UiItemType
C#
[XmlIncludeAttribute(typeof(WidgetItemType))]
[XmlIncludeAttribute(typeof(FlyoutItemType))]
[XmlIncludeAttribute(typeof(SeparatorItemType))]
public abstract class UiItemType
C++
[XmlIncludeAttribute(typeof(WidgetItemType))]
[XmlIncludeAttribute(typeof(FlyoutItemType))]
[XmlIncludeAttribute(typeof(SeparatorItemType))]
ref class UiItemType abstract
J#
/** @attribute XmlIncludeAttribute(typeof(WidgetItemType)) */
/** @attribute XmlIncludeAttribute(typeof(FlyoutItemType)) */
/** @attribute XmlIncludeAttribute(typeof(SeparatorItemType)) */
public class UiItemType
JScript
public
XmlIncludeAttribute(typeof(WidgetItemType))
XmlIncludeAttribute(typeof(FlyoutItemType))
XmlIncludeAttribute(typeof(SeparatorItemType))
class UiItemType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiItemType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.FlyoutItemType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.SeparatorItemType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetItemType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UiItemType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiItemType Members

UiItemType Members
See Also Example Properties Methods
[image]

The following tables list the members exposed by UiItemType.

Public Properties

 | Name | Description
Public property | Function |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UiItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

UiItemType Properties
[image]

Public Properties

 | Name | Description
Public property | Function |
Top

See Also

UiItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Function Property

UiItemType.Function Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Function As UiItemFunctionType
C#
public UiItemFunctionType Function { get; set; }
C++
public property UiItemFunctionType Function sealed {
UiItemFunctionType get();
void set(UiItemFunctionType value);
}
J#
/** property */
public UiItemFunctionType get_Function();

/** property */
public void set_Function(UiItemFunctionType value);
JScript
public function get Function() : UiItemFunctionType

public function set Function(value : UiItemFunctionType);

See Also

UiItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiItemTypeCollection Class

UiItemTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class UiItemTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class UiItemTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class UiItemTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class UiItemTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class UiItemTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiItemTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UiItemTypeCollection Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiItemTypeCollection Members

UiItemTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UiItemTypeCollection.

Public Constructors

 | Name | Description
Public method | UiItemTypeCollection | Initializes a new instance of the UiItemTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | Insert |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UiItemTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiItemTypeCollection Constructor

UiItemTypeCollection Constructor
[image]

Initializes a new instance of the UiItemTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UiItemTypeCollection()
C++
public:
UiItemTypeCollection() sealed
J#
public UiItemTypeCollection()
JScript
public function UiItemTypeCollection()

See Also

UiItemTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

UiItemTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

UiItemTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Item Property

UiItemTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As UiItemType
C#
public UiItemType this[
int idx
] { get; set; }
C++
public property UiItemType default[int idx] sealed {
UiItemType get(int idx);
void set(int idx, UiItemType value);
}
J#
/** property */
public UiItemType get_Item(int idx);

/** property */
public void set_Item(int idx, UiItemType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

UiItemTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Methods

UiItemTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf |
Public method | Insert |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UiItemTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Add Method

UiItemTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As UiItemType _
) As Integer
C#
public int Add(
UiItemType value
)
C++
public:
int Add(
UiItemType value
) sealed
J#
public int Add(
UiItemType value
)
JScript
public function Add(
value : UiItemType
) : int

See Also

UiItemTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


IndexOf Method

UiItemTypeCollection.IndexOf Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
ByVal value As UiItemType _
) As Integer
C#
public int IndexOf(
UiItemType value
)
C++
public:
int IndexOf(
UiItemType value
) sealed
J#
public int IndexOf(
UiItemType value
)
JScript
public function IndexOf(
value : UiItemType
) : int

See Also

UiItemTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Insert Method

UiItemTypeCollection.Insert Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
ByVal index As Integer, _
ByVal value As UiItemType _
)
C#
public void Insert(
int index,
UiItemType value
)
C++
public:
void Insert(
int index,
UiItemType value
) sealed
J#
public void Insert(
int index,
UiItemType value
)
JScript
public function Insert(
index : int,
value : UiItemType
)

See Also

UiItemTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiWidgetType Class

UiWidgetType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class UiWidgetType
Inherits WidgetType
C#
public class UiWidgetType : WidgetType
C++
ref class UiWidgetType : WidgetType
J#
public class UiWidgetType extends WidgetType
JScript
public class UiWidgetType extends WidgetType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiWidgetType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

UiWidgetType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiWidgetType Members

UiWidgetType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by UiWidgetType.

Public Constructors

 | Name | Description
Public method | UiWidgetType | Initializes a new instance of the UiWidgetType class.
Top

Public Properties

 | Name | Description
Public property | Disabled |
Public property | Extension | (inherited from WidgetType)
Public property | ImageClass |
Public property | ImageUrl |
Public property | Label |
Public property | Location | (inherited from WidgetType)
Public property | Name | (inherited from WidgetType)
Public property | StatusText |
Public property | Tooltip |
Public property | Type | (inherited from WidgetType)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

UiWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


UiWidgetType Constructor

UiWidgetType Constructor
[image]

Initializes a new instance of the UiWidgetType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public UiWidgetType()
C++
public:
UiWidgetType() sealed
J#
public UiWidgetType()
JScript
public function UiWidgetType()

See Also

UiWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

UiWidgetType Properties
[image]

Public Properties

 | Name | Description
Public property | Disabled |
Public property | Extension | (inherited from WidgetType)
Public property | ImageClass |
Public property | ImageUrl |
Public property | Label |
Public property | Location | (inherited from WidgetType)
Public property | Name | (inherited from WidgetType)
Public property | StatusText |
Public property | Tooltip |
Public property | Type | (inherited from WidgetType)
Top

See Also

UiWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Disabled Property

UiWidgetType.Disabled Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Disabled As String
C#
public string Disabled { get; set; }
C++
public property string Disabled sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Disabled();

/** property */
public void set_Disabled(string value);
JScript
public function get Disabled() : String

public function set Disabled(value : String);

See Also

UiWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ImageClass Property

UiWidgetType.ImageClass Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageClass As String
C#
public string ImageClass { get; set; }
C++
public property string ImageClass sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ImageClass();

/** property */
public void set_ImageClass(string value);
JScript
public function get ImageClass() : String

public function set ImageClass(value : String);

See Also

UiWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


ImageUrl Property

UiWidgetType.ImageUrl Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageUrl As String
C#
public string ImageUrl { get; set; }
C++
public property string ImageUrl sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ImageUrl();

/** property */
public void set_ImageUrl(string value);
JScript
public function get ImageUrl() : String

public function set ImageUrl(value : String);

See Also

UiWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Label Property

UiWidgetType.Label Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Label As String
C#
public string Label { get; set; }
C++
public property string Label sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Label();

/** property */
public void set_Label(string value);
JScript
public function get Label() : String

public function set Label(value : String);

See Also

UiWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


StatusText Property

UiWidgetType.StatusText Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property StatusText As String
C#
public string StatusText { get; set; }
C++
public property string StatusText sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_StatusText();

/** property */
public void set_StatusText(string value);
JScript
public function get StatusText() : String

public function set StatusText(value : String);

See Also

UiWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Tooltip Property

UiWidgetType.Tooltip Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Tooltip As String
C#
public string Tooltip { get; set; }
C++
public property string Tooltip sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Tooltip();

/** property */
public void set_Tooltip(string value);
JScript
public function get Tooltip() : String

public function set Tooltip(value : String);

See Also

UiWidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetItemType Class

WidgetItemType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class WidgetItemType
Inherits UiItemType
C#
public class WidgetItemType : UiItemType
C++
ref class WidgetItemType : UiItemType
J#
public class WidgetItemType extends UiItemType
JScript
public class WidgetItemType extends UiItemType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiItemType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetItemType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WidgetItemType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetItemType Members

WidgetItemType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by WidgetItemType.

Public Constructors

 | Name | Description
Public method | WidgetItemType | Initializes a new instance of the WidgetItemType class.
Top

Public Properties

 | Name | Description
Public property | Function | (inherited from UiItemType)
Public property | Widget |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

WidgetItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetItemType Constructor

WidgetItemType Constructor
[image]

Initializes a new instance of the WidgetItemType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WidgetItemType()
C++
public:
WidgetItemType() sealed
J#
public WidgetItemType()
JScript
public function WidgetItemType()

See Also

WidgetItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

WidgetItemType Properties
[image]

Public Properties

 | Name | Description
Public property | Function | (inherited from UiItemType)
Public property | Widget |
Top

See Also

WidgetItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Widget Property

WidgetItemType.Widget Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Widget As String
C#
public string Widget { get; set; }
C++
public property string Widget sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Widget();

/** property */
public void set_Widget(string value);
JScript
public function get Widget() : String

public function set Widget(value : String);

See Also

WidgetItemType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetSetType Class

WidgetSetType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class WidgetSetType
C#
public class WidgetSetType
C++
ref class WidgetSetType
J#
public class WidgetSetType
JScript
public class WidgetSetType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetSetType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WidgetSetType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetSetType Members

WidgetSetType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by WidgetSetType.

Public Constructors

 | Name | Description
Public method | WidgetSetType | Initializes a new instance of the WidgetSetType class.
Top

Public Properties

 | Name | Description
Public property | Container |
Public property | MapWidget |
Public property | Widget |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

WidgetSetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetSetType Constructor

WidgetSetType Constructor
[image]

Initializes a new instance of the WidgetSetType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WidgetSetType()
C++
public:
WidgetSetType() sealed
J#
public WidgetSetType()
JScript
public function WidgetSetType()

See Also

WidgetSetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

WidgetSetType Properties
[image]

Public Properties

 | Name | Description
Public property | Container |
Public property | MapWidget |
Public property | Widget |
Top

See Also

WidgetSetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Container Property

WidgetSetType.Container Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Container")>
Public Property Container As ContainerTypeCollection
C#
[XmlElementAttribute("Container")]
public ContainerTypeCollection Container { get; set; }
C++
[XmlElementAttribute(L"Container")]
public property ContainerTypeCollection Container sealed {
ContainerTypeCollection get();
void set(ContainerTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("Container") */
/** property */
public ContainerTypeCollection get_Container();

/** property */
public void set_Container(ContainerTypeCollection value);
JScript
public function get Container() : ContainerTypeCollection

public function set Container(value : ContainerTypeCollection);

See Also

WidgetSetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


MapWidget Property

WidgetSetType.MapWidget Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MapWidget As MapWidgetType
C#
public MapWidgetType MapWidget { get; set; }
C++
public property MapWidgetType MapWidget sealed {
MapWidgetType get();
void set(MapWidgetType value);
}
J#
/** property */
public MapWidgetType get_MapWidget();

/** property */
public void set_MapWidget(MapWidgetType value);
JScript
public function get MapWidget() : MapWidgetType

public function set MapWidget(value : MapWidgetType);

See Also

WidgetSetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Widget Property

WidgetSetType.Widget Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlElementAttribute("Widget")>
Public Property Widget As WidgetTypeCollection
C#
[XmlElementAttribute("Widget")]
public WidgetTypeCollection Widget { get; set; }
C++
[XmlElementAttribute(L"Widget")]
public property WidgetTypeCollection Widget sealed {
WidgetTypeCollection get();
void set(WidgetTypeCollection value);
}
J#
/** @attribute XmlElementAttribute("Widget") */
/** property */
public WidgetTypeCollection get_Widget();

/** property */
public void set_Widget(WidgetTypeCollection value);
JScript
public function get Widget() : WidgetTypeCollection

public function set Widget(value : WidgetTypeCollection);

See Also

WidgetSetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetSetTypeCollection Class

WidgetSetTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class WidgetSetTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class WidgetSetTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class WidgetSetTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class WidgetSetTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class WidgetSetTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetSetTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WidgetSetTypeCollection Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetSetTypeCollection Members

WidgetSetTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by WidgetSetTypeCollection.

Public Constructors

 | Name | Description
Public method | WidgetSetTypeCollection | Initializes a new instance of the WidgetSetTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

WidgetSetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetSetTypeCollection Constructor

WidgetSetTypeCollection Constructor
[image]

Initializes a new instance of the WidgetSetTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WidgetSetTypeCollection()
C++
public:
WidgetSetTypeCollection() sealed
J#
public WidgetSetTypeCollection()
JScript
public function WidgetSetTypeCollection()

See Also

WidgetSetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

WidgetSetTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

WidgetSetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Item Property

WidgetSetTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As WidgetSetType
C#
public WidgetSetType this[
int idx
] { get; set; }
C++
public property WidgetSetType default[int idx] sealed {
WidgetSetType get(int idx);
void set(int idx, WidgetSetType value);
}
J#
/** property */
public WidgetSetType get_Item(int idx);

/** property */
public void set_Item(int idx, WidgetSetType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

WidgetSetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Methods

WidgetSetTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

WidgetSetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Add Method

WidgetSetTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As WidgetSetType _
) As Integer
C#
public int Add(
WidgetSetType value
)
C++
public:
int Add(
WidgetSetType value
) sealed
J#
public int Add(
WidgetSetType value
)
JScript
public function Add(
value : WidgetSetType
) : int

See Also

WidgetSetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetType Class

WidgetType Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIncludeAttribute(GetType(UiWidgetType)), _
XmlIncludeAttribute(GetType(MapWidgetType))>
Public Class WidgetType
C#
[XmlIncludeAttribute(typeof(UiWidgetType))]
[XmlIncludeAttribute(typeof(MapWidgetType))]
public class WidgetType
C++
[XmlIncludeAttribute(typeof(UiWidgetType))]
[XmlIncludeAttribute(typeof(MapWidgetType))]
ref class WidgetType
J#
/** @attribute XmlIncludeAttribute(typeof(UiWidgetType)) */
/** @attribute XmlIncludeAttribute(typeof(MapWidgetType)) */
public class WidgetType
JScript
public
XmlIncludeAttribute(typeof(UiWidgetType))
XmlIncludeAttribute(typeof(MapWidgetType))
class WidgetType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapWidgetType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiWidgetType

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WidgetType Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetType Members

WidgetType Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by WidgetType.

Public Constructors

 | Name | Description
Public method | WidgetType | Initializes a new instance of the WidgetType class.
Top

Public Properties

 | Name | Description
Public property | Extension |
Public property | Location |
Public property | Name |
Public property | Type |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

WidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetType Constructor

WidgetType Constructor
[image]

Initializes a new instance of the WidgetType class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WidgetType()
C++
public:
WidgetType() sealed
J#
public WidgetType()
JScript
public function WidgetType()

See Also

WidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

WidgetType Properties
[image]

Public Properties

 | Name | Description
Public property | Extension |
Public property | Location |
Public property | Name |
Public property | Type |
Top

See Also

WidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Extension Property

WidgetType.Extension Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Extension As CustomContentType
C#
public CustomContentType Extension { get; set; }
C++
public property CustomContentType Extension sealed {
CustomContentType get();
void set(CustomContentType value);
}
J#
/** property */
public CustomContentType get_Extension();

/** property */
public void set_Extension(CustomContentType value);
JScript
public function get Extension() : CustomContentType

public function set Extension(value : CustomContentType);

See Also

WidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Location Property

WidgetType.Location Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Location As String
C#
public string Location { get; set; }
C++
public property string Location sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Location();

/** property */
public void set_Location(string value);
JScript
public function get Location() : String

public function set Location(value : String);

See Also

WidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Name Property

WidgetType.Name Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
C++
public property string Name sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Name();

/** property */
public void set_Name(string value);
JScript
public function get Name() : String

public function set Name(value : String);

See Also

WidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Type Property

WidgetType.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
C++
public property string Type sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Type();

/** property */
public void set_Type(string value);
JScript
public function get Type() : String

public function set Type(value : String);

See Also

WidgetType Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetTypeCollection Class

WidgetTypeCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class WidgetTypeCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class WidgetTypeCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class WidgetTypeCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class WidgetTypeCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class WidgetTypeCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetTypeCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

WidgetTypeCollection Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetTypeCollection Members

WidgetTypeCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by WidgetTypeCollection.

Public Constructors

 | Name | Description
Public method | WidgetTypeCollection | Initializes a new instance of the WidgetTypeCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindByName |
Public method | FindByType |
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

WidgetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


WidgetTypeCollection Constructor

WidgetTypeCollection Constructor
[image]

Initializes a new instance of the WidgetTypeCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public WidgetTypeCollection()
C++
public:
WidgetTypeCollection() sealed
J#
public WidgetTypeCollection()
JScript
public function WidgetTypeCollection()

See Also

WidgetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

WidgetTypeCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

WidgetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Item Property

WidgetTypeCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As WidgetType
C#
public WidgetType this[
int idx
] { get; set; }
C++
public property WidgetType default[int idx] sealed {
WidgetType get(int idx);
void set(int idx, WidgetType value);
}
J#
/** property */
public WidgetType get_Item(int idx);

/** property */
public void set_Item(int idx, WidgetType value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

WidgetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Methods

WidgetTypeCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | FindByName |
Public method | FindByType |
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

WidgetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Add Method

WidgetTypeCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As WidgetType _
) As Integer
C#
public int Add(
WidgetType value
)
C++
public:
int Add(
WidgetType value
) sealed
J#
public int Add(
WidgetType value
)
JScript
public function Add(
value : WidgetType
) : int

See Also

WidgetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


FindByName Method

WidgetTypeCollection.FindByName Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function FindByName( _
ByVal name As String _
) As WidgetType
C#
public WidgetType FindByName(
string name
)
C++
public:
WidgetType FindByName(
String name
) sealed
J#
public WidgetType FindByName(
string name
)
JScript
public function FindByName(
name : String
) : WidgetType

See Also

WidgetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


FindByType Method

WidgetTypeCollection.FindByType Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function FindByType( _
ByVal type As String _
) As WidgetType
C#
public WidgetType FindByType(
string type
)
C++
public:
WidgetType FindByType(
String type
) sealed
J#
public WidgetType FindByType(
string type
)
JScript
public function FindByType(
type : String
) : WidgetType

See Also

WidgetTypeCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


XmlElementCollection Class

XmlElementCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class XmlElementCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class XmlElementCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class XmlElementCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class XmlElementCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class XmlElementCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.XmlElementCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XmlElementCollection Members
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


XmlElementCollection Members

XmlElementCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by XmlElementCollection.

Public Constructors

 | Name | Description
Public method | XmlElementCollection | Initializes a new instance of the XmlElementCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XmlElementCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


XmlElementCollection Constructor

XmlElementCollection Constructor
[image]

Initializes a new instance of the XmlElementCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XmlElementCollection()
C++
public:
XmlElementCollection() sealed
J#
public XmlElementCollection()
JScript
public function XmlElementCollection()

See Also

XmlElementCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Properties

XmlElementCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item |
Top

See Also

XmlElementCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Item Property

XmlElementCollection.Item Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As XmlElement
C#
public XmlElement this[
int idx
] { get; set; }
C++
public property XmlElement default[int idx] sealed {
XmlElement get(int idx);
void set(int idx, XmlElement value);
}
J#
/** property */
public XmlElement get_Item(int idx);

/** property */
public void set_Item(int idx, XmlElement value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

XmlElementCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Methods

XmlElementCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XmlElementCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


Add Method

XmlElementCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.ApplicationDefinition
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As XmlElement _
) As Integer
C#
public int Add(
XmlElement value
)
C++
public:
int Add(
XmlElement value
) sealed
J#
public int Add(
XmlElement value
)
JScript
public function Add(
value : XmlElement
) : int

See Also

XmlElementCollection Class
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


OSGeo.MapGuide.MaestroAPI.BinarySerializer

OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | MgBinaryDeserializer | A utility for serializing objects to the internal MapGuide Format
Public class | MgBinarySerializer | A utility for deserializing data in the internal MapGuide format.

Interfaces

 | Interface | Description
Public interface | IBinarySerializeable | An object that can be serialized, using the internal MapGuide format, must implement this interface


IBinarySerializeable Interface

IBinarySerializeable Interface
See Also Example Members
[image]

An object that can be serialized, using the internal MapGuide format, must implement this interface

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Interface IBinarySerializeable
C#
public interface IBinarySerializeable
C++
interface class IBinarySerializeable
J#
public interface IBinarySerializeable
JScript
public interface IBinarySerializeable

See Also

IBinarySerializeable Members
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


IBinarySerializeable Members

IBinarySerializeable Members
See Also Example Methods
[image]

An object that can be serialized, using the internal MapGuide format, must implement this interface

The following tables list the members exposed by IBinarySerializeable.

Public Methods

 | Name | Description
Public method | Deserialize |
Public method | Serialize |
Top

See Also

IBinarySerializeable Interface
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


Methods

IBinarySerializeable Methods
[image]

Public Methods

 | Name | Description
Public method | Deserialize |
Public method | Serialize |
Top

See Also

IBinarySerializeable Interface
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


Deserialize Method

IBinarySerializeable.Deserialize Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub Deserialize( _
ByVal deserializer As MgBinaryDeserializer _
)
C#
void Deserialize(
MgBinaryDeserializer deserializer
)
C++
void Deserialize(
MgBinaryDeserializer deserializer
) abstract
J#
void Deserialize(
MgBinaryDeserializer deserializer
)
JScript
function Deserialize(
deserializer : MgBinaryDeserializer
)

See Also

IBinarySerializeable Interface
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


Serialize Method

IBinarySerializeable.Serialize Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Sub Serialize( _
ByVal serializer As MgBinarySerializer _
)
C#
void Serialize(
MgBinarySerializer serializer
)
C++
void Serialize(
MgBinarySerializer serializer
) abstract
J#
void Serialize(
MgBinarySerializer serializer
)
JScript
function Serialize(
serializer : MgBinarySerializer
)

See Also

IBinarySerializeable Interface
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


MgBinaryDeserializer Class

MgBinaryDeserializer Class
See Also Example Members
[image]

A utility for serializing objects to the internal MapGuide Format

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MgBinaryDeserializer
C#
public class MgBinaryDeserializer
C++
ref class MgBinaryDeserializer
J#
public class MgBinaryDeserializer
JScript
public class MgBinaryDeserializer

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.BinarySerializer.MgBinaryDeserializer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MgBinaryDeserializer Members
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


MgBinaryDeserializer Members

MgBinaryDeserializer Members
See Also Example Constructors Properties Methods
[image]

A utility for serializing objects to the internal MapGuide Format

The following tables list the members exposed by MgBinaryDeserializer.

Public Constructors

 | Name | Description
Public method | MgBinaryDeserializer |
Top

Public Properties

 | Name | Description
Public property | SiteVersion |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ReadBool |
Public method | ReadByte |
Public method | ReadClassId |
Public method | ReadCoordinates |
Public method | ReadDouble |
Public method | ReadInt16 |
Public method | ReadInt32 |
Public method | ReadInt64 |
Public method | ReadInternalString |
Public method | ReadObject |
Public method | ReadResourceIdentifier |
Public method | ReadSingle |
Public method | ReadStream |
Public method | ReadStreamEnd |
Public method | ReadStreamRepeat | Overloaded. Internal helper that will read from a potentially fragmented stream
Public method | ReadString |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


MgBinaryDeserializer Constructor

MgBinaryDeserializer Constructor
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal stream As Stream, _
ByVal siteversion As Version _
)
C#
public MgBinaryDeserializer(
Stream stream,
Version siteversion
)
C++
public:
MgBinaryDeserializer(
Stream stream,
Version siteversion
) sealed
J#
public MgBinaryDeserializer(
Stream stream,
Version siteversion
)
JScript
public function MgBinaryDeserializer(
stream : Stream,
siteversion : Version
)

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


Properties

MgBinaryDeserializer Properties
[image]

Public Properties

 | Name | Description
Public property | SiteVersion |
Top

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


SiteVersion Property

MgBinaryDeserializer.SiteVersion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SiteVersion As Version
C#
public Version SiteVersion { get; }
C++
public property Version SiteVersion sealed {
Version get();
}
J#
/** property */
public Version get_SiteVersion();
JScript
public function get SiteVersion() : Version

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


Methods

MgBinaryDeserializer Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ReadBool |
Public method | ReadByte |
Public method | ReadClassId |
Public method | ReadCoordinates |
Public method | ReadDouble |
Public method | ReadInt16 |
Public method | ReadInt32 |
Public method | ReadInt64 |
Public method | ReadInternalString |
Public method | ReadObject |
Public method | ReadResourceIdentifier |
Public method | ReadSingle |
Public method | ReadStream |
Public method | ReadStreamEnd |
Public method | ReadStreamRepeat | Overloaded. Internal helper that will read from a potentially fragmented stream
Public method | ReadString |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadBool Method

MgBinaryDeserializer.ReadBool Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadBool() As Boolean
C#
public bool ReadBool()
C++
public:
bool ReadBool() sealed
J#
public bool ReadBool()
JScript
public function ReadBool() : bool

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadByte Method

MgBinaryDeserializer.ReadByte Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadByte() As Byte
C#
public byte ReadByte()
C++
public:
char ReadByte() sealed
J#
public byte ReadByte()
JScript
public function ReadByte() : Byte

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadClassId Method

MgBinaryDeserializer.ReadClassId Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadClassId() As Integer
C#
public int ReadClassId()
C++
public:
int ReadClassId() sealed
J#
public int ReadClassId()
JScript
public function ReadClassId() : int

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadCoordinates Method

MgBinaryDeserializer.ReadCoordinates Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadCoordinates() As Double()
C#
public double[] ReadCoordinates()
C++
public:
array<double>^ ReadCoordinates() sealed
J#
public double[] ReadCoordinates()
JScript
public function ReadCoordinates() : double[]

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadDouble Method

MgBinaryDeserializer.ReadDouble Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadDouble() As Double
C#
public double ReadDouble()
C++
public:
double ReadDouble() sealed
J#
public double ReadDouble()
JScript
public function ReadDouble() : double

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadInt16 Method

MgBinaryDeserializer.ReadInt16 Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadInt16() As Short
C#
public short ReadInt16()
C++
public:
short ReadInt16() sealed
J#
public short ReadInt16()
JScript
public function ReadInt16() : short

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadInt32 Method

MgBinaryDeserializer.ReadInt32 Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadInt32() As Integer
C#
public int ReadInt32()
C++
public:
int ReadInt32() sealed
J#
public int ReadInt32()
JScript
public function ReadInt32() : int

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadInt64 Method

MgBinaryDeserializer.ReadInt64 Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadInt64() As Long
C#
public long ReadInt64()
C++
public:
__int64 ReadInt64() sealed
J#
public long ReadInt64()
JScript
public function ReadInt64() : long

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadInternalString Method

MgBinaryDeserializer.ReadInternalString Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadInternalString() As String
C#
public string ReadInternalString()
C++
public:
String ReadInternalString() sealed
J#
public string ReadInternalString()
JScript
public function ReadInternalString() : String

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadObject Method

MgBinaryDeserializer.ReadObject Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadObject() As IBinarySerializeable
C#
public IBinarySerializeable ReadObject()
C++
public:
IBinarySerializeable ReadObject() sealed
J#
public IBinarySerializeable ReadObject()
JScript
public function ReadObject() : IBinarySerializeable

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadResourceIdentifier Method

MgBinaryDeserializer.ReadResourceIdentifier Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadResourceIdentifier() As String
C#
public string ReadResourceIdentifier()
C++
public:
String ReadResourceIdentifier() sealed
J#
public string ReadResourceIdentifier()
JScript
public function ReadResourceIdentifier() : String

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadSingle Method

MgBinaryDeserializer.ReadSingle Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadSingle() As Single
C#
public float ReadSingle()
C++
public:
float ReadSingle() sealed
J#
public float ReadSingle()
JScript
public function ReadSingle() : float

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadStream Method

MgBinaryDeserializer.ReadStream Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadStream() As Stream
C#
public Stream ReadStream()
C++
public:
Stream ReadStream() sealed
J#
public Stream ReadStream()
JScript
public function ReadStream() : Stream

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadStreamEnd Method

MgBinaryDeserializer.ReadStreamEnd Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReadStreamEnd()
C#
public void ReadStreamEnd()
C++
public:
void ReadStreamEnd() sealed
J#
public void ReadStreamEnd()
JScript
public function ReadStreamEnd()

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadStreamRepeat Method

MgBinaryDeserializer.ReadStreamRepeat Method

Internal helper that will read from a potentially fragmented stream

Overload List

 | Name | Description
Public method | ReadStreamRepeat (Byte, Int32, Int32) | Internal helper that will read from a potentially fragmented stream
Public method | ReadStreamRepeat (Int32) |

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


ReadStreamRepeat Method (Byte[], Int32, Int32)

MgBinaryDeserializer.ReadStreamRepeat Method (Byte[], Int32, Int32)
See Also Example
[image]

Internal helper that will read from a potentially fragmented stream

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReadStreamRepeat( _
ByVal buf As Byte(), _
ByVal offset As Integer, _
ByVal len As Integer _
)
C#
public void ReadStreamRepeat(
byte[] buf,
int offset,
int len
)
C++
public:
void ReadStreamRepeat(
array<char>^ buf,
int offset,
int len
) sealed
J#
public void ReadStreamRepeat(
byte[] buf,
int offset,
int len
)
JScript
public function ReadStreamRepeat(
buf : Byte[],
offset : int,
len : int
)

Parameters

buf
offset
len
The number of bytes to read

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
MgBinaryDeserializer.ReadStreamRepeat Overload List


ReadStreamRepeat Method (Int32)

MgBinaryDeserializer.ReadStreamRepeat Method (Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadStreamRepeat( _
ByVal len As Integer _
) As Byte()
C#
public byte[] ReadStreamRepeat(
int len
)
C++
public:
array<char>^ ReadStreamRepeat(
int len
) sealed
J#
public byte[] ReadStreamRepeat(
int len
)
JScript
public function ReadStreamRepeat(
len : int
) : Byte[]

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
MgBinaryDeserializer.ReadStreamRepeat Overload List


ReadString Method

MgBinaryDeserializer.ReadString Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function ReadString() As String
C#
public string ReadString()
C++
public:
String ReadString() sealed
J#
public string ReadString()
JScript
public function ReadString() : String

See Also

MgBinaryDeserializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


MgBinarySerializer Class

MgBinarySerializer Class
See Also Example Members
[image]

A utility for deserializing data in the internal MapGuide format.

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class MgBinarySerializer
C#
public class MgBinarySerializer
C++
ref class MgBinarySerializer
J#
public class MgBinarySerializer
JScript
public class MgBinarySerializer

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.BinarySerializer.MgBinarySerializer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MgBinarySerializer Members
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


MgBinarySerializer Members

MgBinarySerializer Members
See Also Example Constructors Fields Properties Methods
[image]

A utility for deserializing data in the internal MapGuide format.

The following tables list the members exposed by MgBinarySerializer.

Public Constructors

 | Name | Description
Public method | MgBinarySerializer |
Top

Public Fields

Name | Description
DoubleLen |
FloatLen |
UInt16Len |
UInt32Len |
UInt64Len |
UInt8Len |
Top

Public Properties

 | Name | Description
Public property | SiteVersion |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overloaded.
Public method | WriteClassId |
Public method | WriteCoordinates |
Public method | WriteRaw |
Public method | WriteResourceIdentifier |
Public method | WriteStreamEnd |
Public method | WriteStringInternal |
Top

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


MgBinarySerializer Constructor

MgBinarySerializer Constructor
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal stream As Stream, _
ByVal siteversion As Version _
)
C#
public MgBinarySerializer(
Stream stream,
Version siteversion
)
C++
public:
MgBinarySerializer(
Stream stream,
Version siteversion
) sealed
J#
public MgBinarySerializer(
Stream stream,
Version siteversion
)
JScript
public function MgBinarySerializer(
stream : Stream,
siteversion : Version
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


Fields

MgBinarySerializer Fields
[image]

Public Fields

Name | Description
DoubleLen |
FloatLen |
UInt16Len |
UInt32Len |
UInt64Len |
UInt8Len |
Top

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


DoubleLen Field

MgBinarySerializer.DoubleLen Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared DoubleLen As Integer
C#
public static int DoubleLen;
C++
public:
static int DoubleLen;
J#
public static int DoubleLen
JScript
public static DoubleLen : int;

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


FloatLen Field

MgBinarySerializer.FloatLen Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared FloatLen As Integer
C#
public static int FloatLen;
C++
public:
static int FloatLen;
J#
public static int FloatLen
JScript
public static FloatLen : int;

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


UInt16Len Field

MgBinarySerializer.UInt16Len Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared UInt16Len As Integer
C#
public static int UInt16Len;
C++
public:
static int UInt16Len;
J#
public static int UInt16Len
JScript
public static UInt16Len : int;

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


UInt32Len Field

MgBinarySerializer.UInt32Len Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared UInt32Len As Integer
C#
public static int UInt32Len;
C++
public:
static int UInt32Len;
J#
public static int UInt32Len
JScript
public static UInt32Len : int;

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


UInt64Len Field

MgBinarySerializer.UInt64Len Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared UInt64Len As Integer
C#
public static int UInt64Len;
C++
public:
static int UInt64Len;
J#
public static int UInt64Len
JScript
public static UInt64Len : int;

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


UInt8Len Field

MgBinarySerializer.UInt8Len Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shared UInt8Len As Integer
C#
public static int UInt8Len;
C++
public:
static int UInt8Len;
J#
public static int UInt8Len
JScript
public static UInt8Len : int;

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


Properties

MgBinarySerializer Properties
[image]

Public Properties

 | Name | Description
Public property | SiteVersion |
Top

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


SiteVersion Property

MgBinarySerializer.SiteVersion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SiteVersion As Version
C#
public Version SiteVersion { get; }
C++
public property Version SiteVersion sealed {
Version get();
}
J#
/** property */
public Version get_SiteVersion();
JScript
public function get SiteVersion() : Version

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


Methods

MgBinarySerializer Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | Write | Overloaded.
Public method | WriteClassId |
Public method | WriteCoordinates |
Public method | WriteRaw |
Public method | WriteResourceIdentifier |
Public method | WriteStreamEnd |
Public method | WriteStringInternal |
Top

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


Write Method

MgBinarySerializer.Write Method

Overload List

 | Name | Description
Public method | Write (IBinarySerializeable) |
Public method | Write (Boolean) |
Public method | Write (Byte) |
Public method | Write (Double) |
Public method | Write (Int16) |
Public method | Write (Int32) |
Public method | Write (Int64) |
Public method | Write (Stream) |
Public method | Write (String) |

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


Write Method (IBinarySerializeable)

MgBinarySerializer.Write Method (IBinarySerializeable)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal value As IBinarySerializeable _
)
C#
public void Write(
IBinarySerializeable value
)
C++
public:
void Write(
IBinarySerializeable value
) sealed
J#
public void Write(
IBinarySerializeable value
)
JScript
public function Write(
value : IBinarySerializeable
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
MgBinarySerializer.Write Overload List


Write Method (Boolean)

MgBinarySerializer.Write Method (Boolean)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal value As Boolean _
)
C#
public void Write(
bool value
)
C++
public:
void Write(
bool value
) sealed
J#
public void Write(
bool value
)
JScript
public function Write(
value : bool
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
MgBinarySerializer.Write Overload List


Write Method (Byte)

MgBinarySerializer.Write Method (Byte)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal value As Byte _
)
C#
public void Write(
byte value
)
C++
public:
void Write(
char value
) sealed
J#
public void Write(
byte value
)
JScript
public function Write(
value : Byte
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
MgBinarySerializer.Write Overload List


Write Method (Double)

MgBinarySerializer.Write Method (Double)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal value As Double _
)
C#
public void Write(
double value
)
C++
public:
void Write(
double value
) sealed
J#
public void Write(
double value
)
JScript
public function Write(
value : double
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
MgBinarySerializer.Write Overload List


Write Method (Int16)

MgBinarySerializer.Write Method (Int16)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal value As Short _
)
C#
public void Write(
short value
)
C++
public:
void Write(
short value
) sealed
J#
public void Write(
short value
)
JScript
public function Write(
value : short
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
MgBinarySerializer.Write Overload List


Write Method (Int32)

MgBinarySerializer.Write Method (Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal value As Integer _
)
C#
public void Write(
int value
)
C++
public:
void Write(
int value
) sealed
J#
public void Write(
int value
)
JScript
public function Write(
value : int
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
MgBinarySerializer.Write Overload List


Write Method (Int64)

MgBinarySerializer.Write Method (Int64)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal value As Long _
)
C#
public void Write(
long value
)
C++
public:
void Write(
__int64 value
) sealed
J#
public void Write(
long value
)
JScript
public function Write(
value : long
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
MgBinarySerializer.Write Overload List


Write Method (Stream)

MgBinarySerializer.Write Method (Stream)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal stream As Stream _
)
C#
public void Write(
Stream stream
)
C++
public:
void Write(
Stream stream
) sealed
J#
public void Write(
Stream stream
)
JScript
public function Write(
stream : Stream
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
MgBinarySerializer.Write Overload List


Write Method (String)

MgBinarySerializer.Write Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Write( _
ByVal value As String _
)
C#
public void Write(
string value
)
C++
public:
void Write(
String value
) sealed
J#
public void Write(
string value
)
JScript
public function Write(
value : String
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace
MgBinarySerializer.Write Overload List


WriteClassId Method

MgBinarySerializer.WriteClassId Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteClassId( _
ByVal value As Integer _
)
C#
public void WriteClassId(
int value
)
C++
public:
void WriteClassId(
int value
) sealed
J#
public void WriteClassId(
int value
)
JScript
public function WriteClassId(
value : int
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


WriteCoordinates Method

MgBinarySerializer.WriteCoordinates Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteCoordinates( _
ByVal coordinates As Double(), _
ByVal dimensions As Integer _
)
C#
public void WriteCoordinates(
double[] coordinates,
int dimensions
)
C++
public:
void WriteCoordinates(
array<double>^ coordinates,
int dimensions
) sealed
J#
public void WriteCoordinates(
double[] coordinates,
int dimensions
)
JScript
public function WriteCoordinates(
coordinates : double[],
dimensions : int
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


WriteRaw Method

MgBinarySerializer.WriteRaw Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteRaw( _
ByVal buf As Byte() _
)
C#
public void WriteRaw(
byte[] buf
)
C++
public:
void WriteRaw(
array<char>^ buf
) sealed
J#
public void WriteRaw(
byte[] buf
)
JScript
public function WriteRaw(
buf : Byte[]
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


WriteResourceIdentifier Method

MgBinarySerializer.WriteResourceIdentifier Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteResourceIdentifier( _
ByVal resourceID As String _
)
C#
public void WriteResourceIdentifier(
string resourceID
)
C++
public:
void WriteResourceIdentifier(
String resourceID
) sealed
J#
public void WriteResourceIdentifier(
string resourceID
)
JScript
public function WriteResourceIdentifier(
resourceID : String
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


WriteStreamEnd Method

MgBinarySerializer.WriteStreamEnd Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteStreamEnd()
C#
public void WriteStreamEnd()
C++
public:
void WriteStreamEnd() sealed
J#
public void WriteStreamEnd()
JScript
public function WriteStreamEnd()

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


WriteStringInternal Method

MgBinarySerializer.WriteStringInternal Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.BinarySerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub WriteStringInternal( _
ByVal value As String _
)
C#
public void WriteStringInternal(
string value
)
C++
public:
void WriteStringInternal(
String value
) sealed
J#
public void WriteStringInternal(
string value
)
JScript
public function WriteStringInternal(
value : String
)

See Also

MgBinarySerializer Class
OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


OSGeo.MapGuide.MaestroAPI.RuntimeClasses

OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | RuntimeMap | Implementation of the runtime map. This class is prone to breaking if the MapGuide server code changes. An implementation of RFC 21 can correct this problem.
Public class | RuntimeMapGroup |
Public class | RuntimeMapGroupCollection |
Public class | RuntimeMapLayer |
Public class | RuntimeMapLayerCollection |
Public class | Selection |


RuntimeMap Class

RuntimeMap Class
See Also Example Members
[image]

Implementation of the runtime map. This class is prone to breaking if the MapGuide server code changes. An implementation of RFC 21 can correct this problem.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RuntimeMap
Inherits MapDefinition
C#
public class RuntimeMap : MapDefinition
C++
ref class RuntimeMap : MapDefinition
J#
public class RuntimeMap extends MapDefinition
JScript
public class RuntimeMap extends MapDefinition

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.MapDefinition
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMap

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RuntimeMap Members
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMap Members

RuntimeMap Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Implementation of the runtime map. This class is prone to breaking if the MapGuide server code changes. An implementation of RFC 21 can correct this problem.

The following tables list the members exposed by RuntimeMap.

Public Constructors

Name | Description
RuntimeMap | Overloaded.
Top

Public Properties

 | Name | Description
Public property | BackgroundColor | (inherited from MapDefinition)
Public property | BackGroundColorAsHTML | (inherited from MapDefinition)
Public property | BaseMapDefinition | (inherited from MapDefinition)
Public property | Center |
Public property | ChangeList |
Public property | CoordinateSystem | (inherited from MapDefinition)
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | DataExtent |
Public property | DisplayDPI |
Public property | DisplayHeight |
Public property | DisplayWidth |
Public property | Extents | (inherited from MapDefinition)
Public property | FiniteScales |
Public property | LayerGroupBlob |
Public property | LayerGroups |
Public property | LayerRefreshMode |
Public property | Layers |
Public property | Metadata | Gets or sets the Metadata for the map (inherited from MapDefinition)
Public property | MetersPerUnit |
Public property | Name | (inherited from MapDefinition)
Public property | ObjectID |
Public property | ResourceId | (inherited from MapDefinition)
Public property | ResourceID |
Public property | Scale |
Public property | XsdSchema | (inherited from MapDefinition)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
RuntimeMap | Overloaded.
Top

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMap Constructor

RuntimeMap Constructor

Overload List

 | Name | Description
Public method | RuntimeMap (MgBinaryDeserializer, MgBinaryDeserializer) |
Public method | RuntimeMap (MapDefinition) |

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMap Constructor (MgBinaryDeserializer, MgBinaryDeserializer)

RuntimeMap Constructor (MgBinaryDeserializer, MgBinaryDeserializer)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal ds As MgBinaryDeserializer, _
ByVal ds2 As MgBinaryDeserializer _
)
C#
public RuntimeMap(
MgBinaryDeserializer ds,
MgBinaryDeserializer ds2
)
C++
public:
RuntimeMap(
MgBinaryDeserializer ds,
MgBinaryDeserializer ds2
) sealed
J#
public RuntimeMap(
MgBinaryDeserializer ds,
MgBinaryDeserializer ds2
)
JScript
public function RuntimeMap(
ds : MgBinaryDeserializer,
ds2 : MgBinaryDeserializer
)

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMap Constructor Overload List


RuntimeMap Constructor (MapDefinition)

RuntimeMap Constructor (MapDefinition)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal map As MapDefinition _
)
C#
public RuntimeMap(
MapDefinition map
)
C++
public:
RuntimeMap(
MapDefinition map
) sealed
J#
public RuntimeMap(
MapDefinition map
)
JScript
public function RuntimeMap(
map : MapDefinition
)

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMap Constructor Overload List


Properties

RuntimeMap Properties
[image]

Public Properties

 | Name | Description
Public property | BackgroundColor | (inherited from MapDefinition)
Public property | BackGroundColorAsHTML | (inherited from MapDefinition)
Public property | BaseMapDefinition | (inherited from MapDefinition)
Public property | Center |
Public property | ChangeList |
Public property | CoordinateSystem | (inherited from MapDefinition)
Public property | CurrentConnection | Gets or sets the connection used in various operations performed on this object
Public property | DataExtent |
Public property | DisplayDPI |
Public property | DisplayHeight |
Public property | DisplayWidth |
Public property | Extents | (inherited from MapDefinition)
Public property | FiniteScales |
Public property | LayerGroupBlob |
Public property | LayerGroups |
Public property | LayerRefreshMode |
Public property | Layers |
Public property | Metadata | Gets or sets the Metadata for the map (inherited from MapDefinition)
Public property | MetersPerUnit |
Public property | Name | (inherited from MapDefinition)
Public property | ObjectID |
Public property | ResourceId | (inherited from MapDefinition)
Public property | ResourceID |
Public property | Scale |
Public property | XsdSchema | (inherited from MapDefinition)
Top

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Center Property

RuntimeMap.Center Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Center As Double()
C#
public double[] Center { get; set; }
C++
public property double[] Center sealed {
array<double>^ get();
void set(array<double>^ value);
}
J#
/** property */
public double[] get_Center();

/** property */
public void set_Center(double[] value);
JScript
public function get Center() : double[]

public function set Center(value : double[]);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


ChangeList Property

RuntimeMap.ChangeList Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ChangeList As ArrayList
C#
public ArrayList ChangeList { get; set; }
C++
public property ArrayList ChangeList sealed {
ArrayList get();
void set(ArrayList value);
}
J#
/** property */
public ArrayList get_ChangeList();

/** property */
public void set_ChangeList(ArrayList value);
JScript
public function get ChangeList() : ArrayList

public function set ChangeList(value : ArrayList);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


CurrentConnection Property

RuntimeMap.CurrentConnection Property
[image]

Gets or sets the connection used in various operations performed on this object

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<XmlIgnoreAttribute>
Public Property CurrentConnection As ServerConnectionI
C#
[XmlIgnoreAttribute]
public ServerConnectionI CurrentConnection { get; set; }
C++
[XmlIgnoreAttribute]
public property ServerConnectionI CurrentConnection sealed {
ServerConnectionI get();
void set(ServerConnectionI value);
}
J#
/** @attribute XmlIgnoreAttribute() */
/** property */
public ServerConnectionI get_CurrentConnection();

/** property */
public void set_CurrentConnection(ServerConnectionI value);
JScript
public function get CurrentConnection() : ServerConnectionI

public function set CurrentConnection(value : ServerConnectionI);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


DataExtent Property

RuntimeMap.DataExtent Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DataExtent As Box2DType
C#
public Box2DType DataExtent { get; set; }
C++
public property Box2DType DataExtent sealed {
Box2DType get();
void set(Box2DType value);
}
J#
/** property */
public Box2DType get_DataExtent();

/** property */
public void set_DataExtent(Box2DType value);
JScript
public function get DataExtent() : Box2DType

public function set DataExtent(value : Box2DType);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


DisplayDPI Property

RuntimeMap.DisplayDPI Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisplayDPI As Integer
C#
public int DisplayDPI { get; set; }
C++
public property int DisplayDPI sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_DisplayDPI();

/** property */
public void set_DisplayDPI(int value);
JScript
public function get DisplayDPI() : int

public function set DisplayDPI(value : int);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


DisplayHeight Property

RuntimeMap.DisplayHeight Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisplayHeight As Integer
C#
public int DisplayHeight { get; set; }
C++
public property int DisplayHeight sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_DisplayHeight();

/** property */
public void set_DisplayHeight(int value);
JScript
public function get DisplayHeight() : int

public function set DisplayHeight(value : int);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


DisplayWidth Property

RuntimeMap.DisplayWidth Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisplayWidth As Integer
C#
public int DisplayWidth { get; set; }
C++
public property int DisplayWidth sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_DisplayWidth();

/** property */
public void set_DisplayWidth(int value);
JScript
public function get DisplayWidth() : int

public function set DisplayWidth(value : int);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


FiniteScales Property

RuntimeMap.FiniteScales Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FiniteScales As Double()
C#
public double[] FiniteScales { get; set; }
C++
public property double[] FiniteScales sealed {
array<double>^ get();
void set(array<double>^ value);
}
J#
/** property */
public double[] get_FiniteScales();

/** property */
public void set_FiniteScales(double[] value);
JScript
public function get FiniteScales() : double[]

public function set FiniteScales(value : double[]);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


LayerGroupBlob Property

RuntimeMap.LayerGroupBlob Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LayerGroupBlob As Byte()
C#
public byte[] LayerGroupBlob { get; set; }
C++
public property byte[] LayerGroupBlob sealed {
array<char>^ get();
void set(array<char>^ value);
}
J#
/** property */
public byte[] get_LayerGroupBlob();

/** property */
public void set_LayerGroupBlob(byte[] value);
JScript
public function get LayerGroupBlob() : Byte[]

public function set LayerGroupBlob(value : Byte[]);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


LayerGroups Property

RuntimeMap.LayerGroups Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shadows Property LayerGroups As RuntimeMapGroupCollection
C#
public new RuntimeMapGroupCollection LayerGroups { get; set; }
C++
public new property RuntimeMapGroupCollection LayerGroups sealed {
RuntimeMapGroupCollection get();
void set(RuntimeMapGroupCollection value);
}
J#
/** property */
public RuntimeMapGroupCollection get_LayerGroups();

/** property */
public void set_LayerGroups(RuntimeMapGroupCollection value);
JScript
public function get LayerGroups() : RuntimeMapGroupCollection

public function set LayerGroups(value : RuntimeMapGroupCollection);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


LayerRefreshMode Property

RuntimeMap.LayerRefreshMode Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property LayerRefreshMode As Integer
C#
public int LayerRefreshMode { get; set; }
C++
public property int LayerRefreshMode sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_LayerRefreshMode();

/** property */
public void set_LayerRefreshMode(int value);
JScript
public function get LayerRefreshMode() : int

public function set LayerRefreshMode(value : int);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Layers Property

RuntimeMap.Layers Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shadows Property Layers As RuntimeMapLayerCollection
C#
public new RuntimeMapLayerCollection Layers { get; set; }
C++
public new property RuntimeMapLayerCollection Layers sealed {
RuntimeMapLayerCollection get();
void set(RuntimeMapLayerCollection value);
}
J#
/** property */
public RuntimeMapLayerCollection get_Layers();

/** property */
public void set_Layers(RuntimeMapLayerCollection value);
JScript
public function get Layers() : RuntimeMapLayerCollection

public function set Layers(value : RuntimeMapLayerCollection);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


MetersPerUnit Property

RuntimeMap.MetersPerUnit Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MetersPerUnit As Double
C#
public double MetersPerUnit { get; set; }
C++
public property double MetersPerUnit sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_MetersPerUnit();

/** property */
public void set_MetersPerUnit(double value);
JScript
public function get MetersPerUnit() : double

public function set MetersPerUnit(value : double);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


ObjectID Property

RuntimeMap.ObjectID Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectID As String
C#
public string ObjectID { get; set; }
C++
public property string ObjectID sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ObjectID();

/** property */
public void set_ObjectID(string value);
JScript
public function get ObjectID() : String

public function set ObjectID(value : String);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


ResourceID Property

RuntimeMap.ResourceID Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ResourceID As ResourceIdentifier
C#
public ResourceIdentifier ResourceID { get; set; }
C++
public property ResourceIdentifier ResourceID sealed {
ResourceIdentifier get();
void set(ResourceIdentifier value);
}
J#
/** property */
public ResourceIdentifier get_ResourceID();

/** property */
public void set_ResourceID(ResourceIdentifier value);
JScript
public function get ResourceID() : ResourceIdentifier

public function set ResourceID(value : ResourceIdentifier);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Scale Property

RuntimeMap.Scale Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Scale As Double
C#
public double Scale { get; set; }
C++
public property double Scale sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_Scale();

/** property */
public void set_Scale(double value);
JScript
public function get Scale() : double

public function set Scale(value : double);

See Also

RuntimeMap Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapGroup Class

RuntimeMapGroup Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RuntimeMapGroup
Inherits BaseMapLayerType
C#
public class RuntimeMapGroup : BaseMapLayerType
C++
ref class RuntimeMapGroup : BaseMapLayerType
J#
public class RuntimeMapGroup extends BaseMapLayerType
JScript
public class RuntimeMapGroup extends BaseMapLayerType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.BaseMapLayerType
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMapGroup

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RuntimeMapGroup Members
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapGroup Members

RuntimeMapGroup Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by RuntimeMapGroup.

Public Constructors

Name | Description
RuntimeMapGroup | Overloaded. Initializes a new instance of the RuntimeMapGroup class.
Top

Public Properties

 | Name | Description
Public property | ExpandInLegend | (inherited from BaseMapLayerType)
Public property | Layers | Returns a list of layers present in the current group. This method does NOT run in O(n).
Public property | LegendLabel | (inherited from BaseMapLayerType)
Public property | Name | (inherited from BaseMapLayerType)
Public property | ObjectID |
Public property | Parent |
Public property | ParentGroup |
Public property | ResourceId | (inherited from BaseMapLayerType)
Public property | Selectable | (inherited from BaseMapLayerType)
Public property | ShowInLegend | (inherited from BaseMapLayerType)
Public property | Type |
Public property | Visible |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFullPath | Gets the full path of the group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
RuntimeMapGroup | Overloaded. Initializes a new instance of the RuntimeMapGroup class.
Top

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapGroup Constructor

RuntimeMapGroup Constructor

Initializes a new instance of the RuntimeMapGroup class.

Overload List

 | Name | Description
Public method | RuntimeMapGroup | Initializes a new instance of the RuntimeMapGroup class.
Public method | RuntimeMapGroup (MapLayerGroupType) |

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapGroup Constructor ()

RuntimeMapGroup Constructor ()
See Also Example
[image]

Initializes a new instance of the RuntimeMapGroup class.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RuntimeMapGroup()
C++
public:
RuntimeMapGroup() sealed
J#
public RuntimeMapGroup()
JScript
public function RuntimeMapGroup()

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapGroup Constructor Overload List


RuntimeMapGroup Constructor (MapLayerGroupType)

RuntimeMapGroup Constructor (MapLayerGroupType)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal group As MapLayerGroupType _
)
C#
public RuntimeMapGroup(
MapLayerGroupType group
)
C++
public:
RuntimeMapGroup(
MapLayerGroupType group
) sealed
J#
public RuntimeMapGroup(
MapLayerGroupType group
)
JScript
public function RuntimeMapGroup(
group : MapLayerGroupType
)

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapGroup Constructor Overload List


Properties

RuntimeMapGroup Properties
[image]

Public Properties

 | Name | Description
Public property | ExpandInLegend | (inherited from BaseMapLayerType)
Public property | Layers | Returns a list of layers present in the current group. This method does NOT run in O(n).
Public property | LegendLabel | (inherited from BaseMapLayerType)
Public property | Name | (inherited from BaseMapLayerType)
Public property | ObjectID |
Public property | Parent |
Public property | ParentGroup |
Public property | ResourceId | (inherited from BaseMapLayerType)
Public property | Selectable | (inherited from BaseMapLayerType)
Public property | ShowInLegend | (inherited from BaseMapLayerType)
Public property | Type |
Public property | Visible |
Top

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Layers Property

RuntimeMapGroup.Layers Property
[image]

Returns a list of layers present in the current group. This method does NOT run in O(n).

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Layers As RuntimeMapLayerCollection
C#
public RuntimeMapLayerCollection Layers { get; }
C++
public property RuntimeMapLayerCollection Layers sealed {
RuntimeMapLayerCollection get();
}
J#
/** property */
public RuntimeMapLayerCollection get_Layers();
JScript
public function get Layers() : RuntimeMapLayerCollection

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


ObjectID Property

RuntimeMapGroup.ObjectID Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ObjectID As String
C#
public string ObjectID { get; set; }
C++
public property string ObjectID sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ObjectID();

/** property */
public void set_ObjectID(string value);
JScript
public function get ObjectID() : String

public function set ObjectID(value : String);

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Parent Property

RuntimeMapGroup.Parent Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Parent As RuntimeMap
C#
public new RuntimeMap Parent { get; }
C++
public new property RuntimeMap Parent sealed {
RuntimeMap get();
}
J#
/** property */
public RuntimeMap get_Parent();
JScript
public function get Parent() : RuntimeMap

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


ParentGroup Property

RuntimeMapGroup.ParentGroup Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ParentGroup As String
C#
public string ParentGroup { get; set; }
C++
public property string ParentGroup sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ParentGroup();

/** property */
public void set_ParentGroup(string value);
JScript
public function get ParentGroup() : String

public function set ParentGroup(value : String);

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Type Property

RuntimeMapGroup.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Integer
C#
public int Type { get; set; }
C++
public property int Type sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Type();

/** property */
public void set_Type(int value);
JScript
public function get Type() : int

public function set Type(value : int);

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Visible Property

RuntimeMapGroup.Visible Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Visible As Boolean
C#
public bool Visible { get; set; }
C++
public property bool Visible sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Visible();

/** property */
public void set_Visible(bool value);
JScript
public function get Visible() : bool

public function set Visible(value : bool);

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Methods

RuntimeMapGroup Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFullPath | Gets the full path of the group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


GetFullPath Method

RuntimeMapGroup.GetFullPath Method
[image]

Gets the full path of the group

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFullPath( _
ByVal separator As String, _
ByVal parent As RuntimeMap _
) As String
C#
public string GetFullPath(
string separator,
RuntimeMap parent
)
C++
public:
String GetFullPath(
String separator,
RuntimeMap parent
) sealed
J#
public string GetFullPath(
string separator,
RuntimeMap parent
)
JScript
public function GetFullPath(
separator : String,
parent : RuntimeMap
) : String

Parameters

separator
The string used to separate the individual levels
parent
The parent mapdefinition, use null for the current parent

See Also

RuntimeMapGroup Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapGroupCollection Class

RuntimeMapGroupCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class RuntimeMapGroupCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class RuntimeMapGroupCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class RuntimeMapGroupCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class RuntimeMapGroupCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class RuntimeMapGroupCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMapGroupCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RuntimeMapGroupCollection Members
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapGroupCollection Members

RuntimeMapGroupCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RuntimeMapGroupCollection.

Public Constructors

 | Name | Description
Public method | RuntimeMapGroupCollection | Initializes a new instance of the RuntimeMapGroupCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Overloaded. Gets or sets a layer based on the layers name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Contains | Gets a value indicating if the layer exists in the map. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf | Gets or sets the index of a layer, given the layer name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Public method | Insert |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RuntimeMapGroupCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapGroupCollection Constructor

RuntimeMapGroupCollection Constructor
[image]

Initializes a new instance of the RuntimeMapGroupCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RuntimeMapGroupCollection()
C++
public:
RuntimeMapGroupCollection() sealed
J#
public RuntimeMapGroupCollection()
JScript
public function RuntimeMapGroupCollection()

See Also

RuntimeMapGroupCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Properties

RuntimeMapGroupCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Overloaded. Gets or sets a layer based on the layers name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Top

See Also

RuntimeMapGroupCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Item Property

RuntimeMapGroupCollection.Item Property

Gets or sets a layer based on the layers name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.

Overload List

 | Name | Description
Public property | Item (Int32) |
Public property | Item (String) | Gets or sets a layer based on the layers name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.

See Also

RuntimeMapGroupCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Item Property (Int32)

RuntimeMapGroupCollection.Item Property (Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As RuntimeMapGroup
C#
public RuntimeMapGroup this[
int idx
] { get; set; }
C++
public property RuntimeMapGroup default[int idx] sealed {
RuntimeMapGroup get(int idx);
void set(int idx, RuntimeMapGroup value);
}
J#
/** property */
public RuntimeMapGroup get_Item(int idx);

/** property */
public void set_Item(int idx, RuntimeMapGroup value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

RuntimeMapGroupCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapGroupCollection.Item Overload List


Item Property (String)

RuntimeMapGroupCollection.Item Property (String)
See Also Example
[image]

Gets or sets a layer based on the layers name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal name As String _
) As RuntimeMapGroup
C#
public RuntimeMapGroup this[
string name
] { get; set; }
C++
public property RuntimeMapGroup default[String name] sealed {
RuntimeMapGroup get(String name);
void set(String name, RuntimeMapGroup value);
}
J#
/** property */
public RuntimeMapGroup get_Item(string name);

/** property */
public void set_Item(string name, RuntimeMapGroup value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

RuntimeMapGroupCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapGroupCollection.Item Overload List


Methods

RuntimeMapGroupCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Contains | Gets a value indicating if the layer exists in the map. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf | Gets or sets the index of a layer, given the layer name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Public method | Insert |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RuntimeMapGroupCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Add Method

RuntimeMapGroupCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As RuntimeMapGroup _
) As Integer
C#
public int Add(
RuntimeMapGroup value
)
C++
public:
int Add(
RuntimeMapGroup value
) sealed
J#
public int Add(
RuntimeMapGroup value
)
JScript
public function Add(
value : RuntimeMapGroup
) : int

See Also

RuntimeMapGroupCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Contains Method

RuntimeMapGroupCollection.Contains Method
[image]

Gets a value indicating if the layer exists in the map. Is case sensitive but will search case insensitive if no layer matches with case sensitive.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal name As String _
) As Boolean
C#
public bool Contains(
string name
)
C++
public:
bool Contains(
String name
) sealed
J#
public bool Contains(
string name
)
JScript
public function Contains(
name : String
) : bool

Parameters

name
The name of the layer

Return Value

True if the layer was found, false otherwise

See Also

RuntimeMapGroupCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


IndexOf Method

RuntimeMapGroupCollection.IndexOf Method
[image]

Gets or sets the index of a layer, given the layer name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
ByVal name As String _
) As Integer
C#
public int IndexOf(
string name
)
C++
public:
int IndexOf(
String name
) sealed
J#
public int IndexOf(
string name
)
JScript
public function IndexOf(
name : String
) : int

Parameters

name
The name of the layer

Return Value

The index of the layer, or -1 if no such layer could be found

See Also

RuntimeMapGroupCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Insert Method

RuntimeMapGroupCollection.Insert Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
ByVal index As Integer, _
ByVal layer As RuntimeMapGroup _
)
C#
public void Insert(
int index,
RuntimeMapGroup layer
)
C++
public:
void Insert(
int index,
RuntimeMapGroup layer
) sealed
J#
public void Insert(
int index,
RuntimeMapGroup layer
)
JScript
public function Insert(
index : int,
layer : RuntimeMapGroup
)

See Also

RuntimeMapGroupCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapLayer Class

RuntimeMapLayer Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class RuntimeMapLayer
Inherits MapLayerType
C#
public class RuntimeMapLayer : MapLayerType
C++
ref class RuntimeMapLayer : MapLayerType
J#
public class RuntimeMapLayer extends MapLayerType
JScript
public class RuntimeMapLayer extends MapLayerType

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.BaseMapLayerType
OSGeo.MapGuide.MaestroAPI.MapLayerType
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMapLayer

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RuntimeMapLayer Members
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapLayer Members

RuntimeMapLayer Members
See Also Example Fields Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by RuntimeMapLayer.

Public Constructors

Name | Description
RuntimeMapLayer | Overloaded.
Top

Public Fields

Name | Description
InfinityScale |
Top

Public Properties

 | Name | Description
Public property | DisplayOrder |
Public property | ExpandInLegend | (inherited from BaseMapLayerType)
Public property | FeatureName |
Public property | FeatureSourceID |
Public property | Geometry |
Public property | Group | Gets or sets the Group that this layer belongs to (inherited from MapLayerType)
Public property | Guid |
Public property | HasTooltips |
Public property | IDs |
Public property | Layers | Returns a list of layers present in the current group. This method does NOT run in O(n). (inherited from MapLayerType)
Public property | LegendLabel | (inherited from BaseMapLayerType)
Public property | Name | (inherited from BaseMapLayerType)
Public property | NeedRefresh |
Public property | Parent |
Public property | ResourceId | (inherited from BaseMapLayerType)
Public property | Scaleranges |
Public property | SchemaName |
Public property | Selectable | Overridden.
Public property | ShowInLegend | (inherited from BaseMapLayerType)
Public property | Type |
Public property | Visible | Overridden.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFullPath | Overloaded. Gets the full path of the group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Query | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
RuntimeMapLayer | Overloaded.
Top

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapLayer Constructor

RuntimeMapLayer Constructor

Overload List

 | Name | Description
Public method | RuntimeMapLayer | Initializes a new instance of the RuntimeMapLayer class.
Public method | RuntimeMapLayer (MapLayerType) |
Public method | RuntimeMapLayer (RuntimeMap) |

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapLayer Constructor ()

RuntimeMapLayer Constructor ()
See Also Example
[image]

Initializes a new instance of the RuntimeMapLayer class.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RuntimeMapLayer()
C++
public:
RuntimeMapLayer() sealed
J#
public RuntimeMapLayer()
JScript
public function RuntimeMapLayer()

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapLayer Constructor Overload List


RuntimeMapLayer Constructor (MapLayerType)

RuntimeMapLayer Constructor (MapLayerType)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal layer As MapLayerType _
)
C#
public RuntimeMapLayer(
MapLayerType layer
)
C++
public:
RuntimeMapLayer(
MapLayerType layer
) sealed
J#
public RuntimeMapLayer(
MapLayerType layer
)
JScript
public function RuntimeMapLayer(
layer : MapLayerType
)

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapLayer Constructor Overload List


RuntimeMapLayer Constructor (RuntimeMap)

RuntimeMapLayer Constructor (RuntimeMap)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal parent As RuntimeMap _
)
C#
public RuntimeMapLayer(
RuntimeMap parent
)
C++
public:
RuntimeMapLayer(
RuntimeMap parent
) sealed
J#
public RuntimeMapLayer(
RuntimeMap parent
)
JScript
public function RuntimeMapLayer(
parent : RuntimeMap
)

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapLayer Constructor Overload List


Fields

RuntimeMapLayer Fields
[image]

Public Fields

Name | Description
InfinityScale |
Top

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


InfinityScale Field

RuntimeMapLayer.InfinityScale Field
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public const InfinityScale As Double = 1000000000000
C#
public const double InfinityScale = 1000000000000;
C++
public:
const double InfinityScale = 1000000000000;
J#
public const double InfinityScale = 1000000000000
JScript
public const InfinityScale : double = 1000000000000;

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Properties

RuntimeMapLayer Properties
[image]

Public Properties

 | Name | Description
Public property | DisplayOrder |
Public property | ExpandInLegend | (inherited from BaseMapLayerType)
Public property | FeatureName |
Public property | FeatureSourceID |
Public property | Geometry |
Public property | Group | Gets or sets the Group that this layer belongs to (inherited from MapLayerType)
Public property | Guid |
Public property | HasTooltips |
Public property | IDs |
Public property | Layers | Returns a list of layers present in the current group. This method does NOT run in O(n). (inherited from MapLayerType)
Public property | LegendLabel | (inherited from BaseMapLayerType)
Public property | Name | (inherited from BaseMapLayerType)
Public property | NeedRefresh |
Public property | Parent |
Public property | ResourceId | (inherited from BaseMapLayerType)
Public property | Scaleranges |
Public property | SchemaName |
Public property | Selectable | Overridden.
Public property | ShowInLegend | (inherited from BaseMapLayerType)
Public property | Type |
Public property | Visible | Overridden.
Top

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


DisplayOrder Property

RuntimeMapLayer.DisplayOrder Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property DisplayOrder As Double
C#
public double DisplayOrder { get; set; }
C++
public property double DisplayOrder sealed {
double get();
void set(double value);
}
J#
/** property */
public double get_DisplayOrder();

/** property */
public void set_DisplayOrder(double value);
JScript
public function get DisplayOrder() : double

public function set DisplayOrder(value : double);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


FeatureName Property

RuntimeMapLayer.FeatureName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FeatureName As String
C#
public string FeatureName { get; set; }
C++
public property string FeatureName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FeatureName();

/** property */
public void set_FeatureName(string value);
JScript
public function get FeatureName() : String

public function set FeatureName(value : String);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


FeatureSourceID Property

RuntimeMapLayer.FeatureSourceID Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property FeatureSourceID As String
C#
public string FeatureSourceID { get; set; }
C++
public property string FeatureSourceID sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_FeatureSourceID();

/** property */
public void set_FeatureSourceID(string value);
JScript
public function get FeatureSourceID() : String

public function set FeatureSourceID(value : String);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Geometry Property

RuntimeMapLayer.Geometry Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Geometry As String
C#
public string Geometry { get; set; }
C++
public property string Geometry sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Geometry();

/** property */
public void set_Geometry(string value);
JScript
public function get Geometry() : String

public function set Geometry(value : String);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Guid Property

RuntimeMapLayer.Guid Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Guid As String
C#
public string Guid { get; set; }
C++
public property string Guid sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_Guid();

/** property */
public void set_Guid(string value);
JScript
public function get Guid() : String

public function set Guid(value : String);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


HasTooltips Property

RuntimeMapLayer.HasTooltips Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property HasTooltips As Boolean
C#
public bool HasTooltips { get; set; }
C++
public property bool HasTooltips sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_HasTooltips();

/** property */
public void set_HasTooltips(bool value);
JScript
public function get HasTooltips() : bool

public function set HasTooltips(value : bool);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


IDs Property

RuntimeMapLayer.IDs Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property IDs As ArrayList
C#
public ArrayList IDs { get; set; }
C++
public property ArrayList IDs sealed {
ArrayList get();
void set(ArrayList value);
}
J#
/** property */
public ArrayList get_IDs();

/** property */
public void set_IDs(ArrayList value);
JScript
public function get IDs() : ArrayList

public function set IDs(value : ArrayList);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


NeedRefresh Property

RuntimeMapLayer.NeedRefresh Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property NeedRefresh As Boolean
C#
public bool NeedRefresh { get; set; }
C++
public property bool NeedRefresh sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_NeedRefresh();

/** property */
public void set_NeedRefresh(bool value);
JScript
public function get NeedRefresh() : bool

public function set NeedRefresh(value : bool);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Parent Property

RuntimeMapLayer.Parent Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Shadows ReadOnly Property Parent As RuntimeMap
C#
public new RuntimeMap Parent { get; }
C++
public new property RuntimeMap Parent sealed {
RuntimeMap get();
}
J#
/** property */
public RuntimeMap get_Parent();
JScript
public function get Parent() : RuntimeMap

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Scaleranges Property

RuntimeMapLayer.Scaleranges Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Scaleranges As Double()
C#
public double[] Scaleranges { get; set; }
C++
public property double[] Scaleranges sealed {
array<double>^ get();
void set(array<double>^ value);
}
J#
/** property */
public double[] get_Scaleranges();

/** property */
public void set_Scaleranges(double[] value);
JScript
public function get Scaleranges() : double[]

public function set Scaleranges(value : double[]);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


SchemaName Property

RuntimeMapLayer.SchemaName Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SchemaName As String
C#
public string SchemaName { get; set; }
C++
public property string SchemaName sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SchemaName();

/** property */
public void set_SchemaName(string value);
JScript
public function get SchemaName() : String

public function set SchemaName(value : String);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Selectable Property

RuntimeMapLayer.Selectable Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property Selectable As Boolean
C#
public override bool Selectable { get; set; }
C++
public override property bool Selectable override {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Selectable();

/** property */
public void set_Selectable(bool value);
JScript
public function get Selectable() : bool

public function set Selectable(value : bool);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Type Property

RuntimeMapLayer.Type Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As Integer
C#
public int Type { get; set; }
C++
public property int Type sealed {
int get();
void set(int value);
}
J#
/** property */
public int get_Type();

/** property */
public void set_Type(int value);
JScript
public function get Type() : int

public function set Type(value : int);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Visible Property

RuntimeMapLayer.Visible Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Property Visible As Boolean
C#
public override bool Visible { get; set; }
C++
public override property bool Visible override {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Visible();

/** property */
public void set_Visible(bool value);
JScript
public function get Visible() : bool

public function set Visible(value : bool);

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Methods

RuntimeMapLayer Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetFullPath | Overloaded. Gets the full path of the group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Query | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


GetFullPath Method

RuntimeMapLayer.GetFullPath Method

Gets the full path of the group

Overload List

 | Name | Description
Public method | GetFullPath (String, MapDefinition) | Gets the full path of the group (inherited from MapLayerType)
Public method | GetFullPath (String, RuntimeMap) | Gets the full path of the layer

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


GetFullPath Method (String, RuntimeMap)

RuntimeMapLayer.GetFullPath Method (String, RuntimeMap)
See Also Example
[image]

Gets the full path of the layer

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFullPath( _
ByVal separator As String, _
ByVal parent As RuntimeMap _
) As String
C#
public string GetFullPath(
string separator,
RuntimeMap parent
)
C++
public:
String GetFullPath(
String separator,
RuntimeMap parent
) sealed
J#
public string GetFullPath(
string separator,
RuntimeMap parent
)
JScript
public function GetFullPath(
separator : String,
parent : RuntimeMap
) : String

Parameters

separator
The string used to separate the individual levels
parent
The parent mapdefinition, use null for the current parent

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapLayer.GetFullPath Overload List


Query Method

RuntimeMapLayer.Query Method

Overload List

 | Name | Description
Public method | Query |
Public method | Query (String) |
Public method | Query (String, String) |

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Query Method ()

RuntimeMapLayer.Query Method ()
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Query() As FeatureSetReader
C#
public FeatureSetReader Query()
C++
public:
FeatureSetReader Query() sealed
J#
public FeatureSetReader Query()
JScript
public function Query() : FeatureSetReader

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapLayer.Query Overload List


Query Method (String)

RuntimeMapLayer.Query Method (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Query( _
ByVal filter As String _
) As FeatureSetReader
C#
public FeatureSetReader Query(
string filter
)
C++
public:
FeatureSetReader Query(
String filter
) sealed
J#
public FeatureSetReader Query(
string filter
)
JScript
public function Query(
filter : String
) : FeatureSetReader

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapLayer.Query Overload List


Query Method (String, String[])

RuntimeMapLayer.Query Method (String, String[])
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Query( _
ByVal filter As String, _
ByVal columns As String() _
) As FeatureSetReader
C#
public FeatureSetReader Query(
string filter,
string[] columns
)
C++
public:
FeatureSetReader Query(
String filter,
array<String>^ columns
) sealed
J#
public FeatureSetReader Query(
string filter,
string[] columns
)
JScript
public function Query(
filter : String,
columns : String[]
) : FeatureSetReader

See Also

RuntimeMapLayer Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapLayer.Query Overload List


RuntimeMapLayerCollection Class

RuntimeMapLayerCollection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class RuntimeMapLayerCollection
Inherits CollectionBase
C#
[DefaultMemberAttribute("Item")]
public class RuntimeMapLayerCollection : CollectionBase
C++
[DefaultMemberAttribute(L"Item")]
ref class RuntimeMapLayerCollection : CollectionBase
J#
/** @attribute DefaultMemberAttribute("Item") */
public class RuntimeMapLayerCollection extends CollectionBase
JScript
public
DefaultMemberAttribute("Item")
class RuntimeMapLayerCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMapLayerCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

RuntimeMapLayerCollection Members
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapLayerCollection Members

RuntimeMapLayerCollection Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by RuntimeMapLayerCollection.

Public Constructors

 | Name | Description
Public method | RuntimeMapLayerCollection | Initializes a new instance of the RuntimeMapLayerCollection class.
Top

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Overloaded. Gets or sets a layer based on the layers name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Contains | Gets a value indicating if the layer exists in the map. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf | Gets or sets the index of a layer, given the layer name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Public method | Insert |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RuntimeMapLayerCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


RuntimeMapLayerCollection Constructor

RuntimeMapLayerCollection Constructor
[image]

Initializes a new instance of the RuntimeMapLayerCollection class.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public RuntimeMapLayerCollection()
C++
public:
RuntimeMapLayerCollection() sealed
J#
public RuntimeMapLayerCollection()
JScript
public function RuntimeMapLayerCollection()

See Also

RuntimeMapLayerCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Properties

RuntimeMapLayerCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (inherited from CollectionBase)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. (inherited from CollectionBase)
Public property | Item | Overloaded. Gets or sets a layer based on the layers name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Top

See Also

RuntimeMapLayerCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Item Property

RuntimeMapLayerCollection.Item Property

Gets or sets a layer based on the layers name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.

Overload List

 | Name | Description
Public property | Item (Int32) |
Public property | Item (String) | Gets or sets a layer based on the layers name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.

See Also

RuntimeMapLayerCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Item Property (Int32)

RuntimeMapLayerCollection.Item Property (Int32)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal idx As Integer _
) As RuntimeMapLayer
C#
public RuntimeMapLayer this[
int idx
] { get; set; }
C++
public property RuntimeMapLayer default[int idx] sealed {
RuntimeMapLayer get(int idx);
void set(int idx, RuntimeMapLayer value);
}
J#
/** property */
public RuntimeMapLayer get_Item(int idx);

/** property */
public void set_Item(int idx, RuntimeMapLayer value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

RuntimeMapLayerCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapLayerCollection.Item Overload List


Item Property (String)

RuntimeMapLayerCollection.Item Property (String)
See Also Example
[image]

Gets or sets a layer based on the layers name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal name As String _
) As RuntimeMapLayer
C#
public RuntimeMapLayer this[
string name
] { get; set; }
C++
public property RuntimeMapLayer default[String name] sealed {
RuntimeMapLayer get(String name);
void set(String name, RuntimeMapLayer value);
}
J#
/** property */
public RuntimeMapLayer get_Item(string name);

/** property */
public void set_Item(string name, RuntimeMapLayer value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

RuntimeMapLayerCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
RuntimeMapLayerCollection.Item Overload List


Methods

RuntimeMapLayerCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear | Removes all objects from the CollectionBase instance. (inherited from CollectionBase)
Public method | Contains | Gets a value indicating if the layer exists in the map. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (inherited from CollectionBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IndexOf | Gets or sets the index of a layer, given the layer name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.
Public method | Insert |
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (inherited from CollectionBase)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

RuntimeMapLayerCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Add Method

RuntimeMapLayerCollection.Add Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Add( _
ByVal value As RuntimeMapLayer _
) As Integer
C#
public int Add(
RuntimeMapLayer value
)
C++
public:
int Add(
RuntimeMapLayer value
) sealed
J#
public int Add(
RuntimeMapLayer value
)
JScript
public function Add(
value : RuntimeMapLayer
) : int

See Also

RuntimeMapLayerCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Contains Method

RuntimeMapLayerCollection.Contains Method
[image]

Gets a value indicating if the layer exists in the map. Is case sensitive but will search case insensitive if no layer matches with case sensitive.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal name As String _
) As Boolean
C#
public bool Contains(
string name
)
C++
public:
bool Contains(
String name
) sealed
J#
public bool Contains(
string name
)
JScript
public function Contains(
name : String
) : bool

Parameters

name
The name of the layer

Return Value

True if the layer was found, false otherwise

See Also

RuntimeMapLayerCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


IndexOf Method

RuntimeMapLayerCollection.IndexOf Method
[image]

Gets or sets the index of a layer, given the layer name. Is case sensitive but will search case insensitive if no layer matches with case sensitive.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
ByVal name As String _
) As Integer
C#
public int IndexOf(
string name
)
C++
public:
int IndexOf(
String name
) sealed
J#
public int IndexOf(
string name
)
JScript
public function IndexOf(
name : String
) : int

Parameters

name
The name of the layer

Return Value

The index of the layer, or -1 if no such layer could be found

See Also

RuntimeMapLayerCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Insert Method

RuntimeMapLayerCollection.Insert Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
ByVal index As Integer, _
ByVal layer As RuntimeMapLayer _
)
C#
public void Insert(
int index,
RuntimeMapLayer layer
)
C++
public:
void Insert(
int index,
RuntimeMapLayer layer
) sealed
J#
public void Insert(
int index,
RuntimeMapLayer layer
)
JScript
public function Insert(
index : int,
layer : RuntimeMapLayer
)

See Also

RuntimeMapLayerCollection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Selection Class

Selection Class
See Also Example Members
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class Selection
C#
public class Selection
C++
ref class Selection
J#
public class Selection
JScript
public class Selection

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.Selection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

Selection Members
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Selection Members

Selection Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

The following tables list the members exposed by Selection.

Public Constructors

Name | Description
Selection | Overloaded. Initializes a new instance of the Selection class.
Top

Public Properties

 | Name | Description
Public property | SelectionXml |
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
Selection | Overloaded. Initializes a new instance of the Selection class.
Top

See Also

Selection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Selection Constructor

Selection Constructor

Initializes a new instance of the Selection class.

Overload List

 | Name | Description
Public method | Selection | Initializes a new instance of the Selection class.
Public method | Selection (String) |

See Also

Selection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


Selection Constructor ()

Selection Constructor ()
See Also Example
[image]

Initializes a new instance of the Selection class.

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public Selection()
C++
public:
Selection() sealed
J#
public Selection()
JScript
public function Selection()

See Also

Selection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
Selection Constructor Overload List


Selection Constructor (String)

Selection Constructor (String)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal xml As String _
)
C#
public Selection(
string xml
)
C++
public:
Selection(
String xml
) sealed
J#
public Selection(
string xml
)
JScript
public function Selection(
xml : String
)

See Also

Selection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace
Selection Constructor Overload List


Properties

Selection Properties
[image]

Public Properties

 | Name | Description
Public property | SelectionXml |
Top

See Also

Selection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


SelectionXml Property

Selection.SelectionXml Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.RuntimeClasses
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property SelectionXml As String
C#
public string SelectionXml { get; set; }
C++
public property string SelectionXml sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_SelectionXml();

/** property */
public void set_SelectionXml(string value);
JScript
public function get SelectionXml() : String

public function set SelectionXml(value : String);

See Also

Selection Class
OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


OSGeo.MapGuide.MaestroAPI.XmlSerializer

OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | XmlSerializerAttribute | A decoration attribute for an Xml Serializeable element
Public class | XmlSerializerEngine | An engine that can serialize and deserialize objects using Attributes

Delegates

 | Delegate | Description
NestedPublic delegate | XmlSerializerEngine.DeserializeItem |
NestedPublic delegate | XmlSerializerEngine.SerializeItem |


XmlSerializerAttribute Class

XmlSerializerAttribute Class
See Also Example Members
[image]

A decoration attribute for an Xml Serializeable element

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlSerializerAttribute
Inherits Attribute
C#
public class XmlSerializerAttribute : Attribute
C++
ref class XmlSerializerAttribute : Attribute
J#
public class XmlSerializerAttribute extends Attribute
JScript
public class XmlSerializerAttribute extends Attribute

Inheritance Hierarchy

System.Object
System.Attribute
OSGeo.MapGuide.MaestroAPI.XmlSerializer.XmlSerializerAttribute

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XmlSerializerAttribute Members
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


XmlSerializerAttribute Members

XmlSerializerAttribute Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

A decoration attribute for an Xml Serializeable element

The following tables list the members exposed by XmlSerializerAttribute.

Public Constructors

Name | Description
XmlSerializerAttribute | Overloaded. Initializes a new instance of the XmlSerializerAttribute class.
Top

Public Properties

 | Name | Description
Public property | Attribute |
Public property | ExcludeIfThisValue |
Public property | ExcludeProperty |
Public property | MaxVersion |
Public property | MinVersion |
Public property | NamedTypes |
Public property | Required |
Public property | Text |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Public property | XmlMembername |
Public property | XmlNamespace |
Public property | XmlType |
Top

Public Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetNameOfType |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetTypeOfName |
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
XmlSerializerAttribute | Overloaded. Initializes a new instance of the XmlSerializerAttribute class.
Top

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


XmlSerializerAttribute Constructor

XmlSerializerAttribute Constructor

Initializes a new instance of the XmlSerializerAttribute class.

Overload List

 | Name | Description
Public method | XmlSerializerAttribute | Initializes a new instance of the XmlSerializerAttribute class.
Public method | XmlSerializerAttribute (String, Type, Boolean, Boolean, Version, Version) |

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


XmlSerializerAttribute Constructor ()

XmlSerializerAttribute Constructor ()
See Also Example
[image]

Initializes a new instance of the XmlSerializerAttribute class.

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XmlSerializerAttribute()
C++
public:
XmlSerializerAttribute() sealed
J#
public XmlSerializerAttribute()
JScript
public function XmlSerializerAttribute()

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace
XmlSerializerAttribute Constructor Overload List


XmlSerializerAttribute Constructor (String, Type, Boolean, Boolean, Version, Version)

XmlSerializerAttribute Constructor (String, Type, Boolean, Boolean, Version, Version)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal XmlMembername As String, _
ByVal XmlType As Type, _
ByVal Required As Boolean, _
ByVal Attribute As Boolean, _
ByVal MinVersion As Version, _
ByVal MaxVersion As Version _
)
C#
public XmlSerializerAttribute(
string XmlMembername,
Type XmlType,
bool Required,
bool Attribute,
Version MinVersion,
Version MaxVersion
)
C++
public:
XmlSerializerAttribute(
String XmlMembername,
Type XmlType,
bool Required,
bool Attribute,
Version MinVersion,
Version MaxVersion
) sealed
J#
public XmlSerializerAttribute(
string XmlMembername,
Type XmlType,
bool Required,
bool Attribute,
Version MinVersion,
Version MaxVersion
)
JScript
public function XmlSerializerAttribute(
XmlMembername : String,
XmlType : Type,
Required : bool,
Attribute : bool,
MinVersion : Version,
MaxVersion : Version
)

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace
XmlSerializerAttribute Constructor Overload List


Properties

XmlSerializerAttribute Properties
[image]

Public Properties

 | Name | Description
Public property | Attribute |
Public property | ExcludeIfThisValue |
Public property | ExcludeProperty |
Public property | MaxVersion |
Public property | MinVersion |
Public property | NamedTypes |
Public property | Required |
Public property | Text |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Public property | XmlMembername |
Public property | XmlNamespace |
Public property | XmlType |
Top

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


Attribute Property

XmlSerializerAttribute.Attribute Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Attribute As Boolean
C#
public bool Attribute { get; set; }
C++
public property bool Attribute sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Attribute();

/** property */
public void set_Attribute(bool value);
JScript
public function get Attribute() : bool

public function set Attribute(value : bool);

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


ExcludeIfThisValue Property

XmlSerializerAttribute.ExcludeIfThisValue Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExcludeIfThisValue As String
C#
public string ExcludeIfThisValue { get; set; }
C++
public property string ExcludeIfThisValue sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ExcludeIfThisValue();

/** property */
public void set_ExcludeIfThisValue(string value);
JScript
public function get ExcludeIfThisValue() : String

public function set ExcludeIfThisValue(value : String);

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


ExcludeProperty Property

XmlSerializerAttribute.ExcludeProperty Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property ExcludeProperty As String
C#
public string ExcludeProperty { get; set; }
C++
public property string ExcludeProperty sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_ExcludeProperty();

/** property */
public void set_ExcludeProperty(string value);
JScript
public function get ExcludeProperty() : String

public function set ExcludeProperty(value : String);

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


MaxVersion Property

XmlSerializerAttribute.MaxVersion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxVersion As Version
C#
public Version MaxVersion { get; set; }
C++
public property Version MaxVersion sealed {
Version get();
void set(Version value);
}
J#
/** property */
public Version get_MaxVersion();

/** property */
public void set_MaxVersion(Version value);
JScript
public function get MaxVersion() : Version

public function set MaxVersion(value : Version);

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


MinVersion Property

XmlSerializerAttribute.MinVersion Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property MinVersion As Version
C#
public Version MinVersion { get; set; }
C++
public property Version MinVersion sealed {
Version get();
void set(Version value);
}
J#
/** property */
public Version get_MinVersion();

/** property */
public void set_MinVersion(Version value);
JScript
public function get MinVersion() : Version

public function set MinVersion(value : Version);

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


NamedTypes Property

XmlSerializerAttribute.NamedTypes Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property NamedTypes As String()
C#
public string[] NamedTypes { get; set; }
C++
public property string[] NamedTypes sealed {
array<String>^ get();
void set(array<String>^ value);
}
J#
/** property */
public string[] get_NamedTypes();

/** property */
public void set_NamedTypes(string[] value);
JScript
public function get NamedTypes() : String[]

public function set NamedTypes(value : String[]);

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


Required Property

XmlSerializerAttribute.Required Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Required As Boolean
C#
public bool Required { get; set; }
C++
public property bool Required sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Required();

/** property */
public void set_Required(bool value);
JScript
public function get Required() : bool

public function set Required(value : bool);

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


Text Property

XmlSerializerAttribute.Text Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property Text As Boolean
C#
public bool Text { get; set; }
C++
public property bool Text sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Text();

/** property */
public void set_Text(bool value);
JScript
public function get Text() : bool

public function set Text(value : bool);

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


XmlMembername Property

XmlSerializerAttribute.XmlMembername Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlMembername As String
C#
public string XmlMembername { get; set; }
C++
public property string XmlMembername sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_XmlMembername();

/** property */
public void set_XmlMembername(string value);
JScript
public function get XmlMembername() : String

public function set XmlMembername(value : String);

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


XmlNamespace Property

XmlSerializerAttribute.XmlNamespace Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlNamespace As String
C#
public string XmlNamespace { get; set; }
C++
public property string XmlNamespace sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_XmlNamespace();

/** property */
public void set_XmlNamespace(string value);
JScript
public function get XmlNamespace() : String

public function set XmlNamespace(value : String);

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


XmlType Property

XmlSerializerAttribute.XmlType Property
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlType As Type
C#
public Type XmlType { get; set; }
C++
public property Type XmlType sealed {
Type get();
void set(Type value);
}
J#
/** property */
public Type get_XmlType();

/** property */
public void set_XmlType(Type value);
JScript
public function get XmlType() : Type

public function set XmlType(value : Type);

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


Methods

XmlSerializerAttribute Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetNameOfType |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetTypeOfName |
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


GetNameOfType Method

XmlSerializerAttribute.GetNameOfType Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNameOfType( _
ByVal type As Type _
) As String
C#
public string GetNameOfType(
Type type
)
C++
public:
String GetNameOfType(
Type type
) sealed
J#
public string GetNameOfType(
Type type
)
JScript
public function GetNameOfType(
type : Type
) : String

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


GetTypeOfName Method

XmlSerializerAttribute.GetTypeOfName Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function GetTypeOfName( _
ByVal name As String _
) As Type
C#
public Type GetTypeOfName(
string name
)
C++
public:
Type GetTypeOfName(
String name
) sealed
J#
public Type GetTypeOfName(
string name
)
JScript
public function GetTypeOfName(
name : String
) : Type

See Also

XmlSerializerAttribute Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


XmlSerializerEngine Class

XmlSerializerEngine Class
See Also Example Members
[image]

An engine that can serialize and deserialize objects using Attributes

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlSerializerEngine
C#
public class XmlSerializerEngine
C++
ref class XmlSerializerEngine
J#
public class XmlSerializerEngine
JScript
public class XmlSerializerEngine

Inheritance Hierarchy

System.Object
OSGeo.MapGuide.MaestroAPI.XmlSerializer.XmlSerializerEngine

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

XmlSerializerEngine Members
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


XmlSerializerEngine Members

XmlSerializerEngine Members
See Also Example Constructors Methods
[image]

An engine that can serialize and deserialize objects using Attributes

The following tables list the members exposed by XmlSerializerEngine.

Public Constructors

 | Name | Description
Public method | XmlSerializerEngine | Initializes a new instance of the XmlSerializerEngine class.
Top

Public Methods

 | Name | Description
Public method | AddSerialize |
Public method | Deserialize | Overloaded.
Public method | DeserializeElement |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Serialize | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XmlSerializerEngine Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


XmlSerializerEngine Constructor

XmlSerializerEngine Constructor
[image]

Initializes a new instance of the XmlSerializerEngine class.

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public XmlSerializerEngine()
C++
public:
XmlSerializerEngine() sealed
J#
public XmlSerializerEngine()
JScript
public function XmlSerializerEngine()

See Also

XmlSerializerEngine Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


Methods

XmlSerializerEngine Methods
[image]

Public Methods

 | Name | Description
Public method | AddSerialize |
Public method | Deserialize | Overloaded.
Public method | DeserializeElement |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Serialize | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

XmlSerializerEngine Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


AddSerialize Method

XmlSerializerEngine.AddSerialize Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddSerialize( _
ByVal type As Type, _
ByVal serializer As XmlSerializerEngine.SerializeItem, _
ByVal deserializer As XmlSerializerEngine.DeserializeItem _
)
C#
public void AddSerialize(
Type type,
XmlSerializerEngine.SerializeItem serializer,
XmlSerializerEngine.DeserializeItem deserializer
)
C++
public:
void AddSerialize(
Type type,
XmlSerializerEngine.SerializeItem serializer,
XmlSerializerEngine.DeserializeItem deserializer
) sealed
J#
public void AddSerialize(
Type type,
XmlSerializerEngine.SerializeItem serializer,
XmlSerializerEngine.DeserializeItem deserializer
)
JScript
public function AddSerialize(
type : Type,
serializer : XmlSerializerEngine.SerializeItem,
deserializer : XmlSerializerEngine.DeserializeItem
)

See Also

XmlSerializerEngine Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


Deserialize Method

XmlSerializerEngine.Deserialize Method

Overload List

 | Name | Description
Public method | Deserialize (XmlDocument, Type, Object, Version) |
Public method | Deserialize (XmlDocument, Type, Version) |

See Also

XmlSerializerEngine Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


Deserialize Method (XmlDocument, Type, Object[], Version)

XmlSerializerEngine.Deserialize Method (XmlDocument, Type, Object[], Version)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize( _
ByVal doc As XmlDocument, _
ByVal targetType As Type, _
ByVal constructorparams As Object(), _
ByVal version As Version _
) As Object
C#
public object Deserialize(
XmlDocument doc,
Type targetType,
object[] constructorparams,
Version version
)
C++
public:
Object Deserialize(
XmlDocument doc,
Type targetType,
array<Object>^ constructorparams,
Version version
) sealed
J#
public object Deserialize(
XmlDocument doc,
Type targetType,
object[] constructorparams,
Version version
)
JScript
public function Deserialize(
doc : XmlDocument,
targetType : Type,
constructorparams : Object[],
version : Version
) : Object

See Also

XmlSerializerEngine Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace
XmlSerializerEngine.Deserialize Overload List


Deserialize Method (XmlDocument, Type, Version)

XmlSerializerEngine.Deserialize Method (XmlDocument, Type, Version)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Deserialize( _
ByVal doc As XmlDocument, _
ByVal targetType As Type, _
ByVal version As Version _
) As Object
C#
public object Deserialize(
XmlDocument doc,
Type targetType,
Version version
)
C++
public:
Object Deserialize(
XmlDocument doc,
Type targetType,
Version version
) sealed
J#
public object Deserialize(
XmlDocument doc,
Type targetType,
Version version
)
JScript
public function Deserialize(
doc : XmlDocument,
targetType : Type,
version : Version
) : Object

See Also

XmlSerializerEngine Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace
XmlSerializerEngine.Deserialize Overload List


DeserializeElement Method

XmlSerializerEngine.DeserializeElement Method
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeserializeElement( _
ByVal parent As XmlNode, _
ByVal targetItem As Object, _
ByVal targetType As Type, _
ByVal pi As PropertyInfo, _
ByVal version As Version _
)
C#
public void DeserializeElement(
XmlNode parent,
object targetItem,
Type targetType,
PropertyInfo pi,
Version version
)
C++
public:
void DeserializeElement(
XmlNode parent,
Object targetItem,
Type targetType,
PropertyInfo pi,
Version version
) sealed
J#
public void DeserializeElement(
XmlNode parent,
object targetItem,
Type targetType,
PropertyInfo pi,
Version version
)
JScript
public function DeserializeElement(
parent : XmlNode,
targetItem : Object,
targetType : Type,
pi : PropertyInfo,
version : Version
)

See Also

XmlSerializerEngine Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


Serialize Method

XmlSerializerEngine.Serialize Method

Overload List

 | Name | Description
Public method | Serialize (Object, PropertyInfo) |
Public method | Serialize (Object, Version) |

See Also

XmlSerializerEngine Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


Serialize Method (Object, PropertyInfo)

XmlSerializerEngine.Serialize Method (Object, PropertyInfo)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Serialize( _
ByVal item As Object, _
ByVal versionProperty As PropertyInfo _
) As XmlDocument
C#
public XmlDocument Serialize(
object item,
PropertyInfo versionProperty
)
C++
public:
XmlDocument Serialize(
Object item,
PropertyInfo versionProperty
) sealed
J#
public XmlDocument Serialize(
object item,
PropertyInfo versionProperty
)
JScript
public function Serialize(
item : Object,
versionProperty : PropertyInfo
) : XmlDocument

See Also

XmlSerializerEngine Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace
XmlSerializerEngine.Serialize Overload List


Serialize Method (Object, Version)

XmlSerializerEngine.Serialize Method (Object, Version)
See Also Example
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Function Serialize( _
ByVal item As Object, _
ByVal version As Version _
) As XmlDocument
C#
public XmlDocument Serialize(
object item,
Version version
)
C++
public:
XmlDocument Serialize(
Object item,
Version version
) sealed
J#
public XmlDocument Serialize(
object item,
Version version
)
JScript
public function Serialize(
item : Object,
version : Version
) : XmlDocument

See Also

XmlSerializerEngine Class
OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace
XmlSerializerEngine.Serialize Overload List


XmlSerializerEngine.DeserializeItem Delegate

XmlSerializerEngine.DeserializeItem Delegate
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function XmlSerializerEngine.DeserializeItem( _
ByVal value As Object, _
ByVal target As Object, _
ByVal attribute As XmlSerializerAttribute _
) As String
C#
public delegate string XmlSerializerEngine.DeserializeItem(
object value,
object target,
XmlSerializerAttribute attribute
)
C++
public delegate String XmlSerializerEngine.DeserializeItem(
Object value,
Object target,
XmlSerializerAttribute attribute
)
J#
/** delegate */
public delegate string XmlSerializerEngine.DeserializeItem(
object value,
object target,
XmlSerializerAttribute attribute
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


XmlSerializerEngine.SerializeItem Delegate

XmlSerializerEngine.SerializeItem Delegate
[image]

Namespace: OSGeo.MapGuide.MaestroAPI.XmlSerializer
Assembly: OSGeo.MapGuide.MaestroAPI (in OSGeo.MapGuide.MaestroAPI.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Function XmlSerializerEngine.SerializeItem( _
ByVal value As Object, _
ByVal parent As Object, _
ByVal attribute As XmlSerializerAttribute _
) As String
C#
public delegate string XmlSerializerEngine.SerializeItem(
object value,
object parent,
XmlSerializerAttribute attribute
)
C++
public delegate String XmlSerializerEngine.SerializeItem(
Object value,
Object parent,
XmlSerializerAttribute attribute
)
J#
/** delegate */
public delegate string XmlSerializerEngine.SerializeItem(
object value,
object parent,
XmlSerializerAttribute attribute
)
JScript
JScript suports the use of delegates, but not the declaration of new ones.

See Also

OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


OSGeo.MapGuide.MaestroAPI Hierarchy

OSGeo.MapGuide.MaestroAPI Hierarchy
System.Object
OSGeo.MapGuide.MaestroAPI.AllowedValueType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionContainerInfoSet
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionContainerInfoType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionPanelType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionTemplateInfoSet
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionTemplateInfoType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionWidgetInfoSet
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionWidgetInfoType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionWidgetParameterType
OSGeo.MapGuide.MaestroAPI.AreaRuleType
OSGeo.MapGuide.MaestroAPI.AreaSymbolizationType
OSGeo.MapGuide.MaestroAPI.AreaSymbolizationFillType
OSGeo.MapGuide.MaestroAPI.AreaTypeStyleType
OSGeo.MapGuide.MaestroAPI.AreaUsage
OSGeo.MapGuide.MaestroAPI.AttributeRelateType
OSGeo.MapGuide.MaestroAPI.BaseLayerDefinitionType
OSGeo.MapGuide.MaestroAPI.DrawingLayerDefinitionType
OSGeo.MapGuide.MaestroAPI.GridLayerDefinitionType
OSGeo.MapGuide.MaestroAPI.VectorLayerDefinitionType
OSGeo.MapGuide.MaestroAPI.BaseMapLayerType
OSGeo.MapGuide.MaestroAPI.MapLayerType
OSGeo.MapGuide.MaestroAPI.Box2DType
OSGeo.MapGuide.MaestroAPI.CalculatedPropertyType
OSGeo.MapGuide.MaestroAPI.Change
OSGeo.MapGuide.MaestroAPI.ChangeList
OSGeo.MapGuide.MaestroAPI.ChannelBandType
OSGeo.MapGuide.MaestroAPI.CommandType
OSGeo.MapGuide.MaestroAPI.BasicCommandType
OSGeo.MapGuide.MaestroAPI.CustomCommandType
OSGeo.MapGuide.MaestroAPI.InvokeScriptCommandType
OSGeo.MapGuide.MaestroAPI.PrintCommandType
OSGeo.MapGuide.MaestroAPI.TargetedCommandType
OSGeo.MapGuide.MaestroAPI.BufferCommandType
OSGeo.MapGuide.MaestroAPI.GetPrintablePageCommandType
OSGeo.MapGuide.MaestroAPI.HelpCommandType
OSGeo.MapGuide.MaestroAPI.InvokeURLCommandType
OSGeo.MapGuide.MaestroAPI.MeasureCommandType
OSGeo.MapGuide.MaestroAPI.SearchCommandType
OSGeo.MapGuide.MaestroAPI.SelectWithinCommandType
OSGeo.MapGuide.MaestroAPI.ViewOptionsCommandType
OSGeo.MapGuide.MaestroAPI.CompositeRule
OSGeo.MapGuide.MaestroAPI.CompositeSymbolization
OSGeo.MapGuide.MaestroAPI.CompositeTypeStyle
OSGeo.MapGuide.MaestroAPI.CoordinateSystem
OSGeo.MapGuide.MaestroAPI.CoordinateSystem.Category
OSGeo.MapGuide.MaestroAPI.CoordinateSystem.CoordSys
OSGeo.MapGuide.MaestroAPI.DataStoreItem
OSGeo.MapGuide.MaestroAPI.DataStoreList
OSGeo.MapGuide.MaestroAPI.DrawingSection
OSGeo.MapGuide.MaestroAPI.DrawingSectionList
OSGeo.MapGuide.MaestroAPI.DrawingSectionResource
OSGeo.MapGuide.MaestroAPI.DrawingSectionResourceList
OSGeo.MapGuide.MaestroAPI.DrawingSource
OSGeo.MapGuide.MaestroAPI.DrawingSourceSheet
OSGeo.MapGuide.MaestroAPI.DrawingSourceSheetExtent
OSGeo.MapGuide.MaestroAPI.DwgComponentType
OSGeo.MapGuide.MaestroAPI.DwgDriveAliasType
OSGeo.MapGuide.MaestroAPI.ElevationSettingsType
OSGeo.MapGuide.MaestroAPI.Envelope
OSGeo.MapGuide.MaestroAPI.EnvelopeLowerLeftCoordinate
OSGeo.MapGuide.MaestroAPI.EnvelopeUpperRightCoordinate
OSGeo.MapGuide.MaestroAPI.ExtendedDataType
OSGeo.MapGuide.MaestroAPI.FdoLongTransactionList
OSGeo.MapGuide.MaestroAPI.FdoLongTransactionListLongTransaction
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilities
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesCommand
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesConnection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpression
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionFunctionDefinition
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinition
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesFilter
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesGeometry
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesProvider
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesRaster
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesSchema
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesTopology
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextList
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextListSpatialContext
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextListSpatialContextExtent
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextListSpatialContextExtentLowerLeftCoordinate
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextListSpatialContextExtentUpperRightCoordinate
OSGeo.MapGuide.MaestroAPI.FeatureProviderRegistry
OSGeo.MapGuide.MaestroAPI.FeatureProviderRegistryFeatureProvider
OSGeo.MapGuide.MaestroAPI.FeatureProviderRegistryFeatureProviderConnectionProperty
OSGeo.MapGuide.MaestroAPI.FeatureSet
OSGeo.MapGuide.MaestroAPI.FeatureSetColumn
OSGeo.MapGuide.MaestroAPI.FeatureSetLayer
OSGeo.MapGuide.MaestroAPI.FeatureSetLayerClass
OSGeo.MapGuide.MaestroAPI.FeatureSetReader ---- System.IDisposable
OSGeo.MapGuide.MaestroAPI.FeatureSetRow
OSGeo.MapGuide.MaestroAPI.FeatureSource
OSGeo.MapGuide.MaestroAPI.FeatureSourceDescription
OSGeo.MapGuide.MaestroAPI.FeatureSourceDescription.FeatureSourceSchema
OSGeo.MapGuide.MaestroAPI.FeatureSourceTypeExtension
OSGeo.MapGuide.MaestroAPI.FillType
OSGeo.MapGuide.MaestroAPI.GeoReferenceOverrideType
OSGeo.MapGuide.MaestroAPI.GraphicBase
OSGeo.MapGuide.MaestroAPI.Image
OSGeo.MapGuide.MaestroAPI.Path
OSGeo.MapGuide.MaestroAPI.Text
OSGeo.MapGuide.MaestroAPI.GridColorBandsType
OSGeo.MapGuide.MaestroAPI.GridColorRuleType
OSGeo.MapGuide.MaestroAPI.GridColorStyleType
OSGeo.MapGuide.MaestroAPI.GridColorType
OSGeo.MapGuide.MaestroAPI.GridScaleRangeType
OSGeo.MapGuide.MaestroAPI.GridSurfaceStyleType
OSGeo.MapGuide.MaestroAPI.Group
OSGeo.MapGuide.MaestroAPI.GroupList
OSGeo.MapGuide.MaestroAPI.GroupListGroup
OSGeo.MapGuide.MaestroAPI.GroupUsers
OSGeo.MapGuide.MaestroAPI.GroupUsersUser
OSGeo.MapGuide.MaestroAPI.HillShadeType
OSGeo.MapGuide.MaestroAPI.ImageReference
OSGeo.MapGuide.MaestroAPI.ImageSymbolTypeImage
OSGeo.MapGuide.MaestroAPI.LayerDefinitionType
OSGeo.MapGuide.MaestroAPI.LayerDefinition
OSGeo.MapGuide.MaestroAPI.LengthyOperationCallbackArgs
OSGeo.MapGuide.MaestroAPI.LengthyOperationCallbackArgs.LengthyOperationItem
OSGeo.MapGuide.MaestroAPI.LengthyOperationProgressArgs
OSGeo.MapGuide.MaestroAPI.LineRuleType
OSGeo.MapGuide.MaestroAPI.LineTypeStyleType
OSGeo.MapGuide.MaestroAPI.LineUsage
OSGeo.MapGuide.MaestroAPI.LoadProcedureType
OSGeo.MapGuide.MaestroAPI.DwfLoadProcedureType
OSGeo.MapGuide.MaestroAPI.DwgLoadProcedureType
OSGeo.MapGuide.MaestroAPI.RasterLoadProcedureType
OSGeo.MapGuide.MaestroAPI.SdfLoadProcedureType
OSGeo.MapGuide.MaestroAPI.ShpLoadProcedureType
OSGeo.MapGuide.MaestroAPI.LoadProcedureTypeType
OSGeo.MapGuide.MaestroAPI.LoadProcedure
OSGeo.MapGuide.MaestroAPI.MapDefinition
OSGeo.MapGuide.MaestroAPI.MapDefinitionTypeBaseMapDefinition
OSGeo.MapGuide.MaestroAPI.MapLayerGroupCommonType
OSGeo.MapGuide.MaestroAPI.BaseMapLayerGroupCommonType
OSGeo.MapGuide.MaestroAPI.MapLayerGroupType
OSGeo.MapGuide.MaestroAPI.MapViewType
OSGeo.MapGuide.MaestroAPI.NameStringPairType
OSGeo.MapGuide.MaestroAPI.NameValuePairType
OSGeo.MapGuide.MaestroAPI.Override
OSGeo.MapGuide.MaestroAPI.Parameter
OSGeo.MapGuide.MaestroAPI.ParameterDefinition
OSGeo.MapGuide.MaestroAPI.ParameterOverrides
OSGeo.MapGuide.MaestroAPI.ParameterPairType
OSGeo.MapGuide.MaestroAPI.PointRuleType
OSGeo.MapGuide.MaestroAPI.PointSymbolization2DType
OSGeo.MapGuide.MaestroAPI.PointTypeStyleType
OSGeo.MapGuide.MaestroAPI.PointUsage
OSGeo.MapGuide.MaestroAPI.PrintLayout
OSGeo.MapGuide.MaestroAPI.PrintLayoutLayoutProperties
OSGeo.MapGuide.MaestroAPI.PrintLayoutLogo
OSGeo.MapGuide.MaestroAPI.PrintLayoutLogoPosition
OSGeo.MapGuide.MaestroAPI.PrintLayoutLogoSize
OSGeo.MapGuide.MaestroAPI.PrintLayoutPageProperties
OSGeo.MapGuide.MaestroAPI.PrintLayoutPagePropertiesBackgroundColor
OSGeo.MapGuide.MaestroAPI.PrintLayoutText
OSGeo.MapGuide.MaestroAPI.PrintLayoutTextFont
OSGeo.MapGuide.MaestroAPI.PrintLayoutTextPosition
OSGeo.MapGuide.MaestroAPI.PropertiesType
OSGeo.MapGuide.MaestroAPI.PropertySetTypeProperties
OSGeo.MapGuide.MaestroAPI.PropertyCollectionType
OSGeo.MapGuide.MaestroAPI.PropertySetTypePropertiesPropertyCollection
OSGeo.MapGuide.MaestroAPI.PropertyDefinitionsType
OSGeo.MapGuide.MaestroAPI.PropertySetTypePropertyDefinitions
OSGeo.MapGuide.MaestroAPI.PropertyDefinitionType
OSGeo.MapGuide.MaestroAPI.PropertySetType
OSGeo.MapGuide.MaestroAPI.PropertyType
OSGeo.MapGuide.MaestroAPI.RelatePropertyType
OSGeo.MapGuide.MaestroAPI.RepositoryContentType
OSGeo.MapGuide.MaestroAPI.ResizeBox
OSGeo.MapGuide.MaestroAPI.ResourceDataList
OSGeo.MapGuide.MaestroAPI.ResourceDataListResourceData
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderType
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderTypeGeneral
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderTypeMetadata
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderTypeMetadataSimple
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderTypeMetadataSimpleProperty
OSGeo.MapGuide.MaestroAPI.ResourceFolderHeaderType
OSGeo.MapGuide.MaestroAPI.ResourceIdentifier
OSGeo.MapGuide.MaestroAPI.ResourceList
OSGeo.MapGuide.MaestroAPI.ResourceListResourceDocument
OSGeo.MapGuide.MaestroAPI.ResourceListResourceFolder
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifest
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperations
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperationsOperation
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperationsOperationParameters
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperationsOperationParametersParameter
OSGeo.MapGuide.MaestroAPI.ResourceReferenceList
OSGeo.MapGuide.MaestroAPI.ResourceReferenceType
OSGeo.MapGuide.MaestroAPI.MapType
OSGeo.MapGuide.MaestroAPI.ResourceSecurityType
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeGroups
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeGroupsGroup
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeUsers
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeUsersUser
OSGeo.MapGuide.MaestroAPI.ResultColumnType
OSGeo.MapGuide.MaestroAPI.Role
OSGeo.MapGuide.MaestroAPI.RoleGroups
OSGeo.MapGuide.MaestroAPI.RoleGroupsGroup
OSGeo.MapGuide.MaestroAPI.RoleUsers
OSGeo.MapGuide.MaestroAPI.RoleUsersUser
OSGeo.MapGuide.MaestroAPI.RowCollectionType
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeColumnDefinitionsColumn
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeRowColumn
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeRowColumnName
OSGeo.MapGuide.MaestroAPI.RowType
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeRow
OSGeo.MapGuide.MaestroAPI.ServerConnectionBase
OSGeo.MapGuide.MaestroAPI.HttpServerConnection ---- OSGeo.MapGuide.MaestroAPI.ServerConnectionI, System.IDisposable
OSGeo.MapGuide.MaestroAPI.LocalNativeConnection ---- OSGeo.MapGuide.MaestroAPI.ServerConnectionI, System.IDisposable
OSGeo.MapGuide.MaestroAPI.ServerConnectionI ---- System.IDisposable
OSGeo.MapGuide.MaestroAPI.ServerType
OSGeo.MapGuide.MaestroAPI.SimpleSymbol
OSGeo.MapGuide.MaestroAPI.SiteInformation
OSGeo.MapGuide.MaestroAPI.SiteInformationSiteServer
OSGeo.MapGuide.MaestroAPI.SiteInformationSiteServerOperatingSystem
OSGeo.MapGuide.MaestroAPI.SiteInformationStatistics
OSGeo.MapGuide.MaestroAPI.SiteVersion
OSGeo.MapGuide.MaestroAPI.SiteVersions
OSGeo.MapGuide.MaestroAPI.SpatialContextType
OSGeo.MapGuide.MaestroAPI.StrokeType
OSGeo.MapGuide.MaestroAPI.SymbolDefinitionBase
OSGeo.MapGuide.MaestroAPI.CompoundSymbolDefinition
OSGeo.MapGuide.MaestroAPI.SimpleSymbolDefinition
OSGeo.MapGuide.MaestroAPI.SimpleSymbolDefinition1
OSGeo.MapGuide.MaestroAPI.SymbolInstance
OSGeo.MapGuide.MaestroAPI.SymbolLibraryType
OSGeo.MapGuide.MaestroAPI.SymbolType
OSGeo.MapGuide.MaestroAPI.BlockSymbolType
OSGeo.MapGuide.MaestroAPI.FontSymbolType
OSGeo.MapGuide.MaestroAPI.ImageSymbolType
OSGeo.MapGuide.MaestroAPI.MarkSymbolType
OSGeo.MapGuide.MaestroAPI.TextSymbolType
OSGeo.MapGuide.MaestroAPI.W2DSymbolType
OSGeo.MapGuide.MaestroAPI.SymbolTypeLibrary
OSGeo.MapGuide.MaestroAPI.TaskButtonType
OSGeo.MapGuide.MaestroAPI.TextFrame
OSGeo.MapGuide.MaestroAPI.TextSymbolTypeAdvancedPlacement
OSGeo.MapGuide.MaestroAPI.ThemeLabel
OSGeo.MapGuide.MaestroAPI.UIItemType
OSGeo.MapGuide.MaestroAPI.CommandItemType
OSGeo.MapGuide.MaestroAPI.FlyoutItemType
OSGeo.MapGuide.MaestroAPI.SeparatorItemType
OSGeo.MapGuide.MaestroAPI.UnmanagedDataList
OSGeo.MapGuide.MaestroAPI.UnmanagedDataListUnmanagedDataFile
OSGeo.MapGuide.MaestroAPI.UnmanagedDataListUnmanagedDataFolder
OSGeo.MapGuide.MaestroAPI.User
OSGeo.MapGuide.MaestroAPI.UserList
OSGeo.MapGuide.MaestroAPI.UserListGroup
OSGeo.MapGuide.MaestroAPI.UserListUser
OSGeo.MapGuide.MaestroAPI.Utility
OSGeo.MapGuide.MaestroAPI.VectorScaleRangeType
OSGeo.MapGuide.MaestroAPI.W2DSymbolTypeW2DSymbol
OSGeo.MapGuide.MaestroAPI.WebLayout
OSGeo.MapGuide.MaestroAPI.WebLayoutControlType
OSGeo.MapGuide.MaestroAPI.ContextMenuType
OSGeo.MapGuide.MaestroAPI.StatusBarType
OSGeo.MapGuide.MaestroAPI.TaskBarType
OSGeo.MapGuide.MaestroAPI.ToolBarType
OSGeo.MapGuide.MaestroAPI.WebLayoutResizableControlType
OSGeo.MapGuide.MaestroAPI.InformationPaneType
OSGeo.MapGuide.MaestroAPI.TaskPaneType
OSGeo.MapGuide.MaestroAPI.ZoomControlType
OSGeo.MapGuide.MaestroAPI.XMLValidator
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
OSGeo.MapGuide.MaestroAPI.AllowedValueTypeCollection
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionContainerInfoTypeCollection
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionPanelTypeCollection
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionTemplateInfoTypeCollection
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionWidgetInfoTypeCollection
OSGeo.MapGuide.MaestroAPI.ApplicationDefinitionWidgetParameterTypeCollection
OSGeo.MapGuide.MaestroAPI.AreaRuleTypeCollection
OSGeo.MapGuide.MaestroAPI.AttributeRelateTypeCollection
OSGeo.MapGuide.MaestroAPI.BaseMapLayerGroupCommonTypeCollection
OSGeo.MapGuide.MaestroAPI.BaseMapLayerTypeCollection
OSGeo.MapGuide.MaestroAPI.CalculatedPropertyTypeCollection
OSGeo.MapGuide.MaestroAPI.CommandTypeCollection
OSGeo.MapGuide.MaestroAPI.CompositeRuleCollection
OSGeo.MapGuide.MaestroAPI.DataStoreItemCollection
OSGeo.MapGuide.MaestroAPI.DoubleCollection
OSGeo.MapGuide.MaestroAPI.DrawingSectionCollection
OSGeo.MapGuide.MaestroAPI.DrawingSectionResourceCollection
OSGeo.MapGuide.MaestroAPI.DrawingSourceSheetCollection
OSGeo.MapGuide.MaestroAPI.DwgComponentTypeCollection
OSGeo.MapGuide.MaestroAPI.DwgDriveAliasTypeCollection
OSGeo.MapGuide.MaestroAPI.FdoLongTransactionListLongTransactionCollection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesCommandNameCollection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesConnectionTypeCollection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionCollection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionFunctionDefinitionCollection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionNameCollection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesFilterOperation1Collection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesFilterOperationCollection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesFilterTypeCollection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesGeometryType1Collection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesGeometryTypeCollection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesSchemaType1Collection
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesSchemaTypeCollection
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextListSpatialContextCollection
OSGeo.MapGuide.MaestroAPI.FeatureProviderRegistryFeatureProviderCollection
OSGeo.MapGuide.MaestroAPI.FeatureProviderRegistryFeatureProviderConnectionPropertyCollection
OSGeo.MapGuide.MaestroAPI.FeatureSetLayerClassCollection
OSGeo.MapGuide.MaestroAPI.FeatureSetLayerCollection
OSGeo.MapGuide.MaestroAPI.FeatureSourceTypeExtensionCollection
OSGeo.MapGuide.MaestroAPI.GeoReferenceOverrideTypeCollection
OSGeo.MapGuide.MaestroAPI.GraphicBaseCollection
OSGeo.MapGuide.MaestroAPI.GridColorRuleTypeCollection
OSGeo.MapGuide.MaestroAPI.GridScaleRangeTypeCollection
OSGeo.MapGuide.MaestroAPI.GroupListGroupCollection
OSGeo.MapGuide.MaestroAPI.GroupUsersUserCollection
OSGeo.MapGuide.MaestroAPI.LineRuleTypeCollection
OSGeo.MapGuide.MaestroAPI.MapLayerGroupTypeCollection
OSGeo.MapGuide.MaestroAPI.MapLayerTypeCollection
OSGeo.MapGuide.MaestroAPI.NameStringPairTypeCollection
OSGeo.MapGuide.MaestroAPI.NameValuePairTypeCollection
OSGeo.MapGuide.MaestroAPI.OverrideCollection
OSGeo.MapGuide.MaestroAPI.ParameterCollection
OSGeo.MapGuide.MaestroAPI.ParameterPairTypeCollection
OSGeo.MapGuide.MaestroAPI.PointRuleTypeCollection
OSGeo.MapGuide.MaestroAPI.PrintLayoutLogoCollection
OSGeo.MapGuide.MaestroAPI.PrintLayoutTextCollection
OSGeo.MapGuide.MaestroAPI.PropertyDefinitionTypeCollection
OSGeo.MapGuide.MaestroAPI.PropertySetTypePropertiesPropertyCollectionCollection
OSGeo.MapGuide.MaestroAPI.PropertyTypeCollection
OSGeo.MapGuide.MaestroAPI.RelatePropertyTypeCollection
OSGeo.MapGuide.MaestroAPI.ResourceDataListResourceDataCollection
OSGeo.MapGuide.MaestroAPI.ResourceDocumentHeaderTypeMetadataSimplePropertyCollection
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperationsOperationCollection
OSGeo.MapGuide.MaestroAPI.ResourcePackageManifestOperationsOperationParametersParameterCollection
OSGeo.MapGuide.MaestroAPI.ResourceReferenceTypeCollection
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeGroupsGroupCollection
OSGeo.MapGuide.MaestroAPI.ResourceSecurityTypeUsersUserCollection
OSGeo.MapGuide.MaestroAPI.ResultColumnTypeCollection
OSGeo.MapGuide.MaestroAPI.RoleGroupsGroupCollection
OSGeo.MapGuide.MaestroAPI.RoleUsersUserCollection
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeColumnDefinitionsColumnCollection
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeRowCollection
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeRowColumnCollection
OSGeo.MapGuide.MaestroAPI.SimpleSymbolCollection
OSGeo.MapGuide.MaestroAPI.SpatialContextTypeCollection
OSGeo.MapGuide.MaestroAPI.StrokeTypeCollection
OSGeo.MapGuide.MaestroAPI.SymbolInstanceCollection
OSGeo.MapGuide.MaestroAPI.SymbolTypeLibraryCollection
OSGeo.MapGuide.MaestroAPI.UIItemTypeCollection
OSGeo.MapGuide.MaestroAPI.VectorScaleRangeTypeCollection
OSGeo.MapGuide.MaestroAPI.XmlElementCollection
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
OSGeo.MapGuide.MaestroAPI.LengthyOperationCallBack
OSGeo.MapGuide.MaestroAPI.LengthyOperationProgressCallBack
OSGeo.MapGuide.MaestroAPI.Utility.StreamCopyProgressDelegate
System.MarshalByRefObject
System.IO.Stream ---- System.IDisposable
OSGeo.MapGuide.MaestroAPI.FileBufferedStreamReader
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
OSGeo.MapGuide.MaestroAPI.BackgroundStyleType
OSGeo.MapGuide.MaestroAPI.BasicCommandActionType
OSGeo.MapGuide.MaestroAPI.Change.ChangeType
OSGeo.MapGuide.MaestroAPI.DataType
OSGeo.MapGuide.MaestroAPI.DwgComponentTypeType
OSGeo.MapGuide.MaestroAPI.DwgResourceTypeType
OSGeo.MapGuide.MaestroAPI.ElevationTypeType
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesCommandName
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesConnectionThreadCapability
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesConnectionType
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionFunctionDefinitionArgumentDefinitionDataType
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionFunctionDefinitionReturnType
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesExpressionName
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesFilterOperation
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesFilterOperation1
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesFilterType
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesGeometryType
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesGeometryType1
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesSchemaType
OSGeo.MapGuide.MaestroAPI.FdoProviderCapabilitiesSchemaType1
OSGeo.MapGuide.MaestroAPI.FdoSpatialContextListSpatialContextExtentType
OSGeo.MapGuide.MaestroAPI.FeatureNameType
OSGeo.MapGuide.MaestroAPI.GeometryContextType
OSGeo.MapGuide.MaestroAPI.ItemChoiceType
OSGeo.MapGuide.MaestroAPI.KnownSiteVersions
OSGeo.MapGuide.MaestroAPI.LengthUnitType
OSGeo.MapGuide.MaestroAPI.LengthyOperationCallbackArgs.LengthyOperationItem.OperationStatus
OSGeo.MapGuide.MaestroAPI.Operations
OSGeo.MapGuide.MaestroAPI.OverlapTreatmentType
OSGeo.MapGuide.MaestroAPI.PermissionsType
OSGeo.MapGuide.MaestroAPI.PropertyDefinitionTypeType
OSGeo.MapGuide.MaestroAPI.QueryMapFeaturesLayerAttributes
OSGeo.MapGuide.MaestroAPI.RelateTypeEnum
OSGeo.MapGuide.MaestroAPI.ResourceDataType
OSGeo.MapGuide.MaestroAPI.ResourceTypes
OSGeo.MapGuide.MaestroAPI.RowCollectionTypeColumnDefinitionsColumnType
OSGeo.MapGuide.MaestroAPI.SdfKeyTreatmentType
OSGeo.MapGuide.MaestroAPI.ShapeType
OSGeo.MapGuide.MaestroAPI.SizeContextType
OSGeo.MapGuide.MaestroAPI.TargetType
OSGeo.MapGuide.MaestroAPI.TargetViewerType
OSGeo.MapGuide.MaestroAPI.UIItemFunctionType
OSGeo.MapGuide.MaestroAPI.UnmanagedDataTypes
OSGeo.MapGuide.MaestroAPI.UsageContextType
System.Xml.XmlWriter ---- System.IDisposable
System.Xml.XmlTextWriter
OSGeo.MapGuide.MaestroAPI.Utf8XmlWriter

See Also


OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Hierarchy

OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Hierarchy
System.Object
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.ApplicationDefinitionType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.ContainerType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiItemContainerType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.CustomContentType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapGroupType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapViewType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiItemType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.FlyoutItemType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.SeparatorItemType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetItemType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetSetType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapWidgetType
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiWidgetType
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.ContainerTypeCollection
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapGroupTypeCollection
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.MapTypeCollection
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiItemTypeCollection
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetSetTypeCollection
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.WidgetTypeCollection
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.XmlElementCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
OSGeo.MapGuide.MaestroAPI.ApplicationDefinition.UiItemFunctionType

See Also

OSGeo.MapGuide.MaestroAPI.ApplicationDefinition Namespace


OSGeo.MapGuide.MaestroAPI.BinarySerializer Hierarchy

OSGeo.MapGuide.MaestroAPI.BinarySerializer Hierarchy
System.Object
OSGeo.MapGuide.MaestroAPI.BinarySerializer.IBinarySerializeable
OSGeo.MapGuide.MaestroAPI.BinarySerializer.MgBinaryDeserializer
OSGeo.MapGuide.MaestroAPI.BinarySerializer.MgBinarySerializer

See Also

OSGeo.MapGuide.MaestroAPI.BinarySerializer Namespace


OSGeo.MapGuide.MaestroAPI.RuntimeClasses Hierarchy

OSGeo.MapGuide.MaestroAPI.RuntimeClasses Hierarchy
System.Object
OSGeo.MapGuide.MaestroAPI.BaseMapLayerType
OSGeo.MapGuide.MaestroAPI.MapLayerType
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMapLayer
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMapGroup
OSGeo.MapGuide.MaestroAPI.MapDefinition
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMap
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.Selection
System.Collections.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMapGroupCollection
OSGeo.MapGuide.MaestroAPI.RuntimeClasses.RuntimeMapLayerCollection

See Also

OSGeo.MapGuide.MaestroAPI.RuntimeClasses Namespace


OSGeo.MapGuide.MaestroAPI.XmlSerializer Hierarchy

OSGeo.MapGuide.MaestroAPI.XmlSerializer Hierarchy
System.Object
OSGeo.MapGuide.MaestroAPI.XmlSerializer.XmlSerializerEngine
System.Attribute
OSGeo.MapGuide.MaestroAPI.XmlSerializer.XmlSerializerAttribute
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
OSGeo.MapGuide.MaestroAPI.XmlSerializer.XmlSerializerEngine.DeserializeItem
OSGeo.MapGuide.MaestroAPI.XmlSerializer.XmlSerializerEngine.SerializeItem

See Also

OSGeo.MapGuide.MaestroAPI.XmlSerializer Namespace


SDK Link Manager

NDoc Utilities
SDK Link Manager

SDK Link Namespace