Ciloci.Flee

Fast Lightweight Expression Evaluator Documentation
Ciloci.Flee Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | ExpressionCompileException | The exception thrown when an expression cannot be compiled. This class cannot be inherited.
Public class | ExpressionContext | Class that holds all information required to create an expression This class cannot be inherited.
Public class | ExpressionImports | Holds all the types whose static members can be used in an expression. This class cannot be inherited.
Public class | ExpressionInfo | Holds information about a compiled expression. This class cannot be inherited.
Public class | ExpressionOptions | Allows customization of expression compilation. This class cannot be inherited.
Public class | ExpressionOwnerMemberAccessAttribute | Specifies whether access to a member on the expression owner is allowed. This class cannot be inherited.
Public class | ExpressionParserOptions | Holds settings which enable customization of the expression parser.
Public class | ImportBase | Base class for all expression imports This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.
Public class | InvokeFunctionEventArgs | Provides the data for the InvokeFunction event.
Public class | MethodImport | Represents an imported method This class cannot be inherited.
Public class | NamespaceImport | Represents an imported namespace This class cannot be inherited.
Public class | ResolveFunctionEventArgs | Provides the data for the ResolveFunction event.
Public class | ResolveVariableTypeEventArgs | Provides the data for the ResolveVariableType event.
Public class | ResolveVariableValueEventArgs | Provides the data for the ResolveVariableValue event.
Public class | TypeImport | Represents an imported type This class cannot be inherited.
Public class | VariableCollection | Manages the variables available to an expression This class cannot be inherited.

Interfaces

 | Interface | Description
Public interface | IDynamicExpression | Interface implemented by all expressions that evaluate to an Object
Public interface | IExpression | Interface implemented by all expressions
Public interface | IGenericExpression | Interface implemented by all expressions that evaluate to a specific type

Enumerations

 | Enumeration | Description
Public enumeration | CompileExceptionReason | Defines values to indicate why compilation of an expression failed.
Public enumeration | RealLiteralDataType | Defines values to indicate the data type to use for storing real literals.

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

© 2007 Eugene Ciloci


CompileExceptionReason Enumeration

CompileExceptionReason Enumeration
See Also Example
[image]

Defines values to indicate why compilation of an expression failed.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Enum CompileExceptionReason
C#
public enum CompileExceptionReason
C++
public enum class CompileExceptionReason
J#
public enum CompileExceptionReason
JScript
public enum CompileExceptionReason

Remarks

When compilation of an expression fails, an ExpressionCompileException will be thrown. The Reason property on the exception will contain a value from this enumeration. You can use that value to determine how to handle the exception. For example: if the Reason is a SyntaxError, you can display an error message tailored to syntax errors.

Members

Member Name | Description
SyntaxError | The expression text is not parsable because it does not meet the syntax rules of the expression grammar.
ConstantOverflow | A constant expression cannot be represented in its type.
TypeMismatch | The operation is invalid for the given type.
UndefinedName | The expression references a name that cannot be resolved.
FunctionHasNoReturnValue | The expression calls a function that does not return a value.
InvalidExplicitCast | The requested explicit cast is not valid for the given types.
AmbiguousMatch | More than one member matches the required criteria.
AccessDenied | Access to the specified member is not allowed.
InvalidFormat | The given value is not in the required format.

See Also

Ciloci.Flee Namespace


ExpressionCompileException Class

ExpressionCompileException Class
See Also Example Members
[image]

The exception thrown when an expression cannot be compiled. This class cannot be inherited.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public NotInheritable Class ExpressionCompileException
Inherits Exception
C#
[SerializableAttribute]
public sealed class ExpressionCompileException : Exception
C++
[SerializableAttribute]
ref class ExpressionCompileException sealed : Exception
J#
/** @attribute SerializableAttribute() */
public final class ExpressionCompileException extends Exception
JScript
public
SerializableAttribute
final class ExpressionCompileException extends Exception

Remarks

This exception is thrown whenever an expression cannot be compiled. The Reason property will contain a value indicating the specific cause of the exception.

Inheritance Hierarchy

System.Object
System.Exception
Ciloci.Flee.ExpressionCompileException

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ExpressionCompileException Members


ExpressionCompileException Members

ExpressionCompileException Members
See Also Example Properties Methods
[image]

The exception thrown when an expression cannot be compiled. This class cannot be inherited.

The following tables list the members exposed by ExpressionCompileException.

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Overridden.
Public property | Reason | Gets the reason why compilation failed.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | Overridden.
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

See Also

ExpressionCompileException Class


Properties

ExpressionCompileException Properties
[image]

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Overridden.
Public property | Reason | Gets the reason why compilation failed.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

See Also

ExpressionCompileException Class


Message Property

ExpressionCompileException.Message Property
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
C#
public override string Message { get; }
C++
public override property string Message override {
String get();
}
J#
/** property */
public string get_Message();
JScript
public function get Message() : String

See Also

ExpressionCompileException Class


Reason Property

ExpressionCompileException.Reason Property
[image]

Gets the reason why compilation failed.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reason As CompileExceptionReason
C#
public CompileExceptionReason Reason { get; }
C++
public property CompileExceptionReason Reason sealed {
CompileExceptionReason get();
}
J#
/** property */
public CompileExceptionReason get_Reason();
JScript
public function get Reason() : CompileExceptionReason

Property Value

A value indicating the cause of the exception

Remarks

Use this property to determine the reason why compilation failed.

See Also

ExpressionCompileException Class


Methods

ExpressionCompileException Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | Overridden.
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

See Also

ExpressionCompileException Class


GetObjectData Method

ExpressionCompileException.GetObjectData Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) _
Implements ISerializable.GetObjectData
C#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
C++
public:
virtual void GetObjectData(
SerializationInfo info,
StreamingContext context
) override
J#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
JScript
public override function GetObjectData(
info : SerializationInfo,
context : StreamingContext
)

Implements

ISerializable.GetObjectData

See Also

ExpressionCompileException Class


ExpressionContext Class

ExpressionContext Class
See Also Example Members
[image]

Class that holds all information required to create an expression This class cannot be inherited.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExpressionContext
C#
public sealed class ExpressionContext
C++
ref class ExpressionContext sealed
J#
public final class ExpressionContext
JScript
public final class ExpressionContext

Example

This example shows how to create an evaluate an expression:

C# Copy Code
// Define the context of our expression
ExpressionContext context = new ExpressionContext();
// Allow the expression to use all static public methods of System.Math
context.Imports.AddType(typeof(Math));

// Define an int variable
context.Variables["a"] = 100;

// Create a dynamic expression that evaluates to an Object
IDynamicExpression eDynamic = context.CompileDynamic("sqrt(a) + pi");
// Create a generic expression that evaluates to a double
IGenericExpression<double> eGeneric = context.CompileGeneric<double>("sqrt(a) + pi");

// Evaluate the expressions
double result = (double)eDynamic.Evaluate();
result = eGeneric.Evaluate();

// Update the value of our variable
context.Variables["a"] = 144;
// Evaluate again to get the updated result
result = eGeneric.Evaluate();

Remarks

This class holds all information required to create an expression.

Inheritance Hierarchy

System.Object
Ciloci.Flee.ExpressionContext

Thread Safety

The CompileDynamic and CompileGeneric methods are thread-safe.

See Also

ExpressionContext Members


ExpressionContext Members

ExpressionContext Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Class that holds all information required to create an expression This class cannot be inherited.

The following tables list the members exposed by ExpressionContext.

Public Constructors

Name | Description
ExpressionContext | Overloaded. Initializes a new instance of the ExpressionContext class.
Top

Public Properties

 | Name | Description
Public property | CalculationEngine | Gets the CalculationEngine instance used by the expression.
Public property | Imports | Gets the types imported by an expression.
Public property | Options | Gets the ExpressionOptions to be used in an expression
Public property | ParserOptions | Gets the ExpressionParserOptions for this context.
Public property | Variables | Gets the variables available to an expression
Top

Public Methods

 | Name | Description
Public method | Clone | Creates a copy of the current context.
Public method | CompileDynamic | Creates a dynamic expression (one that evaluates to Object) from an expression text string and the current context
Public method | CompileGeneric | Creates a generic expression from an expression text string and the current context
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
ExpressionContext | Overloaded. Initializes a new instance of the ExpressionContext class.
Top

See Also

ExpressionContext Class


ExpressionContext Constructor

ExpressionContext Constructor

Initializes a new instance of the ExpressionContext class.

Overload List

 | Name | Description
Public method | ExpressionContext | Creates a new expression context with the default expression owner.
Public method | ExpressionContext (Object) | Creates a new expression context with a specified expression owner.

See Also

ExpressionContext Class


ExpressionContext Constructor ()

ExpressionContext Constructor ()
See Also Example
[image]

Creates a new expression context with the default expression owner.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public ExpressionContext()
C++
public:
ExpressionContext() sealed
J#
public ExpressionContext()
JScript
public function ExpressionContext()

Remarks

Use this constructor to create an expression context when you don't plan to use an expression owner.

See Also

ExpressionContext Class
Ciloci.Flee Namespace
ExpressionContext Constructor Overload List


ExpressionContext Constructor (Object)

ExpressionContext Constructor (Object)
See Also Example
[image]

Creates a new expression context with a specified expression owner.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal expressionOwner As Object _
)
C#
public ExpressionContext(
object expressionOwner
)
C++
public:
ExpressionContext(
Object expressionOwner
) sealed
J#
public ExpressionContext(
object expressionOwner
)
JScript
public function ExpressionContext(
expressionOwner : Object
)

Parameters

expressionOwner
The expression owner instance to use

Remarks

Use this constructor to create an expression context when you want to supply an expression owner.

See Also

ExpressionContext Class
Ciloci.Flee Namespace
ExpressionContext Constructor Overload List


Properties

ExpressionContext Properties
[image]

Public Properties

 | Name | Description
Public property | CalculationEngine | Gets the CalculationEngine instance used by the expression.
Public property | Imports | Gets the types imported by an expression.
Public property | Options | Gets the ExpressionOptions to be used in an expression
Public property | ParserOptions | Gets the ExpressionParserOptions for this context.
Public property | Variables | Gets the variables available to an expression
Top

See Also

ExpressionContext Class


CalculationEngine Property

ExpressionContext.CalculationEngine Property
[image]

Gets the CalculationEngine instance used by the expression.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CalculationEngine As CalculationEngine
C#
public CalculationEngine CalculationEngine { get; }
C++
public property CalculationEngine CalculationEngine sealed {
CalculationEngine get();
}
J#
/** property */
public CalculationEngine get_CalculationEngine();
JScript
public function get CalculationEngine() : CalculationEngine

Property Value

The CalculationEngine instance

Remarks

Use this property to get CalculationEngine instance used by an expression

See Also

ExpressionContext Class


Imports Property

ExpressionContext.Imports Property
[image]

Gets the types imported by an expression.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Imports As ExpressionImports
C#
public ExpressionImports Imports { get; }
C++
public property ExpressionImports Imports sealed {
ExpressionImports get();
}
J#
/** property */
public ExpressionImports get_Imports();
JScript
public function get Imports() : ExpressionImports

Property Value

The collection of imported types.

Remarks

Use this property to get the imports that will be used by an expression.

See Also

ExpressionContext Class
Ciloci.Flee Namespace
ImportsCollection


Options Property

ExpressionContext.Options Property
[image]

Gets the ExpressionOptions to be used in an expression

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Options As ExpressionOptions
C#
public ExpressionOptions Options { get; }
C++
public property ExpressionOptions Options sealed {
ExpressionOptions get();
}
J#
/** property */
public ExpressionOptions get_Options();
JScript
public function get Options() : ExpressionOptions

Property Value

The ExpressionOptions instance

Remarks

Use this property to access the options to be used in an expression.

See Also

ExpressionContext Class


ParserOptions Property

ExpressionContext.ParserOptions Property
[image]

Gets the ExpressionParserOptions for this context.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParserOptions As ExpressionParserOptions
C#
public ExpressionParserOptions ParserOptions { get; }
C++
public property ExpressionParserOptions ParserOptions sealed {
ExpressionParserOptions get();
}
J#
/** property */
public ExpressionParserOptions get_ParserOptions();
JScript
public function get ParserOptions() : ExpressionParserOptions

Property Value

The ExpressionParserOptions instance

Remarks

Use this property to customize the expression parser.

See Also

ExpressionContext Class


Variables Property

ExpressionContext.Variables Property
[image]

Gets the variables available to an expression

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Variables As VariableCollection
C#
public VariableCollection Variables { get; }
C++
public property VariableCollection Variables sealed {
VariableCollection get();
}
J#
/** property */
public VariableCollection get_Variables();
JScript
public function get Variables() : VariableCollection

Property Value

The VariableCollection instance

Remarks

Use this property to get collection of variables available to an expression.

See Also

ExpressionContext Class


Methods

ExpressionContext Methods
[image]

Public Methods

 | Name | Description
Public method | Clone | Creates a copy of the current context.
Public method | CompileDynamic | Creates a dynamic expression (one that evaluates to Object) from an expression text string and the current context
Public method | CompileGeneric | Creates a generic expression from an expression text string and the current context
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExpressionContext Class


Clone Method

ExpressionContext.Clone Method
[image]

Creates a copy of the current context.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone() As ExpressionContext
C#
public ExpressionContext Clone()
C++
public:
ExpressionContext Clone() sealed
J#
public ExpressionContext Clone()
JScript
public function Clone() : ExpressionContext

Return Value

An identical copy of the current context

Remarks

Use this method when you need an indentical copy of an existing context. Note that

See Also

ExpressionContext Class


CompileDynamic Method

ExpressionContext.CompileDynamic Method
[image]

Creates a dynamic expression (one that evaluates to Object) from an expression text string and the current context

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function CompileDynamic( _
ByVal expression As String _
) As IDynamicExpression
C#
public IDynamicExpression CompileDynamic(
string expression
)
C++
public:
IDynamicExpression CompileDynamic(
String expression
) sealed
J#
public IDynamicExpression CompileDynamic(
string expression
)
JScript
public function CompileDynamic(
expression : String
) : IDynamicExpression

Parameters

expression
The expression text to parse

Return Value

A new dynamic expression

Exceptions

Exception Type | Condition
ExpressionCompileException | The expression could not be compiled

Remarks

Use this method when you want to create an expression that evaluates to an Object. "Dynamic" means that the result type of the expression can be anything and is not fixed as with a generic expression.

Note
The context, imports, and options of the compiled expression will be a clone of the originals. The variables however are not cloned and will point to the same instance.

See Also

ExpressionContext Class


CompileGeneric Generic Method

ExpressionContext.CompileGeneric Generic Method
[image]

Creates a generic expression from an expression text string and the current context

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function CompileGeneric(Of TResultType)( _
ByVal expression As String _
) As IGenericExpression(Of TResultType)
C#
public IGenericExpression<TResultType> CompileGeneric<TResultType>(
string expression
)
C++
public:
IGenericExpression<TResultType> CompileGeneric<TResultType>(
String expression
) sealed
J#
public IGenericExpression<TResultType> CompileGeneric<TResultType>(
string expression
)
JScript
JScript does not support generic types and methods.

Type Parameters

TResultType
The type that the expression evaluates to

Parameters

expression
The expression text to parse

Return Value

A new generic expression

Exceptions

Exception Type | Condition
ExpressionCompileException | The expression could not be compiled

Remarks

Use this method when you want to create an expression that evaluates to a strongly-typed value.

Note
The context, imports, and options of the compiled expression will be a clone of the originals. The variables however are not cloned and will point to the same instance.

See Also

ExpressionContext Class


ExpressionImports Class

ExpressionImports Class
See Also Example Members
[image]

Holds all the types whose static members can be used in an expression. This class cannot be inherited.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExpressionImports
C#
public sealed class ExpressionImports
C++
ref class ExpressionImports sealed
J#
public final class ExpressionImports
JScript
public final class ExpressionImports

Example

This example shows how to use this class to let an expression use all the static members of the Math class:

C# Copy Code
          // Define the context of our expression
          ExpressionContext context = new ExpressionContext();
          // Import all members of the Math type into the default namespace
          context.Imports.AddType(typeof(Math));

Remarks

Use this class to allow the static functions, methods, and properties of a type to be used in an expression. By default, no types are imported.

Inheritance Hierarchy

System.Object
Ciloci.Flee.ExpressionImports

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ExpressionImports Members


ExpressionImports Members

ExpressionImports Members
See Also Example Properties Methods
[image]

Holds all the types whose static members can be used in an expression. This class cannot be inherited.

The following tables list the members exposed by ExpressionImports.

Public Properties

 | Name | Description
Public property | RootImport | Gets the root import of the context.
Top

Public Methods

 | Name | Description
Public method | AddMethod | Overloaded. Imports a single public and static method into an expression.
Public method | AddType | Overloaded. Makes the static and public members of a type available for use in an expression
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ImportBuiltinTypes | Imports the builtin types into an expression
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExpressionImports Class


Properties

ExpressionImports Properties
[image]

Public Properties

 | Name | Description
Public property | RootImport | Gets the root import of the context.
Top

See Also

ExpressionImports Class


RootImport Property

ExpressionImports.RootImport Property
[image]

Gets the root import of the context.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RootImport As NamespaceImport
C#
public NamespaceImport RootImport { get; }
C++
public property NamespaceImport RootImport sealed {
NamespaceImport get();
}
J#
/** property */
public NamespaceImport get_RootImport();
JScript
public function get RootImport() : NamespaceImport

Property Value

The root import.

Remarks

Use this property to access the root import of an expression.

See Also

ExpressionImports Class


Methods

ExpressionImports Methods
[image]

Public Methods

 | Name | Description
Public method | AddMethod | Overloaded. Imports a single public and static method into an expression.
Public method | AddType | Overloaded. Makes the static and public members of a type available for use in an expression
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ImportBuiltinTypes | Imports the builtin types into an expression
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExpressionImports Class


AddMethod Method

ExpressionImports.AddMethod Method

Imports a single public and static method into an expression.

Overload List

 | Name | Description
Public method | AddMethod (MethodInfo, String) | Imports a public and static method of a type into a given namespace and makes it available to an expression.
Public method | AddMethod (String, Type, String) | Imports a public and static method of a type into a given namespace and makes it available to an expression.

See Also

ExpressionImports Class


AddMethod Method (MethodInfo, String)

ExpressionImports.AddMethod Method (MethodInfo, String)
See Also Example
[image]

Imports a public and static method of a type into a given namespace and makes it available to an expression.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddMethod( _
ByVal mi As MethodInfo, _
ByVal ns As String _
)
C#
public void AddMethod(
MethodInfo mi,
string ns
)
C++
public:
void AddMethod(
MethodInfo mi,
String ns
) sealed
J#
public void AddMethod(
MethodInfo mi,
string ns
)
JScript
public function AddMethod(
mi : MethodInfo,
ns : String
)

Parameters

mi
The method to import
ns
The namespace to import the method into -or- the empty string to import into the default namespace

Exceptions

Exception Type | Condition
ArgumentException | The type the method belongs to is not accessible

Remarks

Use this method to import a single static, public method into an expression. This overload is used when you already have a specific MethodInfo available.

See Also

ExpressionImports Class
Ciloci.Flee Namespace
ExpressionImports.AddMethod Overload List


AddMethod Method (String, Type, String)

ExpressionImports.AddMethod Method (String, Type, String)
See Also Example
[image]

Imports a public and static method of a type into a given namespace and makes it available to an expression.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddMethod( _
ByVal methodName As String, _
ByVal t As Type, _
ByVal ns As String _
)
C#
public void AddMethod(
string methodName,
Type t,
string ns
)
C++
public:
void AddMethod(
String methodName,
Type t,
String ns
) sealed
J#
public void AddMethod(
string methodName,
Type t,
string ns
)
JScript
public function AddMethod(
methodName : String,
t : Type,
ns : String
)

Parameters

methodName
The name of the method to import
t
The type on which to lookup the method
ns
The namespace to import the method into -or- the empty string to import into the default namespace

Exceptions

Exception Type | Condition
ArgumentException | The type the method belongs to is not accessible

Remarks

Use this method to import a single static, public method into an expression. The method with the given name will be looked up on the type argument and added into the specified namespace.

See Also

ExpressionImports Class
Ciloci.Flee Namespace
ExpressionImports.AddMethod Overload List


AddType Method

ExpressionImports.AddType Method

Makes the static and public members of a type available for use in an expression

Overload List

 | Name | Description
Public method | AddType (Type) |
Public method | AddType (Type, String) | Imports all public and static members of a type into a specific namespace and makes them available to an expression.

See Also

ExpressionImports Class


AddType Method (Type)

ExpressionImports.AddType Method (Type)
See Also Example
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddType( _
ByVal t As Type _
)
C#
public void AddType(
Type t
)
C++
public:
void AddType(
Type t
) sealed
J#
public void AddType(
Type t
)
JScript
public function AddType(
t : Type
)

See Also

ExpressionImports Class
Ciloci.Flee Namespace
ExpressionImports.AddType Overload List


AddType Method (Type, String)

ExpressionImports.AddType Method (Type, String)
See Also Example
[image]

Imports all public and static members of a type into a specific namespace and makes them available to an expression.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddType( _
ByVal t As Type, _
ByVal ns As String _
)
C#
public void AddType(
Type t,
string ns
)
C++
public:
void AddType(
Type t,
String ns
) sealed
J#
public void AddType(
Type t,
string ns
)
JScript
public function AddType(
t : Type,
ns : String
)

Parameters

t
The type to import
ns
The namespace to import the type into -or- the empty string to import into the default namespace

Exceptions

Exception Type | Condition
ArgumentException | The imported type is not accessible

Remarks

Use this method to import a type into an expression. All static and public methods, fields, and properties of the type will be directly accessible in the expression. If the namespace parameter is the empty string, the type's members will be able to be referenced without any qualification. Otherwise, they will be imported into the specified namespace and will need to be qualified with it before being accessed. The imported type is deemed accessible if it is either public or in the same module as the expression owner.

Example

If you import the Math type into the default namespace, you can reference its members in the expression: "cos(1.0)". If you import same type into the "Math" namespace, you will need to qualify its members like so: "math.cos(1.0)".

See Also

ExpressionImports Class
Ciloci.Flee Namespace
ExpressionImports.AddType Overload List


ImportBuiltinTypes Method

ExpressionImports.ImportBuiltinTypes Method
[image]

Imports the builtin types into an expression

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub ImportBuiltinTypes()
C#
public void ImportBuiltinTypes()
C++
public:
void ImportBuiltinTypes() sealed
J#
public void ImportBuiltinTypes()
JScript
public function ImportBuiltinTypes()

Remarks

Call this method to import the builtin types (int, string, double) into an expression. After this method is called, you can use members of the builtin types in an expression ie:

int.maxvalue * 2

See Also

ExpressionImports Class


ExpressionInfo Class

ExpressionInfo Class
See Also Example Members
[image]

Holds information about a compiled expression. This class cannot be inherited.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExpressionInfo
C#
public sealed class ExpressionInfo
C++
ref class ExpressionInfo sealed
J#
public final class ExpressionInfo
JScript
public final class ExpressionInfo

Remarks

This class holds information about an expression after it has been compiled. For example: you can use this class to find out what variables an expression uses.

Inheritance Hierarchy

System.Object
Ciloci.Flee.ExpressionInfo

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ExpressionInfo Members


ExpressionInfo Members

ExpressionInfo Members
See Also Example Methods
[image]

Holds information about a compiled expression. This class cannot be inherited.

The following tables list the members exposed by ExpressionInfo.

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetReferencedVariables | Gets the variables that are used in an expression.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExpressionInfo Class


Methods

ExpressionInfo Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetReferencedVariables | Gets the variables that are used in an expression.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExpressionInfo Class


GetReferencedVariables Method

ExpressionInfo.GetReferencedVariables Method
[image]

Gets the variables that are used in an expression.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function GetReferencedVariables() As String()
C#
public string[] GetReferencedVariables()
C++
public:
array<String>^ GetReferencedVariables() sealed
J#
public string[] GetReferencedVariables()
JScript
public function GetReferencedVariables() : String[]

Return Value

A string array containing all the variables used in the expression.

Remarks

Use this method when you need to get a list of all variables used in an expression.

See Also

ExpressionInfo Class


ExpressionOptions Class

ExpressionOptions Class
See Also Example Members
[image]

Allows customization of expression compilation. This class cannot be inherited.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ExpressionOptions
C#
public sealed class ExpressionOptions
C++
ref class ExpressionOptions sealed
J#
public final class ExpressionOptions
JScript
public final class ExpressionOptions

Remarks

Use this class when you need to customize how an expression is compiled. For example: by setting the Checked property to true, you can cause all arithmetic and conversion operations to check for overflow.

Inheritance Hierarchy

System.Object
Ciloci.Flee.ExpressionOptions

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ExpressionOptions Members


ExpressionOptions Members

ExpressionOptions Members
See Also Example Properties Methods
[image]

Allows customization of expression compilation. This class cannot be inherited.

The following tables list the members exposed by ExpressionOptions.

Public Properties

 | Name | Description
Public property | CaseSensitive | Determines how an expression matches member and variable names
Public property | Checked | Gets or sets whether arithmetic and conversion operations check for overflow.
Public property | EmitToAssembly | Determines if the expression's IL will be saved to an assembly on disk.
Public property | IntegersAsDoubles | Gets or sets whether all integer literals are treated as doubles
Public property | OwnerMemberAccess | Determines which members on the expression owner are accessible.
Public property | ParseCulture | Gets or sets the culture to use when parsing expressions
Public property | RealLiteralDataType | Gets or sets the data type used for real literals when no explicit type is specified.
Public property | ResultType | Gets or sets the type of the expression's result.
Public property | StringComparison | Gets or sets a value that determines how strings will be compared.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExpressionOptions Class


Properties

ExpressionOptions Properties
[image]

Public Properties

 | Name | Description
Public property | CaseSensitive | Determines how an expression matches member and variable names
Public property | Checked | Gets or sets whether arithmetic and conversion operations check for overflow.
Public property | EmitToAssembly | Determines if the expression's IL will be saved to an assembly on disk.
Public property | IntegersAsDoubles | Gets or sets whether all integer literals are treated as doubles
Public property | OwnerMemberAccess | Determines which members on the expression owner are accessible.
Public property | ParseCulture | Gets or sets the culture to use when parsing expressions
Public property | RealLiteralDataType | Gets or sets the data type used for real literals when no explicit type is specified.
Public property | ResultType | Gets or sets the type of the expression's result.
Public property | StringComparison | Gets or sets a value that determines how strings will be compared.
Top

See Also

ExpressionOptions Class


CaseSensitive Property

ExpressionOptions.CaseSensitive Property
[image]

Determines how an expression matches member and variable names

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property CaseSensitive As Boolean
C#
public bool CaseSensitive { get; set; }
C++
public property bool CaseSensitive sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_CaseSensitive();

/** property */
public void set_CaseSensitive(bool value);
JScript
public function get CaseSensitive() : bool

public function set CaseSensitive(value : bool);

Property Value

True to respect case when matching; False to ignore case

Remarks

Use this property to control how an expression resolves member and variable names. If set to true, variable and member names will be matched in a case-sensitive manner. When false, case will be ignored.

See Also

ExpressionOptions Class


Checked Property

ExpressionOptions.Checked Property
[image]

Gets or sets whether arithmetic and conversion operations check for overflow.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property Checked As Boolean
C#
public bool Checked { get; set; }
C++
public property bool Checked sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_Checked();

/** property */
public void set_Checked(bool value);
JScript
public function get Checked() : bool

public function set Checked(value : bool);

Property Value

True to emit overflow checks. False to emit no overflow checks.

Remarks

Setting this property to true will cause all arithmetic and conversion operations to emit overflow checks. When one of those operations is executed and the resultant value cannot fit into the result type, an OverflowException will be thrown.

See Also

ExpressionOptions Class


EmitToAssembly Property

ExpressionOptions.EmitToAssembly Property
[image]

Determines if the expression's IL will be saved to an assembly on disk.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property EmitToAssembly As Boolean
C#
public bool EmitToAssembly { get; set; }
C++
public property bool EmitToAssembly sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_EmitToAssembly();

/** property */
public void set_EmitToAssembly(bool value);
JScript
public function get EmitToAssembly() : bool

public function set EmitToAssembly(value : bool);

Property Value

True to save the expression's IL to an assembly; false otherwise.

Remarks

Use this method when you want to inspect the IL that an expression emits. When set to true, the expression will save its IL to the assembly "Expression.dll" on disk. You can then view the IL with a disassembler.

See Also

ExpressionOptions Class


IntegersAsDoubles Property

ExpressionOptions.IntegersAsDoubles Property
[image]

Gets or sets whether all integer literals are treated as doubles

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property IntegersAsDoubles As Boolean
C#
public bool IntegersAsDoubles { get; set; }
C++
public property bool IntegersAsDoubles sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_IntegersAsDoubles();

/** property */
public void set_IntegersAsDoubles(bool value);
JScript
public function get IntegersAsDoubles() : bool

public function set IntegersAsDoubles(value : bool);

Property Value

True to treat all integer literals as doubles; False to use integers for integral numbers and floating point for real numbers (ie: any number with a decimal point)

Remarks

Use this property to force all integer literals to doubles. When set to true, an expression like "1/2" will return 0.5 since both integer literals are treated as doubles. When false, the same expression will return 0 since an integer division will be performed.

See Also

ExpressionOptions Class


OwnerMemberAccess Property

ExpressionOptions.OwnerMemberAccess Property
[image]

Determines which members on the expression owner are accessible.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property OwnerMemberAccess As BindingFlags
C#
public BindingFlags OwnerMemberAccess { get; set; }
C++
public property BindingFlags OwnerMemberAccess sealed {
BindingFlags get();
void set(BindingFlags value);
}
J#
/** property */
public BindingFlags get_OwnerMemberAccess();

/** property */
public void set_OwnerMemberAccess(BindingFlags value);
JScript
public function get OwnerMemberAccess() : BindingFlags

public function set OwnerMemberAccess(value : BindingFlags);

Property Value

A combination of BindingFlags that determine which members are accessible.

Remarks

Using this property, you can control which members on the expression owner are accessible from an expression. For example: if users will be inputing expressions, you can prevent private members on the expression owner from being used. You can use the ExpressionOwnerMemberAccessAttribute attribute on individual members to override the access set using this property.

Note
The default is to only allow access to public members on the expression owner. Currently, only the Public and NonPublic values of the BindingFlags enumeration are used.

See Also

ExpressionOptions Class


ParseCulture Property

ExpressionOptions.ParseCulture Property
[image]

Gets or sets the culture to use when parsing expressions

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property ParseCulture As CultureInfo
C#
public CultureInfo ParseCulture { get; set; }
C++
public property CultureInfo ParseCulture sealed {
CultureInfo get();
void set(CultureInfo value);
}
J#
/** property */
public CultureInfo get_ParseCulture();

/** property */
public void set_ParseCulture(CultureInfo value);
JScript
public function get ParseCulture() : CultureInfo

public function set ParseCulture(value : CultureInfo);

Property Value

The culture to use

Remarks

Use this property to allow for parsing of expressions using culture-specific tokens. This is useful, for example, when you wish to parse numbers using a culture-specific decimal separator.

See Also

ExpressionOptions Class


RealLiteralDataType Property

ExpressionOptions.RealLiteralDataType Property
[image]

Gets or sets the data type used for real literals when no explicit type is specified.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property RealLiteralDataType As RealLiteralDataType
C#
public RealLiteralDataType RealLiteralDataType { get; set; }
C++
public property RealLiteralDataType RealLiteralDataType sealed {
RealLiteralDataType get();
void set(RealLiteralDataType value);
}
J#
/** property */
public RealLiteralDataType get_RealLiteralDataType();

/** property */
public void set_RealLiteralDataType(RealLiteralDataType value);
JScript
public function get RealLiteralDataType() : RealLiteralDataType

public function set RealLiteralDataType(value : RealLiteralDataType);

Property Value

A value specifying the type to use

Remarks

Use this property to set the data type that will be used to represent real literals. For example: if set to Decimal, all real literals (ie: 100.45) will be parsed into a System.Decimal value.

See Also

ExpressionOptions Class


ResultType Property

ExpressionOptions.ResultType Property
[image]

Gets or sets the type of the expression's result.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property ResultType As Type
C#
public Type ResultType { get; set; }
C++
public property Type ResultType sealed {
Type get();
void set(Type value);
}
J#
/** property */
public Type get_ResultType();

/** property */
public void set_ResultType(Type value);
JScript
public function get ResultType() : Type

public function set ResultType(value : Type);

Property Value

A Type indicating the desired result type.

Remarks

Use this property to convert the result of an expression to a particular type. Essentially, it acts as an implicit conversion from the final result of the expression to the given type. When this property is set, the expression will attempt to convert its result to the set value. If the conversion is invalid, an ExpressionCompileException will be thrown.

See Also

ExpressionOptions Class


StringComparison Property

ExpressionOptions.StringComparison Property
[image]

Gets or sets a value that determines how strings will be compared.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property StringComparison As StringComparison
C#
public StringComparison StringComparison { get; set; }
C++
public property StringComparison StringComparison sealed {
StringComparison get();
void set(StringComparison value);
}
J#
/** property */
public StringComparison get_StringComparison();

/** property */
public void set_StringComparison(StringComparison value);
JScript
public function get StringComparison() : StringComparison

public function set StringComparison(value : StringComparison);

Property Value

The type of string comparison to use.

Remarks

Use this property to control the type of string comparison used in an expression that compares two strings. For example: the result of the expression "string" = "STRING" will be true if the string comparison is set to ignore case and false otherwise. The default is Ordinal.

See Also

ExpressionOptions Class


ExpressionOwnerMemberAccessAttribute Class

ExpressionOwnerMemberAccessAttribute Class
See Also Example Members
[image]

Specifies whether access to a member on the expression owner is allowed. This class cannot be inherited.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Method Or AttributeTargets.Property Or AttributeTargets.Field, AllowMultiple := False, Inherited := False)>
Public NotInheritable Class ExpressionOwnerMemberAccessAttribute
Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field, AllowMultiple = False, Inherited = False)]
public sealed class ExpressionOwnerMemberAccessAttribute : Attribute
C++
[AttributeUsageAttribute(AttributeTargets::Method | AttributeTargets::Property | AttributeTargets::Field, AllowMultiple = False, Inherited = False)]
ref class ExpressionOwnerMemberAccessAttribute sealed : Attribute
J#
/** @attribute AttributeUsageAttribute(AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field, AllowMultiple = False, Inherited = False) */
public final class ExpressionOwnerMemberAccessAttribute extends Attribute
JScript
public
AttributeUsageAttribute(AttributeTargets.Method | AttributeTargets.Property | AttributeTargets.Field, AllowMultiple = False, Inherited = False)
final class ExpressionOwnerMemberAccessAttribute extends Attribute

Remarks

Use this attribute to control the accessibility of individual members on the expression owner. The access specified in this attribute overrides the access level specified using the OwnerMemberAccess property.

Inheritance Hierarchy

System.Object
System.Attribute
Ciloci.Flee.ExpressionOwnerMemberAccessAttribute

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ExpressionOwnerMemberAccessAttribute Members


ExpressionOwnerMemberAccessAttribute Members

ExpressionOwnerMemberAccessAttribute Members
See Also Example Constructors Properties Methods
[image]

Specifies whether access to a member on the expression owner is allowed. This class cannot be inherited.

The following tables list the members exposed by ExpressionOwnerMemberAccessAttribute.

Public Constructors

 | Name | Description
Public method | ExpressionOwnerMemberAccessAttribute | Initializes the attribute with the desired access.
Top

Public Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (inherited from Attribute)
Top

Public Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (inherited from Attribute)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

ExpressionOwnerMemberAccessAttribute Class


ExpressionOwnerMemberAccessAttribute Constructor

ExpressionOwnerMemberAccessAttribute Constructor
[image]

Initializes the attribute with the desired access.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal allowAccess As Boolean _
)
C#
public ExpressionOwnerMemberAccessAttribute(
bool allowAccess
)
C++
public:
ExpressionOwnerMemberAccessAttribute(
bool allowAccess
) sealed
J#
public ExpressionOwnerMemberAccessAttribute(
bool allowAccess
)
JScript
public function ExpressionOwnerMemberAccessAttribute(
allowAccess : bool
)

Parameters

allowAccess
True to allow the member to be used in an expression;False otherwise

Remarks

Initializes the attribute with the desired access.

See Also

ExpressionOwnerMemberAccessAttribute Class


ExpressionParserOptions Class

ExpressionParserOptions Class
See Also Example Members
[image]

Holds settings which enable customization of the expression parser.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Class ExpressionParserOptions
C#
public class ExpressionParserOptions
C++
ref class ExpressionParserOptions
J#
public class ExpressionParserOptions
JScript
public class ExpressionParserOptions

Inheritance Hierarchy

System.Object
Ciloci.Flee.ExpressionParserOptions

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ExpressionParserOptions Members


ExpressionParserOptions Members

ExpressionParserOptions Members
See Also Example Properties Methods
[image]

Holds settings which enable customization of the expression parser.

The following tables list the members exposed by ExpressionParserOptions.

Public Properties

 | Name | Description
Public property | DateTimeFormat | Gets or sets the format to use for parsing DateTime literals
Public property | DecimalSeparator | Gets or sets the character to use as the decimal separator for real number literals.
Public property | FunctionArgumentSeparator | Gets or sets the character to use to separate function arguments.
Public property | RequireDigitsBeforeDecimalPoint | Gets or sets a value that determines if literals for real numbers must have digits before the decimal point.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RecreateParser | Updates the expression parser using the settings provided in this class.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ExpressionParserOptions Class


Properties

ExpressionParserOptions Properties
[image]

Public Properties

 | Name | Description
Public property | DateTimeFormat | Gets or sets the format to use for parsing DateTime literals
Public property | DecimalSeparator | Gets or sets the character to use as the decimal separator for real number literals.
Public property | FunctionArgumentSeparator | Gets or sets the character to use to separate function arguments.
Public property | RequireDigitsBeforeDecimalPoint | Gets or sets a value that determines if literals for real numbers must have digits before the decimal point.
Top

See Also

ExpressionParserOptions Class


DateTimeFormat Property

ExpressionParserOptions.DateTimeFormat Property
[image]

Gets or sets the format to use for parsing DateTime literals

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property DateTimeFormat As String
C#
public string DateTimeFormat { get; set; }
C++
public property string DateTimeFormat sealed {
String get();
void set(String value);
}
J#
/** property */
public string get_DateTimeFormat();

/** property */
public void set_DateTimeFormat(string value);
JScript
public function get DateTimeFormat() : String

public function set DateTimeFormat(value : String);

Property Value

The format to use

Remarks

Use this property to set the format that will be used to parse DateTime literals. Expressions which have DateTime literals that are not parseable using this format will fail to compile.

Example

When set to "dd-MM-yyyy", an expression such as "#04-07-2008#" would be parsed to the corresponding DateTime value.

See Also

ExpressionParserOptions Class


DecimalSeparator Property

ExpressionParserOptions.DecimalSeparator Property
[image]

Gets or sets the character to use as the decimal separator for real number literals.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property DecimalSeparator As Char
C#
public char DecimalSeparator { get; set; }
C++
public property char DecimalSeparator sealed {
wchar_t get();
void set(wchar_t value);
}
J#
/** property */
public char get_DecimalSeparator();

/** property */
public void set_DecimalSeparator(char value);
JScript
public function get DecimalSeparator() : char

public function set DecimalSeparator(value : char);

See Also

ExpressionParserOptions Class


FunctionArgumentSeparator Property

ExpressionParserOptions.FunctionArgumentSeparator Property
[image]

Gets or sets the character to use to separate function arguments.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property FunctionArgumentSeparator As Char
C#
public char FunctionArgumentSeparator { get; set; }
C++
public property char FunctionArgumentSeparator sealed {
wchar_t get();
void set(wchar_t value);
}
J#
/** property */
public char get_FunctionArgumentSeparator();

/** property */
public void set_FunctionArgumentSeparator(char value);
JScript
public function get FunctionArgumentSeparator() : char

public function set FunctionArgumentSeparator(value : char);

See Also

ExpressionParserOptions Class


RequireDigitsBeforeDecimalPoint Property

ExpressionParserOptions.RequireDigitsBeforeDecimalPoint Property
See Also Example
[image]

Gets or sets a value that determines if literals for real numbers must have digits before the decimal point.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property RequireDigitsBeforeDecimalPoint As Boolean
C#
public bool RequireDigitsBeforeDecimalPoint { get; set; }
C++
public property bool RequireDigitsBeforeDecimalPoint sealed {
bool get();
void set(bool value);
}
J#
/** property */
public bool get_RequireDigitsBeforeDecimalPoint();

/** property */
public void set_RequireDigitsBeforeDecimalPoint(bool value);
JScript
public function get RequireDigitsBeforeDecimalPoint() : bool

public function set RequireDigitsBeforeDecimalPoint(value : bool);

Property Value

True to require digits (ie: 0.56); False otherwise (ie: .56)

See Also

ExpressionParserOptions Class


Methods

ExpressionParserOptions Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | RecreateParser | Updates the expression parser using the settings provided in this class.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ExpressionParserOptions Class


RecreateParser Method

ExpressionParserOptions.RecreateParser Method
[image]

Updates the expression parser using the settings provided in this class.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub RecreateParser()
C#
public void RecreateParser()
C++
public:
void RecreateParser() sealed
J#
public void RecreateParser()
JScript
public function RecreateParser()

See Also

ExpressionParserOptions Class


IDynamicExpression Interface

IDynamicExpression Interface
See Also Example Members
[image]

Interface implemented by all expressions that evaluate to an Object

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDynamicExpression
Implements IExpression
C#
public interface IDynamicExpression : IExpression
C++
interface class IDynamicExpression : IExpression
J#
public interface IDynamicExpression implements IExpression
JScript
public interface IDynamicExpression extends IExpression

Remarks

This is the interface that dynamic expressions must implement

See Also

IDynamicExpression Members


IDynamicExpression Members

IDynamicExpression Members
See Also Example Methods
[image]

Interface implemented by all expressions that evaluate to an Object

The following tables list the members exposed by IDynamicExpression.

Public Methods

 | Name | Description
Public method | Evaluate | Evaluates the dynamic expression
Top

See Also

IDynamicExpression Interface


Methods

IDynamicExpression Methods
[image]

Public Methods

 | Name | Description
Public method | Evaluate | Evaluates the dynamic expression
Top

See Also

IDynamicExpression Interface


Evaluate Method

IDynamicExpression.Evaluate Method
[image]

Evaluates the dynamic expression

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Function Evaluate() As Object
C#
object Evaluate()
C++
Object Evaluate() abstract
J#
object Evaluate()
JScript
function Evaluate() : Object

Return Value

An Object instance that represents the result of evaluating the expression

Remarks

Use this method to evaluate the expression.

See Also

IDynamicExpression Interface


IExpression Interface

IExpression Interface
See Also Example Members
[image]

Interface implemented by all expressions

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Interface IExpression
C#
public interface IExpression
C++
interface class IExpression
J#
public interface IExpression
JScript
public interface IExpression

Remarks

This is the base interface that exposes members common to both dynamic and generic expressions.

See Also

IExpression Members


IExpression Members

IExpression Members
See Also Example Properties Methods
[image]

Interface implemented by all expressions

The following tables list the members exposed by IExpression.

Public Properties

 | Name | Description
Public property | Context | Gets the context the expression was created with
Public property | Info | Gets the expression's ExpressionInfo instance.
Public property | Owner | Gets or sets the expression's owner
Public property | Text | Gets the text the expression was created with
Top

Public Methods

 | Name | Description
Public method | Clone | Creates a clone of the current expression
Top

See Also

IExpression Interface


Properties

IExpression Properties
[image]

Public Properties

 | Name | Description
Public property | Context | Gets the context the expression was created with
Public property | Info | Gets the expression's ExpressionInfo instance.
Public property | Owner | Gets or sets the expression's owner
Public property | Text | Gets the text the expression was created with
Top

See Also

IExpression Interface


Context Property

IExpression.Context Property
[image]

Gets the context the expression was created with

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Context As ExpressionContext
C#
ExpressionContext Context { get; }
C++
property ExpressionContext Context abstract {
ExpressionContext get();
}
J#
/** property */
public ExpressionContext get_Context();
JScript
public function get Context() : ExpressionContext

Property Value

The expression's ExpressionContext instance

Remarks

Use this property to get the context that was used to compile the expression.

See Also

IExpression Interface


Info Property

IExpression.Info Property
[image]

Gets the expression's ExpressionInfo instance.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Info As ExpressionInfo
C#
ExpressionInfo Info { get; }
C++
property ExpressionInfo Info abstract {
ExpressionInfo get();
}
J#
/** property */
public ExpressionInfo get_Info();
JScript
public function get Info() : ExpressionInfo

Property Value

The ExpressionInfo instance.

Remarks

Use this property to access the expression's ExpressionInfo instance which holds information about the expression.

See Also

IExpression Interface


Owner Property

IExpression.Owner Property
[image]

Gets or sets the expression's owner

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Property Owner As Object
C#
object Owner { get; set; }
C++
property object Owner abstract {
Object get();
void set(Object value);
}
J#
/** property */
public object get_Owner();

/** property */
public void set_Owner(object value);
JScript
public function get Owner() : Object

public function set Owner(value : Object);

Property Value

The expression's owner instance. Must be of the same type as the expression's original owner.

Remarks

Use this property to get or set the instance of the expression's owner.

See Also

IExpression Interface


Text Property

IExpression.Text Property
[image]

Gets the text the expression was created with

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Text As String
C#
string Text { get; }
C++
property string Text abstract {
String get();
}
J#
/** property */
public string get_Text();
JScript
public function get Text() : String

Property Value

A string with the expression's text

Remarks

Use this property to get the text that was used to compile the expression.

See Also

IExpression Interface


Methods

IExpression Methods
[image]

Public Methods

 | Name | Description
Public method | Clone | Creates a clone of the current expression
Top

See Also

IExpression Interface


Clone Method

IExpression.Clone Method
[image]

Creates a clone of the current expression

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Function Clone() As IExpression
C#
IExpression Clone()
C++
IExpression Clone() abstract
J#
IExpression Clone()
JScript
function Clone() : IExpression

Return Value

A copy of the current expression with its own set of variables

Remarks

Use this method when you need to create a copy of an existing expression without the parsing/compilation overhead

See Also

IExpression Interface


IGenericExpression Generic Interface

IGenericExpression Generic Interface
See Also Example Members
[image]

Interface implemented by all expressions that evaluate to a specific type

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Interface IGenericExpression(Of T)
Implements IExpression
C#
public interface IGenericExpression<T> : IExpression
C++
interface class IGenericExpression<T> : IExpression
J#
public interface IGenericExpression<T> implements IExpression
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type that the expression will evaluate to

Remarks

This is the interface that generic expressions must implement

See Also

IGenericExpression<T> Members


IGenericExpression<T> Members

IGenericExpression Members
See Also Example Methods
[image]

Interface implemented by all expressions that evaluate to a specific type

The following tables list the members exposed by IGenericExpression<T>.

Public Methods

 | Name | Description
Public method | Evaluate | Evaluates the generic expression
Top

See Also

IGenericExpression<T> Interface


Methods

IGenericExpression Methods
[image]

Public Methods

 | Name | Description
Public method | Evaluate | Evaluates the generic expression
Top

See Also

IGenericExpression<T> Interface


Evaluate Method

IGenericExpression.Evaluate Method
[image]

Evaluates the generic expression

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Function Evaluate()
C#
T Evaluate()
C++
T Evaluate() abstract
J#
T Evaluate()
JScript
JScript does not support generic types and methods.

Return Value

The result of evaluating the expression

Remarks

Use this method to evaluate the expression.

See Also

IGenericExpression<T> Interface


ImportBase Class

ImportBase Class
See Also Example Members
[image]

Base class for all expression imports This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class ImportBase
Implements IEnumerable(Of ImportBase), IEnumerable, IEquatable(Of ImportBase)
C#
public abstract class ImportBase : IEnumerable<ImportBase>, IEnumerable, IEquatable<ImportBase>
C++
ref class ImportBase abstract : IEnumerable<ImportBase>, IEnumerable, IEquatable<ImportBase>
J#
public class ImportBase implements IEnumerable<ImportBase>, IEnumerable, IEquatable<ImportBase>
JScript
public class ImportBase extends IEnumerable<ImportBase>, IEnumerable, IEquatable<ImportBase>

Inheritance Hierarchy

System.Object
Ciloci.Flee.ImportBase
Ciloci.Flee.MethodImport
Ciloci.Flee.NamespaceImport
Ciloci.Flee.TypeImport

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ImportBase Members


ImportBase Members

ImportBase Members
See Also Example Properties Methods
[image]

Base class for all expression imports This class is abstract (MustInherit in Visual Basic)abstractMustInherit and so cannot be instantiated.

The following tables list the members exposed by ImportBase.

Public Properties

 | Name | Description
Public property | IsContainer | Determines if this import can contain other imports
Public property | Name | Gets the name of the import
Top

Protected Properties

 | Name | Description
Family property | Context |
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetMembers |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
 | AddImportMembers | Overloaded.
 | AddMemberRange |
Family method | AddMembers | Overloaded.
Family method | AlwaysMemberFilter |
Family method | EqualsInternal |
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ImportBase Class


Properties

ImportBase Properties
[image]

Public Properties

 | Name | Description
Public property | IsContainer | Determines if this import can contain other imports
Public property | Name | Gets the name of the import
Top

Protected Properties

 | Name | Description
Family property | Context |
Top

See Also

ImportBase Class


Context Property

ImportBase.Context Property
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Context As ExpressionContext
C#
protected ExpressionContext Context { get; }
C++
protected property ExpressionContext Context sealed {
ExpressionContext get();
}
J#
/** property */
protected ExpressionContext get_Context();
JScript
protected function get Context() : ExpressionContext

See Also

ImportBase Class


IsContainer Property

ImportBase.IsContainer Property
[image]

Determines if this import can contain other imports

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsContainer As Boolean
C#
public virtual bool IsContainer { get; }
C++
public virtual property bool IsContainer {
bool get();
}
J#
/** property */
public bool get_IsContainer();
JScript
public function get IsContainer() : bool

Property Value

True if this import can contain other imports; False otherwise

Remarks

Use this property to determine if this import contains other imports

See Also

ImportBase Class


Name Property

ImportBase.Name Property
[image]

Gets the name of the import

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Name As String
C#
public abstract string Name { get; }
C++
public abstract property string Name abstract {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Property Value

The name of the current import instance

Remarks

Use this property to get the name of the import

See Also

ImportBase Class


Methods

ImportBase Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal.
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetMembers |
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
 | AddImportMembers | Overloaded.
 | AddMemberRange |
Family method | AddMembers | Overloaded.
Family method | AlwaysMemberFilter |
Family method | EqualsInternal |
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ImportBase Class


AddImportMembers Method

ImportBase.AddImportMembers Method

Overload List

Name | Description
AddImportMembers (ImportBase, MemberTypes, ICollection<MemberInfo>) |
AddImportMembers (ImportBase, String, MemberTypes, ICollection<MemberInfo>) |

See Also

ImportBase Class


AddImportMembers Method (ImportBase, MemberTypes, Generic ICollection)

ImportBase.AddImportMembers Method (ImportBase, MemberTypes, Generic ICollection)
See Also Example
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub AddImportMembers( _
ByVal import As ImportBase, _
ByVal memberType As MemberTypes, _
ByVal dest As ICollection(Of MemberInfo) _
)
C#
protected static void AddImportMembers(
ImportBase import,
MemberTypes memberType,
ICollection<MemberInfo> dest
)
C++
protected:
static void AddImportMembers(
ImportBase import,
MemberTypes memberType,
ICollection<MemberInfo> dest
)
J#
protected static void AddImportMembers(
ImportBase import,
MemberTypes memberType,
ICollection<MemberInfo> dest
)
JScript
protected static function AddImportMembers(
import : ImportBase,
memberType : MemberTypes,
dest : ICollection<MemberInfo>
)

See Also

ImportBase Class
Ciloci.Flee Namespace
ImportBase.AddImportMembers Overload List


AddImportMembers Method (ImportBase, String, MemberTypes, Generic ICollection)

ImportBase.AddImportMembers Method (ImportBase, String, MemberTypes, Generic ICollection)
See Also Example
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub AddImportMembers( _
ByVal import As ImportBase, _
ByVal memberName As String, _
ByVal memberType As MemberTypes, _
ByVal dest As ICollection(Of MemberInfo) _
)
C#
protected static void AddImportMembers(
ImportBase import,
string memberName,
MemberTypes memberType,
ICollection<MemberInfo> dest
)
C++
protected:
static void AddImportMembers(
ImportBase import,
String memberName,
MemberTypes memberType,
ICollection<MemberInfo> dest
)
J#
protected static void AddImportMembers(
ImportBase import,
string memberName,
MemberTypes memberType,
ICollection<MemberInfo> dest
)
JScript
protected static function AddImportMembers(
import : ImportBase,
memberName : String,
memberType : MemberTypes,
dest : ICollection<MemberInfo>
)

See Also

ImportBase Class
Ciloci.Flee Namespace
ImportBase.AddImportMembers Overload List


AddMemberRange Method

ImportBase.AddMemberRange Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Protected Shared Sub AddMemberRange( _
ByVal members As ICollection(Of MemberInfo), _
ByVal dest As ICollection(Of MemberInfo) _
)
C#
protected static void AddMemberRange(
ICollection<MemberInfo> members,
ICollection<MemberInfo> dest
)
C++
protected:
static void AddMemberRange(
ICollection<MemberInfo> members,
ICollection<MemberInfo> dest
)
J#
protected static void AddMemberRange(
ICollection<MemberInfo> members,
ICollection<MemberInfo> dest
)
JScript
protected static function AddMemberRange(
members : ICollection<MemberInfo>,
dest : ICollection<MemberInfo>
)

See Also

ImportBase Class


AddMembers Method

ImportBase.AddMembers Method

Overload List

 | Name | Description
Family method | AddMembers (MemberTypes, ICollection<MemberInfo>) |
Family method | AddMembers (String, MemberTypes, ICollection<MemberInfo>) |

See Also

ImportBase Class


AddMembers Method (MemberTypes, Generic ICollection)

ImportBase.AddMembers Method (MemberTypes, Generic ICollection)
See Also Example
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub AddMembers( _
ByVal memberType As MemberTypes, _
ByVal dest As ICollection(Of MemberInfo) _
)
C#
protected abstract void AddMembers(
MemberTypes memberType,
ICollection<MemberInfo> dest
)
C++
protected:
void AddMembers(
MemberTypes memberType,
ICollection<MemberInfo> dest
) abstract
J#
protected abstract void AddMembers(
MemberTypes memberType,
ICollection<MemberInfo> dest
)
JScript
protected abstract function AddMembers(
memberType : MemberTypes,
dest : ICollection<MemberInfo>
)

See Also

ImportBase Class
Ciloci.Flee Namespace
ImportBase.AddMembers Overload List


AddMembers Method (String, MemberTypes, Generic ICollection)

ImportBase.AddMembers Method (String, MemberTypes, Generic ICollection)
See Also Example
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub AddMembers( _
ByVal memberName As String, _
ByVal memberType As MemberTypes, _
ByVal dest As ICollection(Of MemberInfo) _
)
C#
protected abstract void AddMembers(
string memberName,
MemberTypes memberType,
ICollection<MemberInfo> dest
)
C++
protected:
void AddMembers(
String memberName,
MemberTypes memberType,
ICollection<MemberInfo> dest
) abstract
J#
protected abstract void AddMembers(
string memberName,
MemberTypes memberType,
ICollection<MemberInfo> dest
)
JScript
protected abstract function AddMembers(
memberName : String,
memberType : MemberTypes,
dest : ICollection<MemberInfo>
)

See Also

ImportBase Class
Ciloci.Flee Namespace
ImportBase.AddMembers Overload List


AlwaysMemberFilter Method

ImportBase.AlwaysMemberFilter Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Protected Function AlwaysMemberFilter( _
ByVal member As MemberInfo, _
ByVal criteria As Object _
) As Boolean
C#
protected bool AlwaysMemberFilter(
MemberInfo member,
object criteria
)
C++
protected:
bool AlwaysMemberFilter(
MemberInfo member,
Object criteria
) sealed
J#
protected bool AlwaysMemberFilter(
MemberInfo member,
object criteria
)
JScript
protected function AlwaysMemberFilter(
member : MemberInfo,
criteria : Object
) : bool

See Also

ImportBase Class


Equals Method

ImportBase.Equals Method

Determines whether two Object instances are equal.

Overload List

 | Name | Description
Public method | Equals (ImportBase) |
Public method | Equals (Object) | Determines whether the specified Object is equal to the current Object. (inherited from Object)

See Also

ImportBase Class


Equals Method (ImportBase)

ImportBase.Equals Method (ImportBase)
See Also Example
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals( _
ByVal other As ImportBase _
) As Boolean _
Implements IEquatable<ImportBase>.Equals
C#
public bool Equals(
ImportBase other
)
C++
public:
bool Equals(
ImportBase other
) sealed
J#
public bool Equals(
ImportBase other
)
JScript
public function Equals(
other : ImportBase
) : bool

Implements

IEquatable<ImportBase>.Equals

See Also

ImportBase Class
Ciloci.Flee Namespace
ImportBase.Equals Overload List


EqualsInternal Method

ImportBase.EqualsInternal Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Protected MustOverride Function EqualsInternal( _
ByVal import As ImportBase _
) As Boolean
C#
protected abstract bool EqualsInternal(
ImportBase import
)
C++
protected:
bool EqualsInternal(
ImportBase import
) abstract
J#
protected abstract bool EqualsInternal(
ImportBase import
)
JScript
protected abstract function EqualsInternal(
import : ImportBase
) : bool

See Also

ImportBase Class


GetEnumerator Method

ImportBase.GetEnumerator Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetEnumerator() As IEnumerator(Of ImportBase) _
Implements IEnumerable<ImportBase>.GetEnumerator
C#
public virtual IEnumerator<ImportBase> GetEnumerator()
C++
public:
virtual IEnumerator<ImportBase> GetEnumerator()
J#
public virtual IEnumerator<ImportBase> GetEnumerator()
JScript
public virtual function GetEnumerator() : IEnumerator<ImportBase>

Implements

IEnumerable<ImportBase>.GetEnumerator

See Also

ImportBase Class


GetMembers Method

ImportBase.GetMembers Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMembers( _
ByVal memberType As MemberTypes _
) As MemberInfo()
C#
public MemberInfo[] GetMembers(
MemberTypes memberType
)
C++
public:
array<MemberInfo>^ GetMembers(
MemberTypes memberType
) sealed
J#
public MemberInfo[] GetMembers(
MemberTypes memberType
)
JScript
public function GetMembers(
memberType : MemberTypes
) : MemberInfo[]

See Also

ImportBase Class


InvokeFunctionEventArgs Class

InvokeFunctionEventArgs Class
See Also Example Members
[image]

Provides the data for the InvokeFunction event.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Class InvokeFunctionEventArgs
Inherits EventArgs
C#
public class InvokeFunctionEventArgs : EventArgs
C++
ref class InvokeFunctionEventArgs : EventArgs
J#
public class InvokeFunctionEventArgs extends EventArgs
JScript
public class InvokeFunctionEventArgs extends EventArgs

Remarks

Use this class to provide the return value of an on-demand function.

Inheritance Hierarchy

System.Object
System.EventArgs
Ciloci.Flee.InvokeFunctionEventArgs

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

InvokeFunctionEventArgs Members


InvokeFunctionEventArgs Members

InvokeFunctionEventArgs Members
See Also Example Properties Methods
[image]

Provides the data for the InvokeFunction event.

The following tables list the members exposed by InvokeFunctionEventArgs.

Public Properties

 | Name | Description
Public property | Arguments | Gets the values of the arguments to the on-demand function being invoked.
Public property | FunctionName | Gets the name of the on-demand function being invoked.
Public property | Result | Gets or sets the result of the on-demand function being invoked.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

InvokeFunctionEventArgs Class


Properties

InvokeFunctionEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Arguments | Gets the values of the arguments to the on-demand function being invoked.
Public property | FunctionName | Gets the name of the on-demand function being invoked.
Public property | Result | Gets or sets the result of the on-demand function being invoked.
Top

See Also

InvokeFunctionEventArgs Class


Arguments Property

InvokeFunctionEventArgs.Arguments Property
[image]

Gets the values of the arguments to the on-demand function being invoked.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arguments As Object()
C#
public object[] Arguments { get; }
C++
public property object[] Arguments sealed {
array<Object>^ get();
}
J#
/** property */
public object[] get_Arguments();
JScript
public function get Arguments() : Object[]

Property Value

An array with the values of each argument

Remarks

Use this property to get the values of the arguments to the on-demand function being invoked.

See Also

InvokeFunctionEventArgs Class


FunctionName Property

InvokeFunctionEventArgs.FunctionName Property
[image]

Gets the name of the on-demand function being invoked.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FunctionName As String
C#
public string FunctionName { get; }
C++
public property string FunctionName sealed {
String get();
}
J#
/** property */
public string get_FunctionName();
JScript
public function get FunctionName() : String

Property Value

The name of the function

Remarks

Use this property to get the name of the on-demand function being invoked.

See Also

InvokeFunctionEventArgs Class


Result Property

InvokeFunctionEventArgs.Result Property
[image]

Gets or sets the result of the on-demand function being invoked.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property Result As Object
C#
public object Result { get; set; }
C++
public property object Result sealed {
Object get();
void set(Object value);
}
J#
/** property */
public object get_Result();

/** property */
public void set_Result(object value);
JScript
public function get Result() : Object

public function set Result(value : Object);

Property Value

The return value of the function

Remarks

Use this property to set the return value of the on-demand function being invoked.

See Also

InvokeFunctionEventArgs Class


MethodImport Class

MethodImport Class
See Also Example Members
[image]

Represents an imported method This class cannot be inherited.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class MethodImport
Inherits ImportBase
C#
public sealed class MethodImport : ImportBase
C++
ref class MethodImport sealed : ImportBase
J#
public final class MethodImport extends ImportBase
JScript
public final class MethodImport extends ImportBase

Remarks

Use this class when you want to make a single method available to an expression

Inheritance Hierarchy

System.Object
Ciloci.Flee.ImportBase
Ciloci.Flee.MethodImport

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

MethodImport Members


MethodImport Members

MethodImport Members
See Also Example Constructors Properties Methods
[image]

Represents an imported method This class cannot be inherited.

The following tables list the members exposed by MethodImport.

Public Constructors

 | Name | Description
Public method | MethodImport | Creates a new method import with a given method
Top

Public Properties

 | Name | Description
Public property | IsContainer | Determines if this import can contain other imports (inherited from ImportBase)
Public property | Name | Overridden.
Public property | Target | Gets the method that this import represents
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from ImportBase)
Public method | GetEnumerator | (inherited from ImportBase)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetMembers | (inherited from ImportBase)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

MethodImport Class


MethodImport Constructor

MethodImport Constructor
[image]

Creates a new method import with a given method

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal importMethod As MethodInfo _
)
C#
public MethodImport(
MethodInfo importMethod
)
C++
public:
MethodImport(
MethodInfo importMethod
) sealed
J#
public MethodImport(
MethodInfo importMethod
)
JScript
public function MethodImport(
importMethod : MethodInfo
)

Parameters

importMethod
The method to import

See Also

MethodImport Class


Properties

MethodImport Properties
[image]

Public Properties

 | Name | Description
Public property | IsContainer | Determines if this import can contain other imports (inherited from ImportBase)
Public property | Name | Overridden.
Public property | Target | Gets the method that this import represents
Top

See Also

MethodImport Class


Name Property

MethodImport.Name Property
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

MethodImport Class


Target Property

MethodImport.Target Property
[image]

Gets the method that this import represents

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Target As MethodInfo
C#
public MethodInfo Target { get; }
C++
public property MethodInfo Target sealed {
MethodInfo get();
}
J#
/** property */
public MethodInfo get_Target();
JScript
public function get Target() : MethodInfo

Property Value

The method that this import represents

Remarks

Use this property to retrieve the imported method

See Also

MethodImport Class


NamespaceImport Class

NamespaceImport Class
See Also Example Members
[image]

Represents an imported namespace This class cannot be inherited.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NamespaceImport
Inherits ImportBase
Implements ICollection(Of ImportBase)
C#
public sealed class NamespaceImport : ImportBase, ICollection<ImportBase>
C++
ref class NamespaceImport sealed : ImportBase, ICollection<ImportBase>
J#
public final class NamespaceImport extends ImportBase implements ICollection<ImportBase>
JScript
public final class NamespaceImport extends ImportBase, ICollection<ImportBase>

Remarks

This class acts as a container for other imports. Use it when you want to logically group expression imports.

Inheritance Hierarchy

System.Object
Ciloci.Flee.ImportBase
Ciloci.Flee.NamespaceImport

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NamespaceImport Members


NamespaceImport Members

NamespaceImport Members
See Also Example Constructors Properties Methods
[image]

Represents an imported namespace This class cannot be inherited.

The following tables list the members exposed by NamespaceImport.

Public Constructors

 | Name | Description
Public method | NamespaceImport | Creates a new namespace import with a given namespace name
Top

Public Properties

 | Name | Description
Public property | Count |
Public property | IsContainer | Overridden.
Public property | Name | Overridden.
Top

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from ImportBase)
Public method | GetEnumerator | Overridden.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetMembers | (inherited from ImportBase)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Remove |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NamespaceImport Class


NamespaceImport Constructor

NamespaceImport Constructor
[image]

Creates a new namespace import with a given namespace name

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal importNamespace As String _
)
C#
public NamespaceImport(
string importNamespace
)
C++
public:
NamespaceImport(
String importNamespace
) sealed
J#
public NamespaceImport(
string importNamespace
)
JScript
public function NamespaceImport(
importNamespace : String
)

Parameters

importNamespace
The name of the namespace to import

See Also

NamespaceImport Class


Properties

NamespaceImport Properties
[image]

Public Properties

 | Name | Description
Public property | Count |
Public property | IsContainer | Overridden.
Public property | Name | Overridden.
Top

See Also

NamespaceImport Class


Count Property

NamespaceImport.Count Property
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer _
Implements ICollection<ImportBase>.Count
C#
public int Count { get; }
C++
public property int Count sealed {
int get();
}
J#
/** property */
public int get_Count();
JScript
public function get Count() : int

Implements

ICollection<ImportBase>.Count

See Also

NamespaceImport Class


IsContainer Property

NamespaceImport.IsContainer Property
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsContainer As Boolean
C#
public override bool IsContainer { get; }
C++
public override property bool IsContainer override {
bool get();
}
J#
/** property */
public bool get_IsContainer();
JScript
public function get IsContainer() : bool

See Also

NamespaceImport Class


Name Property

NamespaceImport.Name Property
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

NamespaceImport Class


Methods

NamespaceImport Methods
[image]

Public Methods

 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from ImportBase)
Public method | GetEnumerator | Overridden.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetMembers | (inherited from ImportBase)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | Remove |
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NamespaceImport Class


Add Method

NamespaceImport.Add Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal item As ImportBase _
) _
Implements ICollection<ImportBase>.Add
C#
public void Add(
ImportBase item
)
C++
public:
void Add(
ImportBase item
) sealed
J#
public void Add(
ImportBase item
)
JScript
public function Add(
item : ImportBase
)

Implements

ICollection<ImportBase>.Add

See Also

NamespaceImport Class


Clear Method

NamespaceImport.Clear Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear() _
Implements ICollection<ImportBase>.Clear
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
public function Clear()

Implements

ICollection<ImportBase>.Clear

See Also

NamespaceImport Class


Contains Method

NamespaceImport.Contains Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal item As ImportBase _
) As Boolean _
Implements ICollection<ImportBase>.Contains
C#
public bool Contains(
ImportBase item
)
C++
public:
bool Contains(
ImportBase item
) sealed
J#
public bool Contains(
ImportBase item
)
JScript
public function Contains(
item : ImportBase
) : bool

Implements

ICollection<ImportBase>.Contains

See Also

NamespaceImport Class


CopyTo Method

NamespaceImport.CopyTo Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
ByVal array As ImportBase(), _
ByVal arrayIndex As Integer _
) _
Implements ICollection<ImportBase>.CopyTo
C#
public void CopyTo(
ImportBase[] array,
int arrayIndex
)
C++
public:
void CopyTo(
array<ImportBase>^ array,
int arrayIndex
) sealed
J#
public void CopyTo(
ImportBase[] array,
int arrayIndex
)
JScript
public function CopyTo(
array : ImportBase[],
arrayIndex : int
)

Implements

ICollection<ImportBase>.CopyTo

See Also

NamespaceImport Class


GetEnumerator Method

NamespaceImport.GetEnumerator Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEnumerator() As IEnumerator(Of ImportBase) _
Implements IEnumerable<ImportBase>.GetEnumerator
C#
public override IEnumerator<ImportBase> GetEnumerator()
C++
public:
virtual IEnumerator<ImportBase> GetEnumerator() override
J#
public override IEnumerator<ImportBase> GetEnumerator()
JScript
public override function GetEnumerator() : IEnumerator<ImportBase>

Implements

IEnumerable<ImportBase>.GetEnumerator

See Also

NamespaceImport Class


Remove Method

NamespaceImport.Remove Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal item As ImportBase _
) As Boolean _
Implements ICollection<ImportBase>.Remove
C#
public bool Remove(
ImportBase item
)
C++
public:
bool Remove(
ImportBase item
) sealed
J#
public bool Remove(
ImportBase item
)
JScript
public function Remove(
item : ImportBase
) : bool

Implements

ICollection<ImportBase>.Remove

See Also

NamespaceImport Class


RealLiteralDataType Enumeration

RealLiteralDataType Enumeration
[image]

Defines values to indicate the data type to use for storing real literals.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Enum RealLiteralDataType
C#
public enum RealLiteralDataType
C++
public enum class RealLiteralDataType
J#
public enum RealLiteralDataType
JScript
public enum RealLiteralDataType

Members

Member Name | Description
Single | Specifies that real literals will be stored using the Single data type.
Double | Specifies that real literals will be stored using the Double data type.
Decimal | Specifies that real literals will be stored using the Decimal data type.

See Also

Ciloci.Flee Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

© 2007 Eugene Ciloci


ResolveFunctionEventArgs Class

ResolveFunctionEventArgs Class
See Also Example Members
[image]

Provides the data for the ResolveFunction event.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Class ResolveFunctionEventArgs
Inherits EventArgs
C#
public class ResolveFunctionEventArgs : EventArgs
C++
ref class ResolveFunctionEventArgs : EventArgs
J#
public class ResolveFunctionEventArgs extends EventArgs
JScript
public class ResolveFunctionEventArgs extends EventArgs

Remarks

Use this class to provide the return type of an on-demand function.

Inheritance Hierarchy

System.Object
System.EventArgs
Ciloci.Flee.ResolveFunctionEventArgs

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResolveFunctionEventArgs Members


ResolveFunctionEventArgs Members

ResolveFunctionEventArgs Members
See Also Example Properties Methods
[image]

Provides the data for the ResolveFunction event.

The following tables list the members exposed by ResolveFunctionEventArgs.

Public Properties

 | Name | Description
Public property | ArgumentTypes | Gets the types of the arguments to the on-demand function being resolved.
Public property | FunctionName | Gets the name of the on-demand function being resolved.
Public property | ReturnType | Gets or sets the return type of the on-demand function being resolved.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ResolveFunctionEventArgs Class


Properties

ResolveFunctionEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | ArgumentTypes | Gets the types of the arguments to the on-demand function being resolved.
Public property | FunctionName | Gets the name of the on-demand function being resolved.
Public property | ReturnType | Gets or sets the return type of the on-demand function being resolved.
Top

See Also

ResolveFunctionEventArgs Class


ArgumentTypes Property

ResolveFunctionEventArgs.ArgumentTypes Property
[image]

Gets the types of the arguments to the on-demand function being resolved.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ArgumentTypes As Type()
C#
public Type[] ArgumentTypes { get; }
C++
public property Type[] ArgumentTypes sealed {
array<Type>^ get();
}
J#
/** property */
public Type[] get_ArgumentTypes();
JScript
public function get ArgumentTypes() : Type[]

Property Value

An array with the type of each argument

Remarks

Use this property to get the types of the arguments to the on-demand function being resolved.

See Also

ResolveFunctionEventArgs Class


FunctionName Property

ResolveFunctionEventArgs.FunctionName Property
[image]

Gets the name of the on-demand function being resolved.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FunctionName As String
C#
public string FunctionName { get; }
C++
public property string FunctionName sealed {
String get();
}
J#
/** property */
public string get_FunctionName();
JScript
public function get FunctionName() : String

Property Value

The name of the function

Remarks

Use this property to get the name of the on-demand function being resolved.

See Also

ResolveFunctionEventArgs Class


ReturnType Property

ResolveFunctionEventArgs.ReturnType Property
[image]

Gets or sets the return type of the on-demand function being resolved.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnType As Type
C#
public Type ReturnType { get; set; }
C++
public property Type ReturnType sealed {
Type get();
void set(Type value);
}
J#
/** property */
public Type get_ReturnType();

/** property */
public void set_ReturnType(Type value);
JScript
public function get ReturnType() : Type

public function set ReturnType(value : Type);

Property Value

The return type of the function

Remarks

Use this property to set the return type of the on-demand function being resolved.

See Also

ResolveFunctionEventArgs Class


ResolveVariableTypeEventArgs Class

ResolveVariableTypeEventArgs Class
See Also Example Members
[image]

Provides the data for the ResolveVariableType event.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Class ResolveVariableTypeEventArgs
Inherits EventArgs
C#
public class ResolveVariableTypeEventArgs : EventArgs
C++
ref class ResolveVariableTypeEventArgs : EventArgs
J#
public class ResolveVariableTypeEventArgs extends EventArgs
JScript
public class ResolveVariableTypeEventArgs extends EventArgs

Remarks

Use this class to provide the type of an on-demand variable.

Inheritance Hierarchy

System.Object
System.EventArgs
Ciloci.Flee.ResolveVariableTypeEventArgs

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResolveVariableTypeEventArgs Members


ResolveVariableTypeEventArgs Members

ResolveVariableTypeEventArgs Members
See Also Example Properties Methods
[image]

Provides the data for the ResolveVariableType event.

The following tables list the members exposed by ResolveVariableTypeEventArgs.

Public Properties

 | Name | Description
Public property | VariableName | Gets the name of an on-demand variable.
Public property | VariableType | Gets or sets the type of an on-demand variable.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ResolveVariableTypeEventArgs Class


Properties

ResolveVariableTypeEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | VariableName | Gets the name of an on-demand variable.
Public property | VariableType | Gets or sets the type of an on-demand variable.
Top

See Also

ResolveVariableTypeEventArgs Class


VariableName Property

ResolveVariableTypeEventArgs.VariableName Property
[image]

Gets the name of an on-demand variable.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VariableName As String
C#
public string VariableName { get; }
C++
public property string VariableName sealed {
String get();
}
J#
/** property */
public string get_VariableName();
JScript
public function get VariableName() : String

Property Value

The name of the variable

Remarks

Use this property to get the name of the variable whose type needs to be resolved.

See Also

ResolveVariableTypeEventArgs Class


VariableType Property

ResolveVariableTypeEventArgs.VariableType Property
[image]

Gets or sets the type of an on-demand variable.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property VariableType As Type
C#
public Type VariableType { get; set; }
C++
public property Type VariableType sealed {
Type get();
void set(Type value);
}
J#
/** property */
public Type get_VariableType();

/** property */
public void set_VariableType(Type value);
JScript
public function get VariableType() : Type

public function set VariableType(value : Type);

Property Value

The type of the variable

Remarks

Use this property to get or set the type of the on-demand variable.

See Also

ResolveVariableTypeEventArgs Class


ResolveVariableValueEventArgs Class

ResolveVariableValueEventArgs Class
See Also Example Members
[image]

Provides the data for the ResolveVariableValue event.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Class ResolveVariableValueEventArgs
Inherits EventArgs
C#
public class ResolveVariableValueEventArgs : EventArgs
C++
ref class ResolveVariableValueEventArgs : EventArgs
J#
public class ResolveVariableValueEventArgs extends EventArgs
JScript
public class ResolveVariableValueEventArgs extends EventArgs

Remarks

Use this class to provide the value of an on-demand variable.

Inheritance Hierarchy

System.Object
System.EventArgs
Ciloci.Flee.ResolveVariableValueEventArgs

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

ResolveVariableValueEventArgs Members


ResolveVariableValueEventArgs Members

ResolveVariableValueEventArgs Members
See Also Example Properties Methods
[image]

Provides the data for the ResolveVariableValue event.

The following tables list the members exposed by ResolveVariableValueEventArgs.

Public Properties

 | Name | Description
Public property | VariableName | Gets the name of an on-demand variable.
Public property | VariableType | Gets the type of an on-demand variable.
Public property | VariableValue | Gets or sets the value of an on-demand variable.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

ResolveVariableValueEventArgs Class


Properties

ResolveVariableValueEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | VariableName | Gets the name of an on-demand variable.
Public property | VariableType | Gets the type of an on-demand variable.
Public property | VariableValue | Gets or sets the value of an on-demand variable.
Top

See Also

ResolveVariableValueEventArgs Class


VariableName Property

ResolveVariableValueEventArgs.VariableName Property
[image]

Gets the name of an on-demand variable.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VariableName As String
C#
public string VariableName { get; }
C++
public property string VariableName sealed {
String get();
}
J#
/** property */
public string get_VariableName();
JScript
public function get VariableName() : String

Property Value

The name of the variable

Remarks

Use this property to get the name of the variable whose value needs to be resolved.

See Also

ResolveVariableValueEventArgs Class


VariableType Property

ResolveVariableValueEventArgs.VariableType Property
[image]

Gets the type of an on-demand variable.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VariableType As Type
C#
public Type VariableType { get; }
C++
public property Type VariableType sealed {
Type get();
}
J#
/** property */
public Type get_VariableType();
JScript
public function get VariableType() : Type

Property Value

The type of the variable

Remarks

Use this property to get the type of the variable whose value needs to be resolved.

See Also

ResolveVariableValueEventArgs Class


VariableValue Property

ResolveVariableValueEventArgs.VariableValue Property
[image]

Gets or sets the value of an on-demand variable.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property VariableValue As Object
C#
public object VariableValue { get; set; }
C++
public property object VariableValue sealed {
Object get();
void set(Object value);
}
J#
/** property */
public object get_VariableValue();

/** property */
public void set_VariableValue(object value);
JScript
public function get VariableValue() : Object

public function set VariableValue(value : Object);

Property Value

The value of the variable

Remarks

Use this property to get or set the value of an on-demand variable.

See Also

ResolveVariableValueEventArgs Class


TypeImport Class

TypeImport Class
See Also Example Members
[image]

Represents an imported type This class cannot be inherited.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class TypeImport
Inherits ImportBase
C#
public sealed class TypeImport : ImportBase
C++
ref class TypeImport sealed : ImportBase
J#
public final class TypeImport extends ImportBase
JScript
public final class TypeImport extends ImportBase

Remarks

Use this class when you want to make the members of a type available to an expression

Inheritance Hierarchy

System.Object
Ciloci.Flee.ImportBase
Ciloci.Flee.TypeImport

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

TypeImport Members


TypeImport Members

TypeImport Members
See Also Example Properties Methods Explicit Inteface Implementations
[image]

Represents an imported type This class cannot be inherited.

The following tables list the members exposed by TypeImport.

Public Constructors

Name | Description
TypeImport | Overloaded.
Top

Public Properties

 | Name | Description
Public property | IsContainer | Overridden.
Public property | Name | Overridden.
Public property | Target | Gets the type that this import represents
Top

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from ImportBase)
Public method | GetEnumerator | Overridden.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetMembers | (inherited from ImportBase)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Explicit Interface Implementations

Name | Description
TypeImport | Overloaded.
Top

See Also

TypeImport Class


TypeImport Constructor

TypeImport Constructor

Overload List

 | Name | Description
Public method | TypeImport (Type) | Creates a new import with a given type
Public method | TypeImport (Type, Boolean) | Creates a new import with a given type

See Also

TypeImport Class


TypeImport Constructor (Type)

TypeImport Constructor (Type)
See Also Example
[image]

Creates a new import with a given type

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal importType As Type _
)
C#
public TypeImport(
Type importType
)
C++
public:
TypeImport(
Type importType
) sealed
J#
public TypeImport(
Type importType
)
JScript
public function TypeImport(
importType : Type
)

Parameters

importType
The type to import

See Also

TypeImport Class
Ciloci.Flee Namespace
TypeImport Constructor Overload List


TypeImport Constructor (Type, Boolean)

TypeImport Constructor (Type, Boolean)
See Also Example
[image]

Creates a new import with a given type

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub New( _
ByVal importType As Type, _
ByVal useTypeNameAsNamespace As Boolean _
)
C#
public TypeImport(
Type importType,
bool useTypeNameAsNamespace
)
C++
public:
TypeImport(
Type importType,
bool useTypeNameAsNamespace
) sealed
J#
public TypeImport(
Type importType,
bool useTypeNameAsNamespace
)
JScript
public function TypeImport(
importType : Type,
useTypeNameAsNamespace : bool
)

Parameters

importType
The type to import
useTypeNameAsNamespace
True to use the type's name as a namespace; False otherwise

Remarks

When useTypeNameAsNamespace is set to True, the type will act as a namespace in an expression. For example: If you import the DayOfWeek enum and set the flag to true, you can reference it as DayOfWeek.Sunday in an expression. When the flag is false, you would reference it as simply Sunday.

See Also

TypeImport Class
Ciloci.Flee Namespace
TypeImport Constructor Overload List


Properties

TypeImport Properties
[image]

Public Properties

 | Name | Description
Public property | IsContainer | Overridden.
Public property | Name | Overridden.
Public property | Target | Gets the type that this import represents
Top

See Also

TypeImport Class


IsContainer Property

TypeImport.IsContainer Property
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsContainer As Boolean
C#
public override bool IsContainer { get; }
C++
public override property bool IsContainer override {
bool get();
}
J#
/** property */
public bool get_IsContainer();
JScript
public function get IsContainer() : bool

See Also

TypeImport Class


Name Property

TypeImport.Name Property
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String
C#
public override string Name { get; }
C++
public override property string Name override {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

See Also

TypeImport Class


Target Property

TypeImport.Target Property
[image]

Gets the type that this import represents

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Target As Type
C#
public Type Target { get; }
C++
public property Type Target sealed {
Type get();
}
J#
/** property */
public Type get_Target();
JScript
public function get Target() : Type

Property Value

The type that this import represents

Remarks

Use this property to retrieve the imported type

See Also

TypeImport Class


Methods

TypeImport Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Overloaded. Determines whether two Object instances are equal. (inherited from ImportBase)
Public method | GetEnumerator | Overridden.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetMembers | (inherited from ImportBase)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

TypeImport Class


GetEnumerator Method

TypeImport.GetEnumerator Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEnumerator() As IEnumerator(Of ImportBase) _
Implements IEnumerable<ImportBase>.GetEnumerator
C#
public override IEnumerator<ImportBase> GetEnumerator()
C++
public:
virtual IEnumerator<ImportBase> GetEnumerator() override
J#
public override IEnumerator<ImportBase> GetEnumerator()
JScript
public override function GetEnumerator() : IEnumerator<ImportBase>

Implements

IEnumerable<ImportBase>.GetEnumerator

See Also

TypeImport Class


VariableCollection Class

VariableCollection Class
See Also Example Members
[image]

Manages the variables available to an expression This class cannot be inherited.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class VariableCollection
Implements IDictionary(Of String, Object), ICollection(Of KeyValuePair(Of String, Object)), IEnumerable(Of KeyValuePair(Of String, Object)), IEnumerable
C#
[DefaultMemberAttribute("Item")]
public sealed class VariableCollection : IDictionary<string, object>, ICollection<KeyValuePair<string, object>>, IEnumerable<KeyValuePair<string, object>>, IEnumerable
C++
[DefaultMemberAttribute(L"Item")]
ref class VariableCollection sealed : IDictionary<string, object>, ICollection<KeyValuePair<string, object>>, IEnumerable<KeyValuePair<string, object>>, IEnumerable
J#
/** @attribute DefaultMemberAttribute("Item") */
public final class VariableCollection implements IDictionary<string, object>, ICollection<KeyValuePair<string, object>>, IEnumerable<KeyValuePair<string, object>>, IEnumerable
JScript
public
DefaultMemberAttribute("Item")
final class VariableCollection extends IDictionary<string, object>, ICollection<KeyValuePair<string, object>>, IEnumerable<KeyValuePair<string, object>>, IEnumerable

Remarks

Use this class to manage the variables that an expression can use

Inheritance Hierarchy

System.Object
Ciloci.Flee.VariableCollection

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

VariableCollection Members


VariableCollection Members

VariableCollection Members
See Also Example Properties Methods Events
[image]

Manages the variables available to an expression This class cannot be inherited.

The following tables list the members exposed by VariableCollection.

Public Properties

 | Name | Description
Public property | Count | Gets the number of variables defined in the collection.
Public property | Item | Gets or sets the value of a variable.
Public property | Keys | Gets a collection with the names of all variables.
Public property | Values | Gets a collection with the values of all variables.
Top

Public Methods

 | Name | Description
Public method | Add | Adds a variable to the collection.
Public method | Clear | Removes all variables from the collection.
Public method | ContainsKey | Determines if the collection contains a variable.
Public method | DefineVariable | Defines a variable with a specific type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator |
Public method | GetFunctionResultInternal | Gets the result of an on-demand function
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetVariableType | Gets the type of a variable.
Public method | GetVariableValueInternal | Gets the value of a variable
Public method | GetVirtualPropertyValueInternal | Gets the result of a virtual property
Public method | Remove | Removes a variable from the collection.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue | Gets the value of a variable in the collection.
Top

Public Events

 | Name | Description
Public event | InvokeFunction | Occurs when an expression needs the return value of a function.
Public event | ResolveFunction | Occurs when an expression needs the return type of a function.
Public event | ResolveVariableType | Occurs when an expression needs the type of a variable.
Public event | ResolveVariableValue | Occurs when an expression needs the value of a variable.
Top

See Also

VariableCollection Class


Properties

VariableCollection Properties
[image]

Public Properties

 | Name | Description
Public property | Count | Gets the number of variables defined in the collection.
Public property | Item | Gets or sets the value of a variable.
Public property | Keys | Gets a collection with the names of all variables.
Public property | Values | Gets a collection with the values of all variables.
Top

See Also

VariableCollection Class


Count Property

VariableCollection.Count Property
[image]

Gets the number of variables defined in the collection.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer _
Implements ICollection<KeyValuePair<String,Object>>.Count
C#
public int Count { get; }
C++
public property int Count sealed {
int get();
}
J#
/** property */
public int get_Count();
JScript
public function get Count() : int

Property Value

The number of variables in the collection

Implements

ICollection<KeyValuePair<String,Object>>.Count

Remarks

Use this method to get a count of the number of variables in the collection

See Also

VariableCollection Class


Item Property

VariableCollection.Item Property
[image]

Gets or sets the value of a variable.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
ByVal name As String _
) As Object _
Implements IDictionary<String,Object>.Item
C#
public object this[
string name
] { get; set; }
C++
public property object default[String name] sealed {
Object get(String name);
void set(String name, Object value);
}
J#
/** property */
public object get_Item(string name);

/** property */
public void set_Item(string name, object value);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

Parameters

name
The name of the variable

Property Value

The value of the variable

Implements

IDictionary<String,Object>.Item

Exceptions

Exception Type | Condition
ArgumentException | The type of the new value is not compatible with the type of the existing variable

Remarks

Use this method to get or set the value of a variable. If a variable with the given name does not exist, a new variable will be defined. Otherwise, the value of the existing variable will be overwritten.

See Also

VariableCollection Class


Keys Property

VariableCollection.Keys Property
[image]

Gets a collection with the names of all variables.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keys As ICollection(Of String) _
Implements IDictionary<String,Object>.Keys
C#
public ICollection<string> Keys { get; }
C++
public property ICollection<string> Keys sealed {
ICollection<string> get();
}
J#
/** property */
public ICollection<string> get_Keys();
JScript
public function get Keys() : ICollection<string>

Property Value

A collection with all the names

Implements

IDictionary<String,Object>.Keys

Remarks

Use this method to access all the variable names in the collection

See Also

VariableCollection Class


Values Property

VariableCollection.Values Property
[image]

Gets a collection with the values of all variables.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Values As ICollection(Of Object) _
Implements IDictionary<String,Object>.Values
C#
public ICollection<object> Values { get; }
C++
public property ICollection<object> Values sealed {
ICollection<object> get();
}
J#
/** property */
public ICollection<object> get_Values();
JScript
public function get Values() : ICollection<object>

Property Value

A collection with all the values

Implements

IDictionary<String,Object>.Values

Remarks

Use this method to access all the variable values in the collection

See Also

VariableCollection Class


Methods

VariableCollection Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Adds a variable to the collection.
Public method | Clear | Removes all variables from the collection.
Public method | ContainsKey | Determines if the collection contains a variable.
Public method | DefineVariable | Defines a variable with a specific type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetEnumerator |
Public method | GetFunctionResultInternal | Gets the result of an on-demand function
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | GetVariableType | Gets the type of a variable.
Public method | GetVariableValueInternal | Gets the value of a variable
Public method | GetVirtualPropertyValueInternal | Gets the result of a virtual property
Public method | Remove | Removes a variable from the collection.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Public method | TryGetValue | Gets the value of a variable in the collection.
Top

See Also

VariableCollection Class


Add Method

VariableCollection.Add Method
[image]

Adds a variable to the collection.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal name As String, _
ByVal value As Object _
) _
Implements IDictionary<String,Object>.Add
C#
public void Add(
string name,
object value
)
C++
public:
void Add(
String name,
Object value
) sealed
J#
public void Add(
string name,
object value
)
JScript
public function Add(
name : String,
value : Object
)

Parameters

name
The name of the variable
value
The value of the variable

Implements

IDictionary<String,Object>.Add

Remarks

Use this method to add a variable to the collection

See Also

VariableCollection Class


Clear Method

VariableCollection.Clear Method
[image]

Removes all variables from the collection.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear() _
Implements ICollection<KeyValuePair<String,Object>>.Clear
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
public function Clear()

Implements

ICollection<KeyValuePair<String,Object>>.Clear

Remarks

Use this method to remove all variables from the collection

See Also

VariableCollection Class


ContainsKey Method

VariableCollection.ContainsKey Method
[image]

Determines if the collection contains a variable.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
ByVal name As String _
) As Boolean _
Implements IDictionary<String,Object>.ContainsKey
C#
public bool ContainsKey(
string name
)
C++
public:
bool ContainsKey(
String name
) sealed
J#
public bool ContainsKey(
string name
)
JScript
public function ContainsKey(
name : String
) : bool

Parameters

name
The name of the variable

Return Value

True if the collection has a variable with the given name; False otherwise

Implements

IDictionary<String,Object>.ContainsKey

Remarks

Use this method to determine if the collection contains a variable

See Also

VariableCollection Class


DefineVariable Method

VariableCollection.DefineVariable Method
[image]

Defines a variable with a specific type.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub DefineVariable( _
ByVal name As String, _
ByVal variableType As Type _
)
C#
public void DefineVariable(
string name,
Type variableType
)
C++
public:
void DefineVariable(
String name,
Type variableType
) sealed
J#
public void DefineVariable(
string name,
Type variableType
)
JScript
public function DefineVariable(
name : String,
variableType : Type
)

Parameters

name
The name of the variable
variableType
The type of the new variable

Remarks

Use this method when you want to add a variable with a type that is different than what would be inferred from defining it using the indexer.

See Also

VariableCollection Class


GetEnumerator Method

VariableCollection.GetEnumerator Method
[image]

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of KeyValuePair(Of String, Object)) _
Implements IEnumerable<KeyValuePair<String,Object>>.GetEnumerator
C#
public IEnumerator<KeyValuePair<string, object>> GetEnumerator()
C++
public:
IEnumerator<KeyValuePair<string, object>> GetEnumerator() sealed
J#
public IEnumerator<KeyValuePair<string, object>> GetEnumerator()
JScript
public function GetEnumerator() : IEnumerator<KeyValuePair<string, object>>

Implements

IEnumerable<KeyValuePair<String,Object>>.GetEnumerator

See Also

VariableCollection Class


GetFunctionResultInternal Generic Method

VariableCollection.GetFunctionResultInternal Generic Method
[image]

Gets the result of an on-demand function

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function GetFunctionResultInternal(Of T)( _
ByVal name As String, _
ByVal arguments As Object() _
)
C#
public T GetFunctionResultInternal<T>(
string name,
object[] arguments
)
C++
public:
T GetFunctionResultInternal<T>(
String name,
array<Object>^ arguments
) sealed
J#
public T GetFunctionResultInternal<T>(
string name,
object[] arguments
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of the result's value

Parameters

name
The name of the function
arguments

Return Value

The function's result

Remarks

This method is used by the expression to retrieve the values of on-demand functions during evaluation. It must be public so that all expressions can access it. It is meant for internal use and you shouldn't depend on any of its functionality.

See Also

VariableCollection Class


GetVariableType Method

VariableCollection.GetVariableType Method
[image]

Gets the type of a variable.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function GetVariableType( _
ByVal name As String _
) As Type
C#
public Type GetVariableType(
string name
)
C++
public:
Type GetVariableType(
String name
) sealed
J#
public Type GetVariableType(
string name
)
JScript
public function GetVariableType(
name : String
) : Type

Parameters

name
The name of the variable

Return Value

The type of the variable's value

Remarks

Use this method to get the type of the value of a variable.

See Also

VariableCollection Class


GetVariableValueInternal Generic Method

VariableCollection.GetVariableValueInternal Generic Method
[image]

Gets the value of a variable

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function GetVariableValueInternal(Of T)( _
ByVal name As String _
)
C#
public T GetVariableValueInternal<T>(
string name
)
C++
public:
T GetVariableValueInternal<T>(
String name
) sealed
J#
public T GetVariableValueInternal<T>(
string name
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of the variable's value

Parameters

name
The name of the variable

Return Value

The variable's value

Remarks

This method is used by the expression to retrieve the values of variables during evaluation. It must be public so that all expressions can access it. It is meant for internal use and you shouldn't depend on any of its functionality.

See Also

VariableCollection Class


GetVirtualPropertyValueInternal Generic Method

VariableCollection.GetVirtualPropertyValueInternal Generic Method
See Also Example
[image]

Gets the result of a virtual property

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function GetVirtualPropertyValueInternal(Of T)( _
ByVal name As String, _
ByVal component As Object _
)
C#
public T GetVirtualPropertyValueInternal<T>(
string name,
object component
)
C++
public:
T GetVirtualPropertyValueInternal<T>(
String name,
Object component
) sealed
J#
public T GetVirtualPropertyValueInternal<T>(
string name,
object component
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of the result's value

Parameters

name
The name of the property
component

Return Value

The property's value

Remarks

This method is used by the expression to retrieve the values of virtual properties during evaluation. It must be public so that all expressions can access it. It is meant for internal use and you shouldn't depend on any of its functionality.

See Also

VariableCollection Class


Remove Method

VariableCollection.Remove Method
[image]

Removes a variable from the collection.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal name As String _
) As Boolean _
Implements IDictionary<String,Object>.Remove
C#
public bool Remove(
string name
)
C++
public:
bool Remove(
String name
) sealed
J#
public bool Remove(
string name
)
JScript
public function Remove(
name : String
) : bool

Parameters

name
The name of the variable

Implements

IDictionary<String,Object>.Remove

Remarks

Use this method to remove a variable from the collection

See Also

VariableCollection Class


TryGetValue Method

VariableCollection.TryGetValue Method
[image]

Gets the value of a variable in the collection.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function TryGetValue( _
ByVal key As String, _
ByRef value As Object _
) As Boolean _
Implements IDictionary<String,Object>.TryGetValue
C#
public bool TryGetValue(
string key,
ref object value
)
C++
public:
bool TryGetValue(
String key,
Object% value
) sealed
J#
public bool TryGetValue(
string key,
object value
)
JScript
public function TryGetValue(
key : String,
value : Object
) : bool

Parameters

key
value
The location to store the value of the variable

Return Value

True if the collection contains a variable with the given name; False otherwise

Implements

IDictionary<String,Object>.TryGetValue

Remarks

Use this method to get the value of a variable in the collection

See Also

VariableCollection Class


Events

VariableCollection Events
[image]

Public Events

 | Name | Description
Public event | InvokeFunction | Occurs when an expression needs the return value of a function.
Public event | ResolveFunction | Occurs when an expression needs the return type of a function.
Public event | ResolveVariableType | Occurs when an expression needs the type of a variable.
Public event | ResolveVariableValue | Occurs when an expression needs the value of a variable.
Top

See Also

VariableCollection Class


InvokeFunction Event

VariableCollection.InvokeFunction Event
[image]

Occurs when an expression needs the return value of a function.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Event InvokeFunction As EventHandler(Of InvokeFunctionEventArgs)
C#
public event EventHandler<InvokeFunctionEventArgs> InvokeFunction
C++
public:
virtual event EventHandler<InvokeFunctionEventArgs> InvokeFunction {
void add(EventHandler<InvokeFunctionEventArgs> value) sealed ;
void remove(EventHandler<InvokeFunctionEventArgs> value) sealed ;
}
J#
/** event */
public final void add_InvokeFunction(EventHandler<InvokeFunctionEventArgs> value);

/** event */
public final void remove_InvokeFunction(EventHandler<InvokeFunctionEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Remarks

This event is raised when an expression needs the return value of an on-demand function. By handling this event and providing a value for the Result property, you can invoke your on-demand function.

Event Data

The event handler receives an argument of type InvokeFunctionEventArgs containing data related to this event. The following InvokeFunctionEventArgs properties provide information specific to this event.

Property | Description
Arguments | Gets the values of the arguments to the on-demand function being invoked.
FunctionName | Gets the name of the on-demand function being invoked.
Result | Gets or sets the result of the on-demand function being invoked.

See Also

VariableCollection Class


ResolveFunction Event

VariableCollection.ResolveFunction Event
[image]

Occurs when an expression needs the return type of a function.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Event ResolveFunction As EventHandler(Of ResolveFunctionEventArgs)
C#
public event EventHandler<ResolveFunctionEventArgs> ResolveFunction
C++
public:
virtual event EventHandler<ResolveFunctionEventArgs> ResolveFunction {
void add(EventHandler<ResolveFunctionEventArgs> value) sealed ;
void remove(EventHandler<ResolveFunctionEventArgs> value) sealed ;
}
J#
/** event */
public final void add_ResolveFunction(EventHandler<ResolveFunctionEventArgs> value);

/** event */
public final void remove_ResolveFunction(EventHandler<ResolveFunctionEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Remarks

This event is raised when an expression references a function that doesn't exist on the expression owner or imports. By handling this event and providing a value for the ReturnType property, you can implement an on-demand function.

Event Data

The event handler receives an argument of type ResolveFunctionEventArgs containing data related to this event. The following ResolveFunctionEventArgs properties provide information specific to this event.

Property | Description
ArgumentTypes | Gets the types of the arguments to the on-demand function being resolved.
FunctionName | Gets the name of the on-demand function being resolved.
ReturnType | Gets or sets the return type of the on-demand function being resolved.

See Also

VariableCollection Class


ResolveVariableType Event

VariableCollection.ResolveVariableType Event
[image]

Occurs when an expression needs the type of a variable.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Event ResolveVariableType As EventHandler(Of ResolveVariableTypeEventArgs)
C#
public event EventHandler<ResolveVariableTypeEventArgs> ResolveVariableType
C++
public:
virtual event EventHandler<ResolveVariableTypeEventArgs> ResolveVariableType {
void add(EventHandler<ResolveVariableTypeEventArgs> value) sealed ;
void remove(EventHandler<ResolveVariableTypeEventArgs> value) sealed ;
}
J#
/** event */
public final void add_ResolveVariableType(EventHandler<ResolveVariableTypeEventArgs> value);

/** event */
public final void remove_ResolveVariableType(EventHandler<ResolveVariableTypeEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Remarks

This event is raised when an expression references a variable that doesn't exist in its variable collection. You can handle this event to provide on-demand variables.

Event Data

The event handler receives an argument of type ResolveVariableTypeEventArgs containing data related to this event. The following ResolveVariableTypeEventArgs properties provide information specific to this event.

Property | Description
VariableName | Gets the name of an on-demand variable.
VariableType | Gets or sets the type of an on-demand variable.

See Also

VariableCollection Class


ResolveVariableValue Event

VariableCollection.ResolveVariableValue Event
[image]

Occurs when an expression needs the value of a variable.

Namespace: Ciloci.Flee
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Event ResolveVariableValue As EventHandler(Of ResolveVariableValueEventArgs)
C#
public event EventHandler<ResolveVariableValueEventArgs> ResolveVariableValue
C++
public:
virtual event EventHandler<ResolveVariableValueEventArgs> ResolveVariableValue {
void add(EventHandler<ResolveVariableValueEventArgs> value) sealed ;
void remove(EventHandler<ResolveVariableValueEventArgs> value) sealed ;
}
J#
/** event */
public final void add_ResolveVariableValue(EventHandler<ResolveVariableValueEventArgs> value);

/** event */
public final void remove_ResolveVariableValue(EventHandler<ResolveVariableValueEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Remarks

This event is raised when an expression references a variable that doesn't exist in its variable collection. You can handle this event to provide on-demand variables.

Event Data

The event handler receives an argument of type ResolveVariableValueEventArgs containing data related to this event. The following ResolveVariableValueEventArgs properties provide information specific to this event.

Property | Description
VariableName | Gets the name of an on-demand variable.
VariableType | Gets the type of an on-demand variable.
VariableValue | Gets or sets the value of an on-demand variable.

See Also

VariableCollection Class


Ciloci.Flee.CalcEngine

Ciloci.Flee.CalcEngine Namespace
See Also Example Hierarchy

Classes

 | Class | Description
Public class | BatchLoadCompileException | The exception thrown when an batch loaded expression cannot be compiled.
Public class | BatchLoader | Represents a class that can be used to populate the calculation engine in one batch. This class cannot be inherited.
Public class | CalculationEngine | Creates a calculation network which allows expressions to refer to the result of other expressions, tracks dependencies, and enables natural order recalculation.
Public class | CircularReferenceException | Represents the exception thrown when a circular reference is detected in the calculation engine.
Public class | NodeEventArgs | Provides the data for the NodeRecalculated event. This class cannot be inherited.
Public class | SimpleCalcEngine |


BatchLoadCompileException Class

BatchLoadCompileException Class
See Also Example Members
[image]

The exception thrown when an batch loaded expression cannot be compiled.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class BatchLoadCompileException
Inherits Exception
C#
[SerializableAttribute]
public class BatchLoadCompileException : Exception
C++
[SerializableAttribute]
ref class BatchLoadCompileException : Exception
J#
/** @attribute SerializableAttribute() */
public class BatchLoadCompileException extends Exception
JScript
public
SerializableAttribute
class BatchLoadCompileException extends Exception

Remarks

This exception is thrown whenever a batch loaded expression cannot be compiled. You use the AtomName and ExpressionText properties to get more information about the source of the exception.

Inheritance Hierarchy

System.Object
System.Exception
Ciloci.Flee.CalcEngine.BatchLoadCompileException

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

BatchLoadCompileException Members
Ciloci.Flee.CalcEngine Namespace


BatchLoadCompileException Members

BatchLoadCompileException Members
See Also Example Properties Methods
[image]

The exception thrown when an batch loaded expression cannot be compiled.

The following tables list the members exposed by BatchLoadCompileException.

Public Properties

 | Name | Description
Public property | AtomName | Gets the name of the expression that could not be compiled.
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExpressionText | Gets the text of the expression that could not be compiled.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | Overridden.
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BatchLoadCompileException Class
Ciloci.Flee.CalcEngine Namespace


Properties

BatchLoadCompileException Properties
[image]

Public Properties

 | Name | Description
Public property | AtomName | Gets the name of the expression that could not be compiled.
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | ExpressionText | Gets the text of the expression that could not be compiled.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Gets a message that describes the current exception. (inherited from Exception)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

See Also

BatchLoadCompileException Class
Ciloci.Flee.CalcEngine Namespace


AtomName Property

BatchLoadCompileException.AtomName Property
[image]

Gets the name of the expression that could not be compiled.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AtomName As String
C#
public string AtomName { get; }
C++
public property string AtomName sealed {
String get();
}
J#
/** property */
public string get_AtomName();
JScript
public function get AtomName() : String

Property Value

The name of the expression

Remarks

Use this property to determine the name of the expression that caused the exception.

See Also

BatchLoadCompileException Class
Ciloci.Flee.CalcEngine Namespace


ExpressionText Property

BatchLoadCompileException.ExpressionText Property
[image]

Gets the text of the expression that could not be compiled.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExpressionText As String
C#
public string ExpressionText { get; }
C++
public property string ExpressionText sealed {
String get();
}
J#
/** property */
public string get_ExpressionText();
JScript
public function get ExpressionText() : String

Property Value

The text of the expression

Remarks

Use this property to determine the text of the expression that caused the exception.

See Also

BatchLoadCompileException Class
Ciloci.Flee.CalcEngine Namespace


Methods

BatchLoadCompileException Methods
[image]

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | Overridden.
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

BatchLoadCompileException Class
Ciloci.Flee.CalcEngine Namespace


GetObjectData Method

BatchLoadCompileException.GetObjectData Method
[image]

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) _
Implements ISerializable.GetObjectData
C#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
C++
public:
virtual void GetObjectData(
SerializationInfo info,
StreamingContext context
) override
J#
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
)
JScript
public override function GetObjectData(
info : SerializationInfo,
context : StreamingContext
)

Implements

ISerializable.GetObjectData

See Also

BatchLoadCompileException Class
Ciloci.Flee.CalcEngine Namespace


BatchLoader Class

BatchLoader Class
See Also Example Members
[image]

Represents a class that can be used to populate the calculation engine in one batch. This class cannot be inherited.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class BatchLoader
C#
public sealed class BatchLoader
C++
ref class BatchLoader sealed
J#
public final class BatchLoader
JScript
public final class BatchLoader

Remarks

Normally, you have to add an expression to the calculation engine after any expressions it depends on. By using this class, you can load expressions in any order and then have them be loaded into the calculation engine in one call.

Inheritance Hierarchy

System.Object
Ciloci.Flee.CalcEngine.BatchLoader

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

BatchLoader Members
Ciloci.Flee.CalcEngine Namespace


BatchLoader Members

BatchLoader Members
See Also Example Methods
[image]

Represents a class that can be used to populate the calculation engine in one batch. This class cannot be inherited.

The following tables list the members exposed by BatchLoader.

Public Methods

 | Name | Description
Public method | Add | Adds an expression to the batch loader.
Public method | Contains | Determines if the loader contains an expression with a given name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BatchLoader Class
Ciloci.Flee.CalcEngine Namespace


Methods

BatchLoader Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Adds an expression to the batch loader.
Public method | Contains | Determines if the loader contains an expression with a given name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

BatchLoader Class
Ciloci.Flee.CalcEngine Namespace


Add Method

BatchLoader.Add Method
[image]

Adds an expression to the batch loader.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal atomName As String, _
ByVal expression As String, _
ByVal context As ExpressionContext _
)
C#
public void Add(
string atomName,
string expression,
ExpressionContext context
)
C++
public:
void Add(
String atomName,
String expression,
ExpressionContext context
) sealed
J#
public void Add(
string atomName,
string expression,
ExpressionContext context
)
JScript
public function Add(
atomName : String,
expression : String,
context : ExpressionContext
)

Parameters

atomName
The name that the expression will be associated with
expression
The expression to add
context
The context for the expression

Remarks

Use this method to add an expression to the batch loader and associate it with a name

See Also

BatchLoader Class
Ciloci.Flee.CalcEngine Namespace


Contains Method

BatchLoader.Contains Method
[image]

Determines if the loader contains an expression with a given name.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal atomName As String _
) As Boolean
C#
public bool Contains(
string atomName
)
C++
public:
bool Contains(
String atomName
) sealed
J#
public bool Contains(
string atomName
)
JScript
public function Contains(
atomName : String
) : bool

Parameters

atomName

Return Value

True if the loader has an expression with the name; False otherwise

Remarks

Use this method to determine if the loader contains an expression with a given name.

See Also

BatchLoader Class
Ciloci.Flee.CalcEngine Namespace


CalculationEngine Class

CalculationEngine Class
See Also Example Members
[image]

Creates a calculation network which allows expressions to refer to the result of other expressions, tracks dependencies, and enables natural order recalculation.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Class CalculationEngine
C#
public class CalculationEngine
C++
ref class CalculationEngine
J#
public class CalculationEngine
JScript
public class CalculationEngine

Example

This example shows how to add expressions to the engine and have them reference other contained expressions:

C# Copy Code
ExpressionContext context = new ExpressionContext();
VariableCollection variables = context.Variables;

// Add some variables
variables.Add("x", 100);
variables.Add("y", 200);

// Add an expression to the calculation engine as "a"
engine.Add("a", "x * 2", context);

// Add an expression to the engine as "b"
engine.Add("b", "y + 100", context);

// Add an expression at "c" that uses the results of "a" and "b"
// Notice that we have to prefix the expression names with a '$'
engine.Add("c", "$a + $b", context);

// Get the value of "c"
int result = engine.GetResult<int>("c");

// Update a variable on the "a" expression
variables["x"] = 200;

// Recalculate it
engine.Recalculate("a");

// Get the updated result
result = engine.GetResult<int>("c");

Remarks

This class acts as a container for expressions. As expressions are added to it, their dependencies are tracked and their result is cached. Expressions defined in this class can reference other contained expressions. Once all expressions are added, a natural order recalculate can be performed.

Inheritance Hierarchy

System.Object
Ciloci.Flee.CalcEngine.CalculationEngine

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CalculationEngine Members
Ciloci.Flee.CalcEngine Namespace


CalculationEngine Members

CalculationEngine Members
See Also Example Constructors Properties Methods Events
[image]

Creates a calculation network which allows expressions to refer to the result of other expressions, tracks dependencies, and enables natural order recalculation.

The following tables list the members exposed by CalculationEngine.

Public Constructors

 | Name | Description
Public method | CalculationEngine | Initializes a new instance of the CalculationEngine class.
Top

Public Properties

 | Name | Description
Public property | Count | Gets the number of expressions contained in the calculation engine.
Public property | DependencyGraph | Gets a string representation of the engine's dependency graph.
Top

Public Methods

 | Name | Description
Public method | Add | Adds an expression to the calculation engine.
Public method | BatchLoad | Populates the calculation engine from the given BatchLoader.
Public method | Clear | Clears all expressions from the CalculationEngine
Public method | Contains | Determines if the engine contains an expression with a given name.
Public method | CreateBatchLoader | Creates a BatchLoader that can be used to populate the calculation engine in one batch.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetDependents | Gets the names of the expressions that depend on a given name.
Public method | GetExpression | Gets the expression associated with a name.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPrecedents | Gets the names of the expressions that a given name depends on.
Public method | GetResult | Gets the cached result of a contained expression.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | HasDependents | Determines if an expression with a given name is referenced by any other expressions in the engine.
Public method | HasPrecedents | Determines if an expression with a given name depends on any other expression.
Public method | Recalculate | Performs a natural order recalculation of the engine.
Public method | Remove | Removes an expression and all its dependents from the calculation engine.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

Public Events

 | Name | Description
Public event | NodeRecalculated | Occurs when the calculation engine recalculates a node.
Top

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


CalculationEngine Constructor

CalculationEngine Constructor
[image]

Initializes a new instance of the CalculationEngine class.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public CalculationEngine()
C++
public:
CalculationEngine() sealed
J#
public CalculationEngine()
JScript
public function CalculationEngine()

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


Properties

CalculationEngine Properties
[image]

Public Properties

 | Name | Description
Public property | Count | Gets the number of expressions contained in the calculation engine.
Public property | DependencyGraph | Gets a string representation of the engine's dependency graph.
Top

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


Count Property

CalculationEngine.Count Property
[image]

Gets the number of expressions contained in the calculation engine.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count { get; }
C++
public property int Count sealed {
int get();
}
J#
/** property */
public int get_Count();
JScript
public function get Count() : int

Property Value

The number of expressions in the calculation engine

Remarks

Use this property to see how many expressions are contained in the calculation engine.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


DependencyGraph Property

CalculationEngine.DependencyGraph Property
[image]

Gets a string representation of the engine's dependency graph.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DependencyGraph As String
C#
public string DependencyGraph { get; }
C++
public property string DependencyGraph sealed {
String get();
}
J#
/** property */
public string get_DependencyGraph();
JScript
public function get DependencyGraph() : String

Property Value

A string representing the graph.

Remarks

Use this property to get a string version of the engine's dependency graph. There will be one line for each dependency. Each line will be of the format "[reference] -> [dependant1, dependant2]" and is read as "A change in [reference] will cause a change in [dependant]".

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


Methods

CalculationEngine Methods
[image]

Public Methods

 | Name | Description
Public method | Add | Adds an expression to the calculation engine.
Public method | BatchLoad | Populates the calculation engine from the given BatchLoader.
Public method | Clear | Clears all expressions from the CalculationEngine
Public method | Contains | Determines if the engine contains an expression with a given name.
Public method | CreateBatchLoader | Creates a BatchLoader that can be used to populate the calculation engine in one batch.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetDependents | Gets the names of the expressions that depend on a given name.
Public method | GetExpression | Gets the expression associated with a name.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetPrecedents | Gets the names of the expressions that a given name depends on.
Public method | GetResult | Gets the cached result of a contained expression.
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | HasDependents | Determines if an expression with a given name is referenced by any other expressions in the engine.
Public method | HasPrecedents | Determines if an expression with a given name depends on any other expression.
Public method | Recalculate | Performs a natural order recalculation of the engine.
Public method | Remove | Removes an expression and all its dependents from the calculation engine.
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


Add Method

CalculationEngine.Add Method
[image]

Adds an expression to the calculation engine.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add( _
ByVal atomName As String, _
ByVal expression As String, _
ByVal context As ExpressionContext _
)
C#
public void Add(
string atomName,
string expression,
ExpressionContext context
)
C++
public:
void Add(
String atomName,
String expression,
ExpressionContext context
) sealed
J#
public void Add(
string atomName,
string expression,
ExpressionContext context
)
JScript
public function Add(
atomName : String,
expression : String,
context : ExpressionContext
)

Parameters

atomName
The name that the expression will be associated with
expression
The expression to add
context
The context for the expression

Remarks

Use this method to add an expression to the engine and associate it with a name

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


BatchLoad Method

CalculationEngine.BatchLoad Method
[image]

Populates the calculation engine from the given BatchLoader.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub BatchLoad( _
ByVal loader As BatchLoader _
)
C#
public void BatchLoad(
BatchLoader loader
)
C++
public:
void BatchLoad(
BatchLoader loader
) sealed
J#
public void BatchLoad(
BatchLoader loader
)
JScript
public function BatchLoad(
loader : BatchLoader
)

Parameters

loader
The batch loader instance to use

Remarks

Call this method to load the calculation engine with all the expressions in the given batch loader.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


Clear Method

CalculationEngine.Clear Method
[image]

Clears all expressions from the CalculationEngine

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
public function Clear()

Remarks

Use this method to reset the CalculationEngine to the empty state.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


Contains Method

CalculationEngine.Contains Method
[image]

Determines if the engine contains an expression with a given name.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains( _
ByVal name As String _
) As Boolean
C#
public bool Contains(
string name
)
C++
public:
bool Contains(
String name
) sealed
J#
public bool Contains(
string name
)
JScript
public function Contains(
name : String
) : bool

Parameters

name
The name of the expression to look up

Return Value

True if the engine has an expression with the name; False otherwise

Remarks

Use this method to determine if the calculation engine contains an expression with a given name.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


CreateBatchLoader Method

CalculationEngine.CreateBatchLoader Method
[image]

Creates a BatchLoader that can be used to populate the calculation engine in one batch.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateBatchLoader() As BatchLoader
C#
public BatchLoader CreateBatchLoader()
C++
public:
BatchLoader CreateBatchLoader() sealed
J#
public BatchLoader CreateBatchLoader()
JScript
public function CreateBatchLoader() : BatchLoader

Return Value

A new instance of the BatchLoader class

Remarks

Use this method to create a BatchLoader instance.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


GetDependents Method

CalculationEngine.GetDependents Method
[image]

Gets the names of the expressions that depend on a given name.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDependents( _
ByVal name As String _
) As String()
C#
public string[] GetDependents(
string name
)
C++
public:
array<String>^ GetDependents(
String name
) sealed
J#
public string[] GetDependents(
string name
)
JScript
public function GetDependents(
name : String
) : String[]

Parameters

name
The name of the expression to look up

Return Value

The names of all expressions that depend on the expression with the given name

Remarks

Use this method to obtain all the expressions that depend on a given name. For example: if a=100, b=200, and c=a+b, then calling GetDependents("a") will return "c" since when the value of "a" changes, the value of "c" will also change. This method is not recursive, so it will only return the names that directly depend on the given name. This method is the inverse of GetPrecedents

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


GetExpression Method

CalculationEngine.GetExpression Method
[image]

Gets the expression associated with a name.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function GetExpression( _
ByVal name As String _
) As IExpression
C#
public IExpression GetExpression(
string name
)
C++
public:
IExpression GetExpression(
String name
) sealed
J#
public IExpression GetExpression(
string name
)
JScript
public function GetExpression(
name : String
) : IExpression

Parameters

name
The name that the expression is associated with

Return Value

The expression associated with the given name

Remarks

Use this method to obtain the expression associated with a name.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


GetPrecedents Method

CalculationEngine.GetPrecedents Method
[image]

Gets the names of the expressions that a given name depends on.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPrecedents( _
ByVal name As String _
) As String()
C#
public string[] GetPrecedents(
string name
)
C++
public:
array<String>^ GetPrecedents(
String name
) sealed
J#
public string[] GetPrecedents(
string name
)
JScript
public function GetPrecedents(
name : String
) : String[]

Parameters

name
The name of the expression to look up

Return Value

The names of all expressions that the given name depends on

Remarks

Use this method to obtain all the expressions that a given name depends on. For example: if a=100, b=200, and c=a+b, then calling GetPrecedents("c") will return "a, b" since when either "a" or "b" change, the value of "c" will also change. This method is not recursive, so it will only return the names that the given name directly depends on. This method is the inverse of GetDependents

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


GetResult Generic Method

CalculationEngine.GetResult Generic Method
[image]

Gets the cached result of a contained expression.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Shadows Function GetResult(Of T)( _
ByVal name As String _
)
C#
public new T GetResult<T>(
string name
)
C++
public:
T GetResult<T>(
String name
) sealed
J#
public new T GetResult<T>(
string name
)
JScript
JScript does not support generic types and methods.

Type Parameters

T
The type of the expression's result.

Parameters

name
The name that the expression is associated with

Return Value

The cached result of evaluating the expression

Remarks

Use this method after a recalculate to get the updated value of an expression.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


HasDependents Method

CalculationEngine.HasDependents Method
[image]

Determines if an expression with a given name is referenced by any other expressions in the engine.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function HasDependents( _
ByVal name As String _
) As Boolean
C#
public bool HasDependents(
string name
)
C++
public:
bool HasDependents(
String name
) sealed
J#
public bool HasDependents(
string name
)
JScript
public function HasDependents(
name : String
) : bool

Parameters

name
The name of the expression to look up

Return Value

True if the engine has expressions that depend on it; False otherwise

Remarks

Use this method to determine if the expression associated with a given name has any expressions that depend on it. For example: you can use this method to allow a user to remove an expression only when no other expressions depend on it.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


HasPrecedents Method

CalculationEngine.HasPrecedents Method
[image]

Determines if an expression with a given name depends on any other expression.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function HasPrecedents( _
ByVal name As String _
) As Boolean
C#
public bool HasPrecedents(
string name
)
C++
public:
bool HasPrecedents(
String name
) sealed
J#
public bool HasPrecedents(
string name
)
JScript
public function HasPrecedents(
name : String
) : bool

Parameters

name
The name of the expression to look up

Return Value

True if the name has expressions that it depends on; False otherwise

Remarks

Use this method to determine if an expression depends on any other expressions.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


Recalculate Method

CalculationEngine.Recalculate Method
[image]

Performs a natural order recalculation of the engine.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub Recalculate( _
ByVal ParamArray roots As String() _
)
C#
public void Recalculate(
params string[] roots
)
C++
public:
void Recalculate(
... array<String>^ roots
) sealed
J#
public void Recalculate(
string[] roots
)
JScript
public function Recalculate(
ParamArrayAttribute roots : String[]
)

Parameters

roots
The names representing the starting points of the recalculation

Exceptions

Exception Type | Condition
CircularReferenceException | A recalculate is requested on an engine containing a circular reference

Remarks

This method will perform a natural order recalculate on the expressions in the engine. The recalculation will start at the given roots and continue with all their dependents. If no roots are given, then a recalculation of all expressions is performed.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


Remove Method

CalculationEngine.Remove Method
[image]

Removes an expression and all its dependents from the calculation engine.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove( _
ByVal name As String _
) As Boolean
C#
public bool Remove(
string name
)
C++
public:
bool Remove(
String name
) sealed
J#
public bool Remove(
string name
)
JScript
public function Remove(
name : String
) : bool

Parameters

name
The name whose expression to remove

Return Value

True if the name was removed from the engine; False otherwise

Remarks

Use this method to remove an expression and all its dependents from the calculation engine. No exception is thrown if the name does not exist in the engine.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


Events

CalculationEngine Events
[image]

Public Events

 | Name | Description
Public event | NodeRecalculated | Occurs when the calculation engine recalculates a node.
Top

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


NodeRecalculated Event

CalculationEngine.NodeRecalculated Event
[image]

Occurs when the calculation engine recalculates a node.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Event NodeRecalculated As EventHandler(Of NodeEventArgs)
C#
public event EventHandler<NodeEventArgs> NodeRecalculated
C++
public:
virtual event EventHandler<NodeEventArgs> NodeRecalculated {
void add(EventHandler<NodeEventArgs> value) sealed ;
void remove(EventHandler<NodeEventArgs> value) sealed ;
}
J#
/** event */
public final void add_NodeRecalculated(EventHandler<NodeEventArgs> value);

/** event */
public final void remove_NodeRecalculated(EventHandler<NodeEventArgs> value);
JScript
JScript suports the use of events, but not the declaration of new ones.

Remarks

You can listen to this event to be notified when a node in the calculation engine is recalculated.

Event Data

The event handler receives an argument of type NodeEventArgs containing data related to this event. The following NodeEventArgs properties provide information specific to this event.

Property | Description
Name | Gets the name of the recalculated node.
Result | Gets the recalculated result of the node.

See Also

CalculationEngine Class
Ciloci.Flee.CalcEngine Namespace


CircularReferenceException Class

CircularReferenceException Class
See Also Example Members
[image]

Represents the exception thrown when a circular reference is detected in the calculation engine.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute>
Public Class CircularReferenceException
Inherits Exception
C#
[SerializableAttribute]
public class CircularReferenceException : Exception
C++
[SerializableAttribute]
ref class CircularReferenceException : Exception
J#
/** @attribute SerializableAttribute() */
public class CircularReferenceException extends Exception
JScript
public
SerializableAttribute
class CircularReferenceException extends Exception

Remarks

This exception will be thrown when Recalculate is called on the CalculationEngine and there is a circular reference present.

Inheritance Hierarchy

System.Object
System.Exception
Ciloci.Flee.CalcEngine.CircularReferenceException

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

CircularReferenceException Members
Ciloci.Flee.CalcEngine Namespace


CircularReferenceException Members

CircularReferenceException Members
See Also Example Properties Methods
[image]

Represents the exception thrown when a circular reference is detected in the calculation engine.

The following tables list the members exposed by CircularReferenceException.

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Overridden.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (inherited from Exception)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (inherited from Exception)
Public method | GetType | Gets the runtime type of the current instance. (inherited from Exception)
Public method | ToString | Creates and returns a string representation of the current exception. (inherited from Exception)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

CircularReferenceException Class
Ciloci.Flee.CalcEngine Namespace


Properties

CircularReferenceException Properties
[image]

Public Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (inherited from Exception)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (inherited from Exception)
Public property | InnerException | Gets the Exception instance that caused the current exception. (inherited from Exception)
Public property | Message | Overridden.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (inherited from Exception)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (inherited from Exception)
Public property | TargetSite | Gets the method that throws the current exception. (inherited from Exception)
Top

Protected Properties

 | Name | Description
Family property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (inherited from Exception)
Top

See Also

CircularReferenceException Class
Ciloci.Flee.CalcEngine Namespace


Message Property

CircularReferenceException.Message Property
[image]

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
C#
public override string Message { get; }
C++
public override property string Message override {
String get();
}
J#
/** property */
public string get_Message();
JScript
public function get Message() : String

See Also

CircularReferenceException Class
Ciloci.Flee.CalcEngine Namespace


NodeEventArgs Class

NodeEventArgs Class
See Also Example Members
[image]

Provides the data for the NodeRecalculated event. This class cannot be inherited.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NodeEventArgs
Inherits EventArgs
C#
public sealed class NodeEventArgs : EventArgs
C++
ref class NodeEventArgs sealed : EventArgs
J#
public final class NodeEventArgs extends EventArgs
JScript
public final class NodeEventArgs extends EventArgs

Remarks

Use the members of this class to get additional information about the recalculated node.

Inheritance Hierarchy

System.Object
System.EventArgs
Ciloci.Flee.CalcEngine.NodeEventArgs

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

NodeEventArgs Members
Ciloci.Flee.CalcEngine Namespace


NodeEventArgs Members

NodeEventArgs Members
See Also Example Properties Methods
[image]

Provides the data for the NodeRecalculated event. This class cannot be inherited.

The following tables list the members exposed by NodeEventArgs.

Public Properties

 | Name | Description
Public property | Name | Gets the name of the recalculated node.
Public property | Result | Gets the recalculated result of the node.
Top

Public Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

See Also

NodeEventArgs Class
Ciloci.Flee.CalcEngine Namespace


Properties

NodeEventArgs Properties
[image]

Public Properties

 | Name | Description
Public property | Name | Gets the name of the recalculated node.
Public property | Result | Gets the recalculated result of the node.
Top

See Also

NodeEventArgs Class
Ciloci.Flee.CalcEngine Namespace


Name Property

NodeEventArgs.Name Property
[image]

Gets the name of the recalculated node.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
C++
public property string Name sealed {
String get();
}
J#
/** property */
public string get_Name();
JScript
public function get Name() : String

Property Value

The name of the node

Remarks

Use this property to get the name of the recalculated node.

See Also

NodeEventArgs Class
Ciloci.Flee.CalcEngine Namespace


Result Property

NodeEventArgs.Result Property
[image]

Gets the recalculated result of the node.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As Object
C#
public object Result { get; }
C++
public property object Result sealed {
Object get();
}
J#
/** property */
public object get_Result();
JScript
public function get Result() : Object

Property Value

The value of the result

Remarks

Use this property to get the recalculated result of the node.

See Also

NodeEventArgs Class
Ciloci.Flee.CalcEngine Namespace


SimpleCalcEngine Class

SimpleCalcEngine Class
See Also Example Members
[image]

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class SimpleCalcEngine
C#
[DefaultMemberAttribute("Item")]
public class SimpleCalcEngine
C++
[DefaultMemberAttribute(L"Item")]
ref class SimpleCalcEngine
J#
/** @attribute DefaultMemberAttribute("Item") */
public class SimpleCalcEngine
JScript
public
DefaultMemberAttribute("Item")
class SimpleCalcEngine

Inheritance Hierarchy

System.Object
Ciloci.Flee.CalcEngine.SimpleCalcEngine

Thread Safety

Public static (Shared in Visual Basic)staticShared members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

See Also

SimpleCalcEngine Members
Ciloci.Flee.CalcEngine Namespace


SimpleCalcEngine Members

SimpleCalcEngine Members
See Also Example Constructors Properties Methods
[image]

The following tables list the members exposed by SimpleCalcEngine.

Public Constructors

 | Name | Description
Public method | SimpleCalcEngine | Initializes a new instance of the SimpleCalcEngine class.
Top

Public Properties

 | Name | Description
Public property | Context |
Public property | Item |
Top

Public Methods

 | Name | Description
Public method | AddDynamic |
Public method | AddGeneric |
Public method | Clear |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SimpleCalcEngine Class
Ciloci.Flee.CalcEngine Namespace


SimpleCalcEngine Constructor

SimpleCalcEngine Constructor
[image]

Initializes a new instance of the SimpleCalcEngine class.

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub New()
C#
public SimpleCalcEngine()
C++
public:
SimpleCalcEngine() sealed
J#
public SimpleCalcEngine()
JScript
public function SimpleCalcEngine()

See Also

SimpleCalcEngine Class
Ciloci.Flee.CalcEngine Namespace


Properties

SimpleCalcEngine Properties
[image]

Public Properties

 | Name | Description
Public property | Context |
Public property | Item |
Top

See Also

SimpleCalcEngine Class
Ciloci.Flee.CalcEngine Namespace


Context Property

SimpleCalcEngine.Context Property
[image]

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Property Context As ExpressionContext
C#
public ExpressionContext Context { get; set; }
C++
public property ExpressionContext Context sealed {
ExpressionContext get();
void set(ExpressionContext value);
}
J#
/** property */
public ExpressionContext get_Context();

/** property */
public void set_Context(ExpressionContext value);
JScript
public function get Context() : ExpressionContext

public function set Context(value : ExpressionContext);

See Also

SimpleCalcEngine Class
Ciloci.Flee.CalcEngine Namespace


Item Property

SimpleCalcEngine.Item Property
[image]

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Default ReadOnly Property Item( _
ByVal name As String _
) As IExpression
C#
public IExpression this[
string name
] { get; }
C++
public property IExpression default[String name] sealed {
IExpression get(String name);
}
J#
/** property */
public IExpression get_Item(string name);
JScript
JScript supports the use of indexed properties, but not the declaration of new ones.

See Also

SimpleCalcEngine Class
Ciloci.Flee.CalcEngine Namespace


Methods

SimpleCalcEngine Methods
[image]

Public Methods

 | Name | Description
Public method | AddDynamic |
Public method | AddGeneric |
Public method | Clear |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (inherited from Object)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (inherited from Object)
Public method | GetType | Gets the Type of the current instance. (inherited from Object)
Public method | ToString | Returns a String that represents the current Object. (inherited from Object)
Top

Protected Methods

 | Name | Description
Family method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (inherited from Object)
Family method | MemberwiseClone | Creates a shallow copy of the current Object. (inherited from Object)
Top

See Also

SimpleCalcEngine Class
Ciloci.Flee.CalcEngine Namespace


AddDynamic Method

SimpleCalcEngine.AddDynamic Method
[image]

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDynamic( _
ByVal expressionName As String, _
ByVal expression As String _
)
C#
public void AddDynamic(
string expressionName,
string expression
)
C++
public:
void AddDynamic(
String expressionName,
String expression
) sealed
J#
public void AddDynamic(
string expressionName,
string expression
)
JScript
public function AddDynamic(
expressionName : String,
expression : String
)

See Also

SimpleCalcEngine Class
Ciloci.Flee.CalcEngine Namespace


AddGeneric Generic Method

SimpleCalcEngine.AddGeneric Generic Method
[image]

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddGeneric(Of T)( _
ByVal expressionName As String, _
ByVal expression As String _
)
C#
public void AddGeneric<T>(
string expressionName,
string expression
)
C++
public:
void AddGeneric<T>(
String expressionName,
String expression
) sealed
J#
public void AddGeneric<T>(
string expressionName,
string expression
)
JScript
JScript does not support generic types and methods.

See Also

SimpleCalcEngine Class
Ciloci.Flee.CalcEngine Namespace


Clear Method

SimpleCalcEngine.Clear Method
[image]

Namespace: Ciloci.Flee.CalcEngine
Assembly: Ciloci.Flee (in ciloci.Flee.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear()
C#
public void Clear()
C++
public:
void Clear() sealed
J#
public void Clear()
JScript
public function Clear()

See Also

SimpleCalcEngine Class
Ciloci.Flee.CalcEngine Namespace


Ciloci.Flee Hierarchy

Ciloci.Flee Hierarchy
System.Object
Ciloci.Flee.ExpressionContext
Ciloci.Flee.ExpressionImports
Ciloci.Flee.ExpressionInfo
Ciloci.Flee.ExpressionOptions
Ciloci.Flee.ExpressionParserOptions
Ciloci.Flee.IDynamicExpression ---- Ciloci.Flee.IExpression
Ciloci.Flee.IExpression
Ciloci.Flee.IGenericExpression<T> ---- Ciloci.Flee.IExpression
Ciloci.Flee.ImportBase ---- System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable, System.IEquatable<T>
Ciloci.Flee.MethodImport
Ciloci.Flee.NamespaceImport ---- System.Collections.Generic.ICollection<T>
Ciloci.Flee.TypeImport
Ciloci.Flee.VariableCollection ---- System.Collections.Generic.ICollection<T>, System.Collections.Generic.IDictionary<TKey,TValue>, System.Collections.Generic.IEnumerable<T>, System.Collections.IEnumerable
System.Attribute
Ciloci.Flee.ExpressionOwnerMemberAccessAttribute
System.EventArgs
Ciloci.Flee.InvokeFunctionEventArgs
Ciloci.Flee.ResolveFunctionEventArgs
Ciloci.Flee.ResolveVariableTypeEventArgs
Ciloci.Flee.ResolveVariableValueEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
Ciloci.Flee.ExpressionCompileException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Ciloci.Flee.CompileExceptionReason
Ciloci.Flee.RealLiteralDataType

See Also

Ciloci.Flee Namespace

Syntax based on .NET Framework version 2.0.
Documentation version 1.0.0.0.

© 2007 Eugene Ciloci


Ciloci.Flee.CalcEngine Hierarchy

Ciloci.Flee.CalcEngine Hierarchy
System.Object
Ciloci.Flee.CalcEngine.BatchLoader
Ciloci.Flee.CalcEngine.CalculationEngine
Ciloci.Flee.CalcEngine.SimpleCalcEngine
System.EventArgs
Ciloci.Flee.CalcEngine.NodeEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
Ciloci.Flee.CalcEngine.BatchLoadCompileException
Ciloci.Flee.CalcEngine.CircularReferenceException

See Also

Ciloci.Flee.CalcEngine Namespace


SDK Link Manager

NDoc Utilities
SDK Link Manager

SDK Link Namespace