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Command types:

d.x display commands
db.* database commands
g* general commands
*

i imagery commands

m.* miscellanous commands
ps.* postscript commands
r* raster commands

r3.* raster3D commands

* vector commands

V.
wxGUI GUI frontend (wxPython)

gis.m GUI frontend (Tcl/Tk)

NVIZ n-dimensional visualization suite

xganim  raster map slideshow viewer

Display commands:

d.ask Prompts the user to select a GRASS data base file from among files displayed in a
menu on the graphics monitor.

d.barscale Displays a barscale on the graphics monitor.

d.colorlist Output a list of all available display colors with a configurable separator (default is
comma).

d.colors  Allows the user to interactively change the color table of a raster map layer displayed
on the graphics monitor.

d.colortable Displays the color table associated with a raster map layer.
d.correlate Prints a graph of the correlation between data layers (in pairs).
d.erase  Erase the contents of the active display frame with user defined color.

d.extend Sets window region so that all currently displayed raster and vector maps can be
shown in a monitor.

d.extract Selects and extracts vectors with mouse into new vector map.

d.font.freetype Selects the font in which text will be displayed on the user’s graphics monitor.
d.font Selects the font in which text will be displayed on the user’s graphics monitor.
d.frame  Manages display frames on the user’s graphics monitor.

d.geodesic Displays a geodesic line, tracing the shortest distance between two geographic points
along a great circle, in a longitude/latitude data set.

d.graph  Program for generating and displaying simple graphics on the display monitor.
d.grid Overlays a user-specified grid in the active display frame on the graphics monitor.

d.his Displays the result obtained by combining hue, intensity, and saturation (his) values
from user-specified input raster map layers.

d.histogram Displays a histogram in the form of a pie or bar chart for a user-specified raster
map.

d.info Display information about the active display monitor.
d.labels  Displays text labels (created with v.label) to the active frame on the graphics monitor.
d.legend Displays a legend for a raster map in the active frame of the graphics monitor.

d.linegraph Generates and displays simple line graphs in the active graphics monitor display
frame.

d.m Display manager for GRASS.

d.mapgraph Generates and displays simple graphics on map layers drawn in the active graphics
monitor display frame.

d.measure Measures the lengths and areas of features drawn by the user in the active display
frame on the graphics monitor.

d.menu  Creates and displays a menu within the active frame on the graphics monitor.
d.mon To establish and control use of a graphics display monitor.

d.monsize Selects/starts specified monitor at specified size.

d.mvmon Moves displayed maps to another monitor.

d.nviz Creates fly-through script to run in NVIZ.

d.out.file Saves the contents of the active display monitor to a graphics file.

d.out.gpsdrive Export display monitor to a GpsDrive compatible backdrop image.




d.out.png Saves active display monitor to PNG file in home directory.

d.path Finds shortest path for selected starting and ending node.

Vector > Network analysis > Display shortest route (requires X Term)
d.polar  Draws polar diagram of angle map such as aspect or flow directions.
d.profile Interactive profile plotting utility with optional output.

d.rast.arrow Draws arrows representing cell aspect direction for a raster map containing aspect
data.

d.rast.edit Interactively edit cell values in a raster map.

Raster > Change category values and labels > Interactively edit category values
d.rastleg Displays a raster map and its legend on a graphics window.

d.rastnum Overlays cell category values on a raster map layer displayed to the graphics moni-
tor.

d.rast Displays and overlays raster map layers in the active display frame on the graphics
monitor.

d.redraw Redraws the current display frame in the GRASS monitor.
d.resize  Resizes active display monitor.

d.rgb Displays three user-specified raster map layers as red, green, and blue overlays in the
active graphics frame.

d.rhumbline Displays the rhumbline joining two user-specified points, in the active frame on the
user’s graphics monitor.

d.save Creates a list of commands for recreating screen graphics.
d.shadedmap Drapes a color raster over a shaded relief map using d.his.
d.slide.show Slide show of GRASS raster/vector maps.

d.split.frame Split the display into subframes.

d.split Divides active display into two frames & displays maps/executes commands in each
frame.

d.text.freetype Draws text in the active display frame on the graphics monitor using the current
font.

d.text Draws text in the active display frame on the graphics monitor using the current font.
d.thematic.area Displays a thematic vector area map in the active frame on the graphics monitor.
d.title Create a TITLE for a raster map in a form suitable for display with d.text.
d.vect.chart Displays charts of vector data in the active frame on the graphics monitor.
d.vect.thematic Displays thematic vector map.

d.vect Displays vector data in the active frame on the graphics monitor.

d.what.rast Allows the user to interactively query the category contents of multiple raster map
layers at user specified locations within the current geographic region.

d.what.vect Allows the user to interactively query a vector map layer at user-selected locations
within the current geographic region.

d.where Identifies the geographic coordinates associated with point locations in the active
frame on the graphics monitor.

d.zoom  Allows the user to change the current geographic region settings interactively, with a
mouse.

Database management commands:

db.columns List all columns for a given table.

Database > Database in formation > List columns

db.connect Prints/sets general DB connection for current mapset and exits.

Database > Manage databases > Connect

db.copy Copy a table.

Database > Manage databases > Copy table

db.describe Describes a table in detail.

Database > Database in formation > Describe table

db.drivers List all database drivers.

Database > Database information v List drivers
db.dropcol Drops a column from selected attribute table.

db.droptable Drops an attribute table.

Database > Manage databases > Remove table

db.execute Executes any SQL statement.
Database > Query > SQL statement

db.in.ogr Imports attribute tables in various formats.
File > Import database table > Multiple import formats using OGR

db.login  Sets user/password for driver/database.

Database > Manage databases > Login

db.out.ogr Exports attribute tables into various formats.
File v Export database table > Multiple export formats using OGR

db.select Selects data from table.
Database > Query > Query any table

db.tables Lists all tables for a given database.

Database > Database in formation > List tables

db.test Test database driver, database must exist and set by db.connect.
Database > Manage databases > Test




General GIS management commands:

g.access  Controls access to the current mapset for other users on the system.

Config > GRASS working environment > User access
g.ask Prompts the user for the names of GRASS data base files.

g.copy Copies available data files in the user’s current mapset search path and location to the
appropriate element directories under the user’s current mapset.

File > Manage maps and volumes > Copy
g.dirseps Internal GRASS utility for converting directory separator characters.
g.filename Prints GRASS data base file names.
g.findetc Searches for GRASS support files.
g.findfile Searches for GRASS data base files and sets variables for the shell.

g.gisenv  Outputs and modifies the user’s current GRASS variable settings.

Config > GRASS working environment > Change settings

g.gui Launches a GRASS graphical user interface (GUI) session.

Config > GRASS working environment > Change de fault GUT

g list Lists available GRASS data base files of the user-specified data type to standard out-
put.

File > Manage maps and volumes > List

g.manual Display the HTML man pages of GRASS.
Help > GRASS help

g.mapset Change current mapset.

Config > GRASS working environment > Change working environment

g.mapsets Modifies the user’s current mapset search path, affecting the user’s access to data
existing under the other GRASS mapsets in the current location.

g.message Prints a message, warning, or fatal error the GRASS way.
g.mkfontcap Generates the font configuration file by scanning various directories for fonts.

g.mlist  Lists available GRASS data base files of the user-specified data type to standard out-
put.

File > Manage maps and volumes > List filtered

g.mremove Removes data base element files from the user’s current mapset.
File > Manage maps and volumes > Delete filtered

g.parser  Full parser support for GRASS scripts.
g.pnmcomp Overlays multiple PPM image files.

g.proj Converts co-ordinate system descriptions (i.e. projection information) between vari-
ous formats (including GRASS format).

Config > Manage projections > Manage projections

g.region Manages the boundary definitions for the geographic region.

Config b Region v Set or Display region

g.remove Removes data base element files from the user’s current mapset.
File > Manage maps and volumes > Delete

g.rename Renames data base element files in the user’s current mapset.

File > Manage maps and volumes > Rename

g.setproj Interactively reset the location’s projection settings.

Config > Manage projections > Projection for current location
g.tempfile Creates a temporary file and prints the file name.
g.transform Computes a coordinate transformation based on the control points.

g.version Displays version and copyright information.

Config > GRASS working environment & Version

Imagery commands:

iatcorr  Performs atmospheric correction using the 6S algorithm.

I'magery > Atmospheric correction

i.cca Canonical components analysis (cca) program for image processing.

Imagery > Transform image > Canonical correlation

i.class Generates spectral signatures for an image by allowing the user to outline regions of
interest.

Imagery > Classify image > Interactive input for supervised classification (requires X term)

icluster  Generates spectral signatures for land cover types in an image using a clustering al-
gorithm.

Imagery > Classify image o Clustering input for unsupervised classification

i.fft Fast Fourier Transform (FFT) for image processing.

Imagery > Transform image > Fast Fourier

i.fusion.brovey Brovey transform to merge multispectral and high-res panchromatic channels.

Imagery > Brovey sharpening

i.gensig  Generates statistics for i.maxlik from raster map.
Imagery > Classifyimage > Input for supervised M LC

i.gensigset Generates statistics for i.smap from raster map.
Imagery > Classify image > Input for supervised SMAP

i.group  Creates, edits, and lists groups and subgroups of imagery files.

I'magery > Develop images and groups > Create/edit group

ihisxgb  Transforms raster maps from HIS (Hue-Intensity-Saturation) color space to RGB (Red-
Green-Blue) color space.
I'magery > Manage image colors > HIS to RGB

1ifft Inverse Fast Fourier Transform (IFFT) for image processing.

Imagery > Transform image > Inverse Fast Fourier

i.image.mosaic Mosaics up to 4 images and extends colormap; creates map *.mosaic.

Imagery > Develop images and groups > Mosaic images

iinspotvgt Import of SPOT VGT NDVI file into a raster map.
File > Import raster map > SPOT NDV I import




ilandsat.rgb Performs auto-balancing of colors for LANDSAT images.

I'magery > Manage image colors > Color balance for RGB

imaxlik Classifies the cell spectral reflectances in imagery data.

Imagery > Classifyimage > Maximum likelihood classi fication (M LC')

i.oif Calculates Optimum-Index-Factor table for LANDSAT TM bands 1-5, & 7.
Imagery > Report and statistics > OIF for LandSat TM

i.ortho.photo Menu driver for the photo imagery programs.

I'magery > Ortho photo recti fication (requires Xterm)

i.pca Principal components analysis (pca) program for image processing.

I'magery > Transform image > Principal components
ipoints  Mark ground control points on image to be rectified.

irectify  Rectifies an image by computing a coordinate transformation for each pixel in the
image based on the control points.

I'magery o Rectify image or raster

irgb.his  Transforms raster maps from RGB (Red-Green-Blue) color space to HIS (Hue-Intensity-
Saturation) color space.
I'magery > Manage image colors > RGB to HIS

i.smap Performs contextual image classification using sequential maximum a posteriori (SMAP)
estimation.

I'magery > Classify image > Sequential mazimum a posteriori classification (SMAP)

i.spectral Displays spectral response at user specified locations in group or images.

I'magery b Spectral response

itarget  Targets an imagery group to a GRASS location and mapset.

I'magery > Develop images and groups > Target group

itasscap Tasseled Cap (Kauth Thomas) transformation for LANDSAT-TM data.

Imagery > Tasseled cap vegetation index
i.vpoints Set registration points for an imagery group from a vector map or keyboard entry.
izc Zero-crossing ‘edge detection’ raster function for image processing.

Imagery > Filter image > Edge detection
Imagery photo.* commands:

photo.2image Marks fiducial or reseau points on an image to be ortho-rectified and then com-
putes the image-to-photo coordinate transformation parameters.

photo.2target Create control points on an image to be ortho-rectified.
photo.camera Creates or modifies entries in a camera reference file.
photo.elev Selects target elevation model for ortho-rectification.

photo.init Creates or modifies entries in a camera initial exposure station file for imagery group
referenced by a sub-block.

photo.rectify Rectifies an image by using the image to photo coordinate transformation matrix
created by photo.2image and the rectification parameters created by photo.2target.

photo.target Selects target location and mapset for ortho-rectification.

Miscellaneous tools:

m.cogo A simple utility for converting bearing and distance measurements to coordinates
and vice versa.

File > Bearing/distance to coordinates

m.proj Convert coordinates from one projection to another (cs2cs frontend).

Config > Manage projections > Convert coordinates

PostScript commands:

psmap  Hardcopy PostScript map output utility.

File > Postscript plot

Raster commands:

raverage Finds the average of values in a cover map within areas assigned the same category
value in a user-specified base map.

rbasins.fill Generates a raster map layer showing watershed subbasins.

Raster > Hydrologic modeling > Watershed subbasins

rbilinear Bilinear interpolation utility for raster map layers.

Raster > Interpolate sur faces > Bilinear from raster points

rbitpattern Compares bit patterns with a raster map.

I'magery > Report and statistics > Bit pattern comparison

rblend  Blends color components of two raster maps by a given ratio.

Raster > Manage colors > Blend 2 color rasters

rbuffer  Creates a raster map layer showing buffer zones surrounding cells that contain non-
NULL category values.

Raster > Buf fer rasters

Takes vector stream data, transforms it to raster and subtracts depth from the output
DEM.

Raster > Hydrologic modeling > Carve stream channels

r.category Manages category values and labels associated with user-specified raster map layers.

Raster > Report and statistics > Manage category in formation

r.circle Creates a raster map containing concentric rings around a given point.

Raster > Concentric circles

rclump  Recategorizes data in a raster map by grouping cells that form physically discrete
areas into unique categories.

Raster > Transform features > Clump

r.coin Tabulates the mutual occurrence (coincidence) of categories for two raster map layers.

Raster > Report and statistics > Mutual category occurrences

r.colors.stddev Set color rules based on stddev from a map’s mean value.

Raster > Manage colors > Color tables (stddev)




rcolors  Creates/modifies the color table associated with a raster map layer.

Raster > Manage colors > Color rules

r.composite Combines red, green and blue raster maps into a single composite raster map.

Raster > Manage colors > Create RGB

r.compress Compresses and decompresses raster maps.

Raster > Develop raster map > Compress/decompress

r.contour Produces a vector map of specified contours from a raster map.

Raster > Generate contour lines

r.cost Creates a raster map showing the cumulative cost of moving between different geo-
graphic locations on an input raster map whose cell category values represent cost.

Raster > Terrain analysis > Cost sur face

r.covar Outputs a covariance/correlation matrix for user-specified raster map layer(s).

Raster > Report and statistics > Covariance/correlation

I.Cross Creates a cross product of the category values from multiple raster map layers.

Raster > Overlay rasters > Cross product

r.describe Prints terse list of category values found in a raster map layer.

Raster > Report and statistics > Range of category values

r.digit Interactive tool used to draw and save vector features on a graphics monitor using a
pointing device (mouse) and save to a raster map.

Raster > Develop raster map > Digitize raster (requires X Term)

r.distance Locates the closest points between objects in two raster maps.

Raster v Closest points

r.drain Traces a flow through an elevation model on a raster map.

Raster > Terrain analysis > Least cost route or flow

rexternal Link GDAL supported raster file to a binary raster map layer.
File > I'mport raster map > Link to GDAL

rfilldir  Filters and generates a depressionless elevation map and a flow direction map from a
given elevation layer.

Raster > Hydrologic modeling > Depressionless map and flowlines

rfillnulls  Fills no-data areas in raster maps using v.surf.rst splines interpolation.
Raster > Interpolate sur faces > Fill NULL cells

r.flow Construction of slope curves (flowlines), flowpath lengths, and flowline densities (up-
slope areas) from a raster digital elevation model (DEM).

Raster > Hydrologic modeling > Flow lines

r.grow.distance Generates a raster map layer of distance to features in input layer.

Raster > Terrain analysis > Distance to features

r.grow Generates a raster map layer with contiguous areas grown by one cell.

Raster > Transform features > Grou

rgwflow Numerical calculation program for transient, confined and unconfined groundwater
flow in two dimensions.

rhis Generates red, green and blue raster map layers combining hue, intensity and satura-
tion (HIS) values from user-specified input raster map layers.
Raster > Manage colors > RGB to HIS

rhorizon Horizon angle computation from a digital elevation model.

Raster > Terrain analysis > Horizon angle

rin.arc Converts an ESRI ARC/INFO ascii raster file (GRID) into a (binary) raster map layer.

File > Import raster map > ESRI ASCII grid import

rin.ascii Converts ASCII raster file to binary raster map layer.

File > Import raster map > ASCII grid import

rin.aster Georeference, rectify and import Terra-ASTER imagery and relative DEM’s using
gdalwarp.

File > Import raster map > Terra ASTER HDF import

rinbin  Import a binary raster file into a GRASS raster map layer.

File > Import raster map > Binary file import

rin.gdal Import GDAL supported raster file into a binary raster map layer.

File » Import raster map > Import raster data using GDAL

rin.gridatb Imports GRIDATB.FOR map file (TOPMODEL) into GRASS raster map.
File > Import raster map > GRIDATB.FOR import

rin.mat  Imports a binary MAT-File(v4) to a GRASS raster.

File > Import raster map > M AT — File (v.4) import

rin.poly  Creates raster maps from ASCII polygon/line/point data files.

File > Import raster map > ASCII polygons and lines import

rin.srtm  Import SRTM HGT files into GRASS.

File v Import raster map > SRTM HGT import
rinwms Downloads and imports data from WMS servers.

rinxyz  Create a raster map from an assemblage of many coordinates using univariate statis-
tics.
File > Import raster map > Aggregate ASCII xyz import

rinfo Output basic information about a raster map layer.

Raster > Report and statistics > Basic raster metadata

rkappa  Calculate error matrix and kappa parameter for accuracy assessment of classification
result.

I'magery © Report and statistics > Kappa analysis

r.lake Fills lake from seed at given level.
Raster > Hydrologic modeling > Fill lake

rle.patch Calculates attribute, patch size, core (interior) size, shape, fractal dimension, and
perimeter measures for sets of patches in a landscape.

Raster > Landscape structure modeling > Analyze patches

rle.pixel ~Contains a set of measures for attributes, diversity, texture, juxtaposition, and edge.

Raster > Landscape structure modeling > Analyze landscape

rlesetup Interactive tool used to setup the sampling and analysis framework that will be used
by the other r.le programs.

Raster > Landscape structure modeling > Set up (requires X Term)




rleitrace  Displays the boundary of each r.le patch and shows how the boundary is traced, dis-
plays the attribute, size, perimeter and shape indices for each patch and saves the
data in an output file.

Raster > Landscape structure modeling > Output

rlicwed Calculates contrast weighted edge density index on a raster map.

Raster > Landscape patch analysis > Contrast weighted edge density

rli.dominance Calculates dominance’s diversity index on a raster map.

Raster > Landscape patch analysis > Dominance's diversity

rli.edgedensity Calculates edge density index on a raster map, using a 4 neighbour algorithm.

Raster > Landscape patch analysis > Edge density
rlimpa  Calculates mean pixel attribute index on a raster map.

rlimps  Calculates mean patch size index on a raster map, using a 4 neighbour algorithm.

Raster > Landscape patch analysis > Patch area mean

rli.padcv Calculates coefficient of variation of patch area on a raster map.

Raster > Landscape patch analysis > Patch area Coeff Var

rli.padrange Calculates range of patch area size on a raster map.

Raster > Landscape patch analysis > Patch area range

rli.padsd Calculates standard deviation of patch area a raster map.

Raster > Landscape patch analysis > Patch area Std Dev

rli.patchdensity Calculates patch density index on a raster map, using a 4 neighbour algorithm.

Raster > Landscape patch analysis > Patch density

rli.patchnum Calculates patch number index on a raster map, using a 4 neighbour algorithm.

Raster > Landscape patch analysis > Patch number

rlirichness Calculates dominance’s diversity index on a raster map.

Raster > Landscape patch analysis > Richness

rlisetup Configuration editor for r.li."index’.

Raster > Landscape patch analysis > Set up sampling and analysis framework

rli.shannon Calculates Shannon’s diversity index on a raster map.

Raster > Landscape patch analysis > Shannon's diversity

rlishape Calculates shape index on a raster map.

Raster > Landscape patch analysis > Shape indea

rlisimpson Calculates Simpson’s diversity index on a raster map.

Raster > Landscape patch analysis > Simpson's diversity

rlos Line-of-sight raster analysis program.

Raster > Terrain analysis > Visibility
rmapcalc Performs arithmetic on raster map layers.
r.mapcalculator Calculate new raster map from a r.mapcalc expression.

r.mask Create a MASK for limiting raster operation.
Raster > Mask

rmedian Finds the median of values in a cover map within areas assigned the same category
value in a user-specified base map.

r.mfilter.fp Raster map matrix filter.

Imagery > Filter image > Matriz/convolving filter
rmfilter ~ Raster map matrix filter.

rmode  Finds the mode of values in a cover map within areas assigned the same category
value in a user-specified base map.

rneighbors Makes each cell category value a function of the category values assigned to the cells
around it, and stores new cell values in an output raster map layer.

Raster > Neighborhood analysis > Moving window

rnull Manages NULL-values of given raster map.
Raster > Develop raster map > Manage NULL values

routarc Converts a raster map layer into an ESRT ARCGRID file.
File > Export raster map > ESRI ASCII grid export

rout.ascii Converts a raster map layer into an ASCII text file.
File > Export raster map > ASCII grid export

routbin Exports a GRASS raster to a binary array.

File > Export raster map > Binary export
rout.gdal.sh Exports GRASS raster into GDAL supported formats.
rout.gdal Exports GRASS raster maps into GDAL supported formats.

File > Export raster map > Multiple export formats using GDAL

rout.gridatb Exports GRASS raster map to GRIDATB.FOR map file (TOPMODEL).
File > Export raster map > GRIDATB.FOR export

rout.mat Exports a GRASS raster to a binary MAT-File.

File > Export raster map > MAT — File (v.4) export

rout.mpeg Raster File Series to MPEG Conversion Program.
File > Export raster map > MPEG — 1 export

rout.png Export GRASS raster as non-georeferenced PNG image format.

File > Export raster map > PNG export

rout.pov Converts a raster map layer into a height-field file for POVRAY.
File > Export raster map > POV — Ray export

rout.ppm Converts a GRASS raster map to a PPM image file at the pixel resolution of the cur-
rently defined region.

File > Export raster map > PPM export

rout.ppm3 Converts 3 GRASS raster layers (R,G,B) to a PPM image file at the pixel resolution of
the CURRENTLY DEFINED REGION.
File > Export raster map > PPM from RGB export

rout.tiff Exports a GRASS raster map to a 8/24bit TIFF image file at the pixel resolution of the
currently defined region.
File > Ezport raster map > TIFF ezport

rout.vrml Export a raster map to the Virtual Reality Modeling Language (VRML).

File > Export raster map & VRML export

rout.vtk  Converts raster maps into the VTK-Ascii format.

File > Export raster map > VT K export




rout.xyz Export a raster map to a text file as x,y,z values based on cell centers.
File > Export raster map > ASCII z,y, z export

r.param.scale Extracts terrain parameters from a DEM.

Raster > Terrain analysis > Terrain parameters

r.patch Creates a composite raster map layer by using known category values from one (or
more) map layer(s) to fill in areas of 'no data’ in another map layer.

Raster > Overlay rasters > Patch raster maps

r.plane Creates raster plane map given dip (inclination), aspect (azimuth) and one point.

Raster > Generate sur faces > Plane

rprofile  Outputs the raster map layer values lying on user-defined line(s).

Raster > Report and statistics b Sample transects

I.proj Re-projects a raster map from one location to the current location.

Raster > Develop raster map > Reproject raster

rquant  Produces the quantization file for a floating-point map.

Raster > Develop raster map > Quantization

r.quantile Compute quantiles using two passes.

Raster > Report and statistics > Quantiles for large data sets

rrandom.cells Generates random cell values with spatial dependence.

Raster > Generate random cells > Random cells

rrandom.surface Generates random surface(s) with spatial dependence.

Raster > Generate sur faces > Random sur face with spatial dependence

rrandom Creates a raster map layer and vector point map containing randomly located points.

Raster > Generate random cells > Random cells and vector points

rreclass.area Reclasses a raster map greater or less than user specified area size (in hectares).

Raster > Change category values and labels > Reclassify by size

rreclass  Creates a new map layer whose category values are based upon a reclassification of
the categories in an existing raster map layer.

Raster > Change category values and labels > Reclassify

rrecode  Recodes categorical raster maps.

Raster > Change category values and labels > Recode interactively

rregion  Sets the boundary definitions for a raster map.

Raster > Develop raster map > Region boundaries

rregression.line Calculates linear regression from two raster maps: y = a + b*x.

Raster > Report and statistics > Linear regression

rreport  Reports statistics for raster map layers.

Raster > Report and statistics > Sum area by raster map and category

rresamp.interp Resamples raster map layers to a finer grid using interpolation.

Raster > Develop raster map > Resample using multiple methods

rresamp.rst Reinterpolates and optionally computes topographic analysis from input raster map
to a new raster map (possibly with different resolution) using regularized spline with
tension and smoothing.

Raster > Develop raster map > Resample using spline tension
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rresamp.stats Resamples raster map layers to a coarser grid using aggregation.

Raster > Develop raster map > Resample using aggregate statistics

rresample GRASS raster map layer data resampling capability.

Raster > Develop raster map > Resample using nearest neighbor

rrescale.eq Rescales histogram equalized the range of category values in a raster map layer.

Raster > Change category values and labels > Rescale with histogram

rrescale  Rescales the range of category values in a raster map layer.

Raster > Change category values and labels > Rescale

Generates three, or four raster map layers showing 1) the base (perpendicular) rate of
spread (ROS), 2) the maximum (forward) ROS, 3) the direction of the maximum ROS,
and optionally 4) the maximum potential spotting distance.

Raster > Wildfire modeling > Rate of spread

rseries  Makes each output cell value a function of the values assigned to the corresponding
cells in the input raster map layers.

Raster > Overlay rasters > Raster series

r.shaded.relief Creates shaded relief map from an elevation map (DEM).

Raster > Terrain analysis > Shaded relief

rsim.sediment Sediment transport and erosion/deposition simulation using path sampling method

(SIMWE).

Raster > Hydrologic modeling > SIMW E Sediment flux modeling

r.sim.water Overland flow hydrologic simulation using path sampling method (SIMWE).
Raster > Hydrologic modeling > SIMW E Overland flow modeling

rslope.aspect Generates raster map layers of slope, aspect, curvatures and partial derivatives
from a raster map layer of true elevation values. Aspect is calculated counterclock-
wise from east.

Raster & Terrain analysis > Slope and aspect

rspread  Simulates elliptically anisotropic spread on a graphics window and generates a raster
map of the cumulative time of spread, given raster maps containing the rates of
spread (ROS), the ROS directions and the spread origins.

Raster > Wildfire modeling > Anisotropic spread simulation

r.spreadpath Recursively traces the least cost path backwards to cells from which the cumulative
cost was determined.

Raster > Wildfire modeling v Least — cost spread paths

r.statistics Calculates category or object oriented statistics.

Raster > Overlay rasters > Statistical overlay

r.stats Generates area statistics for raster map layers.

Raster > Report and statistics > General statistics

Sums up the raster cell values.

Raster > Report and statistics > Sum category values

Solar irradiance and irradiation model.

Raster > Solar radiance and shadows > Solar irradiance and irradiation

rsunmask Calculates cast shadow areas from sun position and DEM. Either A: exact sun position
is specified, or B: date/time to calculate the sun position by r.sunmask itself.

Raster > Solar radiance and shadows > Shadows map
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r.support.stats Update raster map statistics.

Raster > Develop raster map > Update map statistics

rsupport Allows creation and/or modification of raster map layer support files.

Raster > Develop raster map > Support file maintenance

rsurf.area Surface area estimation for rasters.

Raster > Report and statistics > Total corrected area

rsurf.contour Surface generation program from rasterized contours.

Raster > Interpolate sur faces > Raster contours

rsurf.fractal Creates a fractal surface of a given fractal dimension.

Raster > Generate sur faces > Fractal sur face

rsurf.gauss GRASS module to produce a raster map layer of gaussian deviates whose mean and
standard deviation can be expressed by the user. It uses a gaussian random number
generator.

Raster > Generate sur faces > Gaussian deviates sur face

rsurf.idw Surface interpolation utility for raster map.

Raster > Interpolate surfaces > IDW from raster points
rsurf.idw?2 Surface generation program.

rsurf.random Produces a raster map layer of uniform random deviates whose range can be ex-
pressed by the user.

Raster > Generate sur faces > Random deviates sur face
r.terraflow.short Flow computation for massive grids (Integer version).

r.terraflow Flow computation for massive grids (Float version).

Raster > Hydrologic modeling > Flow accumulation

rtexture Generate images with textural features from a raster map.

Raster > Terrain analysis > Textural features

r.thin Thins non-zero cells that denote linear features in a raster map layer.

Raster > Transform features > Thin

rtileset  Produces tilings of the source projection for use in the destination region and projec-
tion.

Raster > Develop raster map v Tiling

rtimestamp Print/add/remove a timestamp for a raster map.

Raster > Develop raster map > Timestamp

rtorast3 Converts 2D raster map slices to one 3D raster volume map.

File > Map type conversions > Raster series to volume

r.to.rast3elev Creates a 3D volume map based on 2D elevation and value raster maps.

File > Map type conversions > Raster 2.5D to volume

rto.vect Converts a raster map into a vector map layer.

File > Map type conversions > Raster to vector

rtopidx  Creates topographic index [In(a/tan(beta))] map from elevation map.

Raster > Hydrologic modeling > Topographic index map

r.topmodel Simulates TOPMODEL which is a physically based hydrologic model.
Raster > Hydrologic modeling > TOPMODEL simulation
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rtransect Outputs raster map layer values lying along user defined transect line(s).

Raster > Report and statistics > Sample transects (bearing/distance)

runivar  Calculates univariate statistics from the non-null cells of a raster map.

Raster > Report and statistics b Univariate raster statistics
runivar.sh calculates univariate statistics from a GRASS raster map.

rvolume Calculates the volume of data ‘clumps’, and (optionally) produces a GRASS vector
points map containing the calculated centroids of these clumps.

Raster > Report and statistics > Statistics for clumped cells

r.walk Outputs a raster map layer showing the anisotropic cumulative cost of moving be-
tween different geographic locations on an input elevation raster map layer whose cell
category values represent elevation combined with an input raster map layer whose
cell values represent friction cost.

Raster > Terrain analysis > Cumulative movement costs

r.water.outlet Watershed basin creation program.

Raster » Hydrologic modeling > W atershed basin creation

r.watershed Watershed basin analysis program.

Raster b Hydrologic modeling > Watershed analysis
r.what.color Queries colors for a raster map layer.

r.what Queries raster map layers on their category values and category labels.

Raster > Query by coordinates

Raster 3D commands:

r3.cross.rast Creates cross section 2D raster map from 3d raster map based on 2D elevation map.

Volumes > Cross section

r3.gwflow Numerical calculation program for transient, confined groundwater flow in three di-
mensions.

r3.in.ascii Convert a 3D ASCII raster text file into a (binary) 3D raster map layer.
File > Import grid 3D volume > ASCII 3D import

r3.in.v5d import of 3-dimensional Vis5D files (i.e. the v5d file with 1 variable and 1 time step).

File > Import grid 3D volume > Vis5D import

r3.info Outputs basic information about a user-specified 3D raster map layer.

Volumes b Report and Statistics > Basic volume metadata
r3.mapcalc Performs arithmetic on 3D grid volume data.
r3.mapcalculator Calculates new grid3D volume from r3.mapcalc expression.

r3.mask  Establishes the current working 3D raster mask.
Volumes > 3D Mask

r3.mkdspf Creates a display file from an existing grid3 file according to specified threshold lev-
els.

r3.null Explicitly create the 3D NULL-value bitmap file.
Volumes > Develop volumes > Manage 3D NULL values
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r3.out.ascii Converts a 3D raster map layer into an ASCII text file.
File > Export grid 3D volume > ASCII 3D export

r3.out.v5d Export of GRASS 3D raster map to 3-dimensional Vis5D file.

File > Ezport grid 3D volume v Vis5D export

r3.out.vtk Converts 3D raster maps (G3D) into the VTK-Ascii format.

File > Export grid 3D volume > VTK export
r3.stats  Generates volume statistics for raster3d maps.

r3.timestamp Print/add/remove a timestamp for a 3D raster map.

Volumes > Develop volumes > Manage timestamp

r3.to.rast  Converts 3D raster maps to 2D raster maps.

File > Map type conversions > Volume to raster series

r3.univar Calculates univariate statistics from the non-null 3d cells of a raster3d map.

Vector commands:

vbuffer  Creates a buffer around features of given type (areas must contain centroid).

Vector > Buf fer vectors
v.build.all Rebuilds topology on all vector maps in the current mapset.

v.build.polylines Builds polylines from lines or boundaries.

Vector > Develop vector map > Build polylines

vbuild  Creates topology for GRASS vector map.

Vector > Develop vector map > Create or rebuild topology

v.category Attach, delete or report vector categories to map geometry.

Vector > Change attributes > Manage or report categories

v.centroids Adds missing centroids to closed boundaries.

Vector > Develop vector map > Add centroids
v.class Classifies attribute data, e.g. for thematic mapping.

v.clean Toolset for cleaning topology of vector map.

Vector > Develop vector map > Clean vector map

v.colors  Set color rules for features in a vector using a numeric attribute column.

Vector > Manage colors > Color tables
v.convert.all Convert all old GRASS < Ver5.7 vector maps in current mapset to current format.

v.convert Imports older versions of GRASS vector maps.
File v Import vector map > Old GRASS vector import

v.db.addcol Adds one or more columns to the attribute table connected to a given vector map.

Database > Manage databases > Add columns

v.db.addtable Creates and adds a new attribute table to a given layer of an existing vector map.

Database > Manage databases > New table

v.db.connect Prints/sets DB connection for a vector map to attribute table.

Database > Vector database connections > Set vector map — database connection
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v.db.dropcol Drops a column from the attribute table connected to a given vector map.
v.db.droptable Removes existing attribute table of a vector map.
v.dbjoin  Allows to join a table to a vector map table.

v.db.reconnect.all Reconnects vectors to a new database.

Database > Vector database connections > Reconnect vector to database

v.db.renamecol Renames a column in the attribute table connected to a given vector map.

Database > Manage databases > Rename column

v.db.select Prints vector map attributes.
Database > Query > Query vector attribute data

v.db.univar Calculates univariate statistics on selected table column for a GRASS vector map.

v.db.update Allows to update a column in the attribute table connected to a vector map.

Database > Manage databases > Change values

v.delaunay Creates a Delaunay triangulation from an input vector map containing points or cen-
troids.

Vector > Generate areas from points > Delaunay triangles
v.digit Interactive editing and digitization of vector maps.

v.dissolve Dissolves boundaries between adjacent areas sharing a common category number or
attribute.

Vector > Develop vector map > Dissolve boundaries

v.distance Finds the nearest element in vector map "to” for elements in vector map "from’.

Vector » Nearest features

v.drape  Converts vector map to 3D by sampling of elevation raster map.

Vector > Develop vector map » Create 3D vector over raster

v.edit Edits a vector map, allows adding, deleting and modifying selected vector features.

Vector > Develop vector map > Edit vector map (non — interactively)

v.external Creates a new vector as a read-only link to OGR layer.
File > Import vector map > Link to OGR

vextract  Selects vector objects from an existing vector map and creates a new map containing
only the selected objects.

Vector > Query with attributes

vextrude Extrudes flat vector object to 3D with defined height.

Vector > Develop vector map > Extrude 3D vector map

v.generalize Vector based generalization.

Vector > Develop vector map > Smooth or simplify

v.hull Uses a GRASS vector points map to produce a convex hull vector map.

Vector > Generate areas from points > Convex hull

vin.ascii Creates a vector map from ASCII points file or ASCII vector file.
File b Import vector map > ASCII points/GRASS ASCII vector import

vin.db  Creates new vector (points) map from database table containing coordinates.

Vector > Generate points > Generate from database




vin.dxf  Converts files in DXF format to GRASS vector map format.
File > Import vector map > DX F import

vin.e00  Import EQO file into a vector map.

File > Import vector map > ESRI €00 import

vin.garmin Download waypoints, routes, and tracks from a Garmin GPS receiver into a vector
map.

File > Import vector map > Garmin GPS import

v.in.geonames Imports geonames.org country files into a GRASS vector points map.

File > Import vector map > Geonames import

vin.gns  Imports US-NGA GEOnet Names Server (GNS) country files into a GRASS vector
points map.

File > Import vector map > GEOnet import

v.in.gpsbabel Import waypoints, routes, and tracks from a GPS receiver or GPS download file
into a vector map.
File v Import vector map > GPSBabel GPS import

v.in.mapgen Import Mapgen or Matlab vector maps into GRASS.
File > Import vector map > Matlab and MapGen import

vin.ogr  Convert OGR vector layers to GRASS vector map.

File > Import vector map > Import vector data using OGR

vin.region Create a new vector from the current region.

Vector > Generate area for current region
vinsites.all Converts all old GRASS < Ver5.7 sites maps in current mapset to vector maps.

vinsites Converts a GRASS site_lists file into a vector map.

File > Map type conversions > Sites to vector
vinwfs  Import GetFeature from WFS.

v.info Outputs basic information about a user-specified vector map.

Vector > Reports and statistics > Basic vector metadata

v.kev Randomly partition points into test/train sets.

Vector > Test/training point sets

v.kernel  Generates a raster density map from vector points data using a moving 2D isotropic
Gaussian kernel or optionally generates a vector density map on vector network with
a 1D kernel.

Raster > Generate sur faces > Gaussian kernel density sur face

vlabel.sa Create optimally placed labels for vector map(s).

v.label Creates paint labels for a vector map from attached attributes.

Vector > Develop vector map & Create labels

v.lidar.correction Correction of the vlidar.growing output. It is the last of the three algorithms
for LIDAR filtering.

Vector & Lidar analysis > Correct and reclassi fy objects

vlidar.edgedetection Detects the object’s edges from a LIDAR data set.
Vector > Lidar analysis > Detect edges

vlidar.growing Building contour determination and Region Growing algorithm for determining
the building inside.

Vector > Lidar analysis > Detect interiors

v.lirs.create Create Linear Reference System.

Vector > Linear referencing > Create LRS

vlirs.label Create stationing from input lines, and linear reference system.

Vector > Linear referencing > Create stationing

v.lrs.segment Creates points/segments from input lines, linear reference system and positions
read from stdin or a file.

Vector > Linear referencing > Create points/segments

v.lrs.where Finds line id and real km+offset for given points in vector map using linear reference
system.

Vector b Linear referencing > Find line id and of fset

v.ankgrid Creates a GRASS vector map of a user-defined grid.

Vector > Generate grid

v.neighbors Makes each cell value a function of the attribute values assigned to the vector points
or centroids around it, and stores new cell values in an output raster map layer.

Raster > Neighborhood analysis > Neighborhood points

v.net.alloc Allocate subnets for nearest centres (direction from centre).

Vector > Network analysis > Allocate subnets

v.netiso  Splits net by cost isolines.
Vector b Network analysis > Split net

v.net.path Finds shortest path on vector network.

Vector > Network analysis > Shortest path

v.net.salesman Creates a cycle connecting given nodes (Traveling salesman problem).

Vector > Network analysis > Traveling salesman analysis

v.net.steiner Create Steiner tree for the network and given terminals.

Vector > Network analysis > Steiner tree

v.net.visibility Visibility graph construction.

Vector > Network analysis > Visibility network

v.net Performs network maintenance.

Vector > Network analysis > Network maintenance

vanormal Tests for normality for points.

Vector > Reports and statistics > Test normality

v.out.ascii Converts a GRASS binary vector map to a GRASS ASCII vector map.

File > Export vector map > ASCII points/GRASS ASCII vector export

v.out.dxf Exports GRASS vector map layers to DXF file format.
File > Export vector map > DXF export

v.out.gpsbabel Exports a vector map to a GPS receiver or file format supported by GpsBabel.
File > Export vector map > Multiple GPS export formats using GPSBabel

v.out.ogr Converts to one of the supported OGR vector formats.
File > Export vector map > Multiple export formats using OGR
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v.out.pov Converts to POV-Ray format, GRASS x,y,z -> POV-Ray x,z,y.

File > Ezport vector map > POV — Ray export

v.out.svg  Exports a GRASS vector map to SVG.

File > Ezport vector map > SV G export

v.out.vtk  Converts a GRASS binary vector map to VTK ASCII output.

File > Ezport vector map > VT K export

v.outlier Removes outliers from vector point data.

Vector b Remove outliers in point sets

v.overlay Overlays two vector maps.

Vector > Overlay vector maps > Overlay vector maps

v.parallel Creates parallel line to input vector lines.

Vector > Develop vector map > Parallel lines

v.patch  Create a new vector map layer by combining other vector map layers.

Vector > Overlay vector maps > Patch vector maps

v.perturb Random location perturbations of GRASS vector points.

Vector > Generate points > Perturb points

V.proj Allows projection conversion of vector maps.

Vector > Develop vector map > Reproject vector map

v.qcount  Indices for quadrat counts of sites lists.

Vector > Reports and statistics > Quadrat indices

vrandom Randomly generate a 2D /3D vector points map.

Vector > Generate points > Generate random points

v.rast.stats Calculates univariate statistics from a GRASS raster map based on vector polygons
and uploads statistics to new attribute columns.

Vector > Update area attributes from raster

vreclass  Changes vector category values for an existing vector map according to results of SQL
queries or a value in attribute table column.

Vector > Change attributes > Reclassify

vreport  Reports geometry statistics for vectors.

Vector > Reports and statistics > Report topology by category

v.sample Samples a raster map at vector point locations.

Vector > Update point attributes from raster > Sample raster neighborhood around points

v.segment Creates points/segments from input vector lines and positions.

Vector > Develop vector map 1> Split polylines

v.select Selects features from vector map (A) by features from other vector map (B).

Vector > Query with another vector map

v.split Split lines to shorter segments.

v.support Updates vector map metadata.

v.surf.bspline Bicubic or bilinear spline interpolation with Tykhonov regularization.

Raster > Interpolate surfaces > Bilinear and bicubic from vector points

v.surfidw Surface interpolation from vector point data by Inverse Distance Squared Weighting.

Raster & Interpolate sur faces > IDW from vector points

v.surf.aost  Spatial approximation and topographic analysis from given point or isoline data in
vector format to floating point raster format using regularized spline with tension.

Raster & Interpolate sur faces > Regularized spline tension

v.to.3d Performs transformation of 2D vector features to 3D.

File > Map type conversions > 2D vector to 3D vector

v.to.db Populates database values from vector features.

Vector > Reports and statistics > Upload or report topology

v.to.points Create points along input lines in new vector with 2 layers.

Vector b Generate points > Generate points along lines

v.torast  Converts a binary GRASS vector map into a GRASS raster map .

File > Map type conversions > Vector to raster

v.to.rast3 Converts a binary GRASS vector map (only points) layer into a 3D GRASS raster map
layer.

File > Map type conversions > Vector to volume

v.transform Performs an affine transformation (shift, scale and rotate, or GPCs) on vector map.

Vector > Develop vector map > Reposition vector map

v.type Change the type of geometry elements.

Vector > Develop vector map > Convert object types

vunivar  Calculates univariate statistics for attribute. Variance and standard deviation is cal-
culated only for points if specified.

Vector > Reports and statistics > Univariate attribute statistics
v.univarsh Calculates univariate statistics on selected table column for a GRASS vector map.

v.volrst  Interpolates point data to a G3D grid volume using regularized spline with tension
(RST) algorithm.

Volumes > Interpolate volume from points

v.voronoi Creates a Voronoi diagram from an input vector map containing points or centroids.

Vector > Generate areas from points > Voronoi diagram/Thiessen polygons

v.what.rast Uploads raster values at positions of vector points to the table.

Vector > Update point attributes from raster > Sample raster maps at point locations

v.what.vect Uploads vector values at positions of vector points to the table.

Vector > Update point attributes from areas

v.what Queries a vector map layer at given locations.

Vector > Query with coordinate(s)




